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EKTRON, INC. SOFTWARE LICENSE AGREEMENT
** READ THIS BEFORE LOADING SOFTWARE**
YOUR RIGHT TO USE THE PRODUCT DELIVERED IS SUBJECT TO THE TERMS AND CONDITIONS SET OUT IN THIS LICENSE
AGREEMENT. USING THIS PRODUCT SIGNIFIES YOUR AGREEMENT TO THESE TERMS. IF YOU DO NOT AGREE TO THIS SOFTWARE
LICENSE AGREEMENT, DO NOT DOWNLOAD.
CUSTOMER should carefully read the following terms and conditions before using the software program(s) contained herein (the
“Software”). Downloading and/or using the Software or copying the Software onto CUSTOMER’S computer hard drive indicates
CUSTOMER’S acceptance of these terms and conditions. If CUSTOMER does not agree with the terms of this agreement, CUSTOMER
should not download.
Ektron, Inc. (“Ektron”) grants, and the CUSTOMER accepts, a nontransferable and nonexclusive License to use the Software on the
following terms and conditions:
1. Right to use: The Software is licensed for use only in delivered code form. Each copy of the Software is licensed for use only on
a single URL. Each license is valid for the number of seats listed below (the “Basic Package”). Any use of the Software beyond the
number of authorized seats contained in the Basic Package without paying additional license fees as provided herein shall cause this
license to terminate. Should CUSTOMER wish to add seats beyond the seats licensed in the Basic Package, the CUSTOMER may add
seats on a block basis at the then current price for additional seats (see product pages for current price). The Basic Packages are as
follows:
Ektron CMS300 - Licensed for ten seats (10 named users) per URL.
Ektron CMS400.NET - Licensed for ten seats (10 named users) per URL.
Ektron eWebEditPro - Licensed for ten seats (10 named users) per URL.
Ektron eWebEditPro+XML - Licensed for ten seats (10 named users) per URL.
For purposes of this section, the term “seat” shall mean an individual user provided access to the capabilities of the Software.
The CUSTOMER may not modify, alter, reverse engineer, disassemble, or decompile the Software. This software product is licensed, not
sold.
2. Duration: This License shall continue so long as CUSTOMER uses the Software in compliance with this License. Should
CUSTOMER breach any of its obligations hereunder, CUSTOMER agrees to return all copies of the Software and this License upon
notification and demand by Ektron.
3. Copyright: The Software (including any images, “applets,” photographs, animations, video, audio, music and text incorporated
into the Software) as well as any accompanying written materials (the “Documentation”) is owned by Ektron or its suppliers, is
protected by United States copyright laws and international treaties, and contains confidential information and trade secrets.
CUSTOMER agrees to protect the confidentiality of the Software and Documentation. CUSTOMER agrees that it will not provide a copy
of this Software or Documentation nor divulge any proprietary information of Ektron to any person, other than its employees, without
the prior consent of Ektron; CUSTOMER shall use its best efforts to see that any user of the Software licensed hereunder complies with
this license.
4. Limited Warranty: Ektron warrants solely that the medium upon which the Software is delivered will be free from defects in
material and workmanship under normal, proper and intended usage for a period of three (3) months from the date of receipt. Ektron
does not warrant the use of the Software will be uninterrupted or error free, nor that program errors will be corrected. This limited
warranty shall not apply to any error or failure resulting from (i) machine error, (ii) Customer's failure to follow operating instructions,
(iii) negligence or accident, or (iv) modifications to the Software by any person or entity other than Company. In the event of a breach of
warranty, Customer’s sole and exclusive remedy, is repair of all or any portion of the Software. If such remedy fails of its essential
purpose, Customer’s sole remedy and Ektron’s maximum liability shall be a refund of the paid purchase price for the defective Products
only. This limited warranty is only valid if Ektron receives written notice of breach of warranty within thirty days after the warranty period
expires.
5. Limitation of Warranties and Liability: THE SOFTWARE AND DOCUMENTATION ARE SOLD “AS IS” AND WITHOUT ANY
WARRANTIES AS TO THE PERFORMANCE, MERCHANTIBILITY, DESIGN, OR OPERATION OF THE SOFTWARE. NO WARRANTY OF
FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. EXCEPT AS DESCRIBED IN SECTION 4, ALL WARRANTIES EXPRESS AND
IMPLIED ARE HEREBY DISCLAIMED.
NEITHER COMPANY NOR ITS SUPPLIERS SHALL BE LIABLE FOR ANY LOSS OF PROFITS, LOSS OF BUSINESS OR GOODWILL, LOSS
OF DATA OR USE OF DATA, INTERRUPTION OF BUSINESS NOR FOR ANY OTHER INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES OF ANY KIND UNDER OR ARISING OUT OF, OR IN ANY RELATED TO THIS AGREEMENT, HOWEVER,
CAUSED, WHETHER FOR BREACH OF WARRANTY, BREACH OR REPUDIATION OF CONTRACT, TORT, NEGLIGENCE, OR OTHERWISE,
EVEN IF COMPANY OR ITS REPRESENTATIVES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS.

6. Miscellaneous: This License Agreement, the License granted hereunder, and the Software may not be assigned or in any way
transferred without the prior written consent of Ektron. This Agreement and its performance and all claims arising from the relationship
between the parties contemplated herein shall be governed by, construed and enforced in accordance with the laws of the State of New
Hampshire without regard to conflict of laws principles thereof. The parties agree that any action brought in connection with this
Agreement shall be maintained only in a court of competent subject matter jurisdiction located in the State of New Hampshire or in any
court to which appeal therefrom may be taken. The parties hereby consent to the exclusive personal jurisdiction of such courts in the
State of New Hampshire for all such purposes. The United Nations Convention on Contracts for the International Sale of Goods is
specifically excluded from governing this License. If any provision of this License is to be held unenforceable, such holding will not
affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this Agreement shall not constitute or be
construed as a waiver of such provision or of the right to enforce such provision. If you fail to comply with any term of this License,
YOUR LICENSE IS AUTOMATICALLY TERMINATED. This License represents the entire understanding between the parties with respect
to its subject matter.
YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND
THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE, BY LOADING OR RUNNING THE SOFTWARE, OR BY PLACING OR
COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT’S TERMS AND
CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN EKTRON AND YOU, THIS
AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.
Copyright 1999 - 2006 Ektron, Inc. All rights reserved.
LA10031, Revision 1.7
Trademarks
All terms in this manual that are known to be trademarks have been capitalized. Ektron, Inc. cannot attest to the accuracy of this information. Use
of a term in this manual does not affect the validity of any trademark.
The following trademarks might appear in Ektron manuals:
Active Directory®, ActiveX®, Authenticode®, BackOffice®, ClearType®, Developer Studio®, FrontPage®, IntelliSense®, JScript®, Microsoft ®,
MS-DOS®, SharePoint ® Visual C++®, Visual C#®, Visual InterDev®, Visual J++®, Visual J#®, Visual Studio®, Visual Web Developer TM,
Win32®, Win32s®, Windows®, Windows NT®, Windows Server TM, Windows Server System TM, Netscape®, Netscape Navigator®, Mozilla TM,
Firefox TM

Securing Ektron CMS400.NET

Securing Ektron
CMS400.NET
Security Checklist
The following is a checklist of things an Administrator must do to
secure Ektron CMS400.NET.

Change Admin user password
Change builtin user password
IMPORTANT!

If you changed the builtin user password during the site setup, you do not need to
change it again. See ”Editing Builtin” on page ii for additional information.

Remove Sample users
IMPORTANT!

Some users in this list might not appear in your User list. This depends on which
version of the software you have installed.

Admin2
jedit
tbrown
jsmith
vs
EkExplorerUser
Explorer
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Securing Ektron CMS400.NET

Additional Information
You do not need to make these changes if you are using the 400
for demonstration or evaluation purposes. These changes should
be completed once the decision is made to purchase the product
and go live with your site.
IMPORTANT!

Ektron recommends creating your own Administrator user and deleting the Admin
user.

IMPORTANT!

Ektron recommends deleting any users from the 400 that are not needed on the
system.

IMPORTANT!

By default, when the Ektron Explorer client is installed, the Explorer or
EkExplorerUser username and password are also installed. Client-side users
should use their Ektron CMS400.NET username and password when using the
Ektron Explorer. To learn how to change this information, see the Administrator
Manual section “Ektron Explorer” > “Configuring Ektron Explorer.”

Editing Builtin
IMPORTANT!

The “builtin” user does not appear in the Users list. This user appears on the
application setup screen.

To change the builtin account information, follow these steps.
1. In the Workarea, click Settings > Configuration > Setup.
2. Click the Edit button (

).

3. Locate the Built In User field.
4. Edit the built in user information by changing the username and
password.
5. Click the Update button (
NOTE

).

If you cannot sign in to Ektron CMS400.NET because the builtin user
password was changed and you don’t know the new password, use the
BuiltinAccountReset.exe utility. This resets your Ektron CMS400.NET user \
password to Builtin \ Builtin. This utility is located in C:\Program
Files\Ektron\CMS400v6x\Utilities.
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What’s New in the 6.1 Release

What’s New in the 6.1 Release

• You can now personalize certain Web pages. See
”Personalizing a Web Page” on page 387

• You can create and edit documents within any Microsoft Office
application, and save them directly to Ektron CMS400.NET from
within Office without signing on to CMS. See ”Creating a
Microsoft Office Document from the Document Management
Toolbar” on page 220

• New Workspaces within Ektron Explorer let you arrange
content according to your preferences, regardless of their
location within Ektron CMS400.NET. See ”The Workspace” on
page 276

• The editor features a math expression editor. See ”Working
with the Math Expression Editor” on page 654
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Introduction to Ektron
CMS400.NET
Using Ektron CMS400.NET to manage Web content is easy once
you know the basics of setting up and maintaining your site. This
documentation explains how to maintain an Ektron CMS400.NET
site from a user’s point of view. By reading this documentation, you
will gain an understanding of how Ektron CMS400.NET works.
This section introduces basic concepts that you should understand
when beginning to work with Ektron CMS400.NET through the
following subtopics.

• ”What is a Content Block?” on page 1
• ”Workflow in Ektron CMS400.NET” on page 7
• ”Editing Content” on page 8
• ”The Lifecycle of Content” on page 9

What is a Content Block?
A Web site consists of several pages. Each page is made up of
one or more blocks of content. For example, the home page of the
sample Web site installed with Ektron CMS400.NET is below.
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After you sign in, notice that, as you move the cursor, colored
borders appears around one or more areas of the page. Each
surrounded area is content that can be edited independently. The
border disappears when you move the cursor out of the area. Your
system administrator controls the design of each page and
determines where the content appears.
NOTE

The colored borders appear when you are not in site preview mode. See Also:
”Site Preview” on page 12. Also, your administrator can set up your system so
that the borders always appear on a page, instead of appearing only when you
move the mouse over them.
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The advantage of this feature is that you can see a Web page as it
will appear to site visitors. Continue editing until you are satisfied
with its appearance.
To learn what the border color indicates, see ”Appendix A: Content
Statuses” on page 648.
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The Floating Toolbar
When content’s border is visible, you can right click the mouse to
display a floating toolbar (an example is in the green box below).

Toolbar options let you act on the displayed content and view
important information about it. The options change depending on
the content’s status and your permissions for the content. For
example, one toolbar button lets you edit the content, while
another lets you view previous versions of it.
If granted permission by your administrator, you can create new
content, and edit or delete existing ones. Most of your work with
Ektron CMS400.NET involves working with content.

Buttons on the Menu
The following table describes each button that may appear.
Button

Name

Description

More Information

Approve

Approve or decline a request to
publish or delete content

”Approving/Declining Content”
on page 81

Add Task

Assign a task to a user

”Managing Tasks” on page 317
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Button

Name

Description

More Information

Delete

Open View Content page. From it,
you can delete the content.

”Viewing Content” on page 38

Edit

Check out content for editing

”Editing Content” on page 49

Logout

Log out of Ek tr on CMS 400 .NET
view of Web site

”Logging Out of the Sample
Site” on page 13

Preview

Preview content before it is published

Properties

Open content’s View Content page

”Viewing Content” on page 38

View
Content
Difference

Display differences between a
previous and published version of
content

”Comparing Versions of
Content” on page 92

View History

Open View History screen, where you
can view previous versions of content

”Viewing and Restoring
Previous Content” on page 99

Workarea

Opens Workarea. From here, you can
perform all Ek tron CM S40 0.NET
tasks

”The Workarea and Smart
Desktop” on page 15

NOTE

Your administrator can set up your system to have borders always appear on a
page. In that case, you don’t need to click the mouse to make it appear. For
information on the classic user interface, see the Administrators Manual >
“Introduction to Ektron CMS400.NET” > “Getting Started” > “Recognizing Content”
> “Returning to the Classic User Interface”

Types of Content
Every piece of content in Ektron CMS400.NET is one of the
following types. The table below summarizes all types.
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Type

Description

For more information, see

HTML content

Content designed to be published on the
World Wide Web

E ktron CM S40 0. NET ’s editor,

For information on using
see ”Introduction to
eWebEditPro+XML” on
page 461.

HTML Form/Survey

Online forms, polls, or surveys designed to
collect information from site visitors

”Working with HTML Forms” on
page 141

Office Documents

Files normally created and edited using
Microsoft Office

”Working with Microsoft Office
Documents” on page 214

Managed Files

Files created outside of E kt ro n
C M S 4 0 0 . N E T , such as PDFs and .jpeg files.
You cannot create or edit these files within
Ek tron CM S40 0.NET - you can only store
them.

”Working with Managed Files”
on page 234

Multimedia

Files that run in a media player, such as
sound and movie files

E ktron CM S40 0. NET

Files normally created and edited using Open
Office

”Working with Open Office
Files” on page 231

Open Office

Administrator Manual section
“Document Management
Administration“> “Managing
Multimedia Assets'

When creating new content, you must assign a type.
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As you can see, the New menu lists all types of content you can
work with.

Workflow in Ektron CMS400.NET
Organizations typically want a Web site that is updated frequently
with the latest information. They also want to decentralize the
update process, so that non-technical users from any department
can make changes. Further, organizations want oversight over
those changes to ensure the accuracy of the information, that the
content adheres to corporate guidelines, etc.
Ektron CMS400.NET manages the lifecycle of content, from

creation through approval and publication. It helps your
organization set up a process for overseeing changes to a Web
site, indicate content’s status within that lifecycle, and inform the
next approver that it is their turn to review the content.
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Editing Content
Finding Content
Much of your work involves editing existing content or creating new
content. Ektron CMS400.NET provides three methods for finding
content to be updated. You can use whichever method is easiest.

• Navigate through your Web site to the content you want to edit
• Find the content through the Workarea, which resembles
Windows Explorer and helps you find content by navigating
through a folder tree. See Also: ”The Workarea and Smart
Desktop” on page 15

• Use the Search button (

), which appears on many screens.
When clicked, a screen prompts you to enter keywords and
then finds content containing the keywords.

The Editing Process
After you find content, click the Edit button ( ) to open it in an
editor. Below is an example of content within the editor.

The editor resembles popular word processing software. You can
enter text, then select it and click a button to change its display
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properties. For example, you can make text bold, change the color,
or copy and paste it. You can also insert images, tables, links to
other Web pages, and check spelling,

The Lifecycle of Content
After you edit content, you typically submit it for approval to one or
more individuals who oversee changes to your Web site. These
people can review, edit and approve the change. When the last
approver signs off, the new content becomes available on the Web
site.
In some cases, you are one of the content approvers. In this case,
you receive an email notifying you that content needs approval.
You look it over, change it as needed, then pass it on to the next
approver. If you do not agree with the changes, you can decline the
request. In this case, the user who made the edits is informed that
the change is not approved.
The following graphic illustrates the content approval cycle.

To help track content’s position in this workflow, Ektron
CMS400.NET assigns a status to each content item. The status
determines what you can do with it, and indicates what must occur
in order for it to get published to the Web site. For more
information, see ”Appendix A: Content Statuses” on page 648.
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Logging In and Out

Logging In and Out

This section explains how to log in and out of Ektron CMS400.NET,
and to use the site preview feature through the following subtopics.

• ”Prerequisites” on page 10
• ”Logging into the Sample Web Site” on page 10
• ”Site Preview” on page 12
• ”Logging Out of the Sample Site” on page 13

Prerequisites
Once your Webmaster or administrator installs Ektron
CMS400.NET, you need the following items before you can use it.

• URL (Web address) of Ektron CMS400.NET Web site
• Username and password
Once you acquire both, you can log into Ektron CMS400.NET and
begin managing Web site content.
NOTE

This documentation uses the Ektron CMS400.NET sample Web site to
demonstrate the product.

Logging into the Sample Web Site
To access the Ektron CMS400.NET sample site, follow these
steps.
1. In your Web browser, navigate to the URL of your Ektron
CMS400.NET Web site. Your system administrator provides
this.
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Logging In and Out

2. Click the Login button on the screen.

3. The Login dialog box appears.

4. Enter your username and password.
If you are using one of Ektron’s sample sites, you can use any of
three standard users that demonstrate Ektron’s flexible userpermissions model. The table below lists the username and
password needed to log in as each user type, as well as the
permissions assigned to each user.

User Type

Username

Password

Permissions

Administrator

admin

admin

All

Standard user

jedit

jedit

Basic (for example, add/edit content,
manage library files, etc.)

Membership user

jmember

jmember

Read-only permission to private content

5. Click the Login button.
6. The Web page appears.
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Logging In and Out

You can navigate around your Web site as you could before
signing in. But now, the content is surrounded by a colored box
when you move the cursor over it (illustrated below).

Site Preview
While logged into Ektron CMS400.NET, you can preview the Web
site as it would appear to visitors, or view it in regular view.
Button
Appearance

Status

Description

Preview
Mode

Content appears as last edited. The advantage of this mode is
that you can see a Web page as it will appear when published
to your site. Continue editing until you are satisfied with its
appearance.
In Preview mode, click the Preview button to switch to regular
mode.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

12

Logging In and Out

Button
Appearance

Status

Regular View

Description

The most recently published version of content appears.
In this mode, colored borders surround content when you
move the cursor over it.
In regular view, click the Preview button to switch to preview
mode.

Toggling Site Preview
To toggle site preview on and off, follow these steps.
1. Navigate to a page that includes the login/logout button.
2. Click the Preview button.

3. The Web site is now in preview mode.

4. To turn preview mode off, click the (
login screen.

) button on the

Logging Out of the Sample Site
To log out of Ektron CMS400.NET, follow these steps.
1. Click the Logout button (
or click the Logout button (

) in the content’s floating toolbar,
) on the Web page.
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Logging In and Out

2. The Logout confirmation box appears.

3. Click the Logout button.
4. You return to the Web page from which you logged out.
However, it is in standard view, not Ektron CMS400.NET view.
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The Workarea and Smart
Desktop
The Workarea is a central screen from which you perform all
Ektron CMS400.NET activities. From it, you can

• access the Smart Desktop
• view the system’s top level folders
• navigate through the folder structure
• perform actions on content
This chapter describes using the Workarea and Smart Desktop
through the following subtopics.

• ”Accessing the Workarea” on page 15
• ”Installing the Document Management Functionality” on
page 16

• ”Understanding the Smart Desktop” on page 20
• ”Navigating Within the Smart Desktop” on page 23
• ”Sending Instant Email” on page 28

Accessing the Workarea
To access your Workarea, follow these steps.
1. Click the Workarea button at the bottom of the screen
(
) or the Workarea button (
floating toolbar.

) in the content’s

2. The Workarea appears.
3. The following illustrates one of several screens that may
appear in the Workarea. Your system administrator determines
which screen appears for you.
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Closing the Workarea
To close the Workarea, click
in the upper right corner of the
window. When you close the Workarea, you return to the Ektron
CMS400.NET view of your Web site. You do not exit Ektron
CMS400.NET.

Installing the Document Management Functionality
The first time you access the Workarea, the following screen
prompts you to install Document Management software onto your
computer.
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Follow these steps to install the Document Management software.
1. Read the screen.
2. At the bottom of the screen, click Install Now.
3. The following screen appears. The line at the top of the screen
(circled in red) may appear, depending on your browser
security.
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4. If that text appears, click it. The following menu appears.
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5. Click Install ActiveX Control.
6. The following screen appears. Click Install.

7. The following screen appears. Close it when you see Ektron
Asset Control in the top left corner of the screen (circled in red
below).
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Understanding the Smart Desktop
The Smart Desktop is one of Ektron CMS400.NET’s main screens.
To access it from wherever you are working in Ektron CMS400.NET,
click the button in the top left corner (circled below).
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The Smart Desktop consists of three sections, illustrated below.

• The right frame displays
- Content awaiting approval - content you need to approve
before it proceeds to the next approver or is published if
you are the final approver. See Also: The Ektron
CMS400.NET Administrator Manual > “Content Reports “ >
“Approvals Reports”
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- Content currently checked out - all content in a checkedout status. This content cannot be edited by other users
until the user who checked it out or the system
administrator checks it in. See Also: The Ektron
CMS400.NET Administrator Manual > “Content Reports “ >
“Checked Out Report”

- A list of tasks assigned to you See Also: ”Managing Tasks”
on page 317

- Any form submission tasks assigned to you See Also:
”Assigning a Task to a Form” on page 181

- The Content to Expire Report - see See Also: The Ektron
CMS400.NET Administrator Manual > “Content Reports “ >

“Content to Expire Report”
NOTE

The number to the right of each category lists the quantity of content items in that
category for you. When you click an item, up to five content items in a category
appear. To perform tasks on that content, and to view additional content in that
category, click the category.

If you select a folder from the left frame, the right frame
displays content in that folder. If you select content from the list,
information about it fills the right frame.
.

• The top left frame displays the folder tree for the Smart
Desktop folder, which has two subfolders

- Tasks (See ”Managing Tasks” on page 317)
- Content Reports (see ”Content Workflow Reports” on
page 116)

• The bottom left frame displays the top-level folders in Ektron
CMS400.NET. Your display may be different depending on

whether you are an administrator.

- Content folder (see ”Working with Folders and Content” on
page 31)

- Forms folder (see ”Working with HTML Forms” on page 141)
- ”Library Folder” on page 117
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- Modules (see ”Working with Collections” on page 401,
”Working with Menus” on page 420, and ”Working with
Calendars” on page 292 “Private Content & Memberships”
section of the “Managing Users & User Groups” chapter of
the Ektron CMS400.NET Administrator manual)

- Settings folder, which includes ”Updating Your User Profile”
on page 453 and ”Accessing Online Help” on page 458

Navigating Within the Smart Desktop
Ektron CMS400.NET’s top level folders appear in the lower left

corner of the Smart Desktop. Use them to access all other folders.
To open any top level folder, click it. When you do, it appears in the
frame above. Typically, you would a click top-level folder to see its
subfolders, then click a subfolder to see its content.
The following graphic illustrates the location of Ektron
CMS400.NET’s major features from the Smart Desktop.
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From the Smart Desktop, you can also:

• ”Modify the Display of Top Level Folders” on page 24
• ”Hide the Left Panel of the Workarea” on page 26

Modify the Display of Top Level Folders
The display of top level folders can appear in two formats.

Format

Illustration

A full button with an icon and text
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Format

Illustration

An icon on the bottom of the left frame

The full display is easier to see, but the icon format allows more
space for the folder structure. You can decide which option best
suits your needs.

Switching Between Full Buttons and Icons
By default, top-level folders appear as full buttons. To switch the
display of all folders to icons, double click the down arrow circled
below.

To switch back to full buttons, double click the up arrow circled
above.
You can also switch the display of folders one at a time by clicking
the up or down arrow.
As an alternative method of switching the display, you can
1. Place the cursor on the bar above the display of top-level
folders. (The bar has several dots in the middle.)

2. When the cursor turns to a double headed arrow, drag it to the
bottom bar.
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To return the display to full buttons, drag the same bar above.

Hide the Left Panel of the Workarea
You can hide the left frame of the Workarea to provide more space
for working in the right frame. Below is an example of the
Workarea with a minimized left frame. Note that you cannot see
the folder display in the left frame.

To minimize the left frame, click the white X near the top of the left
frame.
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The left frame remains minimized until you move the cursor to the
left of the bar circled below.

Using Autohide
The Workarea screen also provides an autohide feature, which
quickly switches between full right frame view and combination
right-left frame view.
When autohide is turned on, the left frame is minimized unless you
place the cursor to the left of the bar circled above. If you place the
cursor there, the left frame appears. As soon as you move the
cursor back to the right frame, the left frame disappears.
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To turn on the autohide feature, click the push pin icon near the top
of the left frame.

When you do, the push pin turns 90 degrees to indicate autohide is
on.

To turn off autohide, move the cursor to the left frame and click the
push pin icon. When you do, the push pin returns to its original
position.

Sending Instant Email
Ektron CMS400.NET lets you send email instantly to a user or user

group from many screens available from the Smart Desktop. Your
ability to send instant mail is indicated by a small mail icon next to
a user or group name (indicated in red below).

When you click a user/group name or email icon, the email screen
appears, as shown below. Once you complete the screen and click
Send, an email is sent to designated users.
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Conditions for Instant eMail
• You must have a valid email address set up in the user profile.
If not, email icons do not appear in Ektron CMS400.NET. See
Also: ”Updating Your User Profile” on page 453

• Your system administrator must enable the feature.

Where Instant email is Available
Instant email is available from several screens that display users
and user groups. Typically, you click a user name or the email icon
to launch an email. Screens in the following Ektron CMS400.NET
features support instant email.
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• Smart Desktop
• Tasks
• Approvals
• Reports
• User and user group setup
Wherever instant email is available, one of the email icons
appears.

Modifying Instant eMail
When the email screen appears, the following information is
copied from Ektron CMS400.NET into the email.
Field

Source of Default Information

Editable?

To

User you selected to receive the email. If the user does
not have valid email address, an error message appears
on the screen (see below). If you then insert a valid
email address, the email is sent.

Yes.
If desired, you
can add
recipients by
typing them
into this field.

If you specify a group to receive the message, as long
as one group member has a valid email address, all
group members with valid addresses receive the email.
From

You

No

Subject

If the email message is linked to content, its title
appears.

Yes

Body of
message

If the email message is linked to content, a link to the
content appears.

Yes
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Working with Folders and
Content
Every content item resides in the Content folder or one of its
subfolders. So, to work with existing content or create a new
content, you must first navigate to its folder.
A typical content folder screen appears below. It consists of three
sections:

• The top left frame shows the folder structure. You can click any
folder to display its content in the right frame, while its
subfolders appear below it.

• The right frame shows content in the currently selected folder.
Above the right frame is a toolbar of buttons that represent
tasks you can perform on selected content.

• The lower left frame shows Ektron CMS400.NET’s top level
folders
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In this chapter, you learn about adding, editing, publishing, and
deleting content through the following subtopics. (Permissions and
Approvals are explained in the Ektron CMS400.NET Administrator
manual.)

• ”Workarea Toolbar Buttons” on page 56
• ”Viewing a Folder” on page 33
• ”Viewing Content” on page 38
• ”Expanding the Content Area” on page 44
• ”Adding Content” on page 45
• ”Editing Content” on page 49
• ”Adding Content” on page 45
• ”Adding Subfolders” on page 55
• ”Adding Subfolders” on page 55
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• ”Deleting Folders” on page 55

Viewing a Folder
To view any folder under the content folder, follow these steps.
1. Access the Workarea, as described in ”Site Preview” on
page 12.
2. Click Content from the left lower side of the Workarea.

3. All content in the content folder and the selected language
appear on the right side of the screen. Subfolders appear in the
upper left frame.
NOTE

The View Menu lets you filter content by type. For example, you can set it to view
only HTML content. Therefore, you may only see content of a selected type in the
folder. See Also: ”View Menu” on page 36

4. To work with any folder or its content, click the folder. When you
do, its content appears in the right frame.
NOTE

You can only view folders for which your system administrator has granted
permission.

5. If your system supports more than one language, you can
select content for a particular language or all languages using
the View > Language menu option (illustrated below).
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Each folder lists the following information about its content.
Field

Description

Title

The name of the content.

Language

The language of the content.

ID

The number assigned to the content by Ektron
CMS400.NET. It is used to retrieve the content from a
database.

Status

The status of the content. See Also: ”Appendix A:
Content Statuses” on page 648

Date
Modified

The most recent date the content was added, edited, or
published.

Last Editor

The last user who accessed the content.

Additionally, each folder has the following menus.
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NOTE

Depending on your permissions, you may not see all menu options.

• ”New Menu” on page 35
• ”View Menu” on page 36
• ”Delete Menu” on page 37
• ”Action Menu” on page 37

New Menu

Menu
Option

Creates the following new item
within selected folder

For more information, see

Folder

Folder

”Adding Subfolders” on page 55

Blog

Blog

”Blogs” on page 343

Discussion
Board

Discussion Board

E ktron CM S40 0. NET Administrator

HTML
Content

HTML content

”Adding Content” on page 45

HTML Form/
Survey

HTML Form, Poll, or Survey

”Working with HTML Forms” on page 141

Smart Form

Smart Form

E k t r o n C M S 4 0 0 . N E T Administrator
Manual Section “Managing Content
Folders” > “Smart Forms”

Office
Documents

Office Document

”Working with Microsoft Office
Documents” on page 214

Managed
Files

Managed file, any supported type

”Working with Managed Files” on
page 234

Multimedia

Multimedia file, any supported type

”Managing Multimedia Assets” on
page 307

Open Office

Open Office file, any supported type

”Working with Open Office Files” on
page 231

Collection

Collection

”Working with Collections” on page 401

Manual Section “Discussion Boards”
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Menu
Option

Creates the following new item
within selected folder

For more information, see

Menu

Menu

”Working with Menus” on page 420

View Menu
The View Menu provides the following functions.

Menu
Option

Function

All types

Displays all content types of selected
language.

•

HTML
content

•

HTML
Form/
Survey

Limits folder display to selected content
type. For example, choose View > Office
Documents, and see only Office
Documents in the folder -- other content
types are suppressed.

•

Office
Documents

•

Managed
Files

•

Multimedia

•

Open
Office

Language

For more information, see

This is especially helpful if the folder has
a lot of items, and you are looking for
only one type of content.
Note that the icon for the selected type
appears to the left of the View Menu
option, as illustrated below.

Limits display within a folder to one
language.
The language setting also determines the
language of any new items you create in
the folder.

Menus

Lets user view and work with menus

”Working with Menus” on page 420

Collections

Lets user view and work with Collection

”Working with Collections” on page 401
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Menu
Option

Function

For more information, see

Archived
Content

Lets user view and work with Archived
content. That is, content that passed its
scheduled End Date and whose archive
option is either Archive and remove
from site or Archive and remain on
Site.

”Setting Archive Options” on page 64

Delete Menu
This menu lets you perform the following functions.

Menu option

Lets you

More Information

Delete this
folder

Delete current folder and all of its content

”Deleting Folders” on page 55

Delete content

Delete one, some, or all content items
within folder

”Deleting Content” on page 53

Action Menu
This menu lets you perform the following functions.

Menu option

Lets you

More Information

Export for
translation

Prepare content for translation by a
translation agency

E ktron CM S40 0. NET Administrator

Search

Search through content in the Workarea.

”Adding Subfolders” on page 55

Manual section “Multi-Language
Support” > “Using the Language Export
Feature”
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Viewing Content
You can view all content in your Ektron CMS400.NET Web site.
Viewing content allows you to see the content, metadata,
summaries, and other information. To view content in Ektron
CMS400.NET, follow these instructions.

Viewing Content from a Web Page
To view content from a Web page, follow these steps.
1. Sign in.
2. Browse to the content you want to view.
3. Click the Properties button (

).

4. Continue reading from ”The View Content screen appears.” on
page 40.
5.

reading from ”The View Content screen appears.” on page 40.

Viewing Content from the Workarea
1. Navigate to the folder that contains the content, as explained in
”Viewing a Folder” on page 33.
2. The icon to the left of the View option indicates the type of
content being displayed. Possible icons are described below.

Icon

Content Type
All types

HTML

HTML form or survey

Office documents
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Icon

Content Type
Managed files

Multimedia

Open Office

To change the type of content being displayed, click View then
select a content type from the menu options.

3. If your system supports more than one language, you can
select an edition of the content in a particular language via the
View > Language menu option (illustrated below).
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4. Click the content.
5. The View Content screen appears.

After you select the content, you have the following options. (Your
options may vary depending on your permissions and the status of
the content.)
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Button or
Tab

Name

Description

For more information, see

Properties

Content
Properties

View the content’s properties

”Properties” on page 42

Content

View Content

Displays content

Summary

Edit Summary

Edit content’s summary.

”Adding a Content Summary”
on page 67

Metadata

Edit Metadata

Edit content’s metadata

”Adding or Editing Metadata” on
page 71

Comment

View Comment

View comments on changes
made when editing content.
This comment also appears on
the View Content and Content
History screens.

Tasks

Add/edit tasks

Add or edit tasks for this content

”Managing Tasks” on page 317

Web Alerts

Add/edit Web
Alerts

Add or edit Web Alerts for this
content

E ktron CM S40 0. NET

Edit Content

Open content for editing

”Editing Content” on page 49

View History

View older versions of content;
restore older version

”Viewing and Restoring
Previous Content” on page 99

View Staged

Displays staged content

”Staged Content” on page 654

View Difference

Compares current and earlier
versions of content

”Comparing Versions of
Content” on page 92

Delete

Delete content

”Deleting Content” on page 53

Check for
content linked to
this content

Identify all content with
Quicklinks to this content

”Checking for Broken
Quicklinks” on page 55

Administrator manual chapter
“Web Alert Feature”
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Button or
Tab

Name

Description

For more information, see

Add Task

Attach a task to content

”Task Module Toolbar” on
page 342

Properties

View and modify Content
Searchable setting

Check this box if the content
should be found when someone
searches your Web site.

Return

Go back to previous menu

View
(language)

View

If you can view content in more
than one language, select a
language from the drop down
list.

Add

Add

-select
language-

-select
language-

Lets you copy current content
into a new item and translate it
to selected language.

”Translating Content to Another
Language” on page 51

Properties
The content properties screen contains information about the
content.
Field

Description

Content Title

The title assigned to the content

Content ID

The ID number assigned to the content. The ID number is used to retrieve
content from a database.

Content language

The content’s language

Status

The current status of the content
See Also: ”Appendix A: Content Statuses” on page 648

Last User to Edit

The last user to edit this content

Last Edit Date

When the content was last edited
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Field

Description

Start Date

When the content will go live on the Web site

End Date

When the content will be removed from the Web site

Action on End Date

What happens to the content when its end date and time are reached. See
Also: ”Setting Archive Options” on page 64

Date Created

When the content was created

Approval Method

Whether all approvers must sign off on content before it is published;
managed by your system administrator.

Approvals

The users in the approval chain for this content. See Also: ”Approving/
Declining Content” on page 81

Smart Form
Configuration

The Smart Form applied to the content. This is typically managed by your
system administrator. See Also: E kt r o n C M S 4 0 0 . N E T Administrator Manual
Section “Managing Content Folders” > “Smart Forms”

Template

The template currently assigned to the content. See Also: The E kt ro n
C M S 4 0 0 . N E T Administrator Manual section “Managing HTML Content” >
“Creating/Updating Templates”

Path

The folder path to the content’s folder. A slash (\) represents the Content
folder.

Rating

E k t r o n C M S 4 0 0 . N E T provides a Content Rating feature that lets site visitors

rate any content item on a scale of 1 to 10. If this feature is enabled for the
content item, the average numerical rating appears. See Also: E kt r o n
C M S 4 0 0 . N E T Administrator Manual section “Managing Content” > “Content
Rating”
Content Searchable

True appears if the content can be found when someone searches your Web
site.
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Expanding the Content Area
It is possible to expand the content area of the screen vertically.
This gives you more space to work on content. To expand the
content portion of the Workarea, click the up arrow (
),
highlighted below.

Once the content area is expanded, the top row of buttons and title
are not visible.

Click the down arrow (
) to return the content area to normal
size. The top row of buttons and title also return to the screen.
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Adding Content
If you have permission to add content to a folder, you can create
content for that folder. The following flowchart illustrates a typical
sequence of events when working with content.

After you create content, you or your system administrator must
make it available on the site. For example, you can add a hyperlink
to it from another page, or place it in a collection or menu. Your
administrator can add it to a list summary or content list.
To add content, follow these steps.
1. Browse to the folder where you want to create the new content.
2. Select a language from the language dropdown list.
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3. Select a content type from the New menu.
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See Also: ”Types of Content” on page 5
4. The Edit Content window opens.
5. Create content in the editor using the following table.

Responding to the Fields on the Add Content Screen

Field

Description

Title

Enter a title for the content.

Add to
Quicklinks
Table

Check if you want to create a Quicklink to this
content. If you do, users can insert links to this
content from within other E ktron CM S40 0. NET
content items
See Also: ”A quicklink is a special kind of hyperlink
that jumps to another content item on your Web
site. (A regular hyperlink jumps to a Web page on
the internet.)” on page 118

Content
Searchable

Check this box if the content should be found when
someone searches your Web site.

After you respond to the above fields, the following buttons are
available.

Buttons on the Add Content Screen

Button

Name

Description

Submit

Submit the content into the approval chain. This action also
returns the new or updated content to the database and exits the
editor.
See Also: ”Approving/Declining Content” on page 81
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Button

Name

Description

Publish

Publish the content to the Web site.
Note: Only the last approver in the approval chain sees this button.
See Also: ”Approving/Declining Content” on page 81
This action also returns the changed content to the database and
exits the editor.

Check In

Save and check-in the document. This action returns the changed
content to the database and exits the editor. It does not submit the
content into the approval chain. Rather, it allows you and other
users to continue changing it.

Save

Save the content without leaving the editor. It is a good idea to
save your work frequently.

Cancel

Close the editor without saving changes.

Tabs on the Edit Content Screen

Tab

Description

Content

Insert content. For more information about using E k tro n
C M S 4 0 0 . N E T ’s editor, see ”Introduction to eWebEditPro+XML”
on page 461.

Summary

Enter or edit the content summary.
See Also: ”Adding a Content Summary” on page 67

Metadata

Enter or edit the content metadata.
Note: All required metadata must be added before the content can
be submitted into the approval chain.
See Also: ”Adding or Editing Metadata” on page 71
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Tab

Description

Comment

Briefly describe the content, or comment on changes made when
editing content.
The history comment appears on the View Content and Content
History screens.

Schedule

If you don’t want to submit the content to the approval chain
immediately, enter when it will be submitted.
See Also: ”Scheduling Content to Begin and End” on page 60
If appropriate, enter a date when the content will no longer be
viewable on the Web site.
See Also: ”Setting an End Date on Content” on page 63

Web Alerts

See the Ek tron CM S40 0.NET Administrator Manual chapter
“Web Alert Feature””Web Alert Feature” on page 765

Templates

This content’s folder must have a default template. It can also
have additional template assigned.
When content is created, the default template is automatically
assigned to it. If you want to change the template assigned to this
content, click this tab and choose a template from the dropdown
list.

Editing Content
Ektron CMS400.NET content can be in any of several statuses, as
described in ”Appendix A: Content Statuses” on page 648. You can
only edit content for which you have permission and in one of the
following statuses:

• published
• checked in
• checked out by you
• submitted for your approval
NOTE

Once you check out content, it cannot be checked out by other users until you
check it in.

Steps in Editing Content
Accessing the Edit Content Screen from a Web Page
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To access the Edit Content screen from a Web page, follow these
steps.
1. Sign in.
2. Browse to the content you want to edit.
3. Right click the mouse and select Edit.

•edit content
•create or edit a summary
•specify metadata for the content
•enter or update a comment
•enter or update start and end dates
•review and update Web Alert information (To learn more, see
the Ektron CMS400.NET Administrator manual chapter “Web
Alert Feature”)

•if manual aliasing is enabled, an Alias tab appears (To learn
more, see the Ektron CMS400.NET Administrator Manual
section “URL ALiasing” > “Manual Aliasing”)
•assign or change available templates (To learn more, see the
Ektron CMS400.NET Administrator Manual section “Managing

HTML Content” > “Creating/Updating Templates”)

•save changes
•check in content
•submit content for approval
•publish content to the Web site
•access the library
4. Make the necessary edits to the content. See Also: ”Table of
Toolbar Buttons and Drop-Down Lists” on page 468
Or, you can choose a toolbar option or tab from the top of the
Edit Content window. These options are described in ”Buttons
on the Add Content Screen” on page 47 and ”Tabs on the Edit
Content Screen” on page 48.

Accessing the Edit Content Screen from the Workarea
To access the Edit Content screen from the Workarea, follow these
steps.
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1. Access the View Content screen for the content you want to
edit, as described in ”Viewing Content” on page 38.
2. Select the language whose content blocks you want to view.
3. Click the Edit button (

).

4. The editor opens with the content block inserted.
5. From the Edit Content window, you can

•edit content
•create or edit a summary
•specify metadata for the content
•enter or update a comment
•enter or update start and end dates
•review and update Web Alert information (To learn more, see
the Ektron CMS400.NET Administrator manual chapter “Web
Alert Feature”)

•save changes
•check in content
•submit content for approval
•publish content to the Web site
•access the library
6. Make the necessary edits to the content. See Also: ”Table of
Toolbar Buttons and Drop-Down Lists” on page 468
Or, you can choose a toolbar option or tab from the top of the
Edit Content window. These options are described in ”Buttons
on the Add Content Screen” on page 47 and ”Tabs on the Edit
Content Screen” on page 48.

Translating Content to Another Language
NOTE

The following procedure only works with HTML or XML content. You cannot
translate other file types as described below.

Use this procedure when you want to initialize a new foreign
language content item with content from a source language. This
copying should facilitate the translation.
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For example, an editor is translating content from French to
German. The editor copies the French edition to new content
whose language is German. As the editor translates the French
edition into German, he deletes the French content. Any images in
the content would usually remain, and all formatting (tables,
bullets, etc.) is retained.
To copy content into new content block of a different language,
follow these steps.
1. Go to the View Content screen for the content you want to
translate.
2. From the View drop-down list, select the original language.
3. Use the Add drop down list in the upper right corner to select
the language into which you want to translate the content.

4. The Edit Content screen appears with original language
content. Translate into the new language then delete the
original content.
If desired, you can click the Translate button ( ). If you do, a
new screen prompts you to identify the original language, new
language, and the glossary to use. Then, the content is
translated. If you like the translation, click Paste Content, and
the translated content replaces the original.
Once the translated content is inserted into the editor, you can
edit it as needed.
5. When you save the content, it is saved as the edition of that
content in the selected language.
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Deleting Content
NOTE

The ability to delete content is a privilege granted by the system administrator. If
you do not see a Delete button (
to do so.

) on the screen, you do not have permission

The Delete command lets you permanently delete obsolete
content from your Web site. You can only delete content if its status
is Approved.
Like publishing, deleted content must go through the approval
chain before it is removed. If you are the last approver in the
approval chain, the content is deleted immediately. See Also:
”Approving/Declining Content” on page 81
You can delete a single content item or several content items in a
folder. Both procedures are explained below.

Deleting a Single Content Item
To delete one content item, follow these steps.

Deleting Content from a Web Page
To delete content from a Web page, follow these steps.
1. Sign in.
2. Browse to the content you want to delete.
3. Click the Delete button (

).

4. The View Content screen for the selected content appears.
(See ”Viewing Content” on page 38.)
5. Click the Delete button (

).
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6. The following message appears.

7. Click OK to delete the content.

Deleting Content from the Workarea
1. Access the View Content screen for the content you want to
delete, as described in ”Viewing Content” on page 38.
2. Click the Delete button (

).

3. The following message appears.

4. Click OK to delete the content.

Deleting Several Content Items in a Folder
On the View Content Folder screen, you can delete several
content items at one time. To do so, follow these steps.
1. Access the content folder that contains the content you want to
delete.
2. Click the Delete Content button (

).

3. The Delete Contents of Folder screen is displayed.
4. Check boxes next to content items you want to delete.
NOTE

Check off the box in the header cell to select all or deselect all.
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5. Click the Delete Content button (

).

6. A confirmation message is displayed.
7. Click OK to continue.

Checking for Broken Quicklinks
The Check Links button (
) locates all content that includes a
Quicklink to the displayed content. This feature is useful before
deleting content, because it informs you of every content item that
will include a “dead” link after you delete the selected content. You
should then edit that content and remove or change the obsolete
Quicklinks.
To use the link checker, follow these steps.
1. Access the View Content page for the content whose links you
want to check, as described in ”Viewing Content” on page 38.
2. Click the Check Links button (

).

3. A page lists each content item that links to the current content.
Click the title to access the View Content page for the selected
content. From there, you can remove or change the Quicklink.

Adding Subfolders
Since the procedure for adding new folders is usually only granted
to administrators, it is documented in the Ektron CMS400.NET
Administrator manual section “Managing Content Folders” >
“Adding Subfolders.”

Deleting Folders
Since the procedure for adding new folders is usually only granted
to administrators, it is documented in the Ektron CMS400.NET
Administrator manual section “Managing Content Folders” >
“Deleting Subfolders.”
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Workarea Toolbar Buttons
The top of many Workarea screens feature a toolbar that contains
buttons for performing actions. This section explains the buttons’
functions.
Button

Name

Description

Add

Adds items in several places.

Add Calendar Event

Accesses the add calendar event screen in the Workarea.

Add Content

In a content folder, opens the editor and allows you to create
new content.
See Also: ”Adding Content” on page 45

Add Content Folder

In a content folder, allows you to create a subfolder to further
organize your content.
See Also: ”Adding Subfolders” on page 55

Add Library Item

In the library folder, allows you to upload an image or file, or add
a hyperlink or Quicklink to use in content.
See Also: ”Library Folder” on page 117

Add Task

Assign task to a user. See Also: ”Managing Tasks” on page 317

Approvals

View approval chain for folder or content.
See Also: ”Approving/Declining Content” on page 81

Approve

Approve content that awaits your approval.

Approve All

In the approvals folder, approves all content awaiting your
approval with one click.

Archived Content

If current content is being displayed, switch to display archived
content.
If archived content is being displayed, switch to display current
content. See Also: ”Setting Archive Options” on page 64

Back

Return to previous screen.
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Button

Name

Description

Calendar

Lets you choose when content will go live.
See Also: ”Working with Calendars” on page 292

Cancel

Cancels action you are performing without saving the
information.

Check-in

Saves and checks in content you are working on.
See Also: ”Checked-In Content” on page 650

Check-out

Checks out content to edit; prevents others from simultaneously
working on it.
”Checked Out Content” on page 651

Collection

Accesses the collection area for content; lets you create, edit,
and delete collections. See Also: ”Working with Collections” on
page 401

Decline

Declines an approval request submitted to you.

Delete

Deletes selected item.

Delete Content

Deletes multiple content items at once.

Delete Folder

Deletes current content folder.

Do Not Apply XSLT

Removes XSLT applied to XML content viewed in the content
history area.

Edit

Edits content or specific criteria in the Workarea.

Insert Library Item

Inserts selected library item into content.
See Also: ”Library Folder” on page 117

Link Check

Identifies content with a hyperlink to the current content. You
would typically use this feature to remove the links before
deleting content.
If you do not remove the links, they are inoperative after the
content is deleted.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

57

Button

Name

Description

Overwrite

Replaces an image or file with a newer version.
See Also: ”Overwriting Files” on page 129

Preview

Previews item that was or will be added.

Publish

Save and publish the content.

Remove

Removes items from folders and lists in the Workarea.

Reorder

Changes the sequence of links in a collection.
See Also: ”Working with Collections” on page 401

Restore

Restores previously published content.
See Also: ”Viewing and Restoring Previous Content” on page 99

Save

Saves content that was modified.

Search

Searches content and library folder screens.
See Also: ”Searching the Library” on page 121

Show Calendar

Displays the calendar in the Workarea.

Submit

Saves and submits content to next approver in the approval
chain.

Update

Changes are saved and content is updated.

View Date

View all calendar events for a selected day.

View Difference

Opens the View Content Difference feature.
See Also: ”Comparing Versions of Content” on page 92

View History

View history of selected content.
See Also: ”Viewing and Restoring Previous Content” on page 99
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Button

Name

Description

View Published

Displays currently published version of content.

View Staged

Displays staged content.
See Also: ”Staged Content” on page 654
Selects the language of the content being displayed.
Select

language
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Sc h e d u l i n g C o n ten t to B eg in a nd
End

Scheduling content lets you control when content becomes visible
on the Web site. Similarly, you can remove content on a
predetermined date and time. When used together, a start and end
date can relieve you of much work by managing how long content
is viewable on your Web site.
You can also set options for what happens to content after
reaching its end date.

How Does It Work?
When you create or modify content, you can select a “go live” date
and time. If you do, and the content makes it through the approval
chain, Ektron CMS400.NET publishes the content to the live site at
that time.
For example, your company is having a sale of the century in a
month, and everything is ready except the announcement. You
decide to update your Web site to let the public know about the
sale. With this feature, you create the Web content now and set it
to go live a week before the sale.
The Ektron Windows Service manages these changes to your site.
See Also: Ektron CMS400.NET Administrator Manual section
“Managing your CMS400 System” > “Ektron Windows Service.”
This topic is explained through the following subtopics:

• ”Setting a Start Date” on page 61
• ”Setting an End Date on Content” on page 63
• ”Setting Archive Options” on page 64
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Setting a Start Date
To set a start date, follow these steps.
1. Access the editor by adding new content or editing existing
content.
2. If adding new content, enter a title and the content.
3. Click the Schedule tab.

4. Click the calendar button next to the Start Date field.

5. A calendar pops up.
6. Select the date and time when the content will become visible
on the Web site.
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7. Click the Done button.
8. The date and time appear in the Start Date field
NOTE

When you select a time for content to go live, that time depends on the server’s
system clock. If the clock is incorrect, the content will not go live at the intended
time.

What Happens After I Set a Start Date?
After you save the content, it appears on the Content Pending Start
Date report, which helps you keep track of content with a future
start date. See Also: The Ektron CMS400.NET Administrator
Manual > “Content Reports “ > “Content Pending Start Date
Report”
After you set a go live date and the content completes the approval
chain, two scenarios may occur:

• The content is new
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• The content already exists
Each scenario is now explained.

Setting the Go Live Date on New Content
When you set a go live date on new content, it becomes viewable
on the specified date and time as long as it completes the approval
chain. If a user accesses the page that contains the content before
then, he sees only the template. This occurs within Ektron
CMS400.NET and when the content is viewed on the Web site.

Setting the Go Live Date on Existing Content
When you set a go live date for changes made to existing content,
and it completes the approval chain, the content has a grey border
within Ektron CMS400.NET until the date specified.
When you view content on the Web site, you see the previously
published version. When the go live date occurs, the new content
replaces the previously published version, and the content‘s status
changes to Active.

Setting an End Date on Content
To set an end date for content, follow these steps.
1. Access the editor by adding new content or editing an existing
one.
2. If adding new content, enter a title and content.
3. Click the calendar button next to the End Date field.
4. A calendar pops up.
5. Select the date and time you want the content to be removed
from the Web site.
6. Click the Done button.
7. The date and time appear in the End Date field
NOTE

When you select a time for content to go live, that time depends on the server’s
system clock. If the clock is incorrect, the content will not be removed at the
intended time.
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What Happens After I Set an End Date?
If you set an end date to content, and it gets published to your Web
site, the content is visible on the Web site. When content reaches
its end date, you have three choices for what to do with it. These
are explained in ”Setting Archive Options” on page 64.
If your choice means the content will not appear on the Web site,
Ektron recommends having another content item ready to replace
it. If not, and a site visitor goes to the page containing the content,
he sees the template without the content.

Appearance on Content Reports
After content reaches its end date, it appears on the Expired
Content report, which helps you keep track of expired content. See
Also: The Ektron CMS400.NET Administrator Manual > “Content
Reports “ > “Expired Content Report”
Also, the Content to Expire report lists all content whose end date
will occur within a number of days that you specify. See Also: The
Ektron CMS400.NET Administrator Manual > “Content Reports “ >
“Content to Expire Report”

Setting Archive Options
After setting an End Date, you can specify content’s archive
options, which determine what happens upon reaching its end
date/time.
To be eligible for any option, the content must reach its end date/
time, progress through its approval chain, and be published. Until
those events occur, the content remains visible both within its
content folder and on the site.
The archive options (illustrated below) appear below the Start
Date and End Date fields on the content’s Schedule screen.
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Each option is explained below.

Archive Options

Option

Can site visitors view content
upon expiration?

Can users view and edit
content within Ektron
CMS400.NET upon
expiration?

Archive and remove from
site (expire)

No

Yes, within its folder by clicking
the View > Archive Content
option.
Note: If this option is assigned to
content, it only moves into the
archived area of its folder after a
site visitor accesses the host Web
page.

Archive and remain on Site

Yes
The content does not appear on a
page that uses the ListSummary
function but does appear wherever
the ArchiveListSummary function is
used.

Add to CMS Refresh Report

Yes

Yes, within its folder by clicking
the View > Archive Content
option.
Note: If this option is assigned to
content, it only moves into the
archived area of its folder after a
site visitor accesses the host Web
page.
Yes, in the active area of its folder
and on the Refresh Report.
See Also: Ek tr on CMS 400 .NET
Administrator Manual section “
Content Reports“ > ”Refresh
Reminder Report”
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Restoring Content from Archived to Active State
To restore content from archived state to active, follow these steps.
1. Navigate to its folder.
2. If necessary, click the Archive button to view it. (See ”Archive
Options” on page 65).
3. Click the Edit button (

).

4. Click the Schedule tab.
5. Remove the End Date or change it to a future date.
6. Submit the content for publishing. When the content is
published, it will no longer be archived.
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Adding a Content Summary

A summary provides a short description of content to supplement
the title when displaying a list of content on a Web page. When you
create or edit content, you can create a summary. Then, your Web
site developer can create Web pages that contain just the
summaries to attract readers to the full story.
A good example is a news Web site. A page on that site could list
the titles of the top stories followed by a summary of each
(illustrated below).
TOP STORIES
Ektron Named a Rising Star (08-15-2003)
August 15, 2003, Amherst, New Hampshire, USA —
Ektron, Inc., an innovator in Web content
management and authoring, has been named
a Rising Star as part of the prestigious
New England Technology Fast 50 Program.
Ektron Launches International Distribution Program (0808-2003)
August 8, 2003, Amherst, New Hampshire, USA —
Ektron, Inc., an innovator in dynamic Web
content authoring and management with
over 350,000 users, today announced the
launch of its international distribution
program.
Like content, summaries can include images and files as well as
different font styles and sizes. This chapter explains how to create
summaries and how they can help navigation within your site. Your
system administrator determines how to display the summaries on
your site.
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Creating Summaries
There are two ways to create summaries:

• for a new content (see ”Creating a Summary on New Content”
on page 68)

• for an existing content (see ”Creating a Summary for Existing
Content” on page 69)

Creating a Summary on New Content
1. Navigate to the folder in which you want to create the content.
2. Click the Add Content button. The Add Content screen
appears.

3. Insert a Title and content. See Also: ”Adding Content” on
page 45
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4. Click the Summary tab.
5. Enter summary information for the content. The summary can
include images, files, and hyperlinks. Its length can be
restricted by your system administrator in the configuration
setup screen.
6. When done, click the appropriate button.

Creating a Summary for Existing Content
1. Navigate to the folder that contains the content.
2. Click the content.
3. The View Content screen appears.
4. Click the Summary tab to enter or edit summary information
for the content. The summary can include images, files, and
hyperlinks. Its length can be restricted by your system
administrator in the configuration setup screen.
5. When done, click the Save button (

).

6. The View Content page reappears. The status of the content
changes to “checked out” to you.
NOTE

When you enter or edit existing content’s summary, its status changes to checked
out. After you create the summary, click the Check-In button to check the content
in. From that point, you need to submit or publish it.

Editing a Summary
NOTE

You can only edit the summary of content that is published, checked in, or
checked out by you.

To edit a content’s summary, follow these steps.
1. Access the View Content page for the content whose summary
you want to edit, as described in ”Viewing Content” on page 38.
2. Click the Summary tab.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

69

Adding a Content Summary

3. The Edit Summary window opens.
4. Click the Edit button. The summary opens within the editor.
5. Make the necessary changes.
6. Click the Save button (

).

7. The summary is saved, and the View Content page is
displayed with a status of checked out.
NOTE

When you edit an existing content summary, it goes into a checked out state. After
creating the summary, check the content back in. From that point, you must
submit it or publish it.
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Adding or Editing Metadata

You can add several kinds of metadata to Ektron CMS400.NET
content.

• Metadata that appears on your Web site’s search page, below
the standard search fields (illustrated below). It helps site
visitors find content on your Web site.

This kind of metadata also appears on the Search screen
within the Workarea. For more information, see ”Entering
Custom Metadata” on page 72.
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• Metadata that resides in the source code of a Web page.
Examples include the title and meta tags. This data makes it
easier for search engines to find your Web page (illustrated
below).

For more information, see ”Entering Title and Keywords” on
page 79.

• Metadata that identifies related Ektron CMS400.NET information
(for example, another content item, a collection, or a
ListSummary). Then, your Web site can display the related
content whenever the source content item appears.
For example, your Web site sells motorcycle helmets. On a
page that shows a particular helmet, the left column lists a
collection of motorcycle drivers who use that helmet.
Metadata is more fully explained through the following topics.

• ”Entering Custom Metadata” on page 72
• ”Entering Title and Keywords” on page 79

Entering Custom Metadata
Your system administrator defines the metadata that can be added
to content. The metadata being collected can be customized for
each folder. When you create or update content, you can define
metadata using fields that the administrator specified.
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NOTE

In order to add metadata to content, an administrator must have created
definitions for it in the language of the content.

For example, each document stored in the Document
Management functionality has a unique part number. Your system
administrator adds a custom search field called Part Number, and
specifies that only numbers can be inserted into the field.
When you add a document to Ektron CMS400.NET, you access the
content’s metadata and insert the correct part number for the
document (illustrated below).

Then, anyone visiting your Web site can find that document by its
part number (or a range of part numbers) using the field on your
Web site’s search screen (illustrated below).
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NOTE

When your system administrator sets up metadata, he determines whether or not
is it “publicly viewable.”
If it is, the search field appears on the search screen that site visitors use along
with the search screen in the Ektron CMS400.NET Workarea. If the data is not
publicly viewable, it only appears on the Workarea search screen.

Entering or Editing Metadata
To enter or edit content’s metadata, follow these steps.
WARNING!

You may only edit metadata of content that is published, checked in, or checked
out by you.

1. Access the Edit Content screen for the content whose
metadata you want to enter or edit, as described in ”Editing
Content” on page 49.
2. Click the Metadata tab.
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3. The Edit Metadata screen opens with the current metadata
displayed. In order to add metadata to content, an
administrator must have created definitions for it in the
language of the content.
NOTE

Your screen may differ from the example below. Your system administrator
determines the appearance of the Metadata screen.

4. Edit the metadata. Note that

• Required fields are red and marked with an asterisk (*). You
must place at least one response in such fields before you can
save the metadata.

• Your system administrator may prevent you from editing a field.
In this case, the field has a gray background, and you cannot
place the cursor there.
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• Fields may appear in two columns. In this case, the system
administrator provides a list of terms that you can apply to the
content. You can select terms from the list or enter free text.
One column is labeled Not Included and the other Included.
Move terms between lists by clicking the Add and Remove
buttons.

• You may see a list of terms in one box, and a field labeled Text
to its right.

With such a list, you can

- add a new term by typing it into the Text field and clicking
Add

- remove any term by selecting it and clicking Remove
- modify any term by selecting it. It appears within the Text
field, where you can change it. Then, press the Change
button.

- restore the terms to their default settings by pressing the
Default button
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- change the sequence of terms by selecting one then
pressing the up and down arrows (

)

• If related content metadata is available for the content, its
name appears followed by None Selected (ID) Change Clear.
Click Change to display a window of choices. For example, if
the related content type is a collection, all collections appear in
the popup. Select the appropriate data for this content.
Selected items appear in the bottom of the screen. You can
reorder them by selecting an item then clicking the up and
down arrows. To remove items from the bottom of the screen,
select them and click the delete (

) button.

If the related content type is either content item or library
image, hyperlink, or file, the following window appears when
you click Change.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

77

Adding or Editing Metadata

Use this screen to identify the related content. To do this,

- Select a folder from the left frame
- Double click the related-content item from the top right
frame

- The item appears in the lower right frame
- When all items are in the lower right frame, click the Save
button (

) directly below Select Metadata

• If default metadata is defined for a specific data type, you can
click the Default button at the bottom of each field to restore it.

• Below each field is a Characters Left field, which counts the
number of metadata characters. You cannot exceed the
maximum (500 characters).
5. Click the Save button (

).

6. The View Content screen reappears.
The content is now in a checked out state to you. For the changes
to take effect on the Web site, check in the content and submit it to
the approval chain.
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See Also: ”Approving/Declining Content” on page 81

Entering Title and Keywords
After you create or update content, it is typically published to the
World Wide Web (WWW). Programs that search the Web (such as
Google) look at a page’s title and keywords to determine if they
should return your Web page with their results.
To improve search results, Ektron CMS400.NET provides two fields
within Metadata by default.
NOTE

Your system administrator may enable or disable these fields for each folder.

• Title - appears on the search results screen to further define
your Web page
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• Keywords - are searched by leading search programs, along
with the page’s title
After content is published to the Web site, you can view the page
source to see its metadata. Below is the source of a sample Web
page.

On this Web page, notice the keywords are included in the meta
tag, and the title is in HTML tags. These appear according to how
the administrator sets up the metadata definitions.
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Approving/Declining Content

Your site administrator establishes an approval chain for each
folder, or even specific content items. The approval chain is a list of
people or groups who must approve new or edited content before it
is published to the Web site. If a user group is part of an approval
chain, any member of the group can approve the content.
The administrator also determines the sequence of approvers in
the chain.
When a new or edited content is submitted to the approval chain, it
is reviewed by users who may

• change it
• approve or decline it
• publish it to the Internet (it is published when the last user
approves it)
The chart below illustrates the approval process.
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You can approve and decline all content that has been submitted
to you from the approval folder.
When creating or modifying content, you can select a “go live” date
and time. If you do, and the content makes it through the approval
chain, Ektron CMS400.NET publishes the content to the live site at
that time. See Also: ”Scheduling Content to Begin and End” on
page 60
While an updated version of content is in the approval process, the
current version remains on the site. Also, if you set content to go
live on a future date, the current version remains on the site until
then.
The following topics guide you through the approval or decline of
this content.

• ”Approve/Decline One Content Item” on page 83
• ”Approve/Decline Several Content Items” on page 85
• ”Example of an Approval Chain” on page 85
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Approve/Decline One Content Item
1. Click the Smart Desktop button (circled in red below).

2. Click Reports.
3. Click Approvals.
4. Click the content you want to approve or decline.

To select all displayed content, click Select All at the top of the
screen.

5. The content appears. You can view the content, summary,
metadata, etc.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

83

Approving/Declining Content

A toolbar at the top of the screen lists tasks you can perform on
the content.
Button

Name

Result of Clicking

Publish

Accept changes to the content and publish it to the site.
Note: If there is another approver in the approval chain for the content,
this is replaced by a SUBMIT button.
If you click Publish but the content item has an incomplete task assigned
to another user, the content cannot be published. Instead, the following
error message appears.

The user to whom the task is assigned must complete it before you can
publish the content.
Decline

Reject changes and keep current version of content live on the Web site.
If you choose this option, a window prompts you to enter a reason for not
publishing the content. The reason is saved as part of the content item’s
history.

Edit

Check out content and change it if desired.

View
Published/
Staged

Toggle between the currently published version and submitted version of
content. This can help you compare versions. See Also: ”Staged Content”
on page 654

View Diff

View differences between the version awaiting approval and the currently
published content.
See Also: ”Comparing Versions of Content” on page 92

Back

Return to previous screen.
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Approve/Decline Several Content Items
To approve several submitted content items without reviewing
them, follow these steps.
1. Select the submitted content you want to approve, as
described in ”Approve/Decline One Content Item” on page 83.
2. Click the Approve All button (

).

3. The following message appears.

4. To continue, click OK.
5. The approved content is either submitted to the next publisher,
published immediately to the Web site, or deleted, depending
on the approval chain set for the content.

Example of an Approval Chain
The approval chain begins when a content contributor submits a
new or edited content. If email is enabled, an email is sent to the
next approver in the approval chain.
The following example follows a typical content block from creation
to publication. Three users make up this approval chain.

• Sports Writer - creates sports content
• Sports Editor - edits and publishes all sports articles
• Editor In Chief - edits and publishes all articles
Each user has different permissions that correspond to their roles.
The example uses the following topics to explain a typical approval
chain.
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• ”Creating Content” on page 86
• ”First Approver” on page 87
• ”Second Approver” on page 89

Creating Content
The first step is to create content. To create new content, follow
these steps.
1. Log in to Ektron CMS400.NET as a SportsWriter.
2. Create content, as described in ”Adding Content” on page 45.
3. Click the Submit button (

) at the top of the window.

4. The content is in the approval chain. The next user in the chain
receives an email saying the content is ready for approval.
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NOTE

Emails are only sent if your Administrator enables them.

The content contributor, Sports Writer, has completed his role in
the approval chain but continues to receive emails notifying him of
changes in the content’s status.

First Approver
After Sports Writer submits the content, the first user in the
approval chain, Sports Editor, receives an email stating content
needs his approval. He can change and approve the content or
decline it.
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Sports Editor logs into Ektron CMS400.NET, navigates to his
desktop, where he sees a link Content Awaiting Approval.

He clicks the link and sees all content awaiting his approval.
The approvals folder window displays information such as title,
who submitted it, go live date, etc. The Sports editor clicks the
submitted content.

The View Content Awaiting Approvals window appears listing all
information necessary to decide whether to approve or decline the
content.
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At the approval window, the Sports Editor has several options.
Button
Approve

Decline

Edit

Result
Send content to next approver in approval chain.

1.

Send email to creator, notifying him/her that
content was declined.

2.

Remove content from approval chain.

Invokes the editor. From here, the approver can
change the content.

For demonstration purposes, we‘ll choose Approve.

Second Approver
After the content is approved, the next approver in the approval
chain receives an email saying that the content is ready for
approval.
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EditorInChief logs in to Ektron CMS400.NET and accesses his
Workarea. The Workarea has an Approval folder with the content
awaiting his approval. EditorInChief navigates through the
Approval folder until he finds the content Red Sox win World
Series.
From this window, EditorInChief can view information about the
content, including title, go live date, user who created it, etc. He
then clicks the content he wants to approve.
This window is similar to the previous approver’s but includes a
Publish button at the top of the screen. The EditorInChief has a
publish button (instead of a submit button) because he is the last
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approver in the approval chain. When he approves the content, it is
published to the Web site.
Like the Sports editor, the EditorInChief has the following options.
Button

Description
Publish the content.

Publish
1.

Sends an email to the creator, notifying him/her
that content was declined.

2.

Removes content from the approval chain.

Decline

Edit

Invokes the editor. The approver changes the
content.

After reviewing the content, the EditorInChief decides it is great
and publishes it. At this point, the content becomes live on the Web
site, and the approval chain is complete.
The user who created the content receives an email notifying him
that it was published.
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Comparing Versions of Content

The View Content Difference feature highlights changes that were
made to selected content. Below is an example of the View
Content Difference screen, showing two versions of content. The
changes are indicated by

• redlining deleted content
• highlighting in yellow added content

Within the View Content Difference feature, you can perform
several tasks, as well as view different versions of the content
separately, or compared.
The View Content Difference feature is explained through the
following topics:

• ”When Can I Compare Content?” on page 93
• ”The Compare Content Window” on page 93
• ”First Use of the View Content Difference Feature” on page 98
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When Can I Compare Content?
The View Content Difference feature is only available when

• you are viewing an historical version of content
• a staged version of the content is available (See Also: ”Staged
Content” on page 654)
The following table explains when you can use the feature, and
which versions are compared.
Content Status

Compares current published
version with

Published

Historical version stored in the content
history area

Checked-In

Most recently checked-in version

Submitted

Submitted version

Pending Start Date

Scheduled version pending start date

Checked Out

Not available

If content can be compared with another version, the View
Difference button (
Web page view.

) appears in the content history area or the

The Compare Content Window
NOTE

The first time the View Content Difference feature is opened, a simple installation
program runs. See Also: ”First Use of the View Content Difference Feature” on
page 98.

The Compare Content window consists of the following:

• ”Toolbar” on page 94
• ”Content Area” on page 97
• ”View Tabs” on page 97
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Each area is explained below.

Toolbar
The content comparison toolbar has five buttons, explained below.
Button

Name

Description

Print

Sends content to local or network printer.
Note: This option prints the currently displayed content,
whether it is the compared, published, or staged content.

Save

Saves a copy in HTML format on your local machine or
network. When saved as a physical file, the HTML may be
edited. However, the changes are not saved to the Web
Server.
Note: The save option saves the version of the content you
are viewing.
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Button

Name

Description

Setup

Opens setup dialog box to configure the settings. Typically,
only an administrator would use this.
For more information, see ”Setup” on page 95.

Help

Displays additional information about the compare feature.

Exit

Closes the window.

Setup
Click the Setup button (
) to open the setup dialog box.
Typically, a system administrator would edit these settings.

You can change the setup options to better suit your needs. The
following table explains each option.
Option

Description

Compare Options
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Option

Description

Compare visual
aspect

Compares content as it would appear on a
Web page.

Compare source
code

Displays compared content as source HTML.

Whitespace Options
Ignore All

Blank (whitespace) characters are ignored.

Smart Detect

One or more consecutive whitespace
characters are treated as a single separation
sequence. That is, multiple whitespace
characters are ignored.

Detect All

Blank (whitespace) characters are treated as
any other character.

Other Options
Ignore Case

Determines whether comparison is case
sensitive. For example, if you check this box,
the strings “Bob” and “BOB” are not
highlighted because their only difference is
the case of the characters.

Ignore Format
Attributes

Determines whether comparison ignores
changes in text-formatting attributes (HTML
Visual Analysis only).

After updating setup information, click OK to save changes.
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Content Area
The content area displays the content comparison.

The following table describes the change indicators.

Symbol

Example

Content state

Plain black text

Unchanged

Yellow highlighted text

Added

Red, struck-through text

Deleted

View Tabs
When viewing content in the View Content Difference feature,
there are three view modes, explained below.

View

Description

Diff

Compares published version of content to staged
version
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View

Description

Published

Displays currently published version

Staged

Displays the staged version of content. See Also:
”Staged Content” on page 654

To switch between views, click the corresponding View tab.

First Use of the View Content Difference Feature
The first time the View Content Difference screen is used on a
client machine, a simple installation program is performed.
Click YES when the following screen appears.

When the installation program completes, close and reopen the
View Content Difference feature.
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Viewing and Restoring Previous
Content

Past versions of published content are available unless your
system administrator purged them. Your ability to view a content
item’s history is determined by your user privileges.
After viewing a previous versions of content, you can replace the
current version with any previous version.
NOTE

This section explains how to view and possibly restore older versions of content.
To see a change-by-change comparison of two content items, use the View
Content Difference feature, explained in ”Comparing Versions of Content” on
page 92.

NOTE

The Purge History feature deletes historical versions of content according to userdefined criteria. Therefore, some previous versions may be unavailable. Ektron
CMS400.NET Administrator manual > “Managing Content Folders” > “Folder
Properties” >”Purge History”

The View and Restore features are explained through the following
subtopics.

• ”Accessing Content History” on page 99
• ”The Content History Window” on page 101
• ”Restoring a Previous Version” on page 102
• ”Comparing Historical Versions” on page 103
• ”Removing Applied XSLT” on page 103

Accessing Content History
By default, all users can view the history of Ektron CMS400.NET
content. You can access content history from two places:

• The Workarea’s View Content page
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• The icon menu for content on a Web page
Once you access the history, the functionality is identical.
The following sections explains how to access the content history
from both places.

Accessing the Content History from the Workarea
To access the history from the Workarea, follow these steps.
1. Navigate to the View Content page for the content whose
history you want to view.
2. Click the View History button (

).

Accessing the Content History from a Web page
To access the history for content from a Web page, follow these
steps.
1. Sign in.
2. Browse to the content whose history you want to view.
3. Click the View History button (

).

4. The Content History window opens.
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The Content History Window

The View Content History window lists every version of the content
available in Ektron CMS400.NET. The window displays the following
information for each version.

• version number See Also: ”The Content Version Number” on
page 101

• a green circle appears next to any version that was published.
On dates without a green circle, the content was checked-in
but not published.

• date and time when a version was checked in or published
• title of content
• last user who edited content
• comments entered by user to describe nature of changes
made
To view any version, click its title. When you do, the Content
History window appears for the selected content.

The Content Version Number
Ektron CMS400.NET assigns a unique number to each saved

version of a content block. The number is increased by one tenth if
the content is checked in but not published. If the content is
published, the next whole number is assigned.
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For example, if the current version is 1.0 and you check in that
content, the new version is numbered 1.1. If the next user who
edits that content publishes it, the new version number is 2.0.
If the content is purged, the numbering scheme restarts with the
content that remains in the database.

The Detail History Window
After viewing the View Content History window, you can click any
version to see the detail for it. The detailed History window has two
sides:

• The left side redisplays the information in the content history
window. See Also: ”The Content History Window” on page 101

• The right side displays the selected version of the content.
After viewing a version of content, you can perform these
actions on it.
Action

Button

Description

More Information

Restore

Restore historical version of
content

”Restoring a Previous
Version” on page 102

View Difference

Compare historical version to
current version

”Comparing Historical
Versions” on page 103

View History
Report

View summary list of all versions

”The Content History
Window” on page 101

Remove XSLT

Remove XSLT applied to XML
content

”Removing Applied XSLT” on
page 103

XML Content Only

Actions are explained below.

Restoring a Previous Version
NOTE

The ability to restore content is a privilege granted by the system administrator. If
you do not see a Restore button (
do not have permission to do so.

) on the View Content History screen, you
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1. Select an historical version of the content that you want to
restore from the left pane.
2. Click the Restore button (

).

3. The content history window closes, and you return to the View
Content page or the Web page, with the content in a checked
in status.
4. If desired, check out the content to make additional changes.
5. Select the workflow to perform on the content.
6. When the historical version is placed in the approval chain and
approved, it is published to the Web site.

Comparing Historical Versions
After you select an historical version of content, you can view the
differences between it and the current version. To compare an
historical version, follow these steps.
1. Select an historical version of the content from the left pane.
2. Click the View Differences button (

).

The historical and the current versions are compared. To learn
more about the comparison, see ”Comparing Versions of Content”
on page 92.

Removing Applied XSLT
You can only remove an applied XSLT when viewing historical
versions of XML content. If you remove the applied XSLT, you can
view the content without the irrelevant XML tags.
The following table compares the views.
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With XSLT

Without XSLT
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Searching the Workarea

You can search any folder to quickly locate content within your
Web site. The following sections explains how to use the content
search through the following subtopics.

• ”Accessing the Search Content Folder Screen” on page 105
• ”The Search Screen” on page 106
• ”Specifying the Kind of Content to Search” on page 107
• ”Specifying a Search Word or Phrase” on page 108
• ”Specifying Match Criteria” on page 109
• ”Additional Search Criteria” on page 111
• ”Custom Fields” on page 112
• ”Fields that Apply to MS Office Files Only” on page 112
• ”Result Display Options” on page 113
• ”Information on the Search Results Screen” on page 115

Accessing the Search Content Folder Screen
To access the Search Content Folder screen, follow these steps.
1. Navigate to the folder at which you want to begin the search.
NOTE

To search your entire site, start with the top-level (Root) folder. If you want to limit
the search to a folder (and its subfolders), select it then choose search criteria.

2. Click Action > Search.
3. The Search Content Folder screen appears.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

105

Searching the Workarea

The Search Screen
The search screen helps you find Ektron CMS400.NET content by
specifying the following criteria.

• the kind of content you want to search (for example, HTML
content)

• a search word or words
• how the search words must match the content in order for a
document to be found by the search

• whether the search words are matched against the content
item’s title

• whether the search words are matched against the content’s
comments
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• an optional range of created or modified dates. Only content
created or updated within a date range is found by the search.

• the editor who updated the content most recently
• the status of the content
• any metadata criteria assigned to the folder
• if the content includes Microsoft Word documents, the size of
the documents

• if the content includes Powerpoint presentations, the number of
slides in the presentation
Each feature is explained below.
NOTE

To help track search activity, the Search Phrase Report provides a count of all
words and phrases searched within a date range. In Ektron CMS400.NET, this
report is available from the Smart Desktop > Reports. For documentation of this
report, see Ektron CMS400.NET Administrator Manual > “Content Reports”
“Search Phrase Report.”

Specifying the Kind of Content to Search
Near the top of the screen, check boxes let you determine the
kinds of content to search.

NOTE

Assets only appears if your organization has implemented Ektron’s Document
Management feature.

Check this box

To search

Content

HTML content

Forms

HTML forms

Assets

Content that is neither HTML not XML, such as
Office documents and managed files. See Also:
”Using the Document Management Functionality”
on page 210
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Check this box

To search

Include Archived

Content, forms and assets that have been
archived. See Also: ”Setting Archive Options” on
page 64

IMPORTANT!

The search only considers content, forms, and assets whose Content
Searchable box is checked. The Content Searchable box appears on the item’s
View Properties screen.

Specifying a Search Word or Phrase
In the Search Text field, enter one or more words that you want to
find within content, forms and assets. The search returns content
that includes these words.
Entering one or more words here is optional. That is, you can use
fields on the lower portion of the screen to find content without
knowing any words contained in the content. For example, you can
find every piece of HTML content that was modified by a certain
user within the last 30 days.
If you check off HTML and Form content, you can enter no search
criteria and get a list of all HTML and Form content on your site.
However, if you enter search text, the search only finds items that
include the search text and satisfy other criteria on the screen.
See Also: ”Adding or Editing Metadata” on page 71

The Noise Files
If you are searching for assets, Windows has a noise file that
screens from the search every single letter of the alphabet as well
as common words. Examples of common words are about, after,
all, and also. Avoid entering such words into the Search Text field,
because the search ignores them.
To find the list of noise words, search your computer for files
named noise.xxx, where xxx is a three-letter abbreviation for the
language. For example, noise.eng lists English noise words.
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You can open a noise file with a simple word processor program,
such as Notepad, to view any language’s noise words. You can
also edit the file. For example, you can remove words that users
should be able to search on.

Specifying Match Criteria
NOTE

This field is only applicable if you entered one or more words in the Search Text
field.

From this dropdown list, select criteria for how the search word or
words must appear within the content of the files being searched.

Your choices are described below.

Choice

A search returns content that has

For more information,
see

All Words

all words in the search field

”All Words” on page 110

Any Word

any word in the search field

”Any Word” on page 110

Exact Phrase

all words in the order specified in the search field

”Exact Phrase” on
page 110

Contains (match partial
words)

any part of any word in the search field

”Contains (Match Partial
Words)” on page 110

Match Criteria Examples
The examples below assume you entered these words into the
Search Text field.
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• partners
• content
• Monday
• employee
• green
All Words
All Words works like an “and” function. The search returns only
content that has the words partners and content and Monday and
employee and green. The words can be in any order within the file.

Any Word
Any Word is almost the opposite of All of the Words. It works like
an “or” function.
When you select this option, the search returns all files that have at
least one of the words entered in the search text field. In other
words, it returns files with the word partners or content or Monday
or employee or green.

Exact Phrase
Exact Phrase returns content that have all five words in the order
specified in the search text field.
A better example would be to search for a phrase, such as Content
Management Solution. The search yields only content with that
exact phrase.

Contains (Match Partial Words)
Although you cannot search for wild cards, the Match Partial
Words option does almost the same. For example, enter at into the
search text field, then select Match Partial Words. The search
returns all content with the letters at, finding words such as At, Bat,
Chatter, Atoll, ATM, etc.
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Additional Search Criteria
The next section of the search screen lets you choose one or more
customized search criteria. Note that if you enter more than one
criterion, only content satisfying all criteria appears on the search
results screen.

Fields that Apply to Content, Forms and Assets

Search criterion

Description

Title

The title of the content, form, or asset.
You can enter a partial word. For example, entering Part yields the following
results.

•
•

Multi-Hospital Nurse Executive Participation
Ektron Partners and Customers

You can also enter more than one word or phrase as long as they are in the
correct sequence.
Note: When searching the Title field for assets, the title assigned within
Ek tron CM S40 0.NET is not considered. Rather, the document’s title field is
searched.
In the illustration below, if you search for Home Budget, your search would
return the document. But if you search for Spreadsheet, no result will be
found.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

111

Searching the Workarea

Search criterion

Description

Comments

The content or form’s comments, which can be inserted via the Comment tab.

Date Created

The file’s creation date. You can enter a single date or a range of dates.
The search returns all items with that creation date that satisfy all other
criteria.

Date Modified

The late date when the file was modified. You can enter a single date or a
range of dates.
The search returns all items with that edit date that satisfy all other criteria.

Last Editor’s Last Name

The last name (surname) of the user who most recently changed the content
or form. This is taken from the Last Name field on the User Information
screen.
The search returns all items last edited by that user that satisfy all other
criteria.

Status

The content status. See Also: ”Appendix A: Content Statuses” on page 648
Note: Although you can search for content by any status, the search results
display only the most recently published version. If a version has never been
approved, nothing appears.

Custom Fields
Custom fields are defined by your system administrator and
applied to content by its author or editor. They are custom-defined,
so would be different for every site.
The custom search fields appear below the Status field.

Fields that Apply to MS Office Files Only

Search criterion

Description

Size of Document

As displayed on the read-only Size field on the File
Properties window’s General tab.
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Search criterion

Description

Number of slides
(PowerPoint)

As displayed on the read-only Statistics: Slides field on
PowerPoint’s File Properties window’s Statistics tab.

Result Display Options
At the top of the search screen, a pull-down list lets you choose the
how to display the search results.
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View
option

Description

Graphical

If the item is content or a
form, display a thumbnail
of it.

Example

If the item is an asset,
display a generic icon that
indicates asset type.
In both cases, to the right
are the item’s

•
•
•

title
summary
last edited user, date
and time

Sample HTML content

You can click the title to
display the item inside the
View Contents screen.
From there, you can
perform all available
functions on the item.
Note: Graphical search
results require the Internet
Explorer browser, version
6 or greater.
Text

Sample Microsoft Word document

Display item’s title in the
left column. To the right,
display the

•
•
•
•

last edit date/time

•
•

language

folder name
size (assets only)
DMS rank (assets
only)

status
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Information on the Search Results Screen
The following column headers describe the information displayed
for all content items that satisfy the search criteria.

Column

Description

Header
Content Title

The title of the content item

Last Edit Date

The most recent date on which content was edited. If it
was never edited, its creation date.

Folder name

The folder that contains the content

Size

The size of the content item in kilobytes

DMS Rank

An indication of how well a content item page matches
the search criteria, using a range of 0 to 1000. The
higher the rank, the more relevant content is to the
search criteria.

Language

The locale id value of the content’s language.
For a reference list of these values, see the E kt r o n
CM S40 0.NET Administrator manual section “Appendix
A: List of Supported Languages.”

Status

A one-character abbreviation of the content item’s
status. See Also: ”Appendix A: Content Statuses” on
page 648
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Content Workflow Reports

The Reports folder contains various content reports. For
information about them, see the Content Workflow Reports section
of the Ektron CMS400.NET Administrator Manual.
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The library folder stores images, files, quicklinks, and hyperlinks
that can be inserted into editor content. Before you can insert them
into content, you must copy them from your computer to a larger,
file server computer that everyone editing your site can access.
This chapter explains how to copy such files and insert them into
Web content through the following topics.

• ”Terms Used in this Chapter” on page 117
• ”Accessing The Library” on page 118
• ”Library Folder Properties” on page 120
• ”Searching the Library” on page 121
• ”Files” on page 124
• ”Hyperlinks” on page 136
• ”Images” on page 137
• ”Quicklinks and Forms” on page 138

Terms Used in this Chapter
• An image is any graphic file, which can include illustrations and
photos. Common image file extensions are .gif., .jpg, .tiff, etc.

• A file is type of computer file that can be launched from a
browser, such as Internet Explorer. Examples include a
Microsoft Word document and a .PDF file.

• A hyperlink is a commonly used or hard to remember Web
address (also known as a URL). After you add hyperlinks to the
library, users can easily apply them to editor content.
So for example, if the editor content is “Contact Ektron,” the
user can select the text, click the library button, select
hyperlinks to find the Ektron hyperlink, and apply that
hyperlink to the text.
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Once the page is published, a person reading it can click the
text to “jump” to the Web address www.ektron.com.

• A quicklink is a special kind of hyperlink that jumps to another
content item on your Web site. (A regular hyperlink jumps to a
Web page on the internet.)
Whenever content is created, if the Add to Quicklinks table
box is checked, a quicklink is created for it.

• A form is a quicklink to HTML form content. Whenever content
is created, a form link is automatically created for it.

Accessing The Library
1. Click the Workarea button (

) or icon (

).

2. Click the Library folder in the lower left corner of the Workarea.
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3. The Library folder appears.

4. The sub-folders appear in the left frame. Files in the root folder
(library) appear in the right frame.

You can use the dropdown list (circled above) to change the type of
library files that appear.
To work with any library file, click it. When you do, the View Library
screen appears, providing additional information about the item.
From here, you can
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• edit its title, file name, or description
• overwrite it
• find content linked to it
• delete it
For more information, see ”Viewing Files” on page 127.
The following table explains the toolbar buttons on the library
screen.
NOTE

Button

Your system administrator determines which library folders you can access, and
which functions you can perform on library items within the folders.

Description

For more information, see

Search library

”Searching the Library” on page 121

View the library’s properties
screen

”Library Folder Properties” on page 120

Add an image, file, quicklink, or
hyperlink to the library

”Copying Files to the Library” on
page 125

Select the type of Library file to
work with

Library Folder Properties
To view the library folder’s properties, follow these steps.
1. Click the Properties button (

).
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2. The Library Management screen appears.

3. The screen displays the following settings.

Field

Description

Image Extensions

File extensions of images that can be copied to the library
folder. For example, .gif and .jpg.

Image Upload path/
Physical Path

The folder to which library images are moved when you
insert them into E k t r o n C M S 4 0 0 . N E T .

File Extensions

Extensions of files that can be copied to this library folder.
For example, .doc and .pdf.

FIle Upload path/
Physical Path

The folder to which library files are moved when you insert
them into Ek tr on CMS 400 .NET .

Your system administrator controls these settings.

Searching the Library
You can search the library to find items when you only know some
information about them. For example, you know that an image’s
name includes Ektron but don’t know its filename or folder.
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To search the library, first select the folder in which you want to
begin the search. The search only considers files in that folder and
its child folders. To search the entire library, begin by selecting the
Library (root) folder.
Next, click the Search button ( ) from the library toolbar. When
you do, a search screen appears with several fields that let you
narrow your search. The fields are described below.

Field

Description

Keywords

Specify one or more keywords that the search will use. The search
looks for keywords in the file’s title. (The title is assigned by the user
when the file is added to the library.) If a file’s title matches the
keywords, the file appears on the search results screen.
The search also uses keywords to search through the file’s

•

internal name (for example, airplane.gif) if the Filename Search
checkbox is checked

•

description if the Description search checkbox is checked

A keyword can be a complete or partial word. But, you can only enter
a partial term for one word. For example, you can enter Adv and
have the search return the content titled “Adverse Drug Reactions.”
But if you enter Adv Drug, the search returns nothing.
You can enter several complete search terms but they must be in the
correct sequence. For example, to find the topic titled “Adverse Drug
Reactions,” you can enter Adverse Reactions but cannot enter
Reactions Adverse.
To find all files in a selected library folder, enter nothing in this field.
Or, to find all files in a selected library folder of a type (for example,
images), select the type and enter nothing in this field.
All Types

The search considers all library asset types.

Images only

The search only considers images.

Quicklinks Only

The search only considers quicklinks.

Forms Only

The search only considers forms.

Files Only

The search only considers files.

Hyperlinks Only

The search only considers hyperlinks.
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Field

Description

Filename Search

If you check this box, the search considers the file name when
returning search results. Otherwise, the file name is not considered
by the search.
For example, if you enter ppt into the keyword field, the search
returns all files that include that string (such as all Powerpoint
presentations).

Only search items
last edited by myself

The search only considers library assets that were last modified by
you.

One or more of the search criteria set by your system administrator in the Metadata
Definitions screen.

NOTE

Some search field check boxes are circles while others are squares. If the box is a
circle, you can only choose one option. If it is a square, you can choose as many
as you want.

The search then displays all library items that meet the search
criteria on the search results screen. You can click any item to view
its properties (such as Library ID number, Last Edit Date and
Description).

Displaying Search Results
Search results appear in this order.

• images
• files
• hyperlinks
• quicklinks
• form links
Result Display Options
At the top of the library search screen, a pull-down list lets you
choose the how to display the results.
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View
option

Description

Example

Mixed

If the item is an
image, display the
image in the left
column. If not,
display its title.
To the right,
display the item’s
Description.
Note: Mixed
search results
require the
Internet Explorer
browser, version 6
or greater.

Text

Display item’s title
in the left column.
To the right,
display the file
type and folder
name.

Files
This section explains how to work with library files through the
following subtopics:
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• ”Copying Files to the Library” on page 125
• ”Viewing Files” on page 127
• ”Editing a File” on page 129
• ”Overwriting Files” on page 129
• ”Library Link Searching” on page 132
• ”Adding a Library File to Content” on page 133
For a definition of the term “files,” see ”Terms Used in this Chapter”
on page 117.

Copying Files to the Library
Files must be copied to the Ektron CMS400.NET library before
users can insert them into content. To copy a file to the library,
follow these steps.
1. In the Workarea, browse the library folder and select a folder to
which you want to copy a file.
NOTE

When you copy a file to a folder, only users with permissions to that folder can
insert the file into content.

2. A list of files in that folder appears.
3. Click the Add Library button (

).

4. The Add File screen appears.
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5. Enter the necessary information according to the following
table.

Field

Description

Title

Enter a title for the file to be copied.

Filename

Enter the folder path to the file to be copied. You can
use the Browse button to find the file.

Description

You can enter a full text description to help other users
identify this file.
The Description appears on the View File screen.
It also accompanies the file on the Search Results
screen if the user selects Mixed when viewing the
search results.
See Also: ”Displaying Search Results” on page 123

Below is a description of the buttons on the screen.
Button

Name

Description

Preview

View file to make sure it’s correct before uploading it.
Note: An application that can display the file must be
installed on your computer.

Save

Add file to the library.

Back

Return to previous screen.

After you enter the necessary information and click the Save
button, the file is copied. Now, users with permissions to the
selected folder can insert the file into their content.
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Viewing Files
Once a file is copied to the library, you may preview it. To preview a
copied file, follow these steps.
1. Navigate to the library folder to which the file was copied.
2. Click the file you want to preview.
3. The View File screen appears.

The table below describes each field on the screen.

Field

Description

Title

Title assigned by user who copied or edited it.

Filename

Filename and location on the server.

Library ID

ID number assigned by Ektron CMS400.NET when file was originally
copied.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

127

Library Folder

Field

Description

Parent Folder

File’s parent folder. Users need permissions to this folder to insert the file
into content.

Last User to Edit

Last user who changed file.

Last Edit Date

When file was last edited.

Date Created

When file was originally copied to library.

Description

Optional, full-text description of file.

If the file can be displayed in your browser, a preview of it appears
at the bottom of the screen. If it cannot display in the browser, a
link to preview it in its host application appears instead.
NOTE

You may need to download some files before you can be view them (for example,
.mdb, .mp3, .zip, etc.).

The following table describes the buttons on the View Library Item
screen.

Button

Description

For more information, see

Edit the items title and description

”Editing a File” on page 129

Overwrite the library item

”Overwriting Files” on page 129

Find content linked to the library item

”Library Link Searching” on page 132

Delete library item

See “Deleting Library Items” in the
E ktron CM S40 0. NET Administrator

Manual
Return to previous screen
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Editing a File
You can edit the title, filename and description of any file that was
copied to the library. To do so, follow these steps.
1. Access the View File screen, as described in ”Viewing Files” on
page 127.
2. Click the Edit button (

).

3. The Edit File screen appears.

4. Change the title, file name, and/or description of the file.
5. Click the Update button (

).

Overwriting Files
If a library file becomes out of date or the wrong version was
copied, you may replace it with a new version. Overwriting files lets
you minimize disk space and the number of library files.
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NOTE

The ability to overwrite a library file is a privilege granted by the system
administrator. If you do not see an Overwrite button (
) on the View Library
Item in Folder screen, you do not have permission to overwrite.

NOTE

You can only overwrite images and files. The new image or file must have the
same file extension as the file being replaced.

Before You Overwrite an Image
When overwriting an image, the new image uses the same size
dimensions and file extension as the older image. Be sure that the
two images have the same file extension and size or make the
adjustments at each occurrence of the image.

Before You Overwrite a File
Remember, all links that point to the overwritten file now point to
the new file.

Overwriting Library Assets
To overwrite a library file, follow these steps.
1. Navigate to the View File screen for the file you want to
overwrite, as described in ”Viewing Files” on page 127.
2. Click the Overwrite button (

).

3. The Overwrite File screen appears.
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4. Click the Browse button.
5. A window lets you navigate to the new file.
6. Click the file, then click the Open button.
7. You return to the Overwrite File screen with the path to the new
file in the Filename field.

8. If desired, enter a Description for the new file.
9. To preview the file before you copy it, click Preview file name.
The file is previewed in a separate window. Click the X button
in the top right corner of the screen to close it and return to the
Workarea.
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10. To overwrite the current version of the file with this version,
click the Update button (

).

11. The following message appears.

12. To overwrite the file, click OK.

Library Link Searching
Link searching indicates all content that includes a library link. It is
useful when you want to delete a library item. With the click of a
button, you see all content that you need to update to reflect the
change you are making.

Performing a Library Item Link Search
To perform a library item link search, follow these steps.
1. Access the View Library Item for any type of library item, as
described in ”Viewing Files” on page 127.
2. Click the Link Search button (

).

3. A list of all content that references the library item is displayed.
You should edit that content before deleting the item.

Deleting Library Items
You can delete obsolete items from the library. By deleting an item,
you prevent users from adding it to their content. A deleted
hyperlink, quicklink or form quicklink remains on your Web server,
so any existing links to them are not broken.
On the other hand, if an item is a file or image, the delete window
displays an additional prompt, Remove from the server, that lets
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you remove the item from the server. This feature is available to
help reduce disk space taken up by these files. Before removing an
image or file from your server, you should review all content with
links to it and remove or update the link. To delete an item from the
library, follow these steps.
1. Access the View Library Item for any type of library item, as
described in ”Viewing Files” on page 127.
2. Click the Delete button (

).

3. The Delete Library Item screen is displayed.
4. If appropriate, check the box next to Remove from the server
(see above).
5. Click the Delete button (

).

Adding a Library File to Content
After a file is copied to the library, users can add it to content. (See
”Adding a Library File to Content” on page 133)
You can also insert an item into the library while adding it to
content. (See ”Adding a File to the Library and Inserting it into
Content” on page 135)
If you insert an image file, it appears within the content. If you add
any other type of file, the file name appears as a hyperlink within
the content. When a site visitor viewing that page clicks the
hyperlink, the inserted file is launched.

Adding a Library File to Content
1. Invoke the editor by adding or editing content in Ektron
CMS400.NET.
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2. Place the cursor within the content where you want the library
file to appear.
3. Click the library button (

).

4. The library opens.
5. Navigate to the folder that contains the file you want to insert.

6. From the file types dropdown list, select the kind of file you
want to insert.
7. All library files of that type in the selected folder appear on the
screen.
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8. Click the file you want to insert.
NOTE

You can preview the file by clicking the preview button (

9. Click the insert button (

).

) to insert the file.

10. A hyperlink to the file appears in your content.

You can click the link to open the file.

Adding a File to the Library and Inserting it into Content
Use this procedure to insert an image into content that has not yet
been copied to the library. This procedure inserts the item into the
library then into the content.
1. Invoke the editor by adding or editing content in Ektron
CMS400.NET.

2. Click the library button (

).

3. The library opens.
4. Navigate to the folder that will contain the file after you insert it.
5. From the File types dropdown, select the type of file you want
to insert.
Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

135

Library Folder

6. Click the Add Library button (

).

7. A new screen appears. Browse to the file you want to insert.
Or you can click the search button (
insert.

) to search for a file to

8. Enter a Description for the file.
9. If metadata is required for the library item, you must complete
it. Metadata fields may appear in the lower section of the
screen.
10. Click the Add Library button (

).

11. The file is inserted into the selected library folder and the
content.

Hyperlinks
For a definition of the term hyperlinks, see ”Terms Used in this
Chapter” on page 117.

Adding Hyperlinks
You must copy hyperlinks to the library before content creators can
insert them into content. To copy a hyperlink to the library, follow
the procedure described in ”Copying Files to the Library” on
page 125. The only difference is that you insert a hyperlink instead
of a file.

Viewing Hyperlinks
To view a hyperlink, follow the procedure described in ”Viewing
Files” on page 127. The only difference is that you view a hyperlink
instead of a file.

Editing Hyperlinks
To edit a hyperlink, follow the procedure described in ”Editing a
File” on page 129. The only difference is that you edit a hyperlink
title instead of a file title. You can also edit the URL.
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Adding Hyperlinks to Your Content
Once a hyperlink is added to the library, users can add the
hyperlink to their content.
To add a hyperlink to content, follow the procedure described in
”Adding a Library File to Content” on page 133. The only difference
is that you add a hyperlink instead of a file.

Images
For a definition of the term images, see ”Terms Used in this
Chapter” on page 117.

Uploading Images
You must copy images to the library before content creators can
insert them into content. To copy an image to the library, follow the
procedure described in ”Copying Files to the Library” on page 125.
The only difference is that you add an image instead of a file.

Viewing Images
To view an image, follow the procedure described in ”Viewing
Files” on page 127. The only difference is that you view an image
instead of a file.

Editing Image Titles
To edit an image’s title, follow the procedure described in ”Editing a
File” on page 129. The only difference is that you edit an image’s
title instead of a file title.

Overwriting Images
When an image in the library becomes out of date, or if the wrong
version of an image was copied, you may overwrite that image with
a new or correct version. Overwriting images minimizes disk space
and the number of copied library images.
NOTE

Overwriting images is a permission that your system administrator may or may
not assign to you.
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To overwrite an image, follow the procedure described in
”Overwriting Files” on page 129. The only difference is that you
overwrite an image instead of a file.
NOTE

You can only overwrite an image with another image of the same extension. (that
is, .gif > .gif, not .jpg > .gif)

Adding Images to Your Content
Once an image is added to the library, users can add it to content.
To add an image to content, follow the procedure described in
”Adding a Library File to Content” on page 133. The only difference
is that you add an image instead of a file.
The image is placed into the picture properties dialog box, where
you can change it before inserting it. For information about the
picture properties dialog box, see ”Using the First Picture
Properties Dialog Box” on page 508.

Quicklinks and Forms
For a definition of the terms quicklinks and forms, see ”Terms Used
in this Chapter” on page 117.

Adding a Quicklink or Form to Content
After new content is created, if the Add to Quicklinks table
checkbox was checked for it, users can insert a quicklink to it into
any other content. To do so, follow the procedure described in
”Adding a Library File to Content” on page 133. The only difference
is that you add a quicklink or form instead of a file.
Be sure to place the cursor where you want the quicklink or form to
appear before inserting it. When the quicklink or form is inserted,
the title of the “jumped to” content appears in the content. To test
the quicklink or form, select the newly-inserted title and double
click it.
When the page is published, a reader can click the link to jump to
the quicklink or form page.
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Viewing Quicklinks or Forms
To view a quicklink or form, follow the procedure described in
”Viewing Files” on page 127. The only difference is that you view a
quicklink or form instead of a file.
The table below describes each field on the quicklinks display.

Field

Description

Title

Title given to the hyperlink or form by the user who added it, or last edited it.

URL Link

URL link for the quicklink or form.

Library ID

ID number assigned automatically by Ektron CMS400.NET when the
quicklink or form was originally added.

Parent Folder

Parent folder that the quicklink or form belongs to. Users need permissions
to this folder to be able to access the quicklink or form.

Last User to Edit

Last user that made changes to the quicklink or form.

Last Edit Date

The date the quicklink or form was last edited.

Date Created

The date and time the quicklink or form was originally added to the Ektron
CMS400.NET library.

To preview a quicklink or form, click the link at the bottom of the
page.

Updating Default Template for Multiple Quicklinks
WARNING!

NOTE

This procedure is only necessary if Link Management is set to false in your web.
config file. If if Link Management is set to true, Ektron CMS400.NET
automatically updates the template within the quicklink when content is moved.
See your system administrator for help with the web.config file.
This action can only be performed on quicklinks.
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When content is moved in Ektron CMS400.NET, its quicklink does
not get changed. After it is moved, you need to update the default
template called in the content’s quicklink.
To update the default template for one or more quicklinks, follow
these steps.
1. In the library, access the quicklinks folder containing quicklinks
you want to update.
2. Click the Update Quicklinks button (

).

3. The Update URL Link Template Quicklinks screen is displayed.
4. Check the quicklinks you want to update.
NOTE

Check the box in the table header to select or deselect all.

5. In the To: text field, enter the name of the template you want to
apply to the selected quicklinks.
6. Click the Update Quicklinks button (
changes.

) to update the

A confirmation message is displayed.
7. Click OK to continue.
The selected quicklinks are updated to use the specified template.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

140

Working with HTML Forms

WARNING!

The functionality described in this section is not supported when using an Apple
Macintosh for editing content.

Ektron CMS400.NET provides powerful online form capabilities,

allowing you to create an online dialog with visitors. Now anyone in
your organization – not just a developer or Webmaster– can create
and deploy Web forms to capture visitor information. Support
marketing strategies by getting feedback on their needs. Follow up
on their interest in your products and services. Register people for
events.
Form capabilities include

• Creating a form and its postback message
• Creating polls and surveys for a Web site
• Adding validation criteria to form fields
• Automatically assigning tasks for follow-up activities to form
submissions

• Reporting on form information
• Exporting results to Microsoft Excel
A sample form appears below.
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This chapter explains how to perform all form actions through the
following topics.

• ”Overview of Form Processing” on page 143
• ”The Structure of Form Data” on page 143
• ”Creating a New Form” on page 144
• ”Creating a Form’s Content” on page 152
• ”Form Validation” on page 158
• ”Form Fields” on page 159
• ”Implementing a Form on a Web Page” on page 181
• ”Assigning a Task to a Form” on page 181
• ”Viewing Form Reports” on page 184
• ”Exporting a Form’s Raw Data” on page 190
• ”Viewing Form Information” on page 191
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• ”Editing a Form” on page 197
• ”Mailto or Database Form” on page 198
• ”Deleting a Form” on page 199
• ”View Form Toolbar” on page 199
• ”Creating Polls and Surveys” on page 201

Overview of Form Processing
Step

For more information, see

1.

Create a form

”Creating a New Form” on page 144

2.

Assign it to a Web page

”Implementing a Form on a Web Page” on page 181

3.

Site visitor goes to your Web site
and completes form. Form is mailed
to an email address, saved to a
database, or both.

4.

View submitted form data and
download it to a spreadsheet.

”Viewing Form Reports” on page 184

The Structure of Form Data
Forms reside within the content folder or one of its subfolders. A
form consists of the following components:

• Form (title, ID number, whether the form data is sent as email,
and/or saved to a database, etc.)

• Content information (title, start and/or end date, status,
postback message, etc.)

• Form fields (plain text field, password field, text area, hidden
text, choices, checkbox, select list, calendar, submit button,
etc.)
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Creating a New Form
The screen you use to create a new form has five simple steps.
After you complete the steps, you have a new form that’s ready to
collect the information you need. To make the task even easier,
Ektron CMS400.NET provides sample forms that you can start with
then customize.
As explained in ”Mailto or Database Form” on page 198, form data
can be emailed and/or saved to a database. Forms created using
the procedure described below are saved to a database by default,
but not emailed. To change either setting, use the Edit Properties
screen. See ”Viewing and Editing a Form’s Properties” on
page 192.
To create a new form, follow these steps.
NOTE

You can also create a new edition of a form in another language by copying an
existing form and translating it. For more information, see ”Translating Content”
on page 649.

NOTE

For the steps to create a new poll, see ”Working With Polls” on page 202. For the
steps to create a new survey, see ”Steps to Creating a Survey” on page 207.

1. Choose a content folder.
2. From the View menu, click Language, and select the language
in which to create the form.
3. Click the New menu > HTML Form/Survey.
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4. The New Form screen appears.

NOTE

When you choose Standard Poll or Blank Survey, the number of steps in the
Forms Wizard changes from five to four. This happens because the Assign Tasks
step is removed. See Also: ”Working With Polls” on page 202 and ”Steps to
Creating a Survey” on page 207.

5. Choose the form that you want to begin with. You can click the
preview icon ( ) next to any sample form to preview it before
choosing it.
Select a sample that most closely matches the form you want
to create. After you create it, you can add fields, remove fields,
modify possible responses, etc.
6. Click Next.
7. Enter or edit the form’s Title and Description.

•Title - used to reference the form within the Workarea
(required)

•Description - an extended description of the form
8. The next screen lets you assign a task to a user or user group.
If you do, a task will be created every time a site visitor submits
this form. See Also: ”Assigning a Task to a Form” on page 181
9. A new screen lets you determine what happens after the site
visitor completes the form. The choices are:
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•Display a message - See ”Composing the Postback
Message” on page 146

•Redirect to a file or page - Identify a file or a page on your
Web site that is launched when the visitor completes the
form

- An example of a file is a white paper (a common file
format is .PDF) that the visitor requested

- An example of a page is one that lets the visitor
download your product

•Redirect to an action page and forward form data - See
”Redirect to an Action Page and Forwarding Form Data” on
page 147

•Report on the form - See ”Making Form Results Available to
Site Users” on page 149
10. Now that you have completed information about the form, you
can enter the form’s content. This procedure is described in
”Creating a Form’s Content” on page 152.

Composing the Postback Message
The postback message can contain text or graphics, just like any
other HTML content. Typically, it acknowledges the site visitor’s
completion of the form.
For most sample forms provided, sample text appears in the editor.
Modify it as you wish, using Ektron CMS400.NET’s editor to change
the font size, style, color, insert library items, etc.

Inserting Fields into the Postback Message
You can also insert fields that retrieve form information upon its
submission. Use the Insert Fields pull-down to do this (illustrated
below).
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All form fields appear on the list. In addition, the following fields can
be used to insert form information into the postback message,
although they’re not completed by the person submitting the form.

• Form title
• Form description
• Date form was submitted by site visitor
For example, your postback message may be
Thank you «Full Name» for completing the «[Form Title]».

When the postback message appears, it looks like this.
Thank you Jay Kohler for completing the breakroom survey.

Redirect to an Action Page and Forwarding Form Data
The following section of the Ektron CMS400.NET Administrator
Manual explains how your administrator sets up the action page:
“Working with HTML Forms“> “Redirecting Submitted Form Data”
After your administrator follows that procedure, he identifies a
folder and hyperlink that you use to select an action page.
WARNING!

You must have the folder and hyperlink name from your administrator to complete
this procedure.

To redirect submitted form data to an action page, follow these
steps.
1. Go to the page on which you determine the form’s response. If
this is a new form, it is page 4 of the Forms Wizard.
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To modify an existing form, select the form’s folder, then the
form. Next, select Edit and click the Post Back Message tab.
2. Select Redirect to an action page and forward form data.

3. Click the icon next to File or page.
4. The Select dialog appears. Click the Select button.
5. The library appears. In the left panel, select the folder that
contains the hyperlink.
6. In the right panel, select Hyperlinks from the file type
dropdown.
7. Select the hyperlink whose name was given to you by your
system administrator.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

148

Working with HTML Forms

8. Click the insert button (

).

Making Form Results Available to Site Users
When you create polls and surveys, you can choose to display the
results after site users submit data. The results can be displayed in
the same window or output to a new window. In addition, you can
choose how to chart the data. For a description of chart types, see
”Chart Types” on page 151.
To show site visitors the results, follow these steps:
1. Go to the page on which you determine the form’s response. If
this is a new form, it is page 4 of the Forms Wizard.
To modify an existing form, select the form’s folder, then the
form. Next, select Edit and click the Post Back Message tab.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

149

Working with HTML Forms

2. Select Report on the form.

3. Choose whether you want the results to appear in the Same
Window or a New Window.
4. Choose the style of the report.
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Chart Types
The following table describes the types of charts available.
Chart Type

Description

Data Table

The poll or survey
answers are
displayed with the
percentage of users
who responded to
each item.

Bar Chart

The poll or survey
answers are
displayed with a bar
graph. Use this chart
type when you want
a quick visual
representation of the
responses.

Pie Chart

Displays a standard
pie chart. Poll or
survey answers are
color coded, and the
percentage of
people who chose
each answer is
shown.

Sample
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Chart Type

Description

Combined

Combines the Data
Table and the Bar
Chart.

IMPORTANT!

Sample

You cannot chart data that is entered into a text box. For example, if one of the
choices in a poll is Other, and the survey has a text box for site users to enter
additional information, the text in the box is not charted. However, the fact that the
a user chose Other is charted.

Creating a Form’s Content
Here is an example of form content that you can create.
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Note that some fields are required, and some provide a dropdown
list of choices. You can learn how to create such a screen by
following the directions below.
The following topics explain how to create a form.

• ”The Form Toolbar Options” on page 154
• ”Inserting Form Fields” on page 155
• ”Form Validation” on page 158
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The Form Toolbar Options
Creating form content is similar to creating a standard content
item. (See ”Adding HTML Content” on page 73). The big difference
is a special toolbar (illustrated below) to make it easier to insert
form elements.

All toolbar options except the Select Button pull-down also appear
on a vertical toolbar to the left of the editor. You can use whichever
toolbar you prefer -- all options are the same.

Adding a Field to the Screen
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The major difference between the toolbars is how you add a field to
the screen. If you are using the horizontal toolbar, place the cursor
where you want field, and click the toolbar button.
When using the vertical toolbar, drag a button to the desired
screen location.
Note that a context-sensitive menu, available by right clicking the
mouse, is also available to perform these actions. You can right
click the mouse then select Insert Field to display a contextsensitive menu of all commands.

Inserting Form Fields
The final screen of the Forms setup lets you arrange the screen so
that it collects exactly the information you want. To create the
screen, you insert fields that prompt a site visitor to enter

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

155

Working with HTML Forms

information. Then, add buttons that let the user submit the data on
the screen.
If you chose a sample form at the beginning, the screen includes
fields. If you did not, the screen has only a Submit button.
NOTE

In addition to inserting fields, you can add explanatory text, lines, images, etc.
onto the form screen. If you want to place fields in columns, insert a table and
place the fields within table cells.

The table below explains each field type you can enter.

Button

Inserts this
kind of field

Description

For more information, see

Checkbox

User’s response is either checked or
unchecked

”Inserting a Checkbox Field” on
page 159

Hidden Text
Field

Information a site visitor doesn’t
need to know about

”Inserting a Hidden Text Field” on
page 161

Text Field

Free text field; user cannot format
text

”Inserting a Text Field” on page 162

Password

A password field

”Inserting a Password Field” on
page 166

Text Area

Same as Text Field except field
scrolls vertically to accept more text

”Inserting a Text Area Field” on
page 169

Choices

Several choices appear on screen.
User checks any number of
appropriate boxes.

”Inserting a Choices Field” on
page 171

Select

Same as Choices except options
appear in a drop-down box, and site
visitor can only select one choice

”Inserting a Select List Field” on
page 175

Calendar

Lets user insert a date by clicking a
calendar

”Inserting a Calendar Field” on
page 179
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After you complete the form, you have the following options.
Button or Tab

Description

Postback Message

See ”Composing the Postback Message” on page 146

Metadata

Edit the metadata for the content. See Also: ”Adding or Editing
Metadata” on page 71

Schedule

Assign start or end dates, or both, for when content is published to
Web site See Also: ”Scheduling Content to Begin and End” on
page 60

Comment

Enter history comment to indicate changes made to content

Web Alerts

Assign or update Web Alert information for the form. See the
Ek tron CM S40 0.NET Administrator Manual chapter “Web Alert
Feature”.
Submit content into approval process.

Submit
Publish content to Web site.
Publish

Note: If the content has any active tasks, a comments window
pops up. You can insert comments to describe how approving or
declining the content affects the task.
Note: Only the last approver in the approval chain sees this button.

Check In

Save and check-in content. This button does not submit the
content into the approval process, but rather lets other users
change it.
Save the content without submitting it into the approval process.

Save

Decline

If a user clicks save and then closes the editor, other users cannot
edit the content.
This buttons appears if you are the next approver in the approval
list. Click it to decline the changes made to the content.
Note: If content has any active tasks, a comments window pops
up. You can insert comments to describe how approving or
declining the content affects the task.
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Button or Tab

Description
Close the editor without saving changes.

Cancel

Next, click the Save and Submit or Publish button (
only appears on your Web site after it is published.

). The form

After you complete and save the form, it may need to go through
the approval process. When that is complete, add it to the site by
assigning it to a page template. See ”Implementing a Form on a
Web Page” on page 181.

Form Validation
You can apply validation rules while creating or editing the
following field types:

• text
• password
• textarea
• calendar
Validation rules ensure that the form information entered by site
visitors meets your criteria. For example, a validation rule can
specify that a site visitor’s response to the Telephone field
conforms to a standard format (for example, 7 or 10 digits). If the
response does not conform, an error message informs the site
visitor of the problem. The input must conform before the form can
be submitted.
For a list of validation rule types, see ”Validation Options” on
page 165.

When Validation Rules are Applied
Validation rules are applied when a site visitor submits an entire
form, not as soon as the input is entered. If invalid input is found,
the error message that you define appears.
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The site visitor must change his response to conform to the
validation rule. When he does, the next field is checked and, if that
is invalid, its error message appears, etc.
TIP!

If you apply validation rules to more than one field, include the field name in the
error message. For example, enter The name field only allows text. This is
good practice because error messages only appear after the form is submitted
and, if the message does not identify the field, the user may not know which field
needs correction.

Form Fields
Inserting a Checkbox Field
A Checkbox field is only one character wide and accepts one of
two possible values: checked or unchecked. For example

To insert a checkbox field, follow these steps.
1. Place a checkbox type field
onto the screen. See Also:
”Adding a Field to the Screen” on page 154
2. The following dialog appears.
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Fields on the Checkbox Dialog

Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in
the database and in email if the form is mailed.

This text describes the field on form reports. See
”Viewing Form Reports” on page 184.

Note: You cannot enter spaces nor most special
characters (!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If
you do, they are replaced by underscores.
Tool Tip Text

Enter text that appears when a site visitor hovers the
cursor over this field (circled in red below).
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Field

Description

Default
value

If you want this field to be checked when the screen first
appears, click True.
Otherwise, click False.
Regardless of the default value, the site visitor can
change it while completing the screen.

Inserting a Hidden Text Field
When the form is submitted, this field can pass information that the
site visitor doesn’t need to know about, such as a tracking number.
This is typically data to be stored in the database and/or emailed
along with the rest of the data.
To insert a hidden text field, follow these steps.
1. Place a hidden text field
onto the screen. See Also:
”Adding a Field to the Screen” on page 154
2. The following dialog appears.

Fields on the Hidden Text Field Dialog
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Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in
the database and in email if the form is mailed.

This text describes the field on form reports. See
”Viewing Form Reports” on page 184.

Note: You cannot enter spaces nor most special
characters (!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If
you do, they are replaced by underscores.
Tool Tip Text

Enter text that appears when a site visitor hovers the
cursor over this field (circled in red below).

Value

Enter the value that will be saved with this field when the
form is submitted.

Inserting a Text Field
Use a plain text field when you want the user to enter an
unformatted, free text response.
To insert a plain text field, follow these steps.
1. Place a plain text field
onto the screen. See Also: ”Adding
a Field to the Screen” on page 154
2. The following dialog appears.
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Fields on the Plain Text Field Dialog

Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in
the database and in email if the form is mailed.

This text describes the field on form reports. See
”Viewing Form Reports” on page 184.

Note: You cannot enter spaces nor most special
characters (!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If
you do, they are replaced by underscores.
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Field

Description

Tool Tip Text

Enter text that appears when a site visitor hovers the
cursor over this field (circled in red below).

Default
value

If you want to set a default value for this field, enter it
here. For example, if this field collects a city, and most
users enter New York, enter New York as the value.
Regardless of the default value, the site visitor can
change it while completing the screen.

Validation

Select the kind of validation to apply to this field. See
”Validation Options” on page 165
If you assign to this field any value other than No
validation, the field is initially surrounded by red dashes
in Data Entry mode. If the user’s response does not
meet the validation criterion, the field remains
surrounded by red dashes. The system administrator
determines whether or not the user can save an invalid
document.

Error
Message

Enter text that appears on the screen if the site visitor‘s
response to this field does not satisfy the validation
criterion.
For example, if the validation criterion is telephone
number, the error message could be Please enter 7 or
10 digits. It would appear if the user entered, for
example, S061882.
By default, the error message is the same as the
validation criterion you choose. You can use this field to
customize its text.
Note: You can only enter double-byte characters if your
Windows settings include that language. If you enter
characters that are not in a language defined in your
Windows settings, question marks (?) appear instead of
the characters.
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Validation Options
NOTE

Your Web developer can customize validation options. For details, see the
Ektron CMS400.NET Developer’s Guide section “Customizing Validation.”

Option

Characteristics of Valid Response

No validation

Response is not checked.

Cannot be blank

Response is required. The format of the response is not checked.

Non-negative whole number or
blank

A positive whole number or no response.

Non-negative whole number
(required)

A positive whole number.

Decimal number or blank

A decimal number (for example, 12.345 or 12) or blank . A leading
minus sign “-” is allowed. The decimal point must be a period (.),
even in locales that normally use a comma (,).
Decimal numbers include whole numbers because the decimal point
is implied. That is, 12 is 12.0000.

Decimal number required

A decimal number (it cannot be blank) of none, one, or two decimal
places.
A leading minus sign “-” is allowed. The decimal point must be period
(.), even in locales that normally use a comma (,).
Decimal numbers include whole numbers because the decimal point
is implied. That is, 12 is 12.0000.

Percent: (0-100) required

A whole number from 0 to 100.

email address

a@a.a, where a is one or more characters.

email address list

Several email addresses. Each address’s format is a@a.a, where a
is one or more characters. The user must separate each address
with a semicolon (;).

Zip code (US)

5 (nnnnn) or 9 digits separated by a dash after the fifth (nnnnn-nnnn).

Zip code (US) required

5 (nnnnn) or 9 digits separated by a dash after the fifth (nnnnn-nnnn).
A response is required.
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Option

Characteristics of Valid Response

Social Security (US)

Nine digits in this pattern: nnn-nn-nnnn.

Social Security (US) required

Nine digits in this pattern: nnn-nn-nnnn. A response is required.

Postal Code (Canada)

ana nan, where a is an alphabetic character and n is numeric.

Postal Code (Canada) (required)

ana nan, where a is an alphabetic character and n is numeric. A
response is required.

Social Insurance Number
(Canada)

A nine digit number in the format: nnnnnnnnn.

Social Insurance Number
(Canada) Required

A nine digit number in the format: nnnnnnnnn. A response is
required.

Telephone number (US and
Canada)

A seven or 10 digit number in the format nnnnnnn or nnnnnnnnnn.

Telephone number (US and
Canada) (required)

The site visitor can insert separator characters, such as dashes (-),
between numbers.
A seven or 10 digit number in the format nnnnnnn or nnnnnnnnnn.
The site visitor can insert separator characters, such as dashes (-),
between numbers.
A response is required.

Inserting a Password Field
Use a password field when you want the user to enter a password.
A password is like a text field but the user’s entry appears as dots
instead of characters. This prevents an onlooker from seeing the
password. A user’s password entry cannot exceed 18 characters.
To insert a password field, follow these steps.
onto the screen. See Also: ”Adding
1. Place a plain text field
a Field to the Screen” on page 154
2. The following dialog appears.
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Fields on the Password Dialog

Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in
the database and in email if the form is mailed.

This text describes the field on form reports. See
”Viewing Form Reports” on page 184.

Note: You cannot enter spaces nor most special
characters (!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If
you do, they are replaced by underscores.
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Field

Description

Tool Tip Text

Enter text that appears when a site visitor hovers the
cursor over this field (circled in red below).

Default
value

If you want to set a default value for this field, enter it
here. Regardless of the default value, the site visitor can
change it while completing the screen.

Validation

Select the kind of validation to apply to this field. The
choices are:

•
•

No validation - response is not checked

•

Minimum of 8 characters with at least one digit Site visitor’s entry must be at least 8 characters and
include one digit.

Cannot be blank - Response is required. The format of the response is not checked.

If you assign to this field any value other than No
validation, the field is surrounded by red dashes when
it appears on your Web site.
Error
Message

Enter text that appears on the screen if the site visitor‘s
response to this field does not satisfy the validation
criterion.
For example, if the validation criterion is Minimum of 8
characters with at least one digit, the error message
could be Please enter at 8 or more characters with at
least one digit.
By default, the error message is the same as the
validation criterion you choose. You can use this field to
customize its text.
Note: You can only enter double-byte characters if your
Windows settings include that language. If you enter
characters that are not in a language defined in your
Windows settings, question marks (?) appear instead of
the characters.
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Inserting a Text Area Field
Use a text area field when you want the site visitor to enter an
unformatted, free text response. A text area field is similar to a Text
Field except it scrolls vertically to accept more text.
To insert a text area field, follow these steps.
onto the screen. See Also: ”Adding a
1. Place a text area field
Field to the Screen” on page 154
2. The following dialog appears.

Fields on the Textarea Dialog
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Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in the database and in
email if the form is mailed.

This text describes the field on form reports. See ”Viewing Form Reports” on
page 184.

Note: You cannot enter spaces nor most special characters
(!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.
Tool Tip Text

Enter text that appears when a site visitor hovers the cursor over this field
(circled in red below).

Default
value

If you want to set a default value for this field, enter it here. For example, if this
field collects a city, and most users enter New York, enter New York as the
value.
Regardless of the default value, the site visitor can change it while completing
the screen.

Validation

Select the kind of validation to apply to this field. The choices are:

•
•

No validation - response is not checked

•

Allow maximum of 1000 characters - Site visitor’s entry cannot exceed
1000 characters.

Cannot be blank - Response is required. The format of the response is
not checked.

If you assign to this field any value other than No validation, the field is
surrounded by red dashes when it appears on your Web site.
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Field

Description

Error
Message

Enter text that appears on the screen if the site visitor‘s response to this field
does not satisfy the validation criterion.
For example, if the validation criterion is Cannot be blank, the error message
could be Please enter a response.
By default, the error message is the same as the validation criterion you
choose. You can use this field to customize its text.
Note: You can only enter double-byte characters if your Windows settings
include that language. If you enter characters that are not in a language
defined in your Windows settings, question marks (?) appear instead of the
characters.

Inserting a Choices Field
Use a Choices field when you want the site visitor to select from a
predetermined list of choices. You can allow the site visitor to
select only one or more than one choice. You can also determine
the list of choices and the appearance of the list.
To insert a choices field, follow these steps.
onto the screen. See Also: ”Adding a
1. Place a choices field
Field to the Screen” on page 154
2. The following dialog appears.
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Fields on the Choices Dialog
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Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in the database and in
email if the form is mailed.

This text describes the field on form reports. See ”Viewing Form Reports” on
page 184.

Note: You cannot enter spaces nor most special characters
(!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.
Tool Tip Text

Enter text that appears when a site visitor hovers the cursor over this field
(circled in red below).

List

Custom - You create your own set of choices. Use the Item and Item List
fields to do this.
Note: If, after seeing the following predefined choices, you want to customize
the choices available to site visitors, return to this field, replace the value with
Custom, then define the ranges you want in the Item field.
Age Ranges - Use the predefined choices for age ranges. You can see the
ranges on the screen after you choose this option.
Numeric Ranges -Use the predefined choices for numeric ranges. You can
see the ranges on the screen after you choose this option.
Gender -Use the predefined choices for gender. You can see the values on
the screen after you choose this option.
Marital Status - Use the predefined choices for marital status. You can see
the values on the screen after you choose this option
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Field

Description

Allow
Selection

Click More than one to allow the site visitor to select more than one item on
the data entry screen. Otherwise, click Only one.
For example, if you click More than one, and the choices are: music, art,
sports, the user could select all three choices.
If you click Only one, the user could only select one choice.
A selection is required - Check this box if the user must select at least one
item in the list.

Appearance

Click Vertical List to arrange the choices vertically.

Click Horizontal List to arrange the choices horizontally.

Click List Box to display all choices in a box. The box lengthens to display all
entries.

Item:

Enter the value that is collected when the data entry user selects this item.

Value

For example, if Interests appears in the Name field, and you want music to be
collected when the data entry user selects this item and saves the page, enter
music here.

Item:

Enter text to describe this item on the data entry screen.

Text

After you insert this field onto the screen, you can use eWeb Ed it Pr o+X ML ’s
formatting capabilities to modify its size, font, color, and other attributes.
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Field

Description

Item List

This section of the screen displays the items that you enter in the Value and
Text fields.
Buttons near the bottom of the screen let you remove items from this list as
well as rearrange them.

Place a check in the box of any item to be checked by default on the data
entry screen. If you do, the user can accept the default or uncheck the item by
clicking in the checkbox. Note that if Only One is selected under Allow
selection (above), only one item can be selected.

Inserting a Select List Field
Use a Select List field when you want the site visitor to select from
a predetermined list of choices. Although similar to the choices
field, when you insert a Select List field, the site visitor only sees
the first option in a drop down box.

He must click the down arrow to see the remaining values and
select one.

So, the Select List field occupies less room on the screen than a
choices field. Also, the site visitor can only choose on item on the
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list. In contrast, you can allow a visitor to select several choices if
you use a choices field.
To insert a Select List field, follow these steps.
onto the screen. See Also:
1. Place a Select List field
”Adding a Field to the Screen” on page 154
2. The following dialog appears.

Fields on the Select List Field Dialog
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Field

Description

Descriptive
Name

Enter a description of the field.

Field Name

Enter a name for this field. This text identifies the field in the database and in
email if the form is mailed.

This text describes the field on form reports. See ”Viewing Form Reports” on
page 184.

Note: You cannot enter spaces nor most special characters
(!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.
Tool Tip Text

Enter text that appears when a site visitor hovers the cursor over this field
(circled in red below).

List

Custom - You create your own set of choices. Use the Item and Item List
fields to do this.
See Also: ”Customizing a Standard List” on page 178
Languages - list of languages supported by Windows
Countries - list of all countries in the world
U.S States and Territories - list of all states and territories that make up the
U.S.
Canadian Provinces - list of all Canadian provinces
Age Ranges - Use the predefined choices for age ranges. You can see the
ranges on the screen after you choose this option.
Numeric Ranges -Use the predefined choices for numeric ranges. You can
see the ranges on the screen after you choose this option.
Years - list of calendar years, ranging from 2004 to 2014

Item:

Enter the value that is collected when the data entry user selects this item.

Value

For example, if Interests appears in the Name field, and you want music to be
collected when the data entry user selects this item and saves the page, enter
music here.
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Field

Description

Item:

Enter text to describe this item on the data entry screen.

Text

After you insert this field onto the screen, you can use eWeb Ed it Pr o+X ML ’s
formatting capabilities to modify its size, font, color, and other attributes.

Item List

This section of the screen displays the items that you enter in the Value and
Text fields.
Buttons near the bottom of the screen let you remove items from this list as
well as rearrange them.

Place a check in the box of any item to be checked by default on the data
entry screen. If you do, the user can accept the default or uncheck the item by
clicking in the checkbox.
First item is
not a Valid
Selection

Check here if the first item on the list is not a valid value but instead text that
prompts the user to respond to the field. An example of such text for a list of
states would be Select a state.
If you check this box and the user selects the first value on the list (most likely
by default), an error message appears when he tries to save the screen.

Customizing a Standard List
You can customize any list of predefined choices. For example,
you can change the calendar years so they begin in 1995 and run
through 2020.
To do this, follow these steps.
1. Choose the standard list that you want to customize.
2. Change the value of the List field to Custom.
3. All of the predefined choices appear in the Item List box.
4. To

•add new items, use the Item Value and Text fields
•delete an existing list item, select it and click Remove
•rearrange the list, use the Move Up and Move Down buttons
•edit a list item, select it and press the Change button
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Inserting a Calendar Field
To insert a field that lets a site visitor select a date, use a Calendar
Field. To do that, follow these steps.
1. Place a Calendar field (
) onto the screen. See Also:
”Adding a Field to the Screen” on page 154
2. The following dialog appears.

Fields on the Calendar Field Dialog

Field

Description

Descriptive
Name

Enter a description of the field.
This text describes the field on form reports. See ”Viewing Form Reports” on
page 184.
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Field

Description

Field Name

Enter a name for this field. This text identifies the field in the database and in
email if the form is mailed.
Note: You cannot enter spaces nor most special characters
(!@#$%^&*()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.

Tool Tip Text

Enter text that appears when a site visitor hovers the cursor over this field
(circled in red below).

Default
value

If you want to set a default value for this field, enter it here. For example, if this
field collects a city, and most users enter New York, enter New York as the
value.
Regardless of the default value, the site visitor can change it while completing
the screen.

Validation

Select the kind of validation to apply to this field. The choices are:

•
•

No validation - response is not checked
Cannot be blank - Response is required. The format of the response is
not checked.

If you assign Cannot be blank, the field is surrounded by red dashes when it
appears on your Web site.
Error
Message

Enter text that appears on the screen if the site visitor‘s response to this field
does not satisfy the validation criterion.
For example, if the validation criterion is Cannot be blank, the error message
could be Please enter a response.
By default, the error message is the same as the validation criterion you
choose. You can use this field to customize its text.
Note: You can only enter double-byte characters if your Windows settings
include that language. If you enter characters that are not in a language
defined in your Windows settings, question marks (?) appear instead of the
characters.
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Implementing a Form on a Web Page
After you create the form, you need to link it to another page on
your Web site. You would insert the link as you would any form link.
See ”Adding a Library File to Content” on page 133
Next, open your Web Site, navigate to the host page, and click the
hyperlink to access the form. Now, you can test the form and make
sure it works as you expected. If needed, you can return to edit
mode, change the form, and test it again until you are happy with it.

Assigning a Task to a Form
While tasks typically help Ektron CMS400.NET users track content
activities, you can also assign a task to users or user groups
whenever a form is submitted.
For example, your Web site offers a free product demonstration to
anyone who completes a form. Whenever a site visitor submits the
form, a task is assigned to your sales department’s administrative
assistant. He uses the information collected by the form to
schedule a demonstration. The sales manager can review the task
history to audit sales leads and ensure demonstration requests are
being handled in a timely manner.
To set up a task that it is assigned to users or groups whenever a
site visitor completes the form, follow these steps.
NOTE

You should be familiar with tasks before beginning this procedure. See Also:
”Managing Tasks” on page 317

1. If you are creating a new form, assign the task at Step 3 of the
Forms Wizard.
If you are editing a form, assign the task on the form’s Edit
Properties screen.
In both cases, you identify only users and groups to whom the
task will be assigned whenever a site visitor completes the
form. Ektron CMS400.NET assigns the remaining task
information.
2. You complete the form and make it available on your Web site.
3. A visitor to your site fills out and submits the form.
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4. A task is created and assigned to users and groups you
identified in Step 1.
5. Any Ektron CMS400.NET user can view all tasks created via
form submission in the Smart Desktop. See illustration below.
See Also: ”Understanding the Smart Desktop” on page 20

Ektron CMS400.NET users and administrators can also view and

update tasks assigned to them via the Task screens on the Smart
Desktop. See ”Viewing a Task” on page 331 and ”Viewing a Task’s
History” on page 341.

Task Information
The task created upon form submission has the following
information.
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Field

Value

Title

Form title, as entered by the author

Assigned to

As set up by the user who created or edited the form

Assigned by

User who created or last edited form

Priority

Normal

Task
Category

Form Submission Task Category

Task type

Form Submission Task

Created by

User who created or last edited form

State

Not started

Due date

Not specified

Start date

Not specified

Description

Data from form “form name” was received on date time.
form description
Name of every field on the form: value submitted by
user into that field

email Automatically Generated Upon Form Submission
An email is automatically sent to every user named in Step 1 above
who has a valid email address in the User Information Screen. The
email’s subject line is the form name. The body of the email
contains the following information for each field on the form.

• name
• value submitted by user
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Viewing Form Reports
If a form is set to store data in the database, you can run a report
that displays the submitted data. To view a form report, follow
these steps.
1. Navigate to the folder for which you want to view the report.
2. The View Content screen appears.
3. Click the form you want to view. (If you do not see your form in
the folder, make sure the Content Type drop-down box is set to
All Types or Forms.)
4. Click the View Reports button (

).

5. The View Forms Report screen appears.
6. Enter report criteria using the following table as a reference.
Field

Description

Start Date

If desired, specify a start date. The report displays
only forms that were submitted on or after the start
date.

End Date

If desired, specify an end date. The report displays
only forms that were submitted on or before the
end date.

Report Display

Specify the format to display the report.

Select Legacy
Report

Specify the version of the form or poll for which to
get a report. Using this option allows you to see
the results from previous polls and forms.

7. Click the Get Result button to display the report.

Display Formats
The submitted form data can be viewed in any of these formats.

• ”Table with Totals” on page 185
• ”Bar Chart” on page 151
• ”Summary of Selected Choices” on page 186
• ”Table of Values” on page 187
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• ”List of Submitted Values” on page 188
• ”Submitted Data as XML” on page 189
Table with Totals
The table of values shows the following information for each
completed form.

• a checkbox that lets you delete the response
• an internal identification number of the response
• the name of the user who submitted the form, if he signed in to
Ektron CMS400.NET beforehand. If the user did not sign in,

anonymous appears.

• date response was submitted
• The name of each field on the survey
- under each field name is the submitted response for the
each user

• the bottom line sums the numerical and percentage totals for
each response
Sample of Table with Totals Format
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Summary of Selected Choices
This format totals, for choice and select type fields, the number of
times each choice was selected. Only choices that were selected
at least once appear.
Sample Summary of Selected Choices Format
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Table of Values
The table of values shows the following information for each
completed form.

• a checkbox that lets you delete the response
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• an internal identification number of the response
• the name of the user who submitted the form, if he signed in to
Ektron CMS400.NET beforehand. If the user did not sign in,

anonymous appears.

• date response was submitted
• descriptive name of each form field appears in the column
header

- the value entered for each field appears below the header
Sample of Table of Values Format

List of Submitted Values
The List of Submitted Values format provides the same information
as the Table of Values, but is formatted vertically rather than
horizontally. See Also: ”Table of Values” on page 187
Sample List of Submitted Values Format
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Submitted Data as XML
Displays the results of the form in an XML format. The following
information is included:

• <Title> - the title of the form block
IMPORTANT!

With polls you can create a new poll question to replace an existing poll question.
By default the poll still has the same Title, ID, and other properties. You can
change the title of a new poll question when you are editing the poll.
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• <Description> - the description of the form
• <SubmittedData> - the information that has been submitted
Sample of Submitted Data as XML

Exporting a Form’s Raw Data
After you run a report, you can export its data to a Microsoft Excel
spreadsheet file (.xls) for further analysis. If a form uses an XML
structure, each XML tag becomes a column header in the
spreadsheet.
To export form data, follow these steps.
1. Access the View Form Reports screen for the report you want
to export, as described in ”Viewing Form Reports” on
page 184.
2. Click the Export Reports button (

).

3. A File Download dialog box is displayed. Choose the option
that best suits your needs.
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4. After the data is exported, you can analyze and modify the .xls
file.

Viewing Form Information
You can view

• information about a form
• information about a form’s properties

Viewing a Form’s Information
After a form is created, you can view its information in the Forms
folder. To view a form, follow these steps.
1. Access the folder that contains the form you want to view.
2. Click the form you want to view.
3. The View Form screen displays.
4. Click the Form Properties tab.
5. The following table explains the information on the screen.

Field

Description

Form Title

Title used to reference the form

FormID

ID number automatically assigned to form

Status

The form’s current status

Description

Extended description for the form

Form Data

The type of form data: Mail or Database. See Also: ”The
Structure of Form Data” on page 143

Form Submissions

Shows the amount of times a user can submit the form.
This is often used with polls and surveys to limit the
influence any one user has a given poll or survey.
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Field

Description

Assign Task to

Users and groups to whom a task will be automatically
assigned whenever a site visitor completes the form. See
Also: ”Assigning a Task to a Form” on page 181

Content Properties

Displays the properties of the form’s content

Content Title

Title of content associated with form
Note: The content name is the same as the Form name.

Content ID

Content ID number assigned to content

Status

The status of the content

Last Editor

Last user to edit the content

Start Date

Date and time when the content will go live on the Web site
(if set for a future date)

End Date

Date and time when the content will be removed from the
Web site (if set for a future date)

Date Created

Date and time when content was created

The View Form screen also contains several buttons to perform
actions. To learn about the buttons, see ”View Form Toolbar” on
page 199.

Viewing and Editing a Form’s Properties
To see and update additional form information that does not
appear on the View Form screen, view its properties. To do so,
follow these steps.
1. Navigate to the View Form screen of the form whose properties
you want to view, as described in ”Viewing a Form’s
Information” on page 191.
2. Click the Form Properties button (

).

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

192

Working with HTML Forms

3. The Form Properties screen displays a subset of form
information.

• Title and Description
• Database or Mail - if form data is emailed whenever a site
visitor submits it, enter mail property information below. See
”Mail Properties” on page 193

• Autofill form values - checked by default, this allows the form’s
fields to be automatically filled when a logged in user visits a
page and has filled out the form during previous visits.

• Limit Submission - when checked, you can enter the number of
times a user is allowed to submit a form in the Number of
Submissions text field

• Assign task to - see ”Assigning a Task to a Form” on page 181
• Form block’s ID number
• Mail Properties
Mail Properties

Field

Description

To

Email address to which the form is sent when submitted.
See Also: ”Retrieving email Address from the Submitted
Form” on page 194

From

Text that appears in the email’s From field. See Also:
”Retrieving email Address from the Submitted Form” on
page 194

CC

Text that appears in the email’s CC field. See Also:
”Retrieving email Address from the Submitted Form” on
page 194

Subject

Text that appears in the email’s subject field. See Also:
”Retrieving Form Data Into the Subject and Preamble
Fields” on page 196

Preamble

Beginning text of the email. See Also: ”Retrieving Form
Data Into the Subject and Preamble Fields” on page 196
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Field

Description

Send data in XML
Format

A green check means email data will be in a structured XML
packet.
A red X means the email data will be in a standard mailto
format.
For more information, see “Sending Data as XML” in the
Ektron CMS400.NET Administrator Manual Forms chapter.

Retrieving email Address from the Submitted Form
In the Mail Properties section of the Edit Form screen, you can
select email addresses submitted on the form to be inserted into
any of these Mail Property fields:

• To
• From
• CC
So, instead of entering a static email address, it can be
dynamically retrieved from the user’s form submission. For
example, you want to retrieve the “from” field of an email from the
information the user enters when completing the form.
To do this, use the OR to addresses in field dropdown lists circled
below. These lists contain fields that dynamically retrieve data from
the submitted form.
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Note that the To and CC fields can accept fields whose validation
type is email address or email address list. On the other hand,
the From field can only accept fields whose validation type is
email address (that is, a single email address).
To set this up, follow these steps.
1. Add a form field whose Validation type is Email address or
Email address list . The field prompts the user completing the
form to enter his email address. Label the field something like
Enter your email address.
TIP!

If the field allows more than one address, add on-screen instructions to separate
each address with a semicolon (;).
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2. Go to the Edit Form screen > Mail Properties section.
3. Move to the field labeled From:.
4. At the dropdown list following OR to addresses in field, select
the field you created in Step 1.
Now, when a user completes the form, the value he enters in the
field created in Step 1 is used for the email’s From address.

Retrieving Form Data Into the Subject and Preamble Fields
You can retrieve data from a submitted form directly to the form’s
Subject and Preamble fields. (The subject is a standard mail field,
and the preamble is text that appears at the beginning of the
email.)
For example, the form may provide a list of your products. While
the user is completing the form, he selects a product that he is
interested in. The product then becomes the subject line of the
email.
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NOTE

Since a Textarea field can span multiple lines, it can only be used with the
preamble. However, a plain text field can be used with both the subject and
preamble.

To retrieve data dynamically from a form field into the email’s
subject line or preamble, follow these steps.
1. Add a form field that collects the information you want to insert
into the email’s subject line or preamble. See Also: ”Inserting
Form Fields” on page 155
2. Go to the Edit Form screen > Mail Properties section. See
Also: ”Editing a Form” on page 197
3. Move to the field labeled Subject or Preamble.
4. At the dropdown list following OR use text in field, select the
field you created in Step 1.

Editing a Form
After you create a form, it can easily be edited if information needs
to be changed. You can update the following information by
following the procedure below.

• the form fields
• post back message
• metadata
• schedule
• comments
• Web Alerts
However to edit a form’s Title, Description, form data, or task
values, use the Edit Properties screen.
To edit a form, follow these steps.
1. Access the View Form screen for the form you want to edit, as
described in ”Viewing and Editing a Form’s Properties” on
page 192.
2. Click the Edit Form button (

).
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3. The Edit Form screen is displayed. The screen is the same as
the Add New Form screen. For documentation of individual
fields, see ”Creating a New Form” on page 144.
4. Make the necessary changes to the form.
5. Click the Save button (

).

See Also: ”Working with HTML Forms” on page 141

Editing a Form’s Content
You can edit the content associated with the form by a variety of
methods, including:

• Accessing the content by the floating toolbar on the Web page
• Editing the content by the View Form screen
• Accessing the content by the View Form content properties
screen
This section explains how to edit a form’s content from the View
Form screen. To edit a form’s content, follow these steps.
1. Access the View Form screen for the content, as described in
”Viewing a Form’s Information” on page 191.
2. Click the Edit Content button (

).

3. The Edit Content screen appears.
4. Make the necessary changes to the form’s content.
5. If needed, click the Postback Message, Metadata, Schedule,
Comment or Web Alerts tab to edit that information.
6. Click a workflow button (Submit for Publication or Publish).

Editing a Form’s Properties
See ”Viewing and Editing a Form’s Properties” on page 192

Mailto or Database Form
The Forms feature lets you create a mailto or a database form to
use on your Web site. When creating or editing a form, you must
specify the type of form you are creating. The options are:

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

198

Working with HTML Forms

• Send it via email
• Store it in a database
• Send it via email and store in a database
See ”Viewing and Editing a Form’s Properties” on page 192 for
information about toggling this option on and off.

Advantages of a Mailto Form
By creating a mailto form, any email generation is done on the
server-side, not on the client. This means that site visitors can
submit email whether or not the client has email software.

Storing Form Data in a Database
By storing form data in the Ektron CMS400.NET database, you
can keep information submitted by site visitors and view reports on
that information. You can also export the form data to a
spreadsheet.

Deleting a Form
You can easily delete forms that are no longer needed.
NOTE

Deleting a form also deletes its associated content and information.

To delete a form, follow these steps.
1. Access the View Form screen for the form you want to delete.
2. Click the Delete Form button (

).

3. A confirmation message is displayed.
4. Click OK.

View Form Toolbar
Several toolbar buttons and tabs help you work with forms.
To learn about toolbar buttons available when creating or editing a
form, see “Inserting Form Fields” on page 155.
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Button or
Tab

Name

Description

More Information

Edit Content

Edit the form’s content, which
contains the form fields

”Editing a Form’s
Content” on page 198

View Staged/
Published Content

Click View Staged button to view
content that has not yet been
published.
Click View Published button to view
content that is live on the Web site.

View History

View (and possibly restore) older
versions of a content block

”Content History” on
page 80

View Difference

Compare two versions of content

”Comparing Versions of
Content” on page 92

Edit Form Properties

Edit Form properties not available
via the Edit Content button

”Viewing and Editing a
Form’s Properties” on
page 192

Delete Form

Delete a form

”Deleting a Form” on
page 199

Check Links

Check for other content that contains
a link to this form

”Link Checking” on
page 81

Add Task

Add a task

”Managing Tasks” on
page 349

View Task

View task information

Add Form

Add a new form

”Creating a New Form”
on page 144

Export Raw Data

Download form data to a Microsoft
Excel spreadsheet

”Exporting a Form’s Raw
Data” on page 190

View Reports

View submitted form data; can select
range of dates

”Viewing Form Reports”
on page 184
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Button or
Tab

Name

Description

More Information

View Content
Properties

Access view properties for the
content

”Viewing and Editing a
Form’s Properties” on
page 192

View
(language)

View

If you can view forms in more than
one language, select a language
from the drop down list.

Add

Add

-select
language-

-select language-

Lets you copy current form into new
block and translate it to selected
language.

or Form
Properties

”Translating Content” on
page 649

Creating Polls and Surveys
Polls and surveys are a type of form. All of the same functionality is
available and applies.
WARNING!

For complete understanding of Forms, Polls, and Surveys, you should read the
entire Working with HTML Forms chapter.

Polls are generally one question and appear on a site for a very
short time, an hour or a day. Surveys are usually multiple questions
and appear on your site for a longer time than a poll.
NOTE

For information on scheduling when your polls and surveys appear on the site,
see ”Scheduling Content to Begin and End” on page 60.

With polls and surveys, you can show ongoing results to the site
visitors after they submit their answers.
The following sections provide information that a user creating a
poll or survey might be interested in beyond the normal form
information.

• ”Working With Polls” on page 202
• ”Steps to Creating a Survey” on page 207
• ”Making Form Results Available to Site Users” on page 149
• ”Viewing a Form’s Information” on page 191
• ”Viewing and Editing a Form’s Properties” on page 192
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For information on how to display a poll or survey on a Web site,
see the Developer Reference Manual section “Introduction to
Ektron CMS400.NET Server Controls” > “Poll Server Control”.
To create a poll or survey, use the Forms Wizard.

Working With Polls
Below is an example of a Poll. Note that when a site visitor hovers
over the poll, the question also appears as ToolTip text.

This subsection contains the following:

• ”Steps to Create a New Poll in the Workarea” on page 202
• ”Replacing a Poll with a New Poll from the Web Site” on
page 205

• ”Editing a Poll from the Web Site” on page 206
Steps to Create a New Poll in the Workarea
To create a new poll, follow these steps.
NOTE

You can also create a new edition of a form in another language by copying an
existing form and translating it. For more information, see ”Translating Content”
on page 649.

NOTE

For the steps to create a new form, see ”Creating a New Form” on page 144. For
the steps to create a new survey, see ”Steps to Creating a Survey” on page 207.
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1. Choose a content folder.
2. From the View menu, click Language, and select the language
in which to create the poll.
3. Click New > HTML Form/Survey.
.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

203

Working with HTML Forms

4. The New Form screen appears.

NOTE

When you choose Standard Poll or Blank Survey, the number of steps in the
Forms Wizard changes from five to four. This happens because the Assign Tasks
step is removed.

5. Choose Standard Poll. You can click the preview icon (
next to any sample form to preview it before choosing it.

)

6. Click the Next button.
7. Enter or edit the form’s Title and Description.

•Title - used to reference the poll within the Workarea
(required)

•Description - an extended description of the poll.
8. Click the Next button.
9. This screen lets you add a poll question and the possible
choices.
NOTE

This screen allows you to add eight choices. If you have more than eight choices,
you can add them in the forms editor after clicking the Done button.

10. Click the Next button.
11. This screen informs you that you have finished entering the
basic poll information and you need to click the Done button to
further edit and view the form’s fields.
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12. After clicking the Done button, the form editor launches and
allows you to edit the existing fields and properties. In addition,
you can set post back and schedule information, add metadata
and comments, change the title and submit the poll for
publication.
NOTE

From this screen, you can add additional choices to your poll by right clicking on
the choices field and clicking properties. See Also: ”Inserting a Choices Field” on
page 171.

Replacing a Poll with a New Poll from the Web Site
When logged into Ektron CMS400.NET, you can right click on an
existing poll and choose New Poll to replace the poll with a new
poll. The title of the poll, its ID and properties stay the same. The
only things that change are the questions and answers.
To replace an existing poll with a new poll, follow these steps.
1. Log into Ektron CMS400.NET.
2. Navigate to the Web page where the existing poll is located.
3. Right click the poll and choose New Poll.
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4. The Workarea opens and you are at step three in the Poll
Wizard.

5. Add the new question to the Question text box.
6. Add the possible responses to the Choices text boxes.
7. Click Next.
8. Click Done.
9. After clicking Done, the form editor launches and allows you to
edit the existing fields and properties. In addition, you can set
post back and schedule information, add metadata and
comments, change the title and submit the poll for publication.
10. Once the poll is published, it appears on the site.

Editing a Poll from the Web Site
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To edit an existing poll on a Web site, follow these steps.
WARNING!

If you are logged into the site and create a new poll from the site by right clicking
on the poll selecting New, the existing poll is replaced with the new poll.

1. Log on to the Web site for CMS400.NET.
2. Right click the poll you want to change and click Edit.

3. Make any changes to the Poll using the Forms editor.
4. Submit the Poll to the Approval Process.

Steps to Creating a Survey
To create a new survey, follow these steps.
NOTE

You can also create a new edition of a survey in another language by copying an
existing form and translating it. For more information, see ”Translating Content”
on page 649.

NOTE

For the steps to create a new poll, see ”Working With Polls” on page 202. For the
steps to create a new form, see ”Creating a New Form” on page 144.

1. Choose a content folder.
2. From the View menu, click Language, and select the language
in which to create the form.
3. Click the New > HTML Form/Survey.
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4. The New Form screen appears.

NOTE

When you choose Standard Poll or Blank Survey, the amount of steps in the
Forms Wizard changes from five steps to four steps. This happens because the
Assign Tasks step is removed.

5. Choose Blank Survey. You can click the preview icon (
next to any sample form to preview it before choosing it.

)

6. Click the Next button.
7. Enter or edit the form’s Title and Description.

•Title - used to reference the survey within the Workarea
(required)

•Description - an extended description of the survey.
8. Click the Next button.
9. This screen lets you determine what happens after the site
visitor completes the survey. The choices are:

•Display a message - See ”Composing the Postback
Message” on page 146

•Redirect to a file or page - Identify a file or a page on your
Web site that is launched when the visitor completes the
form

- An example of a file is a white paper (a common file
format is .PDF) that the visitor requested
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- An example of a page is one that lets the visitor
download your product

•Redirect to an action page and forward form data - See
”Redirect to an Action Page and Forwarding Form Data” on
page 147

•Report on the form - See ”Making Form Results Available to
Site Users” on page 149
10. Click the Next button.
11. This screen informs you that you have finished entering the
basic information about the survey and you need to click the
Done button to enter the survey’s content. This procedure is
described in ”Creating a Form’s Content” on page 152.
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WARNING!

The functionality described in this section is not supported when using an
Apple Macintosh for editing content.

The Document Management Functionality (DM) lets you import
Microsoft Office files, Open Office files, as well as most other
kinds of files into Ektron CMS400.NET. (Non-Office files are
known as managed files.) Collectively, these files are known as
documents.
After being saved in Ektron CMS400.NET, documents can be
updated and tracked like HTML and XML content. If you’re
familiar with how that content is handled, most of what you
know also applies to documents. For example, documents

• can be stored in folders with other content, or in separate
folders that you create just for them

• are assigned content ID numbers
• capture summary, metadata, comment, task, and schedule
information

• inherit permissions and approvals from their folder
properties

• progress through a workflow (check out, check in, publish)
• provide a history and let you restore an earlier version
• can be searched, including some Office document
properties

• can have foreign language editions
• can have a task assigned to them
• appear on content reports
• update the Smart Desktop listing of files awaiting approval,
checked out, tasks, to expire
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When a file is imported to the CMS then saved, a copy of it is
saved to the asset management server. Then, whenever a user
edits and saves the file, a new copy is stored. In this way, you can
review and, if needed, restore a prior version.
This chapter explains the Document Management Functionality
through the following topics.

• ”Supported Types of Documents” on page 211
• ”Security” on page 214
• ”Working with Microsoft Office Documents” on page 214
• ”Working with Open Office Files” on page 231
• ”Working with Managed Files” on page 234
• ”Importing Files via Drag and Drop” on page 237
• ”Document Workflow” on page 240
• ”Viewing Documents within the CMS” on page 240
• ”Deleting a Document” on page 241
• ”Approving Documents” on page 241
• ”Adding Documents to Collections and Menus” on page 241
• ”Document Reports” on page 241

Supported Types of Documents
• Microsoft Office 2000 or later documents: Word, Excel,
Powerpoint, Project, Publisher, Visio, etc.

• All Open Office extensions: *.odf, *.odt, *.odp, *.odg, *.ods,
*.odb

• Managed files: any Windows-executable file such as .zip files,
PDFs, .txt files, graphic files such as .gif and .jpeg, etc.
NOTE

The file types that can be uploaded are determined by your administrator. If you
try to upload the wrong type of file, the following error message appears.
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Microsoft Office and Open Office Documents
You can edit any Microsoft Office or Open Office file within the
Content tab, just like an HTML content block. The host
application’s toolbar appears below Ektron CMS400.NET’s tabs on
the Edit Content screen.

You can insert summary, metadata, schedule, comment, and task
information for the Office document. From the View Content
screen, you can use standard toolbar buttons to perform actions
such as view history, submit for publishing, and delete.
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For more information, see ”Working with Microsoft Office
Documents” on page 214 and ”Working with Open Office Files” on
page 231

Managed Files
Ektron CMS400.NET can track and manage any non-Office type of

file that runs on your computer (for example, .PDF, .gif and .zip).
When editing these file types, the host application appears in a
separate window. The Ektron CMS400.NET View Content screen
remains in the background.

You can use the host application to edit the file, then switch to the
View Content screen to insert supporting information such as
summary and metadata. Use standard toolbar buttons to perform
actions like view history, submit for publishing, and delete.
For more information, see ”Working with Managed Files” on
page 234.
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Open Office Files
You cannot create an Open Office file within Ektron CMS400.NET.
You must create it in Open Office then import it into Ektron
CMS400.NET. Once the file is imported into Ektron CMS400.NET,
you can edit it from there. For more information, see ”Working with
Open Office Files” on page 231

Security
For the purposes of security, documents are treated like other
content. Your system administrator applies security to each folder,
determining which user groups can perform which tasks on the
content in a folder. For more information, see the “Setting
Permissions” chapter of the Ektron CMS400.NET Administrator
Manual .

Software Requirements
Your production server must run Windows 2003 server or Windows
2000.

Working with Microsoft Office Documents
Ektron CMS400.NET provides four ways to work with Microsoft

Office documents. They are described below.

Method

Format

Advantages

For more
information, see

Document Management
toolbar

Office. For
example,
.doc

Don’t need to install or learn CMS
software; work within Office

”Creating a Microsoft
Office Document from
the Document
Management Toolbar”
on page 220
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Method

Format

Advantages

For more
information, see

New > Office Documents
from View Contents of
Folders screen

Office

Similar to creating CMS content

”Creating a New
Microsoft Office
Document from the
Workarea” on page 216

Drag and drop into

Office

Easy to migrate existing Office
documents to CMS 40 0.N ET

”Importing an Office
Document” on page 228

HTML

Additional functionality of Word
editor, yet produces HTML content;
similar to creating CMS content

”Editing in Microsoft
Word” on page 503

CM S40 0.NET

New > HTML content from
View Contents of Folders
screen. Then, click Word
toolbar button (

).

Note: You can only create
Word documents. You
cannot create other Office
documents.

This section explains how to work with Microsoft Office documents
through the following subtopics.

• ”Notes on Working with Microsoft Office Documents” on
page 215

• ”Creating a New Microsoft Office Document from the
Workarea” on page 216

• ”Editing a Document’s Properties” on page 218
• ”Save, Check in, and Publish” on page 219
• ”Importing an Office Document” on page 228
• ”The Work Offline Option” on page 230
• ”Editing an Office Document” on page 230

Notes on Working with Microsoft Office Documents
• If you have an Excel spreadsheet open outside DM then you
open one within it, and navigate to another template page on
your Web site, then return to the spreadsheet outside DM, a
new, open worksheet appears. Close it.
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• If you are working with an Excel spreadsheet, the File and
Open toolbar buttons within Excel appear active (that is, not
grayed out) but are not operable.

• If you access an Office document on a Web page, you must
close that instance of the browser before proceeding to another
Web page. If you do not close the browser and continue to add
or edit documents, the original document continues to use up
your computer’s resources.

• You cannot import an Excel file that contains macros or
JavaScript

Creating a New Microsoft Office Document from the Workarea
To create a new Office document from the Workarea, follow these
steps.
1. Log in to Ektron CMS400.NET.
2. From the Workarea, select the Content tab.
3. Select the folder in which you want to place the document. See
Also: ”Working with Folders and Content” on page 31
4. The default language appears next to the screen title. To create
the document under a different language, click View >
Language and select the language.
5. Click New > Office Documents.
6. The Insert New Document Object screen appears.
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NOTE

The list of object types is determined by the applications installed on your
computer. For example, an MS Project file type only displays if MS Project is
installed.

7. If the document does not yet exist, check the Create New
button. Then, select the type of document you want to create
and press OK.
If the document already exists, see ”Importing an Office
Document” on page 228.
8. The application assigned to the document type appears within
Ektron CMS400.NET.
9. Enter a Title and add content to the document.
10. Decide whether the content should be added to the Quicklinks
Table and if the content should be searchable.
11. If desired, add a summary, metadata, a schedule, and
comments. See Also:

•”Adding a Content Summary” on page 67
•”Adding or Editing Metadata” on page 71
•”Scheduling Content to Begin and End” on page 60
12. If desired, you can edit the document’s properties. See Also:
”Editing a Document’s Properties” on page 218
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13. Check in or submit the content for publishing as you would a
content block. See Also: ”Save, Check in, and Publish” on
page 219 and ”Adding Content” on page 45

Editing a Document’s Properties
If the host application (such as Microsoft Word) has a Properties
screen, you can access it by clicking File > Properties or the
Properties option on the host application’s Document
Management menu.
NOTE

CM S40 0. NET installs the Document Management menu on the Office

application.
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Save, Check in, and Publish
When you finish editing a document, you have four options for
what to do next. They are explained in the following table.
You can carry out any option by clicking an Ektron CMS400.NET
toolbar button.

or a Document Management menu option (illustrated below).

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

219

Using the Document Management Functionality

Document
Management Menu
Option

Action

Undo Check out

Discard changes made in current editing
session.

Check in

Check document in so you and others
can continue to edit it.

Publish or submit for
publishing

Submit document into approval chain.
Upon approval, publish content to Web
site.

Save to DocServer

Save recent changes. Use to save latest
changes before continuing.

Work Offline

Toolbar
button

or

Save file to local computer.
See Also: ”The Work Offline Option” on
page 230

Creating a Microsoft Office Document from the Document
Management Toolbar
Ektron CMS400.NET provides a Document Management toolbar

that plugs into any Microsoft Office application supported by your
DMS. See ”Supported Types of Documents” on page 211.
After you create or edit a document in Office, use the toolbar to
save it to Ektron CMS400.NET, and later to edit it. You don’t need to
sign on to or learn how to use Ektron CMS400.NET.
The graphic below illustrates the Document Management toolbar
within Microsoft Word. Like other Office toolbars, it can be moved
to any location.
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The following table explains the toolbar buttons.

Button

Description

For more information, see

Save document to C M S 4 0 0 . N E T .

”Using the Toolbar to Save an Office
Document to Ektron CMS400.NET”
on page 223

Save document under a different name or to
a different folder.

”Saving an Document under a
Different Name or to a Different
Folder” on page 224

Navigate through CMS 40 0.N ET ’s folders
and select a file to edit

”Using the Toolbar to Edit an Office
Document” on page 225

View a list of changes to the document you
are working with

”The Content History Window” on
page 101

Edit a document on your computer. When
you finish, save it to C M S 4 0 0 . N E T .

”The Work Offline Option” on
page 230

Only appears if you are the next user in the
document’s approval chain. Click the button
to approve the document.

”Approving/Declining Content” on
page 81

Only appears if you are the next user in the
document’s approval chain. Click the button
to decline the document.

”Approving/Declining Content” on
page 81

Lets you view and update the configuration
being used

E ktron CM S40 0.NET Administrator

(Save)

(Save as)

Manual section “Ektron Explorer” >
“Configuring Ektron Explorer”
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Button

Description

For more information, see

Refreshes the list of configurations. Use this
after adding a new configuration.

E ktron CM S40 0.NET Administrator

Lets you

E ktron CM S40 0.NET Administrator

•
•
•
•

choose a different configuration

Manual section “Ektron Explorer” >
“Configuring Ektron Explorer”

Manual section “Ektron Explorer” >
“Configuring Ektron Explorer”

edit a configuration
create a new configuration
delete a configuration

The following sections explain how to install and use the Document
Management toolbar.

Installing the Document Management Toolbar
The Document Management toolbar is installed when you install
the Ektron Explorer. See ”Recently Viewed Content” on page 288.
Before beginning to install the Explorer, close all Office
applications, including Outlook and Ektron CMS400.NET.
Your system administrator needs to create or update a
configuration for you in the Configuration Manager. It is available
from both the Document Manager toolbar button ( ) and from
Ektron Explorer. The configuration lets you access Ektron
CMS400.NET.

Displaying the Document Management Toolbar
To display the Document Management toolbar within Office, follow
these steps.
1. Open an Office application.
2. Click View > Toolbars > Document Management.
3. The Document Management toolbar appears on the screen.
You can drag it to another location if desired.
NOTE

If you display the Document Management toolbar within Word, and you use MS
Outlook for email, the toolbar appears when you create email. You may want to
move it away from the standard Save and File Open buttons to prevent confusion.
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As an alternative to the toolbar, you can use the menu available via
the Office Tools > Document Management option.

Using the Toolbar to Save an Office Document to Ektron CMS400.NET
Create the Office document as you normally would. When you are
ready to save it, follow these steps.
1. On the Document Management toolbar, click the Save button
(highlighted below).

2. The following dialog appears.
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3. You have three choices, described below.

Choice

Description

Save

Save all changes made since you opened the document or your last
save. After the document is saved, its status remains checked out so you
can continue working on it.

Save and Check in

Save all changes and check the document back in to CM S40 0.NET . See
Also: ”Checked-In Content” on page 650
After the document is checked in, you can continue working on it.

Publish

Save all changes and submit the document to be published.
If you are the only approver in the document’s approval chain, or the
document does not have an approval chain, the document is published
immediately. See Also: ”Submitted Content” on page 652 and
”Approving/Declining Content” on page 81
If you are the next person in the approval chain, the Approve button (
becomes active. You can click the button to approve the document.

)

Otherwise, the members of the Approval chain must approve it.
While its status is Submitted, you cannot edit it.

To save it under a different name, click the yellow Save button
( ). The Save As dialog appears. Enter the new name in the
Content Title field.
To save it in a different folder, navigate to that folder and click
Save.

Saving an Document under a Different Name or to a Different Folder
1. When you finish your edits, click the Save As button (
Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

).
224

Using the Document Management Functionality

2. The following screen appears, showing Ektron CMS400.NET’s
file hierarchy. Navigate to the folder in which you want to place
the document.

If you want to create a new folder for the document, click the
new folder button ( ).
3. Enter a title for the document in the Content Title field.
4. Click the Save button on the dialog.

Using the Toolbar to Edit an Office Document
1. Click the Open File button (

).

2. The following screen appears, showing Ektron CMS400.NET’s
file structure. Navigate to the folder that contains the Office
document.
IMPORTANT!

You can only edit documents in folders for which you have Edit permission. Your
system administrator sets permissions.
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3. Select the document.
4. The document appears within its application.
5. Edit it.
6. To save it under the same name, click the red Save button (
IMPORTANT!

).

You only save documents in folders for which you have Add permission. Your
system administrator sets permissions.

7. The following dialog appears.

8. You have three choices, described below.
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Choice

Description

Save

Save all changes since you opened the document or your last save. After
the document is saved, you can continue working on it.

Save and Check in

Save all changes and check the document back in to CM S40 0.NET . See
Also: ”Checked-In Content” on page 650

Publish

Save all changes and submit the document to be published.
If you are the only approver in the document’s approval chain, or the
document does not have an approval chain, the document is published
immediately. See Also: ”Submitted Content” on page 652 and
”Approving/Declining Content” on page 81
If you are the next person in the approval chain, the Approve button (
becomes active. You can click the button to approve the document.

)

Otherwise, the members of the Approval chain must approve it.
While its status is Submitted, you cannot edit it.

To save it under a different name, click the yellow Save button
( ). The Save As dialog appears. Enter the new name in the
Content Title field.
To save it in a different folder, navigate to that folder and click
Save.

How Editing in Office Affects Content Status
Before you save a document to Ektron CMS400.NET, it has no
status.
The first time you save a document, its status becomes Checked
Out. You can continue to edit and save it within that Office session.
When you close the Office session, you can either check it in or
submit it for publication.

• If you submit it for publication, you cannot edit it until it
completes the approval chain, when its status changes to
approved.

• If you check it in, you and other users can continue to check it
out and work on it.
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If you need to make additional edits to the document before saving
it (thereby submitting it to the approval chain), use the Work Offline
option. See ”The Work Offline Option” on page 230
If you later edit an approved document, it status reverts to checked
out.

Importing an Office Document
Your computer or network may have Office documents that you
want to manage using DM. Follow these steps to import any
document into Ektron’s Document Management functionality.
See Also: ”Drag and Drop File Uploading vs. the New Content
Menu Options” on page 239
1. From the Workarea, select the Content folder.
2. Select the folder in which you want to place the document. See
Also: ”Working with Folders and Content” on page 31
3. The default language appears next to the screen title. To create
the document under a different language, click View >
Language and select the language.
4. Click New > Office Documents.
5. The Insert New Document Object screen appears.
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NOTE

The list of object types is determined by the applications installed on your
computer. For example, an MS Project file type only displays if MS Project is
installed.

6. Check the Create From File button.

7. Click the Browse button and browse to the file you want to
import. Click OK.
8. The document appears within the host application.
9. Enter a Title and add content to the document.
NOTE

If you want to retain the original document name, insert the full filename into the
Title field. For example, you could enter mydocument.doc.

10. Decide whether the content should be added to the Quicklinks
Table and if it should be searchable.
11. If desired, add a summary, metadata, a schedule, and
comments. See Also:

•””Adding a Content Summary” on page 67
•”Adding or Editing Metadata” on page 71
•”Scheduling Content to Begin and End” on page 60
12. If desired, you can edit the document’s properties. See Also:
”Editing a Document’s Properties” on page 218
13. Check in or submit the content for publishing as you would a
content block. See Also: ”Save, Check in, and Publish” on
page 219 and ”Adding Content” on page 45
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The Work Offline Option
After creating or editing a document, you can save it to your local
computer instead of the document server. To do so, click the Work
Offline button (

).

If you do, the document remains in a checked-out state and only
you or a system administrator can check it in to work on it again.
When you check it in, the file on your local computer is loaded into
the Workarea.
As a result, you can edit the document on your local computer
anywhere, without a network connection. When you are ready to
return it to the document server, check it in, save it, or submit it for
publishing.
You must check the document in on the same computer and folder
to which you checked it out.
NOTE

A system administrator can check in any checked-out document. If he does, the
most recently published document gets checked in.

Editing an Office Document
After an Office document is saved, follow these steps to edit it.
1. From the Workarea, select the document’s folder. See Also:
”Working with Folders and Content” on page 31
2. From the View Contents of Folder screen, click the document.
3. The View Content screen for the document appears.
4. Click the Edit button (

).

5. The document opens in the host application.
6. Edit the document as well as its summary, metadata, schedule,
tasks, Web Alerts, or comments.
See Also:

•”Adding a Content Summary” on page 67
•”Adding or Editing Metadata” on page 71
•”Managing Tasks” on page 317
•”Scheduling Content to Begin and End” on page 60
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•Ektron CMS400.NET Administrator manual chapter “Web
Alert Feature”
7. If desired, edit the document’s properties. See Also: ”Editing a
Document’s Properties” on page 218
8. Check in or submit the content for publishing, as you would any
content block. See Also: ”Save, Check in, and Publish” on
page 219

Working with Open Office Files
This section explains how to work with Open Office files through
the following subtopics.

• ”Creating a New Open Office File” on page 231
• ”Importing an Open Office File” on page 231
• ”Editing Open Office Files” on page 233

Creating a New Open Office File
You cannot create an Open Office file within Ektron CMS400.NET.
You must create it in Open Office then import it into Ektron
CMS400.NET.
Once the file is imported into Ektron CMS400.NET, you can edit it
from there. See Also: ”Editing Open Office Files” on page 233

Importing an Open Office File
Your computer or network may have Open Office files that you
want to manage using DM. Follow these steps to import any
document into Ektron’s Document Management functionality.
See Also: ”The Work Offline Option” on page 230
NOTE

In addition to the procedure described below, you can also drag and drop an
Open Office file into Ektron CMS400.NET. See ”Importing Files via Drag and
Drop” on page 237.

1. From the Workarea, navigate to the folder in which you want to
place the file. See Also: ”Working with Folders and Content” on
page 31
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2. The default language appears next to the screen title. To create
the document under a different language, click View >
Language and select the language.
3. Click New > Open Office.
4. The following screen appears.

5. Click the Browse button and navigate to the Open Office file
that you want to import.
6. Enter a Title.
NOTE

If you want to retain the original document name, insert the full filename into the
Title field. For example, you could enter mydocument.odt.

7. Decide whether the content should be added to the Quicklinks
Table and if it should be searchable.
8.

If desired, add a summary, metadata, a schedule, comments,
and Web alert information. See Also:

•””Adding a Content Summary” on page 67
•”Adding or Editing Metadata” on page 71
•”Scheduling Content to Begin and End” on page 60
•Ektron CMS400.NET Administrator manual chapter “Web
Alert Feature”
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9. Check in or submit the content for publishing as you would a
content block. See Also: ”Save, Check in, and Publish” on
page 219 and ”Adding Content” on page 45

Editing Open Office Files
You can edit any Open Office file within Ektron CMS400.NET. When
you do, the associated Open Office application (highlighted in the
illustration below) appears within the CMS editor area.

The procedure for editing an Open Office file is the same as the
one for editing a Microsoft Office file. For details, see ”Editing an
Office Document” on page 230.
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Working with Managed Files
This section explains how to work with managed files through the
following subtopics. A managed file is any kind of file that you can
import into Ektron CMS400.NET other than HTML, XML, Microsoft
Office, Open Office, or Multimedia.

• ”Creating a New Managed File” on page 234
• ”Importing a Managed File” on page 234
• ”Editing a Managed File” on page 235

Creating a New Managed File
Unlike an Office document, you cannot create a managed file
within Ektron CMS400.NET. Instead, you must create it on your
computer using the host application. After creating the file, import it
into DM.

Importing a Managed File
To import a managed file into DM, follow these steps.
See Also: ”Drag and Drop File Uploading vs. the New Content
Menu Options” on page 239
1. From the Workarea, select the Content folder.
2. Select the folder in which you want to place the file. See Also:
”Working with Folders and Content” on page 31
3. The default language appears next to the screen title. To create
the document under a different language, click View >
Language and select the language.
4. Click New > Managed Files.
5. The Edit Content screen opens, as shown below.
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6. Click the Browse button.
7. Browse through your computer and network to the file you want
to import. When you do, the file’s path appears within the File
field.
8. Insert a Title.
9. Decide whether the content should be added to the Quicklinks
Table and if the content should be searchable.
10. If desired, add a summary, metadata, a schedule, and
comments. See Also:

•”Adding a Content Summary” on page 67
•”Adding or Editing Metadata” on page 71
•”Managing Tasks” on page 317
•”Scheduling Content to Begin and End” on page 60
11. Click the appropriate button to either check in (

) or publish

( ) the file. See Also: ”Save, Check in, and Publish” on
page 219 and ”Adding Content” on page 45.
12. A window appears, indicating that the file is being uploaded to
the DM server.

Editing a Managed File
After a managed file is stored in DM, follow these steps to edit it.
1. From the Workarea, select the Content folder.
2. Select the managed file’s folder.
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3. From the View Contents of Folder screen, click the managed
file.
4. The Content tab displays the file name and a button to let you
view the file within its host application.

5. If you want to view the file before editing it, click the View readonly Asset button. If you do, the file opens for display
purposes only.
6. To edit the file, click the Edit button (

).

7. The following screen appears.

8. To open the managed file in the host application, click Edit in
App. Then make your changes, save it in the host application,
and click either the Check in (
button (

) or Submit for Publishing

).
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- If you want to save this version of the file to your computer,
click Save to Local. If you do, a window appears. Navigate
to the desired folder then click the Save button.

- If you want to select another file on your computer or
network and save it under this name in Ektron CMS400.NET,
click Browse. If you do, a window appears. Navigate to the
desired folder then click the Open button. The new file is
saved under the old Ektron CMS400.NET name.
9. Edit the managed file as well as its summary, metadata,
schedule, tasks, or comments.
See Also:

•”Adding a Content Summary” on page 67
•”Adding or Editing Metadata” on page 71
•”Managing Tasks” on page 317
•”Scheduling Content to Begin and End” on page 60
10. Save the file within the host application.
11. Check in or submit the file for publishing, as you would any
content block. See Also: ”Save, Check in, and Publish” on
page 219

Importing Files via Drag and Drop
You can import files to DM using drag and drop. You can add one
or several files using this method. It doesn’t matter whether the
files are Office or Managed files.
NOTE

If you upload a file using drag and drop whose type is not supported, the
Document Management functionality ignores it and moves on to the next file. After
the files upload, a dialog reminds you which files types are supported. See Also:
”Supported Types of Documents” on page 211

When you drag and drop a file into DM, the file’s name becomes its
title. The file is assigned a content ID and submitted to the
approval process. If either of the following is true, the file’s status is
set to checked in:

• you are required to complete metadata for the file
• the folder in which you are adding the file is set to create PDF
documents when a file is published
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If you add more than one file with the same name or the same file
twice, a number is assigned to the end of the title. For example,
when adding a second test.doc file, the new file is named
test.doc(1).
No information is added to Summary, Metadata, or Comments
when a file is added via drag and drop. You can edit this
information by clicking Edit (
), then the appropriate tab.

Steps to Adding Files via Drag and Drop
1. In the Workarea, click the Content folder button.
2. Select the folder in which you want to place the files.
3. Open Windows Explorer.
4. Find the files you want to upload.
NOTE

You cannot drag and drop folders. You can, however, grab all files in a folder and
drag and drop them.

5. From Windows Explorer, drag and drop the files onto the
Workarea’s drag and drop window.
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After you drag and drop the files, the following screen appears.

When DM uploads the files, they appear in the Workarea.
If you do not see a file you selected to upload, check the following:

• your administrator allows the file type to be uploaded to DM
• the Asset Types dropdown box is set to the type of file you are
looking for. Files upload to the correct category regardless of
what is selected when you drag and drop them.

Drag and Drop File Uploading vs. the New Content Menu
Options
• Drag and drop lets you add files quickly without having to fill in
details. The details can be entered later.

• A file added via drag and drop is submitted into the approval
process for that folder.

• Drag and drop requires fewer mouse clicks. You choose a
folder, use Windows Explorer to find the files, and drag and
drop them. The files are then added to DM.
Alternatively, by using the New Content Menu options, you can
add supporting information (summary, comment, and
metadata) while uploading. When adding files using the New
Content menu options, you can choose whether the files are
published (submitted to the approval chain), checked in, or
saved. See Also: ”Save, Check in, and Publish” on page 219
This process requires more mouse clicks than drag and drop.
You choose a folder and document type, browse to the folder
where the files are located, add the details, and publish the
files.
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Document Workflow
A document proceeds through the same workflow as any other
type of content. A diagram is below.

See Also:

• ”Viewing Documents within the CMS” on page 240
• ”Deleting a Document” on page 241
• ”Approving Documents” on page 241
• ”Adding Documents to Collections and Menus” on page 241
• ”Document Reports” on page 241

Viewing Documents within the CMS
To view a document, follow these steps.
1. From the Workarea, select the Content folder.
2. Select the document’s folder.
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3. From the View Content screen, click the document.
4. The View Content screen for the document appears.

Deleting a Document
WARNING!

Only users with Delete permissions for a document’s folder can delete content
within it.

You can only delete a document if its status is Checked In or
Approved. To delete a document, follow these steps.
1. From the Workarea, select the Content folder.
2. Select the document’s folder.
3. From the View Content screen, click the document.
4. The View Content screen for the document appears.
5. Click the Delete button (

).

Like any type of content, a document must go through the approval
chain before it is removed.

Approving Documents
Documents are placed into the approval chain, like other types of
content. For more information, see ”Approving/Declining Content”
on page 81.

Adding Documents to Collections and Menus
You can add a document to a collection or menu as you would any
other type of content. For more information, see ”Working with
Collections” on page 401 and ”Working with Menus” on page 420.

Document Reports
Ektron CMS400.NET provides several reports that track documents

by status.
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Report

Displays documents in this
status

For more information, see

Approvals

Requiring your approval

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Approvals
Report”
Checked In Content

Checked in

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Checked In
Report”
Checked Out Content

Checked out

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Checked Out
Report”
New Content

Submitted Content

New (that is, created and saved
but never published)

C M S 4 0 0 . N E T Administrator Manual >

Submitted for publication

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “New Content
Report”

“Content Reports” > “Submitted
Report”
Pending Content

Approved and pending a start date

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Content Pending
Start Date Report”
Refresh Reminder Report

End date has been reached

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Refresh
Reminder Report”
Expired Content

Expired date has been reached

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Expired Content
Report”
Content to Expire

Will expire within specified number
of days

C M S 4 0 0 . N E T Administrator Manual >

“Content Reports” > “Content to Expire
Report”
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The Ektron Explorer lets you navigate through and view CMS
content without signing in and using the Workarea. You can also
use a search screen to find and view CMS content. So, even if you
have no knowledge of Ektron CMS400.NET, Ektron Explorer
provides a simple, recognizable way to find and view content.
IMPORTANT!

Ektron Explorer only works with Internet Explorer. Other browsers are not
supported.

Depending on how your system administrator has set up the
Explorer, you may also be able to edit, add, and delete content.
The following is an example of the Ektron Explorer. The left frame
lets you navigate through Ektron CMS400.NET’s folders. The right
frame shows the content in a selected folder.
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A second tab in the left frame lets you search for content. When
you do, the right frame displays search results.
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For more information, see ”Searching for CMS Content” on
page 256.
The rest of this section explains everything you need to know to
work with Ektron Explorer through the following topics.

• ”Recently Viewed Content” on page 288
• ”Displaying Ektron Explorer” on page 252
• ”Searching for CMS Content” on page 256
• ”Performing Actions on Content” on page 257
• ”Performing Actions on Folders” on page 263
• ”Inserting External Files into Ektron CMS400.NET” on
page 271

• ”Favorites” on page 272
• ”Using Workspace Folders” on page 278
• ”Using Smart Folders” on page 280
• ”Recently Viewed Content” on page 288
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Installing Ektron Explorer
To install Ektron Explorer, follow these steps.
NOTE

During the installation, you are asked to identify the folder that stores your E kt ro n
CM S40 0. NET . If you don’t know, ask your system administrator for this

information before beginning.

1. Close any Office applications that are open, including MS
Outlook and Ektron CMS400.NET.
2. Sign on to Ektron CMS400.NET. Your system administrator
provides the address to place in your browser’s address field.
For example: http://163.198.0.227/cms400demo/default.aspx.
3. From the Ektron CMS400.NET workarea, click Settings >
Ektron Explorer.

4. Click the download button.
5. The following window appears. Click Run.
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6. The following window appears. Click Run.

7. The following window appears. The default Explorer user name
and password appear. You would typically want to replace
these with your Ektron CMS400.NET user name and password.
Ektron Explorer uses these values by default in your
configuration. See Also: Ektron CMS400.NET Administrator
Manual section “Ektron Explorer” > “Configuring Ektron
Explorer.”
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8. The following window appears. Click Next.
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9. You are prompted to enter the location of Ektron CMS400.NET
on your computer. The default folder appears. Press Next if
that is correct, or enter a different path then press Next.
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10. You are prompted to select a setup type. Choose Complete.
NOTE

When you install Ektron Explorer, you also install the Document Management
toolbar. (See ”Creating a Microsoft Office Document from the Document
Management Toolbar” on page 220.) If you do not want to install the Document
Management toolbar, click Custom then uncheck Ektron Explorer Office Plugin.
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11. The installation copies the needed files to the specified folder
and displays a final screen. Click Finish.
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Displaying Ektron Explorer
After you install Ektron Explorer, you can use it from both Windows
Explorer and Internet Explorer. To make it available, follow these
steps.
1. Open Windows Explorer or Internet Explorer.
2. From the menu across the top of the screen, select View >
Explorer Bar > Ektron Explorer.
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3. The Ektron Explorer replaces Windows Explorer. As you select
a folder (or conduct a search) in the left frame, the related
content appears in the right frame.
Once Ektron Explorer is enabled, a new toolbar button appears
(

) for quick access to Explorer.

See Also:

• ”Display of Content” on page 254
• ”Removing Ektron Explorer from Display” on page 255

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

253

Using Ektron Explorer

Display of Content
The right side of the screen displays content in the selected folder.
The following graphic illustrates the information available about
that content.

Optionally, the right side of the screen may contain metadata
(additional information) about the content. If metadata appears, it is
red and appears under the Last user information, as illustrated
below.

Changing the Thumbnail Size
You can change the size of the thumbnail images in the right
frame. The default size is small. You can change it to medium or
large.
NOTE

You can only adjust the size of HTML or XML content. If the content is an external
file (such as a Word document), you cannot adjust its thumbnail size.
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Menu options let you to change only the selected image or all
images in the right frame.
The new size is only used for the current viewing of the folder. If
you view other folders then return to this one, the default size is
used.
To display the menu for changing the thumbnail size, move the
cursor to the right of the thumbnail image and right click the
mouse. Then, select View, the desired size and whether the new
size applies to only the selected content, or all content in the folder.

Removing Ektron Explorer from Display
To remove Ektron Explorer from display, click the X in the top
corner of the left frame (see below).

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

255

Using Ektron Explorer

Searching for CMS Content
The Explorer’s search feature lets you look for CMS content by
entering some of the content’s title, or some of its text.

Selecting a Folder to Search in
You can also select a folder in which to begin to search. This
reduces the search time if you are certain the content is within a
folder or its subfolders.
NOTE

The Advanced Search Options let you include or exclude a folder’s subfolders
from the search. See Also: ”Advanced Search Options” on page 257

Use the Look In dropdown to select a folder to search (illustrated
below). The drop down box lists all folders that you opened since
you signed on.
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If the folder you want is not in the list, click Browse and a complete
CMS folder display appears. Select a folder from that display.

Advanced Search Options
Advanced search options let you

• search just the current folder or that folder plus all of its
subfolders

• include words that partially match the search string (for
example, if you enter the word the, the search returns content
that includes theater)

• find content that includes all words you enter, any of the words,
or just the exact phrase. The options are explained in
”Specifying Match Criteria” on page 109.

Performing Actions on Content
Ektron Explorer lets you perform several actions on Ektron
CMS400.NET content. For example, you can edit content, change
its title, move it to another folder, etc. This section explains these
actions.
To see a list of available actions, move the cursor to the right frame
and right click the mouse.
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The menu options may change, depending on your permissions for
and the status of the content.

Selecting Content
To perform most actions, first select content. To do this, move the
cursor to the title until it changes to a hand (see illustration).
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Table of Options

Menu
Option

Description

For More Information,
see

Edit

Edit selected content

”Editing Content Using Ektron
Explorer” on page 261

Add to Favorites

Add content to list of favorites

”Favorites” on page 272

Cut

Removes content from folder after you move to
another folder and Paste it

Copy

Makes a copy of selected content. You then move
to another folder and Paste it

Paste

Pastes content you recently Cut into selected
folder

Rename

Change the title of selected content

Delete

Delete selected content. Its status must be
Approved.

”Approving/Declining Content”
on page 81

Deleted content must go through the approval
chain before it is removed. If you are the last
approver in the chain, the content is deleted
immediately.
Send to Email

Insert a link to the selected content into a new
email

”Using the Ektron Explorer to
email Content” on page 262

New > Folder

Create a new folder under the selected content’s
folder

E ktron CM S40 0. NET

Note: After creating a new folder, move the cursor
to the left frame, right click the mouse, and click
Refresh to see the folder.
New > Content

Create a new content item within the selected
folder

Administrator Manual section
“Managing Content Folders” >
“Adding Subfolders”

”Adding Content” on page 45

Note: After creating new content, move the cursor
to the left frame, click its folder, and click Refresh
to see the content.
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Menu
Option

Description

For More Information,
see

New > Form

Create a new form within the selected folder

”Working with HTML Forms” on
page 141

Note: After creating new form, move the cursor to
the left frame, click its folder, and click Refresh to
see the form.
View

•

Small

•

Medium

•
•
•
•

Large

Change the size of the selected or all thumbnails

”Changing the Thumbnail Size”
on page 254

View information about selected content

”Viewing Information about a
Content Item” on page 260

All Small
All Medium
All Large

View Properties

Viewing Information about a Content Item
To learn about any content item, follow these steps.
1. Browse to or use the search to locate the content.
2. Move the cursor next to the content title, so that it turns into a
hand.
3. Right click the mouse.
4. Select Properties.
5. A screen appears listing information about the content. See
illustration below.
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This information is especially useful to a system administrator.

Editing Content Using Ektron Explorer
You can edit content from within Ektron Explorer if you have
permission to do so and the content is in one of the following
statuses:

• published
• checked in
• checked out by you
• submitted for your approval
To edit content, follow these steps.
1. Browse to or use the search to locate the content.
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2. Move the cursor next to the content title so that it turns into a
hand.
3. Right click the mouse.
4. Select Edit.

5. Edit the content as you would from within Ektron CMS400.NET.
See Also: ”Editing Content” on page 49

Using the Ektron Explorer to email Content
The Ektron Explorer lets you send a link to Ektron CMS400.NET
content via email. You might do this to show the content to
someone who does not have access the Ektron CMS400.NET
server. The email contains a quicklink to the content (see example
below).

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

262

Using Ektron Explorer

When the recipient gets the email, he can click the quicklink to
view the content within a browser.
NOTE

The recipient must have access privileges the folder that contains the content
(192.168.0.203/cms400demo in the above example).

Notice that the content title is copied to the email’s subject line.

Performing Actions on Folders
Folders appear in Ektron Explorer’s left frame. You can perform
actions on them via two menus that appear when you place the
cursor in that frame and right click the mouse. For example, you
can delete a folder, create a new folder, search a folder, etc. This
section explains these actions.
One menu appears if you select a folder then right click the mouse.
See ”Using the Menu that Appears when a Folder is Selected” on
page 263.
A different menu appears if you right click the mouse without
selecting a folder. See ”Using the Menu that Appears when No
Folder is Selected” on page 267

Using the Menu that Appears when a Folder is Selected
To see this menu, move the cursor to the left frame, select a folder,
and right click the mouse.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

263

Using Ektron Explorer

The menu options may change, depending on your permissions
and the state of the folder.

The following table explains the options.

Menu Option

Description

Collapse

Closes the selected folder. The next time you open
it, subfolders below it that were previously open
will be open.

For more information, see

Note: This option only appears if the selected item
is an open folder. A minus sign (-) indicates an
open folder (see illustration below).
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Menu Option

Description

Collapse All

Closes the selected folder and any open
subfolders below it. The next time you open it, no
subfolders below it will be open.

For more information, see

Note: This option only appears if the selected item
is an open folder. A minus sign (-) indicates an
open folder.
Expand

Opens the selected folder.
Note: This option only appears if the selected
folder is closed. A plus sign (+) indicates a closed
folder (see illustration below).

Expand All

Open the selected folder and all subfolders under
it.
Note: This option only appears if the selected
folder is closed. A plus sign (+) indicates a closed
folder.

Open

Display content in the selected folder in the right
frame

Search

Search for content within the selected folder or its
subfolders

”Searching for CMS Content” on
page 256

Add to Favorites

Add selected folder to My Favorites folder

”Favorites” on page 272;
”Adding a Folder to the
Favorites Folder” on page 276

Rename

Rename the selected folder

Delete

Delete selected folder and all its subfolders
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Menu Option

Description

For more information, see

New

Create new folder, Blog or Discussion directly
below selected folder

•

E ktron CM S40 0. NET

Administrator manual section “Managing Content
Folders” > “Adding Subfolders”

•
•

”Blogs” on page 343
E ktron CM S40 0. NET

Administrator manual section “DIscussion Boards”
Manage
Configurations,
Use Configuration

Change the combination of user and server you
are using.

Refresh,

Redisplay both sides of the Explorer screen. You
usually do this to see the results of a change.

Refresh Subtree
Properties

Displays information about the folder. Especially
useful to a system administrator.

E ktron CM S40 0. NET

Administrator Manual section
“Ektron Explorer” > “Configuring
Ektron Explorer”

Ek tr on CMS 400 .NET

Administrator manual section
“Ektron Explorer” > “Viewing
Administrative Information.”

The Diagnostic tab displays important
information, such as the server name, application
path, client and server versions, etc.
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Menu Option

Description

Language

Change the folder’s language.

For more information, see

When you do, only content in that language within
the selected folder appears in the right frame.
Note: Click the browser’s refresh button to see
content in the new language (see illustration
below).

Using the Menu that Appears when No Folder is Selected
To see this menu, move the cursor to the left frame and right click
the mouse without selecting a folder.

The menu options may change, depending on your permissions
and the state of the folder.

The following table explains the options.
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Menu Option

Description

For more information, see

Manage
Configurations

Change the combination of user and server you
are using.

E ktron CM S40 0. NET

Use Configuration

Specify the combination of user and server you
are using.

E ktron CM S40 0. NET

Administrator Manual section
“Ektron Explorer” > “Configuring
Ektron Explorer”

Administrator Manual section
“Ektron Explorer” > “Configuring
Ektron Explorer”

Refresh

Redisplay both sides of the Explorer screen. You
usually do this to see the results of a change.

New Workspace

Lets you organize CMS content in a way that’s
meaningful to you, regardless of its organization
within Ektron CMS400.NET

”Using Workspace Folders” on
page 278

Options

Lets you determine certain aspects of Ektron
Explorer behavior

”The Options Dialog” on
page 269

Properties

Displays information about Ektron Explorer.
Especially useful to a system administrator.

Ek tr on CMS 400 .NET

Administrator manual section
“Ektron Explorer” > “Viewing
Administrative Information.”

The Diagnostic tab displays important information
such as the server name, application path, client
and server versions, etc.
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The Options Dialog
The Options dialog lets you determine certain aspects of Ektron
Explorer behavior. They are explained in the table below.

Option

Description

For more information, see

Display Favorites
Folder

Determines whether folders appear under
Favorites

”Adding a Folder to the
Favorites Folder” on page 276

Display Recently
Viewed Folder

Determines if the Recently Viewed folder appears

”Recently Viewed Content” on
page 288

Folder Options
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Option

Description

For more information, see

Size of Recently
Viewed Folder per
CMS

Maximum number of content items that can
appear in the Recently Viewed folder

”Recently Viewed Content” on
page 288

Content Options
Display Thumbnail
Preview

Check this box if you want to see a miniature
rendition of E k t r o n C M S 4 0 0 . N E T content
(example below).

The thumbnail is resizable. See ”Changing the
Thumbnail Size” on page 254.
If this box is unchecked, a generic icon represents
all E k t r o n C M S 4 0 0 . N E T content.

If you display thumbnails, the page load time is
considerably longer.
Regardless of this value, non-Ektron content is
represented by the generic icon shown above, and
is not resizable.
Display Content in
preview when
Summary is
unavailable

The right side of Ektron Explorer displays the
content’s summary information if it exists (See
illustration below).

If no summary is available, check this box if you
want the content to appear where the summary
would.
If you do not check this box, nothing appears in
place of the summary.
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Option

Description

On Drag from
CMS to Local
Machine

You can drag content from Ektron Explorer to your
computer. When you do this, by default, you are
asked if you want change the content’s status to
checked out.

For more information, see

This field lets you predetermine what happens
when you drag content to your computer. Possible
values are explained below.
Prompt for check out - You are asked if you want
to check out the content
Check out - Content is automatically checked out
Note: Checking out the content is the same as
using the Work Offline feature. See ”The Work
Offline Option” on page 230
Download Local Copy - A copy of the content is
placed on your computer but it is not checked out.
Once downloaded, the file is disconnected from
Ek tron CM S40 0.NET .

Inserting External Files into Ektron CMS400.NET
If you installed the Document Management functionality with
Ektron CMS400.NET, you can add files using the drag and drop
technique common in Windows. You can quickly and easily insert
allowed file types into Ektron CMS400.NET.
See Also: ”Using the Document Management Functionality” on
page 210 and ”Importing Files via Drag and Drop” on page 237
The user performing the drag and drop must have permission to
add files to the selected folder.
To drag and drop external files into Ektron CMS400.NET, follow
these steps.
1. Open Ektron Explorer.
2. Make sure the Explorer tab is selected (not the Search tab).
3. Resize Explorer to half of the screen.
4. Open Windows Explorer and resize it to the other half of the
screen.
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5. From Windows Explorer, navigate to the folder that contains
the file you want to insert into Ektron CMS400.NET.
6. From Windows Explorer, select the files you want to copy to
Ektron CMS400.NET.
7. Hold down the left mouse button and drag the files to the
desired Ektron Explorer folder in the left frame.

8. Release the mouse button. A file upload message appears.

Favorites
The My Favorites folder provides quick access to content or
folders that you frequently work with.
NOTE

Workspace folders provide functionality similar to Favorites but also let you create
a folder structure in which to organize content. The Favorites folder, on the other
hand, is only one level. See Also: ”Using Workspace Folders” on page 278
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First, identify frequently-used content or folders as favorites. Then,
when you want to work with them, instead of navigating through
the folder structure, go to the My Favorites folder and select them.
NOTE

You can also access favorite folders and content from the original location. A
favorite is not a copy of the original item -- it’s merely a shortcut to it.

Displaying the Favorites Folder
To display the My Favorites folder, follow these steps.
1. Place the cursor in the left frame.
2. Right click the mouse.
3. A menu appears.
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4. Click Options.
5. The Options dialog appears.

6. Check Display Favorites Folder.
7. Click Apply then OK.
8. Right click the mouse and click Refresh.

Suppressing the Display of the Favorites Folder
To remove the Favorites menu from the left frame, follow the
procedure in ”Displaying the Favorites Folder” on page 273, but
uncheck the Display Favorites Folder checkbox.
if you turn the Favorites display off then later turn it back on,
designated favorites (folders and content) are remembered and
will reappear.
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Marking Content Favorite
You can add any content item to the Favorites folder. To do so,
follow these steps.
1. Navigate to the content.
2. Right click the mouse.
3. A menu appears.
4. Click Add to Favorites.

Viewing Content in the Favorites Folder
To access content in My Favorites folder, click the folder. When
you do, its content appears in right frame (like other folders).
NOTE

Content in the favorites folder has fewer menu options. This is because options
that move content among folders (cut, copy, delete, etc.) are inactive within the
favorites folder.

Removing Content from the Favorites Folder
To remove any content item from the Favorites folder, follow these
steps.
1. Open the My Favorites folder.
1. Navigate to the content.
2. Right click the mouse.
3. A menu appears.
4. Click Remove from Favorites.
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Adding a Folder to the Favorites Folder
You can add any folder to the Favorites folder. To do so, follow
these steps.
1. Select a folder. (A selected folder has a blue background and
white foreground.)
2. Right click the mouse.
3. A menu appears.
4. Click Add to Favorites.

Viewing a Folder in the Favorites Folder
To work with content in a Favorites folder, click the folder. When
you do, its content appears in right frame (like other folders).
NOTE

Folders in the favorites folder have fewer menu options.

Removing a Folder from the Favorites Folder
To remove any folder from the Favorites folder, follow these steps.
1. Select the folder.
2. Right click the mouse.
3. A menu appears.
4. Click Remove from Favorites.

The Workspace
Ektron Explorer’s Workspace lets you organize CMS content in a
way that makes sense to you, regardless of its folder location with
Ektron CMS400.NET. Each Workspace provides two kinds of
folders that let you realize these benefits.
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Workspace
folder type

Icon for
folder type

Description

For more information, see

Workspace folders

Let you drag and drop desired
content

”Using Workspace Folders” on
page 278

Smart folders

Retrieve content based on
criteria you define, such as
folder location, keyword search,
and content status

”Using Smart Folders” on
page 280

You can also drag and drop files directly into a Workspace. And,
you can create as many Workspaces as you wish to accommodate
your organizational needs.
Your Workspaces are unique to you and your computer. If another
person uses your computer, he will not see your Workspaces.
Similarly, if you sign on to Ektron Explorer using the same
configuration on another computer, you will not see your
Workspaces.
IMPORTANT!

You must be connected to Ektron CMS400.NET to use the Workspace.

Distributing your Workspace Files to Another Computer
Workspace files have an .ews extension, such as My test
workspace.ews. They are stored in C:\Program Files \Ektron\Ektron
Explorer\Explorer configuration name. For example, C:\Program
Files\Ektron\Ektron Explorer\JimB.

To move them to another computer, create a new folder in the
C:\Program Files\Ektron\Ektron Explorer folder. The new folder’s
name must match the user’s Explorer configuration name. Then,
copy the .ews files into it.

Deleting a Workspace
1. Select a Workspace.
2. Right click the mouse.
3. Select Delete Workspace.
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Renaming a Workspace
1. Select a Workspace.
2. Right click the mouse.
3. Select Rename Workspace.

Using Workspace Folders
A Workspace folder lets you organize CMS content in a way that’s
meaningful to you, regardless of its organization within Ektron
CMS400.NET.
NOTE

You can also access content from its original location. A Workspace folder does
not contain a copy of the original item -- it’s merely a shortcut to it.

For example, assume the Ektron CMS400.NET folder structure is
organized according to departments: marketing, sales,
administration, engineering, etc. But, you want to organize content
according to product. So, if your company sells robot models 1000,
2000, and 3000, you create a workspace folder for each product
then place all product-related content in the appropriate folder.
You can create as many Workspaces as you wish, and a
Workspace can have any number of Workspace folders.
Furthermore, any folder can have an unlimited number of
subfolders. So, you can set up a multi-leveled structure for
managing content that suits your perspective.
TIP!

After creating Workspaces to manage your content, click the negative icon (-) to
the left of the topmost Workspace for ‘user name’. This action collapses the
standard folder structure, letting you focus on your Workspace organization.
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To create a Workspace folder, first create a Workspace then create
its folders. Next, drag desired content into the folders.

Creating a Workspace
1. In the left frame of the Explorer, right click the mouse.
2. From the popup menu, select New Workspace.
3. A monitor icon appears in the bottom left frame.

4. Enter the name of the Workspace.

Creating a Workspace Folder
1. Hover the cursor over the Workspace.
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2. Right click the mouse.
3. Select New > New Folder for the popup menu.
4. A folder icon appears with a blinking cursor next to it.

5. Enter a name for the folder.
NOTE

You can create an unlimited number of folders underneath any folder.

Placing Content into a Workspace or Workspace Folder
1. Within the standard Ektron CMS400.NET folder structure (in the
top the left frame), select the folder that contains the content of
interest.
2. That folder’s content appears in the right frame.
3. Place the cursor on the title of the content you want to place in
the Workspace or Workspace folder.
4. Hold the left mouse button down while dragging the content to
the desired Workspace or Workspace folder.

Note

You cannot drag and drop files from your computer’s file system into Workspace
folders.

Using Smart Folders
Like Workspace folders, Smart folders let you assemble content
that you are interested in, without regard to its Ektron CMS400.NET
location. Instead of dragging and dropping content, however, you
enter search criteria. The Smart Folder can retrieve all content that
meet the criteria.
For example, you want a Smart Folder that has vacation request
forms from all departments created during August. In Ektron
CMS400.NET’s folder structure, each department’s folder contains
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its employees’ vacation request forms. You don’t want to open
each folder and look through it to find its employee’s forms. So
instead, you set up a Smart Folder to retrieve all content that
contains Vacation Request Form and was created during August.

Entering Search Criteria
When creating a Smart folder, you can include any combination of
the following criteria.

• folder to be monitored
- whether its subfolders are also searched
• text within the content
• dates when content was created or last modified
• the last name of the person who most recently edited the
content

• content status
• content type
You enter the criteria through a series of friendly screens. That
procedure is described in ”Creating a Smart Folder” on page 283.
You must pick a starting folder, but all other criteria are optional.
Remember that content must satisfy all criteria you define in order
to appear in the Smart Folder.

Editing a Smart Folder’s Search Criteria
When you create a Smart Folder and complete the screens that
collect search criteria, you finalize it. You cannot later edit the
folder’s criteria. If you need to change them, create a new Smart
Folder.

Viewing a Smart Folder’s Search Criteria
You can view any Smart Folder’s search criteria by selecting the
folder, right clicking the mouse, and selecting Properties.
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Deleting a Smart Folder
To delete a Smart Folder, select it, right click the mouse, and select
Delete Folder.

Retrieving Content into the Smart Folder
To apply the Smart Folder’s search criteria to Ektron CMS400.NET,
click the folder. This action begins a search through all selected
folders. All content that matches the search criteria at that time is
retrieved to the folder. Since content changes constantly, whatever
is retrieved now will may differ from what is retrieved later.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

282

Using Ektron Explorer

Creating a Smart Folder
To create a Smart Folder, follow these steps.
1. Smart folders reside within a Workspace. If you already created
a Workspace, skip to Step 2. Otherwise, create a Workspace
as described in ”Creating a Workspace” on page 279.
2. Select the Workspace and right click the mouse.
3. Click New > New Smart Folder.
4. The following dialog appears.

5. Enter the name of the Smart Folder.
6. Click Next. A new screen appears.

7. At the Folder to Monitor field, you must identify a folder whose
content will be checked for placement in the Smart Folder. If
you want to search all of Ektron CMS400.NET, select the top
level folder and check Search all subfolders.
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To identify a folder, click the Browse button and navigate
through Ektron CMS400.NET’s folder structure.
8. If you want to also monitor that folder’s subfolders, click the
Search all subfolders checkbox. If checked, all of the folder’s
subfolders are monitored, no matter how many levels they are
below the selected folder.
9. Click Next. A new screen appears.

In the Keywords field, enter a text string that will be used to
search for content within the selected folder(s). For example, you
enter Robot 1000 to find all documents related to that product.
Your Match choices are described below. Since Match Partial
Words is a checkbox, you can include that search criterion along
with one of the three Match options.

Choice

A search returns content that has

For more information,
see

All Words

all words in the Keywords field

”All Words” on page 110

Any Words

any word in the Keywords field

”Any Word” on page 110

Exact Phrase

all words in the order specified in the Keywords
field

”Exact Phrase” on
page 110

Match Partial Words

any part of any word in the Keywords field

”Contains (Match Partial
Words)” on page 110

10. Click Next. A new screen appears.
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Use this screen to enter additional search criteria of created or
modified date range. For example, the Smart Folder should only
contain content created within the last 30 days.
To select a date, click the calendar icon. When a calendar appears,
select a date. Next, the date appears in the field but is display-only.
You can only change it using the calendar.
To delete a date, click the delete icon ( ). Additional information
about entering these date ranges appears in ”Learn More About
the Created/Modified Date Screen” on page 287.
11. Click Next. A new screen appears.

If you want the Smart folder to contain only content that was
last edited by one user, enter that user’s last name.
12. If you want the Smart folder to contain content in only one
status, click the down arrow at the right end of the Status field.
A list appears.
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Select a status from the list. See Also: ”Appendix A: Content
Statuses” on page 648.
13. If you want the Smart folder to contain only one type of content,
click the down arrow at the right end of the Filter field. A list of
content types appears. Select a type.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

286

Using Ektron Explorer

NOTE

Smart Forms are included with Content.

As you can see, you can either search for all assets or pick a
specific asset type to look for.
14. If you want to change any search criteria on any screen, click
Back and make the changes now. Once you press Finish, you
cannot edit the search criteria. If necessary, create a new
Smart folder with different search criteria.
15. Click the Finish button.
To retrieve content that fits your Smart folder’s criteria, see
”Retrieving Content into the Smart Folder” on page 282

Learn More About the Created/Modified Date Screen
If you enter both Date Created and Date Modified date ranges,
the Smart folder only retrieves content that satisfies both criteria
(along with any other criteria you define for the Smart folder).
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To explain this point, assume you set the following dates on the
screen.

The following table explains how a Smart Folder retrieves content
through four scenarios.

Scenario

Created date

Modified date

Found by date range search?

1

06/25/2006

08/01/2006

no - created prior to created date
range set on screen

2

08/01/2006

none

yes - if no modified date, it is same
as created date

3

08/01/2006

08/01/2006

yes - both dates fall with date ranges
set on screen

4

08/01/2006

08/05/2006

no - while the created date falls
within range set on screen, the
modified date does not. Only content
that satisfies both criteria appears in
the Smart folder.

Recently Viewed Content
The Recently Viewed Content option displays the most recentlyaccessed content items, up to a predetermined maximum. The
maximum number of items appears at the top of the right frame
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(illustrated below). See Also: ”Adjusting the Number of Recently
Viewed Content Items” on page 290

In order to appear in this folder, you must click any content’s title,
so that it appears in a new window. The most recently-accessed
item appears at the top, followed by the second most recent, etc.
NOTE

Content in the Recently Viewed folder has fewer menu options. This is because
options that move content among folders (cut, copy, delete, etc.) are inactive
within the favorites folder.

Displaying the Recently Viewed Folder
To display the Recently Viewed folder, follow these steps.
1. Place the cursor in the left frame.
2. Right click the mouse.
3. A menu appears.

4. Click Options.
5. The Options dialog appears.
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6. Check Display Recently Viewed Folder.
7. Click Apply then OK.
8. Right click the mouse and click Refresh.

Adjusting the Number of Recently Viewed Content Items
By default, you see 10 items. To change the number, follow these
steps.
1. Place the cursor in the left frame.
2. Right click the mouse.
3. A menu appears.

4. Click Options.
5. The Options dialog appears.
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6. Edit the number in the Size of Recently Viewed Folder per
CMS field.
7. Click Apply then OK.
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Calendars in Ektron CMS400.NET perform the same function as a
paper calendar: they keep one or more users informed about
upcoming events. They can be displayed to all visitors to your Web
site, and any authorized user can add events to a calendar.
Typical calendar events could include

• company meeting
• reserving a conference room for an interview
• company holidays
• deadlines
These are only a few uses of calendar events. Calendars are
versatile and can easily meet all of your needs. A sample calendar
appears below.
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The Calendar Feature is explained through the following topics.

• ”Understanding Calendars” on page 294
• ”Accessing the View Calendar Screen” on page 295
• ”Viewing a Calendar” on page 300
• ”Tips on Viewing a Calendar” on page 302
• ”Adding a Calendar Event” on page 304
• ”Understanding Event Types” on page 308
• ”Viewing a Calendar Event” on page 311
• ”Editing Calendar Events” on page 312
• ”Deleting Calendar Events” on page 315
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Understanding Calendars
Before working with calendars, you should understand the
following points.

• Ektron CMS400.NET supports several calendars at one time.
There might be a site-wide calendar, and other calendars for
special interests, such as an athletic events calendar.

• Each date can display several events.
• Only system administrators can create a calendar.
• Each calendar is assigned to a content folder (See Also:
”Working with Folders and Content” on page 31). Your ability to
view, add, edit, and remove calendar events is determined by
your permissions for that folder.

• The following illustrates the workflow of calendar tasks.
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Accessing the View Calendar Screen
The View Calendar screen collects general information about a
calendar, and provides toolbar buttons that let you perform
calendar-related activities.
To access the View Calendar screen, follow these steps.
1. Access the Modules folder from the lower left corner of the
Workarea.
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2. Click the Calendars folder.

3. The Calendar Modules screen appears. It lists all calendars in
Ektron CMS400.NET.

NOTE

Only system administrators can create a new calendar.

4. Click a calendar.
5. The View Calendar screen appears, showing information about
the calendar.
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The following table explains the fields on the View Calendar
screen.
Field

Description

Title

Title given to the calendar. The title identifies the calendar within the
Workarea.

ID

ID number automatically assigned to calendar. This is used to
display the calendar on a Web page.

Description

Description given to the calendar.

Location Label

Label for the calendar’s location information. This label appears on
the calendar when a location is assigned to a calendar event.

Start Time Label

Label for the calendar’s start time. This appears on the calendar
when a start time is assigned to a calendar event.

End Time Label

Label for the calendar’s end time data. This appears on the calendar
when an end time is assigned to a calendar event.

Table Properties:

A green check ( ) means the calendar displays every day of the
week. A red X ( ) means the calendar displays weekdays only.

Display Weekends
Forward Only

If a green check ( ) appears next to Show only events that fall
after the viewing day, and the user viewing the calendar is not
logged in, the calendar only displays events from the viewing date
forward. No past events appear.
A logged-in user can view past calendar events.
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Field

Description

Event Type Label

Indicates if event types are assigned to this calendar.

See Also: ”Understanding Event Types” on page 308
One section of the Add Calendar Events screen displays available
event types and lets the user assign them to the event.

By default, this text is Event Type:. Your system administrator can
edit the text.
Event Types Available

A green check ( ) means you can add event types to the calendar.

Event Types Required

A green check ( ) means that when entering a calendar event, you
must assign an event type to it.

Instructions

If this calendar uses event types, text appears at the bottom of the
screen that explains how to use the event type selection box. By
default, this text is Select Event Type to View:.

Your system administrator can change this text.
Show All Label

If this calendar uses event types, the list of event types appears at
the bottom of the screen. On top of the list is text indicating that all
event types will appear on the calendar. By default, this text is Show
All.

Your system administrator can change this text.
Long Description

Lets the user enter additional text while adding a calendar event.
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Field

Description

Folder Name

Name of content folder to which the calendar is assigned for
permission purposes.
You can only add, edit or delete events for calendars in folders to
which you have been granted permission.

Folder Path

Complete path to the calendar’s content folder.

The View Calendar screen may contain the following toolbar
buttons that let you perform other tasks.
Button

Name

Description

More Information

View
Calendar

Show calendar in the Workarea

”Viewing a Calendar” on
page 300

Back

Return to previous screen

Viewing a Calendar
NOTE

This section explains how to view a calendar and enter calendar events from the
Workarea. Once a calendar is available on your Web site, you can also perform
these actions by logging in and navigating to the calendar on your site.

To view a calendar, follow these steps.
1. Access the View Calendar screen for the calendar you want to
see, as described in ”Accessing the View Calendar Screen” on
page 295.
2. Click the View Calendar (

) button.

3. The calendar appears.
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See Also: ”Tips on Viewing a Calendar” on page 302.
4. If you want to view events of a certain type only, click the
Select Event Type to View drop-down list (illustrated below).
Then, choose an event type. See Also: ”Understanding Event
Types” on page 308

The page is refreshed, and the calendar displays events of that
type only.
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From the View Calendar screen, you can perform the following
tasks. Note that the Add and View buttons appear on each
calendar day, while the Return button is on the toolbar at the top of
the screen.
Click on

Event title within
calendar (sample
below)

Action

More Information

Add Calendar Event

”Adding a Calendar Event” on page 304

View Calendar Events

”Viewing a Calendar Event” on page 311

Return to Previous Screen

Return to previous screen

Jump to calendar event’s
Web page (if available)

See Also: ”Working with Calendars” on page 292

Tips on Viewing a Calendar
• The monthly calendar displays the current month. In the
intranet sample, today is highlighted in yellow (illustrated
below).
At the top of the calendar are the previous and next months.
Click them to view those months.
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• Where an event appears, move the cursor over it to see a
popup box with the event name, location, and start and end
times.
If a Web page is linked to the event, you can click the event
name to jump to that page.

• Click the number that represents any day to view detail for that
day (illustrated below).

• From the daily view, you can
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- see all events and the hours they span
- proceed to the previous or next day (click a date in the upper
left or right corner)

- return to the month view by clicking on today’s date
- view detail about an event by clicking on it
• From the event view (illustrated below), you can view the
event’s location and start and end times. Click the date to
return to the daily view.

Adding a Calendar Event
NOTE

You can only add a calendar event if you have add or edit permission for the
calendar’s folder.

To add a calendar event, follow these steps.
1. Access the calendar to which you want to add an event, as
described in ”Viewing a Calendar” on page 300.
NOTE

You can also add a calendar event after viewing the View Events screen. See
Also: ”Viewing a Calendar Event” on page 311

2. Navigate to the month and day for which you want to add a
calendar event.
Your calendar display is determined by your system
administrator.
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3. Click the Add Event (

) button.

4. The Add Calendar Event screen appears.
NOTE

Folder information appears at the bottom of the screen only if the folder has
subfolders or content under it.

5. Respond to the fields using the following table as a reference.
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Field

Description

Event Title

Enter a title for the event.
Note: If you enter a Quicklink in the Hyperlink field, the Quicklink’s content
title replaces this title. You can then edit the new title if desired.

Event Location

If desired, enter a location for the event (for example, Conference Room 1 or
Cafeteria).

One Time/
Recurring

If you want to enter a one-time only event, continue reading.

Date

Click the calendar icon (

If you want to add a recurring event, see ”Adding a Recurring Event” on
page 308.
) to display a calendar. From it, select a start date.

Technical note: If you see a mix-up of the month and date of your entry (for
example, you select March 2 but see February 3), make sure the date format
specified in the Windows Control Panel Regional Settings dialog matches
your current language. Also, make sure the settings apply to the default user.

Start Time

End Time

Click the clock icon (

) to display a clock. From it, select a start time.

Click the clock icon (
the event.

) to display a clock. From it, select an ending time for
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Field

Description

Display the times
for the event

Check this box if you want the calendar to display the event’s start and end
times (illustrated below).

The time also appears on the event detail if this box is checked.

Hyperlink

You can link a Web page to this calendar event. The Web page could contain
more information about the event, directions to it, etc.
If you insert a hyperlink, when this event appears on the calendar, the reader
can click the event to jump to that page.
To enter any page on the internet, enter its Web address. For example,
www.ektron.com.
To link to content on your Web site, click the library button (
). (This type of
link is known as a Quicklink.) The Quicklinks dialog appears, and you can
navigate to the content.
The last published version of linked content appears. If content has never
been published, nothing appears.
If you select a hyperlink, the title of the selected content replaces any text in
the Event Title field. You can edit the new title if desired.

Launch link in a
new browser

Check this box if you want the Web page or Quicklink specified in the
Hyperlink field to appear in a new browser window when someone clicks it.
If you do not check this box, the new Web page replaces the current one
when the link is clicked.
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Field
Event Type

Description
Note: This field only appears if your system administrator set up one or more
event types for this event.
See Also: ”Understanding Event Types” on page 308
To apply an event type to this event, click an Event Type from the right
column. Then, click the Right Arrow (
Selected column.

) to move the event type to the

Repeat for each event type you want to assign to the event.

6. Click Save (

).

Understanding Event Types
Your system administrator can set up types of calendar events. For
a personal or workgroup calendar, examples might be staff
meetings, employment interviews, conference calls. For an
educational institution, examples might be academic deadlines,
sporting events, and tuition due dates.
If you assign a type to an event while creating it, you can later
display only events of that type. This feature lets the viewer
temporarily suppress unwanted events. As a result, the calendar
display is cleaner, because it only shows relevant information.

Adding a Recurring Event
You can assign an event to occur multiple times on a calendar. To
do so, follow these steps.
1. Add a calendar event (as described in ”Adding a Calendar
Event” on page 304).
2. Click the Recurring tab to assign the event for more than one
day.
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3. Refer to the table below to complete to the Recurring fields.
Field

Description

Start Date

Click the calendar icon (

) to display a calendar. From it, select a start date.

Technical note: If you see a mix-up of the month and date of your entry (for
example, you select March 2 but see February 3), make sure the date format
specified in the Windows Control Panel Regional Settings dialog matches
your current language. Also, make sure the settings apply to the default user.
End Date

Click the calendar icon ( ) to display a calendar. From it, select an end date
for the series of recurring events.

Event will occur

Select the frequency of the event from among the choices.
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4. Finish your edits.
For documentation of
Start Time

End Time

Display the times for the event

See
Click the clock icon (
time.

) to display a clock. From it, select a start

Click the clock icon (
time for the event.

) to display a clock. From it, select an ending

Check this box if you want the calendar to display the event’s start
and end times (illustrated below).

The time also appears on the event detail if this box is checked.

Hyperlink

You can link a Web page to this calendar event. The Web page could
contain more information about the event, directions to it, etc.
If you insert a hyperlink, when this event appears on the calendar,
the reader can click the event to jump to that page.
To enter any page on the internet, enter its Web address. For
example, www.ektron.com.
To link to content on your Web site, click the library button (
).
(This type of link is known as a Quicklink.) The Quicklinks dialog
appears, and you can navigate to the content.
The last published version of linked content appears. If content has
never been published, nothing appears.
If you select a hyperlink, the title of the selected content replaces any
text in the Event Title field. You can edit the new title if desired.
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For documentation of

See

Launch Link in New Browser

Check this box if you want the Web page or Quicklink specified in the
Hyperlink field to appear in a new browser window when someone
clicks it.
If you do not check this box, the new Web page replaces the current
one when the link is clicked.

Event Types

Note: This field only appears if your system administrator set up one
or more event types for this event.
See Also: ”Understanding Event Types” on page 308
To apply an event type to this event, click an Event Type from the
right column. Then, click the Right Arrow (
type to the Selected column.

) to move the event

Repeat for each event type you want to assign to the event.

5. Click the Save button (

).

Viewing a Calendar Event
Once events are added to a calendar, you can easily view them. To
view a calendar event, follow these steps.
1. Access the Show Calendar screen for the calendar that
contains the event you want to view, as described in ”Viewing a
Calendar” on page 300.
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2. Place the cursor on the event you want to view.

3. Click the View Events (

) button.

4. The View Events screen appears, listing all calendar events for
that date.If an event is part of a series of recurring events, the
following icon appears next to it:
From this screen, you can perform the following functions:

- Add a new event (See Also: ”Adding a Calendar Event” on
page 304)

- View, edit, and delete an existing event

Editing Calendar Events
The section explains how to edit a single event or a recurring
series of events.
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NOTE

You can only edit a calendar event if you have edit permission for the folder to
which the calendar is assigned.

See Also: ”Adding a Calendar Event” on page 304

Editing a Single Event
After a calendar event is added to a calendar, you may edit it to
change the title, location, times, etc. To edit a calendar event,
follow these steps.
1. Access the View Calendar Events screen for the date that
contains the event you want to edit, as described in ”Adding a
Calendar Event” on page 304.
2. Click the event you want to edit.
3. The Edit Calendar Event screen appears.
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4. Update the fields using the table described in ”Adding a
Calendar Event” on page 304 as a reference.
5. Click the Save button (

).

Editing Recurring Events
After a recurring series of events is added to a calendar, you may
edit it to change the title, location, hyperlink, and event type.
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NOTE

You cannot edit event dates or times. To change those, delete and re-enter the
series of events.

To edit a recurring series of events, follow the steps in ”Editing a
Single Event” on page 313. The only difference is the Update all

recurring events associated with this event box.
To apply the edits to only the instance of the event that you
selected, uncheck the box. To apply the changes to all instances,
check the box.

Deleting Calendar Events
The section explains how to delete a single event or a recurring
series of events.
NOTE

You can only delete a calendar event if you have add, edit, or delete permission
for the content folder to which the calendar is assigned.

Deleting a Single Occurrence Calendar Event
You can easily delete calendar events that are no longer needed,
or do not belong to the calendar they were added to. To delete a
calendar event, follow these steps.
1. Access the View Calendar Events screen for the date that
contains the event you want to delete, as described in ”Adding
a Calendar Event” on page 304.
2. Click the event you want to delete.
3. The Edit Calendar Event screen appears.
4. Click the Delete button (

).

5. A confirmation message appears.
6. Click OK.

Deleting a Recurring Calendar Event
You can delete a single event in a recurring series or all events in
the series.
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Deleting a Single Recurring Event
1. Access the View Calendar Events screen for the date that
contains the event you want to delete, as described in ”Adding
a Calendar Event” on page 304.
2. Click the event you want to delete.
3. The Edit Calendar Event screen appears.
4. Click the Delete Content button (

).

5. A confirmation message appears.
6. Click OK.

Deleting All Events in a Recurring Series
1. Access the View Calendar Events screen for any date that
contains an events in the series that you want to delete, as
described in ”Adding a Calendar Event” on page 304.
2. Click the event in the series that you want to delete.
3. The Edit Calendar Event screen appears.
4. Click the Delete This and Associated Recurring Events button
(

).

5. A confirmation message appears.
6. Click OK.
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A task is a request from one user to another to perform an action
within Ektron CMS400.NET. Examples of a tasks include:

• updating content
• publishing content
• updating an image
• reordering a collection
The Tasks folder displays all tasks that are either assigned to you
or that you assigned to another user or user group. You can also
assign tasks to yourself.
A task may or may not be related to a specific piece of content. If it
is, you can access content then “attach” a task to it. This kind of
task is managed just like the other tasks, but you can also view and
update it via the attached content. For more information, see
”Viewing a Task” on page 331.
This chapter explains how to work with tasks through the following
topics.

• ”Creating a Task via the Task Folder” on page 318
• ”Adding a Task Category and Task Type” on page 325
• ”Creating a Task from the Web Site” on page 330
• ”Creating a Task via the Content Folder” on page 330
NOTE

Tasks can also be created automatically when forms are submitted. See Also:
”Assigning a Task to a Form” on page 181

• ”Viewing a Task” on page 331
• ”Editing a Task” on page 336
• ”Adding Comments to Tasks” on page 337
• ”Deleting a Task” on page 340
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• ”Viewing a Task’s History” on page 341
• ”Task Module Toolbar” on page 342

Creating a Task via the Task Folder
This topic consists of the following subtopics:

• ”Accessing the Tasks Folder” on page 318
• ”Creating a Task via the Task Folder” on page 319
• ”Adding a Task Category and Task Type” on page 325

Accessing the Tasks Folder
To access the Tasks folder, follow these steps.
1. Access your Smart Desktop, as explained in ”Understanding
the Smart Desktop” on page 20.
2. The Smart Desktop folders appear in the top left frame.

3. Click the Tasks folder. The following subfolders appear:

• Assigned To Me - tasks assigned to you
• Assigned By Me - tasks you assigned to someone else
• Created By Me - tasks you created
• Assigned To User - search for tasks assigned to a user
• Not Started - tasks whose state is set to not started
• Active - tasks whose state is set to Active
• Awaiting Data - tasks whose state is set to Awaiting Data
• On Hold - tasks whose state is set to On Hold
• Pending - tasks whose state is set to Pending
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• Reopened - tasks whose state is set to Reopened
• Complete - tasks whose state is set to Complete
You can click any folder to view only tasks in that category.
Also, the View Tasks screen appears in the right frame, listing all
tasks assigned to you, or assigned by you.

From this page, you can view, sort, update, or add tasks. To learn
more about the View Tasks screen, see ”Viewing a Task” on
page 331.
To learn about sorting by Task Type, see ”Sorting Tasks By Task
Type” on page 335.

Creating a Task via the Task Folder
See Also: ”Task Module Toolbar” on page 342
To create a task, follow these steps.
1. Access your Tasks folder, as described in ”Accessing the Tasks
Folder” on page 318.
2. Click the Add button (

).
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IMPORTANT!

The Add button only appears if your system administrator has granted you
permission to add tasks. For more information, see the Ektron CMS400.NET
Administrator Manual > “Managing Tasks” > “Task Permissions.”

3. The Add Task screen appears.
Enter information for the task using the following table.
Field

Description

Task Title

Enter a title for the task (for example, Update Content). The
title appears in the left column of the View Tasks screen.

Assigned To

Your user name appears.

•

If you do not have Redirect permissions, you cannot
assign tasks to other users.

•

If you have Redirect permissions, your user name
appears followed by Select User or Group. To assign
the task to yourself, proceed to the next field. To assign
the task to someone else, click Select User or Group
and choose a user or group. (The user to whom the task
is being assigned must have permission to edit the content.)

When you complete the screen, an email is sent to the
selected user or user group informing him of the assigned
task.
Note: email is only sent if email notification is enabled for
Ek tron CM S40 0.NET .
Language

Select the language of the user who will perform the task.

Content

If this task involves a piece of content, select it. When you
click Select, a new window appears. From this window, you
can navigate through folders to find the content.
You can only select a piece of content whose language
matches the user language selected above.

See Also: ”Selecting Content for the Task” on page 323
Priority

Select the priority of the task. Your choices are High, Normal
and Low.
The priority appears on the View Tasks screen. A user can
sort tasks on the screen by priority.
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Field

Description

Task Category

Select a category for the task. When a Task Category is
chosen, the Task Type drop down box is auto filled with task
types associated with that category. See Also: ”Adding a
Task Category and Task Type” on page 325.

Task Type

Select the Task Type for this task. You must specify a Task
Category before you assign a task type. See Also: ”Adding a
Task Category and Task Type” on page 325.

Add

By clicking the Add link, you can add Task Categories and
Task Types. See Also: ”Adding a Task Category and Task
Type” on page 325
Note: If you Add a Task Category or Task Type while adding a
task, the task information (Task Title, Assigned To, Language,
etc.) entered will be lost when the screen refreshes.

Edit

By clicking the Edit link, you can edit the Task Type chosen in
the Task Type drop down box. See Also: ”Editing a Task
Type” on page 327
Note: If you edit a Task Type while adding a task, the task
information (Task Title, Assigned To, Language, etc.) entered
will be lost when the screen refreshes.

State

Choose a status for the task. Your choices are:

•
•
•
•
•

Not Started
In Progress
Completed
Waiting on Someone else
Deferred

If the task is not linked to content, you can assign it to any
state. However, if you later link the task to content (via the
Content link above), the state switches to Not Started.
The state appears on the View Tasks screen. A user can sort
tasks on the screen by state.
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Field

Description

Start Date

Using the calendar button, choose a start date for the task.
The start date appears on the View Tasks screen. A user can
sort tasks on the screen by start date.

Technical note: If you see a mix-up of the month and date of
your entry (for example, you select March 2 but see February
3), make sure the date format specified in the Windows
Control Panel Regional Settings dialog matches your current
language. Also, make sure the settings apply to the default
user.

Due Date

Using the calendar button, choose the date by which the task
needs to be completed.
The due date appears on the View Tasks screen. A user can
sort tasks on the screen by due date.
Technical note: If you see a mix-up of the month and date of
your entry (for example, you select March 2 but see February
3), make sure the date format specified in the Windows
Control Panel Regional Settings dialog matches your current
language. Also, make sure the settings apply to the default
user.
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Field

Description

Description

Add additional information to describe the task. The
description appears on the View Task screen (circled below).

4. Click the Save button (

).

If email notification is enabled, an email is sent to the user/user
group to which the task was assigned.

Selecting Content for the Task
When you click Select Content from the Add Task screen, the
Select Content screen appears. It shows only content in the
selected language.
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You should only select a content folder for which you have
permissions.
To select a piece of content to assign to the task, follow these
steps.
1. Navigate to the content. (Click any folder to open it.)
2. Click the circle to the left of the content.

3. Press the Save button (

).
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Adding a Task Category and Task Type
Task Categories and Task Types let users and administrators sort
task by user defined categories and types.
By clicking the Add link, located next to the Task Type drop down
box, you can add Task Categories and Task Types. This allows you
to add categories and types without leaving the Add Task screen.
NOTE

Administrators can also add and edit Task Categories and Task Types from the
Workarea by clicking Settings > Configurations > Task Types. See Also: Ektron
CMS400.NET Administrators Manual > “Managing Tasks” > “Task Categories and
Types”.

To add a Task Category and a Task Type, follow these steps.
1. Go to the Add Task screen, as described in ”Creating a Task
via the Task Folder” on page 319.
2. Click the Add link, next to the Task Type dropdown box.

3. The Add Task Type screen appears.
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From this screen you can perform the following:

• Add a task type to an existing task category
• Create a new task category
• Add a new task type
• Add a task type description
• Define task type availability
NOTE

As a user, if you set the Task type to Not Available, you cannot edit the Task Type
after that. To make the Task Type available, see your administrator. Task Type
availability is explained in the Ektron CMS400.NET Administrators Manual >
“Managing Tasks” > “Task Categories and Types” > “View Categorization
Screen“> “Task Type Availability”

4. Enter your information.
5. Click Save (

).

6. Your new Task Category and Task Type appear in the drop
down boxes.
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Task Type Availability
Task types can be hidden from users by clicking the Not Available
check box in the Add Task Type and Edit Task Type screens. By
making Task Types not available, you can make the Task Type
unavailable without deleting it.

Editing a Task Type
From the Add Task screen, you can edit a Task Type. This will
allow you to change the Task Type name, Task Type description,
and Task Type availability.
To edit a task type, follow these steps.
1. Go to the Add Task screen, as described in ”Creating a Task
via the Task Folder” on page 319.
2. Choose a Task Category and the Task Type to edit.
3. Click Edit, next to the Task Type dropdown box.
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4. The Edit Task Type screen appears.
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From this screen you can edit the following:

• Task Type
• Task Type Description
• Task Type Availability. See Also: ”Task Type Availability” on
page 327
NOTE

As a user, if you set the Task type to Not Available, you cannot edit the Task Type
after that. To make the Task Type available, see your administrator. Task Type
availability is explained in the Ektron CMS400.NET Administrators Manual >
“Managing Tasks” > “Task Categories and Types” > “View Categorization
Screen“> “Task Type Availability”

5. Edit the information.
6. Click Save (

).

7. The Task Type information is changed.
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Creating a Task from the Web Site
To create a task from a Web page, follow these steps.
1. Sign in.
2. Browse to the content for which you want to assign a task.
3. Right click the mouse to display a menu.
4. Click the Add Task button (
IMPORTANT!

).

The Add Task button only appears if your system administrator has granted you
permission to add tasks. For more information, see the Ektron CMS400.NET
Administrator Manual > “Managing Tasks” > “Task Permissions.”

5. The Add Task screen appears. The content you were viewing is
assigned to the task.
6. Follow the directions in ”Creating a Task via the Task Folder”
on page 319. The only differences are

• the content’s ID number and title appear on the screen
• the language of the content is the default language

Creating a Task via the Content Folder
The above section describes assigning tasks from the Tasks folder.
You can also assign task via the content folder, as illustrated
below.

Assigning a Task from the View Content Screen
To assign a task from the View Content screen, follow these steps.
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1. Access the View Content screen for the content to which you
want to “attach” in a task, as described in ”Viewing Content” on
page 38.
2. Click the Add Task button (
IMPORTANT!

).

The Add Task button only appears if your system administrator has granted you
permission to add tasks. For more information, see the Ektron CMS400.NET
Administrator Manual > “Managing Tasks” > “Task Permissions.”

3. Follow the directions in ”Creating a Task via the Task Folder”
on page 319. The only differences are

• the content’s ID number and title appear on the screen
• the language of the content is the default language

Viewing a Task
Once a task is added, (with the exception of Administrators and
users given permission to create tasks) only the user who
assigned the task and those to whom the task was assigned can
view it.
To view a task, follow these steps.

Viewing a Task from the Content Folder
1. Access the Contents folder from the left side of your Workarea.
2. Select the content associated with the task.
3. Click the Tasks tab.
4. The page lists all tasks assigned to the content.
5. Select a task.
From the view task page, you can add a comment to the task. See
”Adding Comments to Tasks” on page 337 for more information.

Viewing a Task from the Tasks Folder
To view a task from the Tasks folder, follow these steps.
1. From the Smart Desktop, select the Tasks folder.
2. Click the task you want to view.
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3. The View Task screen is displayed. From here, you can
perform these tasks.

• ”Editing a Task” on page 336
• ”Deleting a Task” on page 340
• ”Adding Comments to Tasks” on page 337
See Also: ”Task View Options” on page 332, ”Sorting Tasks By
Task Type” on page 335, ”Sorting Tasks By Column” on page 335;
”Managing Tasks” on page 317; ”emailing Tasks” on page 336

Task View Options
Beneath the main task module folder, several view screens display
all tasks filtered by specified categories. After viewing tasks in any
category, most screens let you perform an action on the tasks (the
actions are included in the table below). For example, you can
change a tasks state to another state. To select all tasks on a
screen, click the check box in the header row (illustrated below).

Folder

Displays these tasks

Action you can perform
from view screen

Tasks

All tasks assigned to you, that are in one
of the following states.

•
•
•
•

•
•
•
•
•
•

not started
active
awaiting data

Click on task to view it
Add a task
Sort tasks by Task Type
Sort tasks by column

on hold
reopened
pending
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Folder

Displays these tasks

Action you can perform
from view screen

Assigned To Me

All open tasks assigned to you

•
•
•

Click on task to view it

•
•
•

Click on task to view it

•
•
•

Click on task to view it

•

Select any user and view
all tasks assigned to that
user.

Assigned By Me

Created by Me

Assigned to User

All open tasks you assigned to yourself or
others

All open tasks you created

All open tasks assigned to a user you
select

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column

To do so, select new user
from Assign to User drop
down list and click Get
Tasks.

Not Started

All whose state is Not Started

•
•
•

Click on task to view it

•

Change to the following
states: Awaiting Data, On
Hold

•
•
•

Click on the task to view it

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column
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Folder

Displays these tasks

Action you can perform
from view screen

Active

All whose state is Active

•

Change to the following
states: Awaiting Data, On
Hold

•
•
•

Click on the task to view it

•

Change to the following
states: Awaiting Data, On
Hold

•
•
•

Click on the task to view it

•

Change to the following
states: Awaiting Data, On
Hold

•
•
•

Click on the task to view it

•
•
•

Click on the task to view it

•
•
•

Click on the task to view it

•

Change to the following
state: Archive

•

Click on the task to view it

•
•

Sort tasks by Task Type

Awaiting Data

On Hold

Pending

Reopened

Completed

All whose state is Awaiting Data

All whose state is On Hold

All whose state is Pending

All whose state is Reopened

All whose state is Completed

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column

Sort tasks by Task Type
Sort tasks by column

Sort tasks by column
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Sorting Tasks By Task Type
On every View Task page, you can sort tasks by the Task Type
assigned to the task. You sort by Task Type using the Show Task
Type drop down box. It is located in the upper right corner of the
Workarea.
NOTE

Task Types only appear in the Show Task Type dropdown box when they have
been added to a task.

To sort by Task Type, click the drop down box and choose a Task
Type. Words in bold Italics are Task Categories. You cannot sort
by Task Categories.

Sorting Tasks By Column
On every View Tasks page, you can sort the information by most
columns. Information can be sorted by the following.
Column

Click to sort tasks

Title

Alphabetically by title of associated
content

CID

By content ID number

State

By task state, from first to last

Priority

By task priority. High appears first,
followed by Normal then Low
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Column

Click to sort tasks

Due Date

By due date, beginning with dates closest
to today

Assigned To

Alphabetically by user to whom the task
is assigned
Note: Once set, a task’s assigned-to user
does not change throughout the life of
the task.

Assigned By

Alphabetically by user who assigned the
task

Last Added Comment

Alphabetically by the most recently
created task comment

Create Date

By date task was created, beginning with
dates closest to today

emailing Tasks
You can email the contents of any Task screen. emailing tasks
works the same as emailing reports. See the Ektron CMS400.NET
Administrator Manual section “Content Reports” > “Common
Report Topics” > “emailing Reports”

Editing a Task
You can change task information, such as

• Title
• Assigned to
• Language
• Content
• Priority
• Task Category
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• Task Type
• Status (State)
• Due Date
• Start Date
• Description
To edit a task, perform the following steps.
1. Access the View Task page for the task, as described in
”Viewing a Task from the Tasks Folder” on page 331.
NOTE

You cannot edit a task after viewing it from the Content folder.

2. Click the Edit button (

).

3. The Edit Task screen appears.
4. Edit the task.
5. Click the Update button (

) to save the changes.

Adding Comments to Tasks
You can add comments to an assigned task if you want to provide
additional information about its status. For example, if you update
a task’s status from In progress to Waiting on Someone Else, you
can use a comment to describe the status change, such as:
left voice mail with John with questions about
his changes to the home page
Comments appear at the bottom of the View Tasks screen
(illustrated below).
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Several comments can be added to a task to record its progress
from assignment to completion.
To add a comment to a task, follow these steps.
NOTE

When an approver approves/declines content from the Content Awaiting Approval
screen, if the content has an active task, the Add Comments to Task screen
appears. The screen lets the approver insert comments about the task associated
with the content.

1. Access the View Task screen for the task, as described in
”Viewing a Task” on page 331.
2. Click the Add Comment button (

).

3. The Comments window appears.
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4. Enter your comment in the editor. Note that you can format and
spell check the text using the toolbar buttons.
5. Click the

button.

6. The View Task screen reappears with the comment at the
bottom of the page.

Updating Comments
To update a comment, follow these steps.
1. Access the View Task screen that contains the comment you
want to update, as described in ”Viewing a Task” on page 331.
2. Click the comment’s Date/Time link (illustrated below).
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3. The Comments window opens with the comment displayed.
4. Update the comment.
5. Click the

button.

Deleting a Task
You can easily delete a task that is no longer needed. For example,
the user who assigned a task would typically delete it when it is
completed.
To delete a task, follow these steps.
1. Access the View Task screen for the task, as described in
”Viewing a Task” on page 331.
2. Click the Delete button (

).
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IMPORTANT!

The Delete button only appears if your system administrator has granted you
permission to delete tasks. For more information, see the Ektron CMS400.NET
Administrator Manual > “Managing Tasks” > “Task Permissions.”

3. A confirmation message appears.
4. Click OK.

Viewing a Task’s History
Ektron CMS400.NET maintains a history of all events in the life of a

task, as well as any comments entered. As examples, the task
history shows when and by whom the task was created, when it
changed to Active, when it was linked to content, when its state
changed, when it was approved, etc.
You can view the task’s history until the task is purged. To view a
task’s history, follow these steps.
1. Navigate to the View Task screen, as explained in ”Viewing a
Task” on page 331.
2. Click the History button (

).

3. The history of task events appears (example below).
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Task Module Toolbar
The following table explains the toolbar buttons available while
managing tasks.
Button

Name

Description

More Information

Add Comment

Add a comment to the task.

”Adding Comments to
Tasks” on page 337

Add Task

Access the Add Task screen from the
View Content page.

”Task Module Toolbar”
on page 342

Add Task

Access Add Task screen from task
module folder.

”Creating a Task via
the Task Folder” on
page 319

Back

Return to previous page.

Calendar

Select a date.

Delete Task

Delete a task.

”Deleting a Task” on
page 340

Edit Task

Edit a task.

”Editing a Task” on
page 336

Save

Save task information.

Update

Save task information.

View Task

View task information.

”Viewing a Task” on
page 331
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Introduction
Blogs (short for Web Logs) are a form of online information
sharing. A blog is often set up so a group of people can share their
thoughts on a subject. In addition, blogs can be used to create an
online diary of everyday life.
In the Ektron CMS400.NET Workarea, blogs and blog posts have a
relationship similar to folders and content. The blog is the
equivalent of a folder, and blog posts are the equivalent of content
items. While blogs and blog posts have a few unique properties,
they mostly work the same as folders and content.
On your Web site, blogs are arranged so the latest post appears at
the top. This differs from paper diaries, because you are reading
the newest material first, instead of the oldest. Because blogs are
laid out this way, site visitors can quickly find the most recent
entries.
Blogs are made up of multiple elements. These elements allow site
visitors to view or create a blog post, add comments, and see a roll
call of associated blogs. In addition, if a blog calendar is present on
the blog site, visitors can see which days have blog posts.
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Blogs in the Workarea appear as a language bubble in the folder
structure. This distinguishes a blog folder from a content folder.

The following table lists elements commonly found in a blog.

Element

Description

Blog Title

The name of your blog as you want it to appear on the site.
For example, “My Life Story.”

Blog Post

The main entry for each topic. A blog post is made up of
several sub elements:

•
•
•

Headline - the title of the post

•

TrackBack URL - a URL visitors can use to notify you
when they are talking about the blog post on their site

•
•

PingBack - Pings back any URLs in the blog post

Commentary - the details of the post
Comment Link - links to a comments page, where site
visitors can view or add comments

Images - add images to a blog post. You add images to
a blog post the same way you add them to content.
See Also: ”Adding a Library File to Content” on
page 133

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

345

Blogs

Element

Description

Blog Comments

A Comments link appears at the end of the blog post. The
link includes a number in parentheses, for example (3).
This number denotes how many comments have been
made. Click this link to move to the comments page, where
you can read comments on the post and possibly enter your
own.

Blog Roll

Other blog sites that the blog’s creator wants site visitors to
view.

Blog Categories

Categories associated with the blog. If you click a category,
links to all posts associated with the category appear.

Calendar

Indicates when blog posts were made. This lets site visitors
navigate your blog by clicking a day that has blog posts.

Blog Workflow
The following table explains the workflow of a blog.
Workflow

Description

See Also

Phase 1

An administrator creates a blog in the
Workarea. During this phase, he assigns
blog categories, creates a blog roll, and
decides how comments are handled.

”Adding a Blog” on
page 347

Phase 2

A developer adds the blog to a Web form
using the blog server control. He then
publishes the form.

The Developer Manual
section “Introduction to
Ektron CMS400.NET
Server Controls” > “Blog
Server Controls”

Phase 3

Ek tron CM S40 0.NET users can add

”Blog Posts” on page 369

blog posts, either from the Workarea or
the Web site.
Depending on the user’s permissions, the
post is either published immediately or
submitted to the blog’s approval chain.
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Workflow

Description

See Also

Phase 4

The blog post is published. Now, site
visitors can view it and possibly add
comments.

”Blog Comments” on
page 377

Depending on the blog’s comment
settings, they either appear immediately
or must be approved first.

The following sections explain using the blog feature in the
Workarea.

• ”Adding a Blog” on page 347
• ”Blog Properties” on page 349
• ”Blog Categories” on page 353
• ”The Blog Roll” on page 358
• ”Language Support” on page 368
• ”Searching Blogs” on page 369
• ”Deleting a Blog” on page 368
• ”Blog Posts” on page 369
• ”Blog Comments” on page 377

Adding a Blog
NOTE

To be able to create a blog , you must have permission to Add Folders on the
blog’s Advanced Permissions screen.

To add a blog, follow these steps.
1. Go to the Workarea’s Content folder.
2. Click the folder in which the blog will reside.
3. Click New > Blog.
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4. The Add a Blog screen appears.

5. Fill out the Properties tab according to the table below.

Field

Description

Blog Name

The name of your blog as it appears in the content folder tree.

Blog Title

The title of your blog as it appears on the Web site.

Visibility

Choose whether the site is private or public.

Comments

Public

Any site visitor can view the blog.

Private

A site visitor must log in to view the blog. This
includes membership and Ek tron CM S40 0.NET
users.

Choose how to handle comments by checking the appropriate boxes. For
more information, see ”Controlling Blog Comments” on page 377.

6. On the Categories tab, add categories to the blog. For more
information on blog Categories, see ”Blog Categories” on
page 353.
7. On the Blog Roll tab, add blog sites that you want blog readers
to visit. For more information on blog rolls, see ”The Blog Roll”
on page 358.
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IMPORTANT!

See ”Editing a Blog’s Properties vs. Adding a Blog” on page 349 for additional
properties that are only available when editing a blog’s properties.

Blog Properties
NOTE

To be able to edit blog properties, you must have permission to Edit Folders on
the blog’s Advanced Permissions screen.

By clicking the blog properties button ( ), you can change the
following groups of information about a blog.

• ”Editing a Blog’s Properties vs. Adding a Blog” on page 349
• ”Blog Folder Properties” on page 351
• ”Metadata” on page 352
• ”Blog Categories” on page 353
• ”Web Alerts” on page 357
• ”The Blog Roll” on page 358
• ”Permissions and Approvals” on page 366
• ”Purge History” on page 367

Editing a Blog’s Properties vs. Adding a Blog
When you edit a blog’s properties and settings, more properties
and settings are available than when you created it. This is done to
save time when adding multiple blogs to a site.
The table below shows which properties or settings are available
when adding and editing a blog.

Blog Properties and Settings Availability
Property or Setting

Available When
Adding a Blog

Available When
Editing a Blog

Visibility

Blog Name
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Property or Setting

Available When
Adding a Blog

Available When
Editing a Blog

Blog Title

Tagline

# of Visible Posts

Comment Control

Update Service

Style sheet filename for this folder

Template filename for this folder

Dynamic Replication

Smart Forms

Metadata

Categories

Web Alerts

Blog Roll

Permissions

Approval Chain
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Blog Folder Properties
The following table shows the fields on the Blog’s Properties tab.
To edit these properties

- from the Workarea, navigate to the blog folder, click View >
Folder Properties, then the Edit Properties button (

).

- from the Web site, log in, navigate to the blog, right click the
mouse, and select Properties
When you are finished, click Save (

).

Field

Description

Visibility

Choose whether the site is a private blog or public.

Blog Name
Blog Title

Public

Anyone who visits the site is able to view the blog.

Private

A site visitor must log into the site to be able to
view the blog. This could include membership
users, CMS400 users or both.

The name of your blog as it appears in the content folder tree.
The title of your blog as it appears on the Web site blog. It only appears if the
ShowHeader blog server control property is set to true.

ID

The ID number of the blog. This number is assigned by E k t r o n C M S 4 0 0. NE T
and cannot be changed.
Note: ID only appears when viewing the Properties screen. It does not appear
while editing.

Tagline

A line of additional information that describes the blog. It appears below the
title if the ShowHeader blog server control property is set to true.
For example, the title of a blog is “John’s Blog Page.” The tag line could be “A
place to learn about John's past, present, future, and his current state of mind!”
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Field

Description

# Posts Visible

The number of posts visible on the blog page. If the number of posts exceeds
this number, only this many of the most recent posts appear.
For example, if this property is set to 10 and you add 11 posts, only the ten
most recent posts appear.
This number can be from 1 to 999.
If you leave this field blank, all posts made during the current day are visible.

Comments

Choose how to handle comments by checking the appropriate boxes. For
more information, see ”Controlling Blog Comments” on page 377.

Update Service

Enter a service that notifies a blog search site when blog posts are added to
your blog site. These blog search sites allow Web users to search content
contained in blogs around the world.
To use this feature, check the Notify blog search engines of new posts box
and enter a path to a search site. An example path is: http://
rpc.technorati.com/rpc/ping.

Style sheet
filename for
this folder.

If you want to provide a custom style sheet for the blog, enter the path to it
relative to the site root. For example, WorkArea/csslib/
my_custom_blogs.css.
Leave this field blank to inherit the default style sheet, blogs.css, located in
Workarea/csslib. You can customize the default style sheet but your
modifications will get overwritten when you upgrade Ek tr on CMS 400 .NET .

Page
Templates

Lets you specify one or more templates for content in this folder. For more
information, see the E k t r o n C M S 4 0 0 . N E T Administrator manual section
“Managing HTML Content” > “Creating/Updating Templates.”

Dynamic
Replication:

Determines whether content in this folder is updated when Dynamic
Replication is run.

Replicate
Folder
Contents

See Also: E kt r o n C M S 4 0 0. NE T Administrator manual section “Site
Replication” > “Dynamic Replication”

Metadata
There is no difference when working with Metadata for blogs or
folders. For more information, see ”Adding or Editing Metadata” on
page 71.
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Blog Categories
Categories make it easier for site visitors scanning a blog page find
posts that interest them. Here’s how they work.
1. The creator of a blog post assigns one or more categories to it.
2. When the post is published, a list of categories assigned to all
posts appears in the right column.
3. A site visitor clicks any category and see all posts relating to it.
For example, a blog’s categories are Music, Sports, and Art. A user
creates a new blog post about his favorite band, Ektronica, and
assigns the music category to the post.
When a site visitor views the blog page, he looks under Categories
and clicks Music. A list of music-related posts appears, including
the post about Ektronica.

A category can only be assigned to the blog in which it is created - it cannot be used with other blogs. With each new blog, you need
to create new categories. This gives you the flexibility to tailor
unique categories to each blog.

Adding Blog Categories
To add a blog category, follow these steps.
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1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
3. Click the Edit Properties button (

).

4. Click the Categories tab, then click Add New Category.

5. A text box appears.
6. Enter the category.
NOTE

Add as many categories as you need by clicking Add New Categories.

7. Click Save (

).

Editing Blog Categories
To edit a blog category, follow these steps:
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
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NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
3. Click the Edit Properties button (

).

4. Click the Categories tab.
5. Change the information in the text box for the category you
want to edit.
6. Click Save (
NOTE

).

You can edit several categories before clicking Save.

Removing Blog Categories
There are two ways to remove blog categories.

• Remove the last link that was added.
• Remove any link in the list.
Each task is explained below.
Removing the Last Blog Category
Follow these steps to remove the last blog category on the page.
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
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3. Click the Edit Properties button (

).

4. Click the Categories tab.
5. Click Remove Last Category.

6. A dialog box appears.

7. Click OK to remove the last category.
NOTE

You can continue to remove categories at the end of the list by clicking the
Remove Last Category link.

8. Click Save (

).

Removing a Blog Category
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
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3. Click the Edit Properties button (

).

4. Click the Categories tab.
5. Click Remove next to the category to be removed.

6. A dialog box appears.

7. Click OK if you want to remove the category.
You can continue to remove categories from the list by clicking the Remove link
next to each category.

8. Click Save (

).

Web Alerts
Web Alerts notify users when a blog post is published. This feature
is explained in the Administrator Manual Section “Web Alert
Feature” > “Assigning Web Alert Information to Folders and
Content.”
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Smart Forms
Use a Smart Form when you want to create structured blogging.
Structured blogging provides a form for the blogger to fill out
instead of free form writing. For example, you create a blog for
book reviews. You want to make sure that, when someone submits
a review, he provides the following information:

• Book title
• Author
• Date of review
• Review text
For information on working with Smart Forms, see the Ektron
CMS400.NET Administrator Manual section “Managing Content
Folders” > “Smart Forms.”
NOTE

Unlike the Smart Forms you can assign to regular folders, you cannot require the
user to select a Smart Form when creating a new post. It is only an option.

The Blog Roll
The blog roll lets you add a list of Web site links to your blog page.
Think of this as a roll call of blog pages, a list of blogs related to
you or that you want visitors of your blog to also visit. Below is an
example of a blog roll on a Web page.
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Adding a Blog Roll Link
Follow these steps to add a blog roll link.
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
3. Click the Edit Properties button (

).
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4. On the Blog Roll tab, click Add New Roll Link.

5. The Add Blog Roll Link form appears.

6. Fill out the form according to the table below.
Field

Description

Link Name

Describes the link in the blog roll.

URL

The URL of the blog you are adding to the blog roll. It must
begin with http://.

Short Description

Add a short description of the site.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

360

Blogs

Field

Description

Relationship

Enter the relationship of the blog roll link to you or to the site. For
example, brother.
Click Edit for a pop up screen that helps you choose the site's
relationship.

The table below explains each relationship type.
Type of
Relationship

Description

URL

Check this box if the address is owned by the same person or
company.

Friendship

What level of friendship do you have with the person who owns
the site? Choose one.

•
•
•
•

Contact
Acquaintance
Friend
None

Physical

Check this box if you have physically met the person who owns
this blog.

Professional

Does the person who owns this site have a work level
relationship with you.? Select all that apply.

•
•
Geographical

Co-worker
Colleague

Select one.

•
•
•

co-resident
neighbor
none
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Type of
Relationship

Description

Family

If the site owner is family, what is the relationship? Select one.

•
•
•
•
•
•
Romantic

Child
Parent
Sibling
Spouse
Kin
None

What are your feelings toward the owner of the site? Check all
that apply.

•
•
•
•

Muse
Crush
Date
Sweetheart

7. Click Close.
NOTE

Add as many links to the blog boll as you would like. Just click Add a New Roll
Link. To remove a blog roll link, see ”Removing a Blog Roll Link” on page 363.

8. Click Save (

).

Editing a Blog Roll
To edit a blog roll link, follow these steps.
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
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- click Properties.
2. Click View > Folder Properties.
3. Click the Edit Properties button (

).

4. Click the Blog Roll tab.
5. Find the Blog Roll Link for which the information needs to be
edited.
6. Edit the information.
7. Click Save (
NOTE

).

As with adding a blog roll link, you can edit multiple blog roll links before clicking
Save.

Removing a Blog Roll Link
There are two ways to remove blog roll links.

• Remove the last link that was added.
• Remove any link in the list individually.
The steps to perform each task are documented below.
Removing the Last Blog Roll Link
Using this method to remove the last blog link on the page.
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
3. Click the Edit Properties button (

).
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4. Click the Blog Roll tab.
5. Click Remove Last Roll Link.

6. A dialog box appears.

7. Click OK if you want to remove the last blog roll link.
You can continue to remove categories at the end of the list by clicking the
Remove Last Category link.

8. Click Save (

).
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Removing a Blog Roll Link
To remove any blog roll link on the list, follow these steps.
1. In the Workarea,

- navigate to the blog folder.
or
From the Web site
NOTE

To add a blog category from the Web site, you must be logged in.

- right click the blog.
- click Properties.
2. Click View > Folder Properties.
3. Click the Edit Properties button (

).

4. Click the Blog Roll tab.
5. Find the blog roll link to be removed.
6. Click Remove Roll Link above the Link Name to be removed.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

365

Blogs

7. A dialog box appears.

8. Click OK if you want to remove the blog roll link.
Continue to remove categories by clicking the Remove link.

9. Click Save (

).

Permissions and Approvals
Permissions for blogs work like folder permissions. The same
functionality and features are available. For more information on
working with permissions and approvals, see the Administrator
Manual sections “Setting Permissions” and “Setting Approval
Chains.”

Blog Permission/ Approval Table

Function

Permissions that affect this
function when performed from
Web Site

Permissions that affect this
function when performed from
Workarea

View

Published blogs are viewable by any
site visitor

Blog properties standard permission
View-Only

Add

Not available

Blog properties advanced permission
Add Folders

Edit

Not available

Blog properties advanced permission
Edit Folders

Delete

Not available

Blog properties advanced permission
Delete Folders

Blog
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Function

Permissions that affect this
function when performed from
Web Site

Permissions that affect this
function when performed from
Workarea

View

Published posts are viewable by any
site visitor

Blog properties standard permission
View-Only

Add

Not available

Blog properties standard permission Add

Edit

Not available

Blog properties standard permission Edit

Delete

Not available

Blog properties standard permission
Delete

Approve

Not available

User must be member of blog’s approval
chain

Add

Three blog folder properties control
how comments can be submitted
from Web site. See ”Controlling Blog
Comments” on page 377

Blog properties standard permission Add

Edit

Not available

Blog properties standard permission
Read Only

Delete

Not available

Blog properties standard permission
Read Only

Approve

Not available

Blog properties standard permission Edit

Post

Comment

Purge History
Purge History works the same way for blogs as it does for the rest
of the Ektron CMS400.NET. See Also: the Administrator Manual
section “Managing Content” > “Managing Content Folders” >
“Purge History”.
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Language Support
Language Support for blogs and blog posts work the same way as
it does for folders and content. See the Administrator Manual
section “Multi-Language Support” > “Working with Multi-Language
Content” for an explanation on working with multiple languages.

Deleting a Blog
NOTE

To be able to delete a blog , you must have permission to Delete Folders on the
blog’s Advanced Permissions screen.

Deleting a blog removes the blog and all posts, comments, and
quicklinks for the blog.
WARNING!

After a blog is deleted, you cannot retrieve its posts, comments, or quicklinks.

The following steps explain how to delete a blog.
1. In the Workarea, navigate to the blog folder.
Or
From the Web site, right click the blog and click Properties.
NOTE

To delete a blog from the Web site, you must be logged in.

2. Click the Delete > This Blog.
3. A dialog box appears.

4. Click OK if you want to delete the blog.
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Searching Blogs
Searching blogs works the same as searching HTML content. See
the following topics for an explanation of using the Search feature.

• ”Adding Subfolders” on page 55
• ”Searching the Library” on page 121
• The Administrator Manual chapter “Searching Content on the
Web Site”

Blog Posts
For a definition of blog posts, see ”Introduction” on page 343.
From your Web site, only published blog posts are visible. But,
from the Workarea, you can see all blog posts, regardless of
status. Using the Workarea, you can also create, edit, delete, and
archive blog posts the same way you work with content. See Also:
”Managing HTML Content” on page 61.
This section contains the following subtopics.

• ”Blog Posts on the Site” on page 369
• ”Blog Posts in the Workarea” on page 371
• ”Adding a Blog Post” on page 373
• ”Editing a Blog Post” on page 375
• ”Deleting a Blog Post” on page 376

Blog Posts on the Site
You can view published blog posts on the Web site. The following
is an example of one.
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Contained within the blog post are its Title, Content, Comments
Link, Post Time, Date, and Editor Information. Below is a
breakdown of a blog post on a site.
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Item

Description

Title

The headline of the post. Usually what a site
visitor scans through to find a post to read.

Content

The body of the post.

Comments Information

The comments link shows the number in
parentheses of comments for a post . When this
link is clicked, a new page of comments for the
post appears.
Also on the page is a form to add comments about
the post. The comments only appear if a site
visitor has logged in or authentication is not
required for blog comments.

Editor Information

The person who created or last edited the blog
post.

Post Time and Date

The date and time a blog post was created or last
edited.

Blog Posts in the Workarea
Viewing a blog post in the Workarea is similar to viewing content in
the Workarea. Navigate to the folder that contains the blog. Next,
in the View Posts in Blog screen, click the title of the blog post.
Below is an example of a viewing a blog post in the Workarea
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The View Posts in Blog screen shows the following information
about each blog post.
See Also: ”Blog Posts” on page 369; ”Blogs” on page 343

Item

Description

Title

The headline of the post. Usually what a site
visitor scans through to find a post to read.

Comments Information

The comments link shows the number in
parentheses of comments for a post . When this
link is clicked, the View Comments for Post screen
appears.
If a red flag (
) appears next to the comments
icon, they are awaiting approval.

Editor Information

The person who created or last edited the blog
post.
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Item

Description

Post Time and Date

The date and time the blog post was created or
last edited.

Status

The status of the blog post. For example, if the
blog post is checked in, the status is I.
See Also: ”Appendix A: Content Statuses” on
page 648

From this screen, you can perform all functions with a blog post
that you can with content. You can give it a summary, add
metadata, associate a task, assign Web Alerts, etc. You must have
Edit permission for the blog to perform these functions.
WARNING!

You can also add a history comment to the blog post by clicking the Comment tab.
This is not the same as adding a comment to a blog post on a site. When you add
a history comment, it has the same properties as a comment associated with
content.

Adding a Blog Post
NOTE

To be able to add a blog post, you must have Add permission on the blog’s
Standard Permissions screen.

Follow these steps to add a blog post.
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1. In the Workarea, navigate to the blog folder. Click New > Post.
Or
From the Web site, right click the blog then choose New Post.
NOTE

To add a blog post from the Web site, you must be logged in.

2. When the Add Content screen appears, use the editor to create
the blog post. You create a blog post the same way you create
content. See Also: ”Adding Content” on page 45.
IMPORTANT!

If you are using categories or tags, they can be assigned to a blog post by clicking
the Summary tab and choosing a category. For more information on categories,
see ”Blog Categories” on page 353. For more information on Tags, see ”Tags on
the Summary Page” on page 375.

3. If the user creating the post is a member of the blog’s approval
chain, it is published immediately. If not, it is surrounded by a
yellow border, and a member of the approval chain must
approve it before it can appear on the Web site. (For more
information on working with permissions and approvals, see
the Administrator Manual section “Setting Approval Chains.”)

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

374

Blogs

4. Once the post is published, it appears within the blog on the
Web site.

Tags on the Summary Page
You can add tags to a blog post to further define information about
the post for blog search engines. For example, you create a blog
post about your favorite band, Ektronica, and enter the following
tags: Music, Guitars, Rock & Roll.
When a person visits a blog search site and searches for Rock &
Roll music, your blog post appears. Some blog search sites have a
page specifically for searching blog tags.

Editing a Blog Post
NOTE

To be able to edit a blog post, you must have Edit permission on the blog’s
Standard Permissions screen.

Follow these steps to edit a blog post.
IMPORTANT!

If another editor changes a blog post, the posting information reflects the new
editor, the date, and the time the information was changed. This is important to
remember if you want the original person who posted the blog to get credit for the
post.

1. In the Workarea, navigate to the blog folder.
Or
From the Web site, right click the blog then choose Properties.
Next, choose the post.
NOTE

To add a blog post from the Web site, you must be logged in.

2. Click the blog post title you want to edit.
3. Click the Edit button (

).

4. Change the blog post.
Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

375

Blogs

5. When the blog is published, the changes appear in the blog
post on the Web site.

Approving a Blog Post
If someone who is not a member of the blog’s approval chain
creates or edits a blog post, its status is set to Submitted. It will
only appear on the Web site after a member of the chain approves
it. While its status is Submitted, it has yellow border on the View
Posts in blog screen.
To approve a blog post, see ”Approving/Declining Content” on
page 81.

Deleting a Blog Post
NOTE

To be able to delete a blog post, you must have Delete permission on the blog’s
Standard Permissions screen.

The following steps explain how to delete a blog post.
1. In the Workarea, navigate to the blog folder.
Or
From the Web site, right click the blog then choose Properties.
Next, choose the post.
NOTE

To delete a blog post from the Web site, you must be logged in.

2. From the menu, click the Delete > Posts.
3. The Delete Blog Post screen appears.

4. Click the check box next to each post you want to delete. To
select all posts, click the check box next to Title.
5. Click the Delete Contents button (

).

6. A dialog box appears.
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7. Click OK to delete the selected posts.

Blog Comments
WARNING!

Do not confuse blog comments with history comments. You can add a history
comment to the blog post by clicking the Comment tab. This is not the same as
adding a comment to a blog post on a site. When you add a history comment, it
has the same properties as a comment associated with content.

Blog comments allow site visitors to interact with a blog by adding
their thoughts about a blog post. The blog administrator controls
commenting by deciding who can add comments and if they
require approval for publication.
See Also:

• ”Controlling Blog Comments” on page 377
• ”Comments on the Site” on page 380
• ”Comments in the Workarea” on page 382

Controlling Blog Comments
Ektron CMS400.NET provides three properties for controlling
comments. Use the Blog Properties screen to set them. See Also:
”Blog Properties” on page 349. The following table describes these
properties.
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Field

Description

Enable Comments

Allows user in Workarea and site visitor to add blog comments. Also
displays comments on site and in Workarea.
Note: A member of the Administrators group can always add
comments, regardless of how this checkbox is set.
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Field

Description

Moderate Comments

Determines if comments must be approved before they appear on
site.
If this field is checked, only users with permission to edit the post can
approve comments (see illustration of this permission below).

If users without this permission add comments, they only appear on
the Web site after being approved by someone with permission to
edit the post.
If someone has edit post permission and authenticates before
submitting a comment, it is approved automatically.
Appearance of Unapproved Comments
On the Workarea’s View Posts in Blog screen, an unapproved
comment is indicated by a red flag .

On the View Comments for Post screen, an unapproved comment is
indicated by a yellow border.
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Field

Description

Require Authentication

Determines if a user must be authenticated (that is, logged in as a
CMS400 user or membership user) to add comments via the Web
site.

Comments by default are fully controlled. This means they are
enabled, must be approved, and a site visitor must be
authenticated to create them.
If comments are enabled but not moderated, any site visitor can
add a comment. If you don’t want censorship, this is the way to go.
WARNING!

While you can delete a comment at any time, if comments are not moderated,
they appear on your site as soon as a site visitor submits them.

However, to make sure comments on your site meet certain
criteria, moderate them.
The following topics are explained in this section.

• ”Comments on the Site” on page 380
• ”Comments in the Workarea” on page 382

Comments on the Site
On the site, comments for a blog post appear when one of the
following blog post items is clicked:

• the Comments link
• the Title of the blog post
The comment page contains the original post, any comments that
have been added, and a form to post new comments. Depending
on how the page is designed, the calendar and blog roll can also
appear.
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The Comment Form
NOTE

See ”Controlling Blog Comments” on page 377 to learn about how an
administrator determines if and by whom comments can be submitted.

Site visitors, regular users, and Membership users can add
comments by filling out the form on the comments page. The form
has five fields.
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Field

Description

Name

The person submitting the comment. This
information is required.

Email

The email address of the person submitting the
comment. This information is required.

URL

A URL for the person’s web site.

Comment Section

A text area to insert comments about the post.

Post Comment Button

Post a comment by clicking this button.
Depending on the comment’s settings, it either
posts immediately or is submitted for approval. See
Also: ”Controlling Blog Comments” on page 377

Comments in the Workarea
In the Workarea, you can add, view, approve, edit, and delete
comments for a blog post.
The comment link (illustrated below) indicates the number of
comments. To work with comments, navigate to the blog folder and
click the comment link next to a blog post.
.

This leads you to View Comments screen. Here, you can view
approve, edit, delete, and add new comments.
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NOTE

To learn about recognizing unapproved comments and approving them, see
”Controlling Blog Comments” on page 377.

See Also:

• ”Adding a Comment” on page 383
• ”Editing a Comment” on page 384
• ”Deleting a Comment” on page 385
• ”Approving a Comment” on page 385
Adding a Comment
NOTE

To be able to add a comment, you must have Add permission on the blog’s
Standard Permissions screen.

To add a blog post comment from the Workarea, follow these
steps.
1. From the Content area, navigate to the blog.
2. Click the Comments icon to the left of the post that you want to
comment on.
3. Click New > Comment.
4. The Add Comment screen appears.
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For a description of the fields on this screen, see ”The Comment
Form” on page 381.
Note that Add Comment screen provides an additional field, State.
This field lets the submitting user set the comment’s state to
approved or pending. Approved comments appear on the site
immediately. Pending comments must be approved before they
appear.
To learn about the approval process for pending comments, see
”Moderate Comments” on page 379.

Editing a Comment
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1. From the Content area, navigate to the blog.
2. Click the Comments icon to the left of the post whose comment
you want to edit.
3. Locate the comment you want to edit.
4. Click edit.
5. The Edit Comment screen appears.
For a description of the fields on this screen, see ”The Comment
Form” on page 381.
Note that Edit Comment screen provides an additional field, State.
This field lets the submitting user set the comment’s state to
approved or pending. Approved comments appear on the site
immediately. Pending comments must be approved before they
appear.
To learn about the approval process for pending comments, see
”Moderate Comments” on page 379.

Deleting a Comment
Once a comment is deleted, you cannot retrieve it.
1. From the Content area, navigate to the blog.
2. Click the Comments icon to the left of the post whose comment
you want to delete.
3. Click delete.
4. A dialog box appears:

Click OK to delete the comment.

Approving a Comment
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Comments can require approval if

• they are submitted from the Web site and Moderate
Comments is checked in the blog’s folder properties

• a user submits the comment from the Workarea set its state to
Pending
Only users with permission to edit content (posts) within the blog
folder can approve comments. To learn about the approval process
for pending comments, see ”Moderate Comments” on page 379.
To approve a comment, follow these steps.
1. From the Content area, navigate to the blog.
2. Click the Comments icon to the left of the post whose comment
you want to approve. (Unapproved comments are indicated by
a red flag (

).

3. Click approve.
4. The comment’s status changes to approved.
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The Personalization feature lets a signed-in (typically membership)
user determine a page’s layout and content. The user can
customize the page, displaying whatever interests him in an
arrangement of his own design.
Examples of content that might appear on a personalized page are
frequently-updated information, such as news stories, sports
scores, a calendar, and stock market data.
A user gets his personalized view of the customized page after
logging into any computer. The customization is tied to the user,
not a specific computer.
IMPORTANT!

The Personalization feature requires Internet Explorer 5 or higher. You cannot use
other browsers.

The following topics explain personalization in more detail.

• ”Types of Content that Can Be Personalized” on page 387
• ”Which Web Pages Can be Personalized” on page 388
• ”Personalization and Permissions” on page 388
• ”Layout of a Personalization Page” on page 388
• ”Personalizing a Web Page” on page 389
• ”The Personalization Menu” on page 390
• ”Editing Sequence” on page 391

Types of Content that Can Be Personalized
• Content
• Calendars
• Collections
• Blogs
• HTML Forms
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• List Summary
• Contentlist
• Discussion Forum
NOTE

Assets cannot be personalized.

Which Web Pages Can be Personalized
Your administrator will tell which Web pages you can personalize.
Personalization can be enabled on any number of pages.
In the sample Web site provided with Ektron CMS400.NET, the
and http://localhost/
cms400demo/mypageadvance.aspx pages demonstrate how
personalization may be implemented.

http://localhost/cms400demo/mypage.aspx

Personalization and Permissions
To learn about how permissions affect your ability to personalize,
see the Ektron CMS400.NET Administrator Manual section
“Personalization Feature.”

Layout of a Personalization Page
A Personalization page consists of one or more Web Part Zones.
Each zone can contain one or more content items. You select the
content you wants to see in each zone.
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Personalizing a Web Page
Your system administrator gives you permission to personalize a
Web page. Several permission levels are available (listed below).
You may have any combination of these permissions.

• moving content among zones
• editing a content item
• adding new content
• globally changing the page. So, anyone visiting the page sees
your content and arrangement.
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NOTE

While the first three permissions affect your ability to personalize a page, the last
one lets you design a page that anyone browsing to it will see.

If you have any permission, you can also perform these actions on
a personalization page.

• remove content from a zone temporarily (close)
• remove content from a zone permanently (delete)
• suppress content from a zone (minimize)
These tasks are explained in more detail below.

The Personalization Menu
The top right corner of any content item contains a menu of options
you can perform on it (circled below).

The options change depending your permissions, your mode (for
example, Add Content mode), and the current state of the content.
Also, each content item has its own menu. So, if a Web part zone
contains three items, you see three menus, one in the top right
corner of each item.
The following table describes Personalization menu options.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

390

Personalizing a Web Page

Button

Name

Description

For more information, see

Minimize

In personalization mode, only display the
content title.

”Minimizing a Content Item” on
page 397

To a site visitor, suppress the content.
Restore

Undo minimize.

”Minimizing a Content Item” on
page 397

Close

Removes content item from its zone and
places it in the page catalog. From the
page catalog, the content item can be
moved to any Web Part Zone.

”To remove a content item from its
zone, click the close button (circled
below).” on page 392

See Also: ”The Page Catalog” on
page 399
Delete

Remove content item from its Web part
zone.

”Deleting Content” on page 397

Only appears for content you added.
Edit

•

replace with other content of the
same type

•

move content item to different Web
part zone

•

change its width and height

”Editing Content” on page 393

Editing Sequence
1. Access the Web page that lets you personalize. Your system
administrator tells you how to access this.
2. If you have permission to change the page for unauthenticated
users, the Personalization For box appears.
Otherwise, skip to Step 3.
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Use this box to decide if your page customization applies to
just yourself (Current User) or all site visitors who do not sign
in (Public Users).
3. Click Personalize.
4. The page refreshes, and you see its Web part zones.

• If you have permission to move content, you can do that now.
See Also: ”Moving Content” on page 392

• If you have permission to edit content, you can do that now.
See Also: ”Editing Content” on page 393

• If you have permission to add content, click Add Content. The
screen refreshes, and a new area appears that lets you add
content. See Also: ”Adding Content” on page 395

• You can delete any content item that you added. See ”Deleting
Content” on page 397.

• To suppress the display of a content item but leave it in its
zone, click its minimize button. To restore the content item,
click the restore button. See Also: ”Minimizing a Content Item”
on page 397

• To remove a content item from its zone, click the close button
(circled below).

A closed item is placed in the Page Catalog. If your Web
administrator places the Page Catalog on a personalization
page, you can later move the content from the Page Catalog to
any zone. See Also: ”The Page Catalog” on page 399

• At any time, you can restore the page to the original layout and
content using Reset To Default.

Moving Content
You can move content to an empty zone or one with content. If you
do the latter, the new content appears at the top of the zone, and
existing content in the zone is pushed down.
To move content, follow these steps.
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1. Go to the personalization Web page. Your system administrator
will tell you how to find it.
In the sample database provided with Ektron CMS400.NET, the
page is http://localhost/cms400demo/mypage.aspx.
2. Click Personalize to enter personalization mode.
3. Move the cursor to the left of a content item’s personalization
menu (illustrated below).

4. The cursor changes to a four-headed arrow.
5. Drag the content to a different Web part zone.

Editing Content
Editing allows you to do the following to a content item.

• replace it with another item of the same type
• move it to a different Web part zone
• change its width and height
Editing does not allow you to change the content of any item.
To edit content, follow these steps.
1. Go to the personalization Web page. Your system administrator
will tell you how to find it.
In the sample database provided with Ektron CMS400.NET, the
page is http://localhost/cms400demo/mypage.aspx.
2. Click Personalize to enter personalization mode.
3. The screen refreshes. If you have edit permission, edit
appears on each content item’s personalization menu (circled
below).
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4. Click edit next to any content item.
5. The editor zone appears. Your system administrator
determines its location on the page.
The fields in the editor zone vary depending on the type of
content you are working with.

6. You can replace the content item with another of the same
type. In the above illustration, you can replace the content
block “Home.”
To do so, click the button to the right of the title. When you do, a
popup window prompts you to select a different item of the
same type.
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NOTE

You cannot select another type of item. If needed, you can delete this content item
and add a different type of item in its place.

7. If a Zone dropdown list appears in the Editor Zone, you can
use it to move the selected item to another zone.

Adding Content
When you enter Add Content mode, a new screen zone appears,
displaying content you can add to the page. Your system
administrator determines which content items appear.
To add content, follow these steps.
1. Go to the personalization Web page. Your system administrator
tells you how to find it.
In the sample database provided with Ektron CMS400.NET, the
page is http://localhost/cms400demo/mypage.aspx.
2. Click Personalize to enter personalization mode.
3. The screen refreshes. If you have add permission, Add
Content appears below the Personalization Manager (see
below).
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4. An add content zone appears. Your system administrator
determines its location on the page.
Below is the add content zone on the sample page.

In this example, the administrator provided three categories of
content, and each category has several items. When you
select a category, its items appear below.
5. Select the items you want to display.
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6. Select the zone in which you want to place them.
7. Click the Add button.
8. When you do not need to add more content, click Done Add
Content.

Deleting Content
You can only delete content that you added. (See ”Adding Content”
on page 395) When you delete content, you remove a version of it
from its Web part zone. But, if it exists in another location on the
same page or on any other page, it remains there. And, you can
still add it to any Web part zone.
To delete content, follow these steps.
1. Go to the personalization Web page. Your system administrator
will instruct you on how to find it.
In the sample database provided with Ektron CMS400.NET, the
page is http://localhost/cms400demo/mypage.aspx.
2. Click Personalize to enter personalization mode.
3. A delete button appears on the personalization menu for any
content item you added to the page. See illustration below.

4. To remove that item from that Web part zone, click the delete
button.
5. A warning message appears. Click OK.

Minimizing a Content Item
There are two reasons for minimizing content:

• You want to reduce the clutter while working on a page in
personalization mode. When you minimize, only the title and
menu appear in the zone.
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In this case, you would restore content to full size when you
finish.

• You want to suppress the content for anyone visiting the page.
For example, you are customizing a page for all site visitors,
and want to temporarily hide a content item.
To minimize a content item, click the minimize button on the
personalization menu (circled below).
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After you minimize, the button changes to a restore button (circled
below). Click it to restore the content.

The Page Catalog
If your Webmaster has placed a Page Catalog on your
personalization page, it only appears after you enter Add Content
mode (click Personalize > Add Content). The Page Catalog looks
something like the following.
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You can do two things from the catalog area.

• Add to any Web Part Zone items that have been deleted from
other Web Part Zones.

• Add a type of content to any Web part zone. As you can see
from the illustration above, you can add content, a calendar, a
collection, a blog, etc.
After you add the content type, click Done Add Content. Then,
within that content area, click edit. A new screen area appears.
Use that area to define the content.
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Web Site Navigation Aids
Working with Collections

A collection is a list of content links offered to the readers of a Web
page. In the following illustration, the circled content is an example
of a collection on a Web page.

You can also use a collection to display listings such as job
postings, press releases, and knowledge base articles. The
following graphic illustrates a collection on the landing page of
Ektron’s Knowledge Base.
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This section explains how to create collections. Your system
administrator then creates or updates a Web page to display the
collections using the ecmCollection function or server control.
NOTE

Your system administrator must assign to you permission to work with collections.
For details, see the Collections chapter of the Ektron CMS400.NET Administrator
Manual.

This section explains how to find, create, and manage collections
through the following subtopics.

• ”Finding Collections” on page 402
• ”Viewing a Collection” on page 405
• ”Creating a Collection” on page 407
• ”Editing Content in a Collection” on page 414
• ”Reordering Collections List” on page 415
• ”Editing Collection Information” on page 416
• ”Deleting a Collection” on page 416
• ”Working with Collections in a Multi-Language System” on
page 417

• ”Comparison of Collections, Menus, and the List Summary
Features” on page 418

Finding Collections
Every collection is assigned to a folder. To find the collections
assigned to any folder, navigate to it and click the Collection button
Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

402

Working with Collections

( ). For more information, see ”Finding a Collection by
Navigating to its Content Folder” on page 403.
Since collections can be assigned to any content folder, the
Modules folder provides a central Collections folder, which displays
all collections, regardless of their content folder. For more
information, see ”Finding a Collection Using the Collections Folder”
on page 404.

Finding a Collection by Navigating to its Content Folder
To access collections for a content folder, follow these steps.
1. Click the content folder that contains the collection.
2. If you are using Ektron CMS400.NET’s multi-language support
features, select the language by clicking View > Language.
See Also: ”Working with Collections in a Multi-Language
System” on page 417
3. Click View > Collections.
4. The View Collections screen appears.

The screen displays each collection created for the folder. The
following table explains each column.
Column

Description

Title

The title assigned to the collection by the creator.

ID

The ID assigned to the collection by Ektron
CMS400.NET. This number is used to store and retrieve
the data to/from the database.

Date
Modified

When the collection was last edited.
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Column

Description

URL

The default template used to display the content.

To learn more about a collection and perform tasks on it, proceed
to ”Viewing a Collection” on page 405.

Finding a Collection Using the Collections Folder
To view all collections in all content folders, follow these steps.
1. From the Workarea, click Modules > Collections.
2. The Collections Report screen appears.

3. The screen has four columns, described below.
Column Title

Description

Title

Title given to collection by user who created, or last edited, it.

ID

ID number assigned by Ektron CMS400.NET. (Developers use this number to
reference the collection in ecmCollection custom function.)

Description

Description given to collection by user who created, or last edited, it.

Path

Folder location of the collection.

You can click any collection to view information about it and
perform tasks on it. See ”Viewing a Collection” on page 405.
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You can also add a new collection. See ”Creating a Collection” on
page 407

Viewing a Collection
To view a collection, follow these steps.
1. Select a collection using the procedure described in ”Finding a
Collection by Navigating to its Content Folder” on page 403 or
”Finding a Collection Using the Collections Folder” on
page 404.
2. The View Collection screen appears.
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The screen displays each item in the collection. To learn more
about a collection, click More Info. When you do, the lower section
of the screen displays the following information about the
collection.

• title
• description
• ID number
• template
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• last user who edited it
• last date when it was edited
• date it was created
• whether or not the content folder’s subfolders can be included
• for each content item in the collection
- a link to the content (click this to view and edit the content)
- ID number
- quicklink

Collections Toolbar
The following table describes the collection toolbar buttons.
Button

Name

Description

More Information

Add

Add new collection or add items to a
collection.

”Creating a Collection”
on page 407

Remove

Remove items from a collection.

”Removing Content from
the Collection” on
page 414

Reorder

Reorder items in a collection.

”Reordering Collections
List” on page 415

Edit

Edit collection information.

”Editing Collection
Information” on page 416

Delete

Delete a collection.

”Deleting a Collection” on
page 416

Back

Return to previous screen.

Creating a Collection
Creating a collection involves two steps:

• ”Adding a Collection” on page 408

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

407

Working with Collections

• ”Assigning Content to the Collection” on page 410
The following sections explain each step.
NOTE

This section explains creating a collection in a site that does not support multiple
languages. If you want to create collections in several languages, see ”Working
with Collections in a Multi-Language System” on page 417.

See Also: ”Working with Collections” on page 401

Adding a Collection
To add a new collection, follow these steps.
1. Navigate to the content folder in which you want to create the
collection.
2. If you are using Ektron CMS400.NET’s multi-language support
features, select the language. See Also: ”Working with
Collections in a Multi-Language System” on page 417
3. Click New > Collection.
NOTE

If you access the collection via the Collections folder, you cannot choose the
collection’s folder. It is automatically placed in the Content folder.

4. The Add Collection screen appears.

5. Complete the screen using the following table.
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Field

Description

Title

Assign a unique title to the collection.

Template

Enter the default template for the collection. This template is used to
display the content of the links generated if no template is assigned in the
custom function.
If left blank, the links use their respective Quicklinks.
See Also: ”Default Template vs. Quicklinks” on page 409

Description

Add a more detailed description for the collection.

Include Subfolders

Check if you want to add to the collection content in subfolders of the
content folder.

6. Click the Save button (

).

You can now assign content to the collection. See ”Assigning
Content to the Collection” on page 410.

Default Template vs. Quicklinks
You can specify a template that determines the screen display for a
collection when it is published on a Web page. (See your system
administrator for information about Ektron CMS400.NET templates.)
Or, you can disable the template and, instead, use Quicklinks to
determine the page template. (See Also: ”Quicklinks and Forms”
on page 138)
If you specify a template, all content in the collection uses the
same screen elements other than the specific content. For
example, the page header, footer and information in the right frame
of the screen are all the same. On the other hand, if you use
Quicklinks, every page in the collection uses its original template.
As a result, the surrounding information may change for every
content item in the collection.
Here is an example of links using Quicklinks. Notice that content
uses several templates. As a result, when a user clicks content in
the collection, the screen information around the content changes
according to its template.
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Here is an example of links when using a template named
index.asp. In this case, all pages have the same information
surrounding the content.

To toggle between a default template and Quicklinks, follow these
steps.
1. Access the Edit Collection screen for the collection you want to
edit.
2. Modify the Template field.
3. Click the Save (

) button.

Assigning Content to the Collection
After a collection is created, your next step is to assign content to
it. To do so, follow these steps.
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NOTE

When viewing a Collection on the Web site, the last published version of content
appears. If the content has never been published, nothing appears.

1. Access the collections screen for the content folder in which
you want to add the collection, as described in ”Finding a
Collection by Navigating to its Content Folder” on page 403.
2. Access the View Collection Screen, as described in ”Viewing a
Collection” on page 405.
3. Click the collection to which you want to assign content.

4. The View Collection screen appears.
5. Accept or change the language.

6. Click the Add button (

).

7. The Add Items to Collection screen appears, displaying

• all subfolders within the selected folder (Subfolders are
available if the Include subfolders checkbox was checked for
the collection.)

• content in the selected folder that is not part of the collection.
Note that the file types selection remembers your most recent
choice and can filter which files appear. You can change the
selection if desired.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

411

Working with Collections

8. Check boxes next to content to add to the collection. You can
only add content from the selected folder or its subfolders.
(Subfolders are only available if the Include subfolders
checkbox is checked for the collection.)
Click a subfolder to view its content. To return to the parent
folder, click the folder with the up arrow (
NOTE

).

If you select content from a subfolder, click the Add button to add selected content
to the collection. Navigating between subfolders deselects content.

9. Click the Add button (

).

See Also: ”Creating a Collection” on page 407; ”Working with
Collections” on page 401

Creating New Content for a Collection
You can create new content while adding content links to a
collection. To add content, follow these steps.
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1. Access the View Collections screen for the content folder in
which you want to add the collection, as described in ”Finding a
Collection by Navigating to its Content Folder” on page 403.
2. Access the View Collection Screen for a collection, as
described in ”Viewing a Collection” on page 405.
3. If you are using Ektron CMS400.NET’s multi-language support,
select the language of the collection.
4. Click the Add button (

).

5. The Add Items to Collection screen appears.
6. If your collection includes subfolders and you want to add the
content to one of them, navigate to that subfolder. Otherwise,
proceed to the next step.
7. Click the Add Content button (

).

8. The Add Content screen appears. If you are using Ektron
CMS400.NET’s multi-language support, the content’s language
appears next to the title. The language is derived from the
collection’s language and cannot be changed.

9. Create the content.
NOTE

Refer to ”Adding Content” on page 45 for additional information about creating
new content.

10. Click a workflow option in the Add Content screen.
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11. The Add Content screen closes, and the new content link
appears in the list of links available to the collection.
12. Check off the content you created and other content.

13. Click the Add button (

) to add the content to the collection.

Editing Content in a Collection
After a collection is created, you can add or remove links to and
from it.

Adding Content to the Collection
For information about adding content links to a collection, see
”Assigning Content to the Collection” on page 410.

Removing Content from the Collection
To remove a content link from a collection, follow these steps.
1. Access the collections screen for the content folder in which
you want to add the collection, as described in ”Finding a
Collection by Navigating to its Content Folder” on page 403.
2. Access the View Collection Screen, as described in ”Viewing a
Collection” on page 405.
3. Click the Remove button (

).

4. The Delete Items from Collection screen appears.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

414

Working with Collections

5. Check boxes next to links that you want to delete.

Click Select All to select all boxes.
Click Clear All to remove all check marks.
6. Click the Delete button (

).

Reordering Collections List
After a collection is created, and more than one content item is
assigned to it, you can reorder the collections list. To do so, follow
these steps.
1. Access the collections screen for the content folder in which
you want to add the collection, as described in ”Finding a
Collection by Navigating to its Content Folder” on page 403.
2. Access the View Collection Screen, as described in ”Viewing a
Collection” on page 405.
3. Click the Reorder button (

).

4. The Reorder Collection screen appears.
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5. Click the content whose order you want to change.
6. Click the up or down arrow to move the content in either
direction.
7. Repeat steps five and six until you set the desired order.
8. Click the Update button (

).

Editing Collection Information
To edit information about a collection, follow these steps.
1. Access the collections screen for the content folder in which
you want to add the collection, as described in ”Finding a
Collection by Navigating to its Content Folder” on page 403.
2. Access the View Collection Screen, as described in ”Viewing a
Collection” on page 405.
3. Click the collection whose information you want to change.
4. Change any of the field values. For documentation of the fields,
see ”Complete the screen using the following table.” on
page 408.

Deleting a Collection
When you no longer want a collection, you can delete it. To delete
a collection, follow these steps.
1. Access the collections screen for the content folder in which
you want to add the collection, as described in ”Finding a
Collection by Navigating to its Content Folder” on page 403.
2. Access the View Collection Screen, as described in ”Viewing a
Collection” on page 405.
3. Click the Delete button (

).

4. A confirmation message appears.
5. Click OK to proceed.
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Working with Collections in a Multi-Language
System
In a multi-language Ektron CMS400.NET system, you can create a
language-specific edition of each collection. For example, prior to
the 4.7 Release, the RC International sample site’s products page
had a collection in the default application language (English unless
you change it). From 4.7 on, you can create an edition of a
collection in every enabled language.
When a visitor to your site selects a language then navigates to a
page with a collection, Ektron CMS400.NET displays the collection
in the selected language if available. If not, Ektron CMS400.NET
displays nothing.
NOTE

Note the contrast between the collections and content: if a collection is not
available in the selected language, nothing appears. But if content is not available
in the selected language, content in the default language appears.

When creating a collection for a foreign language, decide if you
want to create

• a foreign edition of an existing collection, or
• a new collection in a foreign language
For example, if you want to provide several versions of a single
page that change depending on the language selected by the user,
see ”Creating a Language-Specific Collection if Another Edition
Exists” on page 417.
On the other hand, if you are creating a collection to appear only
on a foreign language page, and no other edition of the collection
will appear on your site, see ”Creating a Language-Specific
Collection if Another Edition Does Not Exist” on page 418.
You can only add content in the language of a collection. So,
create the content first, then create the collection that links to them.

Creating a Language-Specific Collection if Another Edition
Exists
1. Click the content folder in which your collection exists. The
folder’s contents are displayed.
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2. Click View > Collections.
3. The View Collections screen is displayed.
4. Select the collection that you want to translate.
5. From the Add drop-down list, select the language of the new
collection.
6. Using the Add button ( ), select the content to add to the
collection. Navigate through the folders to the content you want
to add. You can only add content in the selected language.

Creating a Language-Specific Collection if Another Edition
Does Not Exist
1. Navigate to the folder in which you will create the collection.
2. Click View > Collections. The View Collections screen is
displayed.
3. Click the Add button ( ) and enter basic information about
the collection. (This screen is described in ”Creating a
Collection” on page 407.)
4. The View Collections in Folder screen appears. Click the
collection you just created.
5. From the Add drop-down list, select the language of the new
collection.
6. Using the Add button ( ), select the content to add to the
collection. Navigate through the folders to the content you want
to add. You can only add content in the selected language.

Comparison of Collections, Menus, and the List
Summary Features
A menu, a collection, and the ListSummary function are similar in
that they let you add a list of links to a Web page. The following
table compares these features to help you understand which one
would best accommodate your needs for a particular page.
NOTE

To implement these features, the assistance of a developer is required.
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Collection

Menu

X

Display title of all content in
a folder and possibly
subfolders
Display title of selected
content in a folder and
possibly subfolders

X

X

X

Display external hyperlinks
& library assets
Display content summary
(optional)

X

Display additional content
information:

X

•
•
•
•
•
•
•

List Summary

X

comment
last modified date
start date
end date
user who last edited it
ID number
path relative to your
site’s root

Can be multi-leveled (that
is, you can have
submenus)

X
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Working with Menus

Ektron CMS400.NET’s Menu feature lets users create and maintain

a dropdown menu system for your Web site. The menu options can
link to content, library assets, external hyperlinks, and submenus.
Below is a sample menu.

In this example (delivered with Ektron CMS400.NET), the menu
appears when a site visitor moves the cursor over About Us on
the home page.
However, if a content contributor with permission to edit menus
signs in to Ektron CMS400.NET then views the menu, it has
additional options for editing the menu or adding content.

NOTE

For more information on adding content, see ”Adding Content” on page 45. To
learn more about Menu permissions, see the Ektron CMS400.NET
Administrator Manual section “Web Site Navigation Aids” > “Menus.”
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This chapter describes the following aspects of managing menus:

• what they are
• how they can be used
• how to the add, edit, view and delete a them

What’s In This Chapter
The following topics explain Menus.

• ”The Structure of Menus and Menu Items” on page 421
• ”Access to the Menus Feature” on page 422
• ”Adding a New Menu” on page 423
• ”Adding a Menu Item” on page 429
• ”Editing a Menu” on page 438
• ”Editing a Menu Item” on page 440
• ”Viewing a Menu” on page 443
• ”Reordering Menu Items” on page 446
• ”Deleting a Menu” on page 447
• ”Deleting a Menu Item” on page 448
• ”Working with Menus in a Multi-Language System” on
page 449

The Structure of Menus and Menu Items
Menus have the following structure:

• menu - top level structure that is a placeholder for menu items
and submenus. It is assigned to a content folder.
A menu identifies a page template used to display menu
options that are content.

• menu item - the individual options on a menu; can be any of
the following

- content of any type
- library asset
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- external hyperlink (link to a page outside your Web site)
- submenu (a link to another menu. In the illustration below,
the menu on the right is a submenu. It appears when the
user hovers the cursor over Company Profile. The right
arrow indicates a submenu is available.)

Access to the Menus Feature
There are three ways to access the Menus feature:

• the Workarea, by choosing the associated content folder then
clicking View > Menus

• the Workarea, by choosing Modules > Menus
• the Edit Menu option on the sample menu displayed above
If you choose the first or second option, you select a specific menu.
Then, it appears on the View Menu screen. For the third option, the
selected menu appears on the View Menu screen.
From the View Menu screen, you can perform the following actions
on a menu.

• Create a new menu
• Edit its information (for example, the URL and template link)
• Translate it
• Delete it
• Add or remove items
• Change the sequence of menu items
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• Edit menu items
• For submenus
- add /remove items
- change sequence of menu items
- edit menu information
- edit menu items

Managing Menus
Ektron CMS400.NET gives you the flexibility to add, edit, view and
delete a menu. The following sections explain how to do that.

• ”Adding a New Menu” on page 423
• ”Adding a Menu Item” on page 429
• ”Adding New Content to a Menu via Navigation Link on a Web
Page” on page 437

• ”Editing a Menu” on page 438
• ”Editing a Menu Item” on page 440
• ”Viewing a Menu” on page 443
• ”Reordering Menu Items” on page 446
• ”Deleting a Menu” on page 447
• ”Deleting a Menu Item” on page 448
• ”Working with Menus in a Multi-Language System” on
page 449

Adding a New Menu
You can create a menu by navigating to a folder or by choosing
Modules > Menus from the left frame of the Workarea. If you
choose Modules > Menus, you cannot select the menu’s folder -it is automatically assigned to the root folder. In contrast, if you
create a menu after choosing a content folder, it is assigned to the
selected folder.

Adding a Menu via Content Folder
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1. Navigate to a content folder.
2. The current language appears as a flag next to the screen title.
To create the menu in this language, proceed to the next step.
To change the language of the new menu, click View >
Language and select the new language.
3. Click New > Menu.
4. The Add Menu screen appears.

5. At minimum, a menu requires a title. If you want to add more
information, click Advance Settings. When you do, the lower
section of the screen appears as shown below.
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6. Using the following table, complete the fields on the Add Menu
screen.

Fields on the Add/Edit Menu Screen

Field

Description

Title

The name given to the menu by the creator. It appears on the Web
page to indicate the kind of information on the menu.
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Field

Description

Image Link

You can have an image appear next to or instead of the menu title.
For example:

To do this, follow these steps.
Note: Before beginning these steps, the image must reside in the
library. if it does not, add it before proceeding. For more information,
see ”Copying Files to the Library” on page 125.
1.

Click the image icon (

).

2.

The library window opens.

3.

Navigate to the folder that contains the image you want to use.

4.

Click the Insert button (

) to insert it.

Using Image to Replace Title Text
Alternatively, you can have the image replace the menu text, so that
only the image appears to indicate the kind of information on the
menu. To do this, check the Use image instead of a title checkbox.
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Field

Description

URL Link

After you create a menu, your developer links it to text or an image
on a Web page by modifying a page template. When a site visitor
reading that Web page moves the cursor over the text or image, the
menu appears. In the illustration below, the menu appears when the
site visitor moves the cursor over Products.

You can also assign a URL link to a menu, using this field. If you do,
and the user clicks the link text or image, he jumps to the specified
page.
For example, in this field you assign the product landing page,
cms400demo/products.aspx. In the illustration above, if the user
moves the cursor over Products, the assigned menu appears.
However, if the user clicks Products (as indicated by the hand), he
jumps to cms400demo/products.aspx.
Entering the Path to the Landing Page
This path is relative to the site root. For example: /400Demo/
jobs.aspx

This URL path can be a static template path (like the one mentioned
above) or a dynamic path, such as
wellness.aspx?id=40&wellness=Hemophilia
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Field

Description

Template Link

Note: This field applies to content only. It has no effect on other types
of menu items (such as images). Also, this field only affects content
that dynamically references a content block, such as /CMS400Demo/
therapies.aspx?id=84. If the menu option is a template that
includes content (for example, /CMS400Demo/news.aspx), the
template you identify here is ignored.
If you want to apply a template to this menu, enter the template here.
If you do, all content on this menu uses this template when selected
from the menu.
If you do not enter a template here, content on this menu uses the
template specified in its Quicklink.
Overriding the Template Link
You can override the menu template for any content item on this
menu and, instead, use the template specified in its Quicklink. To do
so, follow these steps.
1.

Add all items to the menu. (See ”Adding a Menu Item” on
page 429)

2.

Go to the View Menus option.

3.

Click More Info.

4.

Click the menu item you want to change.

5.

At the Link field, change the value from Menu Template to
Quicklink.

Important! If you created menus prior to upgrading to this version of
Ek tron CM S40 0.NET , those menu items are assigned as
Quicklinks. You cannot change them to template links simply by
entering a template link here. Instead, you must go to each menu
item and change the Link field value from QuickLink to Menu
Template (as illustrated above).
Description

Add a more detailed description for the menu.

Folder
Associations

See the Ek tr on CMS 40 0.NET Administrator Manual section “Menu
Feature” > “Assigning Folders to a Menu.”

6. Click the Save button (

).

With the menu added, you may assign menu items to it. See
”Adding a Menu Item” on page 429.
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Adding a Menu via the Menus Module
1. From the left frame of the Workarea, click Modules > Menus.
2. Click the Add Menu button (

).

3. The Add Menu screen appears.

4. To complete the fields on the Add Menu screen, see ”Fields on
the Add/Edit Menu Screen” on page 425.
With the menu added, you may assign menu items to it. See
”Adding a Menu Item” on page 429.

Adding a Menu Item
Similar to being able to add, edit, view or delete a menu, Ektron
CMS400.NET also allows you to add, edit, view and delete a menu
items. See Also: ”The Structure of Menus and Menu Items” on
page 421

Adding a Menu Item via Content Folder
To add a menu item via a content folder, follow these steps.
1. Navigate to the content folder that contains the menu to which
you want to add items.
2. Click View > Menus.
3. Click the menu that you want to add items to.
4. In the View Language dropdown list, select the language of the
menu. See Also: ”Working with Menus in a Multi-Language
System” on page 449
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5. The View Menu screen opens, displaying the items already on
the menu. Submenus look like a folder with a plus sign to the
left (
).
6. To add a new item to the selected menu or any submenus on it,
move the cursor over the menu item and click Add from the
popup menu.

NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

7. The Add New Item screen appears. Use the table below to
select a type of menu item and follow the steps to add it.

Assign this type of content to
the menu

For details, see

Content

”Adding Content as a Menu Item” on
page 432

Any library asset: images, files,
Quicklinks, hyperlinks to the menu

”Adding a Library Asset as a Menu
Item” on page 434

External hyperlink

”Adding an External Hyperlink as a
Menu Item” on page 434

Submenu to the main menu

”Adding a Submenu as a Menu Item”
on page 435

Adding a Menu Item via Menus Module
To add a menu item via the Menus module, follow these steps.
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1. From the left frame of the Workarea, click Modules > Menus.
2. Click the menu that you want to add a menu item to.
3. In the View Language dropdown list, select the language of the
menu.
4. To add a new item to the selected menu or any submenus on it,
move the cursor over the menu item and click Add from the
popup menu.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

5. The Add New Item screen displays a list of items that you can
add to the menu. Use to the table below to select the type of
menu item and follow the steps to add it.
Menu item type

For more information, see

Content

”Adding Content as a Menu Item” on
page 432

Any library assets: images, files,
Quicklinks, hyperlinks to the menu

”Adding a Library Asset as a Menu Item”
on page 434

External hyperlinks

”Adding an External Hyperlink as a Menu
Item” on page 434

Submenu to the main menu

”Adding a Submenu as a Menu Item” on
page 435

Adding a Menu Item via Navigation Link on a Web Page
1. Log in.
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2. Access the Web page that contains the link to display the
menu.
3. Place the cursor on the hyperlink that causes the menu to
appear.
4. The menu appears.

5. Click Add.
6. The Add Menu screen displays a list of items you can add to
the menu.
7. Use the table below to select the type of menu item and follow
the steps to add that menu item.

Assign this type of content to
the menu

For details, see

Content

”Adding Content as a Menu Item” on
page 432

Any library assets: images, files,
Quicklinks, hyperlinks to the menu

”Adding a Library Asset as a Menu
Item” on page 434

External hyperlinks

”Adding an External Hyperlink as a
Menu Item” on page 434

Submenu to the main menu

”Adding a Submenu as a Menu Item”
on page 435

Adding Content as a Menu Item
To add content as a menu item, follow these steps.
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1. Follow the directions in ”Adding a Menu Item via Content
Folder” on page 429, ”Adding a Menu Item via Menus Module”
on page 430, or ”Adding a Menu Item via Navigation Link on a
Web Page” on page 431.
NOTE

You can only add content that resides in the menu’s content folder or its
subfolders.

2. Click the radio button next to Content Block.
3. Click the Next... button.
4. The Add New item screen appears, listing all content in the
folder (and its subfolders) in which you created the menu.
5. By default, all content is available. To limit your selection to a
type of content (for example, Word documents), click the
content types dropdown and select a type.

6. Content items in the selected folder appear below any
subfolders. You can click any subfolder to display its content.
7. Check all content you want to add from any single screen to the
menu.
WARNING!

If you check items on a screen then proceed to another screen before clicking the
Add button, the items on the first screen are not added to the menu.

8. Click the Add button (

).

9. The View Menu screen reappears, showing the new content.
10. To access the Edit Menu Item screen for the new content,
hover the cursor over the item, then click Edit from the popup
menu.
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NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

11. The Edit Menu Item screen lets you assign additional
information to the menu item, such as the target window. See
”Fields on the Add/Edit Menu Screen” on page 425.
12. Continue to add new items to the menu as needed.

Adding a Library Asset as a Menu Item
To add a library asset as a menu item via a content folder or menus
module, follow these steps.
1. Follow the directions in ”Adding a Menu Item via Content
Folder” on page 429, ”Adding a Menu Item via Menus Module”
on page 430, or ”Adding a Menu Item via Navigation Link on a
Web Page” on page 431.
2. Click the radio button next to Library Asset.
3. Click the Next button.
4. The Add New Item screen appears. Enter a title for the library
asset that will be on the menu.
5. Click Browse Library.
6. The library screen opens.
7. In the right frame, select the type of asset to insert (image,
hyperlink, etc.).
NOTE

To insert assets, the menu’s folder must contain library assets. However, you can
insert library assets from other folders for which you have permission.

8. Select a library asset and click the Insert button (

).

9. The Add New Item screen reappears.
10. Click the Save button (

).

Adding an External Hyperlink as a Menu Item
To add an external hyperlink as a menu item via a content folder or
the Menus module, follow these steps.
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1. Follow the directions in ”Adding a Menu Item via Content
Folder” on page 429, ”Adding a Menu Item via Menus Module”
on page 430, or ”Adding a Menu Item via Navigation Link on a
Web Page” on page 431.
2. Click the circle next to External Hyperlink.
3. Click the Next button.
4. The Add New Item screen is displayed.
5. Complete the fields as needed.
Field

Description

Title

Title of the new external hyperlink menu item.

URL Link

The URL of the external hyperlink. For example,
www.google.com.

6. Click the Save button (
NOTE

).

When adding an External Hyperlink menu item, the URL does not get added to
the library nor is an ID assigned to it. So, when you save the menu item, it is not
added to the CMS database nor can it be retrieved for future use.

Adding a Submenu as a Menu Item
To add a submenu as a menu item via content folder or menus
module, follow these steps.
1. Follow the directions in ”Adding a Menu Item via Content
Folder” on page 429, ”Adding a Menu Item via Menus Module”
on page 430, or ”Adding a Menu Item via Navigation Link on a
Web Page” on page 431.
2. Click the radio button next to Submenu.
3. The Add Menu screen is displayed.
4. Complete the fields using ”Fields on the Add/Edit Menu
Screen” on page 425 as a reference.
5. Click the Save button (

).
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Adding an Item to a Submenu
1. From the left frame of the Workarea, click Modules > Menus.
2. Select the menu.
3. Find the submenu to which you want to add items. (Submenus
have a folder icon (
) next to them.)

4. Move the cursor over the submenu and click Add from the
popup menu.

NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

5. The Add New Item screen opens, displaying items you can
add.
6. Refer to the table below for selecting a menu item and follow
the steps to add it.
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Assign this type of content to
the menu

For details, see

Content

”Adding Content as a Menu Item” on
page 432

Any library asset: images, files,
Quicklinks, hyperlinks to the menu

”Adding a Library Asset as a Menu
Item” on page 434

External hyperlink

”Adding an External Hyperlink as a
Menu Item” on page 434

Submenu to the main menu

”Adding a Submenu as a Menu Item”
on page 435

Adding New Content to a Menu via Navigation Link on a Web Page
NOTE

You can only use this feature after your Web developer has modified a page
template to display the menu. This procedure is described in the Ektron
CMS400.NET Developer Manual section “Custom ASP Functions” > “Menus.”

To add new content to a menu via a navigation link on a Web page,
follow these steps.
1. Access the Web page that contains the link to display the
menu.
2. Place the mouse on the hyperlink that causes the menu to
appear.
3. The menu appears.
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4. Click (

) Add.

5. The Add Menu screen opens, displaying items you can add.
6. Refer to the table below for selecting a menu item and follow
the steps to add it.

Assign this type of content to
the menu

For details, see

Content

”Adding Content as a Menu Item” on
page 432

Any library asset: images, files,
Quicklinks, hyperlinks to the menu

”Adding a Library Asset as a Menu
Item” on page 434

External hyperlink

”Adding an External Hyperlink as a
Menu Item” on page 434

Submenu to the main menu

”Adding a Submenu as a Menu Item”
on page 435

Editing a Menu
You can edit a menu via:

• its content folder
• menus module
• navigation link on a Web page
This section describes each option.

Editing a Menu via its Content Folder
To edit a menu from a content folder, follow these steps.
1. Access the Workarea and navigate to the content folder that
contains the menu.
2. Click View > Menus.
3. Click the menu you want to edit.
4. Move the cursor over the menu that you want to edit.
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5. Click Edit from the popup menu.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

6. The Edit Menu screen is displayed.
7. Change the fields in Edit Menu screen by referencing ”Fields
on the Add/Edit Menu Screen” on page 425.
8. Click the Save button (

).

Editing a Menu via Menus Module
To edit a menu via the Menus Module, follow these steps.
1. From the left frame of the Workarea, click Modules > Menus.
2. Click the menu you want to edit.
3. Move the cursor over the menu that you want to edit.
4. Click Edit from the popup menu.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

5. The Edit Menu screen is displayed.
6. As necessary, update the fields in Edit Menu screen by
referencing ”Fields on the Add/Edit Menu Screen” on
page 425.
7. Click the Save button (

).

Editing a Menu via Navigation Link on a Web Page
To edit a menu via a navigation link on a Web page, follow these
steps.
1. Navigate to the Web page that contains the link to display the
menu.
2. Click the menu link.
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3. The menu appears.

4. Click Edit Menu.
5. The View Menu screen for the menu appears.
6. Move the cursor over the menu that you want to edit.
7. Click Edit from the popup menu.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

8. The Edit Menu screen is displayed.
9. Update the fields by referencing ”Fields on the Add/Edit Menu
Screen” on page 425.
10. Click the Save button (

).

Editing a Menu Item
This section explains how to edit the following types of menu
items:

• content on your Web site
• library asset
• link to an external Web site
• submenu
You can edit a menu item via:

• its content folder
• menus module
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• navigation link on a Web page
See Also: ”Working with Menus” on page 420

Editing a Menu Item via its Content Folder
To edit a menu item from its content folder, follow these steps.
1. Access the Workarea and navigate to the content folder that
contains the menu.
2. Click View > Menus.
3. Click the menu you want to edit.
4. The View Menu screen for that menu appears, listing all menu
items.

5. Move the cursor over the item you want to edit.
6. Click Edit from the popup menu.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

7. To learn about the fields on the screen, see ”Fields on the Add/
Edit Menu Screen” on page 425.
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Editing a Menu Item via Menus Module
To edit a menu via the Menus module, follow these steps.
1. Access the Menu Report screen, as described in ”Viewing a
Menu via the Menus Module” on page 444.
2. Click the menu you want to edit.
3. The View Menu screen for that menu appears, listing all items
on the menu.

4. Move the cursor over the item you want to edit, and click Edit
from the popup menu.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

5. To learn about the fields on the screen, see ”Fields on the Add/
Edit Menu Screen” on page 425.

Editing a Menu Item via Navigation Link on a Web Page
To edit a menu via navigation link on a Web page, follow these
steps.
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1. Access the template where you inserted the link to display the
menu.
2. Click the Menu Navigation link title on the Web page.
3. A menu is displayed along with all menu items on the menu.

4. Click Edit Menu.
5. The View Menu screen appears.
6. Move the cursor over the item you want to edit, and click Edit
from the popup menu.
7. To learn about the fields on the screen, see ”Fields on the Add/
Edit Menu Screen” on page 425.

Viewing a Menu
Just like editing a menu, you can view a menu via

• its content folder
• menus module
• navigation link on a Web page
When viewing a menu via the content or menu folder, you get an
internal view of information entered by menu creator. When
viewing via a navigation link on a Web page, you get an external
view of the menu, as seen by anyone navigating Web site.

View a Menu via its Content Folder
To access a menu via its content folder, follow these steps.
1. Access the Workarea and navigate to the content folder that
contains the menu.
2. Click View > Menus.
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3. The View All Menus screen displays all menus in the folder.

4. Click the menu you want to view.
5. The menu’s options appear.

Viewing a Menu via the Menus Module
To access the menu via the Modules folder, follow these steps.
1. From the left frame of the Workarea, click Modules > Menus.
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2. The Menus Report screen displays all menus.

3. Click the menu you want to view.
4. The menu’s options appear.

View Menus via Navigation Link on a Web Page
To access the menu via a navigation link on a Web page, follow
these steps.
1. Access the Web page on which your Web developer inserted
the link to display the menu.
2. Click the link that launches the menu on the Web page.
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3. A menu is displayed.

For information on how to display a menu on a Web page, refer to
the section on menus in the Developers Manual, and the Ektron
CMS400.NET Administrator Manual sections

• Menu Feature > Permission to Use the Menus Feature
• Menu Feature > Implementation of the Menus Feature

Reordering Menu Items
To rearrange the items on a menu, follow these steps.
1. Navigate to the View Menu screen for the menu that you want
to rearrange. See ”Viewing a Menu” on page 443.
2. Move the cursor over the menu, and click Reorder.
3. The Reorder Items screen appears.

4. Click the item you want to move.
5. Click the up arrow to move it up, or the down arrow to move it
down.
6. When finished, click Save (

).
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Deleting a Menu
Similar to editing and viewing a menu, you can delete a menu via

• its content folder
• menus module
You cannot delete a menu from the navigation link on a Web page.

Deleting a Menu via Content Folder
To delete a menu via its content folder, follow these steps.
1. Access the View Menu screen, as described in ”View a Menu
via its Content Folder” on page 443.
2. Move the cursor over the menu, and click Delete.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

3. A confirmation message is displayed.
4. Click OK to delete the menu.
NOTE

Deleting a menu automatically deletes all menu items associated with it. Do not
confuse the menu link with the item itself. For example, deleting a menu deletes
its links to content but has no effect on the content.

Deleting a Menu via Menus Module
To delete a menu via its menus module, follow these steps.
1. Access the View Menu screen, as described in ”Viewing a
Menu via the Menus Module” on page 444.
2. Move the cursor over the menu, and click Delete.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

3. A confirmation message is displayed.
4. Click OK.
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NOTE

Deleting a menu automatically deletes all menu items associated with it. Do not
confuse the menu link with the item itself. For example, deleting a menu deletes
its links to content but has no effect on the content.

Deleting a Submenu
1. Access the View Menu page, as described in ”Viewing a Menu
via the Menus Module” on page 444.
2. Select the submenu.
3. Move the cursor over the menu, and click Delete.

Deleting a Menu Item
Similar to editing and viewing a menu, you can remove a menu
item from a menu via

• its content folder
• its menu folder
Removing a Menu Item via its Content Folder
1. Access the View Menu screen, as described in ”View a Menu
via its Content Folder” on page 443.
2. Move the cursor over the item.
NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

3. Click Delete.

Removing a Menu Item via Menus Module
1. Access the View Menu screen, as described in ”View a Menu
via its Content Folder” on page 443.
2. Move the cursor over the item.
3. Click Delete.
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NOTE

When moving the cursor to the popup menu, avoid moving across other menus or
options. When you move across another menu or option, it may become selected
instead of the item you want to work with.

Working with Menus in a Multi-Language System
NOTE

For background information about supporting multiple languages on your Web
site, see the Ektron CMS400.NET Administrator manual section

You can create an edition of any menu in every supported
language. When a site visitor selects a language, navigates to a
page that has a menu and clicks the menu link, Ektron
CMS400.NET displays the menu in the selected language if it is
available. If a menu in that language is not available, nothing
appears.
Before creating or translating a menu, it’s a good idea to create or
translate all content that will be on the menu. In this way, you can
link this content to the new menu. However, after creating a menu,
you can add new items to it.

Translating a Menu
To translate a menu into any supported language, follow these
steps. You can navigate to the menu via the Web site or from the
Workarea. Each procedure is described below.
By Navigating the Site
1. Sign on to Ektron CMS400.NET and select the language in
which the menu currently exists.
2. Navigate to the page that has the menu you want to translate.
3. Click the menu and the Edit Menu option.
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4. The View Menu screen appears for the selected menu.
5. From the Add drop-down list, select the language into which
you want to translate the menu.

6. The Add Menu screen appears. Complete the screen for the
menu in the selected language. See ”Fields on the Add/Edit
Menu Screen” on page 425.
7. Click the Save button (

).

8. The View Menu screen reappears. Now, the View In dropdown list displays the menu’s new language.

9. Add items to the menu. See ”Adding a Menu Item” on
page 429. If adding content, you can only insert an item in the
selected language.
10. Later, you can add more menu items, edit them, delete them,
view them, etc. These capabilities are described in this chapter.

By Accessing the Menus Report Screen
1. From the Workarea screen, click Modules > Menus.
2. Click the menu you want to translate.
3. The View Menu screen appears for the selected menu.
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4. From the Add drop-down list, select the language into which
you want to translate the menu.

5. The Add Menu screen appears. Complete the screen for the
menu in the selected language. See ”Fields on the Add/Edit
Menu Screen” on page 425.
6. Click the Save button (

).

7. The View Menu screen reappears. Now, the View In dropdown list displays the menu’s new language.

8. Add items to the menu. See ”Adding a Menu Item” on
page 429. If adding content, you can only insert an item in the
selected language.
Later, you can add more menu items, edit them, delete them, view
them, etc.

Creating a Menu in Any Language
To create a menu in any language, follow these steps.
1. Form the Workarea screen, click Modules > Menus.
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2. From the language drop-down list, select the new menu’s
language.

3. Create the menu. See ”Adding a Menu via the Menus Module”
on page 429.
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Ektron CMS400.NET System
Management
Updating Your User Profile

When a new user is added to an Ektron CMS400.NET Web site,
the administrator sets up a personal profile for him. It contains
information such as password and email address. You can update
some personal profile information when needed. This section
explains how to modify your personal profile.

Viewing Your Profile
Before changing your personal profile, you must view it. To do so,
follow these steps.
1. Access your Workarea.
2. From the lower left frame, click Settings > User Profile.
3. Your user profile appears.
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4. Click the Edit button (

) in the top left corner.

5. The Edit User Information screen appears.

6. The following table explains fields you can edit.
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Field

Description

Password

If desired, enter a new password into this field.
If you change your password, you do not need to log out
then log back in. However, the next time you log in, you
must use the new password.

Confirm Pwd

Confirm your new password by retyping it into this field.

User Language

Select a language in which to view Ektron
CMS400.NET. Click the black down arrow on the right
(circled below) to see a list of choices.

Email Address

Enter a new valid email address. Notification email is
sent to this address unless the Disable E-mail
Notification field is checked.
To understand how email notification operates within the
content workflow, see ”Example of an Approval Chain”
on page 85.
Also, this address identifies the user sending Instant
email. See Also: ”Sending Instant Email” on page 28

Forum Editor

Determines which editor will be used when this user
replies to a Discussion Board.
See Also: The E k t r o n C M S 4 0 0 . N E T Administrator
Manual section “Discussion Boards” > “Using
Discussion Boards on your Web Site”

Disable Email
Notification

Check this box if you do not want to receive notification
email.

Work Page Size
Your system administrator may let you change the work page values. If he does, the
following fields are editable. Otherwise, you can only view the fields.
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Field
Width

Description
If desired, change the width of the screen in which
Ek tr on CMS 40 0.NET appears. The width in pixels

must be between 400 and 2400.
This field accommodates users who have larger
monitors and/or prefer a smaller resolution, such as
1280 x 1024.
Height

If desired, you can change the height of the screen in
which Ektron CMS4 00. NE T appears. The height in
pixels must be between 300 and 1800.
This field accommodates users who have larger
monitors and/or prefer a smaller resolution, such as
1280 x 1024.

Display button text in
the title bar

Check this box if you want any button’s caption text to
appear in the screen title’s bar whenever a user moves
the mouse over the button. Note the word Update,
describing the button, in the illustration below.

If you do not check this box, the screen’s title remains in
the title bar when the user moves the mouse over the
button, as illustrated below.

Landing Page after
login

If you want one page in your Web site to appear after
sign in, enter the URL to that page. You might select a
page that leads to a group of pages that you maintain.
If you don’t know the URL, navigate to the page, go to
the browser address bar and select the text following the
directory in which E k t r o n C M S 4 0 0 . N E T resides. For
example, if the browser address bar says http://
www.ektron.com/customers.aspx?id=945, you would
enter customers.aspx?id=945 here.
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Field

Description

Set smart desktop as
the start location in the
Workarea

If you want the Smart Desktop to appear as soon as you
enter the Workarea, click inside this check box.

See Also: ”Understanding the Smart Desktop” on
page 20
If you leave this check box blank, when you enter the
Workarea, you go to the folder of the content specified
at the Landing Page after login field.

Inherit Task
Permissions From
User Groups

This area indicates your task permissions and if you
inherit them from user groups to which you belong.
For more information, seethe E k t r o n C M S 4 0 0 . N E T
Administrator Manual chapter “Managing Tasks,”
section “Task Permissions.”

User Properties
See “Custom User Properties” in the E k tro n
C MS 4 00 .NE T Administrator Manual.

7. Edit the fields as desired then click the Update button (
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Online Help

Online help provides access to important and useful information
about using Ektron CMS400.NET. Help is provided in two formats:

• online help - accessible from most screens by clicking the help
button ( ), it provides information about the screen you are
currently viewing. Online help is in HTML format, so it opens in
the browser you use to surf the internet.
After viewing a help topic, you can browse to related topics as
well as access a table of contents, index, and search to expand
your quest for information. See Also: ”Accessing Online Help”
on page 458

• online manuals - can be viewed, searched, and printed like a
paper manual. Online manuals are in a PDF format, which
makes it easy to navigate online and print. See Also:
”Accessing Online Manuals” on page 460
Both formats provide the same information. Choose the format that
best suits your needs.

Accessing Online Help
To access online help for any screen, click the help icon (illustrated
below).

When you do, an online help screen appears.
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The following table describes the buttons available on every help
screen.

Button

Description
Moves to prior topic in the help. This refers to the topic
sequence arranged by the help’s author.
Moves to next topic in the help. This refers to the topic
sequence arranged by the help’s author.
Divides the help into two panels.

•

The left panel displays the table of contents. It also
provides buttons for accessing the index and fulltext search.

•

The right panel continues to display help topics.

Highlight the current help topic’s location within the table
of contents.
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Button

Description
Prints current topic

Accessing Online Manuals
To access the help folder, follow these steps.
1. Access the Workarea.
2. From the lower left frame, click Settings.
3. From the top left frame, click Help.

4. The help screen appears in the right frame.

5. Click any link to open the documentation or Web page.
NOTE

Your computer requires an internet connection to access the help page on
Ektron.com.
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eWebEditPro+XML
eWebEditPro+XML is a browser-based, Web content editor
designed for dynamic Web sites. It lets you create and publish your
own Web content in any language supported by the operating
system and your Web site.
More specifically, eWebEditPro+XML lets you perform Web page
editing functions, such as

• copy content from any Windows-based application
• use Microsoft Word to edit Web content
• cut, copy, and paste
• find and replace text
• check spelling
• edit an image
• change font style, size, attributes (bold, italics, underline), and
color

• begin lines with bullets or numbers
• adjust indentation
• right, center, or left justify text and images
• add a bookmark, hyperlink, image, or table
• view your text as WYSIWYG or HTML code
• insert or clean HTML source code
You gain access to these functions either from the toolbar at the
top of the editor window or from a menu that appears when you
right click the mouse inside the editor.

Using eWebEditPro+XML
eWebEditPro+XML is like many other word processing
applications. You type text and then use toolbar buttons (illustrated
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below) and menu options to change the text’s appearance or
perform functions on it, such as spell checking.

To learn more about using eWebEditPro+XML, see these topics.

• ”Creating a Simple Web Page” on page 463
• ”Toolbar Buttons” on page 467
• ”Customizing Your Toolbar” on page 480
• ”The Context Sensitive Menu” on page 489
• ”Using eWebEditPro+XML’s Advanced Features” on page 492
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This section walks you through the process of creating a simple
Web page, using only a few of the many features available. Later
sections explain all of the features and how to use them.

Your Finished Web Page
When you finish this exercise, your simple Web page will look like
this.

Notice that this page has the following elements.

• The second sentence includes bold, italic and underlined text.
• The third sentence includes a hyperlink, text that will jump to
another Web page when the user clicks on it.

• The fourth sentence begins with a bullet.
• The last sentence has some very large (18 point) text.
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Creating a Sample Web Page
To create this page, follow these steps.

Enter the First Two Sentences
1. Open eWebEditPro+XML. (Your Webmaster installs
eWebEditPro+XML on your computer and determines which
fonts and sizes are available. Your system may not match the
example below.)
2. Type the first two sentences.
This is some sample content. You can make text bold,
italic and underlined with the push of a button.
3. Double click the word “bold” to select it. Then, click the Bold
button ( ) to apply bold to the word.
4. Double click the word “italic.” Then, click the Italic button (
apply italic to the word.

) to

5. Double click the word “underlined.” Then, click the underline
button ( ) to underline the word.

Create a Hyperlink
1. Type You can also easily add hyperlinks.
2. Double click the word hyperlinks so that it becomes selected.
3. Click the Hyperlink button (

).

4. The hyperlink dialog box appears.
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5. In the Link field, after http://, enter www.ektron.com.
6. Click OK.
Notice that the word hyperlink now appears in a different color.
When you save this Web page and a user views it, if the user clicks
hyperlink, a new Web page will display Ektron’s home page.
NOTE

If your computer has an internet connection, you can double click the hyperlink to
test it.

Applying a Bullet to a Line of Text
1. Press <Enter> to move the cursor down to the next line.
2. Type You can begin a line with bullets.
3. Click the bullet button (

).

4. Notice that the line is indented and now begins with a bullet.
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Changing the Size of Text
1. Press <Enter> to move the cursor down to the next line.
2. Type Finally, you can change the font to a large size.
3. Select the words large size.
4. Click the down arrow to the right of the font size list. When you
do, the list of available fonts appears.

5. Click 5 (18 pt).
6. Notice that large size is now much larger than the other text.
Congratulations! You have just created your first Web page with
eWebEditPro+XML. You have learned how to apply bold, italic, and
underlining, create a hyperlink, add a bullet to a line, and change
the size of the text.
This sample used only a few of the many features available. The
following sections explain the rest of the details about using the
product.
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This section explains how to use the buttons and drop-down lists
on the toolbar. (The toolbar is the row of buttons across the top of
the editor window, illustrated below.)

The buttons let you perform functions such as cutting and pasting
text, inserting images, and creating tables.
All buttons may not appear. Your Webmaster determines which
buttons appear on your toolbar. Also, you can customize your
toolbar so that it contains only the buttons you use (See
“Customizing Your Toolbar” on page 480).
This section explains

• ”Selecting Text” on page 467
• ”Applying Formatting Attributes to Text” on page 468
• ”Table of Toolbar Buttons and Drop-Down Lists” on page 468

Selecting Text
You select text before performing an action on it, such as copying
it.

• To select all information on a page, press Ctrl+A.
• To select a portion of the information on a page, you have two
choices.

- Hold down the left mouse button and drag the cursor across
the data you want to select.

- Hold down the Shift key and the right arrow key (

) until

the desired data is selected.
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• To select a single word, place the cursor on the word and
double click the mouse.
Selected text has different background and foreground colors, as
illustrated below.

Applying Formatting Attributes to Text
Several buttons apply formatting attributes to text, such as bold
and italics. There are two ways to apply these attributes.

• Enter the text. Then, select the text and press the toolbar
button. The button is now in a “pressed in” condition, and the
text has the formatting attribute.

• Press the toolbar button. Then, begin typing the text. As you
type, the formatting is applied.
To stop applying the formatting, press the button again. This action
changes the button to a “pressed out” condition and terminates the
formatting.

Table of Toolbar Buttons and Drop-Down Lists
The toolbar buttons and drop-down lists on the default toolbar are
explained below.
Five optional toolbars are also available. To display one, place the
cursor on the standard toolbar, right click the mouse, and select it.
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The optional toolbars are explained in these sections.

• ”Form Elements Toolbar” on page 476
• ”Table Elements Toolbar” on page 477
• ”Position Objects Options” on page 475
• ”Text Direction Options” on page 476
• ”Miscellaneous Toolbar” on page 478
NOTE

Button

The Data Designer feature also has a toolbar. For information, see “Using the
Data Designer” on page 177.

Equivalent
Keystroke

Function

For more
information, see

(Internet
Explorer only)

Cut

Ctrl+X

Remove selected text and graphics.
Place that data into temporary memory,
also known as the “clipboard.”
(If you later cut or copy more information
onto the clipboard, the new information
overwrites the original information.)
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Button

Equivalent
Keystroke

Function

For more
information, see

Copy selected text and graphics into
temporary memory. Leave selected data
where it is.

“Copying from Other
Applications” on
page 493

(Internet
Explorer only)

Copy

Ctrl+C

(If you later cut or copy more information
into memory, the original information is
lost.)

Paste

Ctrl+V

Insert the most recently cut or copied text
and graphics at the current cursor
location.
Paste the contents of the clipboard as
plain text. That is, all HTML tags
(including images) are not pasted.

Paste Text

This button is helpful when you want to
eliminate the HTML formatting of the text
being copied.
Replace

Launches the Search and Replace dialog
box. The dialog searches for (and lets
you optionally replace) text that you
specify.

“Finding and
Replacing Text” on
page 494

Find Next

Find next occurrence of the string
entered into the Find What field of the
Search and Replace dialog box.

“Finding and
Replacing Text” on
page 494

Undo

Redo

Spell Check
(manual)

Spell Check
(automatic)

Ctrl+Z

Reverse the most recent action, as if it
never occurred. You can undo as many
actions as you wish.

Ctrl+Y

Reverse the undo action.

Begin spell checker.

“Checking Spelling
Upon Demand” on
page 499

Turn on or off spell check as-you-type
feature.

“Checking Spelling
as You Type” on
page 498
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Button

Equivalent
Keystroke

Function

For more
information, see

Change information about a hyperlink.

“Using Hyperlinks”
on page 603

Remove a hyperlink.

“Removing a
Hyperlink” on
page 608

Insert a library file

”Adding a Library
File to Content” on
page 133

Upload any external files (such as
images) to the server.

”Moving an Image to
the Server” on
page 520

Translate content into another language

Ek tr on
C MS4 00. NE T

(Internet
Explorer only)

Edit Hyperlink

Remove Hyperlink

Library

Upload Files

Translate

Administrator
Manual section
“Multi-Language
Support” > “Working
with Multi-Language
Content” >
“Translating Content”
> “Using Machine
Translation”
Add Comment

Insert a comment into the content

”Adding Comments
to Content” on
page 624

Use the Math Equation editor

”Working with the
Math Expression
Editor” on page 627

Insert a picture.

“Inserting Images”
on page 506

Edit an image.

”Editing Images” on
page 522

Insert or edit a table.

“Introduction to
Tables” on page 554

Mathematical
Expression

Picture

Image Editor

Table
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Button

Equivalent
Keystroke

Function

For more
information, see

Edit content in Microsoft Word.

“Editing in Microsoft
Word” on page 503

Switches to Data Design Mode.

Ek tr on
C MS4 00. NE T

(Internet
Explorer only)

Edit in Microsoft
Word

Data Design Mode

Button only appears when
eWeb Ed i tP ro+ XML configuration
enables the Data Designer feature.

Data Entry Mode

Switches to Data Entry Mode.
Button only appears when
eWeb Ed i tP ro+ XML configuration
enables the Data Designer feature.

View as
WYSIWYG

View as HTML
nbsp

Administrator
Manual section
“Using the Data
Designer”
Ek tr on
C MS4 00. NE T

Administrator
Manual section
“Using the Data
Designer”

Display the page content as WYSIWYG
(What You See Is What You Get).
WYSIWYG is the ability to see in the
editor what will appear when user views
the Web page.
Display the page content as HTML.

“Viewing and Editing
HTML” on page 609

Insert a blank space character.
Although you can add spaces in the
editor using the <space> bar on the
keyboard, those spaces are ignored
when the content is displayed by a
browser.
Insert copyright symbol.

Copyright
Insert registered trademark symbol.
Registered
Trademark
TM

Insert trademark symbol.
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Button

Equivalent
Keystroke

Function

For more
information, see

(Internet
Explorer only)

Insert special characters (such as
and
Special Characters

Remove Style

) from a drop down list.
To view the list, click the black down
arrow.
Remove all style information applied to
selected text. (You apply styles using the
Style dropdown list.) For example
Before
<P class=note>This is initial
content. </P>

After
<P>This is initial content.</P>

Style

Display a list of styles. Users can select
from the list to apply a style to selected
text.
Note that the list can change depending
on the formatting of the selected line.
Your Webmaster determines which styles
are available.

Heading Size

Change the heading size. Your
Webmaster determines which heading
sizes are available.
Change the font style. Your Webmaster
determines which fonts are available.

Font Style

Note: If more than one font appears in a
selection, the browser on the reader’s PC
tries to display text using the first font. If
the browser cannot find that font, it tries
to use the second, etc.

Font
Size

Font Color

Change the font size. Your Webmaster
determines which font sizes are
available.
Change the font color.
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Button

Equivalent
Keystroke

Function

For more
information, see

(Internet
Explorer only)

Change the background color of the text.

Background Color

Note: To remove background color from
selected text, click the Normal button
( ).

Bold

Italic
Strikethrough

Normal

Ctrl+B

Make the text bold.

Ctrl+I

Make the text italic.

Apply strikethrough to selected text. For
example: Here is some text
Remove all formatting from selected text.

Superscript

Make selected text appear smaller and
above text line

Subscript

Make selected text appear smaller and
below text line

Number

Begin the line on which the cursor rests
with a number. If the line above this line
is

•
•

Bullet

Indent

not numbered, assign this line 1
numbered, assign a number one
more than the line above

Begin the line on which the cursor rests
(or all selected lines) with a bullet ( ).
Increase or decrease the current line’s
distance from the left margin.
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Button

Equivalent
Keystroke

Function

For more
information, see

(Internet
Explorer only)

Align paragraph so that it is arranged

•
Left, Center, and Right
Justify

evenly on the left side (uneven on
the right)

•in the center of each line
•evenly on the right side (uneven on
the left)

•

evenly on right and left side

Display a dialog box that shows your
version of eWe bE di tP ro + XML and your
license keys.

About
eWeb Ed it Pr o+X ML

Position Objects Options
These buttons let you absolutely position elements (pictures,
tables, etc.) anywhere on a page.
WARNING!

Button

Some older browsers (for example, Netscape 4) do not display absolutely
positioned elements. Absolute position uses the style attribute. If you use this
feature, the content is not compatible with all browsers.

Function

Position

Lets you move selected table or image anywhere on the screen.

Lock

“Locks” selected table or image at its current screen position. Nothing can move
a locked object.
To move the object, unlock it by clicking this button again.

Move to Front

If two or more images overlay each other, moves the selected image in front of
the others.

Move to Back

If two or more images overlay each other, moves the selected image behind the
others.

Above Text

If text overlays an image, move the image in front of the text.
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Button
Below Text

Function
If an image overlays text, move the text in front of the image.

Text Direction Options
The text direction menu options (
) allow bidirectional editing of text, which is useful for Arabic, Farsi and
Hebrew. The client computer must also support the language.
The text buttons determine the editing direction, while the edit
buttons determine the side of the editor that displays the scroll bar.
For right-to left languages, such as Arabic, Farsi and Hebrew, the
text editing would be “right to left”, and the scroll bar would be on
the left side.
For western European languages, the text editing would be “left to
right”, and the scroll bar would be on the right side.

Button
Left-Right Text

Right-Left Text

Function
Text is entered left to right.

Text is entered right to left.

Left-Right Edit

The vertical scroll bar appears on the
right side of the window.

Right-Left Edit

The vertical scroll bar appears on the left
side of the window.

Form Elements Toolbar
See “Inserting Form Fields” on page 155
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Table Elements Toolbar

Toolbar
button

Description

For more information, see

Insert table

”Introduction to Tables” on page 554

Add row

Inserts a new row below the last one

Add column

Inserts a new column to the right or the right
column

Insert row

Inserts a new row above the current one

Insert column

Inserts a new column to the left of the current one

Insert new cell

Inserts a new cell to the left of the current one

Delete row

Deletes current row

Delete column

Deletes current column

Delete cells

”Deleting a Cell” on page 583

Merge cells

”Merging Two Cells” on page 595

Split cell

”Splitting a Cell” on page 594

Table properties

”Manipulating Your Table’s Format” on page 565

Cell properties

”Working with Table Cells” on page 581
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Miscellaneous Toolbar

Button

Equivalent
Keystroke

Function

For more
information, see

(Internet
Explorer only)

Open local file and copy it into CMS
content.

Open File

While you can open any file type, E kt r o n
CM S40 0. NET ’s editor only works with
.htm and .xml files.
When you open a file into a content
block, the new file replaces any content
currently in the block.
Save CMS content as file on your
computer or network.

Save File

Since E k t r o n C M S 40 0. N E T ’s editor
only works with .htm and .xml files, you
should save the file using one of those
extensions.
Display/hide
Borders

Display or suppress table and cell
borders

Display/hide
Invisible Elements

Display or suppress formatting
characters that do not appear when
content is published
Display a dialog that lets you change the
appearance of the HTML source code

View Preferences

Display a dialog box that shows your
version of eWe bE di tP ro + XML and your
license keys.

About
eWeb Ed it Pr o+X ML

Delete selected content

Delete
Underline

Remove alignment

Ctrl+U

Make the text underlined
Remove alignment settings applied to
selected content
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Button

Equivalent
Keystroke

Function

For more
information, see

Create a bookmark.

“Using Bookmarks”
on page 599

(Internet
Explorer only)

Bookmark

Insert a horizontal line.

Horizontal Line

Print

Select All

Select None

Ctrl+P

Print the editor content.

Ctrl+A

Select all content

Deselect all selected content
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Customizing Your Toolbar

The eWebEditPro+XML toolbar consists of one or more menus.
Each menu has one or more buttons.
You can recognize the beginning of a menu by the double vertical
bars (circled in the illustration).

This sample toolbar has four menus.
Your Webmaster determines

• which menus are available to you
• which buttons appear on each menu, and the sequence in
which they appear initially

• whether or not you are authorized to customize your toolbar. If
you are not authorized, your edits are not saved when you
leave the eWebEditPro+XML screen.
If you are authorized to customize your toolbar, there are several
ways to do so.

• ”Removing Or Adding Menus” on page 481
• ”Removing or Adding Menu Items” on page 482
• ”Restoring Toolbars” on page 485
• ”Rearranging the Menus on a Toolbar” on page 485
• ”Creating a New Menu” on page 485
• ”Moving a Menu Off the Toolbar” on page 487
• ”Changing the Menu’s Orientation” on page 488
Each procedure is explained below.
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Removing Or Adding Menus
To remove or add a menu, follow these steps.
1. Place the cursor on the toolbar.
2. Right click the mouse.
3. A dropdown list appears. It displays all menus available to you
and the Customize option.

NOTE

If Customize does not appear on the menu, you are not authorized to customize
the toolbar.

Menus that are checked appear on your toolbar.
In the above example, the Special Characters, View As,
Format, and Paragraph Format menus appear. The Table,
Position Objects and Text Directions menus, which are not
checked, are available but do not currently appear on the
toolbar.
4. To add a menu to your toolbar that appears on the list but is not
currently checked, place the cursor on the menu name and
click the mouse. A check mark appears, and the menu appears
on the toolbar.
To remove a menu from your toolbar, place the cursor on the
menu name and click the mouse. The check mark disappears,
and the menu no longer appears on the toolbar.
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Removing or Adding Menu Items
1. Place the cursor on the toolbar.
2. Right click the mouse.
3. A dropdown list appears. Click Customize.

NOTE

If Customize does not appear on the menu, you are not authorized to customize
the toolbar.

4. The Toolbar Customization dialog box appears.
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5. Click the menu that you want to edit.
6. Click the Commands tab. A new screen appears.
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Using the Customize Toolbar Dialog Box
The left half of the Commands screen lists the buttons in the
sequence in which they appear on the menu.
The right half of the screen lists available buttons that do not
currently appear on the menu.
To add a button to the toolbar, drag it from the right side of the
screen to the location on the left side where you want it to appear.
(You can also click a button then click <--Add. This action places
the button at the bottom of the list.)
To remove a button from the toolbar, drag it from the left side of the
screen to the right. (You can also click a button then click Remove->.)
The Move Up and Move Down buttons let you to move any button
up or down one slot within the list of buttons.
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Rearranging the Items on a Menu
1. Click the button you want to move
2. Click Move Up and Move Down to move the button up or
down one slot for each click.

Restoring Toolbars
If you remove all toolbars from your menu, and then want to
restore the menus but do not have the Customize menu option,
follow these steps.
1. Place the cursor in the editor.
2. Right click the mouse.
3. A menu appears with a Redisplay toolbars option.
4. Click this option to restore all menus.

Rearranging the Menus on a Toolbar
To move a menu to a different toolbar location, follow these steps.
1. Place the cursor on the double vertical bars that indicate the
beginning of the menu.
2. Click the mouse.
3. Hold down the mouse button and drag the menu to the new
location. You can move the menu anywhere else on the
toolbar.
Note that your Webmaster can define a menu so that it cannot
reside on the same row with another menu. If you move such a
menu, it will not remain on a row with another menu. Instead, it
will move down to the next row.
4. After you place the menu where you want it, release the mouse
button.

Creating a New Menu
1. Place the cursor on the toolbar.
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2. Right click the mouse.
3. A dropdown list appears. Click Customize.

4. The Toolbar Customization dialog box appears.

5. Click New.
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6. A new menu appears on the left side of the window, above the
existing menus. The default name of the new menu is Custom
0.

7. To rename the menu, place the cursor in the field that displays
the new menu and enter the new name.
NOTE

If you click outside the toolbar name field, you cannot later change the menu’s
name.

8. To have the menu appear on your toolbar, click in the small box
to the left of the menu name.
9. Click the Commands tab.
10. Add buttons to the menu, following the procedure described in
“Using the Customize Toolbar Dialog Box” on page 484.

Moving a Menu Off the Toolbar
You can move a menu from the toolbar to anywhere else on the
screen, even if eWebEditPro+XML does not occupy the entire
screen.
You can also change the orientation of a menu that is not on the
toolbar from a horizontal to vertical.
To move a menu, follow these steps.
1. Place the cursor on the double vertical bars that indicate the
beginning of the menu.
2. Click the mouse.
3. Hold down the mouse button and drag the menu to the new
location. You can move the menu anywhere on the screen.
4. After you place the menu where you want it, release the mouse
button.
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Changing the Menu’s Orientation
To change the menu’s orientation, follow these steps.
1. Drag the menu from the toolbar.
2. Move the cursor to the bottom of the menu until it becomes a
double-headed arrow (illustrated below).

3. Drag the cursor to the lower left. As you do, the menu’s
orientation changes from horizontal to vertical (illustrated
below).
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The Context Sensitive Menu

This section explains the functions available on the menu that
appears when you right click the mouse within the
eWebEditPro+XML editor. You can also access this menu by
pressing the application key (

).

Because this menu can change depending on what you are doing,
it is called a context-sensitive menu.

NOTE

A different context-sensitive menu is available when your cursor is within a table.
That menu is described in “The Table Context Sensitive Menu” on page 563.

The following table lists the menu options and where to get more
information on each.
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Menu Option

Lets you

For more information,
see

Menus

View all toolbar menus.

“Using eWebEditPro+XML
without a Mouse” on
page 614

Cut

Remove selected text and graphics.
Place that data into temporary memory.
If you later cut or copy more information
into memory, the information in memory
is lost.

Copy

Copy selected text and graphics into
temporary memory. Leave selected data
where it is. (If you later cut or copy more
information into memory, the original
information is lost.)

Paste

Insert the most recently cut or copied text
and graphics at the current cursor
location.

Paste Text

Paste the contents of the clipboard as
plain text. That is, all HTML tags
(including images) are not pasted.

“Copying from Other
Applications” on page 493

This button is helpful when you want to
eliminate the HTML formatting of the text
being copied.
Select All

Select all information on your page. After
you select it, you can cut it, copy it, etc.

Clean Source

Remove unnecessary HTML tags

“Cleaning Source Code” on
page 611

Hyperlink

Create a link to another Web page or a
spot within the current page

“Using Hyperlinks” on
page 603

Edit Source

Edit your page’s HTML source

“Editing a Section of a
Page” on page 610

Insert Source

Insert HTML source onto the page at the
cursor location.

“Inserting Source” on
page 610
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Menu Option

Lets you

For more information,
see

Check Spelling

Compare words in the editor to Microsoft
WORD spelling list.

“Checking Spelling” on
page 498

View as WYSIWYG/HTML

View and edit your page’s HTML

“Viewing and Editing HTML”
on page 609

Picture

Insert a picture

“Inserting Images” on
page 506
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Using eWebEditPro+XML’s
Advanced Features

Most of eWebEditPro+XML’s features are easy to learn. For
example, to make your text bold, you select the text, and click the
bold button ( ).
However, some of eWebEditPro+XML’s features are more complex.
For example, when creating a table, you must make several
decisions: the number of rows and columns, the size of the border,
the spacing between cells, etc.
The following sections explain eWebEditPro+XML’s more advanced
features.
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Copying from Other
Applications

You can copy information from most other Windows
applications into eWebEditPro+XML and retain the formatting
from the original application. In general, copying from another
application involves these steps.
1. Sign on to the application in which the information resides.
2. Select the information to be copied.
3. Press <Ctrl>+<C>.
4. Go to eWebEditPro+XML.
5. Press <Ctrl>+<V> to paste the selected information.
Note that you can only copy content, not background
information that generates content.
So, for example, you can copy the values in a spreadsheet but
not the formulas used to generate those values. Also, copying
dynamic fields from Microsoft WORD would retrieve the current
value of the fields but not the variables that generate those
values.
It’s a good idea to experiment with copying from different
sources to test the results.
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Finding and Replacing Te xt

To find (and optionally replace) text on your Web page, click the
Replace button ( ). When you do, the Find and Replace
dialog box appears.

You can use this dialog box to simply find text, or to find text
and replace it with other text. Each option is explained below.
NOTE

You can also use this dialog to delete text that appears repeatedly. To do so,
follow the directions in ”Finding and Replacing Text” on page 495 and enter
nothing in the Replace With field.

See Also:

• “Finding Text” on page 494
• “Finding and Replacing Text” on page 495
• “Additional Options on the Dialog Box” on page 495

Finding Text
1. In the Find What field, type the text that you want to find in
the content.
2. Set dialog box options (see ”Additional Options on the
Dialog Box” on page 495).
3. Click Find Next to find the next occurrence of the “find”
text.
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Finding and Replacing Text
1. In the Find What field, type the text that you want to find.
2. In the Replace With field, type the text to replace the “find”
text.
3. Set dialog box options (see ”Additional Options on the Dialog
Box” on page 495).
4. If you want to

- replace all occurrences of the “find” text with the “replace”
text, click Replace All.
NOTE

You can undo replacements one at a time using the Undo button (

).

- replace only the highlighted term with the “replace” text, click
Replace.

- find the next occurrence of the “find” text (and optionally
replace it with the “replace” text), click Find Next.

- change the highlighted term using the editor, exit the Find
and Replace dialog, move to the term and edit as needed.
To restart the search, press the Find Next button (

).

5. Continue to find and optionally replace or edit until you reach
the end of the text.

Additional Options on the Dialog Box
The dialog box also lets you do the following.

• ”Specifying a Search Direction” on page 495
• ”Considering the Case of a Search Term” on page 496
• ”Whole Word Match” on page 497
Specifying a Search Direction
The search begins where the cursor is when you click Find Next.
To make sure you locate every occurrence of a term, place the
cursor at the top of the content before beginning the search.
If you begin the search from somewhere other than the top of the
page, use the Direction field to search from the current location to
the top or bottom of the file.
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To search from the
cursor location to the

Click this option in the
Direction field

end of the page

Down

top of the page

Up

Considering the Case of a Search Term
By default, the search ignores the case (upper or lower) of a
search term. In other words, if you enter Bob in the Find What
field, the search finds bob, Bob, BOB, etc.
If you want the search to be case sensitive, use the Match case
check box on the Find window. If you enter Bob in the Find What
field and place a check in the Match case box, the search only
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stops at Bob, not bob or BOB.

Whole Word Match
By default, the search finds any occurrence of the text that you
type into the Find what field. For example, if you enter the, the
search finds the word the, as well as those letters embedded in
other words, such as others and theater.
If you want the search to find only whole word occurrences of the
text you type into the Find what field, click the Match whole
words only box in the Find dialog box.
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The eWebEditPro+XML editor can check your spelling as you type
or whenever you want to check it.
The rest of this section explains

• ”Disabling Script Blocking” on page 498
• ”Checking Spelling as You Type” on page 498
• ”Checking Spelling Upon Demand” on page 499
• ”Spell Checking Selected Text” on page 500
• ”Setting Spell Check Options” on page 501

Disabling Script Blocking
If Norton Antivirus TM 2001 is installed on your computer, you need
to disable script blocking in order to use the spell checker. If you do
not disable script blocking, an error message will appear whenever
you check spelling.
To do this, follow these steps.
1. Launch Norton Antivirus TM 2001.
2. From the first window, click Options.
3. On the next window, click Script Blocking.
4. On the script blocking window, uncheck Enable Script
Blocking.
5. Press OK.

Checking Spelling as You Type
You can have the editor check spelling as you type. To turn on the
spell-check-as-you-type feature, click the automatic spell check
button(

).

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

498

Checking Spelling

When you click the button, the spell checker reviews every word in
the file. A wavy red line (
) appears under any word whose
spelling is not found in the system’s dictionary.
The spell checker continues to review each word as you type it,
marking any words not in the dictionary.
NOTE

Depending on the speed of your computer, there may be a short delay between
the time you type an incorrect word and when the wavy red line appears. Also, the
spell check does not check a word until you enter a space character after the
word.

Fixing Spelling Errors
There are two ways to fix a spelling error (indicated by a wavy red
line).

• Click the misspelled word and then right click. A menu displays
words that are similar to the misspelled word. Click the correct
word.

• If you know the correct spelling, type the correction.

Checking Spelling Upon Demand
If you do not want to use the spell-check-as-you-type feature, you
can begin spell checking whenever you wish. To do this, click the
spell check button ( ).
When you do, the system checks each word in the file. If the spell
check finds a word in none of the dictionaries, it displays the
Spelling dialog box.
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The Spelling Dialog Box
The Spelling dialog box displays

• the word not in the dictionary (in the Not in Dictionary field).
• suggested spellings for the word (in the Suggestions field).
The most likely replacement is selected at the top of the list.

• buttons that let you ignore the word, change the word, or exit.

If you want to

Do this

Replace the word with one of the suggestions and continue
spell checking the page.

1.

Click the suggested word.

2.

Click Change.

Replace every occurrence of the word with one of the
suggestions and continue spell checking the page.

1.

Click the suggested word.

2.

Click Change All.

Correct the spelling of the word by typing it and continue
spell checking the page.

1.

Click in the Not In Dictionary
field.

2.

Correct the spelling.

3.

Click Change.

Leave the word as is; continue spell checking the page.

Click Ignore.

You would normally do this if a word (such as a company
name) is spelled correctly even though it is not in the
dictionary.
Leave the word as is; continue spell checking the page,
ignoring all other occurrences of the word.

Click Ignore All.

Stop spell checking.

Click Cancel.

Spell Checking Selected Text
To check the spelling for a single word or a group of words, follow
these steps.
1. Select the text that you want to spell check.
2. Press the manual spell check button (

).
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3. The spell checker reviews the words in the selected text and
stops at any word not in the dictionary. For documentation of
options when a misspelled word is found, see “The Spelling
Dialog Box” on page 500.
4. When the spell checker finishes reviewing the words in the
selected text, it displays the following message
Finished checking selection. Do you want to check the rest of the
document?

Click Yes to spell check the rest of the document (including text
above the selected text).
Click No to stop the spell checker.

Setting Spell Check Options
eWebEditPro+XML can use Microsoft Word’s spell checking feature

(your Webmaster makes this decision).
If your installation uses Word, Word’s Spelling & Grammar window
(available from the Tools - > Options menu) has settings that
affect the operation of the spell check.
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Specifically, you can set the spell check feature to check or ignore

• words in UPPERCASE (for example, XYLOGIC)
• words with numbers (for example, mp3)
• Internet and file addresses (for example,

http://www.ektron.com/

)
As an example, if you check the box to the left of Ignore Words in
UPPERCASE, eWebEditPro+XML’s spell check does not consider
words in all uppercase characters.
You also use the custom dictionary section of the screen to identify
custom dictionaries for the spell check to reference.
The spell check feature does not use the other fields on this
screen.
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Editing in Microsoft Word

If your computer has Microsoft Word 2000 or greater, you can edit
content within Word. You may prefer to do this because of
familiarity with Word’s user interface, and to use additional
functionality available in Word.
See Also: ”Working with Microsoft Office Documents” on page 214
NOTE

Some Word formatting may not be compatible with HTML and, as a result, not be
transferred to eWebEditPro+XML.

To edit with Word, follow these steps.
1. Open eWebEditPro+XML.
2. Press the Word toolbar button (

).

3. The following dialog may appear, warning you that some Word
formatting may not be transferred back to eWebEditPro+XML.
Press Yes if you still want to edit in Word.

4. Microsoft Word opens. Any content that was in
eWebEditPro+XML when you pressed the Word button is
copied to Word.
5. Edit content as desired.
6. Press File -> Close.
7. Another warning like the one in Step 3 may appear. Press Yes
to copy the edited content back to eWebEditPro+XML.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

503

Editing in Microsoft Word

8. When done, return to eWebEditPro+XML and press the Word
toolbar button again.
9. If you change your mind and decide to restore the content to
the way it was before you edited it in Word, press the undo
button ( ).
If you want to restore the Word changes after pressing Undo,
press the redo button ( ).

Uploading an Image in a Microsoft Word Document
If you insert an image into the Word content and then paste that
content or save it, the following dialog box appears. The box lists
all images in the content and asks if you want to copy them from
your computer to your organization’s Web server.

If you are ready to publish your Web content and want to display
the image, click Update Now. If you plan to add more content later,
you can click Upload Later and upload all images at that time.

Editing XML Documents
If your organization has implemented eWebEditPro+XML, you
cannot edit XML documents using Microsoft Word. This is because
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Word does not support XML editing. If a full XML document is
loaded, the Word button (

) is disabled.

If a Word document includes some custom/XML tags, the following
dialog appears, warning you about the problem.

You can proceed and edit using Word or decide not to edit using
Word.
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To insert a picture into the editor, place the cursor where you want
the image to appear and click the Insert Picture button ( ). When
you click the button, one of the two Picture Properties dialog boxes
illustrated below appears, depending on how your Webmaster has
set up your system.
The dialog boxes are very similar, with the only difference being
that the Select Server File button only appears on the second
dialog box.
The Select Server File button appears if your upload mechanism
is set to FTP. It does not appear if the mechanism is HTTP. For
more information, see the eWebEditPro+XML Administrator Manual
section “Managing Image Selection” > “Examples of Implementing
Image Selection” > “Selecting Files from the Server.”
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You can also access this dialog box to modify a picture after you
insert it. To do this, follow these steps.
1. Click the picture.
2. Right click the mouse.
3. Click Picture from the menu.
If you see the first dialog box, proceed to “Using the First Picture
Properties Dialog Box” on page 508. If you see the second dialog
box, proceed to “Using the Second Media Selection Dialog Box” on
page 512.

Using the First Picture Properties Dialog Box
When the first Picture Properties dialog box appears, click the
Select New File button. When you do, the Insert Media Item dialog
box appears.
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This box and lets you insert a picture from your computer (and any
network folder available to your computer), or from the Web server
to which your computer is connected. Both choices are described
below.

Inserting a Picture from the Server
The top left corner of the dialog box (Illustrated below) lists the
pictures on the Web server.
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Pictures that you previously inserted appear on this list, as do
pictures inserted by other users connected to that server.
To insert a picture from the server, follow these steps.
1. Click the picture from the To Select an Existing File field that
you want to insert.
2. Information about the picture’s file size, width and height
appears in the upper right corner of the dialog box.
3. If you want to view a picture before inserting it, click Preview
(on the right side of the dialog box).
4. Click OK.
5. The Picture Properties dialog box reappears. Here, you can
change the properties of the picture. For more information, see

•“Adjusting a Picture” on page 514
•“Setting a Border” on page 515
•“Aligning the Picture” on page 516
•“Adding Space around the Picture” on page 518
6. Click OK to insert the picture into the editor.

Deleting a Picture from the Server
To delete a picture from the server, select the picture and click the
Delete button.
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Inserting a Picture from Your Computer
Use the lower left corner of the dialog box to insert pictures from
your computer (and any network folder available to your computer)
into the editor.

NOTE

You can only select files in the To Select a Local File: field if your computer has
permission to upload files to the server.

To insert a picture from your computer, follow these steps.
1. Click the Browse button.
2. Navigate to the file that you want to insert and press Open to
insert it.
Your Webmaster can set a maximum size (in kilobytes) for
images. If you select an image that exceeds the maximum, an
error message appears and you cannot insert it.
Your Webmaster can also restrict the type of image file you can
insert. For example, if your Webmaster does not authorize you
to insert bitmap (.bmp) files and you try to do so, an error
message lists valid file extensions, and you cannot insert the
image.
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3. Click in the Enter a description for the file field. Enter a title
to describe the file.
4. After you insert the picture, the title appears in the dialog box’s
top left corner to identify the picture to you and all users
connected to the same Web server.
NOTE

The title is also the alt text for the image. The alt text appears in place of the
image on the Web page if the image itself cannot display for any reason.

5. Information about the picture’s file size, width and height
appears in the upper right corner of the dialog box.
6. If you want to view a picture before inserting it, click Preview
(on the right side of the dialog box).
7. Click OK.
8. The Picture Properties dialog box reappears. Here, you can
change the picture’s properties. For more information, see

•“Adjusting a Picture” on page 514
•“Setting a Border” on page 515
•“Aligning the Picture” on page 516
• “Adding Space around the Picture” on page 518
• “Editing the Picture’s Title” on page 519
9. Click OK to insert the picture into the editor.

Using the Second Media Selection Dialog Box
When using the second Media Selection dialog box, you can insert
a picture from any folder available to your computer (whether the
folder is on your computer or a remote computer) or from the Web
server. Your Webmaster determines which pictures are available
on the Web server.
To insert a picture from

• a folder available to your computer, click Select New File,
navigate to the file of interest, and click OK.

• the Web server, click the Select Server File button.You are
prompted to enter a User Name and Password. Your
Webmaster assigns these codes to you, which are needed to
copy the file to the Web server.
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Next, the Image Explorer dialog appears (illustrated below).
Navigate through the folder structure until you find the image.
Then click OK to insert the image into eWebEditPro+XML.

See Also:

• ”The Picture Properties Dialog Box” on page 513
• ”Adjusting a Picture” on page 514
• ”Pixels” on page 515
• ”Setting a Border” on page 515
• ”Aligning the Picture” on page 516
• ”Resetting Width, Height, Border Thickness, and Alignment” on
page 518

• ”Adding Space around the Picture” on page 518
• ”Editing the Picture’s Title” on page 519
• ”The Options Button” on page 519
The Picture Properties Dialog Box
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You can also use the Picture Properties dialog box to

• adjust the picture’s width, height, border thickness, and
alignment

• reset the image’s properties width, height, border thickness,
and alignment to their original specifications

• set spacing between the picture and surrounding information
on the page

• enter or edit the picture’s title
• view technical information about your connection
Adjusting a Picture
The layout area of the Picture Properties dialog box lets you adjust
a picture’s width, height, border thickness, and alignment.

You can use the following fields to adjust the picture before
inserting it into the editor.

To make this change

Use this field

The width of the picture, in pixels

Width

The height of the picture, in pixels

Height

Add a border around the picture

Border Thickness
For more information, see “Setting a Border” on
page 515
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To make this change

Use this field

Adjust the alignment of the picture

Alignment
For more information, see “Aligning the Picture” on
page 516

WARNING!

If you substantially adjust the picture’s height and/or width, the picture may be
distorted when users view your Web page.

Pixels
A pixel is a single point in a graphic image.
Computer monitors display pictures by dividing the screen into
thousands of pixels, arranged in rows and columns. The pixels are
so close together that they appear connected.
Below is an image shown at regular size and then enlarged so you
can see the pixels that make up the picture.

regular size

enlarged to show pixels

Setting a Border
To add a border around a picture, enter the border’s thickness in
pixels in the Border Thickness field on the Picture Properties

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

515

Inserting Images

dialog box.

Here is a picture with a 1 pixel border.

Here is the same picture with a 10 pixel border.
If the picture is not a hyperlink, its border is black. If the picture is
also a hyperlink, the border is the same color as a hyperlink (for
example, blue or purple if visited).

Aligning the Picture
To align a picture, use the Alignment field on the Picture
Properties dialog box.

When deciding how to align a picture, you need to become familiar
with these terms.
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• baseline of text - the imaginary line on which the text lies.
Some letters (such as g, p and y) have descenders, segments
of letters that extend below the baseline

• bottom of text - the lowest section of a line to which a
descender extends

• top of text - the highest spot of a line to which any segment of a
letter extends

• vertical center - the midpoint between the top and bottom of the
line

The following table lists your alignment choices.

To align

Click this in the
Alignment field

The picture on the left margin, allowing
subsequent text to wrap around it

Left

The picture on the right margin, allowing
subsequent text to wrap around it

Right

The top of the picture with the top of the
text

Text Top, Top

The vertical center of the picture with the
baseline of the text

Middle

The vertical center of the picture with the
vertical center of the text

AbsMiddle

Illustration

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

517

Inserting Images

To align

Click this in the
Alignment field

The bottom of the picture with the
baseline of the text (This is the default
alignment)

Bottom, Baseline

The bottom of the picture with the bottom
of the text

AbsBottom

Illustration

Resetting Width, Height, Border Thickness, and Alignment
If you adjust the picture’s width, height, border thickness, and/or
alignment and later want to restore all of those settings to their
original values, click the Reset button.

Note that you cannot selectively restore some settings -- the Reset
button automatically restores all of them.

Adding Space around the Picture
On the Picture Properties dialog box, you can use the Spacing
fields (Horizontal and Vertical) to add space around the picture.
You enter a number of pixels to determine spacing value.
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The following graphic illustrates the effect of adding spacing to a
picture.

Editing the Picture’s Title
The title that you entered in the Insert Media Item dialog box
defaults into the Title field of the Media Selection dialog box. You
can edit the title in this field if desired.
NOTE

The title is also the alt text for the image. The alt text appears in place of the
image on the Web page if the image itself cannot display for any reason.

The Options Button
When you click the Options button on the File Properties dialog
box, the options dialog box appears. The box displays information
about your connection to the Web server.
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For information about these settings, see “Uploading Images” in
the eWebEditPro+XML Developer’s Reference Guide.

Moving an Image to the Server
If you insert an image from your computer into eWebEditPro+XML
content, that image must be moved to the server when you save
the content. The image can only appear on Web pages that display
it after you move it to the server.
When you save content that includes an image you inserted, the
following dialog appears.
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All inserted files appear in the dialog, which also estimates how
long it will take to move the files to your server. If you do not want
to wait that long to upload the files, click Upload Later. If you do
this, the images will not appear on the published Web content until
you move them to the server.
You can also enter a Title for the image near the bottom of the
screen. If you do, this text appears when the user reading the Web
pages moves the cursor over the image.

Deleting a Picture
If you want to delete a picture, follow these steps.
1. Move the cursor over the picture.
2. Click the mouse to select the picture.
3. Click the Cut button (

).
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WebImageFX lets you select an image from the content, edit that
image, and then insert the updated image into the content. Editing
consists of several functions available on the toolbar, such as

• brightening
• rotating
• changing the color depth
• inserting text
This section explains WebImageFX.
Important!

WebImageFX is an external, add-on product available from Ektron.

Using WebImageFX
Choosing the Image
If you double click an image, it appears within WebImageFX. You
can also right click the mouse and choose Image Editor from the
menu that appears.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

522

Editing Images

WebImageFX looks similar to eWebEditPro+XML but has different
menu and toolbar buttons.

If the Image Edit button ( ) appears on your toolbar, you can click
it to open WebImageFX. If no image is selected when you press
the button or click the menu command, a blank editor appears, and
you can use the File -> Open command to choose an image.
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Once the image is in WebImageFX, you can use the buttons and
menu options to edit it. The rest of this chapter describes those
buttons and menu options.

Saving the Image
When you finish editing the image, you can insert it into the content
by pressing the Exit button (

). Alternatively, you can save the

image to a local or network folder using the Save button (

).

When you insert the image into the content, WebImageFX checks
the file extension. If the image is a .gif file, it is saved as a .png file
in your temporary directory. For example test.gif is saved as
C:\Documents and Settings\your user name\Local
Settings\Temp\test.png.

Any other file type is saved in your temporary directory without
changing the file extension, unless you use the Save As option.
For example, you save test.jpg as test.png.

Assigning a Name to a New Image
If you create an image in WebImageFX, and then exit
WebImageFX and return to eWebEditPro+XML, the system assigns
the image a random name, such as WIF50A.jpg.
If you want to assign a different name and/or folder to the image,
use the Save as command.
See Also: ”Save As” on page 547

Toolbar Buttons and Menu Commands
The following tables list each toolbar button and menu command.
They are followed by a more detailed description of each function.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

524

Editing Images

File Menu Options

Toolbar
Button

Command

Brief Description

For more
information, see

Create New

Creates a new image.

”Create New” on
page 534

Open

Selects an image to edit.

”Open” on page 540

Save

Saves changes to an image.

”Save” on page 546

Save As

Saves the current image under a
different name or format.

”Save As” on page 547

Performs a single page scan.

”Twain Acquire” on
page 551

Twain Acquire

Before scanning, you must select a
source using the Twain Source
command.
Twain Source

Allows the user to select a source for
acquiring an image, such as a
scanner or digital camera.

”Twain Source” on
page 551

Exit

Save changes and return to
eWe bE di tP ro + XML .

”Exit” on page 536

Exit without save

Ignore changes; return to
eWe bE di tP ro + XML .

”Exit without Save” on
page 537

Command

Brief Description

For more
information, see

copy

Copies a selected area of an image.

”Copy” on page 534

Edit Menu Options

Toolbar
Button
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Toolbar
Button

Command

Brief Description

For more
information, see

paste as new
image

Inserts copied image or area into a
new file.

”Paste as New Image”
on page 542

undo

Reverses the most recent action.

”Undo” on page 552

redo

Reapplies the changes from the
command that occurred before you
pressed Undo.

”Redo” on page 545

select

Selects an area of an image. You
can then perform actions on the
area, such as blur and delete.

”Select” on page 548

crop

Removes everything outside of
selected area of an image.

”Crop” on page 534

delete

Deletes selected area of an image.

”Delete” on page 535

Command

Brief Description

For more
information, see

reset zoom ratio

Displays image at full size.

”Reset Zoom Ratio” on
page 545

zoom in

Increases an image’s magnification.

”Zoom In” on page 552

zoom out

Decreases an image’s magnification.

”Zoom Out” on
page 553

View Menu Options

Toolbar
Button
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Image Menu Options

Toolbar
Button

Command

Brief Description

For more
information, see

image info

Displays information about an
image.

”Image Info” on
page 538

dimensions

Modifies an image’s width and
height.

”Dimensions” on
page 535

color depth

Changes the number of colors
available to an image.

”Color Depth” on
page 532

blur

Blurs or softens an image.

”Blur” on page 528

sharpen

Sharpens edges within an image.

”Sharpen” on page 548

brightness

Changes an image’s brightness.

”Brightness” on
page 529

contrast

Changes the difference between
light and dark areas of an image.

”Contrast” on page 533

horizontal flip

Reverses an image horizontally left
to right.

”Horizontal Flip” on
page 538

vertical flip

Flips an image vertically top to
bottom.

”Vertical Flip” on
page 552

rotate

Turns an image a specified number
of degrees.

”Rotate” on page 546
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Annotation Menu Options

Toolbar
Button

Command

Brief Description

For more
information, see

pointer selection

Click an annotation to select it.

”Pointer Selection” on
page 542

choose color

Sets the color for an annotation
before you insert it.

”Choose Color” on
page 530

choose font

Sets the color of text before you
insert it.

”Choose Font” on
page 531

freehand

Draws a line in any shape that you
want.

”Freehand” on
page 537

line

Draws a straight line.

”Line” on page 539

oval

Draws an oval.

”Oval” on page 541

polygon

Draws a polygon (a closed figure
surrounded by straight lines).

”Polygon” on page 543

rectangle

Draws a rectangle.

”Rectangle” on
page 544

text

Inserts text.

”Text” on page 549

Blur
Standard Toolbar Button

Description
Blurs or softens an image. You can select a level of blur, from 0
through 4.
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If you select an area of the image, the command only changes that
area.

Dialog Box

Brightness
Standard Toolbar Button

Description
Increases or decreases an image’s brightness. You can select a
brightness level from 32 (brightest) through -32 (darkest).
If you select an area of the image, the command only changes that
area.
NOTE

You cannot adjust brightness if the image’s bit depth is 8 or fewer. See
”Specifying Color Depth” on page 553

Also:

Dialog Box

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

529

Editing Images

Choose Color
Standard Toolbar Button

Description
Lets you choose the color of an annotation before you insert it.
To change an annotation’s color after inserting it, place the cursor
on the annotation and press the right mouse button to display the
Attributes menu.

Dialog Box
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Choose Font
Standard Toolbar Button

Description
Lets you choose the color of annotation text before you insert it.
To change an annotation’s color after inserting it, place the cursor
on the annotation and press the right mouse button to display the
Attributes menu.

Dialog Box
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Color Depth
Standard Toolbar Button

Description
Changes an image’s color depth.
See Also: “Specifying Color Depth” on page 553

Dialog Box
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Contrast
Standard Toolbar Button

Description
Increases or decreases an image’s contrast (that is, the difference
between light and dark areas of an image). You can select a
contrast level, from 10 through -10.
If you select an area of the image, the command only changes that
area.

Dialog Box
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Copy
Standard Toolbar Button

Description
Copies a selected area of an image. After you copy an image, you
can paste it using the paste command. See Also: ”Paste as New
Image” on page 542
To select an area of an image, use the Select command. See Also:
”Select” on page 548
If you do not select an area, the entire image is copied.

Create New
Standard Toolbar Button

Description
Lets you create a new image. If you are editing an image when you
press this command, you are asked if you want to save changes to
it first.
By default, a new image’s bit depth is 24, but you can change it if
desired using the color depth command.
See Also: ”Color Depth” on page 532

Crop
Standard Toolbar Button

Description
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Keeps selected area of an image; removes everything outside that
area.
To use the Crop command, follow these steps.
1. Select an area of an image that you want to keep.
2. Press the Crop button (

).

3. Everything outside the selected area is removed.

Delete
Standard Toolbar Button

Description
Removes a selected area of an image. You must select an area
before you delete it.
The deleted area is not saved for later pasting. In contrast, if you
use the Cut command, you can later paste the cut area.

Dimensions
Standard Toolbar Button

Description
Lest you change an image’s width and/or height, which are defined
in pixels.
Maintaining Aspect Ratio
Use this check box to change an image’s size while maintaining its
aspect ratio.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

535

Editing Images

Aspect ratio is the ratio of an image’s width to height. For example,
if a graphic has an aspect ratio of 2:1, its width is twice as large as
its height.
If you check the Maintain Aspect Ratio box, just specify a new
width -- the height is calculated automatically.

Dialog Box

Exit
Standard Toolbar Button

Description
Save the change in the WebImageFX and return to
eWebEditPro+XML, where the updated image appears.
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Exit without Save
Standard Toolbar Button

Description
Ignore changes made to the image in WebImageFX. Return to
eWebEditPro+XML.

Freehand
Standard Toolbar Button

Description
Lets you draw a line in any shape that you want, similar to using a
pen on paper.
To use this command, click the freehand command, drag the line,
and release the mouse. To change the line’s size or color, place
the cursor on the line and press the right mouse button to display
the Attributes menu.

Dialog Box
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Horizontal Flip
Standard Toolbar Button

Description
Reverses an image horizontally left to right.
Click this command again to reverse the image horizontally right to
left.

Image before horizontal flip

Image after horizontal flip

Image Info
Standard Toolbar Button
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Description
Displays information about an image:

• image name
• height and width in pixels
• bit depth (See Also: ”Specifying Color Depth” on page 553)
• file format

Line
Standard Toolbar Button

Description
Draw a straight line. To change a line’s size or color, right click it
after drawing it.
To use this command, click the line command, drag the line, and
release the mouse. To change the line’s size or color, place the
cursor on the line and press the right mouse button to display the
Attributes menu.

Dialog Box
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Open
Standard Toolbar Button

Description
Select an image for editing. The image can be on your computer or
a local area network.

Dialog Box
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To change the type of file that appears in the window, click the
down arrow (circled above) to the right of the Files of type field.
Your system administrator determines which types of files you can
edit.

Oval
Standard Toolbar Button

Description
Draws an oval.
To use this command, click the oval command, drag the line, and
release the mouse. To change the oval’s line size or color, place
the cursor on the line and press the right mouse button to display
the Attributes menu.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

541

Editing Images

Dialog Box

Paste as New Image
Standard Toolbar Button

Description
After you copy or cut an image or an area of an image, use paste
as new image to insert it into a new file.
Before creating a new file, WebImageFX asks if you want to save
changes to current file.

Pointer Selection
Standard Toolbar Button

Description
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Click an annotation to select it. After you select an annotation, you
can perform functions on it, such as delete it.
This command is a toggle, which means the first time you click it, it
is on, and the next time you click it, it is off.

Polygon
Standard Toolbar Button

Description
Draws a polygon (that is, a closed figure surrounded by straight
lines).
To use this command, follow these steps.
1. Click the polygon command.
2. Drag the line in one direction as far as you want.
3. Drag the line in the other directions to complete the polygon.
4. Double click the mouse to terminate the polygon.
5. To change the polygon’s line size or color, place the cursor on
the line and press the right mouse button to display the
Attributes menu.

Dialog Box
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Rectangle
Standard Toolbar Button

Description
Draws a rectangle.
To use this command, click the rectangle command, drag a
rectangle, and release the mouse. To change the rectangle’s line
size or color, place the cursor on the line and press the right mouse
button to display the Attributes menu.

Dialog Box
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Redo
Standard Toolbar Button

Description
If you use the Undo command and then decide that it was a
mistake, use this command. It re-applies the changes from the
command that occurred before you pressed Undo.
See Also: ”Undo” on page 552

Reset Zoom Ratio
Standard Toolbar Button

Description
Displays image at full size.
See Also: ”Zoom In” on page 552; ”Zoom Out” on page 553
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Rotate
Standard Toolbar Button

Description
Turns an image a specified number of degrees. Note that the
dialog box lets you rotate the image

• left or right
• 90, 180, or 270 degrees
• any number of degrees between 1 and 359
Dialog Box

Save
Standard Toolbar Button

Description
Save changes to an image. If required information is missing, such
as the image name, you are prompted for this information.
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Dialog Box

NOTE

The dialog box only appears the first time you save the image. If you later want to
save it to a different folder, or under a different name or file type, use the Save As
command.

Save As
Standard Toolbar Button

Description
Save the current image under a different name or format. For
example, you might save mypicture.gif as mypicture.jpg.
Your system administrator determines which file formats are
available.

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

547

Editing Images

Dialog Box
See ”Save” on page 546

Select
Standard Toolbar Button

Description
Selects an area of an image. You can then execute other
commands on the selected area, such as blur, sharpen, cut, and
delete.
NOTE

Once you press the Select command, it remains selected and continues to be
active until you press it a second time.

Sharpen
Standard Toolbar Button

Description
Sharpens edges within an image. You can select a level of
sharpness, from 1 through 5.
Sharpening brings an image into better focus and increases the
detail.
If you select an area of the image, the command only changes that
area.

Dialog Box
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Text
Standard Toolbar Button

Description
Places text on an image. You can also change the text’s size, font,
color, and attributes (bold, italic, etc.).
To use the Text command, follow these steps.
1. Click the Text button (

).

2. Move the cursor to where you want to place the text.
3. Click the mouse button and drag a rectangle in which to insert
the text.
NOTE

Make sure the rectangle is large enough to accommodate your text. The rectangle
disappears after you enter text.

4. Type the text.
5. Click outside the rectangle to close it.
6. To change the text or its font, size, style, color, etc., place the
cursor over the text and right click the mouse. The text
attributes dialog appears.

Dialog Box
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The following table lists functions you can perform with this dialog.

To change this

Use this tab/field

font

Font Attributes/Font

font size

Font Attributes/Size

font style (bold, italic, etc.)

Font Attributes/Style

underlining

Font Attributes/Underline

strikeout (for example, sample)

Font Attributes/Strikethrough

font color

Color Attributes/Primary
Color

text

Text Attributes/white box

if text wraps when it reaches the
end of a line

Text Attributes/ Wrap
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Twain Acquire
Standard Toolbar Button

Description
Perform a single page scan from a previously selected source.
See Also: ”Twain Source” on page 551
Importing Scanned Images
WebImageFX lets you acquire images from a scanner or digital
camera that supports the Twain standard. You select the source
(using Twain Source) and do a quick acquire from that source
(using Twain Acquire).
Limitations

• You can only acquire one page at a time
• Few digital cameras support twain. Usually, digital cameras
resemble a hard drive or use proprietary software to extract
images. Ektron does not support an interface to proprietary
software.

• Not all scanners support the twain standard

Twain Source
Standard Toolbar Button

Description
Lest you select a source for acquiring an image, such as a scanner
or digital camera.
See Also: ”Twain Acquire” on page 551
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Undo
Standard Toolbar Button

Description
Reverses the most recent commands within the current editing
session.
You can undo several commands at once by pressing the undo
command repeatedly. The first time you press the command, the
most recently completed command is “undone.” The next time, the
second most recently completed command is “undone”, etc.
See Also: ”Redo” on page 545

Vertical Flip
Standard Toolbar Button

Description
Flips an image vertically top to bottom.
Click this command again to reverse the image vertically bottom to
top.

Image before vertical flip

Image after vertical flip

Zoom In
Standard Toolbar Button
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Description
Increases an image’s magnification.
You can press this command several times to continue to increase
magnification.
See Also: ”Zoom Out” on page 553; ”Reset Zoom Ratio” on
page 545

Zoom Out
Standard Toolbar Button
Decrease an image’s magnification.
You can press this command several times to continue to decrease
magnification.
See Also: ”Zoom In” on page 552; ”Reset Zoom Ratio” on
page 545

Specifying Color Depth
To specify an image’s color depth (that is, the number of colors
available to an image), specify a bit depth. The color depth is
derived from the bit depth. Here are the bit depth values.
Bit depth

Color depth

1

2 colors

4

16 colors

8

256 colors

24

16M colors
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Sometimes, the information on your Web page looks better when
displayed on a table. Here is an example.

City

Baseball Team

Hockey Team

Boston

Red Sox

Bruins

New York

Yankees / Mets

Rangers

Chicago

White Sox / Cubs

Black Hawks

This section explains

• ”Creating a Table” on page 555
• ”Deleting a Table” on page 556
• ”Inserting a Table within a Table” on page 557
See Also:

• “Table Dialog Boxes and Menus” on page 558
• “Manipulating Your Table’s Format” on page 565
• “Working with Table Cells” on page 581
• ”Section 508 Tables” on page 616
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Creating a Table
To create a table, click the table button ( ) then click Insert Table
from the menu. When you do, the Insert Table dialog box appears.

You can also access this dialog box after you insert it. You would
do this if you wanted to edit any of the information entered in the
dialog.
To access this dialog after insertion, follow these steps.
1. Click the table.
2. Right click the mouse.
3. Click Table Properties from the menu.
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When creating a table, you can specify the

• number of rows and columns
• width
• horizontal alignment on the page
• background color or background picture
• border size and color
For more information about managing tables, see “Manipulating
Your Table’s Format” on page 565.
For more information about managing individual cells within a
table, see “Working with Table Cells” on page 581.

Deleting a Table
To delete a table, follow these steps
1. Move the cursor over the table until the cursor becomes a fourheaded arrow (

).

2. Click the mouse button. The table becomes selected (small
squares appear around it).

3. Press <Delete>.
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Inserting a Table within a Table
You can insert a table within a table. You might want to do this to
arrange text in columns.

NOTE

HTML does not let you use tabs or spaces to align text in columns. You must use
a table to align columns. You can remove the table’s border, so that no lines
appear between the columns and rows.

To insert a table within a table, follow these steps.
1. Place the cursor in the cell into which you want to insert a table.
2. Click the Insert Table button (

).

3. Click Insert Table from the menu.

4. The Insert Table dialog box appears.
5. Edit the fields in the dialog box as needed. Then, click OK.
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This section explains the menu options and dialog boxes you use
to manipulate tables and cells. In most cases, you are referred to
another section that describes the feature in more detail.
This section explains

• ”The Insert Table Menu” on page 558
• ”The Table Properties Dialog Box” on page 560
• ”The Cell Properties Dialog Box” on page 562
• ”The Table Context Sensitive Menu” on page 563

The Insert Table Menu
You access the Insert Table menu by clicking on the Insert Table
button (
NOTE

) while the cursor is inside a table.

Before you click the button, make sure the table is not selected (that is, the table
is not surrounded by small boxes).

When you do, the following menu appears.
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The following table lists the menu options and where to get more
information on each.

Menu Option

Description

For more information, see

Insert Table

Inserts a new table where the
cursor is currently resting

“Creating a Table” on page 555

Insert Row

Creates a new table row above the
row in which the cursor is currently
resting

“Adding or Removing Rows and
Columns” on page 566

Insert Column

Creates a new table column next to
the column in which the cursor is
currently resting

“Adding or Removing Rows and
Columns” on page 566

Insert Cell

Inserts a cell to the left of the cursor
in a table

Delete Rows

Deletes table row in which the
cursor is currently resting

“Adding or Removing Rows and
Columns” on page 566

Delete Column

Deletes table column in which the
cursor is currently resting

“Adding or Removing Rows and
Columns” on page 566

Delete Cells

Deletes the selected cells

Merge Cells

Combines the contents of two or
more selected cells into one

“Merging Two Cells” on page 595

Split Cell

Divides a cell into two. Each cell
occupies one half the size of the
original cell.

“Splitting a Cell” on page 594

Table Properties

Displays and lets you edit table
properties, such as the number of
rows and columns, cell padding,
and borders.

“The Table Properties Dialog Box” on
page 560

Cell Properties

Displays and lets you edit cell
properties, such as width and
alignment

“The Cell Properties Dialog Box” on
page 562
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The Table Properties Dialog Box
The Insert Table dialog box lets you manipulate most elements of a
table‘s appearance.

The following table lists the fields on this dialog box and refers you
to the section that explains each field.
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Field(s)

Lets you specify

For more
information, see

Size: Rows, Columns

The number of rows and
columns in the table

“Choosing the Number
of Rows and Columns”
on page 565

Layout: Width

Table width

“Specifying Table Width”
on page 567

Layout: Horizontal
Alignment

The table’s alignment
across the Web page

“Setting Horizontal
Alignment” on page 591

Background Color

The background color of
the table

“Specifying a Table’s
Background Color” on
page 574

Background Image

A background image for
the table

“Specifying a
Background Image
for a Table” on
page 576

Borders: Use Default
Color

Whether or not to use
the default color (gray)
for table borders

Border Color

If you do not use the
default, the color of the
table border

“Assigning Border
Color” on page 577

Border Size

The size of the table
border

“Assigning Border Size”
on page 579

Cell Padding

The space (in pixels)
between the cell text
and a cell’s border

“Assigning Cell
Padding” on page 597

Cell Spacing

The space (in pixels)
between a cell and
surrounding cells

“Assigning Cell
Spacing” on page 598
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The Cell Properties Dialog Box
The Cell Properties dialog box lets you manipulate most elements
of a cell‘s appearance.

The following table lists the fields on this dialog box and refers you
to the section that explains each field.
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Field(s)

Lets you specify

For more
information, see

Rows Spanned

If the cell spans two or
more rows

“Spanning Rows or
Columns” on page 589

Columns Spanned

If the cell spans two or
more columns

“Spanning Rows or
Columns” on page 589

Width

The minimum cell width

“Specifying the Width of
a Cell” on page 581

Word Wrap

Whether text moves
down to the next line
when it reaches the
specified width of a cell

“Word Wrap” on
page 596

Horizontal Alignment

The alignment of data
across a cell

“Setting Horizontal
Alignment” on page 591

Vertical Alignment

The alignment of data
up and down within a
cell

“Setting Vertical
Alignment” on page 593

Background Color

The cell’s background
color, if you want it to be
different from the table’s
background color

“Specifying a Cell’s
Background Color” on
page 585

Background Image

A background image for
the cell

“Specifying a
Background Image for a
Cell” on page 587

Use Default Color

Apply the table border
color to this cell border

Border Color

Apply a color other than
the table border color to
this cell border

“Setting a Cell’s Border
Color” on page 584

The Table Context Sensitive Menu
The following menu appears when you right click the mouse while
the cursor is in a table.
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All items on this menu are described in ”The Context Sensitive
Menu” on page 489 except Tables, which is described in ”The
Insert Table Menu” on page 558.
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Format

This section explains how to manipulate your table’s format by
specifying

• a number of rows and columns
• a width
• horizontal alignment
• a background color or image
• border color and size
NOTE

You can also apply most of these properties to individual cells within a table. See
“Working with Table Cells” on page 581 for details.

• ”Choosing the Number of Rows and Columns” on page 565
• ”Specifying Table Width” on page 567
• ”Specifying Horizontal Alignment” on page 572
• ”Table Backgrounds” on page 573
• ”Setting Table Borders” on page 577

Choosing the Number of Rows and Columns
Use the Size section of the Insert Table dialog box to specify the
number of rows and columns in the table.
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A row is a horizontal series of cells, while a column is a vertical
series.

If you know how many rows and columns the table will be, enter
those numbers. If you don’t know the number of rows and columns
you need when you create the table, estimate how many you need.
You can add or remove rows and columns later.

Placement of Inserted Row or Column
If you add a row, it appears above the row in which the cursor was
resting when you pressed Insert Row.
If you add a column, it appears on the left side of the table.

Adding or Removing Rows and Columns
To add or remove rows and columns after you create the table,
follow these steps.
1. Place the cursor in the cell from which you want to add or
delete.
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2. Right click the mouse. A menu appears.

3. Click the appropriate action from the menu. For example to add
a row, click Insert Row.
NOTE

If you are working with nested tables, and you add or remove a column then undo
that action and redo it, you must press the redo button once for each cell in the
row or column.

Specifying Table Width
When you create a table, you can set its width by specifying one of
the following:

• percentage of the window: the table’s width varies as a user
adjusts the browser size

• fixed number of pixels, the table’s width stays the same as a
user adjusts the browser size
You can also not set a width but instead let information you enter
into the table’s cells determine its width.
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NOTE

To set the width of a table column, adjust the width of one of the cells within the
column (as described in “Specifying the Width of a Cell” on page 581). Usually,
this change affects all other cells in the column.

Specifying Table Width by Percentage
Specify table width by percentage if you want the table to be
resized as the user resizes the browser.
NOTE

In order for the table to resize with the browser, the Word Wrap attribute must be
turned on in all of a table’s cells. For details, see “Word Wrap” on page 596.

For example, if you specify that a table is 100% wide, and your
browser displays 14 inches across when it is maximized, the table
fills the screen (except for the browser border).

If you resize the browser to half the screen, the table will be about
7” wide. You still see both columns, but some of the data is moved
down.
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Setting Table Width by Percentage
To specify table width by percentage, choose Percent in the layout
section of the Insert Table dialog box. Then, specify the percentage
at the Width field.
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Specifying Table Width by Pixels
Specify table width by pixels if you want the table to remain the
same size if a user resizes the browser.
For example, if you specify that a table is 610 pixels wide, and the
user’s browser is set to low resolution (640 x 480 pixels), the table
occupies the full width of the browser when it is maximized.
If the user resizes the browser so that it only occupies the left half
of the screen, only the left half of the table appears. A scroll bar
appears at the bottom of the browser. The user must move the
scroll bar to see the rest of the table.
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If you set table width by pixels, do not set it to more than 610
pixels. Otherwise, the table will not fully display on a monitor set to
low resolution (640 x 480).

Setting Table Width by Pixels
To specify table width by pixels, choose Pixels in the layout section
of the Insert Table dialog box. Then, specify the number of pixels at
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the Width field.

Specifying Horizontal Alignment
You can specify your table’s horizontal alignment (left, right, or
center) within the browser.

Alignment

Example

left

right

center
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If you specify right or left justify, you can wrap text around the table.
To do this, move the cursor to the right or left of the table and begin
typing.

Specify the table alignment at the Horizontal Alignment field on
the Layout area of the Insert Table dialog box.

Table Backgrounds
You can specify a background color or image for your table.
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Specifying a Table’s Background Color
You can assign a background color to a table to make it more
pleasing to the eye. Here is an example.

NOTE

If you apply a dark background color to a table, you may want to apply a light
foreground color to the text. Use the font color button (
color.

) to change the text

To assign a background color to your table, click the Background
Color field on the Insert Table dialog box.

When you click that field, a color dialog box appears. Click the
color that you want to apply to the background of the table.
Follow these steps to get help on how to use the color box.
1. Click the question mark in the top right corner.
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2. A large question mark appears next to your cursor.
3. Drag the question mark to the area of the dialog box that you
want to learn about.
4. Click the mouse button. A box appears with instructions for that
area.

Deleting a Table’s Background Color
To delete a table’s background color, click the Unassigned box in
the Custom Background area of the Insert Table dialog box.
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Specifying a Background Image for a Table
If you want a background image to appear in all table cells, use the
Background Image field of the Insert Table dialog box.

Your Webmaster determines which images are available to you.
To insert a background image
1. Click the down arrow to the right of (Select Image). A list of
background images appears.
2. Click the image of your choice.
3. Click OK.
Note that when you apply a background image to a table

• it applies to the entire table, including the borders.
• if the table is larger than the image, the image repeats until it
fills the table.

• if the image is larger than the table, the top left corner of the
image aligns with the top left corner of the table. The rest of the
image fills as much of the table as possible.

• you can also apply an image to individual cells (see “Specifying
a Background Image for a Cell” on page 587).

• make sure that the image does not obscure user’s ability to
read the table text.
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Deleting a Background Image
1. Move the cursor to any cell on the table and right click the
mouse.
2. Click Table Properties from the menu.

3. Select the value in the Background Image field and press
<Backspace>.
4. Click OK.

Setting Table Borders
You can specify a border color or size for your table.

Assigning Border Color
A table border is the line that separates the table from the rest of
your Web page. By default, table borders are gray. You can change
the color of table borders.
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If you want a table’s border to “disappear,” set it to the same color
as the page’s background color. This technique is often used to
format text on a Web page.

Assigning a Cell Border Color
Each cell also has a border that separates it from the other cells
and the table border. By default, a cell’s border color matches the
table border. However, you can individually change a cell border
color (see “Setting a Cell’s Border Color” on page 584).
To assign a color to your table’s border, click the Border Color
field on the Insert Table dialog box.

When you click that field, a color selection box appears. Click the
color that you want to apply to the table’s border. Follow these
steps to get help on how to use the color box.
1. Click the question mark in the top right corner.
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2. A large question mark appears next to your cursor.
3. Drag the question mark to the area of the dialog box that you
want to learn about.
4. Click the mouse button. A box appears with instructions for that
area.

Assigning Border Size
You can also adjust the size of a table border. Size is measured in
pixels.

To assign a border size to your table, enter a number of pixels into
the Border Size field on the Insert Table dialog box.
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If you set a table’s border size to zero (0) but wish to view the
table’s boundary lines while you are editing it, select the table and
click the border button ( ). Boundary lines will appear while you
are editing but disappear when a user views the page.
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Along with functions for managing tables (described in
“Introduction to Tables” on page 554 and “Manipulating Your
Table’s Format” on page 565), eWebEditPro+XML also lets you
perform actions on individual cells within a table.
You can perform the following actions on individual table cells.

• ”Specifying the Width of a Cell” on page 581
• ”Inserting a Cell” on page 582
• ”Deleting a Cell” on page 583
• ”Setting a Cell’s Border Color” on page 584
• ”Specifying a Cell’s Background Color” on page 585
• ”Specifying a Background Image for a Cell” on page 587
• ”Spanning Rows or Columns” on page 589
• ”Aligning Text Within a Cell” on page 591
• ”Splitting a Cell” on page 594
• ”Merging Two Cells” on page 595
• ”Word Wrap” on page 596
• ”Setting Cell Padding and Spacing” on page 597
NOTE

HTML does not allow you to adjust the width of a cell’s border.

You can also select several cells or a row of cells and change them
as described above. However, you cannot select and change a
column of cells.

Specifying the Width of a Cell
As described in “Specifying Table Width” on page 567, there are
several ways to set the width of a table. Within a table, you can
also specify the width of an individual cell.
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When you set a cell width, there is no guarantee that the cell will
occupy that width when displayed in a browser. This is because the
cell is part of a column, and changes to other cells in the column
can affect the cell whose width you set. Setting cell width only
guarantees that the cell will not be less than the width you specify.
If you want to ensure that a cell’s size does not change, set all cells
in a column to that width.
To specify a cell’s width, follow these steps.
1. Place the cursor in the cell whose width you want to set.
2. Right click the mouse.
3. Click Table from the menu.
4. Click Cell Properties from the menu.
5. The Cell Properties dialog box appears.

6. In the layout section of the dialog box, enter the cell width at
the Width field. You can enter the width in pixels or percentage.
These choices are explained in “Specifying Table Width” on
page 567.
7. Click OK.

Inserting a Cell
To insert a cell, follow these steps.
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1. Move the cursor to the right of where you want the new cell to
appear.
2. Right click the mouse.
3. Click Insert Cell from the menu.
The new cell appears to the left of the cell in which the cursor
resides when you click Insert Cell. The cursor cell and all cells to
its right shift right to make room for the new cell.
In this example, the cursor was in cell “b” when the user clicked
Insert Cell.
Before

After

Deleting a Cell
To delete one or more cells, follow these steps.
1. Move the cursor to the first cell you want to delete.
2. To delete only that cell, proceed to the next step. To delete
several contiguous cells, select them. Contiguous cells can
cross rows.
3. Right click the mouse.
4. Click Delete Cells from the menu.
Any cells to the right of the deleted cells shift left to occupy the
vacant space.
In this example, the cursor was in cell “b” when the user clicked on
Delete Cells.
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Before

After

Setting a Cell’s Border Color
A cell border is the line that separates it from other cells.
By default, the color of a cell’s border matches the color of the
table border. However, you can change the color of any cell border
individually.
NOTE

When viewed in Netscape Navigator, cell borders are gray, regardless of any
change you make on the Cell Properties dialog box.

This example illustrates the effect of different cell border colors
within a table.

If you want a cell’s border to “disappear,” set it to the same color as
the table’s background color.
To change the color of a cell’s border, follow these steps.
1. Move the cursor to the cell and right click the mouse.
2. Click Table from the menu.
3. Click Cell Properties from the menu.
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4. Click the Border Color field on the Cell Properties dialog box.

5. When you click that field, a Windows Color selection box
appears. Click the color that you want to apply to the cell
border.
See Also: “Using the Color Box” on page 588

Specifying a Cell’s Background Color
“Specifying a Table’s Background Color” on page 574 explains how
to apply a background color to a table. You can also apply a
background color to a cell.
To apply a background color to a cell, follow these steps.
1. Move the cursor to the cell and right click the mouse.
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2. Click Table from the menu.
3. Click Cell Properties from the menu.
4. Click the Background Color field on the Cell Properties dialog
box.

5. When you click that field, a Windows Color selection box
appears.
See Also: “Using the Color Box” on page 588

6. Click a color to apply to the background of the cell.

Deleting a Cell’s Background Color
To delete a cell’s background color, click the Unassigned box in
the Custom Background area of the Cell Properties dialog box.
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Specifying a Background Image for a Cell
“Specifying a Background Image for a Table” on page 576 explains
how to apply a background image to a table. You can also apply a
background image to a cell.
Your Webmaster determines which images are available.
To insert an image into a cell, follow these steps.
1. Move the cursor to the cell and right click the mouse.
2. Click Table from the menu.
3. Click Cell Properties from the menu.
4. Move the cursor to the Background Image field of the Cell
Properties dialog box.

5. Click the down arrow to the right of (Select Image). A list of
background images appears.
6. Click the image of your choice.
7. Click OK.
Note that when you apply a background image to a cell
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• If the cell is larger than the image, the image repeats until it fills
the cell.

• If the cell is smaller than the image, the top left corner of the
image appears in the top left corner of the cell. The rest of the
image fills as much of the cell as possible.

• Make sure the image does not obscure a user’s ability to read
the cell text (if any exists).

Deleting a Background Image
1. Move the cursor to the cell and right click the mouse.
2. Click Table from the menu.
3. Click Cell Properties from the menu.
4. Select the value in the Background Image field and press
<Backspace>.

Using the Color Box
Follow these steps to get help on how to use the color box.
1. Click the question mark in the top right corner.
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2. A large question mark appears next to your cursor.
3. Drag the question mark to the area of the dialog box that you
want to learn about.
4. Click the mouse button. A box appears with instructions for that
area.

Spanning Rows or Columns
You can create a table cell that stretches across more than one
row or column. In the following table, notice how the row that
contains “Sports Teams” spans three columns.

Sports Teams
City

Baseball Team

Hockey Team

Boston

Red Sox

Bruins

New York

Yankees

Rangers

Chicago

White Sox

Black Hawks

You can also create a column that spans several rows, as
illustrated below. Notice that Boston spans three rows.

Colleges
City

Name

Boston

Boston College
Northeastern University
Boston University
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Colleges
City

Name

New York

Columbia University

Spanning More than One Row or Column
To have a table cell span more than one row or column, follow
these steps.
1. Place the cursor in the cell that will span rows or columns.
2. Right click the mouse.
3. Click Table from the menu.
4. Click Cell Properties from the menu.
5. The Cell Properties dialog box appears. In the Rows Spanned
or Columns Spanned field, enter the number of rows or
columns that you want this cell to span.

6. Click OK.

Effect of Spanning a Cell
When you set a cell to span rows or columns, the editor does not
remove the cells that are in the way. Instead, it moves those cells
across or down to the next available position.
For example, the following table has two rows and two columns.
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If you set cell A to span two rows, note that cell C moves across to
make room for cell A. This action pushes cell D to the next column.

Aligning Text Within a Cell
Within a cell, you can specify how your text aligns horizontally and
vertically.

Setting Horizontal Alignment
In the Cell Properties dialog box, you can specify the horizontal
alignment of a cell. You have set the alignment to left, center, or
right, or

• left
• center
• right
• justify - the text is justified down both left and right edges. Many
books use this alignment style. (This alignment is not
supported by all browsers.)
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This example illustrates these choices.

To set horizontal justification of a table cell, follow these steps.
1. Place the cursor in the cell that you want to edit.
2. Right click the mouse.
3. Click Table from the menu.
4. Click Cell Properties from the menu
5. The Cell Properties dialog box appears. Click the down arrow
to the right of the Horizontal Alignment field.

6. Click your choice from the list and click OK.
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Setting Vertical Alignment
In the Cell Properties dialog box, you can specify the vertical
alignment of a cell. You have four choices.

• top
• middle
• bottom
• along the baseline of the first line of text (the term “baseline” is
defined in ”Aligning the Picture” on page 516)
This example illustrates the choices.

To set vertical justification for a table cell, follow these steps.
1. Place the cursor in the cell that you want to edit.
2. Right click the mouse.
3. Click Table from the menu.
4. Click Cell Properties from the menu.
5. The Cell Properties dialog box appears. Click the down arrow
to the right of the Vertical Alignment field.
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6. Click your choice from the list and click OK.

Splitting a Cell
You can divide a cell into two. If you split a cell, each cell occupies
one half the size of the original cell.
Row before split

Row after split

To split a table cell into two cells, follow these steps.
1. Place the cursor in the cell that you want to split.
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2. Right click the mouse.
3. Click Table.
4. Click Split Cell from the menu.

5. Two cells now appear where only one appeared before.

Merging Two Cells
You can merge two cells into one. If you merge two cells, the new
cell contains all of the information from both. The new cell’s width
equals the sum of the two cells that were merged.
Cells Before Merge

Cell After Merge

To merge two or more cells, follow these steps.
1. Select the cells that you want to merge.
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2. Click the Insert Table button (

).

3. Click Merge Cells from the menu.

Word Wrap
Word Wrap is a text formatting feature of tables. It causes text to
move down to the next line when the width of the characters on a
line equals the column width. For example, if you set column width
to 50%, with word wrap turned on, a table looks like this.

If you turn Word Wrap off for the same table, you get this result.

If Word Wrap is turned off, text stays on one line until the user
entering table text presses <Enter>. That keystroke causes text to
move down to the next line.
By default, all cells have the Word Wrap feature turned on.
To turn Word Wrap on or off for a cell, follow these steps.
1. Place the cursor in the cell that you want to edit.
2. Right click the mouse.
3. Click Table from the menu.
4. Click Cell Properties from the menu.
5. The Cell Properties dialog box appears. Click or off the Word
Wrap checkbox and click OK.
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Setting Cell Padding and Spacing
Cell padding is the space between a cell’s data and its border.

Cell spacing is the space between a cell and surrounding cells.

Assigning Cell Padding
To assign cell padding to your table, click the Cell Padding field on
the Insert Table dialog box. Enter the number of pixels.
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Assigning Cell Spacing
To assign cell spacing to your table, click the Cell Spacing field on
the Insert Table dialog box. Enter the number of pixels.
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Use a bookmark to let a user “jump” from any word, phrase, or
image to another place in a file. On your Web page, text appears in
a different color to indicate that additional information is available
at the bookmark’s location.
For example, if your Web page includes meeting minutes, the top
of the page could list the meeting dates. You could then assign a
hyperlink to each date and a bookmark to each set of minutes.
The user sees that a date is in a different color, so clicks the date to
“jump” to the bookmark that marks the location of the meeting
minutes.
“Creating a Bookmark” on page 599 describes how to set up a
hyperlink to a bookmark within a file. You can also set up hyperlink
to

• another Web page. This procedure is described in “Using
Hyperlinks” on page 603.

• a bookmark within another Web page. This procedure is
described in “Creating a Hyperlink to a Location Within a Web
Page” on page 606.

Creating a Bookmark
When creating a bookmark, you must specify a

• source, the text or image that the user clicks to move to the
bookmark

• bookmark, the place to which the cursor jumps when the user
clicks the source
To continue with the above example, a meeting date is the source,
and the meeting minutes are the bookmark.
To create a bookmark, follow these steps.
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1. Select the bookmark text or image.
2. Click the Bookmark button (

).

3. The Bookmark dialog box appears. Enter the name of the
bookmark. The bookmark can include the following nonalphabetic characters: ; / ? : @ & = + $ , - _ . ! ~ * ' ( ).

4. Click Add.
5. The editor screen returns. (The bookmark does not appear on
the page.) Select the source text or image.
6. Click the Hyperlink button (

).

7. The Hyperlink dialog box appears.
8. Click the down arrow to the right of the Quicklink field and
click the bookmark you created in Step 3.
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9. If desired, you can use the Target Frame field to change the
window in which the destination text appears. For details, see
“Changing the Destination Window” on page 602.
If you leave the Target Frame field blank, the new window
replaces the current window.
10. Click OK.
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Changing the Destination Window
While defining hypertext, you can use the Target Frame field on
the Hyperlink dialog box to change the window in which the
destination page appears.

The possible values that you can enter into the Target Frame field
are explained below.

If you want the destination page to appear

Click this in the Target Frame
field

In a new browser window, on top of the current
browser.

New Window(_blank)

In the same position within the browser window.
The new window replaces the current one.

Same Window(_self)

If your page contains frames, in the frame that
contains the frame with the hyperlink.

Parent Window(_parent)

If your page contains frames, in the full display
area, replacing the frames.

Browser Window(_top)

If your page contains frames, in the frame with the
specified name.

Enter the name of the frame.

Note: this is the default.
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Use hyperlinks to let a user “jump” from any word, phrase or image
to another Web page. The page can be within your network (that is,
on an intranet) or anywhere on the internet.
NOTE

If you want to create jumps within a file, see “Using Bookmarks” on page 599.

For example, if your Web page includes a jump to the Ektron Web
site, you would enter the text to indicate the jump (for example
Ektron Web Site), then create a hyperlink to www.ektron.com. When
users see Ektron Web Site in a different color, they can click the
text to “jump” to the site.
Although most jumps go to the top of another Web page, you can
also jump to a bookmark within a Web page.
This section explains

• ”Creating a Hyperlink” on page 603
• ”Testing a Hyperlink” on page 606
• ”Creating a Hyperlink to a Location Within a Web Page” on
page 606

• ”Editing a Hyperlink” on page 607
• ”Removing a Hyperlink” on page 608
• ”Preventing a URL from Becoming a Hyperlink” on page 608

Creating a Hyperlink
When creating a hyperlink, you must specify a

• source, the text or image the user clicks to move to the
destination

• destination, the Web page to which the display moves when
the user clicks the source
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To continue with the above example, Ektron Web Site is the
source, and the Web page available at www.ektron.com is the
destination.
To create a hyperlink, click the Hyperlink button ( ). When you do,
the Hyperlink dialog box appears. From there, you can select from
a list of Web pages (also known as Quicklinks). Or, if the page you
are jumping to is not on the list, enter the URL address of the
destination Web page.
Each choice is described below.

Using a Quicklink
Your Web master can add to the Hyperlink dialog box any number
of Quicklinks, that is, Web addresses that you can link to simply by
selecting an item from a drop down menu.

Quicklinks are “quick” because you do not need to enter or know
the URL of the destination Web page -- your Web master has
already stored that information for you.
To apply a Quicklink, follow these steps.
1. Select the source text or image.
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2. Click the Hyperlink button (
appears.

). The Hyperlink dialog box

3. Click the down arrow to the right of the Quicklink field. A list of
Web pages that your Web master has pre-loaded appears.
4. Click an item from the list to select it.
5. If desired, you can use the Target Frame field to change the
window in which the destination text appears. For details, see
“Changing the Destination Window” on page 602.
If you leave the Target Frame field blank, the new window
replaces the current window
6. Click OK.

Entering a Hyperlink Manually
To create a hyperlink, follow these steps.
1. Select the source text or image.
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2. Click the New Hyperlink button (
appears.

). The Hyperlink dialog box

3. Click in the Link field after http://. Then, enter the address of
the destination Web page. For example, to enter a hyperlink to
the ektron Web site, enter www.ektron.com.
4. If desired, you can use the Target Frame field to change the
window in which the destination text appears. For details, see
“Changing the Destination Window” on page 602.
If you leave the Target Frame field blank, the new window
replaces the current window
5. Click OK.

Testing a Hyperlink
Within the eWebEditPro+XML editor, you can test a hyperlink. To do
this, select the hyperlink then double click it. That action launches
the Web page assigned to the hyperlink.

Creating a Hyperlink to a Location Within a Web Page
Sometimes, the destination Web page contains bookmarks, and
you want to jump from your page to a bookmark on another page.
(Bookmarks are described in “Using Bookmarks” on page 599.)
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To create a hyperlink that jumps to another page’s bookmark,
follow these steps.
1. Go to the destination Web page.
2. Click the bookmark that you want to jump to. For example, on
the illustration below, the text Benefits to Partners jumps to a
bookmark further down on the page.

3. When you click the bookmark, its full address appears in your
browser’s address bar. This bookmark’s address looks like this.
http://www.ektron.com/single.cfm?doc_id=35#Benefits2

4. Click the address bar. The address is selected. Press
<Ctrl>+<C> to copy the address into the Windows clipboard.
5. Go to eWebEditPro+XML.
6. Select the text or image from which you want to jump to the
bookmark.
7. Click the Hyperlink button (
appears.

). The hyperlink dialog box

8. Move the cursor to the Link field.
9. Press <Ctrl>+<V> to paste the address you copied in Step 4
into the Link field.
10. Click OK.

Editing a Hyperlink
If you need to change a hyperlink’s destination Web page or target
frame, follow these steps.
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1. Click the Hyperlink button (
appears.

). The hyperlink dialog box

2. Edit the Link or Target Frame field as needed.
3. Press OK.

Removing a Hyperlink
If you want to remove the hyperlink from text or an image, select
the text or image and press the Remove Hyperlink button (

).

Preventing a URL from Becoming a Hyperlink
If you enter a URL or an email address into eWebEditPro+XML, it
automatically becomes a hyperlink. To prevent this, enter an extra
space in the URL or address.
For example, instead of entering sales@ektron.com, enter
sales<blank>@ektron.com.
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eWebEditPro+XML creates pages for display on the World Wide

Web or an intranet. These pages use HTML (hypertext markup
language) to format text and images for display in a browser. You
do not need to know HTML to use eWebEditPro+XML.
However, if you know HTML, you can view, insert or edit your Web
page’s HTML code.
This section explains

• ”Viewing and Editing HTML” on page 609
• ”Inserting Source” on page 610
• ”Cleaning Source Code” on page 611
• ”Inserting Content from MS Office” on page 612

Viewing and Editing HTML
When you choose to view your page as HTML, the editor cleans
the content using a method determined by your Webmaster. (For
more information, see “Cleaning HTML” in the eWebEditPro+XML
Developer’s Reference Guide.)
To view your page’s HTML, follow these steps.
1. Click the View as HTML button ( ), or right click the mouse
and click View as HTML from the menu.
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2. The HTML code appears. While viewing the code, you can edit
it using editor functions such as Cut, Copy, Paste and Replace.
To select all content, press <Ctrl>+<A>.
You can also set default values for the style, size and color in
which the HTML appears. To do this, right click the mouse and
click Preferences. When you do, a dialog box appears in which
you can enter formatting information about the HTML code.

These settings will be used whenever you view as HTML.
The settings are ignored when you view the page in WYSIWYG
mode and when the user views the page.
3. To return to normal view, click the View as WYSIWYG button
( ) or right click the mouse and click View WYSIWYG.

Editing a Section of a Page
If you want to edit only a section of the HTML on your Web page,
follow these steps.
1. Select the portion of your Web page that you want to edit.
2. Right click the mouse.
3. Click Edit Source from the menu. The HTML code appears.
4. Edit the HTML code as desired.
5. Click OK.

Inserting Source
If you want to insert HTML source code into your Web page, follow
these steps.
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1. Place the cursor at the spot on the page where you want to
insert the HTML.
2. Right click the mouse.
3. Click Insert Source from the menu.
4. The Insert Source dialog box appears. Paste or type your
HTML code.
5. Click OK.

Cleaning Source Code
eWebEditPro+XML lets you “clean” the HTML source code for your

Web page. You would typically use this feature after entering
HTML text or pasting HTML code into eWebEditPro+XML from
another application.
The Clean Source option removes unnecessary HTML tags,
ensures that all tags begin and end properly, and maximizes the
page for efficiency. As a result, the page should be error-free and
load more quickly in a browser. Also, the appearance of clean
HTML is more consistent when viewed in different browsers.
To clean your HTML, follow these steps.
1. Right click the mouse.
2. Click Clean Source from the menu.
3. eWebEditPro+XML cleans your Web page’s HTML content.
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Inserting Content from MS Office
If you paste text into eWebEditPro+XML from a Microsoft Office
2000 (or higher) application, such as Microsoft Word, the following
window appears.

For best results, click Yes.
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This section explains how eWebEditPro+XML complies with
Section 508 of the Rehabilitation Act (a law enacted by the
United States government that requires Federal agencies to
make their electronic and information technology accessible to
people with disabilities).
Specifically, this section explains the following topics.

• ”Moving the Cursor into eWebEditPro+XML” on page 613
• ”Using eWebEditPro+XML without a Mouse” on page 614
• ”Section 508 Tables” on page 616

Moving the Cursor into eWebEditPro+XML
Using Internet Explorer
If the eWebEditPro+XML editor is one of several fields on a
page, and your browser is Internet Explorer, move to
eWebEditPro+XML by pressing <Tab> until the cursor lands in
the editor.
To move from the editor to the next field, press <Ctrl>+<Tab>.

Using Netscape
If the eWebEditPro+XML editor is one of several fields on a
page, and your browser is Netscape, your Webmaster needs to
create custom toolbar buttons that let you move into and out of
the editor. (This procedure is described in the
eWebEditPro+XML Developer’s Reference Guide.)
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Using eWebEditPro+XML without a Mouse
As explained in ”Customizing Your Toolbar” on page 480, the
eWebEditPro+XML toolbar consists of one or more toolbar
menus. Menus have buttons that you click with the mouse to
perform actions, such as copying text.
This section explains how to perform those actions without using
the mouse.
1. With the cursor in the eWebEditPro+XML editor, press the
application key (

).

2. A menu appears.

3. Press the down arrow key ( ) to select Menus. Menus
becomes highlighted.

4. Press <Enter>. A new menu lists all toolbar menus available to
you.
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If your Webmaster has given you access to all standard toolbar
menus, the menu looks like this.

5. Press the down arrow key ( ) to select the toolbar menu that
has a button that you want to use.
6. A new menu appears, listing all options on the selected menu.
The following menu displays what might appear if you select
the Edit Menu. (Your Webmaster determines which menu
options are available).
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7. Press the down arrow key ( ) until the desired option is
highlighted. Then, click the option to perform the action.

Section 508 Tables
You can apply the following information to any table to make it 508
compliant.

Information

Where applied

For more information, see

Heading Rows

Accessibility dialog

”Accessibility Dialog” on
page 619

Heading Columns

Accessibility dialog

”Accessibility Dialog” on
page 619

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

616

Section 508 Compliance

Information

Where applied

For more information, see

Summary

Accessibility dialog

”Accessibility Dialog” on
page 619

Caption

Accessibility dialog

”Accessibility Dialog” on
page 619

Horizontal Caption
Alignment

Accessibility dialog

”Accessibility Dialog” on
page 619

Vertical Caption
Alignment

Accessibility dialog

”Accessibility Dialog” on
page 619

Abbreviation

Cell properties dialog

”Accessibility Fields on Cell
Properties Dialog” on page 621

Categories

Cell properties dialog

”Accessibility Fields on Cell
Properties Dialog” on page 621

WARNING!

The Section 508 Table Properties dialog only works if Internet Explorer version
6.0 or higher is installed. Once that is installed, any browser can be used
(Netscape, FireFox, IE, etc.).

WARNING!

Even if you change no values on the screen, you must open the Accessibility
dialog whenever you modify a table (for example, add a new row). The table’s
properties, required for Section 508, are generated when you click OK to close
the dialog box.

To create a 508 compliant table, follow these steps.
1. Create a new table or edit an existing one, as explained in
”Introduction to Tables” on page 554.
2. Select the table by moving the cursor to a table border until you
see a four headed arrow (illustrated below). When a table is
selected, small squares surround it.
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3. Click the Tables button (

).

4. Click Table Properties.
5. The Table Properties dialog appears.
6. Click the Accessibility button.
NOTE

Your system administrator can add or remove the Accessibility button from the
Insert Table dialog.

7. The Accessibility dialog appears.
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Accessibility Dialog
Respond to the fields in the dialog. They are described below.

Field

Description

Heading
Rows

If you want your table to have a horizontal header, enter
the number of rows that it should occupy.
Beginning with the top, all cells in the specified number
of rows are designated as table headers.

Heading
Columns

If you want your table to have a header, enter the
number of columns that it should occupy.
Beginning with the left column, all cells in the specified
number of columns are designated as table headers.

Summary

If desired, enter the table summary. Non-visual browsers
can use the summary to explain the contents of the
table.
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Field

Description

Caption

If desired, enter the table caption. The caption appears
centered below the table when viewed.

Horizontal
Caption
Alignment

If desired, enter the caption’s horizontal alignment:

Vertical
Caption
Alignment

•
•
•

center
left
right

If desired, enter the caption’s vertical alignment:

•
•

bottom
top

After you complete the Table Properties dialog, click OK to make
the table comply with Section 508.

Setting Abbreviation and Category Attributes
You can modify abbreviation (ABBR) and category (AXIS)
attributes within a table. To do so, follow these steps.
1. Select one or more cells.
2. RIght click the mouse.
3. Select Table > Cell Properties.
4. Access the Cell Properties dialog.
The Cell Properties dialog includes fields that let you adjust the
Abbreviation and Category Attribute field values (see illustration
below).
NOTE

Your system administrator can add or remove the Accessibility fields from the
Cell Properties dialog.
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The following explains how to respond to these fields.

Accessibility Fields on Cell Properties Dialog

Field

Description

Abbreviation

Sets or retrieves abbreviated text for the content in the
tag. Can be used to render non-visual media, such as
speech or Braille.
For more information, see http://msdn.microsoft.com/

library/default.asp?url=/workshop/author/dhtml/
reference/properties/abbr.asp
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Field

Description

Categories

Sets or retrieves a comma-delimited list of conceptual
categories associated with that tag. Can be used to
render non-visual media, such as speech or Braille.
For more information, see http://msdn.microsoft.com/
workshop/author/dhtml/reference/properties/axis.asp
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Content

While editing Ektron CMS400.NET content, you can insert
comments to the content. Comments might be an author’s note to
himself or other authors about the content. For example, you could
insert a comment explaining why you are using a certain style
class.
Comments are only visible during editing -- they do not appear
when the content is published on your Web site.
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Other users can add comments to your comments. This feature is
know as “Content Collaboration.”
Similar to other word processing programs, comments can be
added, updated, and tracked to audit changes being made.
This section explains the content collaboration feature.
WARNING!

Do not confuse these comments, which are inserted within the content, with
history comments, which are inserted outside the content and used to indicate
what changed during an editing session.

Adding Comments to Content
To add a comment to content, follow these steps.
1. Create new content or edit existing content. See Also: ”Adding
Content” on page 45
2. In the editor, place the cursor where you want to insert the
comment.
3. On the editor toolbar, click the Insert Comment button (

).

4. The Ektron CMS Comment window opens.
5. Insert a comment. Use the toolbar to format the text if desired.
6. Click the Insert button.
7. The comment is saved.
8. Click the Close button.
9. The comment window closes, and a comment icon is placed
where the comment was added to the content.
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Each comment appears in the table at the top of the window. From
this window, you can add another comment and update an existing
one. See the next section for more details.

Viewing a Comment
After a comment is inserted into content, it can be viewed by any
user who can edit the content. To view a comment, follow these
steps.
1. Edit the content that contains the comment.
2. Within the content, double-click the comment icon.

3. The Comments window opens.

Adding Another Comment
To comment on an existing comment, follow these steps.
1. Access the View Comment window for the comment, as
described in ”Viewing a Comment” on page 625.
2. Insert the comment.
3. Click the Insert button.
4. The comment is saved and added to the top row of the
comment table.
5. Click the Close button.

Updating a Comment
You can change a comment if needed. To update a comment,
follow these steps.
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1. Access the View Comments window for the comment that
needs to be updated.
2. Click the Date/Time link of the comment you want to edit.

3. The comment editor opens with the selected comment in it.
4. Update the comment.
5. Click the Update button to save the changes.
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Click the Mathematical Expression button ( ) to display the
Math Expression editor, which lets you enter equations into
Ektron CMS400.NET content.
The editor (WebEQ Input Control) is created by Design
Science, Inc. For more information, go to http://
www.dessci.com/en/products/webeq/interactive/inputctrl.htm.

Prerequisites for the Math Editor
Sun Java VM 1.4 (http://java.sun.com/j2se/1.4.2/
download.html)

• Recommended version: 1.4.2
• Required version: 1.4

Using the Math Expression Editor
After you click the Mathematical Expression button (
editor appears.
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Note that you can easily change the expression’s font size, color,
and background color via the Properties area (lower left corner).

The Toolbar
The editor’s toolbar provides special characters that are not
otherwise available. While entering an expression, you can use
that toolbar along with your keyboard to compose the expression.
Use the toolbar to insert equation templates and symbols. It also
has buttons for common operations like cut and paste.
The standard toolbar contains three main panels. The left side of
the toolbar consists of pull-down menus displaying a variety of
equation templates. Templates are highlighted as you mouse over
them. To insert a template, click or release the mouse over a
highlighted template.
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The middle section of the toolbar consists of pop-up palettes
containing symbol characters. As with template palettes, you insert
a symbol by mousing over to highlight, and then releasing or
clicking the mouse.
Equation template and symbol character palettes are broadly
organized by theme, such as 'calculus templates' or 'arrow
symbols'. Spend a few minutes exploring the toolbar to familiarize
yourself with the available templates and symbols.
The right side of the toolbar is a toolbox of icons for various editor
operations. In addition to the standard cut, copy, paste, and undo
icons, there are buttons for shrinking and magnifying the current
equation, a check syntax icon, and a help icon.

Saving and Editing a Mathematical Expression
A mathematical expression is saved as an image. When you are
ready to save it, enter a file name and description in the Image
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Properties area (lower right corner) and press OK. The
expression then appears within the content.

Later, if you want to edit the expression, select it, right click the
mouse, and select Edit Math. When you do, the Math Expression
editor reappears with the expression. Edit as needed then press
OK.

Accessibility and the Mathematical Expression
Editor
To get a white paper, Making Mathematics Accessible, on
accessibility and MathML, see http://www.dessci.com/en/
reference/accessibility/.
NOTE

The rest of this chapter was copied from documentation provided for the Math
Expression Editor by Design Science, Inc (http://www.dessci.com/en/).
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Editor Overview
The Math Expression editor is based on the idea of an equation
template. It includes templates for fractions, subscripts,
superscripts, matrices, etc. To build an equation, insert templates
and then fill in the blanks.

To fill in the blanks, enter letters and numbers from the keyboard,
select symbols from a palette, or replace a blank with another
template. If you select something before inserting a template from
the toolbar, the selected symbol or expression is inserted into the
first blank in the template. Some people describe this as wrapping
a template around a selection.
By nesting equation templates inside each other, you can build up
almost any equation. Navigate around an equation using the
mouse and arrow keys. You can also cut and paste
subexpressions to build up more complex expressions.
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The Math Expression Editor templates and symbols are based on
MathML. MathML is a markup language for encoding math on the
Web, standardized by the World Wide Web Consortium (W3C).
You can use the Math Expression Editor without knowing much
about MathML. However, if you want to understand more, read A
Gentle Introduction to MathML.
As an example, here is the MathML source code for a very simple
expression, x + 4.
<math><mi>x</mi><mo>+</mo><mn>4</mn></math>

Moving the Cursor
The Math Expression Editor tries to make cursor movement as
natural and as intuitive as possible. In general, the left, right, up
and down arrows move the cursor to the next valid insertion point
in the corresponding direction. Similarly, clicking the mouse
anywhere in an equation moves the cursor to the closest valid
location to the click.
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Behind the scenes, the editor is negotiating a complicated, nested
structure of MathML templates. Moving the cursor to the right on
the screen can involve jumping in and out of MathML structures
behind the scenes.
The cursor may occasionally not move exactly as you would
expect on account of the nesting of the MathML structure. In these
cases, the cursor movement is giving you additional information
about the structure of your equation.
To help you follow where the cursor is in the MathML structure of
the equation, Math Expression editor gives two visual cues. The
cursor position is represented by a blinking red vertical bar.
However, note that there is a faint gray rectangle as well. This gray
rectangle is outlining the equation template containing the cursor
location, and is the first cue about the MathML structure near the
cursor.
To illustrate, consider stepping through the following equation with
the right arrow.

As the cursor moves to the right, note that as it moves into the
fraction, the outline shifts to the fraction, instead of the entire
equation.

Entering Symbols
For simple equations, you may only need the letters, symbols and
digits available on the keyboard. However, in many situations, you
will want to enter special mathematical symbol characters. You can
enter a symbol in an equation by clicking it on the toolbar, or by
selecting it from one of the symbol palettes, also on the toolbar.
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The standard toolbar configuration contains many commonly used
symbol characters.

Generating Content Markup
MathML can describe an equation in two ways. Presentation
markup describes the way an equation should look, and content
markup describes what an equation means. Ordinarily, editing an
equation is a process of getting its appearance to look right, and so
by default, Math Expression editor uses presentation markup for
an equation in progress. When you finish your equation, Math
Expression editor can apply sophisticated algorithms to try to
discern the mathematical meaning of your equation, and generate
a content markup description as well.

Strengths and Weaknesses of Content Markup
Not all equations can be described with content markup. For
example, in presentation markup, it is fine to type “1 + 2 -”. This is
just a sequence of symbols as far as its appearance is concerned.
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However, from a mathematical viewpoint, this is an unfinished
expression that doesn't have a well-defined meaning. If you try use
Math Expression editor to generate content markup from this
expression, it warns you that it can't since the “-” operator expects
something to its right. You could only generate content markup by
completing it as a mathematically meaningful expression, say “1 +
2 - 3".
Also, MathML content markup only covers basic mathematics,
roughly up to calculus. Even if you have a meaningful math
expression, it may fail to translate to content MathML if it is too
complicated or advanced.
Another problem with content markup is that the author has less
control over how an equation renders visually. For example, when
viewing the content version of an equation, extra parentheses are
sometimes automatically added or removed. Also, most visual
style properties you may have changed are lost in the translation to
content MathML.
Nonetheless, content MathML can be very useful. For one thing, it
is relatively easy to evaluate in a computation engine. Also, a
single, content-encoded equation can be rendered differently,
depending on context, than a presentation equation. For example,
in some experimental MathML environments, users can choose
among various common notations for derivatives by editing a style
sheet. Content MathML can also be very useful for teaching and
learning about the structure and meaning of math expressions.

Checking Syntax
Two problem areas can cause the Math Expression editor content
markup generation algorithms to fail.

• The equation is too advanced or complicated to be represented
as content markup, as described above.

• Problems with the equation structure prevent the algorithms
from guessing what you mean.
You can’t do much about the first problem. However, there is a lot
you can do to avoid the second.
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The key to content markup generation is to ensure there are no
surprises in the nesting of templates in the equation. The content
generation algorithms rely heavily on the grouping of templates in
the equation as a hint to the underlying meaning.
The main things that can cause problems are:

• Inadvertently separating an operator and its arguments with
spurious expression groups. For example:

• Mismatched fences

• Confusion over function application and multiplication

function sinx

multiplication sin*x

• Confusion over the symbol “d”.

differential function

just multiplication d/dx*f

• Inherently ambiguous notations.

open interval or vector

closed interval or list
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To assist in diagnosing these problems, you can check your
equation by clicking the “check mark” button on the far right of the
standard toolbar. This action highlights parts of your equation
based on the role Math Expression editor thinks they play in your
equation, as well as revealing “invisible times” operators, and
expression grouping.

You can toggle back and forth between syntax highlighting and
regular display by clicking the check mark button again. Also,
starting to edit switches the equation to normal mode.
If there are obvious problems with your equation, Math Expression
editor displays an error message in the editor status line, and
highlight the template where the error was detected in blinking red.
As long as you don't see any errors, Math Expression editor is
generating some content markup encoding of your equation.
However, you should always look carefully to be sure that there
aren't any subtle errors in the translation, such as extra invisible
multiplications.
The color of symbols in a highlighted expression denotes the role
the content generation algorithm thinks it plays in your equation.
The color codes are as follows.

Color

Syntactic role

red

operator

blue

operand

green

function

Fixing Problems
Math Expression editor tries to automatically do the right thing to
avoid content generation problems. However, it is still possible to
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confuse the content generation algorithms. The following explains
more about correcting problems with content generation.

• Inadvertently separating an operator and its arguments with
spurious expression groups
In general, the content generation algorithms treat expression
groups as if they have parentheses around them. Thus, for
example, in the expression

The extra inner expression group leads Math Expression editor to
treat this like x(-y), that is, x times -y, not x minus y. To avoid this
problem, pay attention to the parent highlighting as you edit,
especially after cut and paste operations which can introduce extra
expression groups. Strange nesting of expression groups is also
usually easy to spot with content syntax highlighting.

• Mismatched fences
Math Expression editor needs to be able to match up right and left
“fence” characters such as absolute value bars, parentheses,
braces and brackets. Therefore, it is best to make sure that
matching fences are always contained in an expression group.

• Confusion over function application and multiplication
Mathematical notation is often ambiguous. There is often no
algorithmic way to determine when an expression denotes invisible
multiplication and when it denotes function application.

One way to avoid confusion is to explicitly insert invisible “function
application” and “invisible times” characters. These characters can
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be inserted from the toolbar. However, because they are invisible,
use of these characters is inherently error prone.

• Confusion over the symbol “d”.
The special character “d” is frequently ambiguous in math
expressions involving differentiation and integration. Is it just a
variable, or is it the differential d?
MathML has a separate character to represent differential d to
clear up the ambiguity. With Math Expression editor, you can
ensure you are getting the special version of the character and not
the generic variable by using the calculus templates on the toolbar
instead of the keyboard.

• Inherently ambiguous notations
To give authors control over the conversion of inherently
ambiguous notations, WebEQ provides a way of giving semantic
hints using the MathML 'other' attribute on an expression. The
syntax for hints is a comma separated list of rule:value pairs:
other="rulename:value, rulename:value, ..."

Valid rule names and values are listed below.

Notation

Rule name

Legal values

Default value

vector-interval-rule

interval | vector

interval

list-interval-rule

interval | list

interval

mean-moment-rule

mean | moment

mean

Navigating with the Cursor
Most of the time, cursor movement in Math Expression editor
works as you would expect. However, as the cursor moves through
your equation, its shape changes to give you extra information
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about the equation structure. Spending a few minutes learning
about the subtleties of cursor movement will have a big pay off in
the long run.

Moving the Cursor
The arrow keys move the cursor around in the equations. In
general, the editor tries to move the cursor to the next valid
insertion location in the direction of the arrow key. For example, in
templates such as fractions and matrices, the vertical arrows to
move up and down.
In addition to the arrow keys, you can also position the cursor with
the mouse. The editor tries to move the cursor to the insertion point
nearest to a mouse click.
Usually, Math Expression editor does a good job of judging when
to ignore all the layers of MathML nesting and jump ahead to the
next reasonable place to begin inserting characters again.
Sometimes, however, it can be difficult to navigate the cursor into a
deeply nested structure using the arrow keys. If you find yourself
having a hard time getting the cursor where you want it with the
arrow keys, use the mouse to position the cursor where you need
it.

Cursor Shapes
Math Cursor
When you start a new equation, the cursor automatically starts as
a blinking vertical red line. When the Math Expression editor
window loses focus, the cursor changes to gray and stops blinking.
The vertical line is the normal cursor in Math Expression editor.
As you type, the editor begins inserting characters into the
equation, and the cursor moves to show the insertion point. Also, a
faint gray box appears, outlining the template in which the cursor is
currently located. As you move around in an equation, the gray
outline shifts, giving you a visual cue about the nesting structure of
the underlying MathML, as illustrated below.
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In the first two illustrations, the cursor is located in the numerator
and denominator of a fraction, and the outlined parent is the row
template containing the entire numerator and denominator
respectively. In the third illustration, the cursor is on the left edge of
the fraction itself, and the outlined parent is a “wrapper” row
containing nothing but the fraction itself.
Token Cursor
Math Expression editor automatically puts characters into special
MathML templates called tokens. There are tokens for variables
(called an <mi> template in MathML for math identifier), numbers
(<mn>), operators (<mo>), etc.
The right and left arrow keys generally move the cursor between
the tokens in the row. However, when you move the cursor over a
token that contains several characters together, the cursor takes
an upside-down, T-shape to show the extent of the grouped items
by underlining them, as shown below.

Within a token, the arrow keys move the cursor between the
individual characters in the token. You can also position the cursor
within a multi-character token using the mouse.
In MathML, identifier tokens with more than one character, for
example “sin”, are rendered in an upright font by default, while
single character tokens are rendered in italics. If you move two
alphabetic tokens together, say by deleting an intervening space,
the editor merges the characters together into a single token. A
similar behavior applies to numbers. By noticing the cursor shape,
you can easily keep track of what characters are being grouped
into tokens.
Text Cursor
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Math Expression editor also supports the MathML text template.
Within a text template, characters appear in an upright font by
default, and the spacebar always inserts a space. (Outside a text
template, the spacebar may not insert a space. See Math
Expression editor: Keyboard Input for details.)
When the cursor is in a text template, it changes to an “I-beam”
shape as shown below.

You can insert a text template from the layout templates palette on
the toolbar.

Template Blanks
When you insert a new template into an equation, small squares
indicate the empty slots, or template blanks, where data should be
inserted.
When you insert a template, the cursor automatically jumps to the
first template blank. If you want to fill in the template blanks later,
move the cursor out of the template without entering characters.
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Just reposition the cursor in the template when you are ready to fill
it in.
Moving Directly to Template Blanks
Because selecting a template blank is such a common task, there
are two kinds of shortcuts. Hitting the <TAB> key cycles between
all open template blanks. You can also move the cursor to a
template blank by clicking it with the mouse.

Keyboard Input
Typing letters, numbers and symbols from the keyboard inserts
them into the current equation at the current cursor position. In
addition, special “keyboard shortcuts” can be used to cut, paste,
insert templates and perform other useful functions. Both kinds of
keyboard input are described below.

Inserting Characters
In MathML equations, all characters are categorized according to
type. In Math Expression editor, the most important types are text,
identifiers, numbers and operators. These types correspond to the
MathML elements <mtext>, <mi>, <mn> and <mo>. In MathML, these
basic character types are called tokens.
As you enter characters from the keyboard, Math Expression
editor analyzes the input and automatically inserts the characters
into the appropriate MathML token element. Ordinarily, this results
in the appropriate MathML markup, and makes authoring MathML
equations much easier. As with any automatic algorithm there are
cases where problems can arise. However, by understanding how
Math Expression editor chooses token types for characters, you
can easily avoid or correct problem situations.
When two or more characters of the same type are entered in
succession, Math Expression editor places the characters into the
same MathML token element. Thus, typing 's', 'i', 'n' results in a
single identifier token containing 'sin'. Similarly, if you place two or
more characters of the same token type together by some other
means, such as cut and paste, backspacing, etc. Math Expression
editor merges them together into a single token.
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Math Expression editor uses the following rules to decide what
token type to assign to characters.

• A run of alphabetic characters is placed in an identifier, or
<mi>, token.

• A run consisting of digits, commas and or periods are placed in
number, or <mn>, token.

• By default, everything else is placed in an operator, or <mo>,
token. Whenever you enter a character of a type that doesn't
match the preceding characters, the editor starts a new token
for it.
When problems arise, they usually result when a run of characters
should be broken into several tokens, or when separate tokens
merge as a result of editing. Here are the most common issues.

Invisible Multiplication
MathML uses an “invisible multiplication” character to make explicit
when two variables or expressions are being multiplied. For
example, ab might mean “a times b”, or the two-letter variable “ab”.
Similarly a(b+c) might mean “a times b + c” or it might mean, “apply
a function a to the argument b+c”.
Math Expression editor's automatic tokenizing behavior helps
remind you code equations properly, since if you just type “a”
followed by “b”, it groups them both into one token and switches
the typeface to upright. This is a visual cue that what you entered
was the two-letter variable “ab”. To enter “a times b”, you need to
put an invisible times between them.
By default, when you hit the space bar following an identifier, Math
Expression editor inserts an InvisibleTimes character. By doing so,
the “a” and the “b” each go into identifier tokens of their own, with
the InvisibleTimes operator token in between. The “a” and the “b”
remain in the customary italic typeface, giving you a visual cue that
you have encoded a multiplication.
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If you press the space bar after anything other than an identifier,
Math Expression editor inserts a space character as usual.

Text Tokens vs. Identifiers
Ordinarily Math Expression editor assumes alphabetic characters
are identifiers. Sometimes, however, you may want to treat a run of
alphabetic characters and spaces as text. In particular, if you are
entering a bit of descriptive text in an equation, you want the space
bar to insert spaces, not InvisibleTimes characters.
You can tell Math Expression editor to treat a run of characters as
text by inserting a text template from the toolbar. When you insert a
text template, the editor assumes subsequent alphabetic
characters and spaces should be treated as text, and won't break
them into smaller tokens. See Also: ”Text Cursor” on page 641
To switch out of a text token to an identifier token, enter a number
followed by the identifier. Then delete the number. Entering the
number starts a number token, and the following alphabetic
character then starts an identifier token as usual.

Merging Style Properties
When two token elements with differing style properties merge, the
resulting token may or may not have the desired style properties.
There is no alternative but to reset style the properties of the new
token when this happens.

Keyboard Shortcuts
Though most people prefer to use menus and a mouse when first
learning an application, in the long run it is often more convenient
to use keyboard shortcuts for common operations. Math
Expression editor has a number of useful shortcuts, which are
listed below.

Template Shortcuts
These keyboard shortcuts handle the insertion of templates.
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Shortcut
Key

Action

Supported Platforms

<Ctrl>+r

insert row template (<mrow>)

all

<Ctrl>+ y

insert style change template (<mstyle>)

all

<Ctrl>+ t

insert text template (<mtext>)

all

<Ctrl>+f

insert fraction template (<mfrac>)

all

<Ctrl>+/

insert fraction template (<mfrac>)

not MAC OSX

<Ctrl>+L,
<Ctrl>+B,

insert subscript template (<msub>)

all

<Ctrl>+H,
<Ctrl>+P,
<Ctrl>+^

insert superscript template (<msup>)

all

<Ctrl>+J

insert sub and superscript template
(<msubsup>)

all

<Ctrl>+Q

insert square root template (<msqrt>)

all

<Ctrl>+R

insert nth root template (<mroot>)

all

<Ctrl>+P

insert parenthesized expression template

all

<Ctrl>+0,
<Ctrl>+9

insert parenthesized expression template

not MAC OSX

<Ctrl>+i

insert definite integral template

all

<Ctrl>+ _

Also, pressing the caret character (^) adds a superscript to the
previous expression. So, for example, if you enter x^2, the result is
an x with a superscript of 2.

Navigation and Selection Shortcuts
These keyboard shortcuts facilitate cursor navigation and
selection.
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Shortcut
Key

Action

Supported
Platforms

<Tab>

Cycles the cursor among open template blanks in an
equation. After all templates are visited, <TAB> moves the
cursor to the end of the equation.

all

Continuing to hit TAB repeats the cycle.
<Enter>

When the cursor is at a location in the MathML structure
where a on-line is a valid action, <Enter> inserts one.

all

<End>

Moves cursor to end of current line.

all

<Home>

Moves cursor to beginning of current line.

all

<Ctrl>+
<Home>

Moves cursor to beginning of equation.

all

<Ctrl>+
<Enter>

Move cursor to end of equation.

all

<Shift> ->

Extends selection to right.

all

<Shift> <-

Extends selection to left.

all

<Ctrl>+ A

Select all.

all
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Appendix A: Content Statuses
The table below describes all possible content statuses. The rest
of this appendix explains each status in more detail.

Letter

Border
Color

Meaning

Content state

More Information

A

green

Approved

Through the workflow and
published on the Web site.

”Active Content” on
page 649

O

red

Checked Out

Currently being edited. Has
not been checked in.

”Checked Out
Content” on
page 651

I

green

Checked In

Checked in for other users
to edit.

”Checked-In
Content” on
page 650

S

yellow

Submitted for
Approval

Saved and submitted into
the approval chain.

”Submitted Content”
on page 652

See Also: ”Approving/
Declining Content” on
page 81

M

yellow

Marked for Deletion

Requested for deletion.

”Marked for Deletion
Content” on
page 653

P

grey

Pending Go Live
Date

Approved but the Go Live
date hasn’t occurred yet.

”Pending Start Date
Content” on
page 654

T

Awaiting Completion
of Associated Tasks

Task(s) assigned to content
are not complete

D

Pending Deletion

Content was created with a
future start date then
checked in and deleted.
This status only remains
until the start date is
reached. At that point, the
content is deleted.
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Active Content
If content has a green border, it is live on the Web site.

When content is active, you can perform the following actions on it,
depending on your permissions.
The content’s status remains active until it is checked out and
changes are made to it.
.
Button

Name

Description

For more information,
see

Edit

Check-out the content to
change it.

”Editing Content” on
page 49

Edit Summary

Edit the brief summary used to
describe the content.

”Adding a Content
Summary” on page 67

Edit Metadata

Change the content’s metadata.

”Adding or Editing
Metadata” on page 71

Delete

Submit a request to delete the
content. If you are the last or
only approver, the content is
immediately deleted.

”Adding Content” on
page 45

See Also: ”Example of an
Approval Chain” on page 85
Back

Go to previous window.
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Checked-In Content
If content has a green border, it could mean that the content is
checked in. A checked-in content item is one to which changes
were made, after which it was checked in instead of being
submitted or published. When content is checked in, it is
accessible to all users who have permissions to edit it. They can
check it out and change it.
Keep in mind that the content seen on the template is not the same
as the content in the editor view.

See Also: ”Example of an Approval Chain” on page 85
Each option you may perform on checked-in content is described
below.

Button

Name

Description

For more information, see

Edit

Check-out the content to
change it.

”Editing Content” on page 49

Edit Summary

Edit its summary.

”Adding a Content Summary”
on page 67

Edit Metadata

Edit its metadata.

”Adding or Editing Metadata” on
page 71
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Button

Name

Description

Submit/Publish

Submit content into approval
chain.

For more information, see

If you are last approver in the
approval chain, the publish
button appears. If you click it,
the content is immediately
posted to Web site.
View Staged/
Published

View Staged button - displays
content that hasn’t been
published yet.

”Staged Content” on page 654

View Published button displays content live on the Web
site.
Delete

Submit a request to delete the
content into approval chain. If
you are the last or only
approver, the content is
immediately deleted.

Back

Go to previous window.

”Example of an Approval Chain”
on page 85

Checked Out Content
If content has a red border, it was checked out by a user other than
you. (If you checked it out, the border is green.) While in this
status, other users are prevented from editing the content.

The content remains checked out until it is checked in by the user
who checked it out or your system administrator.
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Each option you may perform on checked-out content is described
below.

Button

Name

Description

Check In

Check in content.

View Staged/
Published

Click the View Staged button to view the content that has not
yet been published.
Click the View Published button to view the content that is live
on the Web site.

See Also: ”Staged Content” on page 654
Back

Go to previous window.

Submitted Content
A yellow border shows that a user has submitted the content into
the approval chain. The border remains yellow until the content is
published or declined. While the content is in the approval chain,
no user can check it out.

See Also: ”Example of an Approval Chain” on page 85
Each toolbar button is described below.
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Button

Name

Description

Submit

Submit the content into the approval chain.

See Also: ”Example of an Approval Chain” on page 85
Publish

Approve and publish the content to the Web site.
Note: You have this option only if you are the last approver in the
chain.

See Also: ”Example of an Approval Chain” on page 85
Decline

Refuse to publish the submitted content, and change its status
to checked-in.

Edit

Check out the content and make changes to it.
Note: If you edit the content, you need to re-submit it to the
approval chain.

View Staged/
Published

Click the View Staged button to view the content that has not
yet been published.
Click the View Published to view the content that is live on the
Web site.

See Also: ”Staged Content” on page 654
Back

Go to previous window.

Marked for Deletion Content
Content that is marked for deletion has been requested to be
removed from the Web site by a user. When content is marked for
deletion, it goes through the approval chain like content that is
submitted for publishing. When the content completes the approval
chain, it is deleted from the Web site.
See Also: ”Example of an Approval Chain” on page 85
The table below describes the toolbar buttons.
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Button

Name

Description

Delete

Approve the deletion request.
Note: If you are the last user in the approval chain, the content is
deleted when you click this.

Decline

Refuse the deletion request. This sends the content back into a
checked-in status.

Back

Go to previous window.

Pending Start Date Content
Content that is pending a Go Live date has been approved, but its
scheduled “go live” date and time have not occurred yet.
You cannot perform any action on content with a pending start
date.

Staged Content
A staged version of content is one that is not published. It can be
content that is checked in, or content that is approved with a
pending a start date.
Staging lets you make changes to content, while keeping it from
the Web site until you are ready to publish it.
See Also: ”After you select the content, you have the following
options. (Your options may vary depending on your permissions
and the status of the content.)” on page 40; ”Appendix A: Content
Statuses” on page 648; ”Workflow in Ektron CMS400.NET” on
page 7
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Appendix B: Macintosh Support
for Ektron CMS400.NET Clients
IMPORTANT!

An additional editor license is required when using the Macintosh as a client and
editing content. For information on adding the license, see the Setup Manual
section “Macintosh Editor License.”

You can use an Apple Macintosh computer to create and edit
Ektron CMS400 content. To get the most functionality from Ektron
CMS400.NET on the Macintosh, use the Safari browser.
When using a Macintosh to edit content, log on to your site as if
you were using a PC.
1. Open a Safari browser.
2. Navigate to your site’s login page.
3. Click the Login button.
If you have access to the Workarea, the Workarea button appears,
and you can start editing.
While there are a few limitations when using the Macintosh with
Safari to edit content, almost all functionality is the same as using a
PC. The following functionality is different when using a Macintosh:

• creating and editing HTML forms is not supported
• creating and editing XML Forms (aka the Data Designer) is not
supported

• working with Document Management content is not available

Using the Integrated Macintosh Editor
The Integrated Macintosh Editor (IME) plays the same role on a
Macintosh that eWebEditPro plays on a PC, that of a content
editor. While both editors have similar functionality, some functions
are accessed differently with the IME.
Ektron CMS400.NET clients only support the IME when used on
an Apple Macintosh running the Safari browser.
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If you use another browser, such as Internet Explorer, Firefox, or
Netscape Navigator, a plain text box appears where the editor
should be and you can add content as plain text or html code.
Below is an image of the Integrated Macintosh Editor in the Ektron
CMS400.NET Workarea.

Menu Items and Toolbar Buttons
This section explains how to use the menu Items and toolbar
buttons in the Integrated Macintosh Editor (IME). The menus are
located above the rows of toolbars button across the top of the
editor window, illustrated below.
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The toolbar is the row of buttons across the top of the editor
window, illustrated below.

The menu items and toolbar buttons allow you perform functions
such as cutting and pasting text, inserting images, and creating
tables.

Table of Menu Items, Toolbar Buttons and Drop-Down Lists
The following table explains each menu item, toolbar button and
drop-down list.

Command
Spelling

Access to Command

Button:

Description
Begin spell checker.

Menu: Tools > Spelling...

Keystroke: F7
Automatic Spell
Check

Button:

Turn on or off spell check as-you-type
feature.

Menu: Tools > Disable Check Spelling
As You Type

Keystroke: None
Accessibility
Report...

Button: None
Menu: Tools > Accessibility Report...

Keystroke: F8

Provides an report on how accessible
your page is, according to Section 508,
WCAG Priority 1 and WCAG Priority 2
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Command

Access to Command

Description

Word Count

Button: None

Details the amount of words used in the
editor.

Menu: Tools > Word Count...

Keystroke: None
Find

Keystroke: Control F

Launches a dialog box that allows you to
Find, Find Next or Replace an
occurrence of the string entered into Find
field.

Button:

Remove selected text and graphics.
Place that data into temporary memory.

Button:
Menu: Edit > Find...

Cut

Menu: Edit > Cut

Keystroke: Control X

(If you later cut or copy more information
onto the clipboard, the new information
overwrites the original information.)

Button:

Copy selected text and graphics into
temporary memory. Leave selected data
where it is.

Copy
Menu: Edit > Copy

Keystroke: Control C

Paste

Button:
Menu: Edit > Paste

(If you later cut or copy more information
into memory, the original information is
lost.)
Insert the most recently cut or copied text
and graphics at the current cursor
location.

Keystroke: Control V
Paste Special

Button: None
Menu: Edit > Paste

Keystroke: None
Select

Button: None
Menu: Edit > Select

Keystroke: None

Paste text in a different format. For
example, you can copy text from a
browser and paste it as Rich Text instead
of Hypertext.
Similar to the Document Navigator, this
function lets you highlight a section of
text, a table or section of a table. The
menu is dynamic and the selections can
change depending on the location of the
cursor. For example, if the cursor is in a
table, the menu has the following entries:
html, body, table, tr, td and content.
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Command

Access to Command

Description

Select All

Button: None

Selects everything in the editor.

Menu: Edit > Select All

Keystroke: Control A
Undo

Button:
Menu: Edit > Undo

Reverse the most recent action, as if it
never occurred. You can undo up to 50
actions.

Keystroke: Control Z
Redo

Button:

Reverse the undo action. You can redo
as many actions as you have undone.

Menu: Edit > Redo

Keystroke: Control Y
Insert Hyperlink

Button:

Launches the Insert Hyperlink dialog box.
Adds hyperlink to text in the editor.

Menu: Insert > Insert Hyperlink...

Keystroke: Control K
Bookmark

Button: None
Menu: Insert > Bookmark...

Launches the Insert Bookmark dialog
box. Adds a bookmark to the content.

Keystroke: None
Remove Hyperlink

Button: None
Menu: Insert > Remove Hyperlink...

Removes the hyperlink from text in the
editor

Keystroke: None
Files, Images,
Hyperlinks

Button:
Menu: Insert > Files, Images, Hyperlinks

Launches the Library dialog box which
allows you to add library items to the
content.

Keystroke: None
Insert Symbol

Button:
Menu: Insert > Insert Symbol...

Launches a special characters and
symbols dialog box. Choose a character
or symbol and click Insert.

Keystroke: None
Insert Horizontal
Rule

Button:

Inserts a Horizontal line below the line
where the cursor is located.

Menu: Insert > Insert Horizontal Rule

Keystroke: None
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Command

Access to Command

Description

Insert Table

Insert a table. When using the Table

Button:
Menu: Insert > Insert Table...
Menu: Table > Insert Table...

Keystroke: None

Add Row or
Columns

Button: rows =

column =

button (
), a table appears below the
button and allows you to choose how
many columns and rows you want. When
using a menu to insert a table, the insert
table dialog box appears.
Add a row or column to an existing table.

Menu: Table > Insert Row or Column...

Keystroke: None
Insert Cell

Button: None
Menu: Table > Insert Cell

Keystroke: None
Delete Row

Button:

Inserts a cell where the cursor is located
in a table. Cells in that row to the right of
the new cell are shifted to the right.

Deletes the row where the cursor is
located.

Menu: Table > Delete Row

Keystroke: None
Delete Column

Button:

Deletes the column where the cursor is
located.

Menu: Table > Delete Column

Keystroke: None
Delete Cell

Button: None
Menu: Table > Delete Cell

Keystroke: None

Split Cell

Button:
Menu: Table > Split Cell

Keystroke: None
Merge Cell

Button:

Deletes a cell where the cursor is located
in a table and shifts the remaining cells in
that row to the left. If multiple cells are
selected, they are deleted and the
remaining cells are shifted to the left.
Launches a dialog box that allows you to
split a cell into multiple columns or rows.
This only adds columns or rows to that
cell, not the whole table.

Choose multiple adjoining cells and
merge them into one cell.

Menu: Table > Merge Cell

Keystroke: None

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

660

Command

Access to Command

Description

Cell Properties

Button: None

Launches a dialog box that provides
information about the cell properties. In
this dialog box you can further define an
individual cell.

Menu: Table > Cell Properties...

Keystroke: None
Row Properties

Button: None
Menu: Table > Row Properties...

Keystroke: None
Column Properties

Button: None
Menu: Table > Column Properties...

Keystroke: None
Table Properties

Button: None

Launches a dialog box that provides
information about the column in which
the cursor is located. In this dialog box
you can further define the column.

Keystroke: None

Launches a dialog box that provides
information about the table in which the
cursor is located. In this dialog box you
can further define the table.

Button:

Shows or hides the grid lines that make
up a table.

Menu: Table > Table Properties...

Show/Hide Grid
Lines

Launches a dialog box that provides
information about the row in which the
cursor is located. In this dialog box you
can further define the row.

Menu: Table > Hide Grid lines

Keystroke: None
Design View

Button:

Switches editor from HTML code view to
design view.

Menu: View > Design View

Keystroke: None
Code View

Button:

Switches editor from design view to
HTML code view.

Menu: View > HTML View

Keystroke: None
Window View

Button:

Launches the current editor into its own
window.

Menu: View > Window View

Keystroke: None
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Command

Access to Command

Description

Document Navigator

Button: None

Similar to Select, this function adds a
clickable menu bar to the editor when in
design mode. This lets you to highlight a
section of text, a table or section of a
table. The menu is dynamic and the
selections can change depending on the
location of the cursor. For example, if the
cursor is in a table, the menu has the
following entries: html, body, table, tr, td
and content.

Menu: View > Document Navigator

Keystroke: None

Show Paragraph
Markers

Button:
Menu: View Show > Paragraph Markers

Keystroke: None
Style Dropdown List

Button:

Shows or hides paragraph markers and
other special markings related to
formatting, such as formatting for
bulleted items.

Choose from a predefined list of styles to
apply to your text.

Menu: Format > Style

Keystroke: None
Font

Button: None

Choose from a predefined list of fonts.

Menu: Format > Font

Keystroke: None
Size

Button: None
Menu: Format > Size

Choose from a predefined list of sizes for
your font.

Keystroke: None
Make the text bold.

Bold

Button:
Menu: Format > Bold

Keystroke: Control B

Ektron CMS40 0.NET User Manua l, Version 6.1 for .NET 2 .0 , Revisi on 3

662

Command

Access to Command

Italics

Description
Make the text italic.

Button:
Menu: Format > Italic

Keystroke: Control I
Underline

Button:

Make the text underlined.

Menu: Format > Underline

Keystroke: Control U
Align Left

Button:

Aligns the text to the left of the page. For
example:

Menu: Format > Align Left

This text is aligned left.

Keystroke: Control L
Align Center

Button:

Aligns the text to the center of the page.
For example:

Menu: Format > Align Center

This text is aligned center.

Keystroke: Control E
Align Right

Button:

Aligns the text to the right of the page or
table cell. For example:

Menu: Format > Align Right

This text is aligned right.

Keystroke: Control R
Unordered List

Button:

Begin the line on which the cursor rests
(or all selected lines) with a bullet.

Menu: Format > Unordered List

Keystroke: None
Ordered List

Button:
Menu: Format > Ordered List

Keystroke: None

Decrease Indent

Button:

Begin the line on which the cursor rests
with a number. If the line above this line
is

•
•

not numbered, assign this line 1
numbered, assign a number one
more than the line above

Decrease the current line’s indent
distance from the left margin.

Menu: Format > Decrease Indent

Keystroke: None
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Command

Access to Command

Description

Button:

Increase the current line’s indent
distance from the left margin.

Increase Indent
Menu: Format > Increase Indent

Keystroke: None
List Properties

Button: None
Menu: Format > List Properties...

Keystroke: None

Launches a dialog box that allows you to
view and edit the properties of an
ordered or unordered list.

Adds a color Highlight to text.

Highlight Color

Button:
Menu: Format > Highlight Color

Keystroke: None
Choose the color of the text.

Color

Button:
Menu: Format > Color

Keystroke: None
Superscript

Button: None

Make text appear in Superscript

Menu: Format > Superscript

Keystroke: None
Subscript

Button: None

Make text appear in Subscript

Menu: Format > Subscript

Keystroke: None
Strikethrough

Button: None

Make text appear with a Strikethrough.

Menu: Format > Strikethrough

Keystroke: None
Remove Formatting

Button: None
Menu: Format > Strikethrough

Removes the formatting of text and
returns it to the default color and style.

Keystroke: Control Space
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Command

Access to Command

Description

Button:

Paint the formatting of selected text to a
new piece of text.

Format Painter
Menu: Format > Format Painter

Keystroke: Control

C

Highlight the text that has the formatting
you want to copy. Next, click the Format
Painter button. Then, click the text where
the formatting is to be applied.
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Index
B
508 compliance 613

A
about eWebEditPro box 475, 478
absolute positioning of objects 475
add
button
calendar event 56
library items 56
task 56
workarea toolbar 56
column
toolbar button 477
content 45
block button 56
folder button 56
row
toolbar button 477
add content screen
buttons 47
responding to fields 47
tabs 48
address, email, user, editing 455
AddSubMenu 436
adjusting number of items 290
alignment
cell 591
image 516
table 572
text 475
text, remove, toolbar button 478
Apple, see macintosh
approval chain, example 85
approvals toolbar button 56
approve
all, toolbar button 56
button
floating toolbar 4
workarea toolbar 56
content 81
one content item 83
several content blocks 85
approving file
document management
feature 241
archived content, toolbar button 56
archiving
definition 64
options 64
restoring archived content 66
assign task button, floating toolbar 4
auto hide, feature of Smart Desktop 27

background color
applying to text 474
cell
applying 585
deleting 586
removing from text 474
table
applying 574
deleting 575
background image
cell
deleting 588
inserting 587
table
deleting 577
inserting 576
bidirectional editing 476
blogs
adding 347
categories 353
adding 353
editing 354
removing 355
comments
in the Workarea 382
on the site 380
overview 377
deleting 368
overview 343
posts
adding 373
deleting 376
editing 375
made from the Web site 369
made from the Workarea 371
overview 369
properties 349
roll 358
assigning link 359
editing 362
link, removing 363
searching 369
setting style sheet 352
smart forms used with 358
tagline 351
update service 352
visibility setting 348
workflow 346
blur, WebImageFX command 528
bold, toolbar option 474
bookmarks 599
border

image
color 516
thickness 515
border color
cell 584
content block, meaning 648
table 577
border size
cell 581
table 579
brightness, WebImageFX command 529
broken links, finding 55
bullet, toolbar option 474
buttons
adding to menu 482
rearranging on menu 485
removing from menu 482
text, displaying in title bar 456

C
calendars
add event button 56
authorization for creating 294
button to display in Workarea 58
definition 292
event types 308
events
adding 304
assigning event types 308
button for viewing 58
deleting 315
display times 307, 310
editing 312
end time 306, 310
insert hyperlink 307
location 306
recurring, adding 308
start date 306, 309
start time 306, 310
viewing 311
screen, information on 296
viewing 300
cell properties
toolbar button 477
cells
background color 585
background image
deleting 588
inserting 587
border
color 584
invisible 584
deleting 583
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inserting 582
merging 595
padding 597
spacing 597
splitting 594
text alignment 591
width 581
check in, toolbar button 57
check out, toolbar button 57
checked in content
definition 650
checked out content
definition 651
choose color, WebImageFX
command 530
choose font, WebImageFX
command 531
cleaning HTML 611
collaboration, content 623
collections
adding content 410
changing sequence of links 58
compared with menu and List
Summary 418
creating 407
creating new content for 412
default template 409
definition 401
deleting 416
editing content blocks 414
finding 402
folder, using to find collection 404
information, editing 416
multi-language 417
removing content 414
reordering content blocks 415
toolbar button 57
toolbar buttons 407
using default template or
quicklinks 409
viewing 405
color
background
cell
applying 585
deleting 586
table
applying 574
deleting 575
cell border 584
default 563
content block border,
meaning 648
depth, specifying 553
font, changing 473
picture border 516
table border 577

default 561
columns
table
adding 566
deleting 566
spanning 589
specifying 565
comments
adding another 625
adding to a task 337
inserting into content 623
updating 625
viewing 625
Compare source code field, eWebDiff 96
Compare visual aspect field,
eWebDiff 96
comparing content 92
content area explained 97
Diff tab 97
how status affects comparison 93
published tab 98
setup window 95
staged tab 98
toolbar 94
view tabs 97
when available 93
window explanation 93
content
see also content block
active, definition 649
adding 45
adding as menu option 432
adding to collection 410
approval process 85
archived, toolbar button 56
archiving see archiving
area, expanding 44
awaiting approval 21
checked in, definition 650
checked out, definition 651
collaboration 623
comparing, see comparing content
creating 45
currently checked out 22
declining 84
declining, see declining content
deleting 53
difference
view, button, floating toolbar 5
viewing 92
editing 49
editing, toolbar button 57
end date, setting 63
folders, see folders
history
accessing from Web page 49, 100

accessing via Workarea 50, 100
marked for deletion, definition 653
metadata, see searchable properties
pending start date 654
previous version, viewing 99
properties 42
publish see publish
restoring previous version 99
scheduling 60
start date, setting 61
statuses 648
approved 648
submitted, definition 652
summary see summary
translating 51
types 5
viewing 38
Workarea search 105
workflow reports see reports
content block
see also content
add button 56
definition 1
deleting
several at once 57
editing
overview 8
finding 8
lifecycle 9
contrast, WebImageFX command 533
copy
information from other
applications 493
toolbar and menu option 470
WebImageFX command 534
copyright character, inserting 472
create new, WebImageFX
command 534
creating
document, document management feature 234
Office document, document management feature 216
crop, WebImageFX command 534
customizing toolbar 480
cut, toolbar and menu option 469

D
decline
content
from publishing 84
one content item 83
several content blocks 85
delete
button, floating toolbar 5
content, toolbar button 57
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folder, toolbar button 57
toolbar button 57
WebImageFX command 535
delete cell
toolbar button 477
delete column
toolbar button 477
delete row
toolbar button 477
deleting
cell 583
folders 55
table 556
Detect All field, eWebDiff 96
difference
content
view, toolbar button 5
dimensions, WebImageFX
command 535
display borders
toolbar button 478
Do not apply XSLT button 57
document
creating, document management
feature 234
importing into DMS 228
Office, creating, document management feature 216
document management feature
adding documents to
collections 241
adding documents to menus 241
approving file 241
checking in document 220
creating managed file 234
creating Office document 216
deleting document 241
document types 211
drag and drop files 237
exit without saving changes 220
file types 211
importing document 228
installing on client 16
introduction 210
managed files 213, 234
Office document properties,
editing 218
Office document, editing 230
Office documents 212
overview 210
reports 241
reports of document by status 241
saving recent changes 220
saving to local computer 220
security 214
submitting for publication 220
viewing documents in CMS 240

work offline 220, 230
workflow 240
documentation, online, accessing 458
drag and drop files
document management
feature 237
using explorer 271

E
edit button, floating toolbar 5
editing
content block, overview 8
content, toolbar button 57
HTML 610
Ektron Explorer, workspace,
definition 276
Ektron Explorer, workspace,
deleting 277
Ektron Explorer, workspace, distributing
files 277
Ektron Explorer, workspace,
renaming 278
email
address, user, editing 455
instant
modifying 30
requirements 29
sending 28
where available 29
notification, disabling 455
end date, setting for content 63
end time, calendar event 306, 310
eWebDiff window 95
exit without save, WebImageFX
command 537
exit, WebImageFX command 536
explorer
changing thumbnail size 254
creating
content 259
folder 259
form 260
deleting content 259
displaying 252
editing content 261
emailing content 262
favorites 272
adding content to 275
adding folder 276
removing content from 275
removing folder 276
favorites folder 273
suppressing 274
folders
changing language 267
collapsing 264
creating 266

deleting 265
display properties 266
expanding 265
options dialog 269
renaming 265
inserting external files 271
installing 246
introduction 243
recently viewed content 288, 290
displaying 289
removing from display 255
search feature 256
selecting content 258
viewing content information 260
extensions
file, allowed in library 121
image, allowed in library 121

F
file
open
toolbar button 478
save to local computer
toolbar button 478
files
copying to library 124
extensions, library, setting 121
library
inserting into content 133
overwriting 129
viewing 127
library, editing title 129
find next
toolbar and menu option 470
finding
content block 8
text 494
floating toolbar 4
folders
add button 56
button for deleting 57
content
toolbar buttons 34
deleting 55
information available when
viewing 34
screen display 31
view history, restore 102
viewing 33
fonts
background color 474
color 473
heading size 473
size 473
style 473
form elements toolbar 476
forms
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adding to content 138
HTML
assigning task 181
creating 144
creating content block 152
database 199
deleting 199
editing
content block 198
introduction 197
summary 198
field validation options 165
implementing on Web page 181
inserting fields 155
calendar field 179
checkbox 159
choices 171
hidden text 161
password 166
select list 175
text 162
text area 169
introduction 141
mailto 199
processing overview 143
reports, exporting 190
reports, viewing 184
structure of data 143
toolbar 199
toolbar options 154
validation 158
viewing 191
properties 191
viewing 139
freehand, WebImageFX command 537

G
gray, content border color, meaning 648
green, content border color,
meaning 648

H
height, work page, customizing for
user 456
help, online, accessing 458
hide borders
toolbar button 478
history
button, view, floating toolbar 5
content
accessing from Web page 49, 100
accessing via Workarea 50, 100
viewing 58
window 101
horizontal flip, WebImageFX
command 538

horizontal line, inserting, toolbar
button 479
HTML
cleaning 611
editing 610
inserting 610
view as, toolbar and menu
option 472
viewing 609
hyperlink
edit, toolbar and menu option 471
remove, toolbar and menu
option 471
hyperlinks 603
adding as menu option 434
creating 603
definition 117
editing 607
entering manually 605
library
adding 136
adding to content 137
editing 136
viewing 136
preventing 608
removing 608
testing 606
to a bookmark in another web
page 606
to content block, finding 57
using a Quicklink 604

I
icon menu 4
Ignore All field, eWebDiff 96
Ignore Case field, eWebDiff 96
Ignore Format Attributes field,
eWebDiff 96
image extensions, library, setting 121
image info, WebImageFX command 538
image upload
from Microsoft Word
document 504
inserting picture from
computer 511
media file selection 508
images
adding space around 518
aligning 516
background
cell, inserting 587
table, inserting 576
border
color 516
thickness 515
deleting 521
deleting from server 510

editing 522
inserting 506
from server into editor 509
inserting from your computer 511
library
adding to content 138
editing titles 137
overwriting 137
uploading 137
viewing 137
locking in position 475
moving to server 520
scanning 551
specifying color depth 553
indent, toolbar option 474
insert
column, toolbar button 477
library item, toolbar button 57
new cell, toolbar button 477
row, toolbar button 477
table, toolbar button 558
inserting
cells 582
HTML 610
instant email, see email, instant
Internet addresses, spell checking 501
italic, toolbar option 474

J
jumps, see bookmarks and hyperlinks
justify, toolbar option 475

L
landing page after login, customizing for
user 456
language, user, editing 455
library
accessing 118
add items button 56
asset, adding as menu item 434
copying files to 124
definition 117
file extensions 121
files
editing 129
inserting into content 133
overwriting 129
viewing 127
folder properties 120
forms
adding to content 138
viewing 139
hyperlinks
adding 136
adding to content 137
editing 136
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viewing 136
images
adding to content 138
editing titles 137
extensions 121
overwriting 137
uploading 137
viewing 137
quicklinks
adding to content 138
viewing 139
search results
include images 114, 124
text only 114, 124
searching 121
license keys, viewing 475, 478
lifecycle, content block 9
line, WebImageFX command 539
link check button 57
links, broken, finding 55
ListSummary, compared with collection
and menu 418
lock table or image in position 475
log in 10
log out 12
button, floating toolbar 5

M
Macintosh support 655
menu items 657
toolbar buttons 657
using editor 655
managed files 234
creating 234
document management
feature 213
editing 235
importing one 234
manuals, online, accessing 458
marked for deletion content 653
menus
accessing 422
add new content block via navigation link 437
adding new
via content folder 423
via Menus module 429
adding to toolbar 481
appearance
to content contributor 420
to site visitor 420
changing orientation 488
compared with collection and List
Summary 418
creating 485
in any language 451
definition 420

deleting 447
editing 438
via content folder 438
via menus module 439
via navigation link 439
icons 4
items
adding
content block as 432
external hyperlink as 434
library asset as 434
submenu 435
to submenu 436
via content folder 429
via modules folder 430
via navigation link on Web
page 431
definition 421
deleting
via content folder 448
via menus module 448
editing
via content folder 441
via menus module 442
via navigation link 442
rearranging 446
moving from toolbar 487
multi-language issues 449
rearranging on toolbar 485
removing from toolbar 481
structure 421
submenu, definition 422
template link field 428
translating 449
URL link field 427
viewing
via content folder 443
via menus module 444
via navigation link 445
merge cell
toolbar button 477
merging cells 595
metadata
definition 71
Microsoft Word
editing in 503
editing XML documents 504
uploading image from 504
multi-language menus 449

N
number, toolbar option 474
numbers in words, spell checking 501

O
objects, absolute positioning 475

Office 2000, inserting content from 612
Office documents
creating 216
document management
feature 212
editing properties 218
importing one 228
open file, toolbar button 478
Open Office files
creating 231
editing 233
importing 231
open, WebImageFX command 540
oval, WebImageFX command 541
overwrite button 58

P
padding, cell 597
password, changing 455
paste
toolbar and menu option 470
paste as new image, WebImageFX
command 542
paste text
toolbar and menu option 470
pending start date content 654
pictures
inserting see image upload
properties, image upload 508
pixels 515
pointer selection, WebImageFX
command 542
polls
creating 201
creating in Workarea 202
editing from Web site 206
replacing existing with new from
Web site 205
polygon, WebImageFX command 543
position objects menu 475
prerequisites 10
preview
button 58
floating toolbar 5
feature 12
print editor content, toolbar button 479
profile
users
updating 453
viewing 453
properties
button, floating toolbar 5
content 42
publish
button 58
content to web site 84
published
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content block, viewing 59

Q
quicklinks 604
adding to content 138
broken, finding 55
definition 118
using for a collection 409
viewing 139

R
rectangle, WebImageFX command 544
red, content border color, meaning 648
redisplay toolbars 485
redo
toolbar and menu option 470
WebImageFX command 545
registered trademark character,
inserting 472
remove alignment, toolbar button 478
remove button 58
remove XSLT from XML content
block 102
reorder button 58
replace
toolbar and menu option 470
replacing text 494
reports
content
workflow 116
restore, toolbar button 58
restoring content 102
right to left editing 476
rotate, WebImageFX command 546
rows
table
adding 566
deleting 566
spanning 589
specifying 565

S
save
file to local computer, toolbar
button 478
to database, toolbar button 58
WebImageFX command 546
save as, WebImageFX command 547
scanning an image 551
scheduling content 60
search 494
considering case of search
term 496
content folder 105
content using explorer 256

direction 495
library 121
toolbar button 58
whole word match 497
search screen 106
noise files 108
specifying
kind of content to search 107
match criteria 109
word or phrase 108
searchable properties
creating 74
editing 74
section 508
compliance 613
tables 616
select all
menu option 490
toolbar button 479
select none, toolbar button 479
select, WebImageFX command 548
selecting text 467
server, moving picture to 520
sharpen, WebImageFX command 548
shortcuts, keyboard 468
show calendar, toolbar button 58
Smart Desktop
definition 20
hiding left panel 26
modifying folder display 24
navigating 23
set as start location for user 457
Smart Detect field, eWebDiff 96
smart folders, creating 283
smart folders, definition 280
smart folders, deleting 282
smart folders, entering search
criteria 281
smart folders, retrieving content 282
space character, inserting 472
spacing, cell 597
spanning
table columns 589
table rows 589
special characters, inserting 473
spell check
automatic, toolbar and menu
option 470
manual, toolbar and menu
option 470
spelling
check a single word 500
check as you type 498
check on demand 499
check selected text 500
checking file addresses 501
checking Internet addresses 501

checking uppercase words 501
checking words with numbers 501
fix errors 499
split cell
toolbar button 477
splitting a cell 594
staged content block, viewing 59
start date
content block, setting 61
setting, results 62
start time, event calendar 306, 310
Strikethrough, toolbar and menu
option 474
style class, assigning to text 473
submenus
adding as menu item 435
adding items 436
definition 422
deleting 448
submit, toolbar button 58
submitted content, definition 652
Subscript, toolbar and menu option 474
summary
adding 67
content
creating for existing content
block 69
creating for new content block 68
editing 69
Superscript, toolbar and menu
option 474
surveys
creating 201, 207

T
table
insert, toolbar button 477
table properties
toolbar button 477
tables
alignment 572
background color
applying 574
deleting 575
background image
deleting 577
inserting 576
border
color 577
invisible 578
size 579
columns
adding 566
deleting 566
spanning 589
specifying 565
creating 555
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deleting 556
inserting within a table 557
locking in position 475
rows
adding 566
deleting 566
spanning 589
specifying 565
section 508 616
width
setting by percentage 568
setting by pixels 570
tasks
add button 56
assign button, floating toolbar 4
assigning
to content block 320
to HTML form 181
to user 320
comments
adding 337
updating 339
creating
via content block 330
via task folder 319
definition 317
deleting 340
due date 322
editing 336
priority, assigning 320
redirecting to another user 320
relationship to content blocks 317
start date 322
state, assigning 321
toolbar buttons 342
viewing 331
options 332
sorting options 335
template link
field on Add/Edit Menu screen 428
text
aligning 475
in columns 557
within a cell 591
direction menu 476
indenting 474
remove formatting 474
replacing 494
searching 494
selecting 467
WebImageFX command 549
title bar, displaying button text 456
toolbars
buttons 56, 468
collections 407
customizing 480
floating 4

buttons 4
redisplay 485
restore 485
trademark
character, inserting 472
toolbar and menu option 472
translate
toolbar and menu option 471
twain acquire, WebImageFX
command 551
twain source, WebImageFX
command 551

U
underline, toolbar option 478
undo
toolbar option 470
WebImageFX command 552
uppercase words, spell checking 501
URL link
field on Add/Edit Menu screen 427
users
email address, editing 455
language, editing 455
profile
customizing work page height 456
customizing work page size 455
customizing work page width 456
landing page after login 456
see profile
set Smart Desktop as start
location 457

V
validation
HTML form 158
version number, viewing 475, 478
vertical flip, WebImageFX command 552
view content difference 92
button, floating toolbar 5
screen, first use 98
view date, toolbar button 58
view difference, toolbar button 58
view history
button, floating toolbar 5
toolbar button 58
view preferences toolbar button 478
view published, toolbar button 59
view staged, toolbar button 59
ViewAllMenus 420
viewing HTML 609

W
WebImageFX
assigning new name to image 524

choosing image 522
commands
blur 528
brightness 529
choose color 530
choose font 531
contrast 533
copy 534
create new 534
crop 534
delete 535
dimensions 535
exit 536
exit without save 537
freehand 537
horizontal flip 538
image info 538
line 539
open 540
oval 541
paste as new image 542
pointer selection 542
polygon 543
rectangle 544
redo 545
rotate 546
save 546
save as 547
select 548
sharpen 548
text 549
twain acquire 551
twain source 551
undo 552
vertical flip 552
zoom in 552
zoom out 553
introduction 522
menu commands 524
saving image 524
specifying color depth 553
toolbar buttons 524
whole word match 497
width, table
setting by percentage 568
setting by pixels 570
width, work page, customizing for
user 456
word wrap 596
Word, Microsoft
editing in 503
editing XML documents 504
inserting from 612
uploading image from 504
work offline, document management
feature 220, 230
work page size, customizing for user 455
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workarea
accessing 15
button, floating toolbar 5
definition 15
hiding left panel 26
toolbar buttons 56
add 56
add calendar event 56
add content block 56
add content folder 56
add library items 56
add task 56
approvals 56
approve 56
approve all 56
archived content 56
calendar 57
check in 57
check out 57
collections 57
delete 57
delete content 57

delete folder 57
do not apply XSLT 57
edit 57
insert library item 57
link check 57
overwrite 58
preview 58
publish 58
remove 58
reorder 58
restore 58
save to database 58
search 58
show calendar 58
submit 58
view date 58
view difference 58
view history 58
view published 59
view staged 59
workspace folder, creating 279
workspace folder, inserting content 280

Workspace folders, definition 278
workspace, see Ektron Explorer, workspace
WYSIWYG, view as, toolbar and menu
option 472

X
XSLT, removing from XML content
block 102

Y
yellow, content border color,
meaning 648

Z
zoom in, WebImageFX command 552
zoom out, WebImageFX command 553
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