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Ektron OnTrek Requirements
OnTrek has the following requirements.

l OnTrek works for both CMS Users and Membership Users.
l When you use eSync to update your server from the OnTrek site, you must manually copy
the application.config and application.security.config files to the [siteroot];
eSync does not automatically synchronize these files for security reasons. Also synchronize
the bin directory when you synchronize the database and templates to ensure that
skmValidators.dll is synchronized.

l Do not disable aliasing. If you do, the site will break.
l Do not delete the pre-defined Information Architecture implemented via Ektron Taxonomy,
Menu, and Folder components. If you do, the site will break.

application.config
The application.config file is located at the [siteroot] folder of OnTrek.

<?xml version="1.0"?>
<appSettings>
<!-- Site specific keys -->
<add key="SiteTitle" value="OnTrek" />
<add key="LoadDefaultThemeRollerTheme" value="false" />
</appSettings>

This file contains application-specific keys as follows.

1. SiteTitle key—Sets what shows up in the Browser’s Title bar. For example, the browser
title bar on the Products page is OnTrek: Products.

2. LoadDefaultThemeRollerTheme key—Determines whether to load its own jQuery UI
ThemeRoller theme for any Ektron component. Some Ektron components require a jQuery
UI ThemeRoller theme to render properly in a browser. This key defaults to true. You
should set this to false only if the site has its own ThemeRoller theme. You can apply these
components to three use-cases relative to ThemeRoller themes:

l In the Workarea where the component needs to load the Workarea theme (the orange
one).
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l In a Web site that has its own ThemeRoller theme, in which case, the component must
load its own ThemeRoller theme (named “Smoothness” – which is silver) for the
component to work properly.

l Outside the Workarea in a Web site that does not have its own ThemeRoller theme, in
which case, the component must NOT load its own ThemeRoller theme (and use the
ThemeRoller theme provided by the site) because it otherwise would overwrite the
site’s ThemeRoller theme.

application.security.config
The application.security.config file is located at the [siteroot] folder of OnTrek. The alias
paths are placeholders (and are commented out). You can set up secure pages by using these
aliases, or by the template (.aspx). Templates can be accessed by multiple aliases.

<?xml version="1.0"?>
<!-- paths are from root. aliases must exactly match rawurl. -->
<!-- template example:
/example.aspx, and /folder-1/folder-2/example.aspx -->

<!-- alias example:
/Secure-Section/, and /Secure-Section/Super-Secure-Section/ -->

<ektron:SecureRequests xmlns:ektron="urn:Ektron.OnTrek.Security">
<!-- <ektron:template path="/checkout.aspx" /> -->
<!-- <ektron:template path="/account.orderHistory.aspx" /> -->
<!--
<ektron:alias path="/" />
<ektron:alias path="/" />

-->
</ektron:SecureRequests>

WARNING! The checkout.aspx and account.orderHistory.aspx files are commented out to
permit checkout to proceed without using a Secure Socket Layer (SSL) for demonstration purposes only.
Your transactions will not be secure unless you set up SSL and uncomment those files. We highly
recommend for any eCommerce implementation that you set up SSL for secure transactions. For information
about setting up SSL, see .
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Introducing Ektron OnTrek
OnTrek is a starter site that is built on Ektron.

You can modify many things directly on the OnTrek site through the CMS Workarea, the in-
context editor from the access point ( ), or from the PageBuilder menu (dropping a widget onto
the page). OnTrek uses PageBuilder technology that lets you drag and drop blocks of functional
content called widgets onto the page. Some widgets are so flexible, you can put what you want
in them and display them at specified times or conditions.

You can access the Ektron Developer Reference (EDR) with a click in OnTrek. The EDR provides
information about the Ektron API and Ektron UI controls. (You also can access the EDR at
http://reference.ektron.com.)

Additionally, you can modify the site itself through the ASP.NET templates and user controls in
your installation hierarchy, using Microsoft Visual Studio or similar tool. This OnTrek in Ektron
Reference describes direct manipulation of the starter site and does not contain information
about modifying the templates or user controls. Developers of .NET templates and user controls
can refer to Ektron Users Guide: Building an Ektron Powered Website and the Ektron Reference.

l Templates (.aspx files) and PageBuilder templates (.pb.aspx files) in the [siteroot]
folder of the installation.

l Master pages—[siteroot] > OnTrek > components > templates.
l User controls—[siteroot] > OnTrek > components > userControls.

Revenue Generation

l Sell products and services from the Web site.
l Analyze customer activity to increase site traffic and sales conversions.

Customer Loyalty and Satisfaction

l Promote your company brand and provide promotional and customer events.
l Communicate with your customers through social networking and product ratings.
l Support customers with forums, knowledge base, and technical support.

Operational Efficiency

l Track customer purchases and support cases.
l Attract top talent to your organization.
l Ektron OnTrek Requirements—Read this topic before you get started.
l Touring Ektron OnTrek Site—Read this topic to see how OnTrek is laid out.
l Ektron Reference—Open the Ektron Reference.
l http://www.ektron.com/Resources/Product-Documentation/—Get the latest versions of
Ektron documentation.

Touring Ektron OnTrek Site
OnTrek comes with the following pre-built pages and templates.

Introducing Ektron OnTrek
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Home Page
OnTrek provides a home page design from which you can start customizing your Web site. The
home page displays dynamic up-to-date content about your company, providing access to your
products, services, and other company information. For information about modifying the home
page, see Modifying the OnTrek Home Page on page 28. The following figure shows the Home
Page when you are logged in as Admin.

The following images show the Ektron Developer Reference that you can access from the Home
page.
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Products Page
Displays the products you want to sell. The default OnTrek Products page contains the building
blocks to get your products and services up for sale. To modify these pages, see Modifying the
Products Pages on page 38.

l Secure purchasing.
l Search, filter, and browse products.
l Promote highest rated, most purchased, newest, most bookmarked, and most shared
products to cross-sell, up-sell, and customer-sell your products.

l Add items to a purchasing cart or wish list.
l The text block introduces your products and can be edited on the page or in the Workarea
content. (See .)

l Displays a short description and optional image of the product with links to go to a Product
Detail page, or to add the product to the customer's cart.
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Services Page
Displays the services you want to provide:

l Training
l Consulting
l Installation
l Contact information for representatives

To modify the Services pages, see Modifying the Services Pages on page 49.

Services Page
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Clients Page
Contains the building blocks to display your client list and successful partnering stories and case
studies.

l Client biographies
l Testimonial quotes and videos

To modify these pages, see Modifying the Clients Pages on page 55
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Support Page
Contains the building blocks for you to place information and knowledge into the hands of your
customers.

l Host customer forums about your products
l Maintain a knowledge base and FAQs
l Handle online support requests

To modify these pages, see Modifying the Support Pages on page 60.

Support Page
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Company Page
Contains the building blocks to display information about your company. Related Company
pages include the following information:

l News Articles Page
l Events
l Our team
l Careers
l Office Locations
l Contact Information

To modify these pages, see Modifying the Company Pages on page 71.
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Community Page
Contains the building blocks to create a social networking community and can display customer-
driven information about your products and services. To modify these pages, see Modifying the
Community Pages on page 82

l Registration and login
l Custom dashboard and user profile for each user
l Social networking forums to discuss, propose, and answer
l Blogs

Community Page
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My Account Page
Contains the building blocks to create an account for a registered user. You also can do the
following in this area.

l My Cart
l Order History
l Shipping and Billing Information

To modify these pages, see Modifying the My Account Pages on page 107.
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Search Page
Search the site for content using sorting, relevance, date, and other filters.

More information: Searching the Site on page 34

Widgets
Functional content blocks that you drag and drop onto a PageBuilder page.

More information: Using Widgets in OnTrek on page 123

Search Page
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Modifying the OnTrek Web Site
You can customize the OnTrek Web site to suit your organization. The following sections
describe managing your site.

l Logging into OnTrek below
l Logging in With a Facebook Account on next page
l Registering a User on page 24
l Using the Smart Desktop to Manage Your OnTrek Site on page 26
l Managing Site Permissions on page 26

The following topics describe how to modify the landing pages and their associated sub-pages.

l Modifying the OnTrek Home Page on page 28
l Modifying the Products Pages on page 38
l Modifying the Services Pages on page 49
l Modifying the Clients Pages on page 55
l Modifying the Support Pages on page 60
l Modifying the Company Pages on page 71
l Modifying the Community Pages on page 82
l Modifying the My Profile Page on page 93
l Modifying the My Account Pages on page 107
l Modifying Site Styles on page 116

Logging into OnTrek
You can log into OnTrek by clicking Login on the main page. The Register or Login page appears
as shown in the following figure.

Modifying the OnTrekWeb Site
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l If you are modifying the OnTrek site, you can enter admin in the Email Address field and
admin in the Password field and login with full editing privileges.

l If you are an existing user, enter your email address and password. Your privileges are
determined by a site administrator.

l If you are a Facebook user, you can login in using your Facebook account credentials by
clicking Connect with Facebook. Your privileges are determined by a site administrator.
For more information, see Logging in With a Facebook Account below.

l If you are a new user, use the register block to join the community. Your privileges are
determined by a site administrator. For more information, see Registering a User on page
24.

Logging in With a Facebook Account
You can use your Facebook account credentials to login to OnTrek by following these steps.
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1. Click Connect with Facebook on the login screen. The Facebook Login screen appears.

2. New users can register by filling out the form and clicking Complete Registration.
Existing users can enter their User Name and Password and click Login.

Logging inWith a Facebook Account
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To set up the Facebook login, see Developer Experience: Setup Instructions in the Ektron
Reference. The user control files are located at [siteroot]/OnTrek/facebookRegister.aspx
and facebookRegister.aspx.cs.

Registering a User
When someone registers to become part of the online community you set up, the user
information is stored in the Settings section of the Workarea at Settings > Community
Management > Memberships > Users.

To register as a member of the online community, fill in the Register form and click Register. A
confirmation dialog box appears.
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A registered member has limited options in the activity panel, as shown in the following figure.

By contrast, an administrator has the following options.

Registering a User
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Using the Smart Desktop to Manage Your OnTrek
Site
You can maintain your site content using your Workarea Smart Desktop. Measure Web page
traffic, approve comments and content where necessary, or maintain content to keep it current
and up-to-date from this page.

The Smart Desktop contains widgets that help you identify tasks to complete, or view comments
and content that you need to approve. The Smart Desktop uses PageBuilder technology to help
you rearrange or add/delete widgets.

You can add, rearrange, or remove widgets on your Smart Desktop. To learn more about
customizing the Smart Desktop, see How Customizing the Smart Desktop Works in the Ektron
Reference.

Managing Site Permissions
Site permissions are determined by a user profile. The following matrix tables show the
permissions a user has based on their context.

Administrator
visits a... ...that is... ...then has access to...

user

a colleague all tabs; full rights to user profile content (add, edit, delete).

not a col-
league

all tabs; full rights to user profile content (add, edit, delete).

26 OnTrek in Ektron Reference
June 2012—Doc. Rev. 1.8

http://documentation.ektron.com/cms400/v8.60/Reference/PDF/EktronReference.pdf
http://documentation.ektron.com/cms400/v8.60/Reference/PDF/EktronReference.pdf


Administrator
visits a... ...that is... ...then has access to...

public group

amember all tabs

not amember
Group tab
Documents tab
Photos tab

private group

amember all tabs

not amember

Group tab
Documents tab
Photos tab
(May join a private group without having to be approved)

Non-admin-
istrator visit
a...

...that is... ...then has access to...

user

colleague
all tabs, but not content in folders that have "share-level" set to
"selected colleagues"

a selected
colleague

all tabs, and content in folders that have "share-level" set to "selected
colleagues"

not a col-
league

Group tab
Documents tab
Photos tab

public group

amember all tabs

not amember
Group tab
Documents tab
Photos tab

private group

amember all tabs

not amember
Group tab
Documents tab
Photos tab

Managing Site Permissions
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Modifying the OnTrek Home Page
The OnTrek home page is an example of how you may want to display your "first impression."
The page employs many controls and uses PageBuilder technology to let an administrator drag
and drop widgets onto the page.

The following topics show you how to modify the home page.

Modifying the Rotating Home Page Banner Images
The home page displays a set of rotating banner images. You can modify the rotating banner
with the following steps.

1. Add a new banner to the ones that came with OnTrek.
a. Choose Library > MainSite > Content > Home > HomePageBanner.

b. Click Add. the Add library Item form appears.
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c. Enter a Title and Description.
d. Click Browse... to find the image file you want.
e. Click Save. the images is added to the library in the HomePageBanner folder.
2. Edit the Smart Form that is the basis for the rotating banner.
a. Choose Content > Folders > MainSite > Content > Home > HomePageBanner.

The HomePageBanner item appears in the View Contents panel.
b. Click the HomePageBanner item (ID=366). The details appear.
c. Click Edit. The editor appears.

NOTE: This example duplicates a slide and thenmodifies it.

d. In the Homepage Slideshow contentin the editor, click on the Slides menu ( ) and choose
Duplicate. A duplicate slide is added.

e. To change the image, click Select Picture ( ). An Image properties dialog box appears.

Modifying the Rotating HomePage Banner Images
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f. Choose a new image, specify the other properties and click OK. the new image appears.
g. Modify the Title and Summary then click Publish.
Refresh the screen (Ctrl/F5) on the Home page to see your image added to the default page
banner images.

For information about Smart Forms, see the Ektron Reference.

You can also resize the banner width directly on the home page by following these
steps.
1. While logged in, choose File > Edit from the PageBuilder menu. The home page appears

in PageBuilder mode.
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2. In the banner widget click Edit ( ). The New Width box appears.
3. Specify a numeric value and unit (Pixels, Em, or Percent) and click Save.

Adding a Widget to the Page
Some pages in OnTrek have spaces where you can add one or more widgets to the page. This is
indicated by the PageBuilder menu when you are logged in. To add a widget to the page:

1. While logged into the page, open the PageBuilder menu and choose File > Edit. The
widget area appears on the page.

2. Open the widget bar ( ) and choose a widget.
3. Drag and drop a widget in to the widget space.

Adding Assets
Assets are files that are created outside of Ektron. You can store and manage assets on your
OnTrek site. To add a single asset:

1. Find a page that accepts assets; for example, the Documents accordion tab on My Profile
page.

2. Choose Add new... > Add Asset. A dialog box appears.
3. Click on the File Upload tab.
4. Click Browse... to locate the file.
5. Click Upload.
The following browsers use different methods for uploading assets.

Adding Assets with Microsoft Internet Explorer
You can upload 1 file at a time using the File Upload dialog box.

1. Click Browse.
2. Select the file you want, then click Upload.

Adding Assets with Google Chrome
You can upload 1 file at a time using the File Upload dialog box.

Adding aWidget to the Page
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1. Click Choose File.
2. Select the file you want, then click Upload.

Adding Assets with Mozilla FireFox
You can upload 1 file at a time using the File Upload dialog box. You can also upload multiple
files clicking on the Drag Drop tab and dragging files to the Drag Drop area.

Adding Assets with Microsoft Internet Explorer and Microsoft
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Office
You can upload 1 file at a time using the File Upload dialog box.

1. Click Browse.
2. Select the file you want, then click Upload.
You can also upload multiple files by checking boxes next to the files that you want to upload.

1. Click the Multiple DMS Documents tab.
2. Select your office version (Microsoft Office 2010, or Microsoft Office 2003 or 2007).
3. Check the boxes next to the files you want, then click Upload. 

NOTE: You can see a list of allowed file types by clickingShow File Types. Ektron administrators
can edit this list in theWorkarea.

4. If any selected file type is not allowed, you are notified. OnTrek uploads all allowed file
types.

Selecting a Language for the Web Site
OnTrek comes installed in U.S. English ( ) and Spanish ( ) languages. Click on the language
icon to display OnTrek in that language.

Adding Assets with Microsoft Internet Explorer and
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NOTE: If you login with a computer in another country, another version of Englishmay be installed. For
example,British English is installed in the United Kingdom ( ).

To install a language that is not shown in the links, (for example, to add French), see Working
with Multi-Language Content in the Ektron Reference.

Searching the Site
To search the OnTrek site, type a string into the search box at the top of the screen and click the
magnifying glass icon.

The Search page appears, which displays Basic Search and Advanced Search tabs.

Filtering Your Search
If you receive too many results from your search, you can filter the results by using the drop
down menu beside the Basic Search box. You can filter by Site, HTML, Documents, Images,
Multimedia, Forms, Tags, or Pages. The following image shows a search filtered by Images.

Specifying an Advanced Search
From the Advanced Search tab, you can refine your search to very fine granularity. The
Advanced Search parameters are as follows.

l with all of the words—Results must have all the words specified; uses an AND operator
for the strings that you specify.

l advanced search exact phrase—Results must contain the exact string that you specify.
l at least one of the words—Results must have any the words specified; uses an OR
operator for the strings that you specify.

l without the word—Results must not have the string that you specify.
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l Filter Results—Choose one of the following filters. Click Add Filter to specify more than
one filter.

o Created Before—Results show items created before YYYY/MM/DD.
o Created After—Results show items created after YYYY/MM/DD.
o Modified Before—Results show items modified before YYYY/MM/DD.
o Modified After—Results show items modified after YYYY/MM/DD.
o Author—Results show items created by the specified author.
o File Size—Results show items larger (>) or smaller (<) than the specified file size in
kilobytes.

Using the Site Map Page
The following figure shows the default OnTrek Site Map page. It is automatically generated from
the pages of your Web site, and changes accordingly. You can click on any of the links to go to
the selected page.

Modifying the Request a Demo Page
The Request a Demo page is an HTML Form.

Using the Site Map Page
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1. While logged in to the Request a Demo page, open the access point ( ) and choose Edit.
The Request a Demo form appears in the content editor.

2. Modify the form. For information about HTML Forms, see the Ektron Reference. The
following figure shows a modified form.

l Twitter Name field was added
l Tweet was added to Preferred Method of Contact.

Modifying the Privacy Policy Page

36 OnTrek in Ektron Reference
June 2012—Doc. Rev. 1.8



To modify it for your company:

1. While logged in to the Privacy Policy page, open the access point ( ) and choose Edit in
Context to modify the page text, or Edit to modify the text and other content data in the
Ektron editor.

2. Change the content (and metadata) to suit your company and click Save.
The following figure shows the default Privacy Policy page.

Modifying the Terms of Use Page
To modify it for your company:

1. While logged in to the Terms of Use page, open the access point ( ) and choose Edit in
Context to modify the page text, or Edit to modify the text and other content data in the
Ektron editor.

2. Change the content (and metadata) to suit your company and click Save.
The following figure shows the default Terms of Use page.

Modifying the Terms of Use Page
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Modifying the Products Pages
The Products page displays products and services that you want to sell. To see the default
Products page, see Products Page on page 12.

To create your own Products page, you must modify or create templates and user controls,
which is not described in this OnTrek in Ektron Reference. Developers of .NET templates and
user controls can find product templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

For additional information, see the Ektron Users Guide: Building an Ektron Powered Website and
the Ektron Reference.

You can modify this page, and its associated pages, in the following ways.
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Editing the Products Page Introduction In Context
OnTrek preloads the introduction to the Products page with Lorem ipsum text to give you an
example of what a Products page introduction can look like. You can edit this content from the
page by following these steps after logging in:

1. Open the access point ( ) above the content.
2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the Products Page in the Workarea
You can access the Products page introductory content in the Workarea, where you can create
additional information about the content (such as Metadata).

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > Products.
3. Choose Products Home from the content list.

Editing the Products Page Introduction In Context
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4. Choose Edit.

Selecting a Content Block for the Products Introduction
Content
To change the Products page introduction by selecting an existing piece of content, follow these
steps:

1. While logged in to the Products page, open the PageBuilder menu and choose File > Edit.
The widget spaces appear on the page.
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2. Click Edit ( ) in the Products Home widget. The Editing widget dialog box appears.
3. Navigate the folder hierarchy to find a piece of content. When you click on a folder, valid

content appears in the View Results panel.

Selecting a Content Block for the Products

OnTrek in Ektron Reference
Ektron 8.02, 8.5, 8.6

41



4. Double click on a content item. The content appears on the page.

5. Choose File > Publish.

Searching the Product Inventory
The search box on the Product page operates only on products contained on the Product pages
(and not on the entire OnTrek site). To search the Products area, type a string into the search
box at the top of the screen and click Search.

The Search page appears, which displays Basic Search and Advanced Search tabs. From the
Advanced Search tab, you can refine your search to very fine granularity. The Advanced Search
parameters are as follows.

l with all of the words—Results must have all the words specified; uses an AND operator
for the strings that you specify.

l advanced search exact phrase—Results must contain the exact string that you specify.
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l at least one of the words—Results must have any the words specified; uses an OR operator
for the strings that you specify.

l without the word—Results must not have the string that you specify.
l Filter Results—Choose one of the following filters. Click Add Filter to specify more than
one filter.

o Price Below—Results show products below the specified price.
o Price Above—Results show products above the specified price.
o Product SKU—Results match the stock-keeping unit (SKU) number specified.

Displaying Product Specifications
When you click on a product title or a Learn more > link, a product specifications page appears
with more details about the product. Product information is located in the Content section of the
Workarea at Folders > MainSite > Content > Store, and in one of the store's folders. For
example, in the Hardware folder you can click on Basic Wireless Router to display or edit the
content about this product.

You can create new products in the Hardware, Software, and Training folders from the New
menu. If you want to create a new catalog and new product types, see Creating a New Catalog
below.

Creating a New Catalog
Unless you create your own products page, you only can add a catalog, new product types, and
new products to the content management system to the existing Hardware, Software, and
Training pages. To create your own products page, you must modify or create templates and
user controls, which is not described in this OnTrek in Ektron Reference. Developers of .NET
templates and user controls can find templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and C# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek >Components > Templates.
l User controls—[siteroot] > OnTrek >Components > userControls.

For more information, see the Ektron Users Guide: Building an Ektron Powered Website and the
Ektron Reference.

To place products on your Web site for sale, you can do the following steps directly to the
OnTrek pages.

l Adding a Catalog to the Product Store below
l Creating New Product Types on page 45
l Adding a New Product Type to a Catalog on page 47
l Adding Products to a Catalog on page 48

Adding a Catalog to the Product Store
OnTrek comes with 3 product catalogs: Hardware, Software, and Training. In the Workarea, the
catalog folders (and the Store folder) are green for quick identification.

Displaying Product Specifications
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The following example shows you how to add a new catalog called Farm Products for the sale of
farm-fresh fruits and vegetables and other farm-related items.

1. While logged into the Workarea, open the Content tab.
2. Choose Folders > MainSite > Content > Store.
3. Right click on Store and choose Add Catalog (or choose New > Catalog from the

menus). The Add Catalog to Store screen appears.

4. Enter the name Farm Products in the Catalog Name field. Optionally add other data.
5. Click Add Catalog. The new category appears in the list. The following figure shows the
Farm Products Catalog with other catalogs already created under it.
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Creating New Product Types
Product types let you categorize your product line so that customers can browse your product
line more easily. For example, you can have Produce, Equipment, and Supplies product types
for a Farm Products catalog, or Monitors, Systems, and Accessories product types for Computer
Products.

1. Login to the Workarea and choose the Settings tab.
2. Choose Settings > Commerce > Catalog > Product Types.
3. In the View Product types panel, choose New > Product Type. The Add Product Type

screen appears.
4. On the Properties tab, enter the Title (Produce), Description (Farm Produce) and Class

(Product).

Creating New Product Types
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5. On the Media Defaults tab, click Add Thumbnail and specify the following 2 media default
items:

l Name:_main,Width:150 px, Height: 125 px
l Name:_thumb,Width:70 px, Height: 58 px

IMPORTANT: The dimensions of the images are optimized for the OnTrek presentation of product
images on a product page. Also, becauseOnTrek uses the _main and _thumb filename prefixes, do not
use these in your product image filenames, or it may cause unpredictable results. The code-behind and
XSLT used in the product section of OnTrek key off of these text strings.

6. Click Save. The new product type appears in the View Product Types panel.
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Adding a New Product Type to a Catalog
1. Login to the Workarea and choose the Content tab.
2. Choose Folders > Mainsite > Content > Store > Farm Products (assuming that you

created Farm Products as described in Adding a Catalog to the Product Store on page 43).
3. In the View Entries panel, choose View > Catalog Properties. The properties appear.
4. Click Edit Properties.
5. Click the Product Types tab.
6. Break the inheritance value by unchecking Inherit Parent Configuration.
7. Select a product type and click Add ( ). For example, select Produce. (See Creating New

Product Types on page 45.)
8. Click on the radio button ( ) to enable the product type. The following figure shows 4

product types added to the Farm Products catalog.

Adding a New Product Type to a Catalog
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9. Click Update. The View Properties panel reappears.

Adding Products to a Catalog
NOTE: This example builds on prior steps outlined inCreating a New Catalog on page 43.

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > Store > Farm Products > Produce.
3. In the View Entries panel, choose New > Produce. The Add Catalog Entry window

appears.
4. Enter the following information:

a. Title: Pumpkins
b. Summary tab:  Pumpkins
c. Properties tab:

l SKU: 123412341234
l Number of Units: 200
l Tax class: Goods

d. Pricing tab:
l List price: $3
l Our Sales Price: $2.60

e. Media tab:
a. Click Add New Image.
b. Title: Pumpkins
c. Alt Text: Pumpkins
d. Browse for an image and click Upload.
e. Click Set as Product Icon.

48 OnTrek in Ektron Reference
June 2012—Doc. Rev. 1.8



f. Metadata tab:
a. Description: Pumpkins
b. Keywords: Text: Produce. Click Add ( ).
c. Keywords: Text: Pumpkins. Click Add ( ).
d. Title: Pumpkins

g. Category tab:
a. Open the category tree to OnTrek Site Navigation and hover the cursor over
Products and click Add ( ). The Add Category dialog box appears.

b. Category Title: Pumpkins.
c. Click Save.
d. Check Products and Pumpkins

5. Click Action > Publish. The View Entries screen appears with Pumpkins in the Produce
catalog.

Modifying the Services Pages
The Services page displays information about training and consulting services you offer. To see
the default Services page, see Services Page on page 13. You can access the pages associated
with the Services page by clicking the Learn More button in a tabbed window, or from the
Services menu. You can create and modify the following types of Services pages.

l Services page introductory text
l Training Services page
l Consulting Services page
l Widget space

To create your own Services page, you must modify or create templates and user controls,
which is not described in this OnTrek in Ektron Reference. Developers of .NET templates and
user controls can find product templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

For additional information, see the Ektron Users Guide: Building an Ektron Powered Website and
the Ektron Reference.

Editing the Services Page Introduction In Context
OnTrek preloads the introduction to the Services page with text to give you an example of what
a Services page can look like. You can edit this content from the page by following these steps
after logging in:

1. Open the access point ( ) above the content.
2. Choose Edit in Context. An editor window appears.

Modifying the Services Pages
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3. Edit the text, and click Save ( ). The text changes on the page.

Editing the Services Page Introduction in the Workarea
You can access the Services page introductory content in the Workarea where you can create
additional information about the content (such as Metadata).

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > Services.
3. Choose Services from the content list.
4. Choose Edit.

Selecting a Content Block for the Services Introduction
To change the Services page introduction by selecting an existing piece of content, follow these
steps:

1. While logged in to the Services page, open the PageBuilder menu and choose File > Edit.
The widget spaces appear on the page.
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2. Click Edit ( ) in the Services widget. The Editing widget dialog box appears.
3. Navigate the folder hierarchy to find a piece of content. When you click on a folder, valid

content appears in the View Results panel.

4. Double click on a content item. The content appears on the page.

Selecting a Content Block for the Services
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5. Choose File > Publish.

Modifying the Consulting Services Page
The following figure shows the default OnTrek Consulting Services page.

To modify the form on the Consulting Services page to display your company information, follow
these steps:

1. While logged in to the Consulting Services page, open the access point ( ) and choose Edit.
The Edit Content editor appears with the consultation form.
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2. Modify the form. For information about HTML Forms, see the Ektron Reference. The
following figure shows a modified form with a Phone field added to the form, and the result
on the page when you click Publish.

Modifying the Training Services Page

Modifying the Training Services Page
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The following figure shows the default OnTrek Training Services page.

The Training Services page has 3 sections: the introduction, the tabbed course offering section,
and a widget space. The following topics describe each section.

Modifying the Training Page Introduction
To modify the introductory text, open the access point ( ) and choose Edit in Context, or
choose Edit to modify the content in the Workarea, if you want to specify additional metadata.

Adding a Course and Tab to the Course Offering Section
1. In the Workarea in the Content section, choose Folders > MainSite > Content
> Services > Training. The contents of the folder appear in the View Contents panel.

2. In the View Contents panel, choose New > HTML Content. The content editor appears.
3. Specify the content for a new training course. When done, click Publish. The new course

appears in the View Contents panel with the other courses.
4. In the Workarea in the Content section, choose Collections > Training Tabs. The

existing tabs appear in the View Collection panel.
5. In the View Collection panel, click Add Items. The Add Items panel appears.
6. Check the box next to the new course and click Add. The new course appears in the View

Collection screen.

Removing a Tab from the Course Offering Section
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1. In the Workarea in the Content section, choose Collections > Training Tabs. The
existing tabs appear in the View Collection panel.

2. Click on the tab you want to remove. The View Content screen appears for the selected
item.

3. Click Delete ( ) and then OK.
4. Choose Collections > Training Tabs to see the changes in the course offering tab.

Modifying the Clients Pages
The Clients page uses Smart Form content placed in a custom template. To see the default
Clients page, see . You can add clients to the client list, and drag and drop widgets onto the
page.

To create your own Clients page, you must modify or create templates and user controls, which
is not described in this OnTrek in Ektron Reference. Developers of .NET templates and user
controls can find product templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

For additional information, see the Ektron Users Guide: Building an Ektron Powered Website and
the Ektron Reference.

The following topics describe the modification you can make the default Clients pages.

l Adding a Client and Case Study below
l Modifying the Case Studies Page on page 57
l Adding Testimonials on page 57

Adding a Client and Case Study
1. While logged into the Case Studies page, click on Add Case Study, which opens a Client

Smart Form in Folders > MainSite > Content > Clients in the Contents section of the
Workarea. For information about Smart Forms, see the Ektron Reference.

Modifying the Clients Pages
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2. Enter a Title.
3. Enter a Client Name.
4. Enter a Client URL to the client's Web site.
5. Click Select Picture ( ) to upload a Client Logo. The Library Folder: "Clients\Images"

dialog box appears.
a. Select an image from the library and click Insert ( ).

NOTE: If you do not have the image already loaded in the library, you can search your computer
by clickingAdd Library, browsing for the image, and then click Add Library to continue with the
Image Properties dialog box.
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b. Specify theWidth. The Height is automatically calculated when you specify width.
c. Click OK. The client logo displays on the Client Smart form.

6. Checking the box next to Display Case Study on Case Studies page if you want it to
show there.

7. Specify the case study information you want.
8. In the Category tab, check the taxonomies that apply at Ontrek Site Navigation
> Clients > Industries.

9. Click Publish. The new client appears in the client list and on the Clients page.
If you set the Education industry in the Category tab, then choose Education from the By
Industry filter menu on the Clients page to see your new client filtered with other clients with
the same taxonomy.

Modifying the Case Studies Page
Like the Clients page, the Case Studies page displays clients that you can filter with the By
Industry filter menu. However, the Case Studies page displays more information about the
clients that was entered in the Client Smart Form, which is described in . To add a case study to
the Case Studies page, you must check the box in the Smart Form next to Display Case Study
on Case Studies page.

You can edit the introduction by opening the access point ( ) and choosing Edit in Context. You
can specify additional metadata in the Workarea for the introduction by choosing Edit.

The Case Studies page also contains a widget space. For information about adding a widget to
the page, see .

Adding Testimonials
The testimonials in OnTrek are created from a Video Smart Form.

1. While logged into the Testimonials page, click on Add Testimonial, which opens a Video
Smart Form in Folders > MainSite > Content > Clients > Client Testimonials in the
Contents section of the Workarea. For information about Smart Forms, see the Ektron
Reference.

Modifying the Case Studies Page
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2. Click Select Picture ( ). The Edit Content in Folder "Client Testimonials" screen appears.
3. Double click an item from the Library folder, or click Add Library to browse for a new one.

The item appears in the Video section of the editor.
4. To change the image properties, click Select Picture ( ). The Images Properties dialog

box appears.
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5. Fill in the dialog box and click OK.

6. Click Select File ( ) next to Video Source. The Link Manager dialog box appears.

Adding Testimonials
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7. Fill in the dialog box and click OK.
8. Enter Caption text.
9. Enter a Description of the testimony.
10. On the Category tab, check the taxonomies that apply.
11. Click Publish. A testimonial is added to the group of existing testimonies.

Modifying the Support Pages
You can create and modify the following types of Support pages. To see the default Support
page, see Support Page on page 15.

l Support page introductory text
l Support Forums
l Knowledge Base
l Support Request
l Support Search
l Widget space
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To create your own Support page, you must modify or create templates and user controls, which
is not described in this OnTrek in Ektron Reference. Developers of .NET templates and user
controls can find product templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

Editing the Support Page Introduction In Context
OnTrek preloads the introduction to the Support page with Lorem ipsum text to give you an
example of what a Support page introduction can look like. To edit this content from the page
after logging in:

1. Open the access point ( ) above the content.
2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the Support Page in the Workarea
You can access the Support page introductory content in the Workarea, where you can create
additional information about the content (such as Metadata).

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > Support.
3. Choose Support Home from the content list.
4. Click Edit.

Editing the Support Page Introduction In Context
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5. Click Publish to display your changes.

Selecting a Content Block for the Support Introduction
To change the Support page introduction by selecting an existing piece of content:

1. While logged in to the Support page, open the PageBuilder menu and choose File > Edit.
The widget spaces appear on the page.

2. Click Edit ( ) in the Support Home widget. The Editing widget dialog box appears.
3. Navigate the folder hierarchy to find a piece of content. When you click on a folder, valid

content appears in the View Results panel.
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4. Click on a content item, then click Save. The content appears on the page.

5. Choose File> Publish from the PageBuilder menu.

Creating a New Knowledge Base Page
To add a Knowledge Base page:

Creating a New Knowledge Base Page
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1. Click Resource Wizard in the top navigation area. A dialog box appears.

2. Enter the name of a new Knowledge Base resource and click Add. A new Knowledge Base
resource page is created. The following figure shows a new Knowledge Base resource page
for Farm fresh produce.

The new page is pre-loaded with Content, a PageBuilder Page, a taxonomy category, and
menu links.

Adding Content to a Knowledge Base Page
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1. While logged into the Workarea in the Content section, choose Folders > MainSite
> Content > Support > Knowledge Base. The View Content screen displays the
current articles in the Knowledge Base.

2. Choose New > HTML Content. A content editor appears.
3. Add the Title and content of the article.
4. On the Category tab, choose OnTrek Site Navigation > Support > Knowledge Base,

and check the type of article.
5. Click Publish.
Administrators can add subfolders to the default or user-created Knowledge Base page directly,
as described in the following steps.

1. On the Knowledge Base page on the left side, right click on the Knowledge Base folder and
choose Add Folder. The Add Folder dialog box appears.

2. Specify the name of a subfolder (or example, Best Practices) then click Add. The folder
is added to the list as shown in the following sample figure.

When you add content to a folder, the taxonomy of the folder is applied to the content
automatically.

Modifying the Request Support Form
The Request Support page is created with a HTML Form. To modify the form:

1. While logged in to the Request Support page, open the access point ( ) and choose Edit.
The Request Support form appears in the content editor.

2. Modify the form. For information about HTML Forms, see the Ektron Reference. The
following figure shows a modified form and the result when you click Publish.

l Twitter name field was added
l Tweet was added

Modifying the Request Support Form
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The Request Support page also has a widget space that contains two List Summary widgets by
default. To add a widget, see .

Viewing Support Requests
When the Request Support form is filled out and the Submit Request is clicked, the form data
is added to Ektron. To view submitted requests:

1. Login as administrator.
2. Navigate to Support > Request Support. The Request Support page appears.

Viewing Support Requests
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3. Open the access point ( ) and choose Properties. The View Forms "Request
Support" screen appears in the Ektron Workarea.

4. Click Report ( ). The form changes for you to specify viewing criteria, such as start and
end dates and so on.
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5. Click Get Report. The requests display within the criteria that you specified.

Searching the Support Database
The search tool on the support page operates on the forums and knowledge base content. The
following example shows a search with a wildcard (*) for the word work* that produced 4
results. Specify your search criterion and click Search.

Searching the Support Database
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Searching the Knowledge Base
The search tool on the Knowledge Base page operates only on knowledge base content. (You can
search the Knowledge Base and Support forums on the Search Support page (Support >
Support Search). See Searching the Support Database on previous page.)

The following example shows a search with a wildcard (*) for the word work* that produced 2
results. Specify your search criterion and click Search.

Filtering the Search
You can filter the search by All Types, How To, Problem, or Documentation.

Adding a Filter to the Search
1. Go toWorkarea > Content > Taxonomies > OnTrek Site Navigation > Support >
Knowledge Base.

2. Right click on Knowledge Base and choose Add Category. The Add Category screen
appears.
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3. Enter a Category Title (Best Practice, for example) and other optional information,
then click Save.

NOTE: To enable topics to be found in a search by the new category, youmust check the taxonomy on
the Category tab of the content item in theWorkarea. For information, seeAdding Content to a
Knowledge Base Page on page 64.

Modifying the Company Pages
The Company page and associated pages contain elements that you may want to present your
company to visitors to your site. The main Company page displays a content block and a widget
space with an Upcoming Events widget. To see the default Company page, see . You can create
and modify the following types of Company pages.

l Company page introductory text
l Company News page—Modifying the Company News Page on page 75
l Company Calendar page—Adding Events to the Company Calendar on page 75
l Our Team page—Modifying the Our Team Page on page 76
l Careers page—Modifying the Careers Page on page 77
l Contact Us page—Modifying the Contact Us Page on page 79
l Widget space—Adding a Widget to the Page on page 31

To create your own Company page, you must modify or create templates and user controls,
which is not described in this OnTrek in Ektron Reference. Developers of .NET templates and
user controls can find product templates and user controls at the following locations.

Modifying the Company Pages
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l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

For additional information, see the Ektron Users Guide: Building an Ektron Powered Website and
the Ektron Reference.

Editing the Company Page Introduction In Context
OnTrek preloads the introduction to the Company page with Lorem ipsum text to give you an
example of what a Company page introduction can look like.

You can edit this content from the page by following these steps after logging in:

1. Open the access point ( ) above the content.
2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save. The text is changed on the page.

Editing the Company Page in the Workarea
You can access the Company page introductory content in the Workarea, where you can create
additional information about the content (such as Metadata). To do this, follow these steps:

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > Company.
3. Choose Company from the content list.
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4. Click Edit.

Selecting a Content Block for the Company Page
Introduction
To change the Company page introduction by selecting an existing piece of content, follow these
steps:

1. While logged in to the Company page, open the PageBuilder menu and choose File > Edit.
The widget spaces appear on the page.

Selecting a Content Block for the Company Page
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2. Click Edit ( ) in the Company widget. The Editing widget dialog box appears.
3. Navigate the folder hierarchy to find a piece of content. When you click on a folder, valid

content appears in the View Results panel.

4. Click on a content item, then click Save. The content appears on the page.
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5. Choose File > Publish from the PageBuilder menu.

Modifying the Company News Page
To view the Company News page, choose Company > Company News.

To add a news item to the Company News page:

1. While logged in on the Company News page, open the access point ( ) and choose Add
News. A content editor window appears.

2. Fill in the content and click Publish when done. The HTML content item is added to the
following location in the Content section of the Workarea: Folders > MainSite >
Content > Company > Company News.

3. Refresh the browser (F5) to see the changes on the Company News page.

Adding Events to the Company Calendar
To view the Company calendar page, choose Company > Events. Events on the company
calendar appear in the Upcoming Events widget.

To add a news item to the Company News page:

Modifying the CompanyNewsPage
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1. Double click on a day in the calendar. The Edit Appointment screen appears.

2. Fill out the form. When done, click Save.

NOTE: You can find the company calendar in theWorkarea in the Content area at Folders > MainSite
> Content > Company > Event Calendar.

Modifying the Our Team Page
The Our Team page consists of an introduction, a collection of team members, and a widget
space in the right column. To modify the Our Team page introduction, see Editing the Company
Page Introduction In Context on page 72 or Editing the Company Page in the Workarea on page
72.

Adding a Widget to the Page
To add or change the widget on the page, see Adding a Widget to the Page on page 31.

Adding a Team Member to the Page
To add a team member to the page:
1. If you want to use a picture of a new team member, you must first add the image.

a. While logged into the Workarea in the Library section, choose Library > MainSite >
Content > Company > Our Team.

b. Click Add.
c. Enter Title.
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d. Click Browse to upload the image. You also can add additional information.
e. Click Save.

2. While logged into the Our Team page, open the access point ( ) and choose Add Team
Member. The Employee Profile form appears.

3. Fill out the form.
a. Fill in the text fields.
b. To use a previously stored image, click on the add image icon ( ). The Image

Properties dialog box appears.
1. Click the Image Src ellipses (...). The library folder Our Team/images appears.
2. Double click on the image you want.

4. Click Publish. The new team member appears on the page.

Deleting a Team Member from the Page
To delete a team member:

1. While logged into the Workarea in the Content section, choose Collections > Our Team.
The View Collection panel displays the team members.

2. Click the person you want to remove.
3. Click Delete ( ). The member is removed from the page.

Modifying the Careers Page

Deleting a TeamMember from the Page
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The Careers page contains a search box, a filter, a list of available jobs, and a widget space in
the right column. The following topics show you how to modify these elements.

NOTE: The Search box is not modifiable.

Creating a Job Posting
Job postings are located in the Workarea in the Content section at Folders > MainSite >
Content > Company > Careers. When you are logged in and at this location, you can create
a new job posting with the following steps.

1. In the View Contents panel, choose New > Job Description. The content editor appears
with a Job Profile Smart Form, as shown in the following figure. For information about
Smart Forms, see the Ektron Reference.

2. Fill out the form.
3. Select the type of job in the Category tab by checking one or more boxes next to the

categories to which the job applies.
4. Click Publish. The new entry appears on the Careers page.

Modifying the Filter Careers Box
The Filters Career box is dynamically loaded from the taxonomy.

To add a filter, you must add a category to the taxonomy.
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1. While logged into the Workarea in the Content section, choose Taxonomies
> Taxonomies > OnTrek Site Navigation > Company > Careers. The View
Taxonomy screen appears.

2. Click Add Category. The Add Category screen appears.

3. Enter a name in the Category Title field. For example, QA.
4. Click Save.
5. Refresh the browser (F5) to see the changes in the Filter Careers box.

To add or change the widget on the page, see Adding a Widget to the Page on page 31.

Modifying the Contact Us Page

Modifying the Contact Us Page

OnTrek in Ektron Reference
Ektron 8.02, 8.5, 8.6

79



The Contact Us page has an introduction section and a tabbed section. The following topics
describe each section.

The Directions tab displays a Bing™ map from which you can search for geographic locations.

Modifying the Contact Us Page Introduction
To modify the introductory text, open the access point ( ) and choose Edit in Context, or
choose Edit to modify the content in the workarea, if you want to specify additional metadata.

Modifying the Contact Form
The Contact Us form is created with a HTML Form.

1. While logged in to the Contact Us page, open the access point ( ) and choose Edit. The
Contact Us form appears in the content editor.

2. Modify the form. For information about HTML Forms, see the Ektron Reference. The
following figure shows a modified form and the result when you click Publish.

l Street, City, State, and Zip Code fields were added.
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Viewing the Default Multivariate Experiment Page
OnTrek has a default multivariate experiment page set up.

1. While logged in, choose Company > News. The Company News page appears.
2. Click on OnTrek Releases SelfServ Helpdesk Pro. The news item appears.
3. Click on the Learn More > button. A new page appears with more information.

Viewing the Default Multivariate Experiment Page
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4. Open the PageBuilder menu and choose File > Edit. The Multivariate widgets appear.

The target page for the multivariate experiment is the Request a Demo page.

For information about how to set up a multivariate experiment, see the Ektron Reference.

Modifying the Community Pages
The Community pages let people engage in social networking. To see the default page, see . The
default Community page provides access to the following areas:

l Introduction—Content that you enter to introduce the page.
l My Profile—Manage your online persona. See Modifying the My Profile Page on page 93 for
information about personalizing a user experience on a social networking site.

l Corporate Blogs—The Corporate Blogs page contains unmanaged content, but when you
click on the "Visit Blog" link, a blog-specific page appears where you can modify the
managed content. For more information, see Modifying the Corporate Blogs Page on page
92.
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l Find Connections—Look for colleagues and friends to connect to or add to your social
network. For more information, see Finding Connections on page 92.

To create your own Community page, you must modify or create templates and user controls,
which is not described in this OnTrek in Ektron Reference. Developers of .NET templates and
user controls can find product templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

For additional information, see the Ektron Users Guide: Building an Ektron Powered Website and
the Ektron Reference.

Editing the Community Page Introduction In Context
OnTrek preloads the introduction to the Community page with Lorem ipsum text to give you an
example of what a Community page introduction can look like. You can edit this content from
the page by following these steps after logging in:

1. Open the access point ( ) above the content.
2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save. The text is changed on the page.

Editing the Community Page in the Workarea
You can access the Community page introductory content in the Workarea, where you can
create additional information about the content (such as Metadata). To do this, follow these
steps:

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > Community.
3. Choose Community Landing from the content list.

Editing the Community Page Introduction In Context

OnTrek in Ektron Reference
Ektron 8.02, 8.5, 8.6

83

http://documentation.ektron.com/cms400/v8.60/Reference/PDF/EktronReference.pdf
http://documentation.ektron.com/cms400/v8.60/Reference/PDF/EktronReference.pdf


4. Choose Edit.

Selecting a Content Block for the Community
Introduction
To change the Community page introduction by selecting an existing piece of content, follow
these steps:

1. While logged in to the Community page, open the PageBuilder menu and choose File
> Edit. The widget spaces appear on the page.

2. Click Edit ( ) in the Community Landing widget. The Editing widget dialog box appears.
3. Navigate the folder hierarchy to find a piece of content. When you click on a folder, valid

content appears in the View Results panel.
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4. Double click on a content item. The content appears on the page.

5. Choose File > Publish from the PageBuilder menu.

Managing Groups
Community groups provide common interest areas for people to collaborate. You can create
groups, join groups, maintain documents, calendars, discussion boards, blogs, and photos. A

ManagingGroups
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group moderator creates a group and determines whether the group is restricted or public.
OnTrek provides an example group called SelfServ HelpDesk User Group.

To create a new group, see Creating a Group below.

To see what the example group lets you do with a group, see Moderating a Group Message Board
on page 88

To access groups in the Workarea, open the Settings tab and choose Settings > Community
Management > Community Groups. For information about Community Groups, see the
Ektron Reference.

Creating a Group
1. Choose Community > Find Groups. The Find groups screen appears.
2. Click the Create Group button.

NOTE: Administrators also can create a group from theMy Profile > Group area.
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l Group Name—The name of the group.
l Administrator—A group administrator has privileges to delete a group or edit its
properties. By default, the person who created the group is the group administrator.
Click Browse if you want to select a different group administrator.

l Membership—Select whether the group is
o Open—open to the public.
o Restricted—members can only join if invited.

l Features—Check the applicable options.
o Create Group Calendar—Let members of the group add events to keep other
members informed.

o Create Group Forum—Start a groups discussion board.
l Image—Upload an image to use as an avatar for the group.
l Location—The geographical location associated with the group.
l Short Description—A brief description of the group.
l Description—A fully detailed description of the group.

Creating aGroup
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l Enable Distribute—Check this box if you want the group and system administrator
to be able to distribute content to any folder. For more information, see Distributing
Content to Another Folder in the Ektron Reference.

l Allow member to manage photo/workspace folders—Check this box if you
want to allow members to add, remove and control the sharing of folders in a
community group’s Photo Gallery or Document’s Workspace. For more information,
see Authorizing Group Documents and Photos on page 90.

l Group MessageBoard Moderation—Check this box if you want to this groups
message board to be moderated. For more information, see Moderating a Group
Message Board below.

l Attach Documents in Email Notifications—Check this box if you want email
notifications of connected user activity to include attached documents, if applicable.

l Tags Tab—From this screen, you can either create a new tag or select from a default
list of community group tags. For more information, see Assigning Tags to a
Community Group in the Ektron Reference.

3. Click Save to create the group.

Moderating a Group Message Board
1. Choose Community > Find Groups. The Find groups screen appears. If you have many

groups, use the Search tab to find the group that you want to manage.
2. Click the group that you want to edit.
3. Click Manage > Edit Group.

—Image—

4. The Edit Group dialog box appears. For information about the properties, see Creating a
Group on page 86.

5. Check the Group MessageBoard Moderation box so that any group member must
approve a post before it appears on the group message board. Inappropriate posts may be
deleted before they appear on the message board (although they will appear to
reviewers/approvers).

Adding Members to a Group
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When you create a group, you can determine if its membership policy is open or restricted. An
open policy lets anyone join the group. A restricted policy requires the group's administrator to
approve new members.

Inviting Users to Join a Group
To invite colleagues to join a group:
1. Choose Community > Find Groups. The Find groups screen appears. If you have many

groups, use the Search tab to find the group that you want to manage.
2. Click the group that you want to edit. The group page appears.
3. On the left, choose Manage > Invite Colleagues. The Invite Colleagues dialog box

appears.

4. Check the box next to the colleagues you want to invite to the restricted group. (You can
also specify email addresses on the Email tab.)

5. Optionally modify the default message.

Inviting Users to Join a Group
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6. Click Send Invitations to send the message to the selected colleagues. Your colleagues
will have to accept the invitation to appear in the group.

The invited member receives notification of the invitation and chooses the Invitationmenu to
accept or decline it.

Joining a Group
To request joining a group, find the group you want and click on the Join Group link. If the
group is restricted, the moderator will have to approve your membership.

Authorizing Group Documents and Photos
You can authorize Community Group members to access the right-click menu options on the
Group's Documents and Photos folders.

1. From your group page, click Manage > Edit Group.
2. On the Properties tab, check the Allow member to manage photo/workspace
folders box.

Managing Group Documents
Group Documents let you store and share documents that are relevant to the group. Group
members can create their own documents and folders in the common place, without having to
create a file-sharing folder on a file server. Additionally, you can add important information
such as history (for archive purposes), metadata, and work flow.

To create new HTML content, choose Add New > Content.

To add Microsoft Office documents and other file types (including multimedia files):

1. Choose Add New > Asset.
2. Click Browse... and find the document you want to add.
3. Click Upload. The document appears in the table.

For information about adding assets using different browsers, see Adding Assets on page 31.

Managing a Group Blog
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Group blogs let you post important comments, instructions, procedures, policies, or any type of
communication. Blog functionality includes reply, edit, post, RSS feeds, and subscribe.

Managing a Group Dashboard
The Dashboard lets you customize a group page to include content for your group, such as a list
of content, a collection of links, documents, or images.

To customize your dashboard, follow these steps:

1. If you do not already have a tab, you must create one by opening the Option menu ( )
and choosing Add Tab. The Add Tab dialog box appears.
a. Enter a Tab Label.
b. Select a Tab Scope (Public or Private).
c. Click OK.

2. Open the widget bar ( ).
3. Drag and drop a widget onto your dashboard.
The following figure shows a group dashboard with an iTune Podcast widget and an upcoming
Events widget in the dashboard space.

Managing aGroup Dashboard
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To change the contents of a widget, click Edit ( ).

To dismiss the widget from the Dashboard, click Close ( ).

Modifying the Corporate Blogs Page
1. While logged into the Workarea in the Content section, choose Folders > MainSite >
Content > Community.

2. In the View Contents panel, choose New > Blog. The Add Blog screen appears.
3. Name the new blog and give it a title, then click Add Blog. The blog appears as a subfolder

under the Community Folder.
4. To add the new blog to the Corporate Blogs page, you must modify the user controls, which

is at [siteroot] > OnTrek >Components > User Controls
> community.corporateBlogs.aspx.

NOTE: This OnTrek in Ektron Reference document does not describe how tomodify templates.
Developers of .NET templates and user controls can refer toEktron Users Guide: Building an Ektron
PoweredWebsite and theEktron Reference.

For more information about blogs, see Creating a Blog on page 101.

Finding Connections
To find a connection, type the name of a colleague or friend in the Display Name search field, as
shown in the following figure.
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You can search by one or more of the following criteria. Click Add Filter to search by more than
one criterion.

l Display name
l First name
l Last Name
l Tags
l Email
l User Properties

Modifying the My Profile Page
The My Profile page is where registered users can personalize their experience and lets them
connect and collaborate with other people on your Web site.

You can modify the following items in My Profile:

Editing My Profile
You can specify the following information on the Edit Profile tabs:

General
The following list and figure describe the information you can set. Fields with a red asterisk (*)
are required fields.

l *First name—Enter your first name.
l *Last Name—Enter your last name.
l *Password—Enter a password.
l *Confirm Password—Re-enter the same password.
l *E-Mail Address—Enter your email address.

Modifying theMyProfile Page
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l *Display Name—Enter the name you want to display to others, which can be a nickname
or title.

l User Language—Select from available languages.
l Address—Enter the address (or just the zip code) of where you are located.
l Latitude—This field is automatically determined by the address.
l Longitude—This field is automatically determined by the address.
l Avatar—Click on "Click to upload your Avatar" and choose an image file that you want to
associate with your profile.

l Profile Links—This field is automatically determined by your profile.

Forum
The following list and figure describe the information you can set.

l Content and Forum Editor—Choose eWebEdit400 or eWebEditPro.
l Topics per Page—Select the number of topics you want to display on a page. If the
number of available topics exceeds the number you select, a scroll bar lets you see the
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additional topics. For example, if you select 10, and there are 25 topics, you can scroll to
see all the topic, but only 10 will be displayed at one time.

l Forum Signature—Click Edit to enter or modify an automatic signature that appears at
the bottom of each post you make to a forum topic.

Tags
The following property and figure describe the information you can set.

Tags—Keywords that you can assign to content and library items, which allows for tag-based
searching. For example, you can add the tag Electronics and tag content that is related to the
electronic devices, so that people can search for the content using the Electronics tag.

EditingMyProfile
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Custom
The following list and figure describe the information you can set. Fields with a red asterisk (*)
are required fields.

l Moderate—Check the Moderate box to give this user privileges on a message board to
approve and delete posts. Regular users in a group message board can create and delete
only their own posts.

l Features—Check the Features box to give the user an individual calendar. (There may be
other features to grant, also.)

l Private Profile—Choose from one of the following options:
o Public—The user information is accessible by others on the eIntranet.
o Private —The user information is not accessible by others on the eIntranet.
o Colleagues—The user information is accessible only by people on the eIntranet that
are connected as colleagues.

l Time Zone—Select the time zone where the user works.
l Email—Enter a valid email address.
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l Phone—Enter the user's company telephone number.

Activities
The following list and figure describe the information you can set. By default, all activity is
checked to display in the Activity Stream widget. By checking the boxes, you can select criteria
for the types of content you want to see when colleagues or community groups create the
content. You can also select (publish) the types of content that you want colleagues to see under
the My Activities category.

l SMS—A checked box indicates that the type of content will be sent to your cell phone Short
Message Service (SMS).

l Activity Stream—A checked box indicates that the type of content will be displayed in the
Activity Stream widget on the eIntranet pages.

l Email—A checked box indicates that the type of content will be sent to your Email address,
which is specified in the General tab of your profile.

EditingMyProfile
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Joining a Community Group
Community groups are online places where people can discuss similar interests (such as car
racing, or product reviews). In the Group section of My Profile, you can view or hide the tags
associated with your groups, or click on a group to go to the group page. If you have
administrator privileges, you also can do the following:

l Create a new group by clicking Create Group. For information about creating new groups,
see Managing Groups on page 85.

l View and approve requests to join the groups for which you are a moderator.
l View the requests that you have made of other moderators to join another group.

To join a group:
1. Choose Community > Find Groups. A list of available groups appears.

98 OnTrek in Ektron Reference
June 2012—Doc. Rev. 1.8



2. Click on the group you want to join. The Group page appears.
3. Click Join Group. The Group is added to the My Groups tab on My Profile.

Joining a Community Group

OnTrek in Ektron Reference
Ektron 8.02, 8.5, 8.6

99



The activity also shows up in My Activity tab of My Profile.

Connecting with Colleagues
Colleagues are people with whom you connect and who are connected to you, either through
friendship or professional contact.

You can do the following in your Colleagues area.
l Display the people with whom you are connected.
l View requests of people who want to connect to you as a colleague.
l View the requests that you have made of others to connect as a colleague.
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Creating a Blog
You can create your own Web log (blog) and colleagues can follow your blog entries
automatically when you create them, when you make them public and your colleagues have set
up their profile to follow your blog. See for information about setting up your profile.

You can do the following in the Blog area.

l Add a new blog post.
l Edit an existing post.
l Delete an exiting post.

Creating a Blog
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l Create a permanent link to a specific blog post that you can access it via the URL in the
browser’s address bar. (Most blog pages show only recent posts. After a post is moved off
the blog’s front page, it is still accessible via this link.)

l Subscribe to RSS or Email notifications.
l View highlighted and clickable days on the calendar indicating when a blog entry was
posted.

l View an automatic roll of blog entries.
l View a list of archived blog entries.
l View a list of blog post subjects.
l View the most recent blog entries.

To create a blog:

1. Open the access point ( ) and choose New Post (or click on Add Post). An Ektron editor
appears.

2. Enter a title and content for your blog.
3. Click Publish when ready. The following figure shows the Ektron editor with "The

Administrator's First blog" ready to publish.

The following figure shows the published blog on the page.
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Personalizing Your Dashboard
The Dashboard lets you personalize your own Web view of OnTrek.

1. If you do not already have a tab, you must create one by opening the Option menu ( )
and choosing Add Tab. The Add Tab dialog box appears.
a. Enter a Tab Label.
b. Select a Tab Scope (Public or Private).
c. Click OK.

2. Open the widget bar ( ).
3. Drag and drop a widget onto your dashboard.
The following figure shows an open widget bar with a Clock widget and a Blog widget in the
dashboard space.

Personalizing Your Dashboard
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To change the contents of a widget, click Edit ( ).

To dismiss the widget from the Dashboard, click Close ( ).

Uploading and Managing Documents
You can create or upload documents that you want to share with colleagues on your OnTrek. You
can create new HTML content, or upload document assets (such as Word or PDF documents).

To create a new HTML document:

1. Open the Add New menu on the right side of the page and choose Content, an editor
appears.

2. Enter a title and content, and any other data you want to associate with the content, and
click Publish ( ) when done.

To upload one or more document assets:

1. Open the Add New menu on the right side of the page and choose Asset. The Add
Document dialog box appears.
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2. Do one of the following methods:
l Click on the Multiple DMS Documents tab, then drag one or more files from a Windows
Explorer to the dialog box.

l Click the File Upload tab, then browse for a file and click Upload when ready.

Managing a List of Favorite Links
You can create a list of often-used or important links on the Favorites page.

1. Enter a URL in the field that is seeded with http://.
2. Enter the title of the link that you want to display in your Favorites list.
3. Click Add. The title appears in the list and you can click on it to display the specified URL.

You can also create folders to categorize your favorite links.

To add folders to My Favorites:

Managing a List of Favorite Links
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1. Right-click on the My Favorites folder and choose Add Folder.
2. Enter the name of a subfolder in the Add Folder dialog box and click Add.

The following figure shows subfolders created called Farm Products, Produce,
Supplies, Equipment, and Seasonal Jobs.

NOTE: The folders display in the order that you create them.

Uploading and Managing Photos
You can create and manage folders of photos.

1. Click Add Photo.
2. Optionally describe the one or more photos that you want to add then click Next.
3. Depending on your browser, you can upload photos one at a time or more than one file at a

time. For information about your browser's method, see .
You can also create folders to categorize your photographs.

To add folders to My Photos:
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1. Right-click on the My Photos folder and choose Add Folder.
2. Enter the name of a subfolder in the Add Folder dialog box and click Add.

The following figure shows the My Photos folder with several photos loaded.

Modifying the My Account Pages
The My Account page lets a registered user participate in eCommerce by specifying shipping and
billing information. The My Cart page allows secure order processing. The Order History page
offers secure viewing of purchase orders.

To create your own My Account page, you must modify or create templates and user controls,
which is not described in this OnTrek in Ektron Reference. Developers of .NET templates and
user controls can find product templates and user controls at the following locations.

l Template files (.aspx), PageBuilder template files (.pb.aspx), and c# code behind files
(.cs) in the [siteroot] folder of the installation.

l Master pages—[siteroot] > OnTrek > Components > Templates.
l User controls—[siteroot] > OnTrek > Components > userControls.

For additional information, see the Ektron Users Guide: Building an Ektron Powered Website and
the Ektron Reference.

Editing the My Account Page Introduction In Context
OnTrek preloads the introduction to the My Account page with Lorem ipsum text to give you an
example of what a My Accounts page introduction can look like.

You can edit this content from the page by following these steps after logging in:

Modifying theMyAccount Pages
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1. Open the access point ( ) above the content.
2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the My Account Page in the Workarea
You can access the My Account page introductory content in the Workarea, where you can create
additional information about the content (such as Metadata). To do this, follow these steps:

1. Login to the Workarea and choose the Content tab.
2. Choose Folders > MainSite > Content > My Account. The View Content panel displays

the content.
3. Click onMy Account in the View Content panel.
4. Click Edit. The content editor appears.
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5. When you are finished editing, click Publish. The text changes on the page.

Creating an SSL Certificate
You must have a Secure Socket Layer (SSL) Certificate to engage in eCommerce. In OnTrek,
you can use SSL when users log in to your Web site. SSL encrypts the username and password
during transmissions to the server.

When you set up the SSL certificate, and configure OnTrek to use it, the login page launches in a
Secure Socket Layer. The following topics explain how to set up SSL for OnTrek.

Setting Up the Secure Socket Layer (SSL) Certificate
Many articles on the Internet describe how to install a SSL Certificate. Use the proper procedure
for the specific version of IIS you are using on your server.

l IIS 6.0—
http://ww-
w.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/56bdf977-
14f8-4867-9c51-34c346d48b04.mspx

l IIS 7.0—http://learn.iis.net/page.aspx/144/how-to-set-up-ssl-on-iis-7/

Use a self-signed certificate for developer and testing servers.

Creating an SSL Certificate
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Updating the web.config File
After you set up the Secure Socket Layer (SSL) certificate, configure OnTrek to use the SSL
certificate.

1. Open the web.config file.
2. Locate the section of the file with these settings.

<add key="ek_UseSSL" value="false" />
<add key="ek_SSL_Port" value="443" />

3. Set the ek_UseSSL value to false. (This setting differs from other Ektron sites that use
eCommerce pages.)

4. Save and close the file.

Updating the application.security.config File
The application.security.configfile determines which pages in the site require an HTTPS
connection.

1. Open the applicaton.security.config file located in the [siteroot] with your editor.
2. Locate the code that looks like the following:

<ektron:template path="/checkout.aspx"> 
<ektron:template path="/account.orderHistory.aspx">

3. Add or change names of templates that you want to use HTTPS.

Viewing My Cart
OnTrek enables eCommerce, providing the building blocks you need to sell product on the
Internet. You can do the following from the My Cart page:

l Create one or more named carts to organize your purchases. See Creating a Named Cart
on the facing page.

l Empty the active cart to start over.
l Modify the quantity of the items you selected and click Update Subtotal.
l Enter a coupon code. See Entering a Coupon Redemption Code on the facing page.
l Continue shopping.
l Go to a secure checkout page.

IMPORTANT: Youmust have Secure Socket Layer (SSL) certificate to complete an eCommerce
transaction. See .

The following figure shows a My Cart page with 2 named carts (Training and High Tech). The
active cart is High Tech which shows 3 items in the cart.
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Creating a Named Cart
The default My Cart is all you need to shop. However, you can personalize or organize
your cart by naming it. To do this:

1. Click on the Rename Cart icon ( ).
2. Enter the name of the cart in the Cart field.

3. Click OK ( ). The new cart becomes active and appears in the My Saved Carts section.

Entering a Coupon Redemption Code
You can get additional discounts with a valid coupon code. To do this:

Creating a NamedCart
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1. Click on Apply Coupon.
2. Enter a valid coupon code. 

3. Click OK ( ). If the code is valid, the discount will be deducted from the subtotal and
appear on the order form.

Viewing the Order History
OnTrek securely displays order history. You secure the Order History page in the
Application.Security.config file in the site's [siteroot] folder. See .

To change the Order History page, you must modify the account.orderHistory files
that are located in the [siteroot] folder of the OnTrek installation.

WARNING! You are strongly recommended to have a Secure Socket Layer (SSL) certificate to complete an
eCommerce transaction. Without SSL, your transaction will not be secure. See .

Modifying Shipping and Billing Information
OnTrek displays information about a registered user on the Shipping and Billing Information
screen. To modify personal, billing, or shipping information, click Edit.

Checking Out Your Purchase
OnTrek comes with a checkout process. To change the checkout process, you must modify the
templates that are located in the [siteroot] folder of the OnTrek installation. Developers of
.NET templates and user controls can refer to Ektron Users Guide: Building an Ektron Powered
Website and the Ektron Reference for information about modifying templates.
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WARNING! You are strongly recommended to have a Secure Socket Layer (SSL) certificate to complete an
eCommerce transaction. Without SSL, your transaction will not be secure. See .

The following figures show an example checkout process.

1. Enter the Billing information and then click Save Changes.

2. The Shipping Address screen appears. Verify the shipping information. If the shipping
address is the same as the billing address, click Next Page. Otherwise, click Edit Info to
change the information.

CheckingOut Your Purchase
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3. Choose the shipping rate, then click Next Page.

4. Review your order. You can edit your cart from this screen. If it is correct, click Next
Page.
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5. Enter your payment information. When complete, click Submit Order.
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Modifying Site Styles
Developers who are familiar with cascading style sheets (CSS) can change OnTrek styles. This
section shows how to use individual CSS files and sprites.

Style Sheets Used in The OnTrekWeb Site
The following key style sheets produce the major user interface features that you can modify for
your site.

l jquery-ui-1.8.13.custom.css

Defines styles that are built on top of the jQuery JavaScript Library. 
Path: [siteroot]/css/jquery-ui-custom-theme/.

l BlueprintCSS ie.css, print.css, screen.css

Defines key styles for columns and typography for overall page integrity. Path:
[siteroot]/css/blueprint/

l ektron-jQuery-Blueprint-overrides.css

Defines overrides to classes defined in the jQueryUI styles. Defining them in this file
instead of the jQueryUI file allows for easier maintenance. Classes names defined in this
file are preceded with .ui-xxx. Path:[siteroot]/css/.

l ektron.ui.framework.css

Defines styles specific to basic Ektron site pages including definitions for header, footer,
body, channel and others. Classes names defined in this file are preceded with .ektron-
ui-xxx. Path: [siteroot]/css.

l ektron.site.css

Defines the majority of the style changes needed for a specific site's appearance and style.
Definitions for common elements like H1-H6, body, and form styles are defined here. Also,
classes from the previous style sheets are further defined and extended.

If you need to make specific style changes, make them in this css file.

Testing Your Styles Using the Messages Page
OnTrek includes a special page for examining style changes you make in various css files.
Display this page in a browser by entering http://[siteroot]
/unittests/messages/ektron.messages.aspx.

This page displays each of the styles as you check a style name.

NOTE: Apply changes to styles by modifying or adding specific style classes to the ektron.site.css file
where practicle.

To see how styles are applied:

1. Uncheck all options
2. Check the styles you want. The text changes according to the style sheet cascading rules.
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Understanding jQueryUI
jQueryUI provides basic style definitions that enhance a Web site visitor's experience and also
provides a reliable development basis from which you can quickly construct pages.

You can download jQueryUI definitions from the Web site http://www.jQuery.com and apply
them to OnTrek.

Classes defined within jQueryUI CSS files define the appearance of various states and
containers. In most cases, the classes contained in the jQueryUI CSS file begin with .ui-.

IMPORTANT: Youmust use version 1.8.13 jQuery UI in this version of OnTrek.

To change the style class definitions:
1. Browse to http://www.jqueryui.com.
2. Select Themes from the menu.
3. Click the Gallery tab.

4. Decide which theme you want to use and click Download.
5. Unzip the files.
6. Copy the images folder and jquery-ui-1.8.13.custom.css to the folder [siteroot]

/css/jquery-ui-custom-theme.

Understanding jQueryUI
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Understanding BlueprintCSS
Ektron's best practice for styling Web sites include adopting a standard called BlueprintCSS.
(http://www.blueprintcss.org) This standard defines an easy-to-use column and typography
layout that provides ease-of-maintenance and  reliable high-quality layouts. BlueprintCSS also
provides cross-browser definitions to minimize your time to resolve these issues.

BlueprintCSS class names provide consistency between designers and developers when applying
specific styles to the elements of a page.

Installing BlueprintCSS Files
To download BlueprintCSS.css:

1. Browse to http://www.blueprintcss.org.
2. Follow the directions to Download Now.
3. Unzip the files and place it in the folder [siteroot]/css/blueprint.
4. Link ie.css, print.css, and screen.css into your templates.

Using BlueprintCSS for Vertical Alignment
To understand how to use BlueprintCSS in OnTrek, look at the code for default.aspx in Visual
Studio. Look for definitions like this.

<div class="span-24"> or <div class="span-8 last">

With BlueprintCSS, the page is divided into 24 evenly spaced columns spanning 30px plus a 10px
gutter between them. When you define an element with a class="span-24", you set it to the
full page width (950px). To define 3 equal columns across a page, all of the class spans must
equal 24. Use the last class to indicate the last column. The HTML code looks like this.

<div class="span-24">
(code inside full width column)

</div>
<div class="span-16">

(code inside a large column)
</div>
<div class="span8 last">

(code inside small column, the last column on the right)
</div>

The following figure shows the 24-column definition used by BlueprintCSS.
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To understand more about using BlueprintCSS, refer to the tutorials and forums that support it
at http://www.blueprintcss.org.

Understanding Ektron UI Framework
Ektron.ui.framework.css (located in [siteroot]/css) defines specific class names for use
within Ektron projects. This style definition file generally bridges the gaps BlueprintCSS and
jQueryUI CSS with Ektron standard definitions and styles.

The namespaces standardize the class names that you use across multiple projects, thus
unifying wireframe construction methods. Individual rules vary from one project to another, but
the class names are standardized.

Class rules defined in the Ektron UI Framework include the following components.

l Page framework—header, body, footer
l Typography helpers - uppercase, lowercase, smallcaps
l Color helpers - background colors for even and odd rows
l Sprites
l Tables and Grids
l Forms
l Paging
l Wizards
l Calendars
l Breadcrumbs
l Sprites

The site designer applies designs to the site using these definitions in parallel to the work the
developer does in coding the pages using these style classes.

The ektron.ui.framework.css file prefaces classes with .ektron-ui.

Understanding Ektron UI Framework
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For more information, see http://reference.ektron.com/developer/controls.aspx.

Understanding Ektron Site CSS
The ektron.site.css style sheet contains the definition of classes at the most detailed or
specific level. When you modify styles in this CSS, you have the largest impact on the
appearance of elements on the Web page.

You can override class definitions by applying specific style rules. The following code shows a
style for a special message that looks different from a normal paragraph.

div.ektron-ui-message > p {margin: .75em 0 .75em 20px; }

With this stylesheet, a developer and designer can work rapidly because classes and terms are
(in most cases) self-defining.

Using Sprites for Icons
A sprite is an image file made up of icons used in a Web site. A stylesheet defines the size and
location of individual icons within this file.

Using sprites improves Web site performance by reducing the number of images that are
transmitted to a browser from a server. When you combine all of the icons used in a site into
one larger image and add the definitions of the sprites into CSS styles, the images are loaded
into memory once and rapidly rendered by the browser.

Locating the Sprite Files
The sprite files are located in folder [siteroot]/css/sprites/silk. You can change or replace
this file as long as the dimensions are not changed and the filenames remain the same.

Viewing the Icons in a Sprite
The OnTrek Web site includes a special page to help you examine sprites. Display this page in a
browser by entering http://[siteroot]/unittests/sprites/ektron.sprite.silk.aspx.

The tab called Ektron Sprites: Silk OnTrek shows a copy of the sprite file containing 36
commonly used icons found in the file ektron.sprite.silk.OnTrek.png. The tab called Ektron
Sprites: Silk shows a copy of the sprite that contains all icons found in the
ektron.sprite.silk.png file.
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NOTE: If youmodify the sprite file, copy it into the unittests/sprites folder to see your changes in this
page.

Using the Sprite Generator
Create your own sprite by using the Sprite Generator located at http://spritegen.Website-
performance.org/. Follow the instructions to upload your icons in a zip file, modify the tools
configuration and generate the sprite. Be sure to use the same naming convention used in the
sprite file that you are replacing.

Using the Sprite Generator
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Using Widgets in OnTrek
Widgets are mini-applications that can provide either specific functionality (such as calendar
events) or areas into which you can add Ektron content (content blocks, list summaries,
collections, and so on). You can drag and drop widgets onto a page using PageBuilder. You can
find help about widgets anywhere you see and click Help ( ). To open the widget bar from the
PageBuilder menu, click on the up/down controls ( ).

The following list shows the widgets that are specifically designed for OnTrek (in addition to the
other widgets in the site. You can find more widgets at Ektron Exchange
(http://dev.ektron.com/exchange/) where Ektron users create and share Ektron code.

l Collection Widget on page 125—Displays a collection that is a list of content that you
choose from the content available in the Ektron.

l Content Analytics List Widget on page 126—Displays content based on how people rated
the content, what were the most recently published content items, or how many people
viewed the content .

l Content Block Widget on page 127—Displays any content on your Web page that you want
from Ektron.

l Featured Event Widget on page 128—Displays a single event with a link to more
information about the event.

l List Summary Widget on page 129 —Shows a list of content from a folder (and optionally
its subfolders) on your Web page.

l Product Analytics Widget on page 132—Displays a list of content from a folder (and
optionally its subfolders) on your Web page.

l TabPlus Widget on page 134—Displays items based on how customers rated the items,
how many customers viewed the items, or what were the most recently viewed items.

l Upcoming Events Widget on page 136—Displays a list of scheduled calendar events.
If you cannot find the widget you are looking for, perhaps it is not enabled for the wireframe. To
select the widgets that you want in a wireframe, see Choosing Widgets for a Wireframe below.

NOTE: Each landing page has a specialized OnTrek-specific widget. Youmay move these widgets between
drop-zones or remove them from their host PageBuilder pages like any other widget. However, because
these widgets were created specifically for OnTrek to fulfill OnTrek-specific design specifications, they do
not have the standardWidget edit interface. To edit these widgets youmust use a code editor like Visual
Studio. The following are the specialized widgets: Site-ClientList, Site-CommunityLanding, Site-
FeaturedProducts, Site-ProductSearchForm, Site-ServicesHome, Site-Slider, and Site-SupportLanding.

Choosing Widgets for a Wireframe
To select the widgets you want in a wireframe:

1. While logged into the Workarea in the Setting section, choose Settings > Configuration
> Template Configuration. The Active System Templates screen appears.

UsingWidgets in OnTrek
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2. Click on default.aspx (Wireframe Template). A window of widgets appears.

NOTE: You can select a different set of widgets for each wireframe. For example, click on
clients.pb.aspx (Wireframe Template) and continue with these steps.

3. Click on the widgets you want (or click Select All or Deselect All). Highlighted widgets
appear in the widget selection bar of pages that use the wireframe template; non-
highlighted widgets do not appear there.

4. You can also indicate that these widgets are for other device configurations.
5. Click Update Template. The widgets appear in the widget bar of pages that use the

wireframe you selected.
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Collection Widget
Shows a collection that is a list of content that you choose from the content
available in the Collection section of the Workarea. The following figure shows a
collection of Featured Products.

Properties

To change the properties, click Edit ( ).

l Collection ID—The drop down list is populated in the Workarea in the Collections area of
the Content tab. If you add a new collection in the Collections Workarea, it displays in the
Collection ID list.

l Description—Displays the description of the Collection ID, if one was written (otherwise
blank).

l Page Size—Enter the number of items you want displays in the widget window.
l Teaser—Check to display text from the Summary of each item in the list, if one was
written.

l Enable Paging—Check to see more content titles with forward and back buttons when
more items are in a collection than were specified in the Page Size property.

l IncludeIcons—Check to display an icon if an item has an icon associated with it.
l AddText—Enter the menu item text to add more content. For example, if you enter "Add
Quick Reference" it displays as follows in the editor menu.

CollectionWidget
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l Random—Choose True to list the collection items in random order; False to list them in
the order appearing in the Workarea.

l Get HTML—Choose True to display the associated HTML content of each collection item;
False to not display the HTML.

l XSLT—Enter the path to an EXtensible Stylesheet Language Transformation (XSLT) that you
want to use on the collection.

l CSS—Enter the path to a cascading style sheet (CSS) that you want to use on the collection.
l SelTaxonomyID—Enter the ID of the taxonomy that is assigned to the new content when
Add Items is chosen.

l Display Selected Content—Check to show content in this widget location when the site
visitor selects the content link from the collection. This overrides the quick link normally
associated to the content.

l Display Header—Check to show header text above the widget.
l Header Text—Enter text for the Header. Check the Enable Header property box to show
this text. If no text is entered into the Header property, the collection name shows.

Content Analytics List Widget
Displays information about a set of content or products. The following figure shows
the Highest Rated products in the default Software taxonomy.

Properties

To change the properties, click Edit ( ).

l Folder ID—Enter the ID of the folder that contains the items to appear in the list. You can
also select the folder from the folder tab.

l Header—Enter text for the header.
l Display Mode—Select one of the following to determine how the content information
displays.

o Accordion—Displays vertical tabs for viewing Highest Rated, Most Recent, and Most
Viewed items.

o Tabs—Displays horizontal tabs for viewing Highest Rated, Most Recent, and Most
Viewed items.

l Enable Paging—Check to show links to page forward or backward through the content list.
The amount of content shown in each page is set by the Items Per Page property.
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l Items Per Page—Enter the number of content items you want to display on a page. If
blank, page forward/backward buttons do not show.

l Taxonomy ID—Enter the ID of the taxonomy that is assigned to the new content when
Add Items is chosen.

l Display Read More—Check to display the Read More link.
l Read More Link Text—Enter text for the Read More Hyperlink set in the next property.
For example: "Read More..."

l Read More Hyperlink—Enter the hyperlink used for the Read More Text set in the
previous property. For example: "Content.aspx?id=168".

Content Block Widget
Shows any content on your Web page that you want from Ektron including html,
text, documents and digital media. You can set the content block widget to show a
specified content id. The following example shows the content called OnTrek
Announced New Book: Building an OnTrek-Powered Solution located under the
Content tab at Folders > MainSite > Company > Company News folder. A

header was added from the Properties tab.

Properties

To change the properties, click Edit ( ).

l Filter By:—Choose Content, Form, or Multimedia and then click View Results on the
bottom left of the dialog box to see the content items in the selected type.

l View Result—Click to display contents of the selected folder. Hover over a content item
so see a summary of the content. You can filter the content as described in the previous
table entry.

l Cancel button—Click to dismiss the dialog box without adding content.
l Save button—Click to save the changes you made and dismiss the dialog box.
l New button—Click to create new content (rather than selecting existing content).

Content BlockWidget
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l Foldertab—Use the Folder tab to navigate to content that you want to display in the
content block. For example, the sample content in the figure above is located at [siteroot]
> MainSite > Content > Company > Company News, and called OnTrek
Announces New Book:Building an OnTrek-Powered Solution in the View Results
pane.

l Taxonomytab—Use the Taxonomy tab to navigate to content that you want to display in
the content block. For example, select OnTrek Site Navigation > Clients > Case
Studies and select one of the result to display in the widget.

l Searchtab—Use the Search tab to find content to display. For example, type acme in the
search box and select one of the result to display in the widget.

l Propertiestab—Use the Properties tab to create a header text for the content.
o Display Header—Check to display the header text on the Web page.
o Header Text—Enter text that you want to display as the content header.

Featured Event Widget
Displays a single event with a link to more information about the event. The
following figure shows an example event that was created at [siteroot]
> MainSite > Content > Company > Event Calendar, and calledWebinar:
Maximizing Your Company Brand. A header was added from the Properties
tab of the Featured Widget dialog box.

Properties

To change the properties, click Edit ( ).

l Filter By:—Choose Content, Form, or Multimedia and then click View Results on the
bottom left of the dialog box to see the content items in the selected type.

l View Result—Click to display contents of the selected folder. Hover over a content item
so see a summary of the content. You can filter the content as described in the previous
table entry.

l Cancel button—Click to dismiss the dialog box without adding content.
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l Save button—Click to save the changes you made and dismiss the dialog box.
l New button—Click to create new content (rather than selecting existing content).
l Foldertab—Use the Folder tab to navigate to content that you want to display in the
content block. For example, the sample content in the figure above was created at
[siteroot] > MainSite > Content > Company > Event Calendar, and called
Webinar: Maximizing Your Company Brand in the View Results pane..

l Taxonomytab—Use the Taxonomy tab to navigate to content that you want to display in
the content block. For example, select OnTrek Site Navigation > Clients > Case
Studies and select one of the result to display in the widget.

l Searchtab—Use the Search tab to find content to display. For example, type acme in the
search box and select one of the result to display in the widget.

l Propertiestab—Use the Properties tab to create a header text for the content.
o Display Header—Check to display the header text on the Web page.
o Header Text—Enter text that you want to display as the content header.

List Summary Widget
Shows a list of content from a folder (and optionally its subfolders) on your Web
page. The following example shows the list summary in the Content tab at
Folders > Mainsite > Content > Store > Hardware folder.

Properties

To change the properties, click Edit ( ).

Property Description

Folder ID
Enter the ID of the folder that contains the items to appear in the
list. Set theRecursive property to include subfolders under this
folder.

List SummaryWidget
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Property Description

MaxResults Enter the number of content items you want to display on a page. If
blank, page forward/backward buttons do not show.

Teaser Check to display text from the Summary of each item in the list, if
one was written.

Recursive Check to include content in subfolders under the folder indicated by
the FolderID property.

EnablePaging
Check to show links to page forward or backward through the con-
tent list. The amount of content shown in each page is set by the
Max Results property.

Include Icons Check to show icons that represent each content item's type in the
ListSummary.

OrderByDirection ChooseAscending (A-Z; first-last) orDescending (Z-A; last-
first).

OrderKey

Choose one of the following options.

Title—Sorts by the title of the content.

DateModified—Sorts by the date the content was
last edited.

DateCreated—Sorts by the date the content was
first published.

Last Editor's First Name—Sorts by the first name
of the person who last published the content.

Last Editor's Last Name—Sorts by the last name
of the person who last published the content.
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Property Description

Content Type

Choose the type of content to display in the ListSummary.

AllTypes—Displays all types of content.

Content—Displays only content.

Forms—Displays only forms.

Archive_Content—Displays only archived content.

Archive_Forms—Displays only archived forms.

Assets—Displays only assets.

Archive_Assets—Displays only archived assets.

LibraryItem—Displays only library items.

Multimedia—Displays only multimedia file types.

Archive_Media—Displays only archivedmedia.

NonLibraryContent—Displays only non-library
content.

Discussion Topic—Displays only discussion
topics.

CatalogEntry—Displays only catalog entries.

Add Text

Enter the text used in the editor's menu to addmore content. For
example: if you enter "AddQuick Reference" it appears in the Edit
menu.

List SummaryWidget
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Property Description

SelTaxonomyID Enter the ID of the taxonomy that is assigned to the new content
when Add Items is chosen.

DisplaySelectedContent
Check to show content in this widget location when the site visitor
selects the content link from the list. This overrides the quick link
normally associated to the content.

XSLT Enter the path to an EXtensible Stylesheet Language Trans-
formation (XSLT) that you want to use.

CSS Enter the path to a cascading style sheet (CSS) that you want to
use on the collection.

Display Header Check to show header text above the widget.

Header Text Enter text for the Header. Check the Enable Header property box
to show this text.

Display Read More Check to display the ReadMore link.

Read More Link Text Enter text for theReadMore Hyperlink set in the next property. For
example: "ReadMore..."

Read More Hyperlink Enter the hyperlink used for theReadMore Text set in the previous
property. For example: "Content.aspx?id=168".

Enable
RSS Syndication Check to subscribe to RSS notification.

Product Analytics Widget
Displays information about a set of content or products. The following figure shows
the Highest Rated and most Viewed products in the Hardware taxonomy.
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Properties

To change the properties, click Edit ( ).

l Folder ID—Enter the ID of the folder that contains the items to appear in the list. You can
also select the folder from the Folder tab.

l Max Results—Enter the number of content items you want to display on a page. If blank,
page forward/backward buttons do not show.

l Recursive—Check to include content in subfolders under the folder indicated by the
FolderID property.

l Enable Paging—Check to show links to page forward or backward through the content
list. The amount of content shown in each page is set by the Max Results property.

l Include Icons—Check to show icons that represent each content item's type.
l Add Text—Enter the text used in the editor's menu to add more content. For example: if
you enter "Add Quick Reference" it appears in the Edit menu.

l SelTaxonomyID—Enter the ID of the taxonomy that is assigned to the new content when
Add Items is chosen.

Product AnalyticsWidget
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l Display Selected Content—Check to show content in this widget location when the site
visitor selects the content link from the collection. This overrides the quick link normally
associated to the content.

l XSLT—Select one of the following to determine how the content information displays.
o BulletedList—Displays the content titles as a bulleted list.
o CalendarEvents—Displays a list of scheduled events.
o ecmNavigation—Displays the titles of the content.
o ecmTeaser—Displays the titles and summary of the content.
o ecmHtml—Displays each content in the list summary.

l CSS—Enter the path to a cascading style sheet (CSS) that you want to use on the collection.
l Header Text—Enter text for the header.
l Display Accordion—Check to display vertical tabs for viewing Highest Rated, Most
Recent, and Most Viewed items.

TabPlus Widget
Lets you display more than one type of content in a tabbed widget. You can display
a tab for a Content Block, a List Summary, a Collection, or Upcoming Events. the
following figure shows the default appearance of the TabPlus widget with News (a
List Summary) and Events (Upcoming Events).

To add a tab, follow these steps:

1. Choose File > Edit from the PageBuilder menu.
2. If you do not have the TabPlus widget on the page, open the widget menu ( ) and

drag and drop the widget onto the page.
3. Click Edit ( ). The Tab Plus dialog box appears.
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4. Click AddNewTab.
5. Choose one of the Tab Type options: Content Block, List Summary, Collection, or
Upcoming Event. Fields appear that are the properties of each option's widget type.

Properties

To change the properties, click Edit ( ).

The properties table describes the properties you can fill out when you choose a tab option. Each
tab option has its own set of properties.

l Add New Tab—Click to add a new tab to the widget. A Tab Type drop down list appears.
l Tab Type—Choose the type of content you want in the new tab: content block, list
summary, collection, or upcoming event.

l ID—Enter the ID of the folder—or navigate to a folder using the folder tree—that contains
the items to appear in the list. Set the Recursive property to include subfolders under this
folder.

l Tab Title—Enter text for the tab header.
l Add Text—Enter the menu item text to add more content. For example, if you enter "Add
Quick Reference" it displays as follows in the editor menu.
—Image—

l Items Per Page—Enter the number of items you want displays in the widget window.
l Enable Paging—Check to see more content titles with forward and back buttons when
more items are in a collection than were specified in the Page Size property.

l Display Read More—Check to display the Read More link.
l Read More Link Text—Enter text for the Read More Hyperlink set in the next property.
For example: "Read More..."

l Read More Link URL—Enter the hyperlink used for the Read More Text set in the previous
property. For example: "Content.aspx?id=168".

l Enable RSS Syndication—Click to allow RSS notifications.
Additional properties for the List Summary option:

l Display XSLT —Select one of the following to determine how the content information
displays.

TabPlusWidget
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o ecmNavigation—Displays the titles of the content.
o ecmTeaser—Displays the titles and summary of the content.
o ecmHtml—Displays each content in the list summary.
o BulletedList—Displays the content titles as a bulleted list.

l Random—Choose True to list the collection items in random order; False to list them in
the order appearing in the Workarea.

l Recursive—Check to include content in subfolders under the folder indicated by the
FolderID property.

l Sort Order—Choose Ascending (A-Z; first-last) or Descending (Z-A; last-first).
l Order By—Choose one of the following options.

o Title—Sorts by the title of the content.
o DateModified—Sorts by the date the content was last edited.
o DateCreated—Sorts by the date the content was first published.
o Last Editor's First Name—Sorts by the first name of the person who last published
the content.

o Last Editor's Last Name—Sorts by the last name of the person who last published
the content.

Upcoming Events Widget
Shows a list of scheduled calendar events, similar to the following figure.

Properties

To change the properties, click Edit ( ).

—Properties—
l Folder ID—Enter the folder ID that contains the events you want to show in the list. You
can use the Folder Tab to browse the content folders to set the Folder ID property. To
select a folder or content:
1. Click the Folder tab.
2. Navigate to the folder you want and click it.
3. If the View Results panel is showing, click the content you want.
4. Click Save.

l Enable Header—Check to show the header above the widget.
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l Header—Enter text to show a colored bar with text above the Search box. If you leave this
blank, no text or colored bar shows above the search box. Text for the header is placed
inside an <h3> tag and adopts the same styles as the column in which it's placed.
(Optional)

l Enable Paging—Check to show links to page forward or backward through the content
list. The amount of content shown in each page is set by the Items Per Page property.

l Items Per Page—Enter the number of content items you want to display on a page. If
blank, page forward/backward buttons do not show.

l Read More Link text—Enter the string for the Read More Hyperlink set in the next
property. For example: "Read More..."

l Read More Hyperlink—Enter the hyperlink used for the Read More Link Text property.
For example: Events.aspx

l Enable RSS Syndication—Click to allow RSS notifications.

Upcoming EventsWidget
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Getting Support
Ektron has resources to help you.

l ektron.com—Ektron's home page has useful information, including additional contact
information and services. You can find product documentation at
http://www.ektron.com/Resources/Product-Documentation/.

l The Dev Center—The Ektron Dev Center (http://dev.ektron.com) has resources to help you
find a solution to a problem or see what you can do with Ektron. The Dev Center also has
Webinars for many of the features of Ektron Ektron. In the product forum, you can post tips
or ask other users about how they use Ektron products more effectively.

l Professional Services—Ektron Professional Services (http://www.ektron.com/services/) is
a complete services infrastructure that is customized to meet your specific needs.

l Implementation—Using Ektron's proven Implementation
(http://www.ektron.com/Solutions/Services/Implementation/), expert application
engineers can implement all or part of your Web site project,ensuring the success of your
project.

l Training—Ektron's Training Services (http://www.ektron.com/Solutions/services/training/)
 ensures your Web project’s success by providing the right level of training to your team at
the right stage of your Web project’s lifecycle.

l Synergy—The annual Synergy Customer Conference (http://synergy.ektron.com) is a
great way for you to learn more about using Ektron and meet other Ektron users.

l Local User Groups—Ektron management meets with Local User Groups (LUG) to bring the
latest news and products from Ektron. See http://usergroups.ektron.com/ for location and
dates.

l Support—Customer Support (http://www.ektron.com/Resources/Support/)
o United States: 1-603-594-0249 x7002
o Europe: +44 (0) 1628 509 040
o Australia: +61 2 9248 7222

For additional contact information, see http://www.ektron.com/About-Ektron/Contact-Us/.
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