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Introducing Ektron OnTrek
Ektron OnTrek is a starter site that is built on Ektron's powerful CMS400.NET.

You can modify many things directly on the Ektron OnTrek site through the CMS
Workarea, the in-context editor from the access point ( ), or from the
PageBuilder menu (dropping a widget onto the page). Ektron OnTrek uses
PageBuilder technology that lets you drag and drop blocks of functional content
called widgets onto the page. Some widgets are so flexible, you can put what
you want in them and display them at specified times or conditions.

Additionally, you can modify the site itself through the ASP.NET templates and
user controls in your installation hierarchy, using Microsoft Visual Studio or
similar tool. This Ektron OnTrek Reference describes direct manipulation of the
starter site and does not contain information about modifying the templates or
user controls. Developers of .NET templates and user controls can refer to
Ektron Developers Guide: Building an Ektron Powered Website and the Ektron
CMS400.NET Reference. You can find templates and user controls at the
following locations.

Templates (.aspx files) and PageBuilder templates (.pb.aspx files)
in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > components > templates.

User controls—[siteroot] > OnTrek > components
> userControls.

Ektron OnTrek addresses 3 key business needs:

Revenue Generation

Sell products and services from the web site.

Analyze customer activity to increase site traffic and sales con-
versions.

Customer Loyalty and Satisfaction

Promote your company brand and provide promotional and customer
events.

Communicate with your customers through social networking and
product ratings.

Support customers with forums, knowledge base, and technical sup-
port.

Operational Efficiency

Track customer purchases and support cases.

Attract top talent to your organization.

Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)

1

http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://www.amazon.com/exec/obidos/ASIN/0470885696/ektron-20
http://documentation.ektron.com/cms400/v802/webhelp/index.html
http://documentation.ektron.com/cms400/v802/webhelp/index.html
http://documentation.ektron.com/cms400/v802/webhelp/index.html


Ektron OnTrek Requirements
Ektron OnTrek has the following requirements.

OnTrek works for both CMS Users and Membership Users.

When you use eSync to update your server from the OnTrek site, you
must manually copy the application.config and
application.security.config files to the [siteroot]; eSync does
not automatically synchronize these files for security reasons. Also
synchronize the bin directory when you synchronize the database and
templates to ensure that skmValidators.dll is synchronized.

Do not disable aliasing. If you do, the site will break.

Do not delete the pre-defined Information Architecture implemented
via Ektron Taxonomy, Menu, and Folder components. If you do, the
site will break.

application.config
The application.config file is located at the [siteroot] folder of Ektron
OnTrek.

<?xml version="1.0"?>

<appSettings>

<!-- Site specific keys -->

<add key="SiteTitle" value="OnTrek" />

<add key="LoadDefaultThemeRollerTheme" value="false" />

</appSettings>

This file contains application-specific keys as follows.

1. SiteTitle key—Sets what shows up in the Browser’s Title bar. For
example, the browser title bar on the Products page is OnTrek: Prod-
ucts.

2. LoadDefaultThemeRollerTheme key—Determines whether to load
its own jQuery UI ThemeRoller theme for any Ektron component.
Some Ektron components require a jQuery UI ThemeRoller theme to
render properly in a browser. This key defaults to true. You should
set this to false only if the site has its own ThemeRoller theme. You
can apply these components to three use-cases relative to The-
meRoller themes:

In the Workarea where the component needs to load the
Workarea theme (the orange one).
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In a Web site that has its own ThemeRoller theme, in which
case, the component must load its own ThemeRoller theme
(named “Smoothness” – which is silver) for the component
to work properly.

Outside the Workarea in a Web site that does not have its
own ThemeRoller theme, in which case, the component
must NOT load its own ThemeRoller theme (and use the The-
meRoller theme provided by the site) because it otherwise
would overwrite the site’s ThemeRoller theme.

application.security.config
The application.security.config file is located at the [siteroot] folder of
Ektron OnTrek. The alias paths are placeholders (and are commented out). You
can set up secure pages by using these aliases, or by the template (.aspx).
Templates can be accessed by multiple aliases.

<?xml version="1.0"?>

<!-- paths are from root. aliases must exactly match

rawurl. -->

<!-- template example: /example.aspx, and /folder-

1/folder-2/example.aspx -->

<!-- alias example: /Secure-Section/, and /Secure-Sec-

tion/Super-Secure-Section/ -->

<ektron:SecureRequests xmlns:e-

ktron="urn:Ektron.OnTrek.Security">

<!-- <ektron:template path="/checkout.aspx" /> -->

<!-- <ektron:template path="/account.orderHistory.aspx" />

-->

<!--

<ektron:alias path="/" />

<ektron:alias path="/" />

-->

</ektron:SecureRequests>

Warning! The checkout.aspx and account.orderHistory.aspx files are commented out to
permit checkout to proceed without using a Secure Socket Layer (SSL) for demonstration
purposes only. Your transactions will not be secure unless you set up SSL and uncomment
those files. We highly recommend for any eCommerce implementation that you set up SSL for
secure transactions. For information about setting up SSL, see Setting Up the Secure Socket
Layer (SSL) Certificate on page 121.
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Touring the Home Page
Ektron OnTrek provides a home page design from which you can start
customizing your web site. The home page displays dynamic up-to-date content
about your company, providing access to your products, services, and other
company information. For information about modifying the home page, see
Modifying the OnTrek Home Page on page 21 The following figure shows the
Home Page.
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Touring the Products Page
The default Ektron OnTrek Products page contains the building blocks to get
your products and services up for sale. To modify these pages, see Modifying
the Products Pages on page 33.

The text block introduces your products and can be edited on the page
or in the Workarea content. For information about this, see Editing the
Products Introduction In Context on page 33.

The search box lets people find the products from your products list.

The Products page displays a short description and optional image of
the product with links to go to a Product Detail page, or to add the
product to the customer's cart. For information about adding a prod-
uct to the Products page, see Adding Products to the Products Page.

You can promote the highest rated, most purchased, newest, most
bookmarked, and most shared products to cross-sell, up-sell, and cus-
tomer-sell your products.

You can add items to a purchasing cart or wish list.

Ektron OnTrek Reference
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Touring the Clients Page
The default Ektron OnTrek Clients page contains the building blocks to display
your client list and successful partnering stories and case studies.

Client biographies

Testimonial quotes and videos

To modify these pages, see Modifying the Clients Pages on page 54
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Touring the Services Page
The default Ektron OnTrek Services page contains the building blocks to display
information about services that you provide, such as the following:

Training

Consulting

To modify the Services pages, see Modifying the Services Pages on page 45.
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Touring the Support Page
The default Ektron OnTrek Support page contains the building blocks for you to
place information and knowledge into the hands of your customers.

Host customer forums about your products

Maintain a knowledge base and FAQs

Handle online support requests

To modify these pages, see Modifying the Support Pages on page 60.
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Touring the Company Page
The default Ektron OnTrek Company page contains the building blocks to display
information about your company. Related Company pages include the following
information:

News Articles Page

Events

Our team

Careers

Office Locations

Contact Information

To modify these pages, see Modifying the Company Pages on page 72.
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Touring the Community Page
The default Ektron OnTrek Community page contains the building blocks to
create a social networking community.To modify these pages, see Modifying
the Community Pages on page 87
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Touring the My Account Page
The default Ektron OnTrek My Account page contains the building blocks to
create an account for a registered user. You also can do the following in this
area.

My Cart

Order History

Shipping and Billing Information

To modify these pages, see Modifying the My Account Pages on page 118.
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Modifying the Ektron OnTrek
Web Site
You can customize the Ektron OnTrek web site to suit your organization. The
following sections describe managing your site.

Logging into OnTrek on next page

Logging in With a Facebook Account on page 15

Registering a User on page 16

Using the Smart Desktop to Manage Your OnTrek Site on page 18

Managing Site Permissions on page 19

The following topics describe how to modify the landing pages and their
associated sub-pages.

Modifying the OnTrek Home Page on page 21

Modifying the Products Pages on page 33

Modifying the Services Pages on page 45

Modifying the Clients Pages on page 54

Modifying the Support Pages on page 60

Modifying the Company Pages on page 72

Modifying the Community Pages on page 87

Modifying the My Profile Page on page 101

Modifying the My Account Pages on page 118

Modifying Site Styles on page 130

Ektron OnTrek Reference
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Logging into OnTrek
You can log into OnTrek by clicking Login on the main page. The Register or
Login page appears as shown in the following figure.

If you are modifying the Ektron OnTrek site, you can enter admin in
the Email Address field and admin in the Password field and login with
full editing privileges.

If you are an existing user, enter your email address and password.
Your privileges are determined by a site administrator.

14
Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)



If you are a Facebook user, you can login in using your Facebook
account credentials by clicking Connect with Facebook. Your priv-
ileges are determined by a site administrator. For more information,
see Logging in With a Facebook Account below.

If you are a new user, use the register block to join the community.
Your privileges are determined by a site administrator. For more infor-
mation, see Registering a User on next page.

Logging in With a Facebook Account
You can use your Facebook account credentials to login to Ektron OnTrek by
following these steps.

1. Click Connect with Facebook on the login screen. The Facebook
Login screen appears.

2. New users can register by filling out the form and clicking Complete
Registration. Existing users can enter their User Name and Pass-
word and click Login.

Ektron OnTrek Reference
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To set up the Facebook login, see Developer Experience: Setup Instructions in
the Ektron CMS400.NET Reference. The user control files are located at
[siteroot]/OnTrek/facebookRegister.aspx and
facebookRegister.aspx.cs.

Registering a User
When someone registers to become part of the online community you set up,
the user information is stored in the Settings section of the Workarea at
Settings > Community Management > Memberships > Users.

To register as a member of the online community, fill in the Register form and
click Register. A confirmation dialog box appears.
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A registered member has limited options in the activity panel, as shown in the
following figure.

By contrast, an administrator has the following options.

Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)

17



Using the Smart Desktop to Manage
Your OnTrek Site
You can maintain your site content using your Workarea Smart Desktop.
Measure web page traffic, approve comments and content where necessary, or
maintain content to keep it current and up-to-date from this page.

The Smart Desktop contains widgets that help you identify tasks to complete, or
view comments and content that you need to approve. The Smart Desktop uses
PageBuilder technology to help you rearrange or add/delete widgets.

You can add, rearrange, or remove widgets on your Smart Desktop. To learn
more about customizing the Smart Desktop, see How Customizing the Smart
Desktop Works in the Ektron CMS400.NET Reference.
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Managing Site Permissions
Site permissions are determined by a user profile. The following matrix tables
show the permissions a user has based on their context.

Administrator
visits a...

...that is... ...then has access to...

user

a colleague all tabs. The Administrator has full rights to user
profile content (add, edit, delete).

not a colleague all tabs. The Administrator has full rights to user
profile content (add, edit, delete).

public group

amember all tabs

not amember

Group tab

Documents tab

Photos tab

private group

amember all tabs

not amember

Group tab

Documents tab

Photos tab

(May join a private group without having to be
approved)

Non-admin-
istrator visit

a...
...that is... ...then has access to...

user

colleague all tabs, but not content in folders that have "share-
level" set to "selected colleagues"

a selected colleague all tabs, and content in folders that have "share-
level" set to "selected colleagues"

not a colleague

Group tab

Documents tab

Photos tab

Ektron OnTrek Reference
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Non-admin-
istrator visit

a...
...that is... ...then has access to...

public group

amember all tabs

not amember

Group tab

Documents tab

Photos tab

private group

amember all tabs

not amember

Group tab

Documents tab

Photos tab

20
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Modifying the OnTrek Home Page
The Ektron OnTrek home page is an example of how you may want to display
your "first impression." The page employs many controls and uses PageBuilder
technology to let an administrator drag and drop widgets onto the page.

The following topics show you how to modify the home page.

Setting Up the Rotating Home Page Banner Images

Adding a Widget to the Page on page 24

Adding Assets on page 24

Selecting a Language for the Web Site on page 27

Searching the Site on page 27

Using the Site Map Page on page 28

Modifying the Request a Demo Page on page 29

Modifying the Privacy Policy Page on page 30

Modifying the Terms of Use Page on page 31Modifying Site Styles on
page 130

Modifying the Rotating Home Page Banner
Images
The home page displays a set of rotating banner images. You can modify the
rotating banner with the following steps.

1. Add a new banner to the ones that came with Ektron OnTrek.

1. Choose Library > MainSite > Content > Home > Home-
PageBanner.

Ektron OnTrek Reference
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2. Click Add ( ). the Add library Item form appears.

3. Enter a Title and Description.

4. Click Browse... to find the image file you want.

5. Click Save ( ). the images is added to the library in the Home-
PageBanner folder.

2. Edit the Smart Form that is the basis for the rotating banner.

1. Choose Content > Folders > MainSite > Content > Smart
Forms > HomePageBanner. The HomePageBanner item appears in
the View Contents panel.

2. Click the HomePageBanner item (ID=31). The details appear.

22
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3. Click Edit ( ). The editor appears.

Note: This example duplicates a slide and then modifies it.

4. Click on the Slides menu ( ) and choose Duplicate. A duplicate slide
is added.

5. To change the image, click Select Picture ( ). An Image properties
dialog box appears.

6. Choose a new image, specify the other properties and click OK. the
new image appears.

7. Modify the Title and Summary then click Publish ( ).

Refresh the screen (Ctrl/F5) on the Home page to see your image added to the
default page banner images.

For information about Smart Forms, see the Ektron CMS400.NET Reference.

You can also resize the banner width directly on the home page by
following these steps.

1. While logged in, choose File > Edit from the PageBuilder menu. The
home page appears in PageBuilder mode.

Ektron OnTrek Reference
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2. In the banner widget click Edit ( ). The New Width box appears.

3. Specify a numeric value and unit (Pixels, Em, or Percent) and click
Save.

Adding a Widget to the Page
Some pages in Ektron OnTrek have spaces where you can add one or more
widgets to the page. This is indicated by the PageBuilder menu when you are
logged in. To add a widget to the page, follow these steps.

1. While logged into the page, open the PageBuilder menu and choose
File > Edit. The widget area appears on the page.

2. Open the widget bar ( ) and choose a widget.

3. Drag and drop a widget in to the widget space.

Adding Assets
Assets are files that are created outside of CMS400.NET. You can store and
manage assets on your Ektron OnTrek site as shown in the following example.

To add a single asset, do the following:

1. Find a page that accepts assets; for example, the Documents accor-
dion tab on My Profile page.

2. Choose Add new... > Add Asset. A dialog box appears.

3. Click on the File Upload tab.

4. Click Browse... to locate the file.

5. Click Upload.

The following browsers use different methods for uploading assets.
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Adding Assets with Microsoft Internet Explorer below

Adding Assets with Google Chrome below

Adding Assets with Mozilla FireFox below

Adding Assets with Microsoft Internet Explorer and Microsoft Office on
next page

Adding Assets with Microsoft Internet Explorer
You can upload one file at a time using the File Upload dialog box.

1. Click Browse.

2. Select the file you want, then click Upload.

Adding Assets with Google Chrome
You can upload one file at a time using the File Upload dialog box.

1. Click Choose File.

2. Select the file you want, then click Upload.

Adding Assets with Mozilla FireFox
You can upload one file at a time using the File Upload dialog box. You can also
upload multiple files clicking on the Drag Drop tab and dragging files to the

Ektron OnTrek Reference
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Drag Drop tab.

Adding Assets with Microsoft Internet Explorer and
Microsoft Office
You can upload one file at a time using the File Upload dialog box.

1. Click Browse.

2. Select the file you want, then click Upload.

You can also upload multiple files by checking boxes next to the files that you
want to upload.

1. Click the Multiple DMS Documents tab.

2. Check the boxes next to the files you want, then click Upload. 

Note: You can see a list of allowed file types by clicking Show File Types. Ektron
CMS400.NET administrators can edit this list in the Workarea.
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3. If any selected file type is not allowed, you are notified. Ektron
OnTrek uploads all allowed file types.

Selecting a Language for the Web Site
Ektron OnTrek comes installed in U.S. English ( ) and Spanish ( ) languages.
Click on the language icon to display Ektron OnTrek in that language.

Note: If you login with a computer in another country, another version of English may be
installed. For example,British English is installed in the United Kingdom ( ).

To install a language that is not shown in the links, (for example, to add
French), see Working with Multi-Language Content in the Ektron CMS400.NET
Reference.

Searching the Site
To search the Ontrek site, type a string into the search box at the top of the
screen and click the magnifying glass icon.

The Search page appears, which displays Basic Search and Advanced Search
tabs.

Filtering Your Search
If you receive too many results from your search, you can filter the results by
using the drop down menu beside the Basic Search box. You can filter by Site,
HTML, Documents, Images, Multimedia, Forms, Tags, or Pages. The following
image shows a search filtered by Images.
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Specifying an Advanced Search
From the Advanced Search tab, you can refine your search to very fine
granularity. The Advanced Search parameters are shown in the following table.

Search
Parameter

Description

with all of the words Resultsmust have all the words specified; usesan AND operator for the
strings that you specify.

advanced search
exact phrase Resultsmust contain the exact string that you specify.

at least one of the
words

Resultsmust have any the words specified; usesanOR operator for the
strings that you specify.

without the word Resultsmust not have the string that you specify.

Filter Results

Choose one of the following filters. ClickAdd Filter to specifymore
than one filter.

Created Before—Results show itemscreated before
YYYY/MM/DD.
Created After—Results show itemscreated after
YYYY/MM/DD.
Modified Before—Results show itemsmodified before
YYYY/MM/DD.
Modified After—Results show itemsmodified after
YYYY/MM/DD.
Author—Results show itemscreated by the specified
author.
File Size—Results show items larger (>) or smaller (<)
than the specified file size in kilobytes.

Using the Site Map Page
The following figure shows the default Ektron OnTrek Site Map page. It is
automatically generated from the pages of your web site, and changes
accordingly. You can click on any of the links to go to the selected page.
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Modifying the Request a Demo Page
The Request a Demo page is an HTML Form. To modify this form, follow these
steps.

1. While logged in to the Request a Demo page, open the access point (
) and choose Edit. The Request a Demo form appears in the content
editor.

2. Modify the form. For information about HTML Forms, see the Ektron
CMS400.NET Reference. The following figure shows a modified form
and the result when you click Publish ( )

The introduction was modified

Name was changed to Full name

Twitter name field was added

Tweet was added
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Modifying the Privacy Policy Page
The following figure shows the default Privacy Policy page.
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To modify it for your company, follow these steps:

1. While logged in to the Privacy Policy page, open the access point (
) and choose Edit in Context to modify the page text, or Edit to mod-
ify the text and other content data in the CMS400.NET editor.

2. Change the content (and metadata) to suit your company and click
Save ( ).

Modifying the Terms of Use Page
The following figure shows the default Terms of Use page.
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To modify it for your company, follow these steps:

1. While logged in to the Terms of Use page, open the access point (
) and choose Edit in Context to modify the page text, or Edit to mod-
ify the text and other content data in the CMS400.NET editor.

2. Change the content (and metadata) to suit your company and click
Save ( ).
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Modifying the Products Pages
The Products page displays products and services that you want to sell. To see
the default Products page, see Touring the Products Page on page 5. You can
modify this page, and its associated pages, in the following ways.

Product page introductory text
Editing the Company Introduction In Context on page 72

Editing the Company Page in the Workarea on page 73

Selecting a Content Block for the Products Introduction on
page 35

Searching the Product Inventory on page 37

Displaying Product Specifications on page 37

Creating a New Catalog on page 38
Adding a Catalog to the Product Store on page 38

Creating New Product Types on page 40

Adding a New Product Type to a Catalog on page 42

Adding Products to a Catalog on page 43

To create your own Products page, you must modify or create templates and
user controls, which is not described in this Ektron OnTrek Reference.
Developers of .NET templates and user controls can find product templates and
user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Editing the Products Introduction In Context
Ektron OnTrek preloads the introduction to the Products page with Lorem
ipsum text to give you an example of what a Products page introduction can
look like. You can edit this content from the page by following these steps after
logging in:
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1. Open the access point ( ) above the content.

2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the Products Page in the Workarea
You can access the Products page introductory content in the Workarea, where
you can create additional information about the content (such as Metadata). To
do this, follow these steps:

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > Products.

3. Choose Products Home from the content list.
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4. Choose Edit ( ).

Selecting a Content Block for the Products
Introduction
To change the Products page introduction by selecting an existing piece of
content, follow these steps:

1. While logged in to the Products page, open the PageBuilder menu and
choose File > Edit. The widget spaces appear on the page.
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2. Click Edit ( ) in the Products Home widget. The Editing widget dialog
box appears.

3. Navigate the folder hierarchy to find a piece of content. When you
click on a folder, valid content appears in the View Results panel.

4. Click on a content item, then click Save. The content appears on the
page.

5. Click Publish ( ).
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Searching the Product Inventory
The search box on the Product page operates only on products contained on the
Product pages (and not on the entire OnTrek site). To search the Products area,
type a string into the search box at the top of the screen and click Search.

The Search page appears, which displays Basic Search and Advanced Search
tabs. From the Advanced Search tab, you can refine your search to very fine
granularity. The Advanced Search parameters are shown in the following table.

Search
Parameter

Description

with all of the words Resultsmust have all the words specified; usesan AND operator for
the strings that you specify.

advanced search
exact phrase Resultsmust contain the exact string that you specify.

at least one of the
words

Resultsmust have any the words specified; usesanOR operator for
the strings that you specify.

without the word Resultsmust not have the string that you specify.

Filter Results

Choose one of the following filters. ClickAdd Filter to specifymore
than one filter.

Price Below—Results show products below the spec-
ified price.
Price Above—Results show products above the spec-
ified price.
Product SKU—Resultsmatch the stock-keeping unit
(SKU) number specified.

Displaying Product Specifications
When you click on a product title or a Learn more > link, a product
specifications page appears with more details about the product. Product
information is located in the Content section of the Workarea at Folders
> MainSite > Content > Store, and in one of the store's folders. For
example, in the Hardware folder you can click on Basic Wireless Router to
display or edit the content about this product.
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You can create new products in the Hardware, Software, and Training
folders from the New menu. If you want to create a new catalog and new
product types, see Creating a New Catalog below.

Creating a New Catalog
To place products on your web site for sale, you can do the following steps
directly to the Ektron OnTrek pages.

1. Adding a Catalog to the Product Store below

2. Creating New Product Types on page 40

3. Adding a New Product Type to a Catalog on page 42

4. Adding Products to a Catalog on page 43

Unless you create your own products page, you only can add a catalog, new
product types, and new products to the content management system to the
existing Hardware, Software, and Training pages. To create your own products
page, you must modify or create templates and user controls, which is not
described in this Ektron OnTrek Reference. Developers of .NET templates and
user controls can find templates and user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
C# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek >Components > Templates.

User controls—[siteroot] > OnTrek >Components
> userControls.

For more information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Adding a Catalog to the Product Store
Ektron OnTrek comes with 3 product catalogs: Hardware, Software, and
Training. In the Workarea, the catalog folders (and the Store folder) are green
for quick identification.

The following example shows you how to add a new catalog called Farm
Products for the sale of farm-fresh fruits and vegetables and other farm-related
items.

1. While logged into the Workarea, open the Content tab.

2. Choose Folders > MainSite > Content > Store.

3. Right click on Store and choose Add Catalog (or choose New
> Catalog from the menus). The Add Catalog to Store screen
appears.
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4. Enter the name Farm Products in the Catalog Name field. Option-
ally add other data.

5. Click Save ( ). The new category appears in the list. The following
figure shows the Farm Products Catalog with other catalogs already
created under it.
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Creating New Product Types
Product types let you categorize your product line so that customers can browse
your product line more easily. For example, you can have Produce, Equipment,
and Supplies product types for a Farm Products catalog, or Monitors, Systems,
and Accessories product types for Computer Products.

To create a product type, follow these steps.

1. Login to the Workarea and choose the Settings tab.

2. Choose Settings > Commerce > Catalog > Product Types.

3. In the View Product types panel, choose New > Product Type. The
Add Product Type screen appears.
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4. On the Properties tab, enter the Title (Produce), Description (Farm
Produce) and Class (Product).

5. On the Media Defaults tab, click Add Thumbnail and specify the fol-
lowing 2 media default items:

Name: _main,Width: 150 px, Height: 125 px

Name: _thumb,Width: 70 px, Height: 58 px

Important: The dimensions of the images are optimized for the OnTrek presentation
of product images on a product page. Also, because OnTrek uses the _main and _
thumb filename prefixes, do not use these in your product image filenames, or it may
cause unpredictable results. The code-behind and XSLT used in the product section
of OnTrek key off of these text strings.

6. Click Save ( ). The new product type appears in the View Product
Types panel.
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Adding a New Product Type to a Catalog
To add a product type to a catalog, follow these steps.

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > Mainsite > Content > Store > Farm Prod-
ucts (assuming that you created Farm Products as described in Add-
ing a New Product Type to a Catalog).

3. In the View Entries panel, choose View > Catalog Properties. The
properties appear.

4. Click Edit Properties ( ).

5. Click the Product Types tab.

6. Break the inheritance value by unchecking Inherit Parent Con-
figuration.

7. Select a product type and click Add ( ). For example, select
Produce. (See Creating New Product Types on page 40.)

8. Click on the default radio button ( ) to enable the product type. The
following figure shows 4 product types added to the Farm Products cat-
alog.
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9. Click Update ( ). The View Properties panel reappears.

Adding Products to a Catalog
To add a product to a catalog, follow these steps.

Note: This example builds on prior steps outlined in Creating a New Catalog on page 38.

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > Store > Farm Prod-
ucts > Produce.

3. In the View Entries panel, choose New > Produce. The Add Catalog
Entry window appears.

4. Enter the following information:
a. Title: Pumpkins

b. Summary tab:  Pumpkins

c. Properties tab:
SKU: 123412341234

Number of Units: 200

Tax class: Goods

d. Pricing tab:
List price: $3

Our Sales Price: $2.60

e. Media tab:
a. Click Add New Image.

b. Title: Pumpkins

c. Alt Text: Pumpkins
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d. Browse for an image and click Upload.

e. Click Set as Product Icon.

f. Metadata tab:
a. Description: Pumpkins

b. Keywords: Text: Produce. Press Add ( ).

c. Keywords: Text: Pumpkins. Press Add ( ).

d. Title: Pumpkins

g. Category tab:
a. Open the category tree to OnTrek Site Navi-
gation and hover the cursor over Products and
click Add ( ). The Add Category dialog box
appears.

b. Category Title: Pumpkins.

c. Click Save ( ).

d. Check Products, Produce, and Pumpkins

5. Click Action > Publish. The View Entries screen appears with Pump-
kins in the Produce catalog.
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Modifying the Services Pages
The Services page displays information about training and consulting services
you offer. To see the default Services page, see Touring the Services Page on
page 7. You can access the pages associated with the Services page by clicking
the Learn More button in a tabbed window, or from the Services menu. You
can create and modify the following types of Services pages.

Services page introductory text
Editing the Services Introduction In Context below

Editing the Services Introduction in the Workarea on next
page

Selecting a Content Block for the Services Introduction on
page 47

Training Services page—Modifying the Training Services Page on page
51.

Consulting Services page—Adding Content to a Knowledge Base Page
on page 65.

Widget space—Adding a Widget to the Page on page 24

To create your own Services page, you must modify or create templates and
user controls, which is not described in this Ektron OnTrek Reference.
Developers of .NET templates and user controls can find product templates and
user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Editing the Services Introduction In Context
Ektron OnTrek preloads the introduction to the Services page with text to give
you an example of what a Services page can look like. You can edit this content
from the page by following these steps after logging in:

1. Open the access point ( ) above the content.

2. Choose Edit in Context. An editor window appears.
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3. Edit the text, and click Save ( ). The text changes on the page.

Editing the Services Introduction in the
Workarea
You can access the Services page introductory content in the Workarea where
you can create additional information about the content (such as Metadata). To
do this, follow these steps:

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > Services.

3. Choose Services from the content list.

4. Choose Edit ( ).
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Selecting a Content Block for the Services
Introduction
To change the Services page introduction by selecting an existing piece of
content, follow these steps:

1. While logged in to the Services page, open the PageBuilder menu and
choose File > Edit. The widget spaces appear on the page.

2. Click Edit ( ) in the Services widget. The Editing widget dialog box
appears.

3. Navigate the folder hierarchy to find a piece of content. When you
click on a folder, valid content appears in the View Results panel.
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4. Click on a content item, then click Save. The content appears on the
page.
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5. Click Publish ( ).

Modifying the Consulting Services Page
The following figure shows the default Ektron OnTrek Consulting Services page.

To modify the Consulting Services page to display your company information,
follow these steps:
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1. While logged in to the Consulting Services page, open the access point
( ) and choose Edit. The Edit Content editor appears with the con-
sultation form.

2. Modify the form. For information about HTML Forms, see the Ektron
CMS400.NET Reference. The following figure shows a modified form
with a Phone field added to the form, and the result on the page when
you click Publish ( ).
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Modifying the Training Services Page
The following figure shows the default Ektron OnTrek Training Services page.
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The Training Services page has 3 sections: the introduction, the tabbed course
offering section, and a widget space. The following topics describe each section:

Modifying the Training Page Introduction below

Adding a Course and Tab to the Course Offering Section below

Removing a Tab from the Course Offering Section on the facing
pageAdding a Widget to the Page on page 24

Modifying the Training Page Introduction
To modify the introductory text, open the access point ( ) and choose Edit in
Context, or choose Edit to modify the content in the workarea, if you want to
specify additional metadata.

Adding a Course and Tab to the Course Offering
Section
To add a tab to the course offering section, follow these steps.

1. In the Workarea in the Content section, choose Folders > MainSite
> Content > Services > Training. The contents of the folder
appear in the View Contents panel.
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2. In the View Contents panel, choose New > HTML Content. The con-
tent editor appears.

3. Specify the content for a new training course. When done, click Pub-
lish ( ). The new course appears in the View Contents panel with the
other courses.

4. In the Workarea in the Content section, choose Collections
> Training Tabs. The existing tabs appear in the View Collection
panel.

5. In the View Collection panel, choose Add Items ( ). The Add Items
panel appears.

6. Click onMainSite, then Content, then Services, then Training.
Your added course appears in a list of courses.

7. Check the box next to your new course and click Save ( ).

8. Refresh the browser (F5) to see the changes in the course offering
tab.

Removing a Tab from the Course Offering Section
To remove a tab from the course offering section, follow these steps.

1. In the Workarea in the Content section, choose Collections
> Training Tabs. The existing tabs appear in the View Collection
panel.

2. Click Remove Items ( ). The list of tabs reappears with check
boxes next to each.

3. Check the boxes of the tabs you want to remove and click Delete (
).

4. Refresh the browser (F5) to see the changes in the course offering
tab.
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Modifying the Clients Pages
The Clients page uses Smart Form content placed in a custom template. To see
the default Clients page, see Touring the Clients Page on page 6.

You can add clients to the client list, and drag and drop widgets onto the page.
The following topics describe the modification you can make the default Clients
pages.

Adding a Client and Case Study below

Modifying the Case Studies Page on page 56

Adding Testimonials on page 56

To create your own Clients page, you must modify or create templates and user
controls, which is not described in this Ektron OnTrek Reference. Developers of
.NET templates and user controls can find product templates and user controls
at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Adding a Client and Case Study
To add a client or case study, follow these steps.

1. While logged into the Case Studies page, click onAdd Case Study,
which opens a Client Smart Form in Folders > MainSite > Content
> Clients in the Contents section of the Workarea. For information
about Smart Forms, see the Ektron CMS400.NET Reference.
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2. Enter a Title.

3. Enable Content Searchable.

4. Enter a Client Name.

5. Enter a Client URL to the client's Web site.

6. Click Select Picture ( ). The Image Propertied dialog box appears.
a. Click on the ellipsis button (...). The Library Folder appears.

b. Select an image from the library and click Insert ( ).

Note: If you do not have the image already loaded in the library, you can
search your computer by clicking Add Library ( ), browsing for the
image, and the click Add Library ( ) to contunie with the Image
Properties dialog box.

c. Specify theWidth to 70. Height is automatically calculated
(to 79 in this case) when you specify width.

d. Click OK. The client logo is display on the Client Smart
form.
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7. Checking the box next to Display Case Study on Case Studies
page if you want it to show there.

8. Specify the case study information you want.

9. In the Category tab, check the taxonomies that apply at Ontrek Site
Navigation > Clients > Industries.

10. Click Publish ( ). The new client appears in the client list and on the
Clients page.

If you set the Education industry in the Category tab, then choose Education
from the By Industry filter menu on the Clients page to see your new client
filtered with other clients with the same taxonomy.

Modifying the Case Studies Page
Like the Clients page, the Case Studies page displays clients that you can filter
with the By Industry filter menu. However, the Case Studies page displays
more information about the clients that was entered in the Client Smart Form,
which is described in Adding a Client and Case Study on page 54. To add a case
study to the Case Studies page, you must check the box in the Smart Form next
to Display Case Study on Case Studies page.

You can edit the introduction by opening the access point ( ) and choosing Edit
in Context. You can specify additional metadata in the Workarea for the
introduction by choosing Edit.

The Case Studies page also contains a widget space. For information about
adding a widget to the page, see Adding a Widget to the Page on page 24.

Adding Testimonials
The testimonials in Ektron OnTrek are created from a Video Smart Form.

To add a client testimonial, follow these steps.

1. While logged into the Testimonials page, click on Add Testimonial,
which opens a Video Smart Form in Folders > MainSite > Content
> Clients > Client Testimonials in the Contents section of the
Workarea. For information about Smart Forms, see the Ektron
CMS400.NET Reference.
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2. Click Select Picture ( ). The Images Properties dialog box appears.
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3. Fill in the dialog box and click OK.

4. Click Select File ( ). The Link Manager dialog box appears.
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5. Fill in the dialog box and click OK.

6. Enter Caption text.

7. Enter a Description of the testimony.

8. On the Category tab, check the taxonomies that apply.

9. Click Publish ( ). A testimonial is added to the group of existing tes-
timonies.
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Modifying the Support Pages
You can create and modify the following types of Support pages. To see the
default Support page, see Touring the Support Page on page 8.

Support page introductory text
Editing the Support Introduction In Context below

Editing the Support Page in the Workarea on the facing page

Selecting a Content Block for the Support Introduction on
page 62.

Support Forums—Creating a New Knowledge Base Page on page 64.

Knowledge Base—Adding Content to a Knowledge Base Page on page
65.

Support Request—Modifying the Request Support Form on page 66.

Support Search—Searching the Support Database on page 70 or
Searching the Knowledge Base.

Widget space—Adding a Widget to the Page on page 24

To create your own Support page, you must modify or create templates and
user controls, which is not described in this Ektron OnTrek Reference.
Developers of .NET templates and user controls can find product templates and
user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Editing the Support Introduction In Context
Ektron OnTrek preloads the introduction to the Support page with Lorem ipsum
text to give you an example of what a Support page introduction can look like.
You can edit this content from the page by following these steps after logging
in:

1. Open the access point ( ) above the content.

2. Choose Edit in Context. An editor window appears.
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3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the Support Page in the Workarea
You can access the Support page introductory content in the Workarea, where
you can create additional information about the content (such as Metadata). To
do this, follow these steps:

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > Support.

3. Choose Support Home from the content list.

4. Choose Edit ( ).
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5. Publish ( ) your changes.

Selecting a Content Block for the Support
Introduction
To change the Support page introduction by selecting an existing piece of
content, follow these steps:

1. While logged in to the Support page, open the PageBuilder menu and
choose File > Edit. The widget spaces appear on the page.
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2. Click Edit ( ) in the Support Home widget. The Editing widget dialog
box appears.

3. Navigate the folder hierarchy to find a piece of content. When you
click on a folder, valid content appears in the View Results panel.

4. Click on a content item, then click Save. The content appears on the
page.
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5. Click Publish ( ).

Creating a New Knowledge Base Page
To add a Knowledge Base page, follow these steps.

1. Click Resource Wizard in the top navigation area. A dialog box
appears.

2. Enter the name of a new Knowledge Base resource and click Add. A
new Knowledge Base resource page is created. The following figure
shows a new Knowledge Base resource page for Farm fresh produce.
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The new page is pre-loaded with Content, a PageBuilder Page, a
taxonomy category, and menu links.

Adding Content to a Knowledge Base Page
To add content to a Knowledge Base page, follow these steps:

1. While logged into the Workarea in the Content section, choose Fold-
ers > MainSite > Content > Support > Knowledge Base. The
View Content screen displays the current articles in the Knowledge
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Base.

2. Choose New > HTML Content. A content editor appears.

3. Add the Title and content of the article.

4. On the Category tab, choose OnTrek Site Navigation > Support >
Knowledge Base, and check the type of article.

5. Click Publish ( ).

Administrators can add subfolders to the default or user-created Knowledge
Base page directly, as described in the following steps.

1. On the Knowledge Base page on the left side, right click on the Knowl-
edge Base folder and choose Add Folder. The Add Folder dialog box
appears.

2. Specify the name of a subfolder (or example, Best Practices) then
click Add. The folder is added to the list as shown in the following sam-
ple figure.

When you add content to a folder, the taxonomy of the folder is applied to the
content automatically.

Modifying the Request Support Form
The Request Support page is created with a HTML Form. To modify this form,
follow these steps.

1. While logged in to the Request Support page, open the access point (
) and choose Edit. The Request Support form appears in the content
editor.

2. Modify the form. For information about HTML Forms, see the Ektron
CMS400.NET Reference. The following figure shows a modified form
and the result when you click Publish ( ).

Twitter name field was added

Tweet was added
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The Request Support page also has a widget space that contains two List
Summary widgets by default. To add a widget, see Adding a Widget to the Page
on page 24.
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Viewing Support Requests
When the Request Support form is filled out and the Submit Request is
clicked, the form data is added to the CMS400.NET. To view submitted
requests, follow these steps.

1. Login as administrator.

2. Navigate to Support > Request Support. The Request Support
page appears.

3. Open the access point ( ) and choose Properties. The View Forms
"Request Support" screen appears in the CMS400.NET Workarea.

4. Click Report ( ). The form changes for you to specify viewing crite-
ria, such as start and end dates and so on.
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5. Click Get Report. The requests display within the criteria that you
specified.

Searching the Support Database
The search tool on the support page operates on the forums and knowledge
base content. The following example shows a search with a wildcard (*) for the
word "work*" that produced 4 results. Specify your search criterion and click
Search.
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Modifying the Company Pages
The Company page and associated pages contain elements that you may want
to present your company to visitors to your site. The main Company page
displays a content block and a widget space with an Upcoming Events widget.
To see the default Company page, see Touring the Company Page on page 10.
You can create and modify the following types of Company pages.

Company page introductory text
Editing the Services Introduction In Context on page 45

Editing the Services Introduction in the Workarea on page 46

Selecting a Content Block for the Company Introduction on
page 74.

Company News page—Modifying the Training Services Page on page
51.

Company Calendar page—Adding Content to a Knowledge Base Page
on page 65.

Our Team page—Modifying the Request Support Form on page 66.

Careers page—Modifying the Careers Page on page 81.

Contact Us page—Modifying the Contact Us Page on page 83.

Widget space—Adding a Widget to the Page on page 24.

To create your own Company page, you must modify or create templates and
user controls, which is not described in this Ektron OnTrek Reference.
Developers of .NET templates and user controls can find product templates and
user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Editing the Company Introduction In Context
Ektron OnTrek preloads the introduction to the Company page with Lorem
ipsum text to give you an example of what a Company page introduction can
look like.
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You can edit this content from the page by following these steps after logging
in:

1. Open the access point ( ) above the content.

2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the Company Page in the Workarea
You can access the Company page introductory content in the Workarea, where
you can create additional information about the content (such as Metadata). To
do this, follow these steps:

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > Company.

3. Choose Company from the content list.
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4. Choose Edit ( ).

Selecting a Content Block for the Company
Introduction
To change the Company page introduction by selecting an existing piece of
content, follow these steps:

1. While logged in to the Company page, open the PageBuilder menu and
choose File > Edit. The widget spaces appear on the page.
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2. Click Edit ( ) in the Company widget. The Editing widget dialog box
appears.

3. Navigate the folder hierarchy to find a piece of content. When you
click on a folder, valid content appears in the View Results panel.
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4. Click on a content item, then click Save. The content appears on the
page.

5. Click Publish ( ).

Modifying the Company News Page
To view the Company News page, choose Company > Company News.
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To add a news item to the Company News page, follow these steps.

1. While logged in on the Company News page, open the access point ( )
and choose Add News. A content editor window appears.

2. Fill in the content and click Publish ( ) when done. The
HTML content item is added to the following location in the Content
section of the Workarea: Folders > MainSite > Content > Com-
pany > Company News.

3. Refresh the browser (F5) to see the changes on the Company News
page.

The following example shows an added news item (Catering Services Available)
to the OnTrek default items.

Adding Events to the Company Calendar
To view the Company calendar page, choose Company > Events. Events on
the company calendar appear in the Upcoming Events widget.

To add a news item to the Company News page, follow these steps.

1. Double click on a day in the calendar. The Edit Appointment screen
appears.
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2. Fill out the form. When done, click Save.

Note: You can find the company calendar in the Workarea in the Content area at Folders
> MainSite > Content > Company > Event Calendar.

Modifying the Our Team Page
The Our Team page consists of an introduction, a collection of team members,
and a widget space in the right column. To modify the Our Team page
introduction, see Editing the Company Introduction In Context on page 72 or
Editing the Company Page in the Workarea on page 73.

Adding a Widget to the Page
To add or change the widget on the page, see Adding a Widget to the Page on
page 24.

Adding a Team Member to the Page
To add a team member to the page, follow these steps.

1. If you want to use a picture of a new team member, you must first
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add the image.
a. While logged into the Workarea in the Library section,

choose Library > MainSite > Content > Company
> Our Team.

b. Click Add ( ).

c. Enter Title.

d. Click Browse to upload the image. You also can add addi-
tional information.

e. Click Save ( ).

2. While logged into the Our Team page, open the access point ( ) and
choose Add Team Members. The Select Folder window appears.

3. Click MainSite, then Content, then Company, then Our Team (the
text says, Selected Name: "Our Team"), and then click Next. The
Employee Profile form appears.
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4. Fill out the form.
a. Fill in the text fields.

b. To use a previously stored image, click on the add image
icon ( ). The Image Properties dialog box appears.

1. Click the Image Src ellipse button. The library
folder Our Team/images appears.

2. Choose the image you want and click Insert ( ).

3. Click OK.

5. Click Publish ( ). The new team member appears on the page.

Deleting a Team Member from the Page
To delete a team member, follow these steps.
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1. While logged into the Workarea in the Content section, choose Col-
lections > Our Team. The View Collection panel displays the team
members.

2. Click Remove Items ( ). Check boxes appear to the left of each
member.

3. Check the member that you want to remove and click Delete ( ).
The members are removed from the page.

Modifying the Careers Page
The Careers page contains a search box, a filter, a list of available jobs, and a
widget space in the right column. The following topics show you how to modify
these elements.

Note: The Search box is not modifiable.

To add or change the widget on the page, see Adding a Widget to the Page on
page 24.

To create a new job posting, see Creating a Job Posting below.

To modify the Filter Careers box, see Modifying the Filter Careers Box on next
page.

Creating a Job Posting
Job postings are located in the Workarea in the Content section at Folders >
MainSite > Content > Company > Careers. When you are logged in and at
this location, you can create a new job posting with the following steps.

1. In the View Contents panel, choose New > Job Description. The
content editor appears with a Job Profile Smart Form, as shown in the
following figure. For information about Smart Forms, see the Ektron
CMS400.NET Reference.
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2. Fill out the form.

3. Select the type of job in the Category tab by checking one or more
boxes next to the categories to which the job applies.

4. Click Publish ( ). The new entry appears on the Careers page.

Modifying the Filter Careers Box
The Filters Career box is dynamically loaded from the taxonomy.

To add a filter, you must add a category to the taxonomy by following these
steps.

1. While logged into the Workarea in the Content section, choose Tax-
onomies > Taxonomies > OnTrek Site Navigation > Company
> Careers. The View Taxonomy screen appears.

2. Click Add Category ( ). The Add Category screen appears.
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3. Enter a name in the Category Title field. For example, QA.

4. Click Save ( ).

5. Refresh the browser (F5) to see the changes in the Filter Careers box.

Modifying the Contact Us Page
The Contact Us page has an introduction section and a tabbed section. The
following topics describe each section:

Modifying the Contact Us Page Introduction on next page

Modifying the Contact Form on next page
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The Directions tab displays a Bing™ map from which you can search for
geographic locations.

Modifying the Contact Us Page Introduction
To modify the introductory text, open the access point ( ) and choose Edit in
Context, or choose Edit to modify the content in the workarea, if you want to
specify additional metadata.

Modifying the Contact Form
The Contact Form is created with an HTML Form. To modify this form, follow
these steps.

1. While logged in to the Contact Us page, open the access point ( ) and
choose Edit. The Contact Us form appears in the content editor, as
shown in the following figure.

2. Modify the form. For information about HTML Forms, see the Ektron
CMS400.NET Reference. The following figure shows a modified form
and the result when you click Publish ( ).

Job Posting was added to the Select Topic drop down menu
(by clicking Edit Menu ( ) next to the menu).

Twitter name field was added.
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Viewing the Default Multivariate Experiment
Page
Ektron OnTrek has a default multivariate experiment page set up. To view the
multivariate experiment, follow these steps.

1. While logged in, choose Company > News. The Company News
page appears.

2. Click on OnTrek Releases SelfServ Helpdesk Pro. The news item
appears.

3. Click on the Learn More > button. A new page appears with more
information.

4. Open the PageBuilder menu ( ) and choose File > Edit. The Mul-
tivariate widgets appear.
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The target page for the multivariate experiment is the Request a Demo page.

For information about how to set up a multivariate experiment, see the Ektron
CMS400.NET Reference.
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Modifying the Community Pages
The Community pages let people engage in social networking. To see the
default page, see Touring the Community Page on page 11. The default
Community page provides access to the following areas:

Area Description

Introduction

See the following topics:

Editing the Community Introduction In Context on
next page
Editing the CommunityPage in theWorkarea on
next page
Selecting a Content Block for the Community Intro-
duction on page 89

MyProfile
Manage your online persona. SeeModifying theMyProfile Page
on page 101 for information about personalizing a user expe-
rience on a social networking site.

Corporate Blogs

The Corporate Blogspage contains unmanaged content, but
when you click on the "Visit Blog" link, a blog-specific page
appearswhere you canmodify themanaged content. For more
information, seeModifying the Corporate BlogsPage on page 99.

Find Connections
Look for colleaguesand friends to connect to or add to your social
network. For more information, see Finding Connectionson page
99.

Find Groups Look for groups that share interestswith your own. For more infor-
mation, see FindingGroupson page 98.

To create your own Community page, you must modify or create templates and
user controls, which is not described in this Ektron OnTrek Reference.
Developers of .NET templates and user controls can find product templates and
user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.
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Editing the Community Introduction In
Context
Ektron OnTrek preloads the introduction to the Community page with Lorem
ipsum text to give you an example of what a Community page introduction can
look like. You can edit this content from the page by following these steps after
logging in:

1. Open the access point ( ) above the content.

2. Choose Edit in Context. An editor window appears.

3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the Community Page in the
Workarea
You can access the Community page introductory content in the Workarea,
where you can create additional information about the content (such as
Metadata). To do this, follow these steps:

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > Community.

3. Choose Community Landing from the content list.

88
Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)



4. Choose Edit ( ).

Selecting a Content Block for the
Community Introduction
To change the Community page introduction by selecting an existing piece of
content, follow these steps:

1. While logged in to the Community page, open the PageBuilder menu
and choose File > Edit. The widget spaces appear on the page.

2. Click Edit ( ) in the Community Landing widget. The Editing widget
dialog box appears.

3. Navigate the folder hierarchy to find a piece of content. When you
click on a folder, valid content appears in the View Results panel.
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4. Click on a content item, then click Save. The content appears on the
page.

5. Click Publish ( ).
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Managing Groups
Community groups provide common interest areas for people to collaborate.
You can create groups, join groups, maintain documents, calendars, discussion
boards, blogs, and photos. A group moderator creates a group and determines
whether the group is restricted or public. Ektron OnTrek provides an example
group called SelfServ HelpDesk User Group.

To create a new group, see Creating a New Group below.

To see what the example group lets you do with a group, see Moderating a
Group Message Board on page 93

To access groups in the Workarea, open the Settings tab and choose Settings
> Community Management > Community Groups. For information about
Community Groups, see the Ektron CMS400.NET Reference.

Creating a New Group
To create a Group, follow these steps.

1. Choose Community > Find Groups. The Find groups screen
appears.

2. Click the Create Group button.

Note: Administrators also can create a group from the My Profile > Group area.

Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)

91



Property Description

Group Name The name of the group.

Administrator

A group administrator hasprivileges to delete a group or edit its
properties.

Bydefault, the person who created the group is the group
administrator. Click theBrowse button if you want to select a
different group administrator.

Membership

Select whether the group is

Open—open to the public.

Restricted—members can only join if invited.
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Property Description

Features
Create Group Calendar—Letmembersof the group add events
to keep other members informed.

Create Group Forum—Start a groupsdiscussion board.

Image Upload an image to use asan avatar for the group.

Location The geographical location associated with the group.

Short Description A brief description of the group.

Description A fully detailed description of the group.

Enable Distribute

Check this box if you want the group and system administrator to
be able to distribute content to any folder.

For more information, seeDistributing Content to Another Folder
in theEktron CMS400.NET Reference.

Allow member to
manage
photo/workspace
folders

Check this box if you want to allow members to add, remove and
control the sharing of folders in a community group’sPhoto Gallery
or Document’sWorkspace. For more information, seeAuthorizing
Group Documents and Photoson page 96.

GroupMessageBoard
Moderation

Check this box if you want to this groupsmessage board to bemod-
erated. For more information, seeModerating aGroupMessage
Board below.

Attach Documents in
EmailNotifications

Check this box if you want email notificationsof connected user
activity to include attached documents, if applicable.

Tags Tab

From this screen, you can either create a new tag or select from a
default list of community group tags. For more information, see
Assigning Tags to a CommunityGroup in theEktron CMS400.Net
Reference.

3. Click Save ( ) to create the group.

Moderating a Group Message Board
To moderate a group message board, follow these steps.

1. Choose Community > Find Groups. The Find groups screen
appears. If you have many groups, use the Search tab to find the
group that you want to manage.

2. Click the group that you want to edit.
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3. Click Manage > Edit Group.

4. The Edit Group dialog box appears. For information about the prop-
erties, see Creating a New Group on page 91.

5. Check the Group MessageBoard Moderation box so that any group
member must approve a post before it appears on the group message
board. Inappropriate posts may be deleted before they appear on the
message board (although they will appear to reviewers/approvers).

AddingMembers to a Group
When you create a group, you can determine if its membership policy is open or
restricted. An open policy lets anyone join the group. A restricted policy
requires the group's administrator to approve new members.

Inviting Users to Join a Group
To invite colleagues to join a group, follow these steps.

1. Choose Community > Find Groups. The Find groups screen
appears. If you have many groups, use the Search tab to find the
group that you want to manage.

2. Click the group that you want to edit. The group page appears.

3. On the left, choose Manage > Invite Colleagues. The Invite Col-
leagues dialog box appears.
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4. Check the box next to the colleagues you want to invite to the
restricted group. (You can also specify email addresses on the Email
tab.)

5. Optionally modify the default message.

6. Click Send Invitations to send the message to the selected col-
leagues. Your colleagues will have to accept the invitation to appear
in the group.

The invited member receives notification of the invitation and chooses the
Invitationmenu to accept or decline it.

Joining a Group
To request joining a group, find the group you want and click on the Join
Group link. If the group is restricted, the moderator will have to approve your
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membership.

Authorizing Group Documents and Photos
You can authorize Community Group members to access the right-click menu
options on the Group's Documents and Photos folders.

To enable these menu options for group members, follow these steps.

1. From your group page, click Manage > Edit Group.

2. On the Properties tab, check the Allow member to manage
photo/workspace folders box.

Managing Group Documents
Group Documents let you store and share documents that are relevant to the
group. Group members can create their own documents and folders in the
common place, without having to create a file-sharing folder on a file server.
Additionally, you can add important information such as history (for archive
purposes), metadata, and work flow.

To create new HTML content, choose Add New > Content.

To add Microsoft Office documents and other file types (including multimedia
files), follow these steps.

1. Choose Add New > Asset.

2. Click Browse... and find the document you want to add.

3. Click Upload. The document appears in the table.

For information about adding assets using different browsers, see Adding
Assets on page 24.
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Managing a Group Blog
Group blogs let you post important comments, instructions, procedures,
policies, or any type of communication. Blog functionality includes reply, edit,
post, RSS feeds, and subscribe.

Managing a Group Dashboard
The Dashboard lets you customize a group page to include content for your
group, such as a list of content, a collection of links, documents, or images.

To customize your dashboard, follow these steps:

1. If you do not already have a tab, you must create one by opening the

Option menu ( ) and choosing Add Tab. The Add Tab dialog box
appears.

a. Enter a Tab Label.

b. Select a Tab Scope (Public or Private).

c. Click OK.

2. Open the widget bar ( ).

3. Drag and drop a widget onto your dashboard.
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The following figure shows a group dashboard with an iTune Podcast widget and
an upcoming Events widget in the dashboard space.

To change the contents of a widget, click Edit ( ).

To dismiss the widget from the Dashboard, click Close ( ).

Finding Groups
To find a group, follow these steps.

1. Choose Community > Find Groups. The Find groups screen
appears.

2. Click on the Search tab.

3. Enter the search string in the search box.

4. Click Search. The results are displayed in a table.

The following figure shows CEO* in the search box with Group Name as
the filter criterion.
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Modifying the Corporate Blogs Page
To add a blog to the Corporate Blogs page, follow these steps.

1. While logged into the Workarea in the Content section, choose Fold-
ers > MainSite > Content > Community.

2. In the View Contents panel, choose New > Blog. The Add Blog
screen appears.

3. Name the new blog and give it a title, then click Save ( ). The blog
appears as a subfolder under the Community Folder.

4. To add the new blog to the Corporate Blogs page, you must modify
the user controls, which is at [siteroot] > OnTrek >Components
> User Controls > community.corporateBlogs.aspx.

Note: This Ektron OnTrek Reference does not describe how to modify templates.
Developers of .NET templates and user controls can refer to Ektron Developers
Guide: Building an Ektron Powered Website and the Ektron CMS400.NET
Reference.

For more information about blogs, see Creating a Blog on page 110.

Finding Connections
To find a connection, type the name of a colleague or friend in the Display
Name search field, as shown in the following figure.
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You can search by one or more of the following criteria. Click Add Filter to
search by more than one criterion.

Display name

First name

Last Name

Tags

Email

User Properties
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Modifying the My Profile Page
The My Profile page is where registered users can personalize their experience
and lets them connect and collaborate with other people on your web site.

You can modify the following items in My Profile:

Editing My Profile
You can specify the following information on the Edit Profile tabs:

General

The following table and figure describe the information you can set. Fields with
a red asterisk (*) are required fields.

Field Description

First name Enter your first name.

Last Name Enter your last name.

Password Enter a password.

Confirm
Password Re-enter the same password.

E-Mail Address Enter your email address.

DisplayName Enter the name you want to display to others, which can be a nick-
name or title.

User Language Select from available languages.

Address Enter the address (or just the zip code) of where you are located.

Latitude This field is automatically determined by the address.

Longitude This field is automatically determined by the address.

Avatar Click on "Click to upload your Avatar" and choose an image file that
you want to associate with your profile.

Profile Links This field is automatically determined by your profile.
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Forum

The following table and figure describe the information you can set.

Field Description

Content and Forum
Editor Choose eWebEdit400 or eWebEditPro.
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Field Description

Topics per Page

Select the number of topics you want to display on a page. If the
number of available topics exceeds the number you select, a scroll
bar lets you see the additional topics. For example, if you select 10,
and there are 25 topics, you can scroll to see all the topic, but only
10 will be displayed at one time.

ForumSignature ClickEdit to enter or modify an automatic signature that appears
at the bottom of each post youmake to a forum topic.

Tags

The following table and figure describe the information you can set.

Field Description

Tags

Keywords that you can assign to content and library items, which allows for
tag-based searching. For example, you can add the tagElectronics and
tag content that is related to the electronic devices, so that people can
search for the content using theElectronics tag.
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Custom

The following table and figure describe the information you can set. Fields with
a red asterisk (*) are required fields.

Field Description

Moderate
Check theModerate box to give this user privilegeson amessage
board to approve and delete posts. Regular users in a groupmessage
board can create and delete only their own posts.

Features Check the Featuresbox to give the user an individual calendar. (There
maybe other features to grant, also.)
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Field Description

Private Profile

Choose from one of the following options:

Public—The user information is accessible byothers on
the eIntranet.
Private—The user information is not accessible by
others on the eIntranet.
Colleagues—The user information is accessible only by
people on the eIntranet that are connected as col-
leagues.

Time Zone Select the time zone where the user works.

Email Enter a valid email address.

Phone Enter the user's company telephone number.
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Activities

The following table and figure describe the information you can set. By default,
all activity is checked to display in the Activity Stream widget. By checking the
boxes, you can select criteria for the types of content you want to see when
colleagues or community groups create the content. You can also select
(publish) the types of content that you want colleagues to see under the My
Activities category.

Field Description

SMS Achecked box indicates that the type of content will be sent to your cell
phone Short Message Service (SMS).
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Field Description

ActivityStream A checked box indicates that the type of content will be displayed in the
ActivityStreamwidget on the eIntranet pages.

Email A checked box indicates that the type of content will be sent to your
Email address, which is specified in the General tab of your profile.

Joining a Community Group
Community groups are online places where people can discuss similar interests
(such as car racing, or product reviews). In the Group section of My Profile, you
can view or hide the tags associated with your groups, or click on a group to go

Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)

107



to the group page. If you have administrator privileges, you also can do the
following:

Create a new group by clicking Create Group. For information about
creating new groups, see Managing Groups on page 91.

View and approve requests to join the groups for which you are a mod-
erator.

View the requests that you have made of other moderators to join
another group.

To join a group, follow these steps.

1. Choose Community > Find Groups. A list of available groups
appears.

2. Click on the group you want to join. The Group page appears.

3. Click Join Group. The Group is added to the My Groups tab on My Pro-
file.
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The activity also shows up in My Activity tab of My Profile.
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Connecting with Colleagues
Colleagues are people with whom you connect and who are connected to you,
either through friendship or professional contact.

You can do the following in your Colleagues area.

Display the people with whom you are connected.

View requests of people who want to connect to you as a colleague.

View the requests that you have made of others to connect as a col-
league.

Creating a Blog
You can create your own Web log (blog) and colleagues can follow your blog
entries automatically when you create them, when you make them public and
your colleagues have set up their profile to follow your blog. See Editing My
Profile on page 101 for information about setting up your profile.
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You can do the following in the Blog area.

Add a new blog post.

Edit an existing post.

Delete an exiting post.

Create a permanent link to a specific blog post that you can access it
via the URL in the browser’s address bar. (Most blog pages show only
recent posts. After a post is moved off the blog’s front page, it is still
accessible via this link.)

Subscribe to RSS or Email notifications.

View highlighted and clickable days on the calendar indicating when a
blog entry was posted.

View an automatic roll of blog entries.

View a list of archived blog entries.

View a list of blog post subjects.

View the most recent blog entries.

To create a blog, follow these steps.

1. Open the access point ( ) and choose New Post (or click on Add
Post). A CMS400.NET editor appears.

2. Enter a title and content for your blog.

3. Click Publish ( ) when ready. The following figure shows the
CMS400.NET editor with "The Administrator's First Bog" ready to pub-
lish.
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The following figure shows the published blog on the page.

Personalizing Your Dashboard
The Dashboard lets you personalize your own Web view of the Ektron OnTrek.

To customize your dashboard, follow these steps.

1. If you do not already have a tab, you must create one by opening the
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Option menu ( ) and choosing Add Tab. The Add Tab dialog box
appears.

a. Enter a Tab Label.

b. Select a Tab Scope (Public or Private).

c. Click OK.

2. Open the widget bar ( ).

3. Drag and drop a widget onto your dashboard.

The following figure shows an open widget bar with a Clock widget and a Blog
widget in the dashboard space.

To change the contents of a widget, click Edit ( ).

To dismiss the widget from the Dashboard, click Close ( ).

Uploading and Managing Documents
You can create or upload documents that you want to share with colleagues on
your Ektron OnTrek. You can create new HTML content, or upload document
assets (such as Word or PDF documents).

To create a new HTML document, follow these steps:

1. Open the Add New menu on the right side of the page and choose
Content, a CMS400.NET editor appears.
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2. Enter a title and content, and any other data you want to associate
with the content, and click Publish ( ) when done.

To upload one or more document assets, follow these steps:

1. Open the Add New menu on the right side of the page and choose
Asset. The Add Document dialog box appears.

2. Do one of the following methods:
Click on the Multiple DMS Documents tab, then drag one or
more files from a Windows Explorer to the dialog box.

Click the File Upload tab, then browse for a file and click
Upload when ready.

Managing a List of Favorite Links
You can create a list of often-used or important links on the Favorites page.

To add a favorite link, follow these steps:

1. Enter a URL in the field that is seeded with http://.

2. Enter the title of the link that you want to display in your Favorites
list.

3. Click Add. The title appears in the list and you can click on it to dis-
play the specified URL.
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You can also create folders to categorize your favorite links.

To add folders to My Favorites, follow these steps:

1. Right-click on the My Favorites folder and choose Add Folder.

2. Enter the name of a subfolder in the Add Folder dialog box and click
Add.

The following figure shows subfolders created called Farm Products,
Produce, Supplies, Equipment, and Seasonal Jobs.

Note: The folders display in the order that you create them.
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Uploading and Managing Photos
You can create and manage folders of photos.

To add a photo to your personal photo gallery, follow these steps:

1. Click Add Photo.

2. Optionally describe the one or more photos that you want to add then
click Next.

3. Depending on your browser, you can upload photos one at a time or
more than one file at a time. For information about your browser's
method, see Adding Assets on page 24.

You can also create folders to categorize your photographs.

To add folders to My Photos, follow these steps:

1. Right-click on the My Photos folder and choose Add Folder.
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2. Enter the name of a subfolder in the Add Folder dialog box and click
Add.

The following figure shows the My Photos folder with several photos
loaded.
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Modifying the My Account Pages
The My Account page lets a registered user participate in eCommerce by
specifying shipping and billing information. The My Cart page allows secure
order processing. The Order History page offers secure viewing of purchase
orders. you can do the following My Account pages.

Editing the My Account Introduction In Context below

Editing the My Account Page in the Workarea on the facing page

Creating an SSL Certificate

Viewing My Cart on page 122

Viewing the Order History on page 124

Modifying Shipping and Billing Information on page 124

Checking Out Your Purchase on page 125

To create your own My Account page, you must modify or create templates and
user controls, which is not described in this Ektron OnTrek Reference.
Developers of .NET templates and user controls can find product templates and
user controls at the following locations.

Template files (.aspx), PageBuilder template files (.pb.aspx), and
c# code behind files (.cs) in the [siteroot] folder of the installation.

Master pages—[siteroot] > OnTrek > Components >
Templates.

User controls—[siteroot] > OnTrek > Components > user-
Controls.

For additional information, see the Ektron Developers Guide: Building an Ektron
Powered Website and the Ektron CMS400.NET Reference.

Editing the My Account Introduction In
Context
Ektron OnTrek preloads the introduction to the My Account page with Lorem
ipsum text to give you an example of what a My Accounts page introduction can
look like.

You can edit this content from the page by following these steps after logging
in:

1. Open the access point ( ) above the content.

2. Choose Edit in Context. An editor window appears.
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3. Edit the text, and click Save ( ). The text is changed on the page.

Editing the My Account Page in the
Workarea
You can access the My Account page introductory content in the Workarea,
where you can create additional information about the content (such as
Metadata). To do this, follow these steps:

1. Login to the Workarea and choose the Content tab.

2. Choose Folders > MainSite > Content > My Account. The View
Content panel displays the content.

3. Click onMy Account in the View Content panel. The content editor
appears.
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4. When you are finished editing, click Publish ( ). The text changes on
the page.

Creating an SSL Certificate
You must have a Secure Socket Layer (SSL) Certificate to engage in
eCommerce. In Ektron OnTrek, you can use SSL when users log in to your Web
site. SSL encrypts the username and password during transmissions to the
server.

When you set up the SSL certificate, and configure Ektron OnTrek to use it, the
login page launches in a Secure Socket Layer. The following topics explain how
to set up SSL for Ektron OnTrek.
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Setting Up the Secure Socket Layer (SSL)
Certificate
Many articles on the Internet describe how to install a SSL Certificate. Use the
proper procedure for the specific version of IIS you are using on your server.

IIS Version Sample Articles

IIS 6.0
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/56bdf977-

14f8-4867-9c51-34c346d48b04.mspx

IIS 7.0 http://learn.iis.net/page.aspx/144/how-to-set-up-ssl-on-iis-7/

Use a self-signed certificate for developer and testing servers.

Updating the web.config File
After you set up the Secure Socket Layer (SSL) certificate, configure Ektron
OnTrek to use the SSL certificate as shown in the following steps.

1. Open the web.config file.

2. Locate the section of the file with these settings.

<add key="ek_UseSSL" value="false" />

<add key="ek_SSL_Port" value="443" />

3. Set the ek_UseSSL value to false. (This setting differs from other
Ektron sites that use eCommerce pages.)

4. Save and close the file.

Updating the application.security.config File
The application.security.configfile determines which pages in the site
require an HTTPS connection. To change this file, follow these steps.

1. Open the applicaton.security.config file located in the [siteroot]
with your editor.

2. Locate the code that looks like the following
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<ektron:template path="/checkout.aspx"> 

<ektron:template path="/account.orderHistory.aspx">

3. Add or change names of templates that you want to use HTTPS.

Viewing My Cart
Ektron OnTrek enables eCommerce, providing the building blocks you need to
sell product on the Internet. You can do the following from the My Cart page:

Create one or more named carts to organize your purchases. See Cre-
ating a Named Cart on the facing page.

Empty the active cart to start over.

Modify the quantity of the items you selected and click Update Sub-
total.

Enter a coupon code. See Entering a Coupon Redemption Code on
page 124.

Continue shopping.

Go to a secure checkout page.

Important: You must have Secure Socket Layer (SSL) certificate to complete an
eCommerce transaction. See Setting Up the Secure Socket Layer (SSL) Certificate
on previous page.

The following figure shows a My Cart page with 2 named carts (Training and
High Tech). The active cart is High Tech which shows 3 items in the cart.
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Creating a Named Cart

The default My Cart is all you need to shop. However, you can
personalize or organize your cart by naming it. To do this, follow these steps.

1. Click on the Rename Cart icon ( ).

2. Enter the name of the cart in the Cart field.

3. Click OK ( ). The new cart becomes active and appears in the My
Saved Carts section.
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Entering a Coupon Redemption Code
You can get additional discounts with a valid coupon code. To do this, follow
these steps.

1. Enter a valid coupon code. 

2. Click OK ( ). If the code is valid, the discount will be deducted from
the subtotal and appear on the order form.

Viewing the Order History

Ektron OnTrek securely displays order history. You secure the Order
History page in the Application.Security.config file in the site's [siteroot]
folder. See Updating the application.security.config File on page 121.

To change the Order History page, you must modify the
account.orderHistory files that are located in the [siteroot] folder of the
Ektron OnTrek installation.

Warning! You are strongly recommended to have a Secure Socket Layer (SSL) certificate to
complete an eCommerce transaction. Without SSL, your transaction will not be secure. See
Setting Up the Secure Socket Layer (SSL) Certificate on page 121.

Modifying Shipping and Billing Information
Ektron OnTrek displays information about a registered user on the Shipping and
Billing Information screen. To modify personal, billing, or shipping information,
click Edit.
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Checking Out Your Purchase
Ektron OnTrek comes with a checkout process. To change the checkout process,
you must modify the templates that are located in the [siteroot] folder of the
Ektron OnTrek installation. Developers of .NET templates and user controls can
refer to Ektron Developers Guide: Building an Ektron Powered Website and the
Ektron CMS400.NET Reference for information about modifying templates.

Warning! You are strongly recommended to have a Secure Socket Layer (SSL) certificate to
complete an eCommerce transaction. Without SSL, your transaction will not be secure. See
Setting Up the Secure Socket Layer (SSL) Certificate on page 121.

The following figures show an example checkout process.
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1. Enter the Billing information and then click Save Changes.

2. The Shipping Address screen appears. Verify the shipping information.
If the shipping address is the same as the billing address, click Next
Page. Otherwise, click Edit Info to change the information.
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3. Choose the shipping rate, then click Next Page.

4. Review your order. You can edit your cart from this screen. If it is cor-
rect, click Next Page.
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5. Enter your payment information. When complete, click Submit
Order.
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Modifying Site Styles
Developers that are familiar with cascading style sheets (CSS) can change
Ektron OnTrek styles. This section helps how to use individual CSS files and how
to use sprites.

Style Sheets Used in This Web Site
The following key style sheets produce the major user interface features that
you can modify for your site.

Stylesheet Description

jquery-ui-

1.7.3.custom.css

Defines styles that are built on top of the jQuery JavaScript
Library. 

Path: [siteroot]/css/jquery-ui-custom-theme/.

BlueprintCSS ie.css,

print.css, screen.css

Defines key styles for columnsand typography for overall page
integrity. Path: [siteroot]/css/blueprint/

ektron-jQuery-

Blueprint-overrides.css

Definesoverrides to classesdefined in the jQueryUI styles.
Defining them in this file instead of the jQueryUI file allows for
easier maintenance. Classesnamesdefined in this file are

preceded with .ui-xxx. Path:[siteroot]/css/.

ektron.ui.framework.css

Defines styles specific to basicEktron site pages including
definitions for header, footer, body, channel and others. Classes
namesdefined in this file are preceded with .ektron-ui-xxx.

Path: [siteroot]/css.

ektron.site.css

Defines themajority of the style changesneeded for a specific
site's appearance and style. Definitions for common elements
like H1-H6, body, and form styles are defined here. Also, classes
from the previous style sheets are further defined and extended.

Note: If you need tomake specific style changes, make them in
this css file.

Using the Messages Page to Test Your
Styles
Ektron OnTrek includes a special page for examining style changes you make in
various css files. Display this page in a browser by entering
http://[siteroot]/unittests/messages/ektron.messages.aspx.

This page displays each of the styles as you check a style name.
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Note: Apply changes to styles by modifying or adding specific style classes to the
ektron.site.css file where practicle.

To see how styles are applied, follow these steps.

1. Uncheck all options

2. Check the styles you want. The text changes according to the style
sheet cascading rules.

Understanding jQueryUI
jQueryUI provides basic style definitions that enhance a web site visitor's
experience and also provides a reliable development basis from which you can
quickly construct pages.

You can download jQueryUI definitions from the Web site
http://www.jQuery.com and apply them to Ektron OnTrek.

Classes defined within jQueryUI CSS files define the appearance of various
states and containers. In most cases, the classes contained in the jQueryUI css
file begin with .ui-.

Important: You must use version 1.7.3 jQuery UI in this version of Ektron OnTrek.

To change the style class definitions, follow these steps.

1. Browse to http://www.jqueryui.com.

2. Select Themes from the menu.

3. Click the Gallery tab.
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4. Decide which theme you want to use and click Download.

5. Unzip the files.

6. Copy the images folder and the file - jquery-ui-1.7.3.custom.css to
the folder [siteroot]/css/jquery-ui-custom-theme.

Understanding BlueprintCSS
Ektron's best practice for styling web sites include adopting a standard called
BlueprintCSS. (http://www.blueprintcss.org) This standard defines an easy-
to-use column and typography layout that provides ease-of-maintenance and 
reliable high-quality layouts. BlueprintCSS also provides cross-browser
definitions to minimze your time to resolve these issues.

BlueprintCSS class names provide consistency between designers and
developers when applying specific styles to the elements of a page.
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Installing BlueprintCSS Files
To download BlueprintCSS.css, follow these steps.

1. Browse to http://www.blueprintcss.org.

2. Follow the directions to Download Now.

3. Unzip the files and place it in the folder [siteroot]/css/blueprint.

4. Link ie.css, print.css, and screen.css into your templates.

Using BlueprintCSS for Vertical Alignment
To understand how to use BlueprintCSS in Ektron OnTrek, look at the code for
default.aspx in Visual Studio. Look for definitions like this.

<div class="span-24"> or <div class="span-8 last">

With BlueprintCSS, the page is divided into 24 evenly spaced columns spanning
30px plus a 10px gutter between them. When you define an element with a
class="span-24", you set it to the full page width (950px). To define 3 equal
columns across a page, all of the class spans must equal 24. Use the last class
to indicate the last column. The HTML code looks like this.

<div class="span-24">

(code inside full width column)

</div>

<div class="span-16">

(code inside a large column)

</div>

<div class="span8 last">

(code inside small column, the last column on the right)

</div>

The following figure shows the 24-column definition used by BlueprintCSS.
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To understand more about using BlueprintCSS, refer to the tutorials and forums
that support it at http://www.blueprintcss.org.

Understanding Ektron UI Framework
Ektron.ui.framework.css (located in [siteroot]/css) defines specific class
names for use within Ektron projects. This style definition file generally bridges
the gaps BlueprintCSS and jQueryUI CSS with Ektron standard definitions and
styles.

The namespaces standardize the class names that you use across multiple
projects, thus unifying wireframe construction methods. Individual rules vary
from one project to another, but the class names are standardized.

Class rules defined in the Ektron UI Framework include the following
components.

Page framework—header, body, footer

Typography helpers - uppercase, lowercase, smallcaps

Color helpers - background colors for even and odd rows

Sprites

Tables and Grids

Forms

Paging

Wizards

Calendars
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Breadcrumbs

Sprites

The site designer applies designs to the site using these definitions in parallel to
the work the developer does in coding the pages using these style classes.

The ektron.ui.framework.css file prefaces classes with .ektron-ui.

Understanding Ektron Site CSS
The ektron.site.css style sheet contains the definition of classes at the most
detailed or specific level. When you modify styles in this CSS, you have the
largest impact on the appearance of elements on the Web page.

You can override class definitions by applying specific style rules. The following
code shows a style for a special message that looks different from a normal
paragraph.

div.ektron-ui-message > p {margin: .75em 0 .75em 20px; }

With this stylesheet, a developer and designer can work rapidly because
classes and terms are (in most cases) self-defining.

Using Sprites for Icons
A sprite is an image file made up of icons used in a Web site. A stylesheet
defines the size and location of individual icons within this file.

Using sprites improves Web site performance by reducing the number of
images that are transmitted to a browser from a server. When you combine all
of the icons used in a site into one larger image and add the definitions of the
sprites into CSS styles, the images are loaded into memory once and rapidly
rendered by the browser.

Locating the Sprite Files
The sprite files are located in folder [siteroot]/css/sprites/silk. You can
change or replace this file as long as the dimensions are not changed and the
filenames remain the same.

Viewing the Icons in a Sprite
The Ektron OnTrek Web site includes a special page to help you examine
sprites. Display this page in a browser by entering
http://[siteroot]/unittests/sprites/ektron.sprite.silk.aspx.

Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)

135



The tab called Ektron Sprites: Silk OnTrek shows a copy of the sprite file
containing 36 commonly used icons found in the file
ektron.sprite.silk.OnTrek.png. The tab called Ektron Sprites: Silk shows
a copy of the sprite that contains all icons found in the
ektron.sprite.silk.png file.

Note: If you modify the sprite file, copy it into the unittests/sprites folder to see your
changes in this page.

Using the Sprite Generator
Create your own sprite by using the Sprite Generator located at
http://spritegen.website-performance.org/. Follow the instructions to
upload your icons in a zip file, modify the tools configuration and generate the
sprite. Be sure to use the same naming convention used in the sprite file that
you are replacing.
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Using Widgets in Ektron
OnTrek
Widgets are mini-applications that can provide either specific functionality
(such as calendar events) or areas into which you can add Ektron CMS400.NET
content (content blocks, list summaries, collections, and so on). You can drag
and drop widgets onto a page using PageBuilder. You can find help about
widgets anywhere you see and click the help icon ( ). To open the widget bar
from the PageBuilder menu, click on the up/down controls ( ).

The following table shows the widgets that are specifically designed for Ektron
OnTrek (in addition to the other widgets in the site. You can find more widgets
at Ektron Exchange (http://dev.ektron.com/exchange/) where Ektron users
create and share CMS400.NET code.

Name Description

CollectionWidget on page 140 Displaysa collection that is a list of content that you choose from the
content available in the CMS400.NET.

Content Analytics ListWidget on
page 142

Displays content based on how people rated the content, what were
themost recently published content items, or howmanypeople
viewed the content .

Content BlockWidget on page 144 Displaysany content on your web page that you want from your
CMS400.NET.

Featured EventWidget on page
146

Displaysa single event with a link tomore information about the
event.

List SummaryWidget on page 148  Showsa list of content from a folder (and optionally its subfolders) on
your Web page.

Product AnalyticsWidget on page
152

Displaysa list of content from a folder (and optionally its subfolders)
on your Web page.

TabPlusWidget on page 155
Displays itemsbased on how customers rated the items, howmany
customers viewed the items, or what were themost recently viewed
items.

Upcoming EventsWidget on page
158 Displaysa list of scheduled calendar events.
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If you cannot find the widget you are looking for, perhaps it is not enabled for
the wireframe. To select the widgets that you want in a wireframe, see
Choosing Widgets for a Wireframe below.

Note: Each landing page has a specialized OnTrek-specific widget. You may move these
widgets between drop-zones or remove them from their host PageBuilder pages like any other
widget. However, because these widgets were created specifically for OnTrek to fulfill OnTrek-
specific design specifications, they do not have the standard Widget edit interface. To edit these
widgets you must use a code editor like Visual Studio. The following are the specialized widgets:
Site-ClientList, Site-CommunityLanding, Site-FeaturedProducts, Site-ProductSearchForm, Site-
ServicesHome, Site-Slider, and Site-SupportLanding.

Choosing Widgets for a Wireframe
To select the widgets you want in a wireframe, follow these steps.

1. While logged into the Workarea in the Setting section, choose Set-
tings > Configuration > Template Configuration. The Active Sys-
tem Templates screen appears.

2. Click on default.aspx (Wireframe Template). A window of widg-
ets appears.

Note: You can select a different set of widgets for each wireframe. For example, click
on clients.pb.aspx (Wireframe Template) and continue with these steps.
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3. Click on the widgets you want (or click Select All or Deselect All).
Highlighted widgets appear in the widget selection bar of pages that
use the wireframe template; non-highlighted widgets do not appear
there.

4. Click Save ( ). The widgets appear in the widget bar of pages that
use the wireframe you selected.
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Collection Widget

Shows a collection that is a list of content that you choose from the
content available in the Collection section of the Workarea. The following figure
shows a collection of Featured Products.

Properties

To change the properties, click Edit ( ).

Property Description

Collection ID

The drop down list is populated in theWorkarea in the Col-
lectionsarea of the Content tab. If you add a new collection
in the CollectionsWorkarea, it displays in the Collection ID
list.

Description Displays the description of the Collection ID, if one was
written (otherwise blank).

Page Size Enter the number of itemsyou want displays in the widget
window.

Teaser Check to display text from the Summaryof each item in the
list, if one waswritten.

Enable Paging
Check to seemore content titleswith forward and backbut-
tonswhenmore itemsare in a collection than were specified
in the Page Size property.
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Property Description

IncludeIcons Check to display an icon if an item hasan icon associated
with it.

AddText

Enter themenu item text to addmore content. For example,
if you enter "AddQuickReference" it displaysas follows in
the editor menu.

Random Choose True to list the collection items in random order;
False to list them in the order appearing in theWorkarea.

Get HTML Choose True to display the associated HTML content of
each collection item; False to not display the HTML.

XSLT Enter the path to an EXtensible Stylesheet Language Trans-
formation (XSLT) that you want to use on the collection.

CSS Enter the path to a cascading style sheet (CSS) that you
want to use on the collection.

SelTaxonomyID Enter the ID of the taxonomy that is assigned to the new con-
tent when Add Items is chosen.

Display Selected Content
Check to show content in thiswidget location when the site
visitor selects the content link from the collection. This over-
rides the quick link normally associated to the content.

Display Header Check to show header text above the widget.

Header Text
Enter text for the Header. Check the Enable Header prop-
erty box to show this text. If no text is entered into the
Header property, the collection name shows.
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Content Analytics List Widget

Displays information about a set of content or products. The following figure
shows the Highest Rated products in the default Software taxonomy.

Properties

To change the properties, click Edit ( ).

Property Description

Folder ID Enter the ID of the folder that contains the items to appear in
the list. You can also select the folder from the folder tab.

Header Enter text for the header.

Display Mode

Select one of the following to determine how the content
information displays.

Accordion—Displays vertical tabs for
viewing Highest Rated, Most Recent, and
Most Viewed items.

Tabs—Displayshorizontal tabs for
viewing Highest Rated, Most Recent, and
Most Viewed items.

Enable Paging
Check to show links to page forward or backward through
the content list. The amount of content shown in each page
is set by the ItemsPer Page property.
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Property Description

Items Per Page
Enter the number of content itemsyou want to display on a
page. If blank, page forward/backward buttonsdo not
show.

Taxonomy ID Enter the ID of the taxonomy that is assigned to the new con-
tent when Add Items is chosen.

Display Read More Check to display the ReadMore link.

Read More Link Text Enter text for theReadMore Hyperlink set in the next prop-
erty. For example: "ReadMore..."

Read More Hyperlink Enter the hyperlink used for theReadMore Text set in the
previousproperty. For example: "Content.aspx?id=168".
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Content Block Widget

Shows any content on your web page that you want from your
CMS400.NET including html, text, documents and digital media. You can set the
content block widget to show a specified content id. The following example
shows the content called OnTrek Announced New Book: Building an OnTrek-
Powered Solution located under the Content tab at Folders > MainSite
> Company > Company News folder. A header was added from the
Properties tab.

Properties

To change the properties, click Edit ( ).

Control Description

Filter By:
ChooseContent, Form, orMultimedia and then click
View Results on the bottom left of the dialog box to see the
content items in the selected type.

View Result
Click to display contents of the selected folder. Hover over a
content item so see a summaryof the content. You can filter
the content asdescribed in the previous table entry.
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Control Description

Cancel button Click to dismiss the dialog boxwithout adding content.

Save button Click to save the changes youmade and dismiss the dialog
box.

New button Click to create new content (rather than selecting existing
content).

Tab Description

Folder tab

Use the Folder tab to navigate to content that you want to
display in the content block. For example, the sample con-
tent in the figure above is located at [siteroot] > MainSite
> Content > Company > Company News, and called
OnTrek Announces New Book:Building an OnTrek-
Powered Solution in the View Results pane.

Taxonomy tab

Use the Taxonomy tab to navigate to content that you want
to display in the content block. For example, selectOnTrek
Site Navigation > Clients > Case Studies and select
one of the result to display in the widget.

Search tab
Use the Search tab to find content to display. For example,
type acme in the search boxand select one of the result to
display in the widget.

Properties tab

Use the Properties tab to create a header text for the
content.

Display Header—Check to display the
header text on the web page.

Header Text—Enter text that you want to
display as the content header.
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Featured Event Widget

Displays a single event with a link to more information about the
event. The following figure shows an example event that was created at
[siteroot] > MainSite > Content > Company > Event Calendar, and
calledWebinar: Maximizing Your Company Brand. A header was added
from the Properties tab of the Featured Widget dialog box.

Properties

To change the properties, click Edit ( ).

Control Description

Filter By:
ChooseContent, Form, orMultimedia and then click
View Results on the bottom left of the dialog box to see the
content items in the selected type.

View Result
Click to display contents of the selected folder. Hover over a
content item so see a summaryof the content. You can filter
the content asdescribed in the previous table entry.

Cancel button Click to dismiss the dialog boxwithout adding content.

146
Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)



Control Description

Save button Click to save the changes youmade and dismiss the dialog
box.

New button Click to create new content (rather than selecting existing
content).

Tab Description

Folder tab

Use the Folder tab to navigate to content that you want to
display in the content block. For example, the sample con-
tent in the figure above wascreated at [siteroot] > Main-
Site > Content > Company > Event Calendar, and
calledWebinar: Maximizing Your Company Brand in
the View Results pane..

Taxonomy tab

Use the Taxonomy tab to navigate to content that you want
to display in the content block. For example, selectOnTrek
Site Navigation > Clients > Case Studies and select
one of the result to display in the widget.

Search tab
Use the Search tab to find content to display. For example,
type acme in the search boxand select one of the result to
display in the widget.

Properties tab

Use the Properties tab to create a header text for the
content.

Display Header—Check to display the
header text on the web page.

Header Text—Enter text that you want to
display as the content header.
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List Summary Widget

Shows a list of content from a folder (and optionally its
subfolders) on your Web page. The following example shows the list summary
in the Content tab at Folders > Mainsite > Content > Store > Hardware
folder.

Properties

To change the properties, click Edit ( ).

Property Description

Folder ID
Enter the ID of the folder that contains the items to appear in the
list. Set theRecursive property to include subfolders under this
folder.

MaxResults Enter the number of content itemsyou want to display on a page. If
blank, page forward/backward buttonsdo not show.

Teaser Check to display text from the Summaryof each item in the list, if
one waswritten.

Recursive Check to include content in subfolders under the folder indicated by
the FolderID property.
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Property Description

EnablePaging
Check to show links to page forward or backward through the con-
tent list. The amount of content shown in each page is set by the
Max Results property.

Include Icons Check to show icons that represent each content item's type in the
ListSummary.

OrderByDirection ChooseAscending (A-Z; first-last) or Descending (Z-A; last-
first).

OrderKey

Choose one of the following options.

Title—Sorts by the title of the content.

DateModified—Sorts by the date the content
was last edited.

DateCreated—Sorts by the date the content
was first published.

Last Editor's First Name—Sorts by the first
name of the person who last published the
content.

Last Editor's Last Name—Sorts by the last
name of the person who last published the
content.
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Property Description

Content Type

Choose the type of content to display in the ListSummary.

AllTypes—Displaysall typesof content.

Content—Displaysonly content.

Forms—Displaysonly forms.

Archive_Content—Displaysonly archived
content.

Archive_Forms—Displaysonly archived forms.

Assets—Displaysonly assets.

Archive_Assets—Displaysonly archived
assets.

LibraryItem—Displaysonly library items.

Multimedia—Displaysonlymultimedia file types.

Archive_Media—Displaysonly archivedmedia.

NonLibraryContent—Displaysonly non-library
content.

Discussion Topic—Displaysonly discussion
topics.

CatalogEntry—Displaysonly catalog entries.

Add Text

Enter the text used in the editor'smenu to addmore content. For
example: if you enter "AddQuickReference" it appears in the Edit
menu.

SelTaxonomyID Enter the ID of the taxonomy that is assigned to the new content
when Add Items is chosen.

DisplaySelectedContent
Check to show content in thiswidget location when the site visitor
selects the content link from the list. This overrides the quick link nor-
mally associated to the content.

XSLT Enter the path to an EXtensible Stylesheet Language Trans-
formation (XSLT) that you want to use.
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Property Description

CSS Enter the path to a cascading style sheet (CSS) that you want to
use on the collection.

Display Header Check to show header text above the widget.

Header Text Enter text for the Header. Check the Enable Header property box
to show this text.

Display Read More Check to display the ReadMore link.

Read More Link Text Enter text for theReadMore Hyperlink set in the next property. For
example: "ReadMore..."

Read More Hyperlink Enter the hyperlink used for theReadMore Text set in the previous
property. For example: "Content.aspx?id=168".

Enable RSS Syndication Check to subscribe to RSSnotification.
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Product Analytics Widget

Displays information about a set of content or products. The
following figure shows the Highest Rated and most Viewed products in the
Hardware taxonomy.

Properties

To change the properties, click Edit ( ).
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Property Value

Folder ID Enter the ID of the folder that contains the items to appear
in the list. You can also select the folder from the Folder tab.

Max Results
Enter the number of content itemsyou want to display on a
page. If blank, page forward/backward buttonsdo not
show.

Recursive Check to include content in subfolders under the folder indi-
cated by the FolderID property.

Enable Paging
Check to show links to page forward or backward through
the content list. The amount of content shown in each page
is set by theMax Results property.

Include Icons Check to show icons that represent each content item's
type.

Add Text

Enter the text used in the editor'smenu to addmore
content. For example: if you enter "AddQuickReference" it
appears in the Edit menu.

SelTaxonomyID Enter the ID of the taxonomy that is assigned to the new con-
tent when Add Items is chosen.

Display Selected Content
Check to show content in thiswidget location when the site
visitor selects the content link from the collection. This over-
rides the quick link normally associated to the content.
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Property Value

XSLT

Select one of the following to determine how the content
information displays.

BulletedList—Displays the content titles
asa bulleted list.

CalendarEvents—Displaysa list of
scheduled events.

ecmNavigation—Displays the titles of
the content.

ecmTeaser—Displays the titles and
summaryof the content.

ecmHtml—Displayseach content in the
list summary.

CSS Enter the path to a cascading style sheet (CSS) that you
want to use on the list of products.

Header Text Enter text for the header.

Display Accordion Check to display vertical tabs for viewing Highest Rated,
Most Recent, andMost Viewed items.
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TabPlus Widget

Lets you display more than one type of content in a tabbed widget.
You can display a tab for a Content Block, a List Summary, a Collection, or
Upcoming Events. the following figure shows the default appearance of the
TabPlus widget with News (a List Summary) and Events (Upcoming Events).

To add a tab, follow these steps:

1. Choose File > Edit from the PageBuilder menu.

2. If you do not have the TabPlus widget on the page, open the widget
menu ( ) and drag and drop the widget onto the page.

3. Click Edit ( ). The Tab Plus dialog box appears.

4. Click AddNewTab.

5. Choose one of the Tab Type options: Content Block, List
Summary, Collection, or Upcoming Event. Fields appear that are
the properties of each option's widget type.

Properties

To change the properties, click Edit ( ).
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The properties table describes the properties you can fill out when you choose a
tab option. Each tab option has its own set of properties.

Property Description

Add New Tab Click to add a new tab to the widget. A Tab Type drop down
list appears.

Tab Type Choose the type of content you want in the new tab: content
block, list summary, collection, or upcoming event.

ID

Enter the ID of the folder—or navigate to a folder using the
folder tree—that contains the items to appear in the list. Set
theRecursive property to include subfolders under this
folder.

Tab Title Enter text for the tab header.

Add Text

 Enter themenu item text to addmore content. For
example, if you enter "AddQuickReference" it displaysas
follows in the editor menu.

Items Per Page Enter the number of itemsyou want displays in the widget
window.

Enable Paging
Check to seemore content titleswith forward and backbut-
tonswhenmore itemsare in a collection than were specified
in the Page Size property.

Display Read More Check to display the ReadMore link.

Read More Link Text Enter text for theReadMore Hyperlink set in the next prop-
erty. For example: "ReadMore..."

Read More Link URL Enter the hyperlink used for theReadMore Text set in the
previousproperty. For example: "Content.aspx?id=168".

Enable RSS Syndication Click to allow RSS notifications.
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Property Description

Additional properties for the List Summary option

Display XSLT 

Select one of the following to determine how the content
information displays.

ecmNavigation—Displays the titles of the
content.

ecmTeaser—Displays the titles and
summaryof the content.

ecmHtml—Displayseach content in the
list summary.

BulletedList—Displays the content titles
asa bulleted list.

Random Choose True to list the collection items in random order;
False to list them in the order appearing in theWorkarea.

Recursive Check to include content in subfolders under the folder indi-
cated by the FolderID property.

Sort Order ChooseAscending (A-Z; first-last) or Descending (Z-A;
last-first).

Order By

Choose one of the following options.

Title—Sorts by the title of the content.

DateModified—Sorts by the date the
content was last edited.

DateCreated—Sorts by the date the
content was first published.

Last Editor's First Name—Sorts by the
first name of the person who last published
the content.

Last Editor's Last Name—Sorts by the
last name of the person who last published
the content.
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Upcoming Events Widget

Shows a list of scheduled calendar events, similar to the following
figure.

Properties

To change the properties, click Edit ( ).

Property Values

Folder ID

Enter the folder ID that contains the events you want to show in the list.
You can use the Folder Tab to browse the content folders to set the
Folder ID property. To select a folder or content, do the following:

1. Click the Folder tab.
2. Navigate to the folder you want and click it.
3. If the View Results panel is showing, click the content you

want.
4. ClickSave.

Enable Header Check to show the header above the widget.

Header

Enter text to show a colored bar with text above the Search box. If you
leave this blank, no text or colored bar showsabove the search box.
Text for the header is placed inside an <h3> tag and adopts the same
styles as the column in which it's placed. (Optional)

Enable Paging
Check to show links to page forward or backward through the content
list. The amount of content shown in each page is set by the ItemsPer
Page property.
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Property Values

Items Per Page Enter the number of content itemsyou want to display on a page. If
blank, page forward/backward buttonsdo not show.

Read More Link
text

Enter the string for the ReadMore Hyperlink set in the next property.
For example: "ReadMore..."

Read More Hyper-
link

Enter the hyperlink used for theReadMore LinkText property. For
example: "Events.aspx"

Enable RSS
Syndication Click to allow RSS notifications.
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Getting Support
The following resources are available to help you with your Ektron OnTrek
project.

Locations and Phone Numbers

Location Phone

Worldwide Headquarters
542 Amherst Street (Route 101A)
Nashua, NH 03063 USA

1-866-4-EKTRON

603 -594-0249

SUPPORT 1-603-594-0249 x7002

Canada
675 Cochrane Drive East Tower, 6th Floor
Markham, Ontario L3R 0B8

905-530-2211

United Kingdom
Sienna Court,
The Broadway,
Maidenhead
SL6 1NJ
UK

+44 (0) 1628 509 040

Australia
Level 3
61 YorkStreet
SydneyNSW2000
Australia

+61 2 9248 7222

Singapore
81 Anson Rd.
Suite 8.35, Level 8
Singapore 079908

+61 2 9248 7206

For additional contact information, see http://www.ektron.com/contact/.

ektron.com
The web home of Ektron has useful information, including additional contact
information and services. You can find product documentation in the
documentation section (http://www.ektron.com/documentation/).
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Synergy
Ektron's investment in you never stops. We are always listening to our
customers, and the annual Synergy Customer Conference is a great way for us
to learn what is important to you. The conference also is a great way for you to
learn more about using your Ektron CMS400.NET.

For more information, see our web page: http://synergy.ektron.com.

Local User Groups
Every Spring, Ektron management meets with Ektron users in as many cities as
possible to bring the latest news and products from Ektron. We listen to what is
important to you. The Local User Group Sessions (LUGS) receive positive
ratings year after year.

The Dev Center (dev.ektron.com)
The Ektron Dev Center includes resources to assist our customers. If you are
looking for a solution to a specific problem or just seeing what you might be
able to do with CMS400.NET, you can find it here. You also can find Webinars
that offer help and insight to many of the features of Ektron CMS400.NET.

The Dev Center also has a product forum where you can pose questions,
provide answers to other users, and share tips on how to use Ektron OnTrek
more effectively.

See the Dev Center at http://dev.ektron.com.

Professional Services
Ektron has a complete services infrastructure, in addition to providing you with
a powerful CMS platform, to ensure your project’s success. Each service
engagement is unique and customized to meet your specific needs. Ektron
assures predictable results using comprehensive Web Project Methodology and
RAMP strategy (Risk mitigation, Adoptability, Maintainability, Performance) to
guide every project.

Click here to see more about Ektron Professional Services.

162
Ektron OnTrek Reference
Doc. Rev. 1.0 (Oct. 2010)

http://synergy.ektron.com/
http://dev.ektron.com/
http://www.ektron.com/services/
http://www.ektron.com/services/
http://www.ektron.com/services/


Best Practice Services
Ektron’s Best Practice Services (BPS) gives you access to Ektron solution
engineers who are intimately familiar with your web project goals and have the
expertise to make them a reality using Ektron CMS400.NET.

Implementation
By engaging Ektron to implement all or part of your web site project, expert
application engineers follow our proven Ektron Methodology to ensure the
success of the project.

Hosting
Ektron offers a complete line of web site hosting packages to fit the needs of
each deployment, from enterprise-level to small and medium-sized businesses.
Ektron Hosting’s secure facility ensures that your business-critical applications
are online and secure, giving you peace of mind.

For more information about Ektron Hosting, see
http://www.ektron.com/hosting.

Training
Ektron’s training courses ensure your web project’s success by providing the
right level of training to your team at the right stage of your web project’s
lifecycle.

Call your Ektron Customer Support Representative to schedule your class.

For more information about Ektron Training, see
http://www.ektron.com/services/training/.
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