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Ektron CMS User Guide

“ktron CMS User Guide

This document describes essential operations for editing content through the
Workarea. For complete information about the Ektron product, see the Ektron
Reference.

Workarea Quick Reference

« 1—Workarea Tabs

[e]

[¢]

(o}

(o}

o

[e]

Desktop—Smart personalization desktop.
Content—Folders, contents, DMS, taxonomies, collections, and menus.

Library—Content folder structure that organizes images, files , hyperlinks and
quicklinks.

Settings—Manage CMS settings based upon permissions.
Reports—Content reports and site analytics.
Help—Access to this document.

. Content Tab Types

[¢]

[¢]

o

(o}

2—Folder Tab—View folder architect structure of CMS.
3—Taxonomy Tab—View Taxonomy Structure and options.
4—Collections Tab—View Collections and options.
5—Menu Tab—View Menus and options.

. Folder Types

(o}

o

[e]

6—Content Folder—View contents in the selected folder.

7—Blog Folder—View the posts and comments on this blog.

8—Forum Folder—View the discussion forums, categories, topics, and replies.
9—eCommerce Folder—View the eCommerce items.

10—Calendar Folder—View and plan events on the calendar.
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Content Quick Reference

o 11—Community Folder—Folders for membership uses to edit content, select to
view contents.

. Drop-down Menus
o 12—New menu—Create new content, forms documents, Folders menus and
collections.

o 13—View menu—View Language, Properties and archived content and more.
o 14—Delete menu—Delete multiple items. Administrators can delete folders.
o 15—Action menu—Export for translation, search, move/copy content, eSync.

o 16—DMS/ Add asset—Pop up the window for drag and drop documents from local
machine.

o 17—In Context Help—Context help.
o 18—Content Organization Bar—Sort content by the title.

. Content Types
o 19—Content Items—HTML Content, Forms, DMS, or Multimedia Content.

o 20—Quick Edit Menu—For content editing, properties and content eSync.
o 21—Llanguage Flag—Indicate the content language version.
o 22—Content ID—Automatically generated by system.

o 23—Content Status—Current status of a piece of content.
= (A) Approved, Published and on the website.

m (O) Checked Out Only, available for editing by the content editor who checked
it out.

m (I) Checked In, Available for editing.

m (S) Submitted, Currently in the approval chain. Waiting for acceptance.

m (M) Deletion, Marked for deletion.

m (T) Awaiting Tasks, Currently awaiting completion of tasks.

m (P) Pending, Awaiting scheduled start date.

m (D) Pending Deletion, Pending deletion but created with a future start date.
o 24—Date Modified—Last modified date of the content.
o 25—Last Editor—Person who made the last modification.

Content Quick Reference

Types of content are described in this section. A website has pages with 1 or more
blocks of content.

Content Types

« HTML content—Content to be published on the World Wide Web.

« XML Smart Forms—Online forms, polls, or surveys to collect information from site
visitors and save it in XML format.

« HTML form/survey—Online forms, polls, or surveys to collect information from site
visitors and save it in HTML format.

« DMS Documents—Office documents, managed files, and multimedia files.
« Office documents—Microsoft Office files.
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Content Properties

Managed files—Files created outside of Ektron, such as PDF files. You cannot create
or edit these files within Ektron—you can only store them.

Multimedia—Files that run in a media player, such as audio and movie files.

Blogs—A form of online information sharing for a group of people to share their
thoughts.

Web Calendars—Keeps visitors informed about upcoming events, displayed to all
visitors to your website, and any authorized user can add events to a calendar.

Discussion Boards—Allows topic discussions on your website. A site or membership
user with Add Topic permission creates a topic and posts a starter question. Site visitors
can then reply.

Content Imported from SharePoint®—After an Ektron administrator sets up DxH to
map SharePoint to Ektron, an end user only needs to place content in a SharePoint
folder to update their Ektron-powered website; the content is automatically transferred
to the Ektron Workarea. You also can manually import SharePoint content from the
Ektron Workarea.

Content Properties

Content Title—The title assigned to the content.

Content ID—The ID number assigned to the content to retrieve content from a
database.

Content Language—The language in which the content is written.

Status—The current status of the content.

Last User to Edit—The last user to edit the content.

Last Edit Date—When the content was last edited.

Start Date—When the content appears on the website.

End Date—When the content is removed from the website.

Action on End Date—What happens to the content when its end date and time occurs.
Date Created—The date on which the content was created.

Approval Method—Which approvers must sign off on content before it is published.
Approvals—Users in the approval chain for this content.

Smart Form Configuration—The Smart Form applied to the content (managed by the
administrator).

Template—The template currently assigned to the content (managed by the
administrator).

Path—The folder path to the content’s folder. A slash (\) represents the Content folder.
Ranking—If this feature is enabled for the content, the average numerical rating
appears (1-10).

Content Searchable—True appears if the content can be found when someone

searches your website. However, even if content is not searchable, the Workarea
Advanced search still finds it.

Content Statuses
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Other Content Information

A (Approved)—Through the approval chain and published on the website.

O (Checked Out)—Currently being edited; has not been checked in.

I (Checked In)—Checked in for other users to edit.

S (Submitted for Approval)—Saved and submitted into the approval chain.

M (Marked for Deletion)—Requested for deletion.

P (Pending Go Live Date)—Approved but the publish date has not occurred yet.

T (Awaiting Completion of Associated Tasks)—Tasks assigned to content are not
complete.

D (Pending Deletion)—Content was created with a future start date then checked in and
deleted. This status only remains until the start date is reached when the content is
deleted.

Other Content Information

Properties tab—View the content’s properties.
Content tab—Display and edit content.
Summary tab—Edit content’s summary.
Metadata tab—Edit content’s metadata.

Alias tab—View and edit the content item’s primary alias, or view all secondary
aliases.

Comment tab—View comments on changes made when editing content. This comment
also appears on the View Content and Content History screens. Use it to help distinguish
one version from another.

Tasks tab—Add or edit tasks for this content.
Web Alerts tab—Add or edit Web Alerts for this content.
Templates tab—The template currently assigned to the content.

Category tab—Any taxonomy categories currently assigned to the content. Only
appears if at least 1 taxonomy is applied to the folder in which the content resides.

Edit—Open content for editing.
i)—View older versions of content; restore older version.
E',—Toggle display between published and staged versions
#—Compare current and earlier versions of content.
+—Delete content.
#“—\liew and edit permissions for content.

—View and possibly edit the content's approval chain.
ea—Find all content with Quicklinks to this content.
¥ —Attach a task to content.
& —View Analytics for this content.
..ll]zl—DispIays the content item's rating and reviews, messages, and flags.

[E—View and edit content's Content Searchable check box and flagging definitions.

¢ —Go back to previous menu

& —Determines if content will be included when an .xIf file is created.
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Creating New Content

#A_—Copy content to XLIFF files that can be submitted to a translation agency.

. View (language)—If you can view content in more than one language, select a

language from the drop-down list.

« Add-select language—Lets you copy current content into a new item and translate it to

selected language.

Creating New Content

1.

In the Workarea, go to the folder in which you want to create a new content item.

2. Choose a type of content from the New menu. (For example, choose New

> HTML Content. The Edit Content screen appears.

View Contents of Folder "My Account™ =

m VIEW DELETE ACTION Q L2

Folder nguage D
Blog

Discussion Board = 289
Community Falder

Calendar

Catalog

HTML Content
HTML FormiSurvey

O3 Document

Collection
Menu

3. Specify a title and begin creating your new content item.

Title—Enter a title for the content. It cannot include these characters: \/ * > < |

Content Searchable—(Administrators) Check this box if this content should be
found when someone searches your website.

Publish or Submit—Publish the content to the website. This action updates the
content in the database and exits the editor.

Only the last approver in the approval chain sees the Publish button.
Other users see Submit. If no approval chain is assigned to the content’s
folder, every authorized user sees Publish.

l4—Check In—Save and check-in the content. This action updates the content in
the database and exits the editor. It does not submit the content into the approval
chain. Rather, it allows you and other users to continue changing it.

) —Undo Checkout—Close without saving changes. Return content to its state
prior to checkout.
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Editing in Ektron

. @—Save—Save content without leaving the editor. It is a good idea to save your
work frequently. But, if you later click Cancel and exit the editor, you lose
changes saved by clicking this button.

<

. —Cancel—Close editor without saving changes. Leave content in checked out
state.

« | Zi—Preview—Preview current content within its template in a new browser.

Editing in Ektron

In some Workarea locations, the editor toolbar "floats," and you can drag it to any
screen location. In other locations, the toolbar is fixed at the top of the editor. When
your hover the cursor over editable content, a yellow border appears. When you
click the content, the border turns blue, and a floating editor toolbar appears.

You can edit content only for which you have permission and in one of the following
statuses:

« checked out by you

« checkedin

« published

« submitted for your approval
You can edit HTML content, HTML forms, XML Smart Forms, add information about
content (summary, metadata, and so on), check in, submit, and publish content.

1. From the Workarea, click Content and navigate to the folder that contains content you
want to edit. If you do not know the folder location, you can find content using Action
> Search from the root folder.

Click the content you want to edit.
3. Click Edit. The editor appears.

Edit Content in Folder "Root”

€| puBuisH | ) g @

Title: |Praesent congue tincidunt diam [English (U.5.)]

¥| Content Searchable

Content Summary Metadata Aliases Schedule Comment Templates
B I = s = = | 6ece| asoce AaBb  AaBb AaBbCc AaBbCc AaBb AaBbCc
X ¥ Peragragh Span Heading 1 Heading 2 N =pacing imrt Indent Camnter

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse hendrerit tempus mauris, ac omare lorem lobortis
eu. Praesent congue tincidunt diam sit amet gravida. Praesent pulvinar feugiat dui, laoreet tincidunt est sodales a
Morbi at placerat erat. Suspendisse libero nisl, luctus ut fringilla id, fermentum quis sem SLlspenHisse vestibulum
metus eget nibh tempor sagittis. Maecenas lorem elit, feugiat id dictum eu, tincidunt nec mauris. Mulla id dignissim elit
Sed tristique felis quis nisi feugiat nec posuere risus imperdiet

Editor Notes

« Cut, copy, and paste are accessible through your browser. Right-click to choose them or
use keyboard shortcuts. The editor may modify pasted content, depending on tags that
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Applying Styles

an administrator sets in styleConfig.js. For example, headings, bullets, and bolded

fonts may be maintained during a paste operation but the actual font may not.

IMPORTANT: When you paste content from another application, the editor formats
that content into valid, minimal HTML and retains as much formatting and styling as

possible. However, results are browser-dependent.

Paste HTML content into the Source Viewer.

Your browser checks spelling. If your browser does not support it, find and install a

plug-in to do it.

Use the Inspector to perform advanced actions on content items (images, hyperlink,
paragraphs, and so on). If enabled, the Inspector appears at the bottom of the editor.

Click to open, set values, then click the minimize button.

Summary Metadata Aliases Schedule Comment Templates

& = i= R li
B I | =) EE AaBbCc | AaBoCe AaBb  AaBb 2 Remove styling

X x S S ED Span Headng 1 Headng 2

=

Ektron CMS400.NET Server Controls

Developer productivity is a critical issue among Web teams. Faced with the challenge of reduced IT budgets,
Internet and intranet sites and rich Web applications, developers need every advantage tilted in their favor to h

Inspector

Ektron CMS3400.MET delivers that advantage.
up to four times faster than working in J2EE. BHighlight Tags On Click

With CMS400.MNET's new “toolbox” of pre-buil Basic D

integrate Ektron CMS components into their {
Type:

As a result, developers can dynamically build a
management solutions, while also customizi URL:

© upL @ Existing Bookmark

In addition to visual controls, Web developers

pragrammatically manage data and create hig .
flexible Web presentation options. And, unlii €

with the production Web site, allowing the de

[l =1 c in new tabfwindow
Ektron CMS400 NET is pure ‘NET content m SESTEE RS SR

NET application. Thanks to CMS400.NET's & Css Class: v
application for Web developers to learn NET. aloha-ink-1ext

Applying Styles

To apply inline styles and classes to text, use the styling toolbar.
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Removing Styling from Text

Summary Metadata Aliases Schedule Comment Templates

B I & & = =

aBbCc

AaBoCce || AaBoCc | AaBh  AaBb

Hesdng1  Hesdng2

AaBbCc ) AaBb Aa_Bch

LA o

=

4

Ektron CMS400.NET Server Controls

Styling toolbar

Developer productivity is a critical issue among Web teams. Faced with the challenge of reduced IT budgets, smaller teams, and ¢

schedules to roll out new Internet and intranet sites and rich Web applications, developers need every advantage tilted in their favo
organizational Web strategies succeed.

You can select paragraphs or individual words, then use styling toolbar buttons to
style the selected text. Click the down arrow in the toolbar's lower right to view
additional buttons. Styling buttons are context-sensitive, so they vary according to
cursor location, which format toolbar button is selected, and whether any text is
selected. For example, within the editor, select the text critical issue and click

Span (). Next, open the styling toolbar, and click one or more buttons to apply
styling.

Removing Styling from Text

1. Select the text to which the styling is applied.
2. Click the down arrow in the toolbar's lower right.
3. Click Remove styling.

AzaBbCc AaBbCc AaBbCc AasBbEs

L)

A
aabbcc  AABBCC )

- L -

et Tzt ' Click to open \
the . styling toolbar |
je tilted in their favor to help their nrganizatil:fﬁal Web strateqgi ‘

Working with Links

This section shows you how to view, insert, or delete a link in content.

Viewing a Link

1. Click the cursor on the linked text or image.
2. Open the Inspector (&) on the Review tab to view the link's properties.
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Inserting a Link to Text
3. Use the dialog to modify the link's properties.
Inspector

WHighlight Tags On Clickgl

The <z>tag indicates you

are working with a link

O upL @ Existing Bockmark

hittp:ffwranw ekiron.com

Inserting a Link to Text

1. Highlight text that you want to become a hyperlink.

2. Click Link (==) on the Format tab. (If you click Link on an empty space, a link appears
in the content as New Link.)

1"

hitp: /Mo ektron.com| _ E2

3. Inthe link field, enter the desired URL and press Enter. The selected text becomes a
hyperlink.

4. To enter additional link properties, select linked text and open the Inspector (&) on
the Review tab.

Inspector

WHighlight Tags On Clickg

The <z> tag indicates you
are working with a link

@ upL @ Existing Bockmark
hittp:ffwranar elkdron.com

Inserting a Link to an Image

1. Click an image that you want to become a hyperlink.
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Editing a Link

NOTE: You know that you selected an image if you see an <IMG> tag in the
Inspector.

Inspector

piv | p [E
BHighlight Tags On Shick

2. Open the Inspector (=) on the Review tab.
3. Click Add hyperlink to Image.
4. Click the <A> tag.

Inspector

DV | P ING

.HighlightTElgE: On Click

Type:

| emai |
URL:
& upL @ ecsting Bockmark

S
Titke:
-

5. Enter hyperlink information.

Editing a Link

1. Click the linked item. The link destination appears in the toolbar.
2. Edit the link text as needed.

Removing a Link

1. Click the linked item. The link destination appears in the toolbar.

2. Click Break Link ("%':.5‘). The link is removed.

Adding a Bookmark

Use a bookmark to let a site visitor go from any word or phrase to another place in

the same content block. On your Web page, text appears in a different color to
indicate the bookmark.

Bookmarks are particularly helpful on a long page. For example, your Web page
contains minutes from several meetings, and the top of the page lists meeting
dates. You could assign a hyperlink to each date, and a bookmark to each set of

minutes. A site visitor can click any date to go to those minutes (using the
bookmark).
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Working with Tables

To use a bookmark, you create 2 things:

« asource—text a user clicks to jump to the bookmark
« a destination—the location to which the cursor jumps when the source is clicked

For example, place the text [ Top ] [ Bottom ] at the top and bottom of a content
block. The following procedure shows how to create bookmarks so that clicking [
Top ] at the bottom of the page jumps to the top of the page, and clicking on [
Bottom ] at the top of the page jumps to the bottom of the page.

1. Create the bookmark's (destination).

a. Atthe bottom of the page, insert then highlight the destination text, in this case [
Top 1.

b. On the editor toolbar, choose Insert > Bookmark (). A bookmark icon displays
next to the source text but does not show up on the Web page.

c. Click the bookmark icon then the Inspector (=) on the Review tab. A dialog
displays the bookmark options.

d. Specify the title, PageTop.

Repeat steps a through d for [ Bottom ] at the bottom of the content, and give it
the Title of PageBottom.

2. Create links to the bookmarks.
a. Highlight the source text. In this example, [ Top ] at the bottom of the content.
b. Choose Format > Insert Link (==). The text is selected.
c. Double click the selected text.
d. Open the Inspector (=) on the Review tab.
e

. Choose Existing Bookmark. A drop-down list appears from which you can select
a bookmark.

Choose PageTop from the drop down list.

Repeat steps a through d for [ Bottom ] at the top of the content, and choose
PageBottom from the drop-down list.

—h

Working with Tables

This section describes how to insert and edit tables.

You can use Tab to move from one cell to the next. If you are on the last cell, Tab
creates a new row. Use Shift/Tab to move backwards.

Inserting a Table

1. From the toolbar's Insert tab, click Table (__). A table dialog box appears.

2. Drag the cursor over rows and columns to indicate the table size. The following example
shows 5 columns and 5 rows.
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Applying Table Properties

3. Click the mouse. The table is inserted.
J.l'i.“

Applying Table Properties

Use the Inspector (=) on the Review tab to apply properties to a table, a table row
(TR), or a single cell (TD).

r Apply styling to| | Apply styling to)
entire table one row

Inzspector

DIy DI TABLE TBODY TR
Apply styling to

EdHighlight Tags On §lick
one cell

n
Caopital cutloy 2012

Summary

This i= my table
Size:
I -

Adding a Table Caption
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Modifying Rows and Columns

1. Hover the cursor over the top left corner and click the table handle.

compared to a record sales month in July 2009, “Deman
our ability to deliver upon mission-critical business initiativ
CEO of OnTrek. “With competitive technical analysis and

and elerated growth is expected to continue”

1 a 1b
2 3 2b
33 b

2. Inthe toolbar, the Table tab is selected.
3. Enter the caption in the text box and click the Table caption button (=).

Format Insert Table Review

This is a new table caption

e ol

Alternatively, you can enter a table caption in the Inspector.

Modifying Rows and Columns

Click the gray area beside a table row or above a table column. Your selection is
highlighted.

Format Insert Review Table Column

H B B E

You can use the following table functions on selected rows/columns:

o ll—Add column to the left

« HF—Add column to the right

. =_Add row below

. 'éI—Add row above

. [H—Delete column

« LH—Delete row

« LH—Format column as header (create a 508-compliant table without modifying the

source)
. [E—Format row as header (create a 508-compliant table without modifying the source)
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Modifying a Table Style

. fH—Merge cells

. G8—split cells

+ =—Table caption; when you click on this, Table caption appears above the table.
Modify text as desired.

o Text Box—Add a summary that visually impaired users can access with a screen reader.

The summary does not appear in the editor or on a Web page.

IMPORTANT: When you save and publish your content, your site styling is applied.
Therefore, a table in the Workarea may appear differently from a table you edit in
context.

Table with merged cells:
J.l'.'-“

NOTE: To split a merged cell, select the column or row of the merged cell before clicking
Split.

Modifying a Table Style
With the Inspector open, click anywhere in a table to view styles and advanced

properties you can apply.

r Apply styling to] | Apply styling to|
entire table one row

Inspector

D o\ TABLE TBODY | TR

ElHighlight Tags On

Capital cutloy 2012

Apply styling to
one cell

Sumimary

This is my table

In the following example, a 3x3 table was created. Clicking in a cell, the nested tag
structure shows the following:
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Moving a Table

o Jov  rasce [ reoor f = B fov ]

Click any tag to see styles you can apply to it. For example, click Qs i=8 to see
table properties. The following image shows the table size reduced to 25%.

Ektron CMS400_MET delivers that advantage. It now offers eight visual. drag-and-drop template develoj
developers to assemble Web sites up tg

Inspector

With CMS400.NET's new “toolbox” of p
working in Visual Studio .MET to rapid|

pv | o =S TBODY TR || TD
ElHighlight Tags On Click

As a result, developers can dynamicall
than with other content management so

In addition to visual controls, Web devel
developers can programmatically manag
¥SLT to data returned by the controls, g
the Ektron CMS provides a "virtual deve Summary
to work from a remote development stat

1a 1b 1c

2a 2b 2

Ja 3b 3c M Table Styles
Productivity ACBbCC - clean 100% width [style|
Ektron CMS400 NET is pure NET cont ACBbCC - clean 75% width |style)

enterprise-size organizations to choose

amiarnnmant  and nowe with Adovalnnarfrid

AcBbCc - ciean 50% width [style)

Moving a Table

When you make a table the content focus (a colored bar appears around the table),
a tab appears above the table's left top corner. Use the tab to drag the table to
another place in your content. You can also move a table in Source Viewer.

compared to a record sales month in July 2009, “Deman
our ability to deliver upon mission-critical business initiativ

elerated growth is expected to continue ™

1 a 1h
2 a 2b
3a ib

Deleting a Table
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Working with Images

1. Select the table.
2. Click the handle.

compared to a record sales month in July 2009, “Deman
our ability to deliver upon mission-critical business initiativ
CEO of OnTrek. “With competitive technical analysis and

and elerated growth is expected to continue.”

i 1b
7 3 2 b
3 a ib

3. Press Delete.

You can also delete a table from Source View, and easily collapse the entire table to
delete it in one line of HTML.

Working with Images

The easiest way to insert an image into content is by dragging and dropping it from a
Windows Explorer window. You can also

« insert an image that has been saved to the Library or as an asset, or

. add a new image to the Library while inserting it into content

Inserting an Image using Drag and Drop

You can drag-and-drop an image from your computer into Ektron content using a file
browser. Dropped images are added to the Library for future reuse. Dropped images
must have one of these extensions: .jpg, .gif, or .png, and cannot exceed 5 MB.

When dragging and dropping, the file name becomes the item's title, and no other
library information is collected (for example, its summary and metadata). Once the
content is saved, use the Edit Library screen to add information for the new library
item.

Inserting an Image Using the Library

1. Place the cursor where you want the image to appear.

2. Click Library (E) in the Insert menu. The Library screen appears.

3. From the left panel, navigate to the folder containing the image you want to insert. If
you do not know its folder, use Search (|_\) to find an image by title, description, or

internal file name.

NOTE: If the file is not in the library, you can insert it by clicking the Add Library
button > Browse and navigating to the file. Then, enter a title and optionally a
description and metadata information. The file is inserted into the content and added
to the library.
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Editing Images

4. Select Images from the content type drop-down.

5. Select an image and click Insert (@). The image is inserted into the content. (You can
also double-click the image.)

CMS400 Library

& Library
= MainSite Library Folder: "Our Team\images”
= Content
F Campaigns Images B' Englizh (U.5.)
+ Clients

+ Community

= Company
Careers
Company Mews

| Event Calendar

Locations
Our Team

¥ Haome

Alternatively, you can insert a miniature version of the image, called a
thumbnail, by clicking the thumbnail button (@,). When the thumbnail appears

on a Web page, a site visitor clicks it to view a full-sized image.

Editing Images

After inserting an image, you can adjust its properties by opening the Inspector (=
) on the Review tab.

The Inspector’s Advanced tab lets you modify the image size, position, wrapping,
and so on, and lets you select images that change based on breakpoints for viewing
modes of your users. For example, click Responsive Image Selection > Change
and select an image to display when screen resolution is 275 pixels or fewer.
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Editing Images

Inspector

DI Dl FIGURE IMG
.Highlight Tags On Click

Basic Advanced

Responsive Image Selection

If you reduce the size of the editing window to under 276 pixels, the editor
automatically switches to the smaller picture.
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Adjusting Image Size

Ektron CMS400.NET Server
Controls

Developer productivity is a
critical issue amaong Web
teams. Faced with the
challenge of reduced IT
budgets, smaller teams, and
compressed schedules to roll
out new Internet and intranet
sites and rich Web

applications, developers need
every advantage tilted in their
favor to help their
organizational Web strategies
succeed

Adjusting Image Size

In the Inspector, the Basic and Advanced tabs have a field for adjusting image size.
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Deleting an Image

Advanced

Image Scurce Basic Advanced
fOnTrekfuplcadedimagesfreporizs.png

Alternate Text Image Souwrce

fOnTrekfuplcodedimagesfreportz.png

Alternate Text

Size setting on
Basic tab

Size setting on
Advanced tab

Edit Image

periink to Image

% Size
Constrain Proporticns
Width
Height

pax

by

« Basic tab—Use the Size slider to specify a percentage of the original image. The Size
is calculated as pixels and stored in the <img> tag as a style attribute.

« Advanced tab—the Size > Width field represents a percentage of the parent
container. This number is stored in the <img> tag as is.

Deleting an Image

1. Select the image.
2. Open the Inspector (=) on the Review tab.

NOTE: You know that you selected an image if an <IMG> tag appears in the
Inspector.

Inzspector

v P I
BHighlight Tags On Shick

3. Click Delete image.

Viewing and Editing HTML Source Content

To view and edit the HTML source, click View Source (E) on the Review tab. The

Source Viewer appears. As you edit the HTML, the content window dynamically
updates with your changes.

When you finish editing in the Source Viewer, click the X in the top right corner.

The Source Viewer supports tag completion. For example, if you type <p>, the
Source Viewer automatically adds a closing </p> tag.

The Source Viewer supports collapsing and expanding tags. For example, if a table is
in the content, a small arrow appears next to the line numbers. Click the arrow to
expand or collapse the nested tags.
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Embedding External Content

Source Viewer x
k;)CnIrek announced a 37 percent gain in revenue for the first half of 2010 over the first half o =
combined with cur ability to deliver upon mission-critical business initiatives continues to

customers’ due diligence, our momentum and accelerated growth is expected to continue.”

<br/>

"#" title="/OnIrek/uploadedImages/MainSite/Content/Company/Our_ Team/VicletSawyer.jpg"
"this.conclic "
" 3rc="/0nIrek/uploadedIimages/Mainiite/Content/Company,/0ur_Team/th
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L5 feugiat sem faucibus et. Aliquam erat volutpat. {uisque sed lectus nec elit euismod & i

i C r

Embedding External Content

You can embed the following types of external content into the editor.

« YouTube
« Vimeo
« DailyMotion
« Google Maps
You can also insert content using its <embed> or <object> code.

Embedded elements are treated responsively. This means that a video or map is
sized according to the device on which it is viewed.

PREREQUISITE

You need the URL of the media item that you want to embed. Content
providers typically supply an easy way to find the content's URL. For
example, to find a YouTube video, click Share, then copy the URL.
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Embedding External Content

Search Capabilities in Ektron 9 - Developer Office Hours

‘60(\ Ektron ~ . %0 0
oF ' 206 | Click Share |
\"‘“w\
il Like p About Share Add to = Al [
Share this video Embed Email
]v]: Je o) /G o] -
/

Start at- ' 0:09

1. On the editor toolbar, click the Insert tab then Insert Embedded Media (+ ). The
Insert Embedded Media screen appears.

Insert Embedded Media

Select the Media Source:
Other

Embed Source:
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Embedding External Content

2. Use the Select the Media Source pulldown to select a media source.

Select the Media Source:

YouTube
Other

Vimeo

DailyMation
Google Maps
iFramea

3. Insert the URL for the content that you want to embed.

To embed content from another source, choose Other in the Select the Media
Source pulldown, then insert the code.

Select the Media Source:

YouTube URL:

https-/fwww youtube comfwatchhv=zPAVILIAKDY
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Embedding a Google Map

4. Click Embed. The media is embedded in the content.

Edit Contentin Folder "Amanda Lynne"

¢ euBush | ) 3 [EH (4 2]

Title: |[Ektron in a Minute [English (U.5.)]

Content Summary Metadata Schedule

& £l B 0=t —

Y

Ektron in 2 Minute: PageBuilder for Developers

M
i

ARTY
INTEGRATION

Embedding a Google Map

Click the Share link. Then copy the text in the Paste HTML to embed in website
field and paste it into the Embed Source field.
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Embedding a Vimeo Video

Go gle 542 Amherst St, Nashua, NH | a |

e My places & oo Paste link in email or IM 3
Short URL Learn more Send

S J https://maps.google.com/maps?q=542+Amherst+5
542 Amherst St Paste HTNL to embed in website

MNashua, NH 03063
g __|<iframe width="425" height="350" frameborder="0" :

Paste HTML field / Customize and preview embedded map

&) (=1 Stone ~ Customize and preview

Qleamery link
| y
BT -
fi®
. . The Cl
Directions Search nearby Save to map more D) i) Jesus
— Latter
d
Maps Labs - Help
Round Pond
Google Maps - ©2013 Google - Terms of Use - Privacy Ektron (=

%

To modify the map before inserting it, click the Customize and preview
embedded map link. You can change the size, view, and zoom. When finished,
copy the HTML from the bottom of the screen and paste it to the Embed Source
field.

Embedding a Vimeo Video

When embedding a Vimeo video, use the URL in the browser address bar.

How to Add a Calendar Event | + _

vimea,com, 59213563

SEEMLindu

i Foldars g
. Rt e
Lo E—
Aot
Tila Saphaftibes
Amdemn

Briminalama

Removing External Content

1. On the Review tab, click the View Source button (). Source Viewer appears.

2. Find and delete content between the opening and closing <div class="embed-
container> tags that surround the video. An example is below.

<div class="embed-container">
<iframe marginheight="0" marginwidth="0"
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Removing External Content

src="https://maps.google.com/maps?f=g&amp; source=s_g&amp;

hl=en&amp; geocode=&amp; g=542+Amherst+Street, +Nashua, tNH&amp; ag=0&amp; og=542&amp; s1
1=42.752811,

71.49671&amp; sspn=0.203443,0.308647&amp; ie=UTF8&amp; hg=&amp; hnear=542+Amherst+St, +
Nashua, +New+Hampshire+03063

&amp; t=hé&amp; 11=42.796156, -

71.573181l&amp; spn=0.120922,0.219727&amp; z=12&amp; iwloc=A&amp; output=embed"
frameborder="0" height="480" scrolling="no"

width="640"></1iframe>

<br/><small><a href="https://maps.google.com/maps?f=g&amp;
source=embedé&amp; hl=en&amp; geocode=&amp; g=542+Amherst+Street,

+Nashua, +NH&amp; ag=0&amp; og=542&amp; s11=42.752811, -

71.49671&amp; sspn=0.203443,0.308647&amp;

1e=UTF8&amp; hg=&amp; hnear=542+Amherst+St, +Nashua, +New+Hampshire+03063&amp; t=h&amp;
11=42.796156,-71.573181l&amp; spn=0.120922,0.219727&amp; z=12&amp; iwloc=A"
style="color:#0000FF; text-align:left">View Larger Map</a></small>

</div>
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