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Getting started with Ektron

Ektron manages the life cycle of content, from creation to approval and publication. It
helps your organization set up a process for overseeing changes to a website, indicate
the status of content within that life cycle, and inform the next approver that it is their
turn to review the content.
Business users, such as marketing or public relations professionals, can author,
manage and publish Web content, build and deploy Web forms, and collect and
leverage visitor information. The editor supports the industry’s best in-context editing
environment, ensuring user adoption and project success.
People interact with your Ektron website in different ways. Some people operate in
different roles, and sometimes different roles overlap in activity. For example, a
developer uses PageBuilder to create page structures, while content authors use
PageBuilder to build a page in those structures. Similarly, some administrators and
developers may perform installation and set-up actions.
The major roles for people interacting with your website are as follows:
l

6

CMS User (Content Author). creates content for your website and may edit the
content in context on the Web page or in the Workarea. Content authors can have
specialized roles and permissions, such as a discussion board administrator.
o Ektron's marketing suite on page 1123
n Creating personalized Web experiences with personas on page 1137
n

Connecting visitors with targeted content on page 1155

n

Measuring Web experiences with multivariate testing on page 1179

n

Managing landing pages on page 1201

n

Managing calls to action on page 1193

n

Managing a blog platform on page 1237

n

Ektron's marketing suite on page 1123

n

Analyzing websites on page 531

n

Targeting content with GeoIP information on page 1172

o

Editing in Ektron on page 605

o

Creating PageBuilder pages on page 1077

o

Editing content on a PageBuilder page on page 1082

o

Managing content on page 645

o

Working with Ektron content on page 679

o

Working with assets in the Document Management System on page 708

o

Working with files in the library on page 733

o

Working with collections on page 804

o

Managing user communities on page 1623

o

Working with discussion boards on page 1013

o

Working with forums on page 1025
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l

l

o

Assigning and managing tasks on page 1449

o

Working with calendars on page 991

Marketer. marketing campaign managers, lead generation managers, digital
marketers, and content marketing managers.
l Ektron's marketing suite on page 1123
l

Creating personalized Web experiences with personas on page 1137

l

Connecting visitors with targeted content on page 1155

l

Measuring Web experiences with multivariate testing on page 1179

l

Managing calls to action on page 1193

l

Managing landing pages on page 1201

l

Managing a blog platform on page 1237

l

Analyzing websites on page 531

l

Personalizing a Web page on page 1437

CMS Administrator. manages the website including access to all content,
taxonomies, users, rules, and settings.
o Setting up your CMS folder structure on page 149
o

Managing content on page 645

o

Working with Ektron content on page 679

o

Approving content for publication on page 749

o

Organizing content with taxonomies on page 1357

o

Creating a mobile-driven Web experience on page 503

o

Synchronizing servers using eSync on page 1925

o

Developing wireframe templates on page 1093

o

Using responsive frameworks with PageBuilder on page 1087

o

Applying adaptive image resizing on page 518

o

Personalizing a Web page on page 1437

o

Creating and using widgets on page 1271

o

Creating menus for your website on page 1339

o

Creating user-friendly URLs with aliasing on page 1399

o

Navigating a website with breadcrumbs on page 1431

o

Working with multi-language content on page 1507

o

Analyzing websites on page 531

o

Defining roles on page 1581

o

Creating business rules for your website on page 1473

o

Working with Smart Forms on page 888

o

Viewing network server diagnostics on page 2049

o

Managing users and user groups on page 1555

Ektron Reference

7

Getting started with Ektron

l

l

o

Sending notifications to a community on page 1665

o

Sending Web Alert emails to subscribers on page 1481

Web Administrator. installs, upgrades, or migrates sites to Ektron and gets
Ektron ready for use.
o Ektron release notes
o

Ektron system requirements

o

Installing Ektron on page 9

o

Upgrading to Ektron 9.40 SP1 on page 37

o

Securing Ektron on page 57

o

Setting up Ektron on page 71

o

Setting up search for your website on page 191

o

Ektron Digital Experience Hub release notes on page 499

o

Distributing resources with 3-tier architecture on page 175

o

Using LDAP with Ektron on page 1616

Developer. writes API code, modifies ASPX pages, creates wireframe templates
with PageBuilder, and create widgets to customize your website.
o Framework API
o

Framework UI

o

Templated server controls

o

Server controls

o

Strategies

o

Constants

o

Ektron Markup Language

o

Creating and using widgets on page 1271

For information about developing a Web strategy, see Creating a mobile-driven Web
experience on page 503.
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Installing Ektron

For information about system requirements for the current release, see System
Requirements. If your system does not conform to them, you should upgrade before
installing or upgrading Ektron.
IMPORTANT: Each deployment has unique requirements. Ektron recommends that
you engage with a Certified Ektron Partner when making decisions about the needs
of your production environment.

License keys
IMPORTANT: Read the Ektron Perpetual License Agreement before installing
Ektron software.
Ektron controls the usage through a license key, a unique code assigned to your
domain. Your license key is included in the email that is sent when you request or
purchase Ektron.
When you login to a website that contains Ektron, it checks the license key(s) against
the domain.
If the URL of a valid license key matches the URL of the site being accessed, the
Workarea appears.
If no valid license key is found for the URL of the site being accessed, Ektron is disabled
and you must log in the with Builtin account to change the License Key.
If you have a broken license key or a license key with an incorrect base URL, an error
message appears in the Ektron Login window. The message states, “Error: A license
violation has occurred and the application is presently locked. Please see your
administrator.” If this message appears, login with the Builtin account and reenter your
license key. If the message continues to appear and you are sure you have a valid key,
contact Ektron Support.

Domains in which you can use a license key
The license key is assigned to a base URL, typically your domain name. For example, if
your domain name is www.mycompany.com, the license key follows this pattern:
www.mycompany.com(expdate)(Modifiers)?1234567890.
Each domain requires its own license key. For example, to support the domains,
www.mycompany.com, sales.mycompany.com and support.mycompany.com, you need 3
license keys.
When you purchase a license key, be sure to register a domain name, not an IP
address. Although Ektron supports IP addresses, the domain that you license becomes
the required URL in the browser address. For example, if you register 192.168.0.1, you
would need to access the site as
http://192.168.0.1/somedirectory/myloginpage.aspx. Because users would
typically not identify a Web page by its IP address, register a domain name instead.
10
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Using Ektron without a license key
For evaluation purposes, when you install Ektron, you do not need a license key. During
the installation process, leave the License Key field blank and click Next on the
License screen. This lets you use Ektron as localhost.

Inserting the license key
You are prompted to enter a license key during installation. If you do not, enter it by
choosing Workarea > Settings > Setup > Edit and completing the License Key(s)
field.
When cutting and pasting license keys, keep the full license key intact without adding or
deleting characters. License keys that are changed in any way render Ektron
inoperable.

Upgrading a license key
If you upgrade Ektron and want to replace the old license key with a new one, choose
Workarea > Settings > Setup > Edit. Next, add the license key to the License Key
(s) field. If you want to add new keys in addition to old keys, create a comma-delimited
list of keys in the License Key(s) field.

Installing Ektron
By default, the installation places files in 2 server locations:
l

C:\Program Files (x86)\Ektron\CMS400vXX. sample and minimal databases,
documentation, utilities, setup files for creating additional sites.

l

C:\Inetpub\wwwroot\site root. bin folder, Web services, scripts, supporting
files, uploaded files and images, graphics used in Ektron, CustomAPI, and so on.
NOTE: The bin folder stores Ektron’s binary executable files. .NET automatically
searches this folder for .dll files.

During installation, the ASPNET or IIS_WPG and IUSR users are given permission to
create folders in these directories:
l

C:\Inetpub\wwwroot\site root\uploadedfiles

l

C:\Inetpub\wwwroot\site root\uploadedimages

Before you install
1. Create a folder for the site. Make sure the drive and folder to which you install your
Ektron website have sufficient space. Anticipate future needs, since the site is
likely to grow over time.
Ektron Reference
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2. Make sure that Internet Information Server (IIS) is installed on your server. See
Creating multiple websites on a single server on page 95.
3. Install the Application Server role on your server. For more information, see
https://technet.microsoft.com/en-us/library/cc754684.aspx.
4. Create an IIS site. See also: How to set up your first IIS Web site.
a. Open IIS.
b. In the left panel, right click the Sites folder and choose Add Web Site.
c. In the Add Web Site dialog, insert sitename, hostname, and physical path for
the new site.
IMPORTANT: Ektron does not support the installation of nested sites, each
having its own web.config file. Nested sites can disrupt features, such as
Aliasing, Menus, and eSync.
Also, do not install the site under another application’s folder within Web
root, nor to an IIS Application under another site.

5. If you are setting up one website that uses multiple Ektron servers and points to a
single database server, make sure both servers connect to the same database. This
configuration ensures that membership user registrations, forum/blog posts,
statistics, and so on, are the same on both servers. For more information, see
Setting up Ektron on page 71.
6. Decide which search provider you will use. See also: Search providers on page 192.
If you will use any Microsoft search provider, install it. See also: Working with
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Microsoft FAST search on page 466; Setting Up Microsoft Search Server 2010 on
page 325; Using Solr search on page 216
7. Enable IIS 6 metabase compatibility and ASP.NET. To do that:
a. From the Windows Control Panel, choose Programs and Features.
b. From the left panel, choose Turn Windows Features On or Off.

c. Click to open Internet Information Services > Web Management Tools
> IIS 6 Management Compatibility.
d. Check IIS Metabase and IIS 6 configuration compatibility.
e. Click to open Internet Information Services > World Wide Web
Services > Application Development Features.
f. Check ASP.NET.
g. Click OK.
8. Obtain a license key from Ektron. Send email to license@ektron.com.

Installing the Ektron base
1. Contact your Ektron account manager to obtain a link to download Ektron.
2. Double click the downloaded CMS400Basevreleasenumber.exe file.
3. Ektron verifies that your server has all required components. You must install any
missing ones before you can continue.

Ektron Reference
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4. A screen displays Ektron’s License Agreement. Read it and click I Accept. If you do
not accept, the setup ends.

5. Select Complete to install all components. Or, select Custom to choose which
components to install. You can also choose where to install them.

14
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6. When you click Next, the install checks for SQL or SQL Express on the server. If
SQL is not installed, a dialog prompts you to install SQL Express.
7. If you will use a remote SQL server, click Continue. If you plan to use SQL Server
on this computer, click the link on the message to install SQL Server Express 2008
R2 RTM. If you do, the Ektron installation terminates. After installing SQL Server
Express, restart the Ektron installation.

8. The Ready to Install the Program screen appears. Click Install. The
installation program copies files to the C:\Program Files folder.

Ektron Reference
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IMPORTANT: After completing the installation, further configure your
permissions based on your network security model before using Ektron.
9. Click Yes to check for updates. This verifies that you have the latest version of
Ektron.

10. You might be prompted to restart your server. If so, you should restart now.
Otherwise, the installation begins.
IMPORTANT: If this dialog appears, do not run the site setup until the system
reboots.
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After you install Ektron, the web.config file is updated as follows.
l

ek_sitePath. webroot/siteroot

l

ek_buildNumber. Current build number of Ektron

l

ek_cmsversion. Current version of Ektron

l

Connection String. Information about the database's connection to Ektron

See also: Managing web.config on page 78

Installing a site
NOTE: Continue with these steps after completing Installing the Ektron base on
page 13.
The installation copies the following folders from C:\Program Files
(x86)\Ektron\CMS400vxx to the Web root folder you specify:
l

BIN

l

workarea

l

documentation

l

uploaded files and uploaded images

l

a login page

l

the Visual Studio solution file
Ektron Reference
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1. You can create a new site manually by clicking the cms400sitesetup.exe file
located in C:\Program Files(x86)\Ektron\CMS400vxx\Utilities\SiteSetup or
by choosing Start > Programs > Ektron > CMS400vXX Utilities > CMS400
Site Setup. The Setup Type screen appears.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
CMS400 Site Setup. Right click and choose Run as Administrator.
2. Choose an option and click Next.
l CMS400 Full Installation. For setting up a new site installation.
l

CMS400 Upgrade. For upgrading existing site's database and site files.

l

CMS400 Database Setup. For setting up a new site database. Site files,
such as .aspx pages, are not included in this setup.

3. In the License Key field, enter your primary license key for Ektron. License keys
are typically emailed to your organization when you request a copy of the
application. When cutting and pasting a license key, keep it intact without adding
or deleting characters. If you do not have license keys now, you can insert them
later.

4. Select a site to install. This screen does not appear the first time you run the site
setup for a starter site. If you run it again and have multiple sites, this dialog
appears.
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Installing a site

5. Select from the drop-down list the site to which you want to install Ektron. You
created the site when preparing for the Ektron installation, as documented in Step
4 of Before you install on page 11.
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6. Enter the destination folder for the site. If your website resides in a folder other
than the default, click Browse and go to that folder. The default reflects your
selection in the previous dialog.
WARNING! Do not install under another application’s folder within the Web
root.
IMPORTANT: Ektron does not support the installation of nested sites, each
having its own web.config file. Nested sites can disrupt Ektron features, such
as Aliasing, Menus, and eSync.
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7. Enter the path of the Secure Asset Location. The Site Options screen appears.
IMPORTANT: If you plan to load balance several servers, make sure this path
is the same for all servers in the cluster. See also: Balancing the load on your
servers on page 99.
NOTE: Be sure the drive to which you install the asset library has sufficient
storage space plus room for growth.
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8. You may see the following dialog.

Click Yes if you want the installation to
a. Enable IIS's IP Address and Domain Restrictions role.
b. Restrict access to the /workarea/webservices and /workarea/services
folders and the /workarea/ServerControlWS.asmx file, so they are only
accessible from localhost.
If you click No, the site installation is terminated.
For more information, see https://portal.ektron.com/kb/10234/.

22

Ektron 9.40 SP1

Installing a site

If you click Yes and complete the installation, you may have to grant permission to
other servers that need to access the restricted folders and file. To do this:
a. Go to IIS.
b. Choose the /workarea/webservices folder.
c. Choose IP Address and Domain Restrictions.
d. Click Add Allow Entry from the right panel
e. Add IP addresses for each server that will access this server's
/workarea/webservices folder.
f. Repeat Steps a through e for the /workarea/services folder and the
/workarea/ServerControlWS.asmx file.
9. On the Search Provider screen, choose the search provider you will use with
Ektron.

See also: Working with Microsoft FAST search on page 466; Setting Up Microsoft
Search Server 2010 on page 325; Using Solr search on page 216.
10. On the Site Options screen, check each option you want to install.
NOTE: You should generate a security certificate because it lets the Ektron
Windows Service register Ektron sites with Search. Certificates also allow
content scheduling and are required for eSync.
See also:

Ektron Reference

23

Installing Ektron

l

Viewing network server diagnostics on page 2049.

l

Managing eSync security certificates on page 1979

NOTE: eSync is only available if the eSync modifier is in your license key.
11. After choosing, click Install. The Moving Files dialog appears, and the following
things happen.
l files are copied to the site
l

permissions are set for the site’s directories

l

ASPNET, IIS_WPG, or Network Service user and IUSR are given permissions to
the directories

l

the site is set up to use .NET 4.5

l

web.config settings are configured

l

IIS is configured

Setting up a database
PREREQUISITE

If you are using a separate database server, you need the following information:
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l

Database server host name or IP address.

l

If the database server is on the same domain as the application server, it supports
NT or SQL authentication.

l

If the database server is on a separate domain from the Ektron server, it supports
SQL authentication.

l

You have database administrator or database creator privileges .

NOTE: Continue with these steps after completing Installing a site on page 17.
Your database contains information such as users and content blocks. The database
setup program:
l

checks for SQL or SQL Express server. If either is installed on your server, an
appropriate database is set up.

l

loads database tables

l

updates the web.config file with information about your database connection,
based on your responses

1. You are prompted to set up a database. Click Yes.

Ektron Reference
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2. Enter a name for the database.

3. Enter the Ektron administrator user's password. It cannot be admin. You may also
change the user's username if you wish.
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Setting up a database

After completing the installation, Ektron administrators may edit these values in
the Ektron Workarea > Settings > Users screen.
The Ektron administrator user is a member of the Administrators group. Group
members have access to all Ektron Workarea screens.
4. Enter the builtin user’s password. For information about the builtin user, see
Editing the builtin username and password on page 117.

Ektron Reference

27

Installing Ektron

5. Click Next. The SQL Server DB Setup screen appears and prompts for database
connection information.
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l

Server. List the database server on this system. To setup the database on this
server, accept the default. Otherwise, enter a SQL or SQL Express server that
already exists. For SQL, this would typically be (local) if it’s installed on the
local server. Otherwise, enter the Server’s name. For SQL Express, enter
(local)\SQLEXPRESS.

l

Username. Enter the username you will use to access the database.

l

Password. Enter the password you will use to access the database.
NOTE: If you want to use NT authentication, leave the username and
password blank. This will set up a trusted connection.

After you complete the screen, the setup verifies the database connection
information. If the database name already exists, you are asked to assign a
different name. When a connection is made and the name is available, the
installation program creates a database using the provided information.
6. If you did not leave the Username and Password fields blank on the previous
screen, the following screen appears.
7. The setup verifies the database connection information. If the database name
already exists, you are asked to assign a different name. If the name does not
already exist and a connection is made, the installation program creates a
database using the provided information.
8. Click Install to begin the installation. The Setup Status screen appears.
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9. When the SDK install is finished, the following screen appears. Click Finish. The
site and database setup portion of the install is complete.

10. The following screen appears, providing information about setting up a search
provider. The message varies according to the chosen search provider.

11. If you checked the eSync box in Step 9 of Installing a site on page 17, the
following dialog appears.
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To learn about eSync security certificates, see Part 2: Generate and copy security
certificates on page 1937.

Troubleshooting installation issues
Error: Failed to Create Directory

The possible cause and solutions are as follows:
l

User does not have permission to create objects. Grant user permission to create
objects. For information on how to, read IIS Security help topic “Setting NTFS
Permissions for a Directory or File.”
http://localhost/iishelp/iis/htm/core/iidfpsc.htm

l

Host is not localhost. Install Ektron on localhost machine only.

Error: Configuration error
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If Ektron requires .NET 4.0, but you server has a previous version of the Microsoft .NET
framework, Install the .NET 4.0 framework.

Installing Ektron on several servers
Perform these steps on the development server.
1. Complete all steps in Before you install on page 11.
2. Download and run the Ektron installation file, CMS400Basevversionnumber.exe.
3. In Windows Explorer, create a folder to be used for development (for example,
c:/cmsdev).
a. At the Setup Type page, select CMS 400 (Complete).
b. On the Site Setup screen, at the Select Site drop-down, select the site you
created in Step 3, dev.example.com. At Select Host, select the host you
entered for dev.example.com.
c. On the Site Path Directory screen, browse to the C:\cmsdev folder.
d. On the Host screen, enter http://dev.example.com or an IP address. A
window prompts you to define the Asset Storage Location. Enter
C:\assetlibrary\cmsdev and C:\assetcatalog\cmsdev. The Database
Setup utility begins. (See Setting up a database on page 24.)
4. Run the Site Setup utility by choosing Start > Programs > Ektron > Utilities >
CMS400 Site Setup. This installs the site on the development server. (See
Installing a site on page 17.)
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
CMS400 Site Setup. Right click and choose Run as Administrator.
a. Enter your database name, cmsdev to continue the example. (Do not leave it
as localhost.)
b. Enter your database server information, then the host, user and password.
The database is created. The site is ready for use.
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c. Open Internet Explorer and go to http://your web site/login.aspx to test
the site.
d. Log in to make sure the database is working.
Using the steps, install sites to your staging and production servers.

Uninstalling Ektron
Uninstalling removes all Ektron files from your server. You might want to do this if you
installed Ektron, experimented with it, and now want to remove that version and install
a clean, new version.
IMPORTANT: Do not use the Windows Add/Remove programs utility to uninstall
Ektron. Use the uninstall utility instead.
To uninstall Ektron:
1. Close all programs that are using your Ektron website. Close all Ektron files.
2. Go to C:\Program Files (x86)\Ektron\CMS400vxx\Utilities.
3. Copy the CMS uninstaller folder to your desktop.
4. From that folder, run CMSUninstaller.exe. You can uninstall specific websites, the
Ektron application directory, or all Ektron files.

Effect of removing a website
When you uninstall a website, the following happens.
Ektron Reference
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1. The IIS and Indexing Service stops.
2. The website's database is deleted.
3. The website folder's files are deleted.
4. The IIS and Indexing Service starts.

Effect of removing a website's database
If you check the Remove Websites Database box, the site database is removed.

Effect of removing the Ektron application directory
If you check the Remove Ektron Application directory box, the following items are
removed.
l

All Ektron services

l

These Program Files (x86)\Ektron directories (if they exist)
o CMS400v76
o

CMS400v75

o

CMS400v70

o

Dms400

o

EktronWindowsService40

o

EktronWindowsService30

o

EktronWindowsService20

o

EktronWindowsService

o

EktronCmsFileHelperService

o

EktronNotificationServices

o

Plugins

o

CMS400SDK

l

Various system directory files

l

These registry entries
o Everything under Software\Ektron

l

o

All StarterSite keys

o

SDK install key

The base installer key

Removing search server files and services
If you check the Remove Ektron Search Server Files and Services box, the
services and files that Ektron uses for Microsoft Search Server are removed. (This
action does not remove Microsoft Search Server 2010).
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Removing all sites and application directory
If you check the Remove All Sites and Application Directory box, all Ektron files
are removed.
NOTE: After you complete the uninstall, you may need to manually remove the
AssetLibrary, EktronSearchData directories.

Removing third-party programs
To remove all third-party applications required to run Ektron, go to Windows Control
Panel > Uninstall a Program and remove these programs.
l

Your search provider (for example, Microsoft Search Server 2010)

l

SQL 2008 R2 Reporting Services Sharepoint 2010 Addin

l

Microsoft Sync Framework 2.1 SDK

l

Microsoft Visual C++ 2010 x64 Redistributable

l

Microsoft Filter Pack 2.0

l

Microsoft Visual C++ 2008 Redistributable

l

MSXML 4.0 SP2 Parser and SDK

l

Microsoft Visual C++ 2005 Redistributable (x64)

l

Microsoft Server Speech Recognition Language = Tele (enUS)

l

Adobe PDF iFilter for 64bit platforms

l

Microsoft Chart Controls for Microsoft .NET Framework 3.5

l

Microsoft Server Speech Platform Runtime (x64)

l

Microsoft ASP.NET 2.0 AJAX Extensions 1.0

l

Microsoft .NET Framework 4 Extended

l

Microsoft .NET Framework 4 Client Profile

l

Microsoft Sync Services for ADO.NET v2.0 (x64)

l

Microsoft Report Viewer Redistributable 2008 SP1

l

Microsoft Office 2003 Web Components

NOTE: Some applications may have been installed before you installed Ektron.

Installing help files on a local server
Beginning with Ektron Version 8.5, Ektron online help files reside in an Ektron-hosted
Web server instead of a folder on your Web server. If you block your users' workstation
access to the Internet, help files are not available, and users see an error when they
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click the help button. To remedy this issue, either change the firewall to allow access to
the internet, or install help files locally.
PREREQUISITE
l

You can download files to the Ektron server.

l

You can edit files in your website's siteroot folder.

Step 1: Download and install the help folder on your
Web server
1. Click the following link:
http://documentation.ektron.com/cms400/v9.30/Reference/Zip/EktronReference
.zip.
2. Download the .zip file to your Ektron server.
3. Create a folder called help in the Workarea folder, typically
inetpub/wwwroot/your-website/Workarea/.
4. Unzip the file to your Ektron help folder, typically inetpub/wwwroot/yourwebsite/Workarea/help. (You can install help to any website folder.)
NOTE: If you installed help to another folder, replace the web.config default
value with the complete URL to that folder. For example: <add key="ek_
helpDomainPrefix" value="http://www.example.com/help" />

Step 2: Change your website's web.config file
1. Edit your siteroot/web.config file.
2. Find ek_helpDomainPrefix.
3. If you installed the help folder to this website's Workarea folder, remove the path
value. For example:
<add key="ek_helpDomainPrefix" value=""/>

If you installed help to another folder, replace the default value with the complete
URL to that folder.
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The upgrade procedure copies Ektron’s latest features to your Web server. Ektron is
installed to its own folder, C:\Program Files (x86)\Ektron\. This means Ektron can
coexist with previous versions on the same machine—the template directories are
independent.
If you are upgrading from version 8.00 or higher, follow the instructions in this section.
If you are upgrading from an Ektron version prior to 8.00 and need assistance, please
contact Ektron technical support.
For information about the current release's system requirements, see System
Requirements. If necessary, upgrade your infrastructure before beginning the Ektron
upgrade.
Consider the following information before upgrading:
l

Warning! During the upgrade procedure, your website’s Bin, Workarea and
Documentation folders are removed. Any customized files in these folders will be
lost. Only store custom files in these folders when absolutely necessary. Even then,
keep a backup file in another folder.

l

Important! You cannot upgrade Ektron sample or starter sites because they are
designed to demonstrate the product's latest features, so each version is uniquely
created to support a release.

l

Important! Each deployment has unique requirements. Ektron recommends that
you engage with a Certified Ektron Partner when making decisions about the needs
of your production environment.

The Site Setup utility uses files in the CMS400v9x base folder to create and upgrade
Ektron sites. The base folder contains these subfolders.
l

AssetManagement. Folders and files for the Document Management Functionality

l

Bin. Required .NET assemblies

l

CMSServiceUpdate. Files to update your services

l

CommonFiles. Application Global Resources, Web References and Starter
Application files

l

Documentation. Documentation. The site setup procedure copies this directory to
the workarea directory when setting up a site.

l

EktronAsyncProcessor_Service. Files needed to add Asynchronous Processor for
Web Alerts

l

StarterSites. Files for starter sites that have been added

l

StudioHelp. Files for adding API help to Visual Studio

l

SyncUpdate. Files to update eSync

l

Utilities. Utilities for
o database upgrade
o
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l

o

email encrypt password tool

o

a setup SharePoint Portal

o

Document Management Registration tool

o

Load Balancing service files

Workarea. Scripts used for the Workarea
NOTE: The contents of this folder are later copied to a website folder, typically
in the Web server’s Web root. The sample provides a good way to learn how to
work with an Ektron site.

Backing up databases
To protect your database, back it up before upgrading. During the upgrade, Ektron
attempts to back up your database. If that fails, use the following MSDN link for
instructions on backing up and restoring your database via SQL Server.
l

Backup SQL Server

NOTE: On that web page, links for restoring a backed-up database are at the
bottom of MSDN resources.
Before restoring a SQL database, either stop the Ektron Windows service or force all
connections closed. You need to do this because the Ektron Windows Service accesses
the database. To view and update the status of the service, go to Computer
Management > Services and Applications > Services. For more information, see
Handling background processing functions with the Ektron Windows Service on
page 136.

Upgrade overview
The upgrade procedure performs these tasks.
1. Installs new files to new directories. See also: Installing the Ektron base on
page 13.
2. Removes the following folders (and their subfolders) from and copies new folders
to your site directory.
l bin
l

workarea

l

Documentation

WARNING! Any customized files in these folders will be lost. So, only store
custom files in these folders when absolutely necessary. Even then, keep a
backup of customized files in another folder.
3. Updates the web.config file.
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4. Updates your databases using the upgrade and language update utilities.
NOTE: The upgrade automatically starts the IIS and Search services.

Performing the upgrade
1. If you have not done so already, install a Search provider. You must use an
external search provider if you want to use search with Ektron. See also: Setting up
search for your website on page 191.
2. Copy the Assets folder.
NOTE: This step is only relevant if you are using Microsoft Search Server 2010
on a server that is different from your Ektron server.
For Microsoft Search Server 2010 to index your Ektron assets, they must be copied
from the Web server to the Search Server. This process is handled in the
background once your site is up and running. However, if your site has a large
number of assets, the initial copy may get clogged. To avoid this problem, inspect
the size of your Ektron site's Assets folder. If it exceeds 1 gigabyte, follow these
steps. Failure to do so may result in errors.
a. Create a folder on your search server to hold the assets. The folder's path
must match the path to your Ektron site's Assets folder and include
EktronSearchData between C:\ and the beginning of the path.
For example, if your site's Assets folder is
C:\inetpub\wwwroot\OnTrek85\Assets, create a folder on your Search
Server named C:\EktronSearchData\inetpub\wwwroot\OnTrek85\Assets.
b. Copy the Assets folder from your Ektron site folder to the Search Server folder
you created in Step a.
3. Follow the steps of the installation procedure, Installing the Ektron base on
page 13, which instruct you to install Ektron and restart your server. Continue to
the next step when the Site Setup Selection appears.
4. The Setup wizard appears. (If this screen does not appear, launch it by following
this path from the Windows Start menu: Start > Programs > Ektron >
CMS400vxx > Utilities > Site Setup. If you're using Windows 8 or 2012, press
the Windows key (
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)/Q then enter CMS400 Site Setup.)

Performing the upgrade

5. The Setup Type screen appears. Choose CMS400 Upgrade and click Next.
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6. Choose an application directory. If you are not sure, use the default (C:\Program
Files(x86)\Ektron\CMS400vxx). This directory stores Ektron components and
utilities.
NOTE: This dialog appears only if Setup cannot detect the location of the site’s
application directory.

7. If your server operating system accommodates multiple websites, select the site to
which you want to upgrade Ektron. Otherwise, accept the default.
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8. Select the path of the website you are upgrading. Note that the upgrade only
updates the web.config file, Ektron assembly files, and Web services/Workarea
components. It does not update your templates nor other files not mentioned
above.
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9. The following message appears. Click Yes to back up your site.
WARNING! Ektron strongly recommends backing up your site before
continuing the upgrade. If you choose No and the upgrade fails, you cannot
revert the files to their original state.

10. If you choose to back up your site, a dialog asks where to store the backup, and
provides a suggested folder.
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11. If you chose to back up your site, you may see the following dialog.

Click Yes if you want the installation to
a. Enable IIS's IP Address and Domain Restrictions role.
b. Restrict access to the /workarea/webservices and /workarea/services
folders and the /workarea/ServerControlWS.asmx file, so they are only
accessible from localhost.
If you click No, the site installation is terminated.
For more information, see https://portal.ektron.com/kb/10234/.
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If you click Yes and complete the installation, you may have to grant permission to
other servers that need to access the restricted folders and file. To do this:
a. Go to IIS.
b. Choose the /workarea/webservices folder.
c. Choose IP Address and Domain Restrictions.
d. Click Add Allow Entry from the right panel
e. Add IP addresses for each server that will access this server's
/workarea/webservices folder.
f. Repeat Steps a through e for the /workarea/services folder and the
/workarea/ServerControlWS.asmx file.
12. On the Search Provider screen, determine which search provider you will use with
Ektron.

See also: Setting up search for your website on page 191.
13. The Site Options screen appears. Check the box next to each option you want to
install. Boxes are grayed out if an option is not available for your site. See also:
l Viewing network server diagnostics on page 2049
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l

an eSync security certificate. See also: Managing eSync security certificates
on page 1979.

l

Using Ektron’s Developer SDK
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14. After choosing, click Install.
NOTE:
eSync is only available if you have the eSync modifier in your license key. SDK
is only available if Visual Studio 2010 is installed on your server.

15. You are asked if you want to update your siteroot/widgets directory. Click Yes
to install the latest widgets. Before doing so, rename any customized widgets in
that folder; otherwise, they will be overwritten.
16. You are notified that files are moving to the starter site directory. The Choose
Destination Location screen appears.
17. Enter the path to your AssetManagement Directory.
NOTE: This dialog appears only if the upgrade cannot find the
AssetManagement directory.
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18. If you chose to do so, your site is backed up. Next, the bin, Workarea and other
files are updated. Any missing permissions or Index catalogs are added.
WARNING! The previous version’s bin and Workarea folders are removed from
your website. Any customized files within these folders are lost. Do not store
custom files in them unless absolutely necessary. Even then, always keep a
backup file in another folder.
19. Your web.config file is updated with information needed to run Ektron. If other
applications use the web.config file, their sections are unaffected.
20. A dialog asks if you want to upgrade the database. Select Yes to upgrade. If you
select No, the site will not work properly until the database upgrade has been run.
To upgrade the database at a later time, run the Site Setup and select Database
Upgrade. The site setup is located in Start > Programs > Ektron >
CMS400vxX > Utilities > CMS400 Site Setup. If you're using Windows 8 or
2012, press the Windows key (
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)/Q then enter CMS400 Site Setup.

Performing the upgrade

21. If you selected yes, the Database Upgrade Wizard appears. Click Install.
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22. This screen prompts for database connection information.

Server. List the database server on this system. To set up the database on this
server, accept the default. Otherwise, enter a SQL or SQL Express server that
already exists. For SQL, this would typically be (local) if it’s installed on the local
server. Otherwise, enter the Server’s name. For SQL Express, enter
(local)\SQLEXPRESS.
NOTE: This dialog appears if you are using SQL Authentication. If you are using
Windows Authentication, skip to the next step.
23. A dialog appears asking you to back up your database. See also: Backing up
databases on page 39
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24. If you clicked Yes, select the location of your database backup. If this path does
not exist on your database machine, the backup will fail. Otherwise, skip to the
next step.

IMPORTANT: If the backup fails, the following message appears: Warning!
The install could not backup your database. Please manually back it
up now before continuing. You should manually back up your database
before clicking OK.
25. If your license key was not generated for the 9.x Release, you are prompted to
enter a 9.x license key. If you do not have an 9.x license key:
l Complete the upgrade.
l

Obtain a 9.x license key from Ektron (send email to license@ektron.com).

l

Log in as builtin user. See also: Editing the builtin username and password on
page 117.

l

Insert the key into the Settings > Configuration > Setup screen's >
General tab >License Key(s) field.

26. If you selected Microsoft Search Server as a search provider, the following screen
appears.
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l

If you have already upgraded the search server to use the Search
components, click Yes. (This would typically be the case when an Ektron site
on the server is already using search).

l

If you have not set up a search provider, or the Ektron search components
have not yet been installed or upgraded to , click No.
After completing the Ektron CMS installation, install the search provider and
the search components.

If you chose Solr, the following dialog appears. Click OK.

To complete the search setup, log on to the search server, click the Windows Start
menu > All Programs > Ektron > CMS400Vxx > Utilities > Search
Configuration. If you're using Windows 8 or 2012, press the Windows key (
)/Q then enter Search Configuration.
The Connection Information screen appears. See also:
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o

Installing Solr on a single on-premises (local) server on page 229

o

Setting up Microsoft Search Server 2010 Express on page 317
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o

Setting Up Microsoft Search Server 2010 on page 325

o

Working with Microsoft FAST search on page 466

After upgrading your site and rebuilding the solution, you are ready to use Ektron.
If you did not run the database upgrade or language update during the installation, you
need to do it manually. The next sections explain how to do that.

Troubleshooting upgrade problems
Problem 1: After upgrade, Ektron does not load properly. Also, an error icon appears
next to your templates when you open the project in Visual Studio.NET. The problem is
that your .NET references need to be updated.

Solution 1: To verify the problem, open the Ektron solution file in Visual Studio.NET
(webroot\siteroot\cms400sitename.sln; for example, cms400Intranet.sln) and
look at the template files. If your references are broken (as shown in the sample screen
on the left), delete all Ektron references. Then, add new references with the same name
from the webroot\siteroot\bin folder.
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Problem 2: When viewing a page containing Ektron server controls or API calls, the
page returns a fatal error Compiler failed with Error Code 2000. Detailed compiler
output may say Fatal error BC2000: compiler initialization failed unexpectedly:
The filename, directory name, or volume label syntax is incorrect. This error
message might appear after an upgrade.
Solution 2: To remove the error message, open up your site's .sln file in Visual Studio.
Then, rebuild the solution using the Build > Rebuild solution menu option.
In this case, the error can be resolved by correcting the database settings in
web.config.
NOTE: To use SQL Authentication with Microsoft SQL server (as opposed to
Windows Authentication), you must have the database 'Security' properties set to
allow "Windows and SQL Authentication." After changing this setting, you must
restart SQL Server for it to take effect.
Problem 3: After upgrading from Ektron version 4.8 or earlier, Metadata is no longer
applied or required when adding or editing content.
Solution 3: In Ektron version 4.8 or earlier, Metadata is applied globally. In later
versions, metadata is applied to each folder individually. Child folders can inherit the
metadata from a parent folder or they can have their own metadata settings. To set the
metadata settings back to global:
1. In the Workarea, click the site root folder.
2. Next, choose View > Folder Properties.
3. Click Edit Properties.
4. Click the Metadata tab.
5. Check the all of the appropriate check boxes for Assigned and Required
Metadata.
6. Click Save.
If you have not broken inheritance on any of the folders, your metadata settings are
applied globally.

UTC datetime storage in the database
If you upgrade from an older version of Ektron, the UTC Converter is automatically run
after the database upgrade is complete.
Dates in the CMS are stored in UTC rather than in the server time zone, and display in
the local user’s selected time zone. The dates default back to the server time zone if the
user is not logged in.
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1. Choose one of the Ektron sites from a provided list.
2. Choose the time zone from which to convert data.
3. Click Run. The conversion occurs and UTC automatically closes.
NOTE: If UTC Converter is opened while running an upgrade, you are not
permitted to change the "Site."
After installation, you can find the UTC converter at C:\Program Files
(x86)\Ektron\CMS400v93\Utilities\UTCConversion\UTCConverter.
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WARNING! Securing your Ektron site is critical to you and to anyone using your
site. Failure to implement security measures can make your site vulnerable to cyberattacks and other security threats. You should complete the actions in this section to
make Ektron as secure as possible.
Security updates are available for Ektron versions 8.02, 8.5, 8.6, 8.6.1, 8.7, 9.00,
9.10, and 9.20, including all service packs from 8.02 to 9.10 SP2. For information,
see Security Update 3.
l

Change the password for the Admin and Builtin users.
o Do not use easy-to-guess passwords (because thieves use automatic
programs to test for easy passwords).
o

Do not use passwords that you use for other systems (because if thieves gain
access to passwords on one system, they will try them on others).

l

Update browsers to take advantage of advances in technology (including security).

l

Apply available service packs and updates for CMS, .NET, and Windows.

Changing the admin password
NOTE: If you changed the admin password during site setup, you do not need to
change it again.
IMPORTANT: You should create your own Administrator user and delete the Admin
user. Also, delete unnecessary users from Ektron.
1. In the Workarea, choose Settings > Users.
2. Click the Admin user.
3. Click Edit Users.
4. Enter the new password in the Password and Confirm Password fields.
5. Click Save.

Changing the builtin password
NOTE: If you changed the builtin user password during the site setup, you do not
need to change it again. See Editing the builtin username and password on page 117
for additional information. Also, the “builtin” user does not appear in the Users list.
This user appears on the application setup screen.
1. Workarea > Settings > Configurations > Setup.
2. Click Edit.
3. Find the Built In User field.
4. Enter the new password in the Password and Confirm Password fields.
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5. Click Update.
NOTE: If you cannot sign in to Ektron because the builtin user password was
changed and you do not know the new password, use the
BuiltinAccountReset.exe utility. This resets your Ektron user / password to
Builtin / Builtin. This utility is located in C:\Program Files
(x86)\Ektron\CMS400versionnumber\Utilities.

Changing the everyone group permissions
By default, the root folder in Workarea provides the Everyone Group with all
permissions except Overwrite Library. You should review the permission needs of the
Everyone Group when you add a folder. See also: Managing folder and content
permissions on page 168.
1. Go to Workarea > Folders > Folders. The View Contents for Folder "Root"
appears.
2. Choose View > Properties.
3. Choose View Permissions (

). The View Permissions for Folder "Root" appears.

4. Click on the Everyone group. The Edit Permissions for Folder "Root" appears.

5. Check the permissions that you want and click Update.

Removing sample users and sample membership
users
Ektron includes sample CMS users and membership users for evaluation and
demonstration purposes. Remove these users when they are no longer needed.

Ektron Reference

59

Securing Ektron

l

CMS users have access to the Workarea and can be content authors,
administrators or developers. These users count towards the number of users in
your license.

l

Membership users are typically people who only interact with your website but
have limited privileges to Ektron. They cannot use the Workarea and do not count
towards the number of users in your license.

NOTE: Some users in the following lists might not appear in your user list. Also, you
might have sample users that appear in your users lists. This depends on your
Ektron version.
Ektron users. See also: Managing users and user groups on page 1555
o

jedit

o

tbrown

o

jsmith

o

vs

Membership users. See also: Membership users and groups on page 1625
o

jmember

o

member@example.com

o

north

o

supermember

o

west

Removing Ektron users
1. In the Workarea, choose Settings > Users.
2. Check the box next to each user that you want to remove.
3. Click Delete (

).

4. Click OK.

Removing membership users
1. In the Workarea, choose Settings > Community Management >
Memberships > Users.
2. Check the box next to each user that you want to remove.
3. Click Delete (

).

4. Click OK.

Disallowing group user accounts
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A group account is an account used by more than one person to log in to Ektron using
the same username and password. This is a serious security issue because it prevents
you from tracking user activities in your Workarea. Group accounts violate Ektron's
license agreement.

Securing services
IMPORTANT: Typically, the \workarea\services\path is used in 3-tier
implementations. Review your site architecture and configure access to support
accordingly.
You need to restrict services to specific IP addresses in IIS 7.
1. From the Windows Start menu, choose Run, then type INETMGR. If you're using
Windows 8 or 2012, press the Windows key (
Manager appears.

) /Q then enter INETMGR. IIS

2. Go to your website > Workarea > services.
3. Double click IP Address and Domain Restrictions.

4. In the Action pane, click Add Allow Entry. The Add Allow Restriction Rule dialog
box appears.
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5. Select Specific IP Address, enter the IP address of the Web server, and click OK.

6. In action pane, click Edit Feature Settings. The Edit IP and Domain Restrictions
Settings dialog box appears.
7. Choose Deny from the drop-down and click OK.

Securing WebServices
You need to restrict Web services to specific IP addresses in IIS 7.
1. From the Windows Start menu, choose Run, then type INETMGR. If you're using
Windows 8 or 2012, press the Windows key (
Manager appears.

) /Q then enter INETMGR. IIS

2. Go to your website > Workarea > webservices.
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3. Double click on IP Address and Domain Restrictions.

4. In the Action pane, click Add Allow Entry. The Add Allow Restriction Rule dialog
box appears.
5. Select Specific IP Address, enter the IP address of the Web server, then click
OK.
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6. In action pane, click Edit Feature Settings. The Edit IP and Domain Restrictions
Settings dialog box appears.
7. Choose Deny from the drop-down and click OK.

Securing ServerControlWS.asmx
1. From the Windows Start menu, choose Run, then type INETMGR. If you're using
Windows 8 or 2012, press the Windows key (
Manager appears.

) /Q then enter INETMGR. IIS

2. Go to your website > Workarea.
3. Click Content View at the bottom of the window.
4. Right click ServerControlWS.asmx and choose Switch to Features View.
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5. Double click IP Address and Domain Restrictions.

6. In the Action pane, click Add Allow Entry. The Add Allow Restriction Rule dialog
box appears.
7. Select Specific IP Address.
8. Enter the IP address of the Web server and then click OK.

9. In action pane, click Edit Feature Settings. The Edit IP and Domain Restrictions
Settings dialog box appears.
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10. Choose Deny from the drop-down and click OK.

Securing assets and user folders
As of version 8.50, user data is no longer indexed directly under the Assets folder. The
/users/ folder may expose user data, such as your users email addresses, when
browsing to this folder. Prevention was made within the Ektron handlers to address this
issue in version 8.00, but you should review and remove the following folder [site
root]\Assets\users if you have version 8.50 or later. If the users folder exits, you
should delete it.

Defining the default file types for assets
Enable only file types that your website needs to support.
1. Go to Workarea > Settings > Configuration > Asset Server Setup.
2. Click Edit File Types ( ).
3. Add or remove file types that your website needs.
4. Click Save (

).

Enabling firewall use
l

Only open port 80 for standard websites. If you enable SSL, open port 443 also.

l

If you need FTP, open port 21, but restrict access to IP addresses that need to FTP
access to your server. The same applies for SFTP, FTPES, SSH for their respective
ports.

l

Do not open remote desktop ports, SQL ports, SMTP ports, or any other port unless
absolutely necessary. Instead, use a VPN tunnel through the firewall for access to
these services. Even FTP can be made accessible through a VPN tunnel.

Setting up SSL
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Ektron strongly recommends configuring a secure socket layer (SSL), especially if you
are using Active Directory integration. SSL encrypts user names and passwords during
transmissions to the Ektron server that are otherwise sent as clear text. See Updating
web.config to use SSL on page 77.
If your Web server does not have an SSL certificate, install one. If you set up an SSL
certificate and configure Ektron to use it, the login page is launched in a Secure Socket
Layer.
After completing this procedure, the Ektron Workarea and your website require the
https protocol—URLs beginning with http no longer work.
To set up SSL for Ektron:
PREREQUISITE

Your server has an SSL certificate. See http://technet.microsoft.com/enus/library/cc731977%28v=ws.10%29.aspx.
1. Open the siteroot\web.config file.
2. Set the value of ek_UseSSL to true.
3. Set the value of ek_SSL_Port to the server port that you want to use for SSL
communications.
4. Set the value of ek_ecom_ComplianceMode to true.
5. Save siteroot\web.config.
6. Configure IIS so that your site uses SSL only. To do this:
a. Open IIS Manager.
b. Select your Ektron website.
c. From the right panel, select Bindings.
d. Click Add.
e. In the Type drop-down, choose https.
f. In the SSL certificate drop-down, choose your server's SSL certificate.
g. Click OK.
h. From the IIS Manager's center panel, click SSL settings.
i. Check Require SSL.
See also: How to Set Up SSL on a Server.
7. If you are using a self-signed certificate, follow these additional steps.
a. Open IIS Manager.
b. Select your Ektron website.
c. From the right panel, select Bindings.
d. Select https and click Edit.
e. On the Edit Site Binding screen, click View....
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f. On the General tab, copy the value next to Issued by.

g. Open your Windows host file.
h. Insert the URL copied in Step 7f.

Additional security measures
The following measures are also recommended.
l

Encrypt cookies in web.config.
<add key="ek_EnableCookieEncryption" value="true" />

NOTE: After making this change, you must reset IIS.
l

68

Enable Captcha for new user signup and other membership features. Captcha
prevents automated tools from creating unwanted data and traffic on your site. Set
the Membership server control's EnableCaptcha property to true. See
Membership Properties.

l

Enable IP filtering on all FTP sites, and WWW sites as needed. Use Ipsec filters to
accomplish this. See How to configure TCP/IP filtering in Windows 2000.

l

Install needed services only (for example, FTP, www, SMTP, NNTP).
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l

If you make a backup of web.config, do not use another extension. The .config
extension is secured, but another extension may make the backup file readable.
(For example, web.BAK.config is secured, but web.config.BAK is not!)

l

Remove test scripts you may have left on your site.

l

If you zip up databases and code, do not leave .zip files on your site.

l

Do not use IIS on a domain controller.

l

Never use virtual directories across servers.

l

Never install websites on the system drive.

l

Remove NTFS write permissions wherever possible. See How IT Works: NTFS
Permissions.

l

Configure a default website with extremely secure settings (for example, require
SSL, Integrated Windows authentication only, accessible from only one IP, NTFS
permissions to none on an empty home directory, and so on), then stop the site.
This results in a broken default website that 80% of hackers will blindly attack
instead of your real website.

l

Configure websites so that the host header matches the site's DNS name. Do this
for both HTTP and HTTPS. Do not configure the default website with host
header. This should prevent 90% of automated hacking tools from working by
sending them to your crippled default website. To do this:
1. Open IIS Manager.
2. Right-click your website icon.
3. On the Web Site tab, click Advanced.
4. Click the IP Address then Edit.
5. Enter the host header in the Host Header field.
6. Click OK to save.

l

Enable IIS auditing.

l

Enable W3 extended logging. Verify that the logged information is appropriate.
Consider enabling the following items:
o Date and time
o

IP address of client

o

IP address of server

o

Server port

o

Username

o

HTTP method used to access your site

o

URI Stern

o

URI Query

o

Status of request

See Extended Log File Format and W3C Extended Log File Format (IIS 6.0).
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l

Set permission for IIS logs to system and local administrators only.

l

Remove write permissions to hklm\software for non-admin accounts.
o Administrators & System: Full
o

l

Everyone: Read/Execute

Restrict NTFS permissions to all executable files on the system.
o Administrators & System: Full
o

Users: Read/Execute

o

IUSR account: execute permissions sparingly

See How IT works: NTFS Permissions.
l

l
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Restrict NTFS permissions to any script interpreters, such as Perl.
o Administrators & System: Full
o

Everyone: Read/Execute

o

IUSR account: execute permissions sparingly

Ensure that the Everyone group has read-only permissions for these directories.
o Web root
o

%systemroot%

o

%systemroot%\system32

o

%systemroot%\system32\inetsrv

o

%systemroot%\system32\inetsrv\asp

o

%systemroot%\program files\common files\
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Setting up development and staging environments
You can set up your Ektron website in the following ways. You decide which
configuration is the best fit for your particular situation.

Virtual staging
Use Ektron’s approval process and scheduled publishing of content to manage when
content goes live.

l

Best choice when changes to templates and library files are infrequent

l

No special implementation guidelines; just an installation on one server

l

When upgrading this type of site, make a temporary copy of the site (both display
layer and database) on a separate server to test the upgrade

Same server, same database
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l

Production and development/staging sites use separate copies of Ektron but reside
on same server and point to same database

l

Ektron’s settings, managed content, and library files are identical between sites

Ektron 9.40 SP1

Same server, different databases

To set up this configuration:
l

To maintain file paths between sites:
o Create separate websites in IIS.
o

Assign different ports to the production and development/staging sites. For
example, the production site is http://www.example.com, and the
development/staging site is http://www.example.com:8080.

l

Both sites must use the same pathing relative to the Web root. For example,
www.example.com\Workarea\applicationAPI.asp and
dev.example.com\Workarea\applicationAPI.asp.

l

Because both sites use the same database, editing and publishing content on one
site affects the other site. As a result, the development/staging server always has
the freshest content.

l

Make the Ektron uploadedimages/ and uploadedfiles/ folders IIS virtual
directories that point to the same physical directory.

l

Template changes must be copied between sites. The best way to copy site
templates and other assets is eSync. This is described in Synchronizing servers
using eSync on page 1925.
o If eSync was not implemented and changes to these items are infrequent, you
can manually copy them.

To test and QA an upgrade, make a temporary copy of the site’s display layer on a
separate server connected to the development/staging database.
If the development/staging database is the master, back it up before upgrading.

Same server, different databases
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l

Production and development/staging sites use separate copies of Ektron’s display
layer, reside on same server, but point to different databases

l

Changes to content, configuration, or library files made in one site must be copied
to other site

To set up this configuration:
l
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To maintain file paths between sites:
l Create separate websites in IIS.
l

Assign different ports to the production and development/staging sites. For
example, the production site is http://www.example.com, and the
development/staging site is http://www.example.com:8080.

l

Separate the databases for isolation.

l

One database is the master, and the other is a copy

l

Only edit content in the site connected to the master database

l

Remove the Ektron login page from the site connected to the copy database

l

To copy the Ektron database, your best choice is Ektron’s eSync feature. This is
described in Synchronizing servers using eSync on page 1925.

l

If you have not implemented eSync, copy site content using a replication tool for
the database.
l SQL Server 2008 SDK Replication: See SQL Server Replication.

l

Library files. Make sure the Ektron uploadedimages/ and uploadedfiles/ folders
IIS virtual directories point to the same physical directory.

l

Templates and other file system assets—The best way to move these is eSync. If
that was not implemented and changes to these items are infrequent, you can
manually copy them. For automated replication, use a product such as Microsoft
Application Center.
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l

Upgrading Ektron. To test an upgrade, make a temporary copy of the site’s display
layer on a separate server connected to the development/staging database. If the
development/staging database is the master, back it up before upgrading.

Separate servers, same database
l

Production and development/staging sites reside on separate servers, which point
to the same database.

l

Ektron settings, content, and library files are identical between sites.

l

Changes to templates must be copied between servers.

To set up this configuration:
l

Configure Ektron’s Load Balancing feature to copy uploaded images and files
between the servers.

l

The best way to move site templates and other assets is eSync. This is described in
Synchronizing servers using eSync on page 1925.
l If that was not implemented and changes to these items are infrequent, you
can manually copy them. For automated replication, use a product like
Microsoft Application Center.

l

When upgrading Ektron:
1. Back up the file system of the development/staging server.
2. Make a temporary copy of the production server database.
3. Switch the development/staging site to use the copy.
4. Test and QA the upgrade on the development/staging server.
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Separate servers, separate databases
l

Production and development/staging sites are installed to separate servers and
point to different databases

l

Changes to content, configuration, or files must be copied between sites.

To set up this configuration:
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l

Both sites must have the same pathing relative to the Web root, for example,
www.example.com\Workarea\applicationAPI.asp and
dev.example.com\Workarea\applicationAPI.asp.

l

Separate the databases for isolation.
l One database is the master, and the other is a copy
l

Only edit content in the site connected to the master database

l

Remove the Ektron login page from the site connected to the copied database

l

The best way to copy site templates and library files is eSync. This is described in
Synchronizing servers using eSync on page 1925.
l If that was not implemented and changes to these items are infrequent, you
can manually copy them. For automated replication, use a product like
Microsoft Application Center.

l

To copy the Ektron database (containing HTML and XML content), your best choice
is Ektron’s eSync feature.
l If you have not implemented eSync, copy site content using a replication tool
for the database, such as SQL Server 2008 SDK Replication. See SQL
Server Replication.
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l

Make sure the Ektronuploadedimages/ and uploadedfiles/ folders IIS virtual
directories point to the same physical directory.

l

When upgrading Ektron:
1. Back up the file system of the development/staging server
2. Make a temporary copy of the production server database
3. Switch the development/staging site to use the copy
4. Test and QA the upgrade on the development/staging server

Copying the site and database to other servers
When your project is ready to be tested in house, move the site to a staging server.
When the project is ready to go live, move the site to a production (live) server. You can
use the same database for all environments. Back up that database often to keep it
safe. Alternatively, create a separate database for each server.
To create new environments:
1. On the same server or a separate server, create new folders for Ektron:
C:/cmsstage and/or C:/cmsproduct.
2. In IIS, create a new domain for each server. http://stage.example.com points to
c:/cmsstage and http://www.example.com points to c:/cmsproduct.
3. If all environments are on the same server, you do not need to copy other folders.
But, if you are using a separate server for each environment, copy the
c:/assetcatalog and c:/assetlibrary folders to the other servers.
4. For the database, access the SQL manager and make a backup of the development
database. Then, create new databases for staging and production. Finally, restore
the backup of the development database to the staging and production databases.
5. In the staging and production environments, open web.config. Then, update the
database connection information so that it points to the new databases.
6. Test the staging and production environments.

Setting up the certificate for IIS 7
See Configuring Internet Server Certificates (IIS 7).

Updating web.config to use SSL
1. Open the siteroot/web.config file.
2. Find these settings.
<add key="ek_UseSSL" value="false" />
<add key="ek_SSL_Port" value="443" />
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3. Set ek_UseSSL to true.
WARNING! If ek_UseSSL is true, but you did not install the certificate to the
Web Server, you cannot log into Ektron.
4. Set the ek_SSL_Port to 443 (unless you specified another SSL port).
5. Find the following line: <add key="WSPath" value="http://server name/site
name/Workarea/ServerControlWS.asmx" />
6. Change http to https.
7. Edit the <wsHttpBinding>/<security> element so it looks like this:
<security mode="Transport">
<transport clientCredentialType="None"
proxyCredentialType="None" realm="">
</transport>
</security>

8. Save and close the file.

Managing web.config
Ektron’s web.config file lets you control many key functions of your content
management system. When you install Ektron, web.config is placed into
webroot/siteroot.
If your server is currently running another .NET application, you must merge that
web.config file with this one. To distinguish Ektron’s tags, they begin with ek_ and
reside within the <appSettings> tags of the web.config file.
The following sections show the settings in the web.config file.
Analytics
l

See Running Google Analytics on page 559.

Connection strings
For SQL Server, use this connection string to define an SQL server.
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l

name. ektron.DbConnection

l

providerName. System.Data.SqlClient

l

connectionString. this part of the connection string contains the following
element.

l

server. the name of the database server to which Ektron is installed. If installed
locally, the value is localhost. This value is set during installation, at the Host
screen.

l

database. use the name of the database.

l

Integrated Security. use True or False. True. use integrated security.
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l

user. If required, specify the username used to connect to the DSN. This user
account must have at least read and write permissions to the database.
NOTE: This value can be blank if you are using Windows authentication.

l

pwd. If required, specify the password for the username given. It should match
your database name.
NOTE: This value can be blank if you are using Windows authentication.
IMPORTANT: After changing any database settings, you must stop and restart
the Ektron Windows Service. See also: Handling background processing
functions with the Ektron Windows Service on page 136.

appSettings
l

ek_AdvancedWorkflowEnabled. Enables or disables advanced workflow; when
set to false the original (basic) approval functionality is available.

l

ek_appName. The name of the application, CMS400. You typically would not
change this value.

l

ek_appPath. This element is prefixed by the ek_sitePath value and describes the
location of the Workarea folder. This file stores external applications (such as
eWebDiff), templates, and the images folder.

l

ek_appImagePath. The folder that stores Ektron images, such as toolbar icons.
Only change this value if you need to move the images folder to another location.
This value is prefixed by the value in the ek_appPath variable. By default, ek_
appPath is set to webroot/siteroot/workarea/. So, by default, this folder is set
to webroot/siteroot/workarea/images/application/.

l

ek_appXSLTPath. The folder that stores XSLTs. Only change this value if you
need to move the XSLT folder to another location. This value is prefixed by the
value set in the ek_appPath variable. By default, ek_appPath is set to
webroot/siteroot/workarea/. So, by default, this folder is set to
webroot/siteroot/workarea/Xslt.

l

ek_buildNumber. Value set by the installation program. You typically would not
change it.

l

ek_cmsversion. Value set by the installation program. You typically would not
change it.

l

ek_enableLegacyBlogFields. Determines whether the Summary tab displays
the 9.00 fields for Tags, Traceback URL and Pingback URL when you create a blog
post. In 9.10, the default is false. Setting it to true uses the functionality from
9.00 and earlier versions. (Blog subjects will display but will not allow changes to
be saved without setting the value to true.)
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l

ek_LDAPMembershipUser. Integrate membership users with LDAP or Active
Directory. Set the value to True for Membership Users to be authenticated using
LDAP/AD.

l

ek_RedirectFromLoginKeyName. Provides a mechanism to return from the
login page to the previous page, specify the query string key-name. By default the
value is RedirectUrl. Currently, the redirect works in 2 instances.
1. When a user tries to use a forum but is not logged in, it sends them to a login
page and returns them. The value in this key used in conjunction with the ek_
RedirectToLoginURL key sends the user from a forum page to a login page
and back to the previous page.
For example, a user tries to reply to a forum post but is not logged in. The user
is sent to the login page, then returned to the original page.
2. A user sends a private message to another user or group administrator from
the SocialBar server control. In this case, once the message is sent, the user is
returned to the page from which he/she clicked private message.
For example, you visit a community group’s page and click Private Message
Admin. You are directed to the private message screen. When you click post,
you return to the community group’s page. For additional information, see
ActiveTopics.

l

ek_RedirectorInstalled. Turns the redirector on or off. Turning the redirector on
alloes you to alias your website's URL. The default is False.
o True. Aliasing turned on.
o

False. Aliasing turned off.

See also: Creating user-friendly URLs with aliasing on page 1399.
l

ek_RedirectorManualExt. Set a comma-delimited list of Web page extensions
for which you will create aliased pages. For example, .aspx,.htm,.html. By
default, the list contains.aspx. See also: Creating user-friendly URLs with aliasing
on page 1399.
NOTE: You can enter several extensions. Each extension must begin with a
period, and the last extension must be followed by a comma (,).
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l

ek_RedirectToLoginURL. The URL of a login page to which to redirect a site
visitor who is not logged.

l

ek_sitePath. The location of Ektron relative to the Web root. This value is set
during installation at the Site Path Directory screen. If you move Ektron to another
folder, you must update this value.

l

ek_TreeModel. Choose whether or not to use Ajax for the folder tree in the
Workarea.
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o

0. use the legacy folder tree in the Workarea.

o

1. use Ajax for the folder tree in the Workarea.
NOTE: This key has been removed from the web.config file. However, you
can still use this key by adding it between the <appSettings> tags. For
example, <add key=”ek_TreeModel” value=”0”> changes the Workarea
folder tree to legacy.

l

ek_workareaDateFormat. Choose how to display dates in some areas of the
Workarea.
o long. example: Tuesday May 21, 2014
o

short. example: 5/21/2014

l

ek_xmlPath. The location of the xmlfiles directory. The ek_sitePath path is
prefixed to this location. Only change this value if you want to move the location of
the xml files relative to the Web root.

l

GoogleMap. Enter connection information for using Google Maps with the
Mapping feature in Ektron. See also: Map.

l

VirtualEarthMap. Enter connection information for using Bing Maps for Enterprise
with the Mapping feature in Ektron. See also: Map.

Images
These images appear before a user logs in, so cannot be stored in the database. Update
as needed. Their location is set in the ek_appImagePath variable. See also: ek_
appImagePath.
l

ek_Image_1. close button

l

ek_Image_2. small login button

l

ek_Image_3. big login button

SMTP server configuration
See Enabling email notification on page 105.
l

ek_SMTPPass. The password set up to send and receive email

l

ek_SMTPPort. The port your system uses to retrieve email

l

ek_SMTPServer. The server that processes email

l

ek_SMTPUser. The username set up to send and receive email

Mail format
l

ek_MailFormat. The format of the email created in Ektron.HTML generates email
in HTML format, while Text generates plain text email.

SSL support
See Updating web.config to use SSL on page 77.
l

ek_SSL_Port. SSL port used by Web server.

l

ek_UseSSL. Determines if server uses SSL for security.
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Active Directory Server Configuration
See Using Active Directory with Ektron on page 1589.
l

ek_ADAdvancedConfig. Enable Active Directory advanced configuration.

l

ek_ADEnabled. Whether Ektron uses Active Directory support.

l

ek_ADPassword. Password for the Active Directory server.

l

ek_ADUsername. User name for the Active Directory server.

l

ek_AUTH_Protocol. The directory access protocol used with the Active Directory
feature. The default value is LDAP. Other protocols are GC (global catalog) and
WINNT.

Menu settings
l

ek_MenuDisplayType. Determines the appearance of the content menu that
appears within every content block after the user logs in.
NOTE: This setting only works if ek_UserMenuType is set to zero (0).

l

l

0. Horizontal—menu icons are arranged horizontally

l

1. Vertical—menu icons are arranged vertically and include the tooltip text

ek_UserMenuType. Determines the appearance of the content menu that
appears within every content block after the user logs in.
o 0. New dynamic menu—only appears when user moves cursor over content
block
o

1. Old classic menu—always appears

o

2. Menu without borders—a silver pin head appears above content that has a
menu available. Hovering over this pin produces a menu.

Multilingual settings
l

ek_DefaultContentLanguage. Sets the 4 digit, decimal representation of the
default content language. For example, American English is 1033. See also:
Setting the default language on page 1512.

l

ek_EnableMultilingual. Enable or disable multilingual content support.
o 1. enable
o

0. disable

See also: Enabling/disabling support for multiple language content on page 1510.
l

ek_ServerURL. Mainly used in Web services to determine a remote server
location. For example, in a Web farm environment, the content server can reside in
a remote location. In this case, the developer’s content is replaced with this value,
so all <img src=””…/> and <href…. references point to server named here instead
of the local one.

Machine translation
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Lets you enter the path to the Google Translation Service API key. See also: Enabling
machine translation on page 1533.
Miscellaneous settings
l

ek_assetPath. The folder that stores assets. Only change this value if you need to
move the Assets folder to another location. Note that this value is prefixed by the
ek_appPath value. By default, ek_appPath is set to webroot/CMS400Min. So, by
default, this folder is set to webroot/CMS400Min/assets.

l

ek_BatchSize. The number of files that can be uploaded at one time. The default
is 4, but it can be any non-negative number.
NOTE: Users can upload any amount of files. The system handles them 4 at a
time.

l

ek_CacheControls. Enable or disable caching for Ektron server controls. See
also: Caching with Server Controls.
o 0. Disable
o

1. Enable

l

ek_EditControlMac. Defines the editor used by a Macintosh operating system
user. See also: Changing the default editor on page 637.

l

ek_EditControlWin. Defines the editor used by a Microsoft Windows operating
system user. See also: Changing the default editor on page 637.

l

ek_EnableMessageBoardEmail. Set to True to enable e-mail notification when
a user posts a message to a user or community group’s message board. If true and
a user posts to another user’s message board, the board's owner is notified. If true
and a user posts a message to a community group’s message board, all group
members are notified. This setting does not affect content messages. See also:
Sending notifications to a community on page 1665.

l

ek_helpDomainPrefix. The path to the help files. By default, help files are
located on an external server and the path is
http://documentation.ektron.com/cms400/v[ek_cmsversion]/webhelp
Change this path if you install help files on a local server. See also: Installing help
files on a local server on page 35.

l

ek_InvitationFromEmail. The “From” email address used when a user sends an
Invitation. Invitations are emails that are sent to non-system users asking them to
join your site. See also: Invite server control.

l

ek_LinkManagement. This setting determines if Ektron uses linkit.aspx when
inserting a quicklink. By default, it is set to false. If set to true, when a user
inserts a quicklink, Ektron inserts a special link instead of a quicklink. A special link
determines the correct quicklink to use when a site visitor clicks it. For example, a
user adds a content block to folder A. A quicklink to that content is a.aspx?id=10.
Later, if an administrator changes the folder’s template but doesn’t update the
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quicklink within the content block, the quicklink is broken. To avoid this problem,
enable link management.
l

ek_LogFileName. Path to the log file name for the message queue

l

ek_loginAttempts. Ektron has a login security feature that, by default, locks out
a user after 5 unsuccessful attempts to log in. See also: Restricting login attempts
on page 115.

l

ek_LoginScreenWidth. The width of the login screen in pixels. You may need to
widen the screen if you are using Active Directory and database names are long.

l

ek_PageSize. This setting determines the maximum number of items that can
appear on a page before it “breaks.” When a page breaks, additional entries appear
on another screen, and the following appears near the bottom of the list:
Page 1 of 2
[First Page] [Previous Page] [Next Page] [Last Page]

NOTE: The above text changes depending on the page you are viewing.
l

ek_QueueName. Path to the message queue.

l

ek_ShowWorkareaRetErrorReferrer. Choose whether to enable referrer debug
information on the RetError.aspx page.
o True. enable
o

False. disable

l

ek_ToolBarFormatTag. This setting only applies after a user logs in to your site.
Change this setting if the colored border that surrounds content looks wrong. (The
border color indicates the content’s status.) By default, <table> tags create the
border. If the border looks wrong or inappropriate, change setting to div. If you do,
<div> tags are used to draw the border instead of <table> tags. This change
typically solves the problem.

l

ek_WorkareaLibSearchResultMode. Sets the Workarea Library search-results
mode.
o text. returns a text only version of the library search results.
o

mixed. returns text and images associated with library search results.

o

graphical. returns a images associated with library search results.

l

ek_XliffVersion. Define the XLIFF version to use when exporting files. See also:
Exporting content to XLIFF on page 1533.

l

WSPath. Determines the location of the Web services page used by the server
controls at design time.

system.diagnostics
l

LogLevel. Enter a numeric value that determines the level of message logging. By
default, diagnostic messages are logged in the Event Log. Choices are:
1—Error: log errors.
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2—Warning: log errors and warnings.
3—Information: log errors, warnings and informationals.
4—Verbose: Everything is logged.
ektronCommerce
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
See Conducting eCommerce on page 1733.
l

ek_ecom_ComplianceMode. When set to true, your site is Security Compliant.
This means the Workarea is encrypted in an SSL session and Logging is started.

l

ek_ecom_DefaultCurrencyId. Select the default currency and enter its Numeric
ISO code. This should be done before creating your product catalog. See also: The
default currency on page 1767.
WARNING! Do not change the default currency or measurement system after
your eCommerce site is live.

l

ek_ecom_TestMode. When set to true, payments are sent to a test gateway
instead of the actual one.

l

ek_MeasurementSystem. Select whether to use English or Metric
measurements for your packages. See also: Configuring packages on page 1792.

mediaSettings
See also: Managing multimedia assets on page 716.
l

application/x-shockwave-flash. Define the relationship between the
Shockwave Flash mime type and the Flash player.

l

audio/mpeg. Define the relationship between the MPEG audio mime type and the
Windows Media Player.

l

audio/x-ms-wma. Define the relationship between the MS-WMA mime type and
the Windows Media Player.

l

audio/x-realaudio. Define the relationship between the realaudio mime type and
the Real player.

l

audio/x-wav. Define the relationship between the WAV mime type and the
Windows Media, Quicktime and Real players.

l

audio/x-wav-default. Define the relationship between the WAV default mime
type and the Windows Media Player.

l

Flash-CLSID. The class ID for the Flash player.

l

Flash-Codebase. Location of the code base plug-in for Flash player.

l

Quicktime-CLSID. The class ID for the Quicktime player.
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l

Quicktime-Codebase. Location of the code base plug-in for Quicktime player.

l

Realplayer-CLSID. The class ID for the Real player.

l

Realplayer-Codebase. Location of the code base plug-in for Real player.

l

video/mpeg. Define the relationship between the MPEG video mime type and the
Windows Media Player.

l

video/quicktime. Define the relationship between the Quicktime mime type and
the Quicktime player.

l

video/x-avi. Define the relationship between the AVI mime type and the Windows
Media, Quicktime and Real players.

l

video/x-avi-default. Define the relationship between the AVI default mime type
and the Quicktime player.

l

video/x-msvideo. Define the relationship between the msvideo mime type and
the Windows Media, Quicktime players.

l

video/x-msvideo-default. Define the relationship between the msvideo default
mime type and the Windows Media Player.

l

video/x-ms-wmv. Define the relationship between the MS-WMV mime type and
the Windows Media Player.

l

video/x-realvideo. Define the relationship between the realvideo mime type and
the Real player.

l

WindowsMedia-Codebase. Location of the code base plug-in for Windows Media
Player.

l

WindowsMedia-CLSID. The class ID for the Windows Media Player.

Miscellaneous
l

HttpHandlers. This section sets how the URL Aliasing feature handles URLs with
certain extensions. If you have any extension you do not want aliased, add it below
the following line using the same syntax.
add verb="*" path="*.png" type="URLRewrite.StaticFileHandler,
Ektron.Cms.URLRewriter" />

l

maxRequestLength. This setting determines the maximum size of files that can
be uploaded to your server. The default setting is 204,800 kilobytes, or 200 MB.
Enter the desired value in kilobytes. To convert megabytes to kilobytes, go to
OnlineConversion.com.

l

session state. Mode—determines the storage option for session data. Ektron
supports all session-state modes listed in this article: Session-State Modes.

Migrating your site to Ektron
This section explains how to migrate your website to Ektron, as follows.
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l

What to copy to your website

l

Setting up and deploying templates
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Before you migrate
l

Ektron requires a physical installation of the product. If you do not have physical
access to the machine, someone with access to the machine must run the install.
For more information, see Installing Ektron on page 11.

l

After you install Ektron, verify that it is properly installed by using the starter site.
By default, the sample website is located at the following address on the machine
to which Ektron is installed.
http://localhost/siteroot/default.aspx

If you can browse the starter site and it works properly, Ektron is properly
installed.
BEST PRACTICE
Keep a working version of the starter site to help you debug problems.
For example, if you encounter errors on your site, try to reproduce on
the starter site. If you can, that may indicate a problem with the
installation. If you cannot, the installation is probably OK and an
external factor is causing the problem.

Setting up a new site
NOTE: You can use the Site Setup utility to perform these tasks by choosing Start
> Programs > Ektron > CMS400 > Utilities > Site Setup. See Installing a site
on page 17.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
CMS400 Site Setup. Right click and choose Run as Administrator.
1. Copy application core files. Copy these files from the siteroot/workarea folder
into your site folder. These files operate the Workarea, library, and content
functions.
2. Set up the database. Content is stored in a database. To learn how to set one up,
see Setting up a database on page 24.
3. Modify application parameters. Modify the web.config file installed to the Ektron
site root directory. In that file, update the <ConnectionString> tags to point to
your server, database, user, and pwd.
NOTE: If you are using SSL, web.config settings are explained in Setting up SSL
on page 66.
4. Create a Login Page. You can either copy the one from the starter site or create
your own. See also: Log-in server control.
5. Log In
a. Browse to the login page you created and click Login. A login dialog box opens
asking for a username and password.
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b. Enter the admin username and password and click Login. (You selected these
while installing Ektron.) You are logged into Ektron.
6. Modify configuration settings. Click Workarea to modify these settings.
l Set up Active Directory. If plan to use Active Directory, configure this now. The
settings for Active Directory can be found in the Settings > Configuration
folder. Refer to Using Active Directory with Ektron on page 1589.
l

Modify the Setup screen. The Ektron setup section is located under the
Settings > Configuration folder. The setup section lets you configure items
such as your license key, style sheet support, and default language. See
Modifying setup information on page 129.

l

Set up Metadata. Ektron includes extensive metadata support. Settings for
metadata definitions can be found under the Settings > Configuration
folder in the Workarea. You can have as many metadata definitions as needed.
See also: Working with Metadata on page 822.

l

Set up Smart Forms. You can also set up your Smart Forms. You create XML
files externally or via the Data Designer. Next, a Smart Form is assigned to
content blocks and folders. See also: Working with Smart Forms on page 888.

7. Create Ektron users. If you are not using Active Directory support, add users
manually. The maximum number of users is determined by your license key. For
instance, if you purchase a 10-user license, you can enter 10 users. If you exceed
the licensed number of users, you may get locked out of Ektron. Every user must
belong to a group. When you first add a user, the user is automatically added to the
Everyone group. You can create more user groups and add users to them as
desired. See also: Managing users and user groups on page 1555.
8. Configure content and forms folders. Create folders to organize content blocks and
forms. Create as many folders as you want. Each folder level can go as deep as you
want. See also: Planning your CMS folder structure on page 150.
9. As you create folders, you can assign a default template and style sheet. The
default template is used when a new content block is created and Ektron creates a
Quicklink that points to the new content block. If you do not provide a default
template, it is inherited from the parent folder.
After creating the folders, assign permissions and workflow to them. Permissions
can be assigned to a user or a user group. The same is true for workflow.
BEST PRACTICE
Limit permissions for the “Everyone” group, as this gives every user
permissions to content. Similarly, limit the “Everyone” group’s inclusion
in the workflow to restrict which users can publish content.
10. Create templates. Templates determine the look and feel of the site. Masthead,
navigation, and footer graphics are all part of the template. Use server controls to
insert Ektron content into a template. For a list of server controls, see Server
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Controls.
BEST PRACTICE
Because dynamic templates include URL parameters, make each main
landing page and other important pages static tags. This makes it easier
for you to remember if you need to provide that link to someone.
For instance, each main landing page from your home page could use
the static tag. Then, as you go deeper into that section, subsequent
pages use a dynamic tag.
11. Migrate or create content. You can create or migrate your content. If you are
migrating content from an existing site, add a new content block, and cut and
paste the content into the Ektron editor.
NOTE: All images and files must be uploaded and inserted into the content
separately.
12. Deploy the content. Deployment from development to production is as simple as
moving the files over. To properly deploy your new Ektron website:
a. Copy all assets (templates, images, files, and so on) from your development
box to your production machine.
b. Move the database. You have 2 choices
l point your data source on the production machine to the database you
were using.
l

copy the database, move it to your production server, and point a data
source to that.

13. Optionally, for email notification to work in Ektron, make sure the SMTP service is
setup and running in IIS, and that it points to a valid mail server. See Enabling
email notification on page 105.

Setting up an additional site
After installing Ektron, it is easy to create another site. While creating the new site, you
can create a sample or minimal site and database. To create a site for your content, you
typically install a minimal site and database, then create your Web page templates.
Later, add users and content.
1. Set up New Site.
a. Create a new folder in the Web root folder to contain the site files.
b. From the Windows Start menu, choose Start > Programs > Ektron >
CMS400 > Utilities > SiteSetup.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then
enter CMS400 Site Setup. Right click and choose Run as Administrator.
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c. Follow the steps for creating a new site, as described in Installing a site on
page 17. When prompted to select a folder to which you want to install the
files, choose the folder you created in Step 1.
2. Set up New Database. After installing an Ektron site, it is easy to create a new
database. You can create either a sample or minimal database. When creating a
database for your content, you typically install a minimal database.
a. From the Windows Start menu, choose Start > Programs > Ektron >
CMS400 > Utilities > SiteSetup .
If you're using Windows 8 or 2012, press the Windows key ( )/Q then
enter CMS400 Site Setup. Right click and choose Run as Administrator.
b. On the Setup Type screen, choose CMS400 Database Setup.

c. Follow the steps for creating a new database, as described in Setting up a
database on page 24.
3. Create Project in Visual Studio.NET. To work with the new site in Visual Studio.NET,
you must create a new project for it. To do that:
a. Go to the folder that contains the new site.
b. Double click Ektron’s solution file. If you are using the minimal database, the
file is CMS400Min.sln.
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At this point, you can build the project and log in. If you cannot log in because
you have not set up the license key, use the builtin account: by default, the
username is builtin and password is builtin.
IMPORTANT: You should only use the builtin account temporarily. As soon
as possible, you should insert the license key and log in under a user name
assigned in Ektron.
To learn about creating templates and using server controls, see Ektron Server
Controls.

Supporting multi-site configurations
Ektron’s multi-site support lets you set up and manage several websites under one
CMS. (The multi-site support feature does not support multiple databases.) You
manage content in the additional sites the same way you work with content in the root
site. You log into a root site then begin editing content in an additional site. Regardless
of which site you are using, you can use the library to insert common hyperlinks,
images, files, and quicklinks.
IMPORTANT: Place any file (such as an XSLT file) that needs to be shared among
sites in a multi-site environment in a virtual folder. Also, you cannot create a
quicklink within content, a collection, menu, and so on to a form that resides in
another site.
PREREQUISITES
l

All sites reside on the same server.

l

Each site has a multi-site license key. To purchase additional licenses,
contact Ektron sales.

Advantages of multi-site configurations:
l

l

The URL can indicate the nature of the site to visitors
o www.example.com
o

support.example.com

o

forums.example.com

All sites can share a single database
o common content, but appear within their own site and templates
o

a shared library of images and files. These files can be stored once; authors
can insert them into content from any site.

In the Workarea, sites appear in Ektron’s folder structure with a globe icon.
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A folder to which a production domain is assigned is a domain folder. Links to content in
a domain folder are activated via linkit.aspx, which redirects to the appropriate
domain name using the appropriate template for the folder or content.

Best practices for working in a multi-site environment
BEST PRACTICES
IMPORTANT: Do not remove your root site!
l

l

Log into the root site before working with the root site or any secondary site.
o Exception: If you are a content author, log into the site for which you are
authoring content.
Do not log into a secondary site then add files to a different secondary site.

There are 2 ways to install multi-site support. (The automatic setup is easy to use and
minimizes issues.)
l

Automatic multi-site setup below

l

Setting up Ektron on page 71

Automatic multi-site setup
IMPORTANT: Before creating a multi-site configuration, you must have installed an
Ektron website. All installed folders must remain in that site. The original site cannot
have virtual folders. Also, you cannot nest a multi-site under another IIS site.
1. Create each new site in IIS. See http://www.iis.net/learn/manage/creatingwebsites.
2. Run the Multi-Site Setup Wizard.
a. Double click C:\Program Files
(x86)\Ektron\CMS400vxx\Utilities\MultiSiteInstall\Multisite.exe.
b. Use the pulldown to select the site you created in Step 1.
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c. Select your host.

d. Enter a path to the new site.

e. Identify your main website; that is, the site to which this multi-site is being
added.
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f. When prompted to add a multi-site key, click Yes.
g. Enter a license key for the new site. This step copies the new site's license keys
to the database.
h. Enter information about the new site's database.
i. Follow the remaining screens in the wizard.
3. Assign multi-site capabilities in Ektron.
a. Log in the Workarea.
b. Click Content.
c. Click the site root folder.
NOTE: Site folders must reside within the site root folder.
d. On the View Contents of Folder screen, create a new top-level site folder for
each site by choosing New > Site.
e. Assign site folder properties as you did for the root folder. The Multi-site
Configuration fields appear on the lower section of the screen.
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f. In the Staging Domain field, insert your staging domain.
IMPORTANT: Production and staging URLs must be unique across multisites. In other words, in a multi-site configuration, one site's production or
staging URL cannot be the same as another site‘s production or staging
URL.
g. In the Production Domain field, insert your production domain.
h. Click Add Folder. Within Ektron, new sites are indicated by a globe icon.

Creating multiple websites on a single server
NOTE: This text is adapted from Microsoft’s IIS help.
IIS lets you create multiple websites on a single server.

Before adding a website
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Adding a website to a server requires careful preparation before running the Website
Creation Wizard. Consider these recommendations.
l

Review the methods of hosting multiple websites, and determine which one is
appropriate for your environment.

l

Multiple websites can use the same IP address. But if you decide to use a unique IP
address for the new website, obtain a static IP address from your organization or
ISP. Then, configure the server’s TCP/IP settings.

l

If you use a host header name to identify the new website, select a unique name.
On a private network, the host header can be an intranet site name. But on the
Internet, the host header must be a publicly available Domain Name System (DNS)
name, such as support.microsoft.com. Register a public DNS name with an
authorized Internet name authority.

l

Update your name resolution system (typically DNS) with a new record that
contains the new IP address and site name. For more information, see Domain
Name Resolution in IIS help.

l

Standard Internet services use TCP port 80 by default. It is not recommended to
use any other port for HTTP services.
If you use a non-standard TCP port number to identify a new website for special
situations (such as a private website for development/testing), select a TCP port
number above 1023. In this way, the number does not conflict with well-known
port numbers assigned by the Internet Assigned Numbers Authority. (For more
information about IANA and port assignments, see List of TCP and UDP port
numbers.)

l

Use Windows Explorer to create a home directory for the content. Create
subdirectories to store HTML pages, image files, and other content as needed.
To organize home directories for multiple websites on one server, create a toplevel directory for all home directories, then subdirectories for each site.
You can create a home directory
o

on the local server

o

as a uniform naming convention (UNC) path on a network share

o

as a URL that redirects clients to a different Web server

You can also create virtual directories that map to physical directories. For more
information, see “Setting Home Directories” and “Using Virtual Directories” in IIS
help.
l

Determine whether to generate the website’s identification number incrementally
or from the website name.

l

Create a home page that clearly identifies the new site.

Adding a website
IIS provides 2 methods for adding a new website.
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l

The Website Creation Wizard

l

The iisweb.vbs command-line script

IMPORTANT: You must be a member of the Administrators group on the local
computer to perform the following procedure (or procedures), or you must have
been delegated the appropriate authority. As a security best practice, log on to your
computer using an account that is not in the Administrators group, and then use the
Run as command to run IIS Manager as an administrator. From the command
prompt, type runas /user:administrative_accountname "mmc
%systemroot%\system32\inetsrv\iis.msc".

Using IIS 7's website creation wizard
1. In IIS Manager, expand the local computer, right-click the Sites directory, and
click Add Web Site.
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2. Click Next. The following dialog appears.
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l

Site Name. Enter the website name.

l

Application Pool. Click Select if you want to select a different application
pool than the one listed in the Application Pool box. If you do, the Select
Application Pool dialog box appears. Select an application pool from the list
and then click OK.

l

Physical path. Enter the physical path to the website's folder. Or, click the
browse button (...) to go the file system and find the folder.If the physical path
that you enter is to a remote share, click Connect as... to specify credentials
that have permission to access the path. If you do not use specific credentials,
select the Application user (pass-thru authentication) option in the Connect
As dialog.

l

Type. Select the protocol for the website from the Type list.

l

IP Address. The default value in the IP address box is All Unassigned. If
you must specify a static IP address for the website, type the IP address in the
IP address box. All Unassigned refers to IP addresses assigned to a
computer but not a specific site. The default website uses all IP addresses not
assigned to other sites. Only one site can be set to use unassigned IP
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addresses for a given port number. For more information on how sites are
identified, see Creating Multiple FTP Sites in IIS help.
l

Port. Enter a port number. The TCP port is assigned to port 80 by default. To
use a nonstandard port number to create a unique identity for a private
website, enter a new port number above 1023.

l

Host name. Optionally, enter a host header name for the website.If you are
adding additional sites to a single IP address by using host headers, you must
assign a host header name containing the full name of the site, for example,
world.optimizely.com/ektron/.

l

Start website immediately. Check this box if you do not have to make any
changes to the site and want it to be immediately available.

Adding a website with a command line script in IIS 7
To add a site, use the following syntax:
appcmd add site /name: string /id: uint /physicalPath:
string /bindings: string

The variable namestring is the name, and the variable iduint is the unsigned integer
that you want to assign to the site. The variables namestring and iduint are the only
variables that are required when you add a site in Appcmd.exe.
NOTE: If you add a site without specifying values for the bindings and
physicalPath attributes, the site will not be able to start.
The variable physicalPathstring is the path of the site content in the file system.
The variable bindingsstring contains information that is used to access the site, and it
should be in the form of protocol/IP_address:port:host_header. For example, a
website binding is the combination of protocol, IP address, port, and host header. A
binding of http/*:85: enables a website to listen for HTTP requests on port 85 for all IP
addresses and domain names (also known as host headers or host names). On the
other hand, a binding of http/*:85:marketing.contoso.com enables a website to
listen for HTTP requests on port 85 for all IP addresses and the domain name
marketing.contoso.com.
To add a website named contoso with an ID of 2 that has content in c:\contoso, and
that listens for HTTP requests on port 85 for all IP addresses and a domain name of
marketing.contoso.com, type the following at the command prompt, and then press
Enter.
appcmd add site /name: contoso /id:2 /physicalPath: c:\contoso /bindings:http/*:85:
marketing.contoso.com

See also: Appcmd.exe (IIS 7).

Balancing the load on your servers
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Load Balancing has 2 purposes:
l

Provides redundancy for your website—if one server fails, a second can handle
requests

l

Balances requests—distributes requests across multiple servers

To enable load balancing, set up several servers that include the same files.
IMPORTANT: The physical path to the Ektron website must be the same on all load
balanced servers. Also, sticky sessions must be enabled.
Purchase load balancing equipment to evenly distribute content requests among
servers. Then, whenever an image or file is uploaded, regardless of the Web server the
user is working on, the asset is replicated on all servers.
The client browser is unaware that more than one server is involved. All URLs point to a
single website. The load balance software resolves them.
Ektron provides different strategies for load balancing library images and files and DMS
assets. See also: eSync in a load-balanced environment on page 2022.

Load-balancing library images and files
Library load balancing is important when your configuration consists of 2 or more
websites that share one database. When uploaded, library files are saved to the site
root folders uploadedfiles and uploadedimages.
To support load balancing, library files on all servers must be identical. To maintain this
state, whenever a user uploads a library item, it is copied to the corresponding folder on
other servers in the configuration.
1. Open the file C:\Program Files
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.EktronServices40.exe.
config using a word processor such as Notepad.
2. Set the value of the LibraryLoadBalanced property to 1.
3. Set the value of the AssetsLoadBalanced property to 1.
4. Set the value of the LoadBalServerCount property to the number of servers in
your load balance cluster.
5. Save the config file.
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6. Restart the Ektron Windows Service.

See also: Handling background processing functions with the Ektron Windows Service
on page 136.

Load-balancing assets
Asset load balancing is important when your configuration consists of 2 or more
websites that share one database. To balance requests to work with assets across
multiple servers, Ektron ensures that each server in the configuration has a copy of
every asset.
So, after setting up asset load balancing, any asset added to one server is copied to the
corresponding folder on the other servers in the configuration. There is no limit to the
number of servers that can be load balanced.
To set up load balancing for assets, follow these steps on all servers in the load balance
configuration.
1. Within the /siteroot folder, open the AssetManagement.config file using a word
processor such as Notepad.
2. Change the value of the LoadBalanced element to 1.
3. Save the file.
4. Open the following file using a word processor such as Notepad:
C:\Program Files (x86)\Ektron\EktronWindowsservice40\
Ektron.ASM.EktronServices40.exe.config
5. Set the value of the LibraryLoadBalanced property to 1.
6. Set the value of the LoadBalServerCount property to the number of servers in
your load balance configuration.
7. Save the config file.
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8. Repeat steps 1 through 7 on each server in the load balance cluster.
9. Log on to Ektron. This action sets up the load balance software in the database.

Refreshing load-balanced files
PREREQUISITES
l

You must be a member of the Administrators group to access the Load
Balancing screen.

l

Your Ektron license key contains a load balance component

Asset and Library files may become out-of-date or lost due to equipment failures, power
outages, or other events. You Load Balance software may have the ability to sync these
files.
Ektron also provides a screen which ensures that all files in the DMS Assets folders and
the Library Files and Images folders are identical across the servers in the
LB configuration. In addition, the Refresh screen ensures that the contents of the
siteroot\Templates and siteroot\Workarea folders are identical across servers.
NOTE: For load balancing refresh to work properly, open Port 8732 on load balanced
servers.
To refresh load balanced files:
1. Workarea > Settings > Configuration > Load Balancing.

102

Ektron 9.40 SP1

Load-balancing status

2. Click Start. A status screen appears.

3. Verify that the status screen shows servers you expect to be refreshed. Server
name WS10155 is circled in the example.
IMPORTANT: If you click Start and the screen quickly returns and files do not
refresh, or if a server is missing from the status list, check Load Balancing
settings in Ektron.ASM.EKtronServices40.exe.config.
4. When finished viewing the status, click Close.

Load-balancing status
PREREQUISITES
l

You must be a member of the Administrators group to access the Load
Balancing screen.

l

Your Ektron license key contains a load balance component

To check the load balancing status:
1. Workarea > Settings > Configuration > Load Balancing.
2. Click the toolbar button ( ). The status screen shows either the previous refresh
or the current refresh in progress

Setting up a user for the Ektron database
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The installation automatically sets up user permissions based on data collected during
setup. However, if you have issues with user permissions, this section describes how to
install manually.
NOTE: If you are using SQL Authentication, you only need to set up the SQL user. If
you are using Windows Authentication, you need to set up IUSR and an IIS_WPG or
Network Service user.
1. In the SQL Server Management Studio, select Security > Logins.
2. Right click and select New Login.
3. On the Login dialog, click Search to the right of the Login name field. Network
Service
4. Select your server.
5. Enter ASPNET, IIS_WPG, or Network Service user (depending on your
Windows version).
6. Click Add then OK.
7. Select your Ektron database. Then, assign permission to read and write to that
database.
8. Run the grant permission script.
NOTE: Before doing this, review your users and their permissions. Adjust as
necessary for your configuration. Also, if you use Windows Authentication and
all users are domain users (and the database administrator wants it this way),
you may not have to perform this step.
a. Open SQL Server Profiler.
b. Choose File > Open.
c. Open C:\Program Files
(x86)\Ektron\CMS400vnn\Utilities\SiteSetup\Database\cms400_
permissions.sql. (nn represents the release number)
d. Within that file, replace [MACHINENAME or DOMAINNAME\USERNAME] with your
domain name, backslash (\), and ASPNET (the ASP.NET machine account). For
example, [ws10080\ASPNET].
NOTE: If you are using Microsoft Windows 2003 Server or Microsoft
Widows Vista, the user is IIS_WPG. For example, [ws10080\IIS_WPG]. If
you are using Microsoft Windows 2008 Server, the user is Network
Service.
e. Click Execute Query (

).

f. Replace the text between square brackets with your domain name, backslash
(\), and the IIS Internet Guest Account. For example, [ws10080\IUSR_
ws10080]. Click Execute Query ( ).
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g. If using SQL server authentication, replace the text between square brackets
with the SQL server authentication name only. Do not include the domain
name. Click Execute Query ( ).

Enabling email notification
Microsoft’s SMTP service can be set up to send an email that notifies a user when a task
(such as approving a content block) was performed or needs to be performed. This
section explains how to enable email notification in Ektron.
To process email, Ektron uses CDOSYS. Using Simple Mail Transport Protocol (SMTP)
and the Network News Transfer Protocol (NNTP) standards, CDOSYS enables Windows
applications to route email and USENET-style news posts across multiple platforms.
CDOSYS lets authors create and view sophisticated emails using HTML and data
sources.
NOTE: If CDOSYS is not installed on the SMTP email server, it tries to use the
CDONTS mail server protocol.
For CDOSYS to work, set up the SMTP server on your Ektron server or a remote system
that sends and receives email. It is good practice to run SMTP on a server separate
from your Ektron server. However, your Ektronserver must relay email messages to
your SMTP server.
NOTE: To access an SMTP server on a local or remote system, consult your
organization's email administrator.
l

Local. Before setting up an SMTP server locally, install IIS. Below are examples of
SMTP server settings on a local system.
“ek_SMTPServer" value=“localhost”
“ek_SMTPServer" value=“127.0.0.1”
“ek_SMTPServer" value=“myname”

l

Remote. Set up an SMTP server on a remote system. Below are examples of SMTP
server settings on a remote system.
“ek_SMTPServer" value=“smtp.example.com”
“ek_SMTPServer" value=“example.com”

Use this article to configure SMTP in IIS7: Configuring SMTP E-mail in IIS 7.
Next, configure Ektron to use SMTP.
1. Open the siteroot/web.config file.
2. Find the section with these settings.
<!-<add
<add
<add
<add
<add

SMTP Server configuration -->
key="ek_SMTPServer" value="localhost" />
key="ek_SMTPPort" value="25" />
key="ek_SMTPUser" value="" />
key="ek_SMTPPass" value="" />
key="ek_SMTP_EnableSsL" value="" />
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3. Set the ek_SMTPServer value.
4. Set ek_SMTPPort to the port your system will access to retrieve email. In most
cases, the port is 25. If that is not the case, consult your organization's email
administrator.
5. Set ek_SMTPUser to the username that is set up for the SMTP server to send and
receive email. Typically, the username is an email address, such as
"ek_SMTPUser" value="yourname@example.com".
This retrieval of email is based on how basic authentication is set up for you. You do
not need a username when using a local SMTP server. Check with your system
administrator for details. If you are using a remote system for accessing email, you
must provide an authenticated username before you can send or receive email.
6. Set ek_SMTPPass to the password set up for the SMTP server to send and receive
email. This password is based on basic authentication. Ektron only accepts
encrypted passwords.
7. To encrypt the password, use Ektron's password encrypting tool.
a. Open C:\Program Files (x86)\Ektron\CMS400vxx\Utilities
b. Run EncryptEmailPassword.exe. The Encrypt Utility dialog appears.

c. Enter your SMTP password in the Text field.
d. Click Encrypt. The screen displays an encrypted password.
e. Copy the encrypted password and paste it into the web.config file's "ek_
SMTPPass" value.
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8. Set ek_SMTP_EnableSsL to true.
9. Set IP Address and Domain Restrictions by following these steps. See
also: https://portal.ektron.com/kb/10234/.
a. On your Web server, open IIS.
b. Click your website > workarea > services.
c. Click IP Address and Domain Restrictions in the right pane.
NOTE: If you do not see this option, enable it through your server's Roles,
or by adding it as a Windows feature.
d. Click Add Allow Entry for IP addresses or the IP address range that will
connect to the server to access the services APIs. Add all IPs for each server,
not just the primary.

e. Repeat steps b-d for the workarea > webservices folder and the
/workarea/ServerControlWS.asmx file.
NOTE: To access the features for the ServerControlWS.asmx file:
1. Right click the Workarea folder and select Switch to Content View.
2. Locate the ServerControlWS.asmx file.
3. Right click the file and select Switch to Features View.
4. Open the IP Address and Domain Restrictions feature.

Using Google as an SMTP server
If you want to use smtp.google.com as an SMTP server, use TLS encryption and port
587.
You cannot use implicit SSL. This is because .Net Framework does not support implicit
SSL which, by default, uses port 465. See also: SmtpClient.EnableSsl Property.

SMTP error messages
When submitting content to an approval process, if you get an error message listed
below, it is generated by the SMTP server on which you set up the mail system, not by
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Ektron.
l

The Transport failed to connect to the server. [CBR SendMail R1] [CBR R65] [DIO R
36]

l

The server rejected one or more recipient addresses. The server response was:
550 5.7.1 Unable to replay for yourname@example.com [CBR SendMail R1] [CBR
R1] [DIO R36]

Automatic email notification
Ektron's automated system sends email to users when an action has been, or needs to
be, performed. See also: Customizing Ektron email with tokens below.
Email is generated when any of the following content actions takes place.
l

Submitted to be published—email sent to next approver

l

Submitted to be deleted—email sent to next approver

l

Published to website—email sent to author

l

Declined to be published or deleted—email sent to author

To be notified of these actions, the following must be set:
l

In the Application Setup screen
o a valid System E-Mail Address was entered
o

the Enable Sending of System Notification Email box is checked
See also: General tab on page 129.

l

In the Edit User screen, for each user to receive notification email
o a valid E-Mail Address was entered
o

the Disable Receiving of Workflow and Task Email box is unchecked
See also: Managing users and user groups on page 1555.

The Tasks feature also has automatic email notification. See Setting up task types and
categories on page 1453.

Customizing Ektron email with tokens
Ektron can send email notification to users, informing them that actions have taken
place or are requested of them. For example, a content contributor receives an email
that the contributor's content was published. These emails are stored in resource files,
where each email consists of one string for the subject and one for the body. To learn
about editing the resource file, see Translating the Workarea on page 1548.
Each message is called in the presentation layer by its message title. Ektron does not
support HTML email, however the message text is fully customizable.
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The body of an email can include tokens, located between @ symbols. Ektron replaces
them with the information for that instance of the email. For example,
@appContentTitle@ in the following sentence is replaced with the email’s title.
l

Before: The content “@appContentTitle@” has been deleted.

l

After: The content “Home Page Content” has been deleted.

You can customize the emails, move the tokens, add text, rewrite and reorganize.
l

Before: “@appContentTitle@” has been deleted from the XYZ website.

l

After: “About Us” has been deleted from the XYZ website.

Carriage Return/Line Feeds are represented by @appCRLF@. These cause the email to
move down one line. For example:
l

Before: The content was approved.@appCRLF@Thank you!

l

After: The content was approved.
Thank you!

Ektron email tokens
Ektron email tokens are specialized for the type of email message you need to send.
l

Notify CMS users
o @appApprovalList@. The current approval list that the content block must
pass through.
o

@appChangeDateTime@. The date and time changes will be updated on the
website.

o

@appComment@. Displays the comments for the content block.

o

@appContentLink@. The link to the content block on the website.
NOTE: You must be logged in to see the changes.

o

@appContentTitle@. The title of the content block.

o

@appCRLF@. A carriage return.

o

@appDeclinerFirstName@. The first name of the user who declined the
content block.

o

@appDeclinerLastName@. The last name of the user who declined the
content block.

o

@appDeletionDateTime@. The date and time the content will be deleted
from the website.

o

@appEmailFrom@. The address of the email sender.

o

@appEmailTo@. The address of the email recipient.

o

@appFolderPath@. The location of the content block in the Ektron folder
tree.
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l

l

o

@appPassword@. Displays the account password for ResetPassword and
RequestResetPassword message types.

o

@appSubmitterDateTime@. The date and time the content block was
submitted.

o

@appSubmitterFirstName@. The first name of the user who submitted the
content block.

o

@appSubmitterLastName@. The last name of the user who submitted the
content block.

Notify discussion board users—Discussion board email.
o @appForumUrl@. The forum’s URL.
o

@appHostUrl@. The host site’s URL.

o

@appPosterDisplayName@. The display name of the person who posted.

o

@appPosterId@. The integer ID of the person who posted.

o

@appPosterProfileUrl@. The profile URL for the person who posted.

o

@appPostMessage@. The text of the message posted to the discussion
board.

o

@appPostUrl@. The URL of the post on the website.

o

@appRecipientDisplayName@. The display name of the email recipient.

o

@appRecipientEmail@. The email address of the email recipient.

o

@appRecipientFirstName@. The first name of the email recipient.

o

@appRecipientId@. The email recipient’s integer ID.

o

@appRecipientLastName@. The last name of the email recipient.

o

@appTopicId@. The integer ID of the topic.

o

@appTopicTitle@. The title of the topic.

Invite users to participate in a community group—Community group email.
l @appFriendDisplayName@. The recipient's name.
l

@appFromUserDeleted@. Token message is from a user that was deleted.

l

@appFromUserDisplayName@. The name of the user from whom the
private message was sent.

l

@appFromUserID@. The ID of the user from whom the private message was
sent.

l

@appGroupName@. The group a person is being invited to join.

l

@appInvitedEmail@. The recipient's email address.

l

@appInviteId@. Appends the invite ID to the registration URL. For example:
Click <a href=http://www.example.com/register.aspx&fInvId=
@appInviteId@>here</a> to accept.

l
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l

l

@appOptionalText@. Text a user types into the Optional Message box on
the Invite server control.

l

@appPrivateMessageID@. The CMS ID for the particular private message.

l

@appSenderName@. The sender of the invitation.

l

@appSubject@. The Subject field of the private message.

l

@appToUserDisplayName@. The name of the user receiving the message.

l

@appToUserID@. User ID of the user receiving the message.

l

@appToUserMessageID@. The CMS ID of the recipient's message object.

Notify a subscription list of users through a Web Alert—Web alert email.
o @appComment@. The comments for the content block.
o

@appContentLink@. The link to the content block on the website.
NOTE: You must be logged in to see the changes.

o

@appContentTitle@. The title of the content block.

o

@appContentURL@. The URL of the content, from the quicklink and domain.

o

@appCRLF@. A carriage return. Moves text down one line.

o

@appSubmitterFirstName@. The first name of the user who submitted the
content block.

o

@appSubmitterLastName@. The last name of the user who submitted the
content block.

o

@appSubscriptionNames@. Comma separated list of subscriptions that a
user selected.
You can insert these membership tokens into the confirmation message.
n

@appActivateId@. Account ID

n

@appAvatar@. Avatar

n

@appDisplayName@. Display name

n

@appEmail@. email address

n

@appFirstName@. First name

n

@appLastName@. Last name

n

@appSignature@. Signature

n

@appUserName@. UserName

email notification tokens
The list shows tokens you can use to customize email messages. When the email is
sent, the corresponding description replaces the token.
l

@appApprovalList@. The current approval list that the content block must pass
through.
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l

@appChangeDateTime@. The date and time changes will be updated on the
website.

l

@appComment@. Displays the comments for the content block.

l

@appContentLink@. The link to the content block on the website.
NOTE: You must be logged in to see the changes.

l

@appContentTitle@. The title of the content block.

l

@appCRLF@. A carriage return.

l

@appDeclinerFirstName@. The first name of the user who declined the content
block.

l

@appDeclinerLastName@. The last name of the user who declined the content
block.

l

@appDeletionDateTime@. The date and time the content will be deleted from
the website.

l

@appEmailFrom@. The address of the email sender.

l

@appEmailTo@. The address of the email recipient.

l

@appFolderPath@. The location of the content block in theEktron folder tree.

l

@appPassword@. Displays the account password for ResetPassword and
RequestResetPassword message types.

l

@appSubmitterDateTime@. The date and time the content block was submitted.

l

@appSubmitterFirstName@. The first name of the user who submitted the
content block.

l

@appSubmitterLastName@. The last name of the user who submitted the
content block.

Default Ektron email messages
The following messages are used if basic workflow is applied to content. To view the
messages with advanced workflow, see Notifying users of advanced workflow activities
on page 768.
l

Approved Content Awaiting Go Live Date
Message Title: content changes approved.
Message Text: Content changes have been approved.

l

Approved Content Published Immediately
Message Title: content has been changed.
Message Text: Content changes have been made.

l

Decline Approval Request
Message Title: approval request declined.
Message Text: Content approval request declined.
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l

Deletion of Content Approved
Message Title: content deletion approved.
Message Text: Deletion of content has been approved.

l

Immediate Deletion of Content
Message Title: content has been deleted.
Message Text: Content has been deleted.

l

Send Approval Message
Message Title: request for approval.
Message Text: Request for content approval.

Sending instant email
In addition to automatic email, Ektron lets you email a user or user group from many
screens. An email icon ( ) next to a user or group name or on the toolbar indicates
your ability to do this. Screens in the following features support instant email.
l

Tasks

l

Approvals

l

Reports

l

User groups

When you click one or more user/group names then the toolbar's email icon, a screen
appears.
NOTE: The email software must be configured for your server. See Enabling email
notification on page 105.
When the email screen appears, the following information is copied from Ektron into the
email.
l

To. User you selected to receive email. If the user does not have a valid email
address, an error message appears. If you then insert a valid address, the email is
sent. If you specify a group to receive the message, as long as one group member
has a valid email address, all group members with valid addresses receive the
email. You can edit and add recipients.

l

From. User signed on to Ektron. You cannot edit this field.

l

Subject. If the email message is linked to content, its title appears. You can edit
this field.

l

Body of message. If the email message is linked to content, a content link
appears. You can edit this field.

Managing logins and passwords
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This section describes how to log in and out, restrict login attempts, and manage
passwords.

Logging into an Ektron website
PREREQUISITE
l

URL (Web address) of your website. Your system administrator provides this.

l

Username and password

To log into an Ektron site:
1. In a Web browser, enter the URL of your Ektron website.
2. Click the Login button. The Login dialog box appears.

3. Enter your username and password.
If you are using an Ektron sample site, you can use any of 3 standard users that
demonstrate Ektron’s flexible user-permissions model.
l

Administrator. Username: admin; Password: ????; Permissions: All
NOTE: When Ektron is installed, you are prompted to change the admin
user's name and password.

l

Standard user. Username: jedit; Password: jedit; Permissions: Basic (for
example, add/edit content, manage library files, and so on)

l

Membership user. Username: jmember; Password: jmember; Permissions:
Read-only permission to private content

4. Click the Login button. The Web page appears. See also: Managing content on
page 645.
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Logging out
1. Click Logout from the content menu, or on the Web page. The Logout confirmation
box appears.

2. Click Logout. You return to the Web page from which you logged out. However, it
is in standard view, not Ektron view.

Restricting login attempts
Ektron can lock out a user after 5 unsuccessful attempts to log into one computer. You
control login security via the ek_loginAttempts element in the siteroot/web.config
file.
Possible values for ek_loginAttempts.
l

1 through 254. The number of unsuccessful login attempts after which a user is
locked out

l

0. Lock out all users

l

-1. Disable feature; unlock all locked users

l

-2. Lock out Ektron users only; membership users can log in

If a user unsuccessfully tries to log in more than the specified number of times, an error
appears: The account is locked. Please contact your administrator. After that
happens, even if the user enters the correct password, the user is locked out.
NOTE: You can change the error message text in the resource file. See also:
Translating the Workarea on page 1548.

Unlocking a locked account
When an account is locked out, the Account Locked field is checked on the Edit User
screen.
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To unlock the account, an administrator user (or a user assigned to the User Admin
role) accesses the Edit User screen and unchecks the box. At this point, the user can
login.
NOTE: To unlock all users, open siteroot/web.config and set ek_login Attempts
to -1.

Manually locking a user from logging on
You can use the Account Locked field to manually lock a user out of Ektron.
1. In the Workarea, go to Settings > Users.
2. Click the user then Edit.
3. Check the Account Locked field.
That user cannot login until either you uncheck the box or open siteroot/web.config
and set ek_login Attempts to -1.

Preventing Ektron users from logging on
To lock out all Ektron users, open siteroot/web.config and set ek_login Attempts to 2. If you do, only membership users can log in.
NOTE: The builtin user cannot log in if ek_loginAttempts is set to -2.

Preventing all users from logging on
To lock out all users (including membership users), set the ek_loginAttempts element
in the web.config file to 0. If you do, no one can log in to Ektron until you change the
value.
NOTE: The builtin user cannot log in if ek_loginAttempts is set to 0.

Changing images used for logging in and out
You can change the images used for the login and logout buttons. To do so:
1. Move the new images to the following folder:
siteroot\Workarea\images\application.
2. Open the web.config file in your website’s root directory.
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3. Change the images in this section of the file:
<add key="ek_Image_1" value="btn_close.png" />
<add key="ek_Image_2" value="btn_login.png" />
<add key="ek_Image_3" value="btn_login_big.png" />

NOTE: You must update the images and web.config whenever you upgrade
Ektron.

Resolving a problem with the login screen
You may find that in certain browsers, the login screen occupies the entire browser
window instead of just a small box. Browsers such as Internet Explorer 8 and Firefox
have a feature called tabs. When the login window pops up, it may appear as a new tab.
You can change this behavior by turning off tabs within the browser.

Managing passwords
This section explains various aspects of managing passwords.

Editing the builtin username and password
WARNING! Use the builtin user only to correct a bad or expired license key. It is not
designed for regular Ektron operations, such as editing content.
The builtin user is an emergency user to use if you cannot log into Ektron. The builtin
user can log in to Ektron whether or not Active Directory or LDAP is enabled.
If you log into the Workarea as the builtin user, you can access only the following
screens on the Settings tab.
l

Active Directory

l

Asset Server Setup

l

Setup

l

User

l

User Group

If the builtin user password was changed and you don’t know it, you cannot log in. In
this case, use the BuiltinAccountReset.exe utility, which resets the username/password
to builtin/builtin. This utility is located in C:\Program Files
(x86)\Ektron\CMS400versionnumber\Utilities.
The builtin username and password are entered during installation. You can change
them on Ektron's setup screen.
PREREQUISITE

You are a member of the Administrators group.
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1. From the Workarea, choose Settings > Configuration > Setup. The Application
Setup screen appears.
2. Click Edit.
3. Locate the Built In User fields.
4. Change the username or password or both.
5. Click Update.

Ektron's password security policy
If you use the Workarea or the API to add a CMS or membership user, or if you change
an existing user's password, Ektron enforces a security policy. By default, the policy
enforces these criteria:
l

at least 5 alphabetical and numeric characters

l

at least one uppercase letter

You can modify the criteria by editing the Regex Expression tab on the Application
Setup screen. See also: Password Regex tab on page 133.
IMPORTANT: This policy is new as of Ektron Release 9.10. If you upgrade from an
earlier version, this policy does not affect existing users' passwords.

Enforcing a password change every 90 days
Ektron has a security feature that forces an administrator or user with the Commerce
Admin role to change the password at least every 90 days. This feature is only enabled
if the ek_ecom_ComplianceMode key in the site’s web.config file is set to true.
If such a user goes 85 days without changing the password, a dialog appears upon login, asking to change the password. If the user does not want to, click Skip. The user
can repeat this for the next 5 days. After 90 days since the password was entered, the
user must enter a new password before he or she can log in.

Enforcing log in after time of inactivity
Ektron has a password security feature that automatically logs out an administrator or
user with the Commerce Admin role after 15 minutes of inactivity. Activity is based on
requests made to the server.
This feature is enabled if the site’s web.config file‘s ek_ecom_ComplianceMode key is
set to true. In addition, if you are using IIS7, the <add name="EkUrlAliasModule"...
line in the following code needs to appear between the <modules> tags in the
web.config file. This line is a part of the default install—make sure it has not been
removed.
<modules>
<add name="MyDigestAuthenticationModule"
type="Ektron.ASM.EkHttpDavHandler.Security.DigestAuthenticationModule,
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Ektron.ASM.EkHttpDavHandler" />
<add name="ScriptModule"
type="System.Web.Handlers.ScriptModule, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode" />
<add name="EkUrlAliasModule" type="UrlAliasingModule"
preCondition="integratedMode" />
</modules>

Enforcing a minimum password
Ektron has a password security feature that forces an administrator or user with the
Commerce Admin role to use at least 7 characters in a password. Further, the password
must contain at least one alphabetic and one numeric character.
This feature is enabled only when the ek_ecom_ComplianceMode key in the site’s
web.config file is set to true.

Enforcing a no-match password
Ektron has a security feature which ensures that when an administrator or user with the
Commerce Admin role enters a new password, it does not match that person's previous
4 passwords. This feature is enabled only if site’s web.config file has the ek_ecom_
ComplianceMode key is set to true.
You can set ek_ecom_PasswordHistory to a number higher than 4 if you want a higher
level of security. If you set this key to less than 4 and the ek_ecom_ComplianceMode
key is set to true, Ektron enforces 4.

Creating a custom password strategy
The Ektron password validation provider lets developers create custom password
validation strategies. These providers can enforce custom password rules inside the
system, beyond the out-of-box capabilities.
This section explains how to create a custom password validation provider for Ektron.
1. Create a class library project in Visual Studio.
2. Import the namespaces you need. Add references to:
l Ektron.Cms.Commerce
l

Ektron.Cms.Common

l

Ektron.Cms.ObjectFactory

l

Microsoft.Practices.EnterpriseLibrary.Validation.dll

l

System.Configuration

l

Ektron.CMS.User
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l

Ektron.CMS.DataRW

l

Ektron.Cms.Contracts

3. Add the following using statements.
using
using
using
using
using
using
using
using
using
using
using

System;
System.Collections;
System.Configuration.Provider;
Microsoft.Practices.EnterpriseLibrary.Validation;
Ektron.Cms;
Ektron.Cms.Common;
Ektron.Cms.Commerce;
Ektron.Cms.Commerce.PasswordValidation.Provider;
System.Collections.Generic;
System.Text;
System.Text.RegularExpressions;

4. Change the namespace to Ektron.Cms.Extensibility.Commerce.Samples,
rename your class to CustomPasswordProvider, and inherit from the
Ektron.Cms.Commerce.PasswordValidation.Provider.PasswordValidationPr
ovider class and the Ektron.Cms.Commerce.IPasswordValidation interface.
namespace Ektron.Cms.Extensibility.Commerce.Samples
{ public class CustomPasswordProvider :
Ektron.Cms.Commerce.PasswordValidation.Provider.PasswordValidationProvider,
Ektron.Cms.Commerce.IPasswordValidation

5. Add the following constructor.
#region constructor, member tokens
public CustomPasswordProvider() { }
#endregion

6. Add GetRegexFor methods required by the PasswordValidationProvider base
class. These methods return the RegExs that will validate passwords in Ektron for
specific user types.
l GetRegexForMember. Returns one or more regular expressions used for
client side validation of membership users, along with corresponding error
messages to be used when client-side validation fails.
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l

GetRegexForAuthor. Returns one or more regular expressions used for
client side validation of Ektron authors, along with corresponding error
messages to be used when client-side validation fails.

l

GetRegexForCommerceAdmin. Returns one or more regular expressions
used for client-side validation of eCommerce administrators, along with
corresponding error messages to be used when client side validation fails.

l

GetRegexForAdmin. Returns one or more regular expressions used for
client-side validation of Ektron administrators, along with corresponding error
messages to be used when client side validation fails.
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NOTE: This example enforces a minimal requirement for authors/members,
and adds a length and diversity requirement for administrators.
#region public methods
public override string GetRegexForAdmin()
{ return "[/.{7}/, Password must contain at least seven characters]
" + ",[/[0-9]+/,
Password must contain at least one number]
" + ",[/[a-zA-Z]+/,
Password must contain at least one alphabetical character]
" + ",[/^[^ \t'\"%#]+$/,
Password cannot contain spaces, tabs, single-quotes,
double-quotes, percent-signs, or pound-signs]";
}
public override string GetRegexForAuthor()
{ return "[/.{1}/, Password too short]" + ",[/^[^ \t'\"%#]+$/,
Password cannot contain spaces, tabs, single-quotes,
double-quotes, percent-signs, or pound-signs]";
}
public override string GetRegexForCommerceAdmin()
{ return "[/.{1}/, Password too short]" + ",[/^[^ \t'\"%#]+$/,
Password cannot contain spaces, tabs, single-quotes,
double-quotes, percent-signs, or pound-signs]";
}
public override string GetRegexForMember()
{ return "[/.{1}/, Password too short]" + ",[/^[^ \t'\"%#]+$/,
Password cannot contain spaces, tabs, single-quotes,
double-quotes, percent-signs, or pound-signs]";
}
#endregion

7. Implement the ValidateFor methods, which use the regexs to validate
passwords. We use the generic function Validate to which we pass parameters.
public override ValidationResults
ValidateForAdmin(string password)
{ return Validate(password, GetRegexForAdmin());
}
public override ValidationResults
ValidateForAuthor(string password)
{ return Validate(password, GetRegexForAuthor());
}
public override ValidationResults
ValidateForCommerceAdmin(string password)
{ return Validate(password, GetRegexForCommerceAdmin());
}
public override ValidationResults
ValidateForMember(string password)
{ return Validate(password, GetRegexForMember());
}
protected ValidationResults
Validate(string password, string regexErrorMessage)
{ ValidationResults results = new ValidationResults();
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string regex, errorMessage;
string[] parts;
string[] raw = regexErrorMessage.TrimStart('[').TrimEnd(']')
.Split(new string[] { "],[" }, StringSplitOptions.None);
foreach (string combined in raw)
{ parts = combined.Split(new string[] { "/," },
StringSplitOptions.None);
regex = parts[0].Trim('/');
errorMessage = parts[1].Trim().TrimStart('"').TrimEnd('"');
if (!Regex.IsMatch(password, regex))
{ results.AddResult(new ValidationResult(errorMessage,
this, "", "", null));
}
}
return results;
}

8. Tell the system whether to enforce password expiration on users. There are 2
requirements.
l PasswordExpirationEnabled. Enabled password expiration globally, which
allows the RequiresPasswordExpiration to be called.
l

RequiresPasswordExpiration. Returns whether password expiration is
enforced for a user.

NOTE: The system handles password expiration dates. Setting
PasswordExpirationEnabled and RequiresPasswordExpiration tells
Ektron to check and enforce those values.
public override bool PasswordExpirationEnabled()
{ return RequestInformation.CommerceSettings.ComplianceMode;
}
public override bool RequiresPasswordExpiration(long userId)
{ return (userId == 1);
}

9. Build the project, and copy the assembly to the Ektron site's bin directory.
10. Register the provider, and direct Ektron to use it. The siteroot/web.config file
lets you manage password providers within Ektron.
a. Locate the <passwordValidationProvider...> tag in the web.config file.
b. Add a reference to the class created earlier in the <providers> key.
c. Change the defaultProvider attribute, as shown below.
<passwordValidationProvider defaultProvider="CustomPasswordProvider">
<providers>
<add name="CustomPasswordProvider"
type="Ektron.Cms.Extensibility.Commerce.Samples
.CustomPasswordProvider, CustomPasswordProvider" />
</providers>

Logging in through Facebook
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Facebook Login, an alternative to Ektron's standard login, lets users log in using their
Facebook username and password instead of creating an Ektron username and
password. Here is an example of Facebook Login control.

This control lets Membership and Ektron users log into an Ektron website. If users have
an Ektron user profile, they can be prompted to link the Facebook username and
password with that profile.
Facebook Login allows log in only—it provides no other Facebook features, such as
viewing profiles or sending messages.
NOTE: The Facebook Login feature does not support Active Directory.
The OnTrek starter site includes a samples of a Facebook Login.
NOTE: The user experience is enabled only after a developer sets up the feature.
See also: Setting up Facebook login on the next page.
If a user clicks a Facebook Login button but is not logged into Facebook, the following
screen appears.

When you complete this screen or if you are already logged into Facebook, you are
forwarded to a page that prompts you to register with or log into Ektron.
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This screen asks if you have a membership account. If so, do you want to connect this
Facebook username and password with the Ektron account? If you agree, you will
access your membership account via the Facebook Login with Facebook credentials
from now on. If you do not have a membership account, complete the lower half of the
screen. This is the same screen that new members use to create Ektron accounts. From
then on, you can click the Facebook Login button to log into Ektron using a Facebook
username and password.
When you log out of Ektron, that action does not log you out of Facebook. Conversely, if
a user logs out of Facebook, you are not logged out of Ektron.
NOTE: Facebook often caches information in your browser. If you see JavaScript
errors or other odd behavior, clear the browser cache, close all browser windows,
and try again.

Setting up Facebook login
To set up the Facebook login feature:

Step 1: Connect Facebook to Your Ektron Website
Follow these steps to obtain Facebook keys, paste them into the web.config file, and
identify your site to Facebook.
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Step 1: Connect Facebook to Your Ektron Website

1. In you do not have one, create a Facebook account. Go to www.facebook.com and
follow the sign up instructions.
2. Log in to the Facebook Developer site.
3. Click +Create New App.
4. Enter an App Name and APP Namespace for your application. The name cannot
include facebook or any variations, such as FB. Click Continue. A new screen
appears, showing your App ID and AppSecret.

5. Open your website's root folder/web.config file.
6. Copy the Facebook keys into these web.config elements.
l APP ID. ek_FacebookApiKey
l

App Secret. ek_FacebookSecret

NOTE: Keys shipped in Ektron sample sites are for localhost. Also, make sure
the Facebook keys were generated for the host header/URL to which you're
applying them. And, if you are testing secure site setup, verify that the
web.config element ek_useSSL is true.
7. Save and close web.config.
NOTE: After you update web.config with Facebook keys, wait a few minutes
before logging into the Ektron site via the Facebook Login server control.
8. Return to the Facebook Basic screen.
9. Under Select how your app integrates with Facebook, click Website.
10. In the Site URL field, enter your website's URL.
l for a public site, enter its URL. For example, http://www.example.com.
l

for a shared server or if you are accessing the site from a remote machine, use
the IP address. As examples, http://192.168.14.10,
http://192.168.14.10/QA
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l

for a local server, use localhost. As examples, http://localhost,
http://localhost/EktronTech

11. Save and close the Facebook screen.
12. After setting up your application, you can return to this screen at any time to view
the keys, edit the Site URL, etc.

Step 2: Create or Modify a Facebook Login/Signup Page
A Facebook form appears if a user clicks a Facebook Login button and is not currently
logged into Facebook.

The form is created by Facebook, not Ektron. You can customize parts of it, such as the
title and site image, using Facebook's Application settings.
When the user completes the form, the user is forwarded to an Ektron form that
prompts the person to register or log in to Ektron.
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Step 2: Create or Modify a Facebook Login/Signup

You specify which form appears via the Facebook Login server control's
SignupTemplate property.
The logic to connect a Facebook user with an Ektron account (circled) is not part of the
Facebook Login server control. However, sample code for that functionality is included
in the Ektron Tech sample site's register.aspx page.
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Alternative to redirecting to the signup form
If you do not want to redirect the user to a signup form after Facebook login, you can
hook the Ektron_FacebookNewMemberLoggedIn JavaScript event and do whatever you
want with it. For example, you could raise a modal dialog with a short signup form. .

Step 3: Place the Facebook login server control on a page
1. In Visual Studio, open the template onto which you want to place a Facebook Login
server control. See also: Ektron Server Controls.
2. Drag and drop the control.
3. Use the following information to complete its properties.
l Authenticated (String)
l

FacebookButtonText (String)
Enter the Facebook Login button text. The default is Connect with
Facebook.

l

Hide (Boolean)

l

InstructionDetail (String)
Enter additional text that appears above the Facebook Login button. The
default is Sign in using your Facebook account.

l

InstructionHeader (String)
Enter text that appears above the Facebook Login button. The default is Sign
in using your Facebook account.

l

Language

l

SignupTemplate (String)
Enter the path to the template that appears after a user completes the
Connect with Facebook screen.

You can customize the markup for the form using the LoginTemplate and
LogoutTemplate server controls.

Using Facebook connect extension with the Targeted Content
widget
Facebook Login lets you retrieve the following Facebook profile information, using
Facebook Connect Extension.
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l

Age

l

Gender

l

Marital Status

l

Likes

l

Employment
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Modifying setup information

See also: Creating Personalized Web Experiences with the Targeted Content Widget

Modifying setup information
PREREQUISITE

You are a member of the Administrators group.
You must complete this before any user can access your Ektron website.
In Workarea > Settings > Configuration > Setup, you can enter or edit
information for the Ektron website including:
l

License keys

l

Default language

l

email notification

l

Physical library folders on file server

l

Builtin user information

l

Editor options

l

Work page size settings

l

Password Regex

The Application Setup screen appears. Click Edit to modify the settings.

General tab

l

Version. This number shows the Ektron version and build numbers. This number is
important to know if you place a call to Ektron Support.

l

License Key(s). Enter the license key sent to you from Ektron.
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l

Default Application Language. Select a default language for Ektron. This user’s
language determines the screens and messages that appear in Ektron. In the user
profile, you can set any user’s language to system default. Each user set to
system default uses the language assigned here.
NOTE: Do not confuse the default application language with the ek_
DefaultContentLanguage variable in web.config. For more information on that,
see Setting the default language on page 1512.

l

System E-mail Address. Enter a valid email address. This address will appear in
the From field in the notification emails. See also: Enabling email notification on
page 105.

l

Enable Sending of System Notification Email. Check this box if you want
notification emails to be sent when triggering actions occur. See also: Enabling
email notification on page 105.

l

Server Type: Staging Server. Check this box if you want your library links to
refer to the staging server domain, as opposed to the production server domain.
This would help you verify that the linked items exist on the staging server. See
also: Automatic multi-site setup on page 92
NOTE: Checking this box disables the Web Alerts feature on your server.

l

Asynchronous Processor Location. If your site uses the Web Alerts feature,
enter or update the location of the asynchronous processor Web services file. The
default location is “[none specified].” See also: Setting up message queuing and
the asynchronous processor on page 1483.

l

Enable CMS to create file system folders for library assets. Check the box if
you want to create physical folders on your file system server that match the
Ektron library folder tree. See also: Creating file system folders with Ektron on
page 135.

l

Builtin User. Edit the username and/or password for the built in user. By default,
the username and password combination is builtin/builtin.
WARNING! Ektron strongly urges you to change the default password assigned
to the builtin user. Opportunities to do this are presented during installation and
in the above field.

Editor tab
IMPORTANT: Editor tab settings apply only to the eWebEdit400 editor.
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Workarea tab

l

Preserve MS-Word Styles. When Microsoft Word content is pasted into the
editor, it removes some Word styles by default. Check this box if you want to
prevent the editor from removing them.
NOTE: Ektron does not recommend enabling this feature.

l

Preserve MS-Word Classes. Similar to styles, when Microsoft Word content is
pasted into the editor, it removes some Word classes by default. Check this box if
you want to prevent the editor from removing them.

l

Enable Font Buttons. Checking this option displays the following font-related
buttons on the editor toolbar:
o Font Face

l

o

Font Size

o

Font Color

o

Font Background Color

Accessibility/Section 508 Evaluation. If your editor is eWebEdit400:

Workarea tab
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The following fields change the default Web page after log-in and the default Workarea
page. The default values are automatically applied to all new users, and to all existing
users when you upgrade. Normally, you can modify these values for any user via the
Edit User screen. But, you can force these values on all users, removing the ability to
personalize them.
l

Landing Page After Login. If you want one page in your website to appear after
users log in, enter the URL to that page. If you do, the landing page points to
published content, not the Workarea. You can click Select Page to browse to a
landing page. The last published version of the page appears. If the page has never
been published, nothing appears.
By default, the page from which the user logged in reappears.

l
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IMPORTANT: If you are logging in from the OnTrek sample site, this field is
ignored. OnTrek has its own landing page after login, regardless of this setting.

l

Set Smart Desktop as Start Location in the Workarea. If you want the Smart
Desktop to appear as soon as a user enters the Workarea, click this box. By
default, the user sees the Smart Desktop after log in. If you leave this box blank,
when a user enters the Workarea, the folder of the content specified in the user
profile at the Landing Page after login field is displayed.

l

Force Preferences to all users. To force these settings on all Ektron users,
check this box. If you do, users can see the values in the user profile screen but not
change them. If you leave this box blank, users can personalize these values in
their User Profile.

l

Enable Verify Email. Check this box if site visitors who complete the membership
form are placed on the Users Not Verified list. Upon confirming their interest, these
site visitors become membership users. If you do not check this box, site visitors
who complete the membership form automatically become membership users. See
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System tab

also: Allowing membership users to self-subscribe on page 1629.
IMPORTANT: When using the Checkout server control on an eCommerce site,
the Enable setting must be unchecked. Otherwise, new users will receive an
error message when they sign-up using this control. See also: Checkout.
l

Enable PreApproval Group. Use this field to enable Automatic Task Creation.
See also: Setting up an automatic task for pre-approving content on page 1467.

System tab

Use this button to clear Ektron's cache, which recycles the application pool. For
example, you updated the web.config file but cannot yet see the changes.
Under certain circumstances, Ektron's support group may instruct you to click this
button.
Administrators would use this button if they cannot access the hosting servers yet need
to reset their website. The button is an alternative to submitting a request to their IT
department or hosting company.

Impact on Ektron
After you click Restart, the first request takes longer than usual since the application
needs to recompile. Subsequent requests should be processed normally.
To minimize the impact on site visitors, visit your home page immediately after the
restart, so that your request is the first "hit."
See also: Managing Application Pools in IIS 7

Password Regex tab
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Use the Application Setup screen's Password Regex tab to customize Ektron's
password security policy, and the error text that appears if a user's entry does not
conform to the policy. Ektron provides a default policy and error text. The default policy
enforces these criteria:
l

minimum of 5 alphabetical and numeric characters

l

at least one uppercase letter

The password policy is enforced if either the Workarea or the API is used to add a CMS
or membership user, or an existing user's password is changed.

Additional Password Policy Notes
l

The policy is not enforced when using the Membership User Reset Password
screen. See also: Activating other membership actions on page 1631.

l

The policy is not enforced during installation, when you are prompted to enter a
password for admin and builtin users. The policy is enforced if you later change
those users' passwords.

l

The policy is not enforced if you are using Active Directory. See also: Using Active
Directory with Ektron on page 1589.

Customizing the password security policy and error text
PREREQUISITE
l

Knowledge of RegEx.

l

You are a member of the Administrators group.

To customize the password security policy:
1. Go to Settings > Configuration > Setup > Edit > Password Regex.
2. Change the Type drop-down to Custom.
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3. If desired, edit the error text. This appears if a new password does not conform to
the RegEx expression.

4. If desired, edit the RegEx expression.
5. Click Update.
6. Ektron recommends creating a new "dummy" user and entering passwords that
both pass and fail the updated RegEx expression, to verify the expected behavior.

Restoring the default password RegEx and error text
To restore the default password policy and error text:
1. Go to Settings > Configuration > Setup > Edit > Password Regex.
2. Change the Type drop-down to Default.
3. Click Update.
4. Ektron recommends creating a new "dummy" user and entering passwords that
both pass and fail the RegEx expression, to verify the expected behavior.

Creating file system folders with Ektron
If this option is enabled, each time you create a new content or library folder in Ektron,
a corresponding physical folder is created on the file system to organize library files on
your file server. The following image shows a library folder tree and its corresponding
system folder structure.
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NOTE: If you are upgrading, the installation does not create sample website folders
on the file server. You must add these folders manually. However, all folders that
you create are also created on the file server when enabled.

Handling background processing functions with
the Ektron Windows Service
Ektron provides a Windows service (EWS) to handle the following background
processing functions.
l

Balancing the load on your servers on page 99

l

Bad link report on page 1064

l

Scheduling Content to go live at a future time, and removal of content scheduled to
expire.

l

Applying Metadata to content: When a new metadata definition is created, the
Windows service applies it to all content in the Ektron database. However, the
metadata definition is only activated for the content when it is enabled for the
content’s folder.

Also, the EWS propagates updates that are made to the database connection string or
the site path in the web.config file. The service copies the new value to the
data.config and sitedb.config files, which are located in C:\Program Files
(x86)\Ektron\EktronWindowsservice40. Any Ektron components that reference
these values can retrieve the current information from these files.
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The data.config and sitedb.config files are updated once each day at a time
prescribed in the updateTime value in C:\Program Files
(x86)\Ektron\EktronWindowsservice40\Ektron.ASM.EktronServices.exe.config
. You can change this time.
WARNING! Do not edit the data.config and sitedb.config files. They are
dynamically generated by Ektron. If these files have incorrect values, edit the
web.config file, which is used to generate them.
The EWS starts automatically when Ektron is installed, and again whenever the server
is restarted.
To see the status of the service, go to Start > Computer, then right click and choose
Manage.
l Windows 7: The Computer Management screen appears. Choose Computer
Management > Services and Applications > Services.
l Windows 2008: The Server Manager screen appears. Choose Server Manager >
Configuration > Services.
If you're using Windows 8 or 2012, press the Windows key (
Services.

) /Q then enter

Look for Ektron Windows Services. You can see its status in the Status column.

On your file system, the EWS is located in C:\Program Files
(x86)\Ektron\EktronWindowsservice40. Within that folder, the
Ektron.ASM.EktronServices.exe.config file runs the EWS.
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Additional resources
Upgrading the Ektron Windows Service

Viewing the EWS activity log
The EWS has an Activity Log that tracks all related events. To view detail for any event,
double click it.
l

Windows 7: Computer Management > System Tools > Event Viewer >
Ektron Log

l

Windows 2008: Server Manager > Diagnostics > Event Viewer > Ektron
Log

A common source of errors is that the service cannot find Ektron sites, because they
have not been created yet, as shown in the sample below.
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Setting up an Ektron site to use Amazon BLOB

Setting up an Ektron site to use Amazon BLOB
storage
This section explains how to set up a local site to use Amazon BLOB storage. The
resulting configuration stores assets in BLOB storage rather than the local file system.
This configuration also allows files to be served from the BLOB store, by redirecting
requests to the BLOB URL rather than the local system.
1. Create new bucket on Amazon.
a. Name: [ektronbucket]
b. Region: [Asia Pacific (Singapore)]
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2. To install the package to your website project, run the Install-Package AWSSDK
command.
Ensure that the latest AWSSDK.dll file resides in the Ektron site's bin folder.
3. Modify your website's web.config file.
a. Change the unity.storage section to match the sample below:
<section name="unity.storage"
type="Microsoft.Practices.Unity.Configuration.UnityConfigurationSection,
Microsoft.Practices.Unity.Configuration, Version=3.0.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" />

b. Define unity.storage as follows:
<unity.storage>
<assembly name="Ektron.Storage"/>
<assembly name="Ektron.Cloud"/>
<namespace name="Ektron.Cloud.Amazon.Storage"/>
<namespace name="Ektron.Storage"/>
<container name="storageContainer">
<register type="IFileService" mapTo="S3FileService"/>
<register type="IDirectoryService" mapTo="S3DirectoryService"/>
</container>
</unity.storage>

c. Modify appsettings keys or add them to match the sample below:
<add
<add
<add
<add
<add

key="ek_CloudStorageType" value="AMAZON" />
key="BlobStorageName" value="ektronbuket" /> <!--bucket name-->
key="AWSAccessKey" value="*******" /> <!--bucket access key-->
key="AWSSecretKey" value="*********" /> <!--bucket secret key-->
key="AWSRegion" value="ap-southeast-1" /> <!--bucket region-->

d. Add the following to the <modules> section:
<add name="EkBlobModule" type="BlobRedirectModule"
preCondition="integratedMode" />

4. Delete all contents (except web.config) from the following folders on the Amazon
vm.
l [siteroot]\assets
l

[siteroot]\privateassets

l

[siteroot]\uploadedfiles

l

[siteroot]\uploadedimages

l

C:\assetlibrary\[sitename]

For eSync
1. Create 2 sites. Configure and run a successful eSync between them. Ensure that
the profile is one way sync (Upload/Download).
2. Create a sync relationship from the local server to the remote server that has the
CDN settings.
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a. Apply appropriate certificates to both sides.
b. Make sure appropriate ports are open. See
https://portal.ektron.com/kb/10123/.
c. Make sure appropriate ports are open on the remote server network security
group.
d. Make sure you can access the remote server site from the local server.
3. Run the initial sync.
At this point, the db sync should work, and assets will be uploaded. But, they will
be uploaded to the local folder of Remote server, not the BLOB store. The next
steps change sync to push directly to the BLOB.
4. Update the scheduler row in the database.
Replace the tokens in the below statement, and run it on the database in which you
just created the relationship (the sending side). This updates the most recent
relationship created. See notes if you need to update an older relationship.
update scheduler set external_args=N'
<CloudServiceRequest
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SubscriptionID>[Leave blank for Amazon]</SubscriptionID>
<StorageAccountID>[AWSAccessKey from web.config]</StorageAccountID>
<StorageAccountKey>[AWSSecretKey from web.config]</StorageAccountKey>
<UseHttps>True</UseHttps>
<CDNEndpoint />
<ContainerConfigName>amazon</ContainerConfigName>
<WebSites>
<SiteInfo>
<ContainerAddress>[BlobStorageName from web.config]</ContainerAddress >
<LocalSitePath>[Your local website path ex., c:\inetpub\site1]</LocalSitePath>
</SiteInfo>
</WebSites>
<ServiceArguments>
<ComputeArguments>
<Location>ap-southeast-1</Location>
</ComputeArguments>
</ServiceArguments>
</CloudServiceRequest>'
where scheduleid=(select top 1 scheduleid from scheduler
where parentsyncid = 0 order by date_created desc) or
parentsyncid=(select top 1 scheduleid from scheduler
where parentsyncid = 0 order by date_created desc)

5. Run the updated profile again.
a. Validate that the assets went into the BLOB.
b. Validate that the assets are viewable from the Amazon site.
6. Delete all content (except for the web.config file) from inside the following folders
on the Amazon vm.
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l

[siteroot]\assets

l

[siteroot]\privateassets

l

[siteroot]\uploadedfiles

l

[siteroot]\uploadedimages

l

C:\assetlibrary\[sitename]

Notes:
l

The sql statement must be run again after new sync profiles are created.
If you hover over the plus sign (+) on the relationship, the URL is something like:
http://91site.com/workarea/sync/SyncProfile.aspx?action=add&id=7.
The id at the end of the URL is the parent sync row. The statement to update all
profiles on that id is:
update scheduler set external_args=N' <CloudServiceRequest
xmlns:xsd=http://www.w3.org/2001/XMLSchema
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SubscriptionID>[Leave blank for Amazon]</SubscriptionID>
<StorageAccountID>[ AWSAccessKey from web.config]</StorageAccountID>
<StorageAccountKey>[ AWSSecretKey from web.config]</StorageAccountKey>
<UseHttps>True</UseHttps>
<CDNEndpoint />
<ContainerConfigName>amazon</ContainerConfigName>
<WebSites>
<SiteInfo>
<ContainerAddress>[ BlobStorageName from web.config]</ContainerAddress >
<LocalSitePath>[Your local website path ex., c:\inetpub\site1]</LocalSitePath>
</SiteInfo>
</WebSites>
<ServiceArguments>
<ComputeArguments>
<Location>ap-southeast-1</Location>
</ComputeArguments>
</ServiceArguments>
</CloudServiceRequest>'
where scheduleid=[parent id from url (in this case 7)]
or parentsyncid=[parent id from url (in this case 7)]

l

The profiles to sync assets cannot be bidirectional. They must be upload or
download. You can have both types of profiles.

Setting up Azure BLOB for the Ektron CMS
This document explains how to set up a local site to use Azure BLOB. The resulting
configuration stores assets in a BLOB store rather than the local file system. This
configuration also allows files to be served from the BLOB store, by redirecting requests
to the BLOB URL rather than the local.
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1. Create a new Storage Account on Azure.

a. Name: [ektronblob]
b. Deployment model: Resource manager
c. Account kind: Storage (general purpose v1)
2. Using Visual Studio, open your local site and install the Windows Azure Storage
package. To do this, run the command: Install-Package
WindowsAzure.Storage -Version 8.7.0.

Ektron Reference

143

Setting up Ektron

3. Modify the site's web.config file.
a. Change the unity.storage section as follows:
<section name="unity.storage"
type="Microsoft.Practices.Unity.Configuration.UnityConfigurationSection,
Microsoft.Practices.Unity.Configuration, Version=3.0.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" />

b. Define unity.storage as follows:
<unity.storage>
<assembly name="Ektron.Storage"/>
<assembly name="Ektron.Cloud"/>
<namespace name="Ektron.Cloud.Azure.Storage"/>
<namespace name="Ektron.Storage"/>
<container name="storageContainer">
<register type="IFileService" mapTo="CloudFileService"/>
<register type="IDirectoryService" mapTo="CloudDirectoryService"/>
</container>
</unity.storage>

c. Modify appsettings keys or add them to match.
<add key="ek_CloudStorageType" value="AZURE"/>
<add key="ek_CloudAccountId" value="ektronblob"/>
<!--storage account name-->
<add key="ek_CloudAccountKey" value="xxxxxxxx"/>
<!--storage account primary key-->
<add key="ek_CloudContainer" value=""/>
<add key="BlobOrCdnUrl" value="https://ektronblob.blob.core.windows.net/"/>
<!-- url for storagecontainer -->
<!--update this with accurate values. Note: For CMS 9.20 or older,
you should remove "EndpointSuffix=core.windows.net" in the connection string ->
<add key="StorageConnectionString"
value="DefaultEndpointsProtocol=https;AccountName=ektronblob;AccountKey=xxxxxx
xxx" />

d. Add the following to the <modules> section:
<add name="EkBlobModule" type="BlobRedirectModule"
preCondition="integratedMode" />

4. Delete all contents (except web.config) from the following folders on the Azure
vm.
l [siteroot]\assets
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l

[siteroot]\privateassets

l

[siteroot]\uploadedfiles

l

[siteroot]\uploadedimages

l

C:\assetlibrary\[sitename]
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For eSync
1. Create 2 sites. Configure and run a successful eSync between them. Ensure
that the profile is one way sync (Upload/Download).
2. Create a sync relationship from the local server to the remote server that has
the CDN settings.
a. Apply appropriate certificates to both sides.
b. Make sure appropriate ports are open. See
https://portal.ektron.com/kb/10123/.
c. Make sure appropriate ports are open on the remote server network
security group.
d. Make sure you can access the remote server from the local server.
3. Run the initial sync.
At this point, the db sync should work, and assets will be uploaded. But, they
will be uploaded to the local folder of Remote server, not the BLOB store. The
next steps change sync to push directly to the BLOB.
4. Update the scheduler row in the database.
Replace the tokens in the below statement, and run it on the database in
which you just created the relationship (the sending side). This updates the
most recent relationship created. See notes if you need to update an older
relationship.
update scheduler set external_args=N'
<CloudServiceRequest
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SubscriptionID>[xxxxxxxxxx]</SubscriptionID>
<StorageAccountID>[ek_CloudAccountId from web.config]</StorageAccountID>
<StorageAccountKey>[ek_CloudAccountKey from web.config]</StorageAccountKey>
<UseHttps>True</UseHttps>
<CDNEndpoint />
<ContainerConfigName>amazon</ContainerConfigName>
<WebSites>
<SiteInfo>
<ContainerAddress>[Leave blank for Azure]</ContainerAddress >
<LocalSitePath>[Your local website path for example,
c:\inetpub\site1]</LocalSitePath>
</SiteInfo>
</WebSites>
<ServiceArguments>
<ComputeArguments>
<Location>ap-southeast-1</Location>
</ComputeArguments>
</ServiceArguments>
</CloudServiceRequest>'where scheduleid=(select top 1 scheduleid from

Ektron Reference

145

Setting up Ektron

scheduler where
parentsyncid = 0 order by date_created desc) or parentsyncid=(select top 1
scheduleid from scheduler where parentsyncid = 0 order by date_created desc)

5. Run the updated profile again.
a. Validate that the assets went into the BLOB.
b. Validate that the assets are viewable from the Amazon site.
6. Delete all content (except for the web.config file) from the following folders
on the Azure vm.
l [siteroot]\assets
l

[siteroot]\privateassets

l

[siteroot]\uploadedfiles

l

[siteroot]\uploadedimages

l

C:\assetlibrary\[sitename]

Notes:
l

The SQL statement must be run again after new sync profiles are created.
If you hover over the plus sign (+) on the relationship, the URL is something
like:
http://91site.com/workarea/sync/SyncProfile.aspx?action=add&id=7.
The id at the end of the URL is the parent sync row. The statement to update
all profiles on that id is:
update scheduler set external_args=N' <CloudServiceRequest
xmlns:xsd=http://www.w3.org/2001/XMLSchema
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SubscriptionID>[xxxxxxxx]</SubscriptionID>
<StorageAccountID>[ek_CloudAccountId from web.config]</StorageAccountID>
<StorageAccountKey>[ek_CloudAccountKey from web.config]</StorageAccountKey>
<UseHttps>True</UseHttps>
<CDNEndpoint />
<ContainerConfigName>azure</ContainerConfigName>
<WebSites>
<SiteInfo>
<ContainerAddress>[Leave blank for Azure]</ContainerAddress >
<LocalSitePath>[Your local website path, for example,
c:\inetpub\site1]</LocalSitePath>
</SiteInfo>
</WebSites>
<ServiceArguments>
<ComputeArguments>
<Location>ap-southeast-1</Location>
</ComputeArguments>
</ServiceArguments>
</CloudServiceRequest>'
where scheduleid=[parent id from url (in this case 7)]
or parentsyncid=[parent id from url (in this case 7)]
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l

The profiles to sync assets cannot be bidirectional. They must be upload or
download. You can have both types of profiles.
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Chapter 6

Setting up your CMS folder
structure
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Folders are containers for . Ektron provides the following types of folders:
l

Standard. See this chapter

l

Root. The top-level container for all folder types

l

Site. See Supporting multi-site configurations on page 91

l

Community. See Community folders on page 1639

l

Blog. See Working with blogs on page 963

l

Discussion Board. See Working with discussion boards on page 1013

l

eCommerce catalog. See Creating a catalog folder on page 1819

l

Web Calendar. See Working with calendars on page 991

Planning your CMS folder structure
At their core, all Web content management systems serve the same purpose: to
manage content. The only real difference among systems is the way in which that
content is used. You can divide content into 3 categories:
l

Complete Content. A content item that is considered ready for visitor
consumption without further manipulation of the content. It may be comprised of
several other items. For example, a Press Release is complete if does not have
dependencies on other data. Also, a PageBuilder Page Layout, which has had its
dependencies on other content fulfilled, is a complete object. These items require
no other context in order to convey their intended meaning.

l

Resource Content (or Incomplete Content). A content item that is not yet ready
for visitor consumption because it lacks some surrounding context to complete its
message. It is not intended to be viewed without the complete context. For
example, a call to action (CTA) is a resource that needs to be placed in the context
of a complete page to make sense. You also do not want a CTA showing up in
search results, and shown without more information.

l

Custom Configuration Data. Settings or global configuration to the site. This
data is not complete and useful without context, yet it is also not content to be
dragged onto a larger page. Rather, it helps define smaller, more global elements
and settings. This data is stored in a Smart Form and can vary among the following
items: selecting other CMS content, menus or other objects, or providing a text
template for your copyright statement and standard values for your Previous and
Next buttons in pagination.

The following base CMS folder structure uses the 3 categories to organize your content
to provide sufficient separation of roles, search scopes, and content purpose to satisfy
most Ektron implementations. You can further sub-divide the structure. The structure
may be your root architecture in a single-site instance, or developed within site folders
in a multi-site environment.
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This structure lets you clearly identify configuration roles, resource roles and content
versus page layout roles with user groups and setup permissions accordingly. The
folder structure gives you an easy means of keeping unwanted content from showing
up in the site search results by having clearly defined locations for the various content
types and functions.

l

Configuration. Administrative content, such as Smart Forms, that supports
Custom Configuration Data.

l

Content. Complete content that can be indexed and included in the scope for your
site search. You should consider any content URL or Alias within these folders as
complete and requiring no additional context.

l

Images. An image is resource content because it is frequently part of a larger
content item and therefore should not be independently searchable. If you want to
have some images on your site returned in search results (for example, infographics or gallery photos), place them in a sub-directory of the Content folder.

l

Master Layouts. PageBuilder Master Layouts or Page Layouts used as templates
for other pages or content, respectively, within the CMS. This content is not
searchable and, without the additional content, does not stand on its own as an
individual site page.

l

Pages. PageBuilder Page Layouts that may rely on other data, but the page itself
is complete. Because these pages are complete, they should be indexed for search.

l

Resources. Smart Form or HTML content that requires a larger context are
resource content; for example, slides for your home page banner, CTAs, or
descriptive text to be placed at the top of a careers listing. Content in this folder
should not be searchable because each item does not make sense on its own.

By dividing the content data into categories that are based on how the content is used
in the application, everything else falls into place more easily.

Using folder menus
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The following menus and button appear across the top of the View Contents of Folder
screen. Depending on your permissions, you may not see all menu options.

For information on Add Asset ( ), see Working with assets in the Document
Management System on page 708.

New menu
Lets you create and upload new items into a folder.
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l

Add Calendar Event. Add calendar event. This option is only available in a
WebCalendar folder.) See also: Adding system calendar events on page 994

l

Blog. Add blog. See also: Working with blogs on page 963

l

Calendar. Add Web calendar. See also: Working with calendars on page 991

l

Catalog. Add eCommerce catalog. See also: Creating a catalog folder on
page 1819

l

Collection. Add collection. See also: Working with collections on page 804.

l

Community Folder. Add folder whose content can be updated by membership as
well as regular users. See also: Community folders on page 1639.

l

Discussion Board. Add discussion board. See also: Working with discussion
boards on page 1013.

l

DMS Document. Add Office document, managed file, or multimedia file, any
supported type. See also: Managing Microsoft Office assets on page 720, Managing
assets on page 712.

l

Folder. Add folder. See also: Setting up your CMS folder structure on page 149.

l

HTML Content. Add HTML content. See also: Creating new content on page 684.

l

HTML Form/Survey. Add HTML form, poll, or survey. See also: Creating surveys
and polls on page 868.

l

Master Layout. Add master layout. This option is only available in a PageBuilder
folder. See also: Creating a PageBuilder master layout on page 1097.

l

Menu. Add menu. See also: Creating menus for your website on page 1339.

l

Multiple DMS Documents. Add several Office documents, managed files,
multimedia files, any supported type. See also: Adding multiple DMS documents on
page 715.

l

Page Layout. Add page layout. This option is only available in a PageBuilder
folder. See also: Developing wireframe templates on page 1093.
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l

Site. Add website. This option is only available in the root folder. See also:
Supporting multi-site configurations on page 91.

l

Smart Form. Add Smart Form. This option is only available if one or more Smart
Form configurations are assigned to the folder. See also: Working with Smart
Forms on page 888.

View menu
Lets you display information about content in a folder.
l

All types. Displays all content types of selected language.

l

Archived Content. View and work with content that passed its scheduled End
Date and whose archive option is either Archive and remove from site or
Archive and remain on Site. When a Web Calendar folder is selected, this menu
item is labeled "Archived Events".

l

Collection. Work with collections assigned to this folder. See also: Working with
collections on page 804.

l

HTML content, HTML Form/Survey, Office Documents, Managed Files,
Multimedia, or Image Assets. Limits folder display to selected content type. For
example, choose View > Managed Files and see only managed files in the
folder; other content types are suppressed. This is especially helpful if the folder
has many items, and you are looking for only one type of content. If a PageBuilder
folder is selected, you can limit the display to Page Layouts or Master Layouts. For
more information on specific types of content:
l Creating new content on page 684
l

Working with HTML forms on page 843

l

Managing Microsoft Office assets on page 720

l

Managing assets on page 712

l

Managing multimedia assets on page 716

l

Language. Limits display of folder content to one language, or lets you display all
languages. If set to one language, this also determines the language of new items
you create or upload into the folder.

l

Menu. Work with menus assigned to this folder. See also: Editing a menu item on
page 1350.

l

Properties. Only members of the administrators group and those assigned to the
Folder-Admin role see this option. It lets you assign folder properties, such as
which users can edit a folder’s content. See also: Defining roles on page 1581,
Setting folder properties on page 158.

Delete menu
Lets you delete folder or content within folder.
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l

Content. Delete one or more content items in folder. See also: Deleting content on
page 688.

l

This folder. Delete current folder and all of its content. If a Web Calendar is
selected, the menu option appears as "This calendar." You cannot delete the Root
folder. See also: Deleting a folder on page 166.

Action menu
Lets you perform actions on the folder or content within the folder.
l

Cut/Copy. Move or copy content to another folder. See also: Moving or copying
content on page 687.

l

Export For Translation. Prepare content for translation by a translation agency.
See also: Exporting content to XLIFF on page 1533.

l

Search. Search content in the Workarea. See also: Searching the Workarea on
page 390.

l

Synchronize Folder. Sync this folder on the current server with the same folder
on another server. This option is only displayed if eSync has been set up, you have
the required privileges, and content has changed. See also: Synchronizing content
and folders on page 1996.

Workarea content menu
The View Contents of Folder screen features a context-sensitive, drop-down menu of
options you can perform for content.

The options depend on several factors, such as
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l

your folder permissions

l

your position in the workflow (if any)

l

the content’s status

l

whether the item is a Microsoft Office document or asset

To see any content item's menu options:
1. Go to the folder that contains the content.

2. Click the triangle. A menu of options for that content item appears. The following
options may be available:
l Approve. Approve content that was submitted for publishing. See also:
l Approving content
l

Check-In. Change content status to checked in. Might use if you checked out
and saved a document then it became lost or corrupted. This option changes
original document’s status to checked in. However, it does not replace the
version of the file in Ektron. To replace content that was checked out and
edited, drag and drop it into Ektron. See also: Updating an Office document on
page 721.

l

Check out and Save As. Change a content item’s status to checked out and
save it to your local computer. When you finish editing the item, drag and drop
it to Ektron. See also: Updating an Office document on page 721.

l

Decline. Decline an approval request submitted to you. This option rejects the
changes and keeps the current version live on website. You are prompted to
enter a reason for the decline. After you decline, the author who made the
change is notified by email and the content is removed from the workflow. If
the author updated content then submitted it for approval, the updated
content remains in the file. If you do not want it to remain, choose the Edit
option. See also: Approving content for publication on page 749.

l

Delete. Submit content for deletion. See also: Deleting content on page 688.

l

Edit. For HTML, HTML form, or Smart Form content, edit content within the
editor. For assets, use Check out and Save As or Save As to save asset to
your computer and edit it. Then, use Edit to replace version in Ektron.

l

Edit in Microsoft Office. Edit Office document within Ektron. See also:
Managing Microsoft Office assets on page 720.
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l

Edit Properties. Edit item’s Ektron information, such as summary, metadata,
Schedule, and taxonomy. After you complete the edit screen, you proceed to
the View Content screen. From here, you can perform additional content
activities, such as move/copy, delete, and view history.See also:
l Scheduling content on page 698

l

Force Check In. Only appears if login user is a member of the Administrator
group or assigned the folder user admin role and content is checked out. This
option lets an administrator check in content even though the administrator
did not check it out.

l

Publish. Accept changes to content and publish it to the site.

l

Request Check In. Allows either admin user or non-admin user with edit
permission for the content’s folder to email the user who checked out content.
The email asks the check-out user to check it in.

l

Save As. Save Office document or asset to your computer. See also: Saving
an Office document on page 722.

l

Submit. Submit current version of content for publishing. When you do this,
the first user or user group in the workflow is notified that your content is
ready for review.

l

Synchronize. Synchronize content or folders between 2 servers. See also:
Synchronizing servers using eSync on page 1925.

l

View. View item’s Ektron information, such as summary, metadata, Schedule,
and taxonomy. After viewing, you can also edit that information if you have
permission

l

View in Microsoft Office. View Office document within Office application.
Cannot change.

l

View Properties. View Office document’s Ektron information, such as
Summary, Metadata, Schedule, and Taxonomy. After viewing, you can edit the
information if you have permission.

Viewing a folder
The View Contents of Folder screen lists the following information about each content
item.
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l

Title. The content title.

l

Content Type. HTML content, HTML form, XML Smart Form, managed asset,
image, and so on.

l

Language. The content language. See also: Working with multi-language content
on page 1507.

l

ID. The number assigned to the content by Ektron. It is used to retrieve the
content from a database.

l

Status. The content status. See also: Content statuses on page 681.
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l

Date Modified. The most recent date the content was added, edited, or
published.

l

Last Editor. The last user who edited the content.

To view a folder, follow these steps.
NOTE: You can only view folders for which your system administrator has granted
permission. See also: Managing folder and content permissions on page 168
1. Access the Workarea and click the Content tab.

2. All content in the root folder and the selected language appear in the right frame.
Subfolders appear in the left frame.
NOTE: The View menu option lets you filter content by type. For example, you
can set it to view only HTML content. Therefore, you may only see content of a
selected type in the folder.
3. To work with any folder or its content, click the folder. When you do, its content
appears in the right frame.
4. If your system supports more than one language, you can view content for a
particular language or all languages using the View > Language option.

Adding a folder
To organize content on your website, create folders to store related content. See also:
Planning your CMS folder structure on page 150
1. Go to and click the folder within which you want to create the new folder (that is,
the parent folder).
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2. Choose New > Folder. Alternatively, you can hover the cursor over a folder, right
click the mouse, and choose Add Folder. The Add a Folder screen appears.

3. Complete the fields. See Setting folder properties below.
4. Click Add Folder.
You can modify the folder’s properties, permissions, workflow, and so on.
l

If this is a Community Folder, see Community folders on page 1639.

l

If this is a Site Folder, see Supporting multi-site configurations on page 91.

l

If this is a Catalog Folder, see Creating a catalog folder on page 1819.

Setting folder properties
The folder properties screen lets you set permissions and workflow for a folder. You can
also assign or modify the folder’s metadata, Web Alerts, and Smart Forms.
PREREQUISITE

Only members of the Administrator Group and those assigned to the Folder
User Admin role can view, add, or edit folder properties. (See also: Defining
roles on page 1581).
In addition, if a user is not a member of the Administrators Group, the user
must be given permission on the View Permissions for Folder screen. (See
also: Managing folder and content permissions on page 168).
NOTE: If you are using an eCommerce catalog, see Creating product types and
catalogs on page 1806 for a description of the Product Types screen. If you are using
a Web Calendar folder, see Viewing system calendar properties on page 998.
1. Select the folder.
2. From the View Contents of Folder screen, choose View > Properties.
Alternatively, from the left panel, right click the mouse and choose View
Properties.
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The Folder Properties screen contains these toolbar buttons.
l

l

Edit Properties. Access the Edit Folder Properties screen.
Permissions. Access the folder’s Permissions screen; see Managing
folder and content permissions on page 168.

l

Modify Preapproval Group. Set or update preapproval group assigned
to folder; see Setting up an automatic task for pre-approving content on
page 1467

l

Approvals. Access the folder’s workflow; see Managing folder and content
permissions on page 168

l

Purge History. Access the folder’s purge history table; see Purging
content history on page 167

l

Restore Web Alert Inheritance. Assigns the folder’s Web Alert
properties to all content in folder; see Restoring folder-level Web Alert settings
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to content on page 1501
l

Back. Go to previous screen

3. To change properties, click Edit Properties to open the edit screen.
The Properties screen lets you set the following folder properties, arranged by tab:
Properties tab
l

Name. Edit the name of the content folder. You cannot change the root folder
name.

l

Description. Edit the description of the content folder.

l

Style Sheet. Specify a style sheet filename that defines styles that may be
applied to content in this folder. The style sheet populates the style drop-down
list within the editor. Leave this field blank to inherit the parent folder’s style
sheet.
This style sheet affects content being edited. It does not necessarily affect the
content’s appearance on your website. To set or edit the style sheet that
determines your Web pages’ appearance, open the page’s Web form and place
a <link rel=”stylesheet”...tag within its <HEAD>tags. If desired, you can
identify the same style sheet in both locations. To include user-selectable
styles, they must be generic classes.
The Ektron editor ignores the CSS custom properties caption and visible.
To address this problem for Internet Explorer, replace them with the custom
CSS properties localeRef, caption and visible. For other browsers, use
the custom CSS selectors localeRef and unselectable (same as visible:
false). To achieve cross-browser compatibility, use both approaches. Non-IE
browsers have no equivalent forcaption.
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l

Multi-site Domain Configuration. The Site Name, Staging Domain, and
Production Domain fields only appear for Site folders. These fields are used
to set up and manage several websites under one CMS. See also: Supporting
multi-site configurations on page 91.

l

Office Documents. This field only appears if the Enable Office documents
to be published in other format property is checked in the Settings >
Configuration > Setup screen. See also: General tab on page 129. Enable
the Publish Office documents as PDF check box if Office documents in this
folder are published as PDF files. This property is not inherited from a parent
folder, nor is it inherited by any subfolders below this folder.

l

Content Searchable. Check the Inherit Parent Configuration box if you
want this folder to inherit the Content Searchable value from its parent folder.
Uncheck this box to break inheritance and apply a unique Content Searchable
setting to this folder.
Check this box to set the default value of the Content Searchable property for
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new content added to this folder. It does not affect existing content in the
folder, or content copied or moved to this folder. Regardless of the default
value, an authorized user can change the Content Searchable value while
adding content to the folder or at any other time. See also: Making content
searchable on page 371.
l

Display Settings. Enable the Inherit Parent Configuration check box if
you want this folder to inherit the Display Settings value from its parent folder
setting. Disable this check box if you want to break inheritance and apply a
unique Display Settings setting to this folder.

l

Display All Tabs. Check this box to display all tabs on the Create or Edit
Content screen. Or, check any tab-specific check boxes to display the selected
tabs on the Create or Edit Content screen. If you enable the Display All Tabs
check box and other tab-specific selections, only the individually checked tabs
remain when you click Update. Also, if a tab has a "required" property on it,
the tab displays even if you uncheck its box.

Taxonomy tab. See Assigning categories to a folder on page 1367
l

Taxonomy. Enable the Inherit Parent Configuration check box if you want
this folder to inherit taxonomy configurations from the parent folder. If you
disable Inherit Parent Configuration, you can then select taxonomies that
can be applied to content in this folder. Check the At least one category is
required check box if you want all content in this folder to be assigned at least
one taxonomy category. See also: Organizing content with taxonomies on
page 1357

Templates tab. See Working with templates on page 838
l

Page Templates. Lets you specify one or more templates for content in this
folder. This folder’s content uses the specified template when appearing on
your website. Enable the Inherit parent configuration check box to inherit
the template from the parent content folder. Or, do not check this box and
specify one or more templates.

Flagging tab. See Assigning a flagging definition to a folder on page 1719
l

Flagging. Enable the Inherit Parent Configuration check box if content in
this folder inherits a flagging definition from its parent folder. If you do not
check the box, use the drop-down list to apply a flagging definition to content
in this folder. See also: Defining flags for content on page 1717, Assigning a
flagging definition to a folder on page 1719.

Metadata tab. See Working with Metadata on page 822.
l

Metadata. Enable the Inherit Parent Configuration check box if you want
this folder to inherit the metadata values from its parent folder setting.
Uncheck this box if you want to break inheritance and apply unique metadata
settings to this folder. If inheritance is disabled, check the applicable boxes to
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determine which metadata definitions can be used.Only metadata definitions
whose Assigned box is checked can be completed by users working with
content in the folder.
Web Alerts tab. See Assigning a Web Alert to a folder or content on page 1496.
l

Web Alerts. Lets you specify custom Web alert settings for this folder or
inherit settings from the parent folder. For a description of the Web alert
settings, see Assigning a Web Alert to a folder or content on page 1496.

Smart Forms tab. See Working with Smart Forms on page 888.
l

Smart Forms. Lets you specify custom Smart Form settings for this folder or
inherit settings from the parent folder. For a description of the Smart Form
settings, see Assigning a Smart Form to a folder on page 903.

Product Types tab. See Creating product types on page 1806.
l

Default product type. Enable the Inherit Parent Configuration check box
if you want this folder to inherit the metadata values from its parent folder
setting. Uncheck this box if you want to break inheritance and apply unique
metadata settings to this folder. If inheritance is broken, use the radio buttons
to enable a default product type.

Breadcrumb tab. See Creating a sitemap breadcrumb trail on page 1432
l

Breadcrumbs. Lets you specify custom breadcrumb settings for this folder or
inherit settings from the parent folder.

Site Alias tab. See Creating a URL alias for a site on page 1425
l

Name. A URL to be used as an alias for the site. This tab and field combination
only appears for Site folders.

Aliasing tab. See Creating user-friendly URLs with aliasing on page 1399
l

Aliasing. Only appears if some form of aliasing is enabled. Enable the Manual
Alias Required check box to force the user creating or updating content in
the folder to add a manual alias (if none exists). Enable the Inherit parent
configuration check box (disabled by default) if you want the folder to inherit
the Manual Alias Required value from the parent folder.

Copying and moving a folder
You can copy a folder and paste it into another folder. Or you can cut and paste one
folder into another. Cut and paste is synonymous with move.
1. In the left panel of the Workarea, hover the cursor over the folder you want to
copy/move.
2. Right click the mouse.
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3. Click Copy or Cut folder name.

4. Hover the cursor over the folder to which you want to paste the copied/cut folder.
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5. Right click the mouse and select Paste Folder.

6. A warning message appears. Click OK.

Who can copy and move folders
These users can copy or move folders.
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l

users who have Add, Edit and Delete permissions for the folder being
moved/copied and the destination folder See also: Managing folder and content
permissions on page 168

l

members of the Administrators user group

l

users assigned in the Roles > Folder Specific > Folder User Admins screen

l

users assigned in the Roles > Folder Specific > Move or Copy screen

See also: Defining roles on page 1581

Rules for copying and moving folders
l

When you copy or move a folder, you also copy/move all of its subfolders.

l

All properties assigned to a folder (permissions, metadata, templates, and so on)
remain assigned after the copy or move. You can edit the folder in its new location
and adjust properties as needed.

l

Inherit checkboxes that were checked are now unchecked. After the copy/move,
check them as needed.

l

You cannot copy or move the root folder

l

You cannot copy or move a folder into its own subfolder

l

You cannot move a folder to same level in the folder structure

l

You can copy a folder to same level in the folder structure. If you do, a number is
appended to the folder name, such as calendar(1).

l

If you move a folder, its content retains its status. That is, if content's status was
checked out (O) before the move, it is checked out after the move.

l

If you copy a folder, only Approved content is copied. Content in other statuses is
not copied.

l

All folder content that follows the above rules is moved/copied. This includes all
language versions of those items.

Folder types that can be moved and copied
The following folder types can be copied or moved into other folder types.
l

Content folders. Can be copied or moved into Content, Site, and Root folders.

l

Blog folders. Can be copied or moved into Content, Site, and Root folders.

l

Discussion Board folders. Can be copied or moved into Content, Site, and Root
folders.
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l

Forum folders. Cannot be copied or moved into any other folder.

l

Community folders. Can be copied or moved into Content, Community, Site, and
Root folders.

l

Web Calendar folders. Can be copied or moved into Content, Site, and Root
folders.

l

Catalog folders. Only the folder can be copied or moved into Content, Catalog,
Site, and Root folders; the content of the Catalog folder is not copies or moved.

l

Site folders. Cannot be copied or moved into any other folder.

Deleting a folder
You can delete obsolete folders from the Ektron website.
NOTE: The top-level folder, Root, cannot be deleted nor renamed.
WARNING! Deleting a folder permanently deletes the content and Quicklinks that
belong to the folder and all of its subfolders. You cannot retrieve deleted content.
NOTE: Only certain users are allowed to delete Ektron folders. See Auditing changes
on page 690.
1. In the Workarea, go to the content folder you want to delete.
2. From the options across the top of the screen, choose Delete > This Folder.

3. Alternatively, you can hover the cursor over the folder in the folder display panel,
right click the mouse, and choose Delete folder name.
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4. Click OK.

Purging content history
WARNING! Purging permanently deletes content. You cannot retrieve purged
content.
The Purge History option lets you delete historical versions of content in a folder. For
more information on content versioning, see Managing versions of content on
page 701.
Purging is generally performed due to storage space concerns or to clear away obsolete
versions before going live or migrating a site. Before purging, make sure you are aware
of any organizational or legal data retention policies.
When purging, you can:
l

specify a date to limit which historical versions are purged. Only historical versions
with an edit/publish date before this are purged.

l

indicate whether a folder’s subfolders are purged

l

purge published as well as checked-in versions of content

PREREQUISITE
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Only members of the administrators group and users identified on the
Manage Members for Role: Folder User Admin screen can purge history.
To purge the history for a folder:
1. In the Workarea, go to the folder whose content you want to purge.
2. Click View > Properties.
3. Click Purge History (

). The Purge History screen appears.

4. Customize the purge options.
l Only purge historical versions before (required). Specify a date to limit
which historical versions are purged. When specified, only historical versions
with a date before this date are purged.
l

Recursive Purge (optional). Purges historical content versions in this folder’s
subfolders.

l

Purge versions marked as Published (optional). Purges published
versions of content as well as checked-in versions. If you do not check this
box, Published version are not purged.

5. Click Purge History.
6. Click OK to execute the purge.

Managing folder and content permissions
Permissions determine which actions Ektron users and user group members can
perform on content, library items, and content folders. For example, you let your
Webmaster perform advanced actions, such as adding folders, editing folder properties,
and deleting folders. At the same time, you let content contributors only view, edit, and
add content.
You can set permissions for a folder or content item. Content item permissions override
the associated folder permissions. When you assign permissions to a folder, they affect
all of its subfolders and content unless you break inheritance for a subfolder or content
item.
Unlike some folder properties (such as workflow), permissions are not languagespecific. They apply to all language versions of a content item.
Only Ektron administrators and users identified on the Manage Members for Role:
Folder User Admin screen can set permissions. See also: Using the roles screens on
page 1582
NOTE: Use the Roles screens to assign permissions not defined in the Permissions
screen, such as the ability to create tasks. See also: Defining roles on page 1581
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NOTE: You can view and update permissions for membership users by selecting
Membership users from the User Type drop-down menu; see Assigning
membership permissions on page 1634.

Accessing the permissions screen
IMPORTANT: Members of the administrators group have all permissions for all
Ektron folders, whether or not they appear on a folder’s permissions screen.
You manage the following permissions through the Permissions screen.
l

Content management: view, add, edit, delete, restore

l

Library File Management: view, add images, add other types of files, add
hyperlinks, overwrite files

l

Folder management: add, edit, delete, traverse

l

Work with collections and menus

To access the Permissions screen:
1. From the left frame of the Workarea, select a content folder.
2. Choose View > Properties. The Folder Properties screen appears.
3. Click Permissions (

). The Permissions screenappears.

The Permissions screen displays each user or group’s abilities to act on content in the
selected folder. Because all permissions cannot fit on one screen, click the Advanced
tab to see additional actions.
NOTE: To let users copy or move content, assign the Move or Copy role. See also:
Defining roles on page 1581
Standard permissions
l

Read Only. View content

l

Edit. Edit content

l

Add. Add content
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l

Delete. Delete content

l

Restore. Restore old versions of content

l

Library Read Only. View items in the corresponding library folder See also:
Working with files in the library on page 733

l

Add Images. Upload images to the corresponding library folder

l

Add Files. Upload files to the corresponding library folder

l

Add Hyperlinks. Add hyperlinks to the corresponding library folder

l

Overwrite Library. Overwrite images and files to the corresponding library folder

Advanced permissions
l

Collections. Manage collections See also: Working with collections on page 804
IMPORTANT: If a user is assigned any of the following roles, the user can
create, edit, and delete collections regardless of the user's Collections folder
permission: Collection and Menu Admin, Collection Admin, Collection Approver.

l

Add Folders. Add sub folders See also: Adding a folder on page 157

l

Edit Folders. Edit folder properties See also: Setting folder properties on
page 158

l

Delete Folders. Delete the current folder or its subfolders See also: Deleting a
folder on page 166

l

Traverse Folders. Access folders under the root folder. By default, the Everyone
user group has permission to view all subfolders. If you disable or modify the
Everyone user group, and you want to grant users/groups permission to a folder
other than the root folder, you must also assign Traverse permission. If you do not,
the user cannot access the folder. In that case, the user cannot perform any other
granted permissions.

l

Modify Preapproval. Set or update a folder’s preapproval group. This permission
is only displayed if preapproval groups are enabled. See also: Setting up an
automatic task for pre-approving content on page 1467

Inheriting permissions
By default, folders and content items inherit permissions from their parent folder. You
have 2 options for modifying folder or content permissions.
l

Modify the parent folder's permissions

l

Break inheritance then modify the permissions fr the folder/content

Breaking inheritance
IMPORTANT: You cannot break inheritance if you are using advanced workflow,
and any content in the folder is in Submitted status.
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1. From the left frame of the Workarea, select a content folder.
2. Choose View > Properties. The Folder Properties screen appears.
3. Click Permissions (

). The Permissions screenappears.

4. Uncheck the Allow this object to inherit permissions box.
5. Click OK.

Restoring inheritance
IMPORTANT: You cannot restore inheritance if you are using advanced workflow,
and any content in the folder is in Submitted status.
1. From the left frame of the Workarea, select a content folder.
2. Choose View > Properties. The Folder Properties screen appears.
3. Click Permissions (

). The Permissions screenappears.

4. Check the Allow this object to inherit permissions box.
5. Click OK.

Adding a user or user group to the permissions screen
NOTE:
* Before adding users or groups, you must break inheritance. See Breaking
inheritance on the previous page.
* If a user and a user group to which that user belongs are both given permission to
a folder, the user has all permissions to which he/she is assigned as well as
permissions assigned to the group.
* You can assign only Read Only permission to a Membership user or group. See
also: Membership users and groups on page 1625.
1. From the left frame of the Workarea, select a folder.
2. Choose View > Properties. The Folder Properties screen appears.
3. Click Permissions (

). The Permissions screenappears.
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4. Select CMS users or Membership users from the User Type drop-down menu.
Users and groups of the selected type appear.
5. Click Add Permissions. The Add Permissions screen appears. Only users and
groups not assigned to the Permissions screen appear.
6. Check users and groups to add to the Permissions screen.
7. Click Save. The Add Permissions screen appears.
8. Check the standard and advanced permissions for the user or group.
NOTE: Check Enable All to assign all permissions on the screen.
9. Click Save.

Deleting a user or user group from the permissions
screen
IMPORTANT: If a user or group is assigned to an advanced workflow, before you
can delete the user or group, you must remove it from all workflows. See also:
Editing an advanced workflow for a folder on page 774, Editing an advanced
workflow for content on page 778
1. From the left frame of the Workarea, select a content folder.
2. Choose View > Properties. The Folder Properties screen appears.
3. Click Permissions (

). The Permissions screenappears.

4. Select CMS users or Membership users from the User Type drop-down menu.
Users and user groups of the selected type appear.
5. Click Delete (

). The Remove Permissions screen appears.

6. Select the user or group to remove from the Permissions screen.
7. Click Remove Permissions for folder.
8. Click OK.
NOTE: When you delete the permissions of a user or user group, that change is
propagated to all subfolders and content that inherit the permissions. Also, if
the user or group was part of a workflow, they are removed from it.

Editing user or user group permissions
IMPORTANT: If a user or group is assigned to an advanced workflow, before you
can edit the user or group, you must remove it from all workflows. See also: Editing
an advanced workflow for a folder on page 774, Editing an advanced workflow for
content on page 778
1. From the left frame of the Workarea, select a content folder.
2. Choose View > Properties. The Folder Properties screen appears.
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3. Click Permissions (

). The Permissions screenappears.

4. Select CMS users or Membership users from the User Type drop-down menu.
Users and user groups of the selected type appear.
5. Click the user or group for which you want to edit permissions. The Edit
Permissions screen appears.
6. To assign any permission, check the box. To remove any permission, uncheck the
box. See also: Standard permissions on page 169, Advanced permissions on
page 170
NOTE: Remember to toggle between standard and advanced permissions.
7. Click Update.

Setting permissions for content
For an overview of permissions, see Managing folder and content permissions on
page 168.
Users can only add, edit, or delete content in folders if they have traverse permission
for its parent folders all the way up to root. If the folder to which you assign permissions
is not the root folder, you must grant the user the Traverse Folder permission to all
folders above that folder. Otherwise, the user cannot go to the folder. For example,
consider the following folder structure.

To let a user edit the Book Store folder only and no other folders, assign to the user
Traverse Folder permission for the 2 folders above Book Store: CMS400Demo and
Folders (root folder).
PREREQUISITES
l

Traverse permission to the folder containing the content, and all folders
above it

l

Edit permission for the content

1. Access the content by navigating to its folder, selecting a language, and clicking on
it.
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2. Click View Permissions (

).

3. Uncheck the box next to Allow this object to inherit permissions.
NOTE: If Allow this object to inherit permissions is already checked, you
cannot uncheck this box. The content in this folder is private and can only be
viewed by authorized users and members; see Making content private on
page 695. In that case, this folder is inheriting this setting from its parent folder.
4. Click OK.
5. You can perform any action on the content that you can perform on a folder. These
options are described in Managing folder and content permissions on page 168.
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Versions of Ektron previous to 8.5 featured 2-tier architecture, in which the Application
and Presentation tiers resided on the same server. In 3-tier architecture, you can locate
the Application tier in the client’s environment or an Ektron hosting environment. This
represents a true separation of the Web server from the database. The Application tier
does the bulk of the work, while the Presentation tier does basic processing.
IMPORTANT: You are not required to use 3-tier architecture—Ektron continues to
run successfully on 2-tier architecture.
A 3-tier architecture lets you spread the processing of Ektron data among 3 tiers,
shown in the following figure. Each tier should reside on its own server.

NOTE: You may run all 3 tiers on a single server for development purposes only.
The 3 tiers are Data, Application, and Presentation.
l

Data. Contains SQL and Ektron database objects (stored procedures, views,
tables, and so on).

l

Application. Full Ektron installation.
o Ektron DLLs

l

o

Ektron Workarea

o

Ektron Windows Services

o

Ektron WCF Services

o

Custom WCF Services

Presentation.
o Handles site visitor requests and displays Web pages
o

176

Minimal footprint, lightweight

Ektron 9.40 SP1

Benefits of 3-tier architecture

o

Requires IIS

o

No Ektron installation

o

Contains
o Standard ASP.NET website
o

Minimal set of Ektron .dlls in bin folder

o

Configuration files (web.config, unity.config)

o

Workarea required only if website uses PageBuilder or templated server
controls.

The Ektron Framework API uses the Microsoft Unity Framework to inject business
logic implementations into our Framework API. When running in 3-Tier mode, the
Framework API on the Presentation tier uses a WCF service client implementation,
thereby routing Framework API calls through WCF services, while the actual logic is
running on the Application server.
To minimize network requests the between Presentation and Application tiers,
Ektron includes a caching tier.
NOTE: 3-tier architecture is different from MVC coding style, which consists of a
data layer, business logic layer, and an API layer.
NOTE: To communicate between servers, you can choose any unused port. If you
choose a port other than 80, Ektron recommends one outside the well-known port
range (0 to 1023).

Benefits of 3-tier architecture
3-tier architecture provides the following benefits.
l

Scalability. Each tier can scale horizontally. For example, you can load-balance
the Presentation tier among 3 servers to satisfy more Web requests without adding
servers to the Application and Data tiers.

l

Performance. Because the Presentation tier can cache requests, network
utilization is minimized, and the load is reduced on the Application and Data tiers.
If needed, you can load-balance any tier.

l

Availability. If the Application tier server is down and caching is sufficient, the
Presentation tier can process Web requests using the cache.

Limitations of 3-tier architecture
3-tier architecture has the following limitations.
l

You must manually push templates, assets, private assets, uploaded images, and
uploaded files from the Application tier to the Presentation tier. You may use a tool
like Robocopy to do this.
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l

You create content (HTML, assets, PageBuilder pages, and so on) only in the
Application tier. You can only view content from Presentation tier.

l

Because 3-tier architecture uses WCF, it requires:
o the 8.5 or higher Framework API and databinding. You cannot use API calls
outside of the Framework API

l

o

templated server controls

o

widgets created by the Framework API

Because the business logic executes on the Application tier, its website directory
must be identical to the Presentation tier's.

Impact of 3-tier setup on a developer
The Unity Framework provides the same developer experience, whether you use 2- or
3-tier architecture, by defining which container to use in the web.config file. See also:
Introduction to Unity, Creating a sample content block in 3-tier architecture on
page 183.
NOTE: You do not need to know about the Unity Framework—it is mentioned here to
help you understand how Ektron achieves 2-tier and 3-tier architecture.
Ektron has 3 main containers, which transmit data between tiers.
l

Business object (BusinessObjects.Content)
o contains Ektron's implementation of business logic
o

used in 2-tier architecture

o

in 3-tier architecture, executed in the Application tier

l

WCF service proxy (Framework.Services.Content.ContentServiceClient)
o used in 3-tier architecture to communicate between Application and
Presentation tiers

l

Cache (BusinessObjects.Caching.Content)
o Ektron uses the Unity Framework to insert a caching layer
o

When an API call is made (or a templated server control is used) from the
Presentation tier, Ektron caches frequently-used objects

o

Caching minimizes API calls between Application and Presentation tiers
NOTE: Caching uses a provider model. By default, Web caching is
implemented, but you can replace it with other caching options.

The following chart shows how the Framework API uses the containers.
1. Content manager gets initialized and implements the IContentManager interface.
2. The Presentation tier uses the container specified in web.config. In web.config, if
defaultContainer= “Default”, the Presentation tier first looks in cache for the
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requested data object. If the data object is not there, the Presentation tier looks in
the ChildContainer property value, which is WCF by default.

Setting up 3-tier architecture
PREREQUISITES
l

The IP address of your application tier server

l

If the Ektron machine is running Windows 2012 server, you must install
WCF HTTP Activation.
Installing WCF HTTP Activation
a. Launch Server Manager from the task bar or Start menu.
b. Choose the server on which you want to install WCF.
c. From the task drop-down, scroll to Roles and Features.
d. On the Add Roles and Features Wizard dialog, in the left panel,
select Features.
e. Expand .NET Framework 4.5 Features.
NOTE: If you have not installed .NET 4.5, go back to Server
Roles and install it.
f. Under WCF Services, check the HTTP-Activation box.
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g. Click Install.

1. On your Web Application server, install an Ektron website to the site root folder (if
you do not already have one). During installation, install the Ektron database to a
remote SQL Server.
NOTE: The 8.5 and higher installation includes a
startersites\3TierMin\Content folder that contains files needed for the
Presentation tier.
2. On the Web application server, copy the C:\Program Files
(x86)\Ektron\CMS400vxx\startersites\3TierMin\Content folder.
3. On the Presentation tier server, paste that folder to the website root folder.
4. On the Presentation tier server, open IIS and make the new folder a website. See
also: Creating multiple websites on a single server on page 95.
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5. On the Presentation tier server, open the site root/web.config file.
6. Update ek_ServicesPath to point to the workarea/services folder on your
Application tier server.
<appSettings>
<!-- This is the path to your CMS App Site.
It should always end in workarea/services/ -->
<add key="ek_ServicesPath" value="http://[YOUR_CMS_SERVER]
/workarea/services/" />
</appSettings>

7. If you want to turn on caching, set the following values in the web.config file.
<ektron.cacheProvider defaultProvider="webCache">
<providers>
<add name="webCache" cacheTimeSeconds="300"
type="Ektron.Cms.Providers.Caching.WebCacheProvider,
Ektron.Cms.Providers" />
</providers>
</ektron.cacheProvider>

Ektron Reference

181

Distributing resources with 3-tier architecture

8. Make sure the value of the framework defaultContainer tag is Cache, and the
framework childContainer tag is WCF.
<framework defaultContainer="Cache" childContainer="WCF">

9. On the Application tier server, open IIS.
10. Click your website > workarea > services.
11. Click IP Address and Domain Restrictions in the right pane.
12. Click Add Allow entry and enter your Presentation layer's IP address.

13. Click your website > workarea > webservices. Then, click IP Address and
Domain Restrictions in the right pane.
14. Click Add Allow entry and enter your Presentation layer's IP address.
15. Open a browser and browse to your site.
16. Deploy templates and supporting files to the Presentation server.

Files copied to the Presentation tier
The following files are copied from the Application tier server to initialize the
Presentation tier after you complete the set up. The files are located in the
startersites\3TierMin\Content folder.
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l

App_Code folder. Contains URL Aliasing module See also: Aliasing with 3-tier
architecture on page 184.

l

Bin folder. Subset of full bin folder; contains binaries for Presentation tier only

l

Workarea folder. Subset of full Workarea folder; Framework UI is required to run
templated controls and PageBuilder controls on Presentation tier

l

The following configuration files:
o Ektron.cms.framework.ui. Contains default templates for templated server
controls
o

Ektron.cms.framework.unity. Has mapping interfaces and implementation

o

Ektron.cms.framework.ui.unity. Has mapping for templated control to
services
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l

Within web.config
o Within <configsections> tags. <sectionGroup> settings define how the
Presentation tier communicates with the Application tier
o

ek_ServicesPath. Defines the path to the Application tier's Web services file

o

The following UI elements for templated server controls
<ui.unity configSource="ektron.cms.framework.ui.unity.config" />
<ui configSource="ektron.cms.framework.ui.config" />

l

The <ektron.framework.services> tag defines the container.
<ektron.framework.services>
<unity configSource="ektron.cms.framework.unity.config"/>
<framework defaultContainer="Default" childContainer="WCF"/>
</ektron.framework.services>

If defaultContainer=“Default”, the Presentation tier first looks in cache for the
requested data object. If the data object is not there, the Presentation tier looks in the
ChildContainer property value, which is WCF by default.
l

content of <pages> tag. Controls used by PageBuilder and templated server
controls.

l

The <modules> section manages Aliasing. See also: Aliasing with 3-tier
architecture on the next page.
<system.webServer>
<modules runAllManagedModulesForAllRequests="true">
<add name="EkUrlAliasModule" type="UrlAliasingModule"
preCondition="integratedMode"/>
</modules>
</system.webServer>

Creating a sample content block in 3-tier
architecture
This example illustrates how the same code can work in the Application and
Presentation tiers. Ektron uses the Framework API to get a content item.
1. In Visual Studio, open the Presentation tier's website.
2. Add a new Web form.
3. Add a label control that can render a content block.
<asp:Label ID=”contentblock1” runat=”server”> </asp:Label>

4. Open the form’s code-behind file.
5. Insert the following code.
NOTE: This example assumes that ID 30 is a valid Ektron content item.
long id = 30;
if (!string.isNullorEmpty(Request.QueryString[“id”]))
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{ long.TryParse(Request.QueryString[“id”].ToString(), out id);
}

6. While in the code-behind file, initialize content manager as the logged in user.
ContentManager contentManager = new ContentManager();

7. Get the content and return it to the asp Label control.
ContentData data = contentManager.GetItem(id);
contentblock1.Text = data.Html;

8. Build and run.
9. Open a Web browser.
10. Insert the Presentation server/page you just created into your browser address
field, where you will see Ektron content through the Presentation tier.

Creating a PageBuilder page with 3-tier
architecture
PREREQUISITES
l

A PageHost file in the Presentation tier used specifically to support 3-tier
architecture. The file lets you view only; you cannot edit.

l

A widget built using the Framework API (for example, the sample
Content Block widget).
NOTE: A 3-Tier site contains many widgets. Only those built using
the Framework API work on the Presentation tier.

l

A wireframe template (content.pb.aspx) that exists on the Application
and Presentation tiers.

1. Go to the Application tier website's Workarea.
2. Create a sample PageBuilder page. See also: Developing wireframe templates on
page 1093.
3. Go to a folder to which the content.pb.aspx wireframe template is applied.
4. Create new Page Layout.
5. Drag and drop a content block widget onto the page layout and assign an Ektron
content item.
6. Publish.
7. Browse to the Presentation website to see the content.

Aliasing with 3-tier architecture
URL Aliasing works within 3-tier architecture. See also: Creating user-friendly URLs
with aliasing on page 1399.
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NOTE: Aliasing code is stored in the App_Code/CSCode/UrlAliasingModule.cs file.
3-tier architecture requires the Aliasing module files (UrlAliasingModule.cs and
UrlAliasingBase.cs in the App_Code/CSCode folder), and the registration of that
module in the web.config file. To verify the registration:
1. In the Presentation website, open siteroot/web.config. See also: Setting up 3tier architecture on page 179.
2. Go to the <Modules> tag.
3. Verify that the URL alias module is registered, as shown in the following code.
<modules runAllManagedModulesForAllRequests="true">
<add name="EkUrlAliasModule"
type="UrlAliasingModule"
preCondition="integratedMode" />
</modules>

To test URL aliasing, follow these steps.
1. Go to the Application tier website.
2. Create a content block.
3. On its Alias tab, enter a manual alias.

4. On the Template tab, choose a template that exists on the Application and
Presentation tiers.
5. Publish the content.
6. Verify that Aliasing works on the Application tier.
7. Verify that Aliasing works on the Presentation tier.

Using eSync with 3-tier architecture
You may use eSync to move files among tiers and sites, but eSync is not a prerequisite
of 3-tier architecture.
You can use eSync to move changes from the development to the staging to the
production sites. You also can use eSync to move changes from the Data to Application
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tier. Then, use Web services to move files from the Application tier to the Presentation
tier. However, see Limitations of 3-tier architecture on page 177.

Using search with 3-tier architecture
If you use Microsoft Search Server 2010 with 3-tier architecture, you do not need to
make any adjustments.
To use Solr search with 3-tier architecture, see Using Solr search with 3-tier
architecture below.
To use Microsoft FAST Search Server 2010 search with 3-tier architecture, see Using
Solr search with 3-tier architecture below.

Using Solr search with 3-tier architecture
If you are using Solr search for your presentation layer, follow these steps to prepare it
for Solr.
1. Open the presentation layer's site root/ektron.cms.framework.unity.config file.
2. Locate the following section.
<!-- Search-->
<typeAlias alias="BusinessObjects.ICrawler"
type="Ektron.Cms.Search.SearchServerCrawler, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchSettings"
type="Ektron.Cms.Search.SearchSettings, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISynonyms" type="Ektron.Cms.Search.CmsSynonyms,
Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISuggestedResults"
type="Ektron.Cms.Search.SuggestedResults, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchManager"
type="Ektron.Cms.Search.SearchManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchPropertyRule"
type="Ektron.Cms.Search.SearchPropertyRule, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchProvider"
type="Ektron.Cms.Search.SS2010.SS2010SearchProvider, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchResultBuilder"
type="Ektron.Cms.Search.SharePointSearchResultBuilder, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IIntegratedSearchMapping"
type="Ektron.Cms.Search.IntegratedSearchMapping, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IPropertyNameResolver"
type="Ektron.Cms.Search.SharePointPropertyNameResolver, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IDocumentPromotionManager"
type="Ektron.Cms.Search.DocumentPromotionManager, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryProposition"
type="Ektron.Cms.Search.SharepointQueryPropositionService, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryPropositionManager"
type="Ektron.Cms.Search.QueryPropositionManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IRecordQueryStatisticsHelperService"
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type="Ektron.Cms.Search.SharepointRecordQueryStatisticsService,
Ektron.Cms.Search"/>

3. Replace that section with the following code.
4. <!-- Search-->
<typeAlias alias="BusinessObjects.ICrawler" type="Ektron.Cms.Search.SolrCrawler,
Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchSettings"
type="Ektron.Cms.Search.SearchSettings, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISynonyms" type="Ektron.Cms.Search.CmsSynonyms,
Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISuggestedResults"
type="Ektron.Cms.Search.SuggestedResults, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchManager"
type="Ektron.Cms.Search.SearchManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchPropertyRule"
type="Ektron.Cms.Search.SearchPropertyRule, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchProvider"
type="Ektron.Cms.Search.Solr.SolrSearchProvider, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchResultBuilder"
type="Ektron.Cms.Search.Solr.SolrSearchResultBuilder, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IIntegratedSearchMapping"
type="Ektron.Cms.Search.IntegratedSearchMapping, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IPropertyNameResolver"
type="Ektron.Cms.Search.Solr.SolrPropertyNameResolver, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IDocumentPromotionManager"
type="Ektron.Cms.Search.DocumentPromotionManager, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryProposition"
type="Ektron.Cms.Search.Solr.SolrQueryPropositionService, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryPropositionManager"
type="Ektron.Cms.Search.QueryPropositionManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IRecordQueryStatisticsHelperService"
type="Ektron.Cms.Search.Solr.SolrRecordQueryStatisticsHelperService,
Ektron.Cms.Search"/>

Using Microsoft FAST Search Server 2010 with 3-tier
architecture
If you are using Microsoft FAST Search Server 2010 for your presentation layer, follow
these steps to prepare it for FAST.
1. Open the presentation layer's site root ektron.cms.framework.unity.config file.
2. Locate the following section.
<!-- Search-->
<typeAlias alias="BusinessObjects.ICrawler"
type="Ektron.Cms.Search.SearchServerCrawler, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchSettings"
type="Ektron.Cms.Search.SearchSettings, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISynonyms" type="Ektron.Cms.Search.CmsSynonyms,
Ektron.Cms.Search"/>
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<typeAlias alias="BusinessObjects.ISuggestedResults"
type="Ektron.Cms.Search.SuggestedResults, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchManager"
type="Ektron.Cms.Search.SearchManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchPropertyRule"
type="Ektron.Cms.Search.SearchPropertyRule, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchProvider"
type="Ektron.Cms.Search.SS2010.SS2010SearchProvider, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchResultBuilder"
type="Ektron.Cms.Search.SharePointSearchResultBuilder, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IIntegratedSearchMapping"
type="Ektron.Cms.Search.IntegratedSearchMapping, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IPropertyNameResolver"
type="Ektron.Cms.Search.SharePointPropertyNameResolver, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IDocumentPromotionManager"
type="Ektron.Cms.Search.DocumentPromotionManager, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryProposition"
type="Ektron.Cms.Search.SharepointQueryPropositionService, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryPropositionManager"
type="Ektron.Cms.Search.QueryPropositionManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IRecordQueryStatisticsHelperService"
type="Ektron.Cms.Search.SharepointRecordQueryStatisticsService,
Ektron.Cms.Search"/>

3. Replace that section with the following code.
<!-- Search-->
<typeAlias alias="BusinessObjects.ICrawler"
type="Ektron.Cms.Search.SearchServerCrawler, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchSettings"
type="Ektron.Cms.Search.SearchSettings, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISynonyms" type="Ektron.Cms.Search.CmsSynonyms,
Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISuggestedResults"
type="Ektron.Cms.Search.SuggestedResults, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchManager"
type="Ektron.Cms.Search.SearchManager, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchPropertyRule"
type="Ektron.Cms.Search.SearchPropertyRule, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.ISearchProvider"
type="Ektron.Cms.Search.FS2010.FS2010SearchProvider, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.ISearchResultBuilder"
type="Ektron.Cms.Search.SharePointSearchResultBuilder, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IIntegratedSearchMapping"
type="Ektron.Cms.Search.IntegratedSearchMapping, Ektron.Cms.BusinessObjects"/>
<typeAlias alias="BusinessObjects.IPropertyNameResolver"
type="Ektron.Cms.Search.SharePointPropertyNameResolver, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IDocumentPromotionManager"
type="Ektron.Cms.Search.DocumentPromotionManager, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryProposition"
type="Ektron.Cms.Search.SharepointQueryPropositionService, Ektron.Cms.Search"/>
<typeAlias alias="BusinessObjects.IQueryPropositionManager"
type="Ektron.Cms.Search.QueryPropositionManager, Ektron.Cms.BusinessObjects"/>
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<typeAlias alias="BusinessObjects.IRecordQueryStatisticsHelperService"
type="Ektron.Cms.Search.SharepointRecordQueryStatisticsService,
Ektron.Cms.Search"/>
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Ektron Web search finds relevant results within several parts of the CMS structure and
offers massive scalability, scaling to tens of millions of items and beyond. Search
capability is based on Microsoft Search Server or Apache Solr technology, which provide
superior search capability with performance and extensibility currently demanded by
enterprises world wide. There are specific search functions for the visitor using the
website and the administrator using the Workarea. You can search content, documents,
metadata, keywords, descriptions, titles, community content, users, groups, and
activity streams.
For more information about Search, see the Ektron Framework API >
Ektron.Cms.Framework.Search and the Framework UI > Templated Server
Controls > Search in the Ektron Online Developer's Reference.

Search providers
BEST PRACTICES
l

The server hosting your search provider needs at least 120 GB free
space.

l

Install SQL Server on a standalone server

l

Operating system is Microsoft Windows Server 2008 R2 or 2012

You can choose from the following search providers. Use the following guidelines to
determine which search server is best for you.
l

Solr Search
o An open-source, enterprise-level search platform, from the Apache Lucene
project, that is known for scalability and performance.
o

l

Installing Solr on a single on-premises (local) server on page 229

Microsoft Search Server Express 2010
IMPORTANT: As of Ektron version 9.3 SP1, Microsoft Search Server 2010
Express is no longer supported.

l

o

A free, enterprise search solution that is simple and flexible to configure, and
powerful enough to meet your needs.

o

Requirements: Hardware and software requirements (Search Server 2010)

o

Installation: Setting up Microsoft Search Server 2010 Express on page 317

Microsoft Search Server 2010
IMPORTANT: As of Ektron version 9.3 SP1, Microsoft Search Server 2010 is no
longer supported.
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o

You are indexing more than 10 million items.

o

Requirements: Hardware and software requirements (Search Server 2010)
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o

Installation: Setting Up Microsoft Search Server 2010 on page 325

l

Microsoft Search Server 2013 or 2016
o Installation: Installing and Setting up Microsoft Search Server 2013 or 2016
on page 405

l

Microsoft FAST Search Server 2010
o You are indexing more than 100 million items.

l

o

Requirements: Hardware and software requirements (FAST Search Server
2010 for SharePoint)

o

Installation: Working with Microsoft FAST search on page 466

Optimizely Search & Navigation
o A powerful and scalable query platform that lets you index and query large
amounts of structured or unstructured content
o

Using Optimizely Search & Navigation with Ektron on page 195

Search provider comparisons
The following table compares functionality available with search providers.

Function

Solr search

Microsoft
Search
Server
Express

Microsoft
Search
Server
2010, 2013,
or 2016

Microsoft
FAST
Search
Server

Providing
suggested results
on page 376
(managed within
Ektron)
Synonym sets
(managed within
Ektron)
Integrated search
Load balanced
search
Faceted search
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Function

Solr search

Microsoft
Search
Server
Express

Microsoft
Search
Server
2010, 2013,
or 2016

Microsoft
FAST
Search
Server

as supported
by Microsoft
Search
Server
Express

as supported
by Microsoft
Search
Server

as supported
by Microsoft
Fast Search
Server

Similar Results

Autosuggest

see autocomplete

Autocomplete
"Did you
mean?" feature

Language support

1—additional

single word only

14 supported
"out of the box"1

languages may be enabled; see Solr language support on page 305

This chapter also contains the following topics.
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l

Using Solr search on page 216

l

Setting up Microsoft Search Server 2010 Express on page 317

l

Setting Up Microsoft Search Server 2010 on page 325

l

Installing and Setting up Microsoft Search Server 2013 or 2016 on page 405

l

Working with Microsoft FAST search on page 466

l

Using Microsoft Search Server features on page 360

l

Search Templated Server Controls

l

Using Optimizely Search & Navigation with Ektron on the facing page
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Using Optimizely Search
& Navigation with Ektron
Optimizely Search & Navigation is a powerful and scalable query platform that lets you
index and query large amounts of structured or unstructured content. Using Optimizely
Search & Navigation, you can create customized website search functionality or build
advanced navigation for non-hierarchical content. Other search providers use a crawl to
update site content, which can delay the updating of search results. Optimizely Search
& Navigation, on the other hand, uses push technology, which means that search
results on your website are updated in near real-time.
Optimizely Search & Navigation provides search capabilities for all Ektron content,
including HTML content, HTML forms, Smart Forms, assets, and PageBuilder. When
using Optimizely Search & Navigation with Ektron, Ektron content and documents are
initially pushed to a Find index. from then on, the Find index is updated whenever
Ektron content is edited, deleted, or added. For example, if content is scheduled to go
live at a future date and time, Optimizely Search & Navigation can retrieve the content
after the go-live date and time. Similarly, content scheduled to be archived and
removed from site is no longer available in search results as of the scheduled date and
time. To query the index and return search results, use Find APIs.
Because Find does not impact existing search capabilities, it can co-exist with your
current search provider.

Setting up Optimizely Search & Navigation
This section explains how to set up Optimizely Search & Navigation as a search provider
for your Ektron website.
PREREQUISITE

Ektron version 9.10 SP1 or higher

Obtaining Find indexes
Upon creating a developer account, you can use a free development index for testing.
This index has a 10,000 document limit, a 90-day lifespan, and a maximum file size of 5
MB.
After completing testing, if you want to move into a production environment, obtain a
production index. See http://www.episerver.com/orderfind.
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Installing Optimizely Search & Navigation
1. Create an Optimizely Search & Navigation developer service.
a. Go to http://find.episerver.com/.
b. Create an account and verify it.
c. Click Add Developer Service. The Create Developer Service screen appears.
d. Enter an index name, choose languages to support, accept the terms and
conditions, and click Create Service. The Index Details screen displays your
information.
TIP — SAVE THIS PAGE WITH YOUR BROWSER FAVORITES SO YOU CAN QUICKLY OPEN IT
IN THE FUTURE.

2. Prepare the Ektron website in Visual Studio.
a. Open the Ektron site as a website.
b. Save a solution file for the site.
c. Set the site's Target Framework to .NET Framework 4.5.
3. Update the Ektron web.config file with snippets from the Create Service screen.
a. From the Optimizely Search & Navigation Create Service screen, copy the
web.config snippet within the <configSections> tag.

b. Open your Ektron siteroot\web.config file.
c. Find the closing configSections tag (</configSections>).
d. Paste the copied text above the closing </configSections> tag.
e. From the Optimizely Search & Navigation Create Service screen, copy the
web.config snippet below the closing </configSections> tag and above the
closing </configuration> tag.

f. Within the Ektron siteroot\web.config file, find the closing configuration tag

196

Ektron 9.40 SP1

Installing Optimizely Search & Navigation

(</configuration>).
g. Paste the copied text above that tag.
4. Create an Optimizely Search & Navigation package source.
a. In Visual Studio, choose Tools > Library Package Manager > Package
Manager Settings. The Options screen appears.
b. Under Package Manager, choose Package Sources.
c. Add a new source called Episerver Find. Assign it a URL of
http://nuget.episerver.com/feed/packages.svc/
5. Install the Ektron.Cms.Find Nuget package.
a. In Visual Studio, open Solution Explorer.
b. Right-click the Ektron website project.
c. From the context menu, choose Manage NuGet Packages...
d. In the left panel, choose Online.
e. In the Search field, enter Ektron.cms.find.
f. Click the Ektron.Cms.Find package's Install button.
6. Update the Global.asax file with a reference to bootstrapper file.
a. Open yoursiteroot\Global.asax.
NOTE: If your siteroot folder does not contain a Global.asax file, create
one.
b. Find the following method:
void Application_Start(object sender, EventArgs e)
{
}

c. Between the curly brackets ({}), insert the following code.
Ektron.Cms.Find.AspNetBootstrapper.EktronFindBootstrapper.Start();

7. To update the Find index with content changes created by Ektron eSync, follow
these steps.
a. Stop the Ektron Windows Service.
b. Copy the Ektron.Cms.Find.EsyncNotification.dll file from the bin folder. Paste it
to the C:\Program Files (x86)\Ektron\EktronWindowsService40 folder.
c. Open the C:\Program Files
(x86)\Ektron\EktronWindowsService40\objectFactory.config file.
d. Find the following section of the file.
<add name=”ESyncNotification”>
<strategies>
</strategies>
</add>

Ektron Reference

197

Setting up search for your website

e. Within the <Strategies> tags, insert the following line.
<add name="FindStrategy" type="Ektron.Cms.Find.EsyncNotification.FindStrategy,
Ektron.Cms.Find.EsyncNotification"/>

f. Save the objectFactory.config file.
g. Restart the Ektron Windows Service.

Loading Ektron content into the Find index
After installing Optimizely Search & Navigation, push your website content to the Find
index.
PREREQUISITES
l

You completed all installation steps. See Installing Optimizely Search
& Navigation on page 196.

l

You are a member of the Ektron Administrators Group.

1. Open the following URL: yoursiteroot/episerverfind/. The following screen
appears.

l

The Find Configuration field indicates that the Global.asax file includes the
correct reference to the bootstrapper file. (This step was covered in Installing
Optimizely Search & Navigation on page 196.)

l

The Find Availability field indicates that your web.config file was updated
with snippets from the Create Service screen. (This step was also covered in
Installing Optimizely Search & Navigation on page 196.)

2. Click Index All Content. The screen indicates that indexing has begun.
3. Click Refresh Status occasionally to view progress. When the Total Documents
Indexed number stops changing, indexing is complete.

Using Find with Ektron content types
IMPORTANT: When you edit the bootstrapper file or code that it references, you
must restart IIS to push the latest changes to Find. Then, clear the Find index and
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reindex. These actions prevent mismatches between the Find index and custom
types that use it.

Using Find to query HTML content
You can used FIND APIs to query and filter published HTML content by the following
properties.
l

Title

l

Body

l

Summary

l

Taxonomy category

l

Creation date

l

Modification date

l

Last editor

l

Folder

l

Content ID

l

Language

l

Quicklink

Using Find with a PageBuilder page
Optimizely Search & Navigation returns search results for all searchable content on a
published PageBuilder page. Text that appears on such a PageBuilder page is indexed,
along with the page's title. For example, if a PageBuilder page includes a collection
widget, and each collection item's teaser is displayed, the teaser text is searchable.

Indexing PageBuilder master layouts
Pagelayout pages are indexed. Master layouts are not indexed, but PageBuilder pages
based on a master layout are indexed. See also: Creating a PageBuilder master layout
on page 1097.

Suppressing page elements from search results
You may want to suppress certain page elements from search results. For example, you
want to exclude navigation menus or footers. The following Knowledge Base article
explains how to do this: How to hide an element on a PageBuilder page from showing
up in search results.
NOTE: Any text that is not visible to the builtin user is not indexed.
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Using Find with Ektron Smart Forms
NOTE:
* If you want a Smart Form to be indexed, you must select its Content Searchable
checkbox.
* The Indexed checkbox on Smart Form configuration field's dialog has no effect on
whether the field’s content is searchable. Any property specified in your custom
Smart Form class and populated by serialization logic is searchable.
You can query Smart Forms using the content type Smartform. For
example: SearchResults<Ektron.Cms.Find.Models.SmartForm> results;
If you use this approach, Episerver Find returns Smart Form content as a single string.
To extract field data, developers must use a string split technique.
If you want to query data stored in Smart Form fields, use a type mapper to store a
custom content type. This type lets you convert each field in Smart Form configuration
to a field in a custom object. You can then use Find to query that object using this
syntax.
var results = client.Search<customclassname>().Filter(…).GetResult();

For example, if the class created for your Smart Form configuration is OurTeam, you
would use this.
var results = client.Search<OurTeam>().Filter(…).GetResult();

To learn how to use a type mapper to store a custom content type, see Converting a
Smart Form configuration to a class below.
Converting a Smart Form configuration to a class

Converting a Smart Form configuration to a class
Complete these steps for each Smart Form configuration that you want to convert into a
class. After you complete the procedure, Optimizely Search & Navigation indexes
registered configurations when a Smart Form is edited or added.
NOTE: To learn about updating Find upon deleting, see Updating Find index upon
deletion of a Smart Form on page 206.
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Part 1: Analyze the Smart Form configuration
1. Obtain the Smart Form configuration’s ID. You use this information in later steps.

2. Analyze the configuration’s XML structure: its root class and subclasses. These
appear on the View Smart Form Configuration screen's Display Information tab.
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Consider the following example.

This Smart Form configuration has the following structure. You use this information in
later steps
Root class: Ourteam
Subclass: Employee profile
Subclass: Image
Subclass: img

Part 2: Create class and move .dll to bin folder
1. In Visual Studio, create a class library.
2. Save the Smart Form configuration schema as an XSD file, then generate a class
from it. This procedure is explained in steps 1 (Save Schema XSD File) and 2
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(Generate Class from XSD) in the Ektron Knowledge Base article "Generate Class
for Smart Form.
3. Move the .cs file created in step 2 to the Visual Studio class library.
4. Build your Ektron solution. This action creates a .dll file in your Visual Studio
project's bin\Debug folder. For example: C:\Users\jedit\Documents\Visual
Studio
2012\Projects\MySmartFormClassLibrary\MySmartFormClassLibrary\bin\De
bug.
The file name matches the Smart Form configuration name.
5. Copy the .dll file to your Ektron website's bin folder.

Part 3: Register the class
1. In Visual Studio, open your Ektron website solution.
2. Open the findbootstrapper.cs file, located in C:\Users\user
name\Documents\Visual Studio
version
\Projects\yoursitename\packages\Ektron.Cms.Find.1.0.0\content\App_
Code\CSCode\.
3. Find these comments.
// Register type mappings below to translate Smart Forms
// to custom models.
// Example:
// ektronMessaging.Types.Register(content => new MySmartFormModel { ... })
//
.For(content => content.XmlConfiguration.Id == ...);

4. Below the comments, register the class you created in Part 2: Create class and
move .dll to bin folder on the previous page. To do that, use this syntax:
ektronMessaging.Types.Register(SmartForm configuration name.Create)
.For(SmartForm configuration name.CanCreate);

For example:
ektronMessaging.Types.Register(OurTeam.Create).For(OurTeam.CanCreate);

NOTE:
* The Ektron Messaging class’s Types property configures how Ektron indexes
content.
* Register converts Ektron content data to an object that Optimizely Search
& Navigation can query.
* As an argument, the Register method takes a delegate, which receives
content data and returns an object. This object is pushed to the Find index.
* The .For statement enables you to map only content data that satisfy a
criterion. .For takes a delegate, which returns a Boolean. Content is only
converted to the registered class if Ektron content data matches this criterion.
Without a .For statement, the type mapper applies to all content passed
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through the system.
* The CanCreate method is defined in your configuration's .cs file. See step 10
later in this section.
5. Open the .cs file that you created in step 2 of Part 2: Create class and move .dll to
bin folder on page 202. It contains your configuration's XML structure. For
example:
namespace MySmartFormClassLibrary
{
public class Image
{
public img img { get; set; }
}
public class EmployeeProfile
{
public string Name { get; set; }
public string Title { get; set; }
public string Summary { get; set; }
public string LinkedIn { get; set; }
public string Twitter { get; set; }
public string Bio { get; set; }
public Image Image { get; set; }
}

6. Find the following section. The sample below continues using the OurTeam
configuration.
[XmlRoot("root")]
public class OurTeam
{

7. Under that section, insert the following code. It creates a unique identifier for the
Smart Form configuration.
public long Id { get; set; }
public int LanguageId { get; set; }
public string Title { get; set; }

IMPORTANT: Repeat steps 8 through 10 for each subclass directly below
/root/ in your Smart Form configuration.
8. Declare the first subclass in your configuration. (This was discovered in Part
1: Analyze the Smart Form configuration on page 201.)
public EmployeeProfile EmployeeProfile { get; set; }

9. Add the following code to set property values for the OurTeam configuration.
Replace references to OurTeam with your Smart Form configuration name.
NOTE: Ektron Smart Forms store rich text HTML as valid XML. This code
deserializes rich text HTML into an encoded XML string, which Find can
consume.

204

Ektron 9.40 SP1

Part 3: Register the class

public static OurTeam Create(ContentData content)
{
XmlSerializer serializer = new XmlSerializer(typeof(OurTeam));
OurTeam oTeam = (OurTeam)serializer.Deserialize(new StringReader
(content.Html));
oTeam.Id = content.Id;
oTeam.LanguageId = content.LanguageId;
oTeam.Title = content.Title;
return oTeam;
}

10. Define the CanCreate method, which is referenced in the findbootstrapper.cs
file's registration method, which returns the config ID for registering the type (see
step 4 above).
11. Replace the ID number with your configuration ID, which you obtained in Part
1: Analyze the Smart Form configuration on page 201.
public static bool CanCreate(ContentData content)
{
return content.XmlConfiguration.Id == 8;
}

Here is the complete sample file, OurTeam.cs.
OurTeam.cs sample file
using
using
using
using
using
using
using
using

Ektron.Cms;
System;
System.Collections.Generic;
System.IO;
System.Linq;
System.Text;
System.Threading.Tasks;
System.Xml.Serialization;

namespace MySmartFormClassLibrary
{
public class Image
{
public img img { get; set; }
}
public class EmployeeProfile
{
public string Name { get; set; }
public string Title { get; set; }
public string Summary { get; set; }
public string LinkedIn { get; set; }
public string Twitter { get; set; }
public string Bio { get; set; }
public Image Image { get; set; }
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}
[XmlRoot("root")]
public class OurTeam
{
public long Id { get; set; }
public int LanguageId { get; set; }
public string Title { get; set; }
public EmployeeProfile EmployeeProfile { get; set; }
public static OurTeam Create(ContentData content)
{
XmlSerializer serializer = new XmlSerializer(typeof(OurTeam));
OurTeam oTeam = (OurTeam)serializer.Deserialize(new StringReader
(content.Html));
oTeam.Id = content.Id;
oTeam.LanguageId = content.LanguageId;
oTeam.Title = content.Title;
return oTeam;
}
public static bool CanCreate(ContentData content)
{
return content.XmlConfiguration.Id == 8;
}
}
}

Updating Find index upon deletion of a Smart Form
If you delete a Smart Form configuration, its content remains in the Find index. To
remove the custom type entries of a Smart Form from the index, remove the type
mapper by not registering it. Then, clear the index and reindex. These actions index the
Smart Form contents as the default Smart Form type.
Alternatively, you can delete individual documents from the Find index using the
following article: http://world.episerver.com/documentation/Items/DevelopersGuide/Episerver-Find/9/DotNET-Client-API/Deleting-documents/.

Smart Form indexing guidelines
When you create a Smart Form configuration, no indexing occurs because there is
nothing to index at this point. If Smart Form content is published before the
configuration is converted to a class, it is indexed as HTML content. If you later convert
the configuration to a class, you should clear the index and reindex your site to make
Smart Form content available to Optimizely Search & Navigation.
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Similarly, if you modify a class, you should clear the index and reindex your site.

Using Find to search by taxonomy
Taxonomy and category information is updated in the Find index whenever any of these
events occurs.
l

A taxonomy category is assigned to content.

l

A taxonomy category is removed from content.

l

A taxonomy category is updated.

l

A taxonomy category is removed.

Find divides taxonomy paths into individual taxonomies, indexes each category, and
returns the following string-based properties.
l

Id. the taxonomy ID.

l

Path. the taxonomy path using category titles.

l

IdPath. the taxonomy path using IDs.

For example:
Root taxonomy
"Id$$string":"154",
"Path$$string":"\Food",
"IdPath$$string":"\154",

Child taxonomy
"Id$$string":"155"
"Path$$string":"\Food\Chinese"
"IdPath$$string":\154\155

IMPORTANT: All properties are stored as strings.

Taxonomy-based search and parent/child nodes
When a search query uses a taxonomy filter, the results include content assigned to
child categories even if the query only specifies the root taxonomy. Similarly, if a query
specifies a child category, parent taxonomy categories are available, so users can find
content by searching any category in the tree.
Consider the following example.
l

Content title. General Guidelines for Cooking
o ID. 68
o

l

Taxonomy path. \Food

Content title. Grilled Asian Chicken
o ID. 231
o

Taxonomy path. \Food\Chinese
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Search query 1
IClient client = Client.CreateFromConfig(); //A client retrieved from config or injected
into the method
client.Search<Ektron.Cms.Find.Models.Content>()
.Filter<Ektron.Cms.Find.Models.Content>(c =>
c.Categories.MatchContained<TaxonomyCategory>(tax => tax.Path, @"\Food"))
.GetResult();

When executed, this code returns content assigned to the Food and Chinese
categories. So, content IDs 68 and 231 are returned even though 231 is not assigned to
the Food category.
Search query 2
client.Search<Ektron.Cms.Find.Models.Content>()
.Filter<Ektron.Cms.Find.Models.Content>(c =>
c.Categories.MatchContained<TaxonomyCategory>(tax => tax.Path, @"\Food\Chinese"))
.GetResult();

When executed, this code returns content assigned to the Chinese and Food
categories. So, content IDs 231 and 68 are returned.

Using Optimizely Search & Navigation to search assets
Episerver Find can retrieve search results from assets as it does with HTML content.
l

Maximum file size. Developer index: 5 MB; Production index: 50 MB.
NOTE: Indexed files are sent base 64 encoded, which increases their size by
roughly 1/3.

l

Supported file types. See
http://world.episerver.com/documentation/Items/Developers-Guide/EpiserverFind/9/DotNET-Client-API/File-attachments/.

l

Text-based documents. You can search text inside PDFs, Word documents, and
so on.

l

You can search and filter by the following criteria:
o Ektron title
o

summary

o

path

o

searchable metadata

Using Optimizely Search & Navigation to search Ektron
metadata
If you want to query data stored in Ektron metadata, use a type mapper to store a
custom content type. This type lets you convert selected metadata definitions to a field
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in a custom object. You then can use Optimizely Search & Navigation to query that
object using this syntax.
var results = client.Search<custommetadataclassname>().Filter(…).GetResult();

For example, if the class created for your metadata definition is
UnstructuredContentModelWithMetadata, you would use the following code.
var results = client.Search<UnstructuredContentModelWithMetadata>().Filter(…).GetResult
();

To convert a metadata definition to a class, use the following steps.
PREREQUISITE

Your Ektron CMS has metadata definitions that are applied to content and to
which values are entered. The definitions must be of the Searchable
Property type, publicly viewable, and active. See also Metadata types on
page 822.

1. Create a class for each group of Ektron metadata definitions that Find will query.
Within the class, create a property that maps to each metadata definition. The
class's type must match the metadata definition's type. For example:
public class UnstructuredContentModelWithMetadata : UnstructuredContent
{
public string SearchTextMetadata { get; set; }
public List<string> SearchSelectionMetadata { get; set; }
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public DateTime SearchDateMetadata { get; set; }
public int SearchNumberMetadata { get; set;
public string mymeta { get; set; }
public UnstructuredContentModelWithMetadata()
{
SearchSelectionMetadata = new List<string>();
}
}

This example illustrates the following metadata definitions and their types.
SearchTextMetadata. type:string
l SearchSelectionMetadata. type:List<string> (user can select one or
several string values)
l SearchDateMetadata. type:datetime
l SearchNumber. type:integer
2. To enable Optimizely Search & Navigation to search a class, register it in the
EktronFindBootstrapper file, located in siteroot\App_Code\CSCode\. Enter the
register statement below applicationBuilder.App.Start(); as shown in the
following example:
l

ektronMessaging.Types.Register(CreateMyUnstructuredContentModelWithMetadata)
.For(content => (content.XmlConfiguration.Id == 0 &&
(content.SubType ==
Common.EkEnumeration.CMSContentSubtype.Content && content.Type == 1)
));

Register specifies how to convert Ektron ContentData to an instance of the
new type created in Step 1. It accepts a condition that selects eligible CMS
content to be indexed as this type. The
CreateMyUnstructuredContentModelWithMetadata method is described in
step 3.
l .For is a filter that determines which Ektron ContentData can be mapped. In
this example, only HTML content is eligible.
3. Create a function that accepts an Ektron ContentData object and converts it to a
type defined in step 1. This type is indexed by Find for content matching the .For
filter condition specified in step 2 .
You define the function (CreateMyUnstructuredContentModelWithMetadata in
this example) under your site's AppCode directory or in a separate class library/dll.
l

In the following example, the function populates
UnstructuredContentModelWithMetadata with Ektron metadata for the Find
index.
private static UnstructuredContentModelWithMetadata
CreateMyUnstructuredContentModelWithMetadata(
ContentData data)
{
UnstructuredContentModelWithMetadata contentWithMeta = new
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UnstructuredContentModelWithMetadata();
if (data.MetaData == null || data.MetaData.Length <= 0)
return contentWithMeta;
IEnumerable<ContentMetaData> eligibleMetadata = GetMetadataForContent
(data.MetaData.ToList(),
data.FolderId, data.LanguageId);
\\ See note #1 below
ContentMetaData cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchText");
if (cm != null)
{
string metaValue = (string)cm.Text;
if (!String.IsNullOrWhiteSpace(metaValue))
{
contentWithMeta.SearchTextMetadata = metaValue;
}
}
\\ See note #2 below
cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchNumber");
if (cm != null)
{
int value;
if (Int32.TryParse(cm.Text, out value))
contentWithMeta.SearchNumberMetadata = value;
}
\\ See note #3 below
cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchDate");
if (cm != null)
{
DateTime mydate;
if (DateTime.TryParse(cm.Text, out mydate))
contentWithMeta.SearchDateMetadata = mydate;
}
\\ See note #4 below
cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchSelection");
if (cm != null)
{
string metaValue = (string)cm.Text;
if (!String.IsNullOrWhiteSpace(metaValue))
{
string[] metaValues = metaValue.Split(new string[] { ";" },
StringSplitOptions.RemoveEmptyEntries);
if (metaValues != null && metaValues.Length > 0)
{
contentWithMeta.SearchSelectionMetadata = metaValues.ToList();
}
}
}

Notes on the above sample
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l

#1 The following snippet uses the find-extension method to select only
SearchText metadata from ContentData. This type is a string, as defined in
the class and the Ektron metadata definition. If this metadata exists, apply it
to the SearchTextMetadata property of your class.
ContentMetaData cm = eligibleMetadata.ToList().Find(m => m.Name ==
"SearchText");
if (cm != null)
{
string metaValue = (string)cm.Text;
if (!String.IsNullOrWhiteSpace(metaValue))
{
contentWithMeta.SearchTextMetadata = metaValue;
}
}

l

#2 In the following snippet, the SearchNumber metadata is an integer in the
class and the Ektron metadata definition.
cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchNumber");
if (cm != null)
{
int value;
if (Int32.TryParse(cm.Text, out value))
contentWithMeta.SearchNumberMetadata = value;
}

l

#3 In the following snippet, the SearchDate metadata is a DateTime object in
the class and the Ektron metadata definition.
cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchDate");
if (cm != null)
{
DateTime mydate;
if (DateTime.TryParse(cm.Text, out mydate))
contentWithMeta.SearchDateMetadata = mydate;
}

l

#4 In the following snippet, SearchSelection metadata is a list of strings
(List<string>) in the class, and multiple selections in the Ektron metadata
definition. Ektron stores values as a single string, and each value is separated
by a delimiter (in this case, a semicolon (;)). For example, if metadata
definition stores transportation methods, its value might look like this:
train;bus;automobile.
cm = eligibleMetadata.ToList().Find(m => m.Name == "SearchSelection");
if (cm != null)
{
string metaValue = (string)cm.Text;
if (!String.IsNullOrWhiteSpace(metaValue))
{
string[] metaValues = metaValue.Split(new string[] { ";" },
StringSplitOptions.RemoveEmptyEntries);
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if (metaValues != null && metaValues.Length > 0)
{
contentWithMeta.SearchSelectionMetadata = metaValues.ToList();
}
}
}

The string[ ] line separates the multiple selection string into individual
values that Find can query.

How Find manages archived content
Content that has expired and is set to Archive and remove from site or Archive
and remain on site is not automatically removed from the index. Such content is
removed upon the next full reindexing. Until then, to exclude expired content from
search results, use the Find Client API's EndDate and EndDateAction properties to filter
results.
NOTE: Content that has expired but is set to Add to CMS Refresh reports is
considered live content, so remains in the Find index.

Working with the Optimizely Search & Navigation API
Usage of the Find Service and API is outside the scope of this document.

Querying and filtering Ektron content by type
Use the Ektron.Cms.Find.Models namespace to query and filter Ektron content. A
search page's .cs file typically contains a Searchresults command like this:
SearchResults<Ektron.Cms.Find.Models.Content> results;

The namespace contains these classes.
l

Content. Returns Ektron content types. See Fields that you can query and filter
using the content class on the next page.

l

PageBuilder. Returns PageBuilder content. It inherits all properties from the
content class.

l

UnstructuredContent. Returns HTML content. It inherits properties from the
content class.

l

SmartForm. Returns content from Smart Forms, as explained in Converting a
Smart Form configuration to a class on page 200. It inherits all properties from the
content class.

l

asset. Returns content from assets. You can filter them using their summary or
path. It inherits properties from the content class.

l

Taxonomy. Returns content assigned to selected categories. It inherits properties
from the content class.

Ektron Reference

213

Setting up search for your website

Fields that you can query and filter using the content class
namespace Ektron.Cms.Find.Models
{
public class Content : IHaveReferences
{
public Content();
public string Body { get; set; }
public IEnumerable<TaxonomyCategory> Categories { get; set; }
public DateTime CreationDate { get; set; }
public Author Editor { get; set; }
public Folder Folder { get; set; }
public long Id { get; set; }
public int Language { get; set; }
public DateTime ModificationDate { get; set; }
public string Quicklink { get; set; }
public DocumentReference Reference { get; set; }
public string Summary { get; set; }
public string Title { get; set; }
public DateTime EndDate { get; set; }
public EndDateAction EndDateAction { get; set; }
}
}

Using Episerver Find with eSync
If you want the Find index to be updated whenever eSync moves content changes
between servers, follow Step 7 in the installation instructions.
It takes longer for changes triggered by eSync to appear in search results than other
content changes. This is because, after an eSync is completed, a full reindex is
launched.

Notes and limitations of Episerver Find integrated with
Ektron
l
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Basic search, Advance search with match all, none, any word case can search in
fields:
o Title
o

Body

o

Summary

o

Editor first name

o

Editor last name
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o

Folder name

o

Quicklink

l

Taxonomy name

l

Synonym only works when searching one keyword

l

PDF and docx files: search by title only; cannot search by content

l

In Library: can only search for images

l

Archived content: If “Expired and remove from site” assigned, cannot be searched.

l

Search API (expression tree) limitations
l Does not support: ImplicitAnd, Scope, Permission, Boost, Keyword expression
l

l

Supports fields in filter: return and order by:
o Id
o

Language

o

FolderId

o

ContentType

o

ContentSubType

o

Title

o

QuickLink

o

Path

o

HighlightedSummary

o

Description

o

DateCreated

o

DateModified

o

ExpiryDate

o

ExpiryType

o

FolderName

o

Private

o

FolderPath

o

FolderIdPath

Not supported fields
o TaxonomyCategory
o

Tags

o

Author

o

Rank

o

Size

o

GoLiveDate

o

MapDate
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o

MapLongitude

o

MapLatitude

o

MapAddress

o

AssetVersion

o

SiteId

Related information
Optimizely Search & Navigation provides extensive capabilities for monitoring search
activity and customizing search functionality on your website. See the following related
information.
l

Developer documentation.
http://world.episerver.com/documentation/Items/Developers-Guide/EpiserverFind/9/

l

Searching (Episerver World article).
http://world.episerver.com/documentation/Items/Developers-Guide/EpiserverFind/9/DotNET-Client-API/Searching/Searching/

l

Developer forum. http://world.episerver.com/forum/developerforum/Episerver-Search/

l

Get started developing with Find.
http://world.episerver.com/documentation/Other-products/Episerver-Find/Getstarted-with-Find/

l

Episerver Find home page. http://world.episerver.com/add-ons/episerver-find/

Using Solr search
Solr is an open-source, enterprise-level search platform, from the Apache Lucene
project, that is known for scalability and performance. In its implementation of Solr,
Ektron uses Apache Tomcat to host the Solr application, and ManifoldCF to manage the
crawling of new or updated content. According to https://lucene.apache.org/solr/, "Solr
powers the search and navigation features of many of the world's largest internet
sites."
Using Solr, you can search all Ektron content, including Smart Forms and assets.
Ektron's Solr implementation supports advanced search features, such as Refinements,
Synonym Sets, Suggested Results, and Autocomplete. Solr also supports Ektron's
templated search server controls and API. So if you previously worked with these
components, you only need to master a few new concepts to migrate to Solr.
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NOTE: To compare Solr with other Ektron search providers, see Search provider
comparisons on page 193.

Solr Search Components

The Ektron Solr search provider is made up of several components, which can crawl
your content to index the latest changes, as well as manage search queries. Solr
manages the search for any number of Ektron instances, each of which can support
several sites.

Ektron crawl service
This diagram explains the crawl service's activities.

The Apache ManifoldCF (connector framework) crawls data from a repository connector
to an output connector. Ektron's Solr deployment uses its own repository connector
with the Solr output connector that updates the Solr Index.
When a site is registered, the following steps occur within ManifoldCF.
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1. An Ektron repository connection is created, using database information from the
Ektron site.
2. A Solr output connection is created with a connection to a Solr core exclusive to the
Ektron site.
3. Content, user, and community group jobs are created for each Ektron
repository/Solr output connection pair to crawl the various Ektron items.

Asset transfer service
Ektron's crawl component uses the Asset Transfer Service as the endpoint for crawling
assets. The Ektron Asset Transfer Server, which resides on the Ektron Web server, is
one half of a pair of services that supports the indexing of assets. (The Ektron Asset
Transfer Client resides on the Solr server.) When an asset is indexed, it must be
transferred to a cache on the Solr server before its content can be extracted.
When the crawl service requires an asset, it asks the Ektron Asset Transfer Client to
retrieve it. If the Ektron site and Solr run on the same server, the client directs the
indexer to the asset's location on the file system. If the asset resides on a remote
server, the client requests the asset from the appropriate Ektron Asset Transfer Server
and stores it in cache for indexing.

The crawl database
The crawl database stores and maintains the crawl state and crawl queues during a
crawl.

Ektron Solr admin service
The Ektron Solr Admin service manages
l

site registration requests (from the Solr Admin Console)

l

crawl management requests (from Ektron and EWS during eSync)

l

status requests from the Ektron Workarea's Search Status screen

During site registration, the admin service performs
l

validation tasks prior to site registration

l

job deletion and creation in ManifoldCF

l

Solr core deletion and creation

l

search configuration store and Ektron database updates with registration
information

the Solr Admin service also communicates with the crawler component (ManifoldCF) of
the Ektron site and fires an appropriate crawl of jobs for the core.

Ektron query services
This diagram depicts IIS query services that act as a proxy to the Solr counterparts.

218

Ektron 9.40 SP1

Solr core

The Query Service routes queries from sites registered with the Solr Search server to
the Solr core that corresponds to the site.
The Query Proposition service is a RESTful service that routes autocomplete queries to
the Solr core that corresponds to the site.
The Search Config database serves as a "centralized store." It maintains configuration
information for search endpoints, Solr, ManifoldCF, Admin Service, and registration
information for the registered sites.

Solr core
This diagram details the Solr core, the rectangle on the right side of the above image.
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A Solr core is a single instance of Solr with its own configuration, schema, and
independent index. Each Solr core can be thought of a compartmentalized Solr
application. It has several endpoints, called handlers, that serve requests addressed to
the core.
Ektron's search deployment uses handlers to manage queries (search queries &
completion requests), administrative requests (to manage cores), and content
updating.

Mime types supported by Solr search
Solr's ExtractingRequestHandler uses Tika to lets users upload binary files to Solr, and
then have Solr extract text from and index them. For a list of supported file types, see
https://tika.apache.org/1.4/formats.html.
Also, Ektron has its own list of files types that may be uploaded to the Workarea. You
can only upload supported file types. See Supported types of assets on page 710.
See also: Excluding Library Images When Using Solr Search.

Solr search concepts
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This section explains some inner workings of the Solr search. It is intended to help
explain why you do or do not get certain search results.

Keyword search
Keyword search is the search performed when a user types text or a phrase into a text
field. (A phrase is several words enclosed in quotes. For example, “This is a phrase”).
Keyword search is performed against the content title and the body only, because they
contain the "meat" of a content item.
NOTE: For HTML content, content body corresponds to the content table's content_
html column. For PageBuilder pages, content body corresponds to the content
table's content_text column.
Content title and body are subject to linguistic processing, which applies rules based on
the language of the search text or phrase. (By default, this is the site language, but it
can be changed via the Search API). For Solr-based search, linguistic processing refers
to stemming and stop word recognition only.

Stemming
Stemming reduces a word to its stem. English examples of stemming:
l

engineering > engine

l

parsing > pars

l

analysis > analysi

Stemming helps a user find desired content because, in most cases, the user is unsure
of the exact text in the document.
Stemming is applied when content is indexed and when query terms are processed.
During indexing, the content language is used to perform language-specific stemming.
During querying, the language of the query (by default, the site language) is used to
perform stemming.
Sometimes, stemming produces false matches. For example, the terms "engineering"
and "engine" are both reduced to "engine" during indexing. So, a query for "engine"
matches a document that contains "engineering". Also, since Solr only performs
stemming reduction, a query containing "ran" does not match a document containing
"running", since these words get reduced to "ran" (query side) and "run"(index time).
Out-of-the-box Solr only supports stemming and not the more extensive
lemmatization, which provides more accurate results and fewer false positives.

Stop words
Stop words are terms that are removed from queries and indexes because they do not
contribute to the quality of a search. For example, these are English stop words: "the",
"in," "an", "a".

Ektron Reference

221

Setting up search for your website

Query expression
The QueryText property of the KeywordSearchCriteria class contains the text or
phrase that a user enters when submitting a keyword search. With regards to Solr, any
query expression assigned to the ExpressionTree property of the
KeywordSearchCriteria class is treated as a filter query. The filter query merely helps
in reduction of the result subset and does not improve relevance.

Rank computation (relevance)
When ranking content returned as search results, Solr uses the quality of a document's
match against query text. Match quality is based on these factors.
l

Frequency of search text or phrase in the content.

l

Rarity of search terms with regards to the whole corpus of content (the entire site).

l

Proximity of search terms in the content. For example, if a query has the phrase
"content repository", content having "The content item rocks" in closest proximity
is ranked higher than content with the terms "lack of actual content in an item."

l

If search terms include an OR operator, content with the greatest number of terms
ranks highest. For example, if a query consists of "valid OR resultant OR set OR
items", content with "valid resultant set" ranks higher than content with "resultant
set."

Notes regarding rank computation (relevance)
l

When computing rank, Ektron Solr only considers terms in the content's title and
body.

l

Only terms entered against the QueryText property of the
KeywordSearchCriteria class are used for rank computation. Other fields
specified in the ExpressionTree property are not considered for rank
computation.

l

A match on content title has the same weight as a match on content body.

ContainsExpression vs EqualsExpression
When using Solr, the ContainsExpression can be tricky.
NOTE: A ContainsExpression involves using ContainsExpression directly or
indirectly via SearchContentProperty.<PropertyName>.Contains.
Unlike the C#/.NET String.Contains, Solr's ContainsExpression matches whole
words only—it does not match on substrings. For example, if a text metadata field
contains "Tax Revenue Statement, Year 2012," a contains search returns the content
if a query using ContainsExpression includes "Tax" or "Revenue Statement" or
"Revenue" as whole words. The query is not a match for the substring term "State."
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Also, the ContainsExpression query is case-insensitive. So for example, "Revenue" is
the same as "revenue" and "rEvenUe."
The EqualsExpression, on the other hand, performs a letter to letter, case-sensitive,
exact search on the entire text of a field.
NOTE: An EqualsExpression involves either EqualsExpression directly or
indirectly via SearchContentProperty.<PropertyName>.EqualTo.
To continue the above example for an EqualsExpression, a match results only if the
query is submitted as “Tax Revenue Statement, Year 2012”. Note the comma in the
query.

Using .Contains with Solr in Ektron version 9.30
When using the Solr search provider in Ektron version 9.30, the FolderId, FolderPath,
and TaxonomyPath .Contains syntax acts like a startswith expression instead of a
Contains one. Examples:
FolderIdPath examples
l

FolderIdPath .Contains "72/" returns content in folder 72 and subfolder 73

l

FolderIdPath .Contains "72/73/" returns content in folder 73

l

FolderIdPath .Contains "73/", "73", "/73/" returns no content

Taxonomy examples
l

TaxonomyPath .Contains "12/" returns content in category 12 and sub-category
13

l

TaxonomyPath .Contains "12/13/" returns content in sub-category 13

l

TaxonomyPath .Contains "73/", "73", "/73/" returns no content

Exception
l

FolderIdPath or TaxonomyPath .Contains "/" returns content in the root
folder/taxonomy only

Configuring the Ektron Solr package for Java Heap Memory
The Ektron Solr package has the Java Heap Memory (HSQLDB-Crawl Database,
ManifoldCF-Crawler, and Tomcat-Solr Process) tuned to support the simultaneous
registration and crawling of multiple sites. This tuning is optimized for a server with at
least 8GB RAM and 2 high speed disks (1 for the search index, and 1 for search
installation). The tuning also accommodates servers with more than 8GB RAM.
Because the Solr configuration is less reliant on the Java Heap for loading the index ,
the default tuning should suffice for most production usages. Before changing the Java
Heap configuration, Ektron's Professional Services Group must evaluate your plans to
ensure that correct choices are being made with regards to garbage collection patterns
and search/crawl performance.
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After a site is registered, the first query served by Solr is slower than subsequent ones.
If the Solr server is rebooted, you can expect similar slowness for registered sites. To
avoid this slow first response, create a dummy search request to be run after a site is
registered for the first time. You can also avoid this slow first response by issuing a
search request from a site (for every site) after the Solr search server has been
rebooted.
You may perform additional performance tuning via the Apache Solr site. Before
making any adjustments, you must have a thorough understanding of the technologies.
Be very careful when tuning for performance.

Query suggestions vs query completions
Query suggestions are a search type-ahead feature, in which a search field presents
query options as the user begins to type in characters. Suggestions are based on
previously used, successful queries submitted by other users.

Query completions are another search type-ahead feature in which the search field
presents query options as a user begins to type in characters. However, in this case,
query options are based on either the search index (the default option) or a dictionary
of terms.
Ektron Solr only supports query completions.
You can change the source of query completions from the search index to a dictionary
of terms. See also: Managing Solr autoComplete on page 308.
With regards to query completions, the search only considers terms from the title by
default. You can use a custom field instead of title. To accomplish this, customize the
configuration during registration. See also: Part 2: Register your Solr site on page 238.

Securing the Solr server
To maximize the security of your Solr server, follow these guidelines.
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l

Limit traffic to the immediate network between the Web server and the Solr server.
To do this, open these ports and place these restrictions on them.
o Solr server base port (by default, port 7600): Create a firewall rule that
restricts base port access to the IP addresses of
n the Ektron server
n

servers on which users will access the Admin Console to register Ektron
sites for search

o

Solr server base port + 1 (by default, port 7601): Create a firewall rule that
restricts access to the Ektron server only.

o

Ektron server port 8732: Create a firewall rule that allows access to the Solr
search server only.

l

Block unused Solr server ports (for example, ports 80 and 443).

l

Use a firewall to lock down port 7602 so it is accessible only on the local machine.

l

Restrict which IP addresses can access the Solr site's Web services to Ektron Web
servers that use Solr.

l

Leave other needed service ports open (for example, RDP). Use a firewall to lock
these ports down, so they are accessible to localhost only.

Setting up Solr search
Setting up Solr search on a single on-premises (local) server
l

For the configuration database, SQL 2008 or higher (Express version is
supported); can be installed to any server, for example the Ektron server, the Solr
server, or any other database server.

Preparing the Ektron server to work with Solr search
1. On the Ektron search server's firewall, open port 8732. This runs Ektron Windows
service and asset transfer server services.
2. Restart the Ektron server to apply all changes, not only those affecting SQL but
also the JDK installation, new environment variables, and so on.
NOTE: You must generate an eSync certificate to start Ektron Windows Service to
register a site.

Preparing the Solr search server to work with Ektron
During Solr installation, the user selects a base port (the default is 7600). The
installation allocates that port and nine above it to accommodate Solr search. For
example, if you use the default value of 7600, ports 7600 through 7611 are dedicated
to Solr search.
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On the Solr search server's firewall, open to the Ektron Web server ports +0 and +1 in
the range—they are used by Ektron’s query and admin services. To continue the default
example, open ports 7600 and 7601.
PREREQUISITES
l

Solr server
o Hardware requirements: minimum 8 gigabytes of RAM, quad core,
64-bit processor
o

Operating system: Windows 2008, Windows 2012, Windows 2016
NOTE: For a production server, use Windows 2008 R2, Windows
2012, or Windows 2016.

o

Enable the following
o Roles
n Application Server Role Services
n .NET Framework 4.5
IMPORTANT: With Windows Server 2008 or 2008
R2, be sure that .NET 3.5 is installed before
installing 4.5.
n
n

o

Web Server IIS Support

Web Server (IIS) Role Services
n Windows Authentication feature
n

.NET Extensibility 4.5

n

ASP.NET 4.5

Features
n .NET Framework > WCF Activation
NOTE: Make sure that HTTP activation is also checked.
n

o
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SQL browser, if not using default instance

o

For optimal performance, use a separate disk (that is, not the
system drive) for index and asset cache

o

May be installed on Ektron server but only in a development
environment.
Consult an Ektron certified partner to determine your server
requirements. Ektron does not recommend installing Solr on a
server that also hosts Microsoft Search Server.
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o

Java Development Kit 1.8, Windows x64 version.
To download, go to
https://www.oracle.com/technetwork/java/javase/downloads/jdk
8-downloads-2133151.html.
NOTE: From 9.40 SP1, make sure that path system variable is
set to: java_home%\bin for JDK. For example: C:\Program
Files\Java\jdk1.8.0_101\bin.
Make sure that the JAVA_HOME system environment variable
exists and is set to the JDK installation folder, for example:
C:\Program Files\Java\jdk1.8.0_101\.
IMPORTANT: If you upgrade the JDK version, you must replace
it in the same directory to which you originally installed it. You
may not install more than one JDK version to that directory.

l

An Ektron site installed on an Ektron server. See also: Installing Ektron
on page 9, Upgrading to Ektron 9.40 SP1 on page 37.
NOTE: During the Ektron installation, you should have selected Solr
as your search provider. If you need to change your search provider
to Solr, see Changing your search provider to Solr on page 299.

l

The Ektron Solr installation file. Contact your Ektron account manager
to obtain a link to the file.

l

Users
o A SQL login account assigned the dbcreator role. This account is
used to create the search configuration database.
o

A SQL login account that Ektron search components use to access
the search configuration database.
Both SQL accounts must follow these rules:
n

If integrated security is set to true
...and Solr search and the Ektrondatabase are on different
servers, a domain user is required.
...and Solr search and the Ektron database are on the same
server, a local Windows user is required.

n

if integrated security is set to false, a SQL server user.

BEST PRACTICE
Use SQL authentication rather than Integrated Security.
Although Integrated Security is supported, the
connection is made in the context of the search service
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account (Windows user) provided during installation. If
this user does not have access to the database, the
connection fails.
o

A Windows user account under which Solr services will run. This
account, which manages Solr components and authenticates
queries, must have permission to
n write to the search 2.0 folder and its subfolders
n

start the Solr admin service

n

log on as a service

This user can be either a Windows user on the search server, or a
domain user. If it is a domain user, the Netlogon service must be
enabled and running.

l
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Installing Solr on a single on-premises (local) server
After installing Ektron, you can install Solr. This is a 2-step procedure.
1. Install files needed to run Solr.
2. Register the Ektron site with the Solr search engine.
See also: Using Solr search with 3-tier architecture on page 186.
Part 1: Run Solrinstall.exe
1. Contact your Ektron account manager to obtain a link to download the Solr
installation file.
2. Log in as a Windows Administrator user.
3. Download and run the Ektron Solr installation file as an administrator.
4. Accept the license agreement.
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5. Select a folder in which to save the Solr installation files.

6. You are prompted to select a base port. After you select a port, it and 9 consecutive
ports are designated for Solr use. For example, if you accept the default port 7600
as the base, ports 7600 through 7611 are used for Solr.
NOTE: Do not use a port number below 1025. Also, do not use ports 6080,
6081, and 8732: they are reserved for other Ektron components.
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7. Enter credentials (domain, user name, and password) of the Windows user account
under which Solr query services will run. This account manages Solr components
and authenticates queries. The account must have permission to
l write to the search 2.0 folder and its subfolders
l

start the Solr admin service

l

lock pages in memory. You can assign this in the machine's Local Security
Policy under Local Policy > User Rights Assignment.

l

log on as a service. If the user does not have "Log on as a Service" right, you
are prompted to assign it.

If you are using a domain account, the Netlogon Service must be enabled and
running.
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`
8. Enter the SQL Server that will host the Solr configuration database. Then either
select Trusted Connection or enter the username and password of the user who
will create the search configuration database. The user must be assigned the
SQL Server dbcreator role.
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9. Enter a unique name for your search configuration database. Spaces are not
allowed.

Ektron Reference

233

Setting up search for your website

10. Enter credentials for a SQL login account that Ektron search components will use to
access the search configuration database.
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11. Enter the host name of the server on which you are running the Solr installation.
The Ektron server must be able to access this host.
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12. Select a folder in which Solr will store its index data.
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13. Specify the location of your asset cache. The asset cache is used only if the Ektron
asset files are not stored on your Solr search server.
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14. A summary of installation choices appears. If everything looks OK, click Install.

Key points on this screen:
l

The query service port is always the base port.

l

The screen lists your search service account, configuration database, and the
port number assigned to the following:
o Query service. Outbound from Ektron server
o

Admin service. Outbound from Ektron server

o

Tomcat connector. For local communications between Solr and Tomcat

o

Tomcat shutdown. For local communications between Solr and Tomcat

o

ManifoldCF. For local communications between Solr and ManifoldCF

o

Asset Transfer Client. Two-way between Ektron and Solr servers

IMPORTANT: The summary screen's first 2 ports have an asterisk (*). Set up
the Ektron server's firewall such that these ports let the Ektron site
communicate with the Solr service.

Part 2: Register your Solr site
1. Remote onto the Solr machine and go to the following URL:
https://YourSolrMachineName:7600/SolrAdminConsole/Index.html.
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2. If prompted, enter the credentials of the search server user used to install Solr. If
you are uncertain of the username, go to the Windows Services panel, locate the
Ektron Solr Process Manager service, and identify the user in the Log On As
column. Use this user to login to the site listed in step one.
3. In the Web Server Name field, enter the machine name of the server that
contains the CMS site you are registering and click Connect.
4. A list of Ektron databases on the server should be listed. Identify the database you
wish to register.
5. If you deleted the crawl database, click the Start over button, confirm that the
crawl filter and polling interval settings are correct, and hit the Register button.
Take time to consider the crawl filters-your choice can make a considerable
difference in crawl time.

If you are registering the site for the first time, the steps are the same minus the
start over step.
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6. If everything is configured correctly, you see a registration successful message.
Otherwise, search the knowledge base for the error you are receiving. If necessary,
contact Support.

Setting up Solr search in the Amazon cloud
This section explains how to set up Solr search to support an Ektron website deployed
to the Amazon cloud.

Part 1: Set up an Ektron site in the Amazon cloud
When prompted to select a Web Instances Type, select m1.large.

Part 2: Create a security group
The security group authorizes the opening of ports, which access search components
between Ektron and the Solr VM. Two of the ports, selected during the Solr installation,
are base port and base port+1. By default, they are 7600 and 7601.
NOTE: The base port is for the Admin Console/Registration UI and Query services.
The base+1 port is for the Ektron Solr Admin Service.
NOTE: Create the Security Group for the region you selected for the Cloud site (for
example, US East).
1. Sign in to the Amazon Web services console.
2. Click Services > EC2 > Security Groups > Create Security Group.
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3. Add a Name, Description and select No VPC.
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4. Click the group and add these 2 inbound rules.
Rule: TCP
Port range: 3389
Source: 0.0.0.0/0
Rule: TCP
Port range: 7600-7601
Source: 0.0.0.0/0

NOTE: For the second inbound rule, you are not required to use ports 7600 and
7601. These are only examples of ports you might use.

5. Click Apply Rule Changes.

Part 3: Create Solr search VM
In this part, you create a Solr search version on an Amazon virtual machine.
NOTE: Create the Solr Search VM in the same region you selected for the Cloud site.
1. Sign in to Amazon Web services console.
2. Click EC2 > Instances > Launch Instance.
3. Click the Quick Start tab.
4. Select a Microsoft Windows server that supports Solr search. Do not choose one
that is bundled with a SQL server. See also: Setting up Solr search on a single onpremises (local) server on page 225
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5. Click the Select button. A new window appears.
6. Select All Instance Types > M1 large and click Next.

7. On the Configure Instance screen, check Protect against accidental
termination and click Next.
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8. The Storage Device Configuration screen appears. Click Next. The Tag Instance
screen appears.
9. Add a tag. For the Key, enter search. For the Value, enter solr. Click Next.

10. Select the security group you created in Part 2: Create a security group on
page 240 and click Review and Launch.
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11. Review screen information then click Launch.
12. Select the key pair that you created and click Launch Instances.
If you created a new key pair when you ran the deployment wizard, the
CloudPemFile is created in the Ektron on-premises Windows Service install
directory, C:\Program Files
(x86)\Ektron\EktronWindowsService40\CloudPemFile.
NOTE: If you do not have an existing key pair, create new pair and save the key
pair file on your computer. You will need it later to log in.

13. Move the cursor to the row containing the new instance, click the Name field, then
insert a name.
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NOTE: This step is not required but will ease identification of your VM later.

14. When the launch is finished, right click the instance and select Get Windows
Password.

15. Browse to the keypair file described in Step 10, EktronSolrSearchKP.pem, and click
Decrypt Password.
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16. You see the decrypted password & hostname. Save them for future access to the
EC2 Instance Remote Desktop Session.

Part 4: Set up the Amazon Solr search VM
On the Solr search Amazon VM (which you installed in Part 3: Create Solr search VM on
page 242), install the Solr search prerequisites.
PREREQUISITES
l

Solr server
o Hardware requirements: minimum 8 gigabytes of RAM, quad core,
64-bit processor
o

Operating system: Windows 2008, Windows 2012, Windows 2016
NOTE: For a production server, use Windows 2008 R2, Windows
2012, or Windows 2016.

o

Enable the following
o Roles
n Application Server Role Services
n .NET Framework 4.5
IMPORTANT: With Windows Server 2008 or 2008
R2, be sure that .NET 3.5 is installed before
installing 4.5.
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n
n

o

Web Server IIS Support

Web Server (IIS) Role Services
n Windows Authentication feature
n

.NET Extensibility 4.5

n

ASP.NET 4.5

Features
n .NET Framework > WCF Activation
NOTE: Make sure that HTTP activation is also checked.
n

o

Static content

SQL browser, if not using default instance

o

For optimal performance, use a separate disk (that is, not the
system drive) for index and asset cache

o

May be installed on Ektron server but only in a development
environment.
Consult an Ektron certified partner to determine your server
requirements. Ektron does not recommend installing Solr on a
server that also hosts Microsoft Search Server.

o

Java Development Kit 1.8, Windows x64 version.
To download, go to
https://www.oracle.com/technetwork/java/javase/downloads/jdk
8-downloads-2133151.html.
NOTE: Make sure that the JAVA_HOME system environment
variable exists and is set to the JDK installation folder, for
example: C:\Program Files\Java\jdk1.8.0_101\.
IMPORTANT: If you upgrade the JDK version, you must replace
it in the same directory to which you originally installed it. You
may not install more than one JDK version to that directory.

l

An Ektron site installed on an Ektron server. See also: Installing Ektron
on page 9, Upgrading to Ektron 9.40 SP1 on page 37.
NOTE: During the Ektron installation, you should have selected Solr
as your search provider. If you need to change your search provider
to Solr, see Changing your search provider to Solr on page 299.
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l

The Ektron Solr installation file. Contact your Ektron account manager
to obtain a link to the file.

l

Users
o A SQL login account assigned the dbcreator role. This account is
used to create the search configuration database.
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o

A SQL login account that Ektron search components use to access
the search configuration database.
Both SQL accounts must follow these rules:
n

If integrated security is set to true
...and Solr search and the Ektrondatabase are on different
servers, a domain user is required.
...and Solr search and the Ektron database are on the same
server, a local Windows user is required.

n

if integrated security is set to false, a SQL server user.

BEST PRACTICE
Use SQL authentication rather than Integrated Security.
Although Integrated Security is supported, the
connection is made in the context of the search service
account (Windows user) provided during installation. If
this user does not have access to the database, the
connection fails.
o

A Windows user account under which Solr services will run. This
account, which manages Solr components and authenticates
queries, must have permission to
n write to the search 2.0 folder and its subfolders
n

start the Solr admin service

n

log on as a service

This user can be either a Windows user on the search server, or a
domain user. If it is a domain user, the Netlogon service must be
enabled and running.

Ektron Reference

249

Setting up search for your website

l

Knowledge of Solr, for administrators who want to perform advanced
tasks

Part 5: Install Solr on the Solr VM
Remote into your Solr VM then complete these steps.
1. Contact your Ektron account manager to obtain a link to download the Solr
installation file.
2. Log in as a Windows Administrator user.
3. Download and run the Ektron Solr installation file as an administrator.
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4. Accept the license agreement.
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5. On the Deployment Type screen, choose Install Solr on a single server.
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6. Select a folder in which to save the Solr installation files.

7. You are prompted to select a base port. After you select a port, it and 9 consecutive
ports are designated for Solr use. For example, if you accept the default port 7600
as the base, ports 7600 through 7611 are used for Solr.
NOTE: Do not use a port number below 1025. Also, do not use ports 6080,
6081, and 8732. They are reserved for other Ektron components.
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8. Enter credentials (domain, user name, and password) of the Windows user account
under which Solr query services will run. This account manages Solr components
and authenticates queries.
The account must have permission to
n

write to the search 2.0 folder and its subfolders

n

start the Solr admin service

n

log on as a service. If the user does not have "Log on as a Service" right, you
are prompted to assign it.

If you are using a domain account, the Netlogon Service must be enabled and
running.
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`
9. Enter the SQL Server that will host the Solr configuration database. Then either
select Trusted Connection or enter the username and password of the user who
will create the search configuration database.
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To get the SQL server name, use the Endpoint field in the Amazon Cloud Instances
screen. Exclude the Endpoint's port number.

The user must be assigned Create Any Database permission on the RDS database
server. See also: Amazon Relational Database Service (RDS) documentation.
10. Enter a unique name for your search configuration database. Spaces are not
allowed.
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11. Enter credentials for a SQL login account that Ektron search components will use to
access the search configuration database.
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12. Enter the host name of the server on which you are running the Solr installation.
The Ektron server must be able to access this host. Your host name may look like
this.
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The following image indicates where to get the Amazon load balancer host name.
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13. Select a folder in which Solr will store its index data.

14. Specify the location of your asset cache. The asset cache is used only if the Ektron
asset files are not stored on the Solr search server.
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15. A summary of installation choices appears. If everything looks OK, click Install.
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Key points on this screen:
l

The query service port is always the base port.

l

The screen lists your search service account, configuration database, and the
port number assigned to the following:
o Query service. Outbound from Ektron server
o

Admin service. Outbound from Ektron server

o

Tomcat connector. For local communications between Solr and Tomcat

o

Tomcat shutdown. For local communications between Solr and Tomcat

o

ManifoldCF. For local communications between Solr and ManifoldCF

o

Asset Transfer Client. Two-way between Ektron and Solr servers

IMPORTANT: The summary screen's first 2 ports have an asterisk (*). On the
Ektron server, adjust the firewall to allow these ports to communicate between
your Ektron site and the Solr service.

Part 6: Set up a search load balancer
In this section, you load balance your search. You need to do this so the cloud-based
Ektron site can access search components on the Solr VM, which will be accessible
through the load balancer.
1. From the Amazon Web services console, go to EC2 > Load Balancers > Create
Load Balancer.
2. Give the Load Balancer a name.
3. At Create LB Inside, choose EC2.
4. Map the base and base + 1 ports (by default, 7600 and 7601) between load
balancer and Instance. Use TCP protocol, not Http. Click Continue.
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5. On the Health Check dialog
l at Ping Protocol, select HTTP.
l

at Ping Port, enter the base port. By default, it is 7600.

l

at Ping Path, enter /ping.html.

6. The Add EC2 Instances screen appears. Select the instance you created in Part
3: Create Solr search VM on page 242 and click Continue.
7. A review screen displays the settings. When you are ready, click Create. Amazon
sets up a Search Load Balancer.
NOTE: The health check may fail since Solr Install has not run yet, and
ping.html is not present on the VM.

Part 7: Edit health check, create inbound rule, and verify QueryService URL
1. From the Amazon Web services console, go to EC2, click Load Balancers, and
select the load balancer you created.
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2. On the Amazon Solr server, create an inbound rule to allow connections to Solr
ports.This allows your Ektron VM to communicate with the Solr Admin Console. To
do this:
a. Go to Control Panel > Windows Firewall > Advanced settings >
Inbound Rules > New Rule.
NOTE: Leave firewall status "Turned On".

b. On the Rule Type screen, choose Port.
c. On the Protocols and Ports screen, choose TCP. In the Specific local ports
field, enter your baseport and baseport + 1. For example, 7600-7601.
d. Click Next then Allow the connection.
e. On the When does this rule apply? screen, check all boxes.
f. Assign a name to the rule.
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3. Click the Health Check tab. Click Edit Health Check. Change the value of
ResponseTimeout to any value and save. Verify that this action changes your
load balancer status to In Service.
4. On the Amazon Ektron server, create an inbound rule to add 8732 as an inbound
port. This allows the Solr Admin Console to communicate with your Ektron VM. To
do this:
a. On the Amazon instance that hosts Ektron, go to Control Panel > Windows
Firewall > Advanced settings > Inbound Rules > New Rule.
NOTE: Leave Firewall status "Turned On".
b. On the Rule Type screen, choose Port.
c. On the Protocols and Ports screen, choose TCP. In the Specific local ports
field, enter 8732.
d. Click Next then Allow the connection.
5. From Amazon EC2 console, obtain the DNS Name of the search load balancer.

6. Verify that the QueryService Url works from the Ektron server via this
URL: https://load balancer DNS name:baseport
number/SolrQueryService/SolrQueryService.svc

Part 8: Disable "Set Computer Name"
1. On the Solr search Amazon VM, press Windows key\S to open the search box
and enter EC2ConfigService.
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2. On the Ec2 properties dialog, uncheck the Set Computer Name box.

Part 9: Register the load-balanced site
Register the load balanced site using the following URL: https://load balancer DNS
name:baseport number/SolrAdminConsole/index.html.

Additional steps if Ektron is installed manually on Amazon EC2
If Ektron was manually installed in an Amazon EC2 environment, and you want Solr
search to crawl Ektron resource files, follow one these procedures to enable that crawl.

Store resource files on the EC2 instance
Follow these steps to allow Solr search to crawl Ektron resource files (assets, private
assets, uploaded images, uploaded files, asset library) on an EC2 instance. To properly
configure this, create an elastic IP for the Ektron EC2 instance. This enables Solr's asset
transfer client to connect to Ektron's asset transfer service.
1. From the Amazon Web services console, go to EC2 > Network & Security
> Elastic IPs.
2. Select the Ektron machine name and click Allocate New Address.
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3. The Associated Address dialog appears. Check the Ektron server that will work with
this Amazon Solr instance.
4. On the Solr VM, open the hosts file (C:\Windows\System32\Drivers\etc\hosts).
5. Add a new host file entry. Insert the Elastic IP address of and the name of the
Ektron EC2 instance.

Store resource files in the Amazon S3
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Follow these steps to allow Solr search to crawl Ektron resource files stored in the
Amazon Simple Storage Service (S3). To set up this capability, update the following
section of your site's siteroot\web.config file, in the <appsettings> section.
<add
<add
<add
<add

key="ek_CloudStorageType" value="" />
key="ek_CloudAccountId" value="" />
key="ek_CloudAccountKey" value="" />
key="ek_CloudContainer" value="" />

l

ek_CloudStorageType—Enter AMAZON.

l

ek_CloudAccountId—Enter your Amazon account access key.

l

ek_CloudAccountKey—Enter your Amazon account secret key.

l

ek_CloudContainer—Enter the S3 bucket name.

For these changes to take effect:
1. On the Ektron EC2 instance, restart the EktronWindowsServices40 and
EktronAssetTransferServer.
2. On the Solr EC2 instance, restart EktronAssetTransferClient2.0 and
EktronSolrAdminService.
3. Register the site again. See Part 9: Register the load-balanced site on page 266
4. All new resource files will be stored in the S3 bucket. Verify that they are
searchable from the Ektron site.

Setting up Solr Search in the Azure cloud
If you want to deploy an Ektron website to the Azure cloud, deploy Solr search to Azure
cloud, then connect both cloud-based systems, you have 2 options:
l

Install an Ektron site to an on-premises server then push the site up to an Azure
VM. Next, deploy Solr to the cloud. Finally, connect both cloud-based systems.
To view these instructions, see Pushing an Ektron site to the Azure cloud and
connect it to Solr search below.

l

Install an Ektron site on an Azure VM. Next, deploy Solr to the cloud. Finally,
connect both cloud-based systems.
To view these instructions, see Installing Ektron site on Azure cloud and connecting
it to Solr search on page 288.

Pushing an Ektron site to the Azure cloud and connect it to Solr
search
Part 1: Deploy Ektron Site to the Cloud
Follow the steps in Using Ektron in the Windows Azure Cloud to deploy an Ektron site to
the Azure cloud. But note this important difference:
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You cannot update the ektron.cms.framework.unity.config file directly on the
Ektron VM that hosts the Solr search provider. This restriction occurs because, when
the machine reboots, your changes are lost. So, follow these steps to update the
ektron.cms.framework.unity.config file.
1. During the Ektron installation, select Solr. If you did not do this, see Changing your
search provider to Solr on page 299.
2. Copy the siteroot/ektron.cms.framework.unity.config to:
C:\Program Files (x86)\Ektron\CMS400vxx\CommonFiles\Configs

3. Run the initial cloud deployment.
If you need to make these changes after the initial cloud deployment, update the
unity.config file in the
C:\sync\azuredeploy\GUID\HostedServiceName\’HostedServiceName’_web folder.
To upload this file to a cloud-based site, use the EktronConfigUploader.exe utility in
C:\Program Files(x86)\Ektron\EktronCloud\bin\ms\2.0.0.0 .

Part 2: Create Azure Solr search VM
Create an Azure virtual machine to host Solr search.
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1. Log into https://manage.windowsazure.com.
2. Click Virtual Machines > New.

3. Click Quick Create.
4. For the new server, enter a DNS Name.
5. For the image, choose Windows Server 2012.
6. Choose a large size with at least 8 GB of memory.
7. Enter your user name and password.
8. At Region/Affinity Group, select the region selected when setting up the Ektron
site (in Using Ektron in the Amazon EC2 Cloud).
9. Click Create a Virtual Machine.
10. Wait until the status changes from Starting (Provisioning) to Running.
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11. Select the VM and click Connect.

12. The following dialog appears. Click OK to connect to the virtual machine.

Ektron Reference

271

Setting up search for your website

13. When you are prompted for Windows credentials, prefix your username with the
DNS Name you created in Step 4.

Part 3: Set up Solr search on Azure VM
This section explains how to set up Solr search on the Azure VM.
1. Apply all prerequisites to the Azure VM. You already set up an Ektron site in Using
Ektron in the Windows Azure Cloud (PaaS).
l An Azure database server is required. You have 2 options:
o Use the database server that hosts Ektron.
o
l

Create a new database server.

If you installed Ektron manually on an Azure VM (see Installing Ektron site on
Azure cloud and connecting it to Solr search on page 288), follow these steps
to enable the crawling of assets and private assets.
a. On the virtual machine that hosts the Ektron site, locate the Public Virtual
IP (VIP) address.

b. On the virtual machine that hosts Solr search, open the hosts file (located
in %systemroot%\system32\drivers\etc).
c. Into the hosts file, insert the VIP obtained in Step 1, followed by the

272

Ektron 9.40 SP1

Part 3: Set up Solr search on Azure VM

hostname of the VM that hosts Ektron.

2. On the Azure VM, copy the following into a .bat file and run it. This code fixes a
problem in which Java JDBC to SQL Azure connections are being forcibly closed.
REG ADD HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
/v KeepAliveTime /t REG_DWORD /d 30000
REG ADD HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
/v KeepAliveInterval /t REG_DWORD /d 1000
REG ADD HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
/v TcpMaxDataRetransmission /t REG_DWORD /d 10

3. On the Azure VM, register ASP.NET.
a. As an administrator, open a command prompt.
b. Enter cd C:\Windows\Microsoft.NET\Framework64\v4.0.30319
c. Run C:\Windows\Microsoft.NET\Framework64\v4.0.30319>aspnet_
regiis.exe -i
4. Copy your storage access account and primary key to the Azure web.config file.
This enables the Asset Transfer service to correctly transfer Azure assets to Solr
Search VM. To do this:
a. On the Azure VM, find your storage account primary key by navigating to
Storage Accounts > your storage account.
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NOTE: You created the storage account when you deployed an Ektron site
to the Azure cloud, as described in Deploying a Site Package to the Azure
Cloud.
b. Click Manage Access Keys.
c. Copy the Storage Account Name and Primary Access Key. you will paste
them in Step g.
d. Log on to the on-premises Ektron server.
e. Open the file
C:\sync\azuredeploy\GUID\HostedServiceName\HostedServiceName_
web\web.config.
f. Within the <appsettings> tag, add these keys. Insert the values you collected
in Step 4c.
<add key="ek_CloudStorageType" value="AZURE"/>
<add key="ek_CloudAccountId" value="storage account name"/>
<add key="ek_CloudAccountKey" value="storage account primary key"/>

g. Restart the Azure VM.
5. Push the web.config changes to your Azure site. To do this:
a. On the on-premises Ektron server, go to C:\Program Files
(x86)\Ektron\EktronCloud\bin\ms\2.0.0.0.
b. Open EktronConfigUploader.exe.
c. Enter your storage account name and storage account primary key. (You
obtained them in Step 4.)
d. Click Browse and go to the web.config file that you updated in Step 4.
e. Click Upload.
6. Reboot the Worker Hosted service. This, in turn, restarts the Ektron Windows
service. To do this:
a. Log into https://manage.windowsazure.com.
b. Click Cloud Services.
c. Click your cloud service. (You created the cloud service when setting up the
Ektron site in the Azure cloud.
d. Click Instances.
e. Click the instance hosted service name_worker_IN_0.
f. Click Restart.
7. Log into the VM you created in Part 2: Create a security group on page 240.

Part 4: Run the Solr Installation
1. Contact your Ektron account manager to download the Solr installation file.
2. Log in as a Windows Administrator user.
3. Download and run the Ektron Solr installation file as an administrator.
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4. Accept the license agreement.
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5. On the Deployment Type screen, choose Install Solr on a single server.
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6. Select a folder in which to save the Solr installation files.

7. You are prompted to select a base port. After you select a port, it and 9 consecutive
ports are designated for Solr use. For example, if you accept the default port 7600
as the base, ports 7600 through 7611 are used for Solr.
NOTE: Do not use a port number below 1025. Also, do not use ports 6080,
6081, and 8732: they are reserved for other Ektron components.
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8. Enter credentials (domain, user name, and password) of the Windows user account
under which Solr query services will run. This account manages Solr components
and authenticates queries.
The account must have permission to
l

write to the search 2.0 folder and its subfolders

l

start the Solr admin service

l

log on as a service. If the user does not have "Log on as a Service" right, you
are prompted to assign it.

If you are using a domain account, the Netlogon Service must be enabled and
running.
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`
9. Enter a fully qualified DNS name for the Azure SQL Server that will host the Solr
configuration database. Then either select Trusted Connection or enter the
username and password of the user who will create the search configuration
database. If you enter a user, select someone who is either the server-level
principal login or assigned the dbmanager database role. See also: Managing
Databases and Logins in Windows Azure SQL Database.
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10. Enter a unique name for your search configuration database. Spaces are not
allowed.
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11. Enter credentials for a SQL login account that Ektron search components will use to
access the search configuration database.
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12. Enter the fully-qualified DNS name of the server on which you are running the Solr
installation. The Ektron server must be able to access this host.
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13. Select a folder in which Solr will store its index data.
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14. Specify the location of your asset cache. The asset cache is used only if the Ektron
asset files are not stored on your Solr search server.
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15. A summary of installation choices appears. If everything looks OK, click Install.

Key points on this screen:
l

The query service port is always the base port.

l

The screen lists your search service account, configuration database, and the
port number assigned to the following:
o Query service. Outbound from Ektron server
o

Admin service. Outbound from Ektron server

o

Tomcat connector. For local communications between Solr and Tomcat

o

Tomcat shutdown. For local communications between Solr and Tomcat

o

ManifoldCF. For local communications between Solr and ManifoldCF

o

Asset Transfer Client. Two-way between Ektron and Solr servers

IMPORTANT: The summary screen's first 2 ports have an asterisk (*). On the
Ektronserver, adjust the firewall to allow these ports to communicate between
your Ektron site and the Solr service.

Part 5: Add Inbound Rules and Endpoints
Add inbound rules to allow TCP communication for Solr Search components and the
Solr Administration Service. You defined these ports while completing Part 4: Run
the Solr Installation on page 274. To do this:
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NOTE: Leave firewall status "Turned On."
1. Go to Server manager > Windows Firewall with Advanced settings >
Inbound Rules > New Rule.
2. On the Rule Type screen, choose Port.
3. On the Protocols and Ports screen, choose TCP. In the Specific local ports
field, enter your base port and base port + 1. For example, 7600-7601.
4. Click Next then Allow the connection.
5. On the When does this rule apply? screen, check all boxes.
6. Assign a name to the rule.
7. Click Finish.
Add 2 endpoints. To do this:
1. Return to the Windows Azure portal, https://manage.windowsazure.com.
2. Click your virtual machine.
3. Click Endpoints > Add.
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4. The following dialog appears. Click the -> (next) button.

5. Add 2 endpoints that make Ektron Solr components on the Azure Solr Search
VM accessible from the Ektron VM. To do this.
l

Name: SolrSearchSite
o Protocol: TCP
o

Public and private ports: base port (by default, this is 7600)

NOTE: To identify the base port number, log on to the virtual machine,
open IIS, click EktronSolrSearch2.0 > bindings, and view the port
value.
l

Name: SolrAdminSvc
o Protocol: TCP
o

l

Public and private ports: base port plus 1 (by default, this is 7601)

Do not check Create a Load-Balanced Set and Enable Direct Server
Return boxes

Part 6: Test and register Solr on the Azure VM
1. Verify you can reach the Solr Search components by using this ping Url under the
EktronSolrSearch site.
https://DNSname.cloudapp.net:baseportnumber/ping.html

For example, if the DNS name you assigned in Part 2: Create a security group on
page 240 is solrsearch, and your base port is 7600, the URL would be
https://solrsearch.cloudapp.net:7600/ping.html.
2. Register site using this URL.
https://DNSname.cloudapp.net:baseportnumber/SolrAdminConsole/index.html
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See also: Part 2: Add a storage account in Azure manager on page 291

SQL Azure database firewall permissions
l

To understand server-level and database-level SQL Azure permissions, refer to this
Azure documentation.
o How to: Configure the Server-Level Firewall Settings (Windows Azure SQL
Database)
o

How to: Configure the Database-Level Firewall Settings (Windows Azure SQL
Database)

o

Windows Azure SQL Database Firewall

l

If your SQL Azure configuration > Windows Azure Services box is checked or
the allow all azure IPs rule is added to your master database using exec sp_
set_database_firewall_rule N'AllAzureIps','0.0.0.0','0.0.0.0', any
database in this SQL Azure instance is accessible by any Azure IP.

l

To grant your Azure Search VM permission to access the search configuration
database (created by the SolrInstall), add your Azure Search VM to your search
configuration database's firewall rules, and remove server-level permissions.
o Add the public virtual IP of your Azure Search VM to your database firewall
rules (after connecting to your search config database). Example:
exec sp_set_database_firewall_rule
N'ALLAzureIPs','137.135.70.139','137.135.70.139'
o

To delete server-level permissions using the Azure portal:
1. Select your SQL Azure server.
2. Configure it.
3. Remove rules, or revoke them in the master database, using
exec sp_delete_database_firewall_rule N'ALLAzureIPs'
Azure recommends waiting 5 minutes for rule changes to take effect.

l

If you have one IP address in your server-level rule and another IP address in your
database-level rule, both the IPs have access to the search configuration database.
Server-level rules apply to all databases in an instance, while database-level rules
apply to specific databases.

l

To list all rules, use
select * from sys.database_firewall_rules

Installing Ektron site on Azure cloud and connecting it to Solr
search
Follow this procedure if you want to manually install an Ektron site on an Azure VM.
Next, deploy Solr to the cloud. Finally, connect both cloud-based systems.
PREREQUISITES
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l

Contact your Ektron account manager to obtain a link to download
EktronCloudSetup.exe.

Part 1: Provision a virtual machine for the Ektron site

Part 1: Provision a virtual machine for the Ektron site
1. Log into https://manage.windowsazure.com.
2. Click Virtual Machines > New.

3. Click Quick Create.
4. For the new server, enter a DNS Name.
5. For the image, choose Windows Server 2012.
6. Choose a large size with at least 8 GB of memory.
7. Enter your user name and password.
8. At Region/Affinity Group, select the region selected when setting up the Ektron
site (in Using Ektron in the Amazon EC2 Cloud).
9. Click Create a Virtual Machine.
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10. Wait until the status changes from Starting (Provisioning) to Running.
11. Select the VM and click Connect.
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12. The following dialog appears. Click OK to connect to the virtual machine.

13. When you are prompted for Windows credentials, prefix your username with the
DNS Name you created in Step 4.

Part 2: Add a storage account in Azure manager
You need a storage account to store site resources in the cloud storage service, and to
store and synchronize assets, private assets, uploaded files, uploaded images and the
asset library. To create a storage account:
1. From the home page of https://manage.windowsazure.com, click Storage. The
Storage screen appears.
2. At the bottom of the screen, click New. The New panel opens.
3. Choose Data Service > Storage > Quick Create.
a. Specify a URL name for your cloud service (for example, cloudservicename).
The .core.windows.net will be appended to your name to complete the URL.
b. Choose the Location or Affinity Group from the drop-down list. For example,
East US.
c. Leave Enable Geo-replication checked if you have multiple servers.
4. Click Create Storage Account at the bottom of the panel.

Part 3: Install Ektron site on virtual machine
On the Azure VM, install Ektron. See Installing Ektron on page 11.

Part 4: Run EktronCloudSetup.exe on virtual machine
On the Azure VM, install EktronCloudSetup.exe.
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After you download and install EktronCloudSetup.exe, the Cloud Manager is added to
the Workarea Settings.

Part 5: Run security configurator
1. On the Azure VM, click the Windows Start button > All programs > Ektron >
CMS400 v9x > Utilities > Security Configurator. Right click and choose Run
As Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The security configurator screen appears.

2. Check the Remote Server Certificate Folder radio button. Then use the browse
button to go to the Ektron\EktronCloud\bin\worker\certificate folder.
3. Click Apply.

Part 6: Add inbound rules for ports
On the Amazon Solr server, create inbound rules to allow connections to Ektron port 8732 and
database port (for example 1433). The rule enables the Ektron VM to communicate with the Solr
Admin Console. To do this:

1. On the Amazon Solr server, go to Server Manager> Windows Firewall with
Advanced settings > Inbound Rules > New Rule.
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NOTE: Leave firewall status "Turned On".

2. On the Rule Type screen, choose Port.
3. On the Protocols and Ports screen, choose TCP. In the Specific local ports field,
enter 8732.
4. Click Next then Allow the connection.
5. On the When does this rule apply? screen, check all boxes.
6. Assign a name to the rule.
7. Click Finish.
8. Repeat steps 1-7 for the database port.

Part 7: Add endpoints for port 8732 and the database port
1. Return to the Windows Azure portal, https://manage.windowsazure.com.
2. Click your virtual machine.
3. Click Endpoints > Add.
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4. The following dialog appears. Click the -> (next) button.

5. Add your Ektron Windows Service port.
l Name: EWSPort
l

Protocol: TCP

l

Public and private ports: base port 8732

6. Repeat steps 1-5 for the database port.

Part 8: Update the Ektron web.config
1. On the Azure VM, open the Ektron site's siteroot\web.config file.
2. Replace the unity.storage section with this:
<unity.storage>
<assembly name="Ektron.Storage" />
<assembly name="Ektron.Cloud" />
<namespace name="Ektron.Cloud.Azure.Storage" />
<namespace name="Ektron.Storage" />
<container name="storageContainer">
<register type="IFileService" mapTo="CloudFileService" />
<register type="IDirectoryService" mapTo="CloudDirectoryService" />
</container>
</unity.storage>

Save but do not close the web.config file. You will update further soon.
3. Obtain your Azure Storage Account Name and Primary Access Key. To do this:
a. In a browser, go to https://manage.windowsazure.com.
b. From the left panel, click Storage. The Storage screen appears.
c. Select the storage account you created in Part 2: Add a storage account in
Azure manager on page 291.
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d. Click Manage Access Keys at the bottom of the page.

e. A screen shows your Storage Account Name and Primary Access Key.
4. Within the web.config file, find the following element:
<add key="StorageConnectionString"
value="DefaultEndpointsProtocol=http;AccountName={0};
AccountKey={1}"/>

5. Replace {0} with the Storage Account Name you obtained in Step 3. Then,
replace {1}with the Primary Access Key that you obtained in Step 3.
6. Within the web.config file, locate the <appsettings> section then add these keys
within it.
<add
<add
<add
<add

key="ek_CloudStorageType" value="AZURE" />
key="ek_CloudAccountId" value="MyStorageAccountName" />
key="ek_CloudAccountKey" value="MyKeyValue" />
key="ek_CloudContainer" value="" />

7. In the above elements, replace MyStorageAccountName with the Storage
Account Name you obtained in Step 3. Then, replace MyKeyValue with the
Primary Access Key you obtained in Step 3.
8. Save and close web.config.

Part 9: Set up Solr search on the Azure cloud
Follow these steps.
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l

Part 2: Create Azure Solr search VM on page 269

l

Part 3: Set up Solr search on Azure VM on page 272

l

Part 4: Run the Solr Installation on page 274

l

Part 5: Add Inbound Rules and Endpoints on page 285

l

Part 6: Test and register Solr on the Azure VM on page 287

Unregistering a Solr site
If you remove an Ektron Web site which uses a Solr search server, use this procedure to
unregister the Ektron site from Solr. This is especially important if you will install
another Ektron site in the same location as the one that was removed.
1. On the server on which you completed Part 1: Run Solrinstall.exe on page 229, and
using an HTML5 CSS3-compliant browser, click Windows Start menu > All
Programs > Ektron > Ektron Solr Search 2.0 > Ektron Solr
Administration. If you're using Windows 8 or 2012, press the Windows key (
)/Q then enter Ektron Solr Administration. The site registration screen
appears.
2. Enter the host name of the Ektron server then click Connect.
3. Click the Search System Management tab.
4. Under Existing Configurations, find the Ektron database that was removed. If
you are unsure, compare the code following the Ektron database name with the
Search Configuration Details screen's Solr Core name field.
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5. Click the Remove button.

Editing Solr registration information
After a site is configured, the buttons below the database change to Edit and Start
Over.

Start Over is a full reconfiguration. The index, schema, and configuration data are
completely overwritten, and the site’s data is re-indexed. Because the index and
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supporting configuration are overwritten, search functionality is unavailable while the
site is being registered and re-indexed.
Consider this option if
l

You need to change the site’s connection string, which is used to extract data at
index time.

l

You need to change the physical location of the asset files.

l

Your index is in a state where you want to start fresh.

Edit updates an existing search configuration's settings. The index, schema, and
configuration data remain intact. When settings are saved, the site’s data is reindexed.
Search functionality remains available throughout this process.
Consider this option if you need to
l

update the type of data indexed for your site

l

change the automatic polling interval

l

update advanced configuration options

Uninstall Solr search provider from an on-premises
(local) server
The following scenarios describe uninstalling the Solr search provider.
IMPORTANT: Before uninstalling Solr, back up related files that have been
customized. For example, these Ektron Search2.0 directory files may have been
customized.
* solrconfig.xml
* schema.xml
* dictionary files
* wddf types
* .txt files

Simultaneously uninstall Ektron and Solr search provider
To uninstall Ektron and Solr at the same time:
1. Back up any Solr files that have been customized.
2. Use the uninstall procedure described in Uninstalling Ektron on page 33.
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3. On the Uninstall dialog, check the Remove Ektron Solr Files and Services box.

Uninstall Ektron, but do not uninstall Solr search provider
To uninstall Ektron but leave Solr installed, use the uninstall procedure described in
Uninstalling Ektron on page 33. On the Uninstall dialog, do not check the Remove
Ektron Solr Files and Services box.

Uninstall only the Solr search provider
To uninstall the Solr search provider:
1. Back up any Solr files that have been customized.
2. Close the four command windows that open at the end of the Solr installation.
3. Run the Ektron Solr installation file as an administrator. (You used this file to install
Solr.)
4. On the screen that has Upgrade and Remove options, choose Remove.

Changing your search provider to Solr
If you selected a search provider other than Solr during site setup and want to change
to Solr, follow these steps.
Change the search provider to Solr and uninstall the Microsoft Search Server.
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1. Uninstall Microsoft Search Server.
2. On the Ektron server, open c:\Program Files
(x86)\CMSvXXX\Utilities\SetSearchProvider.
3. Click SetSearchProvider.exe.
4. Select the website that you want to change.
5. Select Apache Solr 4.0.
6. Install the Solr search provider. See Installing Solr on a single on-premises (local)
server on page 229.
Change the search provider to Solr but do not uninstall the Microsoft Search Server.
1. On the Ektron server, open c:\Program Files
(x86)\CMSvXXX\Utilities\SetSearchProvider.
2. Click SetSearchProvider.exe.
3. Select the website that you want to change.
4. Select Apache Solr 4.0.
5. Install the Solr search provider. See Installing Solr on a single on-premises (local)
server on page 229.
6. On your search server machine, stop the Search Server Service.
7. On your search server, open C:\Windows\System32\SiteConfiguration.exe and
remove your website's entry.
8. Run an IISReset.
9. Start the Search Server service.

Monitoring the status of search
The Ektron Workarea provides 2 screens to help you monitor the status of your search.
For information about managing the search crawl, see Managing the search crawl on
page 395.

Solr search configuration details screen
The Solr Search Configuration Details screen provides information about
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l

Solr server host

l

Ektron Solr Administration Service URL

l

Ektron Solr Query Service URL

l

Solr core name

l

Query credentials

l

incremental crawl interval—to adjust, use the Solr site registration screen's
Automatic Polling Interval field.

l

crawl filters
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To access the screen, go to the Ektron Workarea > Settings > Configuration
> Search > Configuration.

Solr Search node status screen
The Solr Node Status screen provides information about the search crawl on 2 tabs.
l

Crawl status tab shows
o The crawl status, as returned by ManifoldCF
o

The current and next indexing activities

o

For the most recent crawl: start time, end time, duration

o

If an incremental crawl request is pending See also: Full vs. incremental
crawls on page 395.
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l

Process Status tab shows the status of the (Ektron search) Java processes on the
Solr Search server, such as Apache Tomcat, crawl database, and Apache
ManifoldCF.

From this screen, you can launch an incremental or full crawl using toolbar buttons. See
also: Full vs. incremental crawls on page 395.
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Apache Manifold CF status screen
To view the Apache Manifold CF status screen, on the Solr server, click the Windows
Start button > All Programs > Ektron > Ektron Solr Search 2.0 > Tools
> Apache Manifold CF. If you're using Windows 8 or 2012, press the Windows key (
) /Q then enter Apache Manifold CF.
The Apache Manifold CF screen displays the status of the jobs crawling your Ektron
content. For more information, see ManifoldCF-End-user Documentation.

Apache Solr console
To view the Apache Solr console screen, on the Solr server, click the Windows Start
button > All Programs > Ektron > Ektron Solr Search 2.0 > Tools > Apache
Solr. If you're using Windows 8 or 2012, press the Windows key (
Apache Solr.

) /Q then enter

The Apache Solr console screen provides information about available logging levels,
how to get management information about each core, the Java information about each
core, and so on.
For more information, see Using the Solr Administration User Interface.

Managing Solr administrative tasks
The following topics explain how to perform administrative tasks that are unique to
Solr. The following list shows other search-related functions that apply to all search
providers.
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l

Basic versus advanced website search on page 361

l

The "Did you mean?" feature on page 371

l

Managing searchability of Ektron content on page 371
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l

Managing search results on page 372

l

Using synonym sets on page 374

l

Providing suggested results on page 376

l

Searching the Workarea on page 390

l

Reporting search activity on page 402

Solr language support
The following languages are supported, along with their two-letter language codes,
without customization. Support is limited to Solr's linguistic capabilities (tokenizing,
stemming, and so on).
l

English (en)

l

German (de)

l

Greek ( el)

l

Spanish (es)

l

French (fr)

l

Hindi (hi)

l

Italian ( it)

l

Japanese ( ja)

l

Korean (ko)

l

Dutch (nl)

l

Norwegian ( no)

l

Portugese (pt)

l

Russian (ru)

l

Thai (th)

l

Chinese ( zh)

You may customize Solr to support additional languages. Refer to the guidelines
specified <SolrInstallPath>\Search2.0\Solr\core0\conf\schema.xml.

Managing the stopwords list
When processing a search query, Ektron's Solr search ignores all words in the
stopwords file for the selected language. The stopwords list's default location is:
C:\Program Files (x86)\Ektron\Search2.0\Solr\cores\<core_id_
number>\conf\<lang>\stopwords_<languagecode>.txt.
The language code is a 2-character alphabetic code. For example, English is en.
Your Solr core name appears on the Solr search configuration details screen on
page 300.
To modify the stopwords list, add or remove terms and save.
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NOTE: To change the path to the stopwords file, customize the schema.

Filtering results with Solr refinements
Refinements lets users explore search results by applying one or more filters. Here is an
example from epicurious.com. Refinements are often called facets.

When describing the refinements feature within Ektron's deployment of Solr search, the
following terms are used.

306

l

Facet. A categorization of search results by values of an index field. A facet is
made up of buckets: each bucket contains a collection of values, and the number of
result items that contain that value.

l

Refinement Specification. A data structure defining a request for a particular
facet to be returned with the results for the associated query. The specification
may include data (thresholds) defining how the data should be categorized.

l

Refinement. The classification by which you want to restrict a search query. This
can be thought of as an identifier representing a particular facet bucket. By
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applying a refiner to a query, you indicate that you only want to see results within
that facet bucket.
You can create refinements from any indexed content property, Smart Form field, or
content metadata. Content properties are always indexed for searchable content.
Smart Form fields and metadata that you feel may enhance your site’s search
experience can be marked as searchable, at your discretion. To indicate that Smart
Form fields are searchable, check the Indexed box on the properties dialog. For
metadata, choose searchable type.
Use the following fields on the Solr Registration screen to configure certain elements of
working with facets.
l

Minimum Facet Count

l

Facet Sorting

You request facets by adding refinement specifications to search criteria. A specification
primarily identifies the target field for which a facet should be generated. For example:
criteria.Refinement.Add(new IntegerRefinementSpecification(SearchContentProperty.Size));

If you are working with index fields whose data types may represent ranged values, you
may specify a collection of bounds to help categorize the data.
To access the API for managing refinements:
1. Install the Ektron 9.10 SP3 version of the OnTrek Sample site.
2. From the site's home page, go to Developer Reference > Framework
API > Ektron.Cms.Framework.Search.
3. Look at KeywordSearchCriteria and terms with “refinement” or “facet.”
NOTE: The Ektron Search API supports Solr field types that translate directly to
string, long, double, and DateTime. Other field types (for example, LatLonType) are
not supported as facets.
NOTE: If you do not apply thresholds when submitting a refinement specification for
a field with a ranged-value data type, data is categorized by each individual value.
(Ranges are not auto-generated.)
Every facet bucket references a refinement. The refinement represents a filter that,
when applied to a subsequent query, ensures the results only include items
corresponding to that facet bucket.
BEST PRACTICES

FOR

WORKING

WITH

REFINEMENTS

When you work with Solr refinements, consider the following advice.
l

Limit the number of refinement fields applied to a query. Six or fewer is a "good
rule of thumb." More than that can be confusing and overwhelming, which
undermines your goal of creating a better experience.

l

Use fields with a smaller set of unique values.
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l

As you organize content and design Smart Forms, think about key properties that
will enable users to identify content of interest.

l

Consider the significance of the property in determining the placement of a facet.
For televisions, brand and price are probably the most significant properties, so
should receive more prominent placement. Less significant properties do not
require faceting and can be displayed within the product listing.

l

Tag content. Content tags are a quick and easy way to provide free-form
classifications of your content and be a very effective facet. See also: Tagging
content, library items, users, and groups with keywords on page 1723.

Managing Solr autoComplete
Solr's Autocomplete feature suggests terms based on the user's input. For example, if
you enter ba, autocomplete provides the following suggestions.

If a user selects a word from the list, a query is executed using that word.
Since the suggestion list is based on user input, it changes as a user enters more
characters. By default, the suggestion list is based on words within searchable Ektron
content. If you prefer, you can create a custom autocomplete suggestions list. You
might do this to control which terms appear on the list, thereby directing site visitors to
desired content. If you create a custom list, only its terms appear as suggestions—
Ektron content is ignored. See also: Creating a custom autocomplete suggestions list on
the facing page.
Additional points about working with AutoComplete:
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l

AutoComplete works with single words only—if the user enters a space,
AutoComplete terminates.

l

Suggestion list terms may include a special character, like power-shot

l

Special characters (such as exclamation point (!) or period (.)) within a search
term are ignored.
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Apache Lucene supports the escaping of special characters that are part of the
query syntax. Here is the current special characters list:
+ - && || ! ( ) { } [ ] ^ " ~ * ? : \
NOTE: The period (.) is not listed a special character at Apache Lucene - Query
Parser Syntax.

Enabling autocomplete
...via Server Control
To enable autocomplete for a templated server control, modify the
SiteSearchController control by adding the following
property: EnableAutoComplete="true". See also: SiteSearch templated server
control.
When using Solr search with templated controls, note these restrictions:
l

You cannot retrieve custom content.

l

The FacetsView control does not support ranged facets for integer, decimal, and
date properties.

...via API
For a sample of enabling autocomplete via the API:
1. Install the latest version of Ektron's OnTrek Developer Sample site.
2. From the site's home page, go to Developer Reference > Framework
API > Ektron.Cms.Framework.Search > QueryPropositionManager.
On an Ektron server, the page's path is
siteroot\developer\Framework\Search\QueryPropositionManager.

Creating a custom autocomplete suggestions list
Follow these steps to create a custom autocomplete suggestions list.

Part 1: Changing the source of autocomplete suggestions
1. Access the Solr registration screen by inserting the following URL into a browser:
https://localhost:base port/SolrAdminConsole/index.html

For example, if you selected the default base port of 7600 during the Solr
installation, enter https://localhost:7600/SolrAdminConsole/index.html.
2. Under the database that you are working with, click Show Advanced Options.
3. Within the screen section Query Completion Dictionaries, check the box next to
the default dictionary (term list).
4. Click Register.
5. After a few minutes, the change is registered. If the registration is successful, the
change is registered in the Search configuration database.
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Part 2: Create a custom suggestions list
PREREQUISITES
l

Your Solr Server and Core Name, available on the Workarea > Settings
> Configuration > Search > Configuration screen.

1. On the Solr search server, open the Ektron Search2.0 folder. (You selected its
location when installing Solr. By default, it is installed to C:\Program Files
(x86)\Ektron\ )
2. Within that folder, open Solr\cores\core number\conf\staticfile.txt.
3. Insert custom words into that file, each on a separate line, and save it.
4. Access the Solr Administrator page: https://Solr server from Search Status
screen/#/~cores/Solrcore name from Search Status screen. For example:
https://localhost:7602/solr/#/~cores/56428657.
5. Select Core Admin > your core > Reload.

For more information on using the Custom Suggestions List, see
https://wiki.apache.org/solr/Suggester > Dictionary.

Maximum size of Solr assets
For optimal performance, Ektron imposes a 10 MB limit on assets. Assets greater than
10 MB can be found by searching for their title or description.
NOTE: The description is searchable via the
API's SearchContentProperty.description property.

Accessing Solr API documentation
To access documentation for the Solr search API:
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1. Install the current version of Ektron's OnTrek Developer Sample site.
2. From the site's home page, go to Developer Reference > Framework
API > Ektron.Cms.Framework.Search.
3. The search API classes, methods and properties are available for all search
providers, including Solr. Tabs explain behavior or functionality differences for
each search provider.

Search Framework API Tutorial is an excellent resource for learning Ektron's Search
APIs.

Troubleshooting Solr
Problem: A request to Manifold CF failed unexpectedly
After completing the Solr registration screen, you see this error:
Validation of your input parameters has failed
A request to Manifold CF failed unexpectedly
Cause: The Search Process services stopped running.
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Solution: Run Process Manager as an administrator (C:\Program Files
(x86)\Ektron\Search2.0\ProcessManager\ProcessManager.exe).
Problem: HTTP Error 500.19 - Internal Server Error
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the
page is invalid.

Cause: The modules section is locked at the server level.
Solution: IIS > Configuration Editor > System.webServer/modules > Unlock section.

Problem: Error: (405) Method Not Allowed; also 404.17 may be encountered.
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No search results in the Workarea. You see the following error in the Windows Event
Viewer/WindowsLogs/Application:
Timestamp: 12/16/2013 10:06:32 PM
Message:Ektron.Cms.Search.SearchException: An error occurred while submitting the query.
---> System.ServiceModel.ProtocolException: The remote server returned an unexpected
response: (405) Method Not Allowed.

Cause: WCF Activation is not enabled.
Solution: For IIS 7.5, use the Add Features Wizard. Go to .NET Framework 3.5.1
Features > select both WCF Activation and HTTP activation .
For IIS 8 (Windows Server 2012), use the Add Roles and Features Wizard. The HTTP
Activation feature is located under .NET Framework 4.5 Features > WCF Services.
https://www.iis.net/learn/web-hosting/configuring-servers-in-the-windows-webplatform/windows-communication-framework-wcf

Known Solr issues and limitations
Installation and launch
l

Whenever you use Solr, log in as the user who installed it. Do not let that user's
credentials expire.

l

If you need change port numbers selected during installation, you must reinstall
Solr.

l

If you upgrade your JDK version, you must replace it in the same directory to which
you originally installed. You may not install more than one JDK version to that
directory.

Site registration
l

While re-registering a site, there may be an error (returned by ManifoldCF) while
deleting a pre-existing connection corresponding to your core.

Error description
During site registration, old jobs for existing connectors (output and Ektron
connector) are deleted prior to deleting the connectors themselves. Although the
jobs are deleted, Manifold may perform clean-up operations on deleted jobs.
During clean up, attempts to delete connectors for such jobs may fail.
In this case, the site registration process attempts to delete the connection again
after a specific interval. You can configure the maximum number of re-tries or the
retry interval in the Ektron Solr Admin Service config file (C:\Program Files
(x86)\Ektron\Search2.0\Administrative Service\
Ektron.Cms.Search.Solr.ServiceHost.exe.config). Within that file, edit the
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MaxDeleteAttempts and MaxDeleteInterval properties. Then, restart the Ektron
Solr Admin Service.

Solution
If you see errors like Exceeded MaxTries while trying to delete
output/repository connection in the Ektron Solr Admin Service logs (Verbose
logging), increase these parameters or wait for the jobs to be completely removed
from Manifold CF. Depending on the size of your index, the clean up of a deleted
job may take a few minutes.
l

After installing Solr, until you register at least one site, if you attempt to browse to
the Solr Admin screen, this message appears: There are no Solr cores running.
Using the Solr Admin UI currently requires at least one Solr core.
After you register a site, this message disappears.

l

If you edit the schema.xml file and try to re-register your site, an error is thrown.

Error Description
The site registration process encountered an error while attempting to remove
an existing Solr core for your site. Could not find a part of the path
'C:\Program Files (x86)\Ektron\Search2.0\Solr\cores\1ca92f29\conf.

Solution
Stop and start the Manifold Agent and Tomcat.
l

If you reload a core and try to register your site again, an error is thrown.

Error Description
The site registration process encountered an error while attempting to remove
an existing Solr core for your site. The process cannot access the file
'tlog.0000000000000000000' because it is being used by another process.

Solution
Stop and start Tomcat.

General issues
l
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If you used the Framework API and templated controls to create search controls
using Microsoft Search Server, you can reuse that code with Solr for the most part.
The Ektron Developer Reference documents functional differences among search
providers.
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Crawling

l

l

Only templated server controls and the Framework API are supported.
o Since version 8.5, the following controls and API are not supported:
n IndexSearch server control
n

Web Search server control

n

ProductSearch server control

n

CommunitySearch server control

n

Search APIs that predate the Framework API
> Ektron.Cms.Framework.Search

To improve performance, assign to the user account under which Solr services will
run permission to lock pages in memory.

Crawling
l

If a full crawl fails, the next crawl is a full one (even if a request for an incremental
crawl was received).
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Search results
l

The search ignores words in a custom summary.

l

If you search a Web calendar title, the results include random words with the
search text.

l

Some results from PageBuilder pages return concatenated text.

l

In some asset summaries, asterisks (*), question marks (�), and other special
characters appear.

l

If you
1. Import a .doc file to the Ektron Workarea.
2. Copy and paste that file in another folder.
3. Run a crawl.
4. The second document can only be searched by its title.

l

If you
1. Publish a content block.
2. Crawl the content.
3. Edit the content block, and set the golive date to a future date.
4. Publish the content.
5. Crawl the content, you see this error:
Error: java.lang.IllegalArgumentException: Source input stream may
not be null

l

If you
1. Install and register a site.
2. Open the Solr admin console and reload your core.
3. Try to register the site again, you see this error:
The site registration process encountered an error while attempting
to remove an existing Solr core for your site.
The process cannot access the file 'tlog.0000000000000000000'
because it is being used by another process.
4. To resolve, stop and start Tomcat to register the site again.
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l

Solr misinterprets some complex queries.

l

The Workarea’s search results include content for which the user does not have
read permission. If a user clicks such content, he is denied access.

l

If a search term exists in a document in a location beyond 100,000 characters, the
document appears in search results but its highlighted summary is blank.
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Solr ManifoldCF database maintenance

If desired, you can increase the number of characters beyond which the
highlighted summary appears with search results. If you do, you may see a
degradation in your search's performance. To increase the number of characters,
follow these steps.
1. Open C:\Program Files (x86)\Ektron\Search2.0\Solr\cores\
[CoreName]\conf\solrconfig.xml.
2. Increase the value of the h1.maxAnalyzedChars property.
<int name="hl.maxAnalyzedChars">100000</int>

Solr ManifoldCF database maintenance
See https://portal.ektron.com/KB/10171/.

Templated search controls
The FacetsView control does not support ranged facets for integer, decimal, and date
properties.

Setting up Microsoft Search Server
2010 Express
IMPORTANT: As of Ektron version 9.3 SP1, Microsoft Search Server 2010 and
Microsoft Search Server 2010 Express are no longer supported.
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This section explains how to install Microsoft Search Server 2010 Express. After
installing it, follow Configuring Microsoft Search Server on page 335 to configure the
search provider. To learn how to use the search, read Using Microsoft Search Server
features on page 360.

Prerequisites
l

You have purchased and deployed Microsoft Search Server 2010. See also: Product
Licensing Search.

l

An understanding of Microsoft Search Server 2010, Best practices for Search
Server 2010
Before beginning the installation, review these Microsoft documents.
o

Hardware and software requirements: https://technet.microsoft.com/enus/library/bb905370(v=office.14).aspx#BKMK_hw_reqs

o

User requirements: https://technet.microsoft.com/en-us/library/ff717834
(v=office.14).aspx

o

Installation of Microsoft Search Server 2010:
https://technet.microsoft.com/en-us/library/ee808898(v=office.14).aspx

l

Both servers can browse to each other across the network.

l

The search, SQL, and CMS servers must be on the same domain.

l

On your Microsoft Search Server 2010 server
o Create a Windows user for search purposes. The user should be
n a domain user

o
l

n

assigned the "log-on as a service" role

n

a member of the administrators group. That user must be logged in when
Microsoft Search Server 2010 is being installed.

Open port 6080 (used by the Protocol Handler Service)

On your Ektron server
o Open ports 6080 and 6081 (used by the CMS File Helper Service to
communicate Ektron services and copy files between the Web and Search
servers)
o

Set SQL Security to SQL Server and Windows Authentication mode

o

Through SQL Management Studio, add the Windows login that you created on
your Microsoft Search Server 2010 server. Assign to that user
n db_creator role
n

securityadmin SQL role

Microsoft Search Server 2010 uses that login to access the Ektron database.
BEST PRACTICE
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You should update your Ektron site's web.config file's
<connectionstrings> tag with the username and password of that
SQL user. Set Integrated Security to False. Then, log into
Ektron to verify that the connection string is valid. See also:
Managing web.config on page 78.
l

On your database server
o Open Port 1433

Installing Microsoft Search Server 2010 Express
1. Install or upgrade Ektron on its server, using the normal procedure. See also:
Installing Ektron on page 9, Upgrading to Ektron 9.40 SP1 on page 37.
2. When prompted to choose a search provider, choose Microsoft Search Server 2010
Express. If you already chose another search provider but want to switch, see
Changing your search provider to Solr on page 299.

3. Continue the Ektron installation.
4. Download Search Server Express 2010 on the server that will host it. See
http://www.microsoft.com/en-us/download/details.aspx?id=18914.
NOTE: If you are using SQL Server 2012, install Microsoft Search Server
Express 2010 SP1.
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5. Launch the Search Server Express installation file. The installation wizard installs
the necessary prerequisites.
6. Accept the Microsoft Software License Terms. Click Continue.
7. When asked to install as a Standalone or ServerFarm, choose ServerFarm.
8. On the Server Type dialog, choose Complete then click Install Now. The
Installation Progress screen appears.
9. The following screen appears. Click Run the SharePoint Products
Configuration Wizard now then Close.

10. The SharePoint Products Configuration Wizard appears. Click Next.
11. A notice about services that may be affected during the configuration appears.
Click Yes.
12. The Connect to a server farm dialog appears. Select Create a new server
farm then click Next.
13. Enter the database server and name along with account information. Then click
Next.
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14. The Specify Farm Security Settings screen appears. Enter any password. You will
need this password to work with the SharePoint Products farm.
15. The Configure SharePoint Central Administration Web Application screen appears.
Accept the default port number or enter a different one.
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16. Under Configure Security Settings, choose NTLM. Click Next.
17. The Configuration Successful message appears. Click Finish.
18. The SharePoint Central Administration opens with dialog about Customer
Experience Improvement. Select No (or Yes) then click OK.
19. The Central Administration > Configure your SharePoint farm page appear. Click
Start the Wizard.
20. Select Use existing managed account then click Next.
21. The page to create a top-level website displays. Click Skip.
22. The Farm Configuration Wizard complete page appears. Click Finish.
23. On the Ektron server, copy C:\Program Files
(x86)\Ektron\CMS400
versionnumber\Utilities\SearchServer\EktronSearchConfiguration.exe.
24. On the Search Server Express server, paste and run
EktronSearchConfiguration.exe as an administrator. The Search
Administrator Credentials screen appears.
25. Enter the domain, username, and password of a user who is a member of the
Windows Administrator group on the Search Server Express server. Click Next.
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26. Determine the location of the folder that maintains the Ektron query service files.
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27. Select the port number to use with the Ektron query service website.

28. The following screen appears. Click Yes even though you are using Search Server
Express.

29. The Ektron Search Configuration files are installed and configured.
30. You are prompted to run the Ektron Search Configuration Utility. Click OK.
31. The InstallShield Wizard Complete dialog appears. Click Finish.
32. Run the Search Configuration utility on the Ektron server. For documentation of
that process, see Configuring Microsoft Search Server on page 335.
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Setting Up Microsoft Search Server
2010
IMPORTANT: As of Ektron version 9.3 SP1, Microsoft Search Server 2010 and
Microsoft Search Server 2010 Express are no longer supported.
This section explains how to install Microsoft Search Server 2010. After installing it,
follow Configuring Microsoft Search Server on page 335 to configure the search
provider. To learn how to use the search, read Using Microsoft Search Server features
on page 360.

Prerequisites
l

You have purchased and deployed Microsoft Search Server 2010. See also: Product
Licensing Search.

l

An understanding of Microsoft Search Server 2010, Best practices for Search
Server 2010
Before beginning the installation, review these Microsoft documents.
o

Hardware and software requirements: https://technet.microsoft.com/enus/library/bb905370(v=office.14).aspx#BKMK_hw_reqs

o

User requirements: https://technet.microsoft.com/en-us/library/ff717834
(v=office.14).aspx

o

Installation of Microsoft Search Server 2010:
https://technet.microsoft.com/en-us/library/ee808898(v=office.14).aspx

l

Both servers can browse to each other across the network.

l

The search, SQL, and CMS servers must be on the same domain.

l

On your Microsoft Search Server 2010 server
o Create a Windows user for search purposes. The user should be
n a domain user
n

assigned the "log-on as a service" role

n

a member of the administrators group. That user must be logged in when
Microsoft Search Server 2010 is being installed.

o

Verify that the server meets the Optimizing Microsoft Search Server 2010 with
Ektron on page 341

o

Open port 6080 (used by the Protocol Handler Service)
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l

On your Ektron server
o Open ports 6080 and 6081 (used by the CMS File Helper Service to
communicate Ektron services and copy files between the Web and Search
servers)
o

Set SQL Security to SQL Server and Windows Authentication mode

o

Through SQL Management Studio, add the Windows login that you created on
your Microsoft Search Server 2010 server. Assign to that user
n db_creator role
n

securityadmin SQL role

Microsoft Search Server 2010 uses that login to access the Ektron database.
BEST PRACTICE
You should update your Ektron site's web.config file's
<connectionstrings> tag with the username and password of that
SQL user. Set Integrated Security to False. Then, log into
Ektron to verify that the connection string is valid. See also:
Managing web.config on page 78.
l

On your database server
o Open Port 1433

Microsoft Search Server 2010 features
l
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A configuration screen for connecting Ektron server with the server hosting
Microsoft Search Server 2010. That screen also monitors the status of search
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crawls.
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l

You can also manage search via SharePoint 2010's Central Administration console.

l

Workarea screens that let you
o view the status of search crawls
o

328

begin new ones if needed
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l

Create and maintain synonym sets

l

Create and maintain suggested results

l

Manage the Integrated Search

l

Templated controls let developers deploy search functionality to the website
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l

Workarea search, which lets Ektron administrators and editors find content within
the Workarea

Installing Microsoft Search Server 2010
1. Log into the search server as the user created for search purposes. As explained in
Prerequisites on page 325, the user must be
l a domain user
l

assigned the "log-on as a service" role

l

a member of the administrators group. That user must be logged in when
Microsoft Search Server 2010 is being installed.

2. Install Microsoft Search Server 2010. Make sure you use the farm install.
3. Install or upgrade Ektron on its server, using the normal procedure. See Installing
Ektron on page 9, Upgrading to Ektron 9.40 SP1 on page 37. If you already
installed Ektron, skip to Step 6.
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4. During the Ektron installation, choose Microsoft Search Server 2010 (Full).
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5. After the Ektron database setup, the following dialog appears. Click No.

The Ektron installation completes.
6. On the Ektron server, copy C:\Program Files
(x86)\Ektron\CMS400
versionnumber\Utilities\SearchServer\EktronSearchConfiguration.exe.
7. Log onto the Microsoft Search Server 2010 server as the same user who ran the
Search Server 2010 Install.
8. On the Microsoft Search Server 2010 server, paste and run
EktronSearchConfiguration.exe. The Search Administrator Credentials
screen appears.
9. Enter the domain, username, and password of a user with Windows Administrator
privileges on the server you will use for Microsoft Search Server 2010.
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10. Determine the location of the folder that maintains the Ektron query service files.
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11. Select the port number to use with the Ektron query service website.

12. The following screen appears. Click Yes if you are using Microsoft Search Server
2010. Click No if you are using Microsoft FAST Search Server 2010

13. The Ektron files are installed and configured. A message instructs you to run the
Search Configuration utility on the Ektron server. For documentation of that
process, see Configuring Microsoft Search Server on the facing page.
During installation, Ektron creates a new website in IIS to host the search services.
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Configuring Microsoft Search Server
This section explains how to configure search using the Express or full version of
Microsoft Search Server 2010. The Search Configuration screen lets you manage the
Ektron's implementation of Search Server.
IMPORTANT: Ektron‘s Search Configuration screen provides access to a few
commonly-used features of your search provider. To fully use search capabilities,
use the search provider's administration utility.
Also, if you remove or edit Ektron website information using IIS, you must restart
the Ektron Windows Service before using the Search Server Configuration screen.

Before you log into the Search Configuration screen
l

Is the Ektron Search Server Service started?

l

For ports opened between the Ektron server and the search server, are firewalls
off?

l

Verify that the user entered during the Search Server installation is also the user
running these Windows services:
o SharePoint 2010 Timer

l

o

SharePoint Server Search 14

o

Ektron Search Server

Verify that the user entered during the Search Server installation is also the user
set in the Advanced Settings > Identity field running these Application Pools:
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o

<GUID> (there may be more than one)

o

SecurityTokenServiceApplicationPool

o

SharePoint Central Administration v4

Logging into Ektron's Search Configuration screen
1. Log on to the server hosting Search Server as an administrator.
2. Click the Windows Start menu > All Programs > Microsoft SharePoint 2010
Products > SharePoint 2010 Central Administration. If you're using
Windows 8 or 2012, go to C:\ProgramData\Microsoft\Windows\Start
Menu\Programs\Microsoft SharePoint 2010 Products\SharePoint 2010
Central Administration.
The port number appears in the browser address field, following http://server
name

3. Click the Windows Start menu >All Programs > Ektron > CMS400Vxx >
Utilities > Search Configuration. If you're using Windows 8 or 2012, press the
Windows key (
Administrator.
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)/Q then enter Search Config. Right click and choose Run as

Managing the search configuration

4. The Connection Information screen appears.

5. In the CMS Server Machine Name field, enter the Ektron server.
6. In the SharePoint Administration URL field, enter http://, your search server
name, colon(:), and port number (see Part 1: Install Microsoft Search Server 2010
on page 352) For example, http://MySearchServer:12345.
7. The Search Service Applications screen appears. Select appropriate Content and
Query Service applications. Click Next.

Ektron's Search Server Configuration screen appears.

Managing the search configuration
This section explains how to use the Search Configuration screen.
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When your Search Server configuration is properly set to connect to your Web server,
the following appears on the screen.

l

338

CMS Database. Information about Search Server's connections to your website.
o Site ID. The IIS site ID on the Web server.
o

Database. The database that Search Server crawls.

o

Database Server. The name or IP address of the site's Web server.

o

Site URL. The URL visitors use to view the website.

o

Version. The website's Ektron version.
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l

CMS Database Connection String. Search Server uses the CMS Database
Connection string to connect to your Ektron database. If the database is on the
same domain as your search server, set Integrated Security to true. Otherwise,
set Integrated Security to false and enter a SQL username and password.
You may leave the field blank to use the connection string in your web.config file
(for a first-time registration) or a previously-used string (for subsequent
registrations).
Or, you can enter a connection string if you wish to override the default connection
string chosen by the registration process. Here is a sample connection string that
gives search access to a specific SQL user:
connectionString="server=Ektron1;database=OnTrek;Integrated
Security=FALSE;user=ABC;pwd=123;"
If you manually enter a connection string, the server name and database name
must match those values in the web.config's connection string.
BEST PRACTICE
Use SQL authentication rather than Integrated Security. Although
Integrated Security is supported, the connection is made in the context
of the search service account (Windows user) provided during
installation. If this user does not have access to the database, the
connection fails.

l

Crawl Interval. Set the incremental crawl interval.

l

Search Server Credentials. Enter the domain, username, and password of a
user with privileges to connect to Search Server.

l

Advanced Options
o Crawl Tracing. Use the drop-down to specify a level of detail collected by the
crawl log. A separate log is created for each crawl, and is saved to the Data
Directory.
o

Data Directory. Identify the folder on your Search Server that stores a copy
of Ektron content needed by Search Server. The directory also stores protocol
logs, which track crawl activity. The default value is C:\EktronSearchData.

o

Secondary Search Servers. Use this area to add secondary search servers
to a load-balanced cluster. You would only do this on a primary server, to
identify its secondary servers. See also: Setting up a load-balanced search
with Microsoft Search Server 2010 on page 346
1. In the Secondary Search Servers section, click Add ( ).
2. Insert the name of the secondary servers.

Ektron Reference

339

Setting up search for your website

3. Click Register Site.

Updating the site registration panel
If you make changes to the Site Registration panel, you need to register the site again.
1. Start the Search Configuration Utility. See also: Logging into Ektron's Search
Configuration screen on page 336.
2. If the Ektron server has several databases, select one from the drop-down.

NOTE: If your Ektron version supports multi-site, the CMS Databases dropdown lists the multi-site database only once. The site Url may correspond to the
main site or any sub-site (depending on their order in IIS).
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3. In the Search Server Credentials area, enter the Domain, Username, and
Password for your Search Server.
4. Click Register Site. A confirmation window appears.
5. Click Yes. Progress appears in a window.

6. When finished, click Close.

Troubleshooting site registration
Error: Failed to connect to specified Search Server. Please verify that your Search
Server URL and port number are valid and try again.
Possible solution:
1. Open the Windows Services control panel.
2. Right-click Ektron Search Server Service.
3. Choose Properties from the context menu.
4. Select the Log On tab from the properties dialog window.
5. Select the radio button labeled This account.
6. Enter the credentials to match those of the SharePoint Server Search 14
(OSearch14) service.
7. Commit your changes.

Optimizing Microsoft Search Server 2010 with Ektron
After installing Microsoft Search Server 2010, you can do several things to optimize
Ektron's use of that technology. These actions ensure you are doing everything possible
to help site visitors find Ektron content.
l

You want Ektron to search text within Visio files. See Installing the Visio IFilter on
page 372.
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l

You want Ektron to search aliased pages, and their extension is not one of Search
Server's standard file types. See Defining unusual file extensions used in aliasing
below.

l

The crawl is taking a long time and your website has over 1 gigabyte of assets, and
over 100 PDFs. Install Foxit PDF Filter from Foxit® PDF IFilter - Server.
After installing, update the registry:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office
Server\14.0\Search\Setup\Filters\.pdf] "Extension"=".pdf"
"FileTypeBucket"=dword:00000001
"MimeTypes"="application/pdf"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Office Server\14.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf]
@="{987f8d1a-26e6-4554-b007-6b20e2680632}"

See also: Index and Search PDF Files in SharePoint Server 2010.
l

Either the crawl or the response time for search queries is too slow. See Setting up
a load-balanced search with Microsoft Search Server 2010 on page 346.

Defining unusual file extensions used in aliasing
Ektron's Aliasing feature lets you create human-readable URLs, such as
support.episerver.com. The URL Aliasing Configuration screenlets you define file
types that may be applied to aliased pages. See also: Creating user-friendly URLs with
aliasing on page 1399
If you define an aliasing file type that is not on Search Server's file type list, you must
add the missing type to Search Server. Follow these steps to accomplish that.
1. Go to Windows Start button > All Programs > Microsoft Search Server >
Search Administration. If you're using Windows 8 or 2012, press the Windows
key (

) /Q then enter Search Administration.

2. Click File Types (as illustrated in the following figure).
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3. Review the Search Server's file type list.
4. If you do not see all extensions defined on the URL Aliasing Configuration screen,
click New File Type (shown in the previous image), then add the missing file
types.

Windows services used by Microsoft Search Server
2010
Ektron's search feature uses several Windows services to monitor database updates,
determine if a new crawl needs to be launched, and perform the database crawl. This
section explains the operation of these services.
l

l

l

Ektron Search Server Service
o Runs on search server and Ektron site server.
o

Responsible for communicating between servers. It triggers search tasks such
as crawling, synonym sets, and so on.

o

Whenever content is added, updated or deleted, this service changes the
Search Status screen's Incremental Crawl Request Pending flag to Yes.
As a result, the next time the crawl interval is reached, this service launches
the Ektron CMS File Helper Service. See also: Using Microsoft Search Server
features on page 360

Ektron ProtocolHandler File Helper Service
o Uses protocolhandler.dll file
o

Runs on Ektron server during a crawl

o

Gets content updates from database server and feeds them to Search Server

Ektron CMSFileHelper Service
o Runs on Ektron site server
o

l

Indexes assets and sends them to Ektron ProtocolHandler File Helper Service

Ektron Query Service. Passes search term from Ektron server to Microsoft
Search Server 2010 and returns results

How services process content updates
1. As Ektron content is added, changed or deleted, the Ektron database is updated.
NOTE: To learn about which events trigger a crawl, see Full vs. incremental
crawls on page 395.
2. If the change warrants a full crawl, it is launched immediately.
3. If the change warrants an incremental crawl, the Ektron Search Server Service
updates the flag that determines if a crawl needs to be started to Yes. You can
view this flag on the Search Status screen's Incremental Crawl Request
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Pending field. When the crawl interval expires, the Ektron CMS File Helper Service
sends content updates to the Ektron Protocol Handler Service.
4. The Ektron Protocol Handler Service feeds the content updates to Search Server.

How queries are processed
Querying is the process by which Ektron retrieves content from the search index.
The Ektron site uses Ektron's Query Service to connect to Microsoft Search Server
2010.
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Default settings for managed properties created by Ektron
When Ektron content is crawled by Microsoft Search Server 2010, the following default
values are set for these metadata properties. You can edit the values using the
Microsoft Search Server 2010 Central Administration console.
l

Queryable. True

l

StemmingEnabled. False

l

RefinementEnabled. False

l

MergeCrawledProperties. True

l

SubstringEnabled. False

l

DeleteDisallowed. False

l

MappingDisallowed. False

l

MaxIndexSize. 1024

l

MaxResultSize. 64

l

DecimalPlaces. 10

l

SortableType. SortableEnabled

l

SummaryType. Static
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Setting up a load-balanced search with Microsoft
Search Server 2010
You can use load balancing to distribute your search's workload across multiple servers.
Load balancing improves search's performance by significantly decreasing the time to
complete search crawls and process search queries (especially when a site is under a
heavy load).
This section describes 2 scenarios for setting up Load Balanced search.
l

You already installed Microsoft Search Server 2010 on one server, and now want to
bring additional servers into the cluster—see Adding a site to a server that hosts
Microsoft Search Server 2010 and Ektron below

l

You have not yet installed Microsoft Search Server 2010—see Installing Microsoft
Search Server 2010 to a primary server in a load balance cluster on page 348

Adding a site to a server that hosts Microsoft Search Server
2010 and Ektron
1. On the Ektron server, run the Site Setup utility: Windows Start button >
Programs > Ektron >version> Utilities > CMS400 Site Setup. If you're
using Windows 8 or 2012, press the Windows key (
Site Setup.
See also: Installing a site on page 17

) /Q then enter CMS400

2. During the Ektron installation, you are prompted to choose a search provider.
Choose Microsoft Search Server 2010 Full.
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3. The setup continues as normal. After the installation is complete, the following
dialog appears. Click Yes.
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The Search Configuration screen appears. For documentation of that process, see
Managing the search configuration on page 337

Installing Microsoft Search Server 2010 to a primary server in a
load balance cluster
Use this procedure if you have not installed Microsoft Search Server 2010 on the
primary server in a Load Balance cluster.
PREREQUISITE
l

See Hardware and software requirements (Search Server 2010).

l

A SQL user with the sysadmin role

1. Obtain, download, and install Microsoft Search Server 2010.
NOTE: You may be informed that you need to run the Products Preparation Tool
before beginning the installation.
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2. Choose Server Farm when you are prompted for an installation type.

3. On the Server Type tab, select Complete then click Install Now. Search server
is installed.

4. Run the Configuration Wizard, which lets you set up Microsoft Search Server 2010.
The SharePoint Configuration Wizard is launched.
5. Choose Create a new server farm on the Connect to a server farm screen.

6. Specify a database server, name, and user name and password for access to the
account.
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a. For Database name, accept the default of SharePoint_Config.
b. Enter a Username and Password of a SQL user with the sysadmin role.
Microsoft Search Server 2010 uses them to access your Ektron database. Click
Next.

7. Enter a password for access to the server farm.

8. Enter a port number and Security settings. You may enter any open http port. For
Security Settings, choose NTLM.
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9. Click OK to confirm the information you entered.
10. Click Finish to launch the SharePoint Central Administration site to allow for
additional configuration and provisioning. Noted that the first installation in a farm
does not create a Web application or provision a site. See also: SharePoint 2010
Central Administration.
The following screen appears within SharePoint.

11. Click Start the Wizard and complete the wizard.

Adding servers to a load balance cluster
PREREQUISITE
Ektron Reference
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2 servers running Microsoft Search Server 2010; the servers cannot use
Search Server Express.
See Hardware and software requirements (Search Server 2010)
When setting up search load balancing, you need to decide which server is the primary
one, and which is/are the secondary one(s). This procedure describes how to set up a
single secondary server in a load balanced cluster. To set up additional secondary
servers, follow these instructions for each secondary server. See also: Installing
Microsoft Search Server 2010 to a primary server in a load balance cluster on page 348

Part 1: Install Microsoft Search Server 2010
1. Obtain, download, and begin to install Microsoft Search Server 2010.
NOTE: You may be informed that you need to run the Products Preparation Tool
before beginning the installation.
2. For an installation type, choose Server Farm.

3. On the Server Type tab, select Complete then click Install Now.

Search server is installed.
4. Run the Configuration Wizard, which lets you set up Microsoft Search Server 2010.
The SharePoint Configuration Wizard is launched.
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5. On the Connect to a server farm screen, choose Connect to an existing server
farm.

6. On the Specify Configuration Database Settings screen, in the Database server
field, enter the primary server in the load balance cluster.
7. Click Retrieve Database Names. The primary server's database appears in the
Database name field.

8. Enter the same passphrase that you entered when setting up the primary server.
See also: Installing Microsoft Search Server 2010 to a primary server in a load
balance cluster on page 348
9. Complete the remaining prompts; the wizard uses information to configure
Microsoft Search Server 2010.

Part 2: Set up query components
In this procedure, you create 2 query components. One defines this secondary server
as a failover server, which takes over processing if the primary server goes offline. The
second query component distributes the processing of search queries among search
servers.
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1. Open Microsoft Search Server 2010's Central Administration screen.

2. Click Manage service applications (highlighted). The Service Applications
screen appears.
3. Click Search Service Application 1. The Search Service Application 1: Search
Administration screen appears.
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4. Scroll down to Search Application Topology and click Modify (highlighted).

5. To set up the failover server, under Index partition 0, click Query Component,
then Add Mirror.
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6. Use the following information to complete the Add Mirror Query Component screen.
l Server. Enter the server to which you are currently signed on.
l

Associated Property database. Select the primary server and the database
you specified in Step 4.

l

Location of Index. Accept the default.

l

Failover-only Query Component. Ektron recommends checking this box. If
you do, and the primary search server goes offline, the secondary server
processes all search queries until the primary server returns.

7. The Search Service Application 1: Search Administration screen reappears. Click
Apply Topology Changes.
The secondary server now appears under Index Partition (highlighted).
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8. Set up a query component to distribute the workload of handling search queries.
To do that, from the Search Application Topology area, click New > Index
Partition and Query Component.

9. The Add Query Component Screen appears. Complete Part 2: Set up query
components on page 353, but this time do not check the Failover-only Query
Component box.
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10. The Search Service Application 1: Search Administration screen reappears. Click
Apply Topology Changes.
11. To do that, from the Search Application Topology area, click New > Crawl
Component.

12. Specify the fields when the Add Crawl Component screen appears.
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l

Server. Enter the server to which you are currently signed on.

l

Associated Crawl database. Select the primary server and the database
you specified in Step 4.

l

Temporary Location of Index. Accept the default.

13. The secondary server appears under Crawl (highlighted).

14. Close Search Server Administration.
NOTE: You only need to follow the next 2 steps once. So, if you are setting up
multiple secondary servers, you can skip these 2 steps after setting up the first
one.
15. On the Ektron server, copy C:\Program Files
(x86)\Ektron\CMS400
versionnumber\Utilities\SearchServer\EktronSearchConfiguration.exe.
16. On both search servers, paste EktronSearchConfiguration.exe and run it.
17. On your Ektron Web server, open the Search Configuration screen, available from
C:\Program Files
(x86)\Ektron\CMS400vxx\Utilities\SearchServer\Ektron.Cms.Search.Conf
ig.UI.exe.
18. Click Advanced Options.
19. In the Secondary Search Servers section, click Add (
the secondary server(s).

) then insert the name of
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20. Click Register Site.

Using Microsoft Search Server
features
NOTE: This section applies to Microsoft search servers. Exceptions within Search
Server versions (including FAST) are noted. For information about Solr search
servers, see Using Solr search on page 216.
Visitors choose search to go your website more frequently than any other navigation
option. Search usage often exceeds links, menus, or site maps. This is especially true
when visitors have a term or phrase in mind. Advanced visitors may narrow down
search results by adding special terms or query strings.
As an administrator or developer, you want to provide the optimum search results
quickly, with the most relevant results near the top. To accomplish this, adjust the
search engine results by setting Using synonym sets on page 374, Suggested Results,
and keywords.
In some cases, you can anticipate what the visitor is looking for and provide a
convenient way to display results with the click of a button or image. To do this,
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developers can create automated queries that provide the unique combination of
keywords and terms that provide results that are highly targeted to the visitor's quest.
These queries are found in the code-behind and use the search API.
The website search should provide a simple user interface and relevant results.

Basic versus advanced website search
To provide your website with search capabilities, your developer places Site Search
server controls on a page. See also: SiteSearch Templated Server Controls
The search may look like the following image, although your developer has total control
over its appearance.

Basic search
NOTE: You can designate a folder outside of Ektron to be searched. For more
information, see Including external files in a search on page 385.
The Basic Search finds content that satisfies these criteria.
l

Published. Changes checked in but not published are not accessible.
NOTE: New and updated content is available only after the next crawl
completes. See also: Managing the search crawl on page 395.

l

Active. Also, expired content appears if the archive option is Archive and remain
on Site.

l

Content’s Content Searchable box is checked.

l

Public. Private content is only available to those with permission to view it, such as
membership users after logging in. See also: Making content private on page 695.
IMPORTANT: Private content is hidden from search results if your search
provider is Microsoft Search Server 2010. It is not hidden if you are using
another search provider.

l

Library items are searchable by title and file name. To make the content of nonimage files (for example Word documents) searchable, add them as assets. See
also: Working with assets in the Document Management System on page 708.

l

Language
o Website search—Content in selected site language appears unless the
developer sets the language via Advanced Query Text or API
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o

Workarea search—Content in the Workarea’s current language appears (user
selects Workarea language via the View > Language menu option)

l

Search text is contained in title or content

l

If the search text is more than one term, all terms must be found. So, multiple
terms have an AND relationship.
NOTE: A user may force an OR relationship by entering OR between search
terms, or using the Advanced Search's any of these words option. Developers
may create an OR-based search using the API property ImplicitAnd.
IMPORTANT: If you have a multi-site configuration, a search conducted from
any site returns results from all sites. To limit search to single site, use a syntax
like this:
AdvancedQueryText=' AND ( "parentsiteid"=0 OR "parentsiteid"=161 )
'

l

Satisfies content type criterion selected on screen, if chosen.

NOTE: The search does not find documents inside compressed files, such as
*.zip, *.cab, and so on.
The following list explains the values in the Advanced Search tab's Content Type
field.
l

Site
o

Content from all options.

o

Any document file type defined in the Asset Server Setup screen.
NOTE: You can find these files using Site as the content type criterion, but
not using Documents.

l
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HTML
o HTML
o

HTML form (but not data submitted on form)

o

XML Smart Form (field values but not field labels)
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l

o

Blog entries (not comments)

o

Web calendar events

Documents
o MS Office documents (includes Powerpoint, Excel)
NOTE: To search Visio documents, you must install the Visio IFilter. See
also: Installing the Visio IFilter on page 372
n
o

Document properties (categories, comments, and so on)

PDF file
IMPORTANT: The search only finds text in the first 16 MB of any
PDF document. So, for example, if the file is 32 MB, only the first half
of the text is searchable.

o
l

.txt file

Images added as assets and through the library
o Search text in file name (including file type extension) and summary.
NOTE: If you assign several images to an eCommerce catalog entry, and
want to allow searching for that catalog entry by image file name, the
search only works with the first image assigned to the catalog entry.

l

Multimedia (Flash, .mp3, and so on)
o Search text in file name (including file type extension) or summary

l

Forums
o Forum posts and replies

l

Tags
o Tags applied to content and library items See also: Tagging content, library
items, users, and groups with keywords on page 1723

l

PageBuilder Pages
o PageBuilder page: properties (summary, metadata, and so on) and content
within the page's widgets.
IMPORTANT: If a content block is added to a PageBuilder page, the search
only returns its appearance on the PageBuilder page. The search does not
find such content on a non-PageBuilder page.

Advanced search
The Advanced Search uses the same search criteria as the Basic Search. (See Basic
search on page 361). The differences are additional options and the fact that you
cannot use queries.
NOTE: The advanced search screen may look like the following image, although
your developer has total control over its appearance."
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l

all of these words. Web page includes all submitted terms; their position on the
page does not matter.

l

none of these words. Web page does not contain the submitted term

l

the exact phrase. Web page must include the exact phrase. For example, if you
enter Ektron healthcare, a page with the term Ektron provides healthcare is
not found because it is not an exact match.

l

any of these words. Web page includes any submitted term

Managing search queries
Formulating search queries
NOTE: Following text extracted from Free-Text Keyword Queries.
To search for any word or phrase on a website, enter the word into the field and click
Search to begin.

The following rules apply to formulating queries:

364

Ektron 9.40 SP1

Formulating search queries

l

By default, multiple words have an "and" relationship. So, the search term
calendar server returns pages that have both words.
o To find pages with either term, use the OR operator. For example, calendar
OR server returns pages that have either word.
IMPORTANT: You must capitalize Boolean operators, such as AND.
o

To find pages with several terms in exact order with no intervening words, use
quotes. For example, “calendar server” returns pages that have both terms
in that order.

o

To find pages that have one term without another, use the NOT operator. For
example, For example, calendar NOT server returns pages that have
calendar and do not have server.

o

To find several terms close together, use NEAR. For example, treatment
NEAR immunoglobulin finds pages with the word “treatment” near the word
“immunoglobulin.”
IMPORTANT: You cannot use the NEAR operator with Solr search
provider.
The NEAR operator is like AND because it finds pages that include both search
words. However, the rank assigned by NEAR depends on the proximity of the
search words. A page with search terms closer together has a higher rank than
a page where they are farther apart.
NOTE: The NEAR operator can be applied only to words or phrases.

l

Search terms are case-insensitive.

l

Punctuation marks, such as period (.) and comma (,), are ignored by the search.

l

Operators (<, >, and &) are ignored by a search. Also, the search does not find
text within angle brackets, for example <Ektron>.

l

To include in a query special characters that are not operators, such as +, |, ^, #,
@, $, (,), enclose the query in quotation marks (“).

l

Use the wildcard character (*) to find words that start with a certain letter
sequence. For example, esc* returns Web pages with “ESC,” “escape,” and so on.

l

To nest expressions within a query, add parentheses. Expressions within
parentheses are evaluated before the rest of the query.

l

Use double quotes (“) to ignore a boolean or NEAR operator keyword. For example,
“Abbott and Costello” finds pages with the entire phrase, not pages that match the
Boolean expression.

l

The AND operator has a higher precedence than OR. For example, the first 3
queries are equal, but the fourth is not:
o a AND b OR c
o

c OR a AND b
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o

c OR (a AND b)

o

(c OR a) AND b

Using Autosuggest
IMPORTANT: Autosuggest works with Microsoft-based search providers only. If
you are using the Solr search provider, see Managing Solr autoComplete on
page 308.
Autosuggest is a search feature that suggests similar terms or common refinements
that searchers have used in the past which are related to the search term. As a user
enters text, possible matches appear. This immediate feedback may preclude the user
from typing an entire search phrase, and instead choose a term with which to launch
the search.

Terms appear on the list if they
l

include the submitted letters, and

l

were previously submitted by site visitors, and

l

have resulted in the viewing of a search result

Autosuggest only works with the Site Search Control.

Enabling Autosuggest
1. Every Web page that retrieves search results requires a SiteSearchController
templated server control. See also: SiteSearch Templated Server Control.
In Visual Studio, add the following properties and values to each
SiteSearchController control that will use Autosuggest.
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l

EnableQueryStatistics="true”

l

EnableAutoSuggest="true"

l

AutoSuggestMaxCount—the maximum number of entries in the autosuggest
list
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2. On your search server machine:
a. Go to IIS Manager and expand the EktronSearchSite IIS Site.
b. Right click EktronSearchStatistics and choose Explore.
c. Under EktronSearchStatistics, open web.config.
d. Within that file, set NumberOfClicksToTrigger to 1, 2 or 3. This key defines
the number of times a user chooses an autosuggest search term and then
clicks on a search results page before the term is added to the suggested
results list.
For example, you decide that a term is added to the list only after it is selected
and users click on the results page 3 times.

Adding a term to Autosuggest
Normally, you would not add autosuggest terms, because the terms list is built from
previous successful searches. However, there may be times when you want to add
autosuggest terms that direct searches to specific content. To manually add terms to
the autosuggest list, follow these steps.
PREREQUISITE

Knowledge of SharePoint Powershell cmdlets
1. Log on to your search server.
2. Open the SharePoint 2010 Management Shell.
3. Add a term to the autosuggest list by inserting this command.
New-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication <Search Service Application>
-Name <Name of the term>
-Language <en-US>
-Type QuerySuggestionAlwaysSuggest

Command Parameters
l

If you are using a Microsoft FAST search server, for <Search Service
Application>, enter the Search Service Application you created for FAST
Query in Part 2d: Create a search service application for querying on
page 472.

l

If the search term has more than one word, surround it with double quotes.
For example, "Phrase Term."

l

For Language, enter a language code followed by the locale code (as
examples: en-US, en-UK).

4. Remove the term from the block list (if it exists there) by inserting this command.
Remove-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication <Search Service Application>
-Identity <Name of the term>
-Language <en-US>
-Type QuerySuggestionBlockList
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5. Run the timer job.
Get-SPTimerJob
-Identity "Prepare Query Suggestions" | Start-SPTimerJob

6. Check the Last Run time against the current time.
7. When the Timer Job shows the Last Run Time as the current time, the operation
has succeeded, and the term is added to the suggested terms list.

Example of adding a term to Autosuggest
To manually add a suggestion for ektron:
$app = Get-SPEnterpriseSearchServiceapplication "FASTQuery"
New-SPEnterpriseSearchLanguageResourcePhrase
-SearchApplication $app
-Language en-us
-Type QuerySuggestionAlwaysSuggest
-Name “ektron”

If ektron was added to the Block list, it must be removed. (If it does not exist and you
run these commands, you get an error: Given key not present in the dictionary.)
Remove-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication $app
-Identity ektron
-Language en-us
-Type QuerySuggestionBlockList
(Get-SPTimerJob –Identity “Prepare Query Suggestions”).RunNow()

Wait 3 minutes to see results.

Removing a term from Autosuggest
You may need to remove inappropriate or derogatory terms from the autosuggest list.
To do that, a term to the block list by following these steps.
PREREQUISITE

Knowledge of SharePoint Powershell cmdlets
1. Log on to your search server.
2. Open the SharePoint 2010 Management Shell.
3. Add a term to the block list by inserting this command. See also: Command
Parameters on the previous page
New-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication <The Search Service Application>
-Name <Name of the term>
-Language <en-US>
-Type QuerySuggestionBlockList
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4. Run the timer job.
Get-SPTimerJob
-Identity "Prepare Query Suggestions" | Start-SPTimerJob

5. Check the Last Run time against the current time.
6. When the Timer Job shows the Last Run Time as the current time, the operation
has succeeded, and the term is blocked from the autosuggest list.
If you later decide to remove a term from the block list, use this command.
Remove-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication <The Search Service Application>
-Identity <Name of the term>
-Language <en-US>
-Type QuerySuggestionAlwaysSuggest

Example of removing a term from Autosuggest
To block the term ontrek
$app = Get-SPEnterpriseSearchServiceApplication "FASTQuery"
New-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication $app
-Language en-us
-Type QuerySuggestionBlockList
-Name ontrek

Remove the term from the suggestion list, if it exists. (If it does not exist and you run
these commands, you get an error: Given key not present in the dictionary.)
Remove-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication $app
-Identity ontrek
-Language en-us
-Type QuerySuggestionAlwaysSuggest
(Get-SPTimerJob –Identity “Prepare Query Suggestions”).RunNow()

Wait 3 minutes to see results.

Viewing the blocked words list
To view the blocked words list, enter
Get-SPEnterpriseSearchLanguageResourcePhrase
–SearchApplication <Search Service Application>
-Language en-US
-Type QuerySuggestionBlockList

Troubleshooting Autosuggest
If you don’t see the autosuggest drop-down, try the following.
1. Open all (3) web.configs and verify that they contain the same values for the
QuerySSA and ProviderAdmin keys.
Ektron Reference

369

Setting up search for your website

2. Open C:\Program Files
(x86)\Ektron\EktronSearchServerService\EktronSearchServerHelperServi
ce.exe.config and verify that the following keys have correct paths.
l QueryServiceEndpoint
l

QueryStatisticsEndpoint

l

QuerySuggestionEndpoint

3. In the SharePoint Management Shell, enter
Get-SPEnterpriseSearchQuerySuggestionCandidates -SearchApplication
"<Search Service Application Name>". Inspect the command for your
autosuggest word.

l

If the command returns a blank screen, check the
C:\inetpub\EktronSearchSite\EktronSearchStatistics directory for a
logs folder. If this folder is empty, verify that the SiteSearchController contains
EnableQueryStatistics="true” and EnableAutoSuggest="true”.

l

If your list appears but the autosuggest drop-down does not, verify that your
SiteSearchController contains EnableAutoSuggest="true".

4. Manually test that autosuggest words are returned to your site by entering the URL
on the Ektron server.
http://<Your EktronSearchSite website:Port # >
/EktronQuerySuggestion/SPQuerySuggestion.svc
/QuerySuggestionForCulture?keywordPrefix=sa&culture=en-US

NOTE: ‘sa’ is the prefix you used to return autosuggest entries.
After submitting this url, download and open QuerySuggestionForCulture file in
Notepad to see autosuggest results. To continue the above example, you might see
{"QuerySuggestionForCultureResult":{"Suggestions":["sample"]}}
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The "Did you mean?" feature
If a site visitor enters a word that is similar to a crawled term, the "Did you mean?"
feature often suggests close alternatives. If you click a suggested term, a search is
performed on it.

The "Did you mean?" feature works only with single word queries.
NOTE: If your search provider is Solr, the "Did you mean?" feature only works with
words in the content title.

Managing searchability of Ektron content
Making content searchable
Search only accesses data about the content if the Content Searchable field is
checked.
NOTE: Despite the value of this checkbox, if an Ektron user places this content item
in a Suggested Results list, it appears in the Suggested Results area of the Search
Results screen. See also: Providing suggested results on page 376.
Also, even if Content Searchable is unchecked, the Advanced Workarea search
can find the content.
The default value of this field is determined by the ContentSearchable folder
property.
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Installing the Visio IFilter
The search finds text within Visio documents if the Visio IFilter is installed to the
Microsoft Search Server used by the Ektron Web server. Use the following link to
download and install the Visio IFilter.
Microsoft Office 2010 Filter Packs
IMPORTANT: The Visio IFilter does not work with the Solr search provider.

Searching for metadata
The following rules apply when searching for values inside metadata.
l

The search finds text within Searchable type and Content Tag metadata fields. For
example, a content block has a searchable type metadata field, MapAddress, that
contains 131 Amherst St. Searching for 131 returns that content.

l

To find content with searchable metadata whose style is yes or no, enter true or
false.

See also: Working with Metadata on page 822

Managing search results
Displaying search results
See also: Search result ranking on the facing page
The following example shows the website search results screen. Your developer can
customize it using the appropriate ResultsView server control. For example, to display
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eCommerce catalog entry results, the developer uses ProductSearch templated server
controls.

Customizing the postback message
By default, if a search term yields no results, a message appears.

To customize this message:
1. In your site root folder, find the workarea/resources folder.
2. Open the resource file that corresponds to your site’s language. For example, if
your site is in American English, open EkResource.en-US.resources. To learn
how to work with a resource file, see Translating the Workarea on page 1548.
If your site supports multiple languages, follow these steps for each corresponding
resource file.
a. Within the resource file, find the key lbl search no results.
b. The default text (shown above) follows this key. Modify the text as needed.
c. Save the file.

Search result ranking
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NOTE: This topic describes search rank using Microsoft Search Server 2010. To
learn about search rank using Microsoft FAST Search Server 2010, see Setting Up
Microsoft Search Server 2010 on page 325.
Each content item found by search is given a numerical rank. Search results are sorted
by rank. Criteria used to calculate rank include the
l

number of occurrences of the search term

l

proximity of search term to beginning of file

l

proximity of search term to other occurrences of the term

l

whether the term is in the title

If you need to ensure that certain content appears at the top of search results when
certain terms are entered, use suggested results. See also: Providing suggested results
on page 376
To learn about customizing ranking for Microsoft Search Server 2010, see
l

Custom Ranking Models with SharePoint 2010: Background, Value and
Administrative Overview

l

Creating Custom Ranking Models

l

SharePoint 2010 enterprise search developer training

Using synonym sets
PREREQUISITE

You must be a member of the Administrators Group or assigned the SearchAdmin role to access Synonym Sets. See also: Defining roles on page 1581
IMPORTANT:
*Changes to a Synonym Set reset Search Server. To minimize impact on your
visitors, make such changes during off-peak hours.
* Synonym Sets apply to all Ektron sites associated with a Search Server instance.
For example, if Site A, Site B, and Site C use the same Search Server instance, they
share Synonym Sets. This means that a Synonym Sets created in Site A may affect
Site B's search results.
You can create sets of synonyms to work with the search. If a site visitor enters into the
search field any term in a synonym set, the search returns results for that term plus all
other terms in the set.
For example:
l

Synonym Set: Tuition

l

Terms: tuition, bill, payment, pay, fee, charge, price, amount, cost, balance

If a site visitor inserts bill into the search field, Ektron uses bill or tuition or payment
or pay or fee or charge, and so on., to determine search results.
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The Synonym feature typically produces more “hits.” So, while visitors do no more
work, their chances of finding the right information are greatly increased.
NOTE: Previous to version 8.5, you could use Synonym sets in Suggested Results.
This is no longer provided in versions 8.5 and higher.
BEST PRACTICES

FOR USING SYNONYM SETS

A search term can consist of several words as long as the term is entered the
same way in the Synonym Set. For example, love seat is part of a Synonym
Set that includes sofa. As long as both love and seat are in a content item,
the search finds it even if the words are separated. But, entering a single
term, like love, will not find that Synonym Set. So, if you think people may
search using loveseat or love seat, enter both terms into the Synonym
Set.
The metadata search does not use or support Synonyms Sets.
If a search term consists of several words, it does not return synonym match
results.
For example, you create a synonym set that contains {cms; content
management system}. If a site visitor enters CMS, the search results include
matches for cms and content management system. But, if the site
visitor enters content management system, the results do not include
matches for cms.

Creating a synonym set
IMPORTANT: A term can only appear in one Synonym set.
1. Choose Workarea > Settings > Configuration > Search > Synonyms.
2. Select a language for the Synonym Set from the language drop-down menu. (The
search is language-specific. When site visitors begin using your site, they select a
language. Only synonyms sets in that language are considered.)
3. Click Add Synonym. The following screen appears.

4. Enter all terms in the set. Separate each with a semicolon (;). You cannot enter a
comma (,) or parenthesis character (().
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5. Click Check for Duplicates. Ektron compares these terms against other Synonym
Sets in this language. If the same term is found in another set, you are notified and
must remove it.
6. Click Save Synonyms.

Editing a synonym set
1. Choose Workarea > Settings > Configuration > Search > Synonyms.
2. Select a language for the Synonym Set from the language drop-down menu.
3. Click the Synonym Set that you want to edit.
4. Click Edit. The Edit Synonym Set screen appears.
5. Add or remove terms. Be sure to separate each term with a semicolon (;).
6. Click Check for Duplicates. Ektron compares these terms against other Synonym
Sets in this language. If the same term is found in another set, you are notified and
must remove it.
7. Click Save Synonyms.

Deleting a synonym set
1. Choose Workarea > Settings > Configuration > Search > Synonyms.
2. Select a language for the Synonym Set from the language drop-down menu.
3. Click the Synonym Set that you want to delete.
4. Click Delete ( ).
5. Confirm your action.

Providing suggested results
PREREQUISITE

You are a member of the Administrators Group or assigned the SearchAdmin role See also: Defining roles on page 1581
Your website may contain thousands of content items. Sometimes, depending on the
search phrase, you want to focus the visitor's attention on a few topics. The Suggested
Results feature lets you create a set of search terms, then specify content to appear at
the top of the results when someone searches on a term.
Suggested Result links can jump to your website or an external website.
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IMPORTANT:
* Prior to Ektron version 8.5, Suggested Results could be language-specific.
Beginning with version 8.5, Suggested Results do not filter based on language.
* As of version 8.5, Suggested Results do not use terms from the Synonyms Set
feature.

Using suggested results to enhance business opportunities
You can use Suggested Results to direct site visitors to business partners' websites.
One example is a smoking cessation clinic near your hospital. When someone visits
your website and searches for smoking, you can set the clinic to be the top Suggested
Result.
As another example, your organization creates widgets but does not implement or
customize them. Over time, several agencies develop experience at deploying and
customizing your widgets. Therefore, you want to promote the supporting businesses
on your site. The following steps describe how this works.
1. Create a phrase with synonyms—deploy, install, implement, customize, modify,
adapt.
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2. Assign the websites of approved agencies to the Suggested Results list.
3. When a site visitor searches for the word implement, he gets links to those
agencies’ websites.
Suggested Results can also be used to advertise products, as used in the sponsored
results section of search engines like Google® search and Yahoo!®.

Using suggested results to direct site visitors
Use this feature to provide search results that do not naturally appear at the top of the
page. For example, you manage a university’s website. When a site visitor wants to
know where to mail a tuition payment, he enters bill into the search field and gets
these results.
l

Faculty member Bill McDermott

l

The Student Bill of Rights

l

How a Bill Becomes Law

Frustrated, many people call the business office to get information that exists on the
website but is difficult to find.
Using Ektron, you create Suggested Results to direct site visitors to the correct Web
pages. To continue this example, you could create
l

a title (such as Tuition) that describes a set of terms and links

l

a list of synonyms that visitors might enter when searching for the tuition page on
your site

l

a Suggested Results list, where you assign the content “Tuition & Fees”

After you set up Suggested Results, this is a typical sequence of events.
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1. A site visitor enters text on your Search page.

2. The text matches a term in the Phrases list of a Suggested Results set.

3. Suggested Result links assigned to the phrase appear in a special area of the
results page. They appear in the same order that you created in the Suggested
Results set.
NOTE: The following example shows how suggested results may appear. Your
developer styles suggested results in the ResultsView server control.
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4. The search term’s regular results may also appear. Your developer determines
their location on the results page.

Creating a set of suggested results
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1. Workarea >Settings > Configuration > Search > Suggested Results.
2. Click Add New Suggested Result Set. The following screen appears.

3. Complete the fields.
l Name. A word that names the Suggested Results set and is the first synonym.
(You cannot repeat the phrase in the Synonyms.)
l

Phrases. The list of words that triggers the Suggested Results you will create.
That is, if a user enters a search phrase that matches any term in the
Synonyms, the Suggested Results appear.

l

Suggested Results. The links to appear when a phrase or synonym is found.
To define them, place the cursor in this field and click. A menu appears.

4. Click Add. A screen appears.
5. Add the URL, title, and summary for each suggested result.
l Link. To create a link to...
o content on your website, click the Browse to CMS content button.
Then, go to the folder that contains the content, select it, and click Save.
NOTE: Only content in the Workarea language appears. To change the
language, exit this screen, go to the root folder, and click View >
Language.
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o

l

an external website, enter its full address, starting with its protocol, such
as http://.

Title. If you created a link to...
o content on your website, its title is retrieved and displayed here. You may
edit it as needed.
o

an external website, enter the text of the link that will appear on the
Suggested Results display.
Site visitors use this text to select the linked Web page.

l

Summary. If you created a link to...
o content on your website, its summary appears here. You may edit it as
needed.
o

an external website, nothing appears. Enter text to further describe this
link on the search results page.
The summary cannot exceed 320 characters (including HTML tags). For
example:

6. Click Add New Suggested Result Set. The Add Suggested Results screen
reappears. You can add more links, edit existing ones, and so on.
7. Click Save Suggested Results.

Displaying suggested results
To display suggested results using templated server controls, set up a
SiteSearchResultsView control whose Eval statement refers to SuggestedResults.
<ektron:SiteSearchResultsView ID="r" runat="server" ControllerID="c">
<ItemTemplate>
<h3>Suggested Results</h3>
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<asp:ListView ID="suggestedResults" runat="server"
DataSource='<%# Eval("SuggestedResults") %>'>
<ItemTemplate>
<span class="highlight">
<a href="<%# Eval("Url") %>"><%# Eval("Title") %></a>
<%# Eval("Summary") %>
</span>
</br>
</ItemTemplate>
</asp:ListView>
</ItemTemplate>
</ektron:SiteSearchResultsView>

The suggested results class displays only 3 fields: title, URL, and summary.
If you want regular search results to appear below suggested results (as shown in
Providing suggested results on page 376), your developer may want to style the
suggested results to stand out. Some styling is shown above.
To display regular search results below suggested results and customize the standard
result template, make the following modifications.
<ektron:SiteSearchResultsView ID="r" runat="server" ControllerID="c">
<ItemTemplate>
<h3>Suggested Results</h3>
<asp:ListView ID="suggestedResults" runat="server"
DataSource='<%# Eval("SuggestedResults") %>'>
<ItemTemplate>
<span class="highlight">
<a href="<%# Eval("Url") %>"><%# Eval("Title") %></a>
<%# Eval("Summary") %>
</span>
</br>
</ItemTemplate>
</asp:ListView>
<asp:ListView ID="suggestedResults" runat="server"
DataSource='<%# Eval("Results") %>'>
<ItemTemplate>
. . .
</ItemTemplate>
</asp:ListView>
</ItemTemplate>
</ektron:SiteSearchResultsView>

However, if you want to display standard results and use the default template, insert a
separate SiteSearchResultsView control below the suggested results control. See also:
SiteSearch templated server controls.

Adding a link to a suggested result set
1. Choose Workarea > Settings > Configuration > Search > Suggested
Results.
2. Select the suggested results set to which you want to add a link.
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3. Click Edit.
4. Place the cursor over the first result in the Suggested Results area of the screen.
5. Click once and a menu appears.
6. Click Add. The Add New Suggested Results screen appears.
7. See Click Add New Suggested Result Set. The Add Suggested Results screen
reappears. You can add more links, edit existing ones, and so on. on page 382
8. Click Add New Suggested Result Set.
9. Click Save Suggested Results.

Editing a link in a suggested result set
1. Choose Workarea > Settings > Configuration > Search > Suggested
Results.
2. Select the suggested results set that you want to edit.
3. Click Edit.
4. Place the cursor in the suggested results area of the screen.
5. Place the cursor on the result that you want to edit.
6. Click once and a menu appears.
7. Click Edit.
8. See Click Add New Suggested Result Set. The Add Suggested Results screen
reappears. You can add more links, edit existing ones, and so on. on page 382
9. Click Add New Suggested Result Set.
10. Click Save Suggested Results.

Removing a link from a suggested result set
1. Choose Workarea > Settings > Configuration > Search > Suggested
Results.
2. Select the suggested results set from which you want to remove a link.
3. Click Edit.
4. Place the cursor in the suggested results area of the screen.
5. Place the cursor over the result that you want to delete.
6. Click once and a menu appears.
7. Click Delete.
8. Click OK.
9. Click SaveSuggested Results.

Rearranging the sequence of a suggested result set
1. Choose Workarea > Settings > Configuration > Search > Suggested
Results.
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2. Select the Suggested Results set from which you want to remove a link.
3. Click Edit.
4. Place the cursor in the suggested results area of the screen.
5. Place the cursor over the result that you want to move up or down.
6. Click once. A menu appears.
7. Click Move Up or Move Down.
8. Click Save Suggested Results.

Deleting a suggested result set
1. Choose Workarea > Settings > Configuration > Search > Suggested
Results.
2. Select the suggested results set that you want to delete.
3. Click Delete (

).

4. Click OK to the confirmation message.

Including external files in a search
Use integrated search if you want the search to include files outside of Ektron but
located on your Web server. For example, you want a folder full of press releases to be
searchable but do not want to add them to Ektron. Instead, you follow the steps in this
section to make the folder searchable, and search results include the press releases.
NOTE: The descriptions below refer to the folder that is not part of Ektron as the
external folder.
You can search non-Ektron content by file title. For example, you can find Ektron.gif by
inserting Ektron into the search field. In addition, you can find a variety text-based
files, like .doc, .pdf, and .txt, by searching their text. Finally, Microsoft Search Server
2010 searches file metadata for media files.

Step 1: Place content in an external folder
External folders must reside in the website folder so IIS has permission to access their
content. Best practice is to create the external folder under the Webroot. Then, place
content in the folder for the integrated search.

Set permissions for the external folder
The top-level folder that contains the external files must be accessible to the website,
and the user account used by search server must have permission to read it.
The following example creates a user called IntegratedSearchUser and shares the
external folder. Search Server uses the IntegratedSearchUser account to access the
external folder's content.
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1. On the Web Server, start Control Panel > Administrative Tools > Computer
Management and create a new user called IntegratedSearchUser.
2. Using Windows Explorer, right click the external folder and choose Share.
3. Enter the IntegratedSearchUser user.
4. Click Add.
IntegratedSearchUser now has read permission for the external folder.

Step 2: Create a content source for the external folder
1. On your search server, open the SharePoint 2010 Central Administration screen.
2. Go to Manage service applications > Search Service Application > Content
Sources > New Content Source.
If you are using Microsoft FAST Search Server 2010, go to Manage service
applications > FastContent Connector > Manage Content Sources > New
Content Source
3. Enter the following values.
l Enter a Name for the content source.
l

In the Content Source Type field, choose File Shares.

l

In the Start Addresses field, enter the external folder as a UNC path
(\\server\directory) or full file URI (file://server/directory).
o To make sure the search can access the external folder, you may want to
use C$ in the path, like this: \\server1\c$\integratedsearch.

l

Set up Crawl Schedules for your integrated search folder contents to
automatically refresh search indexes as frequently as you need to keep search
results reliable. (This schedule is different than the crawl schedule for Ektron
content.)

l

Begin a crawl by checking Start full crawl of this content source.

l

Click OK.

If you successfully set this up, you see the new content source and the status
shows "starting".

Step 3: Create scope for a content source
NOTE: If you are using Microsoft FAST Search Server 2010, you can ignore Steps 3
and 4 proceed to Step 5.
1. On your Search Server, open the SharePoint 2010 Central Administration screen.
2. Go to Manage service applications > Search Service Application > Queries
and Results > Scopes.
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3. Click New Scope.
4. Give it a Name (no spaces) and Description.
5. Leave Use the Default Search Results Page checked.
6. Click Ok. The View Scopes screen reappears.
7. Use the pull-down next to the new scope name and select Edit Properties and
Rules.

8. Add a New Rule.
9. In the Scope Rule Type field, select Content Source.
10. In the Content Source field, select the content source you created in Step
2: Create a content source for the external folder on the previous page.
11. Set Behavior to Include.
12. Click Ok.

Step 4: Add external folder to Ektron website scopes
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NOTE: If you are using Microsoft FAST Search Server 2010, you can ignore Step 4
proceed to Step 5.
This step insures that the external folder content is included in Ektron search results.
1. Open the SharePoint 2010 Central Administration screen.
2. Go to Manage service applications > Search Service Application > Queries
and Results > Scopes.

3. Use the pulldown next to your Ektron website's content source and select Edit
Properties and Rules.
4. Click New Rule.
5. In the Scope Rule Type field, select Content Source.
6. In the Content Source field, select the external folder that you created in Step
2: Create a content source for the external folder on page 386.
7. In the Behavior field, select Include.
8. Click OK.

Step 5: Add a crawl rule for the integrated search user
This step sets the permission for the search server to access the external folder.
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1. On your Search Server, open the SharePoint 2010 Central Administration screen.
2. Go to Manage service applications > Search Service Application >
Crawling > Crawl Rules.
3. Click New Crawl Rule.
4. Set the path to the external folder. (For example: \\ws10196\PressReleases\*.)
5. Set the Crawl Configuration to Include all items in this path.
6. Set Specify Authentication to Specify a different content access account.
7. Enter the Account. (For example: IntegratedSearchUser.)
8. Enter the Password and Confirm the Password.
9. Uncheck Do not allow Basic Authentication.
10. Click Ok.

Step 6: Complete the integrated search mappings screen
PREREQUISITE

You are a member of the Administrators Group or assigned the SearchAdmin role See also: Defining roles on page 1581
1. Choose Workarea > Settings > Configuration > Search > Integrated
Search Mappings.

2. In the Start Address field, find the external folder.
3. In the Mapping field, enter the path to the external folder relative to your site
root.
4. Click ( ) to save.

Troubleshooting integrated search
l

Problem. The protocol handler cannot be found. Check that the handler has been
installed
The protocol handler is normally installed in this folder.
c:\windows\system32\DatabaseProtocolHandler.dll
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Solution. If the handler is in the correct place, check that all folder names and
paths are correctly entered in the Content Sources, Crawl Rules and Scopes in the
Search Service Application settings.
l

Problem. Item was not crawled because of a password change. Update password
and retry crawling.
Solution. Verify that the Search Server user account has permission to read and
write to the content database. You may have to create a unique user on the content
server for this purpose.

Searching the Workarea
You can search any Workarea folder to locate content within it. The following sections
explain the Workarea search.

Searching a folder hierarchy
1. Go to the folder from which you want to begin the search.
NOTE: To search the entire site, search from the top-level (Root) folder. To
limit the search to a folder (and its subfolders), select it then enter search
criteria.
2. Click Action > Search. The Search Content Folder screen appears.

l
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Search Published is the same as the Site Search, except your results are
only retrieved from the current folder and its subfolders. If your search
provider is Microsoft Search Server or Microsoft Search Server Express, you
must have read-only or greater permission for the folder.
o You can search for content that contains a metadata value. To do this, use
the pattern emtmetadata definition: metadata value. For example, if the
metadata definition is "MapAddress" and the value is "London", enter
emtmapaddress: london.
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Note that the metadata definition type must be "searchable
property." And, you must enter the definition in all lowercase letters, even
if the name includes uppercase letters.
l

Advanced Search lets you expand search to include internal properties, such
as last editor, date created/modified, status, and comments. See also: Using
advanced search in the Workarea below

Using advanced search in the Workarea
The Workarea Advanced Search lets you find content using information that content
authors and publishers would typically know. For example, you can search for content
edited by a particular author within a date range.
When performing a search, enter one or more words into the text box, select search
preferences, then click Search.
You can use an asterisk as a wildcard character to stand for any character. For example,
the phrase CMS*00 returns topics that include CMS400, CMS300, CMS200 and
CMS100.
Your system administrator can add custom search fields that only appear if a user is
logged in. For more information, see Working with Metadata on page 822.
IMPORTANT: The Advanced search finds content whether or not it is marked
Searchable.
The Workarea Advanced Search finds content that satisfies these criteria.
l

user has read-only or greater permission for content’s folder

l

matches selected language, if site is multilingual
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l

satisfies criteria entered on the screen

The Advanced Search screen lets you find Ektron content by specifying the following
criteria. While the fields are optional, the search only returns content that satisfies all
criteria.
l

content type (for example, HTML content, forms, assets)

l

one or more search terms. Unlike the Search Published screen, you cannot use a
query.

l

to search title only, enter search text into the Title field

l

to search comments, enter search text into the Comments field

l

a range of created or modified dates

l

the editor who created or most recently updated the content

l

the content’s status

l

any searchable metadata assigned to the folder

Specifying content type to search
Near the top of the screen, check boxes let you determine the types of content to
search.
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l

Content. HTML content, blogs entries, and XML Smart Form field values

l

Forms. HTML forms

l

Assets. Content that is neither HTML nor XML, such as Office documents and
managed files. See also: Working with assets in the Document Management
System on page 708

l

Include Archived. Content, forms and assets that were archived using the
Archive and remove from site or Archive and remain on Site option

Specifying a search word or phrase
In the Search Text field, enter one or more words that you want to find within content,
forms, and assets. Entering text here is optional. That is, you can use the other fields to
find content.
If you enter several terms, specify a logical relationship among them in the pulldown
under the Search Text field.

l

All the words. all words in the Search Text field. All Words is an “and”
function. The search returns only content that has the words content and
management and system. The words can be in any order within the content.

l

Any of the words. any word in the Search Text field. This is an “or” function. It
returns content that has at least one of the words in the Search Text field; it
returns content with the word content or management or system.

l

Exact Phrase. all words in the order specified in the Search Text field.

l

Content ID. To find content by ID number
1. In the Search Text field, enter the ID number.
2. From the pulldown below Search Text, select Content ID.
3. Click Search.

Ektron Reference

393

Setting up search for your website

Specifying additional search criteria
l

Title. The title of the content. You can enter a partial word. For example, entering
Part yields the following results.
o Multi-Hospital Nurse Executive Participation
o

Ektron Partners and Customers

You can enter more than one word or phrase as long as they are in the correct
sequence. The Search Text field also searches content title.
l

Comments. The content’s comments, which can be inserted via the Comment
tab.
NOTE: If you enter multiple terms into the Comments field, they must be in
the order in which they appear in the content's comments.
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l

Date Created. The file’s creation date. You can enter a single date or a range of
dates. The search returns content with that creation date that satisfy the other
criteria.

l

Date Modified. The last date when the file was modified. You can enter a single
date or a range of dates. The search returns items with that edit date that satisfy
the other criteria.

l

Last Editor’s Last Name. The last name (surname) of the user who most
recently changed the content. This is taken from the Last Name field on the User
Information screen. The search returns items last edited by that user that satisfy
the other criteria.
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l

Status. The content status. See also: Content statuses on page 681
NOTE: Search results display only the most recently-published version.
Also,content that has never been approved does not appear.

Managing the search crawl
Crawling is the process of preparing index files for searching. When Ektron content is
added, deleted, or updated, a crawl makes that content available (or no longer
available) to the search. In general, Ektron manages the crawl automatically—you do
not need to do anything.
This section explains the automatic crawl: what starts one, how to monitor its status,
and so on. In addition, if your search has a problem, you can run a manual crawl to
troubleshoot it.

Full vs. incremental crawls
Microsoft Search Server 2010 supports 2 types of crawls.
l

Full. occurs immediately after events that significantly change data structure

l

Incremental. occurs after incremental crawl interval passes for less significant
events that still require a crawl

A full crawl registers searchable Ektron properties with the search provider and ensures
that search results reflect the latest information for all Ektron content. An example of a
full-crawl triggering event is the registration of a new site.
Many other Ektron events trigger an incremental crawl, which is run when the specified
time interval passes. See: Setting the incremental crawl interval below. Examples of
incremental-crawl triggering events are the creation of new content and the editing of
existing content.
If you are using eSync, a sync can trigger a full or incremental crawl, depending on the
data being synched and the profile selected.

Setting the incremental crawl interval

Starting crawls manually
You should not need to start a crawl. Ektron initiates crawls as necessary. You would
typically begin a manual crawl for troubleshooting purposes.
PREREQUISITE

You are a member of the Administrators group or assigned to the SearchAdmin role.
l

To start an incremental crawl immediately, go to Workarea > Settings >
Configuration > Search > Status. Click Request Incremental Crawl.
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l

To start a full crawl immediately, go to Workarea > Settings > Configuration
> Search > Status. Click Request Full Crawl.

Improving search performance with crawl filters
When you set up the connection to Microsoft Search Server, you determine the types of
content to be crawled using the following screen.

If your crawl is taking too long, consider removing content types, especially those you
do not use. To update the crawled content types, use the Search Configuration Screen's
Site Registration panel > Advanced Options > Crawl Filters fields.
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l

NOTE: Metadata and tags are crawled regardless of the crawl filter settings.
Also, changes to other Ektron data objects result in the appropriate crawl,
regardless of these settings. See also: Full vs. incremental crawls on page 395.

Monitoring crawls
The Data Directory stores a log of information about each crawl. The Search
Configuration screen's Crawl Tracing field lets you determine the amount of detail you
want the log to collect.
The following errors may appear in the crawl log.
l

Error. <url_path_to_asset>: The filtering was stopped because of a user action,
such as stopping the crawl

l

Problem. An asset is referenced in the Ektron database, but the physical file was
deleted from the file system.
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The following screens also let you monitor and manage crawls.
l

Search Status screen in the Workarea. See also: Monitoring Microsoft Search
Server 2010 from the Workarea on page 401

l

Search Configuration Screen's Crawl Management panel

The following table compares the screens.
Options

How to access

Workarea's Search Status
screen

Workarea > Settings > Configuration > Search > Status

Search Configuration Screen

On server that hosts Search
Server: Windows Start > All
Programs > Ektron >
CMS400vxxx> Utilities >
Search Config
If you're using Windows 8 or
2012, press the Windows key (
)/Q then enter Search
Config. Right click and choose
Run as Administrator.
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Options

Workarea's Search Status
screen
l

search server

l

content source name

l

query credentials

l

if there is a pending
request to begin
incremental search

l

View crawl
information
l

l

current and next
scheduled search action
See also: Monitoring
Microsoft Search Server
2010 from the Workarea
on page 401
most recent start and
end times
duration

(last if no crawl currently
running; current if crawl
currently running)
l

l

interval See also:
Setting the incremental
crawl interval on
page 395

Search Configuration Screen

On Site Registration panel
l

Crawl Interval See also:
Setting the incremental crawl
interval on page 395

l

Crawl Filters

l

Crawl Tracing Level

On Crawl Management panel
l

content source name

l

crawl status (same as
Current Action on Search
Status screen)

l

most recent start and end
times

l

duration

crawl filters

Start full crawl

Not available

Start incremental crawl

Not available
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Options

Workarea's Search Status
screen

Set
incremental
crawl interval

View only

Set the type of
data that is
searched

View only

Search Configuration Screen

Site Registration panel >
Crawl Interval field
See also: Setting the incremental
crawl interval on page 395

Site Registration panel >
Advanced Options > Crawl
Filters

Troubleshooting crawl errors
The following information lists errors that may appears during a crawl, and how to
resolve them. Errors appear in Microsoft Search Server 2010's administration portal.
They do not appear in Ektron.
Condition. What happens if a crawl is running when a new one is scheduled to start?
l If a crawl request is issued while a crawl is running, the new crawl will start only
after the current crawl completes.
l

A pending full crawl starts before any pending incremental crawls.

Problem. A content block based on a Smart Form has a blank content_html field. An
error occurs: Exception from HRESULT: 0xC00CEE2D
Solution. Remove the field or insert content into it.
Problem. The crawl is taking a long time, your website has over 1 gigabyte of assets,
and over 100 PDFs.
Solutions
l

Install Foxit PDF Filter
Install Foxit PDF filter from Foxit® PDF IFilter - Server
After installing, update the registry:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0
\Search\Setup\Filters\.pdf]
"Extension"=".pdf"
"FileTypeBucket"=dword:00000001
"MimeTypes"="application/pdf"
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[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0
\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf]
@="{987f8d1a-26e6-4554-b007-6b20e2680632}"

See also: Index and Search PDF Files in SharePoint Server 2010
l

Use the Filters Screen
The Crawl Filters screen lets you decide which file types are crawled. You can
exclude non-critical file types to speed up the crawl. See also: Using Microsoft
Search Server features on page 360

Monitoring Microsoft Search Server 2010 from the
Workarea
Use the Search Status screen to monitor information about search crawls. You can also
launch an incremental or full crawl from the screen. See also: Managing the search
crawl on page 395
PREREQUISITE

You are a member of the Administrators group or assigned to the Search
Admin role.
1. Choose Workarea > Settings > Configuration > Search > Status. The
Search Status screen appears.

l

Search server. The Search Server instance that hosts your search index.

l

Content source name. The Search Server content source that identifies your
website.

l

Query credentials. The Windows user authorized to communicate with the
query service.

l

Incremental Crawl Request Pending. Yes appears if there is a pending
request to begin an incremental crawl. See also: Using Microsoft Search
Server features on page 360. Otherwise, No.
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l

Current and Next scheduled search action. at any time, there may be an
action that will start when the current one completes. There is never more
than one.
o Idle. Search Server is taking no action.
o

None. (appears for Next Action only) Nothing is scheduled to occur
when the current action completes.

o

Incremental Crawl. Search Server is crawling content that changed
since the last crawl. See also: Full vs. incremental crawls on page 395

o

Full Crawl (Property Discovery). Search Server is crawling Ektron
content, looking for new searchable properties.

o

Full Crawl. Search Server is crawling all content.

o

Property Mapping. Search Server is mapping searchable properties that
were found.

l

Most recent start and end times. When the most recent crawl began and
ended.

l

Duration (last if no crawl currently running; current if crawl currently
running). If last, the length of time (in seconds) required to complete the
most recent crawl. If current, the length of time (in seconds) since the current
crawl began. Click the Refresh button ( ) to get the latest information.

l

incremental crawl interval. See also: Setting the incremental crawl interval
on page 395

l

crawl filters. See Managing the search crawl on page 395.

2. If you want to launch a crawl from the toolbar:
l click (
) to launch an incremental crawl (note black color)
l

click (

) to launch a full crawl (note blue color)

Reporting search activity
EktronSearchStatistics logs
IMPORTANT: EktronSearchStatistics Logs are not available for the Solr search
provider.
This log shows submission of the query statistics. It is updated only after a site visitor
inserts a search term, clicks the search button, and clicks a result. To access the log,
sign on to the Search Server machine > EktronSearchSite Web root > click
EktronSearchStatistics folder.
PID:7284
Verbose
PID:7284
Verbose
PID:7284
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TID:7056
MTID:
2012-04-03T14:55:15
Publishing Search Statistics : Begin
TID:7056
MTID:
2012-04-03T14:55:1
QueryContext.Create: Creating QueryContext /
TID:7056
MTID:
2012-04-03T14:55:15
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Verbose QueryContext.Create: Created QueryContext /
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose QueryServiceInfoProcessor.GetSearchApp for
QuerySSA:Search Service Application
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose QueryServiceInfoProcessor.GetSearchAppProxy
for QuerySSA:Search Service Application
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose MSStatsRecorderProxy.Record: Recording
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose MSSearchStatsHelper.SubmitStatistics:
Beginning statistics recording to SharePoint!
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose MSSearchStatsHelper.FetchClicksToRegisterValue:
Will be using 2 click(s) to complete
statistics recording to SharePoint!
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose MSSearchStatsHelper.SubmitStatistics:
Ending statistics recording to SharePoint!
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose MSStatsRecorderProxy.Record: Recorded!
PID:7284 TID:7056
MTID:
2012-04-03T14:55:15
Verbose
Publishing Search Statistics :
Ends with Status SUCCESSFUL: 0

EktronQuerySuggestion logs
IMPORTANT: EktronQuerySuggestion Logs are not available for the Solr search
provider.
This log shows the number of entries for the query prefix. In the following example, the
user entered ‘samp’ and Autosuggest found one entry (sample). To access the log, sign
on to the Search Server machine, find EktronSearchSite Web root, and click
EktronQuerySuggestion folder.
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
Verbose QueryContext.Create: Creating QueryContext /
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
Verbose QueryContext.Create: Created QueryContext /
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
Verbose QueryServiceInfoProcessor.GetSearchApp for
QuerySSA:Search Service Application
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
Verbose QueryServiceInfoProcessor.GetSearchAppProxy for
QuerySSA:Search Service Application
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
Verbose SPQuerySuggestionReporter.GetQuerySuggestions:
Q:[samp] Profile:[]
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
Verbose SPQuerySuggestionReporter.GetQuerySuggestions:
Response for Q:[samp] : [1]
PID:7900 TID:5168
MTID:
2012-04-04T08:51:18
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Verbose SPQuerySuggestionFeed.QuerySuggestionForProfileFeed:
completed feed request: Q:samp Culture:en-US

Using a search phrase report
The Search Phrase Report displays terms that were entered into a Search field within a
selected range of dates. You can use it to discover terms being submitted to the search.
The report is gathered from the query text of keyword-based queries. The queries
include those submitted through the search field of search server controls, the keyword
search API, and the Workarea’s Search Published tab.

You can narrow down the search by selecting any combination of these criteria.
l

language—the language of the search page (either Workarea or website search).
The user performing the search can choose a language before inserting the search
text. If he does not explicitly choose a language, the search uses the default one.
This report shows results from all languages or one that you select.

l

a minimum number of occurrences of the word or phrase to return. For example,
you only want words or phrases searched for 10 times or more during the last
month.

l

range of dates when searches were conducted

After entering search criteria, click Get Result.
The search results show the number of times each word or phrase that satisfies the
selection criteria appears. They are arranged in this order.
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l

words or phrases with the most occurrences appear first

l

if several words or phrases have the same number of occurrences, they are
arranged alphabetically
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NOTE: Search terms are added to the Search Phrase Report according to rules
explained in Specifying the frequency of writing to the database on page 541.
Also, terms entered into the website or Workarea search are surrounded by
parentheses (). Terms entered into the Advanced Workarea search have no
parentheses. The Microsoft search engine uses this syntax to find content.

Troubleshooting Microsoft search
Problem. You publish a Visio® document but the search cannot find it.
Solution 1. Make sure the Visio iFilter is installed. See Installing the Visio IFilter on
page 372.
Solution 2. Does the content have a non-standard alias extension? Aliases that use
standard extensions are not a problem. However, you can create custom alias
extensions. See also: Creating user-friendly URLs with aliasing on page 1399. If you do,
that content is searchable only if you add the custom extension to Search Server's
extension list. From the Search Server Administration page, click File types > New
File Type, and add the custom extension. Then, run a full crawl to index these pages.
Solution 3. Is the content stored in a Smart Form field whose type is content? Search
does not support Smart Form fields with an Advanced type of Content (instead of
Attribute or Element). Smart Form fields that need to be indexed must have a type of
Attribute or Element.
Problem. SearchConfigUI.exe crashes while building search indexes and catalogs
Solution.
1. Make sure the metaconfig.doc file exists in the siteroot/uploadedfiles
directory. If it does not, ask Ektron Supportto send you a new file.
2. If anyone uploaded Visio documents to your server, make sure the iFilter is
installed. See Installing the Visio IFilter on page 372.

Installing and Setting up Microsoft
Search Server 2013 or 2016
This section explains how to install Microsoft Search Server 2013 or 2016. After
installing it, follow Configuring Ektron to work with Microsoft Search Server 2013 or
2016 on page 458 to configure the search provider. To learn how to use the search,
read Using Microsoft Search Server features on page 360.
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l

Installing active directory domain services below

l

Installing SQL Server 2012 R2 on page 418

l

Installing and troubleshooting online prerequisites issues for SharePoint 2013 on
page 440

l

Installing SharePoint 2013 on page 445

l

Configuring Ektron to work with Microsoft Search Server 2013 or 2016 on page 458

Installing active directory domain services
1. In Server Manager, open the Dashboard and click the Add roles and features
links from the right panel.

2. The Add Roles and Features Wizard appears. Check the Skip this page by
Default box.
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3. You are asked to select an installation type. Click Role-based or feature-based
Installation.
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4. You are asked to select a destination server from the server pool.

5. On the Select Server screen, select the role Active Directory Domain Services.
Next, you are prompted to install prerequisites. Check the Include management
tools (if applicable) box and click the Add Features button.
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6. You have installed all the prerequisites for Active Directory. Select additional Roles
and Features if required.
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7. The following screen has information about how Active Directory Domain Services
will be installed.
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8. On the next screen, Click Restart the destination server automatically if
required and click the Install button.
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9. The Installation process begins. It takes several minutes to complete.

10. Once the Active Directory Domain Service is installed, you see the installation
results. Click Promote this server to a domain controller to launch the Active
Directory Domain Services configuration wizard.
IMPORTANT: Do not close the screen yet.
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11. The Deployment Configuration screen appears. Select the Add new a Forest
button and provide a Root domain name in the text box.

Ektron Reference

413

Setting up search for your website

12. The Domain Controller Options screen appears. Enter a password of your choice in
the Password and Confirm password fields. Keep default values for other
settings.
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13. A warning appears on the DNS Option screen. You don’t need to do anything.

14. The Additional Options screen appears. Verify your NetBIOS domain name.
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15. The Paths screen appears. Leave all settings as is.

16. The Review Options screen shows the selected wizard settings.
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17. The Prerequisites Check screen appears. This takes several minutes to complete.
When the test completes, click the Install button.

18. You reached last screen of the Active Directory Domain Services Configuration
Wizard. This screens shows the installation progress. When the installation is
completed, your server restarts automatically.
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19. After restart, you should be able to able to log into the domain using Domain
credentials, for example, Domain\UserName.
20. You can use the Active Directory Users and Computers administrator tool to create
users and groups.

21. Verify domain details by browsing the Users folder in Left panel.

Installing SQL Server 2012 R2
1. Browse the directory of the system where Microsoft SQL Server 2012 setup files
reside.
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2. Right click Setup.exe files and run as administrator.

3. The Splash screen keeps you waiting until SQL Server installation Center screen
appears.
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4. The SQL Server installation Center screen appears.
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5. From left panel, click Installation. Installation options appear.

6. Click New SQL Server stand-alone installation or add features to an existing
installation link. A splash screen keeps you waiting until the Microsoft SQL Server
2012 Service Pack 1 setup process completes.
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7. On the Setup Support Rules screen, the Installer checks for any issues that
occurred during installation.
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8. In the Product Key screen, provide a valid license Key. If you are installing the free
version, select Specify a free edition.
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9. The License Terms screen appears. Read the terms carefully and check the Accept
the license terms option if you are happy with them
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10. The Product Updates screen appears. You are notified of hot fixes or updates for
SQL Server 2012 relevant to this installation.
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11. On the Install Setup Files screen, the Setup files are downloaded. Click Install.
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12. The Setup Support Rules screen appears, identifying installation issues.
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13. On Setup Role screen, select SQL Server Feature Installation.

l

l

428

Instances Features
o Database Engine Services
o

Full-Text and Semantic Extractions for Search

o

Analysis Services

Shared Features
o

Reporting Services – SharePoint

o

Reporting Services Add-in for SharePoint Products

o

SQL Server Data Tools

o

Management Tools – Basic

o

Management Tools – Complete

Ektron 9.40 SP1

Installing SQL Server 2012 R2

14. The Installation Rules screen indicates if the Installation process had problems and
got stuck.
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15. The Instance Configuration screen prompts you to choose the default SQL Server
Instance or create a new Named Instance. Also, you can change the Instance
directory on Windows Server 2012 R2.
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16. The Disk Space Requirements screen displays the space required for installation. If
your Windows Server 2012 R2 has enough space, click Next to continue.
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17. On the Server Configuration screen, click the Service Accounts tab and perform
the following actions.
a. Change Startup Type for the SQL Server Agent to Automatic.
b. Change the Account Name for the SQL Server Database Engine to NT
AUTHORITY\SYSTEM.
c. Change the Account Name for the SQL Server Analysis Services to NT
AUTHORITY\SYSTEM.
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18. In the next screen, go to the Server configuration tab and select the Mixed
Mode (SQL Server authentication and Windows authentication) option.
Also, add the current logged-in user as a System Administrator Account for this
SQL Server Instance.
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19. On the Analysis Services Configuration screen, select the current logged-in user as
a System Administrator for Analysis Services
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20. On the Reporting Services Configuration screen, select the Install Only button.
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21. On the Installation Configuration Rules screen, review issues that occurred during
installation.
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22. On the Ready to Install screen, review all Feature details that you wanted to install.

23. On the Installation Progress screen, monitor the download status of required
software and the status of installation.

Ektron Reference

437

Setting up search for your website

24. The Complete screen displays the status of features you selected to install. Close
the screen and restart Windows Server 2012 R2.
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25. After restarting Windows Server 2012 R2, you should be able to login in to your
SQL Server Instance.

26. After completing the installation, configure the Named Pipes protocol for SQL
Server 2012. To do this, browse the following path using SQL Server Configuration
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Manager:
SQL Server Configuration Manager > SQL Server Network Configuration
> Protocols for MSSQLSERVER. Locate the Named Piped protocol in the
screen 's right panel and enable.

Installing and troubleshooting online prerequisites issues for
SharePoint 2013
Preliminary steps
NOTE: Before installing prerequisites, follow these steps to ignore an issue that
appears when installing.
1. Update Windows to the latest package.
2. On the Windows server, open Server Manager > Configure this local server >
IE Enhanced Security Configuration. Turn this setting off.
3. Add the following features with a Powershell command:
Add-WindowsFeature NET-HTTP-Activation,NET-Non-HTTP-Activ,NET-WCF-PipeActivation45,NET-WCF-HTTP-Activation45,Web-Server,Web-WebServer,WebCommon-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,WebHttp-Errors,Web-App-Dev,Web-Asp-Net,Web-Asp-Net45,Web-Net-Ext,Web-NetExt45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-LogLibraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-BasicAuth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,WebStat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-MgmtConsole,Web-Mgmt-Compat,Web-Metabase,WAS,WAS-Process-Model,WAS-NETEnvironment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-IdentityFoundation,Xps-Viewer -verbose
4. If you get the error Application Server Role, Web Server (IIS) Role:
configuration error when running the prerequisite installer, follow these steps.
a. Open the MMC console.
b. Add the Group Policy Object snap-in.
c. In Local Computer Policy, go to Computer Configuration > Administrative
Templates and select System.
d. In system settings, scroll down the list and find Specify settings for
optional component installation and component repair.
e. In the top left corner, select Enabled and Contact Windows Update
directly to download repair content instead of Windows Server
Update Services (WSUS).
f. Click OK and close the MMC console.
g. Go to Windows/System32, duplicate servermanager.exe and rename it
servermanagercmd.exe.

440

Ektron 9.40 SP1

Beginning the installation

h. If the SharePoint 2013 Preparation tool is stuck in configuring the Application
Server and the Web Server IIS roles, close the Server Manager windows. The
tool starts the other configurations.
5. If you get an error with the AppFabric, remove the PSModulePath entry in the
system environment variables.

Beginning the installation
1. Go the directory that contains your installation files.
2. Select the Prerequisiteinstaller.exe file and Run as Administrator.

3. You are prompted with a User Account Control dialog. Click Yes.
4. The Microsoft SharePoint 2013 Products Preparation Tool screen appears. You can
see the complete list of prerequisite products for installation.
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5. The License Terms for software products screen appears. Read the license terms
carefully and check the box to accept the license terms.
6. Prerequisite Installer enables the Application Server Role on your server. Then, you
are asked to restart the server.
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7. After you restart the server, the Prerequisite Installer continues the installation.

8. The Prerequisite Installer configures the following components on your server.
l Application Server Role, Web Server (IIS) Role
l

Windows Identity Foundation (Windows6.1-KB974405-x64.msu)

l

Microsoft Sync Framework Runtime v 1.0 SP1 (Synchronization.msi)

l

Windows Server App Fabric (WindowsServerAppFabricSetup_x64.exe)

l

Microsoft Identity Extensions (MicrosoftIdentityExtensions-64.msi)

l

Microsoft Information Protection and Control Client

l

Microsoft WCF Data Services 5.0 (WcfDataServices.exe)

l

Cumulative Update Package1 for Microsoft App Fabric 1.1 for Windows Server
(AppFabric1.1-RTM-KB2671763-x64-ENU.exe)

9. Once all components are configured and installed, a screen asks you restart the
server. Click Finish.
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All SharePoint 2013 prerequisites will be installed.

Installing SharePoint 2013
Prerequisites
l

A valid SharePoint 2013 Server product key.
NOTE: SharePoint Foundation 2013 is not compatible with Ektron.

l

A domain user added to the administrators group of the search machine with
DBCreator permissions on the SQL server. (For example, Domain/SP_Admin.)
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1. Log into Windows Server 2012 R2 as a SharePoint Administrator (SP_Admin) user.

2. Go to the directory that contains the SharePoint 2013 Installation files.
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3. Select the setup.exe file and Run as Administrator.

4. You see with User Account Control Window. Click Yes.
5. The Enter your product Key screen appears. Enter a valid SharePoint 2013 Server
product key.
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6. The Read the Microsoft Software License Terms screen appears. Read carefully and
check the I accept the terms of this agreement box.
7. On the Choose a file location page, accept the default settings and click Install
Now.

8. A screen informs you that it is preparing files for Installation of SharePoint 2013.
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9. An Installation Progress screen appears. It might take some time to complete.

10. When the installation completes, a Run Configuration Wizard appears. Check the
Run the SharePoint Products Configuration Wizard now box. Click the
Close button.
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11. The Welcome to SharePoint Products screen appears.

12. During Configuration, you are prompted to restart the services. Click Yes to
continue.
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13. On the Connect to a server farm screen, click the Create a new server farm
button.
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14. On the next screen, complete the fields below to complete the configuration.
l Database server. Instance name of your SQL Server 2012 R2

452

l

Database Name. Database of the SQL Server

l

Username. Domain user (SP_Farm)

l

Password. Your choice
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15. On the Specify Farm Security Settings screen, to provide a password to secure the
configuration data.
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16. On the following screen, set up the port number and security settings for your site.

17. On the Completing the SharePoint Products Configuration Wizard screen, click
Next.
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18. When the configuration completes, you see the Successful message. Click Finish.

19. You should be able to configure your site through a browser. If you want to take
part in the Microsoft Improvement program, select an option here.

20. The welcome page of the SharePoint Farm configuration appears. Click the Start
the Wizard button.
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21. On the Services screen, configure a new Service Account to operate SharePoint.
NOTE: The SP_FARM user should be a domain user that was added to the
administrators group of the search machine, otherwise it will not let you add it.
Instead of setting up a new user you can click Use existing managed
account.

22. A progress screen appears, saying Working on it.
23. When your service account is created, create a site collection in SharePoint 2013.
Enter a site name of your choice.

24. A success message appears.
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25. You should see your SharePoint 2013 site.

Configuring Ektron to work with Microsoft Search Server
2013 or 2016
Prerequisites
l

Both servers can browse to each other across the network.

l

On your Ektron server
o Set SQL Security to SQL Server and Windows Authentication mode.

l

o

Create a SQL user login with the sysadmin role. Microsoft Search Server 2013
or 2016 uses that login to access the Ektron database.

o

Enable the TCP/IP for SQL server. Open SQL Server Configuration Manager >
SQL Server Network Configuration > Protocols for MSSQLSERVER > Enable all
3 items. Restart the server.

On your Microsoft Search Server 2013 or 2016 server
o Obtain the username and password of a user with Windows administrator
privileges.

1. Install or upgrade Ektron on its server, using the normal procedure. On the Search
Provider screen, choose Microsoft Search Server 2013 or 2016.
2. On Ektron server, copy the folder C:\Program
Files\Ektron\CMS400versionnumber\Utilities\SearchServer.
3. On the Microsoft Search Server 2013 or 2016 server, paste that folder and run the
file EktronSearchConfiguration.exe.
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4. The following screen appears.

Select the folder to which you want to install the Search Server files. Ektron
recommends using the default folder. Click Next.
5. The following screen appears. Enter the domain, username, and password of a
user with Windows Administrator privileges on the server you will use for Microsoft
Search Server 2013. Click Next.
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6. Enter the path where you want to locate the Ektron Querying Services website.
Click Next.
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7. Enter the port number you want to use with the Ektron Querying Services website.
Click Next.
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8. Click Yes for using Microsoft Search Server as your search provider.

9. The following message appears, instructing you what to do next.
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10. Open the Search Configuration screen, available from C:\Program Files
(x86)\Ektron\
CMS400versionnumber
\Utilities\SearchServer\Ektron.Cms.Search.Config.UI.exe.
11. Enter the CMS Server Machine Name and SharePoint Administrator URL. Click
Next.
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12. Click Next.
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13. The following screen appears.

a. In the CMS Databases drop-down, choose the database you installed.
b. In CMS Database Connection String section, enter the connection string of
your Ektron site. It must be accessible from the server hosting the search
provider.
c. In Credentials section, enter domain, username and password of a Windows
user can access to your search provider’s indexes.
d. Click Register Site.
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Working with Microsoft FAST search
Microsoft FAST Search provides the following advantages:
l

Profile ranking. Forces topics to the top of search results. See Managing rank
profiles on page 492

l

Faceted searching. See Using faceted search on page 487

l

Documentation promotion. See Add, remove and display document promotions
for a keyword by using Windows PowerShell (FAST Search Server 2010 for
SharePoint) and Add document promotions.
o Supported for CMS content

l

o

Entirely configured within SharePoint/FAST

o

No explicit API or templated control support required

High degree of relevant results/Similar Results. See Improving Relevance for
FAST Search Server 2010 for SharePointand Find Similar (FAST Search Server
2010 for SharePoint)
o Supported for CMS content
o

No configuration required

o

Support exists within the API and templated controls to add this to search
criteria.

This chapter explains how to set up Microsoft FAST Search, and how to use its features.

Setting up a Microsoft FAST search
PREREQUISITE

You purchased and deployed Microsoft FAST Search Server 2010 and
SharePoint Server 2010. See also: Licensing Q&A: Determining Your
Licensing Needs, Product Licensing Search
Configuring Ektron to work with Microsoft FAST Search Server 2010 and SharePoint
Server 2010 involves the following major tasks.
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l

Part 1: Install SharePoint 2010 and Microsoft FAST Search Server 2010 on the
facing page

l

Part 2: Set up Microsoft FAST Search Server 2010 for SharePoint 2010 Search on
the facing page

l

Part 3: Enable querying from SharePoint to Microsoft FAST Search Server 2010 on
page 476

l

Part 4: Enable indexing of additional formats on page 477
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l

Part 5: Verify that Microsoft FAST Search Server 2010 can communicate with
SharePoint 2010 on page 479

l

Part 6: Set up Ektron to work with Microsoft FAST Search Server 2010 on page 481

l

Part 7: Make FAST SharePoint’s query search application on page 484

After you complete the tasks...
l

the FAST service is configured to crawl the Ektron site.

l

Ektron events that affect content trigger a FAST crawl.

l

Ektron templated search controls can execute FAST queries to retrieve search
results.

Part 1: Install SharePoint 2010 and Microsoft FAST Search
Server 2010
1. Install SharePoint 2010 and Microsoft FAST Search Server 2010, each on its own
server, on the same domain. Please refer to Microsoft's installation documentation
for details.
NOTE: When installing Microsoft FAST Search Server 2010, you are prompted
to enter a certificate password. Note this password, because you need it in Part
2c: Set up SSL-enabled communication on page 471.
2. Create 2 domain user accounts: one for Microsoft FAST Search Server 2010 and
one for SharePoint 2010.
3. Add the SharePoint site administrator to the Microsoft FAST Search Server 2010
administrators group (located on the Microsoft FAST Search Server 2010 server).

Part 2: Set up Microsoft FAST Search Server 2010 for
SharePoint 2010 Search
You need to create 2 Search Service Applications.
l

FAST Search Connector. for crawling content.

l

FAST Search Query. for accepting search terms, querying the database, and
returning results.

In this section, you complete these tasks.
l

Part 2a: Create a collection for the content source below

l

Part 2b: Create a FAST search connector service application for crawling content on
the next page

l

Part 2c: Set up SSL-enabled communication on page 471

l

Part 2d: Create a search service application for querying on page 472

Part 2a: Create a collection for the content source
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Before creating the FAST Search Connector, create a collection for the Ektron content
source. The collection lets you clear only Ektron content from the index. To learn more,
see Manage content collections (FAST Search Server 2010 for SharePoint).
1. On the Microsoft FAST Search Server 2010 server, go to Start > All Programs.
If you're using Windows 8 or 2012, go to
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\.
2. Right click Microsoft FAST Search Server 2010 for SharePoint and click Run
as Administrator. A PowerShell window for managing Microsoft FAST Search
Server 2010 appears.

3. Enter the following command:
New-FastSearchContentCollection –Name ektroncms –Pipeline ”Office14
(webcluster)”
NOTE:
* The Name is the new collection name.
* Surround the Pipeline name in quotes (as shown above).
* Surround webcluster with curly brackets ().
* See also: New-FASTSearchContentCollection

Part 2b: Create a FAST search connector service application for crawling
content
1. Open SharePoint 2010 Central Administration home page.
2. Under Application Management, click Manage Service Applications.
3. On the Manage Service Applications page, click New > Search Service
Application.
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4. Complete the screen.
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l

Name. Enter a unique name for this application.

l

Fast Service Application. Select Fast Search Connector.

l

Search Service Account. Click Register new managed account to create
a new account for this search service.

l

Application Pool for Search Admin Web Service. Select Create new
application pool and enter a name. Under Select a security account,
select Configurable and select the account under which the SharePoint
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search service is running. You created this account in Part 1: Install
SharePoint 2010 and Microsoft FAST Search Server 2010 on page 467.
l

Content Distributors. On the Microsoft FAST Search Server 2010 server,
open the %FASTSEARCH%\Install_Info.txt file. Copy the value of Content
Distributors (for GUI SSA creation) to this field.
===============================================================
FASTSearch: Installation Details
===============================================================
--------------------------------------------------------------FAST Search Query Search Service Application configuration
--------------------------------------------------------------Query Service Location HTTP (default):
http://ektsqa20.fsqa.ektron.com:13287
Query Service Location HTTPS:
https://ektsqa20.fsqa.ektron.com:13286
Administration Service Location HTTP (default):
http://ektsqa20.fsqa.ektron.com:13257
Administration Service Location HTTPS:
https://ektsqa20.fsqa.ektron.com:1325
8Resource Store Location:
http://ektsqa20.fsqa.ektron.com:13255
Account for Administration Service:
fsqa\fsuser
--------------------------------------------------------------FAST Search Content Search Service Application configuration
--------------------------------------------------------------Content Distributors (for PowerShell SSA creation):
ektsqa20.fsqa.ektron.com:13391
Content Distributors (for GUI SSA creation):
ektsqa20.fsqa.ektron.com:13391
Default Content Collection Name: sp
--------------------------------------------------------------Other services.....

NOTE: Keep the Install_Info.txt file open—you need it in Part 2d:
Create a search service application for querying on the next page.
l

Content Collection Name. Enter the name you entered for the Name
parameter in Part 2a: Create a collection for the content source on page 467.

Part 2c: Set up SSL-enabled communication
To authorize SSL communication between SharePoint 2010 and Microsoft FAST Search
Server 2010: Source: Create and set up the Content Search Service Application (FAST
Search Server 2010 for SharePoint)
PREREQUISITE

You need the password you supplied when setting up Microsoft FAST Search
Server 2010.
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1. Log on to the Microsoft FAST Search Server 2010 server.
2. Open \FASTSearch\installer\scripts.
3. Copy securefastsearchconnector.ps1 to any folder on the SharePoint server.
4. Open \FASTSearch\data\data_security\cert.
5. Copy FASTSearchCert.pfx to any folder on the SharePoint server.
6. Log onto the SharePoint server.
7. Open a Microsoft SharePoint 2010 Management Shell using Start >All Programs
> Microsoft SharePoint 2010 Products.If you're using Windows 8 or 2012,
press the Windows key (
Products

) /Q then enter Microsoft SharePoint 2010

8. Right click SharePoint 2010 Management Shell and click Run as
Administrator.
9. Go to the directory to which you copied the securefastsearchconnector.ps1 script in
Step 3.
10. Run the script, replacing parameters with your environment's values. For example:
.\SecureFASTSearchConnector.ps1
–certPath "path of the certificate\FASTSearchCert.pfx"
–ssaName "name of your content SSA"
–username “domain\username”

Replace the following parameter values:
l

certPath. The folder path to which you copied the certificate in Step 5.

l

ssaName. The Name you assigned to your FAST Search Connector service
application in Part 2b: Create a FAST search connector service application for
crawling content on page 468.

l

username. The domain and username under which the SharePoint 2010
service runs. You set up this account in Part 1: Install SharePoint 2010 and
Microsoft FAST Search Server 2010 on page 467.

11. When prompted to enter a certificate password, enter the password you supplied
when you ran the post-setup configuration of Microsoft FAST Search Server 2010.

Part 2d: Create a search service application for querying
(Source: Create and set up the Query Search Service Application (FAST Search Server
2010 for SharePoint))
1. Open the SharePoint 2010 Central Administration home page.
2. Under Application Management, click Manage Service Applications.
3. On the Manage Service Applications page, click New > Search Service
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Application.
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4. Complete the screen.
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l

Name. Enter a unique name for this application.

l

Fast Service Application. Select Fast Search Query.
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l

Search Service Account. Click Register new managed account to create
a new account for this search service.

l

Application Pool for Search Admin Web Service. Select Create new
application pool and enter a name, such as EktQueryAdmin. Under Select a
security account, select Configurable and select the account under which
the SharePoint search service is running. The application pool must run in the
context of a FAST Search administrator.

l

Application Pool for Search Query and Site Settings Web Service.
Select Create new application pool and enter a name, such as
EktQuerySettings. Under Select a security account, select Configurable
and select the account under which the SharePoint search service is
running.The application pool must run in the context of a FAST Search
administrator.

l

Query Service Location. Open the %FASTSEARCH%\Install_Info.txt file to
obtain the value for this field. Use the HTTPS value if you want to use secure
communications between the SharePoint 2011 and Microsoft FAST Search
Server 2010 servers.
===============================================================
FASTSearch: Installation Details
===============================================================
--------------------------------------------------------------FAST Search Query Search Service Application configuration
--------------------------------------------------------------Query Service Location HTTP (default):
http://ektsqa20.fsqa.ektron.com:13287
Query Service Location HTTPS:
https://ektsqa20.fsqa.ektron.com:13286
Administration Service Location HTTP (default):
http://ektsqa20.fsqa.ektron.com:13257
Administration Service Location HTTPS:
https://ektsqa20.fsqa.ektron.com:13258
Resource Store Location:
http://ektsqa20.fsqa.ektron.com:13255
Account for Administration Service:
fsqa\fsuser
--------------------------------------------------------------FAST Search Content Search Service Application configuration
--------------------------------------------------------------Content Distri.......
---------------------------------------------------------------

l

Administration Service Location. Obtain the value for this field from
%FASTSEARCH%\Install_Info.txt. (See example above.) Use the HTTPS
value if you want to use secure communications between the SharePoint 2011
and Microsoft FAST Search Server 2010 servers.

l

Resource Store Location. Obtain the value for this field from
%FASTSEARCH%\Install_Info.txt. (See example above.)
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l

Account for Administration Service. specify a domain account for a user
who is a member of the FAST Search Administrators group on the Microsoft
FAST Search Server 2010 server.

5. You see a confirmation that a new Query Search service application is created.

Part 3: Enable querying from SharePoint to Microsoft FAST
Search Server 2010
Part 3 describes how to transfer a Microsoft FAST Search Server 2010 STS certificate
(MOSS_STS) from SharePoint Server 2010 to FAST servers. This certificate enables
SharePoint query servers to provide security-trimmed queries. See also: Enable queries
from Microsoft SharePoint Server (FAST Search Server 2010 for SharePoint)
PREREQUISITE

You will need a SharePoint Server 2010 directory that is accessible to
Microsoft FAST Search Server 2010 servers.
3. At the Windows PowerShell command prompt, enter the following commands.
$stsCert = (Get-SPSecurityTokenServiceConfig)
.LocalLoginProvider.SigningCertificate
$stsCert.Export("cert") | Set-Content -encoding byte MOSS_STS.cer

4. The MOSS_STS.cer file is created in the directory in which you run the commands.
5. Copy MOSS_STS.cer to a directory accessible to the Microsoft FAST Search Server
2010 server(s).
6. Import the SharePoint STS certificate to each Microsoft FAST Search Server 2010
server. To do that:
a. On the Microsoft FAST Search Server 2010 server, click Start >All Programs
> Microsoft FAST Search Server 2010 for SharePoint.
b. Right click Microsoft FAST Search Server 2010 for SharePoint and select
Run as administrator.
c. At the Windows PowerShell command prompt, browse to
<FASTSearchFolder>\installer\scripts\, where <FASTSearchFolder> is
the path to the Microsoft FAST Search Server 2010 folder. For example,
C:\FASTSearch\installer\scripts\.
d. Enter the following command:
.\InstallSTSCertificateForClaims.ps1
-certPath <"full path of MOSS STS certificate">

Where full path of MOSS STS certificate is the path to the location to
which you copied the MOSS_STS.cer file in Step 5.
7. Repeat steps 6a through 6d for all query servers (if you have more than one).
8. Within the PowerShell window, check the status of FAST services by entering the
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following command: nctrlstatus. The results should look something like this.

Part 4: Enable indexing of additional formats
Advanced Filter Pack is a Microsoft FAST Search Server 2010 feature that enables text
and metadata extraction from several hundred file formats (such as PDF),
complementing the document formats supported by the Microsoft Filter Pack.
PREREQUISITE

Install 1 of the following PDF filters on the Microsoft FAST Search Server
2010 server:
l

l

Foxit PDF filter (Foxit® PDF IFilter - Server—recommended if you will
index a large number of PDF files)
Adobe 64-bit PDF iFilter (installed on Ektron server C:\Program Files
(x86)\Ektron\CMS400vxx\Utilities\iFilterPack)

3. Go to the [FASTSEARCH] folder (represented by the environment variable
%FASTSEARCH%).
4. Move to the installer\scripts folder using this command: cd
.\installer\scripts.
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5. Insert the command .\AdvancedFilterPack.ps1 –enable.
6. When you see Are you sure you want to continue, enter Y.

7. Open the file %FASTSEARCH%\etc\config_
data\DocumentProcessor\formatdetector\user_converter_rules.xml.
8. Enable PDF format detection by adding <ext name=".pdf"
mimetype="application/pdf" /> and <mime type="application/pdf">PDF
Document</mime> as show in the following example:
<ConverterRules>
<IFilter>
<trust>
<!-- A list of extensions that bypasses the builtin format detection.
Any extension that is not supported out-of-the-box, need to be
added here along with the mimetype if you have installed an IFilter
for that type and want to use it. A mime element should also be
added to the MimeMapping element with a human-friendly description
of the type.
<ext name=".xxx" mimetype="application/xxx" />
<ext name=".yyy" mimetype="image/yyy" /> -->
<ext name=".pdf" mimetype="application/pdf" />
</trust>
</IFilter>
<MimeMapping>
<!-- A mapping between mime types and the description of them.
<mime type="application/xxx">XXX Document</mime>
<mime type="application/postscript">YYY Image</mime> -->
<mime type="application/pdf">PDF Document</mime>
</MimeMapping>
</ConverterRules>

IMPORTANT: Back this file up in a safe location, so that you can re-enter these
changes if you later need to apply a FAST service pack, patch, or hotfix.
9. Stop the FAST service by going to Windows Services, find FAST Search for
SharePoint, and click Stop.
10. Restart the Microsoft FAST Search Server 2010 server.
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Part 5: Verify that Microsoft FAST Search Server 2010 can
communicate with SharePoint 2010
1. On the SharePoint 2010 Central Administration Screen, go to Application
Management>Create Site Collections. The Create Site Collection screen
appears.

2. Enter a Title, Description, and URL, assigning any name.
3. In the Template Selection area, click the Enterprise tab then select FAST
Search Center.
4. In the User name field, enter the name of the SharePoint user you created in Part
1: Install SharePoint 2010 and Microsoft FAST Search Server 2010 on page 467.
5. Click OK to create a site collection.
6. On the SharePoint 2010 server, create a new folder and share it with the Microsoft
FAST Search Server 2010 user that you created in Part 1: Install SharePoint 2010
and Microsoft FAST Search Server 2010 on page 467.
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7. On the folder's Security tab, grant the Microsoft FAST Search Server 2010 user full
control.
8. Drag and drop a few text files into that folder. If you enabled PDF support (as
explained in Part 4: Enable indexing of additional formats on page 477), drop some
PDFs.
9. Create a Content Source for the folder. To do this:
a. On the SharePoint 2010 Central Administration screen, click Manage service
applications.
b. Click the Ektron content service application you created in Part 2b: Create a
FAST search connector service application for crawling content on page 468.
c. On the Search Administration screen, under Crawling, click Content
Sources.

d. On the New Content Source screen:
o Enter a Name.
o

For Content Source Type, select File Shares.

o

For Start Addresses, enter the folder that you created in Step 6.

o

For Crawl Settings, select Crawl the folder and all subfolders of
each start address.

o

Check the Start full crawl of this content source box.

o

Click OK.

10. Verify that the search works by navigating to the FAST search site and searching
for content in the test folder you indexed. If correct results are returned, Microsoft
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FAST Search Server 2010 is configured correctly. If not, or if you see errors in the
Crawl Log, there is a configuration issue with your setup.

Part 6: Set up Ektron to work with Microsoft FAST Search
Server 2010
Install Ektron, setting it up for your environment. When prompted to select a search
provider, choose Microsoft FAST Search Server 2010. When prompted to connect the
site to a Microsoft Search Server 2010 instance, click No. Complete the Ektron
installation. See also: Installing Ektron on page 9
In this section, you complete these additional tasks.
l

Part 6a: Set up the Ektron search connection on the SharePoint server below

l

Part 6b: Set credentials for the Ektron search server service below

l

Part 6c: Run the Ektron search configuration utility on the next page

Part 6a: Set up the Ektron search connection on the SharePoint server
EktronSearchConfiguration.exe enables communications between your site and the
FAST search service.
1. From the Ektron server, copy the following file to any folder on the SharePoint
server.
%SystemDrive%\Program Files (x86)\Ektron\Utilities\SearchServer
\EktronSearchConfiguration.exe

2. From the SharePoint folder, run the file.

Part 6b: Set credentials for the Ektron search server service
1. On the SharePoint server, open the Windows Services control panel.
2. Right click Ektron Search Server Service.
3. Click Properties.
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4. Select the Log On tab.

5. Select This account.
6. Enter the credentials of the user under whom the SharePoint Server Search service
runs. You created this user in Part 1: Install SharePoint 2010 and Microsoft FAST
Search Server 2010 on page 467.
7. Click OK.
8. Restart the Ektron Search Server Service.

Part 6c: Run the Ektron search configuration utility
1. Log on to the SharePoint server.
2. Click the Windows Start menu > All Programs > Ektron >
CMS400vreleasenumber > Utilities > Search Config. If you're using Windows
8 or 2012, press the Windows key (
configuration screen appears.
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3. Enter the Ektron server name.
4. Enter the SharePoint Administration URL. See also: Logging into Ektron's Search
Configuration screen on page 336.
5. Click Next. The Step 2 configuration screen appears.

6. At the Content Service Application field, select the application you created in
Part 2b: Create a FAST search connector service application for crawling content on
page 468.
7. At the Query Service Application field, select the application you created in Part
2d: Create a search service application for querying on page 472.
8. Click Next. The Ektron Search Configuration screen appears. For documentation,
see Updating the site registration panel on page 340.
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9. When you complete the screen, click Register Site. Progress appears in a window.

During this process, the FAST search index is populated with your data, and the
schema is modified to include your site’s searchable properties. This process can be
lengthy when registering a site for the first time. You can monitor these activities in
the Workarea.

Part 7: Make FAST SharePoint’s query search application
In this section, you complete these tasks.
l

Part 7a: Update web.config with query service application below

l

Part 7b: Set FAST search query as default search service application below

Part 7a: Update web.config with query service application
1. On the SharePoint server, go to %CommonProgramFiles%\Microsoft Shared\Web
Server Extensions\14\ISAPI\EktronWebService.
2. Open the web.config file.
3. Find the following entry: <add key="QuerySSA" value="FAST Query SSA" />
4. Replace the value property with the name of the Query Service application you
entered in Part 2d: Create a search service application for querying on page 472.
To continue that example, the line would look like this: <add key="QuerySSA"
value="EktQuery" />
5. Restart the Ektron search site application pool. See also: Start or Stop an
Application Pool (IIS 7).

Part 7b: Set FAST search query as default search service application
1. Open the SharePoint 2010 Central Administration Page.
2. Go to Application Management >Service Applications > Configure service
application associations.
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3. Under Web Application, click SharePoint-80. The Configure Service Application
screen appears.
4. If EKTQUERYSSA is the default, exit the screen. Otherwise, click the Edit the
following group of connections pulldown and choose [custom]. The screen
refreshes and the check boxes are active.

5. Check EKTQUERYSSA[default] then click OK.

Managing FAST administrative tasks
The following topics explain how to perform administrative tasks that are unique to
Microsoft FAST Search Server 2010. The following list shows other search-related
Ektron Reference

485

Setting up search for your website

functions that apply to all Microsoft search providers (including Microsoft FAST Search
Server 2010).
l

Basic versus advanced website search on page 361

l

Formulating search queries on page 364

l

Using Autosuggest on page 366

l

The "Did you mean?" feature on page 371

l

Managing searchability of Ektron content on page 371

l

Managing search results on page 372

l

Using synonym sets on page 374

l

Providing suggested results on page 376

l

Using advanced search in the Workarea on page 391

l

Reporting search activity on page 402

Making the title property sortable
By default, the Title property is not sortable. To change it so that it is sortable, follow
these steps.
1. Log into the Fast Central Administrator console.
2. Choose Manage Service App > Query Service Application > Fast Search
Administrator > Managed Properties.
3. Find the Title Managed Property.
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4. Edit it and check the Sort property box.

IMPORTANT: When used to sort, the Title property follows an ASCII sort pattern.
As a result, titles that begin with a capital letter precede ones that begin with a lower
case letter. For example:
Better Business Bureau
Tiramisu recipe
american foreign policy
See also:
l

Enable a managed property as sort option by using Windows PowerShell

l

Make a managed property sort option available in the web front-end by using the
graphical user interface

Using faceted search
Facets are content properties that allow site visitors to filter search results. For
example, your site lists job postings. So, your results page offers a Region facet, which
visitors use to select jobs in specific regions.
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Faceted search has these limitations:
l

If the metadata definition type is integer or date, facet categories only appear if a
metadata value is assigned to 2 or more content items. For example, if the South
region was assigned to only one content item's metadata, South would not appear
on the facets list. However, the content would be returned in search results.

l

If the same metadata value is applied to all content, no facet categories appear. To
continue the above example, if all content to which the Regions metadata
definition may be applied have South for their value, no facets list appears.

l

The refiner count may be inaccurate if you are using duplicate removal. For more
information, see Refiner count is wrong when using duplicate removal.

This section explains how to implement faceted searching using Ektron and Microsoft
FAST Search Server 2010.

Creating facets
1. Create searchable Ektron metadata definitions. See also: Creating and deploying a
Search tag definition on page 827.
IMPORTANT: Carefully plan capitalization, spelling, spacing, and so on of
metadata definitions for Faceted Search. Minor inconsistencies can result in
duplicate entries.

2. Apply metadata values to appropriate content.
3. Run a full crawl. The metadata become managed properties within Microsoft FAST
Search Server 2010.
4. Update search server controls to look for the metadata/managed property. They
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appear as selectors on your search results page.

Creating a faceted search
1. Create a metadata definition in the Workarea. See Working with Metadata on
page 822. This example uses a text metadata definition called region.
2. Apply the new metadata definition to a folder. See Assigning metadata to a folder
on page 832.
3. Within that folder, apply the new metadata definition to appropriate content. See
Adding metadata to content on page 834.
4. Sign on to Microsoft FAST Search Server 2010.
5. Go to Search Central Administrator > Manage Service Applications > click
the query content source > Fast Search Administration > Managed
Properties.
6. In the Search field, enter emt followed by the metadata definition you created in
Step 1. To continue the example, enter emtregion.
NOTE: You enter emt because this is a text-style metadata definition. Use
these prefixes for other styles.
Microsoft FAST Search Server 2010 prefixes for Ektron metadata definition styles:
l

Text, select from list, multiple selections. emt

l

Integer and number. emi

l

Boolean. emb

l

Date. emd
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l

Double. emf

l

If the content is an XML Smart Form, use these prefixes instead:
o Text, select from list, multiple selections. est
o

Integer and number. esi

o

Boolean. esb

o

Date. esd

o

Double. esf

7. Click the metadata definition/managed property.

8. Scroll down to Refiner Property.
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9. Check it and the Deep Refiner box.

10. Complete Steps 1 through 9 for all metadata definitions that you want to add.
11. Run a full crawl. See Using Microsoft Search Server features on page 360.
12. To enable a search server control to display a metadata selector, modify the
SearchController control using a <Refiners> tag as shown. The tag references the
managed property name, emtregion in our example.
<ektron:SiteSearchController ID="controller" runat="server">
<Refiners>
<ektron:Refiner Name="emtregion"/>
</Refiners>
</ektron:SiteSearchController>
<ektronUI:Pager runat="server" ResultsPerPage="50"
PageableControlID="controller" >
</ektronUI:Pager>

Here are sample search results. If you check a box next to a region, the page
refreshes and displays only content to which that metadata property is applied.
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Managing rank profiles
Microsoft FAST Search Server 2010 lets you adjust the rank of search results, enabling
you to control which content appears near the top. This feature is sometimes called
"Advanced Sorting." You typically use the Rank Profile feature when site visitors are not
getting expected search results. For example, your manage a university website and,
when people enter Admissions, the Admissions department page is not among the top
search results. To fix that, use a Rank Profile to force certain search results to the top.
See also: Tune relevance factors (FAST Search Server 2010 for SharePoint), Manage
rank profiles (FAST Search Server 2010 for SharePoint), Ranking and Sorting (FAST
Search Server 2010 for SharePoint).

Increasing the search rank of a content item
Here is an overview of how to increase the search rank for selected content.
1. Create a metadata definition to define searchable properties.
2. Apply metadata values to selected content. When the content is crawled, the
metadata values become managed properties in Microsoft FAST Search Server
2010.
3. Use Microsoft FAST Search Server 2010 to create a Rank Profile. While defining the
profile, you
l list the metadata values/managed properties
l

modify the search rank of the managed properties, which in turn, modify the
rank of content to which they are applied

4. Update a search server control or the API to use the rank in the search results
algorithm.
Part 1: Create metadata definitions
To increase a content item's search rank, first create searchable Ektron metadata
definitions. They contain the content attribute by which site visitors will search. Then,
apply those metadata definitions to relevant folders and content.
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NOTE: The process of creating and applying metadata is abbreviated here. For full
details, see Creating and deploying a Search tag definition on page 827.
To continue the above example, create a searchable metadata definition named
Departments, of the type Select from a List. Add Admissions to the list of values.
Then, apply that metadata to all folders that contain relevant content.

Next, find Ektron content that describes your Admissions department. Edit that
content, click the Metadata tab, and apply the Admissions metadata to the content.
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Part 2: Create a rank profile
PREREQUISITE

The Microsoft FAST Search Server 2010 type and metadata value name you
use to increase the search rank. To continue the above example, use

494

Ektron 9.40 SP1

Part 3: Incorporate the rank profile into the search

emtadmissions. For a list of types, see Using faceted search on page 487.
NOTE: For more information on Index schema cmdlets, see Index schema cmdlets
(FAST Search Server 2010 for SharePoint).
To create a Rank Profile:
3. Create and enter a name for the Rank Profile.
New-FASTSearchMetadataRankProfile
-name (your profile name)

4. Define the Microsoft FAST Search Server 2010 type and name of the metadata
value used to increase search rank.
$mp = Get-FASTSearchMetadataManagedProperty
-Name (your managed property)

5. Set a variable to your profile. This is typically the same as the name you entered in
Step 3.
$rp = Get-FASTSearchMetadataRankProfile
-name (your profile name)

6. Add a managed property boost to your profile. The $mp command has 2
parameters:
l string,int. the Microsoft FAST Search Server 2010 type and name of
metadata value whose search rank you want to increase
l

boost number. a relative value by which you want to increase the profile's
search rank. See also: Change the managed property field boost weight by
using Windows PowerShell
$rp.CreateManagedPropertyBoostComponent($mp,
"<string/integer managed property value>,<boost number>)”)

Replace values within angle brackets (< >) with actual values.
7. Update your profile
$rp.Update()

Here’s an example:
New-FASTSearchMetadataRankProfile -name departments
$mp = Get-FASTSearchMetadataManagedProperty -Name emtadmissions
$rp = Get-FASTSearchMetadataRankProfile -name departments
$rp.CreateManagedPropertyBoostComponent($mp, "admissions,20000")
$rp.Update()

Part 3: Incorporate the rank profile into the search result display
This section explains how to use a Rank Profile to modify search results, using either
the SiteSearchInputView server control or the API.
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1. Add the rank to a Search server control:
Modify all SiteSearchInputView server controls that you want the ranking to
modify. See also: Using the Search Server Controls. To achieve that, use
<SortProperties> tags. Inside the tags, set these parameters.
l

DisplayName. Enter any unique name to identify this profile.

l

RankId. Your profile name that you created on the FAST server.
<ektron:SiteSearchInputView ID="SiteSearchInputView1"
runat="server" ControllerID="SiteSearchController1">
<SortProperties>
<ektron:RankSearchProperty DisplayName="Custom Relevance"
RankId="departments" />
</SortProperties>
</ektron:SiteSearchInputView>

2. Add the rank using the API:
The following illustrates how to modify search results via the Rank Profile using the
API.
criteria.OrderBy = new List<OrderData>()
{ new OrderData(new RankPropertyExpression("rank profile name"),
OrderDirection.Ascending) };

For example:
criteria.OrderBy = new List<OrderData>()
{ new OrderData(new RankPropertyExpression("departments"),
OrderDirection.Ascending) };

Removing a boost
1. Set a variable to the profile. Use the same profile name that you used in Part 1:
Install SharePoint 2010 and Microsoft FAST Search Server 2010 on page 467.
$rp = Get-FASTSearchMetadataRankProfile -name (your profile name)

2. Set to a variable the Microsoft FAST Search Server 2010 type and name of the
metadata value used to increase search rank.
$mp = Get-FASTSearchMetadataManagedProperty
-name Name (your managed property)

3. Set a variable for the boost you want to delete.
The $_.BoostValue command has 2 parameters: string,int and boost number.
Use the same values you used when creating the Rank Profile. See Part 1: Install
SharePoint 2010 and Microsoft FAST Search Server 2010 on page 467.
$boost1 = $rp.GetManagedPropertyBoosts()
| Where-Object{$_.BoostValue -like '*(string/int),(boost number)*'}

4. Delete the boost.
$boost1.Delete()
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5. Update your profile.
$rp.Update()

Here’s an example:
$rp = Get-FASTSearchMetadataRankProfile -name departments
$mp = Get-FASTSearchMetadataManagedProperty -name emtadmissions
$boost1 = $rp.GetManagedPropertyBoosts()
| Where-Object{$_.BoostValue –like '*admissions,20000*'}
$boost1.Delete()
$rp.Update()

Viewing all boosts
Run this query: $rp.GetManagedPropertyBoosts()

Troubleshooting boosts
l

Problem. The boost does not affect search results

l

Solution. Verify that the FreshnessResolution is set to second. See also:
Change the freshness resolution and weight by using Windows PowerShell

Troubleshooting FAST
Problem. Documents are not being indexed.
Solution. Provide full control rights on the %FASTSEARCH%\bin and %FASTSEARCH%\tmp
folders for the user running Microsoft FAST Search Server 2010
More information. Crawling and processing Office documents with FAST for
Sharepoint 2010 results in document conversion errors in the crawl log
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Chapter 9

Ektron Digital Experience
Hub release notes
Ektron's Digital Experience Hub (DXH) adds seamless integrations with
Pardot, Eloqua and Silverpop marketing systems to its extensive library
of out-of-the-box data connectors. Ektron connectors provide bidirectional data integration between Ektron’s core Content Management
System (CMS) and leading enterprise systems for CRM, marketing
automation, social media, web analytics, and enterprise content
management.
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Connectors
DXH has the following connectors that let you export data collected on your website and
map data to targeted content to provide content that matches their interests, thereby
placing your site information in the context of your users.
l

Eloqua

l

ExactTarget

l

Pardot

l

Silverpop

Using connector information in targeted content
See Connecting Visitors with Targeted Content in the Ektron Reference.
ExactTarget and Pardot connectors can provide data criteria to the Targeted Content
widget, which lets you provide content that matches their interests. For example,
search keywords used to find your site might determine the best offer to show a
prospect. Or, site members might explicitly state their interests by adding to their user
profile or filling out a form or survey.
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Using connector information to create a persona
See Creating Personalized Web Experiences with Personas in the Ektron Reference.
You can use connector information to create persona criteria.
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What's fixed in DXH?

502

l

73612. You could map hidden fields on an Ektron form to a CRM form.

l

73726. DXH generated an error in the log pointing to SharePoint.
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Chapter 10

Creating a mobile-driven
Web experience
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Web traffic from mobile devices is accelerating. Making your website available to mobile
users is not enough. Your website must deliver the same, consistent level of experience
to your mobile visitors as you do for those who visit your website on their desktop to
ensure that your consumers are accessing information, products, and services from
your website.
Mobile applications require different, more compact navigational aids, and content must
fit into a smaller footprint. Mobile websites need "tap to call" options to take advantage
of cellular technology, a robust search, flexible menus, and quick access to content.
Tables and figures may need to be adjusted or reconfigured to avoid unnecessary
"pinching" and scrolling.

Developing a multi-channel website design
When you design and develop your website, you want to reach as many people as
possible. People are using a wide variety of devices to access the Web.

When you evaluate your website, or where you want it to be, consider the following
website strategies:
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l

Foundational. Educate your users about your purpose and products with little
interactivity. Enable business users to publish content using content editing and
management, approval chains, and publishing. Reduce site maintenance for IT and
increase the number of visits to your website.

l

Tactical. Facilitate content reuse, user-generated content, categorization, and
page assembly. Create Smart Forms, taxonomies, online communities.
Synchronizemultiple sites. Develop pages, templates, surveys and polls, blogs,
search, commenting and threaded discussions.

l

Strategic. Embrace multi-channel delivery and support a richer customer
experience with eCommerce, multi-channel, multi-site, multi-language, and video.

l

Engagement. Continually analyze and customize the customer experience with
personas, create touch-centric interaction for mobile devices, integrate with
marketing automation, use multivariate testing, geolocation, device orientation,
and activity streamsto target content for what is relevant and meaningful to your
site visitor. Customer Relationship Management systems can personalize the Web
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experience to drive revenue, deliver better business results, increase your brand
awareness, and create customer loyalty.
Consider the following approaches to design.
l

Separate Mobile Site Design

l

Separate Mobile Template Design

l

Responsive Web Design

l

Responsive Web Design and Server Side Components (RESS)

Separate mobile site design
If you have an existing website that you do not want to redesign, you can separate the
content into 2 site architectures: 1 for desktop computers and 1 for mobile devices. You
can target your content specifically for mobile devices, avoiding the complexity of
developing device-conditional style sheets and manipulating existing content.
However, you will have to maintain 2 sites and ensure that they are synchronized
(where applicable). You have to set up device recognition so that mobile device
requests for your website are routed to your mobile (m-dot) site instead.
Also, having 2 sites can impact your SEO ranking negatively if content is found on both
sites.

Separate mobile template design
Separate templates, optimized for mobile, get rendered whenever somebody visits
your site from a mobile device. This approach lets you define a unique mobile
experience, without affecting the desktop experience, and create a mobile experience
without having to undergo a complete website redesign. Loading of pages is more
streamlined when you use separate templates instead of the responsive design
approach because only the mobile content gets retrieved from the server; responsive
sites often have extra content that is then hidden by CSS rules based upon the current
device.
However, you must maintain more than 1 set of templates (for mobile and desktop
experiences). Also, the server must detect whether a visitor is using a mobile device
before rendering a mobile template, so a list of devices must be kept up-to-date.
Fortunately, Ektron is able to keep the device list up to date for you. See Updating the
Wireless Universal Resource File on page 528.

Responsive Web Design
You should consider a Responsive Web Design (RWD) when you have a high degree of
overlap between the site visitor experience and content on many devices.
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Responsive design provides an optimal viewing experience for devices of any size by
adapting the layout of your pages with CSS3 media queries. The elements on your
pages (including any images) must use relative units (percentages or ems) for sizing
instead of fixed dimensions (pixels). This enables your site to expand and contract to
the viewing size of any device.
Responsive design has a single code base, where other approaches require the use of
separate mobile-specific templates to display your pages to mobile devices. While you
may identify which of your content is "canonical" in a Separate mobile site design on the
previous page, the singular architecture and repository of a responsive design means
that you have one authoritative source for SEO leading to higher rankings by search
engines. (Multiple websites can dilute your ranking.) It also lets your site visitors use a
consistent set of URLs without the issue of directing to the WWW or m(dot) site.
Many traditional websites require a complete redesign and implementation to change to
a responsive site. Additionally, a complete redesign may require added time and effort
to ensure that the user experience is mobile-friendly. You must weigh the costs of a
redesign to gain the benefits of a single code base (long-term maintenance savings,
SEO improvements, and so on).
Another issue to consider before creating a responsive website is that entire pages are
loaded. If you have a lot of content on a page, it can impact the user experience. By
contrast, if your site uses separate mobile templates, you can decide if some of that
content should be loaded on certain types of devices.
Using responsive frameworks with PageBuilder on page 1087 shows how to work
responsive Web design into your PageBuilder pages.

Responsive Web Design and Server Side Components
Responsive Web Design + Server Side Components (RESS) has the flexibility of
responsive design while providing the granularity of device detection to deliver devicespecific components.
Ektron supports the use of RESS by providing tools to display content and assets based
on groups of devices, which can be added to your responsive pages. Of course, this
responsive aspect means that your site needs to be redesigned, but once redesigned,
these tools can provide the best of both approaches.
Using responsive frameworks with PageBuilder on page 1087 shows how to work
responsive Web design into your PageBuilder pages.

Using mobile templates
A template is a customized Web page format comprised of objects such as content
blocks, list controls, menus, rotating banners, a search object, and videos. How you
assemble the objects affects the user experience. Because of the smaller display size,
templates for mobile devices may have a single column to eliminate horizontal scrolling,

506

Ektron 9.40 SP1

Setting up a mobile template

pinching, and zooming. You decide what is practical for each device by creating
different templates instead of creating different content. Objects may have to be
omitted or replaced with mobile-friendly objects. The following image shows
PageBuilder templates for desktop and mobile devices. Note that the mobile template
does not include content object 3. See Developing wireframe templates on page 1093
for information about creating PageBuilder wireframe templates.

You should use the same dropzone IDs for both the mobile and desktop templates.
Content does not display if a mobile template contains a dropzone ID that the
corresponding desktop template does not have.
Ektron can detect specific characteristics of a mobile device, such as the differences
between the Android Droid X and Droid 2. These characteristics help you determine
how to render the user experience. For example, one device may support Flash
technology and another may not.
In any case, you want to ensure that your content on a mobile device is elastic,
meaning that it can scale to the various sizes of displays. Use percentages instead of
hard-coded pixel sizes for the mobile template. If you set PageBuilder dropzone width
to 100%, the normal flow of the objects in the mobile browser cause them to stack from
the top to the bottom.

Setting up a mobile template
1. In the site root/web.config file, set ek_EnableDeviceDetection to True.
<add key="ek_EnableDeviceDetection" value="true">

2. Identify a template for which you want to create a mobile version, using the
Workarea > Settings > Configuration > Template Configuration screen.
Click any template to see its folder location relative to your site root.
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3. Open Windows Explorer and locate that template in the site root folder.
4. Copy and save a mobile version of the template under a suitable name, for
example, account.pb.smartphone.aspx.
5. Adapt the template for mobile use by changing column styles, removing unwanted
navigation, images, headers, footers, adding components that help mobile users,
and so on.
6. Create device groups. Assign to each one any mobile devices that use the template
you created. See also: Grouping mobile devices on page 512.
7. Return to the Template Configuration screen and click the template you identified
in Step 2.
8. Check every mobile Device Group for which you created a mobile template
version. Then, for every checked configuration, click the ellipsis button (
right, go to and select the mobile template you created in Step 6.
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Previewing content in a mobile template

Now, if a mobile device user accesses a page which uses that template, the mobileenhanced template displays the content.
l

To test mobile templates, preview your content within them. See Previewing
content in a mobile template below.

l

Ektron uses the Wireless Universal Resource File (WURFL) file to obtain
wireless device information. To learn how to view, update, and customize this
file, see Updating the Wireless Universal Resource File on page 528.

l

To conditionalize Smart Form content based on user device, see Specifying
device-specific content with Smart Forms on page 511.

l

To use a mobile site visitor's geographic location to deliver relevant content,
see Using Geographic data from a mobile device on page 526.

Previewing content in a mobile template
You can preview content in mobile template to ensure the content fits within the screen
resolution.

Previewing mobile content from a PageBuilder page
Ektron multi-channel preview lets you ensure that your page is optimized for devices of
every size. You can browse your entire site using any preview device.
If you have the toolbar enabled...
PREREQUISITE

Previewing virtual mobile devices requires an HTML5 CSS3-compliant
browser. You must also enable the toolbar, for any template you want to use
it, by checking the boxes in the Enable Toolbar column at Workarea
> Settings > Configuration > Template Configuration.
1.

Click Preview on the toolbar to show your page on a variety of simulated
devices (portrait and landscape views). A bar appears with devices that simulate
your Web page on those devices. For information about setting these devices, see
Adding a group by device model on page 517.

2. Click on the device on which you want to preview the web page. For example,
choose Apple® iPhone® 4s. The Web page appears in the simulated device. You
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can select portrait or landscape view.

If you have the toolbar disabled (or do not have an HTML5 CSS3-compliant
browser)...
1. Log into your Ektron website.
2. Go to PageBuilder page that you want to view as a mobile device user would.
3. From the PageBuilder menu, click View > Device Preview. A dialog box appears.

Choose the breakpoint you want to preview from the drop down menu. The page
displays in the dialog box.
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Previewing mobile content within the editor
1. Edit content in the editor.
2. Click Preview (

).

3. Select a model from the Device Configuration drop-down and click Preview.
The content displays in the selected template.

Specifying device-specific content with Smart Forms
You can set up Smart Form configurations to recognize a user's device and, based on
that information, display appropriate content. For example, if a user is not using a
Smart Phone, show a complex display with rich graphics. If a user is using a Smart
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Phone, create a simpler presentation of the same fields without graphics. To learn about
this capability, see Inserting a conditional section on page 900.
You can also designate some or all of an HTML form's postback message to be
conditional upon a user's device. So, for example, the postback message for Smart
Phone users can be much shorter than the message for users who are not using a
mobile device. To learn more about this, see Specifying conditional text in the postback
message on page 875.

Grouping mobile devices
You can accommodate a variety of mobile devices by grouping characteristics, such as
display size. You can group devices for standard presentation and add refinements for
specific devices. For example, a device configuration may consist of a Smart Phones
group (Apple iPhone®, Samsung Galaxy Note™ II, Motorola® Droid RAZR MAXX HD,
and so on) and a Tablets group (Apple iPad®, Google Nexus™ 10, Microsoft® Surface™,
and so on).
With Ektron, you can group devices by breakpoint, model or operating system. A
breakpoint is a screen width at which media queries make changes to the layout and
switch from one image file to another.
For example, you can set a breakpoint of 480 pixels-wide and call the group "Smart
Phones," and set another breakpoint of 1024 pixels-wide and call the group "Tablets." If
an image is loaded at 720 pixels-wide, the image is allowed on devices in the
"Tablets" group. (You may have alternate images to display for the "Smart Phones"
group. See Applying adaptive image resizing on page 518 for information about
optimizing images for device groups.)
Grouping by model gives you more control over specifications, but it is quicker to group
by operating system. You may want to first group by breakpoint, then by operating
system, then only define models that do not work properly under an operating system
configuration.
To determine which mobile devices to add to your device configurations, review your
Analytics reporting to see which mobile devices are browsing your site. To see the
Browser and OS report:
1. In the Workarea, select Reports > Traffic Analytics > Visitors > Browser
Capabilities > Browsers and OS.
2. Modify the time period and rank if needed. For more information, see Analyzing
websites on page 531.
The following example shows that Android and iPhone mobile devices have browsed
pages. You can create templates and device configurations to improve the experience
of these visitors.
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Adding a group by breakpoint
Ektron provides 2 default groups by breakpoint (Smart Phones, and Tablets). When you
set up breakpoints, images that are subsequently uploaded are created in each of the
breakpoint sizes for use on devices that fit the breakpoint criteria. See also: Applying
adaptive image resizing on page 518.
1. Workarea > Settings > Configuration > Mobile Settings > View All Device
Groups.
2. Click New Group.
3. Click Group by Breakpoint.
4. Click Create Group. The Group Device by Breakpoint screen appears. The Smart
Phones group has a breakpoint of 480 pixels. The graphics to the right of the
groups show the devices that fit your criteria. The check boxes under the device
images lets you select the devices that you want to show as options on the Device
Preview screen of the toolbar. See Editor toolbar options on page 606.
NOTE: You can specify new breakpoint values for an existing group on this
screen and click Save.
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5. If a Wireless Universal Resource File (WURFL) update is available, click Update.
For more information about WURFL, see Updating the Wireless Universal Resource
File on page 528.
6. Click Add Breakpoint to create a new breakpoint group. The Add New Device
Group dialog box appears.
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7. Enter the name of this breakpoint group. For example, Small Phones.
8. Enter the breakpoint width for the group. For example, 360.
9. Click Create Group. The Group Device by Breakpoint screen re-appears with
device images next to the new breakpoint group.
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10. Click Save to create the new group. The new group appears in the Groups By
Breakpoint (Default) section of the View All Device Groups screen.

Adding a group by operating system
1. Workarea > Settings > Configuration > Mobile Settings > View All Device
Groups.
2. Click New Group.
3. Click Group by Operating System (OS).
4. Click Create Group. The Group Device by OS screen appears.
NOTE: If your Wireless Universal Resource File (WURFL) is out of date, a notice
appears on the screen. Click Update to update the device information. For more
information about WURFL, see Updating the Wireless Universal Resource File on
page 528.

5. Enter the name of this OS group.
6. Check the boxes next to the available operating systems you want in this group.
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7. You can specify new dimensions for preview, or accept the default values.
8. Click Save to create the new group. The new group appears in the Groups By
Device Configuration section of the View All Device Groups screen.

Adding a group by device model
When adding individual devices to a configuration, group devices that share
characteristics, such as Flash support and screen resolution. Since you will assign the
configuration to a mobile template, make sure that all devices support the template's
functionality.
1. Workarea > Settings > Configuration > Mobile Settings > View All Device
Groups.
2. Click New Group.
3. Click Group by Device Model.
4. Click Create Group. The Group Device by Model screen appears.
NOTE: If your Wireless Universal Resource File (WURFL) is out of date, a notice
appears on the screen. Click Update to update the device information. For
more information about WURFL, see Updating the Wireless Universal Resource
File on page 528.

5. Enter the name of this Model group. For example, My Favorite Phones.
6. Enter a model name in the search box of a device that you want to add. For
example, enter Blackberry or iPhone and press Enter.
7. Select the devices you want in the model group by checking the boxes. If you want
to choose models from Blackberry AND iPhone AND Razr, first select your
device and models from one, then enter another into the search box and select the
others. Your selections appear on the right side of the screen.
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8. You can specify new dimensions for preview, or accept the default values.
9. Click Save to create the new group. The new group appears in the Groups By
Device Configuration section of the View All Device Groups screen.

Deleting a device group
1. Workarea >Settings > Configuration > Mobile Settings > View All Device
Groups.
2. Click Delete ( ). A confirmation dialog box appears.
3. Click Delete.

Applying adaptive image resizing
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Adaptive Image Resizing resizes images and helps you implement a caching strategy to
enhance a user's mobile experience on your site. It includes the following features:
l

Criteria to determine which images get resized

l

A user-defined set of resolutions—Ektron renders the image in a deviceappropriate resolution

l

A direct access mode that lets a developer set an image to a predefined resolution

PREREQUISITE

To enable Adaptive Image Resizing settings, set ek_
EnableDeviceDetection to True in siteroot/web.config.
<add key="ek_EnableDeviceDetection" value="true" />

Some visitors to your website will be on devices that have less-than-optimal bandwidth
due to their geographic location, their network, or device limitations. As a result, the
website loads slower for the mobile visitor than for the desktop visitor. By optimizing
your images for device sizes, you minimize these limitations.
Simply shrinking an image to fit a smaller device may result in an unsatisfactory image.
To ensure that your mobile visitors receive the best experience, Ektron’s Mobile Image
Selector lets content authors replace the image (with a satisfactory substitute) that
gets displayed for visitors on mobile devices of certain sizes. For example, the following
images show a "Times Square" article example on a Smart Phone. Authors can swap
out the desktop image for an image that renders well on smaller devices; the shrunken
image on the left gets replaced by the image on the right.
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Adaptive Image Resizing lets every visitor receive the image that is most appropriate
based on their device. For example, Smart Phones may receive an image that’s been
scaled down to a lower resolution and 480-pixels wide, while the “Desktop” version of
the image might be high resolution and 1200-pixels wide.
Image resolution ultimately defines the amount of detail an image holds. If an original
image is 1024 x 1024 pixels, there is a significant loss of detail when looking at a
scaled-down 24 x 24 thumbnail image. However, a 24 x 24 thumbnail image has a
much smaller physical size in KB, which means that it downloads much faster.
IMPORTANT: A delay in loading a page by only 1 second can dramatically impact
your conversion rate and deliver a poor customer experience.
If you view a 1024-pixel-wide image on a 320-pixel-wide screen, you cannot see the
detail. Downsizing the image to 320 pixels reduces the physical size significantly with
no loss of image detail. Similarly, you also can crop a section of the 1024-pixel-wide
image to a 320-pixel-wide section with all of its detail.
You want to balance image quality with file size because every millisecond of load-time
makes a difference to the experience (and tolerance) of your site visitors.
When you add an image to the Ektron CMS, Ektron creates copies of the image in the
sizes specified in the image breakpoint groups, up to the width of the original image.

For example, if you set up 4 image breakpoints at 320, 476, 620 and 768 pixels wide,
when you upload an 1024 x 1600 image called MonaLisa.jpg, the CMS creates 4
additional images as follows:
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l

Original image. /uploadedimages/MonaLisa.jpg MonaLisa.jpg

l

320 breakpoint. /uploadedimages/320W_MonaLisa.jpg

l

476 breakpoint. /uploadedimages/476W_MonaLisa.jpg

l

620 breakpoint. /uploadedimages/620W_MonaLisa.jpg

l

768 breakpoint. /uploadedimages/768W_MonaLisa.jpg
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If a 400-pixel-wide device calls the Mona Lisa image, the device gets the 476-pixel
image scaled to fit the (400-pixel device) container. However, even though you can
force an 1024 x 1600 image to fit into a container, creating a smaller image drastically
reduces the physical size of the image file by several factors of kilobytes that are
transferred, significantly speeding up page-load time. Delays in page loading can mean
a loss in customer conversions and deliver a poor customer experience.
When you specify both width and height breakpoints, a device uses the larger of the
breakpoints to scale the image while keeping the aspect ratio of the image. For
example, if the height is 400 and the width is 600, the width is used to determine the
scale and the aspect ratio is kept.
NOTE: Adaptive images and responsive images are similar: adaptive images are
affected by the server while responsive images depend on the client to display
correctly. For information about responsive image selection when you are editing
your Web page, see Editing images on page 624 in Editing in Ektron on page 605.

Enabling adaptive images for breakpoints
If you have mobile devices grouped by breakpoints, you must enable groups to create
adaptive images when images are uploaded to the library or as assets. Go to
Workarea > Settings > Configuration > Mobile Settings > Adaptive Image
Settings. The Adaptive Image Settings screen appears. The following example shows
the Small Phones group that was added in Adding a group by breakpoint on page 513.

When you check a box next to a breakpoint group, the screen expands to let you specify
maximum width and height for the breakpoint images, and lets you add a file label as a
prefix to the image filename. In the following example, uploading Mona_Lisa.jpg
generates SM_Mona_Lisa.jpg for the Small Phones group, SP_Mona_Lisa.jpg for the
Smart Phones group, and the TB_Mona_Lisa.jpg for the Tablets group.
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Checking boxes for Library and DMS enables adaptive image generation when images
are uploaded into these locations.
The Advanced Setting tab of the Adaptive Image Setting screen lets do the following:
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l

Specify minimum file size that an image is before it will get resized. The default
minimum is 80 KB—smaller files are not resized.

l

Specify caching levels 1 and 2. Use caching to avoid expensive query storage. You
should approximate the number of image files in the image folders.
To clear both Level 1 and Level 2 cache, click Clear Cache.
o

Level 1 caching stores only a filename, file size, and resolution.

o

Level 2 caching stores the file's content as a byte array.
BEST PRACTICE
Use the following formula to calculate memory usage for Level 2
caching:
Level2CacheItemThresholdKB * Level2CacheSize = total memory used

For example: 256KB*500=128000KB=128MB of maximum memory
used by Level 2 caching.
How adaptive image caching works
1. A user on a mobile device accesses an Ektron Web page that uses Adaptive
Image Resizing.
2. For every image file request, Ektron looks for it in Level 1 cache to determine if
the image size exceeds the threshold.
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l

If the cached item is found, the cached file information is used.

l

If the cached item is not found, Ektron queries the storage device for the
file information and caches it.

3. For every qualified image request, if level 2 caching is enabled, Ektron
searched Level 2 cache for the target file. If the file is found, the cached byte
array is sent to the user's device. If the file is not found, Ektron sends the
image from storage and caches the byte array (if the size does not exceed the
defined limits).
l

The Direct Access Query String Key (targetTypeID) is for developers who want to
ignore a user's device and choose a specific version of an image. The
targetTypeID string is appended after the question mark (?) on a URL. You can
change targetTypeID to another string in this field.

Using responsive images with the editor
When you insert an image from the library into content then click the image to select it,
the Inspector's Advanced tab shows all breakpoints and their corresponding images.
You can replace an image by clicking Change and selecting another image from the
library.
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When responsive images are inserted into the editor, the editor produces HTML similar
to the following code to determine which images should be displayed for each
breakpoint.
<figure class="ektron-responsive-imageset"
title="Mona Lisa"
data-ektron-image-src="/uploadedImages/Content/About/
Mona_Lisa.jpg?targetTypeId=Tablets"
data-media="/uploadedImages/Content/About/
FP_Mona_Lisa.png?targetTypeID=FeaturePhone"
data-media316="/uploadedImages/Content/About/
SM_Mona_lisa.jpg?targetTypeID=Smartphone"
data-media768="/uploadedImages/Content/About/
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Mona_Lisa.jpg?targetTypeID=Tablets">
<img src="/uploadedImages/Content/About/
Mona_Lisa.jpg?targetTypeID=Tablets" alt="Mona Lisa" />
</figure>

For information about the editor, see Editing in Ektron on page 605.

Creating image copies in a specified resolution
After you enable device detection in web.config, Ektron automatically creates versions
of the image in specified sizes for a matching breakpoint when a visitor views an image.
<add key="ek_EnableDeviceDetection" value="true" />

A new image filename consists of ImageResConfig TypeID_original file
name.extension. For example, if the original image filename is mytest.png, and it is
resized to specifications set in the LowRes ImageResConfig element, the new filename
is LowRes_mytest.png.
If a mobile visitor views an image that was in Ektron before device detection was turned
on, the image may be resized at that time. Ektron creates resized image versions in the
same folder as the original image.
If you later view the image on any device with the same resolution range, the saved
version is displayed. This practice enhances the performance of your mobile website.
However, creating additional image versions also increases the number of files and
storage space needed.
BEST PRACTICE
When planning an implementation of Adaptive Image Resizing, consider
your future space requirements.

Using Geographic data from a mobile device
If your site visitor is on a mobile device, the geographic location of your site visitor
becomes very important information. For example, if a mobile visitor is accessing your
site, you can display nearby stores and special promotions. To create a geographically
aware Web experience with Ektron, follow these steps.
1. Create content with MapLatitude and MapLongitude geo-location metadata. This
metadata is automatically added when you publish content with a street and city
address in the MapAddress field.
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2. Place the Map server control in a mobile device template.
3. Because of the size of a mobile device, you may want to rearrange the content list,
map image, and search components provided by the Map server control. To do
this, change the standard map EkML file. See Ektron Markup Language and the
sample file [siteroot]/workarea/template/map/map.ekml.
To learn more about using geolocation, see the Map server control.
After finishing the previous steps, use your mobile device (if it has GPS capability) to
browse to the template that contains the map; it shows your location at the center of
the map. For other mobile devices, the center of the map is the Latitude and Longitude
coordinates set by the Map server control. Content locations appear as map pins, and
the content list is sorted by distance from the current location (with GPS) or map
center.
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Updating the Wireless Universal Resource File
NOTE: The commercial license between Ektron Inc. and ScientiaMobile, Inc., the
owner of WURFL, expired on April 3rd, 2016. You have the following options:
l Disable the WURFL data repository in your deployment so that you are not using
WURFL in an unlicensed manner.
l Contact Scientiamobile, Inc. to obtain a license directly. ScientiaMobile, Inc. has
provided a guide to transitioning.
l Replace the WURFL data repository with the 51 Degrees(TM) Lite library by
51Degrees.mobi, which is licensed under an Mozilla Public License open-source
license agreement.
When a device requests information from a Web server, HTTP headers are passed to the
server along with the image URL. The HTTP headers contain information that identifies
the type of device that is doing the request. Because new mobile devices are being
created every day, it is important for your website to detect these devices when they
are available and present the appropriate experience to visitors who use these devices
when they visit your site.
Each time a user clicks on the View All Device Groups folder, Ektron determines
whether more recent device information is available.
1. Go to Workarea > Settings > Configuration > Mobile Settings > View All
Device Groups. If your WURFL file is not up-to-date, you are given the
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opportunity to update it.

2. Click Update.
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Ektron has 2 types of analytics.
l

Ektron Business Analytics. uses Ektron server controls to track activity, store
the information in the database, and report on that information. See Running
Ektron business analytics on page 536.

l

Ektron Traffic Analytics. uses an outside service provider, such as Google
Analytics to monitor all aspects of Web traffic to your site and report on that
information. See Running Ektron traffic analytics on page 558.

You can also run analytics from other providers documented in this chapter.

Viewing page-level analytics data
After you enable analytics tracking, your provider retains data on every visited page
(that is, a unique URL) such as http://developer.ektron.com/articles.aspx or
http://developer.ektron.com/template.aspx?id=6572. Data is tracked when the
quicklink is used, as well as any alias assigned to the content. See also: Creating userfriendly URLs with aliasing on page 1399
You can view any page’s analytics data from the following locations.
l

Viewing page-level analytics from the site below

l

Viewing page-level analytics from a PageBuilder page on the facing page

l

Viewing page-level analytics from the Workarea on page 534

Viewing page-level analytics from the site
Any authorized user can view analytics for a page on your website by following these
steps.
1. Log into the website.
2. Go to the page whose analytics data you wish to view.
3. Hover the cursor over the Website Content menu.
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4. Choose View Page Activity. The SEO page’s Traffic tab appears.

The Traffic tab of the SEO control graphs the analytics data of any 2 search criteria.
There are data under the graph for the 5 visit criteria tracked by the analytics provider.
l

Pageviews. number of pageviews for this page over the selected date range

l

Unique pageviews. number of unique visitors to this page over the selected date
range

l

Average time on page. how long a visitor spent on the page. It is calculated by
subtracting the initial view time for this page from the initial view time of the
subsequent page. So, this metric does not apply to exit pages.

l

Bounce rate. the percentage of single-page visits (that is, visits in which the
visitor exited your site from the entrance page)

l

% Exit. the percentage of site exits that occurred from this page

You can change the date range, analytics provider, and either search criterion
(Pageviews and Time on Page in the example above).
You can also replace the URL with a different one, and view the page being analyzed
(by clicking Visit this page in the green bar).

Viewing page-level analytics from a PageBuilder page
Any authorized user can view analytics for a PageBuilder page by following these steps.
NOTE: You cannot drag and drop the Analytics widget onto a PageBuilder page.

Ektron Reference

533

Analyzing websites

1. Open the PageBuilder menu. See also: Creating Web pages with PageBuilder on
page 1075
2. From the menu, choose View > Analytics. The SEO page’s Traffic tab appears.

Viewing page-level analytics from the Workarea
The Workarea provides 2 page-level views of analytics data.
l

The View Content History screen compares analytics data for any 2 published
versions

l

The Analytics toolbar button displays the SEO page’s Traffic tab.

To view a content item’s analytics data from the Workarea:
1. Go to the folder containing the content whose analytics data you want to view.
2. Click the content item.
3. To compare analytics data between any 2 published versions, click History(
See also: Comparing versions of content on page 703
To view analytics for the currently published version, click Analytics (
you do, you see the Traffic tab of the SEO page.

).

). When

On the View Content History screen, blue and orange radio buttons appear next to each
published version of content.

To compare analytics data, click the appropriately-colored radio button next to each
version, then click Compare ( ). The Compare screen for the 2 versions appears.
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You can change the date range for each content version. You can also:
l

Use the Display pull-down to graph any visit data.

l

Click the URL Filtering tab to select the URLs being displayed. See also: URL
filtering below

l

Select a different site

l

Select a different analytics provider

l

Use the Segments button (

).

URL filtering
Any content item can be viewed via several URLs, such as
l

its quicklink. See also: Adding a quicklink to content on page 747

l

manual alias

l

automatic alias See also: Creating user-friendly URLs with aliasing on page 1399

NOTE: While Regex-based aliases affect Analytics data, they do not appear on the
URL Filtering tab.
The URL Filtering tab of the Compare Analytics screen lets you analyze the data by
each identifier. So, for example, you can drill down to view only the data collected when
site visitors accessed a page by typing its manual alias into the browser.
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Viewing site-level analytics data
You can view analytical data for any site via the Analytics Report widget and several
reports. See also: Creating and using widgets on page 1271

You can drag and drop the Analytics Report widget onto the Smart Desktop. When you
do, you initially see the Direct Traffic report for the past 7 days.
You can click Edit ( ) to change the display using any of the following options.

There are 3 time interval choices:
l

last 7 days (the default)

l

last 30 days

l

last 90 days

Running Ektron business analytics
The Business Analytics feature lets you track statistics about visits to your website. You
can use it to determine the following kinds of information:
l

how often your content was viewed

l

how many site visitors viewed for first time, and how many returned

l

the most popular referral pages (that is, the Web page from which visitors clicked
to arrive on your site)

Several options for selecting a date range let you compare activity across different
weeks, months, and years.
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By default, the Business Analytics feature is disabled in the web.config file. To enable
it, set the value of the ek_enableClassicAnalytics property to true. If you set this
property to true and later change it to false, statistical data remains within Ektron,
but no additional data is collected.
<add key="ek_enableClassicAnalytics" value="true" />

For every template view, business analytics captures the following statistical
information:
l

url. the visited page

l

content_id. the ID of the visited content. Captured by the Analytics server
control. Tracking clicks by file type on page 577

l

visitor_id. a unique GUID that identifies a visitor

l

hit_date. date and time when a page view occurred

l

referring_url. the URL a user was viewing before jumping to the visited page

l

visit_type. zero (0) indicates new visitor, 1 indicates returning visitor, 2 indicates
all other views. After a user logs on, the first page hit tracks the visit as zero (0) (if
the user is new) or 1 (if the user previously visited the page). From then on, 2 is
logged for that user.

In addition to writing Business Analytics data to the database, you can write it to the IIS
log. To do this, enable the appendToIISLog element in the web.config file. Note that if
you set appendToIISLog to true, some Business Analytics data is only written to the
IIS log and does not appear in the Workarea.

Analyzing site statistics
The following table shows analytic statistics available for each level of the site.
Type of Statistical Information

Sitewide

TemplateLevel

ContentLevel

Views of Any Template

Visitors: New and Return

Pie Chart of New vs. Return Visitor

Pie Chart of Views/Visitors Ratio
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Type of Statistical Information

Sitewide

TemplateLevel

ContentLevel

Bar Graph of Views/Visitors Ratio

Visited Pages

Visited Content Blocks
URLs from which Site Visitors Accessed
Ektron

Site statistics view
The Site Statistics view offers an overview of tracked activity within the selected date
range. You see actual data for the
l

number of views

l

number of visitors

l

ratio of visitors per view

l

number of new and returning visitors

l

ratio of new to return visitors
See also: Tracking site visitors on page 541.

The following image shows pie charts of the ratio of views to visitors and new vs. return
visitors.
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Content view
The Content View shows the most frequently-accessed content on your website.

Click any content item to view:
l

Content Statistics. Statistics for that content item only

l

Content Activity. Relative activity for that content item only
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l

Audit Content. All users who viewed the selected content; to the right of each
user are the date and time when content was viewed

NOTE: Only users who viewed content after logging in appear on the list. Site
visitors who do not log in affect statistics but are not tracked on this report.

Templates view
The Templates View shows all viewed templates on your website, with the most
frequently-accessed ones on top.
By default, the templates at the top have the highest number of unique visitors. You can
change the sort by clicking any column header. For example, to sort templates by the
number of views, click Views.

You can click any template to view
l

Template Statistics. Statistics for that template only

l

Template Activity. Relative activity for that template only

l

Content in Template. If a content item was specified for the template in the
Content Analytic server control, this view show statistics for the template. You can
click the template to view Template Level activity.

Referrers view
The Referrers View shows domains from which your site was most frequently accessed.
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Tracking site visitors
The Business Analytics feature provides information about visits made by new versus
returning visitors. To capture this data, the feature asks this question whenever a page
is visited: is the user logged in as either a membership or regular user?
l

If yes, capture the user ID with the statistical data

l

If no, place a cookie on the visitor’s computer

The next time the user visits that page, the feature checks the visit history for the user
ID, or for a cookie. If either is found, the visit is considered a return.
The same user visit may be considered new on one view but not on another. For
example, someone visits on January 30 (Monday) then again February 2 (Thursday).
On the monthly statistics, that visitor is new, but on the weekly statistics, the February
2 hit would be a return visit (his second this week).
Now consider a second visitor, who browses to your site on the first and 20th of the
month. These visits appear on weekly statistics as 2 new visits, but on the monthly
statistics, only the first visit would show up on that month's tally of new visitors. The
second visit would add to the return visitor statistics.

Specifying the frequency of writing to the database
After you set up the Business Analytics feature, your database is subject to a
continuous barrage of write activity, generated by visits to your site. To optimize your
database’s performance, you can hold visit activity in application server memory until a
predetermined amount of data is collected. When collected, it is moved in one packet to
the database. So, the database is “hit” much less frequently.
Specify the amount of data saved in memory prior to being written to the database
using these web.config file elements.
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l

recordsBeforeWrite. the number of unique template visits

l

timeBeforeWrite. the number of seconds since the last time a database write
occurred

When either element reaches the value set in web.config, all records stored in memory
are written to the database. That event resets both elements to zero (0).
When you first view statistical data, the default date range is today (one day).
If you view statistics for different date ranges, when you return to the screen, the last
selected date range is the default selection. You can change it if needed.

Using Quick View options
Use Quick View options to view analytics for any of these time periods.
l

one day

l

one week

l

one month

l

one year

When you click Quick View [week], [month] or [year], the current end date is used
as the last day of the range. Here are some examples.
l

Week. If end date is today, begin date is one week earlier than today

l

Month. If end date is today, begin date is one month earlier than today

l

Year. If end date is today, begin date is one year earlier than today

Using Jump To options
Use Jump To options to view statistics for a time period before and after the current
date range. The time period is determined by the Quick View increment. For example, if
the Quick View option is Day, you can jump to the previous day, the following day, or
today.
Regardless of the Quick View increment, you can always view statistics for today.

Viewing business analytic reports
The Business Analytics reports let you drill down from the entire site to individual
templates to individual content items.
PREREQUISITE

In your site's web.config file, the ek_enableClassicAnalytics setting is
set to true.
NOTE: The Most Popular and Trends widgets also report on Business Analytics data.
See Most popular widget on the facing page and Trends widget on page 546.
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To access Business Analytics Reports:
Either
1. Browse to a content item for which Business Analytics data is being captured.
2. Right click the mouse.
3. Choose View Template Activity to see Business Analytics data for the current
content item (to learn more about data captured for one content item, see Content
view on page 539).
4. Choose View Site Analytics to view Business Analytics data for the entire site.
or
l

From the Ektron Workarea, choose Reports > Business Analytics to view
analytic data for the entire website. The following reports are available.
l Site statistics view on page 538
l

Content view on page 539

l

Templates view on page 540

l

Referrers view on page 540

Most popular widget

The Most Popular widget reports on these categories of content on your website. By
default, every Most Popular widget tab shows up to 5 results.
l

Most Viewed

l

Most Emailed

l

Most Commented

l

Highest Rated

You can place the Most Popular widget onto any PageBuilder page. See also: Creating
Web pages with PageBuilder on page 1075.
NOTE: You cannot place more than one Most Popular widget on a PageBuilder page.
Also, you can hide up to 3 tabs if desired.
The Most Popular widget references content events, which are Ektron events that are
tracked when used with various server controls. Here are 2 examples of a content
event:
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l

for the Most Viewed tab, the content was viewed and tracked by the Analytics
Tracker server control. See also: Analytics Tracker.

l

for the Most Emailed tab, the content was emailed from the Social Bar server
control.

The Most Popular widget displays content items that meet these criteria.
l

the content is tracked by a server control

l

content events occurred within the date range set in widget properties. The default
value is 7 days, but you can change it if desired.

l

the content is assigned to a selected folder or taxonomy. By default, the widget has
no folder or taxonomy restrictions. But the properties screen lets you restrict
results by folder or taxonomy.

l

the content is among the highest-rated content items for that tab.
For example, if the Most Viewed tab shows the top 5 content items (the default
setting), content that has not been viewed as frequently as the top 5 does not
appear. Consider the following example.

Content ID

Number of Times Content
Viewed within Date
Range

30

87

259

82

316

78

12

78

658

67

243

62

In this example, content ID 243 does not appear on the Most Popular widget
because it is sixth in viewing rank frequency.
Each time a content item is used with one of the following server controls, its count for
that day is incremented by 1.
l
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l

SocialBar. Most Emailed tab—A community group member browses to a page that
hosts the Social Bar server control, and emails a content item to a friend. (The
SocialBar server control must be associated with content.)

l

MessageBoard. Most Commented tab—A Community Group member browses a
page that hosts the Message Board server control and comments on a content item
on that board. (The MessageBoard server control must be associated with
content.)

l

ContentReview. Highest Rated tab—A site visitor browses to page that hosts the
Content Review server control, and uses the control to rate a content item.

Next to each content item is a count. The count indicates the number of times a content
event occurred for that content within the specified time frame.

The date range can affect the count. For example, if a content item was viewed once a
day for the past 10 days but the date range is set to 7 days, the count is 7. To change
this maximum:
1. Open siteroot/widgets/mostpopular.ascx.cs.
2. Find the following line: private int _PageSize = 5;.
3. Change the number at the end of the line to the maximum results to display.
NOTE: This setting affects all tabs and instances of the Most Popular widget.
A logged in user can change properties that determine what appears on the Most
Viewed tab. To do so, click Edit ( ).
l

Tab text. The text that appears on this tab. In the above example, the left tab's
text is the default Most Viewed.

l

Visible. Determines if the tab you are editing appears on the widget. At least one
tab must appear. Checked is the default.

l

Number of days to report. The number of days for which to display the data.
The default is 7.
o The current day is not counted, since it is incomplete. So if you enter 1, you
see information for all of yesterday and today.
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o

The date calculation is based on the clock on the website's server.
NOTE: You can change this to any number you wish. However, the widget
can only show data for days for which data is stored in your database.

l

l

Report. Determines information that appears when a tab is clicked.
o Tab 1. Most Viewed
o

Tab 2. Most Emailed

o

Tab 3. Most Commented

o

Tab 4. Highest Rated

Filter By. You can restrict the content appears on this widget by selecting a folder
(default) or a taxonomy.

While selecting a folder/taxonomy category, you can include all folders/categories
under the selected one. To remove this restriction later, click Delete (

).

Trends widget

By default, the Trends widget shows the Most Viewed content on your website. You can
edit the widget's properties so that it displays any of the following categories of content
instead.
l

Most Emailed

l

Most Commented

l

Highest Rated

The Trends widget is a subset of the Business Analytics, so you should be familiar with
that section before reading this. It explains topics such as how Ektron determines which
content appears for each category. You can place the Trends widget on any PageBuilder
page. See also: Developing wireframe templates on page 1093.
A logged in user can change properties that determine the appearance of the Trends
widget. To do so, click Edit ( ). The Trends widget screen appears.
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l

l

Report Type. Report types are:
o Most Viewed (default)
o

Most Emailed

o

Most Commented

o

Highest Rated

Number of days to report. The number of days for which to display the data.
The default is 7.
o The current day is not counted, since it is incomplete. So if you enter 1, you
see information for all of yesterday and today.
o

The date calculation is based on the clock on the website's server.

NOTE: You can change to any number you wish. However, the widget only
shows data for days for which data is stored in your database.
l

Order Direction. The direction in which search results are sorted. The default is
Descending.
o Ascending. Alphabetical results from A to Z; numeric values low to high;
dates from oldest to most recent
o

l

Descending. Alphabetical results from Z to A; numeric values high to low;
dates from most recent to oldest

Maximum Number of Items. Enter the maximum number of content items that
may appear on the Trends widget. The default is 5. The Ektron database maintains
a count (number of hits) for each content item, for each date. When you select a
number of days, the Trends widget displays the content with the most hits during
that date range, up to the number you set in this field.
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l

Filter By. You can filter which content appears on this widget by selecting a folder
or a taxonomy.

While selecting a folder/taxonomy category, you have the option to include all
folders/categories under the selected one. If you later want to remove this
restriction, click Delete (

)

Business analytics API
The Business Analytics API's namespace is
Ektron.Cms.Framework.Analytics.BusinessAnalytics and consists of several static
methods arranged into 2 groups:
l

those that save events to the database

l

those that retrieve the event data from the database for use in reports

NOTE: The demonstration code in this section uses C# syntax.

Saving event data
The following illustration depicts saving event data to the database.
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To save events, use the static class EventLogger, which exposes the following
methods.
l

IAnalyticsEventData CreateAnalyticsEventData()

l

void Log(IAnalyticsEventData eventObject)

l

void Log(string eventName)

l

void Log(string eventName, string xml)

l

void Log(string eventName, string xml, int count)

The following image shows the EventLogger class.

Ektron Reference

549

Analyzing websites

As long as an event (myEvent) has been registered in the system, you can store an
event like this:
using Ektron.Cms.Framework.Analytics.BusinessAnalytics;
…
EventLogger.Log(“myEvent”);

This code saves the event data with default values. As shown, the Log method has
several overloaded versions. Each provides a different amount of control over the
information saved to the database. The following list shows the Log method's
parameters.
l

eventName (String). A name that uniquely identifies the event. This name must
be registered and enabled in the database for it to be recorded.

l

XML (String). This parameter is purely for customization. By default, its value is
null. The API stack passes the string to the database, where the appropriate stored
procedure can use it. For example, it can store additional values that are not part of
the current event-object

l

count (Integer). Allows increments other than the default value of one. For
example, you may want a specific event to increment the event counter by 5.

In addition to the parameters listed above, you can set other values by referencing the
event object that carries the information to the database. A call to
CreateAnalyticsEventData returns this object, and can be used as follows:
IAnalyticsEventData eventObject = CreateAnalyticsEventData();

Through the interface IAnalyticsEventData, the object provides the following
additional parameters, which allow more control over what information is saved with
the event.
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l

ObjectId (Long). For a content related event, ObjectId should be set to a Content
ID.

l

LanguageId (Integer). The content object's Language ID. If that is not available,
the current request's Language ID.
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l

SiteId (Long). The current request's Site ID
NOTE: A value of -1 means this value has not been set, and will be updated
appropriately at a lower level.

l

UserId (Long). The current request's User ID (if logged in)

l

VisitorId (String). The current request's Visitor ID (if not logged in)

l

EventDate (DateTime). Defaults to current date and time

Retrieving event data
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This illustration depicts retrieving that data into reports.

Use the static class EventReporter to retrieve events stored in the database. This class
exposes the following methods.
l

IList<string> GetReportNameList()

l

IAnalyticsQueryRequest CreateQueryRequest()

l

IContentQueryRequest CreateContentQueryRequest()

l

IList<IAnalyticsEventItem> GetList(IAnalyticsQueryRequest
queryRequest)

l

IList<IContentEventItem> GetList(IContentQueryRequest queryRequest)

l

void UpdateReportData(String eventName, DateTime eventDate)

The EventReporter classes are illustrated as follows.
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GetReportNameList method
Use the GetReportNameList method to obtain a list of recognized (e.g., registered)
report names. You can extend this list by adding custom event types and their
corresponding stored procedure handlers.
For example, to obtain a list of the allowed report names, use the following code.
using Ektron.Cms.Framework.Analytics.BusinessAnalytics;
...
IList<String> names = EventReporter.GetReportNameList();

CreateQueryRequest method
Use the CreateQueryRequest method to specify an event data report of the base-level
type. The method returns an object that implements the interface
IAnalyticsQueryRequest, which has the following parameters.
l

ReportName (String). Uniquely specifies the report, which is registered and
corresponds to one or more stored procedures which, when run, generate the
requested data.

l

SiteId (Long). The Site ID of the data being returned.

l

UserId (Long). The User ID of the data being returned.

l

EventStartDate (DateTime). If desired, use to determine the earliest date for
which report data is returned. By default, data from the earliest date is returned.

l

EventEndDate (DateTime). If desired, use to determine the latest date for which
report data is returned. By default, data through the most recent date is returned.

l

PagingInfo (Ektron.Cms.PageingInfo). Page size and number let you display a
small portion of the report at a time. By setting page size and number, the report
data is reduced, and performance will improve. Conversely, performance degrades
as page size (RecordsPerPage) increases, especially if the amount of stored data is
large. This type has the following fields:
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o

CurrentPage

o

EndRow

o

RecordsPerPage

o

StartRow

o

TotalPages

o

TotalRecords

l

OrderByDirection (EkEnumeration.OrderByDirection). Descending or Ascending

l

XML (String). This parameter is purely for customization. By default, its value is
null. While saving event data, the API stack passes the string to the database,
where the appropriate stored procedure can use it. For example, it can store
additional values that are not part of the current event-object. Within the
CreateQueryRequest method, this parameter can returns that string.

CreateContentQueryRequest method
Use the CreateContentQueryRequest method to specify a report of event data that is
related to content. It returns an object that implements the interface
IContentQueryRequest which, in addition to those provided by interface
IAnalyticsQueryRequest (see CreateQueryRequest method on the previous page) has
the following parameters.
NOTE: You can use either the FolderID or the TaxonomyID parameter but not both.
Also, you can only use the IncludeChild parameter related to the selected parent
parameter.
l

LanguageId (ID). The Language ID of the content that the report returns.

l

FolderId (Long). The folder of the content being returned. All content in the folder
is returned. It defaults to that of the current HTTP request.

l

IncludeChildFolders (Boolean). Determines whether the report includes children
of the folder specified in the FolderID parameter.

l

TaxonomyId (Long). The taxonomy category of the content being returned. All
content to which the category is applied the folder is returned. It defaults to that of
the current HTTP request.

l

IncludeChildTaxonomy (Boolean). Determines whether the report includes
children of the folder specified in the FolderID parameter.

GetList method
There are 2 versions of the GetList method.
One version takes an IAnalyticsQueryRequest object, and returns a list of objects
that implement IAnalyticsEventItem. That version has the following parameters.
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l

ID (Long). The object Id s supplied when the related events were saved.

l

XML (String). This parameter is purely for customization. By default, its value is
null.
While saving event data, the API stack passes the string to the database, where
the appropriate stored procedure can use it. It can store additional values that are
not part of the current event-object.

The other version of the GetList method takes an IContentQueryRequest object and
returns a list of objects that implement the interface IContentEventItem. That
provides the following parameters in addition to those of IAnalyticsEventItem
(shown above).
l

LanguageId (Integer). The Language ID of the content that the report returns.

l

Quicklink (String). The object's URL.

l

Title (String). Determines whether the report includes children of the folder
specified in the FolderID parameter.

l

Teaser (String). The content summary.

l

Status (String). The content's status. See also: Content statuses on page 681

l

FolderID (Long). The FolderID of the content being reported.

l

Count (Integer). The count of the object being reported. For example, if you are
retrieving the most frequently emailed content item, the count is the number of
times it was emailed. The count and average values may be used individually or
together, depending on the report. For example, the rating report returns both the
average (rating) and the count (the number of ratings), while the commented
report uses only the count.

l

Average (Decimal). The a numerical value divided by the count. For example,
when Ektron calculates average content rating, it divides the total number of rating
points (on a scale of 1 thru 10) by the number of votes.

UpdateReportData method
This method tells the database that an event's details should update that event's
aggregated data. This method is only required if the database does not automatically
do this, such as when the corresponding bit is disabled for that an type in the database.
Disabling the corresponding bit generally improves performance, especially if the event
logging rate is high. But, if you disable the corresponding bit, you must call this update
method if you want the report to show current data.
The UpdateReportData method takes the following parameters.
l

eventName (String). The event whose data will be updated.

l

eventDate (DateTime). The date of the event's occurrence. For example, if you
pass 1/1/2009, one row in the aggregate table is updated. If the row does not
exist, it gets created. If you do not pass an event date, this method updates the
aggregate table with summary info for that event for all dates. For example, if
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today is February 1, the system has been in use since the beginning of the year,
and you pass NULL for the date, 32 table rows are updated (31 days in January plus
2/1).

Disabling the saving or reading of events
You can disable the saving or reading of all events or of individual events.
It is useful to disable events when you want to minimize database traffic. To disable all
events:
1. Open siteroot/web.config.
2. Set the following parameters to false.
<!-- Enable saving business-analytics events to the database
(at API level) -->
<add key="ek_enableBusinessAnalyticsEventStorage" value="false"/>
<!-- Enable querying the database for business-analytics events
(at API level) -->
<add key="ek_enableBusinessAnalyticsEventReports" value="false"/>

NOTE: These settings are set to enabled (true) by default.
You can also enable or disable individual events in the database itself, but this does
require a call to travel through the full stack.

Using a custom provider
Providers that read and write event data are located under the service level. Default
providers pass calls through to standard Ektron database-access-level code, which
reads and writes from the database. You can modify this behavior to almost any
conceivable alternative. For example, you can
l

save data to an alternate database on an alternate machine.

l

call Web services to handle reads and writes.

l

filter the data and/or requests.

l

process information on its way to or from the database.

The SDK contains sample providers, as well as full source code for Ektron-supplied
providers. You can use this material as a basis for writing custom providers, which is the
preferred technique for customizing the behavior of the Business Analytics API stack
and subsystem.
The default providers for saving and reading event data (respectively) are
EktronEventProvider.cs and EktronQueryProvider.cs. Example custom-provider
source code has the following names for saving and reading event data (respectively):
DemoEventProvider.cs and DemoQueryProvider.cs. For the default providers, the
siteroot/web.config file must contain the following, inside
<configuration><configSections>.
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<section name="businessAnalyticsQueryProvider"
type="Ektron.Cms.Analytics.Providers
.BusinessAnalyticsQueryProviderConfiguration,
Ektron.Cms.BusinessObjects"
allowDefinition="MachineToApplication"
restartOnExternalChanges="true"/>
<section name="businessAnalyticsEventProvider"
type="Ektron.Cms.Analytics.Providers
.BusinessAnalyticsEventProviderConfiguration,
Ektron.Cms.BusinessObjects"
allowDefinition="MachineToApplication"
restartOnExternalChanges="true"/>

Additionally, the following must exist inside the <configuration> tags.
<businessAnalyticsQueryProvider
defaultProvider="EktronBusinessAnalyticsQueryProvider">
<providers>
<add name="EktronBusinessAnalyticsQueryProvider"
type="Ektron.Cms.Analytics.Providers.EktronQueryProvider,
Ektron.Cms.BusinessObjects"/>
</providers>
</businessAnalyticsQueryProvider>
<businessAnalyticsEventProvider
defaultProvider="EktronBusinessAnalyticsEventProvider">
<providers>
<add name="EktronBusinessAnalyticsEventProvider"
type="Ektron.Cms.Analytics.Providers.EktronEventProvider,
Ektron.Cms.BusinessObjects"/>
</providers>
</businessAnalyticsEventProvider

Creating custom providers
To override the default Ektron provider with a custom provider:
1. Create a new solution with a project named CustomProviders.
2. Add the following references to the project.
l Ektron.Cms.BusinessObjects.dll
l

Ektron.Cms.Common.dll

l

Ektron.Cms.ObjectFactory.dll

3. Add files DemoEventProvider.cs and DemoQueryProvider.cs (from the Ektron
SDK).
4. Build.
5. Copy the CustomProviders.dll file to your Ektron site's bin file.
6. Update web.config by modifying the <configuration> section. Specifically, add
demo providers to the Business Analytics providers.
<businessAnalyticsQueryProvider
defaultProvider="DemoQueryProvider">
<providers>
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<add name="EktronBusinessAnalyticsQueryProvider"
type="Ektron.Cms.Analytics.Providers.EktronQueryProvider,
Ektron.Cms.BusinessObjects"/>
<add name="DemoQueryProvider"
type="Ektron.Cms.Analytics.Providers.DemoQueryProvider,
CustomProviders"/>
</providers>
</businessAnalyticsQueryProvider>
<businessAnalyticsEventProvider
defaultProvider="DemoEventProvider">
<providers>
<add name="EktronBusinessAnalyticsEventProvider"
type="Ektron.Cms.Analytics.Providers.EktronEventProvider,
Ektron.Cms.BusinessObjects"/>
<add name="DemoEventProvider"
type="Ektron.Cms.Analytics.Providers.DemoEventProvider,
CustomProviders"/>
</providers>
</businessAnalyticsEventProvider>

Running Ektron traffic analytics
To access a fully-developed, Web traffic analytics provider model, go to Workarea
> Reports > Traffic Analytics.
By linking to best-of-breed analytics software, such as Google, Webtrends, and
SiteCatalyst, your website’s information is integrated into Ektron's Workarea, and you
can view analytics from other Web Analytics providers.
IMPORTANT: No data is stored in Ektron; Ektron retrieves the analytics on demand
from Web Analytics providers.
By analyzing the user traffic coming to and interacting with your site, you can better
understand key elements of your Web presence. Traditional Web analytics packages
help you understand where your traffic is coming from, when traffic is occurring
(including high and low points), and which pages users are interacting with. But this
information is often isolated from Web content and, so, lacks the context needed to
take advantage of it.
You can place the Analytics Reports widget on your dashboard, so that you have instant
access. Also, the software is integrated into the content history, making your traffic
analytics more relevant because you can view what modifications were made, when,
and how they impacted traffic to that page. You can react immediately, restoring
content that performed better or changing current content to better reflect your goals.
Customer reporting, segmentation, and legacy data are easier to access, and Ektron
becomes the central hub for all of your website’s information, bringing it together so
that it is no longer siloed. Having all information in one place puts it in context, making
it easier to draw conclusions needed to optimize your Web presence.
PREREQUISITES
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l

To view Web traffic analytics, you must have an Ektron Professional or Enterprise
License.

l

Only the following users can view the Web Analytics data.
o Administrators group members
o

Administrators group members

Ektron’s Workarea provides customized reporting, reflecting exactly the information
you care about. The data can analyzed in many ways, such as:
l

number of visits per day

l

browser usage

l

visitor location

l

visitor language

l

top content

l

referring sites

When you set up Web Traffic Analytics, the Analytics Provider monitors every site visit.
In the Workarea, you can view this data from many perspectives.

Running Google Analytics
Google Analytics is an enterprise-class solution that gives you rich insights into your
website traffic and marketing effectiveness. Powerful, flexible, and easy-to-use
features let you see and analyze traffic data in an entirely new way. Google Web
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Analytics prepare you to write better-targeted ads, strengthen your marketing
initiatives, and create higher converting websites. Its main features are:
l

Advertising ROI. Measure the success of your display, search, new media, and
offline advertising efforts.

l

Cross Channel and Multimedia Tracking. Compare your site usage metrics
with industry averages and track Flash, video, and social networking sites and
applications.

l

Visualizing Data. Uncover trends, patterns, and key comparisons with funnel
visualization, motion charts, mapping, and more.

l

Customized Reporting. Create reports, dashboards, and segments that make
the most sense for your business.

l

Sharing and Communicating. Administration controls and email reports let you
share data across your organization.

l

Google Integration and Reliability. Google Web Analytics complements a suite
of related products, all running on the same world-renowned infrastructure that
powers Google.

For more information, see the Google Analytics home page, Configuring your Ektron
Site for Google Analytics.
BEST PRACTICE
See also the following recorded demonstration: Configuring Google Analytics
- Ektron Developer Office Hours; and Configuring your Ektron Site for Google
Analytics.

Deciding which Google Analytics version to use
Ektron supports Google Analytics versions 2.4 and 3.0. To compare versions, see
Migration Guide: Moving from v2.3 APIs to v2.4 & v3.0> Differences between v2.4
and v3.0.
You may use both versions. If you enable both, the Ektron Workarea displays a dropdown for choosing a provider. Data is the same for both providers if you use the same
Google analytics profiles.
IMPORTANT: If you will use Google’s Core Reporting API v3.0, Ektron supports the
ClientLogin and OAUTH 2.0 authentication. If you will use Google’s Core Reporting
API v2.4, Ektron only supports ClientLogin authentication.

Setting up Google Analytics
This section explains how to set up Google analytics. After you complete these steps,
Google begins tracking your entire website. Alternatively, you can track individual site
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pages (see Tracking a single page on page 577), or clicks by file type (see Tracking
clicks by file type on page 577).
PREREQUISITE

If you want to use OAuth2.0 authentication, follow the steps in Setting up
the OAuth2.0 authorization protocol for Google Analytics 3.0 on page 567
before beginning this procedure.
WARNING! Enabling the tracking code may cause a significant increase in CPU
usage.
1. Create a Gmail account (http://mail.google.com).
2. Sign up for Google Web Analytics (www.google.com/analytics/). When setting up a
Google Web Analytics profile for your site, you are assigned a profile ID and a User
Account. You need those to complete Step 8.
3. Open this Google Analytics help page: Migration Guide: Moving from v2.3 APIs to
v2.4 & v3.0.
4. Under "Create a Project in the Google APIs Console," follow steps 1 through 4. On
the API Access screen, under Simple API Access, click the Create new
Browser key button. Copy the new browser key. This will be your API key in Step
8.
5. On the server that hosts Ektron, go to C:\Program Files
(x86)\Ektron\CMS400vxx\Utilities\EncryptEmailPassword.exe.
6. Use that utility to encrypt the Gmail username and password that you obtained in
Step 1. Enter the full user name, including @gmail.com.
7. Open your siteroot/web.config file and find the AnalyticsDataProvider tag. If
you enable versions 2.4 and 3.0, edit the GoogleV3.0 and GoogleV2.4 tags.
<AnalyticsDataProvider defaultProvider="Google">
<providers>
<add name="GoogleV3.0"
type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProviderv3,
Ektron.Cms.BusinessObjects"
EmailAddress=""
KeyFilePassword=""
KeyFilePath="/Key/privateKey/xxxxxxxxx.p12"
Username=""
Password=""
ProfileId=""
SiteURL=""
UserAccount=""
Endpoint="https://www.googleapis.com/analytics/v3/data/"
ApiKey=""
CacheInterval="0"
GoogleAnalyticsTrackingCodePath="Analytics\template\googletrackingcode.ascx"
Version="3.0" />
<add name="GoogleV2.4"
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type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProvider,
Ektron.Cms.BusinessObjects"
Username=""
Password=""
ProfileId=""
SiteURL=""
UserAccount=""
Endpoint="https://www.googleapis.com/analytics/v2.4/"
ApiKey=""
CacheInterval="0"
GoogleAnalyticsTrackingCodePath="Analytics\template\googletrackingcode.ascx"
Version="2.4" />
</providers>
</AnalyticsDataProvider>

NOTE: If your web.config has several analytics providers and you want to
disable tracking for any of them, delete the value of the
GoogleAnalyticsTrackingCodePath property.
8. Complete each tag’s properties.
l name. The free text name of the site being tracked and the Google version.
You should use the site name followed by provider name and version. For
example, www.ektron.com-Google V3.0. When Workarea users view site-level
displays of Web Analytics data, they choose the site from a drop-down. If you
change the name, you must also change the <AnalyticsDataProvider
defaultProvider element to match the name.

NOTE: The following three fields are only used if you are using OAuth 2.0
authentication.
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l

EmailAddress. Enter the service account email address that you used to
register your site in the Google Console. For example:
111111111111@developer.gserviceaccount.com.

l

KeyFilePassword. Appears in the Download dialog that appears while
registering your site in the Google Console.

l

KeyFilePath. Enter the path to the privatekey file that you downloaded and
saved while registering your site in the Google Console.

l

Username. The Gmail username you encrypted in Step 6.

l

Password. The Gmail password you encrypted in Step 6.
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l

ProfileID. The Google Analytics Profile ID you obtained in Step 2. Another
way to find your ProfileID is
a. Log into https://www.google.com/analytics/.
b. Click Admin.

c. In the View column, select the account that you want to track. If you do
not see the account, create it.
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d. In the View column, under View Settings, locate the View ID.

l

SiteURL. Enter the current server's fully-qualified domain name. For instance,
if your site’s URL is http://hostname.domain.com, the SiteURL value should
be hostname.domain.com. Careful! Omit the leading http:// or https://.
NOTE: In an eSync environment, set the ProfileID to the analytics
account you wish to view. The SiteURL, however, should be the fullyqualified domain name of the current server.
For example, if you want to view production site analytics from your staging
URL, set SiteURL to the staging server's fully qualified domain name, while
ProfileID and Account ID point to your production server.
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l

UserAccount. The Google Analytics SiteURL you obtained.
NOTE: On your Google Analytics Settings page, the UA-xxxxxx-x string
next to your site domain is the Google UserAccount.
That string also appears on the Admin > Property> Property
Settings page.

NOTE: To track multiple providers or sites:
1. Copy the <providers> tag.
2. Paste it under the existing tag and above </AnalyticsDataProvider>.
3. Modify the elements.
l

API key. Insert the API key that you created in Step 4.

9. Within the web.config's <analyticsSettings> tags is a suppressBeacon element
that lets you track or suppress the tracking of users on your website. Many site
administrators do not want to track user behavior in Traffic Analytics reports, as it
corrupts the data. (This setting does not apply to Business Analytics.) See also:
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Analyzing websites on page 531. Possible values for this element are
l None. Track all users, including authenticated membership and Ektron users.
l

Members. Track unauthenticated and logged-in Ektron users only. Do not
track membership users.

l

Authors. Track unauthenticated and logged-in membership users only. Do
not track Ektron users.

l

All. Track unauthenticated users only. Do not track membership and Ektron
users.

10. Within the siteroot\web.config file, find the ek_AutoInsertBeaconScript.
Change its value to true.
11. Save web.config.
IMPORTANT: No server control is needed to track Web Analytics. After you
enable Web Analytics in the web.config file, the following JavaScript is
automatically added to each PageBuilder page and any site page that contains
an Ektron server control.
<%@ Control Language="C#"
AutoEventWireup="true"
CodeFile="googletrackingcode.ascx.cs"
Inherits="Analytics_Template_GoogleTrackingCode"
EnableTheming="false" EnableViewState="false" %>
<!-- Start Google Code -->
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount','<asp:literal id="GoogleUserAccount"
runat="server"/>']);
_gaq.push(['_trackPageview']);
<asp:literal runat="server" id="variables"/>
(function()
{ var ga = document.createElement('script');
ga.type = 'text/javascript';
ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
'http://www') + '.google-analytics.com/ga.js';
s.parentNode.insertBefore(ga, s);
var s = document.getElementsByTagName('script')[0];
}
)();
/* Start Track Event binding Code */
//
// extracted from
// http://runtingsproper.blogspot.com/
//
2009/12/how-to-automatically-track-events-with.html
//
// un-comment the following if you want Google Analytics to track your pdf
// download links on the website.
//$(document).ready(function () {
// TrackEventsForClicks();
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//});
//
//function TrackEventsForClicks()
//{
// TrackEventByFileExtension(".pdf");
//
// add your file extension here
//}
//
//function TrackEventByFileExtension(FileExtension)
// {
// $("a[href$='" + FileExtension + "']").click(function()
//{
// var fileURL = $(this).attr("href");
// _gaq.push(['_trackPageview', fileURL]);
// });
//}
/* End Track Event Binding Code */
</script> <!-- End Google Code -->

Setting up the OAuth2.0 authorization protocol for Google
Analytics 3.0
OAuth2.0, the next evolution of the OAuth protocol, lets you provide authorization
flows for Web applications, desktop applications, mobile phones, and so on. Google
APIs use OAuth 2.0 for authentication and authorization. Google has implemented an
OAuth2.0 for access to its resources from third-party applications, such as Ektron. It's
secured, so that the client need not share user credentials with third party applications.
See also: http://oauth.net/2/, https://developers.google.com/accounts/docs/OAuth2
Follow these steps to implement the OAuth2.0 authorization protocol for Google
Analytics 3.0.
1. Createa Gmail account. If you already created an gmail account to complete Step 1
of Setting up Google Analytics on page 560, enter that email address.
2. Sign up for Google Web Analytics (www.google.com/analytics/). When setting up a
Google Web Analytics profile for your site, you are assigned a profile ID and a User
Account. You need those to complete Step 15.
3. Open a browser and go to https://code.google.com/apis/console.
4. Click Create project.
5. In the left panel, click Services.
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6. Turn on Analytics API. Agree to terms of service.

7. In the left panel, click API Access.
8. Click the button Create an OAuth 2.0 client ID.

9. A pop-up window opens. Register your site information. In the Home Page URL
field, enter your website address. Click Next.
10. The Create Client ID screen appears. Choose Service Account and click Create
client ID.

568

Ektron 9.40 SP1

Setting up the OAuth2.0 authorization protocol for

11. The following screen appears. Click Download private key. Close the window.

12. A key file is downloaded. Keep it in a secure directory. The file contains a private
key that is unique per user. You need this information to complete Step 8 of Setting
up Google Analytics on page 560.
13. The next screen displays your Client ID, email address and public key fingerprints.
You need this email address to set up OAUTH in the web.config section (in Step
20).
14. Log into https://www.google.com/analytics/.
15. Click Admin.

16. In the Account column, select the account that you want to track. If you do not
see the account, create it.
17. In the Property column, click User Management.
18. Under Add permissions for, add the GA service email address generated in Step
13. For example: 111111111194@developer.gserviceaccount.com.
19. Open your site’s siteroot/web.config file and find the AnalyticsDataProvider
tag. If you enable version 3.0, edit the GoogleV3.0 tags.
<AnalyticsDataProvider defaultProvider="Google">
<providers>
<add name="GoogleV3.0"
type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProviderv3,
Ektron.Cms.BusinessObjects"
EmailAddress="" <!-- address comes from Step 13 -->
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KeyFilePassword="" <!-- Password is "notasecret" as shown in Step 11 -->
KeyFilePath="/Key/privateKey/xxxxxxxxx.p12" <!-- Replace sample path with actual
path -->
Username="" Password="" ProfileId=""
SiteURL="" UserAccount=""
Endpoint="https://www.googleapis.com/analytics/v3/data/"
ApiKey="" CacheInterval="0"
GoogleAnalyticsTrackingCodePath="Analytics\template\googletrackingcode.ascx"
Version="3.0" />
</providers>
</AnalyticsDataProvider>

NOTE: If your web.config has several analytics providers and you want to
disable analytic tracking for any of them, delete the value of the
GoogleAnalyticsTrackingCodePath property.
NOTE: To track multiple providers or sites:
1. Copy the <providers> tag.
2. Paste it under the existing tag and above </AnalyticsDataProvider>.
3. Modify the elements.
20. Complete each tag’s properties.
l name. The free text name of the site being tracked and the Google version.
You should use the site name followed by provider name and version. For
example, www.ektron.com-Google V3.0. When Workarea users view site-level
displays of Web Analytics data, they choose the site from a drop-down. If you
change the name, you must also change the <AnalyticsDataProvider
defaultProvider element to match the name.

l
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EmailAddress. OAUTH2.0 only—Enter the service account email address that
you used to register your site in the Google console. This address was created
in Step 13 above.
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l

KeyFilePassword. OAUTH2.0 only—Was displayed in the Download dialog
that appears while registering your site in the Google Console (step 10 above).

l

KeyFilePath. OAUTH2.0 only—Enter the path to the privatekey file that you
downloaded and saved while registering your site in the Google Console (step
10 above).

l

Username. non-OAUTH2.0 only—The Gmail username you obtained in Step
1.

l

Password. non-OAUTH2.0 only—The Gmail password you obtained in Step 1.

l

ProfileID. The Google Analytics Profile ID you obtained in Step 2.
Another way to get your Profile ID:
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a. Log into https://www.google.com/analytics/.
b. Click Admin.

c. In the View column, select the account that you want to track. If you do
not see the account, create it.
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d. In the View column, under View Settings, locate the View ID.

l

SiteURL. Your site root name. For example, you could set up one
<providers> tag for the developer.ektron.com site, and another for the
synergy.ektron.com site. The SiteURL needs to match the development site
URL when you test in your development environment. For example, if the site
path is http://MyDevMachine/default.aspx, the SiteURL is MyDevMachine.
If there is no match, the Google beacon is not inserted onto your page.

l

UserAccount. The Google Analytics SiteURL you obtained.
NOTE: On your Google Analytics Settings page, the UA-xxxxxx-x string
next to your site domain is the Google user account.
That string also appears on the Admin > Property> Property
Settings page.
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l

574

API key. non-OAUTH2.0 only—Insert the API key that was displayed in Step
12.
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21. Within the web.config's <analyticsSettings> tags is a suppressBeacon element
that lets you track or suppress the tracking of users on your website. Many site
administrators do not want to track user behavior in Traffic Analytics reports, as it
corrupts the data. (This setting does not apply to Business Analytics.) See also:
Analyzing websites on page 531. Here are the possible values for this element.
l None. Track all users, including authenticated membership and Ektron users.
l

Members. Track unauthenticated and logged-in Ektron users only. Do not
track membership users.

l

Authors. Track unauthenticated and logged-in membership users only. Do
not track Ektron users.

l

All. Track unauthenticated users only. Do not track membership and Ektron
users.
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22. Within the web.config's <appSettings> tags is an ek_AutoInsertBeaconScript
element that either tracks or suppresses tracking activity on your website. Change
its value to true.
23. Save web.config.
IMPORTANT: No server control is needed to track Web Analytics. After you
enable Web Analytics in the web.config file, the following JavaScript is
automatically added to each PageBuilder page and any site page that contains
an Ektron server control.
<%@ Control Language="C#"
AutoEventWireup="true"
CodeFile="googletrackingcode.ascx.cs"
Inherits="Analytics_Template_GoogleTrackingCode"
EnableTheming="false" EnableViewState="false" %>
<!-- Start Google Code -->
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount','<asp:literal id="GoogleUserAccount"
runat="server"/>']);
_gaq.push(['_trackPageview']);
<asp:literal runat="server" id="variables"/>
(function()
{ var ga = document.createElement('script');
ga.type = 'text/javascript';
ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
'http://www') + '.google-analytics.com/ga.js';
s.parentNode.insertBefore(ga, s);
var s = document.getElementsByTagName('script')[0];
}
)();
/* Start Track Event binding Code */
//
// extracted from
// http://runtingsproper.blogspot.com/
//
2009/12/how-to-automatically-track-events-with.html
//
// un-comment the following if you want Google Analytics to track your pdf
// download links on the website.
//$(document).ready(function () {
// TrackEventsForClicks();
//});
//
//function TrackEventsForClicks()
//{
// TrackEventByFileExtension(".pdf");
//
// add your file extension here
//}
//
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//function TrackEventByFileExtension(FileExtension)
// {
// $("a[href$='" + FileExtension + "']").click(function()
//{
// var fileURL = $(this).attr("href");
// _gaq.push(['_trackPageview', fileURL]);
// });
//}
/* End Track Event Binding Code */
</script> <!-- End Google Code -->

Tracking a single page
As an alternative to tracking your entire site, you can track individual .aspx pages. To
do that, follow these steps on every page you wish to track.
PREREQUISITE

You completed all steps in Setting up Google Analytics on page 560.
1. Open the siteroot/web.config file.
2. Find the ek_AutoInsertBeaconScript tag.
3. Set its value to false.
4. Save web.config.
NOTE: The previous steps disable the tracking code on your website.
5. Open Visual Studio.
6. Open the .aspx page to which you want to apply the tracking code.
7. In the Solution Explorer tree, go to
Workarea/Analytics/template/googletrackingcode.ascx.
8. Drag and drop that user control onto the page.
9. Assign EktronAnalyticsTrackingCode as the ID of the control.

Tracking clicks by file type
To track the number of times that files on your site (for example, PDFs) are accessed,
follow these steps.
PREREQUISITE

You completed all steps in Setting up Google Analytics on page 560.
1. Open the siteroot/web.config file.
2. Find the ek_AutoInsertBeaconScript tag.
3. Set its value to true.
4. Save web.config.
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5. Open Visual Studio.
6. Open the .aspx page to which you want to apply the tracking code.
7. In the Solution Explorer tree, go to
Workarea/Analytics/template/googletrackingcode.ascx.
8. Uncomment the following code.
/* Start Track Event binding Code */
//
// extracted from
// http://runtingsproper.blogspot.com
//
/2009/12/how-to-automatically-track-events-with.html
//
// un-comment the following if you want Google Analytics to track your pdf
//
download links on the website.
//$(document).ready(function () {
// TrackEventsForClicks();
//});
//
//function TrackEventsForClicks()
//{
// add your file extension here
// TrackEventByFileExtension(".pdf");
//
//}
//
//function TrackEventByFileExtension(FileExtension)
//{
// $("a[href$='" + FileExtension + "']").click(function() {
// var fileURL = $(this).attr("href");
// _gaq.push(['_trackPageview', fileURL]);
// });
//}
/* End Track Event Binding Code */

By default, the JavaScript tracks the opening of PDF files on your website. To add file
types, copy TrackEventByFileExtension(".pdf"); and paste it, and change the file
type as shown in the following example.
xfunction TrackEventsForClicks()
{
TrackEventByFileExtension(".pdf");
TrackEventByFileExtension(".png");

Google site reports
You can access site-level Google Analytics reports from within the Workarea by
selecting Reports > Traffic Analytics > Google.
NOTE: The following text was adapted from Google Analytics Help Center. Check
that site for additional details on the reports.
Google sites reports show direct traffic on left side, top content on the right.
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Search reports show terms used by site visitors to find content on your site. Note that
this data is not retrieved from Google Analytics. Instead, it is retrieved from Ektron’s
site search.
The following sections describe Google’s site-level reports.

Visitors
This report shows the number of new and returning visitors who came to your site and
how extensively they interacted with your content. This traffic overview lets you view
aspects of visit quality (i.e. average pageviews, time on site, bounce rate) and visit
characteristics (i.e. first time visitors, returning visits).

l

Locations. Countries of your site visitors.

l

New vs. Returning. The number of visitors to your site who are new or returning.
A high number of new visitors suggests that you are successful at driving traffic to
your site, while a high number of return visitors suggests that the site content is
engaging enough to keep visitors coming back. You can see how frequently visitors
return and how many times they return in ‘Recency’ report and the ‘Loyalty report’,
both under ‘New vs. Returning’ in the Visitors section.

l

Languages. Uses the language provided by the HTTP Request for the browser to
determine site visitors’ language. Values are given in 2- or 4-character language
code (for example, en-br for British English).
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This report captures the preferred language that visitors have configured on their
computers. Understanding who your visitors are is crucial to developing the right
content and optimizing your marketing spend. Many times, geo-location is not
enough. Many countries have diverse populations speaking different languages
which present important market targeting opportunities.
l

User defined. If you modified the tracking code to provide a user-defined
segment, this field identifies that segment by the string you provide when setting
up a user-defined segment.

Visitor trending

l

Visits. The number of visits your site receives is the most basic measure of how
effectively you promote your site. Starting and stopping ads, changing your
keyword buys, viral marketing events, and search rank influence the number of
visits your site receives.

l

Absolute Unique Visitors. The number of unduplicated (counted only once)
visitors to your website over the specified time period. A Unique Visitor is
determined using cookies.

l

Pageviews. The total number of pages viewed on your site. It is a general
measure of how much your site is used. It is more useful as a basic indicator of the
traffic load on your site and server than as a marketing measure.

l

Average Pageviews. Average pageviews is one way of measuring visit quality. A
high Average Pageviews number suggests that visitors interact extensively with
your site. A high Average Pageviews results from:
o Appropriately targeted traffic (that is, visitors who are interested in what your
site offers)
o

High quality content presented effectively

Conversely, a low average pageviews indicates that traffic coming to the site has
not been appropriately targeted to what the site offers or that the site does not
deliver what the visitor expected.
l
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Time on Site. One way of measuring visit quality. If visitors spend a long time
visiting your site, they may be interacting with it extensively. However, Time on
site can be misleading because visitors often leave browser windows open when
they are not actually viewing or using your site.
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l

Bounce Rate. The percentage of single-page visits (that is, visits in which the
person left your site from the entrance page).
Bounce rate is a measure of visit quality, and a high bounce rate generally
indicates that site entrance (landing) pages are not relevant to your visitors. You
can minimize Bounce Rates by tailoring landing pages to each keyword and ad that
you run. Landing pages should provide the information and services that were
promised in the ad copy.

Browser capabilities
Optimizing your site for the appropriate technical capabilities helps make your site
more engaging and usable and can result in higher conversion rates and more sales.

l

Browsers. The browsers that your visitors use.

l

Operating Systems. The operating systems that your visitors use.

l

Browsers and OS. The browser/operating system combinations that your visitors
use.

l

Screen Colors. The number of screen colors your visitors use.

l

Screen Resolutions. The screen resolutions that your visitors use.

l

Flash Versions. The versions of Flash that your visitors have installed.

l

JavaSupport. Whether Java is supported on your visitors' platforms.

Network properties
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l

Network Location. The internet service providers that your visitors use. This
report lets you track the internet service provider (ISP) domains to which the user
resolves.
The domain is determined by the internet service that owns the user's internet
protocol (IP) identifier.

l

Hostnames. Hosts from which people are visiting your site. Hostnames
sometimes provide insight into organizations that are interested in what you offer.

l

Connection Speeds. Connection speeds that your visitors are using. Optimizing
your site so that it loads quickly for most visitors can result in higher conversion
rates and more sales.

Traffic sources
This section provides an overview of the different kinds of sources that send traffic to
your site. The graph shows traffic trends; the pie-chart and tables show what is driving
the trends.
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l

Direct Traffic. Visits from people who clicked a bookmark to come to your site or
who typed your site URL directly into their browser. Direct traffic can include
visitors recruited via offline (i.e. print, television) campaigns.

l

Referring Sites. Externals sites from which visitors linked to your site.

l

SearchEngines. Visitors who clicked to your site from a search engine result
page.
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l

All TrafficSources. Visitors referred from search engines, sites, and tagged links.
The graph shows the overall trends while the table shows the specific sources (i.e.
search engines, sites, and tagged links) driving the trends.

l

Keywords. Compares traffic from search keywords to overall traffic to your site.

l

Campaigns. How people referred from your configured campaigns compare to the
“average” visitor to your site.
The graph shows overall trends, while the table lists each configured campaign.
Because all traffic in this report results from campaigns that you explicitly control,
you can use this information to add or delete campaigns, or to determine the
effectiveness of tests that you have set up using custom tags.

l

Ad Versions. Compares your AdWords ads (and configured campaigns in which
you use the “content” tag) against each other.
This report shows you which ad copy (in AdWords ads or in configured campaigns)
is most effective. Ads with high clickthrough rates show that the copy is effective at
getting the user to click, while high bounce rates, for example, indicate a need for
landing pages that are consistent with what the ad promises.

Content
This report provides an overview of pageview volume and lists the pages (Top Content)
that were most responsible for driving pageviews. You can also reach some useful
reports that reveal how users interact with your site and statistics related to how they
found your site in the first place.
NOTE: Content reports include a link icon (
) and a hyperlink. If you click the link
icon, you go to the page. If you click the hyperlink, you see a more detailed Analytics
report about that page.

l

Top Content. The most commonly viewed pages on your site, and how they are
used.
The table lists all pages which were viewed on your site. A high bounce rate
indicates a landing page that should be redesigned or tailored to the specific ad
which links to it. A high 'Time on Page' may indicate content that is particularly
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interesting to visitors. The significance of exits varies according to each page. For
example, it may be common for visitors to exit your site from a receipt or “thank
you” page because they have completed a conversion activity. In contrast, a high
number of exits from a non-goal page (from a funnel page, for example) may
indicate that the page is confusing or that it generates user errors.
l

Content by Title. The most commonly viewed groups of pages on your site
(grouped by title), and how they are used. This report provides the same
information in the “Top Content” report, but aggregated by title tag value.

l

Top Landing Pages. Data on how effectively your landing pages entice visitors to
click further into your site. You can lower bounce rates by tailoring landing pages to
their associated ads and referral links and placing a clear call-to-action on each
landing page.

l

Top Exit Pages. Pages from which people exit your site.
The significance of an exit rate varies according to each page. For example, it may
be common for visitors to exit your site from a receipt or “thank you” page because
they have completed a conversion activity. In contrast, a large number of exits
from a non-goal page (from a funnel page, for example) may indicate that the page
is confusing or that it generates user errors

Viewing Google segments
Google Analytics has an Advance Segments tool that lets you "slice and dice" your
Analytics data with great precision. Advanced segments let you choose what types of
visits you want to be considered when generating the data for a report." (source: About
Advanced Segments)
Google segments allow marketers using analytics reports to drill down to specific
classes, or segments, of site visitors, such as
l

Users

l

Sessions and visitors

l

Members and authors

This section explains how to select and view segments within Ektron.
NOTE: While you can view custom segments within Ektron, you must create them
within Google Analytics.
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1. Browse to a view of Analytics data. See also:
2. Click Segment (

).

3. The Segments screen appears. Select up to 4 segments to display.
4. The screen refreshes and graphs each segment in a different color. In the following
example, new visitors are graphed in blue and returning visitors are orange. Also,
the screen breaks down data by each segment.
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Running Webtrends analytics
Marketers today face a new set of challenges. With the explosion of new digital channels
such as social and mobile, it is even harder to understand customer behaviors and
optimize how to communicate with them. Both Webtrends Analytics On Demand and On
Premises deliver the industry’s most accurate picture of how customers interact with
your brand in the digital space.
Real-time data, intelligent alerts, and the ability to easily share information within your
organization means you empower your team to make smart and timely decisions based
on solid data. You'll find new opportunities, ensure conversions are on track and
respond to needs faster than ever before.

Setting up Webtrends analytics
PREREQUISITE
l

Webtrends On Demand 2.1 and 3

l

You have permission to edit files on the Ektron Web server.

To set up Webtrends Analytics to work with Ektron:
1. Create a Webtrends Account and create a tracking script.
a. Set up a Webtrends account: Webtrends Developer Network.
b. Webtrends sends you an account name, username, and password.
c. Log into Webtrends using this URL: Webtrends Developer Network Login.
d. Use your Webtrends account name, username, and password.
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e. From that page, follow this menu path: Administration> Application
Settings > Data Sources.
f. Click New. A Data Source Wizard screen appears.
l Enter a name for the data you will retrieve.
l

Select your server's time zone.

l

Click Next.

l

A summary of the information you entered appears along with a
Webtrends data collection server ID (DCSID) value.

l

Click Save. The Data Sources screen reappears with your new data
source.

g. Copy your Data Source ID number (DCSID), indicated in the following figure.
You will use this number in the next step.

2. Build the Tracking Files. In this step, you tell Webtrends the type of data you want
to track. Webtrends then generates files that track that data.
a. Open Webtrends' Tag Builder page: Webtrends Tag Builder
b. From the Data Sources screen, you can click Build Tag (Tracking Code).
c. Complete this page, which prompts you to identify which data Webtrends
should track.
d. Into the page's Webtrends data collection server ID (DCSID)field, paste
the number you copied in Step 1g above. For help completing the Tag Builder
page, click the information button in the top right corner.
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e. Click the Build Tag button. Webtrends generates files you will use to track
usage statistics. The Summary and Confirmation screen appears.
f. Click the Download tag button.
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g. Save the .zip file to your computer.
3. Copy Webtrends tracking files to Ektron. In this step, you replace the
Webtrends.html file in your Workarea folder with the one you downloaded, and
you replace the <div> tag in your Workarea's Webtrends.ascx file with the one in
the downloaded file of the same name.
a. Extract the .zip file you downloaded.
b. Open the folder that contains the extracted files.
c. Copy Webtrends.js.
d. Paste it into the site root\Workarea\Analytics\template folder. This
action replaces a file of the same name.
e. In the folder that contains the extracted files, open Webtrends.html.
f. Copy the following <div> tag.
<div><img alt="DCSIMG" id="DCSIMG" width="1" height="1"
src="http://statse.webtrendslive.com/dcs5jd1eg000000g8d40tx1df_5k2p
/njs.gif?dcsuri=/nojavascript&amp;
WT.js.No&amp;WT.tv9.3.0&amp;WT.dcssip=www.documentation.ektron.com"/>
</div>

g. In the site root\Workarea\Analytics\template folder, open
Webtrends.ascx.
h. Replace the <div> tag with the one you copied.
4. Update Ektron's web.config file. You must have permission to edit files on your
Ektron Web server.
a. Obtain a value for your web.config file's ProfileFileName property by going
to https://ws.Webtrends.com/v2/ReportService/profiles/?format=xml.
(Authentication required.)
l In the User name field, enter your account name\username that you
obtained.
l

In the Password field, enter your password. A screen displays your
Webtrends profile as follows.
<?xml version="1.0" encoding="utf-8" ?> —
<list> —
<ProfileDefinition>
<string name="ID">ABCD1234</string>
<string name="name">MyAnalyticsAccountName</string>
<decimal name="AccountID">234567</decimal>
<decimal name="TimeZoneID">-500</decimal>
</ProfileDefinition>
</list>

You will use the string name value (highlighted in red),
ProfileFileName property.
b. Open your siteroot/web.config file
c. Find the tag beginning with <add name="Webtrends".
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d. Replace the Webtrends tag's properties.
l Name. The name displayed on the report. If you have several accounts,
you can use names like these.
o Webtrends. developer.ektron.com
o

Webtrends. document.ektron.com

However, the value of this field for one analytics provider must match the
value of the <AnalyticsDataProvider defaultProvider> tag.
l

Type. Do not change.

l

Username, Password.
1. Go to C:\Program Files (x86)\Ektron\CMS400vxx\
Utilities\EncryptEmailPassword.exe.
2. Encrypt the Webtrends username and password you obtained.
3. Enter the encrypted values into these properties.

l

ProfileFileName. Enter the string name value you obtained.

l

SiteURL. Enter the URL visitors use to access your site. For example,
www.example.com.

l

UserAccount. Enter the account name you obtained.

l

Endpoint. The default endpoint value is
https://ws.Webtrends.com/v2/ReportService/. You only need to
update this value if you are not using the default Data Collection Server on
the Tag Builder page.

l

Cache Interval. Use to cache the Analytics provider's data. Enter a
number in seconds. The maximum 86400. Caching improves the
performance of the traffic report page.

l

AnalyticsTrackingCodePath. Do not change.

Displaying Webtrends site reports
You can access Webtrends analytics reports within the Workarea by selecting Reports
> Traffic Analytics > Webtrends.
Refer to the following WebTrends manual for information about specific reports:
Webtrends Administration User Guide> Chapter 32 : Webtrends Analytics Report
Library

Display options
Webtrends reports provide the following display options.
Data table
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Bar chart
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Heat map
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Pie chart
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From the pie chart, you can change the display to see percentages of the following
factors.
l

Visits

l

Page views

l

Average visit duration (minutes)

l

Single page view visits

l

Entry page visits

Running Adobe Analytics
Adobe Analytics® (formerly known as Omniture SiteCatalyst) provides marketers with
actionable, real-time intelligence about online strategies and marketing initiatives.
Adobe Analytics helps marketers quickly identify the most profitable paths through their
website, determine where visitors are navigating away from their site, and identify
critical success metrics for online marketing campaigns.
To set up and monitor Web traffic analytics using Adobe Analytics.
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1. Log onto site and generate tracking code.
a. Contact Adobeand set up an account to use Adobe Analytics.
b. Use the information Adobe provides (URL, username, password, and so on) to
log in to Adobe Online Marketing Suite.

c. Click Admin > Admin Console > Code Manager.

d. In the Select the type of code to generate drop-down, choose
Javascript.
e. In the Select a Report Suite that collects data for your website dropdown, choose a report suite you selected when setting up your Adobe
Analytics account.
f. In the Match the Character-Encoding of your website drop-down,
choose UTF-8.
g. In the Choose your Currency for Tracking Conversion drop-down,
choose your currency.
h. In the How many periods are in your domain name? drop-down, enter
the appropriate number. The screen shows an example.
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i. If your site uses SSL, check the box next to Use https:// instead of
http://?. See also: Setting up the certificate for IIS 7 on page 77.
j. Click Generate Code.
2. Copy the tracking code to sitecatalyst.ascx.
a. The Code Manager screen displays code to track analytics on your Ektron site.
Copy the code under the Page Code tab.

b. Open the following file:site
root\Workarea\Analytics\template\sitecatalyst.ascx.
c. Delete all text below the following line.
<%@ Control Language="C#"
AutoEventWireup="true"
CodeFile="sitecatalyst.ascx.cs"
Inherits="Analytics_Template_Adobe Analytics"
EnableTheming="false" EnableViewState="false" %>

d. Paste the code you copied in Step 1 into sitecatalyst.ascx, below the line
shown in step c.
e. Save sitecatalyst.ascx.
3. Copy the s_code.js file to Workarea folder.
a. Use the Code Manager screen's Code Archive Name field to assign a name
to the files you created in the previous step.
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b. Use the Code Archive Description field to assign a more detailed description
to the files you created in Business Analytics.
c. Click Save. Code Manager compresses the Page Code and Core JavaScript
files into a .zip file, and displays them under Saved Code.
d. Click Download next to the saved .zip file. You are prompted to download the
.zip file to your computer.
e. Click OK.
f. Open the downloaded .zip file.
g. Extract the s_code.js file to site root\workarea\analytics\template.
You may be prompted to confirm that you are overwriting a file of that name
already in the folder.
4. Update Ektron's web.config file.
PREREQUISITE

Your Adobe Analytics Web Services Username and Shared Secret. To obtain, log in
to Adobe Online Marketing Suite and click Admin > Admin Console > Company
> Company Home > Web Services.
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a. Open your siteroot/web.config file.
b. Find the tag beginning with <add name="SiteCatalyst".
c. Replace the Adobe Analytics tag's properties.
l Name. Do not change.
l

Type. Do not change.

l

Username, Secret.
1. Go to C:\Program Files (x86)\Ektron\CMS400vxx\Utilities
\EncryptEmailPassword.exe.
2. Encrypt the Adobe Analytics Web Services Username and Shared
Secret you obtained.
3. Enter the encrypted values into these properties.
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l

CompanyName. Enter the company name obtained from Adobe when
your account was created.

l

ReportSuiteID. Enter the ReportSuiteID obtained from Adobe when your
account was created.

l

SiteURL. Enter the site URL. For example, www.example.com.
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l

Endpoint. Enter your account's endpoint. You obtain one when you set
up your Adobe Analytics account. An endpoint looks like this:
https://api-sbx1.omniture.com/admin/1.2/rest/.

l

CacheInterval. You can use this field to cache the Analytics provider's
data. Enter a number in seconds. The maximum 86400 (24 hours).
Caching improves the performance of the traffic report page.

l

AnalyticsTrackingCodePath. Do not change.

Adobe Analytics reports
You can access site-level Adobe Analytics reports from within the Workarea by selecting
Reports > Traffic Analytics > Adobe Analytics.
NOTE: The descriptions were adapted from Adobe Analytics Analytics Help Center
(Adobe Marketing Cloud Sandbox Sign In). Check that site for additional details on
the reports.
l

Analyzing site statistics on page 537

l

Site content on the next page

l

Mobile on the next page

l

Paths on page 601

l

Traffic sources on page 582

l

Products on page 602

l

Visitor retention on page 602

l

Visitor profile on page 602

Site metrics
Page views
Displays the number of times your website pages were viewed for the selected time
period (hour, day, week, month, quarter or year). This report lets you track page views
for each individual page on your site, as well as an aggregate of page views for your
website as a whole.
Visits
Displays the number of visits made to your website during the selected time period.
Daily unique visitors
Shows the number of unique visitors to your site for a selected daily time frame. A
unique visitor is counted the first time he/she visits your site within the selected time
frame. If a visitor returns again to your site, they are not counted as a unique user
again until the selected time frame has passed.
Time spent per visit

Ektron Reference

599

Analyzing websites

Reveals the length of time visitors spend viewing your site as a whole during each visit.
It also has an Average Time Spent on Site statistic that shows the average time that
was spent viewing your site, taken across all visitors.

Site content
Pages
Ranks pages on your site based on those that receive the most traffic.
Site Sections
Shows the areas of your site that were visited most by your site customers. Site
Sections could include (but are not limited to) groups of products, similar to Categories.
Data for the Conversion Site Sections report is imported from the Site Section report in
the Traffic group, which receives its information from the channel variable in the Adobe
Analytics tracking code. You can use this report to identify the greatest impact on site
statistics from items in varying site sections.
Servers
Adobe Analytics lets you group pages together that are being hosted by a particular
server. For example, if you have a website that is hosted on two different servers, you
may want to see if one server is serving more impressions than the other server. This
report lists all of the servers of your website that are being tracked by Adobe Analytics
and tells you which servers are being accessed the most.
Exit links
Shows links that your visitors click to leave your site and go to another site. Exit links
are those links that take your visitor to another site. Most common examples of exit
links are links to partners, affiliates, and so on.
Custom links
Shows links your site visitors prefer, helping you better understand the navigation
patterns within your site.
File downloads
Displays files that have been downloaded from your website. These files can be any
type of document you wish to track, including user manuals, presentations, audio, or
video files. This report requires that link tracking code to be installed on the site you are
tracking.
Pages not found
Lists the number of times a Page Not Found (404- error) page appears to your site
visitors and lists the URLs of the pages that were not found.

Mobile
Mobile
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Several criteria about mobile devices visitors use to access your site, such as device
type, screen size, audio support, and so on.

Paths
Reloads
Shows the number of times individual pages were reloaded by page visitors.
Page depth
Identifies the depth at which each page within your site is visited. Depth for a page is
measured by counting the number of pages viewed before that page. So, if your "About
Us" page is the third page visited by a given visitor, its depth for that visit is 3. You can
use this report to identify which pages compel your visitors to travel the deepest into
your site and to optimize content and navigation to make key content more accessible.
Time spent on page
Displays the length of time that visitors browse individual pages in your site. The time
spent is divided into 10 categories: less than 15 seconds, 15-30 seconds, 30-60
seconds, 1-3 minutes, 3-5 minutes, 5-10 minutes, 10-15 minutes, 15-20 minutes, 2030 minutes and greater than 30 minutes.
Entry pages
Shows, by percentage and total visits, which pages on your site are the first ones seen
by new visitors.
Original entry pages
Shows the first page viewed of the first-ever visit to your site. Each user is counted only
once unless they delete their cookies or are not being tracked with cookie

Traffic sources
Search keywords—All, Paid
Displays a breakdown of each search keyword that has been used to find your site. You
can sort this list by page views or search keywords by clicking the column title above
the listing. Click on the blue magnifying glass next to each search keyword to see the
actual search results screens where your site was listed.
Search engines—All, Paid, Natural
Helps you learn which search engines people are using to find your Web page. The
graph shows you the percentage breakdown of the search engines that have been used
to find your site.
All Search Page Ranking
Shows the results pages on which your site links were located in the user's searches
that were performed. For example, a user who came to your site from a search engine
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may have seen you on the third of one hundred pages of results. This can help you
quickly see and optimize search engine efforts. Data for this report may be viewed for
all but the 'Hourly' time period.
Referring domains
Shows the domains that referred the customers that most impacted your site's Success
Metrics. Referrers fall into 2 main categories: Domains and URLs. Domains refer to the
domain name, and appear as the base domain without the query string or
subdirectories attached. URLs include the base domain name, as well as any query
strings or subdirectories.
Original Referring Domain
Shows the original referrers that produced the customers on your site. Customers can
visit your site multiple times, and have a different referrer for each visit. This report
shows how they were referred the first time they arrived at your site. This can help you
see if they continued to use the same referrer and view patterns in how customers are
referred to your site. You can view the number of visitors generated by an original
referrer or discover how much revenue each original referrer was responsible for
producing.

Products
Helps you identify how individual products and groups of products (categories)
contribute to your various conversion metrics, such as revenue or checkouts.

Visitor retention
Return frequency
Shows the number of visitors who returned to your site within one of the following
categories (representing the time lapse between visits): less than 1 day, 1-3 days, 3-7
days, 8-14 days, 14 days to 1 month and longer than 1 month.
Visit number
Provides another method for gauging visitor loyalty by displaying the visit number for
each visitor that comes to your site.

Visitor profile
Geosegmentation
l
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Countries. Shows countries from which visitors access your site. In addition to the
standard "Ranked" and "Trended" views available on most reports, there is also a
"Map" view that color-codes the countries according to their relative contribution to
your total traffic-the more intense the color the greater the number of daily unique
visitors from that country that are visiting your site
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l

Regions. Shows regions from which visitors access your site. To the right of each
region shown, the country of the region is also shown in parentheses. Clicking the
magnifying glass icon to the left of the region will open the line item in the Adobe
Analytics Cities Report. With this report, you can see how a selected region
performed compared to another on your web site.

l

State. The U.S. states from which visitors access your site.

l

Zip/postal code. Shows the zip and postal codes that produced the customers
that had the greatest effect on purchase success metrics.

l

Cities. Shows U.S. cities from which visitors access your site.

l

U.S. DMA (Designated Market Area). Shows the marketing areas within the United
States from which visitors access your site. By clicking the link next to State in the
Report Status header, you may restrict the report to marketing areas within a
particular state. This data is provided via a partnership between Omniture and
Nielsen Media Research, Inc. By clicking the Visitors Per Capita link next to Display
in the Report Status header, you can adjust the data by the relative population of
each marketing area. Enabling this option shows both the number of daily unique
site visitors per 10,000 people living in the market area as well as the percent
above or below the national average value. You can also generate a Correlation
report by clicking the Correlation icon next to one of the market areas and
selecting the item with which you want to correlate the data.

l

Visitor Home Page. Another method of gauging visitor loyalty and assessing the
perceived value your visitors place on your website's content. The report shows
how often your visitors mark a page on your website as their 'Home Page' in their
browser.

l

Language. Displays your visitors' preferred languages. The Languages Report
captures the default browser language and displays those most used by visitors to
your site.

l

Time zone. Displays the time zones your visitors are located in when they view
your site. This report superimposes a bar graph (indicating the number of visitors)
on a map of the world so you can quickly see what part of the world your visitors
are from.

l

Domains. Lists the organizations and ISPs your visitors use to browse your site.
This report differs from the Full Domains report in that the Full Domains report
registers the full ISP domain, whereas this report lists the secondary domain.

l

Top Level Domains. Identifies world regions that visitors come from, based on
their originating domain extension, and shows how many visitors come from these
countries. Domains ending in Commercial (.com), Network (.net), Education
(.edu), Government (.gov) and Organization (.org) are usually based in the United
States, and are listed separately from the rest of the domains.

Technology
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l

Browsers. Identifies the types and versions of browsers that are used by your
visitors.

l

Browser Type. Classifies the browsers visiting your site into their major families

l

Browser Width, Browser Height. Shows the most common widths or heights of
the browsers (in pixels) your visitors use to view your site.

l

Operating Systems. Shows which operating systems are being used by your site
visitors

l

Monitor Color Depth. Shows your visitors' most popular color-depth settings as
configured on their computer. Color-depth refers to the number of colors that can
be displayed on the screen.

l

Monitor Resolutions. Shows screen resolutions that visitors to your website most
commonly use, as configured on their computers.

l

Java, JavaScript. The JavaScript Version report displays the versions of
JavaScript your visitors' browsers use while viewing your site.

l

Cookies. Shows the percentage of visitors that prefer to use cookies while
browsing.

l

Connection Type. Displays the percentage of your site's visitors that utilize highspeed Internet connections versus slower dial-up connections.
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IMPORTANT: If you are using Internet Explorer 11, set the following parameters to
ensure optimum functionality.
1. Press Alt/X to display the Internet Explorer Tools menu.
2. Choose Compatibility View Settings.
3. Uncheck Display intranet sites in Compatibility View.
If you are using Internet Explorer 10, set the following parameters to ensure
optimum functionality.
1. Press F12. A settings menu bar appears at the bottom of the browser above the
tabs.
2. Set Browser Mode to IE10 (not Compatibility view).
3. Set Document Mode to Standards.
4. Click X to exit.
In several places within the Ektron Workarea, a rich-text editor appears. For example,
when creating or editing HTML content, the editor lets you apply text styling, insert
images and tables, and edit the content source. To access these functions, use the
editor toolbar.
In some editor locations, the toolbar "floats," and you can drag it to any screen location.
In other locations, the toolbar is fixed at the top of the editor. To change a fixed toolbar
so that it can float, see Detaching the editor's fixed toolbar on page 637
NOTE: If the editor toolbar is floating, you can place it anywhere on the screen and
make it stay by clicking on the pin icon ( ). When pinned, the icon changes ( ).

The editor toolbar consists of tabs with buttons. A system administrator can customize
the toolbar options depending on the context. For example, he may want the Inspector
available when editing content in the Workarea but not while editing "in context." For
information about customizations, see Customizing the editor on page 637 and
Modifying editor plug-ins on page 637.

Editor toolbar options
This section describes each button on the editor toolbar, which is organized into 3 tabs.
For documentation of additional buttons and tabs available when editing content, see
Creating new content on page 684.
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Format Tab

NOTE: Customizing the editor's toolbar buttons on page 641 explains how an Ektron
administrator may change the toolbar options.

Format Tab
l

—Bold (Ctrl/b). Make selected text bold.

l

—Italic (Ctrl/i). Make selected text italic.

l

—Superscript. Make selected text appear smaller and above text line.

l

—Subscript. Make selected text appear smaller and below text line.

l

—Add Hyperlink. Add information about a hyperlink. See Working with links on
page 610.

l

—Display bubble text on content. See Displaying bubble text on content on
page 631.

l

—Number. Begin the line on which the cursor rests with a number. If the line
above this line is:
o not numbered, assign this line 1.
o

numbered, assign a number one more than the line above.

NOTE: The Number button applies a number to each paragraph. To switch to
regular paragraphs, click the button a second time.
l

—Bullet. Begin the line on which the cursor rests (or all selected lines) with a
bullet.
NOTE: The Bullet button applies a bullet to each paragraph. To switch to
regular paragraphs, click the button a second time.
—Formatting toolbar. Lets you format

l

selected text.
—Styling toolbar. Lets you apply styling to
l

selected text. See also: Applying styles on the next page

Insert tab
l

l

. Insert library file. See Working with files in the library on page 733.
. Insert template. See Using a template to structure content on page 633.
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l

l

. Insert external content (such as a video). See Editing in Ektron on
page 605Embedding external content on page 626
. Insert a table. See Working with tables on page 616.

l

. Insert symbols and special characters.

l

. Add a hyperlink. See Working with links on page 610.

l

. Add a bookmark. See Adding a bookmark on page 615.

l

l

. Display bubble text on content. See Displaying bubble text on content on
page 631.
. Insert horizontal line.

Review tab
l

Inspector. apply properties to selected content. See Applying refinements with
Inspector on page 610.

l

. Validate content against selected guidelines. See Validating content on
page 633.

l
l

. Translate content. See Translating content on page 635.
. View content source. See Viewing and editing HTML source content on
page 631.

Editor notes
l

Cut, copy, and paste are accessible through your browser. Right-click to choose
them or use keyboard shortcuts. The editor may modify pasted content, depending
on tags that an administrator sets in StyleConfig.js. For example, headings,
bullets, and bold fonts may be maintained during a paste operation, but the actual
font may not. See also:Creating styles and classes on page 643.
IMPORTANT: When you paste content from another application, the editor
formats that content into valid, minimal HTML and retains as much formatting
and styling as possible. However, results are browser-dependent.

l

Paste HTML content into the Source Viewer. See also: Viewing and editing HTML
source content on page 631.

l

Your browser checks spelling. If your browser does not support it, find and install a
plug-in to do it.

NOTE: If you apply the Span style, you can select it in the Inspector to enter style
modifications.

Applying styles
To apply inline styles or style classes to text, use the styling toolbar.
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You can select paragraphs or words, then use styling toolbar buttons to style the
selected text. Click the down arrow in the toolbar's lower right to view additional
buttons. Styling buttons are context-sensitive, so they vary according to cursor
location, which format toolbar button is selected, and whether any text is selected.
Place the cursor anywhere inside a paragraph to select it.
For example, within the editor, select the text critical issue and click Span (
Next, open the styling toolbar, and click one or more buttons to apply styling.

).

To modify the style buttons, an Ektron administrator modifies the styleconfig.js file,
as described in Creating styles and classes on page 643.
BEST PRACTICE
To enhance your site's appearance, define a set of styles from which content
authors can select, instead of letting authors apply styling as needed.

Removing styling from text
To remove styling from text:
1. Select the text to which the styling is applied.
2. Click the down arrow in the toolbar's lower right.
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3. Click Remove styling.

Applying refinements with Inspector
Use the Inspector to perform advanced actions on content items (images, hyperlink,
paragraphs, and so on). If enabled, the Inspector button appears on the Review
toolbar tab. Click to open the Inspector dialog, set values, then click the exit button.

NOTE: If you apply the Span style, you can select the affected content in the
Inspector to enter style modifications.
The Inspector lets you apply additional properties to the selected element.

Working with links
This section explains how to view, insert, or delete links to an external Web site or email
address. To learn how to link to another Ektron content item, see Working with
quicklinks on page 614. To learn how to link to paragraph within an Ektron content
item, see Adding a bookmark on page 615.

Viewing a link
1. Click the cursor on the linked text or image.
2. Open the Inspector (Review tab > ) to view the link's properties.
610
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3. Use the dialog to modify the link's properties.

Inserting a link to text
1. Highlight text that you want to become a hyperlink.
2. Click Link ( ) on the Format tab. (If you click Link on an empty space, a link
appears in the content as New Link. Be sure to change New Link to something
meaningful.)

A link tab appears.

3. In the link field, enter the desired URL and press Enter. The selected text becomes
a hyperlink.
4. To enter link properties, select linked text and open the Inspector (Review tab >
).
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Alternatively, you can insert a mailto link. If you do, place the email address in the
email field, and optionally a default Subject.

You can set or modify these link properties within the Inspector.
l

Title

l

Target frame. See http://www.w3schools.com/tags/att_a_target.asp.

l

Text attributes and alignment

l

Css class and styles

Inserting a link to an image
To learn about inserting an image, see Inserting an image on page 623.
1. Click an image that you want to become a hyperlink.
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NOTE: You know that you selected an image if the Inspector displays an
<IMG> tag.

2. Open the Inspector (Review tab > ).
3. Click Add hyperlink to Image.
4. Click the <A> tag.

5. Enter hyperlink information. You can set or modify these link properties within the
Inspector.
l Title
l

Target frame. See http://www.w3schools.com/tags/att_a_target.asp.

l

Text attributes and alignment

l

Css class and styles

Editing a link
1. Click the linked item. The link destination appears in the toolbar.
2. Edit the link text as needed.

Removing a link
1. Click the linked item. The link destination appears in the toolbar.
2. Click Break Link (

). The link is removed.
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Working with quicklinks
A quicklink is a special hyperlink that "jumps" to content on your website. You can apply
a quicklink to text or an image. When a site visitor views the content and clicks the
quicklink, a new page appears, displaying the referenced content.

Adding a quicklink to content
1. Edit the content into which you want to insert the quicklink.
2. Place the cursor where you want the quicklink to appear. If you want to attach the
quicklink to text or an image, select it.
3. Click Insert > Library (

).

4. Go to the folder that contains the content whose quicklink you want to insert.
5. From the file types drop-down list, select Quicklinks. Quicklinks in the selected
folder appear.
6. Click the quicklink you want to insert.
7. Click Insert. The quicklink is added.
NOTE: If you do not select text or an image before inserting a quicklink, the
referenced content's title becomes the quicklink text.

Editing a quicklink
1. Place the cursor on the quicklink.
2. Open the Inspector (Review tab > ).
3. To change the link destination, click the Library button at the end of the URL field.
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4. To edit the link text, edit the Title field.

Deleting a quicklink
1. Click the quicklink. The link destination appears in the toolbar.
2. Click Break Link (

). The link is removed.

Adding a bookmark
Use a bookmark to let a site visitor “jump” from any word or phrase to another place in
the same content block. On your Web page, text appears in a different color to indicate
the bookmark.
Bookmarks are particularly helpful on a long page. For example, your Web page
contains minutes from several meetings, and the top of the page lists meeting dates.
You could assign a hyperlink to each date, and a bookmark to each set of minutes. A
site visitor can click any date to “jump” (using the bookmark) to those minutes.
To use a bookmark, you create 2 things:
l

A source. Text a user clicks to jump to the bookmark

l

A destination. The location to which the cursor jumps when the source is clicked

For example, place the text [ Top ] [ Bottom ] at the top and bottom of a content
block. The following procedure shows how to create bookmarks so that clicking [ Top ]
at the bottom of the page jumps to the top of the page, and clicking on [ Bottom ] at
the top of the page jumps to the bottom of the page.
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1. Create the bookmark's (destination).
a. At the bottom of the page, insert then highlight the destination text, in this
case [ Top ].
b. On the editor toolbar, choose Insert > Bookmark ( ). A bookmark icon
displays next to the source text but does not show up on the Web page.
c. Double click the bookmark icon then open the Inspector (Review tab > ). A
dialog displays the bookmark options.
d. Specify the title, PageTop.
e. Repeat steps a through d for [ Bottom ] at the bottom of the content, and
give it the Title of PageBottom.
2. Create links to the bookmarks.
a. Highlight the source text. In this example, [ Top ] at the bottom of the
content.
b. Choose Format > Insert Link (

). The text is selected.

c. Double click the selected text.
d. Open the Inspector (Review tab > ).
e. Choose Existing Bookmark. A drop-down list appears from which you can
select a bookmark.
f. Choose PageTop from the drop down list.
g. Repeat steps a through d for [ Bottom ] at the top of the content, and choose
PageBottom from the drop-down list.

Working with tables
This section describes how to insert and edit tables.

Inserting a table
1. From the toolbar's Insert tab, click Table (

). A table dialog box appears.

2. Drag the cursor over rows and columns to indicate the table size. The following
example shows 5 columns and 5 rows.
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3. Click the mouse. The table is inserted.

NOTE: You can use Tab to move from one cell to the next. If you are on the last cell,
Tab creates a new row. Use Shift/Tab to move backwards.

Applying table properties
Use the Inspector (Review tab > ) to apply properties to a table, a table row (TR), or a
single cell (TD).

l

table properties. http://www.w3schools.com/tags/tag_table.asp

l

tbody properties. http://www.w3schools.com/tags/tag_tbody.asp

l

table row (TR) properties. http://www.w3schools.com/tags/tag_tr.asp

l

table cell (TD) properties. http://www.w3schools.com/tags/tag_td.asp

Adding a table summary
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1. Place the cursor inside the table. In the toolbar, the Table tab is selected.
2. Enter the summary in the text box (circled in the following image).

Alternatively, you can enter a table summary in the Inspector (Review tab > ).

Adding a table caption
1. Place the cursor inside the table. In the toolbar, the Table tab is selected.
2. Click Table Caption (

).

3. Enter the caption in the textbox above the table.

Alternatively, you can enter a table caption in the Inspector (Review tab > ) .

Modifying rows and columns
Click the gray area beside a table row or above a table column. Your selection is
highlighted.

You can use the following functions on selected rows or columns:
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l

. Add column to the left

l

. Add column to the right

l

. Add row below

l

. Add row above

l

. Delete column

l

. Delete row

l

. Format column as header (create a 508-compliant table without modifying the
source)

l

. Format row as header (create a 508-compliant table without modifying the
source)

l

. Merge cells (to select several cells, depress Shift while selecting)

l

. Split cells (depress Shift while selecting the cell to be unmerged)

IMPORTANT: When you save and publish your content, your site styling is applied.
Therefore, a table in the Workarea may appear differently from a table you edit in
context.
Table with merged cells

NOTE: To split a merged cell, select the column or row of the merged cell before
clicking Split.

Modifying a table style
With the Inspector open, click anywhere in a table to view styles and advanced
properties you can apply.
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In the following example, a 3x3 table was created. Clicking in a cell, the nested tag
structure shows the following:

Click any tag to see styles you can apply to it. For example, click
properties. The following image shows the table size reduced to 25%.
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to see table

Moving a table

l

table properties. http://www.w3schools.com/tags/tag_table.asp

l

tbody properties. http://www.w3schools.com/tags/tag_tbody.asp

l

table row (TR) properties. http://www.w3schools.com/tags/tag_tr.asp

l

table cell (TD) properties. http://www.w3schools.com/tags/tag_td.asp

Moving a table
When you make a table the content focus (a colored bar appears around the table), a
tab appears above the table's left top corner. Use the tab to drag the table to another
place in your content.
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NOTE: You can also move a table in Source Viewer.

Deleting a table
1. Select the table.
2. Click the handle.

3. Press Delete.
NOTE: You can also delete a table from Source View, and easily collapse the entire
table to delete it in one line of HTML.

Working with images
The easiest way to insert an image into content is by dragging and dropping it from a
Windows Explorer window. You can also
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l

insert an image that has been saved to the Library or as an asset, or

l

add a new image to the Library while inserting it into content
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Inserting an image
Inserting an image using drag and drop
You can drag-and-drop an image from your computer into Ektron content using
Windows File Explorer. You can drag and drop only one image at a time.
Dropped images are added to the library for future reuse. Dropped images must have
one of these extensions: .jpg, .gif, or .png, and cannot exceed 5 MB.
When dragging and dropping, the file name becomes the item's title, and no other
library information is collected (for example, its summary and metadata). Once the
content is saved, use the Edit Library screen to add information for the new library
item.

Inserting an image using the library
1. Place the cursor where you want the image to appear.
2. Click Library (

). The Library screen appears.

3. From the left panel, go to the folder containing the image you want to insert. If you
do not know its folder, use Search ( ) to find an image by title, description, or
internal file name.
NOTE: If the file is not in the library, you can insert it by clicking the Add
Library button > Browse and navigating to the file. Then, enter a title and
optionally a description and metadata information. The file is inserted into the
content and added to the library.
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4. Select Images from the content type drop-down.

5. Select an image and click Insert (
can also double-click the image.)

). The image is inserted into the content. (You

Alternatively, you can insert a miniature version of the image, called a thumbnail,
by clicking the thumbnail button ( ). When the thumbnail appears on a Web
page, a site visitor clicks it to view a full-sized image.

Editing images
To adjust an image's properties, click to select it then open the Inspector (Review tab
> ). If you are using the Internet Explorer browser, double click the image.
NOTE: You will know that you selected an image if the Inspector displays an
<IMG> tag.

The Inspector’s Advanced tab lets you modify the image size, position, wrapping, and
so on, and lets you select images that change based on breakpoints for viewing modes
of your users. See Adding a group by breakpoint on page 513.
For example, click Responsive Image Selection > Change and select an image to
display when screen resolution is 480 pixels or fewer.
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If you reduce the size of the editing window to under 481 pixels, the editor
automatically switches to the smaller picture.

Adjusting image size
Within the Inspector, the Basic and Advanced tabs have a field for adjusting image size.
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l

Basic tab—Use the Size slider to specify a percentage of the original image. The
Size is calculated as pixels and stored in the <img> tag as a style attribute.

l

Advanced tab—the Size > Width field represents a percentage of the parent
container. This number is stored in the <img> tag as is.

Deleting an image
1. Select the image.
2. Open the Inspector (Review tab > ).
NOTE: You know that you selected an image if an <IMG> tag appears in the
Inspector.

3. Click Delete image.
Embedding external content

Embedding external content
You can embed the following types of external content into the editor.
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l

YouTube

l

Vimeo

l

DailyMotion
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l

Google Maps

l

any Iframe

You can also insert content using its <embed> or <object> code.
Embedded elements are treated responsively. This means that a video or map is sized
according to the device on which it is viewed.
PREREQUISITE

You need the URL of the media item that you want to embed. Content
providers typically supply an easy way to find the content's URL. For
example, to find a YouTube video, click Share, then copy the URL.

1. On the editor toolbar, click the Insert tab then Insert Embedded Media (
The Insert Embedded Media screen appears.

).

Ektron Reference

627

Editing in Ektron

2. Use the Select the Media Source pulldown to select a media source.

3. Insert the URL for the content that you want to embed.
To embed content from another source, choose Other in the Select the Media
Source pulldown, then insert the code. See also: Tips for embedding a Google map
on the facing page.
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4. Click Embed. The media is embedded in the content.

Tips for embedding a Google map

Tips for embedding a Google map
Click the Share link. Then copy the text in the Paste HTML to embed in website
field and paste it into the Embed Source field.
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To modify the map before inserting it, click the Customize and preview embedded
map link. You can change the size, view, and zoom. When finished, copy the HTML from
the bottom of the screen and paste it to the Embed Source field.

Removing external content
1. On the Review tab, click the View Source button (

). Source Viewer appears.

2. Find and delete content between the opening and closing <div class="embedcontainer> tags that surround the video, as shown in the following example.
<div class="embed-container">
<iframe marginheight="0" marginwidth="0"
src="https://maps.google.com/maps?f=q&amp;source=s_q&amp;
hl=en&amp;geocode=&amp;q=542+Amherst+Street,+Nashua,+NH&amp;aq=0&amp;oq=542&amp;sll
=42.752811,
71.49671&amp;sspn=0.203443,0.308647&amp;ie=UTF8&amp;hq=&amp;hnear=542+Amherst+St,+N
ashua,+New+Hampshire+03063
&amp;t=h&amp;ll=42.796156,71.573181&amp;spn=0.120922,0.219727&amp;z=12&amp;iwloc=A&amp;output=embed"
frameborder="0" height="480"
width="640"></iframe>

scrolling="no"

<br/><small><a href="https://maps.google.com/maps?f=q&amp;
source=embed&amp;hl=en&amp;geocode=&amp;q=542+Amherst+Street,
+Nashua,+NH&amp;aq=0&amp;oq=542&amp;sll=42.752811,71.49671&amp;sspn=0.203443,0.308647&amp;
ie=UTF8&amp;hq=&amp;hnear=542+Amherst+St,+Nashua,+New+Hampshire+03063&amp;t=h&amp;
ll=42.796156,-71.573181&amp;spn=0.120922,0.219727&amp;z=12&amp;iwloc=A"
style="color:#0000FF;text-align:left">View Larger Map</a></small>
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</div>

Displaying bubble text on content
1. Highlight text for which you want to display bubble text.
2. On the Format tab, click Abbreviation ( ) . The Abbreviation tab appears.

3. Enter the bubble text in the field and press Enter. When a site visitor hovers over
highlighted text, the bubble text appears.

Viewing and editing HTML source content
To view and edit the HTML source, click View Source ( ) on the Review tab. The
Source Viewer appears. As you edit the HTML, the content window dynamically updates
with your changes.
When you finish editing in the Source Viewer, click the X in the top right corner.
The Source Viewer supports tag completion. For example, if you type <p>, the Source
Viewer automatically adds a closing </p> tag.
The Source Viewer supports collapsing and expanding tags. For example, if a table is in
the content, a small arrow appears next to the line numbers. Click the arrow to expand
or collapse the nested tags.
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Finding and replacing text in the source viewer
NOTE: Replacing text is supported only in the Source Viewer. Search is supported in
the editor by pressing Ctrl/f.
Consider replacing OnTrek with Ektron in the following content.
<p>OnTrek announced a 37 percent gain in revenue for the first half of 2010
over the first half of 2009. Q3 2010 sales increased 45 percent compared to
a record sales month in July 2009. “Demand for OnTrek’s latest solutions,
from new and existing customers, combined with our ability to deliver upon
mission-critical business initiatives continues to drive a healthy gross margin,”
said James Bradford, founder and CEO of OnTrek. “With competitive technical
analysis and boardroom influence favoring OnTrek in customers’ due diligence,
our momentum and accelerated growth is expected to continue.”
<br/></p>

1. On the Review tab, click the View Source button (

). Source Viewer appears.

2. Press Ctrl/f to open the find and replace boxes.
3. Type the search text in the first box and the replacement text in the second box.
4. Click Replace to find and replace occurrences one at a time. Click All to replace all
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occurrences.

Validating content
You can validate content against Accessibility (Section 508 Guideline), WCAG, HTML5,
or XHTML guidelines by clicking Validate ( ) on the Review tab. The Content Validator
screen appears. Choose which guideline you want to use from the drop-down menu,
then click Validate. Options include:
l

Accessibility (Section 508 Guideline)

l

WCAG 2.0 Level A

l

WCAG 2.0 Level AA

l

WCAG 2.0 Level AAA

l

HTML5

l

XHTML

NOTE: Each standard may have conflicts with the other standards; valid HTML5
code may not be valid XHTML code. Choose the standard guideline that you need.

Using a template to structure content
A template is section of HTML-formatted content that users can copy into their content
for any number of reasons. For example, a template can help maintain a structure, such
as image captions. If you want the caption on the left with content flowing around it,
create mark-up to do this and put it in a template.
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Administrators create content templates within a designated folder structure. When
authors are editing content in any folder, they click a toolbar button, then select and
insert a template.
The following sections provide additional details on how to create and insert templates.

Creating a template
PREREQUISITE

You have permission edit files in the Ektron site root folder.
To prepare for templates, create an Ektron folder structure to contain them. Then,
specify its parent folder's ID number at the templatePlugin element in the
AlohaEktron.aspx file, located in
siteroot\Workarea\FrameworkUI\js\Ektron\Controls\EktronUI\Editor\Aloha\.
templatePlugin: {FolderID: 45}
IMPORTANT: You cannot use zero (0), the root folder, as the parent folder for
templates.
NOTE: You set permissions on the parent template folder as you do for any other
folder. Users must have read-only or greater permission for the parent template
folder in order to insert a template into content.
After you create the folder, open it (or any of its child folders) and create and publish
HTML content to be used as a template. Authors may only select published content from
this folder structure when inserting a template into content.

Inserting a template
To insert a template
1. Place the cursor where you want the template to be inserted.
2. On the toolbar's Insert tab, click Insert Template ( ) .
3. Go to the template that you want to insert.
4. Select it and click Insert.
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The template is copied to your content, and then decoupled from the template source
file. So, you can modify the copied text as you like; modifications do not affect the
template. Also, if you later change the template, that action does not affect previouslyinserted copies.

Translating content
This section describes machine translation, which converts content to another
language. Machine translation operates on an entire piece of content, not selected
portions of content.
IMPORTANT: Before you can use machine translation, a system administrator
must enable it. See Enabling machine translation on page 1533.
1. While editing a piece of content, click Translate (
content appears in a new window.

) on the Review tab. The

Ektron Reference

635

Editing in Ektron

2. Choose the Source and Target Languages and click Translate. The machine
translation appears.

3. If the translation is acceptable, click Paste Content to replace the original with the
translated text.
4. Edit the translation as needed then save.
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Customizing the editor
An administrator can customize the editor.

Detaching the editor's fixed toolbar
By default, the toolbar is in a fixed position in the following editors:
l

editing HTML content, and its summary

l

Smart Form rich area text fields

l

blog posts

An Ektron administrator can change this, so that the toolbar "floats" in these locations.
To do this, open the \siteroot\ektron.cms.framework.ui.config file, and find the
<add name="EditInContext"> element. Within that, find the <add name="Content"
property and delete ektron/persistToolbar.

Changing the default editor
The editor is determined by the ek_EditControlWin (Windows) or ek_EditControlMac
(MacIntosh) element values in web.config. You can change the default values to use
another editor, or let the user choose the editor.
<!-- EditControlWin may be either "Aloha" or "ContentDesigner" or "UserPreferred" -->
<add key="ek_EditControlWin" value="Aloha" />
l

Aloha designates the default editor for all users. See also: Editing in Ektron on
page 605.

l

ContentDesigner designates the eWebEdit400 editor for all users. See also: Using
the eWebEdit400 editor on page 2065.

l

UserPreferred lets users choose an editor on their profile page. See also:
Creating a user on page 1556.
If UserPreferred is chosen for Windows or Macintosh users, Aloha is the default
value for those users.

Modifying editor plug-ins
Plug-ins are open-source, customizable pieces of JavaScript code that provide editor
functionality. Ektron provides several useful plug-ins that lets you customize the editor.
You specify the editor plug-ins that you want to use in the
siteroot\ektron.cms.framework.ui.config file. Many plug-ins are buttons on the
editor toolbar. See also: Customizing the editor's toolbar buttons on page 641
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Editor plug-ins are stored at
\Workarea\FrameworkUI\js\Ektron\Controls\EktronUI\Editor\Aloha\plugins\e
ktron\[plug-in_name]. Each [plugin_name] folder has supporting CSS and lib
folders containing these files:
l

Plug-in_Name.css. Cascading style sheet for the plug-in

l

Plug-in_Name-plug-in.js. JavaScript file for the plug-in

Plug-in code has the following basic outline:
l

Define/inclusion calls are at the top (powered by RequireJS for easy-to-use paths)

l

Main function (returns created plug-in)
o Default variables or strings to be used
o

Init function executes upon loading (usually to create the button)

o

createButtons function adds a button to floating menu

o

Function that can be called whatever you like, and should be executed upon
button click

Each editor plug-in has one of these prefixes:
l

common/. Native to the editor

l

ektron/. Supplied by Ektron

l

extra/. Supplied by others. You can create your own plug-ins. (This document
does not describe how.)

The following are standard editor plug-ins.
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l

common/ui, common/block. Required internal plug-ins; do not remove

l

common/abbr ( ). Specify an abbreviation for content, which shows up as bubble
text. See also: Displaying bubble text on content on page 631.

l

common/characterpicker ( ). Insert special characters (such as ® and ±)

l

common/contenthandler. Controls sanitization of content and supports cleaning of
Microsoft Word documents being pasted to the editor to preserve as much
formatting as possible.
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Content handler is independent of paste. It cleans content when certain actions are
performed, such as paste, getContents (getting content to save it to the
database), and initEditable (opening content).
NOTE: If content contains improper tagging, it is removed when pasted. Also,
images embedded within documents are not pasted into Ektron content; you
must insert them separately.
l

dom-to-xhtml/dom-to-xhtml. Ensures XHTML compliance. This plug-in enables
Ektron controls.

l

common/highlighteditables. Not a toolbar button; if enabled, you can click a
content item to highlight it for easy identification of content elements

l

common/horizontalruler (

). Insert horizontal line

l

common/list ( and
(numbered <ol>) list

l

common/paste. Not a toolbar button; uses the browser’s ability to paste content
from the clipboard

l

common/table (

). Create an unordered (bulleted <ul>) or ordered

). Insert a table See also: Inserting a table on page 616.

l

common/undo. Not a toolbar button; enables the browser’s ability to undo the last
action

l

ektron/bookmark ( ). Set a bookmark See also: Removing a link on page 613.

l

ektron/draganddrop. Not a toolbar button; enables drag and drop of images into
content; supported browsers: Webkit-based (such as Safari and Chrome)

l

ektron/editInContextCallback. Raise callback events (that depend on your
permissions and workflow) when you “edit in context” Editing content in context on
a Web page on page 647.

l

ektron/embed ( ). Embed a video into your content See also: Embedding
external content on page 626

l

ektron/format. Contains bold ( ), italic ( ), subscript ( ), superscript ( ), and
the formatting palette (Paragraph, Span, Heading1-Heading6, Pre)

l

ektron/hyperlink (
page 610.

). Insert a hyperlink See also: Working with links on
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l

ektron/library ( ). Insert a library item (file, form, hyperlink, image, and
quicklink) into the content

l

ektron/persistToolbar. fixes the toolbar to the top of the editor screen. See
also: Detaching the editor's fixed toolbar on page 637

l

ektron/sourceview ( ). Opens a view of HTML coding of the content. Whether
you edit in the source viewer or the HTML editor, both views are kept concurrent.
See also: Viewing and editing HTML source content on page 631.

l

ektron/template( ). Insert predefined content into the editor at the cursor
location; for example, a caption below an image. See also: Using a template to
structure content on page 633.

l

ektron/translate ( ). Machine translate text to another Ektron-supported
language. See also: Translating content on page 635.

l

ektron/validator ( ). Verify content against HTML5, XHTML, WC3, and WCAG
compliance. See also: Validating content on page 633.

Creating "Hello-World-plug-in.js"
The following example shows how to create a "Hello World" plug-in snippet within a
<span> tag. To learn about creating plug-ins, see http://alohaeditor.org/guides/writing_plug-ins.html.
// define the HelloWorld module using RequireJS
define([
'aloha',
'aloha/plug-in',
'aloha/floatingmenu',
'aloha/jquery',
'i18n!aloha/nls/i18n',
'css!helloworld/css/helloworld.css'],
// callback executed once dependencies are loaded by RequireJS
function (Aloha, Plugin, FloatingMenu, jQuery, i18nCore) {
// create and register the Plugin
return Plugin.create("helloworld", {
defaults: {
text: "Hello World!",
wrapper: '<span class="helloworld"></span>'
},
init: function () {
// executed on plug-in initialization
window.console.info("HelloWorld: Begin initialization");
this.createButtons();
window.console.info("HelloWorld: End initialization");
},
createButtons: function () {
// provide locally scoped version of this for use
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// in callbacks,e tc.
var that = this,
tabInsert = i18nCore.t('floatingmenu.tab.insert');
// create hellowworld button
this.helloWorldButton = new Aloha.ui.Button({
'name': 'helloWorld',
'iconClass': 'ektron-aloha-button ektron-aloha-helloWorld',
'size': 'small',
'onclick': function () {
that.insertHello();
},
'tooltip': "Click to insert Hello World!",
'toggle': false
});
// add it to the floating menu
FloatingMenu.addButton(
'Aloha.continuoustext',
this.helloWorldButton,
tabInsert,
1
);
},
insertHello: function () {
window.console.info("HelloWorld: Hello World Button clicked");
var html = jQuery(this.settings.wrapper).text(this.settings.text);
// get the current selection range
var range = Aloha.Selection.getRangeObject();
if (range.isCollapsed()) {
GENTICS.Utils.Dom.insertIntoDOM(html, range,
jQuery(Aloha.activeEditable.obj));
}
else {
// remove the contents of the current selection
range.deleteContents();
// insert our Hello World elements
GENTICS.Utils.Dom.insertIntoDOM(html, range,
jQuery(Aloha.activeEditable.obj));
// deselect the current range object
Aloha.getSelection().removeAllRanges();
}
return false;
}
});
}
);

Customizing the editor's toolbar buttons
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The editor toolbar appears in several Workarea locations, and on your site when
logged-in users edit in context. A variation of the toolbar appears when content authors
create HTML content, enter a calendar event, reply to a discussion forum post, and so
on.
In the \siteroot\ektron.cms.framework.ui.config file, the <add
name="EditInContext"> element lists all editor toolbar variations. Following each
variation is a list of buttons for that variation. To customize the functions that appear in
a variation, edit the list.
IMPORTANT: When placing the editor on an .aspx page, specify its toolbar using
the ToolbarConfig property.
<ektron:AlohaEditor ID="AlohaMessage" runat="server"
AllowScripts="false" ToolbarConfig="Mediamedia" />
NOTE: Embedded within each plug-in's description is the editor tab under which it
appears. You cannot change this information.
Editor variations are:
l

Minimal. Sample minimal toolbar that you can copy to other locations; not used.

l

Content. Toolbar appears when editing HTML content, and its summary; Smart
Form rich area text fields; blog posts.

l

Assets. Toolbar appears when editing an asset's summary.

l

DiscussionTopic. Toolbar appears when working with a discussion topic and its
forum posts.

l

Mediamedia. Used in the following:
o Workarea > Library > Add or Edit Library item
o

library popup within editor, when adding new library item

l

CalendarEntryCMSUser. Toolbar appears when an Ektron user is working with a
calendar event

l

CalendarEntryMembershipUser. Toolbar appears when a membership user is
working with a calendar

l

EditInContext. Toolbar appears when using the Edit in Context option; See also:
Editing a link on page 613.

For example, to remove the validator button (
Form rich area text field:

) from the toolbar when editing a Smart

1. Using the Editor Variations list, determine that you need to find the Content
element within the ektron.cms.framework.ui.config file.
2. Using the Editor Plug-ins list, find the ektron/validator plug-in within the
Content element.
3. Remove the ektron/validator plug-in (crossed out in the following example).
<add name="Content" path="dom-to-xhtml/dom-to-xhtml,common/ui,ektron/format,
common/contenthandler,common/table,common/list,ektron/hyperlink,
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common/highlighteditables,common/undo,common/paste,common/horizontalruler,
ektron/translate,ektron/validator,ektron/template,ektron/embed,ektron/inspector,
ektron/sourceview,ektron/advancedinspector,ektron/draganddrop,common/block"
default="false" />

Creating styles and classes
While the editor supports both inline styles and classes, the preferred method is to use
style classes and a css file. This is because inline styles get embedded into the HTML
source. If you later need to change the styling, you must modify every affected content
item. To change the properties of a style class, on the other hand, simply modify its css
file.
NOTE: Inline styles immediately affect the content display. But classes only affect a
Web page if it loads the CSS file that defines them.
PREREQUISITE
You can edit files on the Ektron server.

Setting up styles and classes
Use the StyleConfig.js file to create styles and classes that appear on the toolbar.
The file is located here:
siteroot\Workarea\FrameworkUI\js\Ektron\Controls\EktronUI\Editor\
Aloha\plugins\ektron\advancedinspector\lib\StyleConfigjs

Creating styles example
In this example, an inline style named “Alert” (which applies to the STRONG tag) is
defined as follows:
"STRONG": {
"styles": {
"Alert": {
"type": "style",
"value": "color:red;",
}
}
}
l

STRONG. The tag to which the style may be applied.

l

Alert. The name of the style that appears on the toolbar.

l

type. Identifies this definition as either an inline style or a CSS class.

l

value. Defines the value of the style property, "color:red;", that will be applied
to the tag.

Example result: <strong style="color:red;">
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Creating classes example
In this example, a CSS style class named “text-justify” (which applies to the P tag)
is defined as follows:
"P": {
"styles": {
"Justify": {
"type": "class",
"value": "text-justify",
}
}
}
l

P. The tag to which the style may be applied.

l

Justify. The name of the style that appears on the toolbar

l

type. Identifies this as a class rather than an inline style.

l

value. Defines the value of the class property, “text-justify”, that will be
applied to the tag (matches the class name defined in the css file).

Example result: <p class=”text-justify”>

Integrating the editor into an ASPX page
ektronUI:Editor Control
The ektronUI:Editor control is an ASP.NET server component that you can integrate
into an .aspx page.
The ToolbarConfig property value (EditInContext in this example) specifies which
plug-ins to load with the editor. See also: Modifying editor plug-ins on page 637.
<!DOCTYPE html PUBLIC "~//WJC//DTD XHTML 1.0 Strict//EN"
"http:..www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<title>Editor control integration</title>
</head>
<body>
<div id="content">
<ektronUI:Editor ID="Editor1" runat="server" ToolbarConfig="EditInContext" />
</div>
</body>
</html>
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Most of your time in Ektron is spent creating, editing, and performing other activities
with content. Content encompasses all of the articles, news, forms, blogs, discussion
forums and even calendars that appear on your website. Authors can conveniently
update content directly from the website (after logging in). To access the full
functionality, however, users complete tasks within the Workarea.
You can manage Ektron content using 1 or more tools.
l

Web Page Editing. You can interact directly on the Web page anywhere you see a
silver access point ( ) or a menu ( ), which lets you edit the content on the page.
For information about editing on the Web page, see Editing a link on page 613.
Access Point versus Menu
Starting with Ektron 9.00, the silver access point ( ) is replaced with a
menu ( ). Ektron recommends that you replace the following code with
its Ektron 9.00 replacement in your site's ASPX pages. This code change
enables the menu for use with any HTML5 CSS3-compliant browser and
it does not affect the use of the access point with other browsers.
Deprecated code:
<ektron:AccessPoint />
Associated Content Goes Here

Replacement:
<ektron:EditorsMenu>
Associated Content Goes Here
</ektron:EditorsMenu>
l

Content Dashboard. Requires an HTML5 CSS3-compliant browser; lets you
manage content that is relevant to you.

l

Workarea. Depending on permissions, lets you access all content, assets, reports,
and settings.

l

Smart Desktop. Lets you organize information that is relevant to you in the
Workarea.

Editing content
You can only edit content for which you have permission and in one of the following
statuses:
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Published

l

Checked in

l

Checked out by you

l

Submitted for your approval
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After you sign in, you can access content by a silver access point ( ) or menu ( ) on
the Web page, or through the Workarea, or through the Content Dashboard. You can
edit content in the following ways:
l

Edit in context on the Web page

l

Edit in the Workarea

l

Edit from the Content Dashboard

NOTE: For information about using the Ektron editor, see Editing in Ektron on
page 605.

Editing content in context on a Web page
When you log in, you can edit content on any Web page that contains an Ektron toolbar
with an edit/view switch.
HTML5 CSS3-compliant browsers may display the Ektron toolbar if it is enabled in the
Workarea. PageBuilder actions are available when you click Design. You can enable or
disable the toolbar for any template at Workarea > Settings > Configuration >
Template Configuration; check or uncheck boxes in the Enable Toolbar column.
See Editing in context on an HTML5 CSS3-compliant browser below.
For other browsers (or if the toolbar is disabled), the top of the page displays a
PageBuilder menu for performing actions on the page, such as checking in, viewing
properties, and placing widgets on the page.

NOTE: For information about how to create a widget, see Creating the “Hello World”
widget on page 1276.

Editing in context on an HTML5 CSS3-compliant browser
PREREQUISITE

The Ektron toolbar requires an HTML5 CSS3-compliant browser. If you do
not have this, see Editing in context on any browser on page 651.

The toolbar lets you:
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l

Use the App Launcher to view and edit your website, or interact with content
using the Content Dashboard. See Managing content from the Content Dashboard
on page 658.

l

Switch to edit your site's content or PageBuilder pages without leaving the page.

l

Click Content to work with content on the current page.
When you edit a page "in context" using an HTML5 CSS3-compliant browser, your
mouse-over exposes editable areas. Click the menu ( ) to display available
actions.
For example, on the OnTrek main page, the first column contains a Content Block
widget. Click the menu to see available actions, such as Edit in Context. To learn
about editor details, see Editing in Ektron on page 605.

Managing edit in context menu options
On the Edit in Context menu, Ektron administrators can provide a full or minimal
set of menu options.
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To determine the menu that content authors see, set the appropriate value in the
siteroot\web.config file's ExcludeEditorMenuItems element.
l

true. Show minimal option set

l

false. Show full set of menu options

l

Click Design to edit PageBuilder layouts and perform other actions on the page,
including adding widgets to the page or accessing the Workarea. Accordion menus
appear: Page Action, Properties, and Widgets.

l

Click Preview to show your page on a variety of simulated devices (portrait and
landscape views). A bar appears with devices that simulate your Web page on

Ektron Reference

649

Managing content

those devices. For information about setting these devices, see Adding a group by
device model on page 517.

Troubleshooting the toolbar
Problem. I cannot see menus or title bars when editing my page.
A JavaScript error occurred on the site and has shut down the JavaScript engine. It is
also possible that the access point ( ) or PageBuilder is not implemented on the page.
Solution. If this is a JavaScript issue, activate the test pages in the Min site. If the error
does not occur on the test pages, then the issue is with your JavaScript, which you
should debug.
Problem. I cannot interact with the page even though the Toolbar is showing and I am
logged in.
Your session may have expired or you may be logged in on another browser. (Need to
reset cookie)
Solution. Log out and then log in again. Also, you can set session expiration time in
web.config.
<sessionState mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
cookieless="false"
timeout="20" />

Problem. The toolbar is enabled and I am using the correct version of Internet
Explorer, but the old user interface is showing up on the page.
You are probably using Internet Explorer in Browser mode: Internet Explorer 9
Compatibility View.
Solution. Change this with the following steps:
1. Press F12 in your IE9 browser. A menu bar appears at the bottom of the browser
above the tabs.
2. Set Browser Mode to Internet Explorer 9 (not Compatibility view).
3. Set the Document Mode to IE9 Standards.
4. Click X to exit.
Problem. The Ektron user experience looks messed up on my page.
You may have errors in your site code, or you may have CSS Cascading conflicts.
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Solution.
1. Debug your page. If no errors are found, the problem is likely a CSS conflict.
2. Modify customer CSS. For example, look for “Important!” rules.
3. Test on test page from min site.
4. If these measures do not resolve the issue, turn off toolbar at Workarea
> Settings > Configurations > Template Configuration.

Editing in context on any browser
When you choose File > Edit from the PageBuilder menu, you see the widget
components on your page. In addition to modifying content, you can add or modify the
widget placement. You can edit the content using the access point ( ), and modify the
widget properties by clicking Edit ( ). Menu options vary depending on the content’s
status, your permissions, and so on. For information about editing the PageBuilder
page, see Creating Web pages with PageBuilder on page 1075. To learn about editor
details, see Editing in Ektron on page 605.
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You can modify the access point menu's appearance by editing the ek_UserMenuType
element of the siteroot/web.config file. By default, ek_UserMenuType is set to 2.
l

652

2. drop-down Interface. No borders; drop-down menu appears when user clicks
the access point.
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l

1. Classic Interface. Colored borders and menus always appear; menu options
appear as icons in the top row.
NOTE: If you use this interface, the page layout is not depicted accurately
because of the fixed toolbars.
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System administrators can modify toolbar buttons by editing the C:\Program
Files(x86)\Ektron\CMS400vxx\workarea\ContentDesigner\configurations
\InterfaceEditInContext.aspx file. Also, the content block server control’s
Suppresswrappertags property must be set to false.
l

Add. Appears if you selected a language and the content is not available in
that language. Use this button to copy existing content into new content and
translate it to the new language. Creating multi-language content on
page 1521

l

Add HTML Content. Create new HTML content in the folder to which the
control is assigned. Creating new content on page 684

l

Add Smart Form Content. Create new Smart Form content in the folder
to which the control is assigned. Working with Smart Forms on page 888

l

Approve. Approve or decline a request to publish or delete content.
Approving content for publication on page 749

l

Add Task. Add a task to a user. Assigning and managing tasks on
page 1449

l
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Delete. Open View Content page. From it, you can delete the content.
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l

Edit. Check out content for editing; open in separate window. Editing content
on page 646

l

Edit in Context. Check out content for editing; content remains within
Web page. Editing content in context on a Web page on page 647
Logout. Log out of website.

l

l

New Poll. Create new poll or survey. Creating surveys and polls on
page 868

l

Preview. Preview content before it is published. Previewing content in a
mobile template on page 509

l

l

Properties. Open content’s View Content page.

l

Publish—Force the immediate publishing of this content item. Forcing the
publication of content on page 785.

l

View Content Difference. Contrast previous and current versions of
content. Comparing versions of content on page 703.

l

View History. Open View History screen, where you can view previous
versions of content. Managing versions of content on page 701

l

View Page Activity. View the current page's SEO information. SEO (Search
Engine Optimization)

l

Workarea. Open Workarea. From here, you can perform all Ektron tasks.
Managing content on page 645

0. Hover Interface. Colored border appears when user hovers mouse over area;
menu appears when user right clicks mouse inside border. This interface has 2
display options: vertical (shown) and horizontal. To change:
1. Open the siteroot/web.config file.
2. Find ek_MenuDisplayType.
3. Change its value:
l 0 (zero) = horizontal
l

1 = vertical
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Editing content in the Workarea
In the Workarea, you can edit all types of content (HTML content, HTML forms, XML
Smart Forms, and so on), add information about content (summary, metadata, and so
on), and edit, check in, submit, and publish content.
1. From the Workarea, click Content and go to the folder that contains content you
want to edit.
NOTE: If you do not know the folder location, search for content using Action
> Search from the root folder.
2. Click the content you want to edit. The View Content screen appears.
3. Click Edit. The editor appears. To learn about editor details, see Editing in Ektron
on page 605.
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You also can edit via the View Contents of Folder screen's context menu. Click the
triangle ( ) next to the content item, and choose Edit from the menu. The editor
appears.

Editing from the Content Dashboard
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PREREQUISITE

The Content Dashboard requires an HTML5 CSS3-compliant browser. You
must also enable the toolbar, for any template you want to use, by checking
the boxes in the Enable Toolbar column at Workarea > Settings
> Configuration > Template Configuration.
You can access content from the Content Dashboard. When you find the content you
want to edit, click Edit. See Managing content on page 645 for more information. To
learn about editor details, see Editing in Ektron on page 605.

Managing content from the Content Dashboard
PREREQUISITE

The Content Dashboard requires an HTML5 CSS3-compliant browser. If you
do not have this, see Managing content from the Smart Desktop on
page 668. You must also enable the toolbar for any template by checking
boxes in the Enable Toolbar column at Workarea > Settings
> Configuration > Template Configuration.
On the website, open the Ektron app launcher and click Dashboard.

The Content Dashboard appears. By default, you see content that you last edited.
IMPORTANT: The Content Dashboard shows Published content only. Content that
has been checked in but not published does not appear. Use the Workarea to edit
unpublished content.
The My Content tab (shown below) displays content that you created or last edited. To
search for all content, click the All Content tab.

658

Ektron 9.40 SP1

Managing content from the Content Dashboard

NOTE: The Language field may display the Locale ID instead of the name of the
language. Locale ID Assigned by Microsoft shows all Language codes.
You can view results in:
l

Grid ( ). shows content data and actions you can take.

l

Tile ( ). shows content data in 2 columns and actions you can take.

l

Line ( ). shows a more compact view of your content.

The action bar that you see depends on your permissions.
If a content item's metadata has an image, it shows as the item's thumbnail. For
example:
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Results are added 10 at a time. If you scroll beyond the first 10 results, another 10
results are added until all results are shown.
NOTE: If no results appear when you open Content Dashboard, then you either have
no content that was "Last edited" by you, or your search is not functioning. Try the
All Content tab to see if anything appears there.
If not, check your search's crawl status: Workarea > Settings > Configuration
> Search > Status. If the search is not set up, contact your Ektron administrator.

Filtering content
IMPORTANT: Content Dashboard filters are supported by Solr search. If you are
using another search provider, results appear but filtering capabilities do not. See
Also: Using Solr search on page 216.
If you have a lot of content to sort and sift, use the Filters panel to narrow your search
by opening the tabs and clicking filters.

Each filter displays the number of content items to which it is assigned.

A filter is a property with a specific value. If you choose a filter, the search results
refresh, and you only see content to which the filter applies. For example, the content's
last editor is John Wang. If you choose that filter (by clicking inside its check box), the
screen refreshes, and only content last edited by John Wang appears.
If you choose several filters, content only appears if it satisfies all filters and the search
term(s).
If you choose a folder or taxonomy category, content within it and any of the child
folders/categories appears.
Upon choosing a filter, the screen refreshes. If a content property can only have one
value, it no longer appears in the filters display. For example, a content item only has
one folder. So, if you choose the Solutions folder, the filters display hides all other
folders. The filters display also hides unapplied editors. On the other hand, more than
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one tag or taxonomy category can be applied to content. So, they continue to appear
after you choose one of them.
If you want to add a hidden filter, remove the applied filters, and all available filters
reappear.
If an item has an arrow ( ), use it to expand the item tree for further refinement. For
example, if you open the MainSite folder path, its subfolders appear, Content and
Pages.

You can choose several filters to refine search results. The following example shows
results that meet these criteria:
l

My Content

l

are assigned to the Support taxonomy

l

belong to the Pages folder path

l

language is English
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Selected filters are checked in the filters panel and appear under the search bar. To
remove a filter, click X on the filter under the search bar. If you do, the results
automatically update.

Saving filtered searches
If you often filter content in the same way, you can save a set of search filters on a tab.
Whenever you click the tab, the filters are applied, and content that satisfies those
filters appears.
1. Specify filters by which you want to narrow search results. See Filtering content on
page 660.
2. Click Save on the right of the tab bar. The Save Content Topic screen appears,
showing the selected filters.
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3. Enter a name for the filtered search and click Save. The new tab appears on the
tab bar.

Sorting content
You can sort search results by Most Relevant, Date Modified, or Title by selecting an
option from the following menu.

If you sort by Most Relevant, content that needs to be checked in (or otherwise acted
on) is displayed ahead of content that does not.

Managing content from the Workarea
The Workarea is a central location where you can perform most tasks for managing
your website. The Workarea is similar to Microsoft Outlook in its ability to manage
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email, calendars, tasks, and so on.
IMPORTANT: If you are using Internet Explorer 11, set the following parameters to
ensure optimum functionality.
1. Press Alt/X to display the Internet Explorer Tools menu.
2. Choose Compatibility View Settings.
3. Uncheck Display intranet sites in Compatibility View.
If you are using Internet Explorer 10, set the following parameters to ensure
optimum functionality.
1. Press F12. A settings menu bar appears at the bottom of the browser above the
tabs.
2. Set Browser Mode to IE 10 (not Compatibility view).
3. Set Documentation Mode to Standards.
4. Click X to exit.
NOTE: To access the Workarea, you must be logged in to your Ektron website.

Workarea quick reference

664

Ektron 9.40 SP1

Workarea quick reference

l

l

l

1. Workarea Tabs
o Desktop. Smart personalization desktop.
o

Content. Folders, contents, DMS, taxonomies, collections and menus.

o

Library. Content folder structure which organizes the storage images, files ,
hyperlinks and quicklinks.

o

Settings. Manage CMS Settings based upon permissions.

o

Reports. Content reports and Site analytics.

o

Help. In Workarea and in context help section.

Content Tab Types
o 2. Folder Tab. Select to view folder architect structure of CMS.
o

3. Taxonomy Tab. Select to view Taxonomy Structure and options.

o

4. Collections Tab. Select to view Collections and options.

o

5. Menu Tab. Select to view Menus and options.

Folder Types
o 6. Content Folder. Regular folder for contents, select to view contents in that
folder.
o

7. Blog Folder. Select to view the posts and comments on this blog.

o

8. Forum Folder. Select to view the discussion forums, categories, topics, and
replies.

o

9. eCommerce Folder. Select to view the eCommerce items.

o

10. Calendar Folder. Select to view and plan events on the calendar.

o

11. Community Folder. Folders for membership uses to edit content, select to
view contents.
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l

l

Dropdown Menus
o 12. New menu. Create new content, forms documents, Folders menus and
collections.
o

13. View menu. View Language, Properties and archived content and more.

o

14. Delete menu. Used to delete multiple items. Administrators can delete
folders.

o

15. Action menu. Export for translation, search, move/copy content, eSync.

o

16. DMS/ Add asset. Pop up the window for drag and drop documents from
local machine.

o

17. In Context Help. Click to get in context help anywhere in the Workarea.

o

18. Content Organization Bar. Ability to sort content by the title.

Content Types
o 19. Content Items. HTML Content, Forms, DMS, or Multimedia Content.
o

20. Quick Edit Menu. For content editing, properties and content eSync.

o

21. Language Flag. Indicate the content language version.

o

22. Content ID. Automatically generated by system.

o

23. Content Status. Shows the current status of a piece of content. See
Content statuses on page 681

o

24. Date Modified. Last modified date of the content.

o

25. Last Editor. Editor who made the last modification.

Workarea tabs
The Workarea has 6 tabs in the upper left corner. Use them to access all other pages.

The following list shows the Workarea's main pages.
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l

Desktop. Managing content from the Smart Desktop on page 668

l

Content. Managing content on page 645

l

Library. Working with files in the library on page 733

l

Settings. contains these folders.
o Commerce. Conducting eCommerce on page 1733
o

Community Management. Managing user communities on page 1623

o

Configuration. See feature-specific topics

o

Digital Experience hub. Ektron Digital Experience Hub release notes on
page 499

o

Localization. Importing translation files on page 1537
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l

l

o

Roles. Defining roles on page 1581

o

Business Rules. Creating business rules for your website on page 1473

o

User Groups. Managing user groups on page 1566

o

Users. Managing users on page 1556

Reports. Contains these folders:
o Commerce. Generating eCommerce reports, widgets, and logs on page 1868
o

Contents. Working with content reports on page 1057

o

Traffic Analytics. Running Ektron traffic analytics on page 558

o

Business Analytics. Running Ektron business analytics on page 536

o

Tasks. Assigning and managing tasks on page 1449

Help

Workarea style sheets
The Workarea uses 2 primary style sheets:
l

Ektron.workarea.css. The primary CSS file for the Workarea. It replaces the
previous Ektron version’s global.css file.

l

Ektron.workarea.ie.css is used for Internet Explorer browsers, and generally
targeted at IE7 or less. It includes overrides for some CSS rules in
Ektron.workarea.css that get around IE CSS bugs or deficiencies.

Using widely accepted style sheet classes and class attributes, you can modify the
Workarea, including colors, spacing, fonts, and so on. Also, if you later upgrade or reinstall Ektron, you can reuse this file and retain your changes.
NOTE: Several language-specific images are used at the top of the Workarea. They
reside in the language folders and always start with the word “Workarea” and end
with “_top.” These images are 467 pixels wide by 77 pixels high. Their width can
change but the height cannot. There are approximately six images in each language
folder. An Adobe Photoshop file, Workarea_top.psd, can be found under
\Workarea\images\English folder. You can modify these images as needed.

Accessing the Workarea
To access the Workarea, log into your website and click Workarea. The Smart Desktop
is the default tab.
NOTE: The Application Setup screen lets you determine the initial screen that
appears when you access the Workarea. See also: Modifying setup information on
page 129.
The Smart Desktop contains useful information that pertains to you. You may
personalize this page by adding, moving or deleting Workarea widgets. See also:
Managing content from the Smart Desktop on the next page
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Closing the Workarea
There are 2 ways to close the Workarea.
l

Log out of the Website from a Logout link on the Web page or the Logout button (
).

l

Using the Windows Close button (
) in the upper right corner of the
browser. If you do this, you remain logged in to the website.

Managing content from the Smart Desktop
To personalize your Smart Desktop, you choose and arrange widgets that pertain to
your work. To access the Smart Desktop, click the Desktop tab in the Workarea.

The default Smart Desktop displays several widgets with information about your
website. You can create new tabs on a Smart Desktop to add, move, delete, and
organize widgets by subject. Each tab consists of 1 or more columns, which you can
create to further arrange widgets on a tab. The following screen has 2 columns.
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Smart Desktop widgets are stored in a widget tray. Drag and drop widgets from the
tray to any tab and column on the Smart Desktop.

Enabling Smart Desktop widgets
PREREQUISITE

You are a member of the Administrators group.
You must complete this procedure before administrators can create a default Smart
Desktop.
1. Workarea > Settings > Configuration > Personalizations > Widget
Space.
2. Click Edit ( ) next to UserSmartDesktop.
3. Select widgets that users can place on their Smart Desktop.
4. Click Click here to save widget space.
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Setting the default Smart Desktop
The following procedure shows how an administrator creates a default Smart Desktop
consisting of a unique arrangement of widgets, tabs, and columns. The default desktop
becomes every user's Smart Desktop until modified by the user. A user can reset the
Smart Desktop to the default setting by running the Reset Widgets command (see
Restoring tabs and widgets on page 674).
NOTE: If you change the default Smart Desktop, that action does not affect existing
users' desktops. Those desktops are set to default settings only if the user runs the
Reset Widgets command.
1. Go to Workarea > Desktop.
2. Choose Options ( ) > Edit Default Widgets on the right side of the Smart
Desktop. A confirmation dialog box appears.

3. Click OK.
4. Arrange the Smart Desktop with widgets, tabs, and columns that you want to be
the default. See also: Adding a widget to the Smart Desktop on page 672, Adding a
tab to the Smart Desktop on page 672, Adding a column on page 673
5. Choose Options ( ) > Done.

Adding Smart Desktop widgets
Smart Desktop widgets are located in the Web server's workarea\widgets folder. You
can also make Personalization and PageBuilder widgets available to the Smart Desktop.
IMPORTANT: Some Personalization and PageBuilder widgets may not work
properly on the Smart Desktop. Test them before notifying users.
PREREQUISITE

You can access the Ektron Web server's file system.
1. On the Web server, copy desired widget files from the siteroot\widgets folder to
the siteroot\Workarea\Widgets folder. Be sure to copy all widget-related files
and folders. The following image shows all Calendar widget folders (with their files
inside).
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2. Click Workarea > Settings> Configuration > Personalizations > Widgets.
3. Click Synchronize Widgets....

4. At the prompt, click OK.
5. Go to Workarea > Settings > Personalizations > Widget Space.
6. Click Edit ( ) next to UserSmartDesktop.
7. Select the new widget (you may have to scroll down to see it).
8. Click Click here to save widget space.
9. Users many now add the widget to the Smart Desktop. See Adding a widget to the
Smart Desktop on the next page.

Customizing the Smart Desktop
An end user can do the following when customizing a Smart Desktop:
l

drag and drop widgets—See Adding a widget to the Smart Desktop on the next
page

l

add tabs—See Adding a tab to the Smart Desktop on the next page

l

add or remove columns within a tab—See Adding a column on page 673, Deleting a
column on page 674
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l

restore Smart Desktop to default settings—See Restoring tabs and widgets on
page 674

Adding a widget to the Smart Desktop
PREREQUISITE

Smart Desktop widgets have been enabled. See also: Enabling Smart
Desktop widgets on page 669
1. Go to the Workarea > Desktop.
2. Click the Toggle widget tray arrow, located in the upper right corner of the Smart
Desktop (circled).

3. The widget tray appears, containing widgets you can drag and drop to your Smart
Desktop. Use the left arrow ( ) or right arrow ( ) buttons to see more widgets.
4. To choose a widget, drag it from the tray and drop it into the Smart Desktop panel.

After placing a widget on the Smart Desktop, you may drag it to any desktop location.

Adding a tab to the Smart Desktop
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Tabs help you organize your Smart Desktop. You may add or remove tabs. For
example, you create an eCommerce tab on which to drop orders widgets. To add a tab:
1. Choose Options ( ) > Add Tab. The Add Tab dialog window appears.

2. Enter a Tab Label. For example, eCommerce.
3. Click OK. The new tab appears at the top of the Smart Desktop.

Adding a column
You can divide a Smart Desktop tab into columns This capability helps you arrange
widgets on the tab.
NOTE: Two columns are created for each new tab by default.
To add a column to a Smart Desktop tab, choose Options ( ) > Add Column.
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Deleting a column
1. Click the toggle widget tray button (circled) to show the widget tray and columns.

2. Click Remove Column ( ) (circled) inside the column you wish to delete.

Restoring tabs and widgets
A user can restore the Smart Desktop to the default widget and tab set.
WARNING! This action removes all tabs and widgets you have modified on your
Smart Desktop. After you restore, the default tabs and widgets appear.
1. Click the Options button on the right side of the Smart Desktop.
2. Click Reset Widgets.

3. A dialog appears. Click OK.

Standard Desktop Widgets
The following list describes the standard Smart Desktop widgets. See also: Adding
Smart Desktop widgets on page 670
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l

Content Awaiting Approval. Content awaiting your approval; Approving
content for publication on page 749

l

Content Checked Out. Content in checked-out status; Checked out content
report on page 1059

l

Content Edited. Content edited within the last week

l

Content Flags. The 10 most recently-added content flags; Defining flags for
content on page 1717

l

Content In Workflow. Content that has been part of an workflow within the
last week;Approving content for publication on page 749

l

Content Reviews. Content reviews awaiting moderation; Moderating reviews
on page 1071

l

Content to Expire. Content that will expire between today and a number of
days you specify; Content to expire report on page 1061

l

Forum Topics and Posts. Forum posts that require approval; Approving a
post on page 1048

l

Order on Hold. eCommerce orders on hold; Managing customer orders on
page 1850

l

Recent Orders. Recent eCommerce orders; Managing customer orders on
page 1850

l

Customer List. The top 5 eCommerce customers ranked according to account
date, sales, and orders;Customer report on page 1868

l

Key Performance Indicators. Compares eCommerce sales and orders for 2
time periods;Key performance indicators report on page 1870

l

Reconciliation report. Lists payments for a specific time period;
Reconciliation reports on page 1871

l

Sales Trend. The number of eCommerce orders for the past 8 periods; Sales
Trend report on page 1872

l

Top Products. The most popular products on your eCommerce site; Top
Products report on page 1873

l

Analytics Report. The Direct Traffic report for the past 7 days; Analyzing
websites on page 531
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Controlling available fonts
As an administrator, you can add, edit, and delete fonts to and from the Ektron
application. By adding fonts, you are allowing the content contributors to use them
when creating content. Administrators can also edit the name of a font, and delete a
font from the system.
Minimizing the number of available fonts makes the website look more uniform. The
following figure shows the Font Manager screen.

NOTE: Only members of the Administrator User Group can view, add, or edit fonts.

Adding fonts
1. From the Workarea, choose Settings > Configuration > Fonts.
2. Click Add Font. The Add Font screen appears.

3. Enter the font name or family into the text field; (Kristen ITC in this example).
4. Click Save.
The new font is available to use when adding or editing content if the Application
Setup screen’s Enable Font Buttons field is checked. See also: Modifying setup
information on page 129

Viewing fonts
When viewing fonts, you can also edit or delete them.
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1. From the Workarea, choose Settings > Configuration > Fonts.
2. Click the font you want to view.The view font screen appears.

Editing fonts
When you edit a font, the font or family name is changed. Editing does not change any
fonts in existing content.
1. From the Workarea, choose Settings > Configuration > Fonts.
2. Click the font you want to edit. The view font screen appears.
3. Click Edit. The Edit Font screen appears.
4. Edit the font name or family in the text field specified.
5. When finished, click Update.

Deleting fonts
By deleting a font from the system, you are taking away the content contributors’ use
of that font in their content.
1. From the Workarea, choose Settings > Configuration > Fonts.
2. Click the font you want to delete. The view font screen appears.
3. Click Delete ( ).
4. Click OK. The screen is refreshed, and the updated fonts table appears.
NOTE: When you delete a font from Ektron, you do not delete it from your
computer.
Additional topics about managing content
The following topics explain managing types of content in Ektron.
l

Working with Ektron content on page 679

l

Working with assets in the Document Management System on page 708

l

Working with files in the library on page 733

l

Working with collections on page 804

l

Working with Metadata on page 822

l

Working with templates on page 838

l

Working with HTML forms on page 843

l

Working with Smart Forms on page 888

l

Working with blogs on page 963

l

Working with calendars on page 991

l

Working with discussion boards on page 1013

l

Working with content reports on page 1057
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l

User-ranking of content on page 1069

l

Using the Map Server Control
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Working with Ektron content
To work with content on your website or in the CMS Workarea, you must log in as a
CMS user. Ektron lets you access content on a Web page in the following ways:
l

Web page with the Ektron 9.10 SP3 toolbar. An HTML5 CSS3 interface that gives
you additional options and experience

l

Web page with PageBuilder menu. Hover over the access point ( ) to see options
for content on the page.

l

Workarea. You can specify additional information for content such as metadata, a
content summary, aliases, comments, scheduling, and so on.
o Go the Workarea folder tree. See also: Managing content on page 645.
o

Use the Action > Search option, which appears in the View screen of every
folder. See also: Searching the Workarea on page 390.

Ektron has many types of content that you can use on your website. See Understanding
Ektron content below for information about the types of content.

Understanding Ektron content
A website consists of pages that are made up of one or more blocks of content as shown
in the following example from the home page of one of Ektron’s sample sites.

The following sections provide information about Ektron content.
l

Content Types

l

Content Properties

l

Content Statuses

l

Other Content Information

Content types
Every piece of content in Ektron is one of the following types.
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l

HTML content. Content designed to be published on the World Wide Web. See
Editing in Ektron on page 605.

l

XML Smart Forms. XML-based Smart Form configurations collect and validate
structured content. An XML schema validation ensures the accuracy and format of
your Web content, which reduces review and revision time. See Working with
Smart Forms on page 888.

l

HTML form/survey. Online forms, polls, or surveys designed to collect
information from site visitors and save it in an HTML format. See Working with
HTML forms on page 843.

l

DMS Documents. consists of Office documents, managed files, and multimedia
files. See Working with assets in the Document Management System on page 708.

l

Office documents. Files normally created and edited using Microsoft Office. See
Working with assets in the Document Management System on page 708.

l

Managed files. Files created outside of Ektron, such as PDF files. You cannot
create or edit these files within Ektron—you can only store them. See Working with
assets in the Document Management System on page 708.

l

Multimedia. Files that run in a media player, such as sound and movie files. See
Managing multimedia assets on page 716.

l

Blogs. A blog is a form of online information sharing and is often set up so a group
of people can share their thoughts on a subject. See Working with blogs on
page 963.

l

Web Calendars. Web Calendars keep visitors informed about upcoming events.
They can be displayed to all visitors to your website, and any authorized user can
add events to a calendar. See Working with calendars on page 991.

l

Discussion Boards. The Discussion Board feature provides an opportunity for
topic discussions on your website. A site or membership user with Add Topic
permission creates a topic and posts a starter question. Site visitors can then reply.
See Working with discussion boards on page 1013.

l

Content Imported from SharePoint®. After an Ektron administrator sets up
DXH to map SharePoint to Ektron, an end user only needs to place content in a
SharePoint folder to update their Ektron-powered website; the content is
automatically transferred to the Ektron Workarea. You also can manually import
SharePoint content from the Ektron Workarea.

Content properties
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l

Content Title. The title assigned to the content

l

Content ID. The ID number assigned to the content. The ID number is used to
retrieve content from a database.

l

Content Language. The content’s language

l

Status. The current status of the content. See also: Content statuses below.

Ektron 9.40 SP1

Content statuses

l

Last User to Edit. The last user to edit this content

l

Last Edit Date. When the content was last edited

l

Start Date. When the content will go live on the website

l

End Date. When the content will be removed from the website

l

Action on End Date. What happens to the content when its end date and time are
reached. See also: Scheduling content on page 698.

l

Date Created. When the content was created

l

Approval Method. Whether all approvers must sign off on content before it is
published; only appears if basic workflow is applied to content or its folder. See
also: Changing the approval method on page 756

l

Approvals. Users in the workflow for this content. See also: Approving content for
publication on page 749.

l

Smart Form Configuration. The Smart Form applied to the content. This is
typically managed by your system administrator. See also: Working with Smart
Forms on page 888.

l

Template. The template currently assigned to the content. This is typically
managed by your system administrator. See also: Working with templates on
page 838.

l

Path. The folder path to the content’s folder. A slash (\) represents the Content
folder.

l

Ranking. Ektron's Content Ranking feature lets site visitors rate content on a scale
of 1 to 10. If this feature is enabled for the content, the average numerical rating
appears. See also: User-ranking of content on page 1069.

l

Content Searchable. True appears if the content can be found when someone
searches your website. See also: Making content searchable on page 371.
However, even if content is not searchable, the Workarea Advanced search still
finds it. See also: Using advanced search in the Workarea on page 391.

Content statuses
l

A (Approved). Through the workflow and published on the website. You can:
o Check content out and save it on your computer
o

Save a copy to your computer

o

Check out the content and edit it

o

Edit the content summary, metadata, schedule, comment, and so on

o

View the content information

o

Delete or submit a request to delete the content.
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l

O (Checked Out). Currently being edited. Has not been checked in. You can:
o If you checked out the content
n Check it in

o

n

Save a copy to your computer

n

Edit it

n

Edit the summary, metadata, schedule, comment, and so on

If you are an administrator
n Force a check in
n

o
l

l

l

l

Anyone can view the content information

I (Checked In). Checked in for other users to edit. You can:
o Check content out and save it on your computer
o

Save a copy to your computer

o

Check out the content and edit it

o

Edit the content summary, metadata, schedule, comment, and so on.

o

View the content information

o

Delete or submit a request to delete the content.

o

Publish content or submit it to the workflow.

S (Submitted for Approval). Saved and submitted into the workflow. You can
o Approve and publish content to the website
o

Decline to publish the submitted content

o

Check out the content and edit it

o

View the content information

M (Marked for Deletion). Requested for deletion. You can:
o Approve the deletion request
o

Refuse the deletion request

o

Save a copy to your computer

o

View the content information

P (Pending Go Live Date). Approved but the Go Live date has not occurred yet. You
can:
o Check out and edit the content
o

l

Request a check in from the person who checked it out

View the content information

T (Awaiting Completion of Associated Tasks). Task(s) assigned to content are not
complete

Other content information
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l

Properties tab. View the content’s properties

l

Content tab. Display and edit content
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l

Summary tab. Edit content’s summary

l

Metadata tab. Edit content’s metadata

l

Alias tab. View and edit the content item’s primary alias, or view all secondary
aliases; Creating a manual URL alias on page 1411

l

Comment tab. View comments on changes made when editing content. This
comment also appears on the View Content and Content History screens. Use it to
help distinguish one version from another.

l

Tasks tab. Add or edit tasks for this content; Assigning and managing tasks on
page 1449

l

Web Alerts tab. Add or edit Web Alerts for this content; Sending Web Alert emails
to subscribers on page 1481

l

Templates tab. The template currently assigned to the content; Working with
templates on page 838

l

Category tab. Any taxonomy categories currently assigned to the content. Only
appears if at least one Taxonomy is applied to the folder in which the content
resides.

l

Edit. Open content for editing

l

. View older versions of content; restore older version; Managing versions of
content on page 701

l

l

l

l

. Toggle display between Published and staged versions
. Compare current and earlier versions of content; Managing versions of
content on page 701
. Delete content; Deleting content on page 688
. View and edit permissions for content

l

. View and possibly edit the content's workflow; Approving content for
publication on page 749

l

. Find all content with Quicklinks to this content; Checking links before deleting
on page 689

l

. Attach a task to content; Creating a task assigned to content on page 1451

l

. View Analytics for this content; Viewing page-level analytics from the
Workarea on page 534

l

. Displays the content item's rating and reviews, messages, and flags; Defining
flags for content on page 1717

l

. View and edit content's Content Searchable check box and flagging
definitions; Making content searchable on page 371; Defining flags for content on
page 1717

l

. Go back to previous menu
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l

. Determines if content will be included when an .xlf file is created; Marking
translation statuses on page 1539

l

. Copy content to XLIFF files that can be submitted to a translation agency;
Working with multi-language content on page 1507

l

View (language). If you can view content in more than one language, select a
language from the drop-down list.

l

Add-select language. Lets you copy current content into a new item and translate it
to selected language; Translating content into another language on page 698

Creating new content
NOTE: For information about editing content, see Editing in Ektron on page 605.
1. In the Workarea, go to the folder in which you want to create a new content item.
2. Choose a type of content from the New menu. (For example, choose New
> HTML Content). The Edit Content screen appears.
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Non-HTML content types:
l

HTML Form/Survey. Creating a form on page 843

l

XML Smart Form. Working with Smart Forms on page 888

l

Assets (including multimedia). Managing assets on page 712

l

Microsoft Office document. Working with assets in the Document Management
System on page 708

l

PageBuilder page. Creating Web pages with PageBuilder on page 1075

l

Web Calendar event. Adding system calendar events on page 994

l

Blog post. Working with blog posts on page 979

l

Discussion forum posts. Working with posts on page 1039

3. Specify a title and begin creating your new content item.
l

Title. Enter a title for the content. It cannot include these characters: * > < |

l

Content Searchable. (Available to Administrators) Check this box if this
content should be found when someone searches your website. However,
even if content is not searchable:
o the Workarea Advanced search still finds it. See also: Advanced search on
page 363
o

l

it can appear among Suggested Results. See also: Providing suggested
results on page 376

Publish or Submit. Publish the content to the website. This action updates
the content in the database and exits the editor. See also: Approving content
for publication on page 749
NOTE: Only the last approver in the workflow sees the Publish button.
Other users see Submit. If no workflow is assigned to the content’s folder,
every authorized user sees Publish.

l

. Check In. Save and check-in the content. This action updates the content
in the database and exits the editor. It does not submit the content into the
workflow. Rather, it allows you and other users to continue changing it.

l

. Undo Checkout. Close editor without saving changes. Return content to
its state prior to checkout.

l

. Save. Save content without leaving the editor. It is a good idea to save
your work frequently. But, if you later click Cancel and exit the editor, you
lose changes saved by clicking this button.

l

. Cancel. Close editor without saving changes. Leave content in checked out
state.
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l

. Preview. Preview current content within its template in a new browser. If
you cannot see the preview, make sure your browser does not block popups.

l

Content. Enter content.

l

Summary. Enter or edit the content summary.

l

Metadata. Enter or edit the content metadata.
All required metadata must be added before content can be checked in or
submitted into the workflow.

l

Alias. Enter or edit the content's manual alias, and view its automatic alias.
See also: Creating user-friendly URLs with aliasing on page 1399.
A folder's Aliasing tab has a Manual Alias Required check box. If checked,
the user creating or updating content must enter a manual alias before the
user can save or submit the content.

l

Comment. Briefly describe the content, or comment on changes made when
editing content. The history comment appears on the View Content and
Content History screens. On the Advanced Workarea Searchscreen, you can
search for content by comments.

l

Schedule. Use this tab to set a future publication date/time. To be published,
this content must be approved and reach its publication date/time. See also:
Scheduling content on page 698. If appropriate, enter a date when the content
will no longer be viewable on the website. See also: Setting an end date on
page 700.

l

Web Alerts. See Sending Web Alert emails to subscribers on page 1481.

l

Templates. This content’s folder must have a default template. It can also
have additional templates assigned. When content is created, the default
template is assigned to it. If you want to change the template assigned to this
content, click this tab and choose a template from the drop-down list. See
also: Working with templates on page 838.

l

Category. Assign taxonomy categories to this content. See also: Organizing
content with taxonomies on page 1357.

After you create content, you or your system administrator typically make it available
on the site. For example, you can add a hyperlink to it from another page, or place it in
a collection or menu. Your administrator can add it to a list summary or content list.
You can set up an workflow process by which content is available to your website after it
is reviewed by people with approval responsibility. See also: Approving content for
publication on page 749. When a content creator submits content for publishing
approval, an email is sent to the list of approvers. When the last approver signs off, the
new content becomes available on the website. The following graphic illustrates the
content workflow cycle.
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To help track content’s position in this workflow, Ektron assigns a status to each
content item. The status determines what you can do with it, and indicates what must
occur for it to get published to the website. See also: Content statuses on page 681.

Moving or copying content
You can move content from a folder to another folder. Or, you can copy content
between folders. Moved content retains the original ID number, while copied content
gets the next available ID number.
Your can only move or copy content that has an Approved status. If a destination folder
has an workflow, the content status changes to Submitted (or Approved if you are the
last person in the workflow).
NOTE: If you are using basic workflow, a folder's Approval Method can affect the
status of the moved/copied content. See also: Setting the approval method on
page 756
You should move or copy content only between regular folders or eCommerce catalog
folders. Do not move or copy from or to other folder types. If you copy an eCommerce
catalog entry whose product type is not assigned to the destination catalog folder, the
new product type gets assigned to the folder. See also: Defining roles on page 1581;
Managing folder and content permissions on page 168.
To move or copy content between folders:
1. Select content items in a folder and choose Action > Cut or Copy (or right click
and choose Cut or Copy).
2. In the left panel of the Workarea, go to the folder to which you want to paste the
selected content, right click and choose Paste Content.
NOTE: If you are copying content, and the content exists in more than one
language, you are informed that some content exist in several languages and asked
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if you want to paste them in all languages or only selected languages. If you are
moving content, all language versions are moved.

Permissions for moving/copying content
Only users with any of these permissions/roles can move or copy content:
l

member of the Administrators user group

l

a user with Add, Edit, and Delete permissions for the source and destination
folders, or is a member of a group with those permissions

l

a user assigned the Folder User Admin role, or is a member of a group assigned
that role. See also: Defining roles on page 1581

l

a user assigned the Move or Copy role, or is a member of a group assigned that role

Effects of Mmoving/copying content
When content is moved or copied, the following changes are made.
l

The content inherits permissions, the workflow, and the default template from the
new folder.

l

The content’s Quicklink is moved or copied in the library to the destination folder.
However, the Quicklink remains the same (that is, the default template doesn’t
change). You can update this by editing the Quicklink.
NOTE: If the Link Management setting in the web.config file is set to true, you
do not need to update the quicklink. Link Management automatically finds the
correct template based on the current folder.

l

If the new folder already contains content with the same title, Ektron appends a
number to the title to make it unique. For example: ASP.NET Unleashed(2).

l

Library image paths inside the content remain the same.

l

If a destination folder has required metadata that the pasted content lacks, the
paste action is not affected. But, the next time a user edits that content, the user
must complete the required metadata before the user can save the edits.

l

If the content’s template is a Smart Form, it remains assigned even if the Smart
Form is not assigned to the new folder.

Deleting content
The Delete command lets you permanently delete content from your website. You can
only delete checked in or approved content. And, if the content is an eCommerce
catalog entry, you can only delete if it is not on an order and its status is checked in or
approved.
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NOTE: If you do not see a Delete button or menu option, you do not have
permission to delete, or the content status does not support deleting.
If content is managed by a basic or advanced workflow, it impacts the deletion
procedure. See also: Deleting content under basic workflow on page 763, Deleting
content in an advanced workflow on page 786.

Checking links before deleting
NOTE: It is good practice to check for broken quicklinks before deleting content.
Use the link checker button to locate all content with a link to the current content. The
identified content that will include a “dead” link after you delete the current content.
So, remove or change the obsolete links before deleting.
1. Go to the folder that contains the content.
2. Click the content and choose View Properties. The View Content screen appears.
3. Click Link Search (
current content.

). A screen displays each content item with a link to the

4. Click the linked content to access the View Content screen for the selected content.
5. Remove or change the Quicklink.

Deleting content from a Web page
1. Sign in and browse to the content you want to delete.
2. From the access point ( ), choose Delete. The View Content screen appears.
3. Click Delete (

).

4. Click OK.

Deleting content from the Workarea
1. Go to the folder that contains content you want to delete.
2. Hover the cursor over the triangle ( ) and choose Delete.
3. Click OK.

Deleting several content items in a folder
On the View Contents of Folder screen, you can delete several content items at once.
1. Go to the folder that contains the content you want to delete.
2. Choose Delete > Content. The Delete Contents screen appears.
3. Check the boxes of content items you want to delete.
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4. Click Delete Content.
5. Click OK.

Auditing changes
The Change Auditing feature provides the ability to audit or archive (or both) the
deletion of these CMS objects:
l

content

l

folders

l

menus

l

taxonomies

l

users

Audit means that a deletion (or attempted deletion, if the user is not authorized to
delete) is logged in the event log.
Archive means that, when an authorized user clicks the Delete option for content, a
folder or a taxonomy, instead of being deleted, the object is placed in a temporary
holding area. From here, it can be restored. Archiving is not available for menus or
users.
The Change Auditing feature is enabled through the following capabilities.
l

A recycle bin folder. A folder to which content and folders are archived when an
authorized user deletes them. Authorized users can restore these items.

l

Designated users who can delete items. Roles or user groups that authorize
users to
o delete/archive and restore content and folders
o

delete menus and users (no archive/restore option)

o

"delete" a taxonomy
NOTE: If you enable the ability to delete taxonomies, the delete action
changes the value of the taxonomy's Display to Users field to false. In
this state, the taxonomy does not appear on your website but is still
available in the Workarea. See also: Creating a taxonomy and its
associated categories on page 1359.

Once you designate these users, other users cannot delete these items.
NOTE: You can designate only some content types for Change Auditing. For
example, you can specify a user group that can archive and restore content and
folders, but not restrict who can delete menus and users.
l

Deletion Logging. The Event Log captures the deletion of these items.
Logging is independent of the other capabilities. So, even if you do not set up a
recycle bin nor users who can delete items, you can still track which users are
deleting items and when.
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Configuring change auditing
PREREQUISITE: ABILITY TO EDIT FILES IN YOUR SITEROOT FOLDER.

To configure Change Auditing, follow these steps.
1. If you want to authorize users to archive content and folders upon deletion:
a. Create a user group and add to it users who can archive and restore content
and folders. See also: Managing user groups on page 1566.
b. Log into the Workarea and create a folder to store archived content and
folders. Name it Recycle Bin.
c. Assign to the user group created in step 1a all permissions for the Recycle Bin
folder.
2. If you want to authorize users to delete menus, users, and taxonomies, set up
three roles.
o users who can delete users.
o

users who can delete menus.

o

users who can "delete" taxonomies. (See Note above.)

Assign appropriate users to each role.
3. In your siteroot/web.config file, find or create the appSettings key.
4. Add an entry for ek_cmsauditlogging and set it to true.
5. In your siteroot folder, edit the ektron.cms.auditing.config file.
6. In the <settings> area, set values for roles or user groups created above.
l MenuDeleterRole. Enter the role whose users can delete menus.
l

UserDeleterRole. Enter the role whose users can delete users.

l

TaxonomyDeleterRole. Enter the role whose users can "delete" taxonomies.
(See Note above.)

l

FolderDeleterGroup. Enter the group whose users can archive and restore
folders.
NOTE: There is no ContentDeleterRole. To give a user the ability to archive
and restore content, assign him to the user group created in step 1a.

7. While in the ektron.cms.auditing.config file, go to the <strategies> section
and define an action for each content type. For example, if you created a user
group named "folder_delete," assigned users to that group, and want authorize
them to archive folders upon deletion, enter <add name="FolderAuditing"
value="LogandArchive"/>.
As shown below, only certain actions are available for each content type. For
example, you cannot apply LogandArchive to menus and users because they
cannot be restored.
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Content Type

Logand
Archive

Logand
Delete

None

Content

X

X

X

Folder

X

X

X

X

X

X

X

X

X

X

X

X

Menu
Taxonomy

X

User

Logand
Exception

Content Type Actions
l

LogandArchive. Upon deletion, item is archived to recycle bin folder.
Authorized users can later restore it. Deletion is recorded in the Event log.

l

LogandDelete. Upon deletion, event is recorded in the Event log. Item cannot
be recovered.

l

None. Upon deletion, item cannot be recovered. Do not record deletion
attempt in Event log.

l

LogandException. Prevent deletion of item. Record deletion attempt in Event
log.

Restoring archived content and folders
To restore content, move it to its original folder and republish.
To restore a folder, move it to its original folder.

Restoring a taxonomy
To make a "deleted" a taxonomy reappear on the website, follow these steps.
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator role can perform these actions.
1. Log into the Workarea.
2. Go to Workarea > Content > Taxonomies.
3. Select the taxonomy.
4. Click Edit (

).

5. Check the Display to Users box.
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Sample ektron.cms.auditing.config file
<?xml version="1.0"?>
<cmsaudit>
<settings>
<add name="MenuDeleterRole" value="MenuDeleter"/>
<add name="UserDeleterRole" value="UserDeleter"/>
<add name="TaxonomyDeleterRole" value="TaxonomyDeleter"/>
<add name="FolderDeleterGroup" value="FolderDeleter"/>
<add name="RecycleBinFolderName" value="Recycle Bin"/>
</settings>
<strategies>
<!-- Valid values for ContentAuditing:
LogandArchive - Log and set content archived rather than delete content
LogandDelete - log and delete content
None
-->
<add name="ContentAuditing" value="LogandArchive"/>
<!-- Valid values for FolderAuditing:
LogandArchive - Log and move folder to configured recycle bin folder above
LogandDelete - Log and delete
None
-->
<add name="FolderAuditing" value="LogandArchive"/>
<!-- Valid values for MenuAuditing:
LogandException - Log and cancel delete action
LogandDelete - Log and delete
None
-->
<add name="MenuAuditing" value="LogandException"/>
<!-- Valid values for TaxonomyAuditing:
LogandArchive - Log and set taxonomy invisible to user
LogandException - Log and cancel delete action
LogandDelete - Log and delete
None
-->
<add name="TaxonomyAuditing" value="LogandArchive"/>
<!-- Valid values for UserAuditing:
LogandException - Log and cancel delete action
LogandDelete - Log and delete
None
-->
<add name="UserAuditing" value="LogandException"/>
</strategies>
</cmsaudit>

Writing a summary for content
A content summary is a short description that supplements the title. It can be used to
summarize a content item when several appear on a Web page, such as page of top
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news stories. Web developers can display a summary to attract readers to the full story.
Summaries can include images and text styling.
Content authors can compose a summary when creating or editing content. Or, a
summary can be automatically generated by extracting the first part of the item's
content.
TOP STORIES
Ektron Named a Rising Star (08-15-2010)
August 15, 2013, Nashua, New Hampshire, USA — Optimizely, an innovator
in Web content management and authoring, has been named a Rising Star as
part of the prestigious New England Technology Fast 50 Program.
Ektron Launches International Distribution Program(08-08-2009)
August 8, 2009, Nashua, New Hampshire, USA — Optimizely, an innovator
in dynamic Web content authoring and management with over 350,000 users,
today announced the launch of its international distribution program.

Automatically creating a summary
Ektron can automatically generate a summary for new content if none exists when it is
published. If the summary is blank and auto-summary is enabled, Ektron copies the
first 40 words of content to the summary. After the content is published, you can
update or delete the summary. If you delete a summary, it remains blank and is not
automatically generated again.
If a membership user edits content and wants to update the summary, the user checks
the Auto Generate New Summary field on the membership editing screen, and the
first 40 words of the content are automatically copied into the summary.

There is no limit on the number of times a membership user can automatically generate
a new summary.

Enabling auto summaries
To enable the auto-generation of summaries for content, apply these settings.
l
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open siteroot/web.config and set the value of ek_enableContentAutoSummary to
true
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l

open C:\Program Files
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.EktronServices40.exe.config
and change the value of GenerateAutoSummary to 1

To enable the auto-generation of summaries for assets, apply these settings.
l

open siteroot/web.config and set the value of ek_enableDmsAutoSummary to true

l

open C:\Program Files
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.EktronServices40.exe.config
and change the value of GenerateAutoSummary to 1

To disable the auto-generation of summaries, set the above values to false and 0
(zero).

Creating or editing a summary
1. Go to the folder in which you want to create or edit the content.
2. In the View Content screen, choose New > {type of content} or open the View
menu next to existing content and choose Edit. The Edit content screen appears.
3. Insert a Title and content, if needed.
4. Click the Summary tab.
5. Enter a summary for the content. The summary can include images, files, and
hyperlinks. To learn about the editor, see Editing in Ektron on page 605.
6. When done, click the appropriate button.
You can only edit the summary of content that is published, checked in, or checked out
by you. When you enter or edit existing content’s summary, its status changes to
checked out. After you create or edit the summary, click Check-In to check the content
in. From that point, you need to submit or publish it.

Making content private
Private content is available to Ektron administrators and users or membership users
with at least Read-Only permissions for its folder. Those users must log in to work with
private content. Unauthorized site visitors cannot see it. When you make a folder
private, the content and any subfolders are also private (if they inherit permissions).
You also can designate specific content items as private.
IMPORTANT: Private content is hidden from search results if your search provider
is Microsoft Search Server 2010. It is not hidden if you are using another search
provider.
To demonstrate private content, the following shows how a user’s permissions affect
the display of content in 3 scenarios.
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l

Site visitor

l

Logged in user with read-only permission

l

Logged-in user with edit permissions

Making a folder private
NOTE: You can only set content to private when inheritance is broken. See also:
Inheriting permissions on page 170.
1. In the Workarea, go to the folder that you want to make private.
2. Choose View > Properties.
3. Click View Permissions (

).

4. If necessary, uncheck the box that says Allow this object to inherit
permissions. (You must disable inheritance before you can make the content
private.)
5. Check the box that says The content in this folder is private and can only be
viewed by authorized users and members.
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6. Click OK. All content in the folder is now private. As new content is added, it is
automatically set to private.

Making content private
1. In the Workarea, go to the folder that contains the content you want to make
private.
2. Click the content item you want to make private.
3. Click View Permissions (

).

4. If necessary, uncheck the box that says Allow this object to inherit
permissions. (Inheritance must be disabled before you can make the content
private.)
5. Check the box that says This content is private and is NOT viewable on the
public website.
6. Click OK. The content is now private.

Making assets private
If assets are set to private, they are handled like other private content with one
important exception: if you do not use the following procedure, anyone can access an
asset by typing the URL of the asset into the browser’s address field.
If a user attempts to access the asset in any other way (such as, linking to it from a
Web page), the regular methods of making content private work. See Making a folder
private on the previous page and Making content private above.
To make assets private even if someone types their URL into the browser’s address
field:
NOTE: If site users receive a 404 Page Not Found error when trying to view
private assets, make sure you have completed the following steps.
1. Open your website’s web.config file, located in the site root folder.
2. Make sure the following line is uncommented.
<remove verb="GET,HEAD,POST" path="*"/>

3. Comment out the following lines with the <!-- and --> comment marks.
<httpHandlers>
<remove verb="GET,HEAD,POST" path="*"/>
<add verb="HEAD,OPTIONS,PROPFIND,PUT,LOCK,UNLOCK,MOVE,COPY,GETLIB,
PROPPATCH,MKCOL,DELETE,(GETSOURCE),(HEADSOURCE),(POSTSOURCE)"
path="*" type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<!-<add verb="GET,POST" path="*.doc"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<add verb="GET,POST" path="*.docx"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
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<add verb="GET,POST" path="*.xls"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<add verb="GET,POST" path="*.xlsx"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<add verb="GET,POST" path="*.ppt"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<add verb="GET,POST" path="*.pptx"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<add verb="GET,POST" path="*.vsd"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
<add verb="GET,POST" path="*.vsdx"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>
-->

The add verb statements in the middle are commented out.
4. Make sure the following line is uncommented.
<add verb="GET,HEAD,POST" path="*"
type="Ektron.ASM.EkHttpDavHandler.EkDavHttpHandlerFactory"/>

5. Save web.config.

Translating content into another language
See Translating content on page 1530.

Scheduling content
Scheduling lets you control when a version of content becomes visible on the website or
when it expires (and is removed).
When you create or modify content, you can select a “go-live” date and time. If you do,
after the content passes through the workflow, Ektron publishes the content to the live
site at the scheduled time. For example, your company is having a sale of the century in
a month, and everything is ready except the announcement. With this feature, you
create the Web content now and set it to go live a week before the sale.
The Ektron Windows Service manages these changes to your site. See also: Handling
background processing functions with the Ektron Windows Service on page 136.

Setting a start date

698

Ektron 9.40 SP1

Setting a start date

1. Edit a content item and click the Schedule tab.
2. Click Add (

) next to the Start Date field.

3. A calendar pops up. Select the date and time when this version of the content will
become visible on the website.

4. Click Done. The date and time appear in the Start Date field.
NOTE: When you select a time for content to go live, that time depends on the
server’s system clock. If the clock is incorrect, the content will not go live at the
intended time.
After you save the content, it appears on the Content Pending Start Date report,
which tracks content with a future start date. See also: Content pending start date
report on page 1060
After you set a go-live date and the content completes the workflow, the following
scenarios may occur:
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l

Setting the Go-Live Date on New Content
When you set a go-live date on new content, it becomes viewable on the
specified date and time as long as it completes the workflow. If a site visitor
accesses the page that contains the content before then, only the template
appears.
If a logged-in Ektron user browses your website, the user sees a gray border
around the content until the date specified. If the user clicks within the gray
border, the user can use the Preview option to see the new content.

l

Setting the Go-live Date on Existing Content
When you set a go-live date for changes to existing content, and it completes
the workflow, a logged-in Ektron user sees a gray border around the content
until the date specified.
When you view content on the website, you see the previously published
version. When the go-live date occurs, the new content replaces the previous
version, and its status changes to Active.

Setting an end date
1. Edit a content item and click the Schedule tab.
2. Click Add (

) next to the End Date field.

3. A calendar pops up. Select the date and time when this version of the content will
become unavailable on the website. To archive immediately, choose a past date.
4. Click Done. The date and time appear in the End Date field.
When content reaches its end date, it appears on the Expired Content report. See also:
Content to expire report on page 1061.
If your choice means the content will not appear on the website, you should have
another content item ready to replace it. If not, the template appears without the
content.

Setting archive options
Use content’s archive options to determine what happens upon reaching its end
date/time. To be eligible for any option, the content must reach its end date/time,
progress through its workflow, and be published. Until those events occur, the content
remains visible within its Workarea content folder and on the site.
Archive and remove from site (expire)
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l

Site visitors cannot view content upon expiration.

l

You can view and edit content within its folder by choosing the View > Archive
Content option. Also, you can find the content through a basic search and
advanced search (if the Archived check box is checked).
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Restoring content from archived to active state

Archive and remain on site
l

Content appears in a List Summary if the ListSummary control’s contentype
property is set to Archive_Content.

l

If content is an HTML form, the response page option appears. For example, if the
form displays a message after the user completes it, that message appears.

l

Content found by the search

l

Content visible within its taxonomy display

l

Content visible if site visitor enters exact path, such as
http://localhost/CMS400Developer
/dynamic.aspx?id=1014&__taxonomyid=14

l

Within Workarea, you can view and edit content within its folder by choosing the
View > Archive Content option. Also, you can find the content through a basic
search and advanced search (if the Archived check box is checked).

Add to CMS Refresh Report
l

Site visitors can view content upon expiration

l

You can view content in the active area of its folder and on the Refresh Report. See
also: Refresh reminder report on page 1060.

Restoring content from archived to active state
1. Go to its folder.
2. Choose View > Archived Content.
3. Hover the cursor over the content, click the triangle ( ), then Edit from the dropdown menu. The Edit Content in Folder screen appears.
4. Click the Schedule tab.
5. Remove the End Date or change it to a future date.
6. Submit the content for publishing. When the content is published, it will no longer
be archived.

Managing versions of content
You can view and restore past versions of Published content. After viewing previous
versions of content, authorized users can replace the current version with any previous
one. See also: Managing folder and content permissions on page 168.
Ektron assigns a unique number to each content version. The number is increased by
one tenth if the content is checked in but not published. If the content is published, the
next whole number is assigned. For example, if the current version is 1.0 and you check
in that content, that version is 1.1. If the next editor publishes it, that version is 2.0.
Published version are indicated by an arrow.
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If content versions are purged, the numbering scheme restarts with the remaining
content.
NOTE: The Purge History feature deletes historical versions of content according to
user-defined criteria. Therefore, some previous versions may be unavailable. See
also: Purging content history on page 167.

Viewing content history
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l

To access content history from the Workarea, click on a piece on content. The View
Content Screen appears. Then click View History ( ).

l

To access content history from a Web page, click the access point ( ) and choose
View History.
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The window displays the following information for each version.
o

a Compare column lets you compare Web traffic analytics data between any 2
Published versions.

o

Ektron assigns a unique number to each saved version of a content block.

o

an arrow indicates a Published version. Versions without an arrow indicate
content that was checked-in.

o

date and time version was checked in or published

o

content title

o

last user who edited content

o

comments entered by user to describe the changes

To view any version, click its title to display the Content History window for that
content.
There are 3 view modes.
l

Diff. Compares Published version of content to staged version

l

Published. Displays currently published version

l

Staged. Displays the staged version of content.

Comparing versions of content
If content can be compared with another version, the View Difference button (
appears in the content history area or the Web page view.

)

NOTE: The first time you use the View Content Difference screen on a client
machine, you are prompted to install the differences tool. When the installation
program completes, close and reopen the View Content Difference feature.
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There are varying versions of this procedure. Consult your system administrator to
determine the correct procedure for you.

Comparing content (32-bit server/32-bit client)
NOTE: Content compare does not work with PageBuilder pages.
1. Click View Properties on content that you want to compare.
2. Click History ( ). The View Content History screen appears.
3. Click a version that you want to compare with the most recently published version.
4. Click View Diff. The View Content Difference screen highlights changes to selected
content as shown in the following example.

l

Difference. Both versions:
o content that only appears in the version on the This Content tab is
highlighted in yellow
o

content that only appears in the currently published version is red

o

unchanged content is black

l

Last Published —Currently-published.

l

This Content. The version you are comparing the currently-published content
against.

Comparing content (64-bit server/32-bit client)
1. Click View Properties on content that you want to compare.
2. Click History ( ). The View Content History screen appears.
3. Click a version that you want to compare with the most recently published version.
4. Click Compare Analytics. The CMS Compare screen highlights changes to
selected content as shown in the following example.
704

Ektron 9.40 SP1

Restoring a previous version

l

Print. Sends content to local or network printer. This option prints the
currently displayed content, whether it is the compared, published, or staged
content.

l

Save. Saves the version of the content (in HTML) to your local machine or
network. When saved as a physical file, you can edit the HTML. However, the
changes are not saved to the Web Server.

l

Setup. Opens setup dialog box to configure the settings. Typically, only an
administrator would use this.
o Compare visual aspect. Compares content as it would appear on a Web
page

l

l

o

Compare source code. Displays compared content as source HTML

o

Ignore All. Blank (whitespace) characters are ignored

o

Smart Detect. One or more consecutive whitespace characters are
treated as a single separation sequence. That is, multiple whitespace
characters are ignored.

o

Detect All. Blank (whitespace) characters are treated as any other
character.

o

Ignore case. Determines whether comparison is case sensitive. For
example, if you check this box, the strings “Bob” and “BOB” are not
highlighted because their only difference is the case of the characters.

o

Ignore format attributes. Determines whether comparison ignores
changes in text-formatting attributes (HTML Visual Analysis only).

Help. Displays additional information about the compare feature.
Exit. Closes the window.

Restoring a previous version
PREREQUISITE
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You have permission to restore the content in question. See also: Managing folder and
content permissions on page 168.
1. Open the folder that contains the content.
2. Click the content item.
3. Click History ( ).
4. Select a version that you want to restore.
IMPORTANT: Ektron recommends restoring a Checked In version of content,
because this restores all content attributes. If you restore a published version,
metadata is not restored.
To learn how to recognize checked-in content on the View Content History
screen, see Managing versions of content on page 701.
5. Click Restore. The content history window closes, and you return to the View
Content page or the Web page, with the content in a Checked In status.
If desired, check out the content to make additional changes. Select the workflow
to perform on the content. When the historical version is approved, it is published
to the website.

Removing applied XSLT
You can only remove an applied XSLT when viewing historical versions of XML content.
If you remove the applied XSLT, you can view the content without the irrelevant XML
tags.
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Removing applied XSLT

IMPORTANT:
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Working with assets in the
Document Management System
The Document Management System (DMS) lets you import Microsoft Office files and
other types of files into Ektron. Collectively, these files are called assets. When you
import and save an asset to Ektron, a copy of it is saved to the Document Management
server. Then, whenever you edit and save the asset, a new copy is stored, letting you
review and, if needed, restore a prior version.
To edit an asset, download it to your local computer, edit it and the upload it again into
Ektron.
Assets have the following qualities:
l

can be stored in folders with other content, or in separate folders that you create
just for them

l

are assigned content IDs

l

can have summary, metadata, comment, task, schedule, and taxonomy
information

l

inherit permissions and workflow from their folder properties

l

progress through the workflow process (check out, check in, publish)

l

retain a history so you can restore earlier versions

l

can be searched

l

support foreign language editions

l

can have a task assigned to them

l

appear on content reports

l

update the Smart Desktop listing of files awaiting approval, checked out, to expire,
and so on

After you save an asset, you can update and track it like other content. Assets are
treated like other content for security purposes. A system administrator applies security
to each folder, determining which user groups can perform which tasks on its content.
For more information, see Managing folder and content permissions on page 168 and
Checking document management permissions on page 725.
The AssetControl and ImageControl server controls are associated with DMS content.
The following image shows the asset workflow.
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Storing external files as library items vs. assets
You may save an external file in Ektron as a library item or an asset. The following list
compares each option. See also: Working with files in the library on page 733.
l

l

Asset
o First class content items
o

All content management features, such as search-ability, history, permissions
and workflow, scheduled go-live date, applying a template, and so on.

o

Used primarily for text-based documents, like Office documents and PDFs

o

Can import and store images, if history and workflow are needed

o

Works well when displaying a resource within a content block

o

Uses logical folder paths, which do not appear in the file system

o

Checks the database to find file location on the Web server, then sends that
location to the client

Library
o Simple resources, such as a company logo
o

No content management features
n Text-based documents, like Office documents and PDFs, are not
searchable

o

Works well when providing a link to download an item
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Supported types of assets
By default, Ektron lets you store these file types as assets. An administrator can add or
delete file types on the Settings > Configuration > Asset Server Setup screen.
NOTE: Ektron does not support double extensions, such as filename.aspx.vb.
l

Microsoft Office 2000 or later documents. Word, Excel, Powerpoint, Project,
Publisher, Visio, and so on.

l

Managed files. *.zip files, PDFs, *.txt files

l

Image Assets. Graphic files such as *.gif and *.jpeg

l

Multimedia files. *.swf, *.mp3, *.wav. *.avi

If you try to upload an unsupported file type, an error message appears.
To learn how to edit the supported asset types, see Configuring document management
below.

Browser notes
l

You can load multiple DMS documents with Internet Explorer, but not other
browsers. See Adding multiple DMS documents on page 715.

l

The Edit in Microsoft Office option is not supported in Chrome

Configuring document management
This section explains configuring the Document Management feature. By changing
these settings, you can:
l

update Document Management server settings

l

change which file types are allowed on the Document Management server

l

set the View Type

There are 2 ways to configure a Document Management server:
l

Asset Server Setup screen

l

AssetManagement.config file

In either case, you are editing the AssetManagement.config file. While the Workarea
screen provides a quick way to update this information without accessing the Ektron
server, some tags can only be updated in the AssetManagement.config file.

Updating asset configuration settings
You can update some AssetManagement.Config tags from the Workarea.
PREREQUISITE
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l

Only Administrators Group members can access the Asset Server Setup
screen.

1. In the Workarea, go to Settings > Configuration > Asset Server Setup. The
Asset Management Configuration screen appears.

2. Click the File Types Edit button ( ).
3. Change the supported file types.
4. Click Save.
The following list describes the AssetManagement.Config file’s tags that you can edit
from this screen in the Workarea.
l

DomainName. Can be Domain Name, IP Address or Machine Name. An example
is: localhost. This is the address a Web client system uses to open managed
documents through HTTP.

l

FileTypes. Files types that users are allowed to upload to Document Management.
The default file types are:
.doc, .xls, .ppt, .pdf, .gif, .jpg, .jpeg, .log, .vsd, .dot, .zip,
.swf, .wma, .wav, .avi, .mp3, .mp4, .rm, .wmv, .ra, .mov, .odb,
.odt, .odf, .odp, .odg, .ods, .png, .docx, .xlsx, .pptx, .vsdx,
.wmf, .xml, .htm, .html, .flv
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_DMSFileTypeWhiteList.
See also: Using the file type whitelist on the next page
Administrators control which file types are allowed by editing the
AssetManagement.config file. Reasons for limiting file types include:
l

Security. For example, you do not want users to load .exe files to your Ektron
server

l

Ease of management. For example, you want your Ektron server to store .doc
files only

The <FileTypes> tag in the AssetManagement.config file contains the file types
users can upload.

Ektron Reference

711

Managing content

To add or remove a file type from the list:
1. Edit the Workarea > Settings > Configuration > Asset Server Setup >
Asset Management Configuration screen.
or
Open the siteroot/AssetManagement.config file.
2. Edit the FileTypes=”” element. All file types must appear between the
quotes. For example, FileTypes=”*.doc,*.xls”.
NOTE: Use a comma to separate file types. Also, format file types as
wildcard.extension. For example, adding an .mp3 file type after *.zip looks
like this: *.zip,*.mp3
3. Add or remove any file type.
4. Save and close the screen or AssetManagement.config file.
l

LoadBalanced. Enables Load Balancing for assets. Set to 1 to enable. See also:
Load-balancing assets on page 101

l

ServerName. The name of the server that hosts Ektron.

l

StorageLocation. The folder location where Published assets are stored. For
example: C:\assetslibrary

l

WebShareDir. The folder that stores temporary data files waiting to be checked
in, saved, or published. For example: dmdata

Using the file type whitelist
The siteroot/web.config file property ek_DMSFileTypeWhiteList contains the same
default file types as those on the Asset Management Configuration screen and
AssetManagement.config file.
<add key="ek_DMSFileTypeWhiteList" value="*.odb,*.ods,*.odg,*.odp,*.odf,*.odt,*.doc,
*.xls,*.ppt,*.pdf,*.gif,*.jpg,*.jpeg,*.log,*.vsd,*.dot,*.zip,*.swf,*.wma,*.wav,*.avi,
*.mp3,*.mp4,*.rm,*.wmv,*.ra,*.mov,*.png,*.docx,*.xlsx,*.pptx,*.vsdx,*.wmf,*.xml,*.htm,
*.html,*.flv" />

A server administrator can use this property to restrict which file types may be
uploaded to Ektron. For example, if an Ektron administrator wants to add a new file
type, someone who can edit files on the Ektron server must first add it to the web.config
ek_DMSFileTypeWhiteList property. This provides additional security over which file
types can be uploaded to Ektron.
Conversely, if a server administrator wants to remove an allowed file type from the
Asset Management Configuration screen/AssetManagement.config file, the
administrator must first remove it from the ek_DMSFileTypeWhiteList property.

Managing assets
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Methods for importing assets

DMS can store and help you manage assets.
When you use the New > DMS Document file import option, you enter an Ektron title
for the file. When you import a file using any other method, its title is the file name
without the extension. So for example, mypicture.jpg becomes mypicture in Ektron.
While it may appear that the file extension was removed, it is retained and reappears
for assets when you use the Edit option, on the View Contents of Folder screen. The
original file extension also appears when you check out.
You cannot import a file whose name and extension match a file already in the folder. If
you import a file of the same name but a different extension into the folder, a number is
appended to the file name. For example, mypicture(2).
You cannot import files whose name includes a percentage sign (%) or ampersand (&).

Methods for importing assets
Ektron provides several ways to import assets.
l

l

l

New > DMS Document (All browsers) from View Contents of Folders screen
o Can enter summary, metadata, and so on for each asset
o

Can create unique title for each asset

o

Can check in or submit for approval

o

Uploads one asset at a time

New > Multiple DMS Documents (Internet Explorer with MS Office) from View
Contents of Folders screen
o Uploads several files at once
o

Can apply same summary, metadata, and so on to all files

o

Can check in or submit for approval

o

Asset title taken from Windows file name

Add Asset button on the View Contents of Folder screen (
o File Upload tab (all browsers)
o

l

)

Multiple DMS Documents tab (Internet Explorer with MS Office)
n Same as Adding multiple DMS documents on page 715 except there is no
check-in option
n

Can upload several files at once

n

Asset title taken from Windows file name

Drag and drop to mapped network folder; Adding assets to a mapped
network folder on page 718
o User doesn’t need to install or learn Ektron software
o

Can drag/drop folder structure; Ektron recreates it in Workarea

o

Title taken from Windows file name

o

Content status is checked in; submitting for publishing is separate step
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o

Cannot assign language to content

o

Cannot work with content in language other than default

Restrictions and warnings about importing assets
l

You can only import assets using a method listed in the previous section. You
cannot simply drop files in the siteroot/assets or siteroot/PrivateAssets
folder then manage them using Ektron.

l

Only users with Add folder permission can import files to it. See also: Managing
folder and content permissions on page 168.

l

You cannot import to a folder for which XML Smart Forms are required. See also:
Assigning a Smart Form to a folder on page 903.

l

If you are using the Firefox browser, you may not be able to upload a large file. To
resolve this, go to Firefox >Tools > Options > Advanced > Network and
increase the Offline Store to a size larger than the file being uploaded.

l

With MS Office 2010, you cannot upload more than 100 files at a time.

l

With MS Office 2010, files greater than 100 megabytes may fail if your computer's
memory is insufficient. In general, do not upload larges file via the Multiple DMS
Documents option.

Adding an asset
To add an asset via the New > DMS Document menu option:
1. Go to the folder in which you want to place the document.
2. The default language icon appears next to the screen title. To create a document
for a different language, click View > Language and select the language.
3. Click New > DMS Document. The following screen appears.

Or, from the View Contents of Folder screen toolbar, click Add Assets (
screen appears.
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Adding multiple DMS documents

4. Click Browse and go to the file you want to import.
5. Enter a Title. It cannot include these characters: *> <|
NOTE: If you want to retain the original document name, insert the full
filename into the Title field. For example, enter mydocument.doc.
6. Use the Content Searchable checkbox to determine if the content should be
searchable.See also: Making content searchable on page 371.
7. If desired, add a summary, metadata, a schedule, and comments. See also:
l Scheduling content on page 698
8. Check in or submit the content for publishing as you would HTML content.

Adding multiple DMS documents
This option requires Internet Explorer and Office 2003 or higher on your computer.
Also, you must enable ActiveX controls in your browser settings. To do this, open
Internet Explorer and go to Tools > Internet Options > Security Tab > Custom
Level button. Within that screen, under ActiveX controls and plugins, find Script
ActiveX controls marked safe for scripting* and click Enable.
IMPORTANT: If you will apply the same information (summary, metadata,
categories, and so on) to several files, place them in the same Windows folder before
starting this procedure.
See also: Managing Microsoft Office assets on page 720.
To add assets to Ektron via the New > Multiple DMS Documents menu option:
1. From the Workarea, select the Content tab.
2. Select the folder in which you want to place the documents.
3. Click New > Multiple DMS Documents.

Ektron Reference

715

Managing content

4. Select your version of MS Office and click OK. If Office 2003 or 2007 is installed as
well as Office 2010, choose Office 2010. The Multiple Document Upload option
uses MS Office to perform the upload. The upload screen appears.
NOTE: If you later change your computer's Office version, update this setting
from the Add Assets button > Multiple DMS Document option > Switch Office
version option.
5. Open Windows Explorer in a separate window, then drag and drop files onto the
screen. Or, you can Browse for files instead. You can only import files from one
folder at a time.
6. If Ektron requires you to apply metadata or a taxonomy category to the content,
complete all required information.
7. To check in the files, click Check In. To submit the files into the workflow, click
Submit or Publish.
NOTE: If your website uses an https secure site setting, you may see errors after
uploading assets. If this occurs, open your site’s web.config file and change the
value of the add key="ek_UseSSL" setting to true.

Managing multimedia assets
Multimedia files contain audio, video, or both. File types include .wav, .mpeg., .swf,
.avi, and .wma.
Ektron supports multimedia files that run on these players.
l

WindowsMedia®

l

Quicktime®

l

Realplayer®

l

Flash®

If you import a multimedia file that does not play on a supported player, it is treated like
any other asset but cannot be played within Ektron. If you try to play a file in the
Workarea, or a site visitor tries to play a file but no supporting media player exists on
the user’s computer, you are prompted to download and install the player.
NOTE: To learn about importing embedding external content (such as content from
YouTube, Vimeo, DailyMotion, Google maps or an Iframe) into HTML content via the
editor, see Embedding external content on page 626.
Every multimedia file type has a corresponding MIME type. For example, an mp3 file's
MIME type is audio/mpeg. Supported MIME types are defined in the mediasettings
element of the web.config file as follows:
<add key="application/x-shockwave-flash" value="Flash" />
<add key="audio/x-wav" value="WindowsMedia, Quicktime, Realplayer" />
<add key="audio/x-wav-default" value="WindowsMedia" />
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<add
<add
<add
<add
<add
<add
<add
<add
<add
<add
<add

key="audio/x-pn-realaudio" value="WindowsMedia, Quicktime, Realplayer" />
key="video/x-avi" value="WindowsMedia, Quicktime, Realplayer" />
key="video/x-avi-default" value="Quicktime" />
key="video/x-msvideo" value="WindowsMedia, Quicktime"/>
key="video/x-msvideo-default" value="WindowsMedia"/>
key="audio/x-ms-wma" value="WindowsMedia"/>
key="audio/mpeg" value="WindowsMedia,Quicktime"/>
key="video/x-realvideo" value="Realplayer"/>
key="video/x-ms-wmv" value="WindowsMedia"/>
key="audio/x-realaudio" value="Realplayer"/>
key="video/quicktime" value="Quicktime"/>

To determine if a multimedia file type is supported, go to HTML Multimedia, then go to
the web.config file section to see if the MIME type exists and insert the player name
within the value element. For example:
<add key="audio/mpeg" value="WindowsMedia"/>

In this example, WindowsMedia is the only supported player for mp3 files. If you know
that other players can run mp3 files, insert additional players after WindowsMedia. To
get the exact name of the player, review the value elements in web.config file section.
If you want Ektron to support additional MIME types, add them within the
<mediaSettings> element using the following syntax:
<add key="MIME type/subtype" value="supported media player(s)"/>

For example:
<add key="video/x-ms-asf" value="WindowsMedia"/>

To identify a player as the default for a MIME type, use the following syntax within
web.config.
<add key="MIME Type/subtype" value="default player"/>

For example:
<add key="video/x-msvideo-default" value="WindowsMedia"/>

You must also add new file types to the supported file list in the
assetmanagement.config file. See also: Using the file type whitelist on page 712.
After a multimedia file is imported into Ektron, you can view supported media players’
properties on the Edit Content screen's Content tab. Players defined for the file’s MIME
type are checked. You may uncheck any media players that you do not want to operate
a particular file.
l

If a default media player is defined for a MIME type in web.config, you cannot
uncheck its checkbox.

l

If the file is supported by several players, first check the player whose properties
you want to modify, then edit its properties.

Ektron Reference

717

Managing content

The Width and Height fields determine the size (in pixels) of the media player when it
appears in the Workarea and on your website. The remaining properties are determined
by the media player (QuickTime in the example above).
When you visit a page that hosts a multimedia file, Ektron tries to match media players
on the user’s computer with those defined in the web.config file for the file’s MIME
type. Ektron then displays a list of choices for every supported media player for the file.
You can change the multimedia player’s style properties by modifying the EKTTabs.css
style sheet. This file is installed to sitefolder/Workarea/csslib.
For example, you can change the color of the text that selects a player to red by
changing the value of the color property.
.EktTabActive
{
padding: 2px 2px 2px 2px;
top:10px;
text-decoration:none;
position: relative;
background-color:white;
border: solid thin navy;
color:Red;
font-weight:bolder;
}

Here is the result.

Adding assets to a mapped network folder
You can set up a mapped network folder then drag and drop folders or assets into it.
You can also delete and move assets using the mapped network folder. The advantage
of this method is that you can upload documents without installing or learning how to
use Ektron.
When using drag and drop, you can choose individual assets or a folder. Only supported
file types may be uploaded. If you choose a folder, Ektron recreates that folder
structure, even if it is several levels deep.
NOTE: You cannot choose a language for assets in a mapped network folder
because they are automatically assigned the Ektron default language (set in the
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siteroot/web.config file at the ek_DefaultContent Language element). Also, you
can only work with assets in the default language.
PREREQUISITE
l

Basic Authentication must be disabled in IIS.

l

You must have the path to your Ektron website.

l

You must have an Ektron username and password.

l

You must verify that WebDav is installed on your client system, and
enabled on the Ektron server that hosts your site. See
http://www.iis.net/learn/publish/using-webdav/using-the-webdavredirector.

1. Log onto the server that hosts Ektron, or a client that can access Ektron.
2. Open Windows Explorer.
3. For Windows 2008 server, click Start > Computer > Map Network Drive. The
Map Network Drive screen appears.
For Windows 8, open File Explorer then click Computer > Map Network Drive.
4. Click Connect to a website that you can use to store documents and
pictures. A wizard screen appears.
5. Click Next. Another wizard screen appears.
6. Click Choose a custom network location and click Next. A third wizard screen
appears.
7. Enter the path to your Ektron site, followed by the ekdavroot folder. For example,
http://CMSMIN870037/ekdavroot and click Next. An Ektron login screen
appears.
8. Enter your username and password and click OK. Another wizard screen appears.
9. Name the network drive and click Next. You use this name to identify the folder
when dropping assets into it. The Finish screen appears.
10. In Windows Explorer, open the new network folder (it appears under Computer >
Local Disk (C:)). Notice that its structure mirrors your Workarea folders.
11. Go to the folder to which you want to drop files, and drag and drop them.
NOTE: Your access to folders and ability to drop files into them are determined
by your Ektron folder permissions (collected in Step 7). See also: Managing
folder and content permissions on page 168
12. If an asset is not supported, an error message appears: An error occurred
copying some or all of the selected files. However, all supported assets are
uploaded.

Status of asset saved to mapped network folder
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The status of an asset dropped in a mapped network folder depends on the workflow
and the user who signed in to the folder.
l

If you are the last approver, or if there is no workflow, its status is Approved.

l

If there is a workflow and you are not the last approver, its status is Checked In (I).

Also, if the content’s folder requires metadata or a taxonomy category which has not
been entered, its status is Checked In (I).

Removing mapped network drives
Ektron’s DMS feature creates a mapped, ekdavroot network drive for many functions.
For example, if you sign on to Ektron and create a new folder, a new mapped,
ekdavroot network drive is created.

If you find that ekdavroot folders clutter up your My Network Places folder, you can
delete them. Deleting ekdavroot folders has no impact on your ability to use Ektron.

Managing Microsoft Office assets
To learn about importing Microsoft Office assets, see
l

Methods for importing assets on page 713

l

Restrictions and warnings about importing assets on page 714

l

Adding an asset on page 714

This section shows you how to do the following:
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l

Deleting an Office document on page 722

l

Updating an Office document on the facing page
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l

Saving an Office document on the next page

l

Saving an Office document in HTML format on page 723

PREREQUISITE

Before you begin working with Microsoft Office documents:
l

Your computer should have MS Office 2003 or higher.

l

Problems can arise if you try to open a document created with Office
2007 or 2010, and your computer has an earlier version of Office. The
best solution is to upgrade to Office 2007/2010.
If you cannot, install the Microsoft Windows Compatibility Pack. See
Microsoft Office Compatibility Pack for Word, Excel, and PowerPoint File
Formats.
When installed, you can work with Office 2007/2010 documents using
an earlier version of Office.

l

If you import an Excel spreadsheet then click it from its Ektron folder,
you see Download this file name. Click the download link to view the
file.

Updating an Office document
To work with an Office document, you check it out and save it to your computer, edit it,
then upload it to Ektron.
While an Office document is checked out, only you or an Ektron administrator can check
it back in. Other users cannot edit it. You may use this feature to work on the document
on your computer, copy it to another computer, or even email it to someone who does
not have access to Ektron.
Follow these steps to update an Office document.
IMPORTANT: There are several ways to import a document into Ektron. Some
methods retain the original file name while others let you assign a name. When you
check out and save a document to your computer, it is saved under the original file
name, which may be different from its Ektron name. The original file name is on the
screen that appears after you select Check out and Save as. Make note of the
original file name, because you use it to identify the file after it is saved to your
computer.
1. Go to the folder that contains the Office document.
2. Click the triangle ( ) next to the document.
3. Select Check out and Save As.
4. Click Save. The document’s status changes to checked out (O).
NOTE: Your browser controls the location of downloaded files.
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5. Edit the document in Office.
NOTE: If you change your mind and do not edit the document, but simply close
Office, the document remains Checked Out (O). Use the Check In menu option
to check it in.
6. Within Office, click File > Save As and select a folder to which to save the
document. Do not change the file name.
7. Within the Ektron folder, open the document's folder and select the document.
8. From the context menu, click Check In.
9. From the context menu, click Edit Properties.
10. Click the Browse button and go to the folder selected in Step 6.
11. Select the edited document.
12. From the toolbar, click Check in or Publish.
13. You are asked to confirm the file replace. Click Yes. The revised document is saved
in Ektron.

Deleting an Office document
NOTE: You must have delete permissions for the folder that contains the document.
See also: Managing folder and content permissions on page 168. Also, it is good
practice to check for broken quicklinks before deleting documents. See Checking
links before deleting on page 689.
To delete an Office document:
1. In the Workarea, open the folder that contains the document.
2. Hover the cursor over the triangle ( ) next to the document and click. A drop-down
menu appears.
3. Click Delete.
4. Click OK.
If a Basic Workflow is applied to the document, deleted content must be approved
before it is removed. If you are the last approver in the workflow, the content is deleted
immediately. See also: Approving or declining content on page 759.

Saving an Office document
You would typically save an Office document to your computer to distribute it to others,
or if you want a personal copy. You should not save a document to your computer if you
plan to edit it then replace the version in Ektron—doing this may overwrite edits made
by other users.
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If you want to edit a document, use the Check out and Save As menu option. The
option sets the content to checked out status, which prevents non-administrator users
from editing it until you check it back in.
To save an Office document:
1. Go to the folder with the Office document.
2. Hover the cursor over the triangle ( ) on the right end of the document and click
Save As.
3. You are asked if you want to open or save the document. Choose Save.
4. Select a folder to which you want to save the document.

Saving an Office document in HTML format
This feature converts Office documents to HTML format, which means they are
formatted to display within a browser. As a result, anyone visiting your site can view
the document, whether or not Microsoft Office is installed on their computer.
NOTE: You can publish only Microsoft Word and Excel documents as HTML. Ektron
does not support publishing Powerpoint or Visio documents as HTML.
There are 2 ways to save an Office document in HTML format.
l

Drag and drop an Office document into Ektron and use the Edit in MS Office
option to save it in HTML format. You don’t need to know the path to your website’s
root folder.

l

Open an Office document on your computer and save it in HTML format to the
ekdavroot folder in your Web root. You don’t need to drag and drop document to
Ektron.

Regardless of how you save Office documents as HTML, be careful to set up procedures
that prevent HTML content from being overwritten. For example:
1. You save a Word document as .html.
2. Someone edits the HTML version.
3. You save the original Office Document as .html again.
In this scenario, the edits made in step 2 are overwritten by step 3. You should
establish procedures to avoid such problems.

Saving an Office document as a Web page
When saving a Word document, after you choose Save as from Word’s File menu,
there are 2 choices for saving as HTML.
NOTE: When saving an Excel document, Save as Web Page (*.htm, *.html) is
the only option.
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l

save as Web Page

l

save as Web Page Filtered

NOTE: For a description of the differences between these options, see About using
filtered HTML.
You should save as Web Page, Filtered because the resulting HTML is almost identical to
the original document. The save as Web Page is not a good option because its HTML
content does not match the original document and may cause problems when being
edited.

Handling images embedded within a Word document
If you save an Office document that includes images, they appear when anyone is
editing the document as well as when it appears on your website. In addition, the
images are saved to the corresponding Ektron Library folder. In this way, other Ektron
users can apply the images to HTML content as needed.
See also: Working with files in the library on page 733

Saving an Office document as .html from Ektron
This procedure assumes the Office document has been saved to Ektron. Procedures for
doing this are explained in Managing Microsoft Office assets on page 720.
1. Go to the folder that contains the Office document you want to save as .html.
2. Hover the cursor over the triangle ( ) on the right end of the document you want to
save
3. Click Edit in Microsoft Office. The document opens within Office.
4. From Office’s File menu, select Save as Web Page.
5. In the Save as Type field, select Web page, Filtered (*,htm, *.html). See
also: Saving an Office document as a Web page on the previous page
6. Click Save.
7. You may be warned about formatting features not supported in HTML. Click
Continue.
8. A dialog prompts you to enter your Ektron user name and password.
9. Ektron’s folders appear in a Save as window. The folder that contains the Word
document is the default folder. Select that or any other Ektron folder and click
Save.
10. The Office document is saved as an HTML file into Ektron.

Saving an Office document as .html from your computer
1. Open the Office Document.
2. Click File > Save as (*,htm, *.html).
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3. Click My Network Places and go to ekdavroot folder on the server that hosts
Ektron.
4. Ektron’s folders appear. The folder that contains the Word document is the default
folder. Select that or any other Ektron folder.
5. In the Save as Type field, select Web page (*.htm, *.html) or Web Page,
filtered (*.htm, *.html). See also: Saving an Office document as a Web page on
page 723.
6. Click Save.
7. You may be warned about formatting features not supported in HTML. Press
Continue.
8. A dialog prompts you to enter your Ektron user name and password.
9. The Office document is saved as an HTML file into Ektron.
The status of the document depends on the workflow and the user who signed in when
the mapped network folder was created.
l

If you are the last approver, or if there is no workflow, its status is Approved.

l

If there is a workflow and you are not the last approver, its status is Submitted.

Checking document management permissions
If you are having any problems with permissions, use this section to verify that your
user and folder settings are assigned properly. You can view current user permission
settings for affected folders in Viewing network server diagnostics on page 2049.
When the Document Management functionality is installed, permissions are granted to
several users for the following folders.
l

root/assetLibrary. Set by the user during installation, you can view and change the
path to this folder in the Workarea Settings > Configuration > Asset Server
Setup > Storage Location.

l

siteroot\AssetManagement\dmdata. Set by Ektron during installation, dmdata
has settings for both the file system and IIS.

l

siteroot/assets. Set by Ektron during installation, the Asset Library folder contains
file assets uploaded to and managed by DMS. You can view and change the path to
this folder in the Workarea Settings > Configuration > Asset Server Setup >
Storage Location.

The assigned permissions vary depending on your server’s operating system.
The following table shows which users and permissions should be enabled for the
folders listed above. Use this information to troubleshoot permission problems. See
also: Managing folder and content permissions on page 168.
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User

Windows
2000 Pro or
XP Pro

Windows
2003
Server

Windows
2003
Enterprise
Edition

IIS_WPG User
IUSR_
The IUSR_ account is required only if
Impersonate is set to True in
web.config, and its username and
password attributes are not specified.
If impersonate is set to false
(default setting), the IUSR_ account
may be harmlessly removed from the
folders listed.
IUSR_Group

ASP.NET User
User Defined (The User Defined user
account is required only if
Impersonate is set to True in
web.config, and its username and
password attributes are specified.)
The following list shows extended permissions for use with the Document Management
functionality.

726

l

Traverse Folder / Execute File

l

List Folder / Read Data

l

Read Attributes

l

Read Extended Attributes

l

Create Files / Write Data

l

Create Folders / Append Data

l

Write Attributes

l

Write Extended Attributes
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l

Delete Subfolder and Files

l

Read Permissions

Removing Front Page server extensions
When you remove FrontPage Server Extensions from the Web root, the extensions also
are removed from folders under the Web root folder.
1. Click the Windows Start button > Control Panel > Administrative Tools >
Internet Information Services Manager.
If you're using Windows 8 or 2012, press the Windows key (

)/Q then enter IIS.

2. In that screen, choose Sites > Default Web Site.

3. Right click the mouse and select All Tasks > Remove Server Extensions.

Troubleshooting assets
This section explains how to fix problems that may occur with Ektron assets.
Ektron Reference
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Problem. Cannot drag and drop assets into Ektron
Symptom. You cannot drag and drop assets into Ektron.
Resolution. See Removing Front Page server extensions on the previous
page.
Problem. Target Directory Already Exists
Symptom. While trying to drag and drop an asset, an error message
appears: The target directory already exists.
Resolution. Check the impersonate element of the web.config file. If it is
set to true, make sure the anonymous access account has at least write
access to the dmdata and assets directories.
Problem. Cannot Update Published DMS Documents
Symptom. When you try to publish DMS documents, Ektron sometimes
does not allow them to update.
Resolution. Make sure your production server is not running Windows XP.
You cannot use XP as a production server for DMS.
Problem. Removing aspnet_isapi.dll from the List of Wildcard Application Maps
Symptom. When you try to upload an asset, you get the error message
“Failed to upload documents.”
Cause. Remove the aspnet_isapi.dll from the list of Wildcard Application
Maps.
Resolution.
1. Open IIS.
2. Go to your Ektron website.
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3. Underneath the website, click Asset Management > dmdata.

4. Right click dmdata and choose Properties.
5. Click the Virtual Directory tab.
6. Click Configuration.
7. Look in the Wildcard Application Maps area. If aspnet_isapi.dll
appears, remove it.
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8. Click OK.
Problem. ERRMSG: AssetManagement error: Failed to save asset
Symptom. After recently moving the ASM database to a new SQL server
that has never hosted an ASM database, the following error appears while
adding a DMS asset.
AssetManagement error: Failed to save asset.
Internal Message: RAISERROR could not locate entry for error 2000000002 in
sysmessages. at
Ektron.ASM.Documents.Asset.Create(enAssetStatus state) at
Ektron.ASM.Documents.AbstractAssetManagement.Create(AssetMetaData
assetMetaData, enAssetStatus state) at
Ektron.ASM.PluginManager.PluginHandler.Create(AssetMetaData
assetMetaData, enAssetStatus state) at
AssetManagement.AssetManagementService.Create(AssetMetaData
assetMetaData, enAssetStatus state) at
Mojave.AssetManagementProxy.Create(AssetMetaData assetMetaData,
enAssetStatus state) at
Ektron.Cms.DataIO.EkContentRW.AddContentv2_0(Collection ContObj) at
Ektron.Cms.EkException.ThrowException(Exception ex) at
Ektron.Cms.DataIO.EkContentRW.AddContentv2_0(Collection ContObj) at
Ektron.Cms.Content.EkContent.AddNewContentv2_0(Collection ContObj)
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Cause. During the creation of the ASM database, a total of 7 messages are
written to the sysmessages table in SQL Server’s master database. Each
installation of SQL Server has its own master database and, in a typical
move from one location to another, changes to the master database are not
brought over.
If the ASM database was moved, and these messages are not in the
sysmessages table in the new location's master table, the above error
appears instead of a standard error message.
Resolution. Run this set of SQL scripts against your database. They add
appropriate messages to the sysmessages table in the master database.
/***************************************************************************
*****/
sp_addmessage 2000000001, 10, N'Error in %s: Error %d inserting into %s. %s',
US_ENGLISH, FALSE, REPLACE
go
/***************************************************************************
*****/
sp_addmessage 2000000002, 10, N'Error in %s: Insert into %s returned %d rows.
%s',
US_ENGLISH, FALSE, REPLACE
go
/***************************************************************************
*****/
sp_addmessage 2000000003, 10, N'Error in %s: Failed creating record because
primary key already exists. %s', US_ENGLISH, FALSE, REPLACE
go
/***************************************************************************
*****/
sp_addmessage 2000000004, 10, N'Error in %s: Error %d updating into %s. %s',
US_ENGLISH, FALSE, REPLACE
go
/***************************************************************************
*****/
sp_addmessage 2000000005, 10, N'Error in %s: Update into %s returned %d rows.
%s',
US_ENGLISH, FALSE, REPLACE
go
/***************************************************************************
*****/
sp_addmessage 2000000007, 10, N'Error in %s: Error %d deleting into %s. %s',
US_ENGLISH, FALSE, REPLACE
go
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/***************************************************************************
*****/
sp_addmessage 2000000008, 10, N'Error in %s: Delete into %s returned %d rows.
%s',
US_ENGLISH, FALSE, REPLACE
go

This snippet utilizes the sp_addmessage stored procedure from the master
database, which adds the appropriate messages to the correct table.
NOTE: Although it is possible to recode these as an INSERT statement
that can run directly against the sysmessages table, that procedure is not
recommended.
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Working with files in the library
The library folder stores images, files, quicklinks, and hyperlinks that can be inserted
into editor content. Before you can insert them into content, you must copy them from
your computer to a larger, file server computer that everyone editing your site can
access.
See also: Storing external files as library items vs. assets on page 709.
l

An image is any graphic file, which can include illustrations and photos. Common
image file extensions are .gif., .jpg, .tiff, and so on.

l

A file is type of file that can be launched from a browser, such as Internet Explorer.
Examples include a Microsoft Word document and a .PDF file.

l

A hyperlink is a commonly used or hard to remember Web address (also known as
a URL). After you add hyperlinks to the library, users can easily apply them to
editor content. For example, if the editor content is “Contact Ektron,” the user can
select the text, click the library button, select hyperlinks to find the Ektron
hyperlink, and apply that hyperlink to the text. When the page is published, a
person reading it can click the text to “jump” to the Web address www.ektron.com.

l

A quicklink is a special kind of hyperlink that jumps to another content item on your
website. (A regular hyperlink jumps to an external Web page on the internet.)

l

A form is a quicklink to HTML form content. Whenever content is created, a form
link is automatically created for it.

Working with the library
This section describe actions you may perform with library files.

Performing actions on library items
The library is made up of images, files, form Quicklinks, hyperlinks, and regular
Quicklinks that were added by Ektron users. The following list shows the actions that
can be performed for each library item type.
l

Files. Add, Edit, View, Overwrite, Delete, Remove from server, Check Links

l

Images. Add, Edit, View, Overwrite, Delete, Remove from server, Check Links

l

Hyperlinks. Add, Edit, View, Delete, Check Links, Update URL

l

Quicklinks. Add, Edit, View, Delete, Check Links, Update URL

l

Form Quicklinks. Add, Edit, View, Delete, Check Links, Update URL

Most actions can be performed by a user who is granted permission to do so.
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Whenever a new content folder is created and permissions given to it, a corresponding
library folder is created. The new library folder inherits permissions from the content
folder.
Items added to library folders are only accessible by users with permission to the
corresponding content folder. If items are added to a library folders directly under the
main library folder, all users with at least library Read-Only permissions can use those
library items in their content.
Conversely, if a library item is uploaded to a folder to which only one person has
permissions, that is the only user who can use that library item.
To add, edit, overwrite, or delete a library item you must either be a member of the
administrators group or have the following combination of folder permissions.
Add

Edit file name, summary, metadata

Overwrite file

Delete

Library
images

Add Images

Add Images

Overwrite
library

Delete and
Add Images

Library files

Add Files

Add Files

Overwrite
library

Delete and
Add Files

Library hyperlinks

Add Hyperlinks

Add Hyperlinks

Overwrite
library

Delete and
Add Hyperlinks

Accessing the library
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1. Click Workarea > Library. The Library folder appears.

2. The sub-folders appear in the left frame. Files in the root folder (library) appear in
the right frame.

You can use the drop-down list (circled above) to change the type of library files
that appear.
To work with any library file, click it. When you do, the View Library screen appears,
providing additional information about the item. From here, you can
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l

edit its title, file name, or description

l

overwrite it

l

find content linked to it

l

delete it

The following table explains toolbar buttons on the library screen.
NOTE: Your system administrator determines which library folders you can access,
and which functions you can perform on library items within the folders.
Button

Description
Search library; Searching the library on page 738.
View the library’s properties screen; Accessing library folder
properties below.
Add an image, file, quicklink, or hyperlink to the library; Adding a
file to the library on page 740.

Select a type of Library file to work with

Accessing library folder properties
The library folder properties screen lets you view and update image and file types may
be uploaded. Administrators have permission to change library properties.
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_LibFileTypeWhiteList.
To view the properties of the library folder:
1. Click Workarea > Library. The Library folder appears.
2. Click Properties ( ). The Library Management window appears, displaying the
following settings.
l Image Extensions. The types of image files that a content contributor can
upload to the library. You can add as many image file extensions as you want,
or have none. If no extensions appear, no one can upload image files to the
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specified folder.
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_LibFileTypeWhiteList. See also:
Using the file type whitelist below.
l

Image Upload Directory. Specifies where the uploaded images are saved
on the Web server. By default, the image upload directory is Web root/ek_
sitepath/uploadedimages. The ek_sitepath value is set in the
siteroot\web.config file.

l

Make Directory Relative to this website. If you want to specify the image
upload directory’s location as relative to your website root, check this box.
(Your website root’s location appears to the right of Make Directory
Relative to this website.)

l

File Extensions. Specify the types of non-image files that a content
contributor can upload to the library. You can add as many non-image file
extensions as you want, or have none. If no extensions appear, no one can
upload non-image files to the specified folder.
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_LibFileTypeWhiteList. See also:
Using the file type whitelist below.

l

File Upload Directory. Specifies where the uploaded files are saved on the
Web server. By default, the file upload directory is Web root/ek_
sitepath/uploadedfiles. The ek_sitepathvalue is set in the
siteroot\web.config file.
NOTE: You must manually create the directory in your Web root folder
before adding it in Ektron.

l

Make Directory Relative to this website. If you want to specify the file
upload directory’s location as relative to your website root, check this box.
(Your website root’s location appears to the right of Make Directory
Relative to this website.)

Using the file type whitelist
The siteroot/web.config file property ek_LibFileTypeWhiteList contains the
same default file types as those on the Library Management screen's Image
Extensions and File Extensions fields.
A server administrator can use this property to restrict which file types may be
uploaded to the library. For example, if an Ektron administrator wants to add a new
file type, someone who can edit files on the Ektron server must first add it to the
web.config ek_LibFileTypeWhiteList property. This provides additional
security over which file types can be uploaded to the library.
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Conversely, if an server administrator wants to remove an allowed file type from
the Library Management screen, he must first remove it from the ek_
LibFileTypeWhiteList property.

Searching the library
NOTE: New and updated library items are available only after the next crawl
completes. See also: Managing the search crawl on page 395.
You can search the library to find items if you know only some information about them.
For example, you know that an image’s name includes Ektron but don’t know its
filename or folder.
To search the library, first select the folder in which you want to begin the search. The
search only considers files in that folder and its child folders. To search the entire
library, select the Library (root) folder.
IMPORTANT: The library search does not find terms within text-based files, such as
Microsoft Word documents and PDFs. To allow searching within such files, import
them as assets. See also: Working with assets in the Document Management
System on page 708.
Next, click Search ( ) from the library toolbar. When you do, a search screen appears.

The left tab, Search Published, finds both library items and content that satisfies the
search criteria.
l

Matches selected language.

l

Search text is contained in title, summary, filename, or path.

l

If the search text is more than one term, all terms must be found. So, multiple
terms have an AND relationship.

To force an OR relationship, enter OR between search terms.
The right tab, Advanced Search, lets you narrow your search.
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l

Enter Keyword(s). Specify one or more keywords that the search will use. The
search looks for keywords in the file’s title. (The title is assigned by the user when
the file is added to the library.) If a file’s title matches the keywords, the file
appears on the search results screen.
The search also uses keywords to search through the file’s
l

internal name (for example, airplane.gif) if the Filename Search checkbox is
checked

l

description if the Description search checkbox is checked

A keyword can be a complete or partial word. But, you can only enter a partial term
for one word. For example, you can enter Adv and have the search return the
content titled “Adverse Drug Reactions.” But if you enter Adv Drug, the search
returns nothing.
You can enter several complete search terms but they must be in the correct
sequence. For example, to find the topic titled “Adverse Drug Reactions,” you can
enter Adverse Reactions but cannot enter Reactions Adverse.
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To find all files in a selected library folder, enter nothing in this field. Or, to find all
files in a selected library folder of a type (for example, images), select the type and
enter nothing in this field.
l

All Types. The search considers all library file types.

l

Images only. The search only considers images.

l

Quicklinks Only. The search only considers quicklinks.

l

Forms Only. The search only considers forms.

l

Files Only. The search only considers files.

l

Hyperlinks Only. The search only considers hyperlinks.

l

Description Search. If you check this box, the search considers the library item’s
description when returning search results. Otherwise, the search ignores the
description. For example, if you enter Ektron into the keyword field, the search
returns all library files that include that string.

l

Filename Search. If you check this box, the search considers the file name when
returning search results. Otherwise, the file name is not considered by the search.
For example, if you enter ppt into the keyword field, the search returns all files that
include that string (such as all Powerpoint presentations).

l

Only search items last edited by myself. The search only considers library files
that were last modified by you.

l

One or more search criteria set by your system administrator in the Metadata
Definitions screen.

NOTE: Some search field check boxes are circles while others are squares. If the
box is a circle, you can only choose one option. If it is a square, you can choose
several.
The search displays library items that meet the search criteria. You can click any item to
view its properties (such as Library ID number, Last Edit Date and Description).

Working with library files
This section explains how to work with library files (which includes files, forms,
hyperlinks, images, and Quicklinks).

Adding a file to the library
After a file is copied to the library, users can add it to content. They can also add an
item into the library while inserting it to content.
PREREQUISITE

For the file being added, its type is defined in the Library Properties screen's
Image Extensions or File Extensions field. See also: Accessing library
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folder properties on page 736.
To add a file to the library:
IMPORTANT: You should use the Document Management system to add files.
Unlike library files, DMS files can be part of a workflow, maintain a history, are
searchable, and can have a summary, schedule, metadata, taxonomy categories,
and so on.
NOTE: Microsoft lets users upload files of any name. However, IIS security blocks
files with names that contain an ampersand (&), colon (:), or percentage sign (%).
Source: FIX: "HTTP 400 - Bad request" error message in the .NET Framework 1.1
To allow these characters, add the following registry key to your Web server then
reset IIS.
Reg Key: DWORD HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET
VerificationCompatibility = 1.
1. In the Workarea, browse the library folder and select a folder to which you want to
copy a file.
2. When you copy a file to a folder, only users with permissions to that folder can
insert the file into content. A list of files in that folder appears.
3. Click Add. The Add Library Item to Folder screen appears.

4. Enter the necessary information according to the following list.
l Title. Enter a title for the file to be copied.
l

Filename. Enter the path to the file to be copied. You can use the Browse
button to find it.
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_LibFileTypeWhiteList. See also:
Using the file type whitelist on page 737.

l

Description. Enter a full text description to help other users identify this file.
The Description appears on the View File and Search Results screens.

5. Click Save to copy the file. Users with permissions to the selected folder can insert
the file into their content.
NOTE: When an image is uploaded to the Media tab for a product in the eCommerce
feature, the original image and any thumbnails associated with it are added to the
Library. For example, if you add an image named “TestImage” (actual file name:
“case.jpg”) with a 150px and 50px thumbnails, you will see the following entries in
your library (File Name - Path):
TestImage - /~siteroot~/uploadedImages/case.jpg
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case[filename]150 - /~siteroot~/uploadedImages/case[filename]150.jpg
case[filename]50 - /~siteroot~/uploadedImages/case[filename]50.jpg

Viewing a file
When a file is copied to the library, you may preview it. To preview a copied file:
1. Go to the library folder to which the file was copied.
2. Click the file you want to preview. The View File screen appears.

742

l

Title. Title assigned by user who copied or edited it.

l

Filename. Filename and location on the server.

l

Library ID. ID number assigned by Ektron when file was originally copied.

l

Parent Folder. File’s parent folder. Users need permissions to this folder to
insert the file into content.

l

Last User to Edit. Last user who changed file.

l

Last Edit Date. When file was last edited.

l

Date Created. When file was originally copied to library.

l

Description. Optional, full-text description of file.
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If the file can be displayed in your browser, a preview of it appears at the bottom of the
screen. If it cannot display in the browser, a link to preview it in its host application
appears instead.
NOTE: You may need to download some files before you can be view them (for
example, .mdb, .mp3, .zip, and so on).

Editing a file
To edit the title, filename and description of any library file:
1. Access the View File screen and click Edit. The Edit File screen appears.

2. Change the title, file name, and/or description of the file.
3. Click Update.

Searching library links
Link searching indicates all content that includes a library link. It is useful when you
want to delete a library item. With the click of a button, you see all content that you
need to update to reflect the change you are making.
To perform a library item link search:
1. Access the View Library Item for any type of library item and click Link Search (
).
2. A list of all content that references the library item appears.
You should edit that content before deleting the item.

Adding a library file to content
After a file is copied to the library, users can add it to content. You can also insert an
item into the library while adding it to content.
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NOTE: Alternatively, you can drag and drop an image file into content. See Inserting
an image using drag and drop on page 623.
If you insert an image file, it appears within the content. If you add any other type of
file, the file name appears as a hyperlink within the content. When a site visitor viewing
that page clicks the hyperlink, the inserted file is launched.
NOTE: The following procedure applies to files, forms, hyperlinks, images and
quicklinks.
1. Invoke the editor by adding or editing content in Ektron.
2. Place the cursor within the content where you want the library file to appear.
3. Click Library (

). The Library screen appears.

4. Go to the folder that contains the file you want to insert.

5. From the file types drop-down list, select the kind of file (file, form, hyperlink,
image, or quicklink) you want to insert. All library files of that type in the selected
folder appear on the screen.
6. Click the file you want to insert.
7. Click Insert ( ) to insert the file. The content appears in your editor. In this
example, inserting the file creates a link in your content. If you select an image,
the image appears.
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If you select Files from the file types list, and Aliasing is enabled for your website, the
following screen appears.

Adding a file to the library and inserting it into content
Use this procedure to insert an image into content that has not yet been copied to the
library. This procedure inserts the item into the library then into the content.
1. Invoke the editor by adding or editing content in Ektron.
2. Place the cursor where you want the library item to appear.
3. Click Library (

). The library opens.

4. Go to the folder that will contain the file after you insert it.
5. Select the type of file (file, form, hyperlink, image, or quicklink) you want to insert
from the File types drop-down.
6. Click Add Library. A new screen appears.
7. Browse to the file you want to insert, or you can click Search ( ) to search for a
file to insert.
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_LibFileTypeWhiteList. See also: Using
the file type whitelist on page 737.
8. Enter a Title for the file.
9. If metadata is required for the library item, you must complete it. Metadata fields
may appear in the lower section of the screen.
10. Click Add Library. The file is inserted into the selected library folder and the
content.

Overwriting a file
If a library file or image becomes out-of-date or the wrong version was copied, you can
replace it with a new version. Overwriting files lets you minimize disk space and the
number of library files.
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NOTE: The ability to overwrite a library file is a privilege granted by the system
administrator. If you do not see an Overwrite button on the View Library Item in
Folder screen, you do not have permission to overwrite. You can only overwrite
images and files. The new image or file must have the same file extension as the file
being replaced.
When overwriting an image, the new image uses the same size dimensions and file
extension as the older image. Be sure that the 2 images have the same file extension
and size, or adjust each occurrence of the image.
Remember, all links to the overwritten file now point to the new file.
To overwrite a library file:
1. Go to the View File screen for the file you want to overwrite and click Overwrite (
). The Overwrite File screen appears.

2. Click Browse. A window lets you go to the new file.
IMPORTANT: You can only add file extensions that are listed in the
siteroot/web.config file property ek_LibFileTypeWhiteList. See also: Using
the file type whitelist on page 737.
3. Select a file, then click Open. You return to the Overwrite File screen with the path
to the new file in the Filename field.
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4. Optionally, enter a description for the new file.
5. Click Update to overwrite the current version of the file with this version. A
message appears before you can continue.
6. Click OK to overwrite the file.

Deleting a library item
You can delete obsolete items from the library. By deleting an item, you prevent users
from adding it to content. A deleted hyperlink, quicklink or form quicklink remains on
your Web server, so existing links are not broken.
On the other hand, if an item is a file or image, the delete window displays an additional
prompt, Remove from the server, that lets you remove the item from the server.
This feature is available to help reduce disk space taken up by these files. Before
removing an image or file from your server, review all content with links to it and
remove or update the link.
To delete an item from the library:
1. Access the View Library Item screen for any type of library item and click Delete (
). The Delete Library Item screen appears.
2. If appropriate, check the box next to Remove from the server.
3. Click Delete (

).

Adding a quicklink to content
A quicklink is a special kind of hyperlink that "jumps" to a content item on your website.
You can apply a quicklink to text or an image. When a site visitor is viewing the content
and clicks the quicklink, a new page appears, displaying the referenced content.
If you do not select text or an image before inserting a quicklink, the referenced
content's title becomes the quicklink text.
1. Edit the content into which you want to insert the quicklink.
2. Place the cursor where you want the quicklink to appear. If you want to attach the
quicklink to text or an image, select it.
3. Click Library (

).

4. Go to the folder that contains the content whose quicklink you want to insert.
5. From the file types drop-down list, select Quicklink. All quicklinks in the selected
folder appear.
6. Click the quicklink you want to insert.
7. Click Insert. The quicklink appears in the editor.

Viewing quicklinks or forms
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To view a quicklink or form, follow the procedure described in Viewing a file on
page 742. The only difference is that you view a quicklink or form instead of a file.
The following list describes each field on the quicklinks display.
l

Title. Title given to the hyperlink or form by the user who added it, or last edited it.

l

URL Link. URL link for the quicklink or form.

l

Library ID. ID number assigned automatically by Ektron when the quicklink or
form was originally added.

l

Parent Folder. Parent folder that the quicklink or form belongs to. Users need
permissions to this folder to be able to access the quicklink or form.

l

Last User to Edit. Last user that made changes to the quicklink or form.

l

Last Edit Date. The date the quicklink or form was last edited.

l

Date Created. The date and time the quicklink or form was originally added to the
Ektron library.

To preview a quicklink or form, click the link at the bottom of the page.

Updating the default template for multiple quicklinks
IMPORTANT: This procedure is only necessary if Link Management is set to false
in your web.config file. If if Link Management is set to true, Ektron automatically
updates the template within the quicklink when content is moved. See your system
administrator for help with the web.config file.
When content is moved in Ektron, its quicklink does not get changed. After it is moved,
you need to update the default template called in the content’s quicklink.
NOTE: This action can only be performed on quicklinks.
To update the default template for one or more quicklinks:
1. In the library, access the quicklinks folder containing quicklinks you want to
update.
2. Click Update Quicklink (
appears.

). The Update URL Link Template Quicklinks screen

3. Check the quicklinks you want to update.
NOTE: Check the box in the table header to select or deselect all.
4. In the To: text field, enter the name of the template you want to apply to the
selected quicklinks.
5. Click Update Quicklink (

) to update the changes.

6. Click OK to continue. The selected quicklinks are updated to use the specified
template.
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Approving content for publication
Workflow, a core element of Ektron, lets you set up a sequence of approvers who
control the publication of content to your website.
When workflow is implemented, submitted content must be approved by each user or
group in the sequence before the content is published. Any reviewer can edit the
content, decline the content (which returns it to the previous approver), or approve the
content (which forwards it to the next approver). Upon final approval, the content is
published, and the website is updated.

Key workflow concepts
l

You can implement workflow at the folder and content level. If a workflow is
applied to content, it overrides a folder-level one.
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l

Inheritance. Content inherits workflow from its folder, and a folder inherits from
its parent folder.
To apply unique workflow rules to a folder or content, break inheritance from the
content's permission screen.
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l

The last approver sees Publish instead of Approve, indicating that upon approval,
the content is updated on your website.

l

You can add only users or user groups to a workflow that have read-only or higher
permission to a folder or content.
o If you assign a user group to a workflow step, any user in the group can
approve the content.

l

For any content, you can view users or groups that make up its workflow on the
View Content screen's Properties tab Approvals field. Red text indicates the
current approver.
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l

Notifications. Ektron can automatically send email notifications, informing users
that workflow events have either taken place or are requested of them. For
example:
o After a user approves content, an email notifies the next approver that content
is ready for their approval.
o

Content authors receive email when their content is published.

The email text and directions for customizing it are described in Customizing
Ektron email with tokens on page 108.

Ektron Reference

751

Managing content

Approving content with a basic workflow
l

Features a simple, linear chain of approvers.

l

Any user or group can appear only once in the workflow.

l

Includes an Approval Method feature, which lets you determine the approval
sequence if a user who is part of the basic workflow submits or edits the content.
See also: Setting the approval method on page 756.

l

Can be managed by an Ektron administrator.

l

Content deletion is subject to approval.

l

Any folder or content item can have a different workflow type for each language.
o If you initialize new foreign language content with content from another
language, the new content initially has no workflow. You must add it as you
would any other workflow. See also: Translating content manually on
page 1530.

l

You can switch from one workflow type to another. See Switching from basic
workflow to advanced workflow on page 764.

l

If a user appears in a basic workflow twice (both as a user and part of a user
group), the second occurrence is skipped because the user already approved the
content.

l

Ektron can automatically send email notification, informing users that workflow
events have either taken place or are requested of them. For example:
o When content is submitted, the first approver or members of the first approver
user group get an email notification.
o

When content is approved, the next approver or members of the next
approver user group are notified.

o

A content contributor receives an email notification when his content is
published.

The list of automatic emails and directions for customizing their content are
described in Customizing Ektron email with tokens on page 108.

Viewing a folder’s basic workflow
1. Go to the folder whose basic workflow you want to view.
2. Choose View > Language and select a language.
3. Choose View > Properties.
4. Click Manage Approvals ( ).
If you see the following screen, no workflow is assigned to the folder.
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NOTE: If a folder inherits its workflow, instead of seeing it, you see Approval
workflow for this folder is currently inherited. You can break this
inheritance in the "View Permissions" screen for parent folder.

Creating a basic workflow for a folder
Assigning basic workflow to a folder consists of selecting users or groups who are
responsible for approving changes to the folder's content before it gets published. You
can also change the order of the approvers and assign an approval method.
PREREQUISITE

Only administrators group members and users assigned to the Folder User
Admin Role screen can assign a basic workflow. See also: Defining roles on
page 1581
1. Go to the folder to which you want to assign a basic workflow.
2. Choose View > Language and select a language.
3. Choose View > Properties.
4. Click Manage Approvals ( ). You may see a screen that prompts you to create
either basic workflow or Advanced workflow.
NOTE: If a folder inherits its workflow, instead of seeing it, you see Approval
workflow for this folder is currently inherited. You can break this
inheritance in the "View Permissions" screen for parent folder.
To view (and possibly break) the inherited workflow, view the parent folder's
workflow. See also: Breaking inheritance on page 170
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5. Choose Basic to create a basic workflow. The Manage Approvals screen appears.

From this screen, you can perform these actions:
l

Add. Add approvers. See also: Adding approvers below

l

. Remove approvers. See also: Deleting approvers on the facing page

l

. Change the order of approvers. See also: Editing the approval order on the
facing page

l

. Change the approval method. See also: Setting the approval method on
page 756

Adding approvers
When you add approvers to a folder or content, that action creates a basic workflow.
PREREQUISITE

Only users and user groups with read-only or higher permissions to the folder may be
added as approvers. See Adding a user or user group to the permissions screen on
page 171 for more information.
BEST PRACTICE
Assign user groups (not individual users) to a basic workflow. In this way, if
someone is out of the office, any group member can approve content.
1. From the Manage Approvals screen, click Add. The Add Approvals screen appears.
2. Click the user or user group to add to the basic workflow.
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3. Click OK.
4. Repeat Steps 2 and 3 until all approvers are chosen.

Deleting approvers
You can delete approvers at any time, including while content is in an approval process.
If you do, the users or groups are eliminated from the basic workflow. If a removed
user was the current approver, approval moves to the next user or group in the basic
workflow.
WARNING! If a user is deleted from a folder or content Permissions screen, the
user is deleted from the basic workflow. If all approvers are deleted from a
Permissions screen, the basic workflow is removed.
1. From the Manage Approvals screen, click Delete ( ). The Remove Approval
screen appears.
2. Click a user or group to remove from the basic workflow.
3. Click OK.
NOTE: If you delete all approvers from a basic workflow, it is removed.

Editing the approval order
After assigning approvers to a folder or content, you can adjust the approval order.
Place the user or group with final approval at the end of the workflow (that is, assign
the highest number). For example, if a department head must approve edits, and a
Webmaster has final review of content, the approval order is:
l

Department Head—1

l

Webmaster—2

To edit approval order:
1. From the Manage Approvals screen, click Reorder Items (
Order screen appears.

). The Edit Approval

2. Click the user or group whose approval order you want to change.

3. Click Up (

) or Down (

) to move users and groups to the desired order.

4. Click Update.
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Setting the approval method
The approval method determines if content must be approved by all users in the
workflow, or only users higher up the workflow than the user submitting the content.
The approval method affects the approval process only if the person submitting content
is a member of the basic workflow.
There are 2 approval methods.
l

Force All Approvers. All users in the basic workflow must approve the content,
beginning with the first.

l

Do Not Force All Approvers. Only approvers after the user submitting content in
the basic workflow must approve the content.

The Approval Method applies to all content in a folder, regardless of its language. For
example, assume a basic workflow consists of
1. Content contributor
2. Department head
3. Webmaster
If the approval method is Force All Approvers, and the department head submits
content, the content must be approved by the content contributor, department head,
then Webmaster before it is published.
If the approval method is Do Not Force All Approvers, and the department head
submits content, the content must only be approved the Webmaster before it is
published.

Changing the approval method
PREREQUISITES
l

If basic workflow is inherited, the approval method is also inherited from
the parent folder. Before you can change an inherited approval method,
you must break inheritance.

By default, the approval method is set to Do Not Force All Approvers. To change the
approval method for a content folder or item:
1. Go to the folder to which you want to assign a basic workflow.
2. Choose View > Language and select the workflow's language.
3. Choose View > Properties.
4. Click Manage Approvals ( ).
5. Click Edit Approval Method (
6. Click the applicable radio button.
7. Click Update.

756

Ektron 9.40 SP1

). The Edit Approval Method screen appears.

Editing a basic workflow for a folder

Editing a basic workflow for a folder
1. Go to the folder that has the basic workflow that you want to edit.
2. Choose View > Language and select the workflow's language.
3. Choose View > Properties.
4. Click Manage Approvals ( ).
5. From the Manage Approvals screen, you can
l Add or remove approvers. See Adding approvers on page 754, Deleting
approvers on page 755
l

Change the approval order. See Editing the approval order on page 755

l

Change the approval method. See Setting the approval method on the
previous page

Removing a basic workflow from a folder
1. Go to the folder that has the basic workflow that you want to remove.
2. Choose View > Language and select the workflow's language.
3. Choose View > Properties.
4. Click Manage Approvals ( ).
5. Remove all approvers by clicking the Remove button (

) then selecting each

approver one at a time. When you complete this, the workflow is no longer
assigned to the folder. See also: Deleting approvers on page 755

Creating a basic workflow for content
You can create, edit, or delete a basic workflow for a specific content item. If you do,
content-level workflow overrides folder-level workflow.
PREREQUISITES
l

You must disable the inheritance of permissions for content whose basic
workflow you want to edit. See Setting permissions for content on
page 173.

l

You must assign users or groups to a basic workflow. Only users and
user groups with permissions to the content can be assigned. See
Managing folder and content permissions on page 168.

1. Go to the folder that contains the content.
2. Choose View > Language and select the language of the basic workflow you
want to create.
3. Click the content and choose View Properties.
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4. Click Manage Approvals (

). If content-level basic workflow is applied to this

content, it appears.

If content inherits a basic workflow from its folder, you are informed of this. To
view (and possibly break)the inherited workflow, view the content folder's
workflow. See also: Viewing a folder’s basic workflow on page 752
5. From this screen, you can perform these actions.
l Add. Add approvers. See also: Adding approvers on page 754
l

. Remove approvers. See also: Deleting approvers on page 755

l

. Change the order of users. See also: Editing the approval order on
page 755

l

. Change the approval method. See also: Setting the approval method on
page 756

Monitoring content under a basic workflow
To see any content item's basic workflow and current approver, view its properties
screen. Red text indicates the current approver.
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To see content
l

awaiting your approval, use the Approval report on page 1057.

l

in Submitted status, use the Submitted content report on page 1059.

l

via desktop widgets—Managing content from the Smart Desktop on page 668.
o Content Awaiting Approval (shortcut to Approval report on page 1057)
o

Content In Workflow—all content in Submitted status (shortcut to Submitted
content report on page 1059)

Approving or declining content
PREREQUISITE

There are several ways that a current approver (or approver group member) can
approve or decline content.
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1. Use one of the following methods to access the Approve or Decline option.
l the content's context menu

l

the content's view screen

l

via the Submitted content report on page 1059

l

via the Approval report on page 1057

l

via desktop widgets
o Content Awaiting Approval (shortcut to the Approval report on page 1057)
o

Content In Workflow—all content in Submitted status (shortcut to
Submitted content report on page 1059)

2. Click Approve or Decline.
If you approve, the content is either submitted to the next publisher or published
immediately, depending on your sequence in the content's workflow, and how the
Approval Method is set.
If you decline, the content status changes to Checked In, and it leaves the approval
process.
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Example basic workflow
The following example shows a typical content item from creation to publication. Three
users make up the basic workflow.
l

Sports Writer—creates sports content

l

Sports Editor—edits and publishes all sports articles

l

Editor-in-Chief—edits and publishes all articles

Each user has different permissions that correspond to their roles.
Basic workflow begins when a content contributor submits new content or edits existing
content.

First approver
After the Sports Writer submits content, the first user in the basic workflow, the Sports
Editor, receives an email stating that content needs approval. The Sports Editor can
modify and approve the content or decline it.
1. The Sports Editor logs into Ektron, goes to the desktop, and sees the Content
Awaiting Approval widget.

2. The Sports Editor clicks the View All link and sees content awaiting approval. The
screen displays information such as title, who submitted it, publication date, and so
on. The Sports Editor clicks the Submitted content.
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On the Approve screen, the Sports Editor has these options.
l

Approve. Send content to next approver in basic workflow.
Decline.

l

l

o

Send email to creator, notifying him/her that content was declined.

o

Remove content from basic workflow.
Edit. Invokes the editor. From here, the approver can change the content.

3. The Sports Editor chooses Approve.

Second approver
After the content is approved, the Editor-in-Chief is the next approver in the basic
workflow who is notified by email that content is ready for approval.

1. The Editor-in-Chief logs in to Ektron and accesses the Workarea. The Workarea has
an Approvals report with the content awaiting approval.
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2. The Editor-in-Chief reviews the Approvals report and finds the content Red Sox
win World Series.
3. From this window, the Editor-in-Chief views information about the content,
including title, publication date, the user who created it, and so on.
4. The Editor-in-Chief clicks the content to be approved. This screen is similar to the
previous approver’s but includes a Publish button, because Editor-in-Chief is the
last approver in the basic workflow.
Like the Sports Editor, the Editor-in-Chief has these options:
l

Publish. Publish the content.
Decline.

l

l

o

Sends an email to the creator, notifying him/her that content was
declined.

o

Removes content from the basic workflow.
Edit. Invokes the editor. The approver changes the content.

5. After reviewing the content, the Editor-in-Chief decides to publish it. The content is
published on the website.
6. The basic workflow is complete and the user who created the content receives
email notification that it was published.

Deleting content under basic workflow
Any member of the administrators group, or user or group assigned delete permission
for content, can begin the process of deleting it. Because content is under basic
workflow control, every approver must approve the request before the deletion is final.
You can only begin the deletion process if the content's status is Checked In (I) or
Approved (A). See also: Deleting content on page 688
To delete content under a basic workflow:
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1. Go to the folder that contains the content.
2. Click the content's right triangle to access the context menu.

3. Click Delete.
The content is set to Submitted status, and assigned to the first approver in the
workflow. That approver can approve or decline the deletion request.
When the last approver approves the deletion request, the content is deleted, and
the website is updated.

Switching from basic workflow to advanced workflow
See also: Switching from advanced workflow to basic workflow on page 780
PREREQUISITES
l

You have permission to edit the folder or content item being switched.

l

All approvers for the advanced workflow are assigned to the folder's or
content item's Permissions screen.

1. If a folder or content item inherits workflow, break inheritance. See also: Key
workflow concepts on page 749
2. Within the Workarea, go to the folder or content item.
3. Choose View > Language and select the content's language.
4. Click View > Properties.
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5. Click Manage Approvals (

).

6. Remove all approvers by clicking the Remove button (

) then selecting each

approver one at a time.
7. When the Manage Approvals screen reappears, click Use advanced workflow.
NOTE: If no users are assigned to basic workflow, and you do not see an
advanced workflow option, it is likely that your Ektron administrator has not
enabled advanced workflow. See Enabling and disabling advanced workflow on
page 768.
8. Follow Setting up advanced workflow for a folder on page 771.

Approving content with an advanced workflow
Advanced workflow provides an alternative way to manage the publication of content.
Like basic workflow, the advanced version supports a sequence of users or groups who
approve content before it is published. Also, content and folders inherit workflow from
their parent folders unless you break inheritance. Advanced workflow differs
significantly from basic workflow in the following ways.
l

Because Advanced workflow leverages the Windows Workflow Foundation, it can
support complex workflows with any number of activities and users.
o State MachineWorkflow type is supported.
o

Typically requires a developer, who can create new workflows to meet your
needs.

l

The same user or group can appear in several steps.

l

To any approval step, you can assign an escalation period and user or group.

l

Deletion is not subject to workflow approval.

l

You cannot use advanced workflow on calendar events.

NOTE: You cannot apply an advanced workflow to assets imported via the Multiple
DMS Documents option. See also: Adding multiple DMS documents on page 715

Standard vs. custom workflow
When you install Ektron, 3 standard workflows are provided. They appear when you are
assigning a workflow on the Manage Approvals screen.
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You can use a standard workflow to implement an approval process that consists of 2, 3
or 4 users or groups. To assign a workflow with more than 4 approvers, or to add
custom code to any approval activity, have a developer create a custom advanced
workflow. See also: Creating a custom advanced workflow on page 788

How escalation affects the approval process
After choosing a workflow, you select a user or group for each approval step. For each
step, you can also assign an escalation time period and user or group. If they are
assigned, and the original user or group member does not approve or decline within
that period, the approval request is transferred to the escalation user or group. If this
happens, the escalation user or group is notified that they are responsible for approving
the content, and the original user can no longer act on the approval request.
Notification to escalation approver
Content Escalated For Your Approval
The following content has been escalated for your approval: Blog Post at: Blog Check/
originally submitted to:adam by James Smith on 12/24/2013 2:15:55 PM
To approve or decline this content,log in to your Ektron workarea, select the content
and click on the Approve or Decline icon or link.

Notification to original approver
Approval Has Been Escalated
The following content was not approved within x days, so the approval has been
escalated:
HTML 1 at: Content Level Test/escalated for approval to: Application Administrator on
12/24/2013 2:16:15 PM
You are no longer required to approve or decline this content.
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Enabling and disabling advanced workflow
PREREQUISITE
You have permission to edit files in the Ektron site root folder.

1. Open the Ektron siteroot\web.config file.
2. Find the ek_AdvancedWorkflowEnabled element.
3. To enable advanced workflow, set its value to true.
To disable advanced workflow, set its value to false.
4. Save.

Notifying users of advanced workflow activities
Ektron's advanced workflow feature automatically sends email to affected users when
certain events occur.
You identify the email "from" address in your siteroot\web.config file's ek_
AdvancedWorkflowEscalationEmail property.
PREREQUISITE

Email notification is enabled. See Enabling email notification on page 105.
l
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When content is submitted, the first approver or members of the first approver
user group get an email notification.
Notification text
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Request for content approval
The content HTML 1 has been submitted for your approval by James Smith.
To locate the content, the folder path in your workarea is: \Content Level Test.
The following link will take you to the submitted content block on the Web site:
http://servername/OnTrek/Default.aspx?id=910&LangType=1033
Please Note: You must login and select the preview icon to view the changes.
The content was submitted for approval on: 23-Dec-2013 14:02:50 PM.
Approvals: [adam]-JohnB
NOTE: The current approver is surrounded by square brackets [ ].
Comment:
l

When content is approved, the next approver or members of the next approver
user group get an email notification.
Notification text
Request for content approval
The content HTML 1 has been submitted for your approval by James Smith.
To locate the content, the folder path in your workarea is: \Content Level Test.
The following link will take you to the submitted content block on the Web site:
http://servername/OnTrek/Default.aspx?id=910&LangType=1033
Please Note: You must login and select the preview icon to view the changes.
The content was submitted for approval on: 23-Dec-2013 14:02:50 PM.
Approvals: [adam]-JohnB
Comment:

l

When content is published, the content author gets an email notification.
Notification text
Content changes have been made
The changes to the content Break-room Survey have been approved. The content
changes went live immediately.

l

If content is declined, the previous approver gets an email notification, unless the
approver is the first one. In that case, the content author gets an email
notification.
Notification text
Content approval request declined

Ektron Reference

769

Managing content

Your submitted approval request for the content Break-room Survey has been
declined by user a. Reason: .
l

If an escalation period is set for a workflow step, and the first approver does not
approve within that period, the approval request transfers to the escalation user or
group. Both the escalation user or group and the original approver get an email
notification.
Notification to original approver
Approval Has Been Escalated
The following content was not approved within x days, so the approval has been
escalated:
HTML 1 at: Content Level Test/
escalated for approval to: Application Administrator on 12/24/2013 2:16:15 PM
You are no longer required to approve or decline this content.
Notification to escalation approver
Content Escalated For Your Approval
The following content has been escalated for your approval:
Blog Post at: Blog Check/
originally submitted to: adam
by James Smith on 12/24/2013 2:15:55 PM
To approve or decline this content, log in to your Ektron workarea, select the
content and click on the Approve or Decline icon or link.

Customizing email notification text
1. On the Ektron server, open the folder C:\Program Files (x86)\Microsoft
SDKs\Windows\v7.0A\Bin\NETFX 4.0 Tools.
NOTE: In some Windows versions, the folder is C:\Program Files
(x86)\Microsoft SDKs\Windows\v8.0A\Bin\NETFX 4.0 Tools.
2. Copy the resgen.exe file.
3. Paste the file in your siteroot\Workarea\resources folder.
4. Open a command window.
5. Insert this command:
cd C:\Inetpub\wwwroot\yoursiteroot\Workarea\resources (replace
yoursiteroot with your site root folder)
6. In the command window, insert resgen EKResource.en-US.resources
anyfilename.txt (You can assign any name to the .txt file.)
A .txt file of resource strings is created in the resources folder.
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7. Update notification text as desired.
IMPORTANT: Each message has a name followed by an equal sign (=). Do not
change text to the left of the equal sign.
The standard message text is shown in Notifying users of advanced workflow
activities on page 768.
To understand the variables within the text, see Customizing Ektron email with
tokens on page 108.
8. In the command window, insert resgen anyfilename.txt EKResource.enUS.resources. This action saves your changes to the resources file.

Setting up advanced workflow for a folder
Assigning an advanced workflow to a folder consists of 3 steps.
l

Select a workflow. (Your developer creates workflows. See also: Creating a custom
advanced workflow on page 788.)

l

Choose users or groups who approve content submissions.

l

For each approver or group, you can assign an escalation time period and user or
group.

PREREQUISITES
l

Only administrator group members and users assigned to the Folder
User Admin Role screen can assign an advanced workflow. See also:
Defining roles on page 1581.

l

Advanced workflow is enabled. See also: Enabling and disabling
advanced workflow on page 768.

Assigning an advanced workflow to a folder
1. Go to Workarea > Content.
2. Select an existing folder or create a new folder.
NOTE: If you create a new folder, its workflow initially matches the parent
folder's workflow.
3. Choose View > Language and select the language of the workflow you want to
add.
4. Choose View > Properties.
5. Click Manage Approvals ( ). Several things can happen:
l

If no workflow is assigned to the folder, a screen prompts you to assign a basic
or advanced workflow. Choose Advanced. The Manage Approvals screen
appears. Continue to the next step.
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l
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If basic workflow is assigned to the folder (as shown in the following image),
see Switching from basic workflow to advanced workflow on page 764. Then,
continue to the next step.
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l

If any content in the folder is in Submitted status, a message appears: The
workflow for this folder cannot be changed because some content is
currently in an approval process
If you still want to edit the workflow, your options are as follows:
o cancel the approval process all content in Submitted status. See also:
Canceling an approval request in an advanced workflow on page 784
o

force publish all content in Submitted status. See also: Forcing the
publication of content on page 785.

o

get all approvers to approve Submitted content, so its status changes to
Published.

Then, continue to the next step.
l

If a folder inherits workflow from its parent folder, you are informed of that. To
break inheritance, go to the folder's Permissions screen and uncheck Allow
this object to inherit permissions. Then, continue to the next step.

6. From the Select Workflow Type drop-down, select a workflow to assign to this
folder. See also: Standard vs. custom workflow on page 765
7. Assign a user or group to each approver. If you assign a group, any group member
can approve or decline the content.
PREREQUISITE

Only users or groups who have read-only or greater permissions for the
folder are available.
BEST PRACTICE
Assign user groups (not individual users) to a workflow. In this way, if
someone is out of the office, any other group member can approve
content.
8. For each approver, you can assign an escalation time period and user or group in
the Escalation column. For example, after 3 days, if an approver has not acted on
the approval request, it is assigned to the administrators group. See also: How
escalation affects the approval process on page 766
9. Click Save.

Viewing an advanced workflow for a folder
To view a folder's workflow, click View > Properties > Manage Approvals ( ). If
any content in the folder is in Submitted status, the following message appears instead
of its workflow: The workflow for this folder cannot be changed because some
content is currently in an approval process.
You can only view a folder's workflow if none of its content is in Submitted status.
Typically, this occurs when the content is approved, although content also can be
canceled or declined, which change the content's status to Checked In.
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Editing an advanced workflow for a folder
You can change the following advanced workflow information for a folder:
l

workflow

l

list of approvers

l

for each approver
o escalation user or group
o

escalation time period

PREREQUISITES
l

Only administrator group members and users assigned to the Folder User Admin
Role screen can edit an advanced workflow See also: Defining roles on page 1581

l

No content in the folder is in Submitted status. If it is, and you want to edit the
workflow, your options are as follows:
o cancel the approval process for each content item in Submitted status. See
also: Canceling an approval request in an advanced workflow on page 784
o

force publish each content item in Submitted status. See also: Forcing the
publication of content on page 785

o

get all approvers to approve Submitted content, so its status changes to
Published.

To edit a folder's advanced workflow:
1. Go to the folder whose workflow you want to edit.
2. Choose View > Language and select the language of the workflow you want to
edit.
3. Choose View > Properties.
4. Click Manage Approvals ( ).
5. From the Select Workflow Type drop-down, you can change the workflow type.
See also: Standard vs. custom workflow on page 765
6. If desired, edit the user or group for each approver. If you assign a group, any
member of the group can approve or decline the content.
PREREQUISITE

Only users or groups who have read-only or greater permissions for the
folder are available.
BEST PRACTICE
Assign user groups (not individual users) to a workflow. In this way, if
someone is out of the office, any other group member can approve
content.
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7. For each approver, you can assign an escalation time period and user or group. See
also: How escalation affects the approval process on page 766
8. Click Save.

Removing an advanced workflow from a folder
This section explains how to remove an advanced workflow from a folder, so that it has
no workflow. If you want to switch an advanced workflow to basic workflow, see
Switching from advanced workflow to basic workflow on page 780.
Because workflow is language-specific, the procedure explains how to delete a
workflow for one language only. To remove workflow for multiple languages, repeat this
procedure for each one.
PREREQUISITES
l

Only administrator group members and users assigned to the Folder
User Admin Role screen can remove an advanced workflow. See also:
Defining roles on page 1581

l

The folder does not inherit its workflow. If it does, you must break
inheritance by viewing the folder's Permissions screen and unchecking
the Allow this object to inherit permissions check box. See also:
Key workflow concepts on page 749

l

No content in the folder is in Submitted status. If it is, and you want to
remove a workflow, your options are as follows:
o cancel the approval process for each content item in Submitted
status. See also: Canceling an approval request in an advanced
workflow on page 784
o

force publish each content item in Submitted status. See also:
Forcing the publication of content on page 785

o

get all approvers to approve Submitted content, so its status
changes to Published.

To remove an advanced workflow from a folder:
1. Go to the folder whose workflow you want to remove.
2. Choose View > Language and select the language of the workflow.
3. Choose View > Properties.
4. Click Manage Approvals ( ).
5. Click Remove Workflow ( ).

Setting up an advanced workflow for content
Assigning an advanced workflow to content consists of several steps.
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l

Select a workflow type. (Your developer creates workflow types. See also: Creating
a custom advanced workflow on page 788)

l

Choose users or groups who approve submissions.

l

Optionally assign an escalation time period and user or group. See also: How
escalation affects the approval process on page 766

PREREQUISITES
l

Only administrators group members and users assigned to the Folder
User Admin Role screen can assign an advanced workflow. See also:
Defining roles on page 1581

l

Advanced workflow is enabled. See Enabling and disabling advanced
workflow on page 768

Creating an advanced workflow for content
1. Go to the folder that contains the content to which you want to assign an advanced
workflow.
2. Choose View > Language and select the content's language.
3. Select the content item and choose View > Properties.
4. Click Manage Approvals ( ). Several things can happen:
l

If the content inherits workflow from its parent folder, you are informed of
that. To break inheritance, view the content's Permissions screen and uncheck
the Allow this object to inherit permissions check box. Then, continue to
the next step.

l

If the content is in Submitted status, you see
The workflow for this content cannot be changed because some
content is currently in an approval process
If you still want to assign a workflow, your options are as follows:
o cancel the approval process for the content. See also: Canceling an
approval request in an advanced workflow on page 784
o

force publish the content. See also: Forcing the publication of content on
page 785

o

get all approvers to approve the content, so its status changes to
Published.

Then, continue to the next step.
l
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If a basic workflow is assigned to the content, see Switching from basic
workflow to advanced workflow on page 764. Then, continue to the next step.
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l

If no workflow is assigned to the content, a screen prompts you to assign
Basic or Advanced workflow.

Choose Advanced. The Manage Approvals screen appears.
5. From the Select Workflow Type drop-down, select a workflow to assign to this
content. See also: Standard vs. custom workflow on page 765
6. Assign a user or group to each approver. If you assign a group, any group member
can approve or decline the content.
BEST PRACTICE
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Assign user groups (not individual users) to a workflow. In this way, if
someone is out of the office, any other group member can approve
content.
PREREQUISITE

Only users or groups who have read-only or greater permissions for the
folder are available.
7. For each approver, you can assign an escalation time period and user or group in
the Escalation column. See also: How escalation affects the approval process on
page 766
8. Click Save.

Viewing an advanced workflow for content
To view a content item's workflow, click View > Properties > Manage Approvals (
). If any content in the folder is in Submitted status, the following message appears
instead of its workflow: The workflow for this folder cannot be changed because
some content is currently in an approval process.
You can only view a folder's workflow if none of its content is in Submitted status.
Typically, this occurs when the content is approved, although content also can be
canceled or declined, which change the content's status to Checked In.
If a content item inherits workflow from its folder, this message appears: Approval
workflow for this content is currently inherited. You can break this
inheritance in the "View Permissions" screen for content title. To view the
workflow assigned to the content's folder, choose the folder's View > Properties
menu option, then click Manage Approvals (

).

Editing an advanced workflow for content
You can change the following advanced workflow information for a content item:
l

workflow

l

list of approvers

l

for each approver
o escalation user or group
o

escalation time period

PREREQUISITES
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l

Only administrator group members and users assigned to the Folder User Admin
Role screen can edit an advanced workflow. See also: Defining roles on page 1581

l

The content does not inherit its workflow. If it does, you must break inheritance by
viewing its Permissions screen and unchecking Allow this object to inherit
permissions.
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l

The content is not in Submitted status. If it is, and you want to edit the workflow,
your options are as follows:
o cancel the approval process. See also: Canceling an approval request in an
advanced workflow on page 784
o

force publish the content item. See also: Forcing the publication of content on
page 785

o

get all approvers to approve the Submitted content, so its status changes to
Published.

To edit a content item's advanced workflow:
1. Go to the folder that contains the content whose workflow you want to edit.
2. Choose View > Language and select the workflow's language.
3. Click the content to access its View Content screen.
4. Click Manage Approvals (

).

5. From the Select Workflow Type drop-down, select a workflow to assign to this
content. See also: Standard vs. custom workflow on page 765
6. You can edit the user or group for each approver. If you assign a group, any
member of the group can approve or decline the content.
BEST PRACTICE
Assign user groups (not individual users) to a workflow. In this way, if
someone is out of the office, any other group member can approve
content.
PREREQUISITE

You can only choose users or groups who have read-only or greater
permissions for the folder.
7. For each approver, you can enter or modify an escalation time period and user or
group in the Escalation column. See also: How escalation affects the approval
process on page 766
8. Click Save.

Removing an advanced workflow from content
You can remove an advanced workflow from a content item, so that it has no workflow.
If you want to switch an advanced workflow to basic workflow, see Switching from
advanced workflow to basic workflow on the next page.
Because workflow is language-specific, the procedure explains how to delete content
workflow for only 1 language. To remove workflow for multiple languages, repeat this
procedure for each one.
PREREQUISITES
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l

Only administrator group members and users assigned to the Folder
User Admin Role screen can remove an advanced workflow. See also:
Defining roles on page 1581

l

The content does not inherit its workflow. If it does, you must break
inheritance by viewing its Permissions screen and unchecking Allow
this object to inherit permissions. See also: Key workflow concepts
on page 749

l

The content is not in Submitted status. If it is, and you want to remove a
workflow, your options are as follows:
o cancel the approval process. See also: Canceling an approval
request in an advanced workflow on page 784
o

force publish the content. See also: Forcing the publication of
content on page 785

o

get all approvers to approve the content, so its status changes to
Published.

To remove an advanced workflow from a content item:
1. Go to the folder that contains the content whose workflow you want to remove.
2. Choose View > Language and select the language of the workflow.
3. Choose View > Properties.
4. Click the content to access its View Content screen.
5. Click Manage Approvals (

).

6. Click Remove Workflow ().

Switching from advanced workflow to basic workflow
See also: Switching from basic workflow to advanced workflow on page 764
PREREQUISITES
l
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No content in the folder is in an approval process. If it is, and you want
to switch a workflow, your options are as follows:
o cancel the approval process for each content item in Submitted
status. See also: Canceling an approval request in an advanced
workflow on page 784
o

force publish each content item in Submitted status. See also:
Forcing the publication of content on page 785

o

get all approvers to approve Submitted content, so its status
changes to Published.

l

You have permission to edit the folder or content item being switched.

l

All approvers for the basic workflow have at least read-only permission
for the folder or content.
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1. If the folder or content item whose workflow you want to switch inherits workflow,
break inheritance. Breaking inheritance on page 170
2. Within the Workarea, go to the folder or content item.
3. Click View > Properties.
4. Click Manage Approvals (

).

5. Click Remove Workflow ( ).
6. When the Manage Approvals screen reappears, click Use basic workflow.
7. Follow Creating a basic workflow for a folder on page 753.

Managing content in an advanced workflow
After you set up an advanced workflow, read the following sections to learn how to
manage content through the approval process.

Submitting content into an advanced workflow
To submit content into the workflow process, a content author uses the Submit button
(on the editor toolbar) or menu option; the content status changes to Submitted.
NOTE: If no workflow is assigned to a folder or content, a Publish button appears
instead of the Submit button.

When content is submitted, the workflow's next approver or group is notified by email
that content awaits their approval. That user can go to the content, then review and
approve it using the Approve context menu option or toolbar button on the View
Content screen.
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Alternatively, the approver can use the Approval report on page 1057 or Submitted
content report on page 1059 to find, review and approve content. Upon approving the
content, the approver is prompted to enter an optional comment. If one is entered, it is
included in the notification email.
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l

If an escalation time period is assigned to an approver or group, and an approver
does not act on the content within that time period, approval responsibility
transfers to the escalation user or group. See also: How escalation affects the
approval process on page 766

l

If not satisfied with the content, any approver can decline it. If declined, approval
responsibility reverts to the previous approver, who can edit then resubmit the
content or decline it. See also: Declining content in an advanced workflow on
page 786

l

An administrator can bypass the approval process at any time, either by force
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publishing or canceling.

See also: Canceling an approval request in an advanced workflow on the next page,
Forcing the publication of content on page 785

Monitoring content in an advanced workflow
To see any content item's workflow and current approver, view its properties screen.
Red text indicates the current approver. Next to that approver is an indication of how
long ago the approval request was assigned.
NOTE: If a content item's approval request is escalated, the escalation user or
group does not appear on the View Content screen. See also: How escalation affects
the approval process on page 766
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To see all content
l

awaiting your approval; use the Approval report on page 1057.

l

in Submitted status; use the Submitted content report on page 1059.

l

via desktop widgets; Managing content from the Smart Desktop on page 668
o Content Awaiting Approval (a shortcut to the Approval report on page 1057).
o

Content In Workflow. All content in Submitted status (a shortcut to the
Submitted content report on page 1059).

Canceling an approval request in an advanced workflow

784
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You can cancel an approval request for any Submitted content item. It does not matter
if anyone has approved the content yet.
For example, you want to change one of the users assigned to a workflow, and can only
do this if no content is in Submitted status. Upon cancellation, the content's status
reverts to Checked In.
PREREQUISITES
l

Content status is Checked in (I), Submitted (S) or Checked out (O)

l

You are a member of the administrators group, or assigned to both of
these roles. See also: Defining roles on page 1581
o folder user admin
o

content workflow admin

To cancel an approval request for a Submitted content item:
1. Go to the folder that contains the content whose approval request you want to
cancel.
2. Choose View > Language and select the content's language.
3. Click the content to access its View Content screen.
4. Click Manage Approvals ( ).
5. Click Cancel Workflow. A confirmation appears.
6. Click OK. The content's status changes to Checked In.

Forcing the publication of content
You can force the publishing of a content item, bypassing its workflow. Upon
publication, the content's status changes to Approved. For example, you want to
change one of the users assigned to a workflow, and can only do this if no content is in
Submitted status.
NOTE: On PageBuilder pages, Force Publish ( ) only appears after the content is
submitted. The button does not appear on the initial PageBuilder dialog when
creating a new page.
l

Content status is Checked in (I), Submitted (S) or Checked out (O).
o You can force publish content upon creating it.

l

You are a member of the administrators group, or assigned to both of
the following roles. See also: Defining roles on page 1581
o content workflow admin
o

folder user admin

To force the publishing of a content item:
1. Go to the folder that contains the content that you want to force publish.
2. Choose View > Language and select the content's language.
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3. Click the content to access its View Content screen.
4. Click Force Publish (

). The content's status changes to Approved.

Declining content in an advanced workflow

Only the current approver (or user group member) can decline content. This would
typically be done if the content was unsatisfactory. Upon declining, the user is
prompted to enter a comment. The next action depends on that user's workflow
position.
l

If the user is the first approver, the content reverts to Checked In status, and is
removed from the workflow process.

l

If the user is not the first approver, approval responsibility reverts to the previous
approver or group. Only that user or group member can work with the content. The
previous approver can edit it then submit again, or decline it.
The previous approver is notified by email that the content was declined. The
notification includes the comment. Notifying users of advanced workflow activities
on page 768

Deleting content in an advanced workflow
You can delete content only if the status is Checked In, Approved, or Pending Go Live
Date. If the content status is Submitted and you need to delete it, your options are:
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l

Cancel the approval process. See also: Canceling an approval request in an
advanced workflow on page 784

l

Force publish. See also: Forcing the publication of content on the previous page

l

Get all approvers to approve the content, so its status changes to Published.
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Editing content in an advanced workflow

Content controlled by an advanced workflow is deleted immediately—no approval is
required. In this way, the procedure is different from the deletion of content controlled
by basic workflow, which requires approval.
For additional guidelines, see Deleting content on page 688.
PREREQUISITE

You are a member of the Administrators group, or are assigned to the
Content Workflow Admin role and have delete permission for the content.
1. Go to the folder that contains the content that you want to delete.
2. Click the triangle to the right of the content to display its context menu.
3. Click Delete.

NOTE: If you do not see a Delete button or menu option, either you lack
permission to delete, or the content status is not Checked In, Approved, or
Pending Go Live Date.

Editing content in an advanced workflow
If you are the current approver and have edit permission for Submitted content, you
can edit it. Otherwise, you can edit content with the status of Checked In, Approved, or
Pending Go Live Date only.
If you want to edit Submitted content but are not the current approver, your options
are as follows:
l

Cancel the approval process. See also: Canceling an approval request in an
advanced workflow on page 784

l

Force publish. See also: Forcing the publication of content on page 785

l

Get all approvers to approve the content, so its status changes to Published.

PREREQUISITE
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You are a member of the Administrators group or have edit permission for
the content.
1. Go to the folder that contains the content that you want to edit.
2. Click the triangle to the right of the content to display its context menu.
3. Click Edit.

Creating a custom advanced workflow
This section explains how a developer can customize an advanced workflow so that it
meets the needs of your business processes. To customize, Ektron recommends saving
the sample workflow installed with the product under a different name, then
customizing the copied file using the following instructions.
PREREQUISITES
l

Visual Studio 2012 (full version with developer tools, and so on)

l

.NET 4.5

l

Knowledge of Windows Workflow Foundation

l

Permission to edit files on the Ektron server

Step 1: Install Ektron’s SDK
To install Ektron's Software Development Kit (SDK) during installation, choose SDK on
the Site Options screen.

If SDK is not selected during installation, you can install the SDK in either of the
following ways:
l

l

Windows Start button > All Programs > Ektron > Cms400vx.x > Utilities >
CMS400SDK install
C:\Program Files (x86)\Ektron\CMS400vx.x\Utilities\CMS400SDK_
Setup.exe

The SDK's workflow components are installed to C:\Program Files
(x86)\Ektron\CMS400SDK\Contentworkflow\code.

Step 2: Open the sample workflow file
788
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Step 2: Open the sample workflow file

1. Launch Visual Studio 2012.
2. Open C:\Program Files
(x86)\Ektron\CMS400SDK\Contentworkflow\code\ContentWorkflowSDKSample
.sln.
3. In Solution Explorer, click ContentWorkflowStateSDKSample.xaml. The sample
workflow file opens.

4. Add Ektron Workflow controls to the Visual Studio toolbox.
a. Open the Visual Studio Toolbox.
b. Add a tab and name it Ektron Workflow.
c. Right click and select Choose Items....
d. Click Browse.
e. Choose C:\Program Files
(x86)\Ektron\CMS400SDK\Contentworkflow\code\CMS\Ektron.Cms.Conte
ntWorkflow.dll.
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f. Click OK. The controls appear on the tab.

Step 3: Edit the sample workflow file
IMPORTANT: Save the sample workflow file under a different name, then
customize the copy of the file.

Rules for working with the sample workflow file
l

Only statemachine workflowis supported.

l

Each workflow approver is represented by one workflow state.

l

Transitions
o Approver states have two transitions: Approved and Declined.
n Upon approval, the transition destination is the next workflow activity.
Upon approval by the last approver, the transition destination is Final
State.
n
o

790

Upon decline, the transition destination is the previous workflow activity.

Final State has no transitions.

l

Do not delete or edit the Get Item Before Transition state.

l

Do not delete the Final State.
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Step 3: Edit the sample workflow file

l

You can add code to customize the behavior of any state or transition.

To see the arguments for use in custom code, open the Arguments panel.
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Step 3a: Adding an approver
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Step 3a: Adding an approver

1. From the Visual Studio toolbox, drag and drop a State machine > State control.

2. Drag the new state near other states with which it will connect.
3. Open an existing workflow activity, such as Second Approver.
4. Right click and copy its UpdateInstance activity.

5. Click to open the new state.
6. Within the Entry box, right-click Drop activity here and paste the
UpdateInstance activity.
7. In the title bar, select the default text, State1, and replace it with the new state's
name. For example, Sixth Approver.
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8. At the bottom of the screen, click Variables to open that panel.

9. Enter these values into the Variables panel.
l Name. ApproverName

794

l

Variable type. String

l

Scope. copied from the name you assigned in Step 7.

l

Default. Within quotes (""), enter the name you assigned in Step 7.

Ektron 9.40 SP1

Step 3b: Removing an approver

10. Create an Approved transition between the new state and its next state.
a. Click an existing Approved transition to open its dialog.
b. Copy its WaitForItemEvent.
c. Create a transition by dragging a line from the side of the new state to its
approval destination state. For example, drag a line from the Sixth Approver
state to the Final State.
d. Click the transition to open its dialog.
e. Within the Trigger box, right-click Drop trigger activity here and paste the
WaitForItemEvent activity.
f. In the title bar, select the default text, Tnumber, and replace it with
Approved.
11. Create a Declined transition between the new state and its previous state.
a. Click an existing Declined transition to open its dialog.
b. Copy the WaitForItemEvent.
c. Drag a line from the side of the new state to its declined destination state. For
example, drag a line from the Sixth Approver state to the Fifth State.
d. Click the transition to open its dialog.
e. In the top box, right-click Drop trigger activity here and paste the
WaitForItemEvent activity.
f. In the title bar, select the default text, Tnumber, and replace it with Declined.

Step 3b: Removing an approver
1. Drag the transitions of the state being removed to new states.
For example, if you are removing the Fourth Approver in a Five Approver workflow,
move the Fifth Approver's declined transition to Third Approver. Then, move the
Third Approver's Approved transition to the Fifth approver.
2. Rename the approver that follows the approver being deleted. To continue the
above example, change the name of Fifth Approver to Fourth Approver.
IMPORTANT: Do not change the name of the Final State.
3. Select the approver state that you want to delete.
4. Right click and choose Delete.

Step 3c: Adding a custom activity to a workflow
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1. In ContentWorkflowSDKSample.sln, add a new Code Activity item to the project.

2. In the new Code Activity file, add custom code. In the following example, a simple
content block is created.
IMPORTANT: Use Try Catches around your code.
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Step 3c: Adding a custom activity to a workflow

3. After saving the Code Activity file, you can find it in the Visual Studio Toolbox. By
default, it appears under the name of your assembly,
Ektron.Cms.ContentWorkflowSDKSample.

You can place the activity anywhere you see Drop activity here.
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In the following example, the activity is placed in the Approved transition between First
Approver and Second Approver.
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Step 4: Update the

Step 4: Update the Ektron.cms.contentworkflow.config
file
After you customize the sample workflow file and save it to a different name, edit
Ektron.cms.contentworkflow.config. Ektron references this file to determine the
properties of your advanced workflows.
1. In Solution Explorer, right click the ContentWorkflowSDKSample project and
choose Properties.
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2. Copy the Assembly name.

3. In Solution Explorer, select the .xaml sample workflow file that you edited in Step
3: Edit the sample workflow file on page 790, right click, and choose View Code.
The xml version of the file appears.
4. Copy the value of x:Class in the top line.
<Activity mc:Ignorable="sap sap2010 sads"
x:Class="Ektron.Cms.ContentWorkflowStateSDKSample"
xmlns="http://schemas.microsoft.com/netfx/2009/xaml/activities"
xmlns:av="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:ecc="clr-namespace:Ektron.Cms.Common;assembly=Ektron.Cms.Common"

5. Open siteroot\Ektron.Cms.ContentWorkflow.config. In this file, each
workflow activity contains the following XML structure. Each workflow has several
"activities" (approvers or states), and each state has several transitions (typically,
a decline and an approve).
<Workflow>
<Activities>
<Activity ActivityName="First Approver" AssignUser="true">
<Transitions>
<Transition TransitionName="Approved" BookmarkName = "First Approver Approved"
Destination="Second Approver" />
<Transition TransitionName="Declined" BookmarkName = "First Approver
Declined"
Destination="Author" />
</Transitions>
</Activity>
<Activities>
</Workflow>
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Step 5: Move the compiled .dll file to siteroot\bin

6. To add a new workflow:
a. Copy and paste an existing workflow. A workflow is surrounded by
<Workflow> </Workflow> elements.
b. Modify the pasted workflow as follows:
i. Change its DisplayName to the name you want to appear in the Ektron
Workarea.
ii. Replace ClassName with the class name you copied in Step 4 of this
procedure.
iii. Replace AssemblyName with the assembly name you copied in Step 2 of
this procedure.
iv. To add an activity, copy and paste an existing one. For example, if the
new workflow has 5 steps, copy and paste the "4 Step Approval" activity.
v. Update the copied <Activity> properties to match the new workflow. To
continue the example:
n Change DisplayName to "5 Step Approval."
n

Within the "Fifth Approver" <Activity> element, update the
approved and declined transition values to match the .xaml file.

n

Modify the properties of other activities to match the .xaml file. For
example, change the Fourth Approver's Destination from "Final
State" to "Fifth Approver".

7. To remove an existing workflow:
a. Select and delete the beginning (<Workflow>) and ending (</Workflow>)
elements.
b. Modify the properties of other activities to match the .xaml file. For example,
change the third Approver's Destination from "Fourth Approver" to "Final
State".

Step 5: Move the compiled .dll file to siteroot\bin folder
1. With the sample project open in Visual Studio, click the menu option Build > Build
Solution. The project starts to build.
The build creates a new .dll file in C:\Program Files
(x86)\Ektron\CMS400SDK\Contentworkflow\code\bin\Debug. The file name
matches the assembly name that you copied in Step 2 of Step 4: Update the
Ektron.cms.contentworkflow.config file on page 799.
2. Copy the .dll file to the siteroot\bin folder.

Step 6: Publish affected content
Before using the new workflow file, publish content that will be affected by it.
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1. Identify every folder or content item to which you want to apply the new workflow.
2. Publish content in those folders, and affected content items. You can either ask
approvers to approve the content, or (if you are an Administrators Group
member) use the Force Publish button. See also: Forcing the publication of
content on page 785

Step 7: Test the new workflow in the Ektron workarea
Ektron Workarea users can select the new workflow on the Manage Approvals screen.

Try out the new workflow in a test environment before moving it to a live system.
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Removing a custom advanced workflow
Use this procedure to remove advanced workflows that are delivered with Ektron, or
any that are created for your site.
PREREQUISITE

You have permission to edit files on the Ektron server.
1. In the Ektron Workarea, review folders and content to make sure that the
advanced workflow you want to delete is not currently assigned to any of them.
2. Open siteroot\Ektron.Cms.ContentWorkflow.config.
3. Select the opening and closing <Workflow> tags of the workflow you want to
remove.
<Workflow DisplayName = "Two Step Approval"
ClassName = "Ektron.Cms.ContentWorkflow.ContentStateMachineWorkflow"
AssemblyName = "Ektron.Cms.ContentWorkflow" >
<Activities>
<Activity ActivityName="First Approver">
<Transitions>
<Transition TransitionName="Approved" BookmarkName = "First Approver
Approved"
Destination="Second Approver" />
<Transition TransitionName="Declined" BookmarkName = "First Approver
Declined"
Destination="Author" />
</Transitions>
</Activity>
<Activity ActivityName="Second Approver">
<Transitions>
<Transition TransitionName="Approved" BookmarkName = "Second Approver
Approved"
Destination="Final State" />
<Transition TransitionName="Declined" BookmarkName = "Second Approver
Declined"
Destination="First Approver" />
</Transitions>
</Activity>
</Activities>
</Workflow>

4. Delete or comment out the unwanted workflow.
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Working with collections
A collection is a list of content links offered to readers of a Web page. The following
illustration shows a collection.

You can use a collection to display any listing, such as job postings, press releases, and
knowledge base articles. The following is a collection within Ektron’s Knowledge Base.

This section explains how to find, create, and manage collections. Your developer then
creates or updates a Web page to display them using the Collection server control or
Collection widget.

Comparing menu, collection, list summary, and
taxonomy features
Menu, collection, list summary, and taxonomy features are similar because they let you
add a list of links to a Web page. The following table compares the features to help you
understand which one is best suited to your needs.
NOTE: To implement these features, the assistance of a developer is required.
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Comparing menu, collection, list summary, and

IMPORTANT: Starting from release 8.6, the ListSummary server control was
replaced by the FrameworkUI: <ektron:ContentView> templated server control. If
you are already using the ListSummary server control, you can continue to do so,
but Ektron recommends using current versions of functionality.

Menu

Display all content in a
folder. As folder’s
content changes,
display changes.

Collection

List
Summary

Taxonomy

(folder
items
appear on
a menu)

Can display all content
in a folder’s subfolders
Display selected
content
Display external
hyperlinks
Display library files
Display content
summary (optional)
Display additional
content information:
l

comment

l

last modified date

l

start date

l

end date

l

user who last
edited it

l

ID number

l

path relative to
your site’s root
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Menu

Collection

Can be multi-leveled

List
Summary

Taxonomy

(recursive
folders)

Main purpose is
navigation
Main purpose is
classification

Finding collections
Every collection is assigned to a folder. You can find collections in the following ways.

Finding collections by folder
To find collections in a folder:
1. Click the content folder that contains the collection.
2. If you are using Ektron’s multi-language support features, select a language by
choosing View > Language. See also: Working with multi-language content on
page 1507
3. Choose View > Collection. The View Collections screen appears.

Finding all collections
806
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The Content tab has a Collections panel that displays all collections, regardless of
folder. To view all collections in all content folders:
1. From the Workarea, click Content > Collections > Collections. The View
Collections screen appears.
2. Select a collection.

If you have a large number of collections, use the screen's Search box to find one.

Creating a collection
This section explains how to create a collection in a site that does not support multiple
languages. To create collections in several languages, see Working with a collection in a
multi-language system on page 817.
PREREQUISITES

To create, edit, remove, delete, or reorder a collection, you must have one
of these criteria.
l

Administrators group member

l

assigned one of these roles See also: Defining roles on page 1581.
l Collection and Menu Admin

l

l

Collection Admin

l

Folder User Admin

l

Collection Approver

granted Collections permission for the collection’s folder. Permission is
granted on the folder Permission screen > Advanced tab. See also:
Managing folder and content permissions on page 168.

NOTE: Only users assigned to the Administrators group, Collection and
Menu Admin role, Collection Approver, or Collection Admin role can work
with Collections via the Collections tab. Users who do not belong to one
of these groups can work with collections (if they have Collections

Ektron Reference

807

Managing content

permission for the collection’s folder) by selecting a folder then New >
Collection or View > Collection.

1. To create a new collection, use one of these methods. The Add Collection screen
appears.
o To create a collection in a specified folder, go to it, and choose New >
Collection.
o

To create the collection in the root folder, choose Content > Collections >
Collections then click Add.

2. Hover the cursor over Collections (see previous image), right click the mouse,
and click Add Collection. Complete the screen using the following information.
o

Title. Assign a unique title to the collection.

o

Template. Enter the default template for the collection. This template
displays the content of the links generated if no template is assigned in the
custom function. If left blank, the links use their respective Quicklinks. See
also: Creating a collection on the previous page

o

Description. Add a more detailed description for the collection.

o

Include Subfolders. Check if you want to be able to add to the collection
content in subfolders of the collection's content folder.

o

Approval is Required. See Setting up collection approval on page 817

3. Click Save when finished.
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Deleting a collection

A collection’s folder appears on the Content > Collections > View All Collections
screen, in the Path column. No value (\ ) indicates root folder.

After creating the collection, you typically add content to it. See Creating content for a
collection on the next page and Assigning content to the collection on page 811.

Deleting a collection
1. From the Workarea, go to Content > Collections.
2. Click the collection you want to delete.
3. Click Delete (

).

Alternatively, hover the cursor over the Collection, right click the mouse, and click
Delete collection name.
If this collection requires approval, and the user who is deleting cannot approve
changes, the following occurs. See also: Setting up collection approval on
page 817.
l

The collection’s status changes to Marked for Deletion (M), and an email
notification is sent to all approval users for the collection. One of the approval
users must open the Edit Collection screen and click the Delete or Decline
button.

l

If an approval user clicks Delete (
website.

l

), the collection is removed from your

If an approval user clicks Decline ( ), the user who submitted the deletion is
notified by email but no website changes are made.
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NOTE: Any user with permission to edit a collection can perform the undo
function until the content is approved
4. Click OK to proceed.

Creating content for a collection
To create new content while adding content links to a collection:
1. Go to the content folder containing the collection.
2. Choose View > Collection. The View Collections screen appears.
Alternatively, choose Content > Collections > Collections.
3. Choose a collection.
4. Accept or change the language.

5. Click Add Items. The Add Items to Collection screen appears, displaying all
subfolders within the selected folder and content in the folder that is not part of the
collection. (Subfolders are available if the Include subfolders checkbox was
checked for the collection.)
Alternatively, hover the cursor over the collection in the left panel, right click the
mouse, and click Add Items.
NOTE: If your collection includes subfolders and you want to add the content to
one of them, go to that subfolder. Otherwise, proceed to the next step.
6. Click Add Content (

). The Add Content screen appears.

NOTE: If you are using Ektron’s multi-language support, the content’s language
appears next to the title. The language is derived from the collection’s language
and cannot be changed.
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7. Create the content.
8. Click a workflow option in the Add Content screen, such as Publish. The Add
Content screen closes, and the new content link appears.
9. Check the content you created and other content.

10. Click Add.

Assigning content to the collection
After creating a collection, you assign content to it as described in the following steps.
NOTE: When viewing a Collection on the website, a site visitor sees the last
published version of content. If it was never published, nothing appears.
1. Go to the content folder containing the collection to which you want to add content.
2. Choose View > Collection. The View Collections screen appears.
Alternatively, choose Content > Collections > Collections.
3. Choose a collection.
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4. Accept or change the language.

5. Click Add Items. The Add Items to Collection screen appears, displaying all
subfolders within the selected folder and content in the folder that is not part of the
collection. (Subfolders are available if the Include subfolders checkbox was
checked for the collection.)
Alternatively, hover the cursor over the collection in the left panel, right click the
mouse, and click Add Items.
As another alternative, go to a content folder, click items to be assigned, right click
the mouse and select Copy. Then, locate the collection, right click the mouse, and
select Paste Items to Collection.
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Assigning content to the collection

NOTE: The file types pulldown remembers your most recent choice and can
filter which files appear. You can change the selection if desired.
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6. Check content to add to the collection. You can only add content from the selected
folder or its subfolders. (Subfolders are available if the Include subfolders
checkbox is checked for the collection.)
l Click a subfolder to view its content.
l

To return to the parent folder, click the folder with the up arrow (

l

Navigating between subfolders deselects content.

).

7. Click Add to add selected content to the collection.

Editing content in a collection
1. Go to the content folder that contains the collection that you want to edit.
2. Choose View > Collection. The View Collections screen appears.
Or from the Content tab, click Collections.
3. Click the collection whose information you want to change.
4. Select a language.
5. Click Properties (

).

6. Click Edit.
7. Change any field values.
o Title. Assign a unique title to the collection.
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o

Template. Enter the default template for the collection. This template
displays the content of the links generated if no template is assigned in the
custom function. If left blank, the links use their respective Quicklinks. See
also: Creating a collection on page 807

o

Description. Add a more detailed description for the collection.
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Removing content from a collection

o

Include Subfolders. Check if you want to be able to add to the collection
content in subfolders of the collection's content folder.

o

Approval is Required. See Setting up collection approval on page 817

Removing content from a collection
1. Go to the content folder that contains the collection and click View > Collection.
Or from the Content tab, click Collections.
2. Click a collection.
3. Click Remove Items ( ). The Remove Items from Collection screen appears.
Alternatively, hover the cursor over the Collection, right click the mouse, and click
Remove Items.
4. Check boxes next to content you want to delete.

5. Click Delete.

Reordering a collections list
After a collection is created, and more than one content item is assigned to it, you can
reorder a collection list as described in the following steps.
1. From the Workarea, go to Content > Collections.
2. Click the collection you want to reorder.
3. Click the Reorder button ( ). The Reorder Collection screen appears.
Alternatively, hover the cursor over the Collection, right click the mouse, and click
Reorder Item.
4. Click the content whose order you want to change.
5. Click the up or down arrow to move the content.
6. When you have the desired order, click Update.
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Using a default template vs. quicklinks for a collection
You can specify a template that determines the screen display for a collection when it is
published on a Web page. You also can disable the template and, instead, use
quicklinks to determine the page template. (See also: Viewing quicklinks or forms on
page 747)
l

If you use quicklinks, every page in the collection uses its original template. As a
result, the surrounding information may change for every content item in the
collection.
The following example shows links using Quicklinks. Notice that content uses
several templates. As a result, when a user clicks content in the collection, the
screen information around the content is determined by its template.

l

If you use a template, all content in the collection uses the template other than the
specific content. For example, the page header, footer and information in the right
frame of the screen are all the same.
The following example show links when you use a template named index.asp.

NOTE: If a collection item is a form, ekfrm is used instead of id to denote form
block.
To toggle between a default template and Quicklinks:
816
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1. Access the Edit Collection screen for the collection you want to edit.
2. Modify the Template field.
3. Click Update.

Working with a collection in a multi-language
system
In a multi-language Ektron system, you can create a language-specific edition of each
collection. When a site visitor selects a language, then goes to a page with a collection,
Ektron displays the collection in the selected language if available. If not, Ektron
displays nothing.
NOTE: Notice the contrast between the collections and content: if a collection is not
available in a selected language, nothing appears. However, if content is not
available in the selected language, content in the other languages may appear.
IMPORTANT: You can only add content in the language of a collection. So, create
content first, then create a collection that links to it.
When you create a collection for a foreign language, decide from the following:
l

Create a foreign edition of an existing collection to provide several versions of a
single page that change depending on the language selected by the user.
1. Form the Workarea, go to Content > Collection.
2. Click the Collection that you want to create in another language.
3. From the View drop-down list, select the language of the new collection.
4. Using AddItems, select content to add to the collection. Go through the
folders to the content you want to add. You can only add content in the
selected language.

l

Create a new collection in a foreign language to appear only on a foreign language
page, and no other edition of the collection appears on your site.
1. Go to the folder in which you will create the collection.
2. Click View > Language and select the language of the collection.
3. Click New > Collection. The Add Collections screen appears.
4. Click Add and enter basic information about the collection.
5. Using AddItems, select the content to add to the collection. Go through the
folders to the content you want to add. You can only add content in the
selected language.

Setting up collection approval
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If you require a collection to be approved, only the following users have permission to
create or edit a collection and can approve a change to a collection.
l

a member of the Administrators group

l

users to whom the Collection Approver role has been assigned and who have
permission to work with the collection

l

users to whom the Folder User Admin role has been assigned and who have
permission to work with the collection

You can set up an approval system for any collection. As with content workflow, you
specify users to approve changes to a collection before it can be published.
l

While content can have a chain of approvers, a collection has a list of approvers.
Any collection approver can publish or decline changes for a collection.

l

While content workflow is folder-specific, collection approval is not. When set up,
collection approval affects the collection to which it was assigned, regardless of its
folder.

l

If a user who is not an approver tries to delete a collection, that action also requires
approval.

Only administrators or users to whom the folder-admin role has been assigned see the
Approval is Required checkbox on the Add and Edit Collection screens.
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What happens when someone submits changes to

What happens when someone submits changes to a
collection
Whenever anyone changes a collection that requires approval (by adding or removing
content items), the toolbar on the View Collection Screen changes.
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By default, you only see approved collection items. To see unapproved items, click
View Stage.
After changing a collection's contents, if a user has permission to edit collections but not
approve changes, he sees the following toolbar.

That user should click Submit (
). This action triggers an email notification to all
approval users for the collection. It also changes the collection’s status to checked out.
No other users can edit it in this status.
A user with permission to approve changes sees the following toolbar after clicking
View Stage.

If the user clicks Publish (
website.

820

Ektron 9.40 SP1

), the new version of the collection is published to your

What happens when someone submits changes to

Any user with permission to edit a collection can go to the screen and click Undo
Checkout () any time before the approval. In this case, the submitted changes are
deleted, and the collection reverts to its original state.
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Working with Metadata
Metadata is information about a content item, such as its title and language. Ektron
provides extensive and flexible support for metadata, which is used in both standard
and innovative ways.
You can add the following kinds of metadata content.

Metadata types
l

Searchable. Metadata that can be found by Ektron’s search and the Workarea
Search screen. Creating and deploying a Search tag definition on page 827

l

Meta tag. Resides in a content’s source code, helping search engines find it.
Creating and deploying a Meta tag definition on page 825

l

HTML tag. Information about content used by a Web browser. For example,
<title> identifies the content in the screen title, favorites list, and browser
history. Creating and deploying a Title tag definition on page 826

l

Related content. A related content item, collection, List Summary, or library item
that accompanies a content item on a Web page. Creating and deploying a related
content definition on page 830.

l

Content tags. Keywords that can be assigned to content and library items.
Content tags allow for tag-based searching. Applying content tags on page 835

l

Image. Not part of a metadata definition; automatically appears for every content
item and lets you assign an image to that content. Assigning an image to metadata
on page 836

l

Simple Dublin Core. Fifteen standard fields that cover the most useful
information about content. Applying Simple Dublin Core metadata on page 836

BEST PRACTICES
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o

When anyone creates a new Metadata definition, it is assigned the next
available ID number. The ID numbers determine the order in which
metadata definitions are arranged on the Folder properties screen’s
Metadata tab. By planning ahead, you can enter metadata definitions
in logical groupings, which make it more intuitive for the person
assigning the metadata to pick the correct ones.

o

You can use metadata as a search criterion for your website content, but
the metadata definition name cannot include a space. Eliminate spaces
from metadata definition names.
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You define metadata in the Workarea at Settings > Configuration > Metadata
Definitions, but you assign metadata in the Content area.
PREREQUISITE

Only Administrator group members and those defined in the Manage
Members for Role: Metadata-Admin screen can view, add, or edit metadata
definitions. See also: Using the roles screens on page 1582

Adding a metadata definition
Use the Add Metadata Definition screen to define metadata (such as keywords and
title). You can define as many instances of metadata as you wish. If your site supports
multiple languages, you create metadata definitions for each supported language.
IMPORTANT: After creating a definition, you assign it to folders, whose content
uses it. See also: Assigning metadata to a folder on page 832
To add a metadata definition:
1. Settings > Configuration > Metadata Definition. The View Metadata
Definitions screen appears.
2. From the language drop-down, select the primary language of the metadata
definition. You may apply other languages to the definition on the Add Metadata
Definition screen.

Ektron Reference

823

Managing content

3. Click Add Metadata Definition. The Add Metadata Definition screen appears.

l

Name. Enter a name to identify this metadata. Do not include spaces. Ektron
reserves a list of names that you cannot use. If you enter one, a message
appears.

l

Type. Select a metadata type from the drop-down list. The type determines
which fields appear on the lower part of the screen. See also: Working with
Metadata on page 822

l

Editable. Check this box to allow users to edit metadata when applying it to
content. Do not check this box if you want uniform metadata text for each
content item that uses this metadata.

l

For documentation of the next screen section, see the selected Type.
o Creating and deploying a Meta tag definition on the facing page
o
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o

Creating and deploying a Search tag definition on page 827

o

Creating and deploying a related content definition on page 830

4. To let users apply this metadata definition to content in languages other than the
primary one (which you selected in Step 2), check each allowed language. See
also: Creating multi-language metadata while creating a metadata definition on
page 1514
IMPORTANT: You can apply additional languages only when creating a
metadata definition. You cannot apply them when editing.
5. Complete the fields and click Update.

Creating and deploying a Meta tag definition
The following definition was copied from www.w3.org/MarkUp/html-spec/html-spec_
5.html.
The META element is an extensible container for use in identifying specialized document
meta-information. Meta-information has 2 main functions:
l

to provide a means to discover that a data set exists and how it might be obtained
or accessed

l

to document the content, quality, and features of a data set, indicating its fitness
for use

1. Complete the steps in Adding a metadata definition on page 823.
2. Complete the Meta Tag description fields.
o Style. Select from the drop-down list to indicate whether you want the style to
be name or http-equiv. For more information, see The Meta Element
o

Remove Duplicates. Check this box to remove duplicate words or phrases
from the metadata.

o

Case Sensitive. Check this box to remove duplicates only if the letters and
case of each letter match.

o

Separator. Enter a character to separate the metadata values. The default is
a semicolon (;).
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o

Selectable Metadata. Check this box to force users to select from the
options specified in the Allow Selectable Text and Default Text fields. If
you do not check this box, users can create their own metadata.

o

Allow Multiple Selections. Check this box to let users select multiple
metadata values instead of one. If multiple values are allowed, use the
separator character to delimit them. If this box is not checked, all values
appears in a drop-down list, and the user selects the correct one. This field is
only active if the Selectable Metadata box is checked.

o

Allowed Selectable Text. Enter standard metadata that can be selected by
users. Separate each option by the separator specified for the metadata
definition. This field is only active if the Selectable Metadata box is checked.

o

Default Text. Enter default content for the metadata tag.

3. Click Save.
4. Add the definition to all applicable folders by editing the properties of the folder and
checking the metadata boxes on the Metadata tab and clicking Update.
5. Edit the metadata on content items in the folder and click Save or Publish.
6. Add a metadata server control to every Web form (.aspx page) on which the
content will appear. See the Metadata server control.

Creating and deploying a Title tag definition
The following definition was copied from www.w3.org/MarkUp/html-spec/html-spec_
5.html.
The title should identify the contents of the document in a global context. A browser
may display the title of a document in a history list or as a label for the window
displaying the document.

1. Complete the steps in Adding a metadata definition on page 823.
2. Enter default content for the HTML tag. For example:
content="document management web content management content management cms"

3. Click Save.
4. Add the definition to all applicable folders by editing the properties of the folder and
checking the metadata boxes on the Metadata tab and clicking Update.
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5. Edit the metadata on content items in the folder and click Save or Publish.
6. Add a metadata server control to every Web form (.aspx page) on which the
content will appear. See the Metadata server control.

Creating and deploying a Search tag definition
Searchable metadata allows content to be found by a search phrase that you add to the
content’s metadata. The content is typically found by either a website search or a
Workarea search.
For example, each DMS document has a unique part number. To let site visitors and
Ektron users locate the document by its part number, you need to:
a. Add a custom metadata definition called Part Number, and specify a type of
number.
b. Add that metadata definition to all folders that contain the documents.
c. When you add a document, click its Metadata tab, and insert the part number for
the document. Then, anyone searching your website can find that document by its
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part number.

1. Complete the steps in Adding a metadata definition on page 823.
2. Complete the Searchable Property description fields.
l Publicly Viewable. If you check the box, site visitors can find the metadata
value when searching your website. Otherwise, site visitors cannot find the
metadata value.
NOTE: Regardless of whether this is checked, content to which this
metadata value is applied can be found using the Workarea’s Search
Content Folder screen > Advanced Search tab > metadata field.
Also, if you have set up an Ektron search (using the Solr or SharePoint
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provider), Publicly Viewable and Searchable metadata is searchable if you
use property queries.
l

l

Style. Select the style of the response field from these choices (available in a
drop-down list). You are specifying the type of information that a user adding
searchable properties to content will enter.
o Text. The user enters free text to describe the content.
o

Number. The user enters a number to describe the content.

o

Byte. 1 byte. 0 through 255 (unsigned)

o

Double. 8 bytes. -1.79769313486231570E+308 through 4.94065645841246544E-324 † for negative values;
4.94065645841246544E-324 through 1.79769313486231570E+308 †
for positive values

o

Float. (single-precision floating-point) 4 bytes. -3.4028235E+38 through
-1.401298E-45 † for negative values; 1.401298E-45 through
3.4028235E+38 † for positive values

o

Integer. 4 bytes. -2,147,483,648 through 2,147,483,647 (signed)

o

Long. 8 bytes. -9,223,372,036,854,775,808 through
9,223,372,036,854,775,807 (9.2...E+18 †) (signed)

o

Short. 2 bytes. -32,768 through 32,767 (signed)

o

Date. The user enters a date to describe the content.

o

Yes or No. The user answers yes or no to describe the content. For
example, if the content describes automobile parts, the user could select
Yes to include new and used parts, or No to search for new parts only.

o

Select from a list. The user picks a from a list to describe the content.

o

Multiple selections. The user selects an item from a drop-down list.

Default. If desired, enter the most common response to this definition. The
default value is automatically applied to content within folders to which this
definition is assigned. While editing content that uses this definition, a user
can change the default value if desired.

3. Click Save.
4. Add the definition to applicable folders by editing folder properties, checking boxes
on the Metadata tab, and clicking Update.
NOTE: Child folders inherit from their parent folders by default. So you only
need to apply metadata to the top-level folder, not all folders beneath it. See
also: Inheriting metadata by folder on page 834
5. Edit the metadata on content items in the folder and click Save or Publish. The
next time you visit the Workarea search screen, you will see the new field.
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6. If you want site visitors to use this field when searching your website, ask your
developer to use the Framework API's
Ektron.Cms.Search.SearchMetadataProperty class.

Creating and deploying a related content definition
You can set up a Web page so that whenever a source content item appears, related
information appears next to it by associating the following types of content with a
content item.
l

another content item

l

a collection

l

a list summary

l

a menu

l

a user

l

image, hyperlink, or file library item

For example, your website sells motorcycle helmets. On a page that shows a particular
helmet, the left column lists a collection of motorcycle drivers who wear that helmet.
Another example might show the profile of a user when a certain content item appears.
Related content lets you connect a content item with several types of related content
(see list above), and is associated with a content item, not a Web form. For example,
you can display a library image of the company logo on a page whenever content in a
certain folder appears. For content in a different folder, a different logo could appear.
NOTE: This capability is similar to the MetadataList Server control except that
MetadataList shows a link to every content item with a selected term in the keywords
or title. Also, a MetadataList is associated with a Web form (.aspx page), not a
content item.
To create and deploy a related content definition:
1. Complete the steps in Adding a metadata definition on page 823. Choose a type
that ends in Selector.
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2. Add the definition to all applicable folders by editing folder properties, checking
metadata boxes on the Metadata tab, and clicking Update.
3. Edit the metadata of content in the folder (associating related content) and click
Save or Publish. The next time you visit the Workarea search screen, you will see
the new field.
4. Have your Web developer add code to each page on which the related item
appears.
IMPORTANT: If you are using Collection Selector type, only users with
permission to work with collections can select a collection. Also, if you are using
Image, Hyperlink or File Selector type, only users with permission at least readonly Library permissions can select a library item. See also: Managing folder and
content permissions on page 168.

Changing the style of a metadata definition
If you create a metadata definition, assign it to a folder, then users apply metadata
information to content, the information takes on the characteristics of the metadata
definition. For example, if the metadata is title and its type is HTML tag, this is how it
appears in the Web page’s source code.
<title>CMS Developer</title>

If you later change its type from HTML tag to Meta, the following occur:
l

metadata to which the definition is already assigned maintains the previous style
definition. For example, <title>CMS Developer</title>.

l

new content that uses the metadata definition is assigned the new style. For
example, <meta name="title" content="CMS developer">.
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NOTE: For information about metadata, see The Meta Element.
When you change the style of searchable property type metadata, Ektron attempts to
maintain data stored in content that uses the definition. For example, if data style was
number but you change it to text, the number stored in that metadata definition is
converted to text and maintained in the content that uses it.
However, sometimes Ektron cannot maintain the data when you change the style. For
example, if you change a metadata definition style from number to date, Ektron cannot
convert those styles, in which case any data stored in metadata definitions is lost. Data
is maintained in the following conversion scenarios; data is lost for other conversions.
l

Text. Data is maintained when converted to Number or Date.

l

Number. Data is maintained when converted to Text.

l

Date. Data is maintained when converted to Text.

l

Boolean. Data is maintained when converted to Text.

l

Single Select. Data is maintained when converted to Text or Multiple Select.

l

Multiple Select. Data is maintained when converted to Text.

When you change metadata definition's style, the screen lets you use existing data (if
possible) or the default value. Following these choices is a field that lets you define a
default value. If you want to replace existing data, select Use default value and enter
the new value in the Default field. If the data is convertible and you want to maintain
existing data if possible, select Use existing data if possible, else default. Then,
enter a default value.

Assigning metadata to a folder
After you create a metadata definition, assign it to folders whose content will use it. To
do that, use the folder’s properties screen's Metadata tab > Assigned boxes to assign
metadata definitions to a folder.
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NOTE: Only metadata definitions created for the language in which you are viewing
the folder are available. Use the language drop-down to choose a language.

Requiring users to assign metadata to content
You can require a metadata value to be inserted before content can be saved (see the
Required checkboxes in the illustration above). If applied, the requirement is enforced
when content is added or edited. Also, on the Edit Content screen's Metadata tab, a
required metadata field has a red label and includes an asterisk (*).
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NOTE: If a default value is supplied for a required metadata field, that value is used
when the content is saved. The user is not prompted to enter a value.

Inheriting metadata by folder
Each folder can inherit metadata fields from its parent folder or have a unique set of
them. The information includes metadata definitions that are assigned, and which are
required. For example, you could assign the top folder (Content) all metadata
definitions, while you assign the Contacts folder (directly below it) none.
On every folder property’s Metadata tab, use the Inherit Parent Configuration
check box to determine if metadata definitions are inherited from the parent folder or
unique. By default, Inherit Parent Configuration is checked, meaning that metadata
definitions are inherited. If you uncheck Inherit Parent Configuration, you can
change the settings as desired.

Adding metadata to content
When a user creates or updates content, he can define its metadata within the
assignments specified for its folder. Default metadata values are applied without user
intervention.
PREREQUISITE
l

Content status must be Published, Checked In, or Checked Out by you.

l

A metadata definition has been created in the content's language
Adding a metadata definition on page 823.

l

That definition is assigned to the content's folder See also: Assigning
metadata to a folder on page 832.

To enter or edit content’s metadata:
1. Access the Edit Content screen for the content whose metadata you want to enter
or edit.
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2. Click the Metadata tab. The Edit Metadata screen opens with the current
metadata displayed.
3. Edit the metadata.
l Required field labels are red and marked with an asterisk (*). You must place
at least one response before you can save.
l

Your system administrator may prevent you from editing a field. In this case,
the field has a gray background, and you cannot place the cursor there.

l

Fields may appear in 2 columns, labeled Not Included and the other
Included. In this case, the system administrator provides a list of terms that
you can apply to the content. You can select terms from the list or enter free
text. Move terms between lists by clicking Add and Remove.

l

You may see a list of terms in one box, and a field labeled Text above it. You
can:
o add a new term by typing it into the Text field and clicking Add.

l

o

remove any term by selecting it and clicking Remove.

o

modify any term by selecting it. It appears within the Text field, where
you can change it. Then, click the Edit button.

o

restore the terms to default settings by pressing the Default button.

o

change the order of terms by selecting one then pressing the up and down
arrows.

If related content metadata is available for the content, its name appears
followed by None Selected (ID) ChangeClear. Click Change to display a
window of choices. For example, if the related content type is a collection, all
collections appear in the popup. Select the appropriate data for this content.
Selected items appear in the bottom of the screen. You can reorder them by
selecting an item then clicking the up and down arrows. To remove items from
the bottom of the screen, select them and click Delete ( ). If the related
content type is content item or library image, hyperlink, or file, a window
appears when you click Change where you can select related content.
a. Select a folder from the left frame.
b. Double click the related-content item from the top right frame. The item
appears in the lower right frame
c. When all items are in the lower right frame, click Save.

l

If default metadata values area defined, you can click Default at the bottom
of each field to restore it.

4. Click Save. The View Content screen reappears. The content is now in a checked
out state to you. For the changes to take effect on the website, check in the
content and submit it to the workflow. See also: Approving content for publication
on page 749

Applying content tags
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Use content tags to apply terms by which you want users to find content when the
terms are not in the content. The search can use the tags to find content.
Default content tags appear on the Metadata tab of every content item. Check any tag
that you want to apply to a content item. You can also create a new tag and apply it to a
content item. You cannot reapply that tag to other content.
When you display metadata tags, the tags are listed alphabetically. However, when you
add a new tag, it is listed at the top of the list until you display the list again.

Assigning an image to metadata
You can assign an image to any content item’s metadata from a standard field that is
available to every content item; it is not a definition in the Metadata fields. Use the
Image field to identify an image that can be retrieved by Ektron Markup Language’s
(EkML) [$Image] and [$ImageThumbnail] variables.
For an example of using Image data, assume that your site promotes a soccer team. A
list summary shows every player on the team. Next to each player’s name is an image.

Applying Simple Dublin Core metadata
Simple Dublin Core is a set of fifteen standard names for metadata fields designed to
cover the most useful items of information on a document. From the Dublin Core site
FAQ: “Dublin Core metadata provides card catalog-like definitions for defining the
properties of objects for Web-based resource discovery systems.” For more
information, refer to the Usage Guide: Using Dublin Core.
To generate Dublin Core metadata, set the GenerateDublinCore property to True. This
creates 7 of the fifteen Dublin Core metadata fields. These fields are automatically filled
with the information from the equivalent Ektron property. The following list shows the 7
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fields and their Ektron equivalent. For more information on the Metadata Server
Control, see the Metadata server control.
l

DC.title. Content block title

l

DC.description. Plain text version of a content summary

l

DC.contributor. Content block last editor name

l

DC.date. Content block last edit date

l

DC.format. "text/html"

l

DC.identifier. URL of current page (from ASP.NET Server.Request object)

l

DC.language. CMS language cookie / current site language, expressed as a .NET
System.Globalization Culture Name

To fully comply with the Simple Dublin Core metadata element set, the administrator
must create the remaining 8 Dublin Core fields as standard Ektron Metadata definitions
and apply them to all Ektron folders. Next, Ektron users complete the appropriate
values for each content block.
IMPORTANT: When creating Dublin Core metadata fields in the Metadata section of
the Workarea, you do not need to create the first 7 fields above. In addition, the
names of the fields you create must match the names in the following list. For
example, in the name field, enter “DC.subject”. DC identifies it as Dublin Core
metadata.
These descriptions are from the Dublin Core Metadata Initiativesite.
l

DC.subject. The topic of the content of the resource. Typically, a subject is
expressed as keywords, key phrases, or classification codes that describe the topic
of the resource.

l

DC.type. The nature or genre of the content of the resource. Type includes terms
describing general categories, functions, genres, or aggregation levels for content.

l

DC.source. A reference to a resource from which the present resource is derived.
For example, DC.source=”Image from page 54 of the 1922 edition of Romeo and
Juliet”

l

DC.relation. A reference to a related resource.

l

DC.coverage. The extent or scope of the content of the resource. Coverage
typically includes spatial location (a place name or geographic co-ordinates),
temporal period (a period label, date, or date range) or jurisdiction (such as a
named administrative entity). Examples: DC.coverage=”1995-1996”,
DC.coverage=”Boston, MA”, DC.coverage=”17th century” or
DC.coverage=”Upstate New York”.

l

DC.creator. An entity primarily responsible for creating the content.

l

DC.publisher. The entity responsible for making the resource available.
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l

DC.rights. Information about rights held in and over the resource. Typically, a
Rights element contains a rights management statement for the resource, or
reference a service providing such information.

Working with templates
While setting up your Ektron website, you create templates for your Web pages. A
template typically includes page headers, footers, and placeholders for content, forms,
summaries, and other page elements; a place to display content items from content
lists, menus, collections, and so on through hyperlinks.
The following image shows a template where the top of the screen contains headers
that appear on several pages. This image also shows that, when a user selects the
Email hyperlink, content item (ID 87) displays within the contactinformation.aspx
template. A developer can modify content within these areas.

NOTE: To learn more about creating templates, see Setting Up a Template.

Declaring a template
PREREQUISITE

You are a member of the Administrators group or assigned to the Manage
Members for Role: Template Configuration screen. See also: Defining roles
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on page 1581.
After creating templates, declare them within Ektron. To do this, go to the Active
System Templates screen, available from Settings > Configuration > Template
Configuration.

From this screen, you can add new templates, or delete or update existing ones.

Adding a template
PREREQUISITE

A developer created the template in Visual Studio. See also: Creating a
Template in Visual Studio.
1. Go to Workarea > Settings > Configuration > Template Configuration.
2. Click Add New Template to System. The Add a New Template screen appears.

3. Enter the path to and name of the new template or click the ellipsis button (
and go to it.

)

4. Enter a name and description for the template.
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5. If you want to let content authors use this template within the Content Dashboard,
check Enable Toolbar. See also: Managing content from the Content Dashboard
on page 658.
6. To allow this template be used to create PageBuilder pages, check Page Builder
Wireframe. See also: Creating a PageBuilder page from your website on
page 1078.
7. To learn about the Specify Templates for Device Groups section, see Setting
up a mobile template on page 507.
8. Click Add New Template to System.

Deleting a template
You can only delete a template if it is not assigned as any folder’s default template. If
you choose a template that is assigned as a default, a screen tells you why you cannot
delete it and lists the folders for which it is the default.
To delete a template:
1. Go to Workarea > Settings > Configuration > Template Configuration.
2. Click Delete ( ) in the appropriate template row.

Updating a template
The update procedures lets you change all references from an old to a new template.
For example, your old template is named MyTemplate.aspx. You can want to replace all
references to it to Updatetemplate.aspx.
1. Within the Workarea, go to Settings > Configuration > Template
Configuration.
2. Click the template that you want to update. A new screen appears.
3. Choose the new template file. You may also update the name or description.
4. Click Update Template.
5. Update that content's quicklink in the library. See also: Working with library files on
page 740.
NOTE: This screen has additional fields when mobile device detection is on and
mobile configurations exist. For more information, see Using mobile templates on
page 506

Assigning a template to a folder
Each folder must have at least one template, and one template must be chosen as the
default. The list of available templates is managed through the Active System
Templates screen. See Adding a template on the previous page.
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If you change a folder’s default template, existing template assignments remain, but
new content added or moved to the folder assumes the new default template.

Template inheritance
By default, folders below the root folder inherit templates from their parent. However,
you can assign unique templates to a folder by overriding the inheritance. To do this, go
to the Edit Folder Properties screen and uncheck the Inherit Parent Configuration
box. If you break inheritance, the inherited templates are assigned to the folder. You
can then remove unwanted templates or add new ones.

Adding a template to a folder
PREREQUISITE

At least one template is defined in the Active System Templates screen.
1. In the Workarea, go to the folder to which you want to apply the template.
2. Choose View > Properties.
3. Click Edit Properties.
4. Click the Templates tab.
5. Uncheck Inherit Parent Configuration (if checked).
6. Click the down arrow next to Select Template.
7. Choose the template to apply to this folder.
8. Click Add (

).

9. Click Update.

Removing a template from a folder
l

If you try to delete a template that is the default for a folder, you are notified that
you must assign a new default before you can delete it.

l

If you try to delete a template that is assigned to a content block, you are notified
via the following message: If you wish to continue and delete this template,
the above content will be set to their parent folder's default template. Do
you wish to continue?

1. In the Workarea, go to the folder to which you want to apply the template.
2. Choose View > Properties.
3. Click Edit Properties.
4. Click the Templates tab.
5. Uncheck Inherit Parent Configuration (if checked).
6. Click Remove that appears on the same row as the template
7. Click Update.
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Assigning a template to content
A folder’s default template is automatically applied to all content in the folder. However,
you can change a content item’s template to any of those assigned to the folder.
The template assigned to the content is used whenever a hyperlink is created to it.
PREREQUISITE

At least one template is defined in the Active System Templates screen.
1. In the Workarea, go to a content item to which you want to apply the template.
2. From the content's View menu, choose View Properties. The View Content screen
appears.
3. Click Edit.
4. Click the Templates tab.
5. Click the arrow next to Template: and choose a template to apply to this content.
6. Click Publish.
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Working with HTML forms
Ektron provides powerful online form capabilities, letting you create an online dialog
with visitors. Anyone can create and deploy Web forms. A form has the following
components.
l

Form (title, ID number, whether the form data is sent as email, and/or saved to a
database, and so on.)

l

Content information (title, start and/or end date, status, postback message, and
so on.)

l

Form fields (text field, password field, text area, hidden text, choices, checkbox,
select list, calendar, submit button, and so on.)

By default, form permissions are inherited from a form’s folder. To customize
permissions for any folder that contains forms, access the corresponding folder under
Content and assign permission as described in Managing folder and content
permissions on page 168.
Similar to content, users in the administrator user group have full control over form
features. You must be a member of the administrator group to add, edit, or delete a
form, or assign content to a form. You may also perform all actions on a form’s content.
Users who are not members of the administrator user group can add, edit, delete, and
restore form content if granted these permissions for the content folder or item.

Creating a form
Ektron provides sample forms to start with and then customize. Forms are saved to a
database by default, but not emailed. To change either setting, use the Edit Properties
screen.
You should only create HTML forms in a folder whose template uses a FormBlock or Poll
server control. For example, in the OnTrek sample site, the Company folder uses the
company.pb.aspx. template.
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You can modify this template as needed or create a form template and assign it to any
folder through its Folder Properties screen. Because folders inherit properties from their
parent folder by default, new folders created under a parent folder use the correct
template. Of course, you can break inheritance and assign a custom template for any
folder. Consult with your Ektron administrator about the folders in which you should
create forms.
To create a new form:
NOTE: You can also create a new edition of a form in another language by copying
an existing form and translating it. For more information, see Translating content
into another language on page 698.
1. From the Workarea, go to the folder in which you will create the form.
2. From the View menu, click Language, and select the language in which to create
the form.
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3. Click New > HTML Form/Survey. The New Form screen appears.

4. Choose the form that you want to begin with. You can click preview ( ) next to
any sample form to see it before choosing it. Select a sample that most closely
matches the form you want to create. After creating the form, you can add/remove
fields, modify possible responses, and so on.
5. Click Next.
6. Enter or edit the form’s Title and Description.
l Title. used to reference the form within the Workarea (required)
l

Description. an extended description of the form
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l

DXH Mapping. (Appears if DXH is installed and enabled.) Check this box if
you want to map this form to DXH.

7. The next screen lets you assign a task to a user or user group. If you do, a task will
be created every time a site visitor submits this form. See Assigning a task to a
form on page 886.
8. A new screen lets you determine what happens after a site visitor completes the
form. The choices are:
l Display a message. See Choosing a format to display form data on
page 881.
IMPORTANT: If your form/survey/poll uses either Redirect option, your
Web developer must use a FormBlock server control to display this form on
a Web page. The Web developer cannot use a Poll server control when
redirecting to an action page.
l

Redirect to form data to an action page. See Redirecting form data to an
action page on page 876.

l

Report on the form. See Letting site users see the form results on page 878.

l

Redirect to a file or page. Identify a file or a page on your website that is
launched when the visitor completes the form.
o sample file. a white paper (PDF format)
o

sample page. prompts visitor to download your product

9. After completing the form information, you enter its content.

Creating a form’s content
Here is an example of form content that you can create.
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Some fields are required, and some provide a drop-down list of choices.
The final screen lets you arrange the form fields. Then, add a button that lets the user
submit the data.
NOTE: The form can also contain explanatory text, lines, images, and so on. To lay
out fields in columns, insert a table and place the fields within table cells.
The following list explains each field type you can enter.
l

Checkbox. User’s response is either checked or unchecked; see Inserting a
checkbox field on the next page.

l

Text. Free text field; user cannot format text; see Inserting a text field on
page 854.

l

Choices. Several choices appear on screen. User checks any number of
appropriate responses. See Inserting a Choices field on page 849.

l

Calendar. Lets user insert a date by clicking a calendar; see Inserting a
Calendar field on page 852.
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l

Insert Button. Button with no text. You can easily add text to it. When a site
visitor completing the form presses this button, the data on the screen is submitted
to your Web server. See Inserting buttons on page 863.

l

Insert Reset. Button with Reset as its text. When a site visitor completing the
form presses this button, the form’s field values are set to their state when the
form first loaded. See Inserting buttons on page 863.

l

Insert Submit. Button with Submit as its text.When a site visitor completing
the form presses this button, the data on this screen is submitted to your Web
server. See Inserting buttons on page 863.

Next, click Save and Submit or Publish. After you complete and save the form, it may
need to go through the workflow process. When that is complete, add it to the site by
assigning it to a page template.

Inserting a checkbox field
A Checkbox field is one character wide and is checked or unchecked. For example:

To insert a checkbox field:
1. Place the cursor where you want the check box field to appear.
2. Click the Checkbox field button (
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Inserting a Choices field

l

Descriptive Name. Enter a descriptive name for this checkbox.

l

Field Name. Enter a name for this checkbox. This text identifies the field in
the database and in email (if the form is mailed).
NOTE: You cannot enter spaces nor most special characters (!@#$%^&*
()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.

l

Tool Tip Text. Enter text that appears when a site visitor hovers the cursor
over this field (circled).

l

Default value. If you want this field to be checked when the screen first
appears, click True. Otherwise, click False. A site visitor can change the
default value while completing the screen.

l

Caption. Enter text to guide the user’s response to this field. The caption
appears on the screen to the right of the checkbox. To continue the above
example, the caption would be Check if you are over 65.

Inserting a Choices field
Use a Choices field when you want a site visitor to select from a predetermined list. You
can let a site visitor select only one or more than one choice. You can also determine
the list’s items and appearance.
To insert a choices field:
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1. Enter a field label. For example, Country.
2. Click Choices (

). The following dialog appears.

l

Descriptive Name. Enter a description of the field. This text describes the
field on form reports.

l

Field Name. Enter a name for this field. This text identifies the field in the
database and in email if the form is mailed.
NOTE: You cannot enter spaces nor most special characters (!@#$%^&*
()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.
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l

Tool Tip Text. Enter text that appears when a site visitor hovers the cursor
over this field (circled).

l

List. One of the following:
o Custom. You create your own set of choices. Use the Item List area to
do this.
o

Languages. A standard list of languages

o

Countries. A standard list of countries

o

U.S States and Territories. A standard list of United States of America
states and territories

o

Canadian Provinces. A standard list of Canadian provinces
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o

Age Ranges. A standard list of age ranges

o

Numeric Ranges. A standard list of numeric ranges

o

Years. A standard list of years

o

Gender. Male or female

o

Marital Status. A standard list marital statuses

l

Allow Selection. Click More than one to let a site visitor select more than
one item for this field. Otherwise, click Only one to limit the user to one
choice.

l

A selection is required. Check this box if the user must select at least one
item.
First item is not a valid selection. You can use the first list item to prompt
the user to make a selection instead of being a valid response. For example,
the first item may say Select from the list. To do so, check this box. If you
do, the site visitor must choose any selection except the first item. If the site
visitor tries to file the screen without choosing a different item, this error
message appears:First item is not a valid selection.
This option is only available if Appearance is set to Drop List.

l

Appearance. One of the following:
o Vertical List. arranges choices vertically

o

Horizontal List. arranges the choices horizontally

o

List Box. displays all choices in a box. If more than 4 choices are
available, the user scrolls to see additional options.

o

Drop List. displays all choices in a drop-down list. When the user clicks
the down arrow, all entries appear.
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l

Item List. This section of the screen displays the list items. It is only editable
if the list type is Custom.
o The Context-Sensitive Menu. Buttons to the left of each item display a
menu. The menu lets you remove items, rearrange them, and insert
additional items anywhere on the list.

o

The Selected Box. Place a check in the box of any item to be checked by
default on the data entry screen. If you do, the user can accept the default
or uncheck the item by clicking in the checkbox. Note that if Only One is
selected under Allow selection (above), only one item can be selected.
If the Appearance is set to Drop-Down list, this value is ignored.

o

Display Text. Enter text to describe this item on the data entry screen.

o

Value. Enter the value that is collected when the site visitor selects this
item. For example, if Interests appears in the Name field, and you want
music to be collected when the data entry user selects this item and saves
the page, enter music here.

o

The Disabled Checkbox. Check the box next to any selection that you
want to disable. If you do, the option appears on the form but the user
cannot select it.

o

Option. Click this button to add a row to the bottom of the list.

Inserting a Calendar field
To insert a field that lets a site visitor select a date, use a Calendar Field. To do that:

852

Ektron 9.40 SP1

Inserting a Calendar field

1. Enter a field label. For example, Expiration Date.
2. Click Calendar field (

). The following dialog appears.

Calendar Field dialog—General tab
l

Descriptive Name. Enter a description of the field. This text describes the
field on form reports.

l

Field Name. Enter a name for this field. This text identifies the field in the
database and in email if the form is mailed.
NOTE: You cannot enter spaces nor most special characters (!@#$%^&*
()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.

l

Tool Tip Text. Enter text that appears when a site visitor hovers the cursor
over this field (circled).

l

Default value. If you want to set a default date, enter it here. The site visitor
can change the default value while completing the screen.

l

Validation. Select the kind of validation to apply to this field. The choices are:
o No validation. response is not checked
o

Cannot be blank. Response is required. The format of the response is
not checked. If you assign Cannot be blank, the field is surrounded by
red dashes when it appears on your website.

o

Custom. See Custom validation on page 859
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l

Error Message. Enter text that appears if a site visitor’s response does not
satisfy the validation criterion. For example, if the validation criterion is
Cannot be blank, the error message could be Please enter a response. By
default, the error message is the same as the validation criterion. Use this field
to customize its text.
NOTE: You can only enter double-byte characters if your Windows settings
include that language. If you enter characters that are not in a language
defined in your Windows settings, question marks (?) appear instead of the
characters.

Calendar Field dialog—Validation tab
l

Descriptive Name. Enter a description of the field. This text describes the
field on form reports.

l

Validation. Select the kind of validation to apply to this field. The choices are:
o No validation. response is not checked

l

o

Cannot be blank. Response is required. The format of the response is
not checked. If you assign Cannot be blank, the field is surrounded by
red dashes when it appears on your website.

o

Custom. See Custom validation on page 859

Message. Enter text that appears on the screen if the site visitor‘s response
does not satisfy the validation criterion. For example, if the validation criterion
is Cannot be blank, the error message could be Please enter a response.
By default, the error message is the same as the validation criterion. Use this
field to customize it.

NOTE: You can only enter double-byte characters if your Windows settings
include that language. If you enter characters that are not in a language defined
in your Windows settings, question marks (?) appear instead of the characters.
Calendar Field dialog—Data Style tab
These are the same as Creating a form on page 843

Inserting a text field
Use a text field when you want the user to enter a free text response, or to display text
on the screen. There are many variations you can apply to such a field, such as
l

a default value

l

text can be read-only or hidden

l

the field can expand to accommodate user input

l

validation, requiring user input to meet criteria such as a non-negative whole
number or a zip code

To insert a text field:
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1. Enter a field label. For example, Name.
2. Place the cursor where you want the text field to appear.
3. Click Text field (

). The following dialog appears.

Text Field dialog—General tab

NOTE: If you are using FireFox, you cannot enter text into a text field while
creating or editing the form. If you need to prefill a text field with text, use the
field’s Default Value property.
l

Descriptive Name. Enter a description of the field. This text describes the
field on form reports.

l

Field Name. Enter a name for this field. This text identifies the field in the
database and in email if the form is mailed.
NOTE: You cannot enter spaces nor most special characters (!@#$%^&*
()+=<>,.:;’"{}[]|‘~) into this field. If you do, they are replaced by
underscores.

l

Tool Tip Text. Enter text that appears if a site visitor hovers the cursor over
this field (circled).

l

Default value. If you want to set a default value for this field, enter it here.
For example, if this field collects a city, and most users enter New York, enter
New York as the value. A site visitor can change the default value while
completing the screen.
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l

Allow multiple lines. Check this box if you want this field to scroll vertically
to allow the person completing the form to enter as much text as needed.
NOTE: This setting cannot be applied if this is a Password field.
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l

Cannot be changed. Check this box to prevent the person completing this
field from changing its content. For example, you want to display a license
agreement. Below this field, you might place a check box prompting the site
visitor to check it to indicate the agreement was read. As another example,
you could provide instructions for completing the screen.

l

Invisible. Check to make this field hidden. This option lets you store unseen
information in each document. An example might be putting a version number
on the form. f you apply this property to a form, the Allow multiple lines and
Cannot be changed fields are automatically checked and cannot be
unchecked. Also, the Validation tab is disabled.

l

Password field. Use a password field when you want the user to enter a
password. A password is like a text field but the user’s entry is disguised. This
prevents an onlooker from seeing the password. Passwords cannot exceed 18
characters.

l

Validation. Select the kind of validation to apply to this field. See Validation
Options on the facing page. Your system administrator determines whether a
user can save an invalid document.
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l

Message. Enter text that appears on the screen if a site visitor's response
violates the validation criterion. For example, if the validation criterion is
telephone number, the error message could be Please enter 7 or 10 digits.
It would appear if the user entered, for example, S061882. By default, the
error message matches the selected validation criterion. Use this field to
customize the text.
NOTE: You can only enter double-byte characters if your Windows settings
include that language. If you enter characters that are not in a language
defined in your Windows settings, question marks (?) appear instead of the
characters.

l

Custom Validation. See Custom validation on page 859.

Validation Options
All of the following options are used with the text field. Only No validation and
Cannot be blank are also used with the calendar field.
l

No validation. Response is not checked.

l

Cannot be blank. Response is required. The format of the response is not
checked.

l

Allow Maximum of 1000 characters. Response cannot exceed 1000
characters. (Only available if text field is set to Allow Multiple lines.)

l

Minimum of 8 characters with at least one digit. Site visitor’s entry
must be at least 8 characters and include one digit. (Only available if text field
is set to Password field.)

l

Non-negative whole number or blank. A positive whole number or no
response.

l

Non-negative whole number (required). A positive whole number.

l

Decimal number or blank. A decimal number (for example, 12.345 or 12)
or blank. A leading minus sign “-” is allowed. The decimal point must be a
period (.), even in locales that normally use a comma (,).
NOTE: Decimal numbers include whole numbers because the decimal point
is implied. That is, 12 is 12.0000.

l

Decimal number required. A decimal number (it cannot be blank) of 0, 1, or
2 decimal places. A leading minus sign “-” is allowed. The decimal point must
be period (.), even in locales that normally use a comma (,).
NOTE: Decimal numbers include whole numbers because the decimal point
is implied. That is, 12 is 12.0000.

l

Percent: (0-100) required. A whole number from 0 to 100. A response is
required.
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l

email address. a@a, where a is one or more characters.

l

email address required. a@a, where a is one or more characters. A
response is required.

l

email address list. Several email addresses. Each address’s format is a@a,
where a is one or more characters. The user must separate each address with
a semicolon (;).

l

email address list required. Several email addresses. Each address’s
format is a@a, where a is one or more characters. The user must separate
each address with a semicolon (;). A response is required.

l

Zip code (US). 5 (nnnnn) or 9 digits. If 9, a dash appears after the fifth
(nnnnn-nnnn).

l

Zip code (US) required. 5 (nnnnn) or 9 digits. If 9, a dash appears after the
fifth (nnnnn-nnnn). A response is required.

l

Social Security (US). Nine digits in this pattern: nnn-nn-nnnn.

l

Social Security (US) required. Nine digits in this pattern: nnn-nn-nnnn. A
response is required.

l

Postal Code (Canada). ana nan, where a is an alphabetic character and n is
numeric.

l

Postal Code (Canada) - (required). ana nan, where a is an alphabetic
character and n is numeric. A response is required.

l

Social Insurance Number (Canada). A 9-digit number in the format:
nnnnnnnnn.

l

Social Insurance Number (Canada) Required. A 9-digit number in the
format:nnnnnnnnn. A response is required.

l

Telephone number (US and Canada). A 7 or 10 digit number in the
formatnnnnnnn or nnnnnnnnnn. The site visitor can insert separator
characters, such as dashes (-), between numbers.

l

Telephone number (US and Canada) (required). A 7 or 10 digit number
in the formatnnnnnnn or nnnnnnnnnn. The site visitor can insert separator
characters, such as dashes (-), between numbers. A response is required.

l

URL. A website address.

l

ISBN. ISBNis a 10 or 13-digit number that uniquely identifies books and booklike products published internationally. When printed, the ISBN number is
preceded by the letters ISBN. (Copied from www.isbn.org.)

l

ISSN. The ISSNis an 8-digit number which identifies periodical publications as
such, including electronic serials. The ISSN takes the form of the acronym
ISSN followed by 2 groups of 4 digits, separated by a hyphen. The eighth
character is a control digit calculated according to a modulo 11 algorithm on
the basis of the 7 preceding digits; this eighth control character may be an “X”
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if the result of the computing is equal to “10”, in order to avoid ambiguity.
(Copied from www.issn.org.)

Custom validation
The Text and Calendar field dialog’s Validation tab features a validation area.

The validation feature can ensure the following aspects user input.
l

l

The data type—the default types are
o text
o

URL

o

whole number

o

decimal number

o

floating point number (Floating point includes scientific notation, so is
appropriate for scientific numbers. Decimals usually suffice for business
numbers.)

o

date (calendars only)

The field value has one of the following relationships with another field, a
number, or an expression. The default expressions are
o between 2 values (either another field or a number that you specify)
o

less than
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o

equal to

o

not equal to

o

maximum length (usually for text responses)

Your system administrator determines if a user can save the invalid data.
When the Custom Validation option is selected from the Validation field, the
Custom Validation screen area becomes active.

l

The Data Type field is the value’s basic type, for example, text, number, or
URL.

l

The Condition field displays the validation logic.

l

The Examples drop-down list shows validation expressions that you can apply
to the field.

Example of creating custom validation
As an example of custom validation, assume that a field collects telephone
numbers, and you want to make sure the user enters 10 digits. To accomplish this:
1. Insert a Text Field.
2. Complete the Text Field dialog’s General tab.
3. Click the Validation tab.
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4. In the Validationdrop-down list, select (Custom).

5. In the Data Type field, select Whole Number from the drop-down list. This
ensures that the user can only enter digits.
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6. Click the down arrow to the right of the Examples field to see sample logic.

7. Click Maximum text length.... This option lets you specify the length of the
user’s response.
8. string-length(.) <= {X} appears in the Condition field.
9. Because you want the user’s input to equal 10, remove the less than sign (<)
from the calculation. Now it looks like this:string-length(.) = {X}.
10. Replace the {X} with 10. Now, it looks like this: string-length(.) = 10.
11. Move the cursor up to the Message field and compose a relevant error
message. For example: must be 10 digits.
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12. Click OK.
Text Field dialog—Data Style tab
Click the Data Style tab to apply formatting to a field that accepts user input.
When you do, the following tab appears.

Use the tab to assign the following formatting attributes to a response field.
l

Font style and size

l

Bold and italic

l

Text alignment (especially helpful for formatting dollar amounts in a plain text
field)

l

Underline or strikethrough

l

Font color and/or background color

Inserting buttons
A form typically includes one or more buttons, which let a site visitor submit a
completed form.
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You can place 3 buttons on a form.

l

Insert. Submits form information to your Web server. By default, it has no
text. To learn how to add button text, see Editing a button’s properties below.

l

Reset. Changes a form’s field values back to their state when the form first
loaded.

l

Submit. Submits form information to your Web server. Its default text is
Submit.

Editing a button’s properties
After you insert a button, you may want to enter or change its properties, such as its
text, height, and width. To edit a button’s properties:
1. Click the button so that it is selected. A selected button is surrounded by small
squares. Below the editor screen, several fields appear.
2. Update the button fields as needed.
l Name. Give the button a unique name.
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l

Id. If needed, give the button a unique ID.

l

Width. Enter or change the button’s width in pixels.

l

Height. Enter or change the button’s height in pixels.
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l

Value. Enter or change the button text.

l

Tooltip. Enter or change the button’s tooltip (that is, text that appears in a
small window when someone hovers the mouse over the button).

l

Classname. Enter or change the style sheet class assigned to the button.

Entering additional form information
Link other Ektron content, you use tabs on the Edit Content screen to enter the
following information about the form:
l

Metadata. Working with Metadata on page 822

l

Aliases. Creating user-friendly URLs with aliasing on page 1399

l

Schedule. Scheduling content on page 698

l

Comment.

l

Templates. Be sure to apply a template that uses a FormBlock or Poll server
control. For example, in the OnTrek sample site, the Company folder uses the
company.pb.aspx. template. See also: Working with templates on page 838

l

Map to DXH.

Viewing form properties
After a form is created, you can view its information in the Forms folder. To view a
form:
1. Access the folder that contains the form you want to view.
2. Click the form you want to view. The View Form screen displays.
3. Click the Form Properties tab.
l Form Title. Title used to reference the form.
l

FormID. ID number automatically assigned to form.

l

Status. The form’s current status.

l

Description. Extended description for the form.

l

Form Data. The type of form data: Mail or Database.

l

Form Submissions. The maximum number of times a user can submit the
form. This is typically used with polls and surveys to limit one user’s influence
over the results.

l

Assign Task to. Users and groups to whom a task will be automatically
assigned whenever a site visitor completes the form.

l

Content Properties. Displays the properties of the form’s content.

l

Content Title. Title of content associated with form.
NOTE: The content name is the same as the Form name.

l

Content ID. Content ID number assigned to content.
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l

Status. The status of the content.

l

Last Editor. Last user to edit the content.

l

Start Date. Date and time when content will go live on website (if set for
future date).

l

End Date. Date and time when content will be removed from website (if set
for future date).

l

Action on End Date. What happens to a form when its end date is reached.

l

Date Created. Date and time when content was created.

Editing a form’s properties
To update additional form information that does not appear on the View Form screen,
go to the form’s View Form screen and click Form Properties (
Properties screen displays a subset of form information.

). The Form

l

Title and Description.

l

Database or Mail. If form data is emailed whenever a site visitor submits it, enter
mail property information.

l

Autofill form values. Checked by default, this allows the form’s fields to fill
automatically when a logged-in site visitor has previously completed the form.

l

Limit Submission. When checked, you can enter the number of times a user can
submit a form in the Number of Submissions text field.

l

Assign task to users and groups to whom a task will be automatically assigned
whenever a site visitor completes the form.

l

Form block’s ID number.

l

Mail properties.
o To. Email address to which the form is sent when submitted.
o

From. Text that appears in the email’s From field.

o

CC. Text that appears in the email’s CC field.

o

Subject. Text that appears in the email’s subject field.

o

Preamble. Beginning text of the email.

o

Send data in XML Format. A green check means email data will be in a
structured XML packet. A red X means the email data will be in a standard
mailto format.

Retrieving an email address from a submitted form
In the Mail Properties section of the Edit Form screen, you can select email addresses
submitted on the form to be inserted into the To, From, and CC Mail Property fields.
Instead of entering a static email address, it can be dynamically retrieved from the
user’s form submission. For example, you want to retrieve the “from” field of an email
from the information a user enters when completing the form. To do this, use the OR to
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addresses in field drop-down lists. These lists contain fields that dynamically retrieve
data from the submitted form.

Note that the To and CC fields can accept fields whose validation type is email
address or email address list. On the other hand, the From field can only accept
fields whose validation type is email address (that is, a single email address).
To set up email address retrieval:
1. Add a form field whose Validation type is Email address or Email address list.
The field prompts the user completing the form to enter an email address. Label
the field something like Enter your email address. If the field allows more than
one address, add on-screen instructions to separate each address with a semicolon
(;).
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2. Go to the Edit Form screen > Mail Properties section.
3. Move to the field labeled From:.
4. At the drop-down list following OR to addresses in field, select the field you
created in Step 1.
When a user completes the form, the value entered in the field created in Step 1 is used
for the email’s From address.

Retrieving form data Into the subject and preamble fields
You can retrieve data from a submitted form directly to the form’s Subject and
Preamble fields. (The subject is a standard mail field, and the preamble is text that
appears at the beginning of the email.)
For example, the form may provide a list of your products. While the user is completing
the form, the user selects a product that the user is interested in. The product then
becomes the subject line of the email.
NOTE: Because a Textarea field can span multiple lines, it can only be used with the
preamble. However, a plain text field can be used with both the subject and
preamble.
To retrieve data dynamically from a form field into the email’s subject line or preamble:
1. Add a form field that collects the information you want to insert into the email’s
subject line or preamble.
2. Go to the Edit Form screen > Mail Properties section.
3. Move to the field labeled Subject or Preamble.
4. At the drop-down list following OR use text in field, select the field you created in
Step 1.

Creating surveys and polls
Surveys and polls are a type of form. All of the same functionality is available and
applies.
l

A survey is usually multiple questions and appears on your site for a longer time
than a poll.

l

A poll is generally one question and appears on a site for a very short time: an hour
or a day.

Surveys and polls can show ongoing results to site visitors after they submit their
answers. For information about how to display a poll or survey on a website, see Poll
server control.

Creating a survey
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NOTE: You can also create a new edition of a survey in another language by copying
an existing form and translating it. For more information, see Translating content
into another language on page 698
To create a new survey:
1. From the View menu, click Language, and select the language in which to create
the form.
2. Click New > HTML Form/Survey. The New Form screen appears.
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NOTE: When you choose Standard Poll or Blank Survey, the number of steps in
the Forms Wizard changes from 5 steps to 4 steps. This happens because the
Assign Tasks step is removed.
3. Choose Blank Survey. You can click preview (
preview it before choosing it.

) next to any sample form to

4. Click Next.
5. Enter or edit the form’s Title and Description.
l Title. used to reference the survey within the Workarea (required)
l

Description. an extended description of the survey.

6. Click Next. This screen lets you determine what happens after the site visitor
completes the survey. The choices are:
l Display a message. See Creating a postback message on page 874
l

Redirect to a file or page. Identify a file or a page on your website that is
launched when the visitor completes the form. An example of a file is a white
paper (a common file format is .PDF) that the visitor requested. An example of
a page is one that lets the visitor download your product.
l Redirect to an action page and forward form data. See Redirecting
form data to an action page on page 876
l

Report on the form. See Letting site users see the form results on
page 878

7. Click Next. A screen indicates that you have entered basic information about the
survey and should click Done to enter the survey’s content. This procedure is
described in Managing form responses on page 873.

Creating a poll
The following example shows a poll. Note that when a site visitor hovers over the poll,
the question also appears as Tooltip text.

To create a new poll:
870
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NOTE: You can also create a new edition of a poll in another language by copying an
existing poll and translating it. For more information, see Translating content into
another language on page 698.
1. From the View menu, click Language, and select the language in which to create
the poll.
2. Click New > HTML Form/Survey. The New Form screen appears.

3. Choose Standard Poll. You can click preview (
preview it before choosing it.

) next to any sample form to

4. Click Next.
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5. Enter or edit the form’s Title and Description.
l Title. used to reference the poll within the Workarea (required)
l

Description. an extended description of the poll

6. Click Next. You can add a poll question and up to 8 replies. If you have more than
8 replies, you can add them in the forms editor after clicking Done.
7. Click Next. This screen indicates that you have entered the basic poll information
and should click Done to further edit and view the form’s fields. After clicking
Done, the form editor launches so you can edit existing fields and properties. In
addition, you can set post back and schedule information, add metadata and
comments, change the title, and submit the poll for publication. From this screen,
you can add more replies to your poll by right clicking on the choices field and
clicking properties.

Editing a poll from a website
WARNING! If you are logged into the site and create a new poll by right clicking on
a poll selecting New, the existing poll is replaced by the new one.
To edit an poll on a website:
1. Click the access point ( ) or menu (
Edit.

) on the poll you want to change and choose

2. Make changes to the poll using the Forms editor.
3. Submit the poll to the workflow.

Replacing a poll from a website
When logged into Ektron, you can right click on a poll and choose New Poll to replace
the current one. The title of the poll, its ID, and properties stay the same. Only the
questions and answers change.
To replace a poll:
1. At the location of the poll, click the access point ( ) or menu ( ) and choose New
Poll. The Workarea opens, indicating you are at step 3 of the Poll Wizard.
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2. Add a new question to the Question text box.
3. Add possible responses to the Choices text boxes.
4. Click Next.
5. Click Done. The form editor launches, allowing you to edit the fields and
properties. In addition, you can set post back and schedule information, add
metadata and comments, change the title and submit the poll for publication.
When published, the updated poll appears on the site.

Editing the poll results bar chart
To edit the style and appearance of the bar chart, modify the following files:
l

siteroot/workarea/csslib/reportchart.css

l

siteroot/workarea/controls/forms/HistogramReportPoll.xslt

Those files include extensive comments that explain how to customize the bar chart's
appearance.
NOTE: You cannot edit pie charts.

Managing form responses
Applying validation rules to a form
You can apply validation rules to text or calendar field types. Validation rules ensure
that the information entered by site visitors meets your criteria. For example, a
validation rule specifies that a response to the Telephone field is 10 digits. If the
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response does not conform, an error message indicates the problem. The input must
conform before the form can be submitted.
Validation rules are applied when a site visitor submits an entire form, not when the
input is entered. If an invalid response is found, the error message that you define
appears.
The site visitor must change the response to conform to the validation rule; then, the
next field is checked and, if that is invalid, its error message appears, and so on.
NOTE: If you apply validation rules to more than one field, include the field name in
the error message. For example, enter The name field only allows text. This is
good practice because error messages only appear after a form is submitted. If the
message does not identify the field, the user may not know which field needs
correction.

Creating a postback message
The postback message is HTML content, so can contain text or graphics. Typically, the
message acknowledges a site visitor’s completion of the form. For most sample forms
provided, sample text appears in the editor. Modify it as you wish, using Ektron’s editor
to change the style sheet class, insert library items, and so on. You can also insert fields
into the Postback Message that retrieve form information. For example, your postback
message may be:
Thank you «Full Name» for completing the «[Form Title]».

When the message appears, it looks like this.
Thank you Jay Kohler for completing the breakroom survey.

When you click the Post back message tab and select Display a message, the
Merge Field button ( ) appears on the toolbar.
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When you click that button, a dialog box appears.

The list includes all fields on the form plus the following fields.
l

Form title

l

Form description

l

Date submitted

Click any field to insert it into the form. The postback message retrieves the field's
value and displays it within the message.

Specifying conditional text in the postback message
You can apply conditions to any portion (or all) of a postback message. For example,
you can display one paragraph if the user browsing your Web page is using a smart
phone, and different text if the user is not on a smart phone. As another example, you
could display a postback message only if the user is not logged into the website as an
Ektron author.
The following image shows the message content after a condition is applied.
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To designate a condition within a postback message, select it then click Conditional
Section ( ).

Redirecting form data to an action page
PREREQUISITE

Obtain the folder and hyperlink name from your administrator who set up an
action page.
To redirect submitted form data to an action page:
1. Go to the page on which you determine the form’s response.
2. To modify an existing form, select the form’s folder, then the form. Next, select
Edit and click the Post back message tab.
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3. Select Redirect form data to an action page.
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4. Click the icon next to File or page. The Link Manager screen appears.

5. Fill in the fields and click OK. The hyperlink is inserted.

Letting site users see the form results
When you create polls and surveys, you can choose to display the results after a site
visitors completes the form. The results can display in the same window or a new
window. In addition, you can choose how to chart the data. See Chart types on the
facing page.
To show site visitors poll/survey results:
1. Go to the page on which you determine the form’s response. If this is a new form, it
is page 4 of the Forms Wizard. To modify an existing form, select the form’s folder,
then the form. Next, select Edit and click the Post Back Message tab.
2. Select Report on the form.
3. Choose whether you want the results to appear in the Same Window or a New
Window.
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4. Choose the style of the report. (Bar Chart, for example.)

Chart types
l

Data Table. Poll/survey answers, with the percentage of users who responded to
each item.

l

Bar Chart. Poll/survey answers as a bar graph. Provides a quick, visual
representation of responses.
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l

880

Pie Chart. Standard pie chart. Poll/survey answers are color coded, and
percentage of people who chose each answer is shown.
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l

Combined. Combines Data Table and Bar Chart.

NOTE: Data entered into a text box cannot be charted. For example, if one
choice in a poll is Other, and the survey has a text box for site users to enter
additional information, the text in the box is not charted. However, the fact that
a user chose Other is charted.

Viewing form reports
If a form is set to store data in the database, you can run a report that displays the
submitted data.
To view a form report:
1. Go to the folder for which you want to view the report. The View Contents of Folder
screen appears.
2. Click the form you want to view. (If you do not see your form in the folder, make
sure the Content Type drop-down box is set to All Types or Forms.)
3. Click View Reports ( ). The View Forms Report screen appears.
l

Start Date. If desired, specify a start date. The report displays only forms
that were submitted on or after the start date.

l

End Date. If desired, specify an end date. The report displays only forms that
were submitted on or before the end date.

l

Report Display. Specify the format to display the report. See also: Choosing
a format to display form data below.

l

Select Legacy Report. Specify the version of the form or poll for which to get
a report. Using this option lets you see the results from previous polls and
forms.

4. Click Get Report to display the report.

Choosing a format to display form data
The submitted form data can be viewed in any of these formats.
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Table with totals
The table of values shows the following information for each completed form.
l

a checkbox that lets you delete the response

l

an internal identification number of the response

l

the name of the user who submitted the form, if the user signed into Ektron
beforehand. If the user did not sign in, anonymous appears.

l

date response was submitted

l

The name of each field on the survey
o under each field name is the submitted response for the each user

l

the bottom line sums the numerical and percentage totals for each response

Summary of selected choices
This format totals, for choice and select type fields, the number of times each choice
was selected. Only choices that were selected at least once appear.
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Table of values
The table of values shows the following information for each completed form.
l

a checkbox that lets you delete the response.

l

an internal identification number of the response.

l

the name of the user who submitted the form, if the user signed in to Ektron
beforehand. If the user did not sign in, anonymous appears.

l

date response was submitted.

l

descriptive name of each form field appears in the column header; the value
entered for each field appears below the header.

List of submitted values
The List of Submitted Values format provides the same information as the Table of
Values, but is formatted vertically rather than horizontally.
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Submitted data as XML
Displays the results of the form in an XML format. The following information is included:
l

<Title>. Title of the form block
NOTE: You can create a new poll question to replace an existing poll question.
By default, the poll still has the same Title, ID, and other properties. You can
change the title of a new poll question when you are editing the poll.

l

<Description>. Description of the form
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l

<SubmittedData>. Information that was submitted

Exporting a form’s raw data
After generating a report, you can export its data to a Microsoft Excel spreadsheet file
(.xls) for further analysis. If a form uses an XML structure, each XML tag becomes a
column header in the spreadsheet.
1. Access the View Form Reports screen for the report you want to export.
2. Generate the report.
3. Click Export Report. A File Download dialog box appears. Choose the option that
best suits your needs.
4. After the data is exported, you can analyze and modify the .xls file.
IMPORTANT: If you are using version 9.00 SP2 update 14 and above or 9.10,
you cannot choose the file's format—it is .htm. To open it, open Microsoft Excel,
then choose File > Open and select the downloaded file.

Assigning a task to a form
While tasks typically help Ektron users track content activities, you can also assign a
task to users or user groups whenever a form is submitted.
For example, your website offers a free product demonstration to anyone who
completes a form. Whenever a site visitor submits the form, a task is assigned to your
sales department’s administrative assistant who uses the form information to schedule
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a demonstration. The sales manager can review the task history to audit sales leads
and ensure demonstration requests are being handled in a timely manner.
To set up a task that it is assigned to users or groups whenever a site visitor completes
the form:
NOTE: You should be familiar with tasks before beginning this procedure. See
also: Assigning and managing tasks on page 1449
1. If you are creating a new form, assign the task using the Forms Wizard.
l If you are editing a form, assign the task on the form’s Edit Properties screen.
l

In either case, you identify only users and groups to whom the task will be
assigned whenever a site visitor completes the form. Ektron assigns the
remaining task information.

2. Complete the form and make it available on your website.
When a site visitor completes and submits the form, Ektron creates a task and
assigns it to users and groups you identified in Step 1. The task created upon form
submission has the following information.
l

Title. Form title, as entered by the author

l

Assigned to. As set up by the user who created or edited the form

l

Assigned by. User who created or last edited form

l

Priority. Normal

l

Task Category. Form Submission Task Category

l

Task type. Form Submission Task

l

Created by. User who created or last edited form

l

State. Not specified

l

Due date. Not started

l

Start date. Not specified

l

Description. Data from form “form name” was received on date time.

l

form description. Name of every field on the form: value submitted by user
into that field

An email is automatically sent to every specified user who has a valid email address in
the User Information Screen. The email’s subject line is the form name. The body of the
email contains a name and a value submitted by the user for each field on the form.
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Working with Smart Forms
Use Smart Form configurations to display, save, and validate the content properly.
Smart Form configurations use XML tags (that are hidden from users) and serve
content to various presentation devices (PDAs, mobile phones, and so on), which saves
users from creating duplicate content. An XML schema validation ensures the accuracy
and format of your Web content, which reduces review and revision time.
PREREQUISITE

Only members of the Administrators group or those defined in Manage
Members for Role: Smart Forms Admin screen can create Smart Form
configurations.
Ektron Smart Forms provide the following benefits:
l

Strictly enforce content and page layout with Ektron's editor, XSLT, and WYSIWYG
templates for content contributors

l

Deliver content to multiple devices (for example, PDAs, mobile phones, and so on)

l

Easily share content across B2B transactions

l

Advanced XML authoring: Ektron's highly-acclaimed XML editor lets developers
hide XML tags from content contributors and provides an easy-to-use WYSIWYG
editing interface

The following are examples of industries that can benefit from XML Indexing.
l

Health Care—A cardiologist whose practice is located in your city

l

Human Resources—Sick time policy

l

Real Estate—A house with a zip code of 03031 priced under $200,000

l

Hospitality—A hotel in the city

l

Online Retail—Fleece gloves for men

l

Educational—A course in .NET programming

You should use XML content whenever possible because of the following advantages.
l

Standardized format for capturing content
o You can create an XML Smart Form then require anyone creating content in a
folder to use the form. The result is more uniform and consistent information.
o
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Within an XML Smart Form, you can require authors to complete fields in a
specified format. So, for example, if you want the author to enter a date, XML
can ensure that it’s captured in a standard format. Several standard formats
are provided (email address, zip code), and you can create your own.
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l

Superior control over content display
o Authors contribute XML content but have virtually no control over its format.
The Web administrator determines the format through an XSLT file. By
customizing the XSLT, you can exert maximum control over your website’s
appearance.
o

l

Because one file controls several (even hundreds of) pages, you can update
just that file to efficiently change the look of all pages whose content is based
on the Smart Form.

Improved search capabilities
o Because XML data is captured in individual fields, you can focus a search on
relevant fields. For example, if your XML content captures data about books,
you can place an author search on your website. Because that search only
looks through content in the Author field, it is much faster and returns more
reliable results than a search of HTML content.

Accessing Smart Form configurations
To access the Smart Form section of the Workarea, go to Settings > Configuration >
Smart Form Configuration. The View Smart Form Configurations screen appears.

When you click a Smart Form configuration to view its information, you can do the
following:

Ektron Reference

889

Managing content

l

l

l

l
l

l

Edit. Edit a Smart Form configuration
Data Design. Open Data Designer
Add Smart Form. Create a new Smart Form configuration from scratch or based
on an existing one
View XSLT. Display a Smart Form configuration’s XSLT
DeleteAssociated Content. Delete content assigned to Smart Form
configuration
Delete. Delete Smart Form configuration (only available if no content is
assigned to configuration) See also: Deleting a Smart Form configuration on
page 904

l

Back. Return to previous screen

Properties tab

l

Title. Name given to Smart Form configuration.

l

ID. ID number assigned by Ektron upon creation of the configuration.

l

Description. Detailed description of configuration given by creator or last editor.
NOTE: If the Smart Form configuration was created using external XML files
(instead of the Data Designer), the following information also appears:
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l

Edit XSLT. XSLT applied to the content when being edited.
NOTE: If no edit XSLT is specified, the Edit Data Design option is enabled in the
toolbar.

l

Save XSLT. XSLT used to transform the XML created in the editor when the Smart
Form is saved to the database.

l

Advanced Configuration. XML file that contains display information, schema
validation, and other advanced XML data.

l

XML Schema. Specify the .xsd file used to validate the XML content that the
Smart Form will be assigned to.

l

Target Namespace. Specify the default namespace used for outgoing XML.

Display Information tab

The display information tab lists the XSLTs that are used when displaying XML in the
respective environment.
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l

XSLT1. Display XSLT 1

l

XSLT2. Display XSLT 2

l

XSLT3. Display XSLT 3

l

XSLT (Packaged). Display XSLT Package (created using the Data Designer)

l

XPaths. Location of the XSLT

NOTE: When a Smart Form configuration is created using the Data Designer, a
default display XSLT is also created which looks similar to the edit XSLT created in
the editor. This default XSLT can be applied to the XML content.
An asterisk (*) denotes a Smart Form's default XSLT.
Preview tab
The Preview tab displays the XSLT applied to the editor when XML content is created.
This is the XSLT that was created for the Smart Form configuration.

Adding a Smart Form configuration
If you need to make major changes to a Smart Form configuration, copy it and modify
the copy so that you do not affect the content controlled by the original configuration.
To copy a Smart Form:
1. Choose Workarea > Settings > Configuration > Smart Form
Configurations.
2. Click a Smart Form configuration.
3. Click Add Smart Form. The Add Smart Form Configuration screen appears.
4. Specify a Title for the copy of the Smart form and click Add Smart Form. The new
title appears in the Smart Forms list and its description shows that it was derived
from an existing Smart form.
5. Click Update.
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6. Design your Smart Form configuration in the Data Designer. See Creating a Smart
Form on page 896 for information about creating XSLTs using the Data Designer.
7. You are ready to assign the Smart Form configuration to a folder or content item.
See Assigning a Smart Form to a folder on page 903 for more information.
A verification button ( ) appears to the right of some fields on the Add Smart Form
screen. After you identify an XSLT or schema, you can click this button to verify that the
file exists in the location specified and contains well-formed XML.
NOTE: The XML Verification feature does not validate the contents of the XML file.
Possible results when clicking the verification button:
l

Verified. File passes all verification parameters.

l

Not Verified. The file either does not exist in the specified location, or does not
contain well-formed XML. Review current settings. Ensure the file is in the proper
location, and that it contains well-formed XML

Adding a Smart Form configuration using the Data
Designer
1. Choose Workarea > Settings > Configuration > Smart Form
Configurations.
2. Click Add Smart Form. The Add Smart Form configuration screen appears.
3. Enter a Title for the Smart Form configuration and click Save. The Smart Form
Data Designer screen appears.
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4. Design your Smart Form configuration in the Data Designer. See Creating a Smart
Form on page 896 for information about creating XSLTs using the Data Designer.
5. Click Update.
You are ready to assign the Smart Form configuration to a folder or content item. See
Assigning a Smart Form to a folder on page 903 for more information.

Adding a Smart Form configuration using external XML
files
NOTE: If you want users to insert Smart Form information using eWebEdit400, you
cannot create or edit Smart Forms using external files. However, you can access
eWebEdit400's source view, paste the external file's XML, then return to design
view.
To add a Smart Form configuration using external XML files:
1. Choose Workarea > Settings > Configuration > Smart Form
Configurations.
2. Click Add Smart Form. The Add Smart Form configuration screen appears.
3. Enter a Title for the Smart Form configuration.
4. Click Save. The Smart Form Data Designer screen appears.
5. Click Backarrow (
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) to exit. The View Smart Form screen for the new Smart Form

Adding a Smart Form configuration using external

configuration appears.
6. Click Edit (

). The Edit Smart Form screen appears.

7. Enter the following information.
General Information
l

Title. Name given to Smart Form configuration.

l

ID. (display only)ID number assigned when configuration is created.

l

Description. Detailed description given to configuration by its creator or last
editor.

Editor Information
l

Edit XSLT. XSLT applied to content while being edited.

l

Save XSLT. XSLT used to transform the XML when saved to the database.

l

Advanced Configuration. XML file that contains display information, schema
validation, and other advanced XML data.

Validation Information
l

XML Schema. The .xsd file used to validate the XML content.

l

Target Namespace. The default namespace used for outgoing XML.

Display Information
l

XSLT1. XSLT 1 applied to XML data when viewed on a device.

l

XSLT2. XSLT 2 applied to XML data when viewed on a device.

l

XSLT3. XSLT 3 applied to XML data when viewed on a device.

l

XSLT (Packaged). XSLT package applied to XML data when viewed on a
device.

NOTE: When a Smart Form configuration is created using the Data Designer, a
default XSLT is created based on the configuration. To learn about modifying
the packaged XSLT, see Editing a Smart Form's XSLT on page 902.
8. Specify the default display XSLT for the configuration by clicking the corresponding
radio button.
9. Click Update.
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Creating a Smart Form
For each field on the screen:
1. Insert a field label.
2. Place the cursor at the desired location.
3. Click the button corresponding to the desired field type.
Ektron provides several options that let you insert or edit fields in the editor.
l

Data Field Types (

)

NOTE: For information about these data field types, see Using data field types
on page 913.
o

Calculated. Performs calculations using other fields on the screen. See
Calculated on page 914.

o

Calendar. Lets user insert a date by clicking a calendar. See Calendar on
page 920.

o

o

Checkbox. User’s response is either checked or unchecked. See Checkbox
on page 924.
Choices. Several choices appear on screen. User checks appropriate
boxes. All user choices are inserted as values within single XML tag. See
Choices on page 926.

o

Group Box. Groups related fields, which can be surrounded by a box and
have a caption. See Group Box on page 930.

o
o

Image Only. Lets user insert an image. See Image Only on page 943.
Link Field. Lets user insert a link to a file, such as a PDF document. See
Link on page 945.

o

Resource Selector. Lets user place content or folders on a Smart Form.
See Resource Selector on page 948.
IMPORTANT: You can place content from folders of the following types on
a Smart Form: standard, root, site, blog, and eCommerce catalog. You
CANNOT place content from Community, Discussion Board, or
WebCalendar folders on a Smart Form.

o
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Tabular. Same as Group Box, but fields can be presented in a table
format. See Tabular Data on page 953.

Ektron 9.40 SP1

Creating a Smart Form

o

Text. Lets user insert and format free text using editor See Text on
page 959.

l

Check Compatibility. Checks the design against existing data.
Field Properties. Lets you change a field's properties. Select field then click

l

this button. This option is also available on the right click menu.
l

View Data as...
o The XML data document
- <root>
- <Information>
<LastName />
<FirstName />
<MiddleName />
<Gender>male</Gender>
<Address />
<city />
<state>MA</state>
<Zip />
<SSN />
<BDate />
<HomeTel />
<WorkTel />
<x-ray />
- <Dental_Insurance>
<Field1 />
<OtherInsurance>N/A</OtherInsurance>
<Account_Number>N/A</Account_Number>
</Dental_Insurance>
<medication />
<lastAppointment />
<clincal />
</Information>
</root>
o

The structure, content, and semantics of an XML document
<xs:schema elementFormDefault="qualified"
attributeFormDefault="unqualified"
xmlns:xs="http://www.w3.org/2001/XMLSchema">
<xs:element name="root">
<xs:complexType>
<xs:sequence>
<xs:element name="Information">
<xs:complexType>
<xs:sequence>
<xs:element name="LastName">
<xs:simpleType>
<xs:restriction base="xs:string">
<xs:minLength xmlns:xs="http://www.w3.org/2001/XMLSchema" value="1" />
</xs:restriction>
</xs:simpleType>
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</xs:element>
<xs:element name="FirstName">
<xs:simpleType>
<xs:restriction base="xs:string">. .. ..
o

A list of all fields and information about them (as XML)
<fieldlist>
<field name="LastName" datatype="string" basetype="text"
xpath="/root/Information/LastName" title="Last Name">Last Name</field>
<field name="FirstName" datatype="string" basetype="text"
xpath="/root/Information/FirstName" title="First Name">First Name</field>
<field name="MiddleName" datatype="string" basetype="text"
xpath="/root/Information/MiddleName" title="Middle Name">Middle Name</field>
<field name="Gender" datatype="choice" basetype="text"
xpath="/root/Information/Gender" datalist="IDAPK3KC">Gender</field>
. .. .. ..

o

xpath information for any indexed field on the screen
<indexable>
<xpath type="string">/root/Information/SSN</xpath>
<xpath type="string">/root/Information/HomeTel</xpath>
<xpath>/root/Information/WorkTel</xpath>
</indexable>

o

The Data Design document’s presentation XSLT
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="xml" version="1.0"
omit-xml-declaration="yes" indent="yes" encoding="utf-8" />
<xsl:strip-space elements="*" />
<xsl:variable name="ektdesignns_fieldlist"
select="/*/ektdesignpackage_list/fieldlist" />
- <xsl:template match="/" xml:space="preserve"> <p> </p>
- <fieldset id="Information" title="Demographic Information">
<legend>Patient Information</legend>
- <div>
- <p> <strong>Last Name</strong> <xsl:text> </xsl:text>
<xsl:value-of select="/root/Information/LastName" />
<strong>First Name</strong>
<xsl:text> </xsl:text>
<xsl:value-of select="/root/Information/FirstName" />
.. .. ... ..

l

Validate. Validates data when previewing data entry. This button is available
in data entry and data design modes.

Buttons at the bottom of the Data Designer screen let you edit the content several
ways.
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l

Data Design mode. Lets you insert and remove fields from the screen.

l

XML mode. Lets you edit the XML source code. If the edited source XML is not
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well-formed, you are notified and must remain in source view until you fix it.
l

Data Entry mode. Simulates the screen’s appearance during data entry.

To edit any field's properties, select it, right click the mouse, and select Field
Properties.
You also can use Ektron’s rich formatting capabilities to design the screen. For example,
you can format text, and use tables, images and hyperlinks to guide the user through
the data entry process. The following sample screen was created with the Data
Designer.

Creating a simple data entry screen
The following example shows how to create a simple data entry screen that has a Group
Box with 2 text fields and a choices field.
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PREREQUISITE

You must be a member of the Administrators group or a Smart Form
administrator. See also: Defining roles on page 1581
1. Workarea > Settings > Configuration > Smart Form Configurations.
2. Click Add Smart Form.
3. Assign the form a title and click Save. For example, Sample Smart Form. The
screen refreshes and the editor appears.
4. Click Group Box (

).

5. Type Address in the Descriptive Name, Field Name, and Caption fields and
click OK. The Address Group Box appears on the form.
6. Click in the Address box and type the label "Street: " then click Text Field (
).
7. Type Street in the Descriptive Name, Field Name, and Tool Tip fields and click
OK. The text field box appears on the form inside the Address Group Box.
8. Under the Street label, type the label "City: " then click Text Field (

).

9. Type City in the Descriptive Name, Field Name, and Tool Tip fields and click
OK. The text field box appears on the form inside the Address Group Box.
10. Under the City label, type the label "State:" then click Choices Field (
).
11. Type State in the Descriptive Name, Field Name, and Tool Tip fields.
12. Choose U.S. States & Territories from the List menu.
13. Click OK. The field box appears on the form inside the Address Group Box.

Inserting a conditional section
You can specify a field or group of fields to appear on a Smart Form configuration only
under certain conditions. For example, a Winter outdoor image does not appear until
November, and drops off on April 1. As another example, one group of fields appears if
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the user is using a mobile device (such as a smart phone), and a different set of fields
appears if the user is not on a mobile device.
1. After you insert the fields on a Smart Form configuration, click Conditional
Section ( ). The Conditional Section dialog appears.
2. Specify the condition. The Examples pull-down has sample conditions that you
can insert then modify.
l The user is viewing the Web page on a Smart Phone
$deviceConfiguration = 'Smart Phones'
l

The user is viewing the Web page on a device that is not a smart phone
not($deviceConfiguration = 'Smart Phones')

l

The user is viewing the Web page on January 1, 2011 or later
$currentDate >= '2011-01-01'

l

The person viewing the Web page is a logged-in Ektron user
$userId != '0'

Use xpathto build the expression. For example, $deviceConfiguration = 'Smart
Phones'. You can click View Data as Index ( ) to see the configuration's xpath
structure.
NOTE: Developers can modify the examples by editing
workarea/ContentDesigner/ConditionalExamples.xml.
3. Select a variable to replace. For example, select X.

4. Select a field from the lower section of the dialog. For example, select Smart
Phones.
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5. Click Replace field in Condition.

The expression looks like this: $deviceConfiguration = 'Smart Phones'
l

You cannot apply a conditional section to a rich area field.

l

You can only apply a conditional section to a Smart Form configuration. You cannot
apply a conditional section to Smart Form content created from a configuration.
But, authors working that content see conditions

Editing a Smart Form's XSLT
902
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Every Smart Form configuration has a packaged XSLT, which is a default XSLT created
from the configuration’s display information. To modify the Smart Form’s appearance:
1. Go to Settings > Configuration > Smart Form Configurations.
2. Click the Smart Form configuration whose XSLT you want to customize.
3. Click View XSLT (

).

4. Select and copy the XSLT and paste it into an XSLT editor.
5. Customize the file.
6. Save it with an .xslt extension to your site root/xmlfiles folder.
7. Return to the Smart Form configuration you selected in Step 2 and click Edit.
8. In the XSLT1 field, enter the Xslt you saved in Step 6.
9. Click the radio button next to XSLT1.
10. Click Update.
You can edit the custom XSLT at any time. The changes immediately affect the
appearance of the Smart Form on your website. So, the XSLT is quite different from
other aspects of the Smart Form configuration, which generally cannot be edited for
existing content.
To view a Smart Form's XSLT, click ( ). The View XSLT screen appears. You can use
this information to create your display XSLT.

Assigning a Smart Form to a folder
Ektron Reference
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If you break inheritance on the Smart Forms tab of the folder properties screen, you can
select the Smart Form configurations to be assigned to content in the folder.

l

To preview a Smart Form configuration, click Preview (

).

l

To add a Smart Form configuration, select it from the drop-down list and click Add
( ). To learn how smart from configurations are created, see Creating a Smart
Form on page 896.

l

To remove a Smart Form configuration, click Remove.

l

To specify that only Smart Forms can be created in a folder, check Require Smart
Forms. If you do, the user can only choose enabled Smart Forms when viewing
that folder’s New menu—all other content types are suppressed.

Deleting a Smart Form
You may delete a Smart Form in the same way that you delete other content. See
Deleting content on page 688.

Deleting a Smart Form configuration
You can delete a Smart Form Configuration only if no content is assigned to it. If no
content is assigned, click Delete ( ) to delete a configuration. If content is assigned,
you must first delete all assigned content.

Deleting assigned content
PREREQUISITE

You have permission to delete the assigned content. See also: Managing
folder and content permissions on page 168.
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1. From the Smart Form Configuration screen, click Associated Content (
access the Delete Contents of Smart Form screen.

) to

2. Delete content assigned to the Smart Form.
3. The Smart Form Configuration screen appears. Click Delete (

) to delete the

configuration.

Searching XML information
XML indexing lets site visitors search XML information collected from Smart Forms and
view the results. The results appear as a list of topic titles, optionally followed by the
content summary. The Ektron Windows Service manages the background processing
that creates XML indexes. See also: Handling background processing functions with the
Ektron Windows Service on page 136.
There are 2 ways that XML indexing can make XML content available to your site
visitors.
l

Present a screen of search criteria. A site visitor uses the screen to select the
desired kind of information. For example, your site sells outdoor clothing, and a
user searches for wool hats under $20.00.

l

Determine the search and display criteria programmatically using a custom
function. Your Web developer inserts a control that specifies search and display
criteria. For example, your site sells books. A site visitor sees a navigation link
Find books under $5.00. When the link is clicked, the control searches your XML
content and returns all books whose price is less than $5.00.

You can choose the XML fields to index with the Data Designer. You can also validate
those fields to be numbers, dates, Boolean, or string values. After you identify fields to
be indexed, a search dialog is created. Where appropriate, the dialog automatically
populates drop-down lists from the indexed data.

Important notes:
l

XML indexing is only available for information collected on XML Smart Forms. It
cannot find information in other types of content.

l

Ektron content has a Content Searchable check box, which you must check if you
want the Index Search to find Smart Form content. See also: Making content
searchable on page 371

l

Do not insert a calendar field into a Smart Form that allows multiple entries (using
the Allow more than One option on the dialog). If you do, you cannot search the
Smart Form using that field.

l

For Smart Form fields to searchable, they must be stored as elements not
attributes.If you are upgrading to version 7.5 or higher, inspect your Smart Forms
and change field properties as needed so they are stored as elements not
attributes.
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Setting up a Smart Form search
To create a search:
1. Select a Smart Form.
2. Assign indexing to each field to be searched. You can index the following types of
fields: Checkbox, Plain Text, Choices, List, Calculated, Image Only, Link, Calendar.
a. Choose Workarea > Settings > Configuration > Smart Form
Configuration.
b. Select a Smart Form configuration that you want to index and open its Data
Design.
c. Move the cursor to the first field you want to index, right click the field, and
choose Field Properties. A dialog box appears.
d. Check Indexed.
e. Repeat these steps for every field by which you want site visitors to search the
Smart Form.
IMPORTANT: If a Smart Form configuration field's xpath exceeds 64
characters, Microsoft Search Server 2010 cannot search it. So, if you need
to index such a field, reduce the length of its xpath to less than 64
characters.
To see a configuration's XPaths, click the Display Information tab.
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3. Set up the search screen.
l Xpath. The xpath to each indexed field.
l

Label. The index field’s field name, as defined on its dialog.

l

Multiple. Check this box if you want to allow the user performing the search
to select more than one value. This checkbox only appears with List and
Choice fields.

4. When you save a Data Design form, a dialog appears that lets you view all and
modify indexed fields.

l

Xpath. The xpath to each indexed field.

l

Label. The index field’s field name, as defined on its dialog.

l

Multiple. Check this box if you want to allow the user performing the search
to select more than one value. This checkbox only appears with List and
Choice fields.

NOTE: To select more than one value on the search screen, the user holds
down the Ctrl key while selecting additional options.
If you choose NoSelection in a search field, the search disregards that field when
compiling results. However, you must select a value (or range of values) in at least one
field to get results.

Validation
Validation ensures that the user completing an XML form enters the right type of data.
You can decide if the user’s input should be a number, boolean, date, string, zip code,
and so on. If you do not specify type attributes using validation data, the field is a
string.
Validation is especially important when users search XML data, because it helps the
search find the correct information. For example, if a field collects a zip code but you set
its type to plain text, a user completing the form can insert anything into the field. If the
user inserts the letter “o” instead of the number zero (0), the field accepts that input
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but the search will not find that record. On the other hand, if you set validation to zip
code, the user can only insert 5 or 9 digits—any other entry is rejected.

User-selected versus developer-selected search criteria
There are 2 ways that XML Indexing can make XML content available to your site
visitors.
l

Present a screen of search criteria. A site visitor uses the screen to select the
desired kind of information. For example, your site sells outdoor clothing, and a
user searches for wool hats under $20.00.

l

Determine the search and display criteria programmatically using a custom
function. Your Web developer inserts a control that specifies search and display
criteria. For example, your site sells books. A site visitor sees a navigation link Find
books under $5.00. When the link is clicked, the control searches your XML
content and returns all books whose price is less than $5.00.

NOTE: The Ektron Windows Service manages the background processing that
creates XML indexes. See also: Handling background processing functions with the
Ektron Windows Service on page 136.
Ektron content has a Content Searchable check box, which must be checked if you
want the Index Search to find Smart Form content. See also: Making content
searchable on page 371

Types of search criteria
XML Indexing allows multi-dimensional searches on all types of XML data.
l

Plain text. Use an exact phrase, or any word or letter in a phrase

l

Numerical and date information. Use expressions such as greater than, less
than, or between 2 values

l

List and choice fields. Display the field values and let the user select relevant
ones.
NOTE: Choices field values can consist of single letter.

l

Image Only. Use the alt or src attribute value

l

Link. Use the text or href attribute value

For every search field, NoSelection is a value. If this is chosen, the search disregards
that field when compiling results. However, the user must select a value (or range of
values) in at least one field to get results.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows multiple
entries (using the Allow more than One option on the dialog). If you do, you
cannot search the Smart Form using that field.
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For Smart Form fields to searchable, they must be stored as elements not attributes.
If you are upgrading to version 7.5 or higher, inspect your Smart Forms and change
field properties as needed so they are stored as elements not attributes.

Specifying which XML elements are indexed
XML indexing allows multi-dimensional searches on all types of XML data.
l

Plain text. Use an exact phrase, or any word or letter in a phrase

l

Numerical and date information. Use expressions such as greater than, less
than, or between 2 values

l

List and choice fields. Display the field values and let the user select relevant
ones. Choices field values can consist of single letter.

l

Image Only. Use the alt or src attribute value

l

Link. Use the text or href attribute value

If a Smart Form configuration field's xpath exceeds 64 characters, Microsoft Search
Server 2010 cannot search it. So, if you need to index such a field, reduce the length of
its xpath to less than 64 characters. To see a configuration's XPaths, click the Display
Information tab.

Adding standard validation options
By default, the Data Designer provides several standard validation options. You can see
them by clicking the down arrow to the right of the Validation drop-down.
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Creating custom validation criteria
If the standard validation options do not provide the flexibility you want, use the custom
validation feature to ensure the following about the user’s input.
l

The data type—the default types are
o text
o

URL

o

whole number

o

decimal number

o

floating point number (Floating point includes scientific notation, so is
appropriate for scientific numbers. Decimals usually suffice for business
numbers.)

NOTE: Your system administrator may customize the choices.
l

The field value has one of the following relationships with another field, a number,
or an expression—the default expressions are
o between 2 values (either another field or a number that you specify)
o

less than

o

equal to

o

not equal to

o

maximum length (usually for text responses)

NOTE: Your system administrator may customize the choices.
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If the user’s response fails to meet the criteria, you can compose an error message that
appears when that happens. Your system administrator determines if a user can save
the invalid data.
As an example of custom validation, assume that a field collects telephone numbers,
and you want to make sure the user enters 10 digits. To accomplish this:
1. Click the Plain Text Field dialog and complete the screen.
2. In the validation section, click Custom Validation. The Custom validation screen
appears.
3. In the Data Type field, select Whole Number from the drop-down list. This
ensures that the user can only enter digits.
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4. Click the down arrow to the right of the Examples field to see sample logic.

5. Click Maximum text length.... This option lets you specify the length of the
user’s response.
string-length(.) <= {X} appears in the Condition field.
6. Because you want the user’s input to equal 10, remove the less than sign (<) from
the calculation. Now it looks like this: string-length(.) = {X}.
7. Replace the {X} with 10. Now, it looks like this: string-length(.) = 10.
8. Move the cursor to the Error Message field and compose a relevant error
message. For example: must be 10 digits. Your screen should look like this.
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9. Click OK and return to the Plain Text field dialog.
10. Click OK to save that dialog and test the validation on the phone number field. To
do this, switch to Data Entry mode and enter more or fewer than 10 digits, as well
as non-digit characters to verify that validation works as expected.

Using data field types
You can insert the following data field types into a data entry screen.
IMPORTANT: For Smart Form fields to searchable, they must be stored as
elements or attributes not content. If you are upgrading to version 8.5 or higher,
inspect your Smart Forms and change field properties as needed so they are not
stored as content.
l

Calculated on the next page

l

Calendar on page 920

l

Checkbox on page 924

l

Choices on page 926

l

Group Box on page 930

l

Image Only on page 943

l

Link on page 945

l

Resource Selector on page 948

l

Tabular Data on page 953

l

Text on page 959
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Calculated
Use a calculated field to perform a calculation based on values in other fields. For
example, if your screen collects mortgage information, you could create one field to
collect the mortgage and interest payment and another to collect taxes and insurance.
The calculated field could sum those 2 numbers and display the monthly payment.
You can validate a calculated field. For example, you can require a positive number
between 100 and 1,000.
Calculated fields are display only.
IMPORTANT: If a field is referenced in a calculation, use validation to require a
value. This forces the user to enter a number used in the calculation.
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l

Descriptive Name. Enter the name of the field.

l

Indexed. Check if you want to index this field. For more information, see
Searching XML information on page 905. The Indexed field may or may not
appear, depending on how your administrator has set up your system.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over this
field.

l

Formula. Enter the calculation that this field will perform. See also: Using the
Formula Field below

l

Select Field. Click this button to select a field to reference in the calculation.

l

Examples. Click the down arrow next to this field to see sample calculations. If
you select an example, it is copied into the Formula field. See also: Formula
examples on page 917

l

Validation. Select the kind of validation to apply to this field. Your choices are:
l No validation. the user’s response is not checked
l

Non-negative number (required). the result of the calculation must be a
positive number

l

Custom Validation. See Creating custom validation criteria on page 910

If you assign any value other than No validation, the field is surrounded by red
dashes in Data Entry mode. If the user’s response does not meet the validation
criteria, the field remains surrounded by red dashes. Your system administrator
determines if a user can save a screen with invalid data.
l

Error message. If you select Non-negative number, insert text that appears on
the screen if the user’s response does not meet this criterion.

l

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

Using the Formula Field
1. Copy a sample calculation into the Formula field by clicking the Examples field.
2. Select an operation from the drop-down list. For example, if you click Examples
Add 2 numbers {X}+{Y}, {X}+{Y} appears in this field.
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3. Replace the variables with fields on the screen. Be sure to select the curly brackets
({}) with the letter between them. Then, when the user enters data into those
fields, the calculation is performed using the current field values.
4. Select the first variable to replace. To continue the example, select {X}.
5. Select a field to replace that variable in the calculation.

6. Click Replace X in Formula.
7. Replace all variables in the formula.

Important information about calculated variables
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l

If the user does not replace all variables, validation will fail.

l

If a variable appears more than once in a formula (for example, {X} * number
({X}<= {Y}) + {Y} * number({X}>{Y}), you only need to replace the first
occurrence—the editor replaces subsequent occurrences for you.

l

If a calculated field tries to perform a numerical calculation with a value that is
blank or contains letters, NaN appears in the field. (NaN stands for “not a number.”)

l

If a calculated field tries to divide by zero, Infinity appears.

l

If an XML document contains several occurrences of a field that is referenced in a
formula, the value is derived as follows:
l When using the XPath functions sum() and count(), all values with the field
name are considered. For example, a document includes 3 books whose prices
are $10, $20 and $30. In this case, sum’s value is $60.
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l

When using all other functions, the first value is used. For example, a
document includes 3 books whose prices are $10, $20 and $30. If a calculation
formula refers to <price>, its value is $10.

l

You can replace a variable with a number instead of a field. For example, replace
{X} * {Y} with ../price * 1.15.

l

The expression can be complex, such as
(round(Field1 * 0.80) + (1 div Field2)) - 2.

l

You can use a string expression that creates a text message. For example, to
calculate a full name from its parts: concat( title, ' ', givenname, ' ',
familyname), which could produce “Dr. Jonathan Smythe”.

l

A calculated field can only reference other calculated fields that appear before it in
a document. For example, a document collects a series of numbers.
l One calculated field counts the number of numbers.
l

Another totals their values.

l

A third computes the average by dividing the total by the count.

In this example, you must place the third field below or to the right of the first 2
fields. Calculated fields that are defined later in a document do not appear in the
Select Field or Group dialog.

Formula examples
These formulae appear in the Examples drop-down list of the Calculated Field dialog.
Your system administrator can customize the list.
l

Add 2 numbers. Add the value in the first field (X) to the value in the second field
(Y).
{X} + {Y}

l

Subtract 2 numbers. Subtract the value in the second field (Y) from the value in
the first field (X).
{X} - {Y}

l

Multiply 2 numbers. Multiply the value in the first field (X) by the value in the
second field (Y).
{X} * {Y}

l

Divide 2 numbers. Divide the value in the first field (X) by the value in the
second field (Y).
format-number({X} div {Y},'0.###')

l

Format as a percentage. Determine what percentage one number (X) is of
another (Y). For example, if {X}=10 and {Y}=100, the result of the calculation is
10%.
format-number({X} div {Y},'#0%')
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l

Absolute value of a number. The number regardless of the sign (negative or
positive).
{X} * (number({X} > 0)*2-1)

l

Minimum of 2 numbers. The smaller of 2 field values.
{X} * number({X} <= {Y}) + {Y} * number({X} > {Y})

l

Maximum of 2 numbers. The larger of 2 field values.
{X} * number({X} >= {Y}) + {Y} * number({X} < {Y})

l

Zero if subtraction is negative. Subtract one number (Y) from another (X). If
the difference is less than zero, insert zero.
({X} - {Y}) * number(({X} - {Y}) >; 0)

l

Multiply by another number if checkbox is checked.
{X} * ( {Y} * number( {Z} ='true') + number( {Z} !='true'))
o

X is a numeric field.

o

Y is another numeric field to multiply by X if a checkbox is checked.

o

Z is the checkbox.

For example, {X}=2 and {Y}=3

l

o

if the checkbox is checked, the result is 2 * 3, which is 6

o

If the checkbox is not checked, the result is 2

Round a decimal number. Rounds the number to the nearest integer. For
example, round(3.14). The result is 3.
round({X})

l

Round up a decimal number. Returns the smallest integer that is greater than
the number. For example, ceiling(3.14). The result is 4. For negative numbers:
ceiling(-3.14) = -3
ceiling({X})

l

Round down a decimal number. Returns the largest integer that is not greater
than the number argument. For example, floor(3.14). The result is 3. For
negative numbers: floor(-3.14) = -4
floor({X})

l

Format decimal number 0.00. Rounds a value either up or down to the
hundredth place. As examples, 100 becomes 100.00, and 3.14159265 becomes
3.14.
format-number({X},'0.00')

l

Total numeric values from multiple fields. Add the values in all referenced
fields. Only elements that contain a value are summed. Empty elements are
excluded.
sum({X}[text()] | {Y}[text()] | {Z}[text()]))
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l

Total a list of numeric values. Total all values in a single repeating field.
sum({X}[text()])

For example:
Plain Text Field properties
o

Name: Miles

o

Allow: more than one

o

Validation: non-negative whole number

XML Data
<root>
<Miles>89</Miles>
<Miles>12</Miles>
<Miles>23</Miles>
<Miles>19</Miles>
</root>
Sum(Miles) equals 89+12+23+19=143

Only elements that contain a value are summed. Empty elements are excluded.
l

Average a list of numeric values. Calculate the average of all values in a single
repeating field.
format-number(sum({X}[text()]) div count({X}),'0.###')

To continue the example from the Total a list of numeric values field:
Plain Text Field properties
o

Name: Miles

o

Allow: more than one

o

Validation: non-negative whole number

XML Data
<root>
<Miles>89</Miles>
<Miles>12</Miles>
<Miles>23</Miles>
<Miles>19</Miles>
</root>
Average=89+12+23+19=143

divided by the number of values (4)= 35.75
Only elements that contain a value are summed. Empty elements are excluded.
l

Count the number of values in a list. Calculate the number of values in a
single repeating field.
count({X})

To continue the example from the Total a list of numeric values field:
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Plain Text Field properties
o

Name: Miles

o

Allow: more than one

o

Validation: non-negative whole number

XML Data
<root>
<Miles>89</Miles>
<Miles>12</Miles>
<Miles>23</Miles>
<Miles>19</Miles>
</root>
Count = 4
l

Lowercase text. Replace all uppercase characters with the lowercase version of
that character.
translate({X},'ABCDEFGHIJKLMNOPQRSTUVWXYZ','abcdefghijklmnopqrstuvwxyz')

l

Uppercase text. Replace all lowercase characters with the uppercase version of
that character.
translate({X},'abcdefghijklmnopqrstuvwxyz','ABCDEFGHIJKLMNOPQRSTUVWXYZ')

l

Remove extra spaces. Remove extra space characters from content.
normalize-space({X})

l

Concatenate text. Link text strings together into a single string. For example,
concat('The',' ','XML') yields The XML.
concat({X}, ', ', {Y})

l

Size of a text string. Count the number of characters in a selected field’s value.
For example, if the referenced field’s value is Hello, string-length = 5.
string-length({X})

Calendar
Insert a calendar field when you want a Smart Form to include a date field. You may use
the current date or click one from a calendar. Because users cannot enter digits, a
standard date format is ensured. The date is stored as a standard XML date (in the
format yyyy-mm-dd), and localized to the computer of the user viewing it.
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l

Descriptive Name. Enter the name of the field.

l

Indexed. Check if you want to index this field. For more information, see
Searching XML information on page 905. The Indexed field may or may not
appear, depending on how your administrator has set up your system.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over this
field.

l

Default value. If you want this screen to have a default date when the user first
sees it, click the calendar icon to the right and select a date. The user can change
the date in Data Entry mode. Check Default to Current date if you want to use
the date on which the content is created or edited.
NOTE: If you enter a default date, you cannot later remove it. You can change
it. If necessary, you can delete the field and enter a new one.

l

Use. Click May not be removed if this field must be included on the screen.
Otherwise, click May be removed.
If you check May be removed, when this field appears on a data entry screen, an
icon ( ) appears to the left of the field. If the user clicks the icon, a drop-down
menu provides an option to remove the field.
If the user removes the field, field name replaces the field on the data entry
screen to indicate that the field was removed and can be re-added if necessary. For
example, if the field’s display name is street address, and the user removes the
field,
appears in place of the field.
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NOTE: The menu icon ( ) can also indicate that the user can add instances of
a field (see the Allow field). So, if a field is required, the icon could appear but
omit a Remove option.
l

Allow. Check more than one if you want to let the user entering data add
instances of this field. Otherwise, check only one. For example, if a screen is
collecting names and addresses and you want to let the user enter several of them,
check more than one. If you check More than one here, you are allowing the
user to insert an entirely new table, not an additional table row.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows
multiple entries (using the Allow more than One option on the dialog). If you
do, you cannot search the Smart Form using that field.
If the user entering data clicks , a menu appears, which lets the user click
Duplicate to add instances of the field to the screen.
NOTE: The menu icon ( ) can also indicate that the user can remove a field
(see the Use field). So, even if a field allows only one instance, the icon could
appear but the menu would only display Remove.
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l

Validation. If you want to require the user using the calendar to enter a response,
click the down arrow to the right of this response field and select Cannot be
blank. You can also choose a date in the past/future option or Custom.

l

Error Message. If you select Cannot be blank, insert text that appears on the
screen if the user’s response does not meet this criterion.

l

Custom Validation. You can ensure the user’s input is greater or less than the
date you are inserting on the Data Design screen.
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Creating a custom validation

l

l

Message. Displays in Data Entry mode when the user inserts an invalid value.
Your system administrator determines if a user can save the invalid data.

l

Data Type. Shows Date.

l

Condition. Displays the validation logic.

l

Examples. Drop-down list shows validation expressions that you can apply to
the field.

l

Select a Field to Insert area. Displays fields that can be inserted into the
Condition field. You must choose a calendar type field (note the calendar icon
to the left of these fields).

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

Creating a custom validation
As an example of custom validation, assume a field collects the date when a patient’s
health insurance policy expires. You want to make sure the date is later than today. To
accomplish this:
1. Create a calendar field that prompts for today’s date.
2. Create another calendar field that prompts for a patient’s health insurance policy
expiration date.
3. While creating the second field, in the Validation section, click Custom
Validation. The Custom validation screen appears.
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4. Click the down arrow to the right of the Examples field to see sample logic.

5. Click Date After (not(. >={X}). This option lets you specify that the user’s
response must be later than a specified date.
6. In the Condition field, select {X} and click the Select Field button. The Select
Field or Group screen appears.
7. Select the field that prompts for today’s date, which you created in Step 1. That
field replaces {X} in the Condition field.
8. Move the cursor to the Error Message field and compose an error message. For
example: Must be after today. Your screen should look like this.

9. Click OK.
10. Click OK to save that dialog and test the validation on the date field. To do this,
switch to Data Entry mode and enter a date earlier than today to verify that
validation works as expected.

Checkbox
924
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A Checkbox field is only one character wide and accepts one of 2 possible values:
checked or unchecked. For example:

l

Descriptive Name. Enter text to guide the user’s response to this field. To
continue the example, the caption would be Check if you are over 65. After you
insert this field onto the screen, the Descriptive Name appears to the right of the
checkbox. You can use the editor's formatting capabilities to modify its size, font,
color, and other attributes.
NOTE: The Descriptive Name field only appears on this dialog when you create
the Check Box field. If you later try to edit the field, it is not on the dialog.
However, you can edit the Descriptive Name text within the editor.

l

Indexed. Check if you want to index this field. See also: Searching XML
information on page 905. The Indexed field may not appear, depending on how
your administrator set up your system.

l

Field Name. Enter the field’s element name. This will define the field in the XML.

l

Tool Tip Text. Enter text that appears when a user hovers the cursor over this
field.

l

Default value. If you want this field to be checked when the screen first appears,
click True. Otherwise, click False.

l

Validation tab. You can use this screen to specify if the checkbox must be
checked or unchecked.
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l

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

Choices
Use a Choices field to give a data entry user several options. For example, you create a
Choices field named Interests that lists these options. The data entry user could check
the first 2 and leave the third blank.
l

music

l

art

l

sports

You can do the following with a Choices field.
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l

Limit a user’s response to one item, or allow more than one.

l

Require a response.

l

Determine the list’s appearance.

l

Choose from a standard list of choices (such as Languages, Countries, and so on)
or create your own list.
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Choices

l

Descriptive Name. Enter the name of the field.

l

Indexed. Check if you want to index this field. For more information, see
Searching XML information on page 905. The Indexed field may or may not
appear, depending on how your administrator set up your system.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over this
choice list.

l

List. Select from a standard list or choose Custom to create your own.

l

Allow selection. Click More than one to let the data entry user select more than
one item on the data entry screen. Otherwise, click Only one. For example, if you
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click More than one, and the choices are: music, art, sports, the user could select
all 3 choices.
l A selection is required. Check this box if the user must select at least one
list item.
l

l

First item is not a valid selection. Check here if the first list item is text
that prompts the user to respond to the field. An example of such text for a list
of states is Select a state. If you check this box and the user selects the first
value on the list (most likely by default), an error appears when he tries to
save the screen.

Appearance. Determine the style of list.
List type

Example

Description

vertical

All choices appear, arranged vertically.

horizontal

All choices appear, arranged horizontally.

list box

All items appear. The default one is selected when the
screen first appears, but can be changed.

drop list

Only the top item appears. To its right, a down arrow
appears (circled). The user clicks the arrow to display
all items and select one.

l

Item List. See Creating a custom choice list below.

l

Value. Enter the value collected when a data entry user selects this item. For
example, if Interests appears in the Name field, and you want music to be
collected when the data entry user selects this item and saves the page, enter
music here.

l

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

Creating a custom choice list
To create your own set of list options, accept the List field’s default value, Custom.
Then, enter the list values using the Item List section of the screen.
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To indicate an option is the default choice, check the Selected checkbox.
l

In the Display Text field, enter text to describe this item on the data entry screen.
After you insert this field onto the screen, you can format it. For example, you can
apply bold, assign a style, and so on.

l

In the Value field, enter the value that is collected when the data entry user
selects this item.
For example, if Interests appears in the Name field, and you want music to be
collected when the data entry user selects this item and saves the page, enter
music here.

To add a new choice, delete an existing choice, or move a choice up or down within the
list, click the menu icon ( ) next to that choice. Then select a menu option.

Creating a custom choice list in a configuration file
Although you can create a custom list of choices using the Item List area of the
Choices Field dialog, that list is only available in that field of that screen. If you want to
insert the same list in another section of the screen or a different screen, you must reenter all options. However, if you create a list according to the following steps, your
custom list is stored in the configuration file (along with the standard choice lists, such
as Countries). As a result, any user connected to your server can insert the list into
any Choices Field on any screen.
To insert a custom list of choices:
1. Open the Ektron configuration file,
siteroot/workarea/contentdesigner/DataListSpec.xml.
2. Insert the new list following the pattern of the other lists in the file, like the
following list.
<datalist name="MyNewList">
<schema datatype="string" />
<item default="true" value="Green" />
<item value="Red" />
<item value="Blue" />
</datalist>
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NOTE: You can specify a data type of value: string, nonNegativeInteger, date,
decimal. You also can specify a default value (as shown in the third line).

Creating a dynamically populated choice list
You specify the elements of the custom options list described in the configuration data.
You can also create a dynamically-populated list from any XML source. The source can
be on your server or on a remote website. Follow these steps to add a dynamic data list
to the Choices field.
1. Open the Ektron configuration file,
siteroot/workarea/contentdesigner/DataListSpec.xml.
2. Insert the new list following the pattern of the other lists in the file, like the
following list.
<datalist name="MyNewList">
<schema datatype="string" />
<item default="true" value="Green" />
<item value="Red" />
<item value="Blue" />
</datalist>

3. Insert a new datalist item according to this pattern.
<datalist
name="MyNewList"
src="{url to xml data source}"
select="{xpath to data item element}"
captionxpath="{relative xpath to data item's display text}"
valuexpath="{relative xpath to data item's value}">

IMPORTANT: The datalist name must match the listchoice data attribute.
For example
<datalist
name="USPS-CA"
src="[eWebEditProPath]/uspsca.xsd"
select="/xsd:schema/xsd:simpleType/xsd:restriction/xsd:enumeration"
captionxpath="xsd:annotation/xsd:documentation"\
valuexpath="@value"
namespaces="xmlns:xsd='http://www.w3.org/2001/XMLSchema'"
validation="select-req">

In this example, the data list is stored in the uspsca.xsd file, located within the
ewebeditpro folder. However, it could be in any XML data source.

Group Box
A Group Box field lets you group related fields together by surrounding them with a box
and optionally placing a caption above them. After you insert a Group Box field, to
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insert other kinds of fields within the box, place the cursor inside the box then select a
field type button.
NOTE: The tabular data field type might better accommodate your needs. See
Tabular Data on page 953.
Grouping fields in Data Entry mode lets you add another instance of a group. For
example, if a screen collects information about each telephone call, you can click
Insert Below to insert a new group of fields, ready to collect information about the
next call.

Use the eyeglass icon to expand or collapse fields within a group.

You also can suppress a group of irrelevant fields. For example, assume a screen
includes 2 groups of fields that collect information about hardcover and paperback
books. When adding information about a hardcover book, you can collapse paperback
book questions because they are not relevant.
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Group Box General tab
l

Descriptive Name. Enter the name of this field, which is used internally as the
field’s caption. By default, the Data Designer assigns a name made up of Field
followed by the next available number. So, the first field’s default name is Field1,
the second field’s default name is Field2, and so on. You can change the default if
you want.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Use. Click May not be removed if this field must be included on the screen.
Otherwise, click May be removed.
If you check May be removed, when this field appears on a data entry screen, an
icon ( ) appears to the left of the field. If the user clicks the icon, a drop-down
menu provides an option to remove the field.
If the user removes the field, field name replaces the field on the data entry
screen to indicate that the field was removed and can be re-added if necessary. For
example, if the field’s display name is street address, and the user removes the
field,
appears in place of the field.
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NOTE: The menu icon ( ) can also indicate that the user can add instances of
a field (see the Allow field). So, if a field is required, the icon could appear but
omit a Remove option.
l

Allow. Check more than one if you want to let the user entering data add
instances of this field. Otherwise, check only one. For example, if a screen is
collecting names and addresses and you want to let the user enter several of them,
check more than one. If you check More than one here, you are allowing the
user to insert an entirely new table, not an additional table row.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows
multiple entries (using the Allow more than One option on the dialog). If you
do, you cannot search the Smart Form using that field.
If the user entering data clicks , a menu appears, which lets the user click
Duplicate to add instances of the field to the screen.
NOTE: The menu icon ( ) can also indicate that the user can remove a field.
So, even if a field allows only one instance, the icon could appear but the menu
would only display Remove.

l

Appearance. Click Show border and caption if you want to surround the fields
in this group with a box. You can also create a caption to appear in the top line of
the box. Click No border if you do not want to surround the fields in this group
with a box.

l

Caption. If desired, enter text to describe this group of fields on the data entry
screen. For example:

After you insert this field onto the screen, you can use the editor's formatting
capabilities to modify its size, font, color, and other attributes.
NOTE: The Caption field only appears on this dialog when you create the Group
Box field. If you later try to edit the field, the Caption field is not on the dialog.
However, you can edit Caption text within the editor.
l

Advanced tab. See Group Box Advanced tab on the next page.

l

Relevance. See Group Box Relevance tab on page 936.

Using a tag other than <root>
By default, Ektron surrounds your Data Design with <root> tags. To replace <root>
tags with another element name:
1. After creating a new Data Design screen, insert a Group Box as the first field.
2. In the Group Box dialog’s Field Name field, enter the root text.
3. On the Group Box Dialog box, click the Advanced tab.
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4. In the Root tag section, select Use this element as the Root tag and press OK.
5. Place all other screen elements within the Group Box field.

Group Box Advanced tab
The Advanced tab lets you generate XML microformats made up of standard XHTML
tags and attributes that contain a specific structure and values.
For example, the microformat of an event looks like this.
<span class="event">
<a class=
"url" href="https://www.lisa.org/events/2006nyc/
package_registration.html?from=fn1206 ">
LISA Global Strategies Summit</a>
</span>

NOTE: If the element is a Group Box or table, its type must be Element because it
surrounds other elements. If the element is a Rich Area field, its type must be
Element or Content.
l

Element. A unique tag. The user’s response to the field becomes its value.
<Lastname>Rogers</Lastname>

l

Attribute. An attribute of the containing field. The containing field is typically a
Group Box. If you insert an Attribute field type, the Field Name field on the dialog
box is grayed out. The field name and type can only be edited on the Advanced
Field properties screen.
<PtInformation Lastname="Rogers">
</PtInformation>

l

Content. The content of the containing field, typically a Group Box. Note that, in
this case, field name is not used (it's is grayed out). The field name and type can
only be edited on the Advanced Field properties screen. Because most fields define
their own content, this option is typically used to define a value to a Group Box that
contains other fields defined as attributes.
NOTE: Only one Content type field is valid within a containing field.
<PtInformation>
Rogers
</PtInformation>

Data entry view
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Data design view

Replacing the XML <root> tag
By default, Ektron surrounds your Data Design with <root> XML tags. You can replace
the <root> tags with another element name by following these steps.
1. After creating a new Data Design screen, insert a Group Box as the first field.
2. In the Group Box dialog box Field Name field, enter the root text. For example,
"state" to replace <root> with <state>.
3. Click the Advanced tab.
4. In the Root tag section of that screen, select Use this element as the Root tag
and click OK.
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5. Place all other screen elements within the Group Box field.

Group Box Relevance tab
The Relevance tab allows a group of fields to appear or disappear according to the
value of other fields in the configuration. It appears on both the Group Box and Tabular
Data Box dialogs.
Here are some example uses.
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l

Questions about pregnancy that appear only if the patient is female.

l

A list of states that appears only if the user selects United States as the person's
country.
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l

A list of car manufacturers. When a user chooses one, all of its models appear in a
second list.

Fields that can be used in relevance conditions
Only the following field types can be used in a Relevance condition.
l

Check box

l

Text

l

Calculated

l

Choices

NOTE: If using a Choices field, in the Appearance area of the dialog, you can only
choose List Box or Drop Box. Vertical List and Horizontal List are not
supported.
To apply relevance to a Group Box field:

Applying relevance to a Group Box field
1. Edit a Smart Form configuration in Data Design mode to which you want to apply
Relevance.
2. If necessary, insert the field(s) on which the Group Box’s appearance depends.
3. Insert a Group Box field. See also: Group Box on page 930
NOTE: The location of the Group Box field is independent of the location of the
fields to which you will apply conditions.
4. Click the Group Box dialog’s Relevance tab.
5. The Relevance tab appears.
6. Scroll through the list of sample conditions to determine which one best fits your
situation.
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7. Select a field from the lower half of the screen to replace the first variable (X or Y)
in the condition. For example, if the condition is A checkbox field is checked
({X} = 'true'), click the check box field whose value must be true for this group
to appear.
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8. Click Replace {X} in Condition.
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9. Notice that, in the Condition field, the variable was replaced by the selected field.

10. If the condition has another variable, repeat Steps 7 and 8.
11. Click OK.
You should switch to Data Entry mode and test the Relevance conditions.

Example of applying relevance to a Group Box field
Assume you want a list of states in the United States to appear only if a user selects
United States from the Country field.
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To accomplish this:
1. Create a Choices field and assign it 3 values:
l United States
l

Canada

l

Other

See also: Choices on page 926
2. Create a Group Box field and name it States.
3. With that Group Box field, create a new Choices field.
l Name it US States.
l

In its List field, select U.S. States & Territories.

l

In Allow Selection, check First item is not a valid selection

l

In the Appearance field, select Drop List.
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4. Click OK. The field appears on the form.

5. Place the cursor on the States Group Box field and click Group Box.
6. Click its Relevance tab.
7. Pull down the Examples list.
8. Click A field has a given value ({X} = 'value').
9. Scroll through the lower half of the screen until you see the country Choices field.
10. Click Replace '{X}' in Condition. Notice that the Condition field now reads
/root/Country = 'value'.
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11. In the Condition field, replace Value with United States.

IMPORTANT: The text that replaces Value must exactly match the desired
value of the selected field.
12. Click OK.

Image Only
Use an Image Only field to place an icon on the screen, which the user can click to insert
an image into the content. You can insert a default image if desired. To let the user
insert any file, such as a Microsoft Word document, use a Link on page 945 field.
In Data Entry mode, the image’s caption appears, followed by a default image (if you
specify one) and this icon:
NOTE: The user can only insert a file whose extension is defined within the
<validext> element of the configdataentry.xml file. Your system administrator can
help you do this.
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l

Descriptive Name. Enter the name of the field.

l

Indexed. Check if you want to index this field. For more information, see
Searching XML information on page 905. The Indexed field may or may not
appear, depending on how your administrator has set up your system.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over this
field.

l

Use. Click May not be removed if this field must be included on the screen.
Otherwise, click May be removed.
If you check May be removed, when this field appears on a data entry screen, an
icon ( ) appears to the left of the field. If the user clicks the icon, a drop-down
menu provides an option to remove the field.
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If the user removes the field, field name replaces the field on the data entry
screen to indicate that the field was removed and can be re-added if necessary. For
example, if the field’s display name is street address, and the user removes the
field,
appears in place of the field.
NOTE: The menu icon ( ) can also indicate that the user can add instances of
a field (see the Allow field). So, if a field is required, the icon could appear but
omit a Remove option.
l

Allow. Check more than one if you want to let the user entering data add
instances of this field. Otherwise, check only one. For example, if a screen is
collecting names and addresses and you want to let the user enter several of them,
check more than one. If you check More than one here, you are allowing the
user to insert an entirely new table, not an additional table row.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows
multiple entries (using the Allow more than One option on the dialog). If you
do, you cannot search the Smart Form using that field.
If the user entering data clicks , a menu appears, which lets the user click
Duplicate to add instances of the field to the screen.
NOTE: The menu icon ( ) can also indicate that the user can remove a field.
So, even if a field allows only one instance, the icon could appear but the menu
would only display Remove.

l

Value. Whether the value is an element or plain text.
o Value is an element renders the field as <img src=”url” alt=”text” />
for an image.
o

l

Value is plain text renders the field as just the url.

Default Image Location. If desired, you can insert a default image, which might
be the most common image or a reminder that an image needs to be inserted. To
find the image, click From File and go to image file. The image file's extension
must appear between the <validext> tags in the configdatadesign.xml file. For
example:
<validext>gif,jpg,png,jpeg,jpe,doc,txt
</validext>

l

Cannot be blank. To require the user to enter a response, check this box.

l

Description. Enter the image’s alt text, which is used as a replacement for an
image whenever it cannot be seen. For example, a visually impaired person is
using a screen reader.

l

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

Link
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Use a Link field to place an icon on the screen. A user in Data Entry mode can use the
icon to link to any Library file, such as a Microsoft Word document or a .gif image file.
(You can also use an Image Only field to let the user insert an image. See also: Image
Only on page 943)
The File Link field does not let you link to Ektron assets.
In Data Entry mode, the file link field’s caption appears, followed by this icon:
. When
the user clicks the icon, a hyperlink screen prompts you to specify information about
the link.
NOTE: Only insert a file whose extension is defined within the <validext> element
of the configdataentry.xml file. Your system administrator can help you do this.
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l

Descriptive Name. Enter the name of the field.

l

Indexed. Check if you want to index this field. For more information, see
Searching XML information on page 905. The indexed field may or may not appear,
depending on how your administrator has set up your system.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over this
field.

l

Use. Click May not be removed if this field must be included on the screen.
Otherwise, click May be removed.
If you check May be removed, when this field appears on a data entry screen, an
icon ( ) appears to the left of the field. If the user clicks the icon, a drop-down
menu provides an option to remove the field.
If the user removes the field, field name replaces the field on the data entry
screen to indicate that the field was removed and can be re-added if necessary. For
example, if the field’s display name is street address, and the user removes the
field,
appears in place of the field.
NOTE: The menu icon ( ) can also indicate that the user can add instances of
a field (see the Allow field). So, if a field is required, the icon could appear but
omit a Remove option.

l

Allow. Check more than one if you want to let the user entering data add
instances of this field. Otherwise, check only one. For example, if a screen is
collecting names and addresses and you want to let the user enter several of them,
check more than one. If you check More than one here, you are allowing the
user to insert an entirely new table, not an additional table row.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows
multiple entries (using the Allow more than One option on the dialog). If you
do, you cannot search the Smart Form using that field.
If the user entering data clicks , a menu appears, which lets the user click
Duplicate to add instances of the field to the screen.
NOTE: The menu icon ( ) can also indicate that the user can remove a field.
So, even if a field allows only one instance, the icon could appear but the menu
would only display Remove.

l

Value. Whether the value is an element or plain text.
o Value is an element renders the field as <img src=”url” alt=”text” />
for an image.
o

l

Value is plain text renders the field as just the url.

Default Location. If desired, you can insert a default link, which can be the most
common link or simply an example. To help find the link, click the Select button
and go to a file. You can only insert a file whose extension appears between the
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<validext> element of the configdatadesign.xml file. For example:
<validext>gif,jpg,png,jpeg,jpe,pdf,doc</validext>
l

Cannot be blank. If you want to require the user completing this field to enter a
response, click this check box.

l

Description. If desired, enter text that the user can click to access the linked file.

l

Target Frame. Use this field to indicate how the hyperlinked files will appear when
clicked.
o New Window(_blank). In a new browser window, on top of the current
browser.

l

o

Same Window(_self). In the same position within the browser window. The
new window replaces the current one.

o

Parent Window(_parent). If your page contains frames, in the frame that
contains the frame with the hyperlink.

o

Browser Window(_top). If your page contains frames, in the full display
area, replacing the frames.

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

Resource Selector
A Resource Selector field lets you place elements of Ektron content, taxonomies,
collections or folders on a Smart Form. For example, on the following page, content in a
selected folder appears.
IMPORTANT: You can place content from these folder types on a Smart Form:
standard, root, site, blog, and eCommerce catalog. You cannot place content from
Community, Discussion Board, or WebCalendar folders nor PageBuilder pages on a
Smart Form.
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Each content item in the folder is represented as a hyperlink followed by its summary. A
site visitor can click the link to view the content. An alternative display showing
hyperlinks only appears as follows.
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A Resource Selector field acts like server controls that let you place content on a Web
page, such as the Content Block and List Summary server controls. The advantages of
the Resource Selector field are:
l

You can add individual content or all content in a folder, collection or taxonomy
category to a Smart Form. So, you can position resources then surround them with
text, images, and so on, to place them into proper context.

l

Management is handled within the Workarea. So, Ektron administrators can display
content via a Smart Form without needing a developer to create/modify templates
and server controls.

These steps summarize how to use a Resource Selector on a Smart Form.
1. Create a Smart Form configuration.
2. Edit its Data Design, placing a Resource Selector field on it.
3. Set the Resource Selector properties. For example, determine whether the content
author can select content, a taxonomy category, a collection, or a folder.
4. Assign the configuration to an Ektron folder. See also: Assigning a Smart Form to a
folder on page 903
5. An author creates a Smart Form based on that configuration.
6. The author adds content, a collection, a taxonomy category, or a folder to the
Smart Form, along with other field types.
7. A site visitor browses to the page and views the assigned content.
To a content author, a Smart Form's Resource Selector fields appear as follows.

The upper field lets the author select content (ID 30 is the default), and the lower one
lets the person select a folder (ID 36 is the default). To select either one, click the folder
to its right, then select. If working with content, the tabs that appear on the dialog are
determined when the resource is placed on the Smart Form configuration.
NOTE: If someone changes the title of content used in a Resource Selector field, the
title is not updated on the Smart Form. In the illustration, if someone changed the
title of content ID 30, you would still see Sample Content Block when viewing the
Resource Selector field.

950

Ektron 9.40 SP1

General tab

General tab
l

Descriptive Name. Enter the name of this field. Internally, the name is used as
the field’s caption. By default, the Data Designer assigns the name Field followed
by the next available number. So, the first field’s name is Field1, the second field
is Field2, and so on. You may change the default.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over the
field.

l

Resource Type. Select Content, Folder, Taxonomy, or collection.
IMPORTANT: You can place content from these folder types on a Smart Form:
standard, root, site, blog, and eCommerce catalog. You cannot place content
from Community, Discussion Board, or WebCalendar folders on a Smart Form.

l

Default Value. Select the default content, folder, taxonomy or collection item by
clicking the folder icon and selecting. The following example shows a taxonomy
default item. The author can accept the displayed default or change it by clicking
on the folder icon.
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l

Minimum Number. Define the minimum number of content items that can appear
where you insert the Resource Selector.

l

Maximum Number. Define the maximum number of content items that can
appear where you insert the Resource Selector.
These settings affect the content author’s work with this field on a Smart Form in
the following way. Assume you set a minimum of 1 and a maximum of 2. After the
content author adds 2 content items for this resource selector, the only options are
to remove or rearrange fields; you cannot add more.

Type tab
Use the Type tab to limit the type of content that a content author may choose. It is
available only if the Resource type is Content Resource.
NOTE: eCommerce products are also known as catalog entries.

Configuration tab
The Configuration tab determines how a content author may select content or a folder
on a Smart Form. It is available only if the Resource Type is Content or Folder.
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l

l

l

Check Browsing folders to let content authors select content or a folder by
browsing through folders.
o If you want to set a beginning folder from which an author can browse, use the
Starting Folder field. Otherwise, browsing begins at the Root folder.
Check Browsing taxonomy categories to let a content author select content by
browsing through taxonomies. (Available only if the Resource Type is Content.)
Check Searching for key words to let a content author select content using the
Workarea search. (Available only if the Resource Type is Content.)

Appearance tab
The Appearance tab determines the default appearance of the resource on your
website.

Tabular Data
The Tabular data button inserts a table into which you can place other types of fields.
It’s similar to a Group Box but its advantage over a Group Box is that it lets you place
fields in columns. After you insert a table, you can insert an appropriate field type into
each column. For example, the Description field type is plain text, while the In
Stock? field type is a choice.
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If you insert a field into a table and its caption appears to the left of the data entry
region, move the caption to the column header.

l

To access table commands (such as add row and add column), place the cursor
inside a table cell and right click the mouse.
NOTE: To delete a column, place the cursor in the column, right click the
mouse, and select Delete Column. You cannot reduce the number of columns
by editing the Tabular Data dialog’s Columns field.

l

To edit tabular data, hover the cursor over a table border line until you see a 4headed arrow. Then, click the right mouse button and select Field Properties.
IMPORTANT: Only table cells into which you place a field are available to
visitors of your Web page.
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l

Descriptive Name. Enter the name of this table. By default, the Data Designer
signs a name made up of Field followed by the next available number. So, the first
field’s default name is Field1, the second field’s default name is Field2, and so on.
You can change the default if you want.

l

Field Name. Enter the table’s element name. This will define the table in the XML.
See also: Tabular data creates 3 levels of XML tags: on page 957

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over the
table’s column headers.

l

Use. Click May not be removed if this field must be included on the screen.
Otherwise, click May be removed.

Ektron Reference

955

Managing content

If you check May be removed, when this field appears on a data entry screen, an
icon ( ) appears to the left of the field. If the user clicks the icon, a drop-down
menu provides an option to remove the field.
If the user removes the field, field name replaces the field on the data entry
screen to indicate that the field was removed and can be re-added if necessary. For
example, if the field’s display name is street address, and the user removes the
field,
appears in place of the field.
NOTE: The menu icon ( ) can also indicate that the user can add instances of
a field (see the Allow field). So, if a field is required, the icon could appear but
omit a Remove option.
l

Allow. Check more than one if you want to let the user entering data add
instances of this field. Otherwise, check only one. For example, if a screen is
collecting names and addresses and you want to let the user enter several of them,
check more than one. If you check More than one here, you are allowing the
user to insert an entirely new table, not an additional table row.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows
multiple entries (using the Allow more than One option on the dialog). If you
do, you cannot search the Smart Form using that field.
If the user entering data clicks , a menu appears, which lets the user click
Duplicate to add instances of the field to the screen.
NOTE: The menu icon ( ) can also indicate that the user can remove a field.
So, even if a field allows only one instance, the icon could appear but the menu
would only display Remove.
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l

Row display name. Enter the text that appears when a user hovers the cursor
over the table’s cells. Use this field to describe the kind of information to be
inserted into the table’s cells.

l

Row name. Enter the name of the XML tag used to collect data for each entry in
the table.

l

Minimum number. If desired, enter the minimum number of rows for this table.
If you enter a number and the data entry user tries to save the screen without
inserting at least the minimum number of rows, the user is informed that Element
content is incomplete according to the DTD/Schema. By default, the user is
allowed to cancel or save the screen anyway. However, the system administrator
determines whether or not the user can save an invalid document.

l

Maximum number. If desired, enter the maximum number of rows for this table.
If you don’t want to assign a maximum number, check Unlimited. When this table
appears on a data entry screen, if a user adds the maximum number of rows, the
Insert Above and Insert Below menu options are grayed out.
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l

Columns. Enter the number of columns to appear in the table.

l

Caption. Optionally enter text to describe this table on the data entry screen. The
caption appears centered above the table. After you insert this field onto the
screen, you can use eWebEditPro+XML’s formatting capabilities to modify the
caption’s size, font, color, and other attributes.

l

Advanced tab. This is the same as the Group Box Advanced tab on page 934.

l

Relevance. This is the same as the Group Box Relevance tab on page 936.

Tabular data creates 3 levels of XML tags:
l

inner level: each field in the table

l

middle level: each row in the table

l

outer level: the entire set of table data

To explain how this works, use the following contact list as an example.
l

John Doe, 555-1212, john.doe@example.com

l

Mary Smith, 555-8765, msmith@example.net

When you insert a field into a table, a dialog helps you define the field type. For
example, when inserting a plain text field, the Plain Text Field dialog appears. On that
dialog, the value of the Phone field defines the tags that enclose that field’s contents.
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To continue the example, every contact is represented in XML as:
<Name>John Doe</Name>
<Phone>555-1212</Phone>
<Email>john.doe@example.com</Email>
and
<Name>Mary Smith</Name>
<Phone>555-8765</Phone>
<Email>msmith@example.net</Email>

Each row of the table collects information for one contact. On the Tabular Data Box
dialog, the Row Name field defines the XML tag that groups information for each
contact. For example, the Row Name field value is Contact.
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<AddressBook>
<contact>
<Name>John Doe</Name>
<Phone>555-1212</Phone>
<Email>john.doe@example.com</Email>
</contact>
<contact>
<Name>John Doe</Name>
<Phone>555-1212</Phone>
<Email>john.doe@example.com</Email>
</contact>
<contact>
<Name>Mary Smith</Name>
<Phone>555-8765</Phone>
<Email>msmith@example.net</Email>
</contact>
</AddressBook>

Text
Use a text field when you want the user to enter a text response.
NOTE: If a plain text field tries to perform a numerical calculation with a value that
is blank or contains letters, NaN appears in the field. (NaN stands for “not a number.”)
If a plain text field tries to divide by zero, Infinity appears.
The following capabilities are available with a text field.
l

Text can be read-only or hidden

l

Can allow plain text only, or let the author apply formatting

l

Can consist of one or several lines
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l

Descriptive Name. Enter the name of the field.

l

Indexed. Check if you want to index this field. For more information, see
Searching XML information on page 905. The Indexed field may or may not
appear, depending on how your administrator set up your system.

l

Field Name. Enter the field’s element name. This defines the field in the XML.

l

Tool Tip Text. Enter the text that appears when a user hovers the cursor over this
field.

l

Default Value. If you want to set a default value for this field, enter it here. The
default value appears in Data Entry mode, where the user can accept, change, or
delete it. For example, if this field collects a city, and most users enter New York,
enter New York as the value.

l

Dimensions. Set the size of the text field in characters.
o Size (or Width). Enter the width of this textbox in characters. This field is
available only if Allow Rich Formatting is not checked.
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o

l

Height. Enter the height of this textbox in characters. This field is available
only if Allow Multiple Lines is checked and if Allow Rich Formatting is not
checked.

Use. Click May not be removed if this field must be included on the screen.
Otherwise, click May be removed.
If you check May be removed, when this field appears on a data entry screen, an
icon ( ) appears next to the field. If the user clicks the icon, a menu provides a
remove option.
If the user removes the field, field name replaces the field on the screen to
indicate that the field was removed and can be re-added if necessary. For example,
if the field’s display name is street address, and the user removes the field,
appears in place of the field.
NOTE: The menu icon ( ) can also indicate that the user can add instances of
a field (see the Allow field). So, if a field is required, the icon could appear but
omit a Remove option.

l

Allow. Check more than one if you want to let the user add instances of this
field. Otherwise, check only one. For example, if a screen is collecting names and
addresses and you want to let the user enter several of them, check more than
one. If you check More than one here, you allow the user to insert a new table,
not an additional table row.
IMPORTANT: Do not insert a calendar field into a Smart Form that allows
multiple entries (using the Allow more than One option on the dialog). If you
do, you cannot search the Smart Form using that field.
If the user entering data clicks , a menu appears, which lets the user click
Duplicate to add instances of the field to the screen.
NOTE: The menu icon ( ) can also indicate that the user can remove a field
(see the Use field). So, even if a field allows only one instance, the icon could
appear but the menu would only display Remove.

l

Allow Rich Formatting. Check this box if you want to let the Smart Form author
format text in this field. If you do not check the box, the author can enter plain text
only.
If you allow rich formatting, a content author uses the editor selected in either the
web.config file's ek_EditControlWin key (for Windows computers) or the ek_
EditControlMac key (for Apple computers). Or, if UserPreferred is the
web.config value, the author uses the editor selected in the user profile.

l

Keep Single Blocking Tag. This checkbox is active only if Allow Rich
Formatting is checked. Check this box if you want the editor to maintain <p> tags
around a single line of text. Uncheck this box if you want the editor to strip <p> tags
from a single line of text.
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NOTE: This checkbox has no effect if text that allows rich formatting consists of
more than one line.
Sample Results
Checked: <p>Here is sample text</p>
Unchecked: Here is sample text
l

Allow Multiple Lines. Check here to let this text box expand to accommodate the
user’s input. If you do not check this box, a single line box appears on the screen to
accept user input.

l

Cannot be Changed. Check here to make this field read-only. You might use this
option to provide instructions for completing the screen.

l

Invisible. Check to make this field hidden in Data Entry mode. This option lets you
store unseen information in an XML document. An example might be putting a
version number for the data design so that XML documents can be upgraded to
newer versions using an XSL transform.

l

Validation. Select the kind of validation to apply to this field. Your choices are:
o No validation. the user’s response is not checked.
o

Cannot be blank. the user must enter a response.

o

Custom. You can create custom validation. See also: Creating custom
validation criteria on page 910

If you assign to this field any value other than No validation, the field is initially
surrounded by red dashes in Data Entry mode. If the user’s response does not
meet the validation criterion, the field remains surrounded by red dashes. The
system administrator determines whether or not the user can save an invalid
document.
l
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Working with blogs
A blog is a form of online information sharing. You create a main blog post, and others
can comment on it. Or, you can use a blog to create an online diary of everyday life.
Your most recent blog post appears at the top with associated blogs following. Some
blogs display a calendar on which days when blogs were created are highlighted. The
blog workflow is as follows:
1. An administrator creates a blog in the Workarea, assigns blog subjects, creates a
blog roll, and decides how comments are handled. In the Workarea, a blog looks
like a content folder but has a distinct icon (

). See Adding a blog on page 967.

2. A developer adds the blog to a Web form using blog server controls, then publishes
the form. See the Blog server controls.
3. Ektron users can add blog posts, either from the Workarea or the website.
Depending on permissions, the post is either published immediately or submitted
to the blog’s workflow. See Working with blog posts on page 979.

4. When published, site visitors can view the post and add comments. See Controlling
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blog comments on page 974.

You can use a Smart Form to implement structured blogging, which provides a form for
the blogger to complete instead of free-form writing. For example, you create a book
review blog and want to make sure that an author submitting a review provides:
l

Title

l

Author

l

Date of review

l

Review text

For information about working with Smart Forms, see Working with Smart Forms on
page 888.
NOTE: Unlike the Smart Forms you can assign to regular folders, you cannot require
the user to select a Smart Form when creating a new post. It is only an option.

Blog elements
964
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The following list shows elements commonly found in a blog.
NOTE: In Ektron 9.10, a new web.config parameter was created—ek_
enableLegacyBlogFields—that determines whether the Summary tab displays the
fields for Traceback URL and Pingback, and Tags when you create a blog post. In
Ektron 9.10, the default is false.
<add key="ek_enableLegacyBlogFields" value="false" />
l

Blog Title. The name of your blog as you want it to appear on the site. For
example, “My Life Story.”

l

Blog Post. The main entry for each topic. A blog post consists of these elements.
See Working with blog posts on page 979.
l Headline. title of the post
l

Commentary. details of the post

l

Comment Link. links to a comments page, where site visitors can view or add
comments

l

TrackBack URL. a URL visitors can use to notify you when they discuss the
post on their site. See also: Trackback (Wikipedia)

l

PingBack. Pings back any URLs in the blog post See also: Pingback
(Wikipedia)

l

Images. add images to a blog post the same way you add them to content.
See also: Adding a library file to content on page 743

l

Blog Comments. A Comments link appears at the end of the blog post. The link
includes a number (for example (3)) that denotes how many comments have been
made. Click this link to move to the comments page, where you can read
comments on the post and possibly enter your own. See Controlling blog
comments on page 974.

l

Blog Roll. Other blogs that the blog’s creator wants site visitors to view. See
Adding blog roll links on page 971.

l

Blog Subjects. Subjects associated with the blog. If you click a subject, links to all
posts associated with the subject appear. See Adding blog subjects on page 969.

l

Calendar. Indicates when blog posts were made. This lets site visitors go your
blog by clicking a day that has blog posts.

A blog folder has the same functionality and features as other folders in the following
areas:
l

Permissions

l

Workflow

l

Purge history

l

Language support

l

Search
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For more information, see Approving content for publication on page 749 and Managing
folder and content permissions on page 168.

Editing blog properties
PREREQUISITE

You have permission to Edit Folders on the blog’s Advanced Permissions
screen.
To edit blog properties:
l

Workarea
1. Go to the blog folder.
2. Click View > Properties.
3. Click Edit Properties.

l

Website
1. Log in.
2. Go to the blog.
3. Open the menu for the blog.
4. Select Properties.

You have more options when you edit the properties of a blog than when you create it.
This saves time when you are creating multiple blogs on a site. You can set the following
properties when you create or edit a blog.
l

Create Blog
o Name. The name of your blog as it appears in the content folder tree.
o

Title. The title of your blog as it appears on the website blog. It only appears if
the ShowHeader Blog server control property is set to true.

o

Visibility.
n Public. any site visitor can view the blog
n

o

l

Comments. Choose how to handle comments by checking the appropriate
boxes. For more information, see Controlling blog comments on page 974.

Edit Blog
o Name. The name of your blog as it appears in the content folder tree.
o

Title. The title of your blog as it appears on the website blog. It only appears if
the ShowHeader Blog server control property is set to true.

o

Visibility.
n Public. any site visitor can view the blog
n
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Private. Membership and Ektron users must log in to see the blog.
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o

Tagline. A line of additional information that describes the blog. It appears
below the title if the ShowHeader Blog server control property is set to true.
For example, the title of a blog is “John’s Blog Page.” The tag line could be “A
place to learn about John's past, present, future, and his current state of
mind!”

o

Post Visible. The number of posts visible on the blog page. If the number of
posts exceeds this number, only this many of the most recent posts appear.
For example, if this property is set to 10 and you add 11 posts, only the 10
most recent posts appear. This number can be from 1 to 999. If you leave this
field blank, all posts made during the current day are visible.

o

Comments. Choose how to handle comments by checking the appropriate
boxes. For more information, see Controlling blog comments on page 974.

o

Update Services. Enter a service that notifies a blog search site when blog
posts are added to your blog site. These blog search sites allow Web users to
search content contained in blogs around the world. To use this feature, check
the Notify blog search engines of new posts box and enter a path to a
search site. An example path is: http://rpc.technorati.com/rpc/ping.

o

Style sheet. If you want to provide a custom style sheet for the blog, enter
the path to it relative to the site root. For example, WorkArea/csslib/my_
custom_blogs.css. Leave this field blank to inherit the default style sheet,
blogs.css, located in Workarea/csslib. You can customize the default style
sheet but your modifications will get overwritten when you upgrade Ektron.

o

Content Searchable. Specify whether the blog can be found through site
searches.

o

Display Settings. Specify the tabs that you want displayed when you create
or edit blog content.

Adding a blog
PREREQUISITE

You have permission to Add Folders on the blog’s Advanced Permissions
screen.
1. From the Workarea, choose Content.
2. Click the folder in which the blog will reside.
3. Choose New > Blog. (You also can right click on a content folder and choose Add
Blog.) The Add a Blog screen appears.
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4. Complete the Properties tab.
l

Name. The name of your blog as it appears in the content folder tree.

l

Title. The title of your blog as it appears on the website.

l

Visibility. Choose whether the blog is private or public. If private, only
logged-in site visitors can see it.

l

Comments. Choose how to handle comments by checking the appropriate
boxes. See Controlling blog comments on page 974.

l

Taxonomy tab. Select taxonomy categories to apply to the blog. See also:
Organizing content with taxonomies on page 1357

l

Templates tab. Select templates to apply to the blog. See also: Working with
templates on page 838

l

Subjects tab. Add subjects to the blog. See also: Adding blog subjects on the
facing page

l

Blog Roll tab. Add blog sites that you want blog readers to visit. See also:
Adding blog roll links on page 971

5. Specify the information in the tabs, and click Add Blog.

Deleting a blog
PREREQUISITE

You must be logged in and have permission to Delete Folders on the blog’s
Advanced Permissions screen.
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1. In the Workarea, go to Content then the blog folder. (From the website, open the
menu for the blog and click Properties.)
2. Choose Delete > This Blog. A dialog box asks you to confirm.
3. Click OK.
WARNING! Deleting a blog removes the blog and all of its posts, comments, and
quicklinks. After a blog is deleted, you cannot retrieve its posts, comments, or
quicklinks.

Adding blog subjects
Subjects make it easier for site visitors scanning a blog page to find posts that interest
them. An author assigns one or more subjects to a blog post. When the post is
published, a list of subjects assigned to all posts appears in a column. A site visitor can
click a subject to see all related posts.
For example, a blog’s subjects are General Information, Cardiology, Oncology, and
Neurology. A blog is written about the importance of screening and then assigned to the
Oncology subject. When a user clicks Oncology, the screening blog appears with other
blogs related to Oncology. By default, a blog's subjects appear with other blog
components when a Blog Server control is placed on a Web page. A developer can place
a list of blog subjects only on a Web page via the BlogCalendar server control.

A subject only can be assigned to the blog in which it is created—it cannot be reused
with other blogs. With each new blog, you must create new subjects. This gives you the
flexibility to tailor unique subjects to each blog.
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To add or edit a blog subject:
NOTE: To add a blog subject from the website, you must be logged in.
1. In the Workarea, go to the blog folder. (From the website, open the menu for the
blog and click Properties.)
2. Choose View > Properties.
3. Click Edit Properties.
4. Click the Subjects tab, then Add Subject.

5. Enter the subject. Add as many subjects as you want by clicking Add New
Subjects.
6. Click Save.

Removing blog subjects
NOTE: To remove a blog subject from the website, you must be logged in.
1. In the Workarea, go to the blog folder. (From the website, open the menu for the
blog and click Properties).
2. Choose View > Properties.
3. Click Edit Properties.
4. Click the Subjects tab.
5. Click Remove Last Subject to remove the subject from the end of the list, or click
Remove to remove a specific subject.
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6. Click OK to confirm removal of the last subject. You can continue to remove
subjects at the end of the list by clicking the Remove Last Subject link.
7. Click Save to save your changes.

Adding blog roll links
A blog roll lists website links to your blog page; a list of related blogs, or blogs that you
want your visitors to view. See also: BlogRoll server control.

NOTE: To add a blog roll link from the website, you must be logged in.
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1. In the Workarea, go to the blog folder. (From the website, open the menu for the
blog and click Properties.)
2. Choose View > Properties.
3. Click Edit Properties.
4. On the Blog Roll tab, click Add Roll Link. The Add Blog Roll Link form appears.

5. Fill out the form. Add as many links to the blog roll as you would like.
l Link Name. Describes the link in the blog roll.
l

URL. Enter the URL of the blog you are adding to the blog roll. It must begin
with http://.

l

Short Description. Add a short description of the site.

l

Relationship. Enter the relationship of the blog roll link to you or to the site.
For example, brother. Click Edit for a pop up screen that helps you choose the
site's relationship.
l URL. Check this box if the address is owned by the same person or
company.
l

Friendship. Choose your level of friendship with the site owner.
o Contact
o

Acquaintance

o

Friend

o

None

l

Physical. Check this box if you have physically met the person who owns
this blog.

l

Professional. Check if the site owner has a work relationship with you.
Select all that apply.
o Co-worker
o
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l

o

Geographical—Select one.

o

co-resident

o

neighbor

o

none

Family. If the site owner is a family member, select the relationship.
o Child
o

Parent

o

Sibling

o

Spouse

o

Kin

o

None

Romantic. Check your feelings toward the site owner.
o Muse
o

Crush

o

Date

o

Sweetheart

6. Click Save.

Removing blog roll links
NOTE: To remove a blog roll link from the website, you must be logged in.
1. In the Workarea, go to the blog folder. (From the website, access the blog’s menu
from the site and click Properties.)
2. Choose View > Properties.
3. Click Edit Properties.
4. Click the Blog Roll tab.
5. Click Remove Last Roll Link to remove the roll link from the end of the list, or
click Remove Roll Link to remove a specific roll link.
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6. Click OK to confirm removal of the last blog roll link.
7. Click Save.

Controlling blog comments
Blog comments let site visitors add their thoughts about a blog post.
IMPORTANT: Do not confuse blog comments with history comments. You can add a
history comment to the blog post by clicking the Comment tab. This is not the same
as adding a comment to a blog post on a site. When you add a history comment, it
has the same properties as a comment associated with content.
The blog administrator controls commenting by deciding who can add comments and
whether a comment requires approval for publication. By default, comments are fully
controlled. This means they are enabled, must be approved, and a site visitor must log
in to create them. The following blog properties control comments. See also: Editing
blog properties on page 966
l

974

Enable Comments. Allows user in Workarea and site visitor to add blog
comments. Also displays comments on site and in Workarea.
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NOTE: An Administrators group member can add comments, regardless of how
this checkbox is set.
l

Moderate Comments. Determines if comments must be approved before they
appear on site. If this field is checked, only Ektron users with permission to edit the
post can approve comments. If a user without edit permission adds comments,
they only appear on the website after being approved by someone with edit
permission.
An unapproved comment is indicated by a red exclamation point ( ). If a user with
edit permission logs in, comments are automatically approved.
NOTE: Membership users cannot approve blog comments.

l

Require Authentication. Determines if a user must be logged in as an Ektron or
membership user to add comments via the website.

If comments are enabled but not moderated, any site visitor can add a comment. If you
want to ensure comments on your site meet certain criteria, moderate them.
IMPORTANT: If comments are not moderated, they appear on your site as soon as
a site visitor submits them.
On the site, blog post comments appear when you click the Comments link or the Title
of the blog post. The comment page contains the original post, any comments, and a
form to post new comments. Depending on how the page is designed, the calendar and
blog roll also may appear.
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The Workarea’s View Posts in Blog screen lets you add, view, approve, edit, and delete
comments for a blog post. The Comments column indicates the number of comments.
An unapproved comment is indicated by a red exclamation point ( ).

Adding a blog comment
PREREQUISITE

You must have Add permission on the blog’s Standard Permissions screen.
To add or edit a blog post comment from the Workarea:
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1. From the Content area, go to the blog and find the post that you want to edit.
2. Click the number in the Comments column. The View Comments for Post screen
appears.
3. Choose New > Comment. The Add Comment screen appears.

l

Name. The person submitting the comment. This information is required.
NOTE: This text box appears only when a site visitor, who is not a regular
user or membership user, is adding a comment. If a regular user or
membership user adds a comment, their name and email address is taken
from their user profile.

l

Email. The email address of the person submitting the comment. This
information is required.
NOTE: This text box appears only when a site visitor, who is not a regular
user or membership user, is adding a comment. If a regular user or
membership user adds a comment, their name and email address is taken
from their user profile.

l

Homepage. A URL for the person’s website.

l

State. Set the comment’s state to approved or pending.
o Approved comments appear on the site immediately.
o

Pending comments must be approved before they appear.
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l

Comment Section. A text area to insert comments about the post.

l

Post Comment button. Post a comment by clicking this button. Depending on
the comment’s settings, it either posts immediately or is submitted for
approval.

Deleting a blog comment
When a comment is deleted, you cannot retrieve it.
1. From the Content area, go to the blog.
2. Find the post that you want to edit.
3. Click the number in the Comments column. The View Comments for Post screen
appears.
4. Click Delete. A dialog box asks you to confirm.
5. Click OK to delete the comment.

Approving a blog comment
Comments can require approval if:
l

they are submitted from the website and Moderate Comments is checked in the
blog’s folder properties.

l

a user submits the comment from the Workarea and sets its state to Pending.

Only users with permission to edit content (posts) within the blog folder can approve
comments.
To approve a comment:
1. From the Content area, go to the blog.
2. Find the post that has a comment that requires approval.
3. Click the number in the Comments column. The View Comments for Post screen
appears.
4. Click Approve.
5. The comment’s status changes to approved.

Notification of moderated blog comments
Whenever a moderated blog comment is published, the Notification system can notify
interested recipients. See Sending notifications to a community on page 1665.
Upon the posting a moderated blog comment, a Moderated Blog Comment message
may be generated.
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Working with blog posts
Your website displays only Published blog posts. However, the Workarea displays all
blog posts, regardless of status. In the Workarea, you can also create, edit, delete, and
archive blog posts in the same way you work with content. See also: BlogPost server
control.

Blog posts on the website
You can view Published blog posts on the website. A blog post has a Title, Content,
Comments Link, Post Time, Date, and Editor Information.
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l

Title. The headline of the post. Usually what a site visitor scans through to find a
post to read.

l

Permanent Link. If you click this link, a new screen displays the permanent link
to this blog post. As long as the blog post is active within Ektron, you can access it
via the URL in the browser’s address bar. Most blog pages show only recent posts.
After a post is moved off the blog’s front page, it is still accessible via this link.

l

Content. The body of the post.

l

Comments Information. The comments link shows the number in parentheses
of comments for a post . When this link is clicked, a new page of comments for the
post appears. Also on the page is a form to add comments about the post. The
comments only appear if a site visitor has logged in or authentication is not
required for blog comments.

l

Editor Information. The person who created or last edited the blog post.

l

Post Time and Date. The date and time a blog post was created or last edited.

Blog posts in the Workarea
Viewing a blog post in the Workarea is similar to viewing content in the Workarea. Go to
the folder that contains the blog then click the title of the blog post in the View Posts in
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Blog screen.

The View Posts in Blog screen shows the following information about each blog post.
l

Title. The headline of the post. Usually what a site visitor scans through to find a
post to read.

l

Comments Information. The comments link shows the number in parentheses
of comments for a post . When this link is clicked, the View Comments for Post
screen appears. If a red flag ( ) appears next to the comments icon, they are
awaiting approval.

l

Editor Information. The person who created or last edited the blog post.

l

Post Time and Date. The date and time the blog post was created or last edited.

l

Status. The status of the blog post. For example, if the blog post is checked in, the
status is I.

From this screen, you can perform all functions with a blog post that you can with
content. You can give it a summary, add metadata, associate a task, assign Web Alerts,
and so on. You must have Edit permission for the blog to perform these functions.
NOTE: You can also add a history comment to a blog post by clicking the Comment
tab. This is not the same as adding a comment to a blog post on a site. A history
comment has the same properties as a comment associated with content.

Adding a blog post
PREREQUISITE
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To add a blog post, you must have Add permission on the blog’s Standard
Permissions screen. To add a blog post from the website, you must be
logged in.
1. In the Workarea, go to the blog folder and choose New > HTML Post. (From the
website, open the menu for the blog then choose New Post.)
2. When the Add Content screen appears, use the editor to create the blog post. You
create a blog post the same way you create content. See also: Editing in Ektron on
page 605
If you are a member of the blog’s workflow, it is published immediately. If not, the
post is surrounded by a yellow border. A workflow approver must approve it before
it appears on the website

When the post is published, it appears within the blog on the website.
You can add tags to a blog post to further define information about it for blog search
engines. For example, you create a blog post about your favorite band and enter the
following tags:
l

Music

l

Guitars

l

Rock & Roll

When a person visiting a blog search site searches for Rock & Roll music, your blog post
appears. Some blog search sites have a page specifically for searching blog tags.

Editing a blog post
PREREQUISITE
l

You have Edit permission on the blog’s Standard Permissions screen. To add a blog
post from the website, you must be logged in

NOTE: If another editor changes a blog post, the posting information reflects the
new editor, the date, and the time the information was changed. This is important to
remember if you want the original person who posted the blog to get credit for the
post.
1. In the Workarea, go to the blog folder. (From the website, open menu for the blog
then choose Properties, then choose the post.)
2. Click the blog post title you want to edit.
3. Click Edit.
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4. Change the blog post. When the blog is published, the changes appear in the blog
post on the website.

Approving a blog post
If someone who is not a member of the blog’s workflow creates or edits a blog post, its
status is set to Submitted. It only appears on the website after a member of the
workflow approves it. While its status is Submitted, it has yellow border on the View
Posts in blog screen. To approve a blog post, see Approving content for publication on
page 749.

Deleting a blog post
PREREQUISITE
l

You have Delete permission on the blog’s Standard Permissions screen. To delete
a blog post from the website, you must be logged in.

1. In the Workarea, go to the blog folder. (From the website, log in, open the menu
for the blog, choose Properties and then choose the post.)
2. From the menu, choose Delete > Posts. The Delete Contents screen appears.
3. Click the check box next to each post you want to delete. To select all posts, click
the check box next to Title.
4. Click Delete Contents (

). A dialog box asks you to confirm.

5. Click OK.

Adding or editing blog posts with Windows Live Writer
TM

Ektron authors and membership users can use Windows Live Writer to add and edit
blog posts to your site. If users have the proper permissions, they upload images and
attach files from their system. For additional Windows Live Writer help from Microsoft,
click hereand sign into the Microsoft website.
NOTE: Ektron only supports the 2010 version of Live Writer.
If you have previously set up Windows Live Writer, choose Weblog > Edit Weblog
Settings. Then, skip to step 4.
To set up Windows Live Writer to work with your Ektron blog:
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1. Go to Windows Essentials: Other Programsand download Windows Live Writer.
2. Begin to install Live Writer. The Welcome window appears. Click Next.

3. In the What blog service do you use? window, select Other services, then click
Next.
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4. In the Add a blog account window, enter the following information:
l Web address of your blog. the page that contains the blog. For example,
http://<your site>/CMS400Min/blogs.aspx.
l

Username. your username to log on to the Ektron site.

l

Password. your password to log on to the Ektron site.

l

Set Proxy.... if needed, edit the proxy settings, then click Next.
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5. In the Select blog type window, from the Type of weblog that you are using
drop-down, choose Custom (Metaweblog API).
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6. In the Remote posting web address for your blog field, enter the path to the
site's xmlrpc.aspx file. The default location is http://site
root/Workarea/Blogs/xmlrpc.aspx. Then click Next.
7. The Select Blog window appears. Select the Ektron blog that you will edit with Live
Writer, then click Next.
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8. Windows Live Writer is installed.
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Subscribing or unsubscribing to a blog or blog post
Logged-in site users and Membership users can subscribe to a blog or a blog post.
l

By subscribing to a blog, you are notified whenever posts are added to it.

l

By subscribing to a blog post, you are notified whenever comments are added to a
post.

If you want to stop receiving notices, you can unsubscribe.
To subscribe to a blog or blog post:
1. Go to the blog on the site.
2. Click Subscribe (

). The Subscribe/Unsubscribe screen appears.

3. Select the Notification Type.
4. Click Add Subscription.
To unsubscribe to a blog or blog post:
1. Go to the blog on the site.
2. Click Subscribe (

). The Subscribe/Unsubscribe screen appears.

3. Select a Notification Type.
4. Check the Unsubscribe check box.
5. Click Update Subscription.
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Working with calendars
Web Calendars keep site visitors informed about upcoming events. Any authorized user
can add events to a calendar. Ektron has System, User, and Group calendars. The
calendar type determines where events are stored in the database, and what
permissions are needed to edit them. See also: WebCalendar server control.
System Calendar

User Calendar

Group Calendar

Where events
are stored

Workarea >
Content >
Calendar Folder

Community User
Calendar

Community Group
Calendar

Where events
are added or
edited

The Web page or
Workarea folder

The community
user’s profile Web
page

The community
group’s Web page

Where
permissions
are set

Folder
Permissions

Community Users
and Colleagues

Community Group
Membership

How it appears
on a Web page
For more
information,
see

Web page with Server Control or widget

Adding a calendar
on the next page

Creating a calendar
in my profile on
page 1000

Creating a calendar
in a group on
page 1002

When first viewed, a Web calendar shows the current day, month, or week, whether
you are on a Web page or in the Workarea. After logging in, you can add or edit
calendar eventsif you have permission to do so.
l

To select the Day, Week or Month View, click a button in the top right corner to
choose the view. (The WebCalendar server control's DisplayType property
determines the appearance of these buttons.)
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l

To select the previous or next period, click the left or right arrow to move the
calendar forward or backward one period of time.

l

To choose a date, click the arrow to open the Date popup. Then, click a date to
show on your calendar.

Adding a calendar
PREREQUISITE

To add, edit or delete a calendar, you must be a member of the
Administrators Group or have permission to Add, Edit, and Delete folders
on the Advanced Permissions screen. See also: Managing folder and content
permissions on page 168.
To create a system calendar:
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1. In the Workarea, click Content > the folder to which you want to add a calendar.
2. Click New > Calendar. The Add Calendar screen appears.

3. Enter the Calendar Name.
4. Enter the Description.
5. Enter a Style Sheet. Specify a style sheet that defines styles that may be applied
to event content in this folder. The style sheet must reside in the site root folder.
Or, leave this field blank to inherit the parent folder’s style sheet. The style sheet
populates the style drop-down list within the editor.

NOTE: This style sheet affects event content being edited. It does not
necessarily affect the content’s appearance on your website. To set or edit the
style sheet that determines your Web pages’ appearance, open the page’s Web
form and place a <link rel=”stylesheet”... tag within its <HEAD> tags. If
desired, you can identify the same style sheet in both locations. To include userselectable styles, they must be generic classes.
6. Set the Content Searchable value. See also: Making content searchable on
page 371
l Calendar Properties Template Tab
o Inherit Parent Template Configuration. Check this box to inherit the
template from the parent content folder. Or, do not check this box and
specify one or more templates.
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o

l

Page Templates. Specify one or more templates for Calendar events in
this folder. This folder’s content uses the specified template when
appearing on your website.

Other Calendar Properties Tabs
o Taxonomy tab. If you want this folder to inherit taxonomy
configurations from the parent folder, check Inherit Parent Taxonomy
Configuration. If you uncheck Inherit Parent Taxonomy
Configuration, you can then select taxonomies that can be applied to
content in this folder. If you want all content in this folder to be assigned
at least one taxonomy category, check Required at least one category
selection. See also: Organizing content with taxonomies on page 1357.
o

Flagging tab. Check this box if content in this folder inherits a flagging
definition from its parent folder. If you do not check the box, use the dropdown list to apply a flagging definition to content in this folder. See also:
Defining flags for content on page 1717, Assigning a flagging definition to
a folder on page 1719

o

Metadata tab. See Working with Metadata on page 822.

o

Web Alerts tab. See Assigning a Web Alert to a folder or content on
page 1496.

o

Breadcrumb tab. See Creating a sitemap breadcrumb trail on page 1432

7. Click Add Calendar. Note that the system calendar icon is unique (

).

After creating a calendar, you may add events.

Adding system calendar events
PREREQUISITE

You logged into Ektron and have edit permission for the calendar. Calendars
have the same permission and workflow settings as folders. See also:
Managing folder and content permissions on page 168,Approving content for
publication on page 749.
To add or edit a system calendar event:
1. Go to your calendar from the Web page containing it or the Workarea > Content
tab.
2. Click any day. (You can also click New > Add Calendar Event.) The Edit Event
screen appears.
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l

Enter the event title into the Title text box. “Company Picnic” for example.
The title appears on the calendar and in the pop-up information. To customize
this pop-up, see Working with calendars on page 991.

l

Enter the Location.

l

Enter the Description.

l

Specify the Start time and the All day options at the bottom of the Edit
Appointment page.

o

o

For start date, click Calendar (

) and set the start date.

For start time, enter the time text or click Clock (

).

Ektron stores event times as UTC (also known as Greenwich Mean Time—
GMT). For members or visitors that login, events show in the member’s time
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zone. For visitors that do not log in, events show in the Web server’s time
zone. For information about setting the user time zone, see Time zone field on
page 1577.
3. If appropriate, set recurrences. Appointments can recur daily, weekly, monthly, or
yearly. They can be spaced at various intervals and have a finite duration or recur
indefinitely. For example, you can set a recurring event for each Friday for the next
5 weeks.

When editing a recurring event, you are prompted to edit either the single
occurrence or the series.
4. Select a Taxonomy category. A typical calendar taxonomy screens events that a
site visitor might wish to see. For example, a college sports website shows all
sports, but a visitor only wants football games. To show only events related a
specific category on your calendar page, use a Taxonomy. See also: Using
taxonomy with Web calendars on page 1011.
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5. If desired, set Metadata for the event. See also: Working with Metadata on
page 822.
6. If desired, set the event alias. See also: Creating user-friendly URLs with aliasing
on page 1399
7. Click Save. The event appears on the calendar.

Exporting appointments to other calendars using iCal
You can export Web calendar appointments to any calendar that accepts an iCalendar
*.ics file. This is helpful if you want to track appointments on your Web calendar and a
mobile device calendar, for example.
NOTE: Ektron uses accepted standards for producing the iCalendar ics file. This
does not mean that all calendar types use the recurring appointment data properly.
Contact your calendar vendor if iCalendar support is needed.
IMPORTANT: Changes to recurring appointments do not work correctly for iCal files
used in Microsoft Office 2003.
PREREQUISITES

You are logged into the Ektron website and are a member of the
Administrators group or assigned the Calendar-Admin role
To export a Web Calendar event to another calendar:
1. Hover over an event on the Web calendar.

2. Click download. The File Download screen appears.
3. Click Save and save to a folder on your computer.
4. After the file is downloaded, click Open Folder.
5. Double click the .ics file you saved. When you do, the appointment setting page for
your default calendar opens. For example, this file name was event-997.ics.
NOTE: If you are adding the appointment to a calendar other than the default
calendar on your PC, first open that calendar and import or add the *.ics file to
it. For example,when using a Google Calendar, click Add then choose import.
See your calendar's instructions for importing iCalendar appointments.
6. Save and close this appointment. It will now appear on your calendar.
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Showing calendar events on activity streams
A new or updated Calendar event appears on a Community Activity Stream if the
following notification settings are checked on a user's or Membership Group's Profile >
Activities tab. For more information, see Notification activities and recipients on
page 1666.
l

Add Calendar Event

l

Update Calendar Event

l

Add Calendar Event

l

Update Group Calendar Event

Viewing system calendar properties
The Calendar properties screen lets you set permissions as well as modify the
calendar’s metadata, taxonomy, templates, flagging, Web Alerts and Breadcrumbs. To
view a system calendar's properties:
1. From the Workarea, choose Content.
2. Click the calendar you wish to view. The View Events screen appears.
3. Click View > Properties. The View Properties screen appears. (To edit the
properties, click Edit Properties.)
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To learn more about the properties, see Adding a calendar on page 992

Using community Web calendars
Both community group and community user profile pages can display a Web Calendar.
The following example shows a user profile page with a personal calendar.

Ektron Reference

999

Managing content

The calendar on a personal community page obeys the same community rules as other
features in the community. You can restrict the visibility of your events to only
colleagues or make them public.

Creating a calendar in my profile
You can place a Web calendar on a user profile to track personal appointments. The
following code places a WebCalendar server control on a User Profile template. You
must set sourceType and dynamicParameter as shown.
<CMS:WebCalendar ID="WebCalendar1" runat="server" >
<DataSource>
<CMS:CalendarDataSource sourceType="UserCalendar" dynamicParameter="id” >
</DataSource>
</CMS:WebCalendar>

Creating the user calendar in the database
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To use a personal calendar, you must add it to the database. Each user needs to do this
when they decide to use a calendar on their profile.
To add a user calendar to the database:
1. Log in to your website.
2. Go to your personal Web page or your profile.
3. Click Edit Profile. In this example, Edit Profile is on a personal profile page of
the eIntranet Starter Site.

Alternatively, you can log into the Workarea then go to Settings > Users > User
Profile.
4. When the Edit Profile window appears, click the Custom tab.
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5. Check Create User Calendarto create a user calendar in the database.

WARNING! After you save this profile, you cannot later uncheck this option.
6. Click Save. Your calendar appears on your profile page.

Creating a calendar in a group
You can add a Web Calendar to any Ektron community group. The following is a sample
calendar on a group page.

The calendar on a community group page obeys the same community rules as other
community features. You can restrict the visibility of group events to group members,
or make the calendar public.
NOTE: An alternate way to use group calendars is using the WebCalendar widget on
a group dashboard. See Adding a calendar to the WebCalendar widget on page 1004
for more information.
The following example provides the code for placing a WebCalendar server control on a
Group Profile template. You must set sourceType and dynamicParameter as shown
for CalendarDataSource.
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<CMS:WebCalendar ID="WebCalendar1" runat="server">
<DataSource>
<CMS:CalendarDataSource sourceType="GroupCalendar" dynamicParameter="id”/>
</DataSource>
</CMS:WebCalendar>

To use a group calendar, you must add it to the database. Each group needs to do this
once when they decide to have a calendar for their group.
To add a group calendar to the database:
1. Log in to your website.
2. Go to your group Web page.
3. Choose Manage > Edit Group.
4. When the Edit Group window appears, check the Create Group Calendar
checkbox to create a group calendar in the database.
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WARNING! After you save this profile, you cannot later uncheck this option.
5. Click Save. A group calendar exists in the database and can appear on the group
page.

Adding a calendar to the WebCalendar widget
The WebCalendar widget can display a combination of system, user, and group
calendars. You place a Web calendar on a Web page by using either a WebCalendar
server control or a WebCalendar widget. A WebCalendar widget is an easy way to add a
calendar to a PageBuilder page or Smart Desktop (See also: Managing content from the
Smart Desktop on page 668.)

Adding a system calendar to a WebCalendar widget
A system calendar is one that is managed within Workarea. For more information, see
Adding a calendar on page 992.
To add a system calendar to a WebCalendar widget:
1. Click Edit ( ) in the upper right corner of the WebCalendar widget.
2. Click the Folder tab.
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3. Locate the calendar to add. Note its unique icon.

4. Click Save. The calendar is added to the Selected Calendars list.

Adding a user calendar to a WebCalendar widget

Ektron Reference

1005

Managing content

1. Click Edit ( ) in the upper right corner of the WebCalendar widget.
2. Click the User tab.

3. Specify a user that has a calendar set up and click Search Users to find a person's
calendar (that is available to you).
4. Click Add Calendar (

) to add the calendar to the Calendar widget list.

5. You can choose colors for events from each user's calendar to differentiate each
use on your calendar. AutoSelect uses the next available color.
6. To remove any calendar, click Remove ( ).
7. Click Save.

Adding a group calendar to a WebCalendar widget
1. Click Edit ( ) in the upper right corner of the WebCalendar widget.
2. Click the Group tab.
3. Search for other group calendars by entering a group name and clicking Search
Groups.
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4. Click Add Calendar ( ) next to a calendar you want to add. All chosen group
calendars appear on the Selected Calendars tab.

5. You can choose colors for events from each user's calendar to differentiate each
use on your calendar. AutoSelect uses the next available color.
6. To remove any calendar, click Remove ( ).
7. Click Save.

Combining Web calendars (mashups)
A Calendar Mashup combines events from different calendars into one calendar view.
As an example, you could combine company meetings from one calendar with a special
seminar series from another.

Combining calendars using the dynamic method
The dynamic method uses the URL query string parameter to specify a calendar. This
method maintains one calendar template that can display many calendars on your site.
The following example uses the EktronTech starter site. The exercise combines
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calendars using a URL whose query parameter is cal2:
http://<servername>/ektrontech/calendar.aspx?cal2=376
To combine 2 calendars:
1. Create 2 calendars in the Workarea. See also: Adding a calendar on page 992
2. Determine each calendar's ID number by examining its properties. This example
uses calendar folder IDs 88 and 376.

3. Edit the calendar.aspx template that contains the Web calendar. In this example,
the template is located on the Web server in this folder:
d:\inetpub\wwwroot\EktronTech.
4. Add 2 CalendarDataSource tags: one for a static calendar, the other for a
dynamic calendar.
l In the first (static) CalendarDataSource property, add defaultId = “88”.
l

In the second (dynamic) CalendarDataSource property, add queryParam =
“cal2”. This lets you display any calendar referenced in the query string.

5. In both CalendarDataSource tags, set the sourceType = “SystemCalendar”
property. The finished code looks like this.
<cms:WebCalendar ID="webcalendar" runat="server"
DynamicParameter="calendar_id" DisplayType="All" SuppressWrapperTags="True">
<cms:WebCalendar ID="webcalendar" runat="server"
DynamicParameter="calendar_id" DisplayType="All" SuppressWrapperTags="True">
<DataSource>
<cms:CalendarDataSource defaultId="88" sourceType="SystemCalendar"/>
<cms:CalendarDataSource queryParam="cal2" sourceType="SystemCalendar"/>
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</DataSource>
</cms:WebCalendar>

6. Save calendar.aspx.
7. Enter the following URL to see the calendar:
http://<servername>/ektrontech/calendar.aspx?cal2=376
You see the combined calendar events. If there are too many events to show on a
date, clock more... to see all events.

Combining calendars using the static method
The static method of combining calendars "hard codes" calendar id numbers instead of
using a query string parameter. This method creates a calendar whose event source
does not change dynamically.
1. Create 2 calendar folders in the Workarea. See also: Adding a calendar on
page 992
2. Determine the ID number for each calendar by examining the Calendar Folder
properties.
3. Edit the calendar.aspx template.
4. In the CalendarDataSource properties, add defaultId values for each calendar as
shown.
<cms:WebCalendar ID="webcalendar" runat="server"
DynamicParameter="calendar_id" DisplayType="All"
SuppressWrapperTags="True">
<DataSource>
<cms:CalendarDataSource defaultId="88" sourceType="SystemCalendar"/>
<cms:CalendarDataSource defaultId="376" sourceType="SystemCalendar"/>
</DataSource>

In this example, events for calendars 88 and 376 are combined on the
calendar.aspx page.

Combining a static mashup and dynamic parameter

Ektron Reference

1009

Managing content

The following example displays a calendar according to a dynamic parameter in the
query string. If the query string parameter is not used, the calendar shows a mashup of
3 calendars. The following example assumes you created 3 calendars with IDs 88, 374,
and 376.
This is the code for the events.aspx template.
<cms:WebCalendar ID="webcalendar1" runat="server">
<DataSource>
<cms:CalendarDataSource sourceType="SystemCalendar" >
</cms:CalendarDataSource>
</DataSource>
</cms:WebCalendar>

This is the code-behind which tests for a query parameter. If none is found, display a
static calendar mashup.
events.aspx.vb
‘This code is located in the Page_Load event
Protected Sub Page_Load(ByVal sender As Object,
ByVal e As System.EventArgs) Handles Me.Load
‘Create a CalendarDataSource instance and set the sourceType and queryParam
Dim cds As New Ektron.Cms.Controls.CalendarDataSource()
cds.queryParam = "calid"
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar
‘Add the DataSource object
webcalendar1.DataSource.Add(cds)
‘If the queryString is used, show that calendar,
otherwise show the following mashup
If (Request.QueryString("calid") = String.Empty) Then
‘Create three CalendarDataSource instances and
add the sourceType and defaultId for each.
cds = New Ektron.Cms.Controls.CalendarDataSource()
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar
webcalendar1.DataSource.Add(cds)
cds = New Ektron.Cms.Controls.CalendarDataSource()
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar
cds.defaultId = 88
webcalendar1.DataSource.Add(cds)
cds = New Ektron.Cms.Controls.CalendarDataSource()
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar
cds.defaultId = 376
webcalendar1.DataSource.Add(cds)
End If
‘Fill and return
webcalendar1.Fill()
End Sub

events.aspx.cs
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//This code is located in the Page_Load event
protected void Page_Load(object sender, System.EventArgs e)
{
//Create a CalendarDataSource instance and set the sourceType and queryParam
Ektron.Cms.Controls.CalendarDataSource cds =
new Ektron.Cms.Controls.CalendarDataSource();
cds.queryParam = "calid";
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar;
//Add the DataSource object
webcalendar1.DataSource.Add(cds);
//If the queryString is used, show that calendar,
//otherwise show the following mashup
if ((Request.QueryString("calid") == string.Empty)) {
//Create three CalendarDataSource instances and add the
//sourceType and defaultId for each.
cds = new Ektron.Cms.Controls.CalendarDataSource();
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar;
webcalendar1.DataSource.Add(cds);
cds = new Ektron.Cms.Controls.CalendarDataSource();
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar;
cds.defaultId = 88;
webcalendar1.DataSource.Add(cds);
cds = new Ektron.Cms.Controls.CalendarDataSource();
cds.sourceType = Ektron.Cms.Controls.SourceType.SystemCalendar;
cds.defaultId = 376;
webcalendar1.DataSource.Add(cds);
}
//Fill and return
webcalendar1.Fill();
}

To see a single calendar such as 376, use this URL:
http://<server>/cms400developer/events.aspx?calid=376

To see all calendars together, do not use the query string parameter.
http://<server>/cms400developer/events.aspx

Using taxonomy with Web calendars
You can use taxonomy categories to filter calendar events. Calendar categories could
include meeting rooms, audience, or whether the event should appear on a special
public calendar. The following example organizes events based on locations and
audience. See also: Creating a taxonomy and its associated categories on page 1359
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After you create a taxonomy, you can assign its categories to events.
Use a CategoryID value in the CalendarDataSource to filter events according to
taxonomy categories. In the following example, the calendar shows events for the
Training Center (category 123) or Administrators (category 124).
<cms:WebCalendarID="webcalendar"runat="server">
<DataSource>
<cms:CalendarDataSourcedefaultId="726"sourceType="SystemCalendar">
<CMS:CategoryIDcategoryId="123"/>
<CMS:CategoryIDcategoryId="124"/>
</cms:CalendarDataSource>
</DataSource>
</cms:WebCalendar>

By using an ID of a higher category in the taxonomy tree, you can show all events
under it. For example, this taxonomy has 2 higher level branches with ID 100 and 200.

If you set the category ID to 100, you see any events associated with categories 100,
111 or 112.
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Working with discussion boards
The discussion board feature provides topic discussions on your website. A site or
membership user with Add Topic permission creates a topic and posts a starter
question. Site visitors can then reply. Ektron supports an unlimited number of
discussion boards. A discussion board consists of a hierarchy. The following example
shows the hierarchy with sample data, to illustrate how each element is used.

On the website, if you click a discussion forum, its topics appear. If you click a topic, its
posts appear.
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In the Workarea, a discussion board appears as a top-level folder (

) in the folder

structure. Forums appears under them. If you click a discussion board, its subjects and
forums appear in the right panel.

Administering discussion boards in the Workarea
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To implement a discussion board into your website, place a Forum server control on a
Web page. Then, select a discussion board. All subjects and forums within that board
appear on the Web page. You cannot selectively suppress subjects or forums. Keep this
in mind when determining the contents of a discussion board.
To view a discussion board, select it from the folders display. When viewing the board,
you see all of its forums. Click any forum to see its details.
An administrator determines the following discussion board features.
l

The subjects being discussed

l

A starter post that initiates a discussion

l

If users must sign in before posting to the forum

l

If a post appears as soon as someone submits it, or must be approved first.
o If a post requires approval
n you can edit or delete it before it appears
n

authorized users can edit, delete, or reply to a post from the Workarea

Creating a discussion board
1. From the Workarea’s Content tab, go to the folder in which to place the discussion
board.
2. Click New > discussion board. (You also can hover the cursor over the folder,
right click the mouse, and select Add discussion board.) The Add a discussion
board to folder screen appears.
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3. Complete the properties.
IMPORTANT: Some fields appear only when editing a discussion board’s
properties.
l

Name (Enter, Edit). Enter the name of the discussion board. This text
describes the board within the Workarea and on your website.

l

Title (Enter, Edit). Enter the title of the board.

l

Accepted HTML (Enter, Edit). A comma-delimited list of HTML tags allowed in
the eWebEdit400 editor. When left blank, all tags are available. Site visitors
posting to the forum can apply these tags to content if the forum editor is
eWebEdit400. See Also: Using the eWebEdit400 editor on page 2065. The
default list is: br, hr, b, i, u, a, div, ol, ul, li, blockquote, img,
span, p, em, strong, font, pre, h1, h2, h3, h4, h5, h6, address,
embed
NOTE: If you want to allow users to insert WMV files into their posts, add
the embed tag.
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l

Accepted Extensions (Edit only). A comma-delimited list of file extensions
that can be uploaded. You can enter the extension with or without the period
(.). Use a comma to separate each extension.
The list appears at the bottom of the editor screen, notifying the person
entering a post which file types can be attached. The default list is: bmp,
conf, doc, gif, jpe, jpg, jpeg, png

l

Max File Size (Edit only). The maximum size of a file, in bytes, that a user
can upload. The default is 200000 bytes (.19 megabytes).

l

CSS Theme (Enter, Edit). Choose a style sheet to determine the appearance
of the discussion board on your website. Select any theme available in the CSS
Theme drop-down. The default is
siteroot/Workarea/threadeddisc/themes/standard.css. Alternatively,
enter a path below the site root folder to your custom CSS file in the path box.
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NOTE: If you edit a CSS file, you should save it under a new name. This
prevents your changes from being overwritten during an upgrade.
l

Require Authentication (Enter, Edit).
Effect of this Field on the Website
Check this box if a site visitor must sign in to post to the discussion board. If
the user cannot access a login screen, the user cannot post. If this box is
unchecked, site visitors can post without signing in.
Effect of this Field in the Workarea
If this field is checked, only users with Add Topic or Edit Topic permissions for
the discussion board can create or reply to posts. See also: Modifying
discussion board permissions on page 1019.

l

Lock (Edit only). Check this box if you want to prevent all posting to this
discussion board. You can do this temporarily or permanently. If a Board is
locked, only Administrator user group members can post to it, or edit or delete
posts. Those users can post from the website or the Workarea. You can
alternatively lock any forum underneath this Board via the forum properties
screen.

l

Page Template (Enter, Edit). Lets you specify a template for the forum. If
you do not specify a template, the search results do not link properly to the
forum. See also: Working with templates on page 838. To preview what the
forum looks like within the selected template, click preview ( ) to the right.

l

Taxonomy: Require category selection (Edit only). If you want all topics
in this discussion board to be assigned a taxonomy category, check Require
category selection. If you do, a signed-in user must select a taxonomy
category when creating a topic. This checkbox has no effect when creating
new topics within the Workarea.
l Taxonomy. Select a taxonomy whose categories will be assigned to
forum topics. The Taxonomies are applied on the Taxonomy tab. The
discussion board’s taxonomy represents another way to organize the
forum’s posts.
Effect of Assigning Taxonomy Categories to a Topic
When a discussion board server control is placed on a Web page, its
display includes a taxonomy icon.
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When a site visitor clicks this icon, taxonomy categories are displayed.
When the user selects a category, the user sees its subcategories followed
by all forum posts assigned to that category. The following example shows
a discussion board’s posts organized by taxonomy category.

l

Subjects Tab (Enter, Edit). You must create at least one subject for each
discussion board. In the following sample forum, Support Tickets and
Support Knowledge Base are subjects.

NOTE: You can also add a subject by selecting a discussion board then
selecting New > Subjects.
l

Subject Sort Order.
Subjects are sorted alphabetically unless you use the Sort Order field.
The Sort Order field accepts a number and uses it to sort a discussion
board's subjects. The lowest numbers appear near the top of the page.
To access the Sort Order field:
1. Save the discussion board.
2. Click the discussion board in the Workarea.
3. Click View > Properties.
4. Click the Subjects tab.
5. Modify the Sort Order field as needed.

l
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Terms & Conditions Tab (Edit only). Add Terms & Conditions for using the
discussion board. By entering text in this box and saving, you activate the
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Terms and Conditions feature. See also: Defining terms and conditions on
page 1023

Editing a discussion board
1. Click the Workarea’s Content tab.
2. From the folder structure in the left frame, go to the discussion board.
3. Click View > Properties.
4. Click Edit Properties. To learn about the fields, see Creating a discussion board
on page 1015.
5. Update the screen as needed.
6. Click Save Board Properties.

Deleting a discussion board
When you delete a discussion board, its subjects, forums, and posts are also deleted.
Once deleted, they cannot be retrieved.
1. Click the Workarea’s Content tab.
2. From the folder structure in the left frame, go to the discussion board.
3. Click Delete > This folder. A confirmation message appears.
4. Click OK.

Modifying discussion board permissions
Discussion boards have a Permissions Screen that lets you determine functions users
can perform. (See Managing folder and content permissions on page 168.) Because
discussion boards have different functions than folders, the Permissions Screen is
slightly different from regular folders.
In addition, each Forum has permission settings. By default, a forum inherits
permissions from its parent discussion board, but you can break inheritance and
customize forum permissions.
To access a discussion board’s Permissions Screen, go to and click the board. Then,
click View > Permissions.
PREREQUISITE

Only Administrators group members can access the discussion board
Permissions Screen.
The following example shows a discussion board Permissions Screen for regular users.
Membership users have fewer permissions.
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When you create a discussion board, it inherits permissions from the parent folder. But
from then on, it is disconnected from the parent folder’s Permissions Screen, so
subsequent changes to the parent folder’s permissions have no effect on discussion
board permissions.
The Permissions Screen inherits the following initial values from the parent folder
(Parent Folder Permission—Discussion Board Permission):

1020

l

Read only. Read only

l

Edit. Edit Topic

l

Add. Add Topic

l

Delete. Delete Topic

l

Add Folders. Add Forum

l

Edit Folders. Edit Forum
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l

Delete Folders. Delete Forum
NOTE: Because there are no corresponding permissions for the discussion
board’s Moderate and Post/reply permissions, their initial value is blank.

For example, if user JSmith has permission to perform all functions for a folder, and a
discussion board is created in that folder, JSmith initially receives the default
permissions for the discussion board. You can modify these permissions.
The following table lists permissions you can grant to regular users. A subset of these
permissions can be granted to membership users.

Permission

Allows user to

Can be
assigned to
membership
users

Read only

View forums and posts; cannot submit a post

Yes

Edit Topic

Edit a topic’s title (Editing a topic title on
page 1037)

No

Add Topic

Add new topics (Adding a topic to a forum on
page 1035)

Yes

Delete Topic

Delete a topic (Deleting a topic on page 1039)

No

Post/Reply

Post a new topic or reply to an existing one,
either from the Workarea or the site. (Adding a
topic to a forum on page 1035 and Replying to a
post on page 1039)

Yes

Moderate

Approve and delete posts and topics. Also,
receive notifications when a post is reported
using the report post feature; only applicable if
the forum’s properties field Moderate
Comments is checked. (Moderating from the
control panel on page 1048)

Yes

NOTE: Everyone who has Moderate
permission will receive notifications when a
post is reported. See also: Setting up post
reporting on page 1049
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Permission

Allows user to

Can be
assigned to
membership
users

Add Forum

Create a new forum (Creating a forum on
page 1026)

No

Edit Forum

Edit a forum (Editing a forum on page 1027)

No

Delete Forum

Delete a forum (Deleting a forum on page 1028)

No

Modifying discussion board permissions for membership users
By default, membership users are assigned these permissions:
l

Read only

l

Add Topic

l

Post Reply

They cannot be granted Edit or Delete topic nor Add, Edit, or Delete forum. However, if
a membership user creates a new topic, that user can delete it.
To modify a membership user's default permissions:
1. Go to and click the discussion board so it appears in the Workarea.
2. Click View > Permissions.
3. Click the User Type drop-down field and choose Membership Users.
4. The View Permissions for Board screen appears.
5. Add new member users and groups, remove existing ones, or change permissions.

Granting discussion board permissions
1. Go to and click the discussion board so it appears in the Workarea.
2. Click View > Permissions.
3. Click Add Permissions. All users and groups who are not currently assigned
permissions appear.
4. Click any users or groups then Save. The Add Permission screen appears with the
selected users or groups.
5. Assign appropriate standard and advanced permissions.
6. Click Save.

Editing discussion board permissions
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1. Go to and click the discussion board so it appears in the Workarea.
2. Click View > Permissions.
3. Click the user or group whose permissions you want to edit. The Edit Permissions
Screen appears.
4. Change the settings as appropriate.
5. Click Update.

Removing discussion board permissions
1. Go to and click the discussion board.
2. Click View > Permissions.
3. Click Delete (

).

4. Select a user or group whose permissions you want to remove.
5. Click Remove Permissions for Folder.
After you remove a user, discussion boards do not appear in that user's Workarea.

Changing page size for discussion boards
You can change the number of topics or posts shown on a page by changing the ek_
PageSize value in the siteroot\web.config file.
This value affects other Ektron pages.

Defining terms and conditions
A discussion board's Terms & Conditions convey your expectations to its users. If you
add Terms & Conditions, anyone posting to the board sees the following screen the first
time a post or reply is sent to a forum. Users can only post after agreeing to the Terms
& Conditions.
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NOTE: You cannot add Terms & Conditions when creating a discussion board—you
can only add them after a discussion board has been created.
To add terms and conditions text to a discussion board:
1. Workarea Content tab > go to the discussion board to which you want to add
terms and conditions.
2. Click View > Properties.
3. Click Edit Properties.
4. Click the Terms & Conditions tab.
5. Add the terms and conditions text.
6. Click Save Board Properties.

Working with subjects
This section explains how to create and edit discussion board subjects.

Creating a subject
1. Workarea Content tab > go to the discussion board to which you want to add a
subject.
2. Click New > Subject.
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3. Enter a subject name and sort order. See Also: Subject Sort Order. on page 1018

4. Click Save Board Subject.

Editing subject name and sort order
1. Workarea Content tab > go to the discussion board that contains the subjects.
2. Click View > Properties.
3. Click the Subjects tab.
4. Click the subject that you want to edit. The current subject name and sort order
appear on a new screen. Edit as needed. See Also: Subject Sort Order. on
page 1018

5. Click Save Board Subject.

Working with forums
A forum is a thread within a discussion board. For each forum, you define:
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l

name and description

l

whether its posts must be approved before appearing on your website

l

if it accepts new posts

l

its sort order, which determines the sequence on the Web page within its subject

l

its subject

Creating a forum
PREREQUISITE
l

At least one subject.

l

You are a member of the Administrators group or have Add Forum
permission for a discussion board

1. Workarea Content tab > go to the discussion board for which you want to create a
forum.
2. Select a discussion board.
3. Click New > Discussion Forum. The Add a Discussion Forum to Board
screen appears.

4. Complete the fields.
l Name. Enter the name of the discussion forum. The name identifies the forum
in the left side of the Workarea, next to a forum icon ( ). The icon
distinguishes it from content and blog folders. The name also appears on the
website.
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l

Description. Enter a more detailed description of the forum. The description
appears in the Workarea, as illustrated above.

l

Moderate Comments. Check this box if comments require approval before
appearing on the website, and if you want every comment to be reported to all
forum moderators. See also: Setting up post reporting on page 1049. Only
users with Moderate permission can approve comments, thereby allowing
them to be published.
The Smart Desktop has a Forum Topics and Posts category, which indicates
how many posts currently require your approval.

l

Lock Forum. Check this box to prevent all posting to this forum. You can do
this temporarily or permanently. If a forum is locked, only Administrators
group members can post to it, or edit or delete posts. Those users can perform
those tasks from the website or the Workarea.
A discussion board can also be locked. If a board is locked, a message on this
screen indicates that. In that case, no posting is allowed to this forum
regardless of this setting.

l

Sort Order. Enter a number if you want to arrange the sequence of forums
within the subject. If you do not, forums appear in alphabetical order within
subject. See Also: Subject Sort Order. on page 1018.

l

Subject. Enter the subject within which this forum will appear on the website.

5. Click Add Discussion Forum.

Editing a forum
PREREQUISITE
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l

You are a member of the Administrators group or have Edit Forum
permission for a discussion board

1. Click the Workarea’s Content tab.
2. From the folder structure in the left frame, click the discussion board that contains
the forum.
3. Click the forum.
4. Click View Properties (

)

5. Click Edit Forum Properties.
6. Update the screen as needed. See also: Name. Enter the name of the discussion
forum. The name identifies the forum in the left side of the Workarea, next to a
forum icon (). The icon distinguishes it from content and blog folders. The name
also appears on the website. on page 1026.
7. Click Save.

Deleting a forum
PREREQUISITE
l

You are a member of the Administrators group or have Delete Forum
permission for a discussion board

Authorized users can delete any forum. When you do, its topics and posts are also
deleted. Once deleted, they cannot be retrieved.
1. Workarea Content tab > go to the discussion board that contains the forum.
2. Click the forum.
3. Click Delete Forum (

). A message asks you to confirm.

4. Click OK.

Modifying forum permissions
You can use the discussion board permission features with any forum. See also:
Modifying discussion board permissions on page 1019.
1. Workarea Content tab > go to the discussion board that contains the forum.
2. Click the forum.
3. Click View Permissions (

). A Permissions Screen appears.

When you first view a forum’s Permissions Screen, you see a check box that lets
you maintain inheritance or break it. A forum initially inherits (that is, copies all
permissions from) its parent discussion board’s permission settings.
4. If you break inheritance by unchecking the Allow this object to inherit
permissions box, the forum Permissions Screens changes from view-only to edit.
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At this point, you can modify the permissions.
To later restore inheritance, check the box. When you do, the parent discussion
board’s permissions overwrite any forum-specific changes, and the forum reverts
to a read-only state. While inheritance is enabled, you can only make permission
changes at the discussion board level.

Blocking an IP address from a forum
If you are not using forum authentication and want to block a site visitor from posting,
use the Restricted IP feature.

NOTE: In addition to using Restricted IPs for a specific forum, you can access the
Restricted IP feature from the Workarea > Settings > Configuration >
Discussion Board > Restricted IPs. If you have more than one forum, this lets
you select the discussion boards to which the Restricted IPs are applied.

Adding an IP address to the restricted list
1. In the Workarea, click the Content tab.
2. Select a forum from the folder structure.
3. Click New > Restricted IP.
4. Enter the IP Address to be blocked in the Block IP field.
5. Click Save. A list of restricted IP addresses appear.

Editing a restricted IP address
1. In the Workarea, click the Content tab.
2. Select a forum from the folder structure.
3. Click View > Restricted IPs. A list of restricted IP addresses appears.
4. Click the IP address to be edited.
5. Click Edit.
6. Edit the IP address in the Block IP text box.
7. Click Save.

Deleting a restricted IP address
1. In the Workarea, click the Content tab.
2. Select a forum from the folder structure.
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3. Click View > Restricted IPs. A list of Restricted IP addresses appears.
4. Click the IP address to be deleted.
5. Click Delete ( ). A dialog asks if you are sure you want to delete the restricted IP
address.
6. Click OK to continue. A list of the remaining restricted IP addresses appear.

Ranking forum users
The User Ranking feature lets you recognize active forum contributors. You can create a
ranking system that moves a contributor to the next level after submitting a specified
number of posts. This is known as a ladder system, which lets forum contributors build
credibility. For example:
l

New User. 1 to 9 posts

l

Intermediate User. 10-19

l

Expert User. 20 and up

To each rank, you can assign an image that appears below the user’s name on any post.
The image also appears on a user’s forum profile.
IMPORTANT: Contributors must submit at least one post before you can move
them to the ladder system.

You can also create ranks that are independent of the ladder system. Such ranks have
no relationship to a contributor's number of posts. For example, after a forum user
acquires Ektron Developer Certification, the user is assigned the Ektron Developer rank.
You can move contributors from a non-ladder rank to the ladder system and vice versa.
Whether or not a contributor is in a ladder system, Ektron keeps a tally of posts. So, if a
user is moved into a ladder system at any time, he is assigned the correct rank.

Adding a user rank
To add a user rank:
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NOTE: You can also access the User Ranks screen from Workarea > Settings >
Configuration > Discussion Board > User Ranks. If you have more than one
forum, this screen lets you pick the discussion board to which a rank is assigned.
1. In the Workarea, click the Content tab.
2. Select a discussion board.
3. Click New > User Rank. The User Ranks screen appears.

l

Name. The name of the rank. For example, New User, Expert User,
Developer, or Associate.

l

Rank Image. Click Upload to select an image to upload. When uploaded, the
image path appears in the text box.
Images are optional. If you assign an image, it appears below the user’s name
on any post.

l

Minimum Number of Posts. Enter the number of posts it takes to reach this
rank. If the Starting Rank box is checked, the number is 1 and cannot be
changed.

l

Ladder System. Check this box if this rank is part of a ladder system. That is,
a rank based on the number of posts a user has submitted to this discussion
forum. If you uncheck Ladder System, Starting Rank and Number of
Posts become inactive, since they manage the ladder system.

l

Starting Rank. If you are using a ladder system, use this box to designate
this as the Starting Rank. A user is assigned to this rank after submitting the
first post. A discussion forum can only have one Starting Rank. Also, if this is
the Starting Rank, you cannot enter a minimum number of posts.

l

Applies To. If you accessed this screen from Workarea > Settings >
Configuration > Discussion Board > User Ranks, select the discussion
forum to which this rank applies.

4. Click Save.
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Deleting a user rank
1. In the Workarea, click the Content tab.
2. Select a discussion board.
3. Click View > User Ranks.
4. Select the rank you want to delete.
5. Click Delete (

).

6. Click OK to the confirmation message.

Changing a user’s rank
A user’s rank appears below the user name on any submitted post. To change a user’s
current rank, you must know what it is. To change a user’s rank:
1. In the Workarea, go to Content and go to the forum to which the user has posted.
2. Click View > User Ranks.
3. Select the rank that you want to move the user out of. The User Ranks screen
appears. The lower half shows all users assigned that rank.
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4. Click the user that you want to move out of the rank. The screen displays all ranks.
The current one is selected.

5. Click next to the desired rank.
6. Click Save.

Sending notifications of forum activity
The discussion board’s Email Notification feature generates email for registered users
when certain forum activities occur. For example, you want to be notified when a new
forum post is created. When that event occurs, registered users receive an email with a
link to the new post. After the messages are set up, you don’t need to do anything—
everything happens in the background.

Creating the email message
You can create an email message to be sent when these discussion board events occur.
l

a new post is added

l

a new topic is added

l

someone reports a post See also: Setting up post reporting on page 1049.

An editor lets you apply XHTML formatting the message. To create a message:
1. Workarea > Settings > Configuration > Discussion Boards > Messages.
2. Click Add.
3. Enter a title that describes the message.
4. At the Type field, select a message type: NewForumTopic, ReportForumPost,
or ForumPost.
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5. Select whether to make the email message a Default message.
6. Enter the message subject.
7. In the editor, enter the message text. See Including variables in the default
message below to include information about the about the new post or topic in the
message.
8. Click Save.

Including variables in the default message
Message text can include variables that retrieve information about a new post or topic.
The variables are surrounded by at signs (@). For example:
@appPosterDisplayName@ has created a thread you have subscribed to.

In the email, this text might read:
Alan Administrator has created a thread you have subscribed to.

Use these variables in discussion board email notifications.
l

@appTopicTitle@. The title of the topic.

l

@appTopicId@. The integer ID of the topic.

l

@appRecipientDisplayName@. The display name of the email recipient.

l

@appRecipientId@. The email recipient’s integer ID.

l

@appRecipientFirstName@. The first name of the email recipient.

l

@appRecipientLastName@. The last name of the email recipient.

l

@appRecipientEmail@. The email address of the email recipient.

l

@appHostUrl@. The host site’s URL.

l

@appForumUrl@. The forum’s URL.

l

@appPostMessage@. The text of the message posted to the discussion board.

l

@appPosterId@. The integer ID of the person who posted.

l

@appPosterDisplayName@. The display name of the person who posted.

l

@appPosterProfileUrl@. The profile URL of the person who posted.

l

@appPostUrl@. The URL of the post on the website.

Working with topics
A topic is a specific issue to be discussed in a forum. For example, in a medical research
forum, a topic might be New Cancer Treatments. Before creating a topic, you must
create a forum into which to place it. To view a topic from the Workarea:
1. Workarea > Content > Folders > select a discussion board.
2. Select a forum from the folder structure.
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3. The forum’s topics appear in the right frame. Click the one that you want to view.

4. The topic's posts appear.

If an option is underlined, you may perform it; if not, you cannot. For example, if a
post’s status is approved, approve is not underlined because the topic is already
approved.

Adding a topic to a forum
When you create a new topic, its first post is created from the topic message. If you add
a topic but are not a forum moderator, you only see the topic in the Workarea after it is
approved.
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NOTE: You also can create new topics from the OnTrek user interface (Support >
Support Forums).
To create a topic:
1. Workarea > Content > Folders > select a discussion board.
2. Select a forum.
3. Click New Topic. The Post New Topic screen appears.

l

Subject. Enter a short description of the topic. The topic subject appears on
the forum page.

l

Priority. Set the topic's priority, which determines where the topic appears in
the topic list on the site. The default setting is Normal.
o

Announcement. topic always appears at the top of the list. If a list has
more than one announcement, they are sorted by date with most recent
on the top. The announcement icon (
of the title.

o

Sticky. topic appears near the top of the list, just below announcements.
If a list has more than one sticky topic, they are sorted by date with most
recent on the top. The Sticky icon (
the title.

o
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) indicates its priority to the left of

Normal. topics follow Announcements and Sticky topics. The Normal icon
(

l

) indicates its priority to the left

) next to the topic indicates its priority.

Lock. Check this box to prevent posting of replies to this topic. You can do this
temporarily or permanently. If a topic is locked, only Administrator user group
members can post to it, or edit or delete posts. Those users can post from the
website or the Workarea.
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l

Message. Enter the topic text. This text appears on a new Web page after a
website visitor clicks a topic’s subject line.

4. If desired, enter a summary and a taxonomy category for the topic.
5. Click Save. The new topic appears in the list.

Editing a topic title
The only aspect of a topic that you can edit is its title.
1. In the Workarea, click the Content tab.
2. Select a discussion board, then select a forum. The forum’s topics appear in the
right frame.
3. Click the topic that you want to edit.
4. Click View Properties ( ). The Edit Topic screen appears.
5. Modify the title as needed.
6. Click Save.

Approving a topic in the Workarea
A topic needs approval if created by a user without moderate permissions for the
forum. Unapproved topics only appear in the forum upon approval. In the Workarea, an
unapproved topic is surrounded by a yellow border.
To approve a topic:
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1. In the Workarea, click the Content tab.
2. Select a discussion board, then select a forum. The forum’s topics appear in the
right frame.
3. Click the one that you want to approve. The View Topic screen appears.

4. Click approve.The topic is approved.

Setting a topic priority
In a forum, topics are sorted by priority, which determines a topic's sequence within the
topic list on the site. You can set a topic’s priority when you create it. A forum
moderator can change a topic’s priority. To set a topic property:
1. In the Workarea, click the Content tab.
2. Select a discussion board, then a forum from the folder structure.
3. Click a topic.
4. Click View Properties (

).

5. Click Click here to Edit the Properties of this Topic. The Edit topic screen
appears.
6. Choose a priority.
l Announcement. topic always appears at the top of the list. If a list has more
than one announcement, they are sorted by date with most recent on the top.
The Announcement icon (
) indicates its priority to the left of the title.
l

Sticky. topic appears near the top of the list, just below the announcements.
If a list has more than one sticky topic, they are sorted by date with most
recent on the top. The Sticky icon (
) indicates its priority to the left of the
title.

l

Normal. topics follow Announcements and Sticky topics.. The Normal icon (
) next to the topic indicates its priority.

7. Click Save.

Locking a topic
1038
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Locking a topic prevents users from posting a reply to it. For example, you might create
an announcement, but don’t want people to reply to it. Or, you might decide that a topic
has had enough discussion and want to stop further replies. If a topic is locked, only
Administrator user group members can post to it, or edit or delete posts from the
website or the Workarea. To lock a topic:
1. In the Workarea, click the Content tab.
2. Select a discussion board, then a forum from the folder structure.
3. Click a topic.
4. Click View Properties (

).

5. Click Click here to Edit the Properties of this Topic. The Edit topic screen
appears.
6. Check the Lock check box. (To unlock a topic, remove the check mark.)
7. Click Save.

Deleting a topic
When you delete a topic, its posts are deleted, too. When deleted, they cannot be
retrieved.
1. In the Workarea, click the Content tab.
2. Select a discussion board, then select a forum from the folder structure. The
forum’s topics appear in the right frame.
3. Click the topic that you want to delete. The View Topic screen appears.
4. Click Delete.
5. Click OK.

Working with posts
When a new topic is created, a first post is also created from the topic's message. Posts
to a topic are replies to the first post. You can search posts by clicking Search.

Replying to a post
l

From the website:
1. Go to the Web page that hosts the discussion board.
2. Click the forum of interest.
3. Click Add Reply.
4. Enter the text of your post.
5. Click Post. If a topic is moderated, a message appears stating that your reply
is pending moderator approval.
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l

From the Workarea:
1. In the Workarea, click the Content tab.
2. Go to a discussion board, then a forum. The forum’s topics appear in the right
frame.
3. Click the topic with the post to which you want to reply. The next screen, View
Topic, displays all posts to the selected topic.
4. Find the post to which you want to reply.
5. Click Reply.
6. In the Message field, enter the text of your post.
7. Click Save.

Editing a post
You can edit the text of a post but you cannot edit its title.
l

From the website
1. Go to the Web page that hosts the discussion board.
2. Click the forum of interest.
3. Find the topic you want to edit.
4. Click Edit.

l

From the Workarea
1. In the Workarea, click the Content tab.
2. Select a discussion board, then a forum from the folder structure.
3. The forum’s topics appear in the right frame. Click the one that has the post
that you want to edit. The View Topic screen displays all posts to the selected
topic.
4. Find the post that you want to edit and click edit under the post icon. The Edit
Reply screen appears.
5. Update the text as needed.
6. Click Save.

Quoting a post
Quoting a post means that your reply begins with the original post. You can then add
comments and even edit the quoted post. For example, you can include only the portion
on which you are commenting. To quote a post:
1. Go to the Web page that hosts the discussion board.
2. Click the forum of interest.
3. Click a topic.
4. Find the post you want to quote.
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5. Click Quote.
6. The editor appears with the quoted text at the top. You may edit the quoted post.
7. Add your comments below the quote.
8. Click Post.

Attaching images and files to a post
You can attach a file to a post. The Attached Files field displays allowed file types. The
list of file extensions and maximum file upload size are defined for the discussion board.
See Also: Creating a discussion board on page 1015.
1. Go to the Web page that hosts the discussion board.
2. Click the forum of interest.
3. Click a topic.
4. Create a new post or reply to an existing post.
5. Click Attachments. The Attachments window appears.

6. Click Browse... and go to the file that you want to attach. It must be one of the
allowed file types.
7. Click Open.
8. Click Attach to attach the file to the post. The file appears in the list of Current File
Attachments.
9. After you add all attachments, click Close.
To remove a file from the list of attachments:
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1. Click Attachments below the editor.
2. Highlight the attached item.
3. Click Remove.
4. Click Close.

Adding a video to a post
Administrator's note: By default, the Insert Embedded Video button does not appear
on the editor toolbar. To learn how to add it, see Modifying editor plug-ins on page 637.
1. Click Insert Embedded Video (
screen appears.

) in a forum post. The Insert Embedded Media

2. For details about embedding videos, see Editing in Ektron on page 605.
3. Click Insert. The video is embedded in the content.

Deleting a post
l

From the website
1. Go to the Web page that hosts the discussion board.
2. Click the forum of interest.
3. Find the topic you want to delete.
4. Click Delete.
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l

From the Workarea
1. In the Workarea, click the Content tab.
2. Select a discussion board, then a forum from the folder structure. The forum’s
topics appear in the right frame.
3. Click the one that has the post you want to delete. The View Topic screen
displays all posts to the selected topic.
4. Find the post that you want to delete and click delete under the post icon.

Moving a topic and its posts to another forum
To move a topic and its associated posts in one forum to another, the forum to which
you want to move the topic and posts must exist.
1. Access a page on your website that has a login button.
2. Sign in as a member of the Administrators group or as a Moderator of the board.
3. Go to a page with discussion board and select a forum.
4. Go to a topic page.
5. Click the Move to... drop-down list.
6. Select the topic to which you want to move.
7. Confirm that you want to move all posts.

Replacing words in a post
You can configure Ektron to replace unwanted words in a post, such as obscene or
indecent words that should not appear on your site. You also can fix commonly
misspelled words. For example, the can replace teh.
The Replace Words feature works with exact matches but does not append words. For
example, if you replace car with auto, the sentence I bought the car from the cartel
becomes I bought the auto from the cartel. Note that "cartel" did not change to
"autotel" even though "car" appears in "cartel."

Using regular expressions
If you want the Replace Words feature to modify words that contain a word you want to
replace, use Regular Expressions. A Regular Expression, often referred to as regex, is a
pattern of metacharacters placed around a word that describe a string. Used for string
manipulation, regex lets you detail a succinct description of a group of words without
having to detail each word in the group.
l

.. Matches any character, similar to a wildcard. For example, .ar matches any 3letter word ending in ar, such as car, bar, tar or far.

l

|. An or operator. For example, steak|stake finds steak or stake.
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l

[ ]. Matches one character between the brackets. For example, [rst] matches r, s
or t. [d-g] matches d, e, f, or g. Another example, [bc]ar matches bar and car. If
you need to match a dash (-), use it a the beginning or end of the group. For
example, [xyz-] or [-xyz].

l

[^ ]. Matches one character not in the group. For example, [^rst] matches any
character other than r, s or t. Another example, [^bc]ar does not match bar or car,
but does match tar and far.

l

^. Matches the beginning of any line. For example, ^[bc]ar matches bar or car, but
only at the beginning of a line.

l

$. Matches the end of any line. For example, ^[bc]ar matches bar or car, but only
when it appears at the end of a line.

l

( ). Marks a sub expression. For example, alt(a|e)r finds altar or alter.

l

*. When an expression is followed by *, it matches zero or more versions of the
expression. For example, [rst]* finds (blank), r, s, t, rs, sr, rt, tr, st, ts, rst, rts, srt,
str, trs and tsr.

l

+. When an expression is followed by +, it matches one or more versions of the
expression. This differs from * because it does not match (blank). It must match at
least one character. For example, r+ matches r, rr, rrr and so on.

l

{x,y}. Must match at least x times and not more than y times. For example, s
{2,4} matches ss, sss and sss. You can also use {x} to specify an exact match. For
example, s{3} matches sss. You can use {x,} to specify that the match is at least x
amount of times. For example, s{4} matches ssss, sssss, ssssss and so on.

l

?. Must match the preceding character zero or one times. For example, Boa?rder
matches boarder and border.

Viewing replacement words
1. In the Workarea, click the Content tab.
2. Select a forum from the folder structure.
3. Choose View > Replace Words. A list of word to be replaced appears.

Adding a replacement word
NOTE: In addition to using Replace Words for a specific forum, you can access the
Replace Word feature from the Workarea > Settings > Configuration >
Discussion Board > Replace Words. If you have more than one forum, this
allows you select to which discussion boards the Replace Words feature is applied.
1. In the Workarea, click the Content tab.
2. Select a forum from the folder structure.
3. Click New > Replace Word. The Replace Words screen appears.
4. Click Add.
5. Add the word to be replaced in the Old Word textbox.
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6. Add the replace word in the New Word textbox.
7. Select the language for the Replace Word.
8. Click Save.

Editing a replacement word
1. In the Workarea, click the Content tab
2. Select a forum from the folder structure.
3. Click View > Replace Words.
4. Click either the Old Word or the New Word to edit.
5. Click Edit.
6. Change the Old Word, New Word or Language.
7. Click Save.

Deleting a replacement word
1. In the Workarea, click the Content tab.
2. Select a forum from the folder structure.
3. Click View > Replace Words.
4. Click either the Old Word or the New Word to delete.
5. Click Delete. A dialog box asks if you are sure you want to delete.
6. Click OK.

Adding emoticons to a post
IMPORTANT: This topic applies to the eWebEdit400 editor only.
An emoticon is an icon used to express emotion in a forum post. In the post editor, click
the emoticon (

) symbol.
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You can also enter a few characters that resemble the image. For example, to insert
,
enter O:\). While working in a post, the user only sees the text. But when the post is
saved, Ektron converts the text to an emoticon. In all subsequent work with the post,
users see only the emoticon. You can add new emoticons at Settings > Configuration
> Discussion Boards > Emoticons.
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Creating or editing an emoticon
1. Within the Workarea, go to Settings > Configuration > Discussion Boards >
Emoticons.
2. Click the emoticon text or image that you want to edit.
3. Click Add or Edit.
l Emoticon Text. Enter or update the characters a forum participant enters to
insert this emoticon.
l

Emoticon Image. Enter the name of the image file that appears after a user
enters the above Emoticon text and saves the post.

l

Regex. See Using regular expressions on page 1043.

l

Language. Select the emoticon’s language from the drop-down list. If a
forum is language-specific, only emoticons assigned to that language or all
languages are available.

Deleting an emoticon
1. Within the Workarea, go to Settings > Configuration > Discussion Boards >
Emoticons.
2. Click the emoticon that you want to delete.
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3. Click Delete.
4. Reply to the confirmation message.

Moderating from the control panel
Users with forum moderate permissions can do so from the Control Panel by clicking the
Moderate link.
1. Log in to the site and go to the forum.
2. Click Control Panel.
3. Click the Moderate link. The forum’s control panel appears with a list of items
requiring approval.

4. Click the item you want to approve. From this screen, you can edit, approve, or
delete a post.

Approving a post
PREREQUISITE

Users must be assigned the Moderate permission.
When defining a forum, you can check the Moderate Comments field. If you do,
forum posts must be approved before they appear on the website. There are 2 ways to
approve a post.
l

From the website:
1. Log into the site and go to the forum.
2. Click Control Panel. The Control Panel appears.
3. Click the Moderate link.
4. Click the topic. The topic appears.
5. Click Approve.
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l

From the Workarea's discussion board:
1. In the Workarea, click the Content tab.
2. Select a discussion board, then a forum.
3. The forum’s topics appear in the right frame. Click the one that has the post
that you want to reply to. (Unapproved posts have an Approval Needed icon in
the left column.)
4. The next screen, View Topic, displays all posts to the selected topic.
5. Find the post you want to reply to. Unapproved posts have a yellow border.
6. Click approve under the post icon.

Setting up post reporting
You can let site visitors report inappropriate posts, such as spam or offensive posts.
When you set up forum post reporting, you add a Report Post button to the bottom of
each post to let site visitors report posts. When a site visitor clicks Report Post, an
email notification is sent to all forum moderators. Any moderator can review the post
and decide to edit, delete, or leave it alone.
NOTE: Your Ektron Web server must be set up to send emails. See Installing Ektron
on page 9.
1. From the Workarea, choose Content.
2. In the left panel, select a discussion board from the folder structure.
3. Select a forum.
4. Click Properties (

).

5. Click EditForum Properties.
6. Check the Moderate Comments box.
7. Click Save.
To edit the report post message, go to the Workarea and choose Settings >
Configuration > Discussion Boards > Messages and select ReportForumPost.

Managing a discussion board on your website
This section explains how to manage a discussion board on your site.

Using the control panel
The Control Panel lets logged in users view your profile, read, reply to, and delete
private messages. It also lets users with moderate permissions moderate the forum.
The Control Panel button is located at the forum level.
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The Inbox view appears by default. From it, you can...
l

read a message by clicking on it. A read message's icon changes from unread (
to read ( ).

l

view information about the message sender by clicking the name.

l

delete the message by clicking the corresponding check box then the Delete
button.

l

switch to a different view.

l

check your subscriptions.

l

reply to a message by clicking Reply (

)

).

IMPORTANT: When replying to a private message, you add your response to the
existing message. Only one message is created.

Approving a topic on your website
If a user who lacks moderate permission for a forum adds a topic, it needs to be
approved. When viewing topics on a Web page, those requiring approval have a
different background color.

From this screen, you can click Approve next to the topic’s title. You could also click the
topic’s title to view it and click Approve on that screen.

1050

Ektron 9.40 SP1

Sorting topics

Sorting topics
1. Go to the Web page that hosts the discussion board.
2. Click the forum of interest.
3. Click a column title to sort by alpha or numerical order.
On first click, items are sorted first by numeric (1-10) values, then by alpha values
(A to Z). Click a column title a second time to sort the items in reverse. When first
viewed, the list is sorted by Last Post date and time.

Deleting a topic
PREREQUISITE

Forum topics can be deleted by users who created them or users with the
Moderate permission. This includes Membership users.
WARNING! When you delete a topic, its replies and posts are also deleted.
1. Go to the Web page that hosts the discussion board and click the forum of interest.
2. Click the topic you wish to delete.
3. Click Delete Topic. A dialog asks you to confirm.
4. Click OK.

Suppressing user information from the forum profile
display
Generally, anyone browsing a discussion forum can view contributor information by
clicking the user name. However, if the forum server control’s HideUserProfile
property is true, non-administrator users cannot see the profile, even if the Private
Profile setting is set to Public. See also: Forum.
Administrators can see the profile, regardless of the HideUserProfile setting. The
profile contains the following user information.
l

First Name

l

Last Name
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l

Email. email address

l

Joined. date the user joined

l

Last Visit. date the user last visited the site

l

Number of Posts. the number of posts a user has contributed

l

Post History. a list of the user's posts

How users control their profile's visibility
Users can determine if their profile is viewable via the Private Profile drop-down box
on the Membership Registration screen and the Edit Profile screen.
NOTE: The Membership Registration screen appears where your developer inserts
the Membership Server Control.
If Private Profile is set to Private, profile information is suppressed. If it is set to
Colleagues, only a user’s colleagues can see the person's profile. If set to public,
everyone can see a user’s profile information.

How administrators control the visibility of user profiles
If you want to suppress the display of user names as an administrator:
1. If the user is an Ektronuser, go to Settings > Users and select a user.
If the user is a membership user, go to Settings > Community Management >
Memberships > Users and select a user.
2. In the User Properties area of the screen, check the Private Profile checkbox.

Outputting a forum as an RSS feed
You can output a forum as an RSS feed by clicking the RSS feed button ( ). Each level
of the forum has an RSS feed button. This lets you output a specific topic as an RSS
feed.
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<?xml version="1.0" encoding="UTF-8" ?>
- <rss version="2.0">
<!-- Generated by Ektron -->
- <channel>
<title>Ektron Medical Center Forum</title>
<link>http://test/webform.aspx</link>
<description>Ektron Medical</description>
- <item>
<title>Research</title>
<link>http://test/webform.aspx?g=topics&f=108</link>
- <description>
<![CDATA[ Latest medical research ]]>
</description>
<pubdate>Mon, 7 Feb 2012 09:56:00 GMT</pubdate>
</item>
</channel>
</rss>

Subscribing to a discussion board
1. After logging into a discussion board, you can subscribe to a forum by clicking
Subscribe ( ). The button appears at each discussion board level, so a user can
subscribe to forums and topics of interest.

2. Select a notification type, listed below.
l All Posts. notifies you when any post or reply is added
l

Replies to Me. notifies you when someone replies to your post

3. Click Add Subscription.

Reviewing subscriptions
To review forum subscriptions, go to the Control Panel and click Notifications in the
lower left corner. A screen indicates each discussion board level to which you have
subscribed.
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Deleting a subscription
To delete a subscription, check the corresponding box and click Delete.

Sending a private message to a forum member
Logged-in users can send a private message to the person who created a post or reply.
Only the sender and receiver can view private messages. This requires both users to be
an Ektron or membership user.
1. Go to a post and click the user’s name.
2. When the User Profile appears, click Message. The Message screen appears.
3. The To: field is filled automatically. You cannot add additional members.
4. Enter a subject.
5. Enter a message.
6. Click Post.

Managing a discussion board in a community
group
A Community Group can have a discussion board, which supports community-based
discussions that are limited to forum members. All discussion board features are
available to a community group forum. See image below.
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To use a group discussion board, first add it to the database. Each group needs to do
this once. To add a group discussion forum database:
1. Log in to your website.
2. Go to your group Web page.
3. Click Manage > Edit Group. The Edit Group Link appears.
4. On the Properties tab, check the Create Group Forum box. After the group
forum database is created, you cannot uncheck this box.

5. Click Save.
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Discussion board server controls
Ektron provides 3 server controls for use with discussion boards.
l

Forum. Places a discussion board on a Web page

l

ActiveTopics. Displays the most active or most recent topics and posts

l

PostHistory. Displays a user's list of posts

After creating at least one hierarchy of discussion board elements within the Workarea,
place a Forum server control on a Web page. If you want to require site visitors to
authenticate, that Web page should also contain:
l

a Membership server control (or a link to page that has one). This lets site
visitors/membership users register for discussion boards.

l

a Login server control that lets the site visitor/membership user log in

NOTE: Add text below the Login server control to remind site visitors to enter their
email address at the User field.
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Working with content reports
The Workarea’s Reports > Contents folder contains reports to help you manage the
workflow of Ektron content. In most cases, you choose a report that corresponds to a
content status, then view content in that status. If appropriate, you can perform tasks
on the content. For example, you can check in checked-out content.
This chapter explains how to access the Workarea’s reports folder, set criteria that
determine the information on the reports, and actions you can perform on them.

Approval report
All content awaiting your approval appears on this report. Thus, you can quickly find all
such content without searching every folder.

l

Title. Title of content.

l

Request Type. Publish or Delete.

l

Start Date. Start date, if any, assigned to the content. Determines when
approved content will go live on website.

l

Date Modified. Date the content was most recently changed.

l

Submitted By. User who submitted content for approval.

l

ID. Content ID number.

l

Language. Content language.

l

Path. Path to folder where content resides.

From the approvals report, you can approve or decline content submitted to you.
1. Go to the Workarea > Reports > Contents screen.
2. Click the content you want to approve or decline. The View Content Awaiting
Approval page appears.
3. Perform an action.
l Publish. Accept content changes and publish.
If there is a subsequent approver in the content’s workflow, a Submit button
appears instead. If you click Publish but the content has an incomplete task
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assigned to another user, the content cannot be published. Instead, a
message appears.
l

Decline. Reject changes and keep current content on website.
You are prompted to enter a comment for the decline. The author who made
the change is notified by email.
The content as edited by the last editor remains in the file. If you do not want
that content to remain, choose Edit.

l

Edit. Check out content and change it if desired.

l

View Published/Staged. Toggle between Published and Submitted versions
of content. This can help you compare differences.

The content is either submitted to the next publisher, published immediately, or
deleted, depending on its workflow.

Approve All option
You can approve several content items at once. To do so, check the box in the header
row then click Approve All.

You are prompted to insert a comment, which is included in the notification email. The
comment cannot begin with a special character.

Checked in content report
Displays all the content currently in a checked-in status.
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l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

Date Modified. Date and time content was last edited.

l

Path. Folder location of content in Ektron website.
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Checked out content report
Displays all content currently in a checked out status.
l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

Date Modified. Date and time content was last edited.

l

Path. Folder location of content in Ektron website.

After selecting content, check it in using the Checkin button.

New content report
Displays content in a new state, that is, it was created and saved but never published.
l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

Date Modified. Date and time content was last edited.

l

Path. Folder location of content in Ektron website.

Submitted content report
Displays all content in a submitted state. The report contains the following information.
l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

Date Modified. Date and time content was last edited.

l

Path. Folder location of content in Ektron Workarea.

While viewing the Submitted Content report, you can view the content’s position is its
workflow. Then, ask those individuals to complete their approval.
1. From the Submitted Content Report, click the content title. The View Content page
appears.
2. Click the Properties tab. The Approvals line indicates the content’s position in
the workflow. Red text indicates the current approver.
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Content pending start date report
Displays all content that was approved, but whose start dates haven’t occurred. Each
content item on the report contains the following information.
l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

Start Date. Date and time content will go live on website.

l

Path. Folder location of content in Ektron website.

You may edit content on the Pending Start Date Content report by clicking the content
you want to view and using the toolbar at the top of the page, perform any action
available.
See also: Scheduling content on page 698

Refresh reminder report
Displays all content whose end date has passed and whose archive option is set to
Refresh Report. This content is still visible on the website. Its appearance on this
report indicates that it is due for review.
l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

Date Modified. Date and time the content was last updated.

l

Path. Folder location of content in Ektron website.

If you review content and decide it should no longer appear on your site, follow these
steps to remove it. The content will be visible if you browse to it through the Workarea,
but won’t appear to site visitors.
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1. From the Refresh Reminder Report, click the content.
2. From the View Content screen, click Edit (

).

3. Click the Schedule tab.
4. Under Action on End Date:, click Archive and remove from site (expire).
See also: Scheduling content on page 698

Expired content report
Displays all content whose end date has passed. Such content is no longer visible on the
website.
l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

End Date. Date and time the content expired.

l

Path. Folder location of content in Ektron website.

You may edit any content on the Expired Content report by clicking the content you
want to view and using the toolbar at the top of the page to perform any action
available.
See also: Scheduling content on page 698

Content to expire report
Lists all content whose end date will occur between today and a number of days that
you specify. For example, if today is January 1 and you select 10 days, the report lists
all content whose end date is January 1 through January 10.
After viewing the report, you can click any content and proceed to the View Content
screen for it. From there, you can edit information about it, including its end date if
desired.
l

Title. Title of content.

l

ID. ID number assigned to content by Ektron.

l

Last Editor. Last user to edit the content.

l

End Date. Date and time the content expired.

l

Path. Folder location of content in Ektron website.

To select the report’s date range, you have 2 options:
l

Enter a number in the Days field. Then click View Reports (

l

Select a number from the drop-down list under the Days field

).
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After selecting a number of days, click view (
within that time frame.

) to see all content that will expire

See also: Scheduling content on page 698

Site update activity content report
Provides a snapshot of the freshness of your website content. Specifically, it lists how
many content items were published within a folder and date range you select, organized
by folder. For example:

To choose which content items appear on the report:

1062

Ektron 9.40 SP1

Asynchronous log file report

1. Choose a Start Date by clicking the calendar icon. You also can choose an End
Date using the same procedure. (Today is the default end date.)
2. At the Select field, choose a folder. The Root folder is the default selection. (Only
folders for which you have read-only or greater permission appear.) To change
that selection, click the folder name. To select all folders on the screen, click the
Select All checkbox. Otherwise, select folders by clicking the corresponding
checkbox. There is also an option to Include Sub-folders of the selected folders.
3. Choose the Report type, which determines the information you will see on the
report.
l Executive View
o name of each page that was published
o

how many times it was published

o

date it was last published

o

users who published page

o

total numbers are not provided

l

Detail View Example

l

Combined View. Combination of Executive and Detail views.

4. To exclude users or user groups from the report, use the Exclude Users field. For
example, you want to see all updates other than those you have completed. When
you click Exclude Users, an alphabetical list of users appears, followed by user
groups.
5. Click Get Result.

Asynchronous log file report
When the Message Queuing and Asynchronous Process are set up and running, you can
access a report of any problems with the Asynchronous Processor. You can also email it
to any Ektron user.
PREREQUISITE

Define the path to your website's asynchronous processor service on the
Settings > Configuration > Setup screen's Asynchronous Processor
Location field.
To access the Asynchronous Process log:
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1. From the Workarea, click Reports.
2. Click Contents > Asynchronous Log File Report.
3. Any problems appear on the screen.

Search phrase report
See Using a search phrase report on page 404.

Preapproval groups report
Lists all preapproval groups assigned to folders within Ektron. To access it, go to
Workarea > Reports > Contents > Preapproval Groups. See also: Setting up an
automatic task for pre-approving content on page 1467

Bad link report
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Lists invalid links to external URLs within your content. (An invalid link returns an error
code to your browser.) The report lists the following information about each item that
contains a bad link.
l

title

l

error description

l

Source, that is, item type followed by information about the item
o if the error is in a content block, you see Content followed by its id number
and language locale id
o

if the error is in a Smart Form, you see Smart Form followed by its ID number

o

if the error is in a menu, you see Menu Item (11,0,1033). The parameters
are: menu ID, menu item ID, and language ID.

o

if URL Aliasing is on, you see ASPX Template followed by the template name

l

the anchor (<a>) tag to which the bad link is assigned

l

URL that cannot be resolved (labeled Invalid Link)

NOTE: The report does not check quicklinks embedded in the content.
The report scans the following types of content.
l

Published HTML content

l

Published XML content

l

HTML forms

l

XML Smart Forms

l

menus

l

active system templates

When the scan is complete, the report lists any item that includes an invalid URL. From
the list, you can click a button to access the item, then update or remove the bad link.
To run the Bad Links Report, go to Reports > Contents > Bad link report. You
immediately see its status, either Done or Running.
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l

To begin, click Check Links. As the report progresses, existing data is replaced by
new data.

l

While the report scans content, you can work in other areas of Ektron and even
sign off. These actions have no effect on the collection of data.

l

After content is scanned, the report’s status changes to Done. If desired, print the
report by clicking Print.

l

To launch the broken link in a browser, move the cursor over it and click when the
cursor turns into a hand.

Fixing a bad link
1. Click Edit ( ).
2. Select the indicated text.
3. Right-click and select Set Link Properties to access the hyperlink dialog.
4. Update or remove the bad link.
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5. Save your changes.

Excluding pages from the bad link report process
You can exclude links or pages from the Bad Link Report process because it is
unnecessary or undesirable to test them. For example, you want to exclude pages with
l

links that log out of the site or Workarea

l

links that go to Pay-per-Click

l

links that start another process or register an event

l

links to new content you have not published

To exclude pages from this process:
1. Edit the file [siteroot] > Workarea > ekbadlinkrpt.excludes.
2. Enter a string to exclude—one per line. Any URL that contains this string is
excluded.
Examples:
l gif would exclude all links ending with .gif
l

/commerce/cart excludes links to /commerce/cart.aspx and
/commerce/mycart.aspx.

3. Save the file.
The following shows an excluded URL on the Bad Link Checker status page.

Content flags report
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Display a list of flags assigned to content. See also: Defining flags for content on
page 1717

Content reviews report
Has pending reviews. See User-ranking of content on the facing page for more
information. See also: Viewing pending reviews on page 1071
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User-ranking of content
The Content Review feature lets you:
l

place a star-based scale on any page of your website

l

let users apply full or half-star rating increments and a comment

l

add reviews, depending on how the feature is used

l

moderate the review comments

l

display reviews and comments next to content for others to see

l

run reports to find the highest-rated content; tweak poorly-rated or reviewed
content to achieve optimal ratings

l

control which reviews get posted through a moderation feature

The ContentReview server control enables Ektron users, membership users, and site
visitors to rate and review content on a Web page, and lets you display the reviews on
your site.

Ektron restricts users to one review per page. If a regular or membership user logs in
before rating a piece of content, Ektron remembers the user ID. For any other site
visitor, Ektron places a cookie on the person's computer. So, when a page with a
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ContentReview server control is visited, Ektron checks the user ID and cookie. If neither
exists, it displays a rating scale. If the user already rated the page, the user can edit the
review but not enter a new one.
NOTE: If you are not logged in as an Ektron or membership user, the browser must
have cookies enabled to submit a content review.

Viewing a history of reviews
1. Go to Workarea > Content > the folder that contains the content.
2. Click the content item.
3. Click View Content Reports ( ). (For an eCommerce catalog entry, select
Reports > Content Statistics.) The Rating tab is selected by default. If desired,
enter a range of start and end dates.

4. Click Get Reviews.
5. If Microsoft Excel is installed on your computer, you can export the ratings detail to
Excel for further data manipulation. To do so, click Export to Excel at the bottom
of the Content Report.
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Moderating reviews
Ektron lets you moderate reviews. This means that a review must be approved by an
Ektron user who has Edit permission for the content before it appears on your site. You
enable or disable this capability via each ContentReview server control's Moderate
property. The options for authorized users to moderate reviews are as follows.
l

Workarea > Smart Desktop > Content Reviews

l

Workarea > Reports > Contents > Content Reviews

l

Content Rating screen associated with a content item

Upon viewing a pending review, an authorized user has 3 choices.
l

Approve it. Your website displays the review

l

Decline it. It is stored with the content's review history but is not visible on your
site

l

Edit it. Update then approve it; your website displays the edited version

If a ContentReview server control is moderated, the following occurs.
l

a site visitor sees a submitted review only after it is approved.

l

an Ektron user can view the status of his or her review by logging into the
Workarea and clicking Reports > Contents > Content Reviews.

If a review was rejected or has been pending for too long, the user can submit another.

Viewing pending reviews
1. From the Smart Desktop, click the Content Review widget.
You can approve or decline reviews from the Content Review widget. But if you
click View All> and proceed to the Pending Reviews screen, you have additional
options.
2. Click View All>. The Pending Reviews screen appears. You can also access the
Pending Reviews screen from the Workarea > Reports > Contents > Content
Reviews.
3. From there, you can:
l Approve or decline a review. Click the appropriate radio button
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l

Edit a review's rating, review, or status. click its title and an edit screen
appears. Change as needed.

l

Print pending reviews. click Print (

l

Email. Click Email ( ) to email this report to Ektron users. Next, select
recipients, then click Email ( ).

l

Filter reviews by folder. Click Folder (
pending reviews. Then, click Save.

l

Filter reviews by language. from the Language drop-down, select the language
of the pending reviews.

).

) and go to the folder that contains

NOTE: To delete a review, use the Content Review Screen. See also:
Moderating reviews from the content review screen below
4. After you approve or decline reviews, click Save. Approved reviews appear on the
site.
NOTE: A site visitor can change his or her review at any time, even if its status
is pending or rejected; then, the information is updated in the Workarea, and
the review's status changes to pending.

Moderating reviews from the content review screen
1. In the Workarea, go to the content item.
2. Click View Content Reports (

).

3. Click the Rating tab.
4. Click Get Reviews. A list of reviews appear for the content.
5. Click the date of content to be moderated. The View Content Review screen
appears.
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l

To change information on this screen, click Edit. From the Edit screen, you can
change the rating, review and status. When finished, click Save.

l

To delete the review, click Back (

) then Delete ( ).

Purging review data
1. Within the Workarea, go to the content.
2. Click View Content Reports (

).

3. Select the date range of the data you want to purge using Start Date and End
Date.
4. Click Purge Reviews.
5. Click OK to the confirmation message.
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Chapter 14

Creating Web pages with
PageBuilder
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PageBuilder lets you easily create new pages on your website. The page template that
you choose is initially created by a developer, but you provide final content, design, and
placement of functionality on the Web page.
The PageBuilder work flow has the following stages:
1. Define the "look and feel" for your website.
Stakeholders may include the CIO, the marketing team, Ektron administrators,
Web designers, and developers. When a consensus is reached, the marketing team
defines the page layout and presents it to the whole team for review and approval.

2. Create the wireframe templates.
A developer creates a wireframe template, which is the basic architecture for a
Web page. The developer adds dropzone user controls where non-technical users
into which content authors place functional widgets and manage the content,
design, and messaging.
Developers manage the level of control non-technical users have. For example, a
developer can configure limits for the width of dropzones. The developer should
understand the requirements and use, modify, or build widgets based on the
requirements. PageBuilder lets IT develop the back-end of a system and address
the technical nuances that today’s websites generate.
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3. Create permissions for content authors.
After a wireframe is created, an administrator assigns the wireframe to a folder,
creates a page, and chooses the widgets that user can place on the page.
4. Build and maintain Web pages.
When wireframe templates are available, you choose the page template you want
to use and create new pages, drag-and-drop widgets, edit properties, and so on.
You create and maintain content.

PageBuilder pages have the same business-level controls as content blocks. Like other
Ektron content, PageBuilder pages maintain permissions, approval chains, enable SEO
(through metadata), taxonomy, Aliasing, and allow users to view histories and restore
past versions.
Approvers can preview PageBuilder pages before they go live, and pages can be cloned
and then modified to maintain consistency across campaigns or to support A/B split
testing.

Creating PageBuilder pages
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You can create a new PageBuilder page from the PageBuilder menu on your website, or
from the Workarea. You must have permissions as a content author to log in and make
changes to your website. See Defining roles on page 1581

Creating a PageBuilder page from your website
1. Log into your website.
2. Open the PageBuilder menu and choose File > New Page. The Add New Page
wizard appears.

3. Click on your choice of template. It is highlighted and shows a check mark on it.
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4. Click Next. The wizard shows fields to define your new page.

5. Enter a title in the Title field, enable Content Searchable, and choose a
taxonomy. By default, the Manual Alias matches the Page Title.
IMPORTANT: You should use automatic aliasing in most cases because you
cannot standardize an aliasing pattern with manual aliasing. Automatic aliasing
standardizes alias naming. See Creating automatic URL alias rules on page 1416
for information about automatic aliasing.
6. Click Next. The wizard shows metadata and summary information that you can
enter.
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7. Click Finish. A confirmation dialog box appears.

8. Click OK to start editing the page.

Creating a PageBuilder page in the Workarea
PREREQUISITE

You must have wireframes already created in a folder. See Assigning the
PageBuilder wireframe to a folder on page 1105.
1. Click on the Pages folder (or one of its subfolders) where you want to add the new
page.
2. Choose New > Page Layout.
3. The Add New Page screen appears. (Because only one template is assigned to the
folder, it appears as the default.)
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4. Click Next. A new screen appears, which lets you assign a title, Taxonomy, and
aliasing information to the page.

5. Enter a title in the Page Title field
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6. By default, the Manual Alias matches the Page Title.
7. Click Next. The following screen appears, which lets you assign metadata and a
summary to the page.

8. Click Finish. A confirmation dialog box appears. Click OK to start editing the page.

Editing content on a PageBuilder page
After the page is created, a new page opens where you can design the page and other
actions, such as check in, view properties, and drop widgets onto the page.
NOTE: For information about how to create a widget, see Creating the “Hello World”
widget on page 1276.
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HTML5 CSS3-compliant browsers may have the Ektron toolbar if it is enabled in the
Workarea. PageBuilder actions are available when you click Design. See also: Editor
toolbar options on page 606.

You can specify which templates have toolbar access at Workarea > Settings
> Configuration > Template Configuration.

The following image shows a page with a 2-column layout.
l

The left column, 35% wide, displays a list of content in the Marketing folder.
website visitors use the list to access Marketing collateral.

l

The right column, 65% wide, displays one content block.
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Step 1: Add column and set column widths
NOTE: If your developer sets dropzone column widths programmatically (as
explained in Setting a dropzone’s column width programmatically on page 1113),
you cannot add a column as described here. Many developers disable this option
because it gives end users liberty to resize columns when you may want to
standardize your layout. If your developer has disabled this option, go to Step 2.
Add a second column to the right of the top one. Then, set the width of both columns.
1. Click Add Column ( ). A new column appears to the right of the existing one. See
also: Using responsive frameworks with PageBuilder on page 1087.
2. Click Resize (

) on the first column. The Resize form appears.

You can customize the Resize form so that you can choose Pixel, Em, Percent,
Bootstrap, Foundation, or other frameworks for creating columns. See Customizing
the PageBuilder.config file on page 1110.
3. This example uses Percent. Set the left column width to 35%, as follows:
a. Select Percent from the Size Type drop-down field.
b. Enter 35 into the Width field.

1084

Ektron 9.40 SP1

Step 2: Insert Content Block widget into a column

c. Click Apply.

4. Set the right column to 65% width by clicking the pencil icon, changing its width to
65 Percent, and clicking Apply.

Step 2: Insert Content Block widget into a column
When the columns are set, insert a ContentBlock widget into a column.
1. From edit mode in the tool bar, click Design. The PageBuilder window appears.
2. Open the Widgets menu and click on the Content Block widget; it highlights and
areas on the page appear where you can place the widget.
NOTE: For information about how to set the widgets that display in the Widgets
menu, see Adding Widgets to the Wireframe Template.
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3. Click on any Place Here block. The Content Block widget appears in the block.

4. Click Edit (

). The Content Block Widget editing screen appears.

5. On the Select File tab, choose Root > Mainsite > Content > Products
> Software and click New to place the new content in the Software folder. The
Edit Content screen appears.
6. Add a Title.
7. In the content area, enter some text and click Publish.

When saved, the content appears in the column.
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8. Choose Page Action > Publish to publish the content to the Web page.

Using responsive frameworks with PageBuilder
You can modify the look of a page by adding columns that can contain dropzone
elements. Each column that you add responds according to the design rules that are
applied to your site. For Ektron releases prior to Version 8.7, when you added a column
to a PageBuilder page, you selected a unit of measurement (pixel, em, percent) and
number of units (for example, 200). With Version 8.7 and beyond, you also can choose
your site's CSS framework (for example, Bootstrap).
Responsive Web Design (RWD) lets columns fit in a window without horizontal scrolling.
The following image shows a Web page built with the Twitter Bootstrap framework and
PageBuilder. The highlighted section displays 3 columns within 1 PageBuilder dropzone.
Each column displays a different widget.
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When this page is resized, styles rearrange the columns so that they fit without
horizontal scrolling.
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If you want to add another column and more widgets to a row, apply styles to the
column according to the website's CSS framework.
To continue the example, the row now has 4 columns. Apply to each column a value of
Span3, so the combined width totals span12, the maximum width of a Bootstrap page.
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Now, 4 columns (each containing widgets) fit into this section of the page. If the
browser is resized, each column is sized according to the Bootstrap styles.

If you view this page on a smart phone, the columns are rearranged.

You can use a variety of RWD frameworks, such as:
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l

Twitter Bootstrap. A free collection of tools for creating websites and Web
applications that contains HTML and CSS-based design templates for typography,
forms, buttons, charts, navigation, other interface components, and optional
JavaScript extensions. See the Twitter Bootstrap website.

l

Foundation. A light-weight framework for rapidly building prototypes and
production websites. See the Foundation website.

l

Skeleton. A small collection of CSS files for rapid development of sites that look
beautiful at any size. See the Skeleton website.

IMPORTANT: The pagebuilder.config file contains sample data from the Twitter
Bootstrap and Foundation frameworks. If you use a different RWD framework (such
as Skeleton), add the necessary CSS style sheets to your site, and update
pagebuilder.config with the framework's class names and CSS paths. See
Customizing the PageBuilder.config file on page 1110.
Any element on the page can take as many columns as it needs, but all elements in a
row must not exceed the maximum number of columns. Twitter Bootstrap and
Foundation have a grid system of 12 columns per row; Skeleton has 16 columns per
row. For example, the following patterns represent how many columns each element
uses in a row. No pattern exceeds 12 (unless you use Skeleton's 16 columns); periods
indicate offset columns (spaces). An offset pushes a column to the right. See the
following examples.
1
4
1
6
4
.
.
.

1
4
1
6
.
.
.
.

1 1 1 1 1 1 1 1 1 1 — 12 single columns
4
— 3 columns (4 columns-wide each)
2 3 4 1
— 6 columns (varying column widths)
— 2 columns (6 columns-wide each)
. . . 4
— 2 columns (4 columns-wide, with a
. 3 . . . 3
— 2 columns (3 columns-wide, with 2
. . 8
— 1 column (8 columns-wide, with a
5 . . . . .
— 1 column (5 columns-wide, with a

4-column offset)
offsets)
4-column offset)
2-column offset)

The following result occurs from adding 12 columns of Type: Bootstrap.

When you add a column to a PageBuilder page and click Resize ( ), then chooses the
Type: Bootstrap, the following Resize form appears.
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The following result occurs from choosing Type: Bootstrap, Width: 5 Columns,
Offset: 2 Columns (which leaves 5 columns to the right).

The following result occurs from adding a column to the previous example, and
choosing Type: Bootstrap, Width: 4 Columns, Offset: 1 Column for the new column.
(Pattern: . . 5 . 4)

Note that if you shrink the window from right to left, the second column gets moved
under the first, as follows:
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Developing wireframe templates
NOTE: Internet Explorer cannot accommodate more than 32 style sheets in one
page. This problem can affect PageBuilder pages, because each widget may include
one or more style sheets, and a page can host any number of widgets.

Creating a PageBuilder wireframe
You first create a wireframe. Next, define the dropzone, one or more areas of the page
on which a content creator drags and drops widgets. The relationship between a
wireframe, a dropzone, and a widget is illustrated in the following image.
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To create a wireframe that contains one dropzone:
1. Open the website in Visual Studio.
2. Choose Web Site > Add New Item to add a new Web form to the site.
3. Select Web Form.
4. Set the Name to PageLayout.aspx, the Language to Visual C#, and check Select
master page.
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5. Click Add.
6. When prompted to select a master page, choose from the directory
siteroot/components/templates.
7. Register the user controls directly below the @Page directive (at the top of the
file).
<%@ Register Assembly="Ektron.Cms.Controls"
Namespace="Ektron.Cms.Controls" TagPrefix="CMS" %>
<%@ Register Src="~/Workarea/PageBuilder/PageControls/PageHost.ascx"
TagPrefix="PH" TagName="PageHost" %>
<%@ Register Src="~/Workarea/PageBuilder/PageControls/DropZone.ascx"
TagPrefix="DZ" TagName="DropZone" %>
<%@ Register Assembly="Ektron.Cms.Widget"
Namespace="Ektron.Cms.PageBuilder" TagPrefix="PB" %>

8. Add code for a PageBuilder Menu (PH: PageHost) and Dropzone. To do this, locate
the ContentPlaceHolder1 and enter this code.
IMPORTANT: When inserting the following code, begin the
<ColumnDefinitions> statements with the TagPrefix on the widget assembly
registration line (PB in the example above). Do not use IntelliSense when
entering <ColumnDefinitions> statements—it may insert an incorrect prefix.
<PH:PageHost ID="PageHost1" runat="server" DefaultPageID="937"
SelTaxonomyID="94" />
<DZ:DropZone ID="DropZone2" runat="server" >
<ColumnDefinitions>
<PB:ColumnData columnID="0" unit="custom" CssFramework="bootstrap"
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CssClass="span4"></PB:ColumnData>
<PB:ColumnData columnID="1" unit="custom" CssFramework="bootstrap"
CssClass="span4"></PB:ColumnData>
<PB:ColumnData columnID="2" unit="custom" CssFramework="bootstrap"
CssClass="span4"></PB:ColumnData>
</ColumnDefinitions>
</DZ:DropZone>

This control lets a content author drop widgets on the page. It also provides the
save/check in/publish functions, and lets the author preview the page when it is
published. The content author uses a Dropzone control as a placeholder, into which
you insert widgets. You also can use it to insert additional placeholders as needed.
BEST PRACTICE
Assign an appropriate value for the SelTaxonomyID property. See
Assigning a default page to a wireframe on page 1106 and Assigning a
default taxonomy category to a wireframe on page 1107.
9. Open the code-behind page, PageLayout.aspx.cs.
10. Add a reference to the PageBuilder namespace by adding the following line after
the last using statement.
using Ektron.Cms.PageBuilder.

11. Inherit the PageBuilder class instead of System.Web.UI.Page. To do this, change:
public partial class PageLayout : System.Web.UI.Page

To:
public partial class PageLayout : PageBuilder

12. Add the following code after the Page_Load event to handle errors and
notifications.
public override void Error(string message)
{ jsAlert(message);
}
public override void Notify(string message)
{ jsAlert(message);
}
public void jsAlert(string message)
{ Literal lit = new Literal();
lit.Text = "<script type=\"\"
language=\"\">{0}</script>";
lit.Text = string.Format(lit.Text, "alert('" + message + "');");
Form.Controls.Add(lit);
}

You do not need to use the jsAlert system defined here. But if you do not, you must
add overrides to handle errors and notifications.
The code page for pagelayout.aspx.cs looks like this.
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13. Save the PageLayout.aspx and PageLayout.aspx.cs files.

Creating a PageBuilder master layout
A Master Layout is a special type of PageBuilder template that may include a special
kind of dropzone called a Master Zone. A Master Zone is only editable by users assigned
to the Administrators group or the MasterLayout-Create role. All other dropzones on a
Master Layout template are called Layout Zones. Anyone can edit them.
An example use of this template is: a department head reserves one Master Zone on
the department pages for content that only the department head may edit. Content
authors may drag and drop a widget into other dropzones, but cannot edit the Master
Zone.
The following diagram shows a Master Layout template that contains 2 dropzones and 4
widgets. In the following example, the Master Zone contains a Flckr widget.
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When a Master Layout is published, you can use it like any other template. The
following figure shows a sample page that uses a Master Layout.

After you created a wireframe with 2 dropzones, both of which are editable, you can set
a dropzone so that others may not edit it.
1. Workarea Content panel, choose New > Folder. The Add folder screen appears.
2. In the Name field, type Master Layouts.
3. In the Templates tab, uncheck Inherit parent configuration. Then, select a
wireframe template from the list of templates. For example, products.pb.aspx
(Wireframe Template).
4. Click Add (
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5. Click the radio button next to the selected template to make it the folder's default
template.

6. Click Add Folder.
7. In the folders screen, click the new Master Layouts folder.
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8. Choose New>Master Layout.

9. Set the title to MasterLayout1.
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10. Click Next.

11. Set metadata, summary, and taxonomy categories if desired, then click Finish.

Setting a dropzone to a master zone type
After the wizard finishes, you see a new Master Layout page with dropzones that can be
used for Master Layout areas. You must unlock a dropzone to convert it to a Master
Zone. The following figure shows a Master Layout with dropzones.

1. Click Lock ( ) to change a dropzone from Layout Zone to Master Zone. A warning
appears. Click OK.
IMPORTANT: Unlocking this dropzone deletes columns and widgets that are on
templates based on this master layout. Click OK to unlock this dropzone.
2. Drag and drop appropriate widgets into the Master Zone. The figure illustrates
dropping a Flickr widget.
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3. On the PageBuilder menu, select File > Publish.

Assign a master layout to the Pages folder
Before creating a PageBuilder page based on the Master Layout, you must add it to the
templates available to the Pages folder. To do this:
1. In the Workarea, choose Folders > Mainsite > Pages.
2. On the View Content screen, choose View > Properties.
3. Click Edit Properties.
4. Click the Templates tab.
5. Select the Master Layout.

6. Click Add (

) to add it to the template list.

7. Click Update.

Using a master layout to create a page
After you create the Master Layout page and assign it to the Pages folder, you can use it
for other PageBuilder pages. To do this:
1. In the Workarea, choose Folders > Mainsite > Pages.
2. On the View Content screen, choose New > Page Layout. The Add New Page
screen appears.
3. Select the new Master Layout and click Next.
4. Complete the settings for Title, Taxonomy, and Aliasing and click Next.
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5. Enter Metadata and a Summary and click Finish.
You can now place widgets in the PageBuilder page's Layout Zones.

Changing a master zone to a layout zone
PREREQUISITE

You must be an Administrators group member or assigned to the
MasterLayout-Create role
You may want to convert a Master Zone back to a Layout zone. To do this:
1. Access the Master Layout page that you want to edit.
2. From the PageBuilder menu, choose File > Edit.
3. On the layout zone, click Lock ( ) to change the dropzone type from Master Zone
to Layout Zone. A warning appears.
WARNING! Locking this dropzone deletes columns and widgets in the master
zone, and affects all templates based on this Master Layout.
4. The Master Zone now appears Locked. PageBuilder editors can use this Layout
Zone for widgets on PageBuilder pages derived from this Master Layout.

Adding the wireframe and widgets into Ektron
An Ektron administrator uses the wireframe that a developer made, and determines
which widgets will be available to the wireframe.
1. In the Workarea, choose Settings > Configuration > Template
Configuration.
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2. Click Add New Template to System. The Add a New Template screen appears.

3. Click Browse (

) and go to PageLayout.aspx, the wireframe you created earlier

in Creating a PageBuilder wireframe on page 1093.
4. Click the PageBuilder Wireframe check box, which indicates that this template
may be used to create a PageBuilder page. Widgets that can be applied to the
template appear. Ektron provides many standard widgets. See Creating and using
widgets on page 1271.
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5. Click any of the widgets (for example, ContentBlock or ContentList). The
background color changes indicating that they are selected.
6. Click Add New Template to System.

Assigning the PageBuilder wireframe to a folder
Create a folder for the content that appears on the new page by performing these
steps.
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1. Choose Workarea > Content > Folders. The View Contents screen appears.
2. Choose New > Folder.

NOTE: You should keep content and PageBuilder pages in separate folders, so
you can later create and configure a folder called “Content.” The content folder
will contain content blocks, assets, and sub-folders.
3. On the Properties tab, type Pages in the Name field.
4. On the Templates tab, if Inherit parent configuration is checked, uncheck it.
5. Select the template that you created in Adding the wireframe and widgets into
Ektron on page 1103as the default (and only) template for this folder. This ensures
that only PageBuilder pages can be created in this folder.
6. Click Add ( ) to the right of the pull-down menu. PageLayout.aspx is added to
the list of page templates.
7. Create a corresponding content folder. However, instead of assigning
pagelayout.aspx as the template, assign a template for creating Ektron content.

Assigning a default page to a wireframe
You can assign a default page to a wireframe. If you do, and a site visitor enters a URL
with a path to that wireframe that lacks a query string ID, the default page appears.
The following example explains this feature.
l

1106

The following URL returns PageLayout ID 1036 in the PageBuilder folder:
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siteroot
/cms400developer/developer/PageBuilder/PageLayout.aspx?pageid=1036
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l

The following URL returns the Page Layout page identified in the PageLayout.aspx
file’s PageBuilder menu user control DefaultPageID property.
http://
siteroot/cms400developer/developer/PageBuilder/PageLayout.aspx
(Note lack of query string parameter)

To assign a default page to a wireframe:
1. In the Workarea, create a PageBuilder page that will be used as the default pageid
for a wireframe.
2. In Visual Studio, open the wireframe file assigned to that folder.
3. Find the PageBuilder menu user control.

4. Add a new property, DefaultPageID.
5. For the property’s value, enter the ID of the page you created in Step 1.
Here is an example of that line with the DefaultPageID property added.
<ucPageBuilder:PageHost ID="ucCms400Developer" DefaultPageID=”1035” runat="server"
/>

6. Save your changes.
To continue the above example, if someone opens a browser and enters
http://
siteroot/cms400developer/developer/PageBuilder/PageLayout.aspx, the
person is redirected to
http://sitroot/cms400developer/developer/PageBuilder/PageLayout.aspx
?pageid=1035

Assigning a default taxonomy category to a wireframe
While creating a new PageBuilder page in the Workarea, the user can assign one or
more taxonomy categories that are set in the page’s folder properties. See the following
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example.

As a developer, you can assign a default taxonomy category to a wireframe. If you do,
and the user creating a page using that wireframe makes no changes, the default
category is assigned to the page. However, the user can change the taxonomy when
the Add New Page screen appears.
NOTE: Default taxonomies are applied only when a user logs into a website and
adds a new page -- they are not applied when creating new pages within the
Workarea.
To assign a default taxonomy category to a wireframe:
PREREQUISITE

The ID number and the name of the top-level parent taxonomy for the
default taxonomy category. For example, the screen shows that the
Products category ID is 190, and its parent taxonomy is OnTrek Site
Navigation.
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1. In the Workarea, go to the folder properties screen of the folder to which the
wireframe is applied.
2. Click Edit Properties.
3. Locate the Taxonomy tab of the Edit Folder properties screen.

4. Check the box of the top-level taxonomy to the wireframe you want to assign.
5. Check the box of the parent taxonomy of a taxonomy category that you want to
assign; that is, a child node below a top-level taxonomy.
6. Click Update to save your changes to folder properties.
7. Open Visual Studio.
8. Open the wireframe to which you will assign a default taxonomy.
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9. Find the PageBuilder menu user control.

10. Add the property SelTaxonomyID.
11. For the property’s value, enter the ID of the default taxonomy or category.
Here is an example of that control with the SelTaxonomyID property added.
<ucPageBuilder:PageHost ID="ucCms400Developer"
SelTaxonomyID=”13” runat="server" />

12. Save your changes.
Continuing the example, the next time someone creates a page based on that
wireframe, taxonomy ID 13 will be the page’s default taxonomy category. If desired,
the user can change it by navigating to the Taxonomy tab and assigning different or
additional categories.

Customizing the PageBuilder.config file
The PageBuilder.config file defines what an end user can do with a PageBuilder page.
For example, when a user clicks Resize ( ) in a dropzone, a form appears that lets the
user choose the type of measurements to be used in setting the column layout.
The Resize form has several appearances based on its definition in
PageBuilder.config. The default PageBuilder.config file has the following size
types: Pixel, Em, Percent, and Bootstrap. You can add custom types in the
PageBuilder.config file which is located in the siteroot folder.
PageBuilder allows RWD measurement types, such as Bootstrap, Foundation, and
anything else that allows CSS classes, which give end users more flexibility in building
their Web pages, and site visitors a better Web experience. To see how and end user
uses the responsive PageBuilder types, see Using responsive frameworks with
PageBuilder on page 1087.
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In the following code sample, the Name property identifies types that can show up on
the Resize form (when Enabled is set to true).
<SizeType Name="Pixels" EnumVal="0" Label="Width in pixels:" Enabled="true" />
<SizeType Name="Em" EnumVal="1" Label="Width in em:" Enabled="true" />
<SizeType Name="Percent" EnumVal="2" Label="Percent width:" Enabled="true" />
<SizeType Name="BootStrap" EnumVal="3" Label="BootStrap" Enabled="true"
DropZoneOuterClass="container" DropZoneClass="row">
<SizeType Name="Foundation" EnumVal="3" Label="Foundation" Enabled="true"
DropZoneOuterClass="" DropZoneClass="row" ColumnClass="columns">

IMPORTANT: Any type that uses a CSS class (such as Bootstrap and Foundation)
should set EnumVal to 3.
SizeType properties
<SizeType Name="Pixels" EnumVal="0" Label="Width in pixels:" Enabled="true" />

SizeType. lets you set the size or CSS Classes for a column within a PageBuilder page.
Each SizeType appears as a separate option in the PageBuilder interface. You can have
as many SizeTypes as you want.
l

Name. Specifies the name of the SizeType. This attribute is used only to provide
reference about a SizeType, and does not affect the functionality of PageBuilder in
any way.

l

EnumVal. Determines how to handle the particular SizeType.
o 0 (Pixels). Specify the width of a column using Pixels as a unit of
measurement.
o

1 (Em). Specify the width of a column using Ems as a unit of measurement.
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o

2 (Percent). Specify the width of a column as a percentage of the entire page
width.

o

3 (Any custom CSS classes or CSS Frameworks). You can have any number of
SizeType noes with EnumVal set to 3. For example, you could have a CSS
Framework such as Bootstrap enabled in this file and also define custom
classes. Both of these should have an EnumVal set to 3.

l

Label. The value of this attribute appears in the PageBuilder user interface,
indicating which SizeType should be applied for a column.

l

Enabled. Specifies whether a SizeType appears as an option in the PageBuilder
interface.
NOTE: Bootstrap is disabled by default.

l

DropZoneOuterClass. Applies the class to an outer <DIV> tag of a PageBuilder
dropzone.
NOTE: This attribute has a default value of “container” for the Bootstrap CSS
Framework. If you do not want to have this class applied to any outer <DIV>
tags, set this value to an empty string.

l

DropZoneClass. Applies a CSS Class to the dropzone containing a column when a
page author applies a CSS class from this SizeType to a column within the
dropzone.
NOTE: This attribute has a default value of “row” for the Bootstrap CSS
Framework. If you do not want to have this class applied to any dropzones, set
this value to an empty string.

l

Sub-Nodes
o Group. Ektron supports an unlimited number of CSS Classes to be applied to
PageBuilder columns. For a given SizeType, the “Group” node will specify the
different types of classes that can be applied.
The options within the “Group” node will be displayed within a Dropdown list.
The DropDown sub-node contains all of the available CSS Classes for a group.
o

CSSInclude. This attribute provides the ability for specific stylesheets to be
registered within a PageBuilder page whenever CSS classes that exist within a
SizeType are applied to the page. Ektron provides the ability to apply an
unlimited number of stylesheets for a SizeType.

The code in PageBuilder.config for the Positioning section (Width and Offset dropdowns) is as follows:
<Group Name="positioning" Label="Positioning">
<DropDown Name="width" Label="Width:">
<CssClass ClassName="span1" Label="1 Column" />
<CssClass ClassName="span2" Label="2 Columns" />
<CssClass ClassName="span3" Label="3 Columns" />
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<CssClass ClassName="span4" Label="4 Columns" />
<CssClass ClassName="span5" Label="5 Columns" />
<CssClass ClassName="span6" Label="6 Columns" />
<CssClass ClassName="span7" Label="7 Columns" />
<CssClass ClassName="span8" Label="8 Columns" />
<CssClass ClassName="span9" Label="9 Columns" />
<CssClass ClassName="span10" Label="10 Columns" />
<CssClass ClassName="span11" Label="11 Columns" />
<CssClass ClassName="span12" Label="12 Columns" />
<CssClass ClassName="rowsplit" Label="Split Row" />
</DropDown>
<DropDown Name="offset" Label="Offset:">
<CssClass ClassName="" Label="No Offset" />
<CssClass ClassName="offset1" Label="1 Column" />
<CssClass ClassName="offset2" Label="2 Columns" />
<CssClass ClassName="offset3" Label="3 Columns" />
<CssClass ClassName="offset4" Label="4 Columns" />
<CssClass ClassName="offset5" Label="5 Columns" />
<CssClass ClassName="offset6" Label="6 Columns" />
<CssClass ClassName="offset7" Label="7 Columns" />
<CssClass ClassName="offset8" Label="8 Columns" />
<CssClass ClassName="offset9" Label="9 Columns" />
<CssClass ClassName="offset10" Label="10 Columns" />
<CssClass ClassName="offset11" Label="11 Columns" />
</DropDown>
</Group>

Customizing a PageBuilder .aspx page
Setting a dropzone’s column width programmatically
To set a dropzone’s column widths programmatically:
1. Add the following Register statements to the page’s <head> tags.
IMPORTANT: The Widget and Dropzone assemblies must have the same Tag
Prefix. See example.
<%@ Register Assembly="Ektron.Cms.Widget"
Namespace="Ektron.Cms.PageBuilder" TagPrefix="PB" %>
<%@ Register Src="~/Workarea/PageBuilder/PageControls/PageHost.ascx"
TagPrefix="PB" TagName="PageHost" %>
<%@ Register Src="~/Workarea/PageBuilder/PageControls/DropZone.ascx"
TagPrefix="PB" TagName="DropZone" %>
<%@ Register Assembly="Ektron.Cms.Widget"
Namespace="Ektron.Cms.PageBuilder" TagPrefix="PB"%>

2. Within the page’s <body> tags, add the following code. The following example adds
3 columns that span 4 each of the 12 available column spaces.
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<PH:PageHost ID="PageHost1" runat="server" DefaultPageID="937" SelTaxonomyID="94"
/>
<CMS:DropZone ID="DropZone2" runat="server" >
<ColumnDefinitions>
<PB:ColumnData columnID="0" unit="custom" CssFramework="bootstrap"
CssClass="span4"></PB:ColumnData>
<PB:ColumnData columnID="1" unit="custom" CssFramework="bootstrap"
CssClass="span4"></PB:ColumnData>
<PB:ColumnData columnID="2" unit="custom" CssFramework="bootstrap"
CssClass="span4"></PB:ColumnData>
</ColumnDefinitions>
</CMS:DropZone>

Overriding the default folder where pages are saved
By default, when a site user creates a new PageBuilder page from an existing one, it is
saved to the same Ektron folder. For example, consider this folder/content structure.
-Root (folder id 0)
--Products (folder id 20)
---PageLayout: “Omaha Mailorder Steaks” (content id 35)
--Services (folder id 30)

If you are viewing content id 35 and click New Page or Copy/Save as, the new
page is saved to that content’s folder (Products, folder id= 20).
NOTE: When you create a new page layout from the Workarea, you first select a
folder then begin creating the page layout.
Use the PageBuilder control’s FolderID property in the .aspx page to override the
default and specify an Ektron folder to which new pages are saved. Here is an example
of that property:
<ucPageBuilder:PageHost ID="ucPageHost1" FolderID="25" runat="server" />

When a user is working on a page that hosts this PageBuilder control, and he saves a
new page, it is saved to folder id 25.

Setting a cache interval
Use the CacheInterval property to cache a page and its widgets that represent Ektron
server controls, such as a Collection widget. This property sets the amount seconds for
which data is cached. The default is 0 (zero).
<ucPageBuilder:PageHost ID="ucPageHost1" CacheInterval="25" runat="server" />

Letting users add columns to a dropzone
Use the AllowAddColumn property to let users add columns to a dropzone.
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<ucPageBuilder:DropZone ID="ucDropZone1"
AllowAddColumn="true"
AllowColumnResize="true" runat="server" />

For example, a Dropzone initially contains one column, but the page creator wants 3. If
this property is set to true, this change is possible. This property’s default value is
true.
NOTE: If you set dropzone’s column widths programmatically (as explained in
Setting a dropzone’s column width programmatically on page 1113), the user
cannot add a column, regardless of this setting.

Letting users resize a dropzone
Use the AllowColumnResize property to let users change the width of columns in a
dropzone.
<ucPageBuilder:DropZone ID="ucDropZone1"
AllowAddColumn="true" AllowColumnResize="true" runat="server" />

For example, column width is 100% by default. A page creator wants to change it to
50%. If this property is set to true, this change is possible. This property’s default
value is true.
NOTE: If you set dropzone’s column widths programmatically (as explained in
Setting a dropzone’s column width programmatically on page 1113), the user
cannot add a column, regardless of this setting.

PageBuilder code samples
The following shows a complete example of AcmeBooksMasterPage.master,
PageLayout.aspx, and PageLayout.aspx.cs.

AcmeBooksMasterPage.master
<%@ Master Language="C#" AutoEventWireup="true"
CodeFile="AcmeBooksMasterPage.master.cs"
Inherits="AcmeBooksMasterPage" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<title>Acme Books</title>
<asp:ContentPlaceHolder id="head" runat="server">
</asp:ContentPlaceHolder>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:ContentPlaceHolder id="ContentPlaceHolder1"
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runat="server">
</asp:ContentPlaceHolder>
</div>
</form>
</body>
</html>

PageLayout.aspx
<%@ Page Language="C#"
MasterPageFile="~/AcmeBooksMasterPage.master"
AutoEventWireup="true"
CodeFile="PageLayout.aspx.cs"
Inherits="PageLayout" Title="Untitled Page" %>
<%@ Register
Assembly="Ektron.Cms.Controls"
Namespace="Ektron.Cms.Controls" TagPrefix="CMS" %>
<%@ Register
Src="~/Workarea/PageBuilder/PageControls/PageHost.ascx"
TagPrefix="PH" TagName="PageHost" %>
<%@ Register
Src="~/Workarea/PageBuilder/PageControls/DropZone.ascx"
TagPrefix="DZ" TagName="DropZone" %>
<%@ Register
Assembly="Ektron.Cms.Widget"
Namespace="Ektron.Cms.PageBuilder"
TagPrefix="PB" %>
<asp:Content ID="Content1"
ContentPlaceHolderID="ContentPlaceHolder1" runat="Server">
<PH:PageHost ID="PageHost1" runat="server"
DefaultPageID="937" SelTaxonomyID="94" />
<DZ:DropZone ID="Middle" runat="server"
AllowAddColumn="false" AllowColumnResize="false">
<ColumnDefinitions>
<PB:ColumnData width="100" columnID="0" unit="pixels"></PB:ColumnData>
<PB:ColumnData width="100" columnID="1" unit="pixels"></PB:ColumnData>
<PB:ColumnData width="100" columnID="2" unit="pixels"></PB:ColumnData>
</ColumnDefinitions>
</DZ:DropZone>
</asp:Content>

PageLayout.aspx.cs
using
using
using
using
using
using
using
using
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System;
System.Data;
System.Configuration;
System.Collections;
System.Web;
System.Web.Security;
System.Web.UI;
System.Web.UI.WebControls;
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PageLayout.aspx.cs

using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using Ektron.Cms.PageBuilder;
public partial class PageLayout : PageBuilder
{ protected void Page_Load(object sender, EventArgs e)
{}
public override void Error(string message)
{jsAlert(message);}
public override void Notify(string message)
{jsAlert(message);}
public void jsAlert(string message)
{ Literal lit = new Literal();
lit.Text = "<script type=\"\" language=\"\">{0}</script>";
lit.Text = string.Format(lit.Text, "alert('" + message + "');");
Form.Controls.Add(lit);
}
}
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Social Business changes everything.
l

how employees collaborate, enabling better communication, innovation, and
productivity

l

customer support, allowing customers to support each other in vibrant online
communities.

l

commerce, providing authentic customer-driven ratings and reviews that build
trust.

Is your company ready for the social revolution?
With Ektron Social Business Software, create vibrant social communities for employees
and customers. Socialize key business processes including Sales, Support, Marketing,
and Innovation. Ektron Social Software powers many well-known customer
communities, delivering enhanced customer satisfaction and loyalty. Social is not a
feature, it is a business strategy. Implement your social strategy with Ektron Social
Business Software.
Ektron's Social Business Software consists of the following components.
l

Working with discussion boards on page 1013 (includes Forums and Message
Boards)
The discussion board feature provides topic discussions on your website. A site or
membership user with Add Topic permission creates a topic and posts a starter
question. Site visitors can then reply. Ektron supports an unlimited number of
discussion boards. A discussion board consists of a hierarchy. The following
example shows the hierarchy with sample data, to explain how each element is
used.

l

User Profiles
A membership user can access his or her profile page only from the website. An
Ektron user can access his or her profile from the Workarea or the website.

l

Activity streams on page 1708
An activity stream is a series of chronologically-arranged notification messages
describing activities within Ektron's Community Feature.

l

Managing a blog platform on page 1237
A blog is a form of online information sharing. You create a main blog post, and
others can comment on it. Or, you can use a blog to create an online diary of
everyday life. Your most recent blog post appears at the top with associated blogs
following. Some blogs display a calendar on which days when blogs were created
are highlighted.

l
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Managing calls to action on page 1193
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l

l

User-ranking of content on page 1069
o place a star-based scale on any page of your website
o

let users apply full or half-star rating increments and a comment

o

add reviews, depending on how the feature is used

o

moderate the review comments

o

display reviews and comments next to content for others to see

o

run reports to find the highest-rated content; tweak poorly-rated or reviewed
content to achieve optimal ratings

o

control which reviews get posted through a moderation feature

Managing community groups on page 1651
Community groups are another aspect of a community sites. Group members can
easily meet people with similar interests, such as car racing for example. Groups
have similar features and functions to user features. For example, a community
group can have a Message Board, Discussion Board, maintain a membership list,
and keep a group journal. You can manage community groups from the website or
the Workarea.

l

Sending notifications to a community on page 1665
Ektron's notification system creates and transmits a notification message to
recipients through various agents, based on Ektron activities. The activities may be
performed by a community group, membership user, or an Ektron user. For
example, a membership user wants to notify colleagues whenever a documented is
uploaded to the profile page. When this occurs, an Ektron event is triggered, which
causes a notification agent to send an email to the person's colleagues.

l

Logging in through Facebook on page 122
Facebook Login, an alternative to Ektron's standard login, lets users log in using
their Facebook username and password instead of creating an Ektron username
and password.

l

Targeting content with GeoIP information on page 1919
GeoIP support lets you target your messaging to specific audiences based on
current geographical location. Ektron uses a site visitor’s IP address to detect the
location. For example, your website may have a special sale on snow blowers. That
information is relevant to people in colder climates but of no interest to those living
in the tropics. As another example, a site visitor uses a cell phone to find the
nearest store location. In this case, Ektron Map server control displays a map of
nearby stores based on the user's current latitude and longitude.

l

Creating surveys and polls on page 868
Surveys and polls can show ongoing results to site visitors after they submit their
answers.
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Surveys and polls are a type of form. All of the same functionality is available and
applies.

l

o

A survey is usually multiple questions and appears on your site for a longer
time than a poll.

o

A poll is generally one question and appears on a site for a very short time: an
hour or a day.

Micro-messaging server control
The Micro-messaging server control lets users post brief messages. It resembles
micro-blogging services like Twitter.

l

SocialBar server control
The SocialBar server control lets users of a community website bookmark
colleagues, community groups, and content. It provides access to Twitter,
Facebook, YouTube, and so on.

l

TagCloud server control
The TagCloud server control shows a weighted list of tags assigned to users,
community groups, content, or library items. Tag sizes are proportional to the
number of times they are assigned. For example, there are 2 tags, Software and
Programming. If the Software tag is used 5 times and the Programming tag is used
2 times, the Software tag is approximately twice as large.
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Ektron's marketing suite is digital marketing software that delivers results by driving
leads and increasing conversion rates. Ektron's marketing suite provides a seamless
transition of your existing content management system with an intuitive, easy-to-use
authoring experience and built-in mobile support. Convert your site into an inbound
marketing powerhouse.
Ektron's marketing suite provides easy-to-use tools for marketing campaign managers,
lead generation managers, digital marketers, and content marketing managers.
Ektron's marketing suite helps your content get found faster, provides relevant and
personalized messaging to your visitors to increase engagement, and boosts campaign
performance, converting more visitors to leads and customers. Boost productivity, get
your message to your target market, and deliver a rapid return on investment with
dynamic results to your content, inbound, and digital strategy.
Ektron's marketing suite consists of the following components.
l

Creating personalized Web experiences with personas on page 1137
Leverage categories of users (personas) who fit a targeted demographic, attitude,
or behavior. With personas, you can create a personalized Web experiences based
on common interests, which increases visitor engagement and drives marketing
qualified leads (MQLs) to your sales team.

l

Connecting visitors with targeted content on page 1155
Personalize a site visitor's experience by providing content that matches his or her
interests. For example, you can use the search keywords that were used to find
your site to determine the best offer to show a prospect. You can use other criteria,
such as user profile information, or a submitted survey.

l

Measuring Web experiences with multivariate testing on page 1179
Multivariate testing lets you offer several variations of the same page, then
measure site visitors' reactions to each variation. The one that generates the most
conversions is automatically promoted to the design for that page, thereby
maximizing your website's ROI.

l

Analyzing websites on page 531
The Business Analytics feature lets you track statistics about visits to your website.
You can use it to determine the following kinds of information:

l

l

how often your content was viewed

l

how many site visitors viewed for first time, and how many returned

l

the most popular referral pages (that is, the Web page from which visitors
clicked to arrive on your site)

SEO (Search Engine Optimization)
The SEO server control analyzes your website for W3C compliance, what
information Google has about the page, Alexa rankings, image alt text, keyword
density and metadata. SEO lets you know how (and if) you have set these values.
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l

Managing calls to action on page 1193
A CTA is a user interface element that prompts a site visitor to touch or click it to
proceed on a path toward conversion from site visitor to customer. Some examples
include buttons and links that say Add to cart, Locate Store, Free Coupon, and so
on. See also

l

Managing landing pages on page 1201
A landing page should accomplish a singular conversion goal of your marketing
campaign, such as getting the contact information of your MQL. A page layout
should be concise, avoid scrolling, and keep important information near the top.
You typically create a landing page before a CTA because you will link the CTA to
the landing page.

l

Managing a blog platform on page 1237
A blog platform contains a list of blog authors, their blogs pages, and analytics for
evaluating blog posts and authors.

l

Setting up an ExactTarget connection to collect the form data on page 1134
If you are an ExactTarget cloud marketing platform customer, you can download
the Ektron Marketing Suite app from the ExactTarget HubExchange into your
ExactTarget account.

l

Personalizing a Web page on page 1437
Personalization is fast becoming an integral part of websites like iGoogle and
Facebook, and organizations see personalization as a way to make their sites
"stickier" and more engaging. Ektron provides tools to let membership users
personalize their experience on your site, bringing relevant information to their
fingertips. By letting users add widgets, applications, and feeds to a website,
Ektron provides a framework on which to easily build true, personalized portals.

Traditional outbound marketing advertises a product or service to potential customers
using television and print media, yet traditional advertising delivers the fewest
Marketing Qualified Leads (MQLs) of any form of marketing.
l

Given the opportunity, almost everyone would skip television commercials.

l

Almost half of direct mail is never opened.

l

84% of 25-to-34-year old people actually left a website they enjoyed because of
intrusive or irrelevant ads.

Site visitors have little patience for generic Web experiences that ignore the context of
their visit. The opportunity for marketers is to connect content with context, to deliver
personal Web experiences that deliver business results.
Ektron's marketing suite empowers marketers to create relevant, personalized Web
experiences that deliver better business results. Engage customers with targeted
marketing to drive them to take action. Maximize conversion rates through
sophisticated multivariate testing. Analyze site performance by connecting your Web
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analytics data to your marketing teams in real time. Create business agility by
empowering marketing with both data and tools with the Ektron's marketing suite.
Inbound marketing attracts customers to a website with relevant and useful content.
Inbound websites are agile and responsive, and are specifically designed to optimize
your inbound, content, and digital marketing strategy.
l

In 2013, 60% of companies will have some sort of inbound strategy.

l

34% of leads will come as a result of an inbound marketing strategy.

Inbound marketing follows these stages:
1. Connect (get found). Develop an SEO strategy (moving beyond target keywords)
by having meaningful conversations over social channels that add value to your
community (and not just talking about yourself). Maintain a high level of quality
and consistency over time.
2. Engage (turn a visitor into a lead). Create a great first impression, identify what is
important to a visitor to your website and what that visitor wants to do next, and
persuade the visitor to take the next step. If your website provides the answer your
visitor is looking for, provide more value to engage the visitor. If the visitor comes
to a landing page with a lead capture form, have a compelling offer that
encourages the visitor to proceed.
3. Convert (convert a lead to sales). A visitor is searching the Web, comparing
solutions and trying to learn on their own. Help them by offering the best content
on your website to the person who is engaged in an opportunity. Get the visitor to
take a direct action to validate the relationship and achieve specific results.
4. Retain (develop a loyal customer). Help a visitor get the most out of the visit and
encourage the visitor into ongoing interaction with your website; make a visitor a
return customer.
5. Analyze (and continuously improve). Inbound websites connect with analytic
systems, marketing automation, and CRM systems, and help marketers use that
information to improve conversion results. Start small (for example offer a webinar
based on the industry of your visitor), gain understanding, improve your results,
and grow the impact across more of your website, while you continue to grow and
measure your progress.
Your inbound marketing strategy should include the following:
l

Start with the results that you want to obtain, (for example, increasing the amount
of new pipeline), then develop strategies to accomplish those results.

l

Engage site visitors with strong content that is easily found by search engines.

l

Test combinations of offers to see which produce the best results.

l

Define the personas that you want to reach, then develop a visitor's journey, and
map the content strategy to the journey.

Using landing pages and CTAs to optimize your marketing campaign
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You can build and manage landing pages and calls-to-action (CTA) to control, organize,
and optimize marketing campaigns.
The following example shows 1 way you can convert a visitor to a Marketing Qualified
Lead (MQL). Your CTA could be on a social media page, a website page, or a blog page;
anywhere your target persona may search for information.

Typically, you create this process starting with a marketing campaign. By first creating
the landing pages for the campaign, you can drive traffic and leads to your marketing
program. You then can create the Thank You page to keep the lead engaged and
continue in the funnel. Additionally, you create the CTA to be promoted to best attract
the visitor based on their digital behavior—whether that is on several key traffic pages
of your corporate site, blog posts, or social media channels.
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To create the content marketing experience, you create a campaign with the following
steps:
1. Create landing pages that help you identify Marketing Qualified Leads (MQLs);
someone who is more likely to become a customer versus others who are
"browsing but not buying." MQLs can be identified through analysis of activity data.
See Managing landing pages on page 1201.
You also create a "Thank You" page that provides content or further information to
your MQL for providing contact information.
You can perform the following actions for landing pages.
l
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Actions on a landing page list
o Create New
o

Edit Properties

o

Go to Thank You Page

o

Go to Landing Page

o

Clone

o

Delete
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l

Actions on a landing page
o Edit Content
o

l

Edit Page Template

Actions on a Thank You page
o Edit Content
o

Edit Page Template

2. Create and place call-to-action (CTA) elements (images and text links) on your
pages that encourage a person proceed on a path toward conversion from site
visitor to customer. For example, links that say For more information..., Add to
cart, or Buy now. Allow your CTAs to be shared on social media (through embed
code). See Managing calls to action on page 1193.
You can take the following actions for CTAs.
l

Actions on the CTA list
o Create New
o

Edit

o

Delete

o

Embed Code

3. Create a list of blog authors, using the Blog Authors app, to write content that
people are looking for, and will find when they search for it. As authors create blog
posts, add relevant and contextual CTAs to take the site visitor to a landing page.
See Managing a blog platform on page 1237.
Combine the elements of your inbound and content marketing strategy. For
example, if a potential student is reading a blog post about your university, make
sure that the post has a CTA offer to go on a virtual tour, or check out another
piece of content. This helps the potential student become more familiar with your
school and moves them further down the funnel, therefore making the prospect
more likely to apply.
You can take the following actions for blogs.
l

l

Actions on an authors list
o Create New
o

Go to Author’s Blog

o

Edit

o

Disable

o

Delete

Action on an author’s blog page
o Go to blog post
o

Edit Content

o

Add New Post
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l

o

View Analytics

o

Edit Page

o

Subscribe via RSS

o

Share on social media

o

Search

Actions on a blog posts
o Edit Content
o

View post analytics

o

Add CTA

o

Add Comment

o

Share on Social media

o

Search

o

Go to author’s blog

4. Analyze the effectiveness of your CTAs, landing pages, and channel data based on
your success criteria. For example, how does your email campaign compare to your
advertisement on social media? See Analyzing blog traffic on page 1254.

Setting up Ektron's marketing suite in ExactTarget
NOTE: The ExactTarget feature is part of Ektron's marketing suite on page 1123.
If you are an ExactTarget customer, you can download the Ektron Marketing Suite app
from the ExactTarget HubExchange into your ExactTarget account.
ExactTarget is a leading cloud marketing platform. The company’s solutions
enable marketers to integrate customer data from any source to power
digital marketing campaigns across multiple channels, all while leveraging
sophisticated marketing automation capabilities. More than 6,000
companies around the world, including Coca-Cola, Gap and Nike, rely on
ExactTarget's solutions to drive customer engagement, increase sales and
improve return on marketing investments.—
http://www.exacttarget.com/salesforce/faqs
1. Login to the ExactTarget Marketing Cloud (Login > Marketing Cloud). The login
screen appears.
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2. Enter your ExactTarget username and password, and click Login.

3. On your ExactTarget dashboard, choose ExactTarget HubExchange > Ektron.

4. If this is the first time that you are logging into Ektron from ExactTarget, the
following login screen appears. If you are a returning user, you will see a simple
login screen.
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a. Enter your Ektron Username.
IMPORTANT: Your ExactTarget and Ektron account email addresses
should match. (For example, user@example.com for both email addresses.)
b. Enter your Ektron Password.
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c. Enter your Ektron URL.
NOTE: If you do not have an Ektron URL, click Learn More to contact
Ektron and request a demonstration of Ektron.
5. Click Link Account. Ektron is added to your ExactTarget apps and the Ektron App
launch screen appears.

If you are an administrator, the Ektron Settings button appears in your toolbar. Click
Ektron Settings to change to another URL.
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Setting up an ExactTarget connection to collect
the form data
PREREQUISITE

This procedure requires that you have already set up the Digital Experience
Hub (DXH). For complete information about setting up and using DXH with
Ektron, see Setting Up the Digital Experience Hub.
Before your website forms can send you data, you must set up an inbound connection.
1. Go to Workarea > Settings > Settings > Digital Experience Hub
> Connections. The View All Digital Experience Hub Connections screen appears.
2. Click Add Connections > Add ExactTarget Connection. The Add ExactTarget
Connection screen appears.
l Connection Name. Enter a unique name for this inbound connection. You
should have 1 inbound connection for each site from where you want to collect
data.
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l

Username. Enter the username of the person who will manage the data.

l

Password. Enter the password of the person who will manage the data.

l

Instance. Enter (copy and paste) the cloud server instance identifier that
ExactTarget emailed to you. Instructions for determining which instance you
are on is located at Accessing the ExactTarget Application.
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3. Click Test Connection. If the connection information passes the test, click Save
Connection. The Connection is added to the View All Digital Experience Hub
Connections screen.
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NOTE: The Personas feature is part of Ektron's marketing suite on page 1123.
A persona is a category of user that fits a targeted demographic, attitude, or behavior.
When a person visits your website, Ektron tracks the activity and matches the behavior
pattern to a defined persona. You can present relevant content, information, or
products that match your visitor's unique interests (based on the persona criteria),
thereby driving more marketing qualified leads (MQLs) to your sales team that may
result in a conversion.
A persona should reflect your site visitors' attributes, goals, and behaviors. You should
conduct user interviews and field observations to gather information about how visitors
interact with your site. Analyze what distinguishes some users from others by asking
questions such as the following:
l

What is the target site visitor’s role?

l

What goals or tasks does a site visitor want to achieve by coming to your site?

l

How can you position your content to get this person to take a desired action?

For example, a persona could be Ted the Technical Decision Maker. You know Ted’s
title, and a few pieces of data to identify him, such as his industry, business challenges,
and so on. From this information, you can design a persona to target the current stage
in a site visitor's decision-making process. For each persona you create, define a
personalized set of site features and content to guide the person through the sales
process and, ultimately, have the person perform the desired outcome.
A persona is assigned to a site visitor, and tracked, as follows:
1. On initial page load, the Persona Management HTTP module launches an
asynchronous process that...
a. Checks caches for persona matches and returns personas that match the
current user.
b. If no matches are found, the user's visitor context is recorded and cached.
c. The page is loaded.
2. On second page load, personas are retrieved from cache.
a. If persona matches are found, they are added to cookies.
A persona uses the VisitorContext data class in the
Ektron.PersonaManagement.Common.dll to represent a site visitor's context
and passes collected site visitor information, including any third-party IDs, to
Persona Management. The VisitorContext data class has the following
properties.
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l

Cookies—The current user's cookies. By default, persona providers can
use a site visitor's cookies.

l

Headers—All HTTP headers associated with the current Web request. As
of now, no persona providers use them.
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l

URL—The current URL being browsed. As of now, no persona providers
use this.

l

UrlReferrer—The current user's IP address. As of now, no persona
providers use this.

l

Properties—Can be used for any additional visitor information.

b. If the page is a PageBuilder page that has a Targeted Content widget, the first
Targeted Content rule that includes a matched persona determines the
visitor's site experience. See also: Creating a personalized site experience for
persona (for marketers) on page 1143.
c. The first persona match is sent to Google Analytics. See also: Setting up
analytic tracking for personas (administrators) on page 1152.

Creating a persona (for marketers)
A persona consists of a title, description, attributes, and rules. A persona bridges the
gap between what your internal systems know about site visitors, and what the site
knows about them. By building rules that connect persona names and descriptions to
attributes that define those personas, you can target content and learn more about the
visitors who are using your site.
1. If you are logged on to the server on which Persona Management was installed,
click Windows Start button > All Programs > Ektron > Persona Management
> Persona Management.
If you're using Windows 8 or 2012, press the Windows key (
Persona Management.

) /Q then enter

NOTE: Your system administrator provides sign-on instructions.
2. Click Add ( ). A new persona is created with the title Anonymous Persona, and
generic description text.
3. Edit the title and description by clicking on each. A persona description identifies
the demographics and story of a persona to help create targeted content that is
appropriate to the persona. The description is optional.
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4. To apply attributes to the persona, click Attributes. The attributes panel opens.
Attributes are data fields that define the qualities of a persona, using information
stored in your CRM (such as Salesforce), marketing automation system (such as
Marketo), or any other DXH connection. Examples of persona attributes include the
following:
o industry = healthcare
o annual revenue = $10 million
o position = Chief Technology Officer
If you determine that a site visitor with those qualities fits the profile of an
important buyer of your products or services, create a persona rule using those
criteria. Alternatively, you may use a persona in other marketing channels and
want to track those users as site visitors.
You can choose from among the following attributes:
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l

data. Display all attributes.

l

connection. Display attributes for one enterprise application.
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l

Search. Display attributes that include certain characters only.

You can combine the connection criteria with the search field. For example,
you can find Marketo attributes that include b.

NOTE: By default the Connection drop-down lists all connectors, even
those that are not enabled in DXH. To suppress unused connectors, your
administrator should open
C:\inetpub\PersonaManagement\ektron.persona.app.config and
comment them out.
If you see no attributes for a connection, and you previously saw them, ask
your administrator to research possible problems with the connection. For
example, is its license still valid?
Even if a connection is missing, you can still remove rules that use its
attributes.
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5. Click an attribute that defines this persona and it appears below + add attributes.
6. Choose an operator and value(s) to complete the rule.
Rules are logical statements that include a connection, attribute, operator, and
value. For example:
(Connection)(Attribute) (operator) (value)
Marketo
Employees greater than 5000
l

The connection is type of connector from which you are collecting data.

l

The attribute is a field in the connector.

l

The operator indicates how to match the field and value. Operators correspond
to the attribute's content type. For example, if the content type is string,
operators are: is, is not, contains, starts with, ends with. The
enterprise application determines an attribute's content type.

l

The value represents possible choices for the field in the connector.

7. Add rules until you define the persona completely.
8. Click Save (

).

Editing a persona
1. Click the title of the persona that you want to edit. It opens up.
2. Click Attributes.
l To delete a rule, click its field then click Delete (
).
l

To cancel editing (and undo your changes since you started editing), click
Cancel ( ). If you do, current edits are ignored, and the persona collapses.

Deleting a persona
To delete a persona, click Delete (

). Then confirm your decision.

You can delete a persona whether it is open or closed.
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Creating a personalized site experience for
persona (for marketers)
After you create a personas, an Ektron site administrator can use it with the Targeted
Content widget, to develop personalized site experiences that move individuals through
the marketing funnel. The Targeted Content widget uses personas and other criteria to
customize the experience for that person. For example, if the persona is CTO in the
data storage industry, you may offer a white paper to download called, Widespread
adoption of flash in the enterprise data center. On the other hand, if the persona is
CTO in the Web Analytics industry, you may offer a white paper to download called,
Latest research in Web analysis, conversion optimization, funnel analysis and decision
support systems.
1. Log into your website and go to the PageBuilder page on which you want to display
personalized content for a persona.
2. Place a Targeted Content widget onto the page.
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3. In 1 or more Targeted Content widget conditions, use a persona that you created.

4. You can add fields to each condition to further identify the site visitor who will
receive personalized content. In the example, the site visitor's country must be
United States or United Kingdom. If a site visitor matches more than one targeted
content rule, the first matching rule (as ordered in the Targeted Content widget)
determines which content appears.
5. You also can place widgets in the Targeted Content Widget, which appear only if
the site visitor matches the conditions. For information about adding widgets to the
Targeted Content widget, see Creating a targeted content configuration on
page 1176.

Installing persona management (administrators)
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You can install Persona Management (PM) on the DXH or Ektron server. Consult a
certified Ektron partner when planning a Persona Management deployment. The
following image shows setup tasks for communicating between Ektron, DXH, and
Persona Management.

l

You can install Ektron, DXH, and Persona Management on the same server.

l

You can install Ektron on one server, and DXH and Persona Management on
another.

l

You can install Ektron and Persona Management on one server, and DXH on
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another.

PREREQUISITE: PERSONA MANAGEMENT REQUIREMENTS
l

An HTML5 CSS3-compliant browser.

l

A server that meets the Ektron System Requirements.

l

Ektron 9.00 or higher. See also: Installing Ektron on page 9.

l

DXH 2.0 or higher.

l

A connection established for every enterprise application whose
attributes you will use on the Manage Personas screen.

1. Contact your Ektron account manager to obtain a link to download the Persona
Management installation file.
2. Download and run the Persona Management installation file as an administrator.
3. Accept the license agreement.
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4. Click Next. Select a folder in which to save Persona Management installation files.

5. Click Next. Enter the path to the DXH with which Persona Management will
connect, which you can obtain by logging onto the DXH server and clicking the
Windows Start button > All Programs > Ektron > DXH > DXH Connection
Url. (If you're using Windows 8 or 2012, press the Windows key (
enter DXH Connection Url.)

)/Q then
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NOTE: If you need to change this path, open
C:\inetpub\PersonaManagement\web.config and edit the value of the
ContextBusEndPointUrl element.
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6. Click Next. Enter database connection information.

l

Server. Enter a database server in which to store Persona Management
information. To set up the database on this server, accept the default.
Otherwise, enter a SQL or SQL Express server that already exists. For a local
SQL, this would typically be (local). For SQL Express enter
(local)\SQLExpress.

l

Username. Enter the user name that will be used to access the database.

l

Password. Enter the password that will be used to access the database.
NOTE: If you want to use NT authentication and set up a trusted
connection, leave the user name and password blank.
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7. Click Next. You are prompted to click Install to begin installing files.

Click Install to complete the installation.
8. On the Ektron server, open the Ektron siteroot folder/web.config file.
9. Remove the comment (<!-- and -->)from the following tag.
<!--<add key="PersonaManagementEndPointUrl" value="http://localhost"/>-->

10. For the value of PersonaManagementEndPointUrl, enter the path to the Persona
Management application, which you can obtain by clicking the Windows Start
button > All Programs > Ektron > Persona Management > Persona
Management. Make sure the path has no trailing slash (/).
If you're using Windows 8 or 2012, press the Windows key (
Persona Management.

)/Q then enter

11. Remove the comment (<!-- and -->) from the following tag.
<!--<add name="PersonaManagementMatchesModule"
type="Ektron.Cms.PersonaManagement.HttpModules.PersonaMatchesModule,
Ektron.Cms.PersonaManagement" preCondition="integratedMode" />-->

12. Save web.config.
After installing Persona Management, you have 2 options to grant access to users who
will manage personas.
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l

Install Persona Management on an internal server, and restrict access to
authorized users.

l

Use Windows authentication to control access to the Persona Management site.

Controlling persona attributes (administrators)
The following data sources and objects populate the Persona Management attributes
list.
l

ExactTarget. Subscriber

l

HubSpot. Contacts

l

Marketo Lead Management. Lead

l

Pardot. Prospects

l

Salesforce. Lead, Contact, Account

l

Microsoft Dynamics CRM. Lead, Contact, Account. Within these Microsoft
Dynamics forms, Ektron supports only these field types:
Bool, Customer, DateTime, Float, Integer, Status, Lookup, Memo,
Picklist, PrimaryKey, State, String

Modifying the attributes list
To add or remove supported objects from the attributes list for a data source:
1. Open persona.app.config in the directory where Persona Management was
installed.
2. Find the data source that you want to modify. For example, Salesforce.
<add dataSourceId="Salesforce" dataSource="Salesforce"
type="Ektron.PersonaManagement.DXH.SalesForceAttributeProvider,
Ektron.PersonaManagement.DXH.DataSources"
whiteListObjectNames="Contact"
blackListObjectNames=""/>
l

To add objects to the attributes list, edit the whiteListObjectNames property.
After any existing objects, insert a comma (,) then object names.

l

To exclude objects from the attributes list, edit the blackListObjectNames
property.

l

If both properties are left blank, the data source's objects are available.

Removing data sources from the attributes list
You may want to eliminate data sources from the Persona Management screen. For
example, if your site does not use HubSpot, there is no need to see HubSpot attributes
in the list.
1. Open persona.app.config in the directory to which Persona Management is
installed.
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2. Comment out the data source, as shown in the following example.
<!-- <add dataSourceId="Salesforce" dataSource="Salesforce"
type="Ektron.PersonaManagement.DXH.SalesForceAttributeProvider,
Ektron.PersonaManagement.DXH.DataSources"
whiteListObjectNames="Contact"
blackListObjectNames=""/> -->

Setting up analytic tracking for personas
(administrators)
Google Analytics lets you track persona activity on your site. You can discover the
following information about users who match a persona:
l

visit duration, bounce rate

l

geographic location, language

l

new vs. returning visitors

l

paths visitors took through your site

l

browser, network information

l

top content, top landing and exit pages

You can use analytic information to refine a persona's Web experience, and with other
Ektron features like Multivariate Testing, ultimately increase their conversion rate.
When you tracks analytic activity with persona data, these events typically occur.
1. An Ektron website visitor completes an HTML form that maps to an enterprise
application, such as Salesforce.
2. If a field value on the form matches a persona, a cookie is placed on the person's
device. For example
l On the HTML form, the user entered Chief of Operations into the Title field.
l

The persona definition contains attribute=Title, operator=contains, and
value=Chief.

NOTE: If a site visitor matches more than one persona, only the first one (as
ordered on the Persona Management screen) is applied to that user's activity.
3. Google Analytics uses the cookies to track the user's activity, and categorizes it
under the identified persona.
4. Within Ektron, use the Google Analytics feature to track persona activity.
The following image shows communications between Ektron, DXH, and Persona
Management.
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To set up analytic tracking for personas:
1. Create a Google Web Analytics account, if you do not already have one.
2. Open siteroot/web.config.
3. Add the following key under <appsettings>.
<add key="Persona_GoogleAccountId" value="UA-*****-**" />

4. Replace the value parameter with your Google AccountId.
5. Also, uncomment the following element.
<add name="PersonaManagementMatchesModule"
type="Ektron.Cms.PersonaManagement.HttpModules.PersonaMatchesModule,
Ektron.Cms.PersonaManagement" preCondition="integratedMode"/>

6. Register Ektron.PersonaManagement.Analytics.js in the master page(s) or any
page on which you want to track persona, using this code.
<script src="Workarea/FrameworkUI/js/Ektron/Ektron.PersonaManagement.Analytics.js">
</script>

Ektron Reference

1153

(This page intentionally blank.)

Chapter 18

Connecting visitors with
targeted content

Ektron Reference

1155

Connecting visitors with targeted content

NOTE: The Targeted Content widget feature is part of Ektron's marketing suite on
page 1123.
You can personalize a site visitor's experience by providing content that matches their
interests. This places your site information in the context of your users. For example,
the search keywords used to find your site might determine the best offer to show a
prospect. Or, site members might explicitly state their interests by adding to their user
profile, or by filling out a survey.
The Targeted Content widget lets you gather information from each interaction, and use
that information to direct visitors to content that relates to their specific interests.
Each Targeted Content widget has 1 or more conditions, and each condition can have 1
or more criteria. For example, a condition may stipulate that the URL parameter
terms contains pizza or terms contains Italian.

After assigning conditions to a Targeted Content widget, you assign one or more
widgets to it, which appear on the page only if a condition evaluates to true. To continue
the example, if the page has a URL parameter that contains "pizza," you display a

1156

Ektron 9.40 SP1

Connecting visitors with targeted content

Taxonomy Summary widget that shows content to which the taxonomy category
"pizza" is assigned.

You can assign any number of conditions to the Targeted Content widget. As soon as
one is true, its associated widgets appear, and any remaining conditions are ignored.
The Targeted Content widget can evaluate the following information about a site visitor.
l

search engine or URL that directed the visitor to the page

l

the page's URL parameters

l

the visitor's device, such as a Smart Phone

l

the page from which the visitor was directed

l

GeoIP regional information about the visitor: U.S. state or country

l

Facebook profile information, such as marital status

l

whether a certain cookie is on the person's computer

l

if logged in
o user or membership group to which the visitor belongs
o

any custom user properties that match your criteria
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l

the current date and time on the Ektron server

The following examples show how you can use the Targeted Content widget.
l

Your jewelry store is promoting gold necklaces. You create a hyperlink with a
Campaign ID of gold. For example,
http://www.mystore.com/product.aspx?cid=gold. In the Targeted Content
widget, set the condition URL Parameter CID contains gold.
If condition = true, the Targeted Content widget displays a ContentBlock widget
that promotes gold necklaces.

l

You are promoting a race to NASCAR fans. Your site has a membership group for
NASCAR fans, and anyone visiting the site can join. In the Targeted Content
widget, create a condition If user is in Group NASCAR.
If condition = true, the Targeted Content widget displays a WebCalendar widget
that lists upcoming NASCAR races.

l

On Sunday Feb. 28, you are running a sale: all couches are 50% off. In the
Targeted Content widget, set Date is 2013-02-28.
If condition = true, the Targeted Content widget displays a TaxonomySummary
widget that lists all couches and the discounted price.

l

Display the "Engineering" Community Group's activity stream to its members. You
have a Community Group for the Engineering Department. In the Targeted Content
widget, set User is In GroupEngineering.
If condition = true, the Targeted Content widget displays an Activity Stream
widget, set up as follows:

l

l

ObjectID= ID of the Engineering group

l

FeedType = Community Group

If the referring page is a Search Engine and its keywords include Pizza, you want to
show a list summary of Pizza shops. Assume your content includes restaurant
listings, and taxonomy categories are applied to this content. One category is
pizza. In the Targeted Content widget, set Search Engine Keywords is Pizza.
If condition = true, the Targeted Content widget displays a TaxonomySummary
widget that lists all content assigned to the category Restaurants > Pizza.

l

If a site visitor's Facebook profile "likes" Ektron, display Ektron products. In the
Targeted Content widget, set the condition Facebook Info: Likes contains
Ektron.
If condition = true, the Targeted Content widget displays a ContentBlock widget
that promotes Ektron products.

Specifying criteria for a Targeted Content widget
PREREQUISITE
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The Targeted Content widget must be in the list of widgets assigned to the
page's template. See Adding the wireframe and widgets into Ektron on
page 1103.
1. Place the Targeted Content widget onto a PageBuilder page.
2. Click New Condition.

NOTE: Global configurations are created and stored in the Workarea. If they
are already created, you can click Select Global Configuration and select one for
use. See Choosing a targeted content configuration on page 1177 and Creating
a targeted content global configuration on page 1175.
3. Enter a condition name.
4. Click +or to set up the first condition and select an option from the drop-down list
of condition criteria. See also: Using multiple criteria in a condition on page 1167.
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l
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ExactTarget ExactTarget.Subscriber. Displays if the connector is installed.
o Email Address
o

Full Name

o

Marital Status

o

Age

Hubspot Hubspot.Contact. Displays if the connector is installed.
o Email Address
o

Company

o

First Name

o

Last Name

o

Address

o

City

o

State

o

Country
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l

Marketo Activity. Displays if the connector is installed.
o Opened Email
o

l

l

l

l

Sent Email

MSDynamicCRM Lead. Displays if the connector is installed.
o Company Name
o

Industry

o

Number of Employees

o

Revenue

o

Promotion

o

Score

Pardot Pardot.Prospect. Displays if the connector is installed.
o Email Address
o

Company

o

First Name

o

Last Name

o

Address 1

o

Address 2

o

City

o

State

o

Country

Salesforce Lead. Displays if the connector is installed.
o Company Name
o

Industry

o

Number of Employees

o

Revenue

o

Products Owned

o

Product Interest

o

Score

Search Engine. Use to specify widgets that appear
o If a site visitor was referred to this page from any search engine (or not)
o

If the search engine from which the site visitor was referred is one of the
following
n Google
n

Bing

n

Yahoo

n

Other

n

None
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o

If the search engine's keywords are (are not, contain, start with, or end
with) a specified value

l

Referring URL. The referring host matches a string value (for example,
www.example.com). Use this to determine the visitor 's originating site, such as
a Facebook fan page.

l

URL parameter. The current page contains the specified URL parameter. For
example, you create a campaign selling gold jewelry and base its content on
the URL parameter cid=gold.
If the URL of the page that hosts the Targeted Content widget contains
cid=gold (for example,
http://www.mystore.com/product.aspx?cid=gold), then display widgets
assigned to that Targeted Content widget.

l

Cookie. A cookie matching the specified pattern is found on the site visitor's
computer. Cookies are generally stored as name/value pairs, such as UserID—
A9A3BECE0563982D. When checking for a cookie, you complete 3 fields.
o cookie ID
o

logic (is, is not, contains, starts with, ends with)

o

a value

l

Device Configuration. The user's device matches a Device Groups that you
specify. For example, a content block displays only if a user accesses your
website with a Smart Phone. See also: Adding a group by device model on
page 517.

l

BreakpointConfig. The user's device matches a breakpoint that was defined
in Adding a group by breakpoint on page 513.

l

Logged in—The user is or is not logged in.

l

User is in group. Only applies to logged-in users. User is member of an
Ektron User or Membership Group that you select from drop-down list.See
also: Membership users and groups on page 1625, Managing users and user
groups on page 1555

l

User is in community. Only applies to logged-in users. User is a member of
an Ektron Community Group that you select from drop-down list. See also:
Managing community groups on page 1651

l

User Properties. Only applies to logged-in users. The value of the logged-in
user's custom property satisfies the logic for the value you specify. See also:
Creating custom user properties on page 1568
Example:
Zip code is a Custom User Property. You want to display a list of stores in New
Hampshire for users whose Zip Code begins with 03.
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l

o

Condition / result

o

Zip code = 03458 true

o

Zip code = 02103 false

Date and Time: Day. The actual date (according to the Web server's clock)
and a date you enter satisfy the specified logic.
Logic operators:
o

is

o

is not

o

less than

o

greater than

o

equal to or less than

o

equal to or greater than

Examples:

l

o

Assume today's date is 2010-01-01

o

Condition / result

o

Date = 2010-01-01 true

o

Date < 2010-01-01 false

o

Date >= 2009-12-01 true

Date and Time: Day of Week. The current day (according to the Web
server's clock) satisfies the specified logic.
Logic operators:
o

is

o

is not

Examples:

l

o

Assume today's date is 2010-03-01 (Monday)

o

Condition / result

o

Day of week is Monday true

o

Day of week is Tuesday false

o

Day of week is not Tuesday true

Date and Time: Day of Month. The actual date (according to the Web
server's clock) and a date you enter satisfy the specified logic.
Logic operators:
o

is

o

is not

o

less than

Ektron Reference

1163

Connecting visitors with targeted content

o

greater than

o

equal to or less than

o

equal to or greater than

Examples:

l

o

Assume today's date is 2010-03-01 (Monday)

o

Condition / result

o

Day of month is 01 true

o

Day of month is not 01 false

o

Date >= 2009-12-01 true

Date and Time: Hour of Day. The actual hour (according to the Web
server's clock) and number between 1 and 23 you enter satisfy the specified
logic. The numbers are based on a 24 hour clock so, for example, 5 p.m. is 17.
Logic operators:
o

is

o

is not

o

less than

o

greater than

o

equal to or less than

o

equal to or greater than

Examples:
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o

Assume current time is 18:30:00

o

Condition / result

o

Hour of day is 18 true

o

Hour of day is 23 false

o

Hour of day >= 12 true

l

User Regional Info. Enter the user's country or state, or both. State
selections are limited to states in the United States. This information is
retrieved from the IP address of the person who is using your website. To
retrieve this information, see Targeting content with GeoIP information on
page 1172.

l

Facebook Info. If the criterion matches information in the user's Facebook
profile, display the widgets inserted into this condition. For example, if the
criterion is Marital Status is Single and the user's Facebook Profile matches
that value, display the assigned widgets. This criterion only works with users
who log in via Logging in through Facebook on page 122. You can apply any of
these Facebook fields.
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o

Age

o

Gender

o

Marital Status

o

Likes

o

Employment

Use Contains with Free Text Fields
On fields that use free text (such as Likes), you should use the contains
operator, as opposed to is or is not. Contains is more flexible and finds a
partial match. For example, if the user likes U.S. Soccer and you enter the
term soccer and the contains operator, a partial match is made, so the user
sees the related widget. On the other hand, if the user likes U.S. Soccer and
you enter the term soccer and the is operator, an exact match is not made,
so the user does not see the related widget.
The Likes Field
The Likes field lets you search through users' Facebook profile Likes and
Interests. Or, you can narrow it down to a specific like/interest. For example,
you could display a widget promoting Red Sox merchandise if, in their
Facebook profile, users like a Sports Team that contains Red Sox.
l

Submitted For Data. Uses field and value for a form (by ID).

l

Persona Title. The site visitor matches the persona that you define in this
condition. See also: Creating personalized Web experiences with personas on
page 1137.

l

Otherwise. No condition evaluates to true.
NOTE: You would typically use this criterion last, since it always evaluates
to true. Any conditions below this are ignored.

5. Add additional criteria as desired.
6. Click Save.
7. Click a widget and place it into the Targeted Content widget. You can place more
than 1 widget into the Targeted Content widget. If the condition is true, the
widgets you place there appear.
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8. If the widget requires you to fill out properties, click Edit (
screen.

1166

Ektron 9.40 SP1

) and complete the

Using multiple criteria in a condition

Using multiple criteria in a condition
A condition can have several criteria joined by and an AND operator.
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In the following example, all conditions must be true for the widgets assigned to this
Target Content widget to appear.
l

the user is logged in

l

today's day must not be Sunday

l

the user is a member of the Ektron user group Administrators

If any of these condition is not true, the next condition assigned to the widget is
evaluated, if one exists.
If all conditions are true, the widgets assigned to this Targeted Content widget appear.
Additional conditions assigned to this widget are ignored.
You can also specify an OR relationship among criteria in one condition. To do so, click
+or below any condition, then enter the OR condition.
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For example, assume you want the user's country to be only the Bahamas or Bermuda.
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Each set of criteria is evaluated independently. If any criteria set is true (that is, all of its
statements are true), the widgets assigned to this Targeted Content widget appear.
Additional conditions assigned to this widget are not evaluated. If none of the criteria
sets is true, the next condition assigned to the widget is evaluated, if one exists.

Targeting content with Salesforce data
The Targeted Content widget personalizes a Web page by displaying content based on
information from a user-completed form. When a user submits a form, the external
application connector (such as Salesforce) writes a user ID for that user's login back to
Ektron. This enables the delivery of targeted content based on the user's identity. For
example, if the Salesforce MQL's industry is healthcare, the page may display content of
interest to healthcare professionals.
1. Determine Targeted Content widget criteria from the external application forms
and fields in the siteroot/dxhTargetingRules.config file. The following sample
shows the default portion of this file.
<dxhRules>
<Adapter name="Salesforce">
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<AdapterObject name="Lead">
<add name="Company Name" value="Company"/>
<add name="Industry" value="Industry"/>
<add name="Number of Employees" value="NumberOfEmployees"/>
<add name="Revenue" value="AnnualRevenue"/>
<add name="Products Owned" value="Products Owned"/>
<add name="Product Interest" value="ProductInterest"/>
<add name="Score" value="Rating"/>
</AdapterObject>
</Adapter>

Tag Descriptions
l

<dxhRules>. The file's root tag.

l

<Adapter name>. The adapter for which to display object rules, such as
Salesforce or MSDynamics. It is not the connection name (for example,
marketingSF).

l

<AdapterObject>. The system name of the object within the specified
adapter. For example, to enter a Salesforce lead, insert the system name Lead
(case-sensitive).

l

<add ...>. The field. The name attribute contains text that the end user sees
(as shown in the following image). The value attribute contains the system
name of the field.

NOTE: The field's datatype is recognized and automatically surfaced into the
correct rule type; numeric rule for an integer or decimal, string rule for a string,
a multi-select rule for a pick list, and so on.
2. Access either a Targeted Content widget or a Targeted Content configuration.
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3. Click the Or+ button to add a criterion for the widget.

4. Select an adapter and field. For example, Salesforce Lead > Industry.
5. Enter additional fields as you would in any Targeted Content widget or
configuration.
6. Save the widget and test it.
See also: Creating personalized Web experiences with personas on page 1137.

Targeting content with GeoIP information
GeoIP support lets you target your messaging to specific audiences based on current
geographical location. Ektron uses a site visitor’s IP address to detect the location. For
example, your website may have a special sale on snow blowers. That information is
relevant to people in northern climates but of no interest to those living in the tropics.
Or, a site visitor uses a cell phone to find the nearest store location, and the Ektron Map
server control displays a map of nearby stores based on the user's current latitude and
longitude.
Ektron maintains GeoIP information in a cookie only while a visitor uses the site. When
the visitor exits, Ektron deletes the cookie. Ektron obtains the following information
from the IP address of your site visitors. (The values are only examples.)
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l

IP Address—208.32.120.10

l

Country code and name. United States

l

Region. NH (New Hampshire)

l

US area code. 603

l

US metro code. 506
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l

City. 506

l

US zip code. Nashua

l

Latitude and longitude. 42.7551/-71.4853

l

Organization. Sprint

l

Domain name. www.example.com

Ektron includes GeoLite data created by MaxMind. You can purchase more accurate
GeoIP databases from MaxMind.
Ektron retrieves the IP address information from a site visitor's IP address via 3
databases. The databases are installed to your site root's App_data folder and listed in
your site's web.config file.
NOTE: The tilde character (~) in the value element represents the site root folder.
l

<!-- GeoIP City Database -->
<add key="GeoIpCityDatabase" value="~/App_Data/GeoLiteCity.dat"/>
Returns the following information, based on IP address:
o

Area code

o

City

o

US State

o

Country code and name

o

Latitude and Longitude

o

MetroCode

o

PostalCode

Telephone area code
<!-- GeoIP Organization Database -->
o

l

<add key="GeoIpOrgDatabase" value="~/App_Data/GeoIPOrg.dat"/>
Returns the organization name, based on IP address.
l

<!-- GeoIP Domain Database -->
<add key="GeoIpDomainDatabase" value="~/App_Data/GeoIPDomain.dat"/>
Returns the domain name, based on IP address.

If you want to move the databases to another folder, you must update their
web.config value elements to the new location.
BEST PRACTICE
You should keep the GeoIP databases in the App_data folder, because this
folder prevents unauthorized copying of the database.

Using GeoIP information in the Targeted Content widget
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Among the Targeted Content widget's criteria is User Regional Info, which has 2
options: Country and US Regions.

If you choose US Regions, you can select from states in the United States.
User Regional Info data uses GeoIP information. See also: Specifying criteria for a
Targeted Content widget on page 1158.

Using GeoIP information in the Map server control
You can center a map on a specific location by using the Map server control's latitude
and longitude properties. You also can use GeoIP information to obtain a user's
latitude and longitude, based on IP address. For example, if a site visitor searches for a
chain restaurant, the map can indicate restaurants near the user.
The following code shows how to set up the Map server control to populate latitude and
longitude with GeoIP information.
Sample .aspx page, showing the placement of the Map server control.
<cms:Map ID="uxMap" runat="server" />

Code-behind page in C#
Ektron.Cms.UserLocationData userLocationData =
Ektron.Cms.UserContext.GetCurrentUserLocationInfo();
if(userLocationData != null)
{
uxMap.Latitude = userLocationData.Latitude;
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uxMap.Longitude = userLocationData.Longitude;
}

Accessing GeoIP information with the API
The following API code demonstrates the retrieval of a user's GeoIP information. Note
that Ektron.Cms.UserContext.GetCurrentUserLocationInfo() returns the
Ektron.Cms.UserLocationInfo() object, which provides access to all elements listed
in retrieving IP address information except IP address.
To obtain the IP address, use Ektron.Cms.UserContext.IP.
Ektron.Cms.UserLocationData userLocationInfo =
Ektron.Cms.UserContext.GetCurrentUserLocationInfo();
//If GeoIpCity.dat/GeoIpLiteCity.dat file is present in webconfig
int AreaCode = userLocationInfo.AreaCode;
string City = userLocationInfo.City;
string CountryCode = userLocationInfo.CountryCode;
string CountryName = userLocationInfo.CountryName;
double Distance = userLocationInfo.Distance(userLocationInfo);
int DMACode = userLocationInfo.DMACode;
double Latitude = userLocationInfo.Latitude;
double Longitude = userLocationInfo.Longitude;
int MetroCode = userLocationInfo.MetroCode;
string PostalCode = userLocationInfo.PostalCode;
string Region = userLocationInfo.Region;
string RegionName = userLocationInfo.RegionName;
// If GeoIpOrg.dat file and GeoIpCity.dat/GeoIpLiteCity.dat file
// is provided in web config
string Organization = userLocationInfo.Organization;
// If GeoIpDomain.dat and GeoIpCity.dat/GeoIpLiteCity.dat file
// is provided in web config
string Domain = userLocationInfo.Domain;

Creating a targeted content global configuration
A Targeted Content Global Configuration is a Targeted Content widget that you create
and store in the Ektron Workarea. When users drop a Targeted Content widget onto a
PageBuilder page, they can select any configuration defined in the Workarea. A
configuration lets you reuse the same Targeted Content widget on any number of
pages.
After choosing a Targeted Content Global Configuration, you cannot edit its conditions
on that page. You can edit the configuration only in the Workarea. If you later change a
configuration setting, all widgets using that configuration are automatically changed.
See Editing a targeted content configuration on the next page.
IMPORTANT: If you apply no conditions to a configuration and reference it in a
Targeted Content widget on a PageBuilder page, nothing appears on the page.
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Creating a targeted content configuration
PREREQUISITE

To access this screen, you must be a member of the Administrators group.
1. Go to Workarea > Settings > Configuration > Personalizations > Targeted
Content.
2. Click Add. The Add Target Content Configuration screen appears.
3. Enter a Title.
4. See Specifying criteria for a Targeted Content widget on page 1158 to complete the
Targeted Content Configuration. You can add widgets to each Targeted Content
Configuration using the widget tray that is attached to the Workarea menu bar.

5. Click Save.

Editing a targeted content configuration
If you edit a Targeted Content Configuration that is placed on one or more PageBuilder
pages, the pages show the changes after you publish the page.
PREREQUISITE
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To access this screen, you must be a member of the Administrators group.
1. Go to Workarea > Settings > Configuration > Personalizations > Targeted
Content.
2. Click Edit ( ) to the left of the configuration you want to edit. The widget appears.
3. See Specifying criteria for a Targeted Content widget on page 1158 to edit the
widget.
4. Click Save.

Deleting a targeted content configuration
IMPORTANT: After you delete a Targeted Content Configuration that was placed on
a PageBuilder page, the page displays a blank area where the widget was dropped.
PREREQUISITE

To access this screen, you must be a member of the Administrators group.
1. Go to Workarea > Settings > Configuration > Personalizations > Targeted
Content.
2. Click Delete ( ).
3. Check the box to the left of the configuration you want to delete.
4. Click Delete.

Choosing a targeted content configuration
To reuse a Targeted Content Configuration:
PREREQUISITE

The PageBuilder page must include the Targeted Content widget.
1. Edit a PageBuilder page.
2. Place a Targeted Content widget onto the page.
3. Click Select Global Configuration.
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4. Choose the Targeted Content Configuration you want to place on the page.

If you select Restaurants, for example, it appears in the Targeted Content widget.

5. Save, check in, or publish the page.
NOTE: You can apply a global configuration to an existing widget. If you do, the
global configuration replaces all conditions and results you previously applied.

Customizing the Targeted Content widget
To create a custom version of the Targeted Content widget (for example, to add rule
templates):
1. Open the siteroot/widgets/Edit TargetedContent.ascx.cs file.
2. Create a class, (for example, MyRuleTemplate), that inherits
Ektron.RuleEditor.RuleTemplate in #region Rule Templates.
3. Modify private void AddAllRuleTemplates.
4. Add an instance of your class to the rest of the rule templates. For example,
AddRuleTemplate(new MyRuleTemplate());
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NOTE: The Multivariate Testing feature is part of Ektron's marketing suite on
page 1123.
Multivariate testing lets you offer several variations of the same page, then measure
site visitors' reactions to each variation. The reaction that generates the most
conversions during the testing period is automatically promoted to the design for that
page, thereby maximizing your website's ROI.
For example, the marketing manager wants to know which of 3 ads produces the most
visits to a registration page.

1180

Ektron 9.40 SP1

Setting up a multivariate experiment

l

The experiment page contains ads that link to a registration form.

l

A target page contains the registration form.

l

When a visitor goes to a special page called the target, it is logged as a conversion.
(A conversion might be a donation, registration, sales lead, and so on.)

Conversions are tracked, and when the target number of conversions occurs, the
variation achieving the best results automatically becomes the permanent page on the
site, without intervention by the website administrator.
You can create variations for a number of page elements (images, copy, buttons, form
fields, and so on) to find the combination that most effectively compels site visitors to
take the next step. You can use actual, timely data to drive decisions.
Multivariate testing is easy to implement, requiring no help from a developer or
designer.
IMPORTANT: The Multivariate Testing feature requires the use of PageBuilder
templates. For more information, see Developing wireframe templates on
page 1093.

Setting up a multivariate experiment
PREREQUISITE

To set up and run a Multivariate experiment, you must be an Administrator
or have the Multivariate Tester Role assigned. See also: Defining roles on
page 1581.
To set up a Multivariate experiment:
1. Create a target page that contains the Target widget. See also: Creating a
multivariate target page on the next page.
2. Create an experiment page that contains the content variations with the
Experiment and Section widgets. See also: Creating a multivariate experiment
page on page 1183.
3. Run the experiment until it ends automatically or you stop it. See also: Running a
multivariate experiment on page 1188.
Use these PageBuilder widgets for Multivariate Testing.

l

Multivariate Target widget. Place this on the Web page that contains the content
that you want people to find. When a page view occurs on a page that contains this
widget, the conversion count increases.
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l

Multivariate Experiment widget. Controls the experiment and its data, all
information about the variations in an experiment, the Start and Stop buttons, and
conversion limits. Use only one Experiment widget per PageBuilder page.
NOTE: The Multivariate Experiment widget temporarily stores data in server
memory before writing to the database in batches of 100, by default. If you
want to change the batch size, insert the following key into the
siteroot\web.config file, within the <appsettings> tags: <add key="ek_
MultivariateThreshold" value="100"/>.
Change the value to adjust the batch size.
If logging is enabled and the key is missing from web.config, Ektron creates a
warning and provides the key in the event viewer.

l

Multivariate Section widget. Contains the content of the experiment. By using a
variety of content combinations, the experiment tests the best content
arrangement to accomplish the desired conversion goals.

Creating a multivariate target page
The target page is the Web page you want your visitors to view. It contains the
Multivariate Target Wizard. Visitors arrive here by clicking links on the experiment
page.
To create the target page:
1. Create or edit the PageBuilder page with the target content. See also: Creating
Web pages with PageBuilder on page 1075.
2. Note and record the ID of the content on this page. (For example: 948.) You use
this number in Step 2 of Creating a multivariate experiment page on the facing
page.
3. Place the Multivariate Target widget anywhere on the page.
Whether you arrive at the target page by browsing to the variations page first or by
browsing to the target page directly, the views are counted with the following
exceptions:
l

if you are logged in

l

if you have not first visited the experiment page to receive the cookie

l

if you have cleared the cookies before visiting the target page

NOTE: Logged in users are counted as a page view of the experiment page, but
not as a conversion on the target page.
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4. Publish the page
Next, create the Multivariate Experiment Page.

Creating a multivariate experiment page
The Experiment page contains:
l

an Experiment widget

l

one or more Section widgets

l

content variations

The following illustration shows steps for creating an experiment page with Multivariate
Test widgets.
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To create a multivariate experiment page:
1. Create or edit the PageBuilder page you want to use during the experiment. See
also: Creating Web pages with PageBuilder on page 1075.
2. Place the Multivariate Experiment widget anywhere on the page. Multivariate Test
widgets do not appear on a Web page when you are not logged in; only the content
shows. The following screen appears:

l

1184

Target. Enter the content ID of the target page. You created this page in
Creating a multivariate target page on page 1182. If you do not know the
number, click Browse (...).
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l

Conversions. Enter the number of conversions any variation must have
before the experiment is stopped. For example, if you enter 1000, the
experiment ends when a variation reaches 1000 conversions.
NOTE: During an experiment, you can choose a specific variation to be the
page that all visitors see and end the experiment.
The experiment widget also indicates how each variation has performed
during the experiment.

3. Place at least 1 Multivariate Section widget into the location where content
variations should appear. Use a variety of content combinations to discover the
best arrangement to accomplish your conversion goals. Add 1 or more Section
widgets per PageBuilder page.
4. Drag a content widget into the Multivariate Section widget.

5. Configure the content widget with the appropriate settings. (You can use any
widget inside the Multivariate Section widget. The Content widget was chosen for
this example.)
6. Add another variation by clicking Add Variations (
You now have variation 2 of 2.

) and repeat steps 4 and 5.
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Use the slider control to select content used in each variation. The following sample
shows the slider control for variations 1/2 and 2/2.

7. To add another section and variations, go back to step 3 and continue. The
following image shows a completed experiment page with 2 Section widgets.
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8. Publish the PageBuilder page. You are ready to run the experiment.

Testing combinations of content
You can create a PageBuilder page with more than one Multivariate Section widget. This
arrangement helps identify content and images that provide the best conversion
results. The following page contains 2 Multivariate Section widgets.
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The content inside the Section widgets are part of the variations shown randomly
during the experiment. The number of variations in a Multivariate Experiment grows
exponentially as you add sections and variations. For example, if you have 2 sections
with 3 variations in each section, there are 8 (23) pages to be tested. If you increase
this to 4 variations each, there are 16 (24) pages.

Running a multivariate experiment
After you create the Target Page and Experiment Page:
1. Select the PageBuilder page that contains the Multivariate Experiment widget.
2. Click File > Edit to see the Experiment widget.
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3. On the Experiment widget, click Start.

After you click Start, you see Stop and Show Report.

When an experiment is running, visitors see a randomly-chosen page variation. When
visitors view the experiment page, a browser cookie is set, which indicates the variation
seen by the visitor. From this point forward, if the visitor next visits the target page,
this cookie is read and the proper variation counter is increased. The visitor continues
to see this variation until the experiment is ended.
A cookie persists forever or until the cookies are removed from the browser cache. The
cookie gives a visitor a consistent page variation each time they revisit during the
experiment. If a visitor's browser blocks cookies, that visitor sees random variations
each time they visit the page; they are not counted in conversions.
NOTE: During an experiment, testers can modify variations and content within the
Multivariate Section widget.

Viewing reports during an experiment
Click Show Reports to see the experiment’s progress. The reports shows:
l

the percentage of conversions compared to visits

l

the number of conversions

l

the total number of visits to each variation
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The bar graph shows the conversion percentage. The numbers to the right of the bar
graph show 2 values.
l

The first value is the percent of conversions compared to the total number of visits
to the experiment page. On variation #2 above, 79% means that 568 visitors to
this variation have successfully reached the target page 451 times.

l

The numbers after the percentage show actual conversions. The first number
before the slash (/) indicates the total number of conversions during the
experiment. The second number is the total number of times this variation was
viewed by a visitor. Logged in users are counted as a page view to the experiment
page but not counted on the target page as a conversion.

The following list describes the buttons.
l

Preview. Shows page configurations for this variation. Notice that the content
in the Multivariate Section wizards change, and the slider number changes too.

l

Variation Enabled. This variation is currently running. Click this button to
disable this variation.

l

Variation Disabled. This variation is currently not running. Click this button
to enable the variation.

l

Promote. Click this button to promote this variation to the page seen by all
visitors. All other variations are disabled and the experiment is ended.

Enabling or disabling a variation
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At any time during the experiment, you can disable any variation. Do this by clicking
Enable ( ). The variation becomes disabled and cannot be viewed by site visitors.
When a variation is disabled, visitors who have seen this page see another variation
instead.
You can re-enable a variation by pressing Stop ( ), which currently shows the
variation as disabled. The variation then becomes enabled.

Scheduling an experiment
The PageBuilder page has the same properties as other content types, including the
Schedule property. To set the beginning and ending date of the page, edit the
PageBuilder page and follow the procedure for setting content schedules as described in
Scheduling content on page 698.
Be sure to set the Schedule End Date to be long enough past the time you believe the
experiment will automatically end.

Stopping an experiment
At any time during the experiment, click Stop on the Experiment widget. This suspends
the experiment. Counters stop incrementing, even though visitors continue to see the
page variations.

While the experiment is stopped, cookies are neither set nor read. For more information
about cookies, see When an experiment is running, visitors see a randomly-chosen
page variation. When visitors view the experiment page, a browser cookie is set, which
indicates the variation seen by the visitor. From this point forward, if the visitor next
visits the target page, this cookie is read and the proper variation counter is increased.
The visitor continues to see this variation until the experiment is ended. on page 1189.
When you stop an experiment, the Multivariate Section widget remains on the
experiment page.
You can restart the experiment by pressing Start. Counters are reset to 0 and
restarted.
When one variation reaches the target number of conversions, it automatically
becomes the page variation that all visitors see; the other variations are disabled.
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You can stop the experiment by promoting a specific variation. When you click
Promote ( ), the selected variation becomes the page variation all visitors see; the
other variations are disabled.
When the experiment automatically or manually ends, the Multivariate Section widget
is removed from the experiment page.

Repeating an experiment
To repeat an experiment after it has ended, first restore the history of this page by
following steps in Restoring a previous version on page 705. After restoring the
previous version, you can edit the parameters of the experiment, modify the content,
and run the experiment again.

Testing a target page outside your website
If the target page is outside your website, you must create an intermediate page that
contains the Target widget, and redirect the visitor to the outside address.
For example, to test visitors from your page to http://www.NFL.com:
1. Create a new PageBuilder page.
2. Add the target widget to it.
3. Add the code to redirect the visitor from this page to www.NFL.com.
4. Create content with links to the target page you just created.
While the experiment is running, the experiment page links the visitor to the
intermediate page, and the conversion is counted. Then, the redirect takes the visitor to
the external page.

1192

Ektron 9.40 SP1

Chapter 20

Managing calls to action

Ektron Reference

1193

Managing calls to action

NOTE: The Calls to Actions feature is part of Ektron's marketing suite on page 1123.
Launch the Calls to Action app by clicking on the
icon. Click Calls to Action in the
toolbar to see the list of available calls to action (CTAs). Using the pulldown menus on
the list page, you can sort the list by type of data (date modified, title, status, date
created, and first or last name of the last person to edit the page) or by order
(ascending
or descending ).
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A CTA is a user interface element that prompts a site visitor to touch or click it to
proceed on a path toward conversion from site visitor to customer. Some examples
include buttons and links that say:
l

Add to cart

l

Locate store

l

Free coupon

l

Share your experience

l

Join our mailing list

l

Get more information...

l

Buy now!

Each CTA has a toolbar from which you can perform actions.
l

Edit. Make changes to the CTA.

l

Delete. Remove the CTA.

l

Embed Code. Opens a window for you to specify custom campaign attributes.
When you click Generate Embed Code, another windows appears in which you
can copy and paste embed code to share your CTA on another site, such as a social
media site. See Creating a CTA below for a description of the campaign attributes.
TIPS
l

Use contrasting colors to draw attention to your CTA.

l

Focus on gain instead of effort. For example, Get, View, Enjoy,
Discover, See, Play instead of Submit, Start, Activate, Learn, Pay.

l

Encourage people to place your CTA (embed code) on their social
media.

l

Use A/B testing to find CTA "winners" by having 2 CTAs go to 1
landing page. (Use multivariate testing to test page elements.)

Creating a CTA
To create a CTA, click Calls to Action in the toolbar, then click Create New Call to
Action. The Call to Action Information form appears.
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1. Call to Action Information

l

Call to Action name. Identify the CTA. You can give it a name similar to the
landing page with which you intend to associate it.

l

Destination Web Address. Enter a Web address that appears when the site
visitor clicks on the CTA. You also can use the drop-down menu to select the
landing page. If you want the landing page to open in a new browser window,
check the box.

l

Notes. Specify information (up to 160 characters) that will show up on the
Calls To Action list with this CTA. (You can specify as much information as you
want, but up-to-160 characters are displayed in the Calls To Action list.)

2. CTA Type

1196

l

Use a Custom Image. Choose this option if you want your CTA to be a
clickable image. Click Select Image to browse for an image. The Alt Text field
lets you specify what a site visitor sees when hovering a cursor over the
image, and what screen readers say to the visually impaired.

l

Create a Text Link. Choose this option if you want your CTA to be clickable
text (a hyperlink).

l

Embed Code. Only appears when you edit a published CTA, and opens a
window in which you can copy and paste embed code to share your CTA on
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another site, such as a social media site. (Embed Code always appears on the
CTA list page.) See Generating embed code for a CTA below.

Generating embed code for a CTA
An Embed Code button appears on the CTA list page or when you edit a published
CTA.
When you click Embed Code an Embed Code window appears. Enter values for the
following field and click Generate Embed Code.
o Campaign Source. Enter a search engine, newsletter name, or other source.
o Campaign Medium. Choose website, email, cpc (cost-per-click), or banner.
NOTE: Choosing email generates HTML embed code. The other options
generate JavaScript embed code.
o
o

o

Campaign Term. Enter keywords for this landing page.
Campaign Content. Enter an identifier that differentiates ads or links that point
to the same URL. (Used for A/B testing and content-targeted ads.)
Campaign Name. Enter a name for a specific product promotion or strategic
campaign.

Copy and paste the generated embed code to share your CTA on another site, such as a
social media site.
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Placing a CTA on a page
NOTE: You also can place a CTA on a blog page through the Metadata tab when the
blog is created or edited (Adding a call to action to a blog post on page 1246) and
also by using the BlogPostCallToAction on page 1302 widget.
1. Go to a page and swipe Switch to Edit. The editable fields appear in the window.
2. Click Design. The PageBuilder menu appears.
3. Choose Page Action > File > Edit.
4. Open the Widgets panel in the PageBuilder menu. The available widgets appear.
NOTE: If you do not see the CTA widget in the PageBuilder > Widgets menu,
an administrator can enable it by following the instructions in Determining which
widgets appear on a wireframe on page 1275.
5. Click Call to Action. The widget is highlighted and the page displays Place Here
fields.
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6. Click in any Place Here field to drop the widget.
7. Choose Edit ( ) on the Call to Action widget. A window appears with available
CTAs.
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8. If you have a lot of CTAs in the list, enter the name of the CTA you want in the
Search box and click Search ( ). Double click on the CTA you want; it is placed on
the page.

1200

Ektron 9.40 SP1

Chapter 21

Managing landing pages

Ektron Reference

1201

Managing landing pages

NOTE: The landing pages feature is part of Ektron's marketing suite on page 1123.
A landing page should accomplish a singular conversion goal of your marketing
campaign, such as getting the contact information of your MQL. A page layout should be
concise, avoid scrolling, and keep important information near the top. You typically
create a landing page before a CTA because you will link the CTA to the landing page.
Launch the landing page app by clicking on the
icon. Click Landing Pages in the
toolbar to see the list of available landing pages. Using the pulldown menus on the list
page, you can sort the list by type of data (date modified, title, status, date created,
and first or last name of the last person to edit the page) or by order (ascending
or
descending ). Each landing page list item has a toolbar that lets you perform actions
on the item.
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l

Edit Properties. Make changes to the landing page specifications (name, URL,
and so on).

l

Go to Thank You Page. Make changes to the results page. You should follow up
every landing page with a thank you message for clicking through.
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l

Go to Landing Page. Make changes to the landing page.

l

Clone. Create a copy on the landing page and open edit mode to make the landing
page unique.

l

Delete. Remove landing page.

Creating a landing page
BEST PRACTICES
Before you create a landing page, an administrator should set up the forms
you will use, and map the form fields using DXH. For information about
setting these up, see the following sections.
l

Editing the properties of a landing page on page 1208

l

Setting up an inbound connection to collect the form data on page 1227

l

Setting up a Salesforce connection to collect the form data on
page 1229

l

Mapping form data between DXH and an external application on
page 1230

To create a landing page, click Landing Pages in the toolbar, then click Create New
Landing Page. The new landing page form appears.
1. Collaborate and Plan

l

Landing Page Name. Identify your landing page.

l

Success Criteria. Specify what this landing page should accomplish so that
you can assess its effectiveness through analysis.

l

Notes. Specify information (up to 160 characters) that will show up on the
landing page list with this landing page. (You can specify as much information
as you want, but up-to-160 characters are displayed in the landing page list.)
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2. Update Web Address for Customers (Instead of Computers)

l

Create a customer-friendly Web address for the landing page. You also can
choose the default address that is based on the landing page name, and is
already loaded in the field.

3. Select Layout

l

Layout Images. Choose from the available layouts by clicking on the
template image. Ektron provides a Basic and Advanced template that you can
modify.
You can create your own landing page templates with PageBuilder and display
it in the template list. See Setting up a landing page layout on page 1215. For
additional information, see Creating Web pages with PageBuilder on
page 1075.

l

1204

o

Form Center. A visitor data form appears below the content.

o

Form Left. A visitor data form appears to the left of the content.

o

Form Right. A visitor data form appears to the right of the content.

o

Menu with Form. A visitor data form appears below a menu bar and
above a footer on the page.

Form template. Choose one of the following. See also Editing the properties
of a landing page on page 1208.
o Basic Form Template. The data capture form has First Name, Last
Name, and Email Address.
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o

Advanced Form Template. The data capture form has First Name, Last
Name, Email Address, Company Name, Phone Number, City,
State/Province, and Zip/Postal Code.

o

Form Title. Specify the title of the data capture form.

o

Button Text. Specify text to appear on the data capture form button
(Get the eBook, Start the Webinar!, and so on).
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4. Select Form Template

IMPORTANT: The following fields are hidden fields that let you collect data for
Google Analytics. They do not appear on the landing page. After you have
created a landing page, you cannot change the campaign attributes by editing
the properties screen. However, you can modify (or add) these values from the
landing page by editing the Form Block of the data capture form.
l

Campaign ID. Enter an identifier that associates the data capture form with a
campaign. The ID determines which CTA was used to access this landing page,
which helps you determine the best CTAs to use. If you leave it blank, the
default ID is CampaignIdA1.
NOTE: If you are using Salesforce with DXH, this field becomes a dropdown selector from which you can choose an available campaign. Each
form can have its own set of campaign options based on what each has
been mapped to.

l

1206

with Campaign Member Status. This field appears only if you are using
Salesforce with DXH. The drop-down shows the statuses established in the
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Salesforce account for a selected Campaign ID. It has a Cache Refresh time of
10 minutes. That is, if the end user edits a campaign in Salesforce and adds a
new member status, it will get reflected in the new drop-down within 10
minutes.
IMPORTANT: The following attributes are used by search engines for
analytics and are replaced when a user comes from a call to action.
l

Campaign Source. Enter a search engine, newsletter name, or other source.

l

Campaign Term. Enter keywords for this landing page.

l

Campaign Content. Enter an identifier that differentiates ads or links that
point to the same URL. (Used for A/B testing and content-targeted ads.)

l

Campaign Name. Enter a name for a specific product promotion or strategic
campaign.

5. Thank You Page
o Create Page. Choose this option to create a new Thank You page. The page is
created, associated with the landing page, and accessed from the landing
page list.
o

Link to Page. Choose this option to specify a URL to an existing page.

If you choose Link to Page, select an existing thank you page, or specify a path to
a custom thank you page. See also: Editing an existing Thank You page on
page 1210 and Creating a custom Thank You page on page 1212.

6. Click Save to save the landing page properties. Click Save & Go to Page to edit
(and publish) the landing page.
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IMPORTANT: If you click Save & Go to Page, the page appears in a new
window, unless you have pop-ups blocked. If the page does not appear in the
new window, check your browser's security settings and allow pop-ups for
Ektron sites.
After the page is created, it appears in the landing Page list. You can change its
specifications by clicking Edit Properties.

Editing a landing page
There are 3 aspects to editing a landing page.
l

Editing the properties of a landing page below—Click Edit Properties to modify
the specifications of an existing landing page.

l

Editing content on a landing page on the facing page—Editable content appears
when you hover over section of the page.

l

Editing a PageBuilder template for a landing page or Thank You page on the facing
page—The landing page form contains elements that you want to repeat on other
landing pages; for example, your company logo, a consistent form, and so on. For
information about PageBuilder, see Creating Web pages with PageBuilder on
page 1075.

TIPS
l

Keep important information high and avoid scrolling.

l

Keep information brief and focused. Avoid overloading the reader.

l

Represent your brand (logo) consistently

l

Make your landing page consistent with your call to action so that a site
visitor correlates the CTA to the landing page.

l

The Thank You (or response) page reinforces the site visitor's action.
You can place additional CTAs on the Thank You page.

Editing the properties of a landing page
To edit the properties of a landing page, click Edit Properties on the Landing Page list
page.
The properties of a landing page are described in Creating a landing page on page 1203.
Because of the set up that occurs when you create a landing page, if you edit a landing
page or its properties, be aware of the following effects.
l
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If you want to change the Layout of a landing page (from Form Center to Form Left,
for example), you will have to re-edit your landing page because the PageBuilder
format cannot be automatically re-adjusted; you must do this manually. Any
widgets that you have already placed on the landing page will be moved to column
1 where you can place them again on the modified landing page.
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l

After you create a landing page, you cannot change the campaign attributes from
the properties screen. However, you can modify (or add) these values from the
landing page by editing the form template of the data capture form.

Editing content on a landing page
1. Swipe Switch to Edit. Content view is the default, and the editable fields appear
in the window.
2. Hover over an editable area and click the menu ( ). An action box appears.
l Edit in Context (where available) lets you modify the content on the screen.
When done, click Save ( ).
l

Edit opens a content editor where you can add information such as summary,
metadata, publishing schedule and so on. When done, click Publish.

Editing a PageBuilder template for a landing page or
Thank You page
These instructions apply to landing pages and thank you pages.
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1. Swipe Switch to Edit. The editable fields appear in the window.
2. Click Design. The PageBuilder menu appears.
3. Choose Page Action > File > Edit. The page components become editable. For
example, you can move a form from column 1 to column 2, or place widgets on the
page. For information about widgets, see the Creating and using widgets on
page 1271.
4. When finished, click Publish in the PageBuilder menu.
See Setting up a landing page layout on page 1215 if you want to create additional
landing page layout (you need administrator permissions). For information about
PageBuilder, see Creating Web pages with PageBuilder on page 1075.

Editing an existing Thank You page
A confirmation page (Thank You) reinforces the action that the user took. You can place
additional CTAs on the confirmation page such as a way to share the experience with
social media. Ektron provides a default Thank You page that you can edit.
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1. On the landing page list, click Go To Thank You Page for its associated landing
page. The Thank You page appears.
2. To edit the page, swipe Switch to Edit, and click on Content.
3. Hover over an editable area and click the menu (

). An action box appears.

4. Choose Edit in Context (or Edit).
l Edit in Context (where available) lets you modify the content on the screen.
When done, click Save ( ).
l

Edit opens a content editor where you can add information such as summary,
metadata, publishing schedule and so on. When done, click Publish.

5. Make the modifications that you want and click Save (
the in-context editor).

) (from the File menu of

6. When you are finished editing the page components, choose Page Action
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> File > Save > Publish from the PageBuilder menu.

Creating a custom Thank You page
1. Choose Campaign Management from the Ektron app launcher.
2. Click Landing Pages. The landing page list appears.
3. Choose any landing page and click on Go To Thank You Page. The thank you
page appears.
NOTE: You can create a new thank you page from a landing page, but you can
add a custom thank you page to the Link to Page drop-down list only when
you create a page from an existing thank you page. If you create a thank you
page from a landing page, you will need the URL to enter into the Link to Page
field.
4. Swipe Switch to Edit and click Design. The PageBuilder menu appears.
5. Choose Page Action > File > New Page. The Add New Page wizard appears.
6. Click Next (accepting the default template).
7. Enter a Title. An alias is automatically entered from the title you give. You can
change it.
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8. Select the slash (/) next to the Alias field and click Next.

9. Optionally add Metadata and Summary information, then click Finish. The Add
New Page confirmation screen appears.
10. Click OK to go to the new page to start editing it. A new thank you page is
completely blank.
11. Swipe Switch to Edit and click Design.
12. Modify the page, add widgets, and so on.
13. When your editing is done, click PageBuilder > Page Action > File > Save
> Publish. The custom thank you page appears in the Link to Page selection list
when you create a new landing page.
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If you created a thank you page from a landing page, use the URL from the created
page and enter it into the Link to Page field.

Cloning a landing page
From the landing page list, click Clone to make a copy of a landing page. For example,
if you have a series of webinars that follow a similar format, clone the webinar landing
page and then modify a few fields to create a unique landing page.

Deleting a landing page
From the landing page list, click Delete remove an existing landing page. A
confirmation dialog box appears.
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Setting up landing pages as an administrator
Administrators have additional access and control to the landing page resources. For
example, you may want to apply your own cascading style sheet (CSS) to your site, or
set up a DXH connection to collect your form data.

Setting up a landing page layout
Ektron provides several landing pages (Form Center, Form Left, Form Right, and Menu
with Form). They are listed in the Select Layout section of the Create Landing Page
screen. You can create additional landing pages to select for use, using the following
procedure.

1. Create a modified page.
a. Open an existing landing page, swipe Switch to Edit and click Design.
b. Choose PageBuilder > Page Action > New Page. The Add New Page
wizard appears.
NOTE: Creating Web pages with PageBuilder on page 1075 describes how
to create new pages.
c. Choose LandingPages/SharedTemplate/SharedLandingPage.aspx
wireframe and click Next.
d. Enter a title (for example, Home Page) for the new page and click Next.
IMPORTANT: Each name must be unique. You cannot name your layout
Form Center, Form Left, Form Right, or Menu with Form (with or without
spaces) because these are the default layouts.
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e. Optionally enter additional data and click Finish. A dialog box appears asking
if you want to go to the new page.
f. Click OK to go to page. Home-Page.aspx is displayed.
g. Swipe Switch to Edit and click Design.
h. Note the Page ID on the PageBuilder > Properties screen.

i. Go to PageBuilder > Page Action > File > Save and click Publish.
2. Go to Workarea > Settings > Campaign Management > Manage Manifests.
The Manage Manifest screen appears.
NOTE: In the Workarea, a landing page layout has a manifest, which is a
collection of page attributes that comprise the new landing page.
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3. Click Add Custom Manifest. The Create Manifest screen appears.

l

Manifest Name. Enter a unique name for the new manifest.

l

PageBuilder Id. Enter the ID of the new manifest. You can find it as follows:
a. Go to your modified page and swipe Switch to Edit.
b. Click Design.
c. Choose PageBuilder > Properties and view the Page ID.
NOTE: In the Workarea, the Page ID is the Content ID in the
properties view.

4. Click Save. The Manage Manifests screen appears with the new manifest. When a
user creates a new landing page, the user can select the new layout from the
Select Layout section of the Create Landing Page screen.

Applying a cascading style sheet
Applying a system-wide CSS
Ektron provides several system-wide CSS options from which you can choose.
1. Login to your Ektron website.
2. Go to Workarea > Content > Folders > Blog Hub > Settings. The View
Content screen appears in the right panel.
3. Click Site Configuration in the right panel. The View Content "Site Configuration"
screen appears in the right panel.
4. Click Edit.
5. In the Content tab, find the Theme drop down and select 1 of the themes
(Default, Amelia, Cyborg, Flatly, Journal, United, or Custom). If you choose
Custom, place your CSS file in
d:\Sites\<YourSite>\content\bootstrap\Custom.
6. Click Publish.
7. Reload your website.
Applying a local CSS to your landing page and thank you page
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You can apply a local CSS to your site pages, overriding the system-wide CSS. If you
have a specific CSS that you want to use, upload it to d:/Sites/<your_site>/<local_
folder>. For example:
d:/Sites/YourSite/MyThankYou/
MyThankYou.aspx
MyThankYou.css
MyThankYou.js
MyThankYou.jps

Setting up a landing page alias prefix
When you create a landing page, the landing page Web address defaults to
http://<your_website>/<name_of_landing_page>. In some cases, you may want to
indicate in your URL that landing pages are in the same URL path. For example:
http://<your_website>/LP/<name_of_landing_page_001>
...
http://<your_website>/LP/<name_of_landing_page_00n>

Adding a prefix gives your URL more definition, and also lets you easily set up a redirect
alias to a proxy service.
The following procedure shows how to set the prefix.
1. Go to Workarea > Settings > Campaign Management > Settings. The
Campaign Management Setting screen appears.
2. Click Edit.
3. Specify the values you want:
a. Landing Pages Alias Prefix. Enter the prefix you want to show on the
landing page Web address.
b. Campaign Medium. Choose a medium that will indicate how a site visitor
came through to your landing page.
l website
l

email

l

cpc (cost-per-click)

l

banner

c. Add. Enter a name to add to the Campaign Medium options and click Add.
4. Click Save.

Setting up a data form
Ektron provides Basic and Advanced data forms. The forms contain the following
information. You can modify these or create your own.
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l

Basic Form Template. Form title, first name, last name, and email address.

l

Advanced Form Template. Form title, first name, last name, email address,
company name, phone number, city, state/province, and ZIP/postal code.

Creating a form template from an existing form template
1. Go to Workarea > Content > Folders > Campaigns > Form Templates.
2. Instead of changing an existing template, create a copy by clicking on the
Advanced Form Template template, then choose Action > Copy.
3. Choose Action > Paste. The copied form template appears in the list as
Advanced Form Template (1).
4. Click on the new template name, and click Edit.
5. Change the Title and modify the form. For example, enter Custom Form Template
and remove several fields from the form so that only first name, last name, email
address, and phone number appear on the form.
IMPORTANT: If you create a drop-down list in the HTML form, the (casesensitive) field values must match exactly when you map the external
application's field values through DXH.
NOTE: The following hidden fields do not display on the published form but
collect Google Analytics:
[CampaignIdA1]
[utm_source]
[utm_medium]
[utm_term]
[utm_content]
[utm_campaign]
[urlreferrer]
[calltoaction_id]
[calltoaction_title]
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6. Click Publish. The new template appears in the list.

Creating a new form template
1. Go to Workarea > Content > Folders > Form Templates. The View Folder
screen appears.
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2. Click New > HTML Form/Survey. The New Form wizard appears.
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3. Choose Contact Information and click Next. The Form Title Screen appears.

4. Enter the title of the new data form template and description, then click Next. The
Assign Task screen appears.
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5. You can assign a task to a person or group whenever the form is submitted. Click
Next. The Response screen appears.

6. Choose and edit a type of response, and click Next. The Setup Complete screen
appears.
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7. Click Done. The Edit Content screen appears.

8. Modify the template and click Publish.
IMPORTANT: If you create a drop-down list in the HTML form, the (casesensitive) field values must match exactly when you map the external
application's field values through DXH.
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9. If you want to collect Google Analytics in your new form template, you must add
the following hidden fields to it:
[CampaignIdA1]
[utm_source]
[utm_medium]
[utm_term]
[utm_content]
[utm_campaign]
[urlreferrer]
[calltoaction_id]
[calltoaction_title]

a. Go to Workarea > Content > Folders > Campaigns > Form Templates.
b. Click on either the Basic Form Template or the Advanced Form Template, then
click Edit. This example uses the Basic Form Template.
c. Click on HTML (

) at the bottom of the screen to view the source code.
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d. Copy the highlighted section (perhaps to Notepad, for example).

Here is unpacked code:
<input name="CampaignId" ektdesignns_nodetype="element"
id="CampaignId" ektdesignns_caption="CampaignId"
ektdesignns_name="CampaignId" title="CampaignId"
readonly="readonly" value="[CampaignIdA1]"
class="design_textfield" type="hidden" />
<input name="utm_source" ektdesignns_nodetype="element"
id="utm_source" ektdesignns_caption="utm_source"
ektdesignns_name="utm_source" title="utm_source"
readonly="readonly" value="[utm_source]"
class="design_textfield" type="hidden" />
<input name="utm_medium" ektdesignns_nodetype="element"
id="utm_medium" ektdesignns_caption="utm_medium"
ektdesignns_name="utm_medium" title="utm_medium"
readonly="readonly" value="[utm_medium]"
class="design_textfield" type="hidden" />
<input name="utm_term" ektdesignns_nodetype="element"
id="utm_term" ektdesignns_caption="utm_term"
ektdesignns_name="utm_term" title="utm_term"
readonly="readonly" value="[utm_term]"
class="design_textfield" type="hidden" />
<input name="utm_content" ektdesignns_nodetype="element"
id="utm_content" ektdesignns_caption="utm_content"
ektdesignns_name="utm_content" title="utm_content"
readonly="readonly" value="[utm_content]"
class="design_textfield" type="hidden" />
<input name="utm_campaign" ektdesignns_nodetype="element"
id="utm_campaign" ektdesignns_caption="utm_campaign"
ektdesignns_name="utm_campaign" title="utm_campaign"
readonly="readonly" value="[utm_campaign]"
class="design_textfield" type="hidden" />
<input name="urlreferrer" ektdesignns_nodetype="element"
id="urlreferrer" ektdesignns_caption="urlreferrer"
ektdesignns_name="urlreferrer" title="urlreferrer"
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readonly="readonly" value="[urlreferrer]"
class="design_textfield" type="hidden" />
<input name="calltoaction_id" ektdesignns_nodetype="element"
id="calltoaction_id" ektdesignns_caption="calltoaction_id"
ektdesignns_name="calltoaction_id" title="calltoaction_id"
readonly="readonly" value="[calltoaction_id]"
class="design_textfield" type="hidden" />
<input name="calltoaction_title" ektdesignns_nodetype="element"
id="calltoaction_title" ektdesignns_caption="calltoaction_title"
ektdesignns_name="calltoaction_title" title="calltoaction_title"
readonly="readonly" value="[calltoaction_title]"
class="design_textfield" type="hidden" />

e. Close the form.
f. Click on the form you created, then click Edit.
g. Click on HTML (

) at the bottom of the screen to view the source code.

h. Paste the copied code just before the </div> tag.
10. To apply a CSS theme, wrap the form code with the following tags:
<div class="imhform btn-primary">
...
</div>

NOTE: The default theme is imhform btn-primary, but you can insert your
own CSS theme.
11. Click Publish.
When you create a new landing page, you can select among the Form Template
options, which includes the newly created forms as shown in the following image:

Setting up an inbound connection to collect the form
data
PREREQUISITE

This procedure requires the Digital Experience Hub (DXH) to be already set
up. For complete information about setting up and using DXH with Ektron,
see Ektron Digital Experience Hub release notes on page 499.
Before your website forms can send you data, you must set up an inbound connection.
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1. Go to Workarea > Settings > Settings > Digital Experience Hub
> Connections.
The View All Digital Experience Hub Connections screen appears.
2. Click Add Connections > Add Inbound Connection.
The Add Inbound Connection screen appears.
l

Connection Name. Enter a unique name for this inbound connection. You
should have 1 inbound connection for each site from where you want to collect
data.

l

UserID. Enter the name of the user who will manage the data.

l

Password. Enter the password of the user who will manage the data.

l

Domain. Enter the domain name; leave blank if the domain is the same as the
1 you are on.

l

Site URL. Enter the site URL from which the data is collected.

3. Click Test Connection. If the connection information passes the test, click Save
Connection.
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The Connection is added to the View All Digital Experience Hub Connections
screen.

Setting up a Salesforce connection to collect the form
data
PREREQUISITE

This procedure requires the Digital Experience Hub (DXH) to be already set
up. For complete information about setting up and using DXH with Ektron,
see Ektron Digital Experience Hub release notes on page 499.
Before your website forms can send you data, you must set up an inbound connection.
1. Go to Workarea > Settings > Settings > Digital Experience Hub
> Connections. The View All Digital Experience Hub Connections screen appears.
2. Click Add Connections > Add Salesforce Connection. The Add Salesforce
Connection screen appears.
l Connection Name. Enter a unique name for this inbound connection. You
should have 1 inbound connection for each site from where you want to collect
data.
l

Security Token. Enter (copy and paste) the identifier that Salesforce emailed
to you.

l

Password. Enter the password of the user who will manage the data.
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3. Click Test Connection. If the connection information passes the test, click Save
Connection. The Connection is added to the View All Digital Experience Hub
Connections screen.

Mapping form data between DXH and an external
application
PREREQUISITE
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This procedure requires the Digital Experience Hub (DXH) to be already set
up. To set up and use DXH with Ektron, see Ektron Digital Experience
Hub release notes on page 499. You should also have an inbound connection
set up: see Setting up an inbound connection to collect the form data on
page 1227.
If you have DXH, you can map the Advanced and Basic Form Templates, and any other
forms that you create (see Editing the properties of a landing page on page 1208). After
you map the fields for a template, DXH maintains the mappings for any landing page
that you create that uses the mapped form template. (You do not need to map the
fields again for new landing pages.)
1. Go to Workarea > Content > Folder > Campaigns > Form Templates.
2. Click the form. The View Form screen appears. For example, click on the Advanced
Form template and note the DXH items on the screen.
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3. Click Map to DXH. The Map Form to the Digital Experience Hub dialog appears.

4. Enter a unique and easy to recognize name in Name of this Mapping.
5. In Digital Experience Hub Connection Name, select the connection to the
external application. The form adjusts to the type of application you select. For
example, if you choose a Salesforce campaign connection, a Salesforce Category
field will appear. The following forms are supported:
l Marketo Lead Management. Lead
l

Salesforce. Lead, Contact, Account

l

Microsoft Dynamics CRM. Lead, Contact, Account

l

HubSpot. Contact

6. Click Next. The Map Required Form Fields screen appears. All required external
fields appear in the left column. Use the drop-down in the right column to map one
Ektron form field to each required field.
IMPORTANT: The external application field's data type must match the Ektron
form field.
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7. When you click Next, you can click Add another optional (application) field (
) to map other Ektron form fields to optional external fields.
NOTE: For Salesforce campaigns, map the CampaignId field as shown in the
following image. (Associated Campaigns is available only in the Lead and
Contact categories of Salesforce.)

8. When your mapping is complete, click Publish. The Form Mapping Completed
screen appears.
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9. Click Test Form Mapping. A new form appears, showing fields that you mapped.
10. Enter sample data into each field and click Test Mapping at the bottom of the
form. You are notified if the sample data is valid.
Test Form Mapping

Test Form Mapping Success
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11. Click OK. The View Contents screen shows the DXH icon next to any forms that are
mapped.

Ektron Reference

1235

(This page intentionally blank.)

Chapter 22

Managing a blog platform
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NOTE: The blogs feature is part of Ektron's marketing suite on page 1123.
To launch the Blog app, click on the

icon and the author page appears.

A blog platform contains a list of blog authors, their blogs pages, and analytics for
evaluating blog posts and authors.
l

Credentialed authors can create and edit their blog posts and online profiles.

l

Guest authors do not have access; their profile is created by an administrator.
Guest authors send blog material to an administrator to post on their behalf.

NOTE: You can sort the Author, Email, and Type columns by clicking the headings
(circled).

Each blog author has links on the Authors page to perform the following actions.
l

Click an author's name to go to that author's blog page.

l

Edit. Make changes to the author's profile.

l

Disable. Removes access from an author while keeping existing blog posts. An
administrator still has access and the ability to post on the author's behalf.

l

Delete. Removes an author and associated posts.

Adding an author
PREREQUISITE

An administrator must set up email notification in web.config to send a
password to the email address.
<add
<add
<add
<add
<add

key="ek_SMTPServer" value="server.intra.xxxxxx.com" />
key="ek_SMTPPort" value="25" />
key="ek_SMTPUser" value="" />
key="ek_SMTPPass" value="" />
key="ek_SMTP_EnableSsL" value="false" />

On the Authors page, click Add Author. The Author form appears. After you save new
author information, the author appears in the author list.
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l

Email. Specify an email address for the blog author. The email address is used as
the author's log in username. A password is sent to the email address.
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l

Logging in?. If you require the author to log in, choose Yes; otherwise No.
o Yes. This credentialed author type can manage his or her own blog posts.
o

No. This author type (Guest) is created for attribution purposes; this author
cannot create or manage his or her blog postings. The guest is generally
created by an administrator author. The guest sends a blog post to the
administrator author to publish on the guest author's behalf. For example, in a
company blog, you create a guest account for an industry expert from outside
your company.
NOTE: If you choose Yes, a CMS user is created for the author in
Workarea > Settings > Users. If you choose No, a guest author does
not have a corresponding user created in the Workarea.

l

First Name. Specify the first name of the author.

l

Last Name. Specify the last name of the author.

l

Display Name. Specify the name you want people to see on blog posts from this
author.

l

Photo. Optionally add a photograph (or other image) of the author.

l

Biography. Optionally specify biographical information that people can read about
the author.

l

LinkedIn URL. Optionally specify the author's LinkedIn address to show with the
author's blog information. For example, http://www.linkedin.com/in/Ektron.

l

Twitter URL. Optionally specify the author's Twitter address to show with the
author's blog information. For example, http://twitter.com/Ektron.

l

Facebook URL. Optionally specify the author's Facebook address to show with the
author's blog information. For example, https://www.facebook.com/Ektron.

l

Google+ URL. Optionally specify the author's Google+ address to show with the
author's blog information. For example, https://plus.google.com/s/Ektron.

Logging in as an author
The administrator determines whether login links and login screens appear on the
website. See Setting up login and logout on page 1257 for information about how the
administrator does this.
l

If you do not see login links, you can login by entering the following URL:
http://[www.site.com]/login.aspx

l

If you have login links, and already have an account, you can log in with your Email
(username) and Password.
IMPORTANT: Email notification to send a password to the email address must
be set up by an Ektron administrator in web.config. Check your email for
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notification of your password. If you did not receive this email, contact your
Ektron administrator.

If you do not have an account, you can sign up.
NOTE: If you want to hear the captcha code, click on the audio icon. The system
administrator must set up audio for you to hear it. For information, see Setting up
sound for the Captcha control on page 1259.
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The following image shows the author's view of the author's list. Note that author,
Arthur Wrytus, can only edit his own profile.

Creating a blog post
1. In the Author's list, click a blog author's name. The blog author's page appears.
2. Swipe Switch to Edit and click Content.
3. Hover over the blog author's name. A List Summary box appears.
4. Click the menu (

). The List Summary action box appears.

Ektron Reference

1243

Managing a blog platform

5. Choose Add New Post. An Edit Content screen appears.

6. Enter a title, content, a summary (that appears with the blog title on the blog page)
and other information about the post. When finished, click Publish. The post
appears on the blog author's page. The following image shows where the data is
displayed.
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You also can enhance your blog post with the following actions:
l

Adding a call to action to a blog post on the next page

l

Adding tags to a blog post on page 1247

l

Analyzing blog traffic on page 1254

l

Managing a blog platform on page 1237

Editing a blog entry that is already posted
1. On the blog page, click the blog post that you want to edit. The blog post appears.
2. Swipe Switch to Edit.
3. Hover over the blog title. A Content Block box appears.
4. Click the menu (

). The Content Block action box appears.
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5. Choose Edit. A list of blog posts and the author profile appears.
6. Edit the content and metadata (perhaps adding a CTA), and then click Publish.

Adding a call to action to a blog post
1. Go to your blog post and swipe Switch to Edit.
2. Choose Content.
3. Hover over the blog title. A Content Block box appears.
4. Click the menu (

). The Content Block action box appears.

5. Choose Edit. Your blog appears in an editor.
6. Click the Metadata tab.
7. Choose Call to Action and click Edit. A selection window appears
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8. Double click a CTA. The ID appears in the Metadata tab.
9. Click Publish. The CTA appears on the blog page.
See also: Placing a CTA on a page on page 1198

Adding tags to a blog post
Tags are keywords that you can assign to users, groups, content, and library items. On
a website, tags for a user or group appear in a profile, helping site visitors learn about a
user or group. For complete information about tags, see Tagging content, library items,
users, and groups with keywords on page 1723.
1. Go to your blog post and swipe Switch to Edit.
2. Choose Content.
3. Hover over the blog title. A Content Block box appears.
4. Click the menu (

). The Content Block action box appears.
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5. Choose Edit. Your blog appears in an editor.
6. Click the Metadata tab.
7. Choose Call to Action > Tags > Add Tag. A window appears.
8. Enter the name of the tag and click Save. Repeat this until you have specified all
the tags you want.

Sharing a blog on social channels
If a blog reader participates in social networks, the reader can click a social channel
icon. A form appears from that social channel to let you share the blog link with friends
and colleagues. By encouraging social amplification, you can reach many more MQLs.

NOTE: When a person shares a blog using 1 of the social channels, the count display
may not show immediately. Some services take more time than others to reflect a
change in the count.

Making comments about a blog
A readers of a blog post can enter comments, as shown in the following image. You can
reply to comments, too, by clicking Reply ( ).
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Disabling a blog author's access
1. In the author's list, click Disable in the Actions column next to the author's name.
A confirmation box appears.

2. Click Disable to confirm.
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NOTE: You can restore an author's access by clicking Enable in the Actions column
of the author list.

Deleting a blog author and his or her blog posts
1. In the author's list, click Delete in the Actions column next to the author's name. A
confirmation box appears.

Delete CMS Author
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Delete Guest Author

2. Click Delete to confirm.

Searching blogs
When you enter search terms in the Search field, a list of blogs appear that contain the
search terms you specified. If this list is long, you can sift through the results using the
Refinement panels on the side. Refinements include the number of posts that contain
the search term for the following categories:
l

all posts that were published within the past 24 hours, week, month, and year.

l

posts by author

l

posts by tags
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Adding resources to the blog site
You can add resources that do not (necessarily) belong to any of the blog authors or
may be outside of the context of a blog post. A resource can be any content. Ektron has
several types of resources built in: White Papers, Case Studies, Ebooks, Webinars,
Analyst Research, and Press Releases.
NOTE: An administrator can create additional resource pages. See Creating a new
resource page on page 1259 and Removing a resource page on page 1264.
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1. On a website page, choose Resources > White Papers. (You can choose any of
the other resource pages.) The resource page appears.
2. Swipe Switch to Edit. Editable blocks appear on the page.
3. Hover over the resource block (for example, White Papers) and click the menu (
). The menu appears.
4. Choose Add Resource. The Edit Content screen appears.

5. Enter a title and content. You also can specify Summary, Metadata, and
Schedule information.
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6. Click Publish. The resource appears on the Web page.
7. Swipe Switch to View.

Analyzing blog traffic
Authors have access to analytic data only for their own blog posts, if analytics is set up.
Administrators can view analytic data for authors and blog post traffic. You must also
have Google Analytics 3.0 with the OAuth2.0 protocol. See Setting Up Google Analytics
on page 1268. See also Setting up the OAuth2.0 authorization protocol for Google
Analytics 3.0 on page 567 if you want to set up OAuth2.0.
PREREQUISITETIPS
l

Analyze to promote good performers and remove poor performers.

l

Wait for statistical confidence; when it is unlikely that data occurred by
chance.

l

Incorporate the search phrases that your visitors used to find your
pages into the landing page.

Analyzing blog post traffic (authors)
Authors can analyze activity for each blog post.
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1. On your blog post, swipe Switch to Edit.
2. Click Content.
3. Hover over the blog post and click menu ( ). The Content Block menu appears. If
analytics are set up, a View Analytics menu item appears.
4. Choose Actions > View Analytics. An analytics screen appears.

l

By default the data collection range is 30 days. You can modify this range by
clicking in the date field and choosing another date, then clicking Submit to
update the data.

l

You can view data captured by the day, week, or month.

l

Hover over a data point to see the number of blog views on that date.

l

Additional data is displayed at the bottom of the window.

Analyzing author and blog post traffic (administrators)
Administrators also can analyze activity for each blog post, or by author.
1. Swipe Switch to Edit. The editable fields appear in the window.
2. Click Design. The PageBuilder menu appears.
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3. Choose Page Action > View > Analytics. An analysis page appears.

Important administrator notes
l

By default the data collection range is 30 days. You can modify this range by
clicking in the date field and choosing another date, then clicking Submit to update
the data.

l

You can view data captured by the day, week, or month.

l

Hover over a data point to see the number of blog views on that date.

l

Additional data is displayed at the bottom of the window.

l

The analytics provider list is set in web.config.
o If every analytics provider in web.config contains empty values, you see all
providers in the drop-down but you also get an error: The hostname does
not report any statistics. The following example shows an analytics
provider with empty settings:
<add name="GoogleV3.0"
type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProviderv3,
Ektron.Cms.BusinessObjects"
EmailAddress=""
KeyFilePassword=""
KeyFilePath=""
Username=""
Password=""
ProfileId=""
SiteURL=""
UserAccount=""
Endpoint="https://www.googleapis.com/analytics/v3/data/"
ApiKey=""
CacheInterval="0"
GoogleAnalyticsTrackingCodePath="Analytics\template\googletrackingcode.ascx"
Version="3.0" />
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o

If any provider is correctly filled out, any of the correctly filled-out providers
are shown in the drop-down list on the analysis page. The following example
shows a filled-out provider (with modified values).
<add name="GoogleV3.0-LocalOnTrek"
type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProviderv3,
Ektron.Cms.BusinessObjects"
EmailAddress="username@yourplace.com"
KeyFilePassword="SeCure38^!paSsWorD"
KeyFilePath="/Key/xx11x1xxx1x11x11x1111xxx1x1xxx1-privatekey.p12"
Username=""
Password=""
ProfileId="12345678"
SiteURL="www.yoursite.com:85"
UserAccount="xx-12345678-9"
Endpoint="https://www.googleapis.com/analytics/v3/data/"
ApiKey=""
CacheInterval="0"
GoogleAnalyticsTrackingCodePath=
"Analytics\template\googletrackingcodewithanalyticsjs.ascx"
Version="3.0" />

Subscribing or unsubscribing to a blog or blog post
Logged-in site users and Membership users can subscribe to a blog or a blog post.
By subscribing to an author's blog, you are notified whenever posts are added to it.
l

If you subscribe from the home page, you subscribe to all authors' blog posts.

l

If you subscribe from an author's blog page or blog post, you subscribe only to that
author.

If you want to stop receiving notices, you can unsubscribe.
To subscribe to a blog or blog post:
1. Go to the blog on the site.
2. Click Subscribe via RSS. The Subscribe/Unsubscribe screen appears.
3. Select a Notification Type.
NOTE: Each browser may have a different field.
4. Click Add Subscription.

Performing administrator tasks
Administrators have additional access and control to the blog hub resources. For
example, you may want to apply your own cascading style sheet (CSS) to your site.

Setting up login and logout
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If you do not want to show a login screen, a user can login by specifying the following
URL:
http://[www.site.com]/login.aspx

See Logging in as an author on page 1240 for information about logging in.
If you want to display login screens, follow these steps.
1. Go to Workarea > Content > Folders > Blog Hub > Settings. The View
Contents screen appears.
2. Click Site Configuration.
3. Click Edit.
4. Scroll down to find LoginMenuID, LogoutMenuId, and ShowLogin configurations.

The LoginMenuId and LogoutMenuId values come from the ID properties in
Workarea > Content > Menus > Authentication. If you create your own,
enter the ID property of the menu into the LoginMenuId and LogoutMenuId Value
fields.
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5. To remove the Login screens, and the Login link from the website pages, set the
ShowLogin key Value to false.
6. Click Publish.

Setting up sound for the Captcha control
If you want people to have the option to hear the Captcha code (in addition to viewing
it):
1. In Windows Explorer, go to
siteroot/WorkArea/FrameworkUI/Templates/EktronUI/Captcha. The
soundmanager folder appears.
2. Right click on the soundmanager folder and choose Properties. The
soundmanager Properties screen appears.
3. Click on the Security tab.
4. Select SYSTEM from the Group or User Names box, then click Edit.
5. Enable (check) the Full Control - Allow box, and click OK.

Creating a new resource page
You can create additional resource pages. For example, you may want a page where
you can display Essay Submissions. See also Adding resources to the blog site on
page 1252.
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1. Go to Workarea > Content > Folders > Folders > Blog Hub > Resources.

2. Choose New > Folder. The Add a Subfolder screen appears.

3. Enter the name and description and click Add Folder. For example, Essay
Submissions. You will be using the exact name that you specify in other steps in
this procedure.

4. Go to the new folder that you just created. (Workarea > Content > Folders
> Folders > Blog Hub > Resources > Essay Submissions)
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5. Choose New > Page Layout. The Add New Page wizard appears.

6. Choose the UI/ResourceLayout.aspx layout and click Next.

7. Enter the exact name of the folder that you created in the Title field. For example,
Essay Submissions. The Alias field is automatically filled in.
8. Choose the slash (/) from the drop-down menu next to the Alias field and click
Next.
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9. Optionally enter additional information and click Finish. A confirmation screen
appears to redirect you to the page so that you can edit it.
10. Go to Workarea > Content > Menus > Main Navigation > Resources. The
View Menu "Resources" screen appears.

11. Click Add Items. The Add New item screen appears.
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12. Click Sub Menu and click Next.

13. Enter the exact name of the folder that you created in the Title field. For example,
Case Studies.
14. Click the URL Link hyperlink icon (

).

15. Go to the folder you created and enable the radio button to fill in the URL Link field,
and click Save.

16. Optionally specify the other fields, and click Save. The new menu appears in the
menu tree and on the Web site when you refresh the page.
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NOTE: You can sort the order of Resource menu items by clicking Reorder (
) on the View Menu screen at Workarea > Content > Menus > Menus
> Main Navigation > Resources.

Removing a resource page
1. Go to Workarea > Content > Folders > Folders > Blog Hub > Resources.
2. Right click on the resource folder you want to remove and click Delete
<foldername>. The resource page is removed.
3. Go to Workarea > Content > Menus > Menus > Main Navigation >
Resources.
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4. Right click on the resource menu you want to remove and click Delete
<foldername>. The menu item is removed from the Resource Menu.

Creating a blog post from the Workarea
1. Go to Workarea > Content > Folders > Blog Hub > Blogs > <blog
author>. The View Contents window appears in the right panel.
2. Choose New > HTML Content.
3. Enter a title, content, and other information (such as a call to action on the
Metadata tab).
NOTE: If you select a CTA, but it does not show up on the blog post, check to
see if the CTA was published because only published CTAs appear.
4. When finished, click Publish. The blog entry is added to the author's page.

Setting up approvals for publishing blog posts
This section shows you how to set up a process for approving blog posts for publication.
By setting the permissions on the folder, any content created by the folder's author
must be reviewed before publication is granted or denied.
NOTE: For complete information about setting up a workflow for an approval
process, see Approving content for publication on page 749.
1. Go to Workarea > Content > Folders > Blog Hub > Blogs > <author
folder>.
2. Choose View > Properties. The View Properties screen appears.
3. Click View Permissions (
folder's workflow.

) because workflow initially matches the parent

If you want this folder to have different permissions from its parent folder, uncheck
Allow this object to inherit permissions. A confirmation box appears. Click
OK, then click Back ( ).
IMPORTANT: By enabling permissions for another author’s folder, a CMS
author can post a blog in the other author’s name.
4. Click Manage Approvals ( ). A screen prompts you to assign a basic or advanced
workflow.
5. Click Use Advanced Workflow if no workflow is assigned to the folder. The
Manage Approvals screen appears.
If any content in the folder is already in Submitted status, a message appears:
The workflow for this folder cannot be changed because
some content is currently in an approval process.

If you still want to edit the workflow, your options are as follows:
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l

Cancel the approval process all content in Submitted status.

l

Force publish content in Submitted status.

l

Get approvers to approve Submitted content, so its status changes to
Published.

6. From the Select Workflow Type drop-down, select a 2-, 3-, or 4-step approval.
7. Assign a user or group to each approver. (Available users or groups have read-only
or greater permissions for the folder.)
BEST PRACTICE
If you assign a group, any group member can approve or decline the
content. Assign user groups (not individual users) to a workflow. In this
way, if someone is out of the office, any other group member can
approve content.
8. For each approver, you can assign an escalation time period and user or group in
the Escalation column. For example, after 1 day, if an approver has not acted on
the approval request, it is assigned to an administrator.

9. Click Save.

Applying a cascading style sheet
Applying a system-wide CSS
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Ektron provides several system-wide CSS options from which you can choose.
1. Login to your Ektron website.
2. Go to Workarea > Content > Folders > Blog Hub > Settings. The View
Content screen appears in the right panel.
3. Click Site Configuration in the right panel. The View Content "Site Configuration"
screen appears in the right panel.
4. Click Edit.
5. In the Content tab, find the Theme drop down and select 1 of the themes
(Default, Amelia, Cyborg, Flatly, Journal, United, or Custom). If you choose
Custom, place your CSS file in
d:\Sites\<YourSite>\content\bootstrap\Custom.
6. Click Publish.
7. Reload your website.
Applying a local CSS to your blog hub
You can apply a local CSS to your site pages, overriding the system-wide CSS. If you
have a specific CSS that you want to use, upload it to d:/Sites/<your_site>/<local_
folder>. For example:
d:/Sites/YourSite/MyThankYou/
MyThankYou.aspx
MyThankYou.css
MyThankYou.js
MyThankYou.jps

Changing the default logo
1. Go to Workarea > Content > Folders > Blog Hub > Settings. The View
Contents screen appears.
2. Click on Site Configuration.
3. Click Edit.
4. Click Image ( ) in the Home Logo field. The Image Properties window appears.
5. Click Browse (...) next to the Image Src field. The CMS400 Library window
appears.
6. Select an image from the library. The image appears as the Home Logo.
You can also upload an image from the file system to the library and select it.
a. Click Add Library. The upload screen appears.
b. Enter a Title.
c. Click Choose File and select a file from the file system.
d. Enter a description for the new image.
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e. Click Add Library. The Image Properties window reappears.
f. Click OK. The image appears as the Home logo.
7. Click Publish.

Setting Up Google Analytics
Google Analytics lets an administrator analyze activity for each blog post, or by author
using either Classic Google Analytics (GA.js) or Universal Google Analytics
(Analytics.js).
IMPORTANT: Google is promoting Analytics.js for upgrading classic Google
analytics "Standard" accounts to "Universal Analytics" accounts in 4 phases.
"Premium" account holders cannot do this until Phase 3. If you have not
upgraded to Google Universal Analytics, you cannot use Analytics.js. For
information about upgrading to Universal Analytics and using Analytics.js, see the
Google website at the Universal Analytics Upgrade Center.
Also, before you upgrade to Universal Analytics, check How can I tell if I have
Universal Analytics or classic Google Analytics.
To implement Google Analytics tracking, you need to enable GA.js or Analytics.js in
web.config with the following keys. You can enable both to use them concurrently and
send the data to separate properties to avoid merging or transferring data.

GA.JS
<add name="GoogleV3.0-LocalOnTrek"
type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProviderv3,
Ektron.Cms.BusinessObjects"
EmailAddress=" " KeyFilePassword="notasecret" KeyFilePath=" "
Username="" Password="" ProfileId="" SiteURL=" " UserAccount=" "
Endpoint="https://www.googleapis.com/analytics/v3/data/"
ApiKey="" CacheInterval="0"
GoogleAnalyticsTrackingCodePath=
"Analytics\template\googletrackingcode.ascx"
Version="3.0" />

Analytics.JS
<add name="GoogleV3.0-LocalOnTrek"
type="Ektron.Cms.Analytics.Providers.GoogleAnalyticsProviderv3,
Ektron.Cms.BusinessObjects"
EmailAddress=" " KeyFilePassword="notasecret" KeyFilePath=" "
Username="" Password="" ProfileId="" SiteURL=" " UserAccount=" "
Endpoint="https://www.googleapis.com/analytics/v3/data/"
ApiKey="" CacheInterval="0"
GoogleAnalyticsTrackingCodePath=
"Analytics\template\googletrackingcodewithanalyticsjs.ascx"
Version="3.0" />

If you choose to use Analytics.js, you also need to perform the following procedure.
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1. Log into your Google Analytics account as the administrator of the account.
2. Choose the account and property that was created (or upgraded) for Universal
analytics.
3. In the Property column, click Custom Definitions > Custom Dimensions. The
Property screen appears.
4. Click New Custom Deminsion and enter the following values:
l Name: Member
l

Scope: Session

l

Enable the Active check box.

5. Click Save.

Setting up multiple languages for your blog hub
You can set up the blog hub with multi-language support by adding available languages
to the Settings, Layouts, and Menus folders, as described in the following procedure. If
you set up a language that is not supported by the website, the default language is
displayed.
1. Go to Workarea > Content > Folders > Blog Hub > Settings and click on
Site Configuration in the right panel. The View Content screen appears.
2. In the menu bar, open the Add drop-down and select a language. The Edit Content
screen appears.
3. Change the Title and click Publish. The View Content screen reappears.
4. In the menu bar, open the Language drop-down and select the language you just
added. The View Content screen reappears in the selected language.
\
The View Contents of Folder screen also reflects the selected language.

5. Go to each of the following content items and repeat steps 2 through 4 for each
item:
l Workarea > Content > Folders > Blog Hub > Layouts >
o 404
o

500

o

Blog Author Page
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l
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o

Blog Post Details Page

o

Blog Post Listing Home Page

o

Resource Page

o

Search

Workarea > Content > Menus >
o Footer Menu (folder)
o

Footer Menu > Home

o

Main Navigation (folder)

o

Main Navigation > Home

o

Main Navigation > Resources

o

Main Navigation > Login

o

Utility Navigation (folder)

o

Utility Navigation > Community

o

Utility Navigation > Support
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Creating and using widgets
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A widget is a mini-application that can provide either specific functionality (search,
social bars, and so on) or areas into which you can add Ektron content (content blocks,
list summaries, collections, and so on). You can drag and drop widgets onto a page
using a wireframe, dropzones, and widgets.

The following figure shows the relationship between a wireframe, dropzones, and
widgets.
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l

A wireframe can have several dropzones.

l

Each dropzone can have several columns.

l

Each column can have several widgets.

Ektron 9.40 SP1

Creating and using widgets

A widget consists of 3 file types.
l

.ascx. contains a widget’s source code

l

.ascx.cs or .vb. contains widget’s code-behind

l

.ascx.jpg. image that represents a widget in the widget selection tool

When you create a widget, save the widget files to the siteroot/widgets folder. This
folder path is defined in the site root/web.config file, so if you change the folder name
or path, you must update the following web.config element:
<add key=”ek_widgetPath” value=”Widgets/" />.

NOTE: Your widget might use additional files, such as .css or .js files.You should
place these files in a folder within siteroot/widgets, and give the folder the same
name as the custom widget.
Ektron stores each page’s data (a serialized XML string) as a type of content in the
Ektron Workarea. The string is stored like other content types, such as HTML content
and XML Smart Forms.
After you integrate widgets into Ektron, you can add them to a dashboard in your
profile page or a community group’s page. You also can drag-and-drop these building
blocks onto a PageBuilder page or a Personalized Web page. See also: Creating Web
pages with PageBuilder on page 1075 and Personalizing a Web page on page 1437.
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Content authors open the widget bar from the PageBuilder menu by clicking the
up/down (
) or down (
) controls.
For HTML5 CSS3-compliant browsers:
1. Click Switch to Edit, then Design. The PageBuilder menu appears.
2. Open the Widgets panel.
3. Click the desired widget to select it.
4. Click a Place Here area to insert the widget onto the page.
Widget states on a Pagebuilder page
Widgets placed on a PageBuilder page have 3 possible combinations of states.
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l

Edit page mode+View widget mode. Widget can be placed on the page, moved,
and deleted. For example:

l

Edit page mode+Edit widget mode. User defines widget information. For example:

l

View page mode+View widget mode. Widget content appears on page. For
example:
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In a widget’s user control file, you create an asp:MultiView element that determines
available actions when a widget is in View mode and Edit mode.
<%@ Control Language="C#" AutoEventWireup="true"
CodeFile="HelloWorld.ascx.cs" Inherits="widgets_HelloWorld" %>
<%@ Register Assembly="System.Web.Extensions, Version=1.0.61025.0,
Culture=neutral, PublicKeyToken=31bf3856ad364e35"
Namespace="System.Web.UI" TagPrefix="asp" %>
<asp:MultiView ID="ViewSet" runat="server" ActiveViewIndex="0">
<asp:View ID="View" runat="server">
<!-- You Need To Do .............................. -->
<asp:Label ID="HelloTextLabel" runat="server"></asp:Label><br />
<asp:Label ID="CheckBoxLabel" runat="server"></asp:Label>
<!-- End To Do .............................. -->
</asp:View>
<asp:View ID="Edit" runat="server">
<div id="<%=ClientID%>_edit">
<!-- You Need To Do .............................. -->
<asp:TextBox ID="HelloTextBox" runat="server" Style="width: 95%">
</asp:TextBox><br />
<asp:CheckBox ID="MyCheckBox" runat="server" Checked="false" />
<br /><br />
<!-- End To Do .............................. -->
<asp:Button ID="CancelButton" runat="server" Text="Cancel"
OnClick="CancelButton_Click" /> &nbsp;&nbsp;
<asp:Button ID="SaveButton" runat="server" Text="Save"
OnClick="SaveButton_Click" />
</div>
</asp:View>
</asp:MultiView>

Determining which widgets appear on a wireframe
An administrator can determine which widgets can appear for use on a wireframe.
1. Go to Workarea > Settings > Configuration > Template Configuration. The
Active System Templates appears with a list of wireframe templates.
2. Click on a wireframe template file name. The Update Template screen appears.
3. Select the widgets you want to make available for this wireframe template by
clicking on the widget icons, highlighting or de-highlighting them. You can also
select or deselect all widgets.
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4. Click Update Template.

Creating the “Hello World” widget
To learn how to create a widget, create a simple widget in the siteroot/widgets
folder. This widget is based on the Hello World widget that is installed with the sample
site with the following files:
l

HelloWorld.ascx. user control file

l

HelloWorld.ascx.cs. user control code-behind file

l

HelloWorld.ascx.jpg. image that represents this control on the widget menu

Step 1: Copy, paste, and rename HelloWorld.ascx and
HelloWorld.ascx.jpg
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1. Open your website in Visual Studio.
2. In the Visual Studio Solution Explorer, open the widgets folder.
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3. Within that folder, scroll down to and select HelloWorld.ascx.

4. Right click the mouse and choose Copy.
5. Scroll up to the widgets folder.
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6. Right click the mouse and choose Paste.

7. Scroll down until you see Copy of HelloWorld.ascx.
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8. Right click and choose Rename.

9. Rename the file new_widget.ascx. Visual Studio automatically renames the codebehind file to new_widget.ascx.cs.
10. Copy, paste, then rename the helloworld.ascx.jpg file to new_
widget.ascx.jpg.The image file is 48 x 48 pixels and 72 dpi. Ektron
administrators and content authors drag a widget’s image onto the page.

Step 2: Update the class names in the new files
1. Double click on new_widget.ascx to open it.
2. On the first line of that file, replace the reference to HelloWorld (circled) with new_
widget.

3. Double click on the code-behind file, new_widget.ascx.cs.
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4. Replace the class HelloWorld with new_widget.

5. Save new_widget.ascx and new_widget.ascx.cs.
6. Check for errors by choosing Build > Build Page for each file. Correct any errors
before proceeding.

Step 3: Add the widget to the wireframe template
NOTE: Use this procedure to select (or restrict) any widget that you want to be
available to use on a wireframe template. When the template is used, the selected
widgets appear in the PageBuilder Widgets menu.
1. Open the Workarea.
2. Choose Settings > Configuration > Personalizations > Widgets.
3. Click Synchronize. The new user control file, new_widget.ascx, appears in the
list.
4. Choose Settings > Configuration > Template Configuration.
5. Find the template that you created in Developing wireframe templates on
page 1093, PageLayout.aspx. Or, any wireframe template that you are using to
create a PageBuilder page.
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6. Click Update Template. On the Update Template screen, scroll down until you see
the new widget.

7. Click Select All (circled in the figure).
8. Click Update Template. For directions on creating a PageBuilder page, see
Developing wireframe templates on page 1093.

1282

Ektron 9.40 SP1

Understanding the user control (.ascx) file

9. Go to Content and select a folder that has a PageBuilder page.
a. Choose Content > Folders > PageBuilder and click on PageLayout.
b. Click Edit Page Layout.
10. Open the widget menu. Make sure your new widget appears on the menu.

After you create a new widget and enable it in the Workarea, you can begin to
customize it. For more information about customizing widgets, see Customizing a
widget on page 1287.

Understanding the user control (.ascx) file
Here is the new_widget.ascx file that is the basis of the widget.
<%@ Control Language=”C#” AutoEventWireup=”true”
CodeFile=”new_widget.ascx.cs” Inherits=”widgets_new_widget” %>
<%@ Register Assembly="System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
Namespace="System.Web.UI" TagPrefix="asp" %>
<asp:MultiView ID="ViewSet" runat="server" ActiveViewIndex="0">
<asp:View ID="View" runat="server">
<!-- You Need To Do .............................. -->
<asp:Label ID="TextLabel" runat="server"></asp:Label><br />
<asp:Label ID="CheckBoxLabel" runat="server"></asp:Label>
<!-- End To Do .............................. -->
</asp:View>
<asp:View ID="Edit" runat="server">
<div id="<%=ClientID%>_edit">
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<!-- You Need To Do .............................
<asp:TextBox ID="TextTextBox" runat="server" Style="width: 95%">
</asp:TextBox><br />
<asp:CheckBox ID="MyCheckBox" runat="server" Checked="false" />
<br />
<!-- End You Need To Do .........................
<asp:Button ID="CancelButton" runat="server" Text="Cancel"
OnClick="CancelButton_Click" />
<asp:Button ID="SaveButton" runat="server" Text="Save"
OnClick="SaveButton_Click" />
</div>
</asp:View>
</asp:MultiView>

-->

-->

Notice the following elements of the file.
l

The asp:MultiView element declares that the control has 2 possible modes: View
and Edit.
<asp:MultiView ID="ViewSet" runat="server" ActiveViewIndex="0">

l

in view mode, the marketing team can see the control but not change it.

l

in edit mode, the developers can change the control’s content and properties.

l

Between the multiview tags is information about the control in view mode. It has
2 fields: one is a text field, and the other is a check box.
<asp:View ID="View" runat="server">
<asp:Label ID="HelloTextLabel" runat="server"></asp:Label><br />
<asp:Label ID="CheckBoxLabel" runat="server"></asp:Label>
</asp:View>

l

Also between the multiview tags is information about the control in edit mode. In
edit mode, a text box, a check box, and a Save button appear. The text box and
check box collect end-user input, and the Save button saves that input to the
database.
<asp:View ID="Edit" runat="server">
<div id="<%=ClientID%>_edit">
<!-- You Need To Do .............................. -->
<asp:TextBox ID="HelloTextBox" runat="server" Style="width: 95%">
</asp:TextBox><br />
<asp:CheckBox ID="MyCheckBox" runat="server" Checked="false" /> <br />
<!-- End You Need To Do .............................. -->
<asp:Button ID="CancelButton" runat="server" Text="Cancel"
OnClick="CancelButton_Click" />
<asp:Button ID="SaveButton" runat="server" Text="Save"
OnClick="SaveButton_Click" />

Understanding the code-behind (.ascx.cs) file
Review the code-behind file,new_widget.ascx.cs.

1284

Ektron 9.40 SP1

Understanding the code-behind (.ascx.cs) file

l

A series of using statements are at the top of the file. Notice the Ektron ones in
particular:
using
using
using
using
using
using

l

Ektron.Cms.Widget;
Ektron.Cms;Marketing team
Ektron.Cms.API;
Ektron.Cms.Common;
Ektron.Cms.PageBuilder;
System.Text.RegularExpressions;

Next, note a widget host class, which inherits the system.Web.UI.UserControl
and IWidget classes.
public partial class widgets_new_widget: System.Web.UI.UserControl, IWidget

The following figure summarizes the remaining elements of the code-behind file.

l

In the next line, notice the widget’s properties: a string for the text field, and a
boolean for the check box. You define the variables and their type here. Possible
types are string, integer, long and date.
#region properties
private string _HelloString;
private bool _CheckBoxBool;
[WidgetDataMember(true)]
public bool CheckBoxBool { get { return _CheckBoxBool; }
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set { _CheckBoxBool = value; } }
[WidgetDataMember("Hello Wolrd")]
public string HelloString { get { return _HelloString; }
set { _HelloString = value; } }
#endregion
l

The following is a widget host declaration.
private IWidgetHost _host;

l

The following is the widget’s page_init events.
protected void Page_Init(object sender, EventArgs e)
{ _host = Ektron.Cms.Widget.WidgetHost.GetHost(this);
_host.Title = "Hello World Widget";
_host.Edit += new EditDelegate(EditEvent);
_host.Maximize += new MaximizeDelegate(delegate() { Visible = true; });
_host.Minimize += new MinimizeDelegate(delegate() { Visible = false; });
_host.Create += new CreateDelegate(delegate() { EditEvent(""); });
PreRender += new EventHandler(delegate(object PreRenderSender, EventArgs Evt)
{ SetOutput(); });
ViewSet.SetActiveView(View);
}

Comments about the page_init code
l

The gethost method returns a reference to the container widgethost for this
widget. This is the case in both Personalization and PageBuilder.

l

The Title property is the title of this widget. By setting it in page_init for the
widget, we inform the host what text to put in the title bar above the widget. This
works in both PageBuilder and Personalization.

l

The events below host.Title are raised by the widgethost. It’s up to the widget
to subscribe to them. In all cases, if we don’t subscribe to them, the icons don’t
show up. This is a method of attaching widget code to button clicks and other
events that occur outside the widget.

l

For PreRender: Ektron renders the contents of this widget on pre-render, thus
ensuring a single render event. Another option is to call SetOutput on the Load
event, but you can only do that if the widget is not in edit mode currently.

l

The final line sets the view to display mode.

l

The following is the declaration of the widget’s edit events.
void EditEvent(string settings) {
string sitepath = new CommonApi().SitePath;
ScriptManager.RegisterClientScriptInclude(this, this.GetType(),
"widgetjavascript", sitepath + "widgets/widgets.js");
ScriptManager.RegisterOnSubmitStatement(this.Page, this.GetType(),
"gadgetescapehtml", "GadgetEscapeHTML('" + HelloTextBox.ClientID + "');");
HelloTextBox.Text = HelloString;
MyCheckBox.Checked = CheckBoxBool;
ViewSet.SetActiveView(Edit);
}

Comments about the edit code
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IMPORTANT: You must register JavaScript and cascading style sheet (css)
instructions in an external file.
l

The Edit event is triggered by the widgethost, and if you subscribed to it already, it
will call the delegate here.

l

Use sitepath to ensure that the correct path for included files is used across
installations.

l

Ensure that it works inside update panels by calling the scriptmanager to include
the script. Alternatively, you can use Ektron.Cms.Api.Js.RegisterJSInclude
ScriptManager.RegisterOnSubmitStatement(this.Page, this.GetType(),
"gadgetescapehtml", "GadgetEscapeHTML('" + HelloTextBox.ClientID +
"');");

l

The onsubmitstatement is JavaScript that is run when the widget is submitted. It
calls escape html, which cleans the submitted text to avoid any XSS.

l

Notice the editing fields, so users can see the existing data.
HelloTextBox.Text = HelloString;
MyCheckBox.Checked = CheckBoxBool;
ViewSet.SetActiveView(Edit);

l

The following code is the widget’s save events.
protected void SaveButton_Click(object sender, EventArgs e)
{ HelloString = ReplaceEncodeBrackets(HelloTextBox.Text);
CheckBoxBool = MyCheckBox.Checked;
_host.SaveWidgetDataMembers();
ViewSet.SetActiveView(View);
}

l

The following code is the widget’s SetOutput events.
protected void SetOutput()
{ HelloTextLabel.Text = HelloString;
// client javascript remove brackets, server side adds back
CheckBoxLabel.Text = CheckBoxBool.ToString();
}

l

The following code is the widget’s Cancel events.
protected void CancelButton_Click(object sender, EventArgs e)
{ ViewSet.SetActiveView(View); }

l

The following code is for greater than and less than signs.
protected string ReplaceEncodeBrackets(string encodetext)
{ encodetext = Regex.Replace(encodetext, "&lt;", "<");
encodetext = Regex.Replace(encodetext, "&gt;", ">");
return encodetext; }

Customizing a widget
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The following topics let you further customize widget behavior.

Working with JavaScript and cascading style sheets
You can use JavaScript or a cascading style sheet to add custom functionality or styling
to a widget. To do this, place the JavaScript or cascading style sheet (css) instructions
in an external file, then register it in the code-behind file.
Example of including a JavaScript file.
void EditEvent(string settings)
JS.RegisterJSInclude(this, _api.SitePath +
"widgets/contentblock/jquery.cluetip.js", "EktronJqueryCluetipJS");

Example of including a .css file.
Css.RegisterCss(this, _api.SitePath
+ "widgets/contentblock/CBStyle.css","CBWidgetCSS");

WARNING! You must register JavaScript and .css files in an external file, as shown
above. If you do not, the OnSubmit event places HTML in the TextArea field in
encoded brackets (< >) and generates a dangerous script error.
The JS.RegisterJSInclude and Css.RegisterCss functions take 3 arguments.
l

1. A reference to the control that needs the script or style sheet on the page.
Typically, ‘this’ or ‘me’. For example:
o this

l

2. The URL of the script or style sheet being included. You should prefix the URL
with a site path so it can be used with URLs like http://localhost/ektrontech
and http://ektrontech. For example:
o _api.SitePath + "widgets/contentblock/jquery.cluetip.js"
o

l

_api.SitePath + "widgets/contentblock/CBStyle.css"

3. A unique key. Only include the script specified by a key once. Your organization
should develop a standard way to define JavaScript and .css keys. For example:
o "EktronJqueryCluetipJS"
o

“CBWidgetCSS”

NOTE: Widgets use an update panel for partial postbacks. As a result, the ASP.NET
tree view and file upload controls do not work with widgets. Ektron has workarounds
for these functions. For an example of a tree view, see the content block widget
(siteroot/widgets/contentblock.ascx). For an Ajax file uploader, see the flash
widget (siteroot/widgets/flash.ascx).

Verifying that a page is a PageBuilder page
Whenever your code is interacting with a widget, you need to verify that it is on a
PageBuilder page (as opposed to another Ektron page that hosts widgets, such as
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personalization).
To check for this, insert the following code:
Ektron.Cms.PageBuilder.PageBuilder p = (Page as PageBuilder);
If(p==null) // then this is not a wireframe
When you want to check the mode, use code like this.
If(p.status == Mode.Edit) // we are in edit mode

Applying global and local properties to a widget
Global and local widget properties reduce your development effort by eliminating
settings data classes. While you can still use these classes and manage your own
serialization, for the vast majority of types, the built-in engine performs the necessary
work.
Global properties apply to every instance of a widget. Local properties apply to one
instance. If both local and global values are assigned to a property, local overrides
global.
As an example of using a local property to override a global, consider a ListSummary
widget. You may want its sort mostly by modified date in descending order, but in
certain instances you want to sort by title in ascending order.
l

Global. Workarea > Settings > Configuration > Personalizations >
Widgets
[GlobalWidgetData()]
public string NewWidgetTextData {
get {return _NewWidgetTextData;} set {_NewWidgetTextData = value;
}}

l

Local. Drop the widget onto PageBuilder page, then click edit (Pencil icon).
[WidgetDataMember()]
public string NewWidgetTextData
{ get { return _NewWidgetTextData; } set { _NewWidgetTextData = value; } }

Setting global properties for a widget
A global property lets an Ektron developer or administrator assign properties and
values that apply to all instances of a widget. You apply a global property to the
widget’s code-behind page. Administrators could then set or update the property’s
value in the Workarea’s Widgets screen.
For example, the Brightcove Video widget requires a player ID. You could insert that in
the widget’s code-behind file. Then, an administrator could review and possibly update
that information in the Workarea widgets screen. Whenever a user drops a Brightcove
Video widget onto a page, the player ID is already assigned.
If the developer does not set a default value in code-behind, an administrator must set
one on the Workarea’s Widgets screen.
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If the developer does set a default value in code-behind, it will be applied unless
changed by an administrator on the Workarea’s Widgets screen.
To set global properties:
1. Open the widget’s code-behind file, which is located in the siteroot/widgets
folder.
2. In the properties section, insert the GlobalWidgetData attribute (as shown) to
set the global property’s name and type.
[GlobalWidgetData()]
public string NewWidgetTextData
{ get { return _NewWidgetTextData; } set { _NewWidgetTextData = value; } }

The supported types for GlobalWidgetData are:
l

Date Time

l

int

l

long

l

double

l

boolean

l

string

l

any enumeration

3. Save the code-behind file.
4. In the Workarea, go to Settings > Configuration > Widgets.
5. Click Edit for the widget whose code-behind file you edited in Step 1. A dialog box
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lets you view and edit global properties set in code-behind.

Setting local properties for a widget
A local property lets an Ektron user assign property values that apply to a particular
instance of a widget. For example, the Brightcove Video widget requires a Video ID,
which identifies the video that appears where you drop the widget.
To set a local properties:
1. Open the widget’s code-behind file, which is located in the site root/widgets
folder.
2. In the properties section, insert the WidgetDataMember attribute to set the
property.
[WidgetDataMember(150530105432)]1
public long VideoID
{ get { return _VideoID; } set { _VideoID = value; } }

3. If you want to set a default value for the widget, use the attribute’s optional
argument, which follows [WidgetDataMember. In the example above, the value is
150530105432.
4. Save the settings in your properties by populating them as you normally would.
5. In the Save event, call _host.SaveWidgetDataMembers();.

Adding a field to a widget
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You can add a Content type drop-down to the ListSummary widget. The drop-down lets
the person dropping the widget on the page select from these choices.
l

all types of content

l

HTML content only

l

assets only

The drop-down appears as follows after it is implemented.

To add this drop-down to the ListSummary widget:
1. In Visual Studio, open the ListSummary widget,
siteroot/widgets/ListSummary.ascx.
2. Find the text DisplaySelectedContent.
3. Below DisplaySelectedContent, add the following code to create a drop-down list
for the ContentType property.
<tr>
<td>DisplaySelectedContent:</td>
<td>
<asp:CheckBox ID="DisplaySelectedContentCheckBox" runat="server" />
</td>
</tr>
<tr>
<td>ContentType:</td>
<td>
<asp:DropDownList ID="ContentTypeList" runat="server">
<asp:ListItem Value="AllTypes">AllTypes</asp:ListItem>
<asp:ListItem Value="Content">Content</asp:ListItem>
<asp:ListItem Value="Assets">Assets</asp:ListItem>
</asp:DropDownList>
</td>
</tr>
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4. Save the ListSummary.ascx file.
5. Open the code-behind file, ListSummary.ascx.cs.
6. In the properties region, declare a string variable for the ContentType property:
private string _ContentType;

7. Create a local property with default setting of AllTypes:
[WidgetDataMember("AllTypes")]
public string ContentType { get { return _ContentType; }
set { _ContentType = value; } }

8. In the EditEvent area, set the select list's value to ContentType:
ContentTypeList.SelectedValue = ContentType;

9. In the SaveButton_Click event, set ContentType as the select list's value:
ContentType = ContentTypeList.SelectedValue;

10. In the SetListSummary() function, set the List Summary server control's
ContentType to the CMSContentType property:
ListSummary1.ContentType =
(CMSContentType)Enum.Parse(typeof(CMSContentType), ContentType);

11. Save the ListSummary.ascx.cs file.

Including help for a widget
You can include help for any widget that has the help icon ().

The help icon only appears when a user is editing a PageBuilder page. The icon appears
both when a user is viewing a widget and editing its properties. It is not available to a
page’s site visitors.
To create a widget’s help file:
1. Create an HTML file with information for users who will drop the widget on the
PageBuilder page.
You could create a content block within Ektron then switch to source view, copy the
content into a word processor (like Notepad), and save it with an HTML extension.
2. Save the help file to the folder that contains the widget.
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3. Add the WidgetHost’s HelpFile property to the code-behind of the page that hosts
the widget.
protected void Page_Init(object sender, EventArgs e)
{
_host = Ektron.Cms.Widget.WidgetHost.GetHost(this);
_host.HelpFile = "~/widgets/myWidget/help.html";

Deleting a widget
If you want to remove a widget, follow these steps. After you do, the widget is removed
from the list of widgets, and from the dashboard of users and community groups.
1. Open the the /siteroot/widgets/ folder.
2. Delete the widget’s files.
3. Go to Settings > Configuration > Personalizations > Widgets and click
Synchronize.

Using the Flash widget
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l

This widget supports both .flv and .swf file types.

l

If you will use .flv files, make sure it is added as a file type. See also: Supported
types of assets on page 710

l

If the Flash file you want to display has already been added to Ektron, use the
Select File tab to it.

l

If the file has not been added to Ektron, first use the Select File tab to select a
folder for the Flash file. Then, use the Upload tab to go your computer’s file system,
and upload the file to the selected folder.

l

The thumbnail feature only works with .flv file types. If you select a Thumbnail, it
appears within the Flash player when the page loads.

l

The thumbnail is only applied to this instance of the widget—not the Flash file. If
you apply this video to a different widget on this page, you must reapply a
thumbnail.

l

The thumbnail is an image file that was dropped into Ektron as an asset. It cannot
be a library image.

l

The autostart feature works only with .flv files.

l

If you log in then upload a flash file, and certain requirements are not met for that
file, you see the following image where the widget appears.

Ektron Reference

1295

Creating and using widgets

The following conditions cause this image to appear.
o

The flash file’s folder properties require certain metadata and/or a taxonomy
category to be applied, and they have not.

o

The folder has a workflow, and this content has not been approved.

Using the Brightcove Video widget
IMPORTANT: You need an account on Brightcoveto show videos in the Ektron
Brightcove Video widget.
Your Brightcove.comaccount lets you upload, store, and play videos on your Web page
with the Ektron Brightcove Video widget.

Setting up your account information for the first time
You see the following screen the first time you use a Brightcove Video widget if you
have not entered account information in the Workarea. Enter your Brightcove account
information here. After you successfully save your account data, this screen does not
appear again.

Adding the Brightcove Video widget
Follow these steps to play videos with the Brightcove Video widget.
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1. Set the Brightcove Video widget Configuration in the Workarea if you did not use
the first timer screen shown in the previous section.
a. From the Workarea, choose Settings > Configuration > Personalizations
> Widgets.
b. Click Edit ( ) next to BrightcoveVideo.ascx to set the properties.

NOTE: Brightcove provides the values for the Global Settings for this
widget on your Brightcove Account pages. Log in to Brightcoveand go to
Account Settings > API Management.
c. Click Save.
2. Place the Brightcove widget on a PageBuilder page.
a. Edit a PageBuilder page.
b. Drag and drop the Brightcove widget into a dropzone.
See Editing content on a PageBuilder page on page 1082 for more information
about PageBuilder and widgets.
3. Upload Videos Using the Brightcove Video widget.
NOTE: You can upload your video using your Brightcove.com account or follow
these steps and upload a video using the Ektron Brightcove Video widget.
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a. Click Edit (

) on the Brightcove Video widget.

b. Notice there are 3 tabs across the top—Video List, Search, and Upload.
c. Click Upload.
d. Enter Video Name.
e. Enter Video Description.
f. Click Browse and choose the video file to upload.
g. Click Upload.
A message on the Edit window shows that the Video is being uploaded. In this
example, we are uploading the Training Program 8.0 video.

NOTE: Your video may not be available to view immediately after
uploading. Allow time for Brightcove to publish it or check its status on your
Brightcove Account page.
4. Choose the Video to Play in the Brightcove Video widget.
a. Click Edit ( ) on the Brightcove Video widget.
b. Click either the picture or title of the video you want to show in this widget.

The following image is an example of the Brightcove Video widget on an Ektron OnTrek
website page.
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Additional Brightcove information
l

Brightcove Documents: http://support.brightcove.com/en/docs

l

Brightcove: Setting Your HTML5 Video Delivery Options

l

Brightcove: Delivering Video with HTML5 and Smart Players

l

Brightcove: Test Your Browser for Brightcove HTML5 Video Player

Troubleshooting the Brightcove Video widget
If your videos do not show in the Brightcove Video widget, check the following topics.
l

Did the video upload succeed?
Check the status of your video by logging into your account on Brightcove and
looking for it in the Media Library.

l

Is the video encoded according to requirements from Brightcove?
According to Brightcove's article Uploading Videos with the Media Module, "Your
video files can use most available file formats; if your files are not already encoded
as VP6 (FLV—Flash video) or H.264, Brightcove transcodes them into one of those
formats."

l

Do you see the video on the widget when editing the PageBuilder page but not
when you publish the page?
Check the publisherID setting in the widget Configuration.

Widget reference
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Widgets are located in the Ektron webroot/siteroot/widgets/ folder. Ektron assigns
standard names to widgets, but Ektron administrators can change a widget's name on
the Synchronize Widgets Screen.

ActivityStream

Displays activities of a user or group, depending on the type of page on which it is
placed. See also Using the ActivityStream widget on page 1709.
l

Object ID. Enter the user’s or community group’s ID.

l

Feed Type. Select User or Community Group.

l

Max Results. Enter the number of results you want to display at a time.

AuthorFacets
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Place this widget on the page to display a list of authors' blog posts.
l

Details-Page Mode. Ignore this checkbox.

Author Facets output
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BlogPostCallToAction

Place this widget on the page and whatever CTA is selected for the blog (on the
Metadata tab) will automatically appear on the page with the blog.

Blogs

After you select a blog ID, displays posts from that blog.
Properties Tab:

1302

l

Blog ID. ID number of the blogs.

l

Blog Name. Name of the blog.

l

Show Summary. Check to display.

l

Show Author. Check to display.

l

Show Date Creation. Check to display.

l

Show Comment. Check to display.

l

Max Results. Enter the number of blogs to display.
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BlogsFeed

l

Page Size. Enter how many lines to show in the feed.

l

Feed URL. Enter the URL of the blogs. The default is the current blog page.

l

Link Text. Enter the text label to click on to obtain the blogs feed.

l

Feed Type. Choose the type of feed─Rss or Atom─from the drop down.
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BrightcoveVideo

Plays a Brightcove video. You must have a Brightcove account to add a video with the
widget.
See Using the Brightcove Video widget on page 1296 for information about using the
BrightCove widget.
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CallToAction

Double click on the CTA that you want on the page. If you have a lot of CTAs in the list,
enter the name of the CTA you want in the Search box and click Search ( ).
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Collection

Displays a collection. You select a Collection ID. See Working with collections on
page 804.

1306

l

Collection Id. Choose the ID of the collection you want to display.

l

Page Size. Enter the number of items you want to display.

l

Teaser. Check if you want to display a 1-line excerpt from the content item.

l

Enable Paging. Check if you want to page through the specified number of titles.
Leave unchecked for an infinite scrolling of blog titles.

l

Include Icons. Check if you want icons to display next to their associated blog
posts.
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ContentBlock

l

Add Text. Enter text that the widget will display when adding a new item to the
widget (rather than going directly in the Workarea and modifying the collection
itself.)

l

SelTaxonomyID. Choose the taxonomy ID that you want to associate with this
collection. Zero (0) means no association.

l

Display Selected Content. Check if you want to show the blog content in the
collection on the page.

ContentBlock

Go to a folder and choose a content item (by ID) to display that content in the widget.
Alternatively, you can create new HTML content from the widget by clicking New.
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ContentList

Displays a list of content blocks. In contrast to a List Summary, where content must be
in a specified folder, the ContentList control displays content from any Ektron folder.

1308

l

Content IDs. Enter a comma-separated list of ID numbers for the content you
want to display.

l

Teaser. Check if you want the summary information to display with each blog post
title.

l

Include Icons. Check if you want icons to display next to their associated blog
posts.

l

Direction. Choose Ascending or Descending order.
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ContentReview

l

Order By. Choose to order the data by title, order of the content IDs, date
modified, date created, and first or last name of the last person to edit the page.

ContentReview

Lets site visitors rate and review the current page.
l

Star Style. Choose 1 of the following:
l Ajax 5 Stars
l

Ajax 5 Stars Comment

l

Ajax 5 Stars with Increments

l

Hide Review List. Check to hide the list.

l

Review Page Size. Enter the size (in lines) of the page.
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DateFacets

Place the DateFacets (Date Range) widget on the page to display a list of blog posts and
resources that were posted during various time periods.
l

1310

Details-Page Mode. Ignore this check box.
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FeaturedItems

Date Facets output

FeaturedItems
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l

Collection Id. Choose the ID of the collection you want to display.

l

Page Size. Enter the number of items you want to display.

l

Teaser. Check if you want to display a 1-line excerpt from the content item.

l

Add Text. Enter text that the widget will display when adding a new item to the
widget (rather than going directly in the Workarea and modifying the collection
itself.)

l

Header Text. Enter the text you want as your featured items headline.

Flash

Displays a selected Flash file which resides in Ektron. You can also set the display’s
height and width. See Using the Flash widget on page 1294.
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Flickr

Display Flickr’s Most Recent or Most Interesting photos. The user also can select the
number of rows and columns for the image display.
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FormControl
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GoogleGadget

Go to a folder and choose a form (by ID) to display in the widget.

GoogleGadget

Select from several Google feeds to display in the widget.
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Heading

Click on the heading size you want, then type the heading text in the text entry box.
Click Save.
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HelloWorld

HelloWorld

Created by Ektron to help developers understand how to create their own widgets.
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iFrame

Lets you enter a path to a Web page or an item on the Web page.

1318

l

URL. Enter the URL of the website you want to display in the iFrame.

l

Widget Title. Enter text to introduce the content.

l

Horizontal Scroll Bar. Check to enable horizontal scrolling of the content.

l

Vertical Scroll Bar. Check to enable vertical scrolling of the content.

Ektron 9.40 SP1

ListSummary

ListSummary

Displays an Ektron List Summary, a list of certain types of content in a selected folder.
You can click on the Folder tab and go to the content or click on the Property tab and
specify the following fields.
l

Folder Id. Enter the number of the folder you want to display in the list.

l

MaxResults. Enter the number of items you want to display in the list.

l

Teaser. Check if you want the summary information to display with each blog post
title.

l

Recursive. Check if you want subfolders to be included in the list.

l

Enable Paging. Check if you want to page through the specified number of titles.
Leave unchecked for an infinite scrolling of blog titles.

l

Include Icons. Check if you want icons to display next to their associated blog
posts.

l

OrderByDirection. Choose Ascending or Descending order.

l

OrderKey. Choose to order the data by title, date modified, date created, and first
or last name of the last person to edit the page.

l

ContentType. Choose the type of content that you want, filtering the results to 1
of the following: AllTypes, Content, Forms, Archive_Content, Archive_Forms,
Assets, Archive_Assets, LibraryItem, Multimedia, Archive_Media,
NonLibraryContent, DiscussionTopic, CatalogEntry.

l

Add Text. Enter text that you want to introduce the collection.

Ektron Reference

1319

Creating and using widgets

l

SelTaxonomyID. Choose the taxonomy ID that you want to associate with this
collection. Zero (0) means no association.

l

Display Selected Content. Check if you want to show the blog content in the
collection on the page.

MessageBoard

Lets a site visitor leave comments on the page.
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MetaDataList

Displays content whose metadata fits a selected folder location and keywords.
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MostPopular

Reports on the following categories of content on your website: Most Viewed, Most
Emailed, Most Commented, or Highest Rated. See also the Most popular widget on
page 543.
l

Tab text. The text that appears on this tab. In the above example, the left tab's
text is the default Most Viewed.

l

Visible. Determines if the tab you are editing appears on the widget. At least one
tab must appear. Checked is the default.

l

Number of days to report. The number of days for which to display the data.
The default is 7.
o The current day is not counted, since it is incomplete. So if you enter 1, you
see information for all of yesterday and today.
o

The date calculation is based on the clock on the website's server.
NOTE: You can change this to any number you wish. However, the widget
can only show data for days for which data is stored in your database.

l

l
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Tab 1 Event. Determines the information appears when a tab is clicked.
o Click Event
o

Most Emailed

o

Most Commented

o

Highest Rated

o

Most Viewed

Filter By. You can restrict the content appears on this widget by selecting a folder
(default) or a taxonomy.
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MultivariateExperiment

This controls the experiment. Settings include the target content number, start/stop
button and the Report hide/show button. See also Measuring Web experiences with
multivariate testing on page 1179.
l

Target. Enter the content ID of the target page. To help find the content, browse
the content folders by clicking Browse (...).

l

Start/Stop. Click this button to start or stop the experiment.

l

Conversions. the number of conversions any variations must have before the
experiment is automatically stopped. For example, 1000 tells the experiment to
automatically end when one variation has reached 1000 conversions.
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MultivariateSection

Drag any type of content widget into the Multivariate Section widget. These produce the
variations used during the experiment. See also Measuring Web experiences with
multivariate testing on page 1179.
l

Variant 1. Place a content widget into Variant 1 and specify its content.

l

Variant n. Click on the Plus icon to add another variant.

MultivariateTarget

When a page view occurs on a page containing this widget, the conversion count is
increased. See also Measuring Web experiences with multivariate testing on page 1179.

QRCode
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RecentPosts

Generates a QR code based on the information you provide.

RecentPosts

l

Page Size. Enter the maximum number of items to show.
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Recent Posts Output
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ResponsiveImage

Adds a responsive image to a page. Click Select Image to browse for an image in the
Library.
l

Title. Enter the text that you want to appear when you hover over the image.

l

Border. Enter the number of pixels you want the image border to have.

l

Link. Enter a URL that you want to load when the image is clicked on.
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RSSFeed

Lets you enter the path of an Really Simple Syndication (RSS) feed.
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Spacer

Lets you create an unused space on the Web page.
l

Horizontal Break. Check to display a line in the space.

l

Height. Choose the height of the space in em, pixel (px), or point (pt) values.
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StaticContentBlock

Type static content into the text entry box and click Save. The text is displayed on the
page.
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TagCloud

l

Minimum Font Size. Enter the point size of the smallest font to be displayed in
the tag cloud.

l

Maximum Font Size. Enter the point size of the largest font to be displayed in the
tag cloud.
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TargetedContent

Lets you create a set of conditions. As soon as any condition evaluates to true, an
appropriate widget appears. See Connecting visitors with targeted content on
page 1155 for information about the TargetedContent widget.
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l

Name. Give a name to the set of criteria for your targeted content.

l

Condition. Click on the +Or button to specify 1 or more criteria. For example, a
condition may stipulate that the URL parameter terms contains either "pizza" or
"Italian."
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TaxonomySummary

Displays content assigned to a taxonomy category.
See also Organizing content with taxonomies on page 1357.
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TextSearch

Place on a PageBuilder page to add a search box to the page.
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Trends

By default, the Trends widget shows the Most Viewed content on your website. You can
edit the widget so it displays any of these content categories instead: Most Emailed,
Most Commented, or Highest Rated.
l

l

Report Type. Report types are:
o Most Viewed (default)
o

Most Emailed

o

Most Commented

o

Highest Rated

Number of days to report. The number of days for which to display the data.
The default is 7.
o The current day is not counted, since it is incomplete. So if you enter 1, you
see information for all of yesterday and today.
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o

The date calculation is based on the clock on the website's server.
NOTE: You can change to any number you wish. However, the widget only
shows data for days for which data is stored in your database.

l

Order Direction. The direction in which search results are sorted. The default is
Descending.
o Ascending. Alphabetical results from A to Z; numeric values low to high; dates
from oldest to most recent
o
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Descending. Alphabetical results from Z to A; numeric values high to low;
dates from most recent to oldest

l

Maximum Number of Items. Enter the maximum number of content items that
may appear on the Trends widget. The default is 5. The Ektron database maintains
a count (number of hits) for each content item, for each date. When you select a
number of days, the Trends widget displays the content with the most hits during
that date range, up to the number you set in this field.

l

Filter By. You can filter which content appears on this widget by selecting a folder
or a taxonomy.
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WebCalendar

WebCalendar

Provides full calendar functionality, including adding events.
See also Working with calendars on page 991.

YouTubeVideo

Lets you embed code for any YouTube video.
l

Video List. Click on this tab to display videos based on the Sort By drop-down.

l

Sort By. Choose 1 of the following sort criteria: recently featured, top rated, top
favorites, most viewed, most popular, most recent.
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l

Search. Click on this tab to display videos based on what is found by the Search By
field.

l

Search By. Enter text to search for videos.
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Ektron lets you create and maintain a drop-down menu system for your website. The
menu options can link to content, library files, external hyperlinks, and submenus. The
following image shows an open Products menu on the Ektron Ontrek sample site.

You must be one of the following users to work with menus.
l

a member of the Administrators user group

l

assigned the Collection and Menu Admin role; See also: Defining roles on
page 1581

l

assigned the Menu Admin role

An Ektron developer can use the MenuView templated server control to place a menu on
a Web form. See MenuView.
NOTE: If you choose to hide the border that surrounds content when you are logged
in, the Add and Edit options are also hidden. This lets you view the page as it
appears when not logged in. If the page is set to show borders and you still do not
see Add and Edit, the feature may be turned off. Ask your administrator or website
developer for more information.

Adding a menu
You can add a menu to a content folder, or to the root folder through Workarea
> Content > Menus. When you add a menu to a content folder, the menu is
associated with that folder. After creating the menu, you can assign items to it. See
Adding a menu item on page 1345.

Adding a menu to a content folder
1. Go to a content folder.
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2. The current language appears as a flag next to the screen title. To create the menu
in this language, proceed to the next step. To change the new menu's language,
click View > Language and select the new language.
3. Click New > Menu. The Add Menu screen appears. For information about the
fields on this screen, see Filling out the Add menu and Edit menu screens below.
4. Click Save.

Adding a menu to the root folder through the Menus tab
1. Choose Workarea > Content > Menus > Menus.
2. The current language appears in the Language field. To create the menu in this
language, proceed to the next step. To change the new menu's language, select
one from the Language field drop-down.
3. Click Add. The Add Menu screen appears.For information about the fields on this
screen, see Filling out the Add menu and Edit menu screens below.
4. Click Save.

Filling out the Add menu and Edit menu screens
The Add Menu and Edit Menu screens have the same information.
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The following list describes the fields for both screens.
l Title. The name of the new menu that appears on the Web page.
l

Image Link. You can have an image appear next to or instead of the menu title.
The image must reside in the library. If it does not, add it before proceeding. For
more information, see Adding a file to the library on page 740.
For example:

To do this:
1. Click the icon to the right of the ImageLink field (

). The library window

opens.
2. Go to the folder that contains the image you want to use.
3. Click Insert.
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4. You can replace menu text with an image so that only the image appears on
the menu by checking the Use image instead of a title box.
l

URL Link. After you create a menu, your developer links it to text or an image on a
Web page by modifying a page template. When a site visitor moves the cursor over
the text or image, the menu appears. In the following image, the menu appears
when the site visitor moves the cursor over Products.

You can also assign a URL link to a menu using this field. If you do, and the user
clicks the link text or image, he jumps to the specified page.
For example, in this field, you assign the product landing page,
siteroot/products.aspx. In the illustration above, if the user moves the cursor
over Products, the assigned menu appears. However, if the user clicksProducts ,
he jumps to siteroot/products.aspx. The path may be....

l

o

relative to site root, such as siteroot/jobs.aspx

o

a static template path or a dynamic path, such as
wellness.aspx?id=40&wellness=Hemophilia

o

an external hyperlink, such as http://www.example.com.

Template Link. If you want to apply a template to this menu, enter it here. If you
do, content on this menu uses this template when selected from the menu. If you
do not, this menu's content uses the template specified in its Quicklink.
NOTE: This field applies to content only. It has no effect on other types of menu
items (such as images). Also, this field only affects content that dynamically
references a content block, such as /CMS400Min/therapies.aspx?id=84. If the
menu option is a template that includes content (for example,
/CMS400Min/news.aspx), the template identified here is ignored.

l

Description. Add a more detailed description for the menu.

l

Folder Associations. When you click Change, the Select Folder screen appears.
See also: Assigning a folder or template to a menu on page 1345
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l
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o

You can assign 1 or more folders to a menu by choosing a folder and clicking
Add Selections. When you are done, click Save in the lower part of the
screen (Reorder and Finalize Selections screen). You can click Cancel ( ) to
exit without saving your changes.

o

To reorder a folder on the Reorder and Finalize Selections screen, click on a
folder (highlighting it) and use the up and down arrows.

o

To remove a folder from the list, check the box next to the folder on the
Reorder and Finalize Selections screen, and click Delete ( ).

Template Associations. Enter the name of 1 or more templates in the Text field
and click Add. The template name appears in the Template Associations box. You
can also click Browse (...) to select a template from the CMS. when you have more
than template associated, you can reorder them, remove them, or change the
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names (to another valid template name). See also: Assigning a folder or template
to a menu below.

Assigning a folder or template to a menu
When you assign a folder or template to a menu, it exposes a menu whenever a content
item that resides in a selected folder appears, or a content item that uses 1 or more of
the selected templates appears. As a result, a user looking for a specific item sees
similar items. For example, if your website sold books, your folders or templates may
be organized by genre. One of your folders or templates is Teen Fiction. You create a
submenu that contains the top 5 sellers in Teen Fiction. You then associate the Teen
Fiction folder or template with that submenu. When a site visitor finds views a book in
that category, a Flex Menu in the page’s left column displays the top 5 Teen Fiction
titles.
All of the following conditions must be true for the Flex Menu to automatically display
selected items on an associated submenu.
l

You assign a folder or template to a menu.

l

A user goes to a content item that resides in the folder, or content that uses the
template.
NOTE: Navigation to the content can consist of clicking a quicklink, a menu
option, a content list, the result of a search, and so on.

l

A Flex Menu whose EnableSmartOpen property is true appears on the screen.

Deleting a menu
1. Open the View Menu screen.
2. Click the menu you want to delete.
3. Click Delete (

).

4. Click OK to delete the menu.
NOTE: Deleting a menu automatically deletes all menu items associated with it. Do
not confuse the menu link with the item itself. For example, deleting a menu deletes
its links to content but has no effect on the content.
NOTE: Only certain users are allowed to delete menus. See Auditing changes on
page 690.

Adding a menu item
You can add menu items in the following ways:
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l

Choose the website's Add option on a menu. The Add New Item screen appears.

l

Choose the website's Edit Menu option and then edit its menu items on the View
Menu screen.

l

Choose Workarea > Content > Menus > {Menu} and then edit its menu items
on the View Menu screen.
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l

Choose Workarea > Content> Folders > {folder} > View > Menu and then
edit its menu items on the View Menu screen.

You can add the following types of menu items.
l

Content Item. Choose content from the CMS to display when the menu item is
selected. The menu item title is the content name by default, but you can edit it
after you create the menu item.

l

Library Asset. Choose a library asset to display when the menu item is selected.
The menu item title is the asset name by default, but you can edit it after you
create the menu item.

l

External Hyperlink. Specify a menu item title and URL. Selecting the menu item
takes the visitor to the URL.

l

Submenu. Create a menu item that is a submenu. Then create menu items for the
submenu.

Adding a menu item that opens a content item
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1. From the View Menus screen, choose Add Items.
2. Click Content Item.
3. Click Next... The Add New Item screen appears, listing all content folders.
4. By default, All Types of content are available. You can narrow your selection (for
example, HTML content), by choosing a filter from the drop-down.

5. Open the folder you want in the folder tree.
6. Check 1 or more folders to add each folder to the menu as separate menu items.
IMPORTANT: If you check items then go to another screen before clicking
Add, the items on the first screen are not added to the menu.
7. Click Add.
You can assign addition information to the menu item by editing the menu from the
View Menu screen.
TIP—ALTERNATE METHOD FOR CREATING A MENU ITEM

You can use the following alternative method for creating a menu item.
1. Go to a content folder.
2. Click items to be assigned.
3. Right click the mouse and select Copy.
4. Locate the menu, right click the mouse, and select Paste Items to
Menu.
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The View Menu screen reappears, showing the new content.

Adding a menu item that opens a library asset
1. From the View Menus screen, choose Add Items.
2. Click Library Asset.
3. Click Next. The Add New Item screen appears.
4. Enter a title for the library file that appears on the menu.
5. Click Browse Library. The Library Folder screen appears.
6. Select the type of file to insert (Files, Hyperlinks, Images).
7. Go to a folder that contains assets.
NOTE: To insert assets, the menu’s folder must contain library assets.
However, you can insert library assets from other folders for which you have
permission.
8. Select a library asset and click Insert. The Add New Item screen reappears with
the asset displayed in the Title field.
9. Click Save.

Adding a menu item that goes to a URL
1. From the View Menus screen, choose Add Items.
2. Click External Hyperlink.
3. Click Next. The Add New Item screen appears.
4. Enter the title of the new menu item.
5. In the Link field, Enter the URL for the menu item.
Examples
l https://world.episerver.com/ektron/ (external link)
l

/news/pr.aspx (root of the website)
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l

pr.aspx (relative path)

6. Click Save.
NOTE: When you add an external hyperlink menu item, the URL does not get
added to the library nor is an ID assigned to it. So, when you save the menu
item, it is not added to the Ektron database nor can it be retrieved for future
use.

Adding a submenu
1. From the View Menus screen, choose Add Items.
2. Click Sub Menu. The Add Menu screen appears.
3. Click Next. The Add Menu screen appears. To complete the fields on the Add Menu
screen, see Filling out the Add menu and Edit menu screens on page 1341.
4. Click Save. The View Menu screen reappears. The Submenu items look like this:
.

Editing a menu item
To edit a menu item, click on its name in the View Menu screen. The Edit Menu Item
screen appears.
When you edit a menu item, you can make the following specifications:
l

Title. The name of the menu item. It appears on the Web page to indicate the
item.

l

Image Link. You can have an image appear next to or instead of the menu title.
The image must reside in the library. If it does not, add it before proceeding. See
also: Adding a file to the library on page 740.
For example:

To do this:
1. Click the icon to the right of the ImageLink field (

). The library window

opens.
2. Go to the folder that contains the image you want to use.
3. Click Insert.
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4. You can replace menu text with an image so that only the image appears on
the menu by checking the Use image instead of a title box.
l

URL Link. After you create a menu, your developer links it to text or an image on a
Web page by modifying a page template. When a site visitor moves the cursor over
the text or image, the menu appears. In the following image, the menu appears
when the site visitor moves the cursor over Products.

You can also assign a URL link to a menu using this field. If you do, and the user
clicks the link text or image, he jumps to the specified page.
For example, in this field, you assign the product landing page,
siteroot/products.aspx. In the illustration above, if the user moves the cursor
over Products, the assigned menu appears. However, if the user clicksProducts ,
he jumps to siteroot/products.aspx. The path may be....
o

relative to site root, such as siteroot/jobs.aspx

o

a static template path or a dynamic path, such as
wellness.aspx?id=40&wellness=Hemophilia

o

an external hyperlink, such as http://www.example.com.

l

Description. Add a more detailed description for the menu.

l

Target.

l

Link. Use this field if you want to override this content's menu template by using
the template specified in its Quicklink.

Deleting a menu item
1. Go to the View Menu screen for the menu that you want to delete.
2. Click Remove Items ( ).
3. Check the box next to items that you want to remove.
4. Click Remove.
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Reordering menu items
1. Go to the View Menu screen for the menu that you want to rearrange.
2. From the toolbar, click Reorder ( ).
Alternatively, hover the cursor over the menu in the left panel, right click the
mouse, and click Reorder Items.

The Reorder Items screen appears.
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3. Click the item you want to move.
4. Click the up arrow to move it up, or the down arrow to move it down.
5. When finished, click Save.

Creating a menu in another language
NOTE: For information about supporting multiple languages on your website, see
Working with multi-language content on page 1507.
NOTE: To export menus to an XLIFF file for translation by an external agency, see
Exporting content to XLIFF on page 1533.
You can create an edition of any menu in every supported language. When a site visitor
selects a language and clicks a menu link, Ektron displays the menu in that language if
it is available. If it is not available, nothing appears.
Before creating or translating a menu, you should create or translate all content that
will be on the menu. In this way, you can link this content to the new menu. However,
after creating a menu, you can add new items to it.
To translate a menu into any supported language, you can go to the menu on your
website or from go to it in the Workarea.
1. Go to the menu on your website or from go to it in the Workarea.
l On your website, lick the menu and the Edit Menu option.

l

In the Workarea, click the menu you want to translate.

The View Menu screen appears for the selected menu.
2. From the Add drop-down list, select the language into which you want to translate
the menu.

Ektron Reference

1353

Creating menus for your website

The Add Menu screen appears.
3. Complete the screen for the menu in the selected language. To complete the fields
on the Add Menu screen, see Filling out the Add menu and Edit menu screens on
page 1341.
4. Click Save. The View Menu screen reappears. The View drop-down displays the
menu’s new language.

5. To add items to the menu, see Adding a menu item on page 1345. If you want to
add a content menu item, you can insert an item in the selected language only.

Menu server controls
IMPORTANT: Starting from release 8.6, the Flex Menu and Menu server controls
were replaced by the FrameworkUI: <ektron:MenuView> templated server control.
If you are already using the Flex Menu and Menu server controls, you can continue to
do so, but Ektron recommends using current versions of functionality.
Managing menus is a two-step process. The previous section describes the first step,
which is how Ektron users create and update menus. The second step involves a
developer placing a menu server control on a Web form. The server control manages
the display of the menu on your website. This section introduces concepts that affect all
of them, and explains the differences between them.
Ektron provides 2 menu server controls: Flex Menu and Menu.

Contrasting menu server controls
Appearance
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Properties

Type

Appearance

Flex

or

(Other styles are available)

Menu

Properties
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Property

Flex Menu

Menu

508 compliant
Shutter menu
(When you click a menu, it opens directly
below the menu title)

Secondary menu opens when cursor hovers
over it

(alternative: secondary
menu opens when
clicked)

Starts out collapsed; expands as site visitor
selects secondary menu
All menu levels open when page displays

(optional)

Can display secondary menu to the right of
the root menu, instead of directly below it

(optional)

How appearance is modified

How behavior is modified

Option to launch menu links in a new
window
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Server control properties
and style sheet

Xslt and
style
sheet

Xslt

Xslt and
style
sheet

Chapter 25

Organizing content with
taxonomies
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A taxonomy is a top-level navigation structure, independent of the folder structure. It
provides site visitors with multiple access routes to content. A taxonomy contains 1 or
more categories.
NOTE: A taxonomy is essentially the highest-level category. You can perform most
of the same operations on a taxonomy that you can a category.
For example, a taxonomy about Books can have categories called Nonfiction,
Entertainment, Mystery, and so on. A site visitor may look for a book about Ronald
Reagan's acting career and find it in the Entertainment category. Another visitor may
look for a book about his political career and find it in the Nonfiction category. Although
you store all the books that were written about Ronald Reagan in 1 Workarea folder
called Famous People, the taxonomy assignments let your site visitors access
information in the way that they think about Ronald Reagan (such as Actor,
US Governor, or US President).
l

Books > Entertainment > Movies > Actors > Ronald Reagan

l

Books > Nonfiction > US Politics > Federal > Presidents > Ronald Reagan

l

Books > Nonfiction > US Politics > State > California > Governors > Ronald
Reagan

The following example shows the hierarchy of a taxonomy and it categories and subcategories. A category can have any number of sub-categories. In the OnTrek sample
site, the OnTrek Site Navigation taxonomy has Products, Services, Clients, Support,
Company, and Community categories. Similarly, the Products category has Software,
Hardware, and Training sub-categories.
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You can use taxonomies in many ways such as helping site visitors narrow shopping
choices in the immediate vicinity with GeoMapping, or organizing a photo album by
categories, or organizing group discussion board topics, and so on.
BEST PRACTICE—DESIGN

A

TAXONOMY

BEFORE

CREATING

IT

It helps to design a taxonomy on paper before creating it in Ektron. This can
let you determine relationships among the kinds of information before you
try to implement the taxonomy.
Review the site content and decide which content items and folders to assign
to taxonomy categories. Some categories might map directly to a folder.
Other categories might refer to content from several folders. After you
determine how content and folders should be assigned to taxonomy
categories, log in to Ektron and set up those relationships.
A taxonomy directory control can create the navigation on your website automatically.
When the content is tagged with a category, it automatically shows up in the correct
section of the site. The author does not need to know where the content is going to
show up because the taxonomy tagging determines that. If you are managing large
amounts of information, this use of taxonomy is especially powerful.

Creating a taxonomy and its associated categories
PREREQUISITE
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Only Administrators group members and those assigned the Taxonomy
Administrator rolecan perform these actions.
1. Go to Workarea > Content > Taxonomies > Taxonomies.
2. Use the View > language selector to choose a language for the taxonomy.

See also: Working with taxonomies in a multi-language environment on page 1396
3. Click Add Taxonomy. The Add Taxonomy screen appears.

4. Complete the screen with the following information.
l Category Title. Give the taxonomy a title. The title identifies the taxonomy
wherever it appears. The title cannot contain these four characters: <> , '.
l
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Category Description. If desired, enter a more complete description of the
taxonomy. It appears only on the Edit Taxonomy screen.
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l

Taxonomy Image. If desired, you can assign an image to this taxonomy. For
example, in the eCommerce feature, you could display an image that indicates
the type of products that make up the taxonomy.
To display the taxonomy image, use Ektron’s API.

l

Template. If desired, select a template to apply to the taxonomy or category.
See also: Creating a taxonomy-based search on a Web page on page 1384.

l

Inherit (only appears when creating a category underneath a taxonomy).
Check this box if you want this category to inherit its template from the parent
category or taxonomy. If not, assign a template using the Template field
(above).

l

Category Link. Use this field to direct a site visitor who clicks this taxonomy
or category to a page on your website. For example, when someone is using
your site’s company directory and clicks Human Resources > Benefits, he is
directed to that area of your site.
Without a Category Link, if a site visitor clicks a taxonomy category, the
results appear on the same page.
Enter a path to a destination page relative to your site root folder. For
example, aboutus.aspx. When a site visitor clicks this taxonomy or category,
the site visitor is directed to http://your-URL/siteroot/aboutus.aspx.
You could also direct the user to a content ID, such as aboutus.aspx?id=62.

l

Synchronize Languages. Check this box to synchronize all language
versions of content assigned to this taxonomy. That is, maintain the same
content in multiple language versions of a taxonomy. The maintenance only
occurs when one of the affected content items is published.
For example
o

there are English and Spanish versions of the taxonomy 'Press Releases'

o

content ID 406 exists in English and Spanish

If you add content ID 406 to the English 'Press Releases' taxonomy then
publish that content, Spanish content ID 406 is added to the Spanish 'Press
Releases' taxonomy.
Conversely, if you delete content ID 406 from the Spanish 'Press Releases'
taxonomy then publish that content, content ID 406 is removed from the
English 'Press Releases' taxonomy.
As another example
o

there are English and a Spanish versions of the taxonomy 'Press Releases'

o

content ID 407 exists in English only
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If you add content ID 407 to the English 'Press Releases' taxonomy then
publish that content, the Spanish 'Press Releases' taxonomy is not affected,
since content ID 407 does not exist in Spanish.
Conversely, if you delete content ID 407 from the English 'Press Releases'
taxonomy then publish that content, the Spanish 'Press Releases' taxonomy is
not affected, since content ID 407 does not exist in Spanish.
If you choose to not synchronize languages, when you click publish, Ektron
does not synchronize the taxonomy of the content with the same ID but
different languages.
NOTE: This setting is enabled by default. You must disabled it on each node
to remove this functionality.
See also: Working with taxonomies in a multi-language environment on
page 1396
l

Create the Taxonomy in All Languages. Check this box if, whenever a
taxonomy is created in the default language, it is also automatically created in
all other enabled languages.
NOTE: This field only appears if you are creating a taxonomy or category
and do not check Synchronize Languages. It does not appear on the Edit
Taxonomy/Category screen.

l

Display to Users. Check this box if you want this taxonomy or category, and
its subcategories, to appear when this taxonomy appears on your website.
Uncheck this box to block categories from appearing as part of this taxonomy.
For example, you have not finished creating content for a category.
If you uncheck this box, this node and its child nodes are indicated by a gray
background in the Workarea.

The gray background also appears when users work with this taxonomy or
category on the Edit Content screen’s Category tab.
This setting does not prevent you from assigning taxonomies or categories in
the Workarea.
l
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Apply display setting for all languages. Check this box if you want the
Display to Users field value to affect content in all languages, not just the
currently-selected language.
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l

Configuration. Select a configuration with which to associate the taxonomy.
o Content
o

User

o

Group

NOTE: By default, a new taxonomy’s configuration is content. Also, this
field only appears for a taxonomy. It does not appear for categories, which
are below the taxonomy.
Custom Properties tab. Let you extend the taxonomy's functionality by
creating custom fields to capture additional information.
5. Click Save. The View Taxonomies screen appears.
6. Add categories to the new taxonomy by clicking Add Category. The Add Category
screen appears.

7. Enter the Category information. See Step 4 for information about these fields.
8. When finished, click Save.
9. Repeat this process for each category you want to add to this taxonomy.
NOTE: You can also assign a Taxonomy to content using the Edit Content in Folder
screen’s Category tab.

Assigning taxonomies and categories
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You assign taxonomies and categories to content and folders. You also can do it the
other way around: assign content and folders to taxonomies and categories.
NOTE: A taxonomy is essentially the highest-level category. You can perform most
of the same operations on a taxonomy that you can a category.
The following table shows you how to connect various types of content to categories.
To assign a
taxonomy
category to

Available methods

Prerequisites

l

Content
NOTE:
Regardless of
the method
you use to
assign a
taxonomy to
content, the
result is the
same.

from the Edit Content
in Folder screen

from the Content Tab
> Taxonomy screen

Ektron Users
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from the Assign Item
(s) to Taxonomy
screen

l

Must be
authorized to
edit the
folder’s
content
You can only
select from
taxonomies
assigned to
the content’s
folder

For more
information, see

Assigning a
taxonomy to
content on the
facing page

Must be member of
administrators
group or
Taxonomy
administrator

Assigning
content to
categories on
page 1372

Taxonomy’s Configuration > User
check box is checked

Assigning
categories to a
user on
page 1371

Assigning a taxonomy to content

To assign a
taxonomy
category to

Available methods

l

Membership Users

from the Assign
Item(s) to
Taxonomy
screen

l

after logging into
a Community
site, editing the
user profile

l

from the
Workarea’s
Assign Item(s) to
Taxonomy
screen

l

from the
Workarea’s
Community
Group Area

l

after logging into
a Community
site, editing the
community
group profile

Community Group

Prerequisites

For more
information, see

Taxonomy’s Configuration > User
check box is checked

Assigning categories to a membership user on
page 1370

Taxonomy’s Configuration > Group
check box is checked

Assigning categories to a community group on
page 1367

Assigning a taxonomy to content
Use a folder property's Taxonomy tab to determine which taxonomies may be
assigned to content in a folder. For example, to restrict Support team members to the
OnTrek Site Navigation taxonomy, check the box next to it; those member cannot
assign other categories from the Featured Products taxonomy.
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Assigning categories to content
When you edit content, if you choose the Category tab, you see Taxonomy categories
that you can apply to the content.
The number to the right of any taxonomy or category is the total items assigned to it.
For example, the Support taxonomy has 22 items assigned to it. The number includes
individual items plus all items in any assigned folders. So, for example, if 1 content item
and 1 folder are assigned to a category, and the folder has 5 items, the category’s
number is 6.

1366

Ektron 9.40 SP1

Assigning categories to a folder

Assigning categories to a folder
An administrator can make a taxonomy available to a folder.
1. Go to Workarea > Content > Folders and then click a folder.
2. Choose View > Properties.
3. Click Edit Properties.
4. On the Taxonomy tab, uncheck the Inherit parent configuration checkbox if it
is checked.
Unlike many folder properties, Taxonomy settings are not inherited from a parent
folder by default. But you can cause them to be inherited if that is appropriate. If
you are not working on the root folder and the appropriate set of Taxonomies is
applied to a folder’s parent folder, go to the folder’s properties screen and check
the Inherit parent configuration checkbox.
5. Check a taxonomy or categories that should be available to this folder.
From now on, users editing content in this folder can assign categories from the
selected taxonomies.

Requiring the assignment of at least one category
In folder properties, you can require all content to be assigned at least one taxonomy
category. If you do, when content in that folder is saved, Ektron verifies that at least
one taxonomy category is assigned. If none is found, the user must assign a taxonomy
category before saving the content.
NOTE: If a required category is assigned to an English content item, it also is
required (for example) for its corresponding content items in other languages.
To set a folder-level requirement for content to be assigned a taxonomy category:
1. Go to the folder.
2. Choose View > Properties.
3. Click Edit Properties.
4. Click the Taxonomy tab.
5. Enable the At least one category is Required checkbox.
6. Click Update.

Assigning categories to a community group
PREREQUISITE

You can perform this procedure only if the Group box is enabled on a
taxonomy properties screen (Configuration field). Only members of the
Administrator user group or those assigned to the Taxonomy Administrator
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rolecan perform these actions.
You can assign a taxonomy or categories to a community group in the following ways.

Assigning categories to a community group from the
community group area
1. Go to Workarea > Settings > Community Management > Community
Groups.
2. Select a community group.
3. Click Edit this Community Group.
4. Click the Category Tab.
5. Check the taxonomies or categories to apply.

6. Click Save.

Assigning categories to a community group from the taxonomy
area
Members of the administrators group or taxonomy administrators can assign a
taxonomy or categories to community groups via the View All Categories of Taxonomy
screen. See also: Defining roles on page 1581
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1. Go to Workarea > Content > Taxonomies.
2. Select a language whose taxonomies you want to work with. You can choose All.

3. Select a taxonomy.
4. Select the category to which you want to assign content.
5. Click Assign Items to Taxonomy (

).

6. From the View drop-down, choose Community Groups.

7. A search field appears. Click the search icon to see a list of all community groups.
You also can enter one or more letters and only groups containing them appear.

8. Check the box next to community groups you want to assign.
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9. Click Update.

Assigning categories to a membership user
You can assign a taxonomy or categories to a membership user from the Workarea.
1. Go to Workarea > Content > Taxonomies.
2. Select a language whose taxonomies you want to work with. You can choose All.

3. Select a taxonomy.
4. Select the category to which you want to assign content.
5. Click Assign Items to Taxonomy (

).

6. From the View drop-down, click Members.

7. A search field appears. Click the search icon to see a list of all community
members. Or, enter one or more letters, and only members containing them
appear. You can use the drop-down to specify if you are searching the membership
user's first name, last name or user name.
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8. Check the box next to membership users you want to assign.
9. Click Update.

Assigning categories to a user
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
1. Go to Workarea > Content > Taxonomies.
2. Select a language whose taxonomies you want to work with. You can choose All.

3. Select a taxonomy.
4. Select the category to which you want to assign content.
5. Click Assign Items to Taxonomy (

).
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6. From the View drop-down, click CMS Authors.

7. A search field appears. Click the search icon to see a list of all Ektron users (that is,
authors). Or, enter one or more letters, and only users containing them appear.
You can also use the drop-down to specify if you are searching the user's first
name, last name or user name.

8. Check the box to the left of the users you want to assign.
9. Click Update.

Assigning content to categories
PREREQUISITE

You can perform these procedures only if the Group box is enabled on a
taxonomy properties screen (Configuration field). Only members of the
Administrator user group or those assigned to the Taxonomy Administrator
rolecan perform these actions.
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1. Go to Workarea > Content > Taxonomies.
2. Select a language whose taxonomies you want to work with.
3. Click a taxonomy.
4. Check a box next to the category to which you want to assign content.
5. Click Assign items to taxonomy (

).

6. From the View drop-down, choose Content.

7. Choose the type of content you want to see via the Type drop-down.

l

All types. Both archived and active content

l

Content. Active content only

l

Library.Library files

l

Archived Content. Only content that has been archived and set to remain on
site.

8. Go to the folder that contains the content you want to assign to the taxonomy or
category. The path shows on the screen. Folder content appears below the folder
path.
9. Check the box to the left of content you want to assign. You can assign all types of
content, even blogs.
NOTE: Only content in the selected language appears.
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10. Click Update.
You can verify that the content was assigned to a category by going to the content
block and viewing the Category tab of its properties.

Assigning a folder to categories
PREREQUISITE

You can perform this procedure only if the Content box is enabled on a
taxonomy properties screen (Configuration field). Only members of the
Administrator user group or those assigned to the Taxonomy Administrator
role can perform these actions.
NOTE: If you assign a folder, a relationship is established between the folder’s
content and the taxonomy category. The folder is only a convenience for creating
this relationship.
Because there is no relationship between a folder and a taxonomy category, if you
delete the folder from the taxonomy, the taxonomy category is still applied to the
folder's content.
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You can assign a folder to a taxonomy, thereby displaying published content in the
folder when the page is viewed. As content is added to or deleted from the folder, the
taxonomy on the Web page changes dynamically.
For example, you have a “Top News Stories” folder, in which newer news items are
frequently added, and old ones are deleted. The taxonomy only shows the latest news
items. The updating of the content is handled by the taxonomy automatically.
IMPORTANT: If you move content from a folder to which a taxonomy category is
assigned, the category remains with the content in the new folder. If the new folder
also has a taxonomy category assigned, the new category is also applied to the
moved content.
To assign a folder to a taxonomy category:
1. Go to Workarea > Content > Taxonomies.
2. Select the language of the taxonomy on which to work.
3. Select the taxonomy or category to which you want to assign a folder.
4. Click Assign Folders to Taxonomy (

).

5. Go to the folder you want to assign to the taxonomy or category.
6. Check the folders you want to assign.
NOTE: Only checked folders are assigned to the taxonomy or category.
Checking a parent folder has no effect on its child folders.
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7. Click Update.

Additional tasks for taxonomies and categories
Viewing taxonomies
1. Go to Workarea > Content > Taxonomies and click on Taxonomies. The View
All Taxonomies screen displays all taxonomies currently in Ektron. The language
pull down lets you filter the list by a language.
2. To work with any taxonomy, select it. When you do, it appears within the View All
Categories of Taxonomy screen.
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3. Click a taxonomy to view the categories in it. The View Taxonomy screen appears.

Editing a taxonomy
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
1. Go to Workarea > Content > Taxonomies.
2. Select the taxonomy from the list of taxonomies.
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3. Click Edit (

). The following screen appears.

For a description of these fields, see Creating a taxonomy and its associated categories
on page 1359.

Adding a taxonomy or category
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
To add a category to a taxonomy, or to add a subcategory to a category:
1. Go to Workarea > Content > Taxonomies.
2. Select the taxonomy or category under which you want to create a new category.
3. Click Add Category. The Add Category screen appears.
4. Complete the fields for the new category. For a description of these fields, see
Creating a taxonomy and its associated categories on page 1359.
5. Click Save.
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Copying and moving a taxonomy or category
You can move any taxonomy or category to any other taxonomy or category. There are
2 ways to do this.

Copying and moving a taxonomy or category using a toolbar
button
1. Go to Workarea > Content > Taxonomies and open the category that you want
to move or copy.
2. Click Move/copy (

). A dialog appears.

3. Select a taxonomy category to which you want to move/copy the current category.

4. Click
l right arrow (
l

) to move the taxonomy or category to the new location

Copy to the current Taxonomy to copy the taxonomy or category to the
new location

Copying and moving a category using menu options
1. From the left panel of the Taxonomy area, right click a category.
2. Choose Cut category name or Copy category name.
3. Hover over the destination category
4. Click Paste Taxonomy.

Deleting a taxonomy or category
WARNING! When you delete a taxonomy, existing links to content (on the
Category tab) are deleted. If a taxonomy was assigned to a folder (on the Folder
Properties screen), it is no longer assigned.
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NOTE: Only certain users are allowed to delete Ektron taxonomies. See Auditing
changes on page 690.

Deleting a taxonomy from View All Taxonomies screen
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
1. Go to Workarea > Content > Taxonomies.
2. From the View All Taxonomies screen, check the box next to the taxonomy you
want to delete.
3. Click Delete (

).

NOTE: The delete button does not appear if the language selector is set to All.

Deleting a category from View All Categories screen
1. Go to Workarea > Content > Taxonomies.
2. Select a taxonomy from the list of taxonomies. The taxonomy items and properties
appear on the right.
3. Click Delete (

).

4. Click OK.

Removing content from a taxonomy or category
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
1. Go to Workarea > Content > Taxonomies.
2. Select a taxonomy or category.
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3. Check the box to the left of content you want to remove.

4. Click Remove Items.

Removing a folder from a taxonomy or category
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
If you assign a content folder to a taxonomy category, the internal relationship is
between the folder’s content and a taxonomy category. A folder is merely a
convenience for creating this relationship. There is no data connection between a folder
and a taxonomy category.
Therefore, if you delete a content folder from a taxonomy category, all content in that
folder remains assigned to it. To remove the folder’s content from the category, see
Removing content from a taxonomy or category on the previous page.
However, after deleting a content folder, the connection between the folder and
taxonomy category is broken. So, content subsequently added to the folder is not
assigned to the taxonomy.
1. Go to Workarea > Content > Taxonomies.
2. Select the taxonomy or category that has the folder that you want to delete.
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3. From the View drop-down, select Folder(s).

4. Check the box next to folders you want to remove.
NOTE: To remove all folders, check the box in the title bar.
5. Click Remove Items.

Reordering categories
PREREQUISITE

Only members of the Administrator user group or those assigned the
Taxonomy Administrator rolecan perform these actions.
You can reorder the categories of a taxonomy or one of its categories. Reordered
subcategories appear only within the Workarea.
To reorder the categories assigned to a taxonomy or category:
1. Go to Workarea > Content > Taxonomy.
2. Select a taxonomy or category that has content that you want to reorder.
3. Click Reorder (

).

4. Set the Type drop-down list to Category.

5. Select an item then click the up or down arrow to move it in that direction.
6. Continue step 5 until the content is in the desired order.
7. If there are several language versions of this taxonomy, you can automatically
reorder all versions. To do that, check Apply ordering for all languages.
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8. Click Update.

Reordering content assigned to a taxonomy category
You can reorder (that is, change the sequence of) content within a category. Reordered
content appears within the Workarea and can appear on your website of the Directory
server control’s ItemSortOrder property is set to taxonomy_item_display_order.
To reorder the content assigned to a category:
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
1. Go to Workarea > Content > Taxonomies.
2. Select the taxonomy or category that has the content that you want to reorder.
3. Click Reorder (

).

4. Set the Type drop-down list to items.

5. All items assigned to the category appear.
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6. Select an item then click the up or down arrow to move it in that direction.
7. Continue step 6 until all content is in the desired order.
8. Click Update.

Creating a taxonomy-based search on a Web page
A site visitor can search your website by its taxonomy structure when a developer
places a Directory server control on a Web page. The following image shows a
taxonomy displayed through the Directory server control.

When a site visitor clicks a hyperlink on a Web page that has the Directory server
control, it uses the template assigned to the linked content (such as default.aspx
shown in the following example).
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To display the linked content in a different template:
1. When creating or editing a taxonomy or category, select the appropriate template
at the Template pull-down field.
NOTE: Any category below the root level can inherit its parent’s taxonomy
template. Use the Inherit checkbox to do this.
You may need a developer’s help with the remaining steps.
2. In Visual Studio, open the .aspx page that contains the directory server control.
3. Look at the server control’s MarkupLanguage property.
4. If the property is blank, open the following file:
siteroot/workarea/template/taxonomy/taxonomy.ekml.
If the property displays an EkML file, open that file. Its path may be listed in the
property. If the .ekml file’s path is blank, it is workarea/template/taxonomy/.
5. Find the following line: [$HyperLink]<br/>[$Teaser]
6. Replace it with the following: <a href="[$TemplateQuickLink]">
[$Title]</a><br/>[$Teaser]
7. Save the .ekml file.
The content selected from this Directory server control will use the template assigned to
the taxonomy or category.

Importing and exporting a taxonomy
You can export any taxonomy as an xml file. Then, you can reuse it or send it to
someone else, who would import it to bring a copy of it onto their computer.
You can use the Export/Import feature like a “save as” feature. For example, you want
to create a taxonomy that is similar to an existing one but has a few differences. The
easiest way to do this is to export an existing one, import it under a new name, and edit
it.
Note that imported categories have no content or folders assigned to them. The import
and export only includes the category names, hierarchy, and properties.
The following example shows part of a taxonomy saved as an XML document.
<ArrayOfTaxonomyData
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<TaxonomyData>
<TaxonomyId>959</TaxonomyId>
<TaxonomyName>Bob Taxonomy</TaxonomyName>
<TaxonomyLanguage>1033</TaxonomyLanguage>
<TaxonomyLanguageName>English (U.S.)</TaxonomyLanguageName>
<TaxonomyDescription>Sample</TaxonomyDescription>
<Taxonomy>
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<TaxonomyData>
<TaxonomyId>960</TaxonomyId>
<TaxonomyName>Subnode</TaxonomyName>
<TaxonomyLanguage>1033</TaxonomyLanguage>
<TaxonomyLanguageName>English (U.S.)</TaxonomyLanguageName>
</TaxonomyData>
</Taxonomy>
</TaxonomyData>
</ArrayOfTaxonomyData>

Exporting a taxonomy
Exporting a taxonomy means saving it as an .xml file on your computer or network
drive. To export a taxonomy:
1. Go to Workarea > Content > Taxonomies.
2. Select the language of the taxonomy that you want to export.
3. All taxonomies in that language appear.
4. Click a taxonomy that you want to export.
5. Click Export Taxonomy (

).

6. You are prompted to select a folder into which to save it.

Importing a taxonomy
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1. Go to Workarea > Content > Taxonomies > Taxonomies.
2. Click Import Taxonomy (

). The Import Taxonomy screen appears.

3. In the Title field, enter a name for the new taxonomy.
4. Click Browse.
5. Go to the taxonomy file you want to import. The path appears in the Files field.
NOTE: Alternatively, you can enter or paste the xml into the XML box.
6. Determine the taxonomy’s configuration.
o Content. Associate this taxonomy with content.
o

User. Associate this taxonomy with Ektron users or membership users.

o

Group. Associate this taxonomy with community groups. (See the Category
tab of the Edit Community Group screen.)

7. Click Import Taxonomy.
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Creating and assigning taxonomy custom
properties
PREREQUISITE

Only members of the Administrator user group or those assigned to the
Taxonomy Administrator rolecan perform these actions.
Custom properties let you extend the functionality of a taxonomy by creating custom
fields to capture additional information. Custom properties act like metadata for
taxonomies and categories.
For example, your organization manages a nationwide chain of retail stores. You create
a Sales Regions taxonomy, where each category represents a different geographic
region (Northeast, Southeast, and Midwest).

You can create a custom taxonomy property named Regional Manager and use it to
create a list of regional managers.
1. Go to Workarea >Settings > Configuration > Custom Properties.
2. Select the language of the new custom property. You will only be able to apply the
custom property to taxonomies/categories in this language.
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3. From the ObjectType drop-down, click Taxonomy.
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4. Click Add. The Add Custom Property screen appears.

l

Name. Enter the custom property name. The name identifies the custom
property on the Edit Taxonomy screen's Custom Properties tab.

l

Editable. Check this box to let the user (who is applying this custom
property) choose a value or edit the default value. Uncheck the box if the user
cannot choose or edit the value. In this case, the user is only applying the
property. If a property is not editable and has several values (type string:
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select from list or boolean), only the first or selected value is applied to
the property.
For example, assume you manage an auto parts stores and want a custom
taxonomy property to indicate if a car can be repaired at a facility. You create a
property named Repair Services Available, and make it boolean and
editable. Then, the person applying that custom property to a taxonomy
category can choose Yes or No to indicate if repair services are available.
l

Enabled. Check this box if this property can be applied to a taxonomy or
categories. If you uncheck this box, this property does not appear on the Edit
Taxonomy screen's Custom Properties tab.

l

Data Type.
o String. a series of characters

l

o

Boolean. true (yes) or false (no)

o

Numeric. a series of numbers

o

DateTime. one or more dates and times selected from a calendar popup

Display Type/Value. If the Data Type is String, Numeric or DateTime, you
have 2 choices.
NOTE: If the Data Type is boolean, select either Yes or No.
o

Select a single value. the property accepts one value

o

Select from a list. the property accepts several values. When you
choose this option, a lower field appears. (See previous image.)
In the top field, insert a value then click Add. When you do, the value
moves to the lower field. Continue until all values are entered.
If you want to edit the order of the values, select a value and then use the
up/down arrows to the right of the lower field..
NOTE: If Editable is checked and you insert several values, the user
applying the custom property can choose the value. If Editable is not
checked, the first value is applied to the custom property.

5. Click Save. The View Taxonomy Custom Properties Screen appears.
6. Go to Content > Taxonomies > Sales Regions > {region} and click Edit (
The Edit Taxonomy screen appears.
7. Click the Custom Properties tab.
8. Choose Regional Manager from the Select a Custom Property drop-down and
click Add ( ).
9. Choose the manager from the Value drip-down that you want to assign to the
selected region.
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10. Click Update.
11. Access each region category, click the Custom Properties tab, and apply a
manager to the region.

Editing a taxonomy custom property
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. Select the language of the custom property.
3. From the ObjectType drop-down, click Taxonomy.

4. Click the Title of the custom taxonomy property you want to edit.
5. The Edit Custom Property screen appears.
6. Move to the field you want to change. You can edit the Name, Editable, Enables,
and Value fields. For a description of these fields, see the Add Taxonomy Custom
Property screen.
NOTE: You cannot edit the ID, Language, CMS Object Type, Data Type, or
Display Type fields. If you need to change these fields, delete the custom
property and create a new one.
7. Click Save.

Deleting a taxonomy custom property
If you delete a taxonomy custom property, it cannot be assigned to additional
taxonomy and categories, but it remains assigned to all taxonomy and categories to
which it is assigned.
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To delete a custom taxonomy property:
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. From the ObjectType drop-down, click Taxonomy.

3. Select the language of the custom property.
4. Click the Title of the property you want to delete.
5. Click Delete (

). A dialog box asks you to confirm.

6. Click OK.

Reordering taxonomy custom property values
To set the order of values in a custom taxonomy property:
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. From the ObjectType drop-down, click Taxonomy.

3. Select the language of the custom property.
4. Click the Title of the custom taxonomy property.
5. In the Value field, select item that you want to reorder.

6. Click the Up or Down arrows to move the value up or down.
7. Click Save.
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Saving a taxonomy custom property in a different
language
When you save a taxonomy custom property in a different language, Ektron creates a
new (different language) version of the content that is not linked to the original
content. If you edit or delete the original language version, your edits do not affect the
new version. (However, the new version uses the same ID number as the original
language version.)
To create a custom taxonomy property in another language:
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. Select the language of the custom property.
3. From the ObjectType drop-down, click Taxonomy.

4. Click the Title of the custom taxonomy property to be created in another language.
5. From the Add drop-down, select the language in which you want to create the
custom property.

NOTE: The Add drop-down shows enabled languages for which this custom
property does not already exist.
6. Complete the fields for the new category. For a description of these fields, see the
Add Taxonomy Custom Property screen.
7. Click Save.
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Working with taxonomies in a multi-language
environment
When creating a taxonomy, you select a language. At that point, a version of that
taxonomy is created in each enabled language. For example, you create a taxonomy in
English, and French and Spanish are also enabled (in the Settings > Language
Settings screen). Ektron now has English, French, and Spanish versions of that
taxonomy. Each taxonomy ID is the same—only the language IDs are different.
You do not need to use all language versions. And, if you add a new category to a
taxonomy, it is automatically added to all language versions of that taxonomy. Also, if
you enable a new Workarea language, a version of every taxonomy is automatically
created in that language. If you disable a language, all of its taxonomies are deleted.

Edits to taxonomy properties
Initially, all related-language versions of a taxonomy inherit properties from the original
language version. For example, if you create a taxonomy in English and French is
enabled, the French taxonomy description is the same as the English one, as are the
taxonomy image, taxonomy template, value of Display? checkbox, and so on.
After the initial creation of the related-language versions, changes to taxonomy
properties affect the current language only—they do not affect the related-language
versions.

Assigning content to a multi-language taxonomy
You can only apply content to a taxonomy category whose language matches the
taxonomy language.
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If the Synchronize Languages field on the Taxonomy Properties screen is checked,
and you assign content to an English taxonomy, content with the same ID in the other
languages is assigned to the other language versions.
For example, you apply content ID=30, Ektron Server Controls to 1 or more
categories of an English language taxonomy. If that same taxonomy also exists in
German, and there is corresponding German content (also ID=30), it is applied to the
corresponding category in the related German taxonomy.
If you remove content from a taxonomy in any language, it is removed from all
language-related taxonomies. However, if you remove a folder from its assignment to a
taxonomy or category, the content in that folder is still applied.
WARNING! If you delete a taxonomy, all related language versions are also
deleted.

Assigning a folder to a multi-language taxonomy
When you assign a folder to a taxonomy category, you indicate that all folder content is
assigned to that node. Ektron folders are language-neutral, so the folder is also applied
to the corresponding taxonomy category in every language. However, only folder
content that matches the taxonomy’s language is assigned to the taxonomy category.
For example, a folder has 3 content blocks.
l

English content in folder—100, 101, and 102

l

German content in folder—100

If you apply that folder to a taxonomy, the English version of the taxonomy gets 3
content blocks assigned, but the German version only gets 1 content block assigned (ID
100).
If content is later added to the folder, new English content is assigned to the English
taxonomy, and new German content is assigned to the German taxonomy.
NOTE: If you apply a folder to a taxonomy, numbers on the View Taxonomy screen
indicate how many content items are applied to it. Unless you have the same
number of content items in each language, this number is different for every
language.

Effect of multi-language on folder’s taxonomy properties
If there are several language-related versions of a taxonomy and you select 1 of them
then edit a folder’s taxonomy properties, content in the related language inherits the
taxonomy folder properties. For example, assume you select English, then apply a
taxonomy or categories to a folder’s properties. If you later edit Spanish content in that
folder, the corresponding Spanish taxonomy categories are available to be assigned on
the Category tab.

Ektron Reference

1397

Organizing content with taxonomies

The value of the At least one category is Required check box is also inherited. See
also: Requiring the assignment of at least one category on page 1367

Reordering content and categories
If you reorder content assigned to a taxonomy or category, there is no change to
corresponding categories in other languages. This is because there is no guarantee that
content that exists in 1 language exists in the other languages.
If you reorder categories assigned to a taxonomy or category, you have an option to
apply the changes to all language-related categories. See also: Reordering categories
on page 1382

Using taxonomies with social networking
If you have a community or social networking website, you can assign users and
community groups to a taxonomy. This lets site visitors search for users and groups by
category.
To enable a taxonomy-based search of users and community groups, a developer uses
the CommunityGroupBrowser server control on your site, which lets a site visitor
browse a taxonomy category for community groups. See also: Assigning categories to a
community group on page 1367
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Ektron’s URL aliasing makes it easy to create descriptive, meaningful and SEO-friendly

URL aliases consistently, maximizing your website’s placement in search results. Use of
words and phrases that actually define the page increases an aliases’ search engine
rankings. If you follow a pattern, you can scale your aliases across your sites as they
grow. Search engines find URL aliases generated by Ektron. Ektron caches aliases to
improve performance of your site.
If you have a static website (for example, all HTML pages) that is indexed in a search
engine, create aliases for your site and retain complete content management without
affecting your search engine ranking.
If you have a PHP site, alias PHP pages and use the same query string names to pass
needed information to the new .aspx pages.
NOTE: Query strings appended to an aliased page pass to the .aspx page and may
be used if necessary.
Existing sites migrate easily to Ektron, adopting the new aliasing scheme. Aliasing
keeps old links valid and you do not have to make changes to web.config. When URL
aliasing is configured and enabled, content inherits the new aliasing structure.
The following link, Creating User-friendly URLs with Aliasing, is a video that explains the
various types of URL aliases.

Types of URL aliasing

1400

l

Manual URL Alias. give a content block a unique name. You can assign several
manual aliases to content then decide which one is the primary alias. If multiple
alias types are provided for a content item, you can enter any alias into the browser
address field to access that content. See Creating a manual URL alias on
page 1411.

l

Automatic URL Alias. create rules to be applied to the following types of CMS
entities. When you add content to any of the following types, it inherits the URL
alias rules. See Creating automatic URL alias rules on page 1416.
o Taxonomy. create an alias that is based on the taxonomy in your CMS by
using the levels of the taxonomy plus the title of the page. Because the alias is
based on taxonomy, you can have multiple aliases that have relevancy to
multiple search criteria.
o

Folder. create an alias that is based on the CMS folder structure. Descriptive
folder names and a well-organized folder structure makes a URL more relevant
to the content’s actual location.

o

User. create an alias using the name of a user in the URL. For example, a
friendly URL for Steve's profile page can be www.example.com/steve.

o

Group. create an alias using the name of a group to help make community
pages within your Ektron website easy to remember and find. For example, a
friendly URL for car enthusiasts would be www.example.com/cars.
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l

Regular Expressions (RegEx). create a URL match pattern that can redirect or
transform a range of URLs with a single setting. See Creating RegEx expressions
on page 1422.

l

Site Alias. lets an existing site URL have more than one URL for the same site. For
example, if your company‘s name just changed from Bionics to NewGen, (and the
site is essentially intact), you can use site aliasing so your customers can get to the
same site content from the old www.bionics.com address and the new
www.newgen.com address. See Creating a URL alias for a site on page 1425.

l

URL Redirect Alias. lets a link to an old URL find the new or changed URL that
you want. You use this alias when you need to add, change, or modify an existing
URL. See Creating a URL redirect on page 1427.

Configuring URL aliasing
Before you can set up aliases, you must enable the feature using the URL Aliasing
Settings screen. Choose Workarea > Settings > Configuration > URL Aliasing >
Settings. Then, click Edit.
IMPORTANT: If you performed a database sync and the site being synchronized
uses URL aliasing, you must go to its URL Aliasing Settings screen and click Clear
Cache ( ) to update its aliasing information. Also, If you enable or disable any alias
type or caching, you must run a full crawl of your Search Server. See also: Managing
the search crawl on page 395.
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l

Enable URL Aliasing. Let CMS users with permissions create URL aliases.

l

Enable URL Redirects. Let CMS users with permissions create redirected URLs
(for example, 301 redirects). See Creating a URL redirect on page 1427.

l

Manual. Enable manual aliasing. See Creating a manual URL alias on page 1411.

l

Folder. Allow automatic folder aliases to be generated.

l

Taxonomy. Allow automatic taxonomy aliases to be generated.

l

User. Allow automatic user aliases to be generated.

l

Community Group. Allow automatic community group aliases to be generated.

l

RegEx. Allow RegEx aliases to be generated.
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l

Extensions. Enter file extensions of pages for which aliases can be created and
click Add. Begin each extension with a period (.). By default, Ektron supplies the
following extensions (which cannot be removed).
o .aspx
o

/ (the slash is actually the lack of an extension at the end of a page’s name)

Do not add any extension entered into the Handler Mapping list. See Restrictions
on extensions on page 1408
The values in this field appear as drop-downs in the Add a New Manual Alias and
Add a New Automatic Alias screens.

See also: Defining unusual file extensions used in aliasing on page 342
l

Override Template. A template and an alias can have the same name, for
example, www.example.com/dynamic.aspx. If this happens, and a site visitor
types such an address into the browser, this check box determines if the template
page or the alias appears. If this box is checked, the alias appears instead of the
template.
NOTE: The template must be defined within the Workarea Settings >
Template Configuration screen.

l

Enable Language Awareness.
o Off (unchecked).
n URL exists in the site visitor's current language: show target.
n

o

URL does not exist in site visitor's current language: 404 File Not Found
appears.

On (checked).
n URL exists in the site visitor's current language: show target.
n

URL does not exist in site visitor's current language:
n If the URL exists in a language listed in the language fallback chain:
show target. (See Setting the fallback locale on page 1529.)
n

If the URL does not exist in the language fallback chain, but does
exist in the site default: show target.

n

If the URL does not exist in the language fallback chain, and does not
exist in the site default, but exists as an alias in any language: get
the first URL match and show target.
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n

If the URL does not exist in the language fallback chain, and does not
exist in the site default, and does not exist as an alias in any
language: 404 File Not Found appears.

l

Default Replacement Character. replace spaces in taxonomy, folder, group or
user path names with a default character (such as underscore, _). You can specify
replacement characters for other characters in the Replacement Character Map on
the Add Aliasing Rule screen.

l

Query String Action. Set up a rule to handle an alias’s query string parameters.
You can set one rule for your entire site (via this field), and separate ones that
override the system-wide rule for specific manual aliases (using the Aliases
screen). The following options are available.
o None. If an aliased URL has a query string, it is ignored. Any query string on
the target URL is used.
o

Replace All Parameters within Alias. replaces a target’s query parameters
with the alias’ s query parameter. Example:
alias’s query string parameter:
http://www.ektron.com/Contact.aspx?id=84
Target: http://www.ektron.com/aboutus.aspx?id=35&Userid=1
Result: http://www.ektron.com/aboutus.aspx?id=84

(The target parameters id=35&Userid=1 are replaced by the alias parameter
id=84)
o

Append Parameters to Alias. appends the alias’s parameters to the target
URL. Example:
Alias: http://www.ektron.com/Contact.aspx?id=84&lang=1033
Target: http://www.ektron.com/aboutus.aspx?id=35&Userid=1
Result: http://www.ektron.com/aboutus.aspx?id=35&Userid=1
& id=84&lang=1033

(The parameter from the alias is appended to the target)
o

Resolve Matched Parameters within Alias. Ektron tries to resolve
matching parameters (it is case sensitive). If a match is found, the alias’s
query string parameter takes precedence. Example:
alias’s query string parameter:
http://www.example.com/Contact.aspx?id=84
Target: http://www.example.com/aboutus.aspx?id=35&UserId=10
Result: http://www.example.com/aboutus.aspx?id=84&UserId=10

(id=35 is replaced by id=84 since it matched the query string parameter.
UserId=10 was not affected because it did not match the alias query string
parameter.)

Setting default documents for URLs
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You can set the default document file (for example, default.aspx) in the ek_
DefaultPage element of siteroot/web.config for client requests of a website that did
not specify a document name. For example, if someone types www.example.com/jobs,
and the default document is default.aspx, this URL resolves to
www.example.com/jobs/default.aspx.
NOTE: The concept of default document is explained in the following Microsoft KB
article: Configure the List of Default Documents in IIS 7
The ek_DefaultPage element determines your website’s default document regardless
of whether you are using URL aliasing.
If a site visitor enters an address without a page name, Ektron refers to ek_
DefaultPage’s values. For example, the first page is default.aspx. If found, that page
displays. If not, it looks for the second page listed, and so on. If no pages are found or a
page is not specified in ek_DefaultPage, Page not found appears in browser.

Permissions for working with URL aliasing
l

Alias-Admin privileges apply to members of the CMS Administrators group and
CMS users with the Alias Administrator role.

l

Alias-Author privileges apply to any CMS user with the Alias Author role.

l

CMS User privileges apply to users that do not have the Alias-Author or Alias
Administrators role applied.
NOTE: By default the Alias-Author role is applied to the Everyone group. This
role can however be removed to further restrict the permissions to the CMS
User state.

Task

AliasAdmin

AliasAuthor

CMS User

View Settings Page

Edit Settings

View Rule List Pages

View Rule
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Task

AliasAdmin

AliasAuthor

CMS User

Edit Rules

View Alias List Page

View alias

Add Aliases

Edit Alias

Delete Alias

View Redirects Page

Edit Redirects Page

View Alias on content
tab
Edit Alias on content
tab

Where aliasing cannot be applied
IMPORTANT: After you enable Aliasing, relative links embedded in your Web pages
that are not preceded by a slash (/) may demonstrate symptoms such as run-time
error notifications, broken images (you see a red X where the image should be), or
missing text styling. The following Ektron Knowledge Base article analyzes this
problem and presents solutions: Avoiding Style Problems, JavaScript Errors, and
Broken Images When Using URL Aliasing.
You cannot apply aliasing to the following areas of Ektron.
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l

images

l

content in root folder (cannot be automatically aliased, although you can alias it
manually and by taxonomy)

l

forums (discussion boards) (links within forum posts can be aliased)

l

forms/polls/surveys—the form is aliased but the postback screen is not (for a
workaround, see Tip/Trick: Url Rewriting with ASP.NET)

l

a link to an HTML form

l

eCommerce. Items in a Cart use an alias unless you assign an .aspx page in the
control’s TemplateProduct property. If you assign a page, it is used in the
product’s URL, not the alias.

l

If you enable .asp as an extension, the alias does not appear when a site visitor
hovers the cursor over assets. Instead, the actual file name appears.
If a site visitor hovers the cursor over HTML content, the alias does appear.

l

The alias does not appear when a site visitor viewing an RSS page hovers the
cursor over assets. Instead, the actual file name appears.

l

content links within the Directory server control. If a template is assigned to a
taxonomy, the template takes precedence over an alias for content found by a
Directory server control.
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Restrictions on extensions
IIS7 handles Web page extensions other than .aspx. There are 2 scenarios.
l

If your site has non-aspx pages, you need to modify the IIS7 Handler Mapping list.
In the Handler Mapping list, extensions that are below ek* in the list are handled
by aliasing. You need to move non-aspx extensions (for example, .asp, .php, .cfm)
above the ek* extensions in the list.
1. Open IIS7.
2. Right click your website.
3. Click Handler Mappings.
4. Click View Ordered List.
5. Move non-aspx extensions used on your site above ek*. For example, if your
site uses .aspx pages, move ASPclassic above ek*.
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NOTE: After you do this, you cannot use these extensions as part of an
alias. So, do not enter them into the Extension field of the URL Aliasing
Settings screen.
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l

If your site previously had non-aspx pages but now it does not, set up aliases to the
previous non-aspx pages so that a visitor's bookmarks will continue to work.
1. Open IIS7.
2. Right click your website.
3. Click Handler Mappings.
4. Click View Ordered List.
5. On the Handler Mappings screen, move non-aspx extensions that you want to
alias below ek*. For example, if your site uses .aspx pages, move ASPclassic
below ek*.
6. Enter the extensions in the Extension field of the URL Aliasing Settings
screen. See also: Types of URL aliasing on page 1400

Clearing the cache
An alias is cached whenever anyone uses it. You should periodically clear the cache so
that aliases are kept current.
IMPORTANT: If your Ektron supports multi-site configurations, you must sign in to
each site’s Workarea, then manually clear its cache.
1. Choose Settings URL Aliasing > Settings.
2. Click Clear Cache (

).

Assigning an alias to multi-language content
When a site visitor selects a language for viewing your site and enters the alias, Ektron
displays the aliased content in the selected language. See also: the Enable Language
Awareness field in Configuring URL aliasing on page 1401.
You can assign a different alias to each language version of content. To do this, select
the content, language, go to the Alias tab, and assign a language-specific alias. For
example, your English home page’s alias is default, while your Spanish alias is
defecto.
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Also, alias names must be unique only within a language. So, for example, you cannot
have 2 aliases named Ektron within U.S. English content. But, you can have 2 two
aliases namedEktron if one is applied to U.S. English content, and the other applies to
Spanish content.

Filtering aliases
You can have many aliases. Ektron lets you sort and filter the aliases to make it easy to
isolate a subset of aliases, to work on, activate, deactivate, delete, and so on. The
Aliases screen (Workarea > Settings > Configuration > URL Aliasing > Aliases)
has the following features for filtering. You can combine these filters to narrow your
focus.
l

Type. filters aliases by taxonomy, filter, manual, user, or group. For example,
choose user and only user aliases appear.

l

Language. filters aliases by the selected language. For example, choose Spanish,
and only the Spanish aliases appear.

l

Default. filters aliases by site, if you have multiple sites; otherwise, default.

l

Search. Type in a string to filter the aliases.

l

Sort column—Click on a column heading to sort the entries A-Z or Z-A.

Creating a manual URL alias
Ektron Reference
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You can choose a page name that makes complex URLs easier to read and remember.
For example, you can create an alias for www.example.com/help.aspx?id=27 that
resolves to www.example.com/help.htm. From then on, the content can be identified
either by its original URL or its alias. You can create any number or aliases for a content
block.
NOTE: You cannot apply an alias to the root website. For example, you cannot alias
www.example.com with www.example2.com. However, you can alias anything below
the root folder.
On multi-site environments, you can apply an alias to a folder on the root site, or to a
folder on other sites, but not both. For example, you can have the alias
content.aspx applied to a root-folder, but then the content.aspx alias cannot be
used on a site-folder at the same time. However, if you apply content.aspx to site1folder, you can also apply content.aspx to site2-folder.
To activate or disable manual aliasing, choose Settings > Configuration > URL
Aliasing > Settings. The URL Aliasing Settings screen appears, which indicates if
manual aliasing is on or off. To change its state, click Edit, check or uncheck the box,
and click Save.

To view a manual URL alias:
1. Choose Workarea > Settings > Configuration > URL Aliasing > Aliases.
2. On Aliases screen, click the alias you want to view. The alias information appears.

Adding/editing a manual URL alias
To add or edit a manual alias, manual aliasing must first be enabled.
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1. Choose Workarea > Settings > Configuration > URL Aliasing > Aliases.
The Aliases screen appears. You can specify the following filters, or go right to Step
2.
NOTE: If there are many aliases, use the search to find one. You can filter by
alias name, Content ID, and so on.
a. Choose Manual from the Type drop-down field. The manual aliases appear in
the Aliases screen.

b. Choose the language from the Language drop-down field.
c. If your Ektron version supports multi-site configurations, use the Site dropdown to choose the site.
2. To create a new alias, click Add Manual Alias. (To edit a manual alias, click an
alias then Edit.) The Alias Data screen appears.
NOTE: After you enable manual aliasing, every content block includes an Alias
tab. You can create a new alias by clicking Add Manual Alias from that Alias
tab. However, if you insert/update an alias from the Alias tab, the alias is
available only after you publish the content.
Also, a folder may require its content to have a manual alias. In this case, you
must add a manual alias before you can check in or submit content.
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3. Check Active to activate the alias when you save it.
4. Optionally, check Default if you want this alias to be the primary alias. Even if the
content already has a primary alias, this alias will become primary.
5. Optionally select another language for this alias.
6. Enter a name in the Alias field. It must be unique within the site and language, and
cannot include the following characters: (comma), (space), \, <, >, “, :, |.
7. To the right of Alias is a pull-down menu of valid extensions. Select an extension
to apply to this alias. Extensions are defined on the URL Aliasing Settings screen.
8. Use the Query String Action field to set up a rule to handle an alias’s query string
parameters. You can set one rule for your entire site (via this field), and separate
ones that override the system-wide rule for specific manual aliases. 4 options are
available.
o None. If an aliased URL has a query string, it is ignored. Any query string on
the target URL is used.
o

Append. Ektron appends the alias’s parameters to the target URL. Example:
Alias: http://www.ektron.com/Contact.aspx?id=84&lang=1033
Target: http://www.ektron.com/aboutus.aspx?id=35&Userid=1
Result: http://www.ektron.com/aboutus.aspx?id=35&Userid=1 |
& id=84&lang=1033

(The parameter from the alias is appended to the target)
o
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Query string parameter: http://www.ektron.com/Contact.aspx?id=84
Target: http://www.ektron.com/aboutus.aspx?id=35&Userid=1
Result: http://www.ektron.com/aboutus.aspx?id=84

(The target parameters id=35&Userid=1 are replaced by the alias parameter
id=84)
o

Resolve. Ektron tries to resolve matching parameters (it is case sensitive). If
a match is found, the alias’s query string parameter takes precedence.
Example:
Query string parameter: http://www.example.com/Contact.aspx?id=84
Target: http://www.example.com/aboutus.aspx?id=35&UserId=10
Result: http://www.example.com/aboutus.aspx?id=84&UserId=10

(id=35 is replaced by id=84 because it matched the query string parameter.
UserId=10 was not affected because it did not match the alias query string
parameter.)
9. Enter the Additional Variables. These are used as query string parameters that
can track how visitors arrived at the aliased page. You might use these in
marketing campaigns to analyze the source of an aliased page’s visitors. For
example, the Additional Variables field has ?gclid=CO7gs_L0_
ZICFRkTIgodBgV9CQ. Your website's analytics software can track the source of the
query through the variable.
NOTE: Within the page load event that returns the query string parameters,
use the Request.RawURL() property instead of request.querystring.
10. In the Content Block section, click Browse. The QuickLink Select window appears.
NOTE: Content choices are affected by value of the Language field on the Add
Manual Alias screen. Only content in the language of the selected alias appears.
Also, only approved content appears.
11. Browse through the folder structure and click on the content to which you are
assigning the alias. The Title and Quicklink fields are filled.
NOTE: A folder’s content appears below its subfolder list. You may have to
scroll down to see the content.
12. Click Save.

Activating/deactivating a manual URL alias
1. Go to Workarea > Settings > Configuration > URL Aliasing > Aliases. The
Aliases screen appears.
2. Click Edit.
3. In the Active column, check the box next to any alias to activate it; uncheck the
box to deactivate it. Check the box next to the Active heading to activate all aliases
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in the list; uncheck to deactivate.
4. Click Save.

Removing a manual URL alias
1. Go to Workarea > Settings > Configuration > URL Aliasing > Aliases. The
Aliases screen appears.
2. Select Manual from the Type drop down to display only manual aliases.
3. Click Edit.
4. In the Delete column, check the box next to any alias that you want to remove.
Check the box next to the Delete heading to select all aliases in the list; uncheck to
clear the check boxes.
5. Click Save.

Creating automatic URL alias rules
Automatic aliasing lets you create rules for several types of CMS entities, based on
taxonomy, folder, user, or group designations. You can select additional elements of
the alias pattern and save all information as a configuration. Because you can assign a
single content block to several taxonomies, that content block can have many
automatic aliases. When you activate an automatic alias configuration, any content
added to the taxonomy, folder, user, or group in the future is assigned that alias (as
long as the configuration is active).
To enable automatic aliasing, choose Settings > Configuration > URL Aliasing >
Settings. The screen indicates if automatic aliasing for taxonomy, folder, community
user, and community group is on or off. To change the state for any of these, click Edit,
then check or uncheck the box, and click Save.
To view an automatic URL alias assigned to a content item, go to a content item and
view the content, then click the Alias tab. Manual aliases appear near the top, followed
by any automatic aliases.

Automatic URL alias pattern
Automatic URL alias pattern combines the following elements—separated by a slash
(/)—in the following order.
1. site root
2. taxonomy, folder, group, or user path.
o Spaces are replaced by the replacement character; the default is underscore
(_). When you create a new rule, you can specify replacement characters in
the Replacement Character Map field on the Add Aliasing Rule screen.
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o

A taxonomy path has taxonomy nodes from the top to the level at which
content is assigned. For example: www.example.com/Medical_
Conditions/Kidney_Disease/.

o

A folder path has folders from the top-level to the folder that contains the
content. For example:
www.example.com/CMS400Developer/CMS400Demo/About_Us/Company_
Profile/Board_of_Directors.aspx.

o

A group path may identify the Marketing group:
http://www.example.com/Marketing/.

o

A user path may identify a community profile for a user:
http://<website>/John/

3. content name source
Spaces are replaced by the replacement character.
4. extension
NOTE: Aliases must be unique. If you try to create a duplicate alias, a value is
appended to the alias to make it unique.
Examples:
Folder-based automatic alias
Suppose that you assign an automatic folder alias called “History” to the
MainSite/Content/Company/Company_News/ folder and you specify the additional rule
that excludes some of the folder path from the URL. When you create
NewHistoryEvent.aspx and put it in the Company_News folder, it has the following URL
automatically generated:
www.example.com/Company_News/New_History_Event.aspx

Taxonomy-based automatic alias
Suppose that you create a new job posting called SalesAdministrator and give it the
Administration and Sales taxonomy categories.
SiteNavigation
Company
Jobs
[x] Administration
[x] Sales
[ ] Marketing
[ ] Engineering
[ ] Support

A taxonomy-based alias automatically generates the following URLs based on the
taxonomy selections:
www.example.com/Jobs/Sales/SalesAdministrator
www.example.com/Jobs/Administration/SalesAdministrator
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User-based automatic alias
A user alias can simplify a reference to someone’s profile page.
www.example.com/member/steve

Group-based automatic alias
A group alias can simplify a reference to a group page.
www.example.com/group_interest/sports_cars

NOTE: Activity streams, SMS, and email notification messages that include links to
users or community groups use the community URL alias in their links. If you want to
show the template alias, use the proper token in the message. For example, to use
the alias for the SubjectUser, use the @SubjectUser.TemplateAlias@ token in your
message. See also: Working with tokens on page 1686.
If you enable a user-based community alias, community users display their alias name
on their profile's Profile Links tab.

Similarly, if you enable a group-based community alias, community groups display their
alias name on the profile's Links tab.

Creating/editing automatic URL aliasing rules
After enabling automatic URL aliasing, you can create rules in a configuration, which
lets you
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l

identify the content source (that is, a taxonomy, folder, user, or group)

l

choose elements of the aliasing pattern

l

preview sample original and aliased URLs
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NOTE: You cannot create a configuration whose values match an existing one.
1. Go to Workarea > Settings > Configuration > URL Aliasing > Aliasing
Rules > Automatic. The Automatic Aliasing Rules screen appears.

2. Click on an existing rule, or click Add Aliasing Rule. A rules screen appears.
a. Specify a unique name for the new automatic rule.
b. Check the Active field if you want the rule to apply immediately after it is
created.
WARNING! If you uncheck this box, automatic aliases set up using this
configuration are deleted from the associated content.
c. If you have more than 1 site, choose the site to which the rule applies.
d. Select the Source Type (Taxonomy, Folder, User, Group).
e. Click Next. The rules screen appears. (The following image shows a sample
Taxonomy rules screen.)
3. Specify the following rules:
l Alias Root (Taxonomy, Folder). Go to and choose a taxonomy or folder to
which you want to assign an automatic alias.
o If you choose a taxonomy, the automatic alias is applied to all content
assigned to it and its child nodes. Furthermore, if your Ektron supports
multi-site configurations, the automatic alias applies to content in all
sites. This is because taxonomy is site independent.
o

If you choose folder, the automatic alias applies to content in that folder
and its subfolders. The taxonomy or folder is part of the automatic alias
pattern.

l

Exclude from Path (Taxonomy, Folder). The automatic alias pattern displays
folders or taxonomy levels from the top to the level you select. You can use
this field to control which folders or taxonomy levels appear in the pattern. For
example, if your Alias Root is based on the following folder path:
/CMS400Demo/About Us/Careers, you can choose any option from the dropdown menu to indicate the folder or taxonomy path in the automatic alias
pattern.

l

Alias Prefix (User, Group). Add a prefix to the alias.
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l

l

Alias Format (Taxonomy, Folder). Use this field to help construct the
automatic alias pattern. Choose 1 of the following items to identify the content
within the alias.
o Content Title. Example: Sample Content Block
o

Content Id. Example: 30

o

Content Id and Language. Example: 30/1033

Extension. Use this field to help construct the automatic alias pattern. Choose
an extension from the list to identify the end of the aliased URL. Extensions are
defined in the Extension field of the URL Aliasing Settings screen.
Do not add any extension entered into the Handler Mapping list. See
Restrictions on extensions on page 1408.

l

Template (Taxonomy). Choose Taxonomy Template or Quicklink. The
alias target URL will be the template of the content item being aliased, along
with any querystring parameters (for example, content.aspx?id=123).
Taxonomy Template can have its own template assigned to the taxonomy
node. When creating the automatic alias, this setting indicates which template
to use for the target URL. Quicklink uses the behavior just described.
Taxonomy Template uses the template assigned to the designated
taxonomy along with the querystring parameters from the Quicklink. For
example:
o Taxonomy Template
n Content ID 123, assigned to template content.aspx

o

l

n

Content assigned to Taxonomy X

n

Taxonomy X has a template taxtemplate.aspx

n

Taxonomy alias rule created targeting Taxonomy X

Quicklink
n Quicklink = /content.aspx?id=123
n

Alias Target with Quicklink Template Field selected =
/content.aspx?id=123

n

Alias Target with Taxonomy Template Field selected =
/taxtemp.aspx?id=123

Query String Param (Taxonomy, Folder). Enter the query string parameter
for this alias. For example, if the alias uses a taxonomy, you could entertaxid.
Here is an example of the parameter in a URL:
http://localhost/eIntranetv2/Blogs.aspx?id=238&blogid=115&
taxId=28
IMPORTANT: Do not enter id here because that will clash with the content
id.
Do not enter more than one parameter.
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l

Example Preview. shows what the alias will look like. To see any content
item’s fully aliased URL, view the content and click the Alias tab; the alias is in
the Automatic section.

l

Replacement Character Map. Accept the default values, or enter the
character that replaces prohibited characters in content titles when they
appear within an automatic alias. Examples of prohibited characters are a
space and question mark (?). So, for example, if the content title is About Us,
and you enter an underscore (_) here, the aliased version of the title is About_
Us. Specify other replacement characters in the Replacement Character Map
section.
You cannot enter one of the following as the replacement character: [, \ / <
> (Space): |? '] # * &%
NOTE: If you're using IIS Admin, and specify a plus sign (+), you get this
error: HTTP Error 404.11 Not Found The request filtering module
is configured to deny a request that contains a double escape
sequence. For a solution, see Error message when you visit a website that
is hosted on IIS 7.0: "HTTP Error 404.11 – URL_DOUBLE_ESCAPED".

Deactivating an automatic URL aliasing configuration
If you deactivate an automatic alias configuration, automatic aliases created by that
configuration are removed from content to which they are applied. The configuration is
saved, so you can reactivate it.
1. Go to Workarea > Settings > Configuration > URL Aliasing > Aliasing
Rules > Automatic.
2. Click the alias that you want to deactivate.
3. Click Edit.
4. Uncheck the Active checkbox.
5. Click Save.

Deleting an automatic URL aliasing configuration
If you delete an automatic aliasing configuration, automatic aliases are removed from
content to which they are applied.
1. Go to Workarea > Settings > Configuration > URL Aliasing > Aliasing
Rules > Automatic.
2. Click Edit List.
3. Check each configuration that you want to delete.
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4. Click Save.
WARNING! No confirmation message appears when you save the Automatic
Aliasing Rules screen, so be deliberate when checking the Delete boxes.

Troubleshooting group or user URL aliases
If you do not see the community alias when you hover over or click a link to a
community group or user, check the following.
l

The alias is set to Active.

l

The alias is the primary alias.

l

The server control that displays the link does not use the TemplateUserProfile
setting. If it does, that value takes precedence over the URL alias.

l

If you are using eSync, refresh the cache after a database sync.

Creating RegEx expressions
A RegEx (regular expression) lets site visitors enter a descriptive URL into the browser
address field and transform that entry into the query string component of an Ektron
page. This lets site visitors “guess” other pages based on a recognizable pattern. For
example, a RegEx expression aliases
blogs.aspx?blogmonth=3&blogyear=2013&blogid=14 as blogs/2013/03/14. From
that, a site visitor can infer that blogs/2013/03/13 would display the previous post,
and blogs/2013/03 would display March 2013 posts, and so on.
To view a RegEx, go to Workarea > Settings > Configuration > URL Aliasing >
Aliasing Rules > RegEx, then click the expression that you want to view.

Creating/editing a RegEx expression
1. Find a site page (such as a blog) whose query string parameters let users guess
similar pages using a pattern. For example:
http://ecmintranet/blogs.aspx?blogmonth=3&blogyear=2013

2. Go to Workarea > Settings > Configuration > Url Aliasing > Aliasing Rules
> RegEx. The RegEx Rules screen appears.
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3. Do 1 of the following:
l To create a new expression, click Add a Regular Expression. The RegEx
Alias screen appears.
l

To edit an existing expression:
a. Click Edit List.
b. Click the expression you want to modify. The RegEx Rule screen appears.
c. Click Edit.

4. Specify the following RegEx Alias parameters (example entries shown):

l

Active. Check this box to activate the expression. If the expression is active,
site visitors can enter an aliased URL to access a page on your site. For
example, they can enter www.example/com/blogs/2013/03/14 to access a
blog page even though the actual URL is
www.example/com/blogs/blogs.aspx?blogmonth=3&blogyear=2013&blogi
d=4
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l

Site. If you have more than 1 site, choose the site to which this RegEx applies.

l

Expression Name. Assign an easily recognizable name to this regular
expression. It appears on the RegEx Rules screen to help users identify it.

l

Expression Library. A link that displays sample expressions.

l

Expression. Enter a RegEx expression that will replace the variables (for
example, $1, $2, and so on.) in the Expression map. If you want to insert a
question mark into the Expression, you must precede it with a backslash (\).

l

Expression Map. Enter a map of original URL elements. The map lets you
replace query string parameters with variables, such as $1, $2, and so on. As a
result, a site visitor can identify other pages that use this pattern by changing
the variable values. You can click Expression Library to view sample RegEx
expression maps. To copy any map that resembles your page pattern, click it
then modify it.
As another example, you can create a pattern without knowing in advance
what URL a user may type, using a querystring variable. When a user types:
www.example.com/catalog/search/christmas

The alias can use a querystring variable after catalog/search/ to see if
content is available in the catalog using the following aliased URL:
www.example.com/catalogsearch.aspx?term=christmas
l

Example URL. Displays an example Web page that follows this pattern.

l

Priority. Assign a priority to this expression from the following choices.
o high (assign to the most frequently-used expressions)
o

medium

o

low

o

none

This field enhances the aliasing feature's response time—it first tries to match
a site visitor’s entry with high priority expressions, then medium, then low.

Deleting a RegEx expression
1. Go to Workarea > Settings > Configuration > URL Aliasing > Aliasing
Rules > RegEx.
2. Click Edit List.
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3. Check the box in the Delete column next to any RegEx you want to delete.
4. Click Save.

Creating a URL alias for a site
If your site supports the multi-site feature, you can enter aliases for any site. For
example, suppose that your company changed its name from Bionics to NewGen, but
the content of your site remains essentially the same. By adding a site alias, along with
appropriate DNS mappings and domain registration, customers can still get to your site
with the bionics.com URL and now also with the new company URL newgen.com.
Note the following conditions for creating a site alias:
l

If your Ektron supports multi-site configurations, an automatic alias assigned to a
taxonomy will apply to content in all sites. This is because taxonomy is site
independent.

l

If the site being aliased resides in a folder under your server’s Web root folder (for
example, ser4325/min), you must add the subfolder to the alias. For example, you
could not enter http://www.myalias.com as an alias for that site. Instead, enter
http://www.myalias.com/min/.

l

You cannot apply an alias to the root website. For example, you cannot alias
www.example.com with www.example2.com. However, you can alias anything below
the root folder. On multi-site environments, you can apply an alias to a folder on
the root site, or to a folder on other sites, but not both. For example, you can have
the alias content.aspx applied to a root-folder, but then the content.aspx alias
cannot be used on a site-folder at the same time. However, if you apply
content.aspx to site1-folder, you can also apply content.aspx to site2-folder.

To create a site alias:
1. Open the site folder for which you want to create aliases. (Site folders have a globe
icon, like this:
).
2. Click View > Properties.
3. Click Edit Properties.
4. Click the Site Alias tab.

5. Enter the alias into the Alias Name field.
NOTE: The alias cannot end with a slash (/).
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From now on, if a site visitor enters the alias into a browser address field, he is
redirected to the site URL (set on the folder properties tab’s Production Domain
field).

6. Add each site alias as an IIS host. To learn how do this for your server, please
consult IIS help.

Editing a site alias
1. Open the site folder for which you want to create aliases. (Site folders have an icon,
like this:
).
2. Click View > Properties.
3. Click Edit Properties.
4. Click the Site Alias tab.
5. Click the alias that you want to edit. When you do, it is highlighted and appears in
the Name field.
6. Change the alias text.
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7. Click Save.
8. Click Update.

Deleting a site alias
1. Open the site folder for which you want to create aliases. (Site folders have a globe
icon, like this:
).
2. Click View > Properties.
3. Click Edit Properties.
4. Click the Site Alias tab.
5. Click the alias that you want to edit. When you do, it is highlighted and appears in
the Name field.
6. Click Delete (

). The alias is deleted.

Creating a URL redirect
You may have an old or original URL that you want to continue to work after you have
moved the content to a new URL. So, you create a URL redirect from an original URL to
a new URL, essentially leaving a "forwarding address" to a new URL. For example, you
can redirect an previously known link (/OnTrek/default.aspx) to a new one
(http://www.example.com/home/).
NOTE: When adding a redirect, the 404 target URL field is optional. If you do not
provide a target URL,a 404 error is handled by the configuration in either the
web.config or IIS.
1. Go to Workarea > Settings > Configuration > URL Aliasing > Settings. The
URL Aliasing Settings screen appears.
2. Ensure that Enable URL Redirects is checked. If it is not:
a. Click Edit.
b. Check the box
c. Click Save. Redirects appears in the URL Aliasing folder.
3. Go to Workarea > Settings > Configuration > URL Aliasing > Redirects.
The Redirects screen appears.
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4. Click Add Redirect. The Add Redirect screen appears.

l

Active. Check the box to activate the redirect.

l

Site. If you have a multi-site environment, choose the site on which the
redirect is active.

l

Redirect Code. Choose the desired redirect code.
o 200 - OK. The original URL and new URL must be relative path URLs;
returns a success status when a person accesses the original URL.
o

301 - Moved Permanently. Use this code to change from one URL to
another. If a person tries to access the original URL, it is replaced with the
new URL. The Original URL must be relative; the new URL can be a
relative or absolute (fully qualified) path.
IMPORTANT: Create separate 301 redirects for your http:// and
http://www versions of your website. They are considered separate
URLs.
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o

302 - Temporary Redirect. Use this code to change from one URL to
another URL, but some information is not passed to servers and Search
engines. (This could affect SEO.) For example, if your website sold
seasonal items, you can redirect each seasonal site to 1 URL, keeping
each season separate, but having 1 branded face to your customer. The
original URL must be relative; the new URL can be a relative or absolute
(fully qualified) path.

o

404 - File Not Found. Use this code for a Web page that no longer
exists, or to force the expiration of a page that may exist. Specify only the
Original URL. If a person tries to access the page in Original URL, a 404
Not Found message is returned.

l

Original URL. Enter the URL of the Web page that will be redirected to the
new URL.

l

New URL. Enter the URL of the Web page to which people will be redirected.
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5. Click Save. The new URL redirect appears on the Redirects screen.
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A breadcrumb displays the path to the current page, providing another type of site
navigation. A site visitor can click any link in a breadcrumb trail to jump to that page.
For example, if a breadcrumb trail is A > B > C > D > E, a site visitor can click B and
jump directly to that page.

You can create breadcrumbs based on either a site visitor's navigation history or the
sitemap of your website.
l

History. Display a trail of recently-visited pages.
NOTE: There is no setup in the Workarea for history breadcrumbs.
To create a history breadcrumb trail, you place a BreadCrumb server control on
each Web form on which you want to display the trail. (To ensure that a
breadcrumb trail appears on each Web page, add a BreadCrumb server control to
every Web form in your site.)

l

Sitemap. Display a site path to the current page.
Sitemap breadcrumbs always show the same path to a page, regardless of how it
was reached. You can use sitemap breadcrumb information to deploy a site map.
Because you determine the organization of a sitemap breadcrumb, you must define
the trail in the Workarea. To do that, see Creating a sitemap breadcrumb trail
below.
See the FolderBreadcrumb server control about how to place a sitemap
breadcrumb on a template.

Creating a sitemap breadcrumb trail
PREREQUISITE

Determine which topics should appear on a Sitemap Breadcrumb trail for
content in a folder. A trail typically consists of topics that introduce a folder's
content, but you can create any sequence that makes sense. For example,
on a university website, content that describes the women's swimming team
has this trail: Home > Athletics > Women's Athletics > Swimming.
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1. Go to the folder for which you want to add the breadcrumbs.
2. Choose View > Properties.
3. Select the language of the breadcrumbs. You must set up a separate breadcrumb
path for every language for which you want to support breadcrumbs.
4. Click Edit Properties.
5. Click the Breadcrumb tab. The Edit Breadcrumbs screen appears.

6. If desired, uncheck the Inherit from parent folder box.
A folder can inherit a sitemap breadcrumb path from its parent, or you can break
inheritance and assign it a unique path.
7. Add the following information.
l Title. The breadcrumb name as you want it to appear in the breadcrumb trail
l

URL Link. The URL path to the breadcrumb’s destination, typically an Ektron
content item.
o If you are not sure of the file path, click Select quicklink (
) and select
the breadcrumb's content item. Only content in the language selected in
Step 3 is available. Alternatively, you can enter a URL, for example,
www.example.com.
o

l

You typically enter items in the sequence in which you want them to
appear in the breadcrumb trail. If you do not, you can easily change the
sequence of items on this screen. See also: Reordering sitemap
breadcrumb items on the next page

Description. Add a description for the breadcrumb.

8. Click Add. The item in the breadcrumb path appears.
9. Repeat steps 7 and 8 for each item in the breadcrumb path.
10. Click Update.
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Reordering sitemap breadcrumb items
1. Go to the folder for which you want to reorder breadcrumbs.
2. On the View Contents of Folder screen, choose View > Properties.
3. Click Edit Properties.
4. Click the Breadcrumb tab. The Edit Breadcrumbs screen appears.
5. Click a breadcrumb item.
WARNING! Clicking the Remove button deletes the breadcrumb item. See
also: Removing a sitemap breadcrumb item on the facing page

6. Click up and down arrows to move the item.
7. Click Save.
8. Click Update.

Editing a sitemap breadcrumb item
1. Go to the folder for which you want to edit breadcrumbs.
2. On the View Contents of Folder screen, choose View > Properties.
3. Click Edit Properties.
4. Click the Breadcrumb tab. The Edit Breadcrumbs screen appears.
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5. Click a breadcrumb item.

7. Edit the Title, URL Link, and Description information.
8. Click Save.
9. Click Update.

Removing a sitemap breadcrumb item
1. Go to the folder for which you want to remove a breadcrumb.
2. On the View Contents of Folder screen, choose View > Properties.
3. Click Edit Properties.
4. Click the Breadcrumb tab. The Edit Breadcrumbs screen appears.
5. Click Remove next to the breadcrumb item you want to remove. (You can do this
only if the breadcrumb item does not have Inherit from the parent folder
checked.)
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6. Click Update.
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Personalization is an integral part of websites like iGoogle and Facebook, and
organizations see personalization as a way to make their sites "stickier" and more
engaging. Ektron provides a framework on which to easily build personalized portals.
Ektron’s portal functionality lets you create a more interactive, engaging experience by
giving power to the user.
Your site becomes their site when membership users can personalize their experience
by adding widgets, application, and feeds, choosing and organizing content on their
digital dashboard. For example, a manager can use widgets to access information about
the team. An HR representative can update job postings through a widget instead of
navigating to the company’s careers site. Building personalization into your intranet
empowers employees with customization that fits their work and personal life.
Widgets have many functions such as photos, local weather, news, a personal work
calendar, a sales time line and tracker, or a feed to a discussion board about a new
product release, and so on. See also: Creating and using widgets on page 1271.

You can create individual and group personalization pages.
l

An individual personalization page is used by a membership user or an Ektron user
to personalize a page on your website. If a tab is private, only that user can view
and edit it. If the tab is public, anyone can view it but only the signed-in user can
create and edit the content.
OnTrek site > Login > My Profile > Dashboard
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l

A group personalization page is used by group members to set up a portal page
that addresses that group’s needs. Any group member can view and create or edit
the page’s content. If a tab on a group page is private, only group members can
view and create or edit it. If the tab is public, anyone can view it but only the group
members can create and edit the content.
OnTrek site > Login > Community > Community Groups > SelfServ
HelpDesk User Group > Dashboard

Using a personalization page
To access a personalization page, a membership user logs in then clicks My profile >
Dashboard.
Individual page
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Group page

Adding a tab
On an Ektron website, you can create and add tabs to organize content by subject.
Tabbed content can be public or private. For example, a tab that displays personal
financial information can be private, so only you can see it. Each tab can have multiple
columns, to further customize the view.

You add a tab by clicking the down arrow choosing Add Tab from the menu. You decide
if the tab is public or private.
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l

Any logged-in user can see a user’s public tab by visiting his or her profile and
clicking Dashboard.

l

A private tab is visible only to the user who created it.
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Adding a column
You must add at least one column by clicking the down arrow and choosing Add
Column.

Adding widgets
Open the widget tray and select the widgets you want and place them on the page.

The selection of widgets that are available was determined when the widget space was
created. See Creating an individual personalization page below

Creating an individual personalization page
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After you create a personalization page, place a link to it on your site. Then, any
authenticated membership user can use the page to create a personal portal.
A widget space declares which widgets a user or community group member can drop on
a personalization page. Widgets appear in the personalization screen’s widget tray
when a membership user is personalizing a page. You can create and modify these
types of widget spaces:
l

User space. widgets that can be applied to a user's profile.

l

Group space. widgets that can be applied to a community group. See also:
Creating a group personalization page on page 1446
For example, suppose you want a NASCAR community group members to be able
to place only weather and news feed widgets onto the group's personalization
page. You would:
1. Create a widget space.
2. Select only weather and news feed widgets.
3. Sign on to Visual Studio to create the .aspx page.
4. Place a Personalization user control onto the page.
5. In the control’s widgetspaceID property, identify the widget space you
created in Step 1.

NOTE: Another type of widget space, Workarea Dashboard, determines which
widgets are available to users when customizing their Smart Desktop.
PREREQUISITE

To access this screen, you must be a member of the Administrators group
1. Go to Workarea > Settings > Configuration > Personalizations > Widgets.
See also: Creating and using widgets on page 1271
2. Click Synchronize Widgets from the Website/Widgets Folder to make sure
all widgets are available.
3. Go to Settings > Configuration > Personalizations > Widget Space.
4. Click Add a Widget Space.
5. Enter a Title.
6. Click Group Space to use the widget space for a community group personalization
page, or click User Space to use widget space for a user's personalization page.
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7. Select widgets that authorized users will be able to place onto a page.

As you select a widget, its background color change
8. Click Add a Widget Space.
IMPORTANT: Remember your widget space’s ID number. You need it when
setting up the Personalization user control.
NOTE: The rest of this procedure explains how to create a personal portal for a
membership user. To learn how to create a portal for a community group, see
Creating a group personalization page on page 1446.
9. Open Visual Studio.
10. Create a new Web Form.
11. Switch to design view.
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12. From the Toolbox, drag and drop an Ajax Extensions > Script Manager control.

NOTE: If you do not see a Script Manager control, install the Microsoft AJAX
Library 3.5. To do this, go to Microsoft ASP.net Download.
13. In the Visual Studio folder browser, open the workarea/personalization/ folder.
14. Drag and drop a Personalization user control (personalization.ascx).
15. Set the control’s widgetspaceid property to the ID number of the widget space
you added in Step 8.
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16. Save the Web Form.
17. Your page should redirect the user to the personalization page, or use an ASP.NET
panel to verify that user is authenticated. Here is sample code:
NOTE: The asp.net panels are implemented in eIntranet and Ektron Tech site.
Aspx.cs
// To check if user is logged in or not
Ektron.Cms.CommonApi IsUserLoggedIn = new Ektron.Cms.CommonApi();
if (IsUserLoggedIn.IsLoggedIn)
{
Response.Redirect(“dashboard.aspx”);
Or
pnlDashboard.Visible= true;
}
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Else
{
pnlDashboard.Visible=false;
}

Aspx
<asp:Panel ID="pnlDashboard" runat="server" Visible="False">
<asp:ScriptManager ID="ScriptManager1" runat="server"
EnablePartialRendering="true">
</asp:ScriptManager>
<ucEktron:Personalization ID="widgetSpace" WidgetSpaceID="1"
DynamicForeignIDParameter="id" runat="server" />
</asp:Panel>

18. The Synchronize Widgets screen helps you synchronize widgets in your website’s
siteroot/widgets folder with those in your Workarea. If you need to make them
available within the Workarea, click Synchronize Widgets from the
Website/Widgets Folder.
The Synchronize Widgets screen also lets you edit widgets by clicking the
corresponding Edit button ( ). For most widgets, you can change only the title
and label. However, you can change a few widgets' properties. For example, you
can enter or update properties of the Brightcove video widget.
After you click the button, you see new widgets on this screen and other Workarea
screens that let you select widgets. Conversely, clicking this button removes any
widgets that you delete from the siteroot/widgets folder.

Creating a group personalization page
A community group personalization page is similar to an individual page. It lets group
members customize a page’s content by placing widgets.
To create a community group personalization page, follow the instructions in Creating
an individual personalization page on page 1441, with the following differences.
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l

When creating a widget space, check the Group Space radio button.

l

When a developer creates an .aspx page and drops a personalization control, the
selected widget space must be one whose Group Space box is checked.
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l

A private tab is visible only to group members.
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Chapter 29

Assigning and managing
tasks
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A task is a required action within Ektron, such as updating or publishing content,
reordering a collection, or updating an image. You can attach a task to a content item,
so that as it progresses through editing and approval, a task tracks those activities.
When working with tasks, you need to understand the following.
l

l

Permissions for creating, redirecting, editing, and deleting tasks.
o You can create and view tasks for yourself.
o

Administrators can perform all task activities.

o

Others must have roles that let them create a task, redirect a task to another
user or group, or delete a task.

o

Only Administrators group members and the user who created a task are
authorized to edit it. This is because the Task feature is designed to restrict the
actions that most users can perform on their tasks, so that tasks progress
through a prescribed series of states.

You can create and manage tasks from multiple places. For example:
o If you are setting up tasks for a project that does not yet have content or for
work items not related to specific content, create tasks through the Workarea
> Reports > Tasks folder.
o

If you are browsing a website and notice that a content change is required,
create a task from the website.

o

If you are reviewing Workarea content and recognize that a new task is
needed, create one from the View Content screen.

l

The difference between a task assigned to content and one not assigned to
content.

l

How task preapproval works.

l

How to create and manage task categories and types, which are used to filter
tasks.

l

How to use task states to indicate the status of a content-associated task

Task states
Tasks are assigned one of the following states.
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l

Not Started

l

Active

l

Awaiting Data

l

On Hold

l

Pending

l

Reopened

l

Completed

l

Archived
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l

Deleted

l

Purged

Contrasting tasks assigned to content with tasks
not assigned to content
There are 2 kinds of tasks. The difference between them involves how a task's state can
change.
l

Tasks assigned to content. Task state changes automatically as the assigned
content's status changes. For example, if content is checked out, the task state
changes to active. Administrators can manually change the task state at any time.
See also: How content events change a task's state on page 1456

l

Tasks not assigned to content. authorized users manually change a task's
state at any time. For example, when a task is finished, you change its state to
Completed. Ektron events do not affect these tasks.

Working with tasks assigned to content
This section explains how to work with tasks that are assigned to content items.

Creating a task assigned to content
PREREQUISITE
l

Only members of the Administrators groups and users assigned to the
Tasks-Create role can create tasks.

1. Create a task and assign it to content from any of these locations.
NOTE: In the second and third options, you choose a content item then select a
task. In these cases, you have already selected the task's content and
language.
l

Workarea > Reports > Tasks > Assigned by and to me > click Add. The
Add Task screen appears.

l

Workarea > Content > folder > content > View Content screen > click
Add Task ( ).

l

a website by clicking the access point ( ) or content menu (

) > Add Task.

2. Complete the Add Task screen.
l Title. Enter a title for the task.
l

Assigned To. To assign the task to anyone who can edit the assigned content
(All Authors), proceed to the next field. Otherwise, click Select User or
Group and choose a user or group.
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NOTE: You can only assign a task to someone else if you are a member of
the Administrators group or assigned the Tasks-Redirect role. If you do not
have this capability, the task is assigned to anyone who can edit the
assigned content (All Authors).
The user to whom a task is being assigned must have edit permission for
the content.
l

Language. Select the language of the content to be assigned to the task.
If you accessed the Add Task screen from the View Content screen or a
website, the language is selected, and you cannot change it.

l

Content. Click Select. A new window appears from which you can go to the
content. You see only content in the selected language and for which you have
at least read-only permission.
If you accessed the Add Task screen from the View Content screen or a
website, the content is selected, and you cannot change it.

l

Priority. Select the priority of the task. Your choices are High, Normal, and
Low. You can sort tasks by priority on the View Tasks screen.

l

Category. If desired, select a category for the task. If you choose a Task
Category, the Task Type drop-down box is auto-filled with task types
associated with that category. See also: Setting up task types and categories
on the facing page.

l

Type. If desired, select the Task Type for this task. You must specify a Task
Category before you assign a task type. See also: Setting up task types and
categories on the facing page.

l

Add. If you want to add Task Categories and Task Types, click Add. See also:
Setting up task types and categories on the facing page
WARNING! If you add a Task Category or Task Type while adding a task,
the task information entered (Task Title, Assigned To, Language, and so
on) is lost when the screen refreshes.

l

Edit. By clicking the Edit link, you can edit the Task Type.
WARNING! If you edit a Task Type while adding a task, the task
information (Task Title, Assigned To, Language, and so on) entered will be
lost when the screen refreshes.
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l

State. The state is set to Not Started and cannot be edited. You can sort
tasks by state on the View Tasks screen. To learn more about the interaction of
content status and task state, see How content events change a task's state on
page 1456.

l

Start Date. Using the calendar button, choose a start date for the task. The
start date appears on the View Tasks screen, where users can sort tasks by
start date.
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l

Due Date. Using the calendar button, choose the date by which the task
needs to be completed. The due date appears on the View Tasks screen,
where users can sort tasks by due date.
If you see a mix-up of the month and date of your entry (for example, you
select March 2 but see February 3), make sure the date format specified in the
Windows Control Panel Regional Settings dialog matches your current
language. Also, make sure the settings apply to the default user.

l

Description. Add additional information to describe the task. The description
appears on the View Task screen.

3. Click Save. If email notification is enabled, an email is sent to the user or group to
which the task was assigned.

Setting up task types and categories
You can organize tasks by category and type. You can assign several types to each
category. For example:
l

Task Categories: Content Maintenance, Engineering, Sales, Documentation, Web
Design, and so on.

l

Task Types: Hardware content update, Software content update, Edit Content,
Update Documents, Contact Customer, and so on.

You can use task categories and types to filter tasks. See Filtering tasks by task type on
page 1463.
1. Go to Workarea > Settings > Configuration > Task Types. To collapse a Task
Category, click

next to the Task Category name; to expand one, click

.
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NOTE: The View Categorization screen has a system-defined category (Form
Submission Task) that can only be used with forms. You can change its name
but cannot delete it. For more information, see Working with HTML forms on
page 843.
2. From the View Categorization screen, click Add Task Type. The Add Task Type
Screen appears.
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3. In the Task Category area, choose an existing Task Category from the drop-down
menu, or enable the Add Task Type to New Task Category radio button and
enter a new category name in the text field.
4. Add a Task Type name in the Task Type field.
5. Enter a Task Type Description.
6. Choose a Task Type Availability.
You can hide Task Types from users by enabling Not Available in the Add Task
Type and Edit Task Type screens. If you make a Task Type unavailable, the
assigned task's Type and Category are changed to Not Specified.
7. Click Save Task Type.

Editing a task category
1. From the View Categorization screen, click the task category whose name you
want to change.
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2. In the text box screen next to the category name, enter the new name.

3. Click Save Category (

).

Deleting a task category or task type
1. From the View Categorization screen, click the check boxes next to the Task items
you want to delete.
2. Click Delete (

). A confirmation box appears.

3. Click OK.

How content events change a task's state
A task assigned to content typically moves through a series of states, from creation to
completion to removal. A task's history shows each state, when it was assigned, and
who assigned it.
Many states are assigned automatically when associated content undergoes a change.
For example, when content is submitted for approval, the task’s state changes to
Pending. Some states are manually assigned by users.
IMPORTANT: At any time, an Administrators group member can change a task’s
state to any other state.
Here is the sequence of user and system actions that change a task’s state.
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Here is the progression of states for tasks assigned to content.
l

Not Started. System action. Automatically assigned when task is created.

l

Active. System action. The task’s content was checked out at some point. It may
currently be checked in.

l

Awaiting Data. User action. The task is started but the assigned-to user is
awaiting information from an external source. Use comments to indicate the data
required for task reactivation.

l

On Hold. User action. Task cannot be worked on at this time.

l

Pending. System action. Content is submitted for approval.
If the current approver edits content then submits it for approval, its status
changes to T (awaiting completion of associated tasks), and all tasks assigned to
the content are set to Pending. At that point, an authorized user must change the
status of all assigned tasks to Completed. Then, all approvers must approve the
content to publish it.
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l

Reopened. System action. Content is declined by an approver in the workflow. Or,
if someone edits content whose task state is Pending, it changes to Reopened.

l

Completed. System action. The content is published.

l

Archived. User action. After a task is completed, administrators can assign this
state. It no longer appears on open task lists but is kept for reviews and reports.
Only the administrator can view Archived tasks. See Archiving a task on the facing
page.

l

Deleted. User action. When an archived task is no longer needed for reporting or
reviewing, administrators can assign this state. While in this state, the task
remains in the database. See Deleting a task on page 1460.

l

(Purged*). User action. When you purge a task, it and all of its transactions are
removed from the database, so the purged state does not actually show. Only
administrators and users with Task-Delete role can purge. See Purging a task on
page 1460.

You can receive email notification of changes in status for tasks and associated content.
See Enabling email notification on page 105 to learn about setting up email
notifications.

Editing a task
PREREQUISITE

Only Administrators group members and the user who created a task are
authorized to edit it. If the person to whom a task is assigned is not
authorized, that person can only view it and insert a comment. The Task
feature restricts most users' ability to edit tasks, so that they progress
through a prescribed series of states.
Authorized users can manually edit any task information (except Assigned By, Task
ID, and Created By).
NOTE: System events automatically change a task's state. See also: How content
events change a task's state on page 1456
1. Go to Workarea > Reports > Tasks > All open Tasks.
2. Click the task. The View Task screen appears.
3. Click Edit. The Edit Task screen appears.
4. Edit task information and click Update.

Adding comments to a task
PREREQUISITE

Only members of the Administrators group, the user who created a task, and
the user to whom a task is assigned can add comments to it.
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Comments can be added to a task to record its progress from assignment to
completion.
Comments appear on the Comments tab of the View Task screen. If a task is assigned
to content, and an approver approves or declines content from the Content Awaiting
Approval screen, the Add Comments to Task screen appears. The screen lets the
approver add comments about the task associated with the content.
Authorized users also can add comments to a task at any time to provide additional
information about its status. For example, if you update a task’s status from In
progress to Waiting on Someone Else, you can use a comment such as: Please review
for grammar and punctuation.
1. Go to Workarea > Reports > Tasks > All open Tasks (or any other type of
task).
2. Click Add Comment ( ). The Comments window appears.
3. Enter a comment.
4. Click Insert. The View Task screen reappears. The comment appears on the
Comments tab.

To update a comment, click its Date/Time link.

Archiving a task
PREREQUISITE
l

Only members of the Administrators group or users to whom a task is
assigned can change its status to archived.

To clean up completed tasks while keeping a record of the tasks, move selected tasks to
the Archived Tasks list. This helps you focus on more recent task completions.
1. Go to Workarea > Reports > Tasks and choose the type of task that you want
to archive. (Typically, you archive completed tasks.) The View Task screen
appears.
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2. Select tasks one at a time, or click the check box in the top left corner to select all.

3. In the Change to State field, choose Archived from the drop-down list.
4. Click Set.

Deleting a task
PREREQUISITE
l

Only Administrators group members and users assigned to the TaskDelete role can delete a task.

l

Users can only delete tasks that they can view. See Determining which
tasks are visible on page 1463

You can delete a task that is no longer needed, such as after it is completed or archived,
depending on your organization’s policies.
1. Go to Workarea > Reports > Tasks.
2. Choose the type of task that you want to delete (for example, All Open Tasks).
The View Task screen appears.
3. Click the task that you want to delete.
4. Click Delete (

).

5. Click OK.

Deleting several tasks at once
1. Go to Workarea > Reports > Tasks and choose the state of tasks that you want
to delete. The View Task screen appears.
2. Select 1 or more tasks, or click the check box in the top left corner to select all.
3. Choose Deleted from the Change to State drop-down.
4. Click Set.

Purging a task
PREREQUISITE
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l

Only members of the Administrators group or users to whom the TaskDelete role is assigned can purge a task.

WARNING! Purging removes a task and its history from the database.
1. Go to Workarea > Reports > Tasks > Deleted.
2. Select tasks one at a time, or click the check box in the top left corner to select all.
3. Click Purge.

Viewing a task
PREREQUISITE
l

Only members of the Administrators group, the user who created a
task, and the user to whom a task is assigned can view it. See also:
Determining which tasks are visible on page 1463

You can view a task in the following ways.
l

If a task is assigned to content
1. Go to Workarea > Content > folder and click content associated with a
task.
2. Click the Tasks tab to see the content's tasks.

l

Whether or not a task is assigned to content
1. Go to Workarea > Reports > Tasks > type of task. For example, All
open Tasks.
2. Click the task you want to view.

l

Viewing a task's history
Ektron maintains a history of events and comments in the life of a task. For
example, the history shows when and by whom the task was created, when it
changed to Active, was linked to content, its state changed, it was approved, and
so on.
NOTE: You can view a task’s history until it is purged.
1. Go to Workarea > Reports > Tasks > type of task. For example, All
open Tasks.
2. Click a task. The View Task screen appears.
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3. Click History ( ). The history of task events appears.

Viewing task reports
The Workarea > Reports > Tasks folder displays all tasks, many filtered by task
state.
PREREQUISITE

Only Administrators group members , the user who created or assigned a
task, or the user to whom a task is assigned can view it. See also:
Determining which tasks are visible on the facing page
The following list shows the types of tasks that authorized users can view, filter, and
assign to other users.
l

All open Tasks. shows all tasks whose status is one of the following:
NOTE: Authorized users also can edit a task from this task state.
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l

not started

l

active

l

awaiting data

l

on hold

l

reopened

l

pending

l

Assigned by and to me. Tasks assigned to you, and tasks you assigned to
yourself or someone else

l

Assigned to me. Tasks assigned to you

l

Assigned by me. Tasks you assigned to someone else

l

Created by me. Tasks you created

l

Assigned to User. Tasks you assigned to a user

l

Not started. Tasks whose state is Not started

l

Active. Tasks whose state is Active

l

Awaiting Data. Tasks whose state is Awaiting Data
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l

On Hold. Tasks whose state is On Hold

l

Pending. Tasks whose state is Pending

l

Reopened. Tasks whose state is Reopened

l

Complete. Tasks whose state is Complete

l

Archived. Tasks whose state is Archived

l

Deleted. Tasks whose state is Deleted
NOTE: You can also purge tasks from the Deleted task state.

Filtering tasks by task type
Every View Task screen lets you filter tasks by type. Use the Show Task Type dropdown to choose a Task Type. Only Task Types that are applied to a task appear in the
Show Task Type drop-down box.
NOTE: Words in bold italics are Task Categories. You cannot filter by Task
Categories.

Determining which tasks are visible
To provide security, Ektron restricts which users can view which tasks. The following
table shows the Viewing options by user or group.

View option

All Open *

Administrator
group member

User or group
member to whom
task assigned

User who
created
task

X

Assigned by
Me *
Assigned to
Me *

User who
assigned
task

X

X
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View option

Administrator
group member

User or group
member to whom
task assigned

Created by
Me *
Assigned to
User
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User who
created
task
X

X

Not Started

all tasks in
specified state

only tasks
assigned to user in
Not Started state

Active

all tasks in
specified state

only tasks
assigned to user in
Active state

Awaiting data

all tasks in
specified state

only tasks
assigned to user in
Awaiting data state

On hold

all tasks in
specified state

only tasks
assigned to user in
on hold state

Pending

all tasks in
specified state

only tasks
assigned to user in
Pending state

Reopened

all tasks in
specified state

only tasks
assigned to user in
Reopened state

Completed

all tasks in
specified state

only tasks
assigned to user in
Completed state

Archived

all tasks in
specified state

Deleted

all tasks in
specified state
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*—user can only view tasks in a not started, active, awaiting data, on hold, pending, or
reopened state

Working with tasks unrelated to content
This section explains how to create tasks for activities that are unrelated to specific
content items.
PREREQUISITE
l

Only members of the Administrators groups and users assigned to the
Tasks-Create role can create tasks.

1. Workarea > Reports > Tasks > Assigned by and to me > click Add. The
Add Task screen appears.
2. Enter the following information.
l Title. Enter a title for the task.
l

Assigned To. Click Select user or group and choose a user or group to
assign to the task.

l

Language. Ignore.

l

Content. Ignore.

l

Priority. Select the priority of the task. Your choices are High, Normal and
Low. The priority appears on the View Tasks screen, where a user can sort
tasks by priority.

l

Category. If desired, select a category for the task. If you choose a Task
Category, the Task Type drop-down box is auto filled with task types
associated with that category. See also: Setting up task types and categories
on page 1453.

l

Type. If desired, select the Task Type for this task. You must specify a Task
Category before you assign a task type. See also: Setting up task types and
categories on page 1453.

l

Add. If you want to add Task Categories and Task Types, click Add. See also:
Setting up task types and categories on page 1453
WARNING! If you add a Task Category or Task Type while adding a task,
the task information entered (Task Title, Assigned To, Language, and so
on) is lost when the screen refreshes.

l

Edit. By clicking the Edit link, you can edit the Task Type.
WARNING! If you edit a Task Type while adding a task, the task
information (Task Title, Assigned To, Language, and so on) entered will be
lost when the screen refreshes.
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l

State. Select a task state to indicate the task's completion status. To find any
task, users can select from options below the Tasks folder to view all tasks in
that state.

'7
l

Start Date. Using the calendar button, choose a start date for the task. The
start date appears on the View Tasks screen, where users can sort tasks by
start date.

l

Due Date. Using the calendar button, choose the date by which the task
needs to be completed. The due date appears on the View Tasks screen, where
users can sort tasks by due date.
If you see a mix-up of the month and date of your entry (for example, you
select March 2 but see February 3), make sure the date format specified in the
Windows Control Panel Regional Settings dialog matches your current
language. Also, make sure the settings apply to the default user.

l

1466

Description. Add additional information to describe the task. The description
appears on the View Task screen.
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3. Click Save. If email notification is enabled, an email is sent to the user or group to
which the task was assigned.

What happens to a task unrelated to content after it is
created
After a task is created, the user to whom it is assigned would typically perform some
aspect of the task. Then, that user would use the Assigned to me screen to change its
state as appropriate. For example, the user might change its state to Completed. Or,
the user might change its status to On Hold and assign it to someone else.
The following activities can be performed on a task not related to content.
l

Setting up task types and categories on page 1453

l

Editing a task on page 1458

l

Adding comments to a task on page 1458

l

Archiving a task on page 1459

l

Deleting a task on page 1460

l

Purging a task on page 1460

l

Viewing a task on page 1461

l

Viewing task reports on page 1462

Setting up an automatic task for pre-approving content
You can set up a preapproval task to require 1 or more users to approve content before
it enters the regular workflow. See also: Approving content for publication on page 749
NOTE: You also can create a task automatically when a form is submitted. See also:
Assigning a task to a form on page 886
When a user submits content for approval, Ektron checks to see if an open task exists
for it. (An open task is one whose state is Not Started, Active, Awaiting Data, On Hold,
or Pending.) If none exists but a preapproval group is assigned to its folder, a task is
automatically created for the content. When the task is reviewed by any preapproval
group member, there are 2 choices.
l

Assign the task to another user, such as an editor. (The user to whom the task is
being assigned must have permission to edit the content.) The editor reviews the
content, updates it as needed, and submits it into the regular workflow.

l

Review the content and submit it for publishing. This action completes the
preapproval process and submits the content into the regular workflow.

NOTE: The user submitting the content does not need permission to create tasks.
Also, the user assigned to the task should not change its state using the task
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system. Instead, the user should review and approve content using the content
approval mechanism. That mechanism automatically changes the task’s state.

The new task has the following default information.
l

Title. A string formulated by joining the content title, content ID number,
underscore (_), and Task. For example, Private Content2_Task.

l

Assigned to. The preapproval group

l

Assigned by. The user who submitted the content

l

Content. The content submitted for approval

l

Priority. Normal

l

State. Not Started

l

Due date. none

l

Start date. none

l

Created by. User who submitted content

l

Description. none

The following list shows the sequence of changes to content and its associated task. All
changes are logged in the task’s history. Also, email is automatically generated for
automatic tasks as it is for manually-created tasks.
Task/content statuses (author cannot approve)
l

Content is created and checked in
o Content status: Checked In
o

l

Task state: No auto task assigned

Content is submitted for approval
NOTE: This action creates an automatic task for the content.
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l

o

Content status: Waiting for completion of associated tasks

o

Task state: Not Started

Content is assigned by a preapproval group member to an editor
l Content status: Waiting for completion of associated tasks
l

l

Editor updates content then checks it in
o Content status: Checked In
o

l

Task state: Not Started

Task state: Active

Content is submitted for approval; it enters any workflow set for the folder or
content
NOTE: Because the task requires an approval, it appears in the task list of the
current approver. When the content is approved, the task is moved to the next
approver’s task list.

l

o

Content status: Submitted for Approval

o

Task state: Pending

Approver denies request
o Content status: Checked In
o

l

Task state: Reopened

Approver approves content
o Content status: Approved
o

Task state: Complete

Task/content statuses (author can approve)
l

Content is created then checked in
o Content status: Checked In
o

l

Content is edited then checked in
o Content status: Checked In
o

l

Task state: No auto task assigned

Task state: Active

Content is submitted for approval
NOTE: Although an author can approve content, the author must click publish
twice: once to change content status to Awaiting Completion of Associated
Task, and a second time to change it to Approved.

l

o

Content status: Pending

o

Task state: Not Started

Content is published
o Content status: Approved
o

Task state: Completed
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Enabling task preapprovals
To set up an automatic preapproval group:
1. Go to Workarea > Settings > Configuration > Setup > Application Setup
> Workarea tab > Enable Preapproval Group and check the box.

2. Assign user groups to folders whose content must complete the preapproval
process before it enters the regular workflow.
PREREQUISITE

You can choose (or update) a preapproval group only if these criteria are both true.
l

The Enable Preapproval Group field is enabled (see Step 1 above)

l

You are an administrator or a user that has the Modify Preapproval
permission enabled on the Advanced tab of a folder's View Permissions screen.
To view permissions, click a folder, then choose View > Properties >
Advanced > View Permissions ( ).

a. Go to the folder's properties screen and click Modify PreapprovalGroup (
) to access the PreApproval Group field. The Edit Properties screen appears.
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b. Check the Inherit parent configuration box if you want this folder to inherit
the preapproval group from its parent folder. If you choose a user group, an
automatic task is assigned to that group whenever content in that folder is
created or updated.
NOTE: The Preapproval Groups Report lists all preapproval groups assigned to
Ektron folders. To access it, go to Workarea > Reports > Contents >
Preapproval Groups.
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PREREQUISITE

Only members of the Administrators user group and those defined in the
Manage Members for Role: Add Role Member Business Rule Editor screen
can work with Business Rules. See also: Defining roles on page 1581
Business Rules let you define conditions for Web pages on your site. You choose an
action based on whether the conditions are true or false when a site visitor browses
your site. For example:
l

Condition. A site visitor visits your site for the first time.

l

Action. Add a cookie to the site visitor’s computer and display a welcome
message.

With Business Rules, you do not write code to set conditions and initiate actions. You
simply complete the Business Rules wizard, have your developer add a Business Rules
server control to your Web form, and assign a Business Ruleset to the server control.
See also: Creating personalized Web experiences with personas on page 1137 and the
BusinessRules server control.
The following list shows several conditions and actions that are already defined for you.
Conditions
l

Cookie Parameter = value

l

Form Parameter = value

l

QueryString Parameter = value

l

Server Variable = value

l

Custom Parameter = value

Actions
l

Display a calendar

l

Display a message

l

Open a URL in a new window

l

Pop up a message

l

Redirect to a new URL

l

Set a cookie value

l

Display content

After you create a rule, you can add it to multiple rulesets. This is useful if several
rulesets use a common rule.

Creating a business ruleset
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears..
2. Click Add New Ruleset. The Add New Ruleset screen appears.
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3. In the Name text box, add a unique, descriptive name for the ruleset.
4. Click Save Ruleset. The View Ruleset screen appears.
You can now add a rule (as described in Adding a rule to a ruleset on the next page) or
click Back ( ) and return to add a rule later.
After creating a ruleset, you typically add rules to it via the View Ruleset screen. This
screen is the launch pad for working with existing rulesets or creating new rulesets.

Editing a business ruleset
You can edit a ruleset from 2 locations: the Web page or the Workarea. To edit a ruleset
from the Web page, go to a Business Rule on a Web page while logged in. Then, right
click the Business Rule icon and click Edit.

To edit from the Workarea:
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears.
2. Click the ruleset name.
3. Click Action > Edit Ruleset. The Edit Ruleset screen appears.
4. From this screen, you can make a rule inactive, remove a rule from the ruleset
(Removing a rule from a ruleset on page 1480), or change the order in which rules
are applied (Changing the order of rules in the ruleset on page 1479).

Deleting a business ruleset
When you delete a Business Ruleset, the ruleset is removed from the system
permanently. However, the rules in a Ruleset are not deleted because they may be
used in other Rulesets.
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears.
2. Click the ruleset name.
3. Click Action > Delete Ruleset. A dialog asks you to confirm the deletion.
4. Click OK.
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Adding a rule to a ruleset
1. Go to Settings > Business Rules. The Business Rulesets screen appears.
2. Click the Business Ruleset for which you want to create a new rule.
3. Click New > Add New. The Rules Wizard launches and helps you define a rule.

4. Wizard Step 1 prompts you to create conditions for the rule and decide whether a
site visitor needs to match Any or All conditions. Click the param and value links to
open a dialog to enter information.
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5. Place a check next to any condition you want to use. Use the following list to help
you complete the param and value fields.
l Cookie param equals value. Use a cookie for this condition.
o param. enter Name in this field.
o

value. enter the name of the cookie in this field.

Does the site visitor's system have an Ektron cookie?
Usage: Cookie param “Name” equals value “Ektron”
l

Custom param equals value. Use custom parameters from the user. User
parameters are defined in the code-behind of a Web page.
o param. enter the name of a custom parameter. For example, AcctBlnc
o

value. the value associated with the parameter. For example, 1000

Is the user's account balance $1000?
Usage: Custom param “AcctBlnc” equals value “1000”
l

Form param equals value. Use a form elements field name and match the
value entered into the element.
o param. enter a form’s element Field Name from a form.
o

value. enter the value you want the form element to match.

A form has a Choices Field element with the Field Name “Favorite_Food” and
choices of Pizza, Steak and Chicken. When a site visitor chooses Pizza and
clicks submit, your rule launches a Pizza company’s website.
Usage: Form param “Favorite_Food” equals value “Pizza”
l

QueryString param equals value. Use the QueryString for this condition
o param. the name of the QueryString. For example, ID.
o

value. the value associated with the parameter. For example, 18.

Is content with the ID of 18 being displayed?
Usage: QueryString param “ID” equals value “18”
l

Server Variable param equals value. Use server variables from the site visitor.
o param. enter the name of a server variable. For example, HTTPS.
o

value. the value associated with the parameter. For example, On.

Is the site visitor’s browser using SSL?
Usage: Server Variable param “HTTPS” equals value “On”
6. Click Next. Wizard Step 2 prompts you select an action to take if conditions are
true. Check the boxes for the actions to take. Click the blue links to add the
appropriate information.
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l

Display Calendar ID. Enter an Ektron Calendar ID.

l

Display a Message. Enter a message to be displayed.

l

Open URL. Enter a URL. This opens a new window with the URL.

l

Popup A Message. Enter a message that appears in a popup dialog box.

l

Redirect to a URL. Enter a URL to redirect a the site visitor’s browser.

l

Set Cookie to Value. Creates a cookie on the site visitor’s system. Enter
Name for Cookie and the name of the cookie for Value.

l

Display Content Block ID. Enter an Ektron content block’s ID.

7. Click Next. Wizard Step 3 lets you select actions to take when conditions are false.
This works the same as Wizard Step 2.
8. Click Next. Step 4 of the Wizard asks you to enter a name for the rule in the text
box.
9. Click Done. The View Ruleset screen appears. Your rule appears in the Ruleset
box.
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Editing a rule in a ruleset
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears.
2. Click on the Ruleset that contains the rule to be changed. The View Ruleset screen
appears.
3. Click on the name of the rule to be changed. The rule is highlighted.
4. Choose Action > Edit Rule. The Rules Wizard appears with the rule loaded.
5. Edit as necessary. The Rules Wizard is explained in Adding a rule to a ruleset on
page 1476.

Changing the order of rules in the ruleset
The order of rules in a Ruleset affects their application when a site visitor views a page.
For example, you want to display a welcome message before a content item. To
accomplish this, move the rule for the welcome message above the rule for a content
item.
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears.
2. Click on the Ruleset that contains the rules you want to re-order.
3. Choose Action > Edit Ruleset. The Edit Ruleset screen appears.
4. Highlight the rule you want to reorder.
5. Click the up and down arrow buttons to move the rule within the list.
6. Click Save Ruleset.
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Adding existing rules to another ruleset
You can add a rule to multiple Rulesets. To do so:
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears.
2. Click on the Ruleset to which you want to add existing rules.
3. Choose New > Add Existing. The Add an Existing Ruleset screen appears
displaying the rules from other Rulesets.
4. Check one or more rules and click Save Ruleset. The rules are added to the
current Ruleset.

Removing a rule from a ruleset
1. Go to Workarea > Settings > Business Rules. The Business Rulesets screen
appears.
2. Click on the Ruleset that contains the rule you want to remove.
3. Choose Action > Edit Ruleset. The Edit Ruleset screen appears.
4. Click on the rule you want to remove, highlighting the rule.
5. Click Remove Rule (
this ruleset only.

). A window indicates that the rule will be removed from

6. Click OK. The rule is removed from the Edit Ruleset screen.
7. Click Save Ruleset.
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PREREQUISITE

Only members of the Administrator group or users assigned to the Folder
User Admin rolecan work with Web Alerts.
You can set up automatic email notification for site visitors who register (or subscribe)
to updates about new or changed information. When new or existing content is
published, the subscriber receives an email with a link to the new or updated page.
A Web Alert is generated and sent to a subscriber in the following way.
1. Content is published.
2. Ektron checks the Staging Server checkbox on the Settings > Configuration >
Setup screen.
l If it is unchecked, proceed to the next step.
l

If the box is checked, no Web Alerts are issued for this server.

3. Ektron checks to see if any subscriptions are assigned to folders or content.
l If no subscriptions are assigned, the Web Alerts tab does not appear when
editing content.
l

If a subscription is assigned, Ektron checks to see if an email should be created
for the content. (The settings appear under the Web Alerts tab. For example,
some content only triggers email when first published, while other content
always generates email.)

4. If an email should be generated, Ektron retrieves its information from the Folder
Properties screen > Web Alerts tab > Web Alert Contents fields.
5. Ektron determines which subscription lists should receive the email. These are
identified on the Available Web Alerts area of the Web Alerts tab. The lists
contain subscribers' email addresses.

6. The email is sent.
This chapter explains how to set up the Web Alert feature.
1. Set up message queue and asynchronous processor.
2. Create messages—Define components of the email to be sent to subscribers.
3. Create subscriptions—Categories of information on your site. Site visitors can
subscribe to be notified when content in a category is added or updated.
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4. Assign Web Alert information to folders and content—For each folder or content
item to which you assign subscriptions, determine
l activities that trigger emails (for example, initial publishing of content)
l

the email content

l

subscription lists to which the email is sent

5. Create and publish site visitor registration page—Create a new Web form and place
the Membership server control onto it. Then, publish that form on your website.
NOTE: This task is typically done by a developer.
6. Site visitors subscribe to lists of interest—Someone signs up to be notified when
changes in a selected subscription (category) are published. (Ektron CMS users
can also subscribe.)
Subscribers are notified when content is first published or updated. If at least one
subscription is assigned to the content or its folder, email is sent according the
folder's Web Alert settings.

Setting up message queuing and the
asynchronous processor
When Ektron is installed, the following directories and files are placed on your server to
set up Microsoft Message Queuing and the Ektron Asynchronous Processor.
l

C:\Program Files
(x86)\Ektron\CMS400versionnumber\EktronAsyncProcessor_Service\

l

C:\inetpub\wwwroot\siteroot\bin\EktronAsyncProcessorWS.dll

l

C:\inetpub\wwwroot\
siteroot\Workarea\webservices\EktronAsyncProcessorWS.asmx

NOTE: If you need to move Web services file, use the Asynchronous Processor
Location field in the Configuration > Setup screen to specify the new folder
location.
The following image and list shows a typical Web Alerts server configuration.
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l

Firewall. the Ektron business tier (which maintains the Ektron files) must have
Web access to the asynchronous server. This configuration enables proper
communication between Ektron and the asynchronous processor.
o The asynchronous processor must have port 25 (SMTP) access to a valid mail
server to send emails
o

l

The mail server (omitted from the illustration) must be allowed to send out
port 25 (SMTP) traffic and can reside on the asynchronous server

Queuing. Message queuing must be enabled on the asynchronous server.
You must create a message queue on the asynchronous machine and record its
name. The message queue is specified in the exe.config file for the service, and in
the web.config file for the Web services interface.

l

CMS. The web.config file includes a key for the location of the asynchronous
processor. This needs to be verified as working.

l

Other. IIS must be installed on the asynchronous processor. IIS allows a Web
service call to schedule a file download and send commands.
o The asynchronous machine should only allow HTTP traffic from Ektron servers.
This provides additional security on the asynchronous processor.

To set up message queuing services and the asynchronous processor:
1. On the server that hosts Ektron,
l If you are using Windows 7 or 2008 R2, go to Control Panel > Add/Remove
programs > Add/Remove Windows Components.
NOTE: This procedure uses Microsoft Window 2008 R2. In some Windows
versions, go to Control Panel > Programs and Features > Turn
Windows features on or off then select Microsoft Message Queue
(MSMQ) Server.
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l

If you are using Windows 8 or 2012, press the Windows key ( )/Q then
enter windows features and choose Turn Windows features on or off.

2. If it is not checked, check Message Queuing Services or Microsoft Message
Queue Server.
Windows 2008 R2

Windows 8 or 2012

3. If Message Queue was checked when you viewed it, go to step 5. If it was not
checked, click OK. A wizard creates the component.
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The rest of this procedure employs a wizard that saves several manual steps. If you
have a problem using the wizard, or prefer to install Web Alerts manually so you
can track the files being installed to your server, see Manually setting up the
message queue and asynchronous processor on the facing page.
4. If you're using Windows 7 or 2008 R2, from the Windows Start menu, click All
Programs > Ektron > CMS400vxx > Utilities > Web Alert Setup.
If you're using Windows 8 or 2012, press the Windows key (
Web Alert Setup.

)/Q then enter

5. The Web Alert Wizard setup screen appears. Complete the following screen.

l

Message Queue Name. Enter the name of the message queue that will
manage the Web Alert email.

l

SMTP Port. Enter the port number that sends Web Alert email.

l

SMTP Server. Enter the name of the server that hosts your Ektron website.

l

SMTP User and Password. Username and password used to send and
receive email.

l

Logfile Verbose. Click if you want a detailed log file.

6. If your Asynchronous Processor service is not running, the following message
appears. If you see this message, click OK then click Finish.
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7. If you're using Windows 7 or 2008 R2, go to Windows Start menu > Run > enter
services.msc. If you're using Windows 8 or 2012, press the Windows key (
)/Q then enter Services.
8. Start the Ektron Async Processor service.
9. When specifying the SMTP port in Step 5, if you entered a port number other than
25
a. Open C:\Program Files
(x86)\Ektron\CMS400vxx\EktronAsyncProcessor_
Service\Ektron.Services.EktronAsyncProcessor.exe.config.
b. Change the value of ek_SMTP_EnableSsL to False.

Manually setting up the message queue and
asynchronous processor
Use this procedure if you had a problem using the wizard, or if you want to know which
files are being installed on your server.
1. Go to Control Panel > Administrative Tools > Computer Management >
Services and Applications > Message Queuing.
NOTE: In some Windows versions, you access this screen by clicking Start >
Computer > Manage. Also, you may need to enable Message Queuing using
the Control Panel > Programs and Features > Turn Windows Features
On or Off option.
If you're using Windows 8 or 2012, press the Windows key (
choose Computer Management.

)/X then

2. Click Services and Applications > Message Queuing > Private Queues
folder and select New > Private Queue.
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3. Create a private queue named msmq_web.
4. Right click msmq_web and select Properties.
5. Go to the Security tab. You can give the Everyone group Full Control if you are in a
testing environment. If you are on a production server or want better security,
delete the following permissions for the local system account (the account under
which the EktronAsyncProcessor Service runs):
l Receive Message
l

Peek Message

l

Send Message

6. Give the ASP.NET account (the account under which the Web services interface
runs) Send Message permission.
7. Click OK.
8. Open the following file: C:\Program Files
(x86)\Ektron\CMS400vxx\EktronAsyncProcessor_
Service\RegEktron.Services.EktronAsyncProcessor.bat
9. Review and update as necessary the paths to the .NET directory and
Ektron.Services.EktronAsyncProcessor.exe file.
10. Update the paths to the .NET Directory and the .exe file if necessary.
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11. Execute the .bat file. Or, from a command line or Start Menu > Run, enter
C:\Program Files (x86)\Ektron\CMS400vxx\EktronAsyncProcessor_
Service\Ektron.Services.EktronAsyncProcessor.exe
NOTE: If you see an error Exception occurred while initializing the
installation, see Problem running
RegEktron.Services.EktronAsyncProcessor.bat in 9.10.
12. Open the following file and enter your SMTP connection settings: C:\Program
Files (x86)\Ektron\CMS400vxx\EktronAsyncProcessor_
Service\Ektron.Services.EktronAsyncProcessor.exe.config.
13. Go to Windows Start menu > Run > enter services.msc. If you're using Windows
8 or 2012, press the Windows key (

)/Q then enter view local services.

14. Start the Ektron Async Processor Service.

Verifying connections
l

l

To verify the Web services-to-queue connection:
o Leave the Ektron asynchronous processor service off, submitting content with
notifications, and verifying that a message arrived in the queue.
o

Turn on journaling for the queue. Submit a message in the queue. The Ektron
asynchronous processor service picks it up and places it in the journaled
messages.

o

Turn on logging for the Ektron asynchronous processor service.

To verify the Ektron-to-Web service connection:
o Open the asynchronous processor location inside a Web browser and test the
Web services.
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l

To verify the writing of files:
o Ensure that Ektron has write access to the [sitepath]subscriptions
directory and submit content that will trigger notifications. This action places a
file inside that directory.

l

To verify that the Ektron asynchronous processor service can download a file:
o Open a Web browser on the asynchronous machine and connect to the location
of the notification command files. Attempt to download one.

Creating a Web Alert email message
A Web Alert email is made up of the following components, defined on the Folder
properties Web Alerts tab. To use the Web Alert feature, you must define
l

default message text

l

1 Opt-Out text

l

1 unsubscribe message

l

1 “from” address

NOTE: If you reached this screen while creating an eCommerce message, see
Sending eCommerce messages on page 1861.

Web Alert components
A Web Alert email may include these components.
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NOTE: To set or modify this information, you must have permission to edit the
folder.
l

From address (required). See Creating the “From” addresses below

l

Recipient (required). Users who signed up for subscriptions that are enabled for
the folder. See also: Setting up a subscription on page 1502

l

Subject line. The Subject field on the Web Alerts tab of the Folder Properties
screen.
See Assigning a Web Alert to a folder or content on page 1496

l

Default message. See Creating the default message text below.

l

Opt out message (required). See Creating the opt-out text on the next page

l

Content summary. The summary of the content whose creation or change
generates the email.
NOTE: The Summary can include variables that retrieve information about the
content. See Including variables in the message on the next page.

l

Content link. Link to content whose creation or change generates the email.

l

Any CMS content item. You may include Ektron content in the email.

l

Unsubscribe message (required). See Creating the unsubscribe message text on
page 1493.

Creating the “From” addresses
Web Alert emails must have a “from” address. Each folder has a set of properties,
including a "from" email address. So for example, you want one "from" email address
for marketing content, and another "from" email address for technical content.
1. Go to Settings > Configuration > Web Alerts > Email From List.
2. Click New > Email From.
3. Enter an email address to be used in the "From" field of Web Alert messages.
4. Click Save.

Creating the default message text
1. From the Workarea, choose Settings > Configuration > Web Alerts >
Messages.
2. Click Add Email Message.
3. Enter a Title that describes the message.
4. At the Type field, select DefaultMessage.
5. In the editor, enter the message text. The message text can include variables.
6. Click Save.
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Including variables in the message
A Web Alert email can include variables that retrieve content information into the
message text. The variables are surrounded by at signs (@). For example
The following content was recently updated: @AppContentLink@

The email text might read:
The following content was recently updated: The Effect of Coumadin on
Cardiac Patients
Use the following variables in a Web Alert message.
l

@appContentTitle@. The title of the content block.

l

@appCRLF@. A carriage return. Moves text down one line.

l

@appContentLink@. The link to the content block on the website.
NOTE: You must be logged in to see the changes.

l

@appContentURL@. The URL of the content, from the quicklink and domain.

l

@appSubscriptionNames@. Comma separated list of subscriptions that a user
selected.

l

@appComment@. The comments for the content block.

l

@appSubmitterFirstName@. The first name of the user who submitted the
content block.

l

@appSubmitterLastName@. The last name of the user who submitted the
content block.

Creating the opt-out text
Opt-Out text appears as the first line of every email. It directs the reader to the
Unsubscribe message at the bottom. Here is an example:
You have subscribed to receive alerts from the Ektron email alert system.
See below for removal instructions.

The Opt-Out text may include variables. See also: Including variables in the message
above
1. Go to Settings > Configuration > Web Alerts > Messages.
2. Click Add Email Message.
3. Enter a Title that describes the Opt-Out text.
4. At the Type field, select OptOut.
5. In the editor, enter the message text. The text may include variables. See also:
Including variables in the message above
6. Click Save.
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Creating the unsubscribe message text
An Unsubscribe message lets an email recipient remove himself or herself from the
subscription list. You can include variables in the Unsubscribe text. See also: Including
variables in the message on the previous page
1. Go to Settings > Configuration > Web Alerts > Messages.
2. Click Add Email Message
3. Enter a title that describes the Unsubscribe message.
4. At the Type field, select OptOut.
5. In the editor, enter the message text. The text may include variables. See
also: Including variables in the message on the previous page
6. Click Save.

Creating a subscription
Create a subscription for each type of information about which site visitors might want
to be notified. For example, if your site sells electronics, create one subscription for
televisions, another for computers, and a third for smart phones. Site visitors then
subscribe to areas of interest. Ektron and membership users can also sign up for
subscriptions.
1. Go to Settings > Configuration > Web Alerts > Subscriptions.
2. Click Add Subscription.
3. Enter a name for the subscription.
4. Check the Enabled box if the subscription is active.
5. Click Save.
When you create and enable a subscription, a new entry appears on the User Properties
screen's Custom tab. By default, its name is Subscriptions, and its type is Category.
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Subscriptions appear on the
l

Site Visitor Registration screen

l

Membership user information screen > Custom tab

l

User information screen > Custom tab

l

User group information screen > Custom tab

The following graphic illustrates the relationship among Subscriptions, Custom
Properties, and the Site Visitor Registration screen's Custom tab.
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Changing the subscriptions label
By default, the label Subscriptions appears on the screen. To change it to something
more helpful, such as Select Areas of Interest:
1. In the Workarea, go to Settings > Configuration > Custom Properties.
2. In the Object Type field, select User.
3. Click Subscriptions.
4. Edit the Label field.

Editing a subscription for a multi-language system
When you create a subscription, a version is created for every enabled language. You
can edit the subscription name and Enabled value for any language, but cannot change
Ektron Reference

1495

Sending Web Alert emails to subscribers

the ID number.

1. Choose Settings > Configuration > Web Alerts > Subscriptions.
2. From the View Languages drop-down list, select the language into which you want
to translate the subscription.
3. Click the subscription that you want to translate.
4. Click Edit.
5. In the Name field, enter the translation for the subscription name. If desired, you
can check or uncheck the Enabled checkbox. Only enabled subscriptions appear.
6. Click Update.

Assigning a Web Alert to a folder or content
After creating messagesand subscriptions, identify folders whose content should trigger
a Web Alert when it is updated. For example, new product announcements in the
Marketing folder should trigger a Web Alert.
Like other Ektron folder-level information, Web Alert settings are inherited from a
parent folder. However, you can break inheritance and customize these settings for any
folder or content item.
You can assign the following Web Alert information to a folder:
l

whether Web Alert information is inherited from a parent folder or customized

l

when email is sent: always, on initial publication only, or never

l

the content of the email

l

the folder's subscriptions, which determine the email recipients.

IMPORTANT: Web Alert emails are not generated for files that are dragged and
dropped into Ektron and immediately published. To generate email for these files,
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you must manually publish them. Also, the files must reside in a folder for which the
Web Alert feature is enabled.
PREREQUISITE
l

You defined Opt-Out text, an unsubscribe message, and a “from”
address that is appropriate for content in this folder. See also: Creating
a Web Alert email message on page 1490

l

You created at least one subscription.

l

You have edit permissions for the folder. See also: Managing folder and
content permissions on page 168

Assigning a Web Alert to a folder
To modify folder-level Web Alert information:
1. Go to the folder whose Web Alert information you want to edit and click View >
Properties.
2. Click the Web Alerts tab.
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l

Inherit parent configuration. To have this folder inherit Web Alert settings
from its parent folder, leave this box checked. To customize this folder's Web
Alert settings, uncheck this box.

l

Restore Web Alert inheritance to the content in this folder. Check this
box if Web Alert inheritance has been broken for some content in the folder,
and you want to restore inheritance. If you do, all folder content uses this
folder's Web Alert properties.

l

Options. Check when Web Alert emails are sent.
o Notify Always. when content in this folder is first published or updated
o

Notify Only on Initial Publication. only when content in this folder is
first published.

o

Notify Never. never sent for this folder's content.

l

Web Alert Subject. Enter the email's subject line.

l

Web Alert email From Address. Select the address from which email for
this folder is sent. See Creating the “From” addresses on page 1491.

l

Web Alert Contents. Check the following components to determine the
email content.
o OptOut Message. see Creating the opt-out text on page 1492.
o

Use Default message. see Creating the default message text on
page 1491.

o

Use Summary. include the content summary in the email

o

Use Content. include Ektron content in the email.
NOTE: If the content item is an Office document or a managed file, a
link to the item appears, not the item itself.
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n

To select existing content, click Select next to the Use Content
checkbox. Then, go to the content item.

n

To select the content whose creation or change triggers the Web
Alert, click Use Current.

n

To create new content to be inserted into the Web Alert message for
this folder, click Select next to the Use Content checkbox. When the
folder navigation window appears, click Add Content. Then, see
Creating new content on page 684.

l

Unsubscribe message. See Creating the unsubscribe message text on
page 1493.

l

Available Web Alerts. All enabled subscriptions set up in the Subscriptions
screen appear. Check those to be notified when content in this folder is added
or updated. See also: Creating a subscription on page 1493
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IMPORTANT: If you uncheck all subscriptions, you disable the Web Alert
feature for this folder and all of its content, even if unique subscription
information is assigned to content within the folder.

Assigning a Web Alert to content
To set a Web Alert for a content item, break the inheritance from its folder. From then
on, the content’s Web Alert settings are independent of the folder’s settings.
IMPORTANT: If all subscriptions are unchecked for a folder, the Web Alert feature
is disabled for all content in the folder, even if unique Web Alert information is
assigned to content.
1. Go to the folder that contains the content.
2. Click the content. The View Content screen appears.
3. Click Edit.
4. Click the Web Alerts tab. The Web Alert settings for the content appear.
NOTE: The Web Alerts tab only appears if required messages, “from” email
addresses, and at least one subscription are assigned to the content’s folder.
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l

Options. Check when Web Alert emails are sent as this content is published.
o Notify Always. when this content is first published or updated
o

Suspend Next Notification (override). check this box to suspend the
next email to be sent for this content. You might use this feature if you
noticed an error in the content and don’t want to notify subscribers that
the page was updated.
NOTE: This setting only applies until the next time this content is
published. When that happens, this box is automatically unchecked.
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o

Notify only on Initial Publication. only when this content is first
published

o

Send Next Notification (override). send email to all subscribers the
next time this content is published. Use this checkbox to send a one-time
mailing to all subscribers about content that was already published.
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NOTE: This setting only applies until the next time this content is
published. When that happens, this box is automatically unchecked.
o

Notify Never. never send email for this content.

l

Subject. Enter the email's subject line.

l

email From. Select the address from which email for this folder is sent. See
Creating the “From” addresses on page 1491.

l

Web Alert Contents. Check the following components to determine the
email content.
o OptOut Message. see Creating the opt-out text on page 1492.
o

Use Default message. see Creating the default message text on
page 1491.

o

Use Summary. include the content summary in the email.

o

Use Content. include Ektron content in the email.
NOTE: If the content item is an Office document or a managed file, a
link to the item appears, not the item itself.
n

To select existing content, click Select next to the Use Content
checkbox. Then, go to the content item.

n

To select the content whose creation or change triggers the Web
Alert, click Use Current.

n

To create new content to be inserted into the Web Alert message for
this folder, click Select next to the Use Content checkbox. When
the folder navigation window appears, click Add Content. Then, see
Creating new content on page 684.

l

Unsubscribe message. See Creating the unsubscribe message text on
page 1493.

l

Available Alerts. All enabled subscriptions set up in the Subscriptions screen
appear. Check those to be notified when this content is added or updated. See
also: Creating a subscription on page 1493

Restoring folder-level Web Alert settings to content
If you customize Web Alert settings for content and later decide to standardize the
settings for all content in a folder, check the Restore Web Alert Inheritance box on
the folder properties Web Alerts tab. This action copies the folder's Web Alert settings
to every content item in the folder, replacing any content-level settings.

Previewing the email message
To preview the Web Alert email message, click Preview on a folder's Web Alerts tab.
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Setting up a subscription
After you set up a Web Alert, create a Web page that lets site visitors subscribe to areas
of interest.

To place this form on a Web page, your developer inserts a Membership server control.
Any user who subscribes via the sample screen becomes an Ektron membership user,
and is automatically added to the All Members user group. See also: Membership users
and groups on page 1625
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NOTE: The email address collected on the screen is used as the membership
Username field.
What happens next depends on the Enable Verify email check box in the Application
Setup screen (shown in the following image).

l

If the Enable Verify email checkbox is not checked, a person that signs up
automatically becomes a membership user.

l

If the Enable Verify email checkbox is checked, a person that signs up is placed
on the Users Not Verified list and receive an email with content that is defined in
Workarea > Settings > Community Management > Messages.
The email should direct the unverified user to a Web page that asks for
confirmation of the person's interest in the subscription. (This step prevents people
from being subscribed without their permission.) To create this page, your Web
developer creates or updates a Web Form using the Membership server control.
Set the control’s DisplayMode property to AccountActivate.
New users are activated when the subscriber confirms interest.

NOTE: Users can also be manually activated or removed via the View Not Verified
Users screen. For more information, see Verifying a new subscriber below.
IMPORTANT: When using the Checkout server control on an eCommerce site, the
Enable Verify Email setting must be unchecked. Otherwise, new users will receive
an error message when they sign-up using this control. See also:

Verifying a new subscriber
A person that signs up for a subscription but has not yet been verified appears on the
View Not Verified Users screen at Workarea > Settings > Community
Management > Memberships > Users not Verified. You can activate accounts by
selecting users then clicking ActivateUsers. Alternatively, you can delete members by
selecting and clicking Delete (

).

NOTE: The ek_PageSize setting in the web.config file determines the maximum
number of users that can appear on a page before adding another page with the
following navigational links:
Page 1 of 2 [First Page] [Previous Page] [Next Page] [Last Page]
To select all members, click the check box next to Username.
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You can also change the way membership users are sorted, or use the Search button to
find users that match your criteria (for example, users whose username includes
example.com.)

Customizing the verification message
By default, Ektron supplies a generic message that asks the subscriber to confirm the
password and directs the person to your website's activateuser.aspx page. To
customize that message:
1. Go to Workarea > Settings > Community Management > Messages.
2. Click Add Email Message.
3. Assign a title to the message, such as Verification Message.
4. In the Type drop-down, select Verification.
5. Click the check mark in the Default box.
6. In the Subject field, enter a subject line for the message.
7. Enter the message. You must insert the @appQueryLink@ variable in the message
to create a link to the confirmation page. For example:
Welcome to example.com. You registered to be notified of updates
to our site. Before we can do this, you need to activate your
account. To do so, please visit @appQueryLink@.

The @appQueryLink@ variable gets resolved as follows (one line):
http://sitepath/workarea
/activateuser.aspx?uid=[username]&acc=[accountID]

For example (one line):
http://www.example.com/Workarea
/activateuser.aspx?uid=john.edit@example.com&acc=ce5w84o936477

You can insert the following membership variables into the confirmation message.
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l

@appEmail@. email address

l

@appActivateId@. Account ID

l

@appUserName@. UserName

l

@appFirstName@. First name

l

@appLastName@. Last name

l

@appDisplayName@. Display name

l

@appAvatar@. Avatar

l

@appSignature@. Signature

Setting up other subscriber actions
You can set up other Web pages that let subscribers perform these actions:
l

Activate their account

l

Reset their password

l

Unsubscribe

To create these pages, place a Membership server control on the page. Then use its
DisplayMode property to determine the kind of screen you want to place. For
example, to create a screen that lets the user reset a password, set the control’s
DisplayMode property to ResetPassword. See also: Membership server control

Subscribing a CMS user
Ektron users can subscribe to any subscription list. This is particularly useful on an
intranet where, for example, employees are notified when job-related information is
updated.
Another example is your internet site. The Marketing manager can sign up to be notified
whenever Marketing content is added or updated. To do so, go to Settings > Users >
Edit User > Custom tab.
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See also: Using eSync with Web Alerts on page 2030
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Ektron enables authoring, organizing, publishing, and versioning of Web content—in
multiple languages. Ektron has a fully-developed, Web content localization solution that
combines Web content management with localization/translation management, and
supports creating content in any language supported by the Unicode standard. Ektron
provides multi-language support for the following areas:
l

Content. Sseen by content contributors; visitors to your site.

l

Spell check dictionary. Seen by visitors to your site.

l

Special Character Encoding. Seen by visitors to your site.

l

Workarea screen labels, alt text, system messages. Seen by content contributors.

Multi-language editions of the same content have the same ID number but are
differentiated by a language attribute. As a result, a Web page template can link to a
content item, but what appears is determined by the selected language. There are 2
ways that content’s language can be selected:
l

a language cookie, which is created when a visitor browses to your site and selects
a language

l

the link to another page includes the language (langType) parameter. For
example, mytemplate.aspx?LangType=1033. For a list of the decimal values for
each supported language, see Ektron Workarea > Settings > Localization >
Languages and Regions.

Developers can use the following server controls for multi-language content:
l

LanguageAPI. To specify a language for a site.

l

LanguageSelect. To display a drop-down list of available languages.

The following Ektron components are affected by multi-language support:
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l

Workflow. You can set up a language-specific workflow. For more information,
see Approving content for publication on page 749.

l

Metadata. Can be set up as part of the xliff export/import process, so that its is
translated along with text in the content, summary and so on. See Creating multilanguage metadata on page 1514.

l

Calendars. You can create calendars in any supported language. If you enter
calendar event information in the non-default language, the day and month names
automatically appear in that language. Also, regional conventions for first/last days
of the week, and date and time formats are maintained. See Working with
calendars on page 991.

l

Collections. You can create a language-specific instance of each collection. See
Working with a collection in a multi-language system on page 817.

l

Menus. You can create an instance of any menu in every supported language so
that site visitors can see a menu displayed in the user-selected language. (If a
menu in the selected language is not available, nothing appears.) See Creating a
menu in another language on page 1353.
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l

Tasks. If you create content then add a task to it, the task can be in any enabled
language. This is helpful if you review English content then want to assign the task
of translating it into another language in that language. When assign content to a
task, you can only choose from content in the language of the task. See Assigning
and managing tasks on page 1449.

l

Taxonomies. Multi-language support affects the way you create, maintain, and
manage taxonomies. See Working with taxonomies in a multi-language
environment on page 1396.

Setting Up a multi-lingual website
The following steps provide an overview for setting up a multi-lingual website.
1. Enable multi-lingual support in web.config.
See Enabling/disabling support for multiple language content on the next page
2. Enable languages that your site will support.
See Determining which languages are available on the next page
3. Set a default content language, one that will be used by the majority of your site’s
content. If you had a previous version of Ektron and selected a default language on
the Database Upgrade Utility, be sure that default language matches the one in
web.config.
4. Add language selection function to templates so that your site can be viewed in
another language.
See Viewing your site in another language on page 1513
5. Create multi-language content.
See Creating multi-language content on page 1521 and Translating content into
another language on page 698
6. Modify page content based on language selection.
See Modifying page content based on language selection on page 1523
7. Modify an image based on language selection.
See Modifying images based on language selection on page 1523
8. Create a metadata definition for each supported language.
See Creating multi-language metadata on page 1514.
9. Set up workflow for new content.
See Approving content for publication on page 749
10. Set up multi-lingual collections.
See Working with a collection in a multi-language system on page 817
11. Set up multi-lingual menus.
See Creating a menu in another language on page 1353
12. Set up multi-lingual taxonomies.
See Working with taxonomies in a multi-language environment on page 1396
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Enabling/disabling support for multiple language
content
1. Open siteroot\web.config.
2. Set the value of ek_EnableMultilingual to 1.
NOTE: To disable, set the value to zero (0).
3. Save web.config.

Determining which languages are available
PREREQUISITE

Only members of the Administrator Group or those assigned to the XLIFFAdmin role can view, add, or edit language settings. See also: Using the
roles screens on page 1582.
A locale consists of a language and a region. For example, English (United States)
describes the variation of English used in the United States, as opposed to English
(English U.K.) used in the United Kingdom.
Each locale's identifier consists of a language code and region code.
l

fr-FR = Language:French + Region:France

l

pt-BR = Language:Portuguese + Region:Brazil

l

es_419-AR = Language:Latin American Spanish + Region Argentina

You can create a new locale, if needed.
To determine which locales are available for creating content:
1. Go to Workarea > Settings > Localization > Languages and Regions. The
Edit Language Details screen lists locales in which you can create content on your
site.
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2. Click Enable. The Enable Languages and Regions screen appears.

3. Each language has 2 check boxes:
l To enable a language in the Workarea and let site visitors select it when
viewing the site, check the box in the check mark ( ) column.

NOTE: If you select
, the box in the
column is checked automatically.
This is because, if you let users view the language on the site, it must be
enabled in the Workarea.
The default content language on a drop-down list is determined in the ek_
DefaultContentLanguage element of the web.config file.
l

To enable a language in the Workarea only, check a box in the triangle ( )
column. The language populates the language drop-down lists in Ektron. So,
you can enable languages in the
column while you are translating the site
but are not ready to publish that content. When you complete the translation,
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check the

column.

If you enable only one language on the Enable Languages and Regions screen, fields
that prompt the user to select a language do not appear in Ektron. Instead, all content
is created in that language.

Disabling a language
To disable any language, uncheck its box in the
Regions screen.

column of the Enable Languages and

Before disabling the default language, you must assign a new one. If you disable a
language for which content exists, that content remains in the database but no one can
access it, either from within Ektron or when visiting your site, unless you later re-enable
that language.

Setting the default language
When you install Ektron, the default language is US-English (1033). The default
language determines which edition of content is displayed if a site visitor does not select
a language, or a visitor selects a language other than the default and goes to page for
which content does not exist in the selected language. In that case, Ektron looks for the
selected language's Fallback Locales. For more information, see Setting the fallback
locale on page 1529. If content is not available in any of its Fallback locales, Ektron
displays that content in the default language (if available).
IMPORTANT: You must enable a language before setting it as the default. See also:
Determining which languages are available on page 1510
To change the default language for your multi-language website:
1512
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1. Open yourwebsite\web.config.
2. Set the value of ek_DefaultContentLanguage to the locale id of the default
language. For example, 1031 for German. For a list of locale ids, see Ektron
Workarea > Settings > Localization > Languages and Regions.
3. Save web.config.

Viewing your site in another language
When a site visitor selects a language then goes to a page on your site, Ektron uses the
following criteria to determine which language edition of content to display.
1. Display content in the selected language, if available.
2. If that edition is not available, check the language's Fallback Locale. If it is set
and content is available in that language, display that. See also: Setting the
fallback locale on page 1529.
3. If content is not available in the Fallback Locale, display it in the default language.
See also: Setting the default language on the previous page.
4. If no editions are available, display nothing.
To let site visitors to view your site in any enabled language, your developer places a
LanguageSelect server control on any template. See also: LanguageSelect

You can also indicate a language-edition by adding a language parameter to a quicklink.
For example, products.aspx?LangType=1033 displays the English (US) edition of the
products.aspx content. This syntax automatically sets the language cookie.
NOTE: For a list of the decimal value of each supported language, see Ektron
Workarea > Settings > Localization > Languages and Regions.
Creating an external link to a page of foreign content
If another website links to a multi-lingual page on your site, the URL must include the
language ID parameter. For example:
www.ektron.com/web-content-management-solutions.aspx?LangType=1036
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Creating multi-language metadata
Part of managing a multi-language website involves creating and deploying multilanguage metadata. There are 2 scenarios for doing this.
l

Authors create content in the default language. Then, content is sent to a
translation agency, translated, and imported back to Ektron. As part of that effort,
text-based metadata is translated. To learn how to manage this multi-language
metadata, see Managing multi-language metadata below.

l

Authors create content is separate languages. For example, your site has French
content for French site visitors, and different Spanish content for Spanish site
visitors. To manage this multi-language metadata, see Creating metadata for
content in any language on page 1519.

Managing multi-language metadata
This section explains how to set up the xliff export/import process so that text-based
metadata is translated along with text in the content, summary, and so on. It is easiest
to set this up while creating a metadata definition. However, if you already have
metadata definitions in a source language and now want them translated along with
content, procedures for that type of setup are also provided.
PREREQUISITES
l

Target languages are enabled. See also: Determining which languages are
available on page 1510

l

Familiarity with creating metadata definitions. See also: Adding a metadata
definition on page 823

Creating multi-language metadata while creating a metadata
definition
To create multi-language metadata to be translated:
1. While creating a metadata definition in the source language, select all target
languages (the languages into which content will be translated) at the bottom of
the screen. See also: Adding a metadata definition on page 823
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2. Apply multi-language metadata to each folder that will contain content to be
translated.
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NOTE: You can assign metadata to a parent folder, and let its child folders
inherit the definitions.
To do that:
a. Go to the folder.
b. Click View > Language > target language.
c. Click View > Properties > Edit properties > Metadata tab.
d. Uncheck Inherit parent configuration (unless you want to inherit from the
parent folder).
e. Check the metadata definition you created in Step 1.
3. Create the content. To do that:
a. Go to the folder.
b. Click View > Language > source language.
c. Create the content. While doing this, fill out the metadata in the source
language.
4. Export the content for translation. An agency translates it. See Exporting content
to XLIFF on page 1533.
5. Import the translated content. The metadata is translated along with the content,
summary, and so on. See Importing translation files on page 1537.

Enabling multi-language metadata after a definition is
created
There are 2 ways to add support for multi-language metadata after a metadata
definition is created.

Creating a new metadata definition in the target language
To create a new metadata definition in the target language:
1. Create the new metadata definition. Be sure to choose the target language. When
you enter a name for the new definition, make sure it exactly matches the name of
the source language metadata definition.
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2. Make sure that all other fields on the screen (Type, Editable, and so on) match
the source language metadata definition.
3. Ignore the bottom of the screen (circled in the following image).
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4. Apply that metadata definition to each folder that will contain content to be
translated. To do that:
i. Go to the folder.
ii. Click View > Language > target language.
iii. Click View > Properties > Edit properties > Metadata tab.
iv. Uncheck Inherit parent configuration (unless you want to inherit from the
parent folder).
v. Check the metadata definition you created in Step 1.
5. From now on, if you export content for translation from that folder then import the
translated files, the metadata is translated along with the content, summary, and
so on. See Exporting content to XLIFF on page 1533, Importing translation files on
page 1537.

Mapping metadata values between source and target
languages
In this procedure, you use an .xml file to map metadata definitions in different
languages. It assumes that, for a metadata definition that exists in a source language,
you want to create a corresponding one in a target language. For example, consider
these metadata definitions.
ID

Name

Language

102

Paper form number

en-US

106

Número de papel de la forma

es-ES

IDs 102 and 106 contain the same information in different languages.
An XML file contains the mapping, which informs the XLIFF export/import process that
metadata ID 102 in English corresponds to 106 in Spanish.
PREREQUISITE

Locale codes for the source and target languages. See Workarea >
Settings > Localization > Languages and Regions.
1. Go to Settings > Configuration > Metadata Definition.
2. Select the target language.
3. Add a new metadata definition. Assign it the same data type and other properties
as the original. Note the new ID number.
4. Repeat Steps 2 and 3 for additional target languages.
5. Open workarea/xslt/metadataDefinitions.xml.
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6. For each metadata definition, enter a <dd> element within the <dl> element. The
<dd> element has the following form.
<dd title="Name of the metadata definition">
<dfn id="ID" xml:lang="language-country code"/>
<dfn id="ID" xml:lang="language-country code"/> :
</dd>

For example:
<dl>
<dd title="Paper form number">
<dfn id="102" xml:lang="en-US"/>
<dfn id="106" xml:lang="es-ES"/>
</dd>
</dl>

7. The XLIFF export/import process accesses the metadataDefinitions.xml file to
determine which definitions in the source language correspond to target language
definitions. From now on, if you export content for translation from that folder then
import the translated files, the metadata is translated along with the content,
summary, and so on. See Exporting content to XLIFF on page 1533, Importing
translation files on page 1537.

Creating metadata for content in any language
Use this procedure if your authors create content in separate languages. There is no
interaction between the content in the different languages
1. Create each metadata definition. Be sure to choose the correct language.

2. Complete the other fields on the screen but ignore the bottom of the screen (circled
in the following image).
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3. Apply that metadata definition to each folder that will contain content in that
language. To do that:
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i. Go to the folder.
ii. Click View > Language > choose the language.
iii. Click View > Properties > Edit properties > Metadata tab.
iv. Uncheck Inherit parent configuration (unless you want to inherit from the
parent folder).
v. Check the metadata definition you created in Step 1.
4. When creating content in that folder, authors access the metadata definition
created in Step 1 on the Metadata tab.

Creating multi-language content
Use this procedure to create new content in a language other than the default
language.
If you already have content in any language and want to create a new content item that
contains a translated version of that content, see Translating content on page 1530.
PREREQUISITE
l

You have permission to add content to the folder.

l

The desired language is available. See also: Determining which
languages are available on page 1510.

1. Go to the content folder in which you want to create the content.
2. Choose View > Language and select the language in which you want to create
the content.
You can also view all content in a folder, regardless of language. This menu option
makes it easy to find content in a selected language.
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The View Contents of Folder screen displays the language of each content item.

3. Click Add Content ( ) and create the content as you would any content. See
also: Creating new content on page 684.
4. When applying metadata, you can only use metadata definitions created for the
selected language. See also: Working with Metadata on page 822.
You can set up a separate workflow for each edition of a content, and can create
collections, menus, taxonomy categories, and tasks in any supported language.
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NOTE: Alternatively, you can designate certain sections of text within a content
item to be included or excluded from certain languages. See also: Creating one or
more localized paragraphs on page 1534

Modifying page content based on language selection
If a template’s text should change according to a user’s language selection, use a case
statement to provide the language-specific content. Assume you want to create
editions of the menu that runs under the header in 3 languages: English, French, and
German.
1. In the template file, declare each menu option a variable. For example:
Dim t_search, t_products, t_support, t_news, t_careers,
t_calendar, t_home, t_login, t_site_lang, t_contact,
t_copyright, calendar_id

2. Enter case statements that provide the value of each variable in each language.
(1031—German; 1036—French.) The following case statement is for the search
menu option.
Select
Case
Case
Case
Case

ContentLanguage
"1031" t_search = "Suche"
"1036" t_search = “Recherche"
else t_search = "Search" End Select

When a user visits a page controlled by this template and selects French or German as
the site language, the page is refreshed and the translated values appear on the
template.

Modifying images based on language selection
Many Web page templates include images that require translation. To set up templates
to invoke images in the user-selected language:
1. Add to the library each image that should change when the language changes. For
example, if your company’s tag line is translated into 3 languages, upload the 3
images into the library.
Include the language in the title of the image. For example, tagline_English,
tagline_French.
2. Create separate content for each language-specific image. Each content block
must have a unique ID number.
3. Insert the appropriate image into the content block for each language. For
example, insert the tagline_English image into the English content block.
4. Insert the content blocks into appropriate templates. For example, insert the
English content block into the English template.
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Setting up locales
Ektron provides locales for every language and region supported by your Windows
server.
You can create a new locale on the Edit Language Details screen by picking a
combination of language and region, as defined by the Unicode Common Locale Data
Repository. On Windows Vista and later versions, you can use the Microsoft Locale
Builder to create custom, supplemental ASP.NET cultures. Custom cultures are helpful if
no ASP.NET culture matches either the language or the region; for example, eo-150
(Esperanto in Europe). You also can create custom cultures for new combinations, for
example, fr-US (French in U.S.). After you create a locale, Ektron authors can create
content, menus, collections, and so on, in that locale, and site visitors can view content
based on it.

Creating a new locale
1. Go to Workarea > Settings > Localization > Languages and Regions.
2. Click Add ( ). The Edit Language Details screen appears. A partial image is shown
in the following image.

l
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the Region field, select a country, and click the Recommended radio button.
Then, go back to the Languages field; you will see all languages spoken in the
selected country by percentage.
l

Region. Provides several options for finding the new locale's region or country.
o If you selected a language above, you can select from a list of countries that
use the language. To do that, click Recommended and scroll below the list of
multinational regions. Click the country of the locale you are defining.
o

To select from an alphabetical list of all countries, click Show All and scroll
below the list of multinational regions.

o

If the language's locale is not tied to a specific country but is connected to a
region, select the region from the regions list.

l

Locale. Assign a locale ID to the new language. The locale ID must be unique, but
is free-form, so you can customize it. It could be based on a target market, for
example, “youth” for English US young adults (for example, youth-US), or “euro”
for English in Europe (euro-UK), or even “klingon” (klingon-US). If you select a
language, the field is filled in for you. Typically, the suggested value is adequate.

l

Fallback Locale. For every language, you can set a Fallback Locale, a language
in which content appears if it is not available in the selected language. If content is
not available in the fallback locale, Ektron looks for content in the fallback locale's
Fallback Locale. If content in that language is not found, Ektron looks for up to 4
additional fallback locales. At that point, if content is still not found, Ektron tries to
display the content in the default language.
For example, your website's default language is US English. You have some
content in Swiss German (de-CH). The fallback language for that is Austrian
German (de-AT), and the fallback language for Austrian German is German (deDE). If the content on a page is not available in Swiss German, Ektron tries to find
an Austrian German edition. If it cannot find that, it looks for a German edition. If
that is not available, it tries to display an English edition. See also Setting the
fallback locale on page 1529.
In certain situations, you may want no fallback locale. That is, you want to display
nothing if content is not available in the selected language. To accommodate this,
None is an option in the Fallback Locale drop-down list.
NOTE: If you set None as the Fallback Locale for any language, and content
is not available in the selected language, nothing appears on the page and no
other languages are checked.

l

Language Tag. Assign a language code to the language. This section of the
screen contains important information about this field.
IMPORTANT: Unlike the Locale field, the Language Tag field must conform
to the IETF BCP 47(Best Current Practice).
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l

Alphabet. Some languages can be written in more than one alphabet. For
example, Serbian can be written using the Latin or Cyrillic alphabet.

l

Custom Ext. Choose between 2 strategies when exporting content for translation:
machine translation and pseudolocalization.
Using a MachineTranslation Strategy
When you export content for translation and apply the MachineTranslation
strategy, Ektron translates the content using machine translation then immediately
imports it. See also: Using machine translation on page 1531
The following is an example of how to implement the strategy. See also: CMS
Strategies.
<objectFactory>
<objectStrategies>
<add name="MachineTranslation">
<strategies>
<add name="MachineTranslationStrategyTemplate"
type="Cms.Extensions.Templates
.MachineTranslationStrategyTemplate,
Cms.Extensions.Templates"/>
</strategies>
</add>
</objectStrategies>
<objectImplementations> </objectImplementations>
</objectFactory>

Using a pseudoLocalization strategy
NOTE: For background information, see Pseudolocalization (Wikipedia).
When you export content for translation and apply the PseudoLocalization strategy,
Ektron converts the content to pseudo-language text and the immediately imports
it..
The following is an example of how to implement the strategy.
See also: CMS Strategies.
<objectFactory>
<objectStrategies>
<add name="MachineTranslation">
<strategies>
<add name="MachineTranslationStrategyTemplate"
type="Cms.Extensions.Templates
.MachineTranslationStrategyTemplate,
Cms.Extensions.Templates"/>
</strategies>
</add>
</objectStrategies>
<objectImplementations> </objectImplementations>
</objectFactory>
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<objectFactory>
<objectStrategies>
<add name="PseudoLocalization">
<strategies>
<add name="PseudoLocalizationStrategyTemplate"
type="Cms.Extensions.Templates
.PseudoLocalizationStrategyTemplate,
Cms.Extensions.Templates"/>
</strategies>
</add>
</objectStrategies>
<objectImplementations> </objectImplementations>
</objectFactory>

Here is an example of how to override the PseudoLocalize method.
public override void
PseudoLocalize(ref string content, PseudoLocalizationEventArgs
eventArgs)

Here are the PseudoLocalizationEventArgs properties.
LocaleData
Locale
LocalizableCmsObjectType
ObjectType
long
ObjectId

Developers use the PseudoLocalize property to write custom code that
programmatically starts the export process. Here is an example:
Ektron.Cms.Localization.LocalizationExportJob.PseudoLocalize = true;
Ektron applies the PseudoLocalization strategy if either of the following conditions
is met:
l

The target locale’s language tag contains x-pseudo.

l

The export job’s PseudoLocalize property is true.

Applying PseudoLocalization strategy to a locale
You can apply PseudoLocalization Strategy to a locale's language tag in the
Workarea. Use the Settings > Localization > Languages and Regions
screen's Custom EXT field, as illustrated in the following figure. Programmatically,
LocaleData.XmlLang contains x-pseudo.
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Overriding the translate method
Here is an example of overriding the Translate method.
public override void
Translate(ref string content, MachineTranslationEventArgs
eventArgs)

The MachineTranslationEventArgs have intellisense, but the following is a list of
its properties.
LocaleData SourceLocale
LocaleData TargetLocale
LocalizableCmsObjectType ObjectType
long ObjectId

Ektron applies the Machine Translation strategy if either of the following conditions
is met.
l

The target locale’s language tag contains x-mt

l

The export job’s MachineTranslate property is true

Developers use the MachineTranslate property to write custom code that
programmatically starts the export process. Here is an example:
Ektron.Cms.Localization.LocalizationExportJob.MachineTranslate =
true;

Applying machine translation strategy to a locale
You can apply Machine Translation Strategy to a locale's language tag in the
Workarea. Use the Settings > Localization > Languages and Regions
screen's Custom EXTfield. Programmatically, LocaleData.XmlLang contains xmt.
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l

ASP.NET Culture. Specifies the region for formatting dates, times, currencies,
and so on. This value is assigned to the ASP.NET Culture property. See also: How
to: Set the Culture and UI Culture for ASP.NET Web Page Globalization.

l

ASP.NET UICulture. specifies the natural language of resource strings. This value
is assigned to the ASP.NET UICulture property. See also: How to: Set the Culture
and UI Culture for ASP.NET Web Page Globalization

l

Flag Icon. used in the Workarea as a quick, visual indicator of the locale, it is
important for each locale to have a unique flag. Flag files must be 16x16 pixel .gif
images. Ektron provides several flags, which are installed to the
/siteroot/WorkArea/images/application/flags/ folder. Any flags with
elements in common with the locale's language and region appear as choices. If
there is no flag next to the locale you are creating (for example fr-017, French in
Africa), you can create an image, assign that name to it, and place it in the
designated folder. Then return to this screen, select the locale, and select the
image.

l

Native Name. the name of the locale in its native natural language. That is, what
the people in that locale call their own language and region.

l

English Name. the name of the locale in English.

Setting the fallback locale
1. Go to Workarea >Settings > Localization > Languages and Regions.
2. Click Edit (

).

3. Click Rename or Change Fallback Locale (

) for the language of interest.

4. Use the pulldown in that language's Fallback Loc column to select a fallback
locale.

NOTE: If you set a language's Fallback Locale to None and the language is
part of a fallback chain, if content is not available in that language, the chain
terminates there.

Ektron Reference

1529

Working with multi-language content

5. Click Save (

) in the row of the language you are changing.

Translating content
You have the following options for translating content.
l

Translating content manually below. Copy original content to a new content
item in new language, then translate content manually.
l Only one content block at a time.
l

l

Using machine translation on the facing page. Use the computer-based
translation tool provided with Ektron.
l Readily available as a browser add-on.
l

l

Error prone because some translatable text is hidden (such as ‘alt’ text in
images). Also, some text might be translated that should not be translated (for
example, Smart Form choice field values).

Results in a poor quality translation.

Exporting content to XLIFF on page 1533. best option for translating,
whether in-house or outsourcing. Use an XLIFF editor.
l Supports batch processing of several content blocks.
l

The XLIFF file is sent to a translation agency and returns translated to the new
language(s). Then, import the translated files into Ektron.

l

Free XLIFF editors may not adequately support the XLIFF standard so may not
be compatible.

IMPORTANT: Before using machine translation services, you must first
register with Google Translation services and then add your Google key value
into the following code in the web.config file:
<machineTranslation>
<add key="GoogleTranslator" value="[your Google key value],
https://www.googleapis.com/language/translate/v2?key=" />
</machineTranslation>

Translating content manually
Use this procedure to initialize new foreign language content with content from a source
language, then translate the content manually. The copying should facilitate the
translation. For example, an editor translates content from French to German. The
editor copies the French edition to new content whose language is German. As the
editor translates the French edition into German, the French content is deleted. Any
images in the content usually would remain, and all formatting (tables, bullets, and so
on) is retained.
1. Go to the View Contents of Folder screen for the content you want to translate. Its
status must allow editing (it cannot be submitted or pending).
2. Choose View > Language and select an original language.
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3. Click the content you want to translate. It appears on the View Content screen.
4. Use the Add drop-down list in the upper right corner to select a language into
which you want to translate the content. The original language content appears.

5. Translate into the new language then delete the original content. At this point, you
can click Translate Content ( ) to have the software translate the content. You
can then edit as needed to perfect the translation. When done, click the Paste
Content button.
NOTE: You cannot translate XML Smart Forms using the Translate Content (
) button.
6. Translate the Title and summary.
7. To add metadata to content, metadata specifications must have been created for
the selected language. See also: Working with Metadata on page 822
8. When you save the content, it is saved as the edition of that content in the selected
language.

Using machine translation
Ektron includes a machine translation feature, which is powered by the Google
Translation Service. To see a list of supported languages, go to
http://translate.google.com/.
NOTE: Machine translation is not supported for all languages in the Language
Settings screen. Also, you cannot translate XML Smart Forms using this method.
Like most software-based translation, someone fluent in the new language should
verify that the translation is appropriate within the context of the page.
The machine translation feature lets you choose a glossary (that is, a field, industry, or
subject area). This helps the software find the best translation for a term or phrase in
that field.
Follow these steps to use the machine translation feature.
PREREQUISITE
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Your Ektron administrator has enabled the feature. See also: Enabling
machine translation on the facing page
1. In the Workarea, open the folder that contains content to be translated.
2. Choose View > Language and select an original language (that is, the language
from which it will be translated).
3. Click the content you want to translate. Its status must allow editing (that is, its
status cannot be submitted or pending). It appears on the View Content screen.
4. Use the Add drop-down list in the upper right corner to select a new language for
the content.
NOTE: If you do not see the language on the drop-down, you need to enable
the language. See also: Determining which languages are available on
page 1510

5. The original language content appears.
6. Edit the title if appropriate.
7. Click Translate Content (

). The Translation screen appears.

8. Select the source (old) and target (new) languages.
9. If the content should refer to a specific glossary, select one from the drop-down
list.
10. Click Translate. The translation appears.
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11. If the translation looks OK, click Paste Content. The translated content replaces
the original content in the editor. Modify as needed.
12. Translate the Title and Summary.
13. To add metadata to the content, metadata specifications must have been created
for the selected language. See also: Working with Metadata on page 822
14. When you save, the content is saved as the selected language edition of the
content.
NOTE: When the View Contents of Folders screen reappears, it is probably set to the
source language. In this case, you do not see the new content in the target
language. To see it, click View > Language and select All or the target language.

Enabling machine translation
Follow these steps to enable Ektron's machine translation feature.
1. Using the information on the Web page
https://developers.google.com/translate/v2/faq, obtain a Google Translation
API key.
NOTE: The Google Translate API is only available as a paid service.
2. Open the Ektron siteroot folder\web.config file.
3. Find the following element:
<machineTranslation>
<!-- ex. value="[API_KEY_FROM_GOOGLE],
https://www.googleapis.com/language/translate/v2?key="-->
<add key="GoogleTranslator" value="" />
</machineTranslation>

4. Insert the API key you obtained in Step 1 into the value attribute.

Exporting content to XLIFF
You can copy content into XLIFF files that you can submit to a translation agency, or
translate the content "in house." When the translation is complete, you import
translated content to Ektron.
You can translate these kinds of Ektron information.
l

content, including summary, comments, and metadata

l

a portion of a content (see Creating one or more localized paragraphs on the next
page)

l

forms, including response message, comments, and metadata

l

all menus (you cannot choose individual menus)

l

assets (Office documents, managed files, and so on. You cannot export. zip files.)

l

taxonomy data
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XLIFF (XML Localization Interchange File Format) is a format for exchanging localization
data between participants in a translation project. This format lets translators
concentrate on the text to be translated, without worrying about its layout. XLIFF is
supported by a large group of localization service and tools providers. To learn more
about XLIFF, visit these websites:
l

XML in localisation: A practical analysis

l

OASIS XML Localisation Interchange File Format (XLIFF) TC

Ektron supports versions 1.0, 1.1, and 1.2 of the XLIFF standard. You specify the
version you are exporting in the web.config file, using the ek_XliffVersion element.
Any listed version can be imported.

Creating one or more localized paragraphs
IMPORTANT: This button is only available in the eWebEdit400 editor.
The Localize Section button ( ) lets you designate paragraphs to localize for the XLIFF
translation process. For example, an author creates content in English, and does not
want a specific paragraph to be translated into French. So, the author uses the Localize
Section feature to exclude that paragraph from the French version of content. When the
content is exported, the selected paragraph does not appear in the French XLIFF file.
1. Open the content with paragraphs that you want to localize.

2. Select one or more paragraphs. You must select entire paragraphs. You cannot
select individual words or sentences within a paragraph. Also, if the content is a
bulleted or numbered list, you must select the entire list.
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3. Click Localize Section (

). The Localize Section dialog appears.

4. For each language on the list, Include or Exclude the selected text.
l If you include one or more languages, all unchecked languages are excluded.
l

If you exclude one or more languages, all unchecked languages are included.

l

If you include some languages and exclude others, all unchecked languages
are excluded.

5. Click OK. From now on, when editing that content, authors see a <localize> box
that shows the localized sections that are exported/imported when using the XLIFF
process.
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On the following sample screen, Dutch and U.S. English are excluded. This means that
French, German and Italian are included even though the Include box is not checked.

On the following sample screen, German and Italian are included. This means that
Dutch, U.S. English, and French are excluded even though the Exclude box is not
checked.

On the following sample screen, Dutch is included and U.S. English is excluded. In this
case, because one language is included and another is excluded, German, Italian, and
French are excluded even though the Exclude box is not checked.
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Editing a localized section
1. Edit the content that contains the localized section. A localized section looks like a
table within the editor.
2. Place the cursor in the table header, near <Localize>.
3. Right click and choose Localize Section.
4. Choose Locale Languages to Include or Exclude.
5. Click OK.

Removing a localized section
1. Edit the content that contains the localized section. A localized section looks like a
table within the editor.
2. Place the cursor in the table header, near <Localize>.
3. Right click and choose Remove Localize Section. The localization information is
removed but the text remains.

Importing translation files
The following is an overview of importing translation files.
1. You select content to translate.
l a content item
l

a folder—all content in the folder is selected; you may include its subfolders

l

all menus

l

all taxonomies
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Alternatively, select a Translation Package. See also: Creating a multi-language
translation package on page 1544.
2. Ektron converts the selected content to XLIFF files. (Only content whose state is
"Ready for translation" is converted to XLIFF format.) You can prepare files for
translation into several languages at once. A separate .xlf file is created for each
language. Then, all .xlf files for each language are compressed into one .zip file.
3. Transmit the .zip file to a translation agency.
4. The agency translates and returns the files. Alternatively, the files can be
translated "in house."
5. Import the files to Ektron. If the content does not exist in the target language, it is
created.
PREREQUISITE

Only members of the Administrator User Group and those defined in the
Manage Members for Role: XLIFF-Admin screen can create or import XLIFF
files. See also: Using the roles screens on page 1582
IMPORTANT: Make sure the files have been translated before you import them.
1. From the Workarea, choose Settings > Localization > Import Translated
Files.
2. Click Browse and go to the folder that contains the translated files.
3. Select the files to import.
4. Click Import Translated XLIFF Files. Ektron creates new or updates existing
foreign-language editions of the imported content/menu/taxonomy.
5. Information about the imported file appears in the history area of the screen. You
can click plus signs (+) to see increasing levels of information about imported
content.
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For each new edition:
l

If the content title is the same as the source edition, the next available number
is appended to the title to distinguish it from the source. For example: Henry
Williams(1).

l

Its status matches the source content's status. Typically, its status is checked
out. When imported, the content can enter the workflow process just like
other content.

l

Its history indicates it was checked in at the time the report was run

l

For content, the following properties are inherited from the original content:
o Smart Form See also: Working with Smart Forms on page 888
o

content searchable See also: Making content searchable on page 371

o

approval method See also: Setting the approval method on page 756

l

Date created and last edit date are captured from when the content is
imported

l

The last user to edit is captured by user who imported the file

Marking translation statuses
PREREQUISITE
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Member of Administrators group, or assigned to the Translation State Admin
or XLIFF Admin role See also: Defining roles on page 1581
Each Ektron content item has a translation status. Only content marked "ready for
translation" is included when you create an .xlf file. Use Mark Translation Status on
the View Content screen to mark translation status. See also: Content statuses on
page 681

A content item's Mark Translation Status button may have any of 3 icons, which
indicate the content's status.
l

Ready for translation. Automatically applied when content status changes to
Approved. Manually applied when authorized user clicks button and changes status
to Ready for Translation.
NOTE: You may apply this status to unapproved content if it needs translation
before the site goes live.

l

Not ready for translation. Automatically applied when content status changes
to anything other than Approved. Translation status changes if
o authorized user clicks button and chooses Ready for Translation
o

l

content's status changes to Approved

Do not translate. Prevents content from being translated. Translation status
changes only if authorized user clicks button and chooses Ready for Translation.

If you click Mark Translation Status ( ), a menu appears that lets you change its
status. Note that Export for Translation (
) appears on the toolbar only if the
content's translation status is Ready for Translation.

If you create an .xlf file for a folder, only content whose translation status is ready is
included in the file.
NOTE: The Localization Dashboardprovides an overview of translation activity
within Ektron.

Applying Translated Metadata to Translated Content
If you follow the guidelines in Creating multi-language metadata on page 1514, key
metadata fields are recognized in the XLIFF process and will be imported/exported.
After you import the translation files, Ektron removes them from the file system.
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NOTE: If an error exists in any of the files, the erroneous files are moved into a
subdirectory. The directory is created using a timestamp. For example:
uploadedFiles\localization\merged\xlf20060208T141841_u1\error\.

Metadata that works with XLIFF export and import
The following metadata field names may be used for translation using the XLIFF export
and import process.
l

XliffReferenceSource. Content Selector

l

XliffReference. Content Selector

l

XliffGlossary. Content Selector

l

XliffNote. Meta Data

Creating the .zip file
PREREQUISITE

Only members of the Administrator User Group or those assigned to the
XLIFF-Admin role can create, export, or import XLIFF files. See also: Using
the roles screens on page 1582.
To create one or more .zip files for translation:
1. Select the content to be exported:
l To translate one content item, go to its folder then click it.
l

To translate all content in a folder (and, if desired, its subfolders), go to its
View Contents of Folder screen.

l

To translate a menu, go to Content Tab > Menus.

l

To translate a taxonomy, go to Content Tab > Taxonomy and check
taxonomies to translate.

l

To translate a Translation Package, see Creating a multi-language translation
package on page 1544.

2. Click Export for Translation (

). (On the View Contents of Folder Screen,

choose Action > Export for Translation.) The Export for Translation screen
appears.
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NOTE: The Include Subfolders field appears only if you click Export for
Translation from the View Contents of Folder screen.
3. To include content in all of a selected folder’s subfolders, check Include
Subfolders.
4. From the Source Language pull-down, select the language of items being
translated.
5. All enabled languages are selected under Target Language. (See also:
Determining which languages are available on page 1510).
6. To translate the content into all languages, proceed to the next step.
To translate the content into some languages, uncheck the languages that you do
not want. You can uncheck the box in the header row to uncheck all, then only
check the ones you want.

7. Click Create XLIFF Files for Translation.
8. Ektron creates one .zip file for each language. The .zip file includes an XLIFF file for
each selected content item. (If content in a target language was edited more
recently than the source language edition, that content is excluded from the .zip
file. Also, the content's translation status must be ready. See also: Marking
translation statuses on page 1539)
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The History section of the Export for Translation screen displays the translated
files.

The history lists the .zip file created for each language. The top of the history
window displays the most recently exported/imported files. ZIP files are indicated
by the WinZip icon (

). To the right of the icon are:

l

the source language's flag

l

an arrow indicating the direction of the translation

l

the destination language's flag and name

l

the zip file size

9. To review items in a zip file, click + next to Extracted. When you do, each content
item’s ID number, title, and last edit date appear.
10. Click the .zip file icon (under Downloadable Zipped XLIFF Files). The File Download
window appears. If you want to review the XLIFF files within the .zip file, click
Open.
11. Click Save. The Save As window appears.
12. Go to the folder where you want to place the zip file and click Save.
13. Transmit the files to the translation agency.
NOTE: When the translation agency returns XLIFF files, their extension must be .xlf
or .xml. Other than that, the file name is not important.

File naming patterns
XLIFF
l

item identifier[item ID]_[new language hexadecimal code][2 letter new language
code].xlf
o item identifier options:
o

content: cont

o

form: form

o

menu: s

o

menu item: s

o

taxonomy: t
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item ID varies, depending on whether the item is content, a form, a menu, or a
menu item
o content: content ID number

l

o

form: form ID number

o

Menu: menu ID number

o

Menu item: menu ID number

ZIP
l

xlf[timestamp in format yyyymmddThhmmss]_u[user ID] _ [new language
hexadecimal code]-[2 letter language code].zip
The user ID indicates which user performed the export or import.

Creating a multi-language translation package
Use the Multi-language Translation Package to create and control groups of content that
require translation. Translation packages contain any type of content managed by
Ektron including
l

HTML

l

XML Smart Forms

l

assets like Microsoft Word documents, PDFs

l

images. Images (.gif, .png, .jpg and so on) are also managed with their associated
source documents like Photoshop (.psd) files.

For ease of use, you may add content and folders to one or more Translation Packages.
After creating a Translation Package, you use the Export for Translation screen's Select
Packages field to export the content for translation. See also: Exporting content to
XLIFF on page 1533.
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Only content that’s selected for that package and marked “Ready for Translation” is
exported. See also: Marking translation statuses on page 1539.
PREREQUISITE

You must be a member of the Administrators group or be assigned to the
XLIFF Admin role. See also: Defining roles on page 1581.

Viewing translation packages
When you first view the Translation Packages screen, you see all packages in the
default language. To view existing packages in any (or all) languages, change the
language drop-down.

Adding a translation package
1. Go to Workarea > Settings > Localization > Translation Packages.
2. Choose a language for this Translation Package using the View: drop-down.
3. Click Add Translation Package. The Add Translation Package screen appears.
4. Enter a translation package title and description.
5. Click Save. TheItems and Properties tabs appear.
6. Below the tabs, a screen appears. Use toolbar buttons to add items to the
Translation Package.
l
. Assign languages to which the package's content is exported for
translation. See Creating the .zip file on page 1541.
l

. Assign content to Translation Package. SeeAssigning items to a translation
package below .

l

. Assign folders to Translation Package. See Assigning folders to a
translation package on the next page.

l

. Edit Translation Package. Change the title or description. To change other
package elements (content, folders, and so on), click the appropriate button.

l

Delete Translation Package.

Assigning items to a translation package
1. Go to Workarea > Settings > Localization > Translation Packages.
2. Choose a language for this Translation Package in the View: drop-down.
NOTE: You can add more languages to the package after creating it.
3. Click a Package Name to view it.
4. Click Assign Items ( ). The following image shows an example of the
\Content\Company\Careers folder.
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5. Check items to include in this package. Only content in the selected language
appears.
6. Click Update Translation Package.

Assigning folders to a translation package
If you select a folder, only content in that folder that matches the Translation Package's
source language is included. For example, you create a Translation Package in English.
In that package, you select a folder which has 1 content item in English, 2 in Spanish,
and 1 in German. When the package is exported for translation, it includes English
content only.
1. Go to Workarea > Settings > Localization > Translation Packages.
2. Click on a Package Name to view it.
3. Choose a language for this Translation Package in View:.
4. Click Assign Folders ( ). The following image shows an example of the
MainSite\Content\Company\Careers folder.
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5. Check folders to include in this package.
NOTE: To check subfolders, open the folder tree to show the subfolders then
check the top folder. To exclude subfolders, do not open the folder tree or
uncheck the specific subfolders.
6. Click Update Translation Package.

Linking a Photoshop source file to an image for translation
Complex images often contain text that you wish to translate. Because the image is a
"flat" non-layered file, it is difficult to make text changes. However, the text may be on
a layer within a Photoshop (.psd) file.
1. Create a Metadata definition called XliffReferenceSource of the type Content
Selector.
NOTE: The key name XliffReferenceSource is a reserved and recognized by
the XLIFF import/export process.Adding a metadata definition on page 823
2. Assign XliffReferenceSource metadata to the folder that contains the images.
3. Add the Photoshop file as an asset in that folder.
4. Go to the Library and edit the image to which you associate the psd file.
5. Click the metadata tab and add the Photoshop file to the XliffReferenceSource
field.
6. Click Publish.
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Translating the Workarea
By default, the Workarea is in English. Ektron provides US English strings in a text file.
Workarea text (that is, screen titles, Workarea menus, messages, alt text for buttons,
and so on) is stored in a resource file. Resource files are installed to the
siteroot\Workarea\resources directory. Workarea images that include text are
stored in the workarea/images/language folder. For example,
Workarea\images\french_standard.
Ektron provides a resource files for the following languages. The English resource file is
complete, so translate the English file into the desired language. The others are
partially complete.
l

German

l

English—United States

l

Spanish

l

French

l

Italian

l

Dutch—Netherlands

l

Dutch—Belgium

A resource file is not human-readable. To make it so, use Microsoft’s resgen utility,
then translate the human-readable, .txt version of the file. The following example
shows a portion of it.
add menu title=Add Menu
lbl ad serverip=Domain Controller IP
alt: remove collection items text=Click here to remove items
from this collection

Each string has the following components:
l

English description—includes information about where the text appears. For
example, btn text appears on a button.

l

an equal sign (=)

l

English text—The text displayed on the screen, for example, a button label, menu
item, or mouse-over text.

For each string, translate the text to the right of the equal sign. Then, run the resgen
utility on the .txt file again, indicating the translate-to language. This converts the file
back to a machine-readable format. Finally, move that file to the appropriate language
folder under workarea/images, and enable the new language in the Workarea.
PREREQUISITES
l
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l

The server that hosts Ektron must have Visual Studio.NET.

1. Copy the resgen.exe utility from C:\Program Files (x86)\Microsoft
SDKs\Windows\v8.0A\Bin\NETFX 4.0 Tools to the your-website\Workarea\resources folder.
In Visual Studio, the resgen.exe utility is typically located in the <SDK dir>\bin
directory, located via HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
SDKs\Windows.
NOTE: If your computer does not have a resgen.exe file, see the following
article: http://msdn.microsoft.com/enus/library/vstudio/ccec7sz1%28v=vs.110%29.aspx
Note that it says "This tool is automatically installed with Visual Studio."
2. Go to Windows Start button > Microsoft Visual Studio 2010 > Visual Studio
Tools > Visual Studio Command Prompt to open a command window.
If you're using Windows 8 or 2012, go to
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft
Visual Studio 2010\Visual Studio Tools\Visual Studio Command Prompt.
3. In the command window, change the directory to the
siteroot\Workarea\resources folder. For example, cd
C:\Inetpub\wwwroot\CMS400Min\Workarea\resources.
4. Insert the following text: resgen EKResource.en-US.resources
anyfilename.txt
You can assign any name to the .txt file. A .txt file of resource strings converted to
a human-readable format is created in the resources directory.
5. Open the .txt file.
6. Replace all single backslashes (\) with a double backslash (\\).
7. Translate the text following every equal sign (=). Be careful not to change any
occurrences of n surrounded by double backslashes (\\n\\).
8. Save and close the .txt file.
9. Open the command window (as described in Step 2) and insert the following:
resgen anyfilename.txt EKResource.two-character country
code-two-character language code.resources.

Replace anyfilename.txt with the file you named in Step 4. In this example, the
.txt file is named span_translation.txt. For example, to indicate that the
Workarea is being translated into the Spanish/Spain, enter resgen.exe span_
translation.txt EKResource.es-ES.resources.
When the conversion is complete, Writing Resource File ...Done appears in the
command window.
10. The Workarea\resources folder includes several resource files. If one exists for
the translate-to language, it is overwritten. If one does not exist, it is created. To
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follow our example, the EkResource.es-ES.resources file was updated with your
changes.
11. Your website's Workarea\images folder contains text images that need translation.
If the country/language into which you are translating has subfolder within
Workarea\images, inspect its images to see if they need translation. If the
country/language into which you are translating does not have a subfolder within
Workarea\images:
a. Create a new folder whose name is the language code into which you are
translating.
b. Copy the files in the Workarea\images\en folder.
c. Paste those files to the folder you created in Step 10a.
d. Review the files in the folder you created in Step 10a. Translate text as
needed.
12. Enable the new language in the Language Settings screen. See Determining which
languages are available on page 1510.
13. Make the new language the default language in the Configuration Setup screen.
See Setting the default language on page 1512.

Setting the spell checking language for
eWebEdit400
NOTE: If you use the default editor, your browser manages the spell checking.
Ektron’s spell checker for eWebEdit400 refers to a standard dictionary of the content’s
language. So, for example, if the content is U.S. English, the U.S. English dictionary is
referenced.
The spell checker also references a language-specific custom dictionary. Words are
added to this list when a user stops at a misspelled word and chooses the Add to
Dictionary option.
Both dictionaries reside on the server that hosts Ektron.
The spell checker compares each word against both sources. If a word is in either one,
the spell checker moves to the next word. If a word is missing from both sources, the
spell check options appear, and the user decides what to do.
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Ektron provides the following standard dictionaries.
l

uk-UA. Afrikaans

l

ar-AR. Arabic

l

bg-BG. Bulgarian

l

cs-CZ. Czech

l

da-DK. Danish

l

de-CH. German (Switzerland)]

l

de-DE. German

l

en-GB. English (Great Britain)

l

en-US. English (United States)

l

es-ES. Spanish

l

fr-FR. French

l

he-IL. Hebrew

l

it-IT. Italian

l

nl-NL. Dutch

l

nn-NO. Norwegian (Nynorsk)

l

pl-PL. Polish

l

pt-PT. Portuguese

l

pt-BR. Portuguese (Brazil)

l

ru-RU. Russian

l

sl-SL. Slovenian

l

sv-SE. Swedish

l

uk-UA. Ukrainian

If Ektron does not have a dictionary that matches the content language, it proceeds
through these steps in the following order:
1. If the language begins with en (for example, en-AU), use the en-GB dictionary.
If it begins with zh, use zh-CHS.
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2. Each language has a default version, indicated by letters before the dash matching
the ones after the dash. For example fr-FR. If the default version’s dictionary is
available, use it.
3. Use the first dictionary (alphabetically) that begins with the content language. For
example, the content language is es-AR, but its dictionary does not exist. The first
dictionary alphabetically beginning with es that is available is es-CO, so use that.
4. If none of the above is available, use en-US.

Using the localization dashboard
PREREQUISITE

You must be a member of the Administrators group or assigned to the XLIFF
Admin role. See also: Defining roles on page 1581
The Localization Dashboard provides an overview of translation activity occurring in
Ektron. To access the Localization Dashboard from the Workarea, go to Settings >
Localization > Dashboard. The top of the screen lets you choose criteria. The lower
section then displays content that meets the criteria. For example, you can find all US
English content whose translation status is Ready for Translation, and resides in the
/Clients folder. The lower section of the screen also lets you perform tasks on its
content, such as print a list or change its Translation Status. See also: Marking
translation statuses on page 1539

Selection criteria
The following list explains the fields at the top of the screen. After you enter the
selection criteria, click Filter Results to apply the new selections.
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IMPORTANT: These criteria have an AND relationship. This means that, if you
select several criteria, only content that satisfies all appears in the lower section of
the screen.
l

Lang/Dialect. Select the language whose content you want to view. To ignore
this field, choose NULL. Alternatively, you can select all content not in the selected
language. To do that, check the Does not Include box.

l

Trans Status. Select the translation status of content you want to view. To
disregard this criterion, choose (Any). See also: Marking translation statuses on
page 1539

l

Date Created. If desired, enter a range of content creation dates. If you do, only
content created within those dates appears below.

l

Last Modified. If desired, enter a range of content modification dates. If you do,
only content edited within those dates appears below.

l

ContentID. To see a particular content item, enter its ID number.

l

Folder. If desired, select a folder whose content you want to view.

l

Author. If desired, select the person who last edited the content you want to view.

l

Title. If you know one or more words in the title of content that you want to view,
enter them. You may enter one partial word and find all content whose title
includes it.

Viewing content on the localization dashboard
When you open the Localization Dashboard, the lower section displays all content in the
Default Application Language.
NOTE: The pagination of the content list is controlled by the <add key="ek_
PageSize"> element in your siteroot/web.config file.
On the lower section, you can:
l

sort by any column in ascending or descending order by clicking on the column
header

l

view and work with any content item by clicking it, if you have permission to do so
See also: Managing folder and content permissions on page 168

l

print current results by clicking Print

l

export current results to a Microsoft Excel spreadsheet by clicking Create Report

l

edit the selected content's export languages

l

change the content's Translation Status

l

estimate the word count for one or more pieces of content

Editing the content's export languages
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As described in Creating the .zip file on page 1541, when exporting content for
translation, you select one or more target languages. You can add, edit, or remove
target languages for content in the lower section of the Localization Dashboard using
Action menu options.

The actions associated with the menu options are performed the next time the Create
XLIFF Files for Translation button is clicked:
l

Set Locales. View and modify locales into which selected content will be exported.

l

Add Locales. Add locales into which selected content will be exported.

l

Remove Locales. Remove locales into which selected content will be exported.

To change the target language assigned to content in the lower section of the
Localization Dashboard:
1. Check the box next to each content item that you want to modify. To check all
items, check the box in the header row.
2. Click Action > menu option. For example, Action > Set Locales.
3. Select desired locales and click Save.

Changing the content's translation status
To learn about Translation Status, see Marking translation statuses on page 1539.
1. Check the box next to each content item that you want to modify. To check all
items, enable the check box in the header row.
2. Click Action > Set Translation Status.
3. Select the appropriate Translation Status and click Save.

Estimating the content's word count
1. Enable the checkbox associated with one or more pieces of content.
2. Choose Action > Estimate Word Count. The Estimated Word Count screen
appears.
3. Click Save. The screen is dismissed. (Note that the word count is not saved.)
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NOTE: Only members of the Administrators User Group and those defined in the
Manage Members for Role: User Admin screen can view, add, or edit users and user
groups.
Users are people who administer the website, create content, or publish content.
Without users, the website would be blank. In Ektron, you can add, edit, and delete
users to and from the application through the Settings folder in the Workarea.
Every Ektron user belongs to a User Group. When you create a user, the user is added
to the Everyone group by default. User groups are used when creating permissions and
a workflow for content folders. User groups can be departments in your company
(Human Resources, Sales, Engineering) or indicate a user’s role (Publishers,
Administrators, Editors, and so on).
All user and user group information is accessible from the Workarea.
To access the user folder in Ektron, go to Workarea > Settings > Users. The View
Users screen appears. From this screen, you can add, edit, and delete users.
To access the user group folder in Ektron, go to Workarea > Settings > User
Groups. The View User Groups screen appears. From this screen, you can add, edit,
and delete user groups.
IMPORTANT: This chapter only applies to systems that do not use Active Directory
Integration. If your system uses the Active Directory Integration Feature, see Using
Active Directory with Ektron on page 1589 to learn about user management
functions. If your system uses LDAP Authentication, see Using LDAP with Ektron on
page 1616.

Managing users
Viewing a user
Go to Workarea > Settings > Users to display the View Users screen.

Creating a user
Before you can assign a user to a user group, you must add the user to the system.
1. Go to Workarea > Settings > Users to display the View Users screen.
2. Click Add User. The Add a New User to the System screen appears.
NOTE: To learn about the lock and unlock buttons (
), see Account
Locked. The buttons provide a shortcut to that field for users with a check in the
box to the left of their name.
3. Enter the following information about the user. A red asterisk (*) next to a field
name indicates that the field is required and cannot be blank.
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General Tab (tabs only appear when editing)
—Editable by a non-administrator user. Non-admin users can edit their own
profiles only, and only fields indicated.
l

Username. Insert a username for the user you want to create.

l

Path. This field is only available when using LDAP Authentication. See also:
Adding user information from an LDAP server to Ektron on page 1619.

l

First Name. Enter the first name of the user.

l

Last Name. Enter the last name of the user.

l

Display Name. Enter the name that is used to identify a user in the
Workarea and on the website. This can be different from the Username, which
is the name used to log in.
NOTE: The Display Name cannot be blank.

l

l

l

Password. Enter a password for the user. See also: Ektron's password
security policy on page 118.
Confirm Pwd. Confirm the password by typing it again.
User Language. Select the language in which the user will view Ektron
screens and messages. The language also determines the default value
whenever a drop-down list of languages appears within Ektron.
The drop-down list is derived from the Language Settings screen, available
from the Settings > Configuration folder.
Do not confuse the system language with the user’s ability to create and edit
foreign editions of content. This field does not prevent a user from working
with multiple language content.
See also: Working with multi-language content on page 1507.
NOTE: If the selected language is not English, French or German, it is only
supported after you download the Ektron Language Support Program from
Ektron and translate the website.

l

E-Mail Address. Enter the email address of the user. Notification email is
sent to this address unless the Check to prevent workflow and task
emails being sent to this user box is checked. Also, this address identifies
the user sending Instant email. See also: Sending instant email on page 113.
NOTE: If the Enable Sending of System Notification Email box on the
Application Setup screen is checked, and the Check to prevent workflow
and task emails being sent to this user box on this screen is not
checked, you must supply an email address.
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l

Account Locked. Available in edit mode: Check this box to lock or unlock
this user. Locked users cannot log in. For information on events that
automatically lock a user out, see Restricting login attempts on page 115. You
can manually lock or unlock users via the lock buttons (
) on the View
Users in Groups screen.

l

l

Content and Forum Editor. the default editor appears, and you cannot
change it, unless your Ektron administrator set the siteroot/web.config file's
ek_EditControlWin (for Windows computers) or ek_EditControlMac (for
Macintosh computers) property to UserPreferred, in which case you may
choose an editor.
Avatar. An image or icon to represent you in the Forum.
Insert a Web path to the image. For example:
http://www.example.com/smileyface.gif. Alternatively, you can click
Upload to browse to a file on your network.

l

Address. Enter the address used to find this user’s location when a search
based on location is being performed. You can enter either a full address or a
postal code.

l

Latitude, Longitude. The Google GeoCoder strategy uses the information
from the Address field to determine the user's latitude and longitude. These
values are used to identify a user’s location when someone performs a search
based on location.

Custom Properties tab
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l

Check to prevent workflow and task emails being sent to this user.
Check this box to disable workflow and task email notifications for this user. If
you do, the user does not receive the notifications described in . However, this
field has no effect on the user’s ability to receive instant email.
NOTE: The field appears only if the Enable Sending of System
Notification Email box on the Application Setup screen is checked.

l

Features. Lets the profile owner edit events on a Web calendar. When this
is checked, it cannot be unchecked. See also: Working with calendars on
page 991

l

Private Profile. Choose from one of the following options to determine
which other users can see the owner's community activities:
o Public. The user information is accessible by others on the eIntranet.
o

Private. The user information is not accessible by others on the
eIntranet.

o

Colleagues. The user information is accessible only by people on the
eIntranet that are connected as colleagues.
NOTE: Using the ActivityStream Widget on a PageBuilder
Pageexplains how this setting affects other users' ability to see your
activities.

l

l

l

Time Zone. Used by the Web Calendar feature, appointment times will
show in the selected time zone.
Phone. Must consist of a 10 digits (String) in this pattern: nnn-nnn-nnnn.
Moderate. Check to make this user a moderator of a message board to
approve and delete posts. Regular users in a group message board can create
and delete only their own posts.

4. Click Save. The View Users in Group Everyone screen appears with the new user
included in the table. When you add a new user, he is automatically placed in the
Everyone user group. To assign users to other groups, see Assigning a user to a
user group on page 1565.
5. Continue this process until you add all website users, or reach the maximum
allowed by your license.
NOTE: Contact Ektron Sales for pricing of adding more users to your license.

Editing a user
NOTE: If you are using Active Directory to edit a user, see Adding and maintaining
user information on page 1606.
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1. Go to Workarea > Settings > Users to display the View Users screen.
2. Click the Username of the user you want to edit. The View User Information
screen appears.
3. Click Edit. The Edit User screen appears. The following lists describe the field
descriptions.
General Tab (tabs only appear when editing)
—Editable by a non-administrator user. Non-admin users can edit their own
profiles only, and only fields indicated.
l

Username. Insert a username for the user you want to create.

l

Path. This field is only available when using LDAP Authentication. See also:
Adding user information from an LDAP server to Ektron on page 1619.

l

First Name. Enter the first name of the user.

l

Last Name. Enter the last name of the user.

l

Display Name. Enter the name that is used to identify a user in the
Workarea and on the website. This can be different from the Username, which
is the name used to log in.
NOTE: The Display Name cannot be blank.

l

l

l

Password. Enter a password for the user. See also: Ektron's password
security policy on page 118.
Confirm Pwd. Confirm the password by typing it again.
User Language. Select the language in which the user will view Ektron
screens and messages. The language also determines the default value
whenever a drop-down list of languages appears within Ektron.
The drop-down list is derived from the Language Settings screen, available
from the Settings > Configuration folder.
Do not confuse the system language with the user’s ability to create and edit
foreign editions of content. This field does not prevent a user from working
with multiple language content.
See also: Working with multi-language content on page 1507
NOTE: If the selected language is not English, French or German, it is only
supported after you download the Ektron Language Support Program from
Ektron and translate the website.

l
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NOTE: If the Enable Sending of System Notification Email box on the
Application Setup screen is checked, and the Check to prevent workflow
and task emails being sent to this user box on this screen is not
checked, you must supply an email address.
l

Account Locked. Available in edit mode: Check this box to lock or unlock
this user. Locked users cannot log in. For information on events that
automatically lock a user out, see Restricting login attempts on page 115. You
can manually lock or unlock users via the lock buttons (
) on the View
Users in Groups screen.

l

l

Content and Forum Editor. The default editor appears, and you cannot
change it, unless your Ektron administrator set the siteroot/web.config file's
ek_EditControlWin (for Windows computers) or ek_EditControlMac (for
Macintosh computers) property to UserPreferred, in which case you may
choose an editor.
Avatar. An image or icon to represent you in the Forum.
Insert a Web path to the image. For example:
http://www.example.com/smileyface.gif. Alternatively, you can click
Upload to browse to a file on your network.

By default, an avatar's maximum size is 200 kilobytes, and its height and
width are reduced 125 pixels, preserving the aspect ratio.
l

Check to prevent workflow and task emails being sent to this user.
Check this box to disable workflow and task email notifications for this user. If
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you do, the user does not receive the notifications described in Automatic
email Notification. However, this field has no effect on the user’s ability to
receive instant email.
NOTE: The field appears only if the Enable Sending of System
Notification Email box on the Application Setup screen is checked.
l

Address. Enter the address used to find this user’s location when a search
based on location is being performed. You can enter either a full address or a
postal code.

l

Latitude, Longitude. The Google GeoCoder strategy uses the information
from the Address field to determine the user's latitude and longitude. These
values are used to identify a user’s location when someone performs a search
based on location.

l

Forum Signature. Enter what you want to appear at the bottom of each
forum post. You do not see the signature in the editor but it is added after you
click Post.

l

Tags. Click Add Tag and enter 1 or more tags that describe the profile owner.
Tag keywords allow for tag-based searching. For example, you can add the tag
electronics so that people can search for the profile owner who may be an
electronics expert. See also: Tagging content, library items, users, and groups
with keywords on page 1723.

Workarea tab
l Full Screen. When a check mark appears in this check box, the Workarea
opens up to the size of the full screen. In addition, the Width and Height
options are hidden. See Workarea tabs on page 666.
l

Landing Page after login. See Modifying setup information on page 129.

l

Set smart desktop as the start location in the Workarea. If you want
the Smart Desktop to appear as soon as this user enters the Workarea, click
this check box. See also: Managing content from the Smart Desktop on
page 668. If you leave this check box blank, when this user enters the
Workarea, he goes to the folder of the content specified at the Landing Page
after login field.

l

Restore Default Preferences. Restore the default Workarea settings
specified by the Administrator.

Custom tab
l
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l

l

l

l

Private Profile. Determines which other users can see the owner's
community activities. For example, Using the ActivityStream Widget on a
PageBuilder Pageexplains how this setting affects other users' ability to see
your activities.
Time Zone. Used by the Web Calendar feature, appointment times will
show in the selected time zone.
Phone. Must consist of a 10 digits (String) in this pattern: nnn-nnn-nnnn.
Moderate. Check to make this user a moderator of a message board to
approve and delete posts. Regular users in a group message board can create
and delete only their own posts.

Activities tab
NOTE: If you disable Notifications, the Activities tab (which lets the user pick
Notifications to receive and send) disappears.
l

l

Colleagues. Select notifications you want to receive when a colleague
performs an activity, and the agent that transmits the notification. For
example, if you want to receive email notifications when a colleague posts a
blog message, check inside the box for Blog Post in the email column. See
also: Sending notifications to a community on page 1665
Community Groups. This tab sets preferences for all community groups.
Select notifications you want to receive when a community group member
performs an activity relating to the group, and the agent that transmits the
notification. For example, you want to receive email notifications when a
community group member posts to group’s blog. To enable this, check inside
the Group Blog Post box in the email column. See also: Sending notifications
to a community on page 1665
For Developers: Ektron has created a UserGroupPreferences user control. If
you add the control to a community group’s profile page, users can specify
notification preferences for individual groups. This control is installed with
Ektron and is located in siteroot\Workarea\Notifications\Controls.

l

My Activities. Select notifications you want publish when performing
various activities on the website. For example, if you want to publish
notifications when you post to your blog, check the box for Blog Post in the
Publish column. See also: Sending notifications to a community on
page 1665.
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l

SMS. A checked box indicates that the type of content will be sent to your cell
phone Short Message Service (SMS).

l

Activity Stream. A checked box indicates that the type of content will be
displayed in the Activity Stream widget on the eIntranet pages.

l

Email. A checked box indicates that the type of content will be sent to your
Email address, which is specified in the General tab of your profile.

Profile Links tab
This field displays the user's alias if community aliasing is set for users. See also:
Types of URL aliasing on page 1400.
4. Make necessary changes to user information.
5. Click Update.

Deleting a user
NOTE: If you are using Active Directory to delete a user, see Maintaining AD user
information on page 1602.
IMPORTANT: You cannot delete a user who is applied to any workflow. If you need
to immediately disable a user, edit the user and check the Account Locked box.
See also: Approving content for publication on page 749.
NOTE: Only certain users are allowed to delete Ektron users. See Auditing changes
on page 690.
To delete a user from Ektron:
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1. Go to Workarea > Settings > Users to display the View Users screen.
2. Click the Username of the user you want to delete. The View User Information
screen appears.
3. Click Delete (

).

4. Click OK.
WARNING! When a user is deleted, that action is permanent. The process cannot
be undone.

Assigning a user to a user group
When you create a user group, no user is initially assigned to it. To add a user to a user
group:
1. Go to Workarea > Settings > User Groups to display the View User Groups
screen.
2. Click the user group to which you want to add a user. The View Users in Group
screen appears.
3. Click Add User. Users who do not (yet) belong to the group appear.
4. Select 1 or more users to add to the group using 1 or more of the following
methods:
l To select specific users, check the box to the left of their name.
l

To select all users, check the box in the column header row.

l

Enter characters into the Search field and find only users that match them.
For example, you could enter bill, click the Search button, and see only users
with those characters in their name.

l

Use the drop-down menu to sort the display by User Name, Last Name or
First Name.

5. Click Save.
6. Click OK. The selected users are now members of the selected group.
7. Continue this process until you add all users into User Groups.
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Removing a user from a user group
NOTE: If you are using Active Directory to remove a user from a group, see
Maintaining AD user group information on page 1604.
Removing a user from a user group does not delete the user from Ektron. Also, you
cannot remove users from the Everyone group.
1. Go to Workarea > Settings > User Groups to display the View User Groups
screen.
2. Click the name of the group that includes the user you want to remove. Members of
the group appear.
3. Click Remove to the far right of the user that you want to remove.
4. Click OK.

Managing user groups
NOTE: If you are using Active Directory to manage user groups, see Setting up
Active Directory integration mode on page 1594.
Every Ektron user belongs to at least one User Group. User groups are used when
creating permissions and workflow for content folders.

Viewing the users in a user group
1. Go to Workarea > Settings > User Groups to display the View User Groups
screen.
2. Click the user group whose members you want to view. The View Users in Group
screen appears with a list of users who are members of the group. From this
screen, you can edit or delete user groups, as well as add and remove users to and
from the user group.

1566

Ektron 9.40 SP1

Creating a user group

Creating a user group
1. Go to Workarea > Settings > User Groups to display the View User Groups
screen.
2. Click Add User Group. The Add a New User Group to the System screen appears.
3. Enter a name and brief description of the user group you want to create.
4. Click Save.

Editing a user group
When editing a User Group, you can only change its name.
NOTE: You cannot edit the default Administrators and Everyone user groups.
1. Go to Workarea > Settings > User Groups to display the View User Groups
screen.
2. Click the User Group you want to edit. The View Users In Group screen appears.
3. Click Edit (

). The Edit User Group screen appears.

4. Edit the group name as required.
5. Click Update.

Deleting a user group
When you do not need a User Group anymore, you can delete it from the system.
NOTE: You cannot delete the Administrator and Everyone groups.
IMPORTANT: You cannot delete a user group that is applied to any workflow. See
also: Approving content for publication on page 749
1. Go to Workarea > Settings > User Groups to display the View User Groups
screen.
2. Click the User Group you want to delete. The View Users In Group screen appears.
3. Click Delete (

).

4. Click OK. The User Group is deleted from the Ektron website.

Assigning a user to a user group
See Managing users and user groups on page 1555.

Removing a user from a user group
See Removing a user from a user group on the previous page.
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Creating custom user properties
PREREQUISITE

Only Administrators Group members can work with Custom User Properties.
Custom User Properties let you create custom fields that collect user information
beyond the standard Ektron properties. Examples include employee ID, phone number,
start date, position, department, and IP address. Once created, custom properties
appear on the User Properties and Membership User Properties screens on the Custom
tab, and on the Membership server control.
IMPORTANT: Custom properties are required fields, which means that a user must
complete them in order to create a new or edit an existing user.

Viewing custom properties
Use the View Custom Properties screen (Settings > Configuration > Custom
Properties) to create custom properties for users and membership users. From the
View Custom Properties screen, you can:
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l

add a new custom property. See Adding a custom user property on page 1570.

l

edit a custom property. See Editing custom user properties on page 1577.
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l

reorder the sequence of custom properties on the users and membership users
screen. See Setting the order of custom user properties on page 1578.

l

work with custom properties in different languages. See Creating a non-English
custom user property on page 1579.

o

Add. Add custom user properties. See Adding a custom user property on the
next page.

o

Reorder. Change the order of the custom user properties on the Users or
Membership User Properties screen. See Setting the order of custom user
properties on page 1578.

o

Language Selection drop-down list —lets you view
custom user properties by language. See Creating a non-English custom user
property on page 1579.
o

Object Type drop-down list—lets you choose users or
taxonomies whose custom user properties you want to manage. See Adding a
custom user property on the next page and Creating and assigning taxonomy
custom properties on page 1389.
o

Title field—Displays the title of a custom user property. When viewing by
language, the title changes to the title used in a specific language if it has been
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defined. Click a Title to edit the property. See Editing custom user properties
on page 1577.
o

Type field. Shows the Type of a custom user property.

Adding a custom user property
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. From the Object Type pulldown, select User.
3. Choose the standard language used in your Workarea.
4. Click Add. The Add User Custom Property screen appears.

o

Label. Title of the property you are adding. For example, Employee ID.
NOTE: Title and Label are the same field. On some screens the word Title is
used, on others the word Label is used.

o

1570

Type. The property’s data type. When a type is selected and saved, you
cannot change it. You must delete the custom property and re-enter it.
l String. Accepts all alpha, numeric, and symbol characters. Text Box, Text
Area, and Hidden input types are available. All validations are available.
See also: ”Validation” on page 15-23
l

Boolean. Accepts a true or false response. Check Box and None input
types are available.

l

Numeric. Accepts numbers only. The following input types are available.
o Text Box
o

No Validation

o

Cannot be blank
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l

l

o

Numeric Only

o

U.S. Zip Code

o

Dollar Amount

Date. Only a date can be entered. The following input types are available.
o Text Box
o

No Validation

o

Cannot be blank

o

Date Only

SelectList. Select a response from a list of choices.
Use a SelectList field to present the user completing the User
Information or Membership User Properties screen with a list of choices.

When you create a custom user property and specify its type to be Select
List, the screen changes, allowing you to add, change, or remove list
entries.
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Completing a SelectList field entry
To add an item to the list, enter its text in the Text field, then click Add .
Added items then appear in the larger box on the left. You can then:
l

remove any item from the list by clicking it. It appears in the Text
field. Click Remove.

l

change the text of any list item by clicking it. It appears in the Text
field. Make changes then click Change.

l

change the sequence of list items by selecting an item then clicking
the up or down arrow to move the item

Using the first list item to prompt a response
You can use the first list item to prompt the user to make a selection
instead of being a valid response. For example, the first list item may say
Select from a list of choices. To do this, check the First item is not a
valid selection for example, “[Select]” check box.
If this option is selected, the field has an asterisk (*) next to it (indicating
it is required) on the User Information and Membership User Properties
screens. The user completing the screen must choose any selection other
than the first item. If he tries to file the screen without choosing a
different item, the following error message appears: Please fill in all
required fields (*)
l

Multi SelectList. Select any number of responses from a list of choices.
Use a MultiSelectList field to present the user completing the User
Information or Membership User Properties screen with a list of choices.
The user can choose as many responses as appropriate.

Selected items are indicated by a blue background.
When you create a custom user property and specify its type to be
MultiSelect List, the screen changes.
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For information about completing the screen, see Completing a SelectList
field entry on the previous page.
l

o

Category. A system-defined type that appears when the first
subscription is created. One entry covers all subscriptions. See also:
Creating a subscription on page 1493.

Input Type. Choose how a user is able to enter a response to the property.
l Text Box. Creates a standard text box. Use this with a String, Numeric,
or Date. For example:

l

Text Area. Creates a multi-lined area for entering text (String). Typically
used when more than one line of text needs to be added. For example:

l

Hidden. Hides the input field (String). This can be used by an
administrator to add additional values at postback time. This requires a
developer to add client-side JavaScript. If you change a String field’s
Input Type from Text Box or Text Area to Hidden, then sign in as a
member of the Administrators group, the field and its value still appear on
the user’s profile.
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l

o

Check Box. Creates a boolean checkbox. Used when the field requires a
boolean (true / false) response. For example:

Validation. Ensures the right type of data is entered in a text box or text area.

Validation

l

String

l

Numeric

l

Date

l

String

l

Numeric

l

Date

l

String

l

Numeric

l

String

l

String

l

Date

Email Only

The response must be entered as an
Email address. For example,
username@domain.domainextentio
n.

l

String

Credit Card
Only

The response must be entered as a
credit card number. For example,
nnnn nnnn nnnn nnnn

l

String

Social Security
Only

The response must consist of 9 digits
in this pattern:nnn-nn-nnnn.

l

String

U.S. State Code

A 2-letter state code. For example:
NH = New Hampshire.

l

String.

No Validation

Cannot be
blank

Numeric Only

1574

Description

An Option
When Used
With

The entry is not checked.

A response must be entered.

The response must be a number.

Text Only

The response must be characters
(any combination of alpha, numeric,
and symbol ).

Date Only

The response must be entered in the
following format: mm/dd/yyyy.
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Validation

Description

An Option
When Used
With

The response must consist of 5
(nnnnn) or 9 digits separated by a
dash after the fifth (nnnnn-nnnn).
U.S. Zip Code

NOTE: If you use the Numeric
Type, you cannot have a dash or
space when using a 9 digit Zip
Code

l

String

l

Numeric

Valid US Phone
Number

The response must consist of a 10
digits in this pattern: nnn-nnn-nnnn.

l

String

Canadian
Postal Code

The response must consist of 6 (xnx
nxn) alpha or numeric characters
with a space after the first 3
characters.

l

String

l

String

l

String

Time is entered in one of the
following 3 formats.
Time HH:MM or
HH:MM:SS or
HH:MM:SS.mm

IP Address

l

HH:MM. Hours and Minutes
09:30

l

HH:MM:SS. Hours, Minutes and
Seconds 09:30:45

l

HH:MM:SS.mm. Hours, Minutes,
Seconds and milliseconds
09:30:45.002

The response must be in the form of
an IP address.
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Validation

Description

An Option
When Used
With

This validation works differently
depending on the Type used. If used
with the String Type, you can have a
dollar sign ($) along with the money
amount in the text field.
Dollar Amount

Canadian Social
Insurance
Number

When used with the Numeric Type,
you are not allowed to have a dollar
sign ($) in the text field. The
following are examples of each type
with validation:
l

String. $3.00

l

Numeric. 3.00

The response must consist of 9 digits
in this pattern (nnn nnn nnn).

l

String

l

Numeric

l

String

o

Min Value. If desired, enter the minimum value you want to allow. The Min
Value only appears when the following Validation methods are used: Numeric
Only, Date Only and U.S. Zip Code. The following is an example of a Date Only
Min Value: 01/01/1900.

o

Max Value. If desired, enter the maximum value you want to allow. The Max
Value only appears when the following Validation methods are used: Numeric
Only, Date Only and U.S. Zip Code. The following is an example of a Date Only
Max Value: 01/01/1987.

o

Message. A message that appears when information entered in a user
property violates the validation criteria. For example, if the validation is U.S.
Zip Code, you might use the following message: Please enter a valid zip
code

Features field
This field is automatically included on the User or Member profile Custom Tab to let
the profile owner edit events on a Web calendar. When this is checked, it cannot be
unchecked. For more information about Web Calendar, see Adding system
calendar events on page 994.

Private profile field
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This field is automatically included on the User or Member profile Custom tab. It
lets the profile owner determine which other users can see the owner's community
activities. For example, Using the ActivityStream widget on a PageBuilder page on
page 1713 explains how this setting affects other users' ability to see your
activities.
The Private Profile field value also determines if a user's profile is visible on a
forum. See also: Managing a discussion board on your website on page 1049.
When a Micro-message server control is placed on a page in TimeLine mode,
micro-messages only appear for users whose Private Profile setting is set to
Public.

Time zone field
The Time Zone property field is a special field used by the Web Calendar feature.

Select the time zone of the User or Member here. When they are logged in,
appointment times will show in this time zone. For more information, See also:
Adding system calendar events on page 994.
5. Click Save. The new property appears on the View Custom User Properties screen.

Editing custom user properties
Click a custom user property’s title to display the Edit Custom Property Screen. From
here, you can edit and delete a custom property or create a version in a non-default
language.
When you save changes to a custom user property, the changes affect all users and
membership users. These changes also affect any other language versions of the
custom user properties that exist.
1. Go to Workarea > Settings > Configuration > Custom Properties to display
the View User Custom Properties screen.
2. From the Object Type pulldown, select User.
3. Click the Title of the Custom User Property you want to edit.
4. Choose the field you want to change. You can edit the following fields:
l Label
l

Input Type

l

Validation

l

Min Value

l

Max Value

l

Message

5. Click Save.
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6. When you click a user or membership user, you see your changes. For descriptions
of these fields, see Creating custom user properties on page 1568.
NOTE: You cannot edit the Type field. If you need to change the type, you must
delete the custom user property and create a new one.

Deleting a custom user property
WARNING! If you delete a custom user property, it is removed from all users and
membership users. Information that was collected for that property is lost. Also, all
language versions of the property are deleted.
1. Go to Workarea > Settings > Configuration > Custom Properties to display
the View User Custom Properties screen.
2. From the Object Type pulldown, select User.
3. Click the Title of the custom user property you want to delete.
4. Click Delete (

).

5. A dialog asks you to confirm.
6. Click OK.

Setting the order of custom user properties
Use this procedure to change the sequence of user properties on the User and
Membership User Custom Properties screens.
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. From the Object Type pulldown, select User.
3. Click Reorder ( ).

4. Click a property.
5. Click the Up or Down arrows to move the property up or down the list.
6. Click Save.
1578

Ektron 9.40 SP1

Creating a non-English custom user property

Creating a non-English custom user property
Like content, custom user properties have a language attribute. This is useful if you
have users or membership users that only use a specific language. It can also be used if
you want a custom user property to appear in the language in which the user is signed
in.
Unless a language other than English is defined for a custom user property, the
property defaults to the English version. For example, if you have 2 properties called
Birthday and Phone Number in English and you can translate the French version of
Birthday to Anniversaire, when you view the properties in French, you see the English
version of Phone Number and the French version of Birthday.
When creating a custom user property, it must be created in English then translated to
the desired language. This is done by editing the property, changing languages, filling
out the Translate Custom Property Label screen, and saving the property.
WARNING! All custom user properties in languages other than English are tied to
the English version of the property. If you delete the English version of the property,
all other language versions are deleted also. However, you can remove a nonEnglish language version of a custom property without deleting the English version.
See Removing a non-English custom user property title on the next page.
To translate the Title/Label of a property into French.
1. Go to Workarea > Settings > Configuration > Custom Properties to display
the View User Custom Properties screen.
2. From the Object Type pulldown, select User.
3. Choose a custom property to be defined in another language.
4. Choose a language from the language select drop-down box. The Translate Custom
Property Label screen appears.

5. Enter a Label for the property in the language you have chosen. For example, if
you are creating a French version of a Birthday custom user property, enter
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Anniversaire in the label text field. For information on the Label property, see
Adding a custom user property on page 1570.
6. Click Save.

Removing a non-English custom user property title
Removing a non-English version of a custom user property title does not remove the
English version of the property.
1. Go to Workarea > Settings > Configuration > Custom Properties.
2. From the Object Type pulldown, select User.
3. From the Language drop-down box, choose the language of the custom user
property.

4. Click the Title you want to delete. The Translate User Custom Property Label screen
appears.

5. Click Delete ( ). A dialog box asks if you want to remove the translated custom
property title.
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6. Click OK. The English version of the Edit Custom Property screen appears.
7. Click Back ( ).
WARNING! Do not click the delete button on the Edit Custom Property screen. This
action deletes the English version of the custom user property. If you click the delete
button, you lose all information collected by the property and all language versions
of the property.

Defining roles
Ektron contains an Administrators User Group. Any member of that group automatically
has full administrator privileges. The Roles feature lets you assign limited or specific
administrator privileges to users who do not require full administrator privileges. For
example, you can let certain users create, redirect, or remove tasks but deny them
other privileges normally granted to administrators.
The Permissions screen lets you control which users can manage a folder’s properties,
its content, library items, and create or edit collections. (See also: Managing folder and
content permissions on page 168) Together, the Roles feature and the Permissions
screen enable you to assign administrative privileges to users who are not members of
the Administrators group.
BEST PRACTICE
When creating new user groups to use with roles, assign names as a
mnemonic aid for the role, especially for folder-specific rules. For example,
the Marketing Folder Admins user group could be used for all role members
who administer the marketing folder.

Administrator role privileges
Administrator privileges include access to the screens that appear when you select
Settings > Configuration.
Administrators can also
l

edit folder properties (including Web alerts, metadata, permissions, and the
workflow)

l

manage aliasing features, such as turn aliasing on or off, activate and deactivate
manual aliases, and create automatic aliases

l

manually alias content

l

add, edit, or delete a calendar

l

add, edit, or delete a business rule

l

create, view, edit, and delete metadata definitions

l

create, view, edit, and delete taxonomies

l

create, redirect, and delete tasks
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l

require a collection to go through an approval process

l

export content for translation to another language using XLIFF

l

run an eSync

l

access the eCommerce Module

Using the roles screens
Use the Roles screens to assign limited administrator privileges. To access the Roles
screens, go to Workarea > Settings > Roles > Built-In > Folder Specific or
System-Wide.
NOTE: In the Roles screens, you can select users or groups. However, you cannot
select the Administrators group, because that group already has full permissions.
To view all roles assigned to any user, go to Workarea > Settings > Users. Then,
select a user and click the Roles tab.

Folder-specific roles
When setting up users and groups for administrative access over folders, keep these
guidelines in mind.
l

After being identified on the Manage Members for Role: Folder User Admin screen,
users or groups must also be given at least Read-Only permission for individual
folders on the Folder Properties > View Permissions for the Folder screen.
See also: Managing folder and content permissions on page 168.

l

You must use the same identity on the Manage Members for Role: Folder User
Admin and Folder properties screens. If a user group is listed for the role, use the
same group when assigning folder permissions, not simply a group member.
Conversely, if individual users are listed on the role screen, they must be specified
in the folder permission.

l

Ektron strongly recommends adding only user groups to the Folder User Admin
role, not individual users. If you set up an individual user as a role member, he
could accidentally receive administrative rights to other folders.

Folder-User admin
View and edit folder properties. These users can update properties, permissions, the
workflow, metadata, Web alerts, purge history, and so on. For example, create a user
group and give it permission to manage the top-level marketing folder. Group members
can do everything to that folder and its subfolders, but cannot manage other folders.
See also: Creating a custom permissions role on page 1587 and Setting folder
properties on page 158.
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Move or copy
Move or copy content. An Ektron best practice is to create a User Group for this
purpose, then assign the group to this role. You should not assign the role to individual
users. After assigning the User Group here, go to the folders whose content these users
will be allowed to move or copy, and assign to that User Group at least Read Only and
Traverse permissions. See also: Managing folder and content permissions on page 168
and Moving or copying content on page 687.

System-wide roles
Alias-Admin
Perform all URL Aliasing functions. See Creating user-friendly URLs with aliasing on
page 1399.

Alias-Author
Perform all functions related to URL Aliasing except viewing and editing the
URL Aliasing Setting screen and Editing aliasing rules.

Analytics Viewer
Can view:
l

Web Traffic Analytics reports

l

Analytics button on the View Content Screen

l

Analytics from the website's Access point menu ( )

l

Analytics from a PageBuilder page

See Analyzing websites on page 531.

Business Rule Editor
Create or edit business rules and rule sets. See Creating business rules for your website
on page 1473.

Collection and Menu Admin
Create, edit and delete collections and menus via the Content tab.
NOTE: To manage permissions for creating collections via the folder’s New >
Collection or New> Menu option, use folder permissions. See also: Managing folder
and content permissions on page 168
See Working with collections on page 804 and Creating menus for your website on
page 1339.

Collection Admin
Create, edit and delete collections via the Content tab.
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NOTE: To manage permissions for creating collections via the folder’s New >
Collection option, use folder permissions. See also: Managing folder and content
permissions on page 168
See Working with collections on page 804.

Collection Approver
If approval is required for a collection, approve changes to it, including the deletion of a
collection. See Setting up collection approval on page 817.

Commerce Admin
Use the eCommerce feature from the Workarea. See Conducting eCommerce on
page 1733.

Community Admin
Perform the following community activities:
l

Set system default preferences

l

View and create new
o Activity Types

l

o

Agents

o

Messages

Enable or disable notifications

See Sending notifications to a community on page 1665.

Community Group Admin
Create, edit and delete and manage all community groups. These users have the same
privileges as the group Administrator and members of the Administrators group. See
Managing community groups on page 1651.

Community Group Create
Create and manage community groups. A user with this role can only manage
community groups she or he has created. See Managing community groups on
page 1651.

Content Workflow Admin
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l

Gets a Force Publish button on the Edit and View Content screens. This button
only appears if the content is being edited or is in Submitted status. (User must
also be assigned the folder user admin role.)

l

Gets a Cancel Workflow button on the Edit and View Content screens. This
button only appears if the content is being edited or is in Submitted status. (User
must also be assigned the folder user admin role.)
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DXH Connection Admin
Create and manage DXH connections via the Workarea > Settings > Digital
Experience Hub > Connect to DXH screen.

DXH Connection User
Import and update DXH content into Ektron folders.

MasterLayout-Create
Create and edit PageBuilder Master Layouts. See Creating a PageBuilder master layout
on page 1097.

Menu Admin
Create, edit and delete menus.
See alsoCreating menus for your website on page 1339

Member Admin
Manage membership users and membership user groups. Member admin role members
cannot work with Ektron users. Users assigned to this role can create, edit, and delete
membership users and groups through the following screen.

See also: Membership users and groups on page 1625; Membership groups on
page 1633

Message Board Admin
Approve pending comments or delete existing comments on a message board. See Who
can moderate message board on page 1646
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Metadata-Admin
View, create and edit metadata definitions. See Working with Metadata on page 822.

Multivariate Tester
Perform multivariate testing. Setting up a multivariate experiment on page 1181.

Search-Admin
Create and edit Synonym Sets, Suggested Results, Integrated Search Mappings, and
the Search Status screen. See Providing suggested results on page 376, Using synonym
sets on page 374, Including external files in a search on page 385.

Smart Forms Admin
Create and edit Smart Forms. See Working with Smart Forms on page 888.

Synchronization Admin
Access the Workarea > Settings > Configuration > Synchronization screen,
which lets the user perform all synchronization activities, such as:
o

manage sync configurations and profiles

o

run a sync

o

perform content and folder-level sync

o

sync packages

See Synchronizing servers using eSync on page 1925.

Synchronization User
o

Sync content and folders

o

View Sync logs

o

Run a sync

o

Sync content and folders

See Synchronizing Servers Using eSync.

Task Create
Create tasks. See Creating a task assigned to content on page 1451.

Task Delete
Delete tasks. See Deleting a task on page 1460.

Task Redirect
Redirect tasks. See Assigning and managing tasks on page 1449.
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Taxonomy Administrator
Create and manage taxonomies. See Organizing content with taxonomies on
page 1357.

Template Configuration
View, create, update, and delete system templates. See Working with templates on
page 838.

Translation State Admin
Change the translation status of content. See Marking translation statuses on
page 1539.

User-Admin
Create, view, edit, and delete users and user groups. See Managing users and user
groups on page 1555.

XLIFF-Admin
Use the Language Xport feature, which copies content into XLIFF files that can be
submitted to a translation agency. Can change the translation status of content. See
Exporting content to XLIFF on page 1533 and Marking translation statuses on
page 1539.

Widget Synchronizer
Update widgets and edit their title, label, and parameters.

Creating a custom permissions role
The custom permissions role lets your Web developer create a site page, and then
extend or restrict access to that page’s content (or areas with a page) to users assigned
to a custom role.
Items you could show and hide could be as simple as a content block. But they could be
more complicated, such as displaying buttons and fields for one user group, and
something completely different for another.
Custom roles have no effect inside the Workarea.

Examples of custom roles
l

Most site visitors belong to different political parties, while some are registered
with no party. By checking the user’s ID against custom roles, you could present
registered voters with selections for their party’s primary, and prevent
unregistered voters from participating.
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l

Your Ektron site visitors fall into 2 categories: suppliers and buyers. You could
check the current user against a custom role and show buyers one set of data and
suppliers a different set.

l

On your eCommerce site, registered students see a list of coupons that are not
displayed for anyone else. Or, only registered adults can order age-controlled
items, such as tobacco or alcohol.

l

Control your pages’ background colors, images, and skins based on custom roles.
For example, mothers get family-oriented background images while teenagers get
rock images and related styling.

Setting up a custom role
1. Set up user groups and add to them users who will have some level of access to the
custom page. See also: Creating a user group on page 1567
2. To continue the above example, create one group of auditors (who will have readonly access), and another group of administrators (who will have edit access).
3. Create a folder to hold the content that will appear on the custom page. Use the
folder’s Permissions screen to assign users and groups appropriate access to the
folder’s content. See also: Managing folder and content permissions on page 168
4. Go to Workarea > Settings > Roles > Custom Permissions.
5. Click Add Custom Roles. The Manage Custom Roles screen appears.
6. Enter a name for the custom role.
7. Click Save. The Manage Custom Roles screen appears, displaying the new custom
role.
8. Click the name of the role you created. The Manage Members for Role screen
appears.
9. From the Show drop-down menu, select the type of users you want to add to the
role.
10. Click AddRole Member.
11. Check the box next to the users or groups that you want to add to the role.
12. Click Save. The Manage Members for Role screen appears.
13. Your Web developer creates the custom page.
14. You create content to appear on the custom page. Place the content in the folder
you created in Step 2.

Information about custom roles for developers
The API provides 2 methods that determine if the current user is logged in, and if he is a
member of the Administrators group. The methods let you test customizable roles with
conditions outside the standard Is-Logged-In /Is-Admin tests.
l
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l

GetRolePermissionFolder(RoleName As String, nFolderId As Long,
nUserId As Long)is a Boolean value indicating if the user belongs to the custom
role for the given folder.

Using Active Directory with Ektron
Active Directory lets you retrieve user and user group information from the Microsoft
Windows Active Directory (AD) into Ektron. As a result, you can administer user
information from 1 place, and users need to remember only 1 username/password
combination to sign on to the network and Ektron.

Setting up Active Directory
IMPORTANT: Ektron strongly recommends configuring SSL, especially if you are
using Active Directory Integration. SSL encrypts passwords that are otherwise sent
as clear text to the Ektron server. See also: Updating web.config to use SSL on
page 77.
You can set up Active Directory in the following ways:
l

l

Advanced Domains. Set up through editing the web.config file and entering
information in the Workarea. Use this method if:
o You are using a firewall.
o

The Ektron server need not be part of an Active Directory domain.

o

You are connecting to multiple Active Directory domains, even ones that do
not see each other.

Legacy. The domain connects to the AD domain within the web.config. Use this
method if you are using auto discovery.

Setting up Active Directory via the advanced domains
method
1. Verify AD information because, after you enable AD integration, logon name and
domain are imported to Ektron.
2. If your Active Directory forest has multiple domains, decide if you want Ektron to
reference the listed domains or if you want to choose a specific one. (You will use
this when completing the Domain field of the Active Directory Setup Screen.)
3. Edit the web.config file to the following values:
<add key="ek_ADEnabled" value="true"/>
<add key="ek_ADAdvancedconfig" value="true"/>
<add key="ek_AUTH_Protocol" value="LDAP"/>
<identity impersonate=“false”>
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NOTE: When using the Advanced Domains Method, the domains screen's
credentials are used.
4. Set up your domains on the Edit Domains screen.
5. Configure the AD setup page. See Setting up Active Directory on page 1595.
6. Assign AD groups to Ektron user groups. See Importing AD user group information
on page 1602.

Setting up Active Directory via the legacy method
1. Make sure each AD user to be used in Ektron is defined correctly in Active
Directory. When you enable AD integration, logon name and domain are copied
from AD to Ektron.
2. If your Active Directory forest has multiple domains, decide if you want Ektron to
reference all domains, or if you want to choose a specific one. (You will use this
when completing the Domain field of the Active Directory Setup Screen.)
3. Encrypt the domain account's Active Directory password using Ektron’s password
encryption utility.
To access that utility, go to the Windows Start menu > All Programs > Ektron
> current release > Utilities > Encrypt Email Password.
If you're using Windows 8 or 2012, press the Windows key (
Encrypt Email Password.

)/Q then enter

4. Set the following elements in the web.config.
a. Set the ek_ADEnabled element to true. It should look like this:
<add key="ek_ADEnabled" value="true"/>

b. Make sure the ek_ADAdvancedconfig element is set to False. (This is the
default value.)
c. Set the ek_AUTH_Protocol element to GC. It should look like this:
<add key="ek_AUTH_Protocol" value="GC"/>

d. Declare a domain account through ek_adusername and ek_adpassword.
It should look like this:
<add key="ek_ADUsername" value="[username]@domain" />
<add key="ek_ADPassword" value="YourPasswordHere" />

e. For the authentication element, change the value of the impersonate
attribute to False. It should look like this:
<identity impersonate="false" userName="" password=""/>

5. Configure the AD setup page. See Setting up Active Directory on page 1595.
6. Assign AD groups to Ektron user groups. See Importing AD user group information
on page 1602.
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Implementing Active Directory
You can implement Active Directory in 1 of 2 modes.
l

l

Active Directory Integration mode—the following information is shared between
Active Directory and Ektron:
o user logon name
o

domain

o

password

User authentication only mode—the following information is shared between Active
Directory and Ektron:
o user logon name
o

domain

o

password

o

user’s first and last name

o

email address

o

user groups

o

user’s group memberships

Implementing Active Directory integration mode
Active Directory Integration maintains consistent user and user group information
between AD and Ektron. First, user information is imported from AD into Ektron. When
this is complete, user group information is imported.
Ektron does not write to Active Directory; it only reads from it. This changes the way
Ektron manages user and user group information.
l

After you enable AD integration, many changes to user and user group information
must be made in AD. Several fields on the Edit User and User Group screens
become view-only.

l

When adding new users or groups, you can only select from users and groups in
AD. If a user or group does not exist in AD, create it there then import it to Ektron.

l

Integration requires Read Membership Group Permissions within Active Directory.

When using Integration, you must select a Administrator group. (There can only be
one admin group per Ektron site.) Click the search option and select Domain users
or an admin group created in AD specifically for Ektron.
Ektron imports the following AD user information.
l

l

Authentication (user logon name and domain) for signing in to Ektron. The AD
password is not stored in Ektron. Ektron only refers to it during sign in.

l

Group name (AD attribute cn), which corresponds to the Ektron domain and user
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group name.
l

User information
AD Field

AD Attribute

Corresponding
Ektron Field

User logon name (pre-Windows
2000)

sAMAccountName

Domain and
Username

Last Name

sn

Lastname

First Name

givenName

Firstname

Email

mail

email Address

NOTE: Users and user groups can share a name in different domains, for example,
juser@example.com and juser@example.net. Otherwise, user names must be
unique.
The following diagram illustrates the Active Directory feature's components.
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Setting up Active Directory integration mode
The Active Directory feature uses multiple Ektron screens to edit domains, set up Active
Directory, display AD status, and view and search for users and user groups.

Adding a domain to AD
Use the Edit Domains screen to identify each network domain you will use with Ektron's
Active Directory Integration. The screen lets you add new domains, modify existing
ones, or delete obsolete ones. Use this screen to define domains, as opposed to using
auto discovery to find them.
While signing on, users must select a domain in addition to username and password.
Domains are also referenced when defining AD users and user groups that map to the
Ektron users and groups.
PREREQUISITE
l

Edit web.config as explained in Setting up Active Directory via the
advanced domains method on page 1589.

l

Your NetBIOS and setting, if it is different from your domain name.
Contact your server administrator for this information.

l

Your domain’s DNS. Contact your server administrator for this
information.

To add a new domain:
1. Go to Workarea > Settings > Configuration > Active Directory > Domains.
2. Click Edit. The Add New Domain and Remove Last Domain options appear.
3. Click Add New Domain. The Edit Domains screen appears.
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l

Domain DNS. Enter the domain’s DNS. Contact your server administrator for
this information. For example, corp.example.com.

l

NetBIOS. If your NetBios is the same as your domain name, leave the box
checked. Otherwise, uncheck the box and enter your NetBIOS setting in this
field. Contact your server administrator for this information.

l

Username. Enter the name of the user with permission to sign on to the
domain server. The name is in the format username@domainDNS. For
example, jsmith@corp.example.com.

l

Password. Enter the password of the user.

l

Domain Controller IP. Enter the IP address or DNS name of your domain
controller. If using Active Directory with LDAP across a firewall, the IP address
should be that of the firewall. On the firewall, traffic on port 389 (LDAP) should
be allowed. Active Directory with GC uses different ports.

Setting up Active Directory
The Active Directory Setup screen lets you enable or disable AD and manage other AD
settings, such as whether users and groups are automatically updated.
To enable AD and manage settings:
1. Go to Settings > Configuration > Active Directory > Setup. The Active
Directory Setup screen appears.
2. Click Edit.
3. Enable options or enter information in fields as required.
Active Directory installed
l

Disable Active Directory and LDAP Authentication. Disables the use of
Active Directory and LDAP Authentication. See Disabling AD integration on
page 1605.

l

Enable LDAP Authentication. If enabled, you must complete the LDAPrelated fields (Type, LDAP Server, Port, Organization, Domain, Attribute, Use
SSL, Path). See Enabling LDAP on page 1617.

l

Enable Active Directory Authentication. If enabled, user authentication is
functional, and you can enable the following 3 fields. If you do not enable
these fields, you are using Implementing user authentication mode on
page 1606. For information on LDAP, see Using LDAP with Ektron on
page 1616.
o Enable Active Directory Integration. If enabled, the Active Directory
Integration feature is functional and you can enable the next 2 fields.
o

Enable automatic addition of user from AD. If enabled, user
information is imported from AD to Ektron when that user logs in or when
the user is added to Ektron.
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o

Enable automatic addition of user to groups. If enabled, a user’s
group membership is first imported from AD when a user logs in or is
added.

Auto Add
l

User Type. Choose the type of user to be automatically added: Author or
Member.

User Property Association
l

EmailAddr1. Enter the Active Directory property that maps to the user’s last
name in Ektron. By default, this is mail, but you can change it to any AD
property.

l

FirstName. Enter the Active Directory property that maps to the user’s first
name in Ektron. By default, this is givenName, but you can change it to any AD
property.

l

LastName. Enter the Active Directory property that maps to the user’s last
name in Ektron. By default, this is sn, but you can change it to any AD
property.
For more information on user properties, see MSDN Library
User Object User Interface Mapping (Windows).

Ektron Administrator Group Association
l

AD Group Name @ AD Domain. Enter the Active Directory user group and
domain name that map to the Ektron administrator group. If your AD does not
have a user group that includes all Ektron administrators, you should create
one then enter it here. See Mapping the administrator group on page 1604.

l

Domain. If you want to restrict the search of new users and groups to one AD
domain, select that domain. The Search Active Directory for Users and Search
Active Directory for Groups screens let you search the selected domain only.
Also, if any Ektron user or group names include a domain (for example,
admin@saturn.example.com) that is excluded by your selection, those
users/groups are flagged on the Active Directory Setup and Active Directory
Status screens because the names include an invalid domain.

4. Messages may appear near the top of the Active Directory Setup screen to notify
you that additional configuration steps are required. If either message appears,
click it. The Active Directory Status screen appears, which helps you resolve the
discrepancies.
Active Directory Authentication is Enabled and Requires More Configuration. Some
Ektron users are not associated with AD users. Also, if you are using full active
directory integration mode, user groups and/or user group relationships may not
be associated.
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Active Directory Authentication is disabled, but needs further configuration. Some
Ektron users and/or groups are no longer unique. This happens because, in AD,
users and groups can share a logon name as long as their domains are different.
But, if AD authentication is disabled, 2 users or groups can no longer share a
name—each must be unique.

Displaying Active Directory status
Use the Active Directory Status screen to identify and resolve discrepancies between
Ektron and AD.
l

An Ektron user must be associated with an AD user.

l

An Ektron user group must be associated with an AD user group.

l

An Ektron user’s group membership must be associated with the same AD user’s
group membership.

Any combination of messages may appear, depending on which issues require
resolution. The following procedure provides steps to resolve all 3 issues.
1. Go to Settings > Configuration > Active Directory > Status.
2. Click a link on the Active Directory Status screen to display a new screen lets you
resolve the discrepancy.
3. Click CMS users need to be associated with Active Directory users on the
Active Directory Status screen. The Associate CMS Users with Active Directory
Users screen appears. Use this screen to associate Ektron users with AD users.

4. Depending on the user, perform the appropriate action:
l If a user with the same username exists in AD, that name and domain appear
in the AD Username and AD Domain fields. If the user exists in more than
one AD domain, select a domain from the pull-down list.
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l

If there is no default and you know the AD user name to associate with an
Ektron user, enter that in the AD Username and AD Domain fields. If you do
not know the AD username, click Search to find the user in AD.

l

If you decide to change the username in AD to match the Ektron username,
make the change in AD. Then, click Refresh ( ) to update Ektron and resolve
the discrepancy.

l

If a user should not exist in Ektron, click the Delete box.

5. Click Save.
6. On the Active Directory Status scree, click CMS relationships need to be
associated with Active Directory relationships. The Associate CMS
Relationships with Active Directory Relationships screen appears. The screen
displays a user’s group membership that exists in Ektron, but does not exist in AD.
Use this screen to coordinate Ektron user group membership with AD user group
membership.

7. After viewing the discrepancy, perform the appropriate action:
l To associate the user with the same user group in AD, go to AD and assign the
user to the group. Then, return to this screen and click Refresh ( ) to update
user group information in Ektron. See also: Importing a user’s AD group
information to Ektron on page 1603.
l

To remove the user’s group membership in Ektron, check the Delete box and

8. After you complete the changes, click Save (

).

9. Click CMS groups need to be associated with Active Directory groups on
the Active Directory Status screen, the Associate CMS User Groups with Active
Directory Groups screen appears. Use this screen to associate Ektron groups with
AD groups.
10. Depending on the group, perform the appropriate action:
l If there is no default, enter that in the AD Group Name and AD Domain
fields. If you do not know the AD group name, click Search to find the group in
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AD.
l

If a group should not exist in Ektron, click the box under the Delete column to
delete the group.

11. After you complete the changes, click Save.

Viewing and searching for users
1. Click Settings > Users from the Workarea. The View users screen appears.
2. Click a user. The View User Information screen appears.

3. If you are using user authentication mode, Username and Domain can only be
edited in AD. You can edit all other fields on this screen.
If you are using full AD Integration mode, Username, Domain, First Name, Last
Name, and email Address can only be edited in AD. You can edit all other fields
on this screen.
The screen also displays the following buttons.
l
l
l

Edit. Edit information on screen.
. Delete user.
. Retrieve latest information from AD into Ektron. This button is not
displayed in user authentication mode.

l

l

. Replace Ektron user with a different AD User.
. Return to previous screen

If you cannot easily find users on the View Users screen, use the search function.
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4. Click Add User. The Search Active Directory for Users screen appears.

5. Enter as many search criteria as you know to reduce the number of users that the
search returns. For example, if you know the user’s last name is Jackson and he is
in the planets domain, enter those criteria to get fewer results.
6. Click Search. The Active Directory Users screen appears.
7. Check the box next to each user you want to add to Ektron.
8. Click Save to import the information.

Viewing and searching for user groups
The View User Groups Screen displays all AD user groups that have been imported to
Ektron.
1. Go to Settings > User Groups. The View User Groups screen appears.
2. Click the group name to display detailed information for the group. The View Users
in Group screen appears, showing the following information for each user in the
group:
l username and domain
l

first and last name

l

language

3. To add AD groups to Ektron, click the toolbar button ( ) that lets you add AD
groups to Ektron. The Search Active Directory for Groups screen appears.
4. If the Domain setting on the Active Directory Setup screen is set to restrict AD
integration to one domain, you can only search for groups in that domain.
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5. Click Search. A new screen appears that lists all AD groups that satisfy the search
criteria.
6. Click the box next to groups you want to create in Ektron.
7. Click Save to import their information.

Importing AD user information to Ektron
This section explains importing AD user information when integration is first enabled
and on an ongoing basis.
AD user information is initially imported to Ektron in different ways depending on
whether:
l

the Ektron database is already populated with users

l

the Ektron database is not yet fully populated with users. (At least one user is
always present because of the default admin user.)

l

users are manually added to the Ektron database

For a populated Ektron database:
1. If Enable automatic addition of user from AD is checked on the Active
Directory Setup screen, user information is imported from AD to Ektron when that
user logs in or is added to Ektron. See also: Setting up Active Directory on
page 1595.
2. At that time, AD information overwrites all Ektron information.
3. If 2 or more AD users have the same Ektron user logon name but different domains
(for example, JDoe in Eng.Example.com and JDoe in Mkt.Example.com) and that
username (JDoe) also exists in Ektron, the Active Directory Setup and Active
Directory Status screens indicate this discrepancy via this message: CMS users
need to be associated with Active Directory users.
4. Click the message to proceed to the Associate Ektron Users to Active Directory
Users screen. From there, you can link an AD user to an Ektron user. See also:
Maintaining AD user information on the next page.
For a Ektron database with only a few users, go to the Search Active Directory for Users
screen and select AD users that will use Ektron. You can only select AD users that do
not exist in Ektron. Also, the Active Directory Setup screen can restrict AD integration
to one domain. If it does, you can only search for users in that domain.When you add a
user, AD information is imported to Ektron. See also: Viewing and searching for users
on page 1599.
You can also manually add AD users to Ektron:
1. From the Workarea, click Settings > Users.
2. Click Add Users. The Active Directory Users screen appears.
3. From the Domain pull-down list, select the domain from which you want to add a
user.
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4. Enter as much information as you know into the other fields.
5. Click Search. A screen displays all users that satisfy the search criteria.
6. Check the box next to each user you want to add.
7. Click Save.

Maintaining AD user information
When AD integration has been established, new AD user information is imported to
Ektron when either of these events occurs:
l

the user logs in

l

someone clicks Refresh (

) on the user’s View User Information screen

Maintenance tasks include:
l

Editing. Because Ektron does not write to AD, you can only change some fields on
the Edit User screen. Edit read-only fields from AD.

l

Deleting. If a user is deleted in AD, Ektron does not delete the user. However, the
login fails because the user cannot be authenticated. To delete the user from
Ektron, use the Delete User function described in Deleting a user on page 1564.
If you mistakenly delete all users with administrative privileges, you can still sign in
using the builtin user’s username and password. For more information, see Editing
the builtin username and password on page 117.

l

Replacing. If you associate the wrong AD user with an Ektron user, you can
replace the user. If you do, all Ektron permissions and approval process
responsibilities transfer from the old to the new user.

1. Go to Settings > Users.
2. Click the user you want to replace.
3. Click Associate CMS User with Different AD User (

).

4. Select a user to replace the previously selected user.
5. Click Save. The first user is deleted from Ektron.

Importing AD user group information
This section explains how a user’s group membership is imported from AD to Ektron
after integration is enabled. When assigned to a group, the user automatically receives
all Ektron permissions and workflow responsibilities associated with it.
NOTE: Active Directory has 2 kinds of user groups: security and distribution. Ektron
does not distinguish between them. As long as a user is a member of either kind of
group, group information can be imported to Ektron.
Before using AD integration, import all AD groups you will use into Ektron:
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1. From the Workarea, choose Settings > User Groups.
2. Click Add Groups. The Search Active Directory for Groups screen appears.
3. From the Domain drop-down list, select the domain of the user group you want to
add.
NOTE: The Active Directory Setup screen can restrict AD integration to one
domain. If it does, you can only search within that domain.
4. Enter as much information as you know into the Active Directory Group field.
5. Click Search. A screen displays all groups that satisfy the search criteria.
6. Check the box to the left of each group you want to import to Ektron.
7. Click Save.

Importing a user’s AD group information to Ektron
Users' membership in AD Groups are imported to Ektron in different ways depending on
the state of existing Ektron user groups.
l

If CMS user groups already exist. If Enable automatic addition of user to
groups is checked on the Active Directory Setup screen, a user’s group
membership is imported from AD to Ektron when a user first logs in or is added. At
this time, any AD group memberships overwrite Ektron group memberships except
the Everyone group, to which all users belong.
In the case of a discrepancy between AD and Ektron user groups:
o

If a user belongs to an AD user group that does not exist in Ektron, no action is
taken. The AD Integration feature assumes that not all AD groups are
meaningful in Ektron.

o

If a user belongs to an Ektron user group that does not exist in AD, the
discrepancy is flagged on the Active Directory Setup and Active Directory
Status screens. From these screens, you can import AD group information into
Ektron.

o

If the user should belong to an AD group, add the group membership within
AD. Then, refresh the user on the View User Information screen to import AD
group information into Ektron.

l

If only default user groups exist in the CMS. Follow the procedure described
in Importing AD user information to Ektron on page 1601 to import AD user groups
to Ektron. Then, as users in those groups are added to Ektron, their group
memberships are applied.

l

After AD integration is enabled. a user’s group memberships in Ektron are
updated when all of the following are true.
o The Enable automatic addition of user to groups field is checked on the
Active Directory Setup screen.
o

A user is added to Ektron or the user's AD group membership changes.
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o

The user logs in or someone clicks Refresh (
Information screen.

) on the user’s View User

Alternatively, if Enable automatic addition of user to groups field is unchecked,
you can add the user to (or remove the user from) groups independently of AD group
memberships.

Mapping the administrator group
On the Active Directory Setup screen, you identify the AD group that maps to the
Ektron Administrator group using a syntax of AD group name@AD domain. Members of
this group receive administrator privileges.See also: Administrator role privileges on
page 1581.

If such a group does not exist in AD, create it, then assign it on the Active Directory
Setup screen.
Note that only one AD group can be mapped to the Ektron Administrator group. You
cannot have an AD administrator group within each AD domain.
NOTE: Unlike other Ektron user groups, whose names are imported from AD, the
Ektron Administrator and Everyone group names cannot be changed.

Maintaining AD user group information
Maintenance tasks include:
l

Removing users from a group. If you delete a user from an AD group, the user
is removed from the associated Ektron group the next time the user's information
is updated.

l

Adding user groups. If AD integration is enabled, you can only add user groups
in AD. Then log on to Ektron and use the Search Active Directory for Groups screen
to import the AD user group to Ektron as described in Importing AD user group
information on page 1602.

l

Adding a user to a group. You cannot add a user to a user group within Ektron;
you must do so in Active Directory.

l

Replacing a group. If you associated the wrong AD user group with an Ektron
user group, replace the user group.
1. From the Workarea, click Settings >User Groups.
2. Click the user group that you want to replace.
3. Click Associate CMS Group with Different AD Group (
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4. Select a group to replace the group you selected in Step 2.
5. Click Save.
l

Deleting a group. You can delete a user group from AD or Ektron. When deleting
user groups, consider the following behaviors:
o If you delete a user group in AD and users are assigned to the group in Ektron,
the group is not deleted in Ektron. However, any Ektron users who were
members of the group are no longer members the next time their Ektron
information is updated. The discrepancy is flagged on the Active Directory
Setup and Active Directory Status screens.
o

If you delete a user group in Ektron and users are assigned to that group
within AD, nothing happens. This is because AD Integration assumes that the
Ektron administrator only maintains user groups that are meaningful to
Ektron, and some AD groups are not meaningful to Ektron.

Disabling AD integration
When you disable AD integration, domain names are dropped, which may cause user
and user group names to not be unique. For example, 2 users are named
JJackson@example.net and JJackson@example.com. When AD is enabled, domain
names make the users and user groups unique. However, when AD is disabled and
domain names are dropped, the names are now identical. You need to make the users
and user groups unique.
To disable AD authentication or integration:
1. Go to Settings > Configuration > Active Directory > Setup. The Active
Directory Setup screen appears.
2. Enable the Disable Active Directory and LDAP Authentication radio button. If
any users or groups have the same name with different domains, the following
message appears: Active Directory Authentication is disabled, but needs
further configuration
3. Click the message. The Active Directory Status screen appears.
4. Click the CMS users need to be made unique message. The Make CMS Users
Unique screen appears.
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User group names are handled in the same manner. Click the CMS user groups
need to be made unique message. The Make CMS Groups Unique screen
appears.

5. Click Save to accept the suggested new names as recommended by Ektron. By
accepting the suggested name, you allow the software to automatically associate
AD and Ektron users or groups if you later decide to re-enable AD integration.

Implementing user authentication mode
In user authentication mode, AD is used only to authenticate users logging in to Ektron.
User groups are managed within Ektron, not AD.

Transferring user information from AD to Ektron
Ektron does not write to AD; it only reads from it. This changes how usernames,
domains, and passwords are handled in Ektron.
l

Changes to user logon name, domain and password must be made in AD. You
cannot update these fields in the Ektron Edit User screens.

l

When adding a new user to Ektron, you can only select AD users. If the user does
not exist in AD, create the user there and then import the user into Ektron.

Ektron refers to the following AD authentication information during sign-in: password,
user logon name, and domain. Ektron does not store the password; Ektron only refers
to it during sign-in.

Adding and maintaining user information
Adding user information in user authentication mode is the same as in AD integration
mode.
If a user’s logon name changes in AD, it no longer matches the Ektron logon name. This
discrepancy is flagged on the Active Directory Setup and Active Directory Status
screens. Go to the Associate CMS Users to Active Directory Users screen, where you can
update the user information.
Alternatively, you could:
1. Go to the View User Information screen.
2. Select the user whose AD name changed.
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3. Click Associate the CMS user with Different AD user (

).

4. Select the AD user and domain.
See also: Maintaining AD user information on page 1602.

Editing user information in Ektron
Ektron does not write to AD. This means that you can only change the Username and
Domain fields from AD. You can edit the following fields on the Ektron Edit User
screen:
l

First Name

l

Last Name

l

E-Mail Address

l

User Language

l

Disable Receiving of Workflow and Task Email

IMPORTANT: If you replace a user in user authentication-only mode, the user’s
first name, last name, and email address are not overwritten with information in AD.

Using AD integration screens in user authentication mode
Because the scope of user authentication mode is limited to authentication, only some
fields on AD Integration screens are used:
l

On the Active Directory setup screen, the only relevant fields are authentication
and domain. See also: Setting up Active Directory on page 1595.

l

On the Active Directory Status Screen, only one discrepancy message may appear:
CMS user needs to be associated with an AD user
See also: Maintaining AD user information on page 1602.

l

The View Users Screen works the same for both modes. See also: Viewing and
searching for users on page 1599.

Logging into a system that uses AD integration
Because AD usernames and passwords are stored by domain, the AD sign-on procedure
requires the user to select a domain. When AD integration is enabled, the sign-on
screen includes a domain drop-down list.

Single sign on
The single sign on feature retrieves a user’s Active Directory login information to
authenticate access to Ektron. The user does not need to enter a password. Upon
clicking Login, the user is immediately logged in.
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Single sign on uses a variable called User.Identity.Name. This maintains the user's
account and domain in Active Directory and has the format [domain]\[username]. For
example, EKTRON1\ssmith. The variable's value is set when a user authenticates
against a Windows server.
When a user clicks the Login server control, if the variable passes successfully and
Active Directory is enabled, the server control opens the autologin.aspx page. Next,
the opening window refreshes like a normal login, except the user is not prompted for a
username, password, and domain.
However, if the user‘s computer is not on a domain, not on the same domain as Ektron,
or does not include the Ektron server as a trusted site, a login screen appears.

If Active Directory is not enabled, the normal login.aspx page appears.
Single sign on also uses the autologin.aspx page in the workarea/SSO directory.
When set up, user authentication is enabled from any domain that this server can
reach. For example, if Ektron is located in a third-level domain, users from third,
second, and first level domains can authenticate.
NOTE: Single sign on may not work directly on servers, due to security settings on
the server and its browser. Try a different machine and make sure it works
elsewhere before troubleshooting further.
After completing the procedures in this section, enable Active Directory within Ektron (if
it isn’t already enabled). See also: Setting up Active Directory on page 1589. Within
that, enable the automatic addition of users and groups.

Enabling membership users for single sign on
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To allow membership users to use single sign on, see Authenticating membership users
with AD or LDAP on page 1622. When enabling this functionality, create one login page
for Ektron users and another for membership users. For example, use the membership
user login as the front-facing login, and then secure a /cmslogin.aspx for Ektron
users. Next, secure the login with IIS security because Windows authentication only
allows the Ektron administrators group in AD to read permissions on the
/cmslogin.aspx page.

Setting up single sign on
Follow these procedures to set up single sign on.

Modifying web.config for single sign on
1. Open site root/Web.config.
2. Find the ek_AUTH_protocol element and change its value to LDAP.
<add key="ek_AUTH_Protocol" value="LDAP" />

3. Find the authentication element and change the value of authentication mode
to Windows.
4. Change the value of impersonate to False.
<authentication mode="Windows" />
<identity impersonate="false" userName="" password=""/>

5. If you want to allow membership users to authenticate using single sign on, set ek_
LDAPMembershipUser to true.

Adjust security on the site root folder
1. Go to Start menu > Administrative Tools > Internet Information Services.
If you're using Windows 8 or 2012, click the Windows key (
INETMGR.

)/Q the enter

2. Go to Sites and select your Ektron site.

Ektron Reference

1609

Managing users and user groups

3. From the center panel, select Authentication.

4. On the Authentication screen, enable Anonymous Authentication.

Adjust security for autologin.aspx
1. Verify that Windows Authentication is installed on this server.
a. Click Windows Start menu > Administrative Tools > Server Manager.
b. Click Roles > WebServer (IIS) Role Services > Security > Windows
Authentication.
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c. If the status of Windows Authentication is Installed, proceed to Step 2.
If the status of Windows Authentication is Not Installed, click Add Role
Services. The Add Role Services screen appears.
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d. Check Windows Authentication.
e. Click Next and follow the prompts to install Windows Authentication.
f. Close Server Manager.
Windows 8 or 2012
a. Press the Windows key (

)/Q.

b. Enter Windows Features.
c. Open Internet information Services > World Wide Web services > Security.
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d. Check Windows Authentication.

2. Open IIS Manager.
3. Go to Sites > your website’s root folder > Workarea > SSO and right click
Switch to Content View.
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4. In the center panel, right click autologin.aspx and select Switch to Features
View.

5. In the center panel, click Authentication.
6. From the center panel, check the status of Windows Authentication. If it is
disabled, enable it by selecting it, right clicking, and choosing Enable from the
menu.
Windows Authentication passes credentials from the client’s browser to IIS
then to Active Directory, allowing auto logins.
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7. From the center panel, check the status of Anonymous Authentication and
Forms Authentication. If either is enabled, disable it by selecting it, right
clicking, and choosing Disable from the menu.

Updating the Login server control for single sign on
This sample shows how to modify the Login server control to accommodate single sign
on.
<cms:login runat="server" AutoLogin="True"
AutoAddType="Author" id="cmslogin" />

Using Active Directory in a multi-site environment
If you want to use Active Directory in a multi-site environment, set the value of the
siteroot\web.config element ek_allowMultipleDomain to true. When this setting is
enabled, a user can log into one site then immediately access other sites without having
to log in again.
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If subdomains are deeply nested (for example, uk.store.mycompany.com), Ektron may
be unable to identify the parent domain. In this case, users cannot use single sign on to
access subdomains.
If that happens, use the siteroot\web.config element ek_UseDomain to explicitly
specify the parent domain. Precede the parent domain value with a period (.). For
example, <add key=”ek_UseDomain” value=”.mycompany.com” />.

Troubleshooting user login with single sign on
When troubleshooting user login with single sign on, use the following code-behind. If
this .NET code cannot get the user login, then Ektron cannot either.
Response.Write("UserName:" & Request.ServerVariables
("LOGON_USER"))

Active Directory and eSync
An Active Directory configuration does not get synchronized.
In an eSync environment, add all users to one environment. Then, sync the users if
multiple servers are using AD login.

Using LDAP with Ektron
Lightweight Directory Access Protocol (LDAP) is a set of protocols that enable the
hierarchical arrangement of corporate directory entries in a structure, which may reflect
geographic or organizational boundaries. Active Directory and LDAP are not the same.
While they perform similar functions, LDAP (when used with Ektron) only verifies login
information and creates the user in the Everyone group.
Ektron's LDAP feature lets you retrieve user login information from an LDAP server. As a
result, you can administer user information from one place, and users only need to
remember one password/username combination to sign on to the network and Ektron.
The hierarchical structure of LDAP authentication can be organized in several different
ways. For example, with the following LDAP structure, the domain would typically span
multiple countries.
NOTE: Abbreviations: CN = Common Name, OU = Organizational Unit, O =
Organization, C= Country, DN = Distinguished Name.
CN=j_smith, OU=Sales, O=MyCompany, C=US, DN=example.com
By changing the order of C and DN, the hierarchy indicates that the domain
example.com is located in the US.
CN=j_smith, OU=Sales, O=MyCompany, DN=example.com, C=US.

1616

Ektron 9.40 SP1

Enabling LDAP

In some instances, it may be necessary to have an Organization appear below an
Organizational Unit. For example, your Organizational Unit has it own Organizations.
The following image shows a sample LDAP hierarchical structure.

Enabling LDAP
You enable LDAP by editing the web.config file and editing settings on the Active
Directory Setup screen. See also: Setting up Active Directory on page 1595.
IMPORTANT: Before enabling LDAP in Ektron, make sure your LDAP server is ready
for use and include an Ektron administrator account for yourself. After you enable
LDAP, only the BuiltIn account can access Ektron without LDAP authentication. See
also: Editing the builtin username and password on page 117.
1. In the siteroot\web.config file, change the ek_AUTH_Protocol property to GC:
<add key="ek_AUTH_Protocol" value="GC"/>
2. Go to Settings > Configuration > Active Directory > Setup. The Active
Directory Setup screen appears.
3. Click Edit.
4. Select Enable LDAP Authentication.
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5. Complete the LDAP-related fields and click Update.
l Type. Choose the type of LDAP authentication you are using. Depending on
your choices, the fields below may be required or disallowed. The following
choices are available:
o Active Directory (LDAP). Domain allowed, Organization is not. For
more information, see Using LDAP to connect to Active Directory below.
o

Novell eDirectory/NDS. Organization allowed, Domain is not.

o

Sun Iplanet/JSDS. Domain allowed, Organization is not.

o

Other. Allows Domain and Organization

l

LDAP Server. The IP address or name of the LDAP server.

l

Port. The LDAP server port with which Ektron communicates. If you are
unsure of the port number, consult your Directory Service documentation .

l

Organization. The name of your company or organization. For example,
Optimizely You can leave this field blank if you enter a domain in the Domain
field.

l

Domain. Your domain name. For example, www.ektron.com. This should be
the name you used when purchasing your license key. You can leave this field
blank if you enter an organization in the Organization field.

l

Attribute. Enter the key value used to reference accounts inside LDAP. As
examples: dn, sn, cn, uid, and so on.

l

Use SSL. Check if you want to enforce a secure connection in traffic to the
LDAP server.

l

Path. The next levels below your Organization or Domain. These can include
multiple levels of Organizational Units. For example, Content Editors,
Marketing, East Coast. Click the Expand link to display the Add field.

l

Add. Enter the path to which you would like access in the text field. Then click
the Add link.
When adding Organizational Units, paths are comma-separated and run from
specific to general. For example, ou=Amherst,ou=New Hampshire,o=US. For
more information, see Adding an organizational unit during setup on the facing
page.
Do not add individual Common Names here. Only add Organizational Units
that contain people who should have access to Ektron. To add a single
individual from a different Organizational Unit, see Adding user information
from an LDAP server to Ektron on the facing page

NOTE: You can add additional Organizations below an Organization Units as long as
the path on your LDAP server is the same.

Using LDAP to connect to Active Directory
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1. In the \web.config file, add the Username and Password for ek_ADUsername and
ek_ADPassword. For example:
<add key="ek_ADUsername" value="mwright@ektron.com" />
<add key="ek_ADPassword" value="mypasswordisthis" />
2. Go to Settings > Configuration > Active Directory > Setup. The Active
Directory Setup screen appears.
3. Click Edit.
4. Use the following settings in the Active Directory Setup screen.
l Type. Active Directory (LDAP)
l

LDAP Server. [IP Address of the AD domain controller]

l

Port. 389

l

Organization. [leave this blank]

l

Domain. [dns name of the AD domain]. For example: internal.domain.com

l

Path (Organizational Units). [any OUs that you want to draw users from]
For example: Support, Users, Ektron Corporate or Engineering, Users, Ektron
Corporate

Adding an organizational unit during setup
Considerations when adding Organizational Units:
l

Should everyone in the OU have access to Ektron?

l

When LDAP is enabled, users are added to the Everyone group upon login. While
everyone in the OU has access to Ektron, every user should not necessarily have
permission to edit content. To control permissions, set up user groups, add users
to groups, and assign permissions to the groups. See also: Managing users and
user groups on page 1555 and Managing folder and content permissions on
page 168.

l

Do users in other Organizational Units need access?

l

Sometimes, managers or editors are in a different OU. They need to be added
manually, or you need to add their OU.

l

When adding an Organizational Unit, several entries might cover the same
hierarchical path. For example, you might have
ou=Sales, ou=Sales_Service, and ou=MyCompany, which lets you authenticate
users listed in Sales, Sales_Sevice, and MyCompany.

Adding user information from an LDAP server to Ektron
Users at each level are automatically available for adding to Ektron. You do not have to
be at the OU or CN level to add a user. If a user is at the DC or OU level, they are
available.
After LDAP is enabled, there are several ways to add LDAP user information to Ektron:
Ektron Reference
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l

The user logs in. As a result, the user appears in the Users list and is added to the
Everyone group. After a user logs in, some fields on the Add User screen can be
filled in manually, such as first and last name. For a description of these fields, see
Manually adding an LDAP user on the facing page.

l

Search an LDAP server for LDAP users.

l

Add the user’s LDAP information manually.

l

A combination of searching and manually completing the remaining fields.

Searching an LDAP server for users
PREREQUISITE

LDAP is enabled. See Enabling LDAP on page 1617.
To search for a user on an LDAP server and add the user to Ektron:
1. From the Workarea, go to Settings >Users.
2. Click Add Users. The Add a New User to the System screen appears
3. Click Browse LDAP (

). The Search LDAP Users screen appears.

4. Enter one or more search criteria.
l Username. Username of the user on the LDAP server.
l

Firstname. First name of the user on the LDAP server.

l

Lastname. Last name of the user on the LDAP server.

l

Path. Select a path from the drop-down list. These paths were enabled when
you configured Ektron for your LDAP server. If you select a path and enter no
other information, you get all users in that path.

5. Click Search. The search returns users that match the submitted criteria.
6. Check each user to be added.

7. Click Save. The user is added to Ektron and the Everyone group. To assign the user
to another user group, see Assigning a user to a user group on page 1565.
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Manually adding an LDAP user
PREREQUISITE

LDAP is enabled. See Enabling LDAP on page 1617.
1. Go to Settings > Users.
2. Click Add User. The Add a New User to the System screen appears.
3. Fill out the fields according to Creating a user on page 1556.
4. Click Save. The View Users in Group Everyone screen appears, displaying the new
user and the other Ektron users. To assign the user to another group, see
Assigning a user to a user group on page 1565.

Using the Browse feature to add an LDAP user
The Browse LDAP feature provides a friendly and intuitive way to find usernames,
domains/organizations and organizational units.
IMPORTANT: The default server IP/DNS name and port are taken from the settings
specified in the Configuration > Setup page. These settings must be specified
before connecting to the LDAP server.
Before using the browse feature, you must specify an Organizational Unit that can
see the user in the Configuration > Setup page.
PREREQUISITE

LDAP is enabled. See Enabling LDAP on page 1617.
1. Go to Settings > Users.
2. Click Add Users. The Add a New User to the System screen appears.
3. Click Browse LDAP (

). The LDAP Explorer appears.

4. Go the LDAP server’s folders by clicking on the folder images. Each folder
represents an Organizational Unit (OU). When you choose an OU level, its users
appear.
NOTE: In the LDAP Explorer, the Path and Org/Domain fields update
dynamically as you go through the LDAP tree.
5. Select a user. The user is added to Ektron and the Everyone group. To learn how to
assign this user to another group, see Assigning a user to a user group on
page 1565.

Editing LDAP user information
It is important to note that Ektron does not write to the LDAP server. So, while you can
change fields when editing a user in Ektron, you also need to make the same changes
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on the LDAP server.
1. Go to Settings > Users.
2. In the Username column, click a user to edit. The View User Information screen
appears.
3. Click Edit.
4. Change the information as needed. For more information on the fields you can edit,
see Creating a user on page 1556.
5. Click Save.

Deleting users
If a user is deleted on the LDAP server, Ektron does not automatically delete the user.
However, the user’s login fails because the login cannot be authenticated. In this case,
delete the user from Ektron using the Delete User function.
NOTE: If you mistakenly delete all users with administrative privileges, you can still
sign in using the builtin user’s username and password. See also: Editing the builtin
username and password on page 117.

Authenticating membership users with AD or LDAP
Usually Membership users are not included in AD or LDAP directories. Ektron's default
settings ignore AD or LDAP f or membership authentication. If you want Membership
users to authenticate with AD or LDAP, follow these steps.
1. Edit the siteroot\web.config file.
2. Set LDAPmembershipUser to true.
<add key "ek_LDAPMembershipUser" value="true" />
If ek_LDAPmembershipUser is false, membership users are not authenticated with
AD or LDAP.

Disabling LDAP authentication
To disable LDAP authentication or integration, edit the Active Directory Setup screen
and select Disable Active Directory and LDAP Authentication.
See also: Setting up Active Directory on page 1595.
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A community is a group of people who network with each other to share information,
ideas, likes and dislikes. Typically, community members are connected by a
relationship. For example, they work for the same company, went to the same school,
share values, or have a friendship.
When you visit a community site, look around to see the kind of information, people and
groups on the site. Typically, you can see only limited information initially. To see all
information, you need to become a member. When you sign up to be member, you
enter information about yourself in a member profile. After becoming a member, you
can:
l

maintain a personal profile, including an avatar

l

search for other members and add them to a friends list

l

join or create a community group

l

invite non-members to join a community and become a friend

l

add photos and documents to a personal or group profile page

l

determine which other users and groups can view and update those files

l

update your status and share that update with selected members

l

post public or private messages to another member’s message board

l

keep a journal

l

create a list of favorite Ektron content links

l

have a list of content that you have added

l

write content reviews

l

flag content

Ektron's Community Platform feature lets users network socially on a website. Access to
the community platform is available from the website or the Workarea, but only Ektron
users and administrators can access their information via the Workarea. Administrators
can manage Community Platform features from the Workarea. Membership users,
Ektron users, and administrators can access their profile pages via a website.
This section also contains the following topics.
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l

Membership users and groups on the facing page

l

Accessing a user profile on page 1643

l

Moderating a message board on page 1644

l

Managing community groups on page 1651

l

Distributing content to another Ektron folder on page 1658

l

Sending notifications to a community on page 1665

l

Generating email invitations for community management on page 1703

l

Activity streams on page 1708

l

Using Ektron's micro-messaging bookmarklet on page 1728
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l

Defining flags for content on page 1717

l

Tagging content, library items, users, and groups with keywords on page 1723

To learn about the server controls that let membership users log into an Ektron site, see
Community Server Controls.

Membership users and groups
Membership users have limited privileges to Ektron. Unlike regular Ektron users, they
cannot use the Workarea. When membership users log in, they can view, add and edit
content from the website (as permitted) only—all other functionality is disabled.
Membership users can be allowed to view private content. This is helpful if your
organization has partners who need access to Web pages that should not be visible to
the general public. See also: Making content private on page 695.
If you have a Social Network or Community website, membership users can create an
online area for themselves.
PREREQUISITE

To work with membership users, you must be a member of the
Administrators group or assigned to the member admin role. See also:
Defining roles on page 1581.

Membership privileges
A typical membership scenario is a Partners section of your website that contains
private content for partners only. Set up a membership user group with users from your
partner’s organization. The group is given add and edit permissions to the Partners
section.
Membership privileges are:
l

Create, edit, and view content after log in

l

Subscribe to receive Web Alerts See also: Sending Web Alert emails to subscribers
on page 1481

l

View private content

l

Use these Community features See also: Managing user communities on
page 1623
o Share Document Workspace and Photo Gallery with other site visitors
o

Join a community group

o

Mark content the member likes and allow site visitors to see the list of these
Favorites

o

Designate other members or site users as Colleagues

o

Keep a Journal
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o

Add and read Message Board comments

o

Send and receive messages with other registered users

o

If a Discussion Board requires sign in, they can view and post to them. See
also: Working with discussion boards on page 1013

l

Post blog comments. See also: Working with blogs on page 963

l

If a poll or survey is set up to track participating users, membership users’ names
appear on Form reports.

Viewing membership users
Use the Membership Module folder to add and edit membership users and user groups.
1. Go to the Workarea > Settings > Community Management >
Memberships.
2. From that folder, you can access the following screens.
l Users. You can sort the Username, Last Name, and First Name columns by
clicking column headers.
l

Users not Verified. A site visitor can sign up to be a membership user. Setting
up a subscription on page 1502

l

User Groups. Membership groups on page 1633

NOTE: The ek_PageSize setting in the web.config file determines the maximum
number of users that can appear on a page before it “breaks.” When a page breaks,
additional entries appear on another screen, and the following text appears near the
bottom of the list:
Page 1 of 2 [First Page] [Previous Page] [Next Page] [Last Page]

Adding membership users
Follow these steps to create a membership user. Alternatively, you can set up a Web
page that lets membership users self-subscribe. SeeAllowing membership users to selfsubscribe on page 1629.
1. From the Workarea, click Settings > Community Management >
Memberships > Users.
2. Click Add Membership User. The Add Membership User screen appears.
3. Complete the form using the following for reference.
l Username. Enter a unique username for the membership user.
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l

First Name. Enter the first name of the user.

l

Last Name. Enter the last name of the user.

l

Display Name. The name used to identify a Membership user on the website.
This can be different from the Username, which is the name you use to log into
the Ektron website.
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IMPORTANT: This name needs to be unique inside Ektron and it cannot be
blank.
l

Password. Enter a password for the user. See also: Ektron's password
security policy on page 118

l

Confirm Pwd. Re-type the password to confirm it is correct.

l

User Language. Select the language in which the user viewsEktron screens
and messages. The language also determines the default value whenever a
drop-down list of languages appears within Ektron. The drop-down list of
choices at this field is derived from the Language Settings screen, available
from the Settings > Configuration folder. Do not confuse the system
language with the user’s ability to create and edit foreign editions of content.
This field does not prevent a user from working with multiple language
content. See also: Working with multi-language content on page 1507. If the
selected language is not English, French or German, it is only supported after
you download the Ektron Language Support Program from Ektron and
translate the website.

l

Email Address. Enter the user's email address.

l

Forum Editor. Determines which editor is used when this user replies to a
Discussion Board. See also: Managing a discussion board on your website on
page 1049

l

Avatar. Click Click to upload your Avatar and choose an image file for your
profile. By default, an avatar's maximum file size is 200 kilobytes. Also, the
avatar's height and width cannot exceed 125 pixels preserving the aspect
ratio.

l

Address. The address used to find your location when a user is performing a
search based on location.

l

Latitude. The latitude used to find your location when a user is performing a
search based on location. Google maps provides a service that takes the
address of user and returns its latitude and longitude. You don’t need to use
Google’s automatic retrieval of latitude and longitude. Instead, you can enter
the values manually.

l

Longitude. The longitude used to find your location when a user is performing
a search based on location. Google maps provides a service that takes the
address of content and returns its latitude and longitude. You don’t need to
use Google’s automatic retrieval of latitude and longitude. Instead, you can
enter the values manually.

User Groups Tab (Tab only appears when editing). Lists user groups to
which the user belongs. See also: Assigning a user to a user group on page 1565.
l

Custom Tab. Lists any custom user properties. See also: Creating custom
user properties on page 1568.
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Activities Tab (Tabs only appear when editing)
NOTE: If you disable Notifications, the Activities tab (which lets the user pick
Notifications to receive and send) disappears.
l

Colleagues Sub Tab. Select the notifications you want to receive when a
colleague performs an activity, and the agent that transmits the notification.
For example, if you want to receive email notifications when a colleague posts
a blog message, you would place a check mark in the box for Blog Post in the
email column. See also: Sending notifications to a community on page 1665.

l

Community Groups Sub Tab. Select notifications you want to receive when
a member of a community group performs an activity relating to the group,
and the agent that transmits the notification. For example, you want to receive
email notifications when a community group member posts a blog message to
group’s blog. To enable this, place a check mark in the box for Group Blog
Post in the email column. See also: Sending notifications to a community on
page 1665.
This tab sets preferences for all community groups.
For Developers:Ektron has created a UserGroupPreferences user control. If
you add the control to a community group’s profile page, users can specify
notification preferences for individual groups. This control comes with Ektron
and is located in:
[Drive:]\webroot\siteroot\Workarea\Notifications\Controls

In this site, when a logged-in member of a community group accesses the
group’s profile page, there is an Edit Group Notifications Preferences link.
Clicking this link opens the user control. When you select your preferences,
they are stored for that group only.
l

My Activities Sub Tab. Select notifications you want publish when
performing various activities on the website. For example, if you want to
publish notifications when you post a blog message to your blog, place a check
mark in the box for Blog Post in the Publish column. See also: Sending
notifications to a community on page 1665.

Profile Links Tab. Lists the user's alias if community aliasing is set for users. See
also: Types of URL aliasing on page 1400.
4. Click Save.

Deleting membership users
1. From the Workarea, click Settings > Community Management >
Memberships > Users.
2. Check the boxes next to the users you want to delete.
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3. Click Delete (

).

4. Click OK.

Allowing membership users to self-subscribe
A developer can create a Web page that lets site visitors sign up to become
membership users. (See the following example.) Interested users complete the form in
order to participate in membership activities, such as community groups and message
boards.

To place this form on a Web page, a developer inserts a Membership server control,
setting the DisplayMode property to User Registration.
NOTE: The email address is used as the membership Username field.
What happens next depends on the Enable Verify email check box on the Application
Setup screen's Workarea tab (shown in the following image). See also: Modifying
setup information on page 129.

l

If the Enable Verify email box is not checked, a site visitor who completes the
form becomes a membership user.

l

If the Enable Verify email box is checked, a site visitor who completes the form
is placed on the Users Not Verified list. These users receive an email asking them to
confirm their registration. Upon confirmation, the site visitor becomes a
membership user. At the same time, an Ektron administrator can review the Users
Not Verified list and either activate members or delete users from the list. See
also: Verifying a new subscriber on the next page.
Ektron provides default text for the confirmation email. To customize the text, see
Customizing the verification message on the next page.
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IMPORTANT: When using the Checkout server control on an eCommerce site, the
Enable Verify Email setting must be unchecked. Otherwise, new users will receive
an error message when they sign-up using this control. See also: Checkout.

Verifying a new subscriber
If site visitors sign up to become membership users and verification is required, they
appear on the View Not Verified Users screen (Settings > Community Management
> Memberships > Users not Verified).
As explained in Allowing membership users to self-subscribe on the previous page,
these users can confirm their registration and become membership users. Or, you can
activate their membership by checking them on View Not Verified Users screen and
clicking Activate Users. Alternatively, you can delete unverified members by checking
them and clicking Delete (

).

NOTE: The ek_PageSize setting in the web.config file determines the maximum
number of users that can appear on a page before adding another page with the
following navigational links:
Page 1 of 2 [First Page] [Previous Page] [Next Page] [Last Page]
To select all members, check the box next to Username.

You can also change the way membership users are sorted, or use the Search button to
find users that match your criteria (for example, users whose username includes
example.com.)

Customizing the verification message
You can customize the message that prompts site visitors to confirm their interest in
becoming a membership user. This message is sent after a site visitor completes the
membership form if the Enable Verify email checkbox is checked. See also: Allowing
membership users to self-subscribe on the previous page.
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The message should direct prospective members to your website's activateuser.aspx
page, where they are asked to confirm their interest in becoming a member. This
prevents people from becoming members without their permission.
PREREQUISITE

To complete Step 8, you must be a developer.
To customize the verification message:
1. Go to Workarea > Settings > Community Management > Messages.
2. Click Add Email Message.
3. Assign a title to the message, such as Verification Message.
4. In the Type drop-down, select Verification.
5. Click the check mark in the Default box.
6. In the Subject field, enter a subject line for the message.
7. Enter the message. Insert the @appQueryLink@ variable in the message to create a
link to the confirmation page. For example:
Welcome to example.com. You registered to be notified of updates
to our site. Before we can do this, you need to activate your
account. To do so, please visit @appQueryLink@.

The @appQueryLink@ variable gets resolved as follows (one line):
http://sitepath/workarea
/activateuser.aspx?uid=[username]&acc=[accountID]

For example (one line):
http://www.example.com/Workarea
/activateuser.aspx?uid=john.edit@example.com&acc=ce5w84o936477

You can insert the following membership user variables into the message.
l

@appEmail@. email address

l

@appActivateId@. account ID

l

@appUserName@. username

l

@appFirstName@. first name

l

@appLastName@. last name

l

@appDisplayName@. display name

l

@appAvatar@. avatar

l

@appSignature@. signature

l

@appQueryLink@. link to confirmation page, as described above

8. On the activateuser.aspx page, your developer places a Membership server
control. Set the control’s DisplayMode property to AccountActivate.

Activating other membership actions
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You can set up Web pages to let membership users perform these actions:
l

Activate their account

l

Reset their password

l

Unsubscribe

To create these pages, place a Membership server control and use the DisplayMode
property to determine the mode in which the form appears. For example, to create a
reset password form, set DisplayMode to ResetPassword.
See also: Membership server control, Ektron Knowledge Base article "Changing the
Membership User Password Reset Message"

Searching for membership users
If there are many membership users, use the search to find users who meet your
criteria. For example, find members whose username includes @example.com. Only
users with those characters in that sequence in their username, first name, or last
name appear. The search is case-insensitive, so MI produces the same results as mi.
You can also search by First and Last name.

Troubleshooting membership users and groups
If you get the following error:
Response object error 'ASP 0251 : 80004005'
Response Buffer Limit Exceeded
Increase the limit as follows:
1. Stop IIS.
2. Locate the file %WinDir%\System32\Inetsrv\Metabase.xml
3. Modify the AspBufferingLimit value. The default value is 4194304, which is about 4
MB. Changing it to 20MB (20971520).
4. Restart IIS.
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Membership groups
You can use a membership group to group similar membership users, reducing the
effort required to assign identical permissions to many users.
IMPORTANT: Membership Groups and Community Groups are different concepts.
Community Groups let users with similar interest join together in a social networking
environment. See Managing community groups on page 1651.
To make friendly URLs that are easy to use and remember for a community user and
group, Ektron provides a Community URL Aliasing feature. See Types of URL aliasing
on page 1400 for more information.
NOTE: Membership users may also be managed with Active Directory and LDAP. For
more information, see Authenticating membership users with AD or LDAP on
page 1622.
PREREQUISITE

To work with membership users, you must be a member of the
Administrators group or assigned to the member admin role. See also:
Defining roles on page 1581

Viewing users in a membership group
1. From the Workarea, click Settings > Community Management >
Memberships > User Groups.
2. Click the membership user group you want to view. The View Users In Group
screen appears.

Adding a membership group
1. From the Workarea, click Settings > Community Management >
Memberships > User Groups.
2. Click Add Membership Usergroup. The Add a New User Group screen appears.
3. Enter a unique name for the group, and optionally add a description.
4. Click Save.

Deleting a membership group
1. From the Workarea, click Settings > Community Management >
Memberships > User Groups.
2. Select the group you want to delete. The View user in Group screen appears.
3. Click Delete (

).

4. Click OK.
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Adding users to a membership group
NOTE: Only membership users can be added to membership user groups.
1. From the Workarea, click Settings > Community Management >
Memberships > User Groups.
2. Click Add Membership User. The Add User to Group screen appears.
NOTE: Only membership users who do not already belong to the group appear.
3. Click the user you want to add.
4. Click Save.

Deleting users from a membership group
1. From the Workarea, click Settings > Community Management >
Memberships > User Groups.
2. Click the name of the membership user you want to remove. The View Users
screen appears.
3. Check the boxes next to the users you want to delete.
4. Click Delete (

).

5. Click OK.

Assigning membership permissions
After you create membership users and groups, you can assign them permissions for
Community folders only. See also: Community folders on page 1639
1. Access the Permissions screen for the content or folder to which you want to assign
membership permissions.
l Content folders—Managing folder and content permissions on page 168
l

Content—Setting permissions for content on page 173

2. If necessary, break the inheritance for the content or folder.
3. If desired, set the folder or item to Private. See also: Making content private on
page 695
4. Click View Membership Users on the right side of the Permissions screen. The
membership users/user groups added to the Permissions screen appear.
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5. Click Add. The Add Permissions screen appears.
6. Click a username or user group name to add to the Permissions screen. The Add
Permissions Options screen appears.
7. Check appropriate permissions for the membership user or group.
8. Click Save.

Assigning templates to groups and members
Ektron's Community Management feature supports both community and individual
member pages. Like other Ektron content, Community Management content appears
on a dynamic Web page. Page templates determine each page’s layout and location of
elements (menus, content, blogs, and so on). The following samples show the
Community Management template.
Sample group template in Visual Studio.NET

Sample group template on a Web page

Ektron Reference

1635

Managing user communities

The Community Management feature includes six templates:
l

l

Community Group
o documents
o

photos

o

journal

User
o documents
o

photos

o

journal

Ektron provides a sample for each template. You can use the sample or create your
own. If you begin with a sample template and modify it, be sure to save it under a
different name to prevent it from being overwritten when you upgrade.
Use the Workarea Settings > Community Management > Templates screen to
assign templates to Community Management pages.
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Group templates
l

Community Document. Page hosts the CommunityDocuments server control;
ObjectType property is set to Group

l

Photo Gallery. Page hosts the PhotoGallery server control; ObjectType property
is set to Group

l

Journal. Page hosts the Blog server control, and the blog was created for a group
page

l

Profile. Page that hosts a CommunityGroupProfile server control.
Note, however, that a site visitor, while viewing a page, may click an icon to visit a
community group profile from there.
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In this case, if the original control has a TemplateUserProfile defined, that value
overrides this field and defines the template in which the community group profile
appears.
User templates
l

Community Document. Page hosts the CommunityDocuments server control;
ObjectType property is set to User

l

Photo Gallery. Page hosts the PhotoGallery server control; ObjectType property
is set to User

l

Journal. Page hosts the Blog server control, and the blog was created for a user
page

l

Profile. Page that hosts a User Profile server control.
Note that a site visitor may click a user icon to visit a user profile from another
page.
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In this case, if the original control has a TemplateUserProfile property value
defined, that value overrides this field and defines the template in which the user
profile appears.

Community folders
Community folders resemble regular folders in most ways. The only difference is that
membership users can add and edit content in these folders only. Community folders
have a unique icon, which looks like 2 people (
).
Membership users add and edit Community folder content after signing in to the
website. They do not use the Workarea to add or edit content.
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NOTE: Authorized Ektron users can also create and update Community folder
content.

Creating a community folder
1. In Workarea > Content, go to the folder in which you want to create the
community folder.
2. Select New > Community Folder. Alternatively, you can hover the cursor over
the folder, right click the mouse, and choose Add Community Folder.
3. Assign properties as you would any other folder. See Adding a folder on page 157
NOTE: The folder properties screen lets you require metadata for any content
item. However, membership users cannot enter metadata. Therefore, this
requirement is ignored when membership users edit community folder content.
If an Ektron user tries to edit that content, the user is required to enter a
metadata value.

Assigning permissions for a community folder
Because Community folders are intended for membership users, this section explains
how to assign permissions for them. To assign folder permissions for regular users, see
Managing folder and content permissions on page 168.
1. Go to the folder.
2. Choose View > Properties.
3. Click View Permissions (

).

4. If necessary, uncheck the Allow this object to inherit permissions checkbox.
5. Click User Type: Membership Users.

6. Click Add Permissions.
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7. Select the membership user or group to which you want to assign permission for
this folder.
8. Check the permission boxes as appropriate.

Adding and updating assets as a membership user
First, your developer must create a template, then drop an Asset server control onto it.
While adding the Asset Server Control, the developer specifies Add at the Upload
Type property, and the community folder to which the asset will be saved at the
DefaultFolderID property.
When a membership user is authorized to add content goes to the page with the server
control, the person sees an Asset control area like the one that appears when Ektron
users add assets. The user then can drag and drop assets into Ektron.

To update an asset, your developer adds the Asset Server Control, as previously
described, but specifies Update at the Upload Type property, and a community folder
to which the asset will be saved at the DefaultFolderID property. Then, the developer
specifies an asset ID number at the DefaultAsset ID property. Using that control, the
membership user can update the identified asset only.

Additional information about administering assets is found in Working with assets in the
Document Management System on page 708.

Viewing and editing community folder content
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When a user with Read-only or higher permission goes to a page whose content is in a
community folder, the user can view it. If the user has edit permission, a menu
appears.

WARNING! Membership users can edit only HTML content and assets. They cannot
edit other content types (HTML forms, Smart Forms, and so on).
When a membership user clicks Edit (
editor.

), a new window displays the content within an

Other membership buttons are View History (

) and Log out (

).

This editor has fewer capabilities than Ektron’s editor. However, a membership user can
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l

l
l

add images and files via library ( ) if the membership user has Add Images and
Add Files permission. See also: Working with the library on page 733
add a wiki using page link( ). See also: Using the wiki feature on page 2077
assign a taxonomy category to the content by clicking the Category tab. See also:
Organizing content with taxonomies on page 1357

NOTE: The Category tab only appears if a Taxonomy is applied to the content’s
folder.
l

replace the content summary with the first 40 words of the content, using the Auto
Generate New Summary check box. See also: Automatically creating a
summary on page 694

When a membership user finishes editing, the user clicks Publish. If the content’s
folder has a workflow, the content’s status changes to Submitted, and the border color
changes to yellow. If there is no workflow, the content is published.

Accessing a user profile
A profile stores and maintains information about a user.
l

An Ektron developer inserts a profile on a page using the UserProfile server control.

l

A membership user can access his or her profile page only from the website.

l

An Ektron user can access his or her profile from the Workarea or the website. Go
to Settings > Users. See Managing users on page 1556.
IMPORTANT: For Ektron users, some profile information in the Workarea’s
View User Information screen is not available on the website profile page.
That information involves Workarea settings.

l

An administrator can access user profiles from the Workarea. Go to Settings >
Community Management > Memberships > Users. See Membership users
and groups on page 1625.

Ektron Reference

1643

Managing user communities

Moderating a message board
A Message Board can be moderated, which means that comments and replies must be
approved by an authorized user before they appear. Those users can either approve or
delete the comment/reply. To learn which users are authorized to moderate, see Who
can moderate message board on page 1646.
You can force all message boards associated with a MessageBoard control to moderate
comments/replies. To do this, set the Moderate property to True. On the other hand,
you can allow the Message Board owners to decide if it will be moderated. To do this,
set the control’s Moderate property to False. If you do, users determine if their
Message Board is moderated by checking their user or group profile’s Moderate check
box.

Community group members determine if a group's Message Board is moderated by
editing the Group Profile's Group MessageBoard Moderation check box.
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NOTE: If a Group administrator submits a comment to a moderated Group Message
Board, it is automatically approved.
If a comment is submitted to a moderated Message Board, users who can see it notice a
green dot border. The comment's author sees an hour glass icon (
) until it’s
approved. At any time, the author can delete the comment using the delete button (

).

Who is authorized to comment and reply to a message
board
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l

l

l

User
o the logged-in user
o

colleagues

o

users assigned to Message Board Admin role See also: Defining roles on
page 1581

o

Administrators group member

Group
o group members
o

users assigned to Community Group Admin role; See also: Defining roles on
page 1581

o

Administrators group member

Content item
o anyone who can view the content
For example, if a content item is set to private, a user must have at least ReadOnly permission for the folder containing the content.

Who can moderate message board
l

If you submit a comment or reply, you can view and delete it.

l

Any of the following can view, delete, and approve pending comments or replies.
o Administrator group members
o

If you or a group member owns the message board to which a comment or
reply was added.

o

Community group administrator

o

User that is assigned to a Message Board Admin role

Approving message board comments
On a moderated message board, approval activity appears on the Approve tab. To
approve a single Message Board comment, an authorized user clicks Approve. An
authorized user any can approve several or all comments at once. To select several
comments, place a check next to each, then click Approve. To select all comments,
click Select: All then Approve.
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To approve comments from the Workarea:
1. Go to Settings > Community Management > Message Board.
2. A list of all unapproved comments appears. You can restrict the list using the dropdown.
3. Place a check next to comments you want to approve. To select all comments,
check the box next to Messages in the header row.
4. Click Approve.

Deleting message board comments
To delete a single comment, find the comment and click Delete.
Deleting unapproved comments from Workarea:
1. Go to Settings > Community Management > Message Board.
2. A list of all unapproved comments appears.
3. Select the comments that you want to delete. To select all comments, check the
box next to Messages in the header row.
4. Click Delete (

).

Replying to message board comments
Users can reply to comments on a user’s, community group’s, or content item’s
Message Board. For community groups, the group must be public and not restricted;
otherwise, only group members can reply.
NOTE: To learn which users are eligible to reply to Message Board comments, see
Who is authorized to comment and reply to a message board on page 1645
If you are in a load-balanced environment, the same reply may appear several
times. If this problem occurs, stop the Ektron notification service on all but one of
the servers in the cluster.
To add a reply, click Reply (

) in a comment’s lower right corner.
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Next, a dialog box displays the original comment and a Reply field.

When the reply is submitted, a Replies link appears under the comment. The number
of replies appears next to the link.

Click the link to view comments. They are arranged from oldest at top to newest at
bottom.
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If the message board is moderated, replies must be approved before everyone can see
them.

Enabling message board notifications
You can send email notifications to Message Board owners and community group
members whenever someone posts a comment to a board. If a comment is posted to a
community group’s Message Board, all group members are notified.
IMPORTANT: To receive email notifications, a user's profile must include a valid
email address. See also: Sending notifications to a community on page 1665
You can turn this feature on or off in the siteroot/web.config file. By default, the
feature is turned off. To turn it on, open the web.config file and set the following key’s
value toTrue.
<add key="ek_EnableMessageBoardEmail" value= "False"/>

When activated, this feature applies to all user and community group message boards.

Filtering spam
Ektron lets you filter spam from your message boards. Ektron defines spam filtering as
setting the following limits in MessageBoard server control’s SpamControlType
property:
l

SameUserSameMessageSameDay. Prevent a user from posting the same
comment more than once a day.

l

SameUserTimeDelay. set the SpamTimeSpan property to 1800 to prevent a user
from posting any other comment for 30 minutes.

l

SameMessageTimeDelay. set the SpamTimeSpan property to 7200 to prevent a
user from posting identical comments for 2 hours.

l

Custom (and add the code to the code-behind page of the template containing the
MessageBoard server control). Use your own spam filter code.

You can create your own spam filter in the code-behind of the page that hosts the
Message Board. To do this, set the SpamControlType property to Custom, call the
CustomSpamMethod in the page load event, and point it to your custom spam filter
method. Your method’s signature must include the following parameters:
l

long objectId—the numeric ID of the object defined in the object type

l

Ektron.Cms.Common.EkEnumeration.MessageBoardObjectType objectType—
the type of object with which the Message Board is associated.

l

long userId—the numeric ID of a user. For example, you want to block a user
with the ID 18 from posting to the board.

l

string messageText—a string of text you want to block
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l

int interval—the amount of time, in seconds, to block posting on the Message
Board. For example, if you want to block a user from posting for 30 minutes, set
this property to 900.

The following C# example blocks the text Hello World.
using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
public partial classWebformCB : System.Web.UI.Page
{
protected void Page_Load(object sender, EventArgs e)
{
this.MessageBoard1.CustomSpamMethod(SpamControl);
}
private bool SpamControl(long objectId,
Ektron.Cms.Common.EkEnumeration.MessageBoardObjectType
objectType, long userId, string messageText, int interval)
{
if (messageText == "Hello World")
{
return true;
}
return false;
}
}

Associating message board comments with content in
the Workarea
You can associate Message Board comments with content. So, for example, a site
visitor can view content then comment on it. You can view these comments in the
Workarea.
NOTE: Message Boards can also be associated with users and groups. See also: the
MessageBoard server control. Message Board comments are not the same as the
Comments tab on the View Content screen.
1. In the Workarea, go to the content block whose messages you want to view.
2. Click that content. The View Content screen appears.
3. Click View Content Reports (

).

4. Click the Messages tab. A list of comments associated with the content appears.
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Managing community groups
IMPORTANT: Membership User Groups and Community Groups are different
concepts. Membership User Groups let an administrator create a group of
membership users, thereby reducing the effort required to assign identical
permissions to many users. See Membership groups on page 1633. Community
Groups are explained in this section.
Community groups are another feature of Ektron's Community Platform. Group
members can easily meet people with similar interests, such as car racing.
Groups have similar features and functions to user features. For example, a community
group can have a Message Board, Discussion Board, maintain a membership list, and
keep a group journal. You can manage community groups from the website or the
Workarea.
You can assign a taxonomy category to a community group so that users can browse
and search for groups by category. You also can assign tags to a community group,
which let users find groups when searching by tag name.
You can access community group information in the following areas of the Workarea:
l

My Workspace > Community Groups. displays groups to which you belong;
also lets you remove yourself from them.

l

Workarea > Settings > Community Management > Community Groups.
displays all groups. You can define a group’s details or add and remove members
from the group when you are:
o a group’s leader (also known as a group administrator)
o

a member of the Ektron administrator's group

o

an Ektron user or Membership user with the Community Group Admin or
Community Group Create role

To view a list of all community groups in the Workarea, click the Settings >
Community Management > Community Groups.
The following server controls are associated with community groups:
l

CommunityGroupBrowser. Lets you browse a taxonomy structure for community
groups.

l

CommunityGroupList. Displays a list of community groups, sorted by name,
newest, most popular, and so on.

l

CommunityGroupMembers. Displays a list of group members, as well as those who
have been invited to join or requested to join the group.

l

CommunityGroupProfile. Displays a group profile.

Viewing a community group’s details
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Any user with access to the Workarea can view a group’s details but cannot see group
members. Only the group leader (also known as a group administrator), a member of
the administrators group, or an Ektron user with the Community Group Administrator
role can edit the group’s information, add and remove members, or delete the group.
1. Click Settings > Community Management > Community Groups.
2. Click Group Name. The group’s detailed information appears.

Viewing community group members
Only the group leader (also known as a group administrator), a member of the
administrators group, or an Ektron user with the Community Group Administrator role
can view group members. These users can also add and remove members. And, if the
group’s membership is Restricted, you can accept or decline requests to join the
group.
1. Click Settings > Community Management > Community Groups.
2. Click a group name.
3. Click View Community Group Members (

). A list of group members appears.

Adding or editing a community group
1. Click Settings > Community Management > Community Groups.
2. If you are adding a new group, click Add New Community Group. If you are
editing a group, click the group name then Edit This Community Group.
l Group Name. The name of the group.
l

Administrator. A group administrator has privileges to delete a group and
edit its properties. Members of the Administrators group and users assigned to
the Community Group Admin role also have these privileges. By default, the
person who creates the group is the group administrator. Click Browse to
change the administrator.

l

Membership. Select whether the group is Open (anyone can join) or
Restricted (only invited members can join). See also: Accepting/declining
requests to join a community group on page 1655
NOTE: Restricted groups can be found in the same way that open groups
can. Also, their activities are published as notifications. For example, Tom
posted a reply to the forum topic titled 'RoboTech
Acquisition'. So, do not create a group or publish activities that you want
to keep secret.

l

1652

Features: Create Group Calendar. Click this radio button if you want to
allow the group administrator to create a group calendar. See also: Creating a
calendar in a group on page 1002
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l

Features: Create Group Forum. Click this radio button if you want to allow
the group administrator to create a group forum. See also: Managing a
discussion board in a community group on page 1054

l

Image. Upload an image to use as an avatar for the group.

l

Location. The geographical location of the group.

l

Short Description. A brief description of the group.

l

Description. A full description of the group.

l

Enable Distribute. Check this box if you want the group and system
administrator to be able to distribute content to any Ektron folder. See also:
Distributing content to another Ektron folder on page 1658

l

Allow member to manage photo/workspace folders. Check this box to
allow members to add, remove and control the sharing of folders in a
community group’s Photo Gallery or Document’s Workspace. See also:
Allowing community group members to work with folders on page 1655.

l

Group MessageBoard Moderation. Check this box if you want the group's
Message Board to be moderated. That is, comments and replies must be
approved by an authorized user before they appear. See also: MessageBoard

l

Attach Documents in Email Notifications. Check this box if you want set
up activity message attachments for a community group. See also: Enabling
attachments to notifications on page 1702

l

Group Email. Check this box to allows emails to be sent to the group.

l

Group Tags (Tags tab). From this screen, you can either create a new tag or
select from a default list of community group tags. See also: Assigning a tag to
a community group on page 1656

l

Category List (Categories tab). The categories tab lists all taxonomy
categories associated with the community group. This tab only appears if you
have defined at least one taxonomy for community groups. See also: Creating
a taxonomy and its associated categories on page 1359

l

Links Tab. Displays the group's alias if aliasing is set for community groups.
You can click the alias to view the community group page. See also: Creating
user-friendly URLs with aliasing on page 1399

3. Click Save.
After you create a group, you can add members to it. See also: Adding members to a
community group on the next page and Managing community groups on page 1651
NOTE: The CommunityGroupBrowser server control also has a Create Group link,
which lets you create a community group from the website. See also:
CommunityGroupBrowser server control.

Deleting a community group
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Only the Group Administrator, Ektron administrators, or Ektron users with the
Community Group Administrator role can delete a group.
1. Click Settings > Community Management > Community Groups.
2. Click a group name.
3. Click Delete This Community Group (

).

Adding members to a community group
Only the group leader (also known as a group administrator), administrators or Ektron
users with the Community Group Administrator role can add members to a group.
1. Click Settings > Community Management > Community Groups.
2. Click on a group name.
3. Click View Community Group Members (
Members for the group screen appears.

). The View Community Group

4. Click Add User(s) to Community Group. The Add Members screen appears.
5. Using the drop-down box, select the type of name (Display name, Last name, First
name, Username) for which to search.
6. Enter a name in the text box.
7. Click Search. The results are returned.
NOTE: If you leave the text box blank and click Search, all results for the name
type are returned.
8. Place a check mark in the box next to each member to add.
9. Click Add Selected User(s) to This Community Group.

Removing members from a community group
Only the group leader (also known as a group administrator), Administrators, or Ektron
Users with the Community Group Administrator role can remove members from a
group.
1. Click Settings > Community Management > Community Groups.
2. Click a group name.
3. Click View Community Group Members (
Members for the group screen appears.

). The View Community Group

4. Check the box next to members you want to remove.
5. Click Remove from Community Group ( ).
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Allowing community group members to work with
folders
When you associate the CommunityDocuments or PhotoGallery server control with a
community group, you can let members of the group add, remove, and control the
sharing of folders in these controls.
1. In the Workarea, go to Settings > Community Management > Community
Groups.
2. Click a community group.
3. Click Edit This Community Group.
4. Check the Allow member to manage photo/workspace folders box.
5. Click Save.

Accepting/declining requests to join a community group
If a group’s membership is set to Restricted (on the Community Group screen), users
must request to join the group. (If membership is Open, users join a group
immediately.) In the Workarea's View Community Group Members screen, use the
Pending tab to accept or decline a user’s request to join a group.
Only a Group Administrator, Ektron Administrator, or Ektron users with the Community
Group Administrator role can do this.
To accept or decline a member's request to join a group in the Workarea:
1. Go to Settings > Community Management > Community Groups.
2. Click the group for which you want to accept or decline requests to join.
3. Click View Community Group Members (

).

4. Click the Pending tab.
5. Check the box next to each member whose request you want to approve or
decline.
l To approve the request, click Approve.
l

To decline the request, click Decline.

Searching for a community group
You can search for a Community Group in the Workarea by using the View All
Community Groups page's Search box.
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To search for Community Groups, click Settings > Community Management >
Community Groups. Enter text in the search box and press Enter. Community
Groups that match the search term appear.

Assigning a tag to a community group
On the website, Tag information for a group appears in the Group’s profile. In the
Workarea, Tag information is on the View Community Group’s > Tag tab. From this tab,
you can either create a new tag or select from a list of group tags.
1. In the Workarea, go to the Settings > Community Management >
Community Group.
2. Click the community group for which to create a new tag.
3. Click Edit This Community Group.
4. Click the Tags tab.
5. Click Add Tag.
6. Add a tag to the Name text box.
7. Select a language.
8. Click Save.
When the Tag is saved, it appears in the Group Tags area with a check mark in the
check box, which means the tag is active for the community group. If you have several
tags, use the check boxes to choose the default tags that you want associated with the
group.

Using discussion boards for community groups
You can use the Discussion Board feature within a community group to provide Webbased discussions on topics of interest to a group. To use this feature, each group must
add the Discussion Board for their group into the database before posts can be added.
To do this, see Using discussion boards for community groups above.
Group discussions may include these topics:
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l

project requirements

l

scope and scheduling
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l

team issues

l

frequently asked questions

The following image shows a discussion board on a community group page.

Using calendars for community users and groups
Ektron's Web Calendar keeps visitors informed about upcoming events. Combined with
the powerful community features, the calendar enhances communication between
individuals and groups. To use this feature, each group must add Calendar into the
database before events can be added; see Creating a calendar in my profile on
page 1000.
Communities calendars events could include
l

personal vacations

l

special personal occasions

l

group milestones

l

group meetings

The following image shows a calendar on a personal profile page.
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Distributing content to another Ektron folder
Ektron supports the distribution of a community document to any Ektron folder. For
example, your Marketing Department uses the Community Documents server control to
create and edit content. After completing a press release, they use the Distribute
menu option to copy it from the private collaboration folder to a public content folder.
From there, the document can pass through a workflow or be published immediately.
The Distribute option can insert new content or overwrite existing content.

Enabling the Distribute option
Only a member of the Ektron Administrators group can enable the Distribute option. Do
this for every community group that will use it. You can do so from the Workarea or
after logging in to the website.
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From the Workarea
1. Go to Settings > Community Management > Community Groups.
2. Click the group for which you want to enable the Distribute option.
3. Click Edit.
4. Check the Enable Distribute box.
5. Click Save.

From the website
1. Log in to a site that uses the Community Management features as a CMS
administrator or a Group Administrator.
2. Go to a Web page that hosts a Group Profile page.
3. Click Edit Group.
4. Check the Enable Distribute check box.
5. Click Save.

Distributing a community document
WARNING! After a community document is distributed the first time, the original
document is forever linked to the destination document. You cannot break the link.
PREREQUISITES
l

You log in as one of the following
o Administrator of the group whose documents are being distributed
o

Ektron user assigned Community Group Administrator role for that
group

o

CMS administrator

l

The content’s status is Approved.

l

You have permission to add, delete, and restore content to the
destination folder. (If you do not, the folder doesn’t appear on the folder
selection screen.) See also: Managing folder and content permissions
on page 168

Distributing a community document
When you distribute a community document that does not exist in Ektron for the first
time, you identify a destination folder and, if required, metadata and taxonomy
categories. This information is collected through a series of screens that guide you
through the process.
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1. Log in to the website that contains content you want to distribute.
2. Go to the Web page that contains content you want to distribute.
3. Click the triangle to the right of the content or asset you want to distribute.
4. Click Distribute from the drop-down menu. The following screen appears.

5. Click in the top box, which begins I want to distribute a copy of this item. The
following screen appears.
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6. Select the folder to which you want to distribute the content and click Next. The
following screen appears if metadata or a taxonomy category is required for the
folder.
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7. Enter any required metadata or taxonomy.
8. Click Done. Ektron copies the selected document to the designated folder.
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Distributing and overwriting a community document
NOTE: This process only occurs the first time you overwrite a document. For a
description of subsequent updates, see Distributing content after the first
distribution on the next page.
During this procedure, you identify a destination folder and content to be replaced.
Because the content’s type that you are distributing must match the content being
replaced, you only see content whose types match.
Upon replacing, any metadata and taxonomy categories applied to the existing content
are applied to the new. Also, the content title and ID number from the existing content
are maintained—they are not replaced by the title and ID number of the new content.
Finally, the existing content’s summary is maintained and can be edited if needed.
1. Log in to the website that contains the content you want to distribute.
2. Go to the page that contains that content.
3. Click the triangle to the right of the document you want to distribute. Distribute
appears on the drop-down menu.
4. Click Distribute. The following screen appears.
NOTE: The following screen only appears the first time you overwrite a file. To
overwrite the file subsequently, see Distributing content after the first
distribution on the next page.

5. Click the lower box, which begins I want to replace an existing item. The
following screen appears.
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6. Go to and select the content you want to replace. Only content whose type matches
the document you selected appears.
7. Click Next.
8. Click Done.

9. Ektron overwrites the selected document with the one you selected.

Distributing content after the first distribution
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If you later try to Distribute the same document (whether you added a new document
or overwrote an existing one), a screen like the following appears.

If you really must distribute the document to another folder, delete the document in the
destination folder. This action breaks the link between documents. When the link is
broken, you can distribute the document to another folder.
To copy the latest version of the document to the distribution folder, click the gray box
whose text begins I want to redistribute... However, you cannot distribute the
document to another folder. (If you want to do so, first delete the document from the
destination folder. Then, you can use either procedure to distribute the document to
any folder.)
When distributing content after the first time, its metadata and taxonomy categories
appear on the Metadata/Category screen by default. You can change them if desired.
As with the replace option, the existing content’s title and ID number are maintained -they are not replaced by the new content’s title and ID number. And, the existing
content’s summary is maintained and can be edited if needed.

Sending notifications to a community
Notifications help you build a tighter, more robust community. They drive users to your
site by notifying them of a recent event, then directing them to the affected page.
Ektron's notification system creates and transmits a notification message to recipients
through various agents, based on Ektron activities. The activity may be performed by a
community group, membership user, or an Ektron user. For example, a membership
user wants to notify colleagues whenever a document is uploaded to his profile page.
When this occurs, a notification agent sends an email to that user's colleagues.
Users can control the notification system by determining
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l

which activities generate notifications to their colleagues and community groups

l

which notifications they want to receive from colleagues and community groups

The following notification system overview is for developers and Ektron administrators.
1. A user performs an activity in Ektron, which raises a corresponding event.
2. Activity data is written to the database's activity table.
3. Activity information is sent to the activity queue.
4. Ektron verifies that the notification system is enabled and that the user who
performed the activity wants to notify others when it occurs.
5. The notification service compiles
l the message associated with the activity
l

agents that send the message

l

recipients who chose to be notified when that user performs that activity

6. The notification service uses notification agents to send the message to
appropriate recipients.

Notifications respect permissions and private content
The notification system respects Ektron’s content permissions. As a result, contentrelated notifications are only sent to users with at least read-only permission for the
content. See also: Managing folder and content permissions on page 168.
For example, Julia adds content to an Ektron folder for which her colleague, Tyler, does
not have permission. Tyler is not notified when content is added, even though he signed
up to be notified about colleagues’ activities. However Kristin, another colleague who
has permission to edit the folder’s content and who signed up to be notified about
colleagues’ activities, does receive notification of that event.
Similarly, private content is only viewable by authorized CMS users or membership
users with at least read-only permissions for it. See also: Making content private on
page 695.

Notification activities and recipients
The following table lists Ektron notification activities, and the users and groups that
receive each notification.
NOTE: As explained in Personalizing notifications about your activities on
page 1677, users must elect to receive these notifications.
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Notification
recipients

Blog Post. user posts to the user's blog

User's colleagues
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Activity

Notification
recipients

User or Community Blog Comment. user comments on a
blog post

Posting user's
colleagues

Add/Update Site Calendar Event. event is added or changed on
site Web calendar

User's colleagues

Add/Update User Calendar Event. event is added or changed on
user Web calendar

User's colleagues

Add/Update Group Calendar Event. event is added or changed
on group Web calendar

Community group
members
l

Colleagues of
user who adds

l

Added
colleague

Add Colleague. user adds a colleague

Create Community Group. user creates a community group

Colleagues of user
who creates group
l

Community
group
members

l

Colleagues of
user who joined

Join Community Group. user joins community group

Add/Edit Group Content. user uploads or edits content in a
community group workspace

Community group
members

Group Blog Comment. user comments on a community
group’s blog post

Community group
members

Group Blog Post. user posts to community group blog

Community group
members

Group Messageboard Post. user posts to a community
group message board

Community group
members

Add/Edit Site Content. user adds or edits Ektron content

User's colleagues
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Activity

Notification
recipients

Content Messageboard Post. user posts to a message
board associated with content

Users who have permission to view the
content

Depends on folder’s
share setting, which
can be

Add/Edit User Workspace Content. user uploads content
to the user profile

Forum Post. user posts to a forum

Forum Reply. user replies to a forum post

Community group forum post. user posts to community group
forum

Community group forum reply —user replies to community
group forum post
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l

Public—all
colleagues

l

Colleagues—all
colleagues

l

Selected
colleagues

l

Private—no
notification

l

Posting user's
colleagues

l

Forum owner
and owner's
colleagues

Posting user's
colleagues
l

Posting user's
colleagues

l

Community
group
members

l

Responding
user's
colleagues

l

Community
group
members

Setting up notifications

Activity

Notification
recipients

Micro-message. user posts micro-message

User's colleagues

User Messageboard Post. user posts to a message board
associated with a user

l

Colleagues of
user who posts

l

Message board
owner and the
owner's
colleagues

Setting up notifications
This section explains how to set up community notifications.

Setting up Ektron to send notifications
PREREQUISITE
l

You are a member of the Administrators group or assigned the
Community Admin role.

l

You have permission to edit files in the Ektron site folder.

1. Set up Ektron to send email notifications. See Enabling email notification on
page 105 and Automatic email notification on page 108.
2. Go to Settings > Community Management > Notifications > Settings
> Edit.
3. Check the Publish Notifications box and click Save.
4. In the siteroot/web.config file, you have 2 options for determining the SMTP server
that sends notifications.
l Use SMTP server information in the web.config file's SMTP Server
configuration area. To do this, set the <notificationAgent> <providers>
element as shown in the following code sample. Then, complete the SMTP
Server configuration area if necessary. (You typically define SMTP server
settings while enabling email notification. See Enabling email notification on
page 105.)
<notificationAgent>
<providers>
<add name="EktronEmail"
type="Ektron.Cms.Notifications.Providers.EktronEmailAgent,
Ektron.Cms.Providers" useSystemSettings="true" smtpServer="" smtpPort=""
userName="" password="" fromEmail="" />
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By setting useSystemSettings to true, you indicate that you want
notifications to use settings set in the SMTP Server configuration area of
web.config. And, if you set useSystemSettings to true, you must go to the
Application Setup screen's General tab and
1. Define the sending email address at the System E-Mail Address field.
2. Check the Enable Sending of System Notification Email box.
3. In your server's Local Services window, restart the Ektron Notification
service.
l

Set SMTP server information in the <notificationAgent><providers>
element. Do this if you want to use a different SMTP server to send
notifications. To do this, set the <notificationAgent> <providers> element
as shown in the following code. Replace the coded values for smptServer,
smtpPort, userName, password, and fromEmail with actual values.
<notificationAgent>
<providers>
<add name="EktronEmail"
type="Ektron.Cms.Notifications.Providers.EktronEmailAgent,
Ektron.Cms.Providers" useSystemSettings="false" smtpServer="mailservervalue"
smtpPort="port number" userName="email address of user authorized to use
mailserver"
password="encrypted password of user authorized to use mailserver"
fromEmail="sending email address" />

IMPORTANT: Whenever the web.config or the
Ektron.Notification.Service.exe.config file is updated with changes affecting
notifications, you must restart the Ektron Notification service.
5. Review, and modify if necessary, the default notification preferences. These
determine which activities trigger notifications, and the agents that send them. See
Creating default notification settings on page 1675.
6. Enable agents that transmit notifications. See Working with notification agents
below.
7. Review the default text of the notification messages. Create new ones or edit
existing ones if necessary. See Managing notification messages on page 1682.
If you want to enable SMS messages, see Setting up SMS on page 1674.
8. If you are a developer, you can raise a custom activity, create a custom agent, set
up SSL, and learn how to use notifications in a multi-site environment, and with
eSync.

Working with notification agents
A notification agent sends notifications to eligible users when an Ektron activity occurs.
After an agent is registered, users can choose notification preferences that use it.
Ektron's predefined agents are
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l

email notifications. Delivered to recipients' inboxes. See also: Generating email
invitations for community management on page 1703.

l

SMS notifications. Delivered to a cell phone or another device that receives SMS
messages. See also: Setting up SMS on page 1674.

l

Activity Stream notifications. delivered by ActivityStream server control.

NOTE: Ektron’s predefined agents are enabled by default.
You can customize these agents or create your own using the extendable notification
agent architecture.

Enabling or disabling an agent
PREREQUISITE
l

You are a member of the Administrators group or assigned to the
Community Admin role.

1. Go to Settings > Community Management > Notifications > Agents.
2. Click the name of an agent.
3. Click Edit.
4. Check (or uncheck) the Enabled check box.
5. Click Save.

Removing an agent
PREREQUISITE
l

You are a member of the Administrators group or assigned to the
Community Admin role.

l

You have permission to edit files in the Ektron site folder.

When you no longer need an agent, you can remove it. This can be a 2 step process,
depending on the level of removal you want to achieve. First, remove the agent from
the Workarea's list of agents. At this time, you can easily reactivate the agent. In the
second step, you remove the agent from the web.config file. At this point, it is no
longer available in the Workarea.
1. Workarea > Settings > Community Management > Notifications > Agents.
2. Click the agent's title.
3. Click Delete (

).

4. In the Delete Agent dialog, click OK.
NOTE: To completely remove the agent from Ektron, follow these additional
steps.
5. Open the site root folder’s web.config file.
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6. Within the <notificationagent> <providers> elements, remove the agent. The
following example shows agents that might appear in the web.config file.
<notificationAgent>
<providers>
<add name="CustomAgent1" type="Ektron.Cms.Notifications...
<add name="EktronEmail" type="Ektron.Cms.Notifications...
<add name="SMSAgent" type="Ektron.Cms.Notifications...
<add name="ActivityFeed" type="Ektron.Cms.Notifications...
</providers>
</notificationAgent>

Creating a custom agent
Ektron provides 3 standard notification agents: email, SMS, and Activity Stream. You
can customize these agents or create your own using the extendable notification agent
provider architecture. This section explains how to extend the object model to build a
customized notification agent.
Each type of notification agent accepts configuration parameters. For example, email
and SMS require an SMTP server, username, and password. These parameters can be
specified in the web.config file, and read when the agent is initialized the first time.
Each agent may also require the ability to store settings for each user receiving
notifications. For example, the SMS agent requires the user’s cell phone number and
carrier, which it stores as an SMS email address. To save these properties, each
notification agent has an associated NotificationAgentSettingsData class. This class
defines properties that must be supplied by a user. Ektron provides APIs for storing and
retrieving this information, but the developer must create an interface for users to
supply the information.

Implementing a custom agent
Object Model
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The NotificationAgent is the abstract base class you must extend to implement a
custom notification agent. Details about the class, available properties, and methods
are as follows:
l

virtual void Initialize(string name, Amenable config);
The initialize method comes from the ProviderBase base class. It supplies all name
value pairs specified in the Providers web.config section.
If custom settings need to be provided to your agent, add them to your provider’s
web.config key, and the Initialize method provides them at runtime. If you have
no custom settings, this class does not need to be overridden.

l

abstract NotificationAgentSettingsData GetAgentSettings();
This method should return a new instance of the NotificationAgentSettingsData
class associated with your agent.

l

abstract void Send(NotificationMessageData message);
This method should send the actual notification. It is called by the notification
engine for each user that needs to be notified.
The NotificationMessageData has all the information you need for sending the
notification, including
o

the message

o

the user to be notified

o

the NotificationAgentSettingsData for the user to be notified

If your agent has a custom NotificationAgentSettingsData, you need to cast the
supplied NotificationAgentSettingsData to the appropriate type so that you can
access the appropriate properties.

Adding a custom agent
PREREQUISITE
l

You have permission to edit files on the Ektron web server.

l

You are either a member of the Administrators group or assigned to the
Community Admin role.

1. Edit your siteroot/web.config file.
2. Insert the new agent between the <notificationAgent><providers> tags .
<notificationAgent>
<providers>
<add name="CustomAgent1"
type="Ektron.Cms.Notifications.Providers.CustomAgent1,
Ektron.Cms.Providers" setting1="" setting2=""/>
<add name="EktronEmail"
type="Ektron.Cms.Notifications.Agents.EktronEmailAgent,
Ektron.Cms.BusinessObjects" useSystemSettings="false"
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smtpServer="amh010" smtpPort="25" userName="" password=""
fromEmail="admin@example.com"/>
<add name="SMSAgent"
type="Ektron.Cms.Notifications.Agents.SMSAgent,
Ektron.Cms.BusinessObjects" smtpServer="amh010" smtpPort="25"
fromEmail="SMSAgent@example.com" validationRequired="true"/>
<add name="ActivityFeed"
type="Ektron.Cms.Notifications.Agents.ActivityFeedAgent,
Ektron.Cms.BusinessObjects" validationRequired="false"/>
</providers>
</notificationAgent>

After you add an agent to web.config, it appears in the Workarea's list of agents.

3. Go to Settings > Community Management > Notifications > Agents.
4. Click Add.
5. Select the custom agent from the Name drop-down box.
NOTE: If you do not see the custom agent in the Name drop-down, check the
web.config file to verify it appears between the <notificationAgent> tags.
6. Check the Enabled box.
7. Click Save.

Setting up SMS
SMS sends notifications from the Ektron website to wireless devices, such as a cell
phone or PDA. To set up this capability, configure several items.
l

web.config. Add SMS agent information. See the following procedure.

l

Cell phone. Verify your cell phone with your website. See Sending notifications to a
community on page 1665.

l

Select SMS as an agent for sending community messages. See also: Enabling or
disabling an agent on page 1671.

To set up SMS agent information:
PREREQUISITE

You have permission to edit files on the Ektron web server.
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1. Open the siteroot\web.config file.
2. Find the SMSAgent tag.
3. Enter the smtpServer value for the server that sends your organization's email.
For example:
smtpServer="EKMAIL291.internal.mycompany.com"

4. Replace the value of fromEmail with the email address of the user from whom
notifications are sent. For example:
fromEmail = "noreply@mycompany.com"

5. Save the file. The completed code looks like this.
<add name="SMSAgent"
type="Ektron.Cms.Notifications.Providers.SMSAgent,
Ektron.Cms.Providers" smtpServer="EKMAIL291.internal.mycompany.com" |
smtpPort="25" fromEmail="noreply@mycompany.com" validationRequired="true" />

Creating default notification settings
Ektron lets an administrator create default notification settings. See also: Sending
notifications to a community on page 1665. The default settings apply to all newlycreated users, but any user or group can personalize them, as described in
Personalizing notification settings on page 1677.
There are 3 types of default settings.
l

Colleagues. Colleagues' activities about which a user wants to be notified

l

Community Groups. Community group activities about which a user wants to be
notified

l

My Activities. User activities that send notifications to colleagues and community
groups.

Ektron Reference

1675

Managing user communities

NOTE: By default, activities are checked for the Activity Stream agent only.
PREREQUISITE
l

You are a member of the Administrators group or assigned to the
Community Admin role.

1. Go to Settings > Community Management > Notifications > System
Default Preferences > Colleagues.
2. Click Edit.
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3. Check the box next to each default notification.

4. Click Save.

Personalizing notification settings
By default, a set of notification preferences is applied to each user's profile. Most users
want to personalize these settings, so they send and receive notifications as they wish.
Similarly, a community group member can access a community group profile and click
Edit Group Notification Preferences to personalize the group's preferences.

Personalizing notifications about your activities
In your profile, enable only activities that you want to notify others about.
NOTE: The My Activities tab appears only after a user is registered and the
Workarea > Settings > Community Management > Notifications >
Settings > Publish Notification setting is checked.
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1. Log into the Ektron site.
2. Go to your profile page.

Alternatively, log into the Ektron Workarea > Settings > Users > your username
> Profile Links tab > click the link.
3. Click Edit Profile.
4. Click the Activities tab.
5. Click the My Activities sub tab.

6. Check the box of each activity that you want to notify other users about.
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7. Click Save.

Personalizing the receipt of notifications
In your profile, enable only activities that you want to be notified about. Use the
Colleagues tab to enable notifications for activities performed by colleagues, and the
Community Groups tab to enable notifications for activities performed by group
members.
1. Log into the Ektron site.
2. Go to your profile page.
Alternatively, log into the Ektron Workarea > Settings > Users > your username
> Profile Links tab > click the link.
3. Click Edit Profile.
4. Click the Activities tab.
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5. Click the Colleagues sub tab.

6. Check the box of each activity that you want to be notified about, and the agent to
notify you.
7. Click the Community Groups sub tab.
8. Check the box of each activity that you want to be notified about, and the agent to
notify you.
9. Click Save.

Raising a custom activity
PREREQUISITES
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l

You are a developer.

l

You are a member of the Administrators group or assigned to the
Community Admin role.
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Ektron's notification system lets you create and raise custom activity types. Custom
activity types can generate notifications, just like standard activity types.
1. In the Workarea, go to Settings > Community Management > Notifications
> Activity Types.
2. Click Add Activity Type. The Add Activity Type screen appears.

3. Enter a unique name.
4. Select an Action Scope, which describes the types of users who create the
activity.
l User. activity raised by an Ektron user
l

CommunityGroup. activity raised by a community group user

5. Save the screen. The following image shows a sample custom activity.

6. Interested users go to their User Profile screen’s Activities tab to indicate if they
want be notified when the custom activity occurs, and if they want to notify others.
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7. To raise a custom activity, call the
Ektron.Cms.Framework.Activity.Activity.Publish method. The method takes
an ActivityData class. You supply the following:
l the Id of the Activity Type you want to raise (1001 in this example)
l

the user causing the activity

l

a message
NOTE: Custom activity types cannot use Community Management
messages as the standard Ektron activities do.
Here is an example of that method.
Activity activityApi = new Activity();
ActivityUserInfo user = new ActivityUserInfo();
user.Id = activityApi.UserId;
ActivityData activityData = new ActivityData();
activityData.ActionUser = user;
activityData.ActivityTypeId = 1001;
activityData.Message = "John Doe just rated Ektron a buy!";
activityData.LanguageId = 1033;
activityApi.Publish(activityData);

When publish is called, the notification service notifies users who signed up to be
notified of this activity.

Managing notification messages
Ektron's notification system uses messages to communicate site activities. A message
is sent if:
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l

it is the default for its activity type

l

an activity occurs that matches the message's sub type

l

the user or group that performs the activity chose to notify others about it in their
notification preferences
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You can view each activity’s message text on the Workarea > Settings >
Community Management > Notifications > Messages screen.

For each activity, you can create an HTML-based and a plain text message. Typically,
HTML messages are sent as email or to the ActivityStream server control, while plain
text is used in SMS style messages. Messages can use text and tokens. See also:
Working with tokens on page 1686

Creating or editing a message
As explained in Managing notification messages on the previous page, one message is
provided for each activity type and sub type in the default language. You can edit the
default message text as well as create new messages in non-default languages.
PREREQUISITE
l

You are a member of the Administrators group or assigned to the
Community Admin role.

1. Go to Settings > Community Management > Notifications > Messages.
2. If you are using the multi-site feature, select the site with which this message will
be associated.
3. Select the language of the message that you want to create or edit.
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4. To create a new message, click Add Message. To edit an existing message, click
its title then Edit.
5. Complete or update the following fields.
l Title. Enter a name for the message.
l

l

Type. Select a message type. Choices are:
o User. message sent when user activity occurs
o

Community Group. message sent when group activity occurs

o

Blog Notifications. message sent when blog activity occurs

o

General Notifications. message sent when activity is "email message
reply"

Sub Type. Select the activity which triggers the sending of this message.

Choosing a message type
User and Community Group messages contains several message sub types.
Sub type is the activity that triggers the message. For example, to edit the
message that notifies colleagues when you upload a document to your
Workspace, select User from the Type drop-down and AddWorkspaceItem
from the Sub Type drop-down.
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Only one default message is active for any sub type. So, if you create a new
message, you must make it the default (via the Add Notification Message
screen’s Default check box) if you want it to be sent. If another message was
the default for that type and sub type, it is no longer used. For a list of Sub
types, see Notification activities and recipients on page 1666.
l

Tokens. Tokens for the selected Sub Type appear. To insert a token into a
message, highlight a token, then copy and paste it into the message. See also:
Working with tokens on the next page.
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WARNING! A message is limited to 3000 characters after its tokens are
converted to text. Characters beyond 3000 are removed.
l

Default. Check this box if you want the message to be the default one that is
sent. See also: Choosing a message type on page 1684.

l

Subject. Enter a subject to be used if the message is sent as email.

l

Text. Enter the text and tokens that comprise the message. The editor lets
you format the text. Use this field for HTML, email, and activity stream
messages. See also: Making a token into a hyperlink on page 1695.

l

Plain Text. Enter the text and tokens that comprise SMS and plain text
messages. (If you already composed the message in the field above, you can
copy and paste it into this field.)
NOTE: Most SMS systems impose a 160-character limit on messages. If
you create a plain text message greater than 160 characters, Ektron
divides it into several smaller messages.

6. Click Save.

Removing a message
PREREQUISITE
l

You are a member of the Administrators group or assigned to the
Community Admin role.

1. Go to Settings > Community Management > Notifications > Messages.
2. Click the title of the message you want to delete.
3. Click Delete (

).

4. Click OK.

Working with tokens
A token is an Ektron variable surrounded by at signs (@). When a message is
generated, tokens retrieve information about CMS users, groups, and objects. For
example, the following message:
@SubjectUser.FirstName@ added a new document, ‘@Content.title@’, to the profile page.

might look like this:
“Paul added a new document, ‘Best Practices for Writing Code’, to the
profile page.”
In this example, @SubjectUser.FirstName@ is the first name of the user performing
the action. @Content.title@ is the title of the object that was uploaded. See also:
Customizing Ektron email with tokens on page 108
There are several token types.
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l

SubjectUser tokens. Represent a user who performs the activity

l

DirectObjectUser tokens. Represent a user to which the activity is happening

l

Content tokens. Represent content involved in the activity

l

CommunityGroup tokens. Represent a community group involved in the activity

l

Blog tokens. Represent blog use in the activity

l

webEvent tokens. Represent a Web Calendar used in the activity

l

MicroMessage tokens. Represent micromessages used in the activity

Message tokens: user and content-based
Add Calendar Event and Update Calendar Event
l @SubjectUser.DisplayName@
l

@SubjectUser.Id@

l

@SubjectUser.FirstName@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

l

@WebEvent.EndTime@

l

@WebEvent.Id@

l

@WebEvent.Quicklink@

l

@WebEvent.StartTime@

l

@WebEvent.Title@

AddColleague
l @DirectObjectUser.FirstName@
l

@DirectObjectUser.Id@

l

@DirectObjectUser.LastName@

l

@DirectObjectUser.TemplateAlias@

l

@DirectObjectUser.UserName@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@
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l

@System.SiteUrl@,

l

@System.UserProfileTemplate@

AddContent
l @Content.Icon@
l

@Content.Id@

l

@Content.Quicklink@

l

@Content.Title@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteURL@

l

@System.UserProfileTemplate@

AddWorkspaceItem
l @Content.Icon@
l

@Content.Id@

l

@Content.Quicklink@

l

@Content.Title@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteURL@

l

@System.UserProfileTemplate@

BlogComment
l @BlogComment.Id@
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l

@BlogComment.Message@

l

@SubjectUser.DisplayName@

l

@SubjectUser.Id@

l

@SubjectUser.FirstName@

l

@SubjectUser.LastName@
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l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

BlogPost
l @Content.Icon@
l

@Content.Id@

l

@Content.Quicklink@

l

@Content.Title@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

CreateCommunityGroup
l @CommunityGroup.Id@
l

@CommunityGroup.Name@

l

@CommunityGroup.TemplateAlias@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

ContentMessageBoardPost
l @Content.Icon@
l

@Content.Id@

l

@Content.Quicklink@

l

@Content.Title@
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l

@MessageBoard.Message

l

@MessageBoard.ObjectId@

l

@MessageBoard.ObjectType@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

l

@SubjectUser.TemplateAlias@

l

@System.GroupProfileTemplate

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

EditContent
l @Content.Icon@
l

@Content.Id@

l

@Content.Quicklink@

l

@Content.Title@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

EditWorkspaceItem
l @Content.Icon@
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l

@Content.Id@

l

@Content.Title@

l

@Content.Quicklink@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@
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l

@System.GroupProfileTemplate@

l

@System.SiteUrl

l

@System.UserProfileTemplate@

ForumReply
l @SubjectUser.DisplayName@
l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

l

@Topic.Id@, @Topic.Title@

l

@Topic.Quicklink@

l

@TopicReply.Id@

ForumPost
l @SubjectUser.DisplayName@
l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

l

@Topic.Id@, @Topic.Title@

l

@Topic.Quicklink@

l

@TopicReply.Id@

JoinCommunityGroup
l @CommunityGroup.Id@
l

@CommunityGroup.Name@

l

@CommunityGroup.TemplateAlias@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@
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l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

MicroMessage
l @MicroMessage.Id@
l

@MicroMessage.Message@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

UserMessageboardPost
l @DirectObjectUser.Id@
l

@DirectObjectUser.FirstName@

l

@DirectObjectUser.LastName@

l

@DirectObjectUser.UserName@

l

@MessageBoard.Message@

l

@MessageBoard.ObjectId@

l

@MessageBoard.ObjectType@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

l

@SubjectUser.TemplateAlias@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

Message tokens: community group-based
Add Calendar Event and Update Calendar Event
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l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@,

l

@System.UserProfileTemplate@

l

@WebEvent.EndTime@

l

@WebEvent.Id@

l

@WebEvent.Quicklink@

l

@WebEvent.StartTime@

l

@WebEvent.Title@

AddWorkspaceItem
l @CommunityGroup.Id@
l

@CommunityGroup.Name@

l

@Content.Icon@

l

@Content.Title@

l

@Content.Id@

l

@Content.Quicklink@

l

@DirectObjectUser.FirstName@

l

@DirectObjectUser.Id@

l

@DirectObjectUser.LastName@

l

@DirectObjectUser.UserName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteURL@

l

@System.UserProfileTemplate@

BlogComment
l @BlogComment.Id@
l

@BlogComment.Message@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@
Ektron Reference

1693

Managing user communities

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

BlogPost
l @Content.Id@
l

@Content.Quicklink@

l

@Content.Title@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

CreateCommunityGroup
l @CommunityGroup.Id@
l

@CommunityGroup.Name@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

GroupMessageBoardPost
l @CommunityGroup.Id@
l

@CommunityGroup.Name@

l

@CommunityGroup.TemplateAlias@

l

@MessageBoard.Message@

l

@MessageBoard.ObjectId@

l

@MessageBoard.ObjectType@

l

@SubjectUser.DisplayName@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.TemplateAlias@

l

@SubjectUser.UserName@

l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

JoinCommunityGroup
l @CommunityGroup.Id@
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l

@CommunityGroup.Name@

l

@SubjectUser.FirstName@
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l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

UserMessageboardPost
l @DirectObjectUser.FirstName@
l

@DirectObjectUser.Id@

l

@DirectObjectUser.LastName@

l

@DirectObjectUser.UserName@

l

@MessageBoard.Message@

l

@MessageBoard.ObjectId@

l

@MessageBoard.ObjectType@

l

@SubjectUser.FirstName@

l

@SubjectUser.Id@

l

@SubjectUser.LastName@

l

@SubjectUser.UserName@

Message tokens: email reply message
Email Message Reply
l

@System.GroupProfileTemplate@

l

@System.SiteUrl@

l

@System.UserProfileTemplate@

Making a token into a hyperlink
A message token represents Ektron content, users, or groups. It can become a link
that, when clicked, forwards the site visitor to referenced content, a user’s profile, or a
community group’s profile.
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To make a token into a clickable link:
PREREQUISITE

The path to the page that displays the referenced content, user, or
community group.
—Image—

1. Create the message, as described in Creating or editing a message on page 1683.
2. While editing message text, highlight a token and click Insert Link (

).

3. In the URL field, enter the path to the page that displays the content, user, or
community group.
Be sure to include a QueryString parameter to identify the object. The parameter
should point to an ID token. For example, an add colleague message might be:
@SubjectUser.UserName@ and @DirectObjectUser.UserName@ are now colleagues.

When creating a link for @SubjectUser.UserName@, insert into the URL field the
path to the user’s profile page. It might look like this.
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http://localhost/Intranet/UserProfile.aspx?id=@subjectUser.Id@

NOTE: The QueryString parameter (?id=) points to a token that represents the
logged-in user’s ID, @subjectUser.Id@.
For @DirectObjectUser.UserName@, enter the same path but change the dynamic
parameter token to ?id=@DirectObjectUser.Id@.
When hyperlinking content, insert into the URL field the path to its QuickLink
token. For example, an add content message might look like this.
@SubjectUser.username@ added new content, @Content.Title@.

4. Click OK.

Managing email replies
The email reply feature consists of additional text within a notification message that
prompts a recipient to reply. See the following example. If the recipient replies, the
resulting email is posted to the group's message board.

To modify the reply message's text and start and end delimiters, see Modifying email
reply text on page 1699.

Setting up the email reply feature
PREREQUISITE
l

You are a member of the Administrators group or a community group
administrator.

l

You enabled community notification feature, as described in Setting up
Ektron to send notifications on page 1669.

IMPORTANT: The Community email reply feature is only supported for group
activities, such as uploading a document to a group workspace. It is not supported
for user activities.
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1. From the Workarea, choose Settings > Community Management >
Notifications > Settings.
2. Click Edit.
3. Check Enable Activity Email Reply.
4. Specify the email reply feature's settings.

l

Email Account Name. Enter the address that receives email delivered to
your website. It must be the same as the account used to send email, which is
defined in Enabling email notification on page 105.
IMPORTANT: Each community group's email address must be unique.

l

Email Account Password. Enter the password for that email address.

l

Email Server. Enter the POP mail server that retrieves email for this account.

l

Email Server Port. Enter the port number used to retrieve email for this
account.

l

Use SSL. Check this box if SSL is used when retrieving email.

l

Test Connection. Click this button to verify the information and the ability to
connect to the mail server.
NOTE: If you are using Gmail as the SMTP server to fetch email replies,
after the notification service processes the emails, you probably want to
delete them from the Inbox. To set up automatic deletion of this email from
the Inbox, got to Gmail's Settings screen > Forwarding and POP/IMAP
tab > Pop Download Area > 2. When messages are accessed with
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POP > select delete Gmail's copy.

5. Verify that all users who may receive an email reply have a valid email address in
their user profile. While in each user profile, verify that the Disable Receiving of
Workflow and Task Email box is unchecked.
6. Enable group email for each community group that may send an email reply. See
also: Creating a community group's email address on page 1705.
7. Make sure that all users who may participate in the email reply are assigned to a
user group mentioned in Step 6.

Modifying email reply text
PREREQUISITE
l

You have permission to edit files on the Ektron web server.

l

You are either a member of the Administrators group or assigned to the
Community Admin role.

Community activity that generates an email can include a reply statement, as shown in
the following example.

NOTE: The message text is determined by the activity. For example, if the activity is
a blog post, the message text is retrieved from the New Blog Post notification
message.
To review and modify email reply text:
1. In the Workarea, choose Settings > Community Management >
Notifications > Messages.
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2. Click Email Message Reply.
3. You cannot edit the Title, Type, Sub Type or Default check box. The Subject
field is not used.
4. Edit the message Text. You can create an HTML-based and a plain text message
for each activity. Typically, HTML messages are sent as email or to the
ActivityStream server control, while plain text is used in SMS style messages.
A line of dashes separates the activity message from the email reply. Messages
typically combine text and tokens. See also: Working with tokens on page 1686.
5. Optionally change the message's start and end delimiters. By default, the email
message reply begins with a new line character and ends with a line of dashes. If
desired, change those defaults. For example, you want to limit the reply to a single
paragraph.
a. On the Ektron server, open C:\Program Files
(x86)\Ektron\EktronNotificationService\
Ektron.Notification.Service.exe.config.
b. Find the <siteNotification> <sites> element.
c. Insert the following properties at the end of the <Add> tag.
l replyStartDelimitter. Marks the beginning of the reply.
l

replyEndDelimitter. Marks the end of the reply.

For example:
<siteNotification>
<sites>
<add name="dev" url="http://localhost/eintranet"
connectionString="server=.;database=eintranet;
Integrated Security=TRUE;user=;pwd=;" services="All"
replyExtractor="Ektron.Notification.Service.EktronReplyExtractor"
replyStartDelimitter="^" replyEndDelimitter="\r\n" />
</sites>
</siteNotification>

Use RegEx expressions to indicate the start and end delimiters. In the above
example, the start delimiter (^) is a new line, and the end delimiter (\r\n) is a
page break. So, only the first paragraph in the email reply is used.

How email replies are handled
The following table shows how the notification system treats email replies.
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How email reply handled

User adds a colleague

Comment on Activity Stream
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Activity

How email reply handled

User adds content to Ektron

Post to Content Message Board

Event is added or changed on Web Calendar

Comment on Activity Stream

User uploads content to community group
Workspace

Post to Content Message Board

User comments on group workspace content or
asset

Comment on Activity Stream

User uploads content to the user's profile

Post to Content Message Board

Comment on user workspace content or asset

Comment on Activity Stream

User comments on a blog post

Comment to same blog post

User posts to the user's blog

Comment on post

User posts to a message board associated with
content

Reply to post

User creates a community group

Comment on Activity Stream

User posts to a Forum

Reply to post

User replies to a Forum post

Reply to post

User comments on a community group’s blog
post

Comment on same blog post

User posts to community group blog

Comment on post

User posts to a community group message
board

Reply to post

User joins community group

Comment on Activity Stream

User posts micro-message

Comment on Activity Stream
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Activity

How email reply handled

User updates status

Comment on Activity Stream

User posts to another user's message board

Reply to post

Message board reply

Reply to same post

Enabling attachments to notifications
Ektron supports the attaching of community group assets to a notification. For example,
a user uploads a Word document to a group workspace, which generates a Group
Content Added notification. The Word document is attached to the notification. If you
enable attachments and the email Reply feature, message recipients can
1. Download the attached asset.
2. Modify it.
3. Reply to the email, attaching the modified asset.
4. The modified asset replaces the original one.
If a group administrator does not want to keep the modified asset, the administrator
uses the asset history to restore the original version. See also: Restoring a previous
version on page 705.
IMPORTANT: If a message's email signature includes an image, the email reply
feature uploads it as a group asset. To avoid this, remove the image from the
signature before replying.
To set up notification attachments for a community group:
PREREQUISITE

You are a member of the Administrators group or assigned to the
Community Admin role.
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1. From the community group page, click Edit Group.

Alternatively, from the Workarea, choose Settings > Community Management
> Community Groups > click a community group > Edit.
2. Near the bottom of the screen, check the Attach Documents in Email
Notifications box.
3. Click Save.

Generating email invitations for community management
The notification system enables Ektron to generate email that invites other users to join
a community group, join a site, or become a colleague.
To create a message:
1. Go to Workarea > Settings > Community Management > Messages.
2. Click Add Email Message.
3. Enter a title that describes the message.
4. At the Type field, click the drop-down arrow to choose the message type that will
trigger a notification.
5. Select whether to make the email message the default message for the activity
type. Only the default message is sent when the corresponding activity occurs.
Non-default messages remain available on this screen in case you want to quickly
change them in the future.
6. In the editor, enter the message text. Messages can include tokens, which retrieve
information about the user sending the invitation or the link to join a group and
display it in the message text. See also: Working with tokens on page 1686.
l @appFriendDisplayName@. The recipient's name.
l

@appFromUserDeleted@. Message is from a user that was deleted.

l

@appFromUserDisplayName@. Name of user who sent message.

l

@appFromUserID@. ID of user who sent message.

l

@appGroupName@. The group that the recipient is invited to join.
Ektron Reference
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l

@appInvitedEmail@. The recipient's email address.

l

@appInviteId@. Appends the invite ID to the registration URL. For example:
Click <a href=http://www.example.com/register.aspx&fInvId=
@appInviteId@>here</a> to accept.

l

@appMessage@. Message text.

l

@appOptionalText@. Text a user inserts into the Optional Message box on
the Invite server control.

l

@appPrivateMessageID@. The Ektron ID of a private message.

l

@appSenderName@. The sender of the invitation.

l

@appSubject@. The message's subject field.

l

@appToUserDisplayName@. Name of message recipient.

l

@appToUserID@. ID of message recipient.

l

@appToUserMessageID@. Ektron ID of the recipient's message object.

7. Click Save.

Managing notifications in a multi-site environment
In a multi-site environment, notifications stay within the site where the activity
happened. For example, if there are 2 sites—an Intranet and Social Club site—when a
user from the Intranet site performs an activity that generates a message, it does not
trigger notifications on the Social Club site.
Exception: A user’s colleagues receive notifications regardless of the site from which
the message originated.
When a message type is created, it becomes the default message used by all sites. But
you can assign a different message of the same type to each site in your environment.
To view the messages assigned to a site, go to the View All Notification Messages
screen, click the Site drop-down, and select the site.

When creating notification messages in a multi-site environment, specify the site for
the message. For example, you want a “Status Update” message targeted one way for
an Intranet site and another way for your Social Club site. The Intranet site message
might be:
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@SubjectUser.username@ has an updated status on Intranet with the
following:
@MicroMessage.Message@.

While your Social Club site might message be:
@SubjectUser.username@ has an updated status on the
Social Club with the following: @MicroMessage.Message@

Creating a community group's email address
To allow anyone to post email to a community message board, set up a community
group email address.
PREREQUISITE
l

You are a member of the Administrators group or a community group
administrator.

l

You enable notification system, as described in Setting up notifications
on page 1669.

To set up a community group's email address:
1. On community site's group page, choose Manage > Edit Group. The Edit Group
screen appears.
Or, from the Workarea, choose Settings > Community Management >
Community Groups. Click the group.
2. Click the Properties tab.
3. Check the Enable Group Emails box.
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4. Complete the fields.
l

Email Address. Enter the email address that will be used to post email to this
group's message board.
IMPORTANT: Each community group's email address must be unique.
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l

Email Account Name. Enter the email address that receives email delivered to
this group's message board.

l

Email Account Password. Enter the password for that email address.

l

Email Server. Enter the POP mail server that retrieves email for this group's
message board.

l

Email Server Port. Enter the port number used to retrieve email for this group's
message board.

l

Use SSL. Check this box if SSL is used when retrieving email.
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l

Test Connection. After you complete the above fields, click this button to verify
the information and the ability to connect to the mail server.
NOTE: If you are using Gmail as the SMTP server to fetch email replies, after
the notification service processes the emails, you probably want to delete them
from the Inbox. To set up automatic deletion of this email from the Inbox, got to
Gmail's Settings screen > Forwarding and POP/IMAP tab > Pop
Download Area > 2. When messages are accessed with POP > select
delete Gmail's copy.

Using SSL with notifications
If your site uses SSL, you must update the Ektron notification service configuration file
with that information. The file is typically located at C:\Program Files
(x86)\Ektron\EktronNotificationService\Ektron.Notification.Service.exe.c
onfig.
Change the url="http value to include an s (https).
<siteNotification>
<sites>
<add name="769723537"
url="https://your server"
connectionString="server=your server;
database=Intranet2;
Trusted_Connection=true;
User ID=;Password=;" />
</sites>
</siteNotification>

Restart the Ektron notification service to enable this change.

Using eSync with notifications
When using eSync with notifications, new agents are not synchronized. This means that
you must manually add new agents to each server in your configuration.
If an agent exists on all servers in your configuration, eSync keeps them updated. For
example, assume a membership user logs into the production server and updates the
profile’s Activities tab by changing the activities a custom agent will perform. eSync
copies those changes to the staging server.
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Activity streams
An activity stream is a series of chronologically-arranged notification messages
describing activities within Ektron's Community Feature. See also: Sending notifications
to a community on page 1665.

The following table describes the various ways of presenting an Activity Stream on your
website.

1708

For this kind of
Web page

Use this

To see notifications for

.aspx

ActivityStream server control

PageBuilder

ActivityStream widget
See also: Using the
ActivityStream widget on a
PageBuilder page on page 1713

The user or group identified
in the page’s query string.

Ektron
Personalization

ActivityStream widget
See also: Using the
ActivityStream widget on a
PageBuilder page on page 1713
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If none is identified, the
logged-in user sees his or her
own notifications.
l

Yourself

l

Your colleagues

l

Your community groups

Using the ActivityStream widget

For this kind of
Web page

Use this

To see notifications for

Community
Feature: your
profile page

No action required—Activity
Stream appears by default

Yourself

Community
Feature: a
colleague’s profile
page

No action required—Activity
Stream appears by default

Colleagues

Community
Feature: group
profile page

No action required—Activity
Stream appears by default

Community group of which
you are a member

Using the ActivityStream widget
The ActivityStream widget is installed with Ektron.
When you drag and drop an ActivityStream widget onto a Personalization page, it
displays activities performed by
l

you, the logged-in user

l

your colleagues

l

community groups to which you belong

When you view another user’s personalization page containing this widget, the
activities you see are controlled by that user’s Private Profile setting and whether that
person is your colleague.
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The following table describes when you can see another user’s Activity Stream.
If the user’s Private Profile
setting is...

and the
user is...

you can...

Public

a colleague

view the person's activities

Public

not a
colleague

view the person's activities

Private

a colleague

view the person's activities

Private

not a
colleague

only view the person's activities if you
are an administrator

Colleague

a colleague

view the person's activities

Colleague

not a
colleague

only view the person's activities if you
are an administrator

If you can view another user’s activities, you see activities that person performs and
activities that person's colleagues perform.
From this widget, you can filter the Activity Stream to view only activities from specific
users and community groups. Filtering the ActivityStream widget means restricting
notifications to those from selected users or groups. For example, you want to see only
activities performed by Kay Milford. In the filter, select Kay Milford, and the
ActivityStream widget shows messages only from her.
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As another example, you are the head of the Engineering department and want to see
your employees’ activities. To accomplish this, add them as colleagues. Then, in an
ActivityStream widget, create a filter with their names. That widget only shows your
employees’ activities.
If your department has a community group, you could add that group to the filter.
Then, in addition to your employees’ activities, you would see the group’s activities.
This feature, combined with the ability to add multiple ActivityStream widgets to a
page, lets you create separate activity streams that focus on people and groups of
interest.
The following image shows 1 ActivityStream widget that displays a user’s colleagues
(on the left), and 3 other widgets with filters that focus on individual users.
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You could take this example one step further. If Leah Mathis and Scott Markey both
work in “Sales & Marketing” and Bill Smith, Works in “Engineering,” you might only
have 2 widgets, one for Scott and Leah and another for Bill.

Filtering the ActivityStream widget
1. Click Filter at the bottom of the widget.
2. In the Users and Groups box, enter the name of a user or community group by
which to filter.
3. Click Add. Only activities performed by the selected user or community group
members appear.
IMPORTANT: A valid name is one that exactly matches a user’s Display Name
or community group’s Group Name. If your entry does not match, the widget
refreshes and no filter is added.
Also, the selected users or community groups appear in the widget’s filter area.
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You can add as many users or community groups to the filter as you like, one at time.
After you finish, you can hide the filter by clicking Hide.

Removing an entry from the ActivityStream widget filter
NOTE: If you remove all users and groups from the filter, the widget shows
notifications from all users whose activities you can view.
1. If you cannot see the filter’s users or community groups, click Filter at the bottom
of the widget.
2. Click Delete ( ) next to the user or community group you want to remove. The
ActivityStream widget refreshes, and the removed user or community group’s
activities disappear from the stream.

Using the ActivityStream widget on a PageBuilder page
NOTE: To learn about Ektron's PageBuilder functionality, see Creating Web pages
with PageBuilder on page 1075.
When used on PageBuilder page, the ActivityStream widget shows the logged-in user’s
activities by default. However, you can modify the widget to focus on another user’s or
community group’s activities.
For example, you create a PageBuilder page about your company's CEO and want to
display notifications about activities that the CEO, colleagues, and community groups
perform on the site.
To accomplish this, add the ActivityStream widget to a “See what the CEO is Up To”
page. While doing that, specify the user ID assigned to your CEO (available from the
CEO's User Profile). Upon visiting the page, a user sees a list of the CEO’s activities.
To display another user’s or community group’s activities in the ActivityStream widget:
PREREQUISITE
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The ID number of the user or community group whose notifications will
appear
1. Drag and drop the ActivityStream widget. The following dialog appears.

2. Use the Feed Type drop-down to select User or Community Group.
3. In the Object ID field, enter the user’s or community group’s ID.
4. Click Save.

Sharing an activity stream event on your profile
Each activity in a stream has a Share link under its text.

When you click Share on someone's status, it appears in your profile's status, too.

Commenting on an activity stream event
Each activity in a stream has a Comment link under its text. When you click it, a
Comment box opens for you to add a comment. When you finish, the comment link
displays the number of comments on that activity. Users can click the number to view
the comments.
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Only the user who made the comment or a member of the Ektron Administrators group
can delete the comment.

Setting up a time display for activity stream events
You can set up an activity stream to assign a time ago link to each event.

When a site visitor clicks that link, the activity stream event is launched in a new
browser. From there, the site visitor can use the page's URL to uniquely identify the
event. For example, the user can forward the URL to other users to notify them about
the event.
To add a time ago link to a page:
1. Create a Template Activity page. It must be an .aspx template with an activity
stream server control that includes these properties.
l ObjectType—enter Activity
l

DynamicObjectParameter—enter id

2. Open the template that hosts the ActivityStream server control to which you want
to add a time ago link.
3. To the ActivityStream server control, add the TemplateActivity property. As the
value for that property, enter the template page you created. That page appears
when a site visitor clicks the time ago link.
Ektron Reference
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Here is an example of an Activity Stream server control with a sample value for
that property.
<CMS:ActivityStream ID="ActivityFeed1"
runat="server" EnablePaging="true" DynamicObjectParameter="id"
TemplateUserProfile="profile.aspx" TemplateActivity="activity.aspx" />

Displaying RSS feed links
Ektron provides the following RSS feed links that can display activity stream events.
l

http://your website/workarea/webservices/feeds.svc/userstatuses/user
ID number.rss
For example: http://your
zwebsite/workarea/webservices/feeds.svc/userstatuses/1.rss
Displays the specified user’s status updates. For example, 1.rss shows all status
updates of the user whose ID is 1.

l

http://your
website/workarea/webservices/feeds.svc/publictimeline.rss
Displays all public status updates

l

http://your
website/workarea/webservices/feeds.svc/publictimeline.rss?search=new
Displays all public status updates that include the term "new"

You can use these feeds with Ektron's API to access and display status updates.

Troubleshooting activity streams
Problem. Notifications do not appear in my Activity Stream and the configurations are
set for Notifications and User/Group Activities. Also, the Application Event log shows the
following error: An exception occurred while enqueueing a message in the target
queue. Error: 15404, State: 11, Could not obtain information about Windows NT
group/user 'WIN-I2VJT0GQ8I2\Administrator', error code 0x534.
This occurs when the person who created the database is not the same person who
created the queues. This creates permission issues when trying to write to the queue.
Solution. Do 1 of the following:
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l

Set the user that writes to the queue with the permission level of "dbo."

l

Run the script sp_changedbowner "sa" where "sa" is the user name who writes to
the queue.
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Defining flags for content
Flagging lets site visitors provide feedback about a piece of content, thereby enabling
site visitors to moderate your site. This is especially important for sites with large
amounts of visitor-generated content. Flagging also helps site visitors feel invested in
the site.
For example, a flagging list can describe types of inappropriate content, such as:
l

Sexually Explicit

l

Mature (over 18 only) content

l

Graphic Violence

l

Hate Speech

Flagging can also indicate the quality of content, so can help create a recommended
content list. For example:
l

I loved this content.

l

I hated this content.

l

I am neutral about the content.

Flagging is similar to the ContentReview server control, except flagging feedback is not
displayed on the site. Also, the Flagging control provides a list of reasons for the flag.
So, a flagging definition describes how a content item may be reviewed, and provides a
list of reasons for the flag. For example:

After creating a flagging definition, you assign it to relevant folders. All content in those
folders can be flagged with that definition.
IMPORTANT: As the final step in letting site visitors flag content, a developer adds
a ContentFlagging server control to a Web page, and assigns to it the ID of the
content being flagged.
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Flagged content appears in the following Workarea locations.
l

ContentFlags list on the Smart Desktop

l

Settings > Community Management > Flagging > Flagged Content

l

a content item’s View Content Reports > Flagging tab

The Flagging Definitions screen is located in the Workarea > Settings > Community
Management > Flagging. Here, you can view a list of flagging definitions, work with
them, or create new ones.
This screen contains the following information about a flagging definition.
l

ID. The ID of the flagging definition.

l

Name. The name of the flagging definition.

l

Description. A description of the flagging definition.

l

Language. The national flag of the language. For example, American English is

l

Items. The number of flags in a definition. For example, the number is 4 if you
have a flag definition for these movie ratings: G, PG, PG-13, and R.

Adding a flagging definition
1. In the Workarea, go to Settings > Community Management > Flagging >
Flagging Definitions.
2. Select a language with which the flagging definition will be associated.
3. Click Add New Flag Definition. The Add Flagging Definition screen appears.
4. Enter a Name and Description for the flagging definition.
5. Click Option ( ) to add a flag choice to this flagging definition.
6. Continue to click the Option button to add additional flag choices.
7. Optionally change the order of the flag choices by clicking the Sorting buttons (
).
8. Click Save.

Editing a flagging definition
1. In the Workarea, go to Settings > Community Management > Flagging >
Flagging Definitions.
2. Click the flagging definition Name link or the ID link.
3. Edit the options. If desired, you can change the order of the flagging options by
clicking the Sorting buttons (
4. Click Save.

Deleting a flagging definition
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).

.

Assigning a flagging definition to a folder

When a flagging definition is deleted, it is removed from all folders with which it was
associated.
1. In the Workarea, go to Settings > Community Management > Flagging >
Flagging Definitions.
2. Click the flagging definition Name link or the ID link.
3. Click Delete ( ).

Assigning a flagging definition to a folder
After creating a flagging definition, you may assign it to folders. If you do, the flagging
definition is applied to all content in that folder.
Like other folder properties, a folder’s flagging definitions may be inherited by its child
folders, although this does not occur by default.
To assign a flagging definition to a folder:
1. Create a flagging definition, as explained in Adding a flagging definition on the
previous page.
2. Click the Workarea Content tab.
3. Go to the folder that contains the content to be flagged.
4. Select View > Properties from the View menu. The View Properties screen
appears.
5. Click Edit Properties.
6. Click the Flagging tab.
7. Make sure the Inherit Parent Flagging Configuration check box is not
checked.
8. Select a flagging definition from the Flagging drop-down.

9. Click Update.
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Working with flagged content
From the Smart desktop
To see content flags, you must add the Content Flags widget to your desktop. The
Content Flags widget lists the 10 most recently-added content flags. From there, you
can view a flag by clicking its title. To view all recent flags, click the View recent flags
link. Clicking this link takes you to the Content Reports: Recent Flags screen.

From the settings tab
Settings > Community Management > Flagging > Flagged Content shows all
flagged content.
NOTE: You can also access this report from the Workarea > Reports > Contents
> Content Flags.

l

Showingflagsforthelast#days. Enter a new number of days for which to show
Flagged Content. Click Report to refresh the display.

l

Title. The title of the content block being flagged. Clicking this link brings you to a
detailed description of the content’s flag.

l

Display Name. The name of the user who flagged the content.

l

Date. The date the content was flagged.

l

Flag. The specific flag from the flagging definition for this content.

l

Comment. Comments added by the site visitor who flagged the content.

To print the flagged content report, click Print (

).

Filtering flagged content by folder
From the Content Reports: Flagged Content screen, you can filter flagged content by
folder. To do so:
1. In the Workarea, go to Settings > Community Management > Flagging >
Flagged Content.
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2. Click Filter Reports by Filter (

). The Select Folder screen appears.

3. Select a folder.
4. Click Save. The page refreshes, and any flagged content in the folder is shown.
NOTE: Only content flagged within the time frame for the Showing flags for the
past # days field is shown. For example, if the field is set to 5, only content that’s
been flagged in the last 5 days appears.

Filtering flagged content by language
To see flagged content for a specific language, select the language from the Language
drop-down box.

From the content report
You can also view flags for a content from the Content Report screen's Flagging tab.
You can filter flags by a date range or see all flags associated with the content. This
screen also contains a purge button, which removes all flags associated with this
content.

Viewing flags applied to a content item
1. In the Workarea, find the content for which to retrieve content flags.
2. Click the content title. The View Content screen appears.
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3. Click Content Reports (

4. Click Start Date (

). The Content Report screen appears.

) and End Date (

) to select a date range.

NOTE: To retrieve all flags, leave Start Date and End Date blank.
5. Click Get Flags. A list of flags applied to that content within the selected date
range appears.

Purging a content item’s flags
1. In the Workarea, find the content block for which to purge content flags.
2. Click the content title. The View Content screen appears.
3. Click Content Reports (
4. Click Start Date (

).

) and End Date (

) to select a date range.

NOTE: To retrieve all flags, leave Start Date and End Date blank.
5. Click Purge Flags.

Viewing the details of a flag
Viewing a flag’s detail lets you read the entire comment, even if it is truncated in one of
the lists. You can also edit or delete a flag from this screen.
1. Go to one of these area in the Workarea:
l Smart Desktop > Content Flags widget
l

Settings > Community Management > Flagging > Flagged Content

l

Reports > Contents > Content Flags

2. Click either a flag’s content title or its date. The flag’s detail information appears.
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Editing the details of a flag
Edit a flag when you want to change the selection or the comments of a flagged content
item. This can be useful if a user selects a flag by mistake, or you want edit its
comments. For example, a user selected the “Offensive Content” flag but the user
meant to choose “Copyright Violation”.
1. Go to one of these area in the Workarea:
l Smart Desktop > Content Flags
l

Settings > Community Management > Flagging > Flagged Content

l

Reports > Contents > Content Flags

2. Click either a flag’s content title or its date. The flag’s detail information appears.
3. Click Edit.
4. Change the flag or edit the comments.
5. Click Save. The flag’s information is changed.

Deleting a flag
NOTE: To remove all flags for a content item, see Purging a content item’s flags on
the previous page.
1. Go to one of these area in the Workarea:
l Smart Desktop > Content Flags
l

Settings > Community Management > Flagging > Flagged Content

l

Content Reports > Flagging tab for a content item

2. Click either a flag’s content title or its date. The flag’s detail information appears.
3. Click Delete (

).

Tagging content, library items, users, and groups
with keywords
Tags are keywords that you can assign to users, groups, content, and library items. On
a website, tags for a user or group appear in a profile, helping site visitors learn about a
user or group.
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You also can perform tag-based searching.

For example, you tag content related to a new product release with “Widgets 2.0.”
Anyone could enter that term into the Search box, click Tags from the drop-down list,
then Search to find all related content.
Tags are used in these Workarea locations:
l

User Information screen’s Tags tab, for users or membership users

l

Community Group screen’s Tags tab

l

A content item’s Metadata tab > Tags area

l

A library item’s Metadata tab > Tags area

l

Settings > Community Management > Tags

NOTE: The CommunityGroupBrowser, CommunityGroupProfile, and
CommunityGroupList server controls can display group tags and link them to a list of
all groups that share the tag. Also, the TagCloud server control displays a weighted
list of tags.

Tag types
There are 2 tag types:
l
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Default
o Created by system administrator in Settings > Community Management
> Tags area
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o
l

Appear as checkbox options where tags can be applied

User-created
o Created by user wherever tags can be applied

Creating default tags as administrator
An Ektron administrator can create default tags for each object (user, user group,
content or library item). For example, you want to let users associate themselves with a
favorite race car driver. You create a default user tag for each driver’s name. When a
user creates or edits an item for which you created the default tags, the tag appears
and the user clicks check boxes to assign them.

Ektron provides screens for creating default tags for user groups, users, content and
library items. They are available via Settings > Community Management > Tags.
1. In the Workarea, go to Settings > Community Management > Tags and select
on the default tag items.
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2. Select a language for the tag.
3. Add the tag in the empty text box. If no empty box appears, click Add (
enter the tag.

) then

4. Click Save Tag.

Creating tags as end user
Users, community group leaders, and content editors can create their own tags. For
example, while you are editing content, you decide that none of the default tags is
correct. So, you create and assign a new tag: Rosebud. That tag is now applied to that
content.

The tag also appears on the Settings > Community Management > Tags screen,
where you can see its ID number. If someone creates another tag with the same name,
it shares the ID number with the previous one, and the Times Used increases from 1
to 2. However, the new tag does not appear as a default on any screen.

Managing tags
Administrators manage tags from the Settings > Community Management > Tags
screen. This screen displays all default and user-created tags. You can filter the list by
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language. Click any tag’s name to see its details.

This screen displays the following information about each tag.
l

ID. Tag's integer ID

l

Name. Tag's title

l

Times Used. The number of times a tag has been assigned

l

Language. Its language. This appears as a national flag. For example, American
English appears as .

When you click a tag’s name, its details appear on the View Tag screen.
l

ID. Tag's integer ID

l

Language. Tag's language

l

Name. Tag's title

l

Tagged Type. Shows how the tag is assigned: to a community group, user,
content, or library item.

l

Times Used. The number of times this tag is assigned to each Tagged Type

Deleting tags
To delete each tag type:
l

User-created
o Deleting a single tag
1. Open the item’s Tags area. For example, for content, edit the Metadata
tab.
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2. Uncheck the checkbox next to the tag.
3. Publish the content.
o

Deleting all occurrences of a tag
1. Go to the Settings > Community Management > Tags screen.
2. Click the tag.
3. Click delete ( ).
4. Click OK.

l

Default. There are 2 methods for deleting default tags. Each has different results.
o Deleting a Default Tag
n No longer available for assignment to users, content, and so on.
n

Existing links to it remain

1. Go to Settings > Community Management > Tags
2. Select the screen for the kind of tag you want to delete (group, user,
content or library).
3. Select the language.
4. Click ( ) to the right of the tag you want to delete. You are asked if you
are sure. Click OK.
5. Click Save.
o

Deleting a Default Tag and All of its Links
n No longer available for assignment to users, content, and so on.
n

Existing links to it are deleted

1. Go to the Settings > Community Management > Tags screen.
2. Click the tag.
3. Click Delete ( ).
4. Click OK.

Using Ektron's micro-messaging bookmarklet
A micro-messaging bookmarklet, a feature of Ektron's Community Platform, lets you
use a micro-message to inform colleagues about a Web page without leaving it. To
create this micro-message:
1. Go to a Web page.
2. Click a Share This link on the browser's Bookmark or Favorites menu/toolbar.
NOTE: In Internet Explorer, these toolbar shortcuts are known as favorites. In
Firefox, they are known as bookmarks. This documentation calls them
bookmarks.
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3. That action generates a link to that Web page as a micro-message. You can add a
comment.

Submitting a Web page link as a micro-message
PREREQUISITE

To enable the Bookmarklet feature, a developer places a Bookmarklet server
control on a page and (if desired) Review and modify the post to profile form
on page 1731.
Before you can use the Micro-messaging bookmarklet feature, add a Bookmarklet link
to your bookmark toolbar or menu.
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1. Go to a page that contains a Micro-messaging bookmarklet link.

NOTE: The text of the Micro-messaging bookmarklet link changes according to
the user's browser. Also, the image above text reflects default text; developers
can easily change it.
2. Right click a bookmarklet link and follow the screen instructions to add it as a
Bookmark. The Bookmarklet appears on the toolbar.

3. Go to a page that you want to post as a micro-message.
4. Click the bookmarklet link. The following screen appears.
NOTE: If you are not logged in to Ektron, you are prompted to do so.
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5. Add comments to replace What would you like to say?
6. Click to edit the title and description.

7. Click Share. The post is shared in a micro-message with colleagues.

The micro-message appears in the user's Activity Stream if it is set up to track micromessages.

Review and modify the post to profile form
Ektron provides the following sample form to appear when a user clicks the Micromessaging bookmarklet link on the browser's Bookmarks menu.
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The sample form is siteroot/Workarea/share.aspx. To modify this form or create
your own, enter the new path into the Micro-messaging Bookmarklet server control's
FormURL property.
Here are a few things to note about this form's behavior.
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l

If a user is not logged it, add a Login server control to prompt the person to do so.

l

The form lets the user enter or update 3 fields
o comment entered by user
o

title tag text

o

meta description

l

All text on the form (including the URL) cannot exceed 2000 characters.

l

The form accepts plain text only—no formatting or images are allowed.

l

This size of the screen is determined by the Bookmarklet server control's
PopupHeight and PopupWidth properties.

l

The form generates a Micro-message, so it follows the conditions for how Micromessages are published.
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IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
NOTE: eCommerce requires a special license from Ektron. Only members of the
Administrators group or those assigned the Commerce Admin role can access the
eCommerce screens within the Workarea. If you do not see the Commerce folder
under Settings tab of the Workarea, it may be because your license does not
support eCommerce. For licensing information, contact sales@ektron.com.
NOTE: While some earlier Ektron versions supported PCI compliance, version 9.10
does not offer PCI support. You may still enable PCI compliance mode in the
web.config file if that helps your eCommerce site. To learn about enabling PCI
compliance mode, see the 7.6 eCommerce Compliance Guide.
Ektron eCommerce gives you a tool set for building the online marketplace you want.
Ektron lets you manage both your website and online marketplace from the same
interface.
Ektron’s eCommerce solution is a flexible and feature-rich platform that offers the
functionality that shoppers expect in an online marketplace.
l

eCommerce reuses many standard Ektron components, so you can leverage
existing Ektron experience to quickly build the store and use server controls to
create the Web pages that customers use to purchase goods and services.

l

Administrators manage products, review inventory, and use Ektron’s powerful
taxonomy to enhance product SEO.

l

Developers use the flexible and scalable API to import an existing store, configure a
customized integration with a payment gateway, and integrate with financial
software.

l

You can sell memberships and/or access to premium content.

l

State and local governments can process online vehicle registration and tax
payments, and event sites can sell tickets.

eCommerce has the following features.
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l

Shared data. As a .NET application, eCommerce uses the same database as Ektron
(to maximize efficiencies) and takes advantage of SQL cluster capabilities to be
scalable. You do not need “glue code” to tie a third-party eCommerce application to
your website. Ektron eCommerce integrates with an IT infrastructure using
Ektron’s existing customizability. Open architecture and a new
ektron.cms.commerce API makes any commerce configuration possible, letting
you connect it to your back-end systems.

l

Imported data. Import existing product data into eCommerce using Ektron’s API.

l

Flexiblility. eCommerce supports single items, complex products (for example,
movies that are available in DVD, Blu-ray®, or other formats), bundles, and kits.
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l

Enhance your SEO. You can enhance product SEO in the Smart Form by setting
attributes, adding metadata, and including photos and other media.
o eCommerce uses key Ektron technologies, including Smart Forms, taxonomy
and search. Smart Forms standardize how product information is entered;
information, attributes, and descriptive text are entered in one place and go
into the database as structured XML data (making it easy to re-purpose this
content wherever and whenever you need it).
o

Adding images of products automatically generates thumbnail images and
gives you complete control over sizes and number of images, as well as a
click-through image gallery. You also can define images for a product type via
the taxonomy.

l

Classify products in multiple ways. taxonomies help customers find what they are
looking for by associating them with multiple categories. For example, a wireless
mouse and an external hard drive may belong to a computer peripherals category
but also to categories for mouses and disk storage. Control over your product
catalog extends to cross-sell and upsell features.

l

Web 2.0 controls. include memberships, ratings, forums and commenting that let
you quickly implement an eCommerce site with the community-based information
customers want when making buying decisions. Your customers can post opinions
and ratings on products. The product search uses taxonomy, which you can filter
by price, ratings, reviews, and more.

l

eCommerce customer memberships. Customers can create and save shopping
baskets for future purchases, or create wish lists and registries. Your site
administrators can see which baskets are open.
o When an order is reviewed and submitted (and payment is authorized), it can
go through a simple or complex routing through your processing setup or
plug-in to your existing CRM or ERP to process the order.
o

When an order is processed, the CRM/ERP notifies Ektron that it is complete.
Online inventory is kept up-to-date; you can set properties so that when items
on hand drop below a certain level, your inventory control system is notified.

o

You can display the checkout process on a single page or distribute it across
multiple pages. Customers can save one or more shipping addresses, or check
“same as billing” when they check out.

o

You can accept credit cards, checks, and PayPal accounts. Ektron also
supports payment gateways (such as Payflow and Authorize.Net) to authorize
and capture transactions. You can create your own payment gateway (that
allows terms or other payment options, for example).

o

Connect with external providers to use real-time rates for shipping, or use
your own rates by setting up an internal shipping provider. You can customize
rates and set up rates by package size, product weight, and even product price
ranges.
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l

Coupons, taxes, and pricing
o eCommerce supports an array of pricing schemes: individual pricing, separate
pricing within complex products, tiered pricing to support volume discounts,
and more.
o

Online coupon capability lets you set the type (dollar amount, percentage) and
at what level coupons are applied (product level, basket level, and type of
item).

o

For global business opportunities, international currencies are available. You
can use conversion rates to determine prices or set flat costs for each product.
This goes hand-in-hand with the tax options available.

o

Set tax classes, including country, state, and local (by postal code), and taxes
for specific classes of goods.

eCommerce architecture
The Ektron eCommerce architecture is composed of several key systems:
l

Catalog/inventory system

l

Order system

l

Shipping system

The eCommerce API is situated within the core Ektron system with customization and
integration points. The following figure shows the eCommerce API within the overall
Ektron architecture.
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The following topics provide an overview of several key eCommerce systems.
l

eCommerce workflow below

l

eCommerce inventory process on the next page

l

eCommerce order fulfillment on page 1739

l

eCommerce subscription model on page 1740

l

eCommerce shipping process on page 1741

l

Conducting eCommerce on page 1733

eCommerce workflow
Ektron leverages Windows Workflow Foundation for order processing.
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Windows Workflow Foundation is a framework that lets you create system or human
workflows. It consists of a namespace, an in-process workflow engine, and designers
for Visual Studio. It comes with a programming model, a re-hostable and customizable
workflow engine, and tools for quickly building workflow-enabled applications on
Windows.
Windows Workflow Foundation gives site developers complete control over how your
store “works.” The workflow is extensible and can integrate with third-party ERP/CRM
systems. There are default Ektron activities such as email notification and inventory
checks. You can customize the workflow to match your organization's business
processes.

eCommerce inventory process
The inventory process uses an inventory provider model. You can use the inventory
system included as part of Ektron’s eCommerce module, or plug into external systems.
The inventory process is called from the order workflow and is extensible.
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eCommerce order fulfillment
Order processing in Ektron includes the management of custom coupons, shipping
providers, tax calculation and payment providers.
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eCommerce subscription model
Ektron’s eCommerce solution lets you not only sell durable goods, but also
memberships and subscriptions. It uses a provider model, and the default
implementation provisions users into groups.
You let shoppers buy membership directly on your site (access to assets or content) and
configure recurring billing at any interval.
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eCommerce shipping process
The shipping system calculates real-time rates from FedEx or UPS by default. However,
its provider model lets you configure the API to access rates from any provider. The
shipping system is completely customizable and extensible.
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Trying a sample eCommerce site
Ektron OnTrek is a sample eCommerce site. Within that site, you can try out a customer
shopping experience by going to http://[siteroot]/OnTrek/. Login to OnTrek and go
to Products > Software. A product catalog screen appears. For information about
Ektron OnTrek, see .
Click the Add to Cart link below a product. You can proceed through a sample
checkout process. OnTrek uses the following eCommerce server controls to facilitate
this process.
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l

Cart

l

Checkout
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Additional eCommerce topics
This chapter also contains the following topics.
l

Designing an eCommerce site below

l

Setting up an eCommerce website on page 1749

l

Configuring eCommerce on page 1763

l

Creating product types and catalogs on page 1806

l

Recommending related products to a customer on page 1838

l

Using coupons on page 1841

l

Managing customer orders on page 1850

l

Viewing customer information on page 1866

l

Generating eCommerce reports, widgets, and logs on page 1868

l

eCommerce Server Controls

l

Customizing eCommerce on page 1877

See also: Using eSync with eCommerce on page 2030

Designing an eCommerce site
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
To demonstrate how to set up, build, and deploy an online marketplace using Ektron,
the example site in this topic (EktronStore.com) sells furniture and accessories and
leverages many eCommerce features.
Before you start building the EktronStore.com website, consider the goals of your
online marketplace. Do you want to simply sell as many products as possible? Or, is the
website a value-added component designed to enhance the customer (site visitor)
experience? When considering the design and functionality, what you intend to sell
plays a significant role. For example, are you selling durable goods? Subscriptions?
Access to premium content? All of the above? These consideration can help you plan
your website's layout.
Shipping options, payment methods, taxation, and the look-and-feel of your store's
website also need to be determined. Be sure to address your store's general workflow—
that is, how shoppers are guided through the shopping experience.

Designing the sitemap
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A sitemap depicts the website's architecture, identifies the major pages, sections, subsections, and shared elements of the site, and is typically organized in hierarchical
fashion. The following image is the sitemap for Ektron's sample site, OnTrek.

Designing the wireframes
Next, plan and scope out the major pages in your store. Using pencil and paper or
software, sketch the basic architecture and components of individual store pages. This
visual guide is referred to as a wireframe.
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Creating mockups
The wireframe helps inform visual design. Typically, a graphic artist creates mockups
(or visual preview) of store pages for stakeholders to review without actually building
Web pages.
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Creating callouts
Callouts help identify functional areas on store pages. Using mockups, identify
navigation areas, locations for promotional information, header and footer details, and
the location of Ektron controls.
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Using images in eCommerce
When using eCommerce, a customer sees images that represent products or services
for sale. The following list shows each image that appears on an eCommerce website,
and its source.
l

Product server control, main image, located on the catalog entry's Content tab.
NOTE: The sample catalog entries are based on Product Types whose XML
Smart Form includes an Image field. As a result, the product description (which
appears at the top of the Product Server control) includes an image. This is not
required, merely a suggested implementation.

Ektron Reference

1747

Conducting eCommerce

l

Product server control, thumbnails, located on the catalog entry's Media screen.
NOTE: To control the thumbnail display, use the XSLT files generated by the
Product, Product List, Product Search, and Recommendation server controls.
When a customer clicks a thumbnail, the corresponding full image appears.
Because the Media screen can have several images, several thumbnails can
appear. They appear left to right reflecting their sequence (top to bottom) on the
Media screen. If an image’s Gallery Display field is set to Yes, its smallest
thumbnail appears on the Product server control, below the content area. (This
assumes you are using the control’s default XSLT.) See also: Determining
thumbnail size on page 1834.
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l

ProductList, ProductSearch templated server controls, and Recommendation
server controls located on the catalog entry’s Media tab, the image designated as
Product Icon.

Setting up an eCommerce website
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
This section describes how to set up a basic eCommerce website. This walkthrough
explains everything you need to set in the web.config file and the Workarea. The
section includes a list of needed templates and describes how to set up Ektron’s
eCommerce server controls on them.

Required templates
To create a basic eCommerce site, you need the following templates.
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l

Master page. Recommended, but not absolutely necessary. This template could
contain any of the following:
l Select Currency. Lets customers choose a currency with the CurrencySelect
server control.
l

View Cart link. Links to the template containing the Cart server control.

l

View My Account/Orders link. Links to the template containing the
MyAccount and OrderList server controls.

l

Login server control. Lets customers and users log in from any page.

l

Landing page. This page should enable customers to start shopping and could
contain a Product server control.

l

Product Display page. Use the Product server control on a template to display
the details of a catalog entry (product). If you are using the Cross Sell or Up Sell
functionality, add a recommendation server control to this template.

l

Product Search page. Use the ProductSearch templated server controls on a
template to let customers search for product.

l

Cart page. Use the Cart server control on a template to allow a customer to work
with items they have selected to purchase.

l

Checkout page. Use the Checkout server control on a template to facilitate the
check out process.

l

My Account/Order History page. Use the MyAccount and OrderList server
controls to display a customer’s account information and a list their order history.

Step 1. Set keys in web.config
WARNING! Do not change the settings for the default currency or measurement
system after the site is live.
In the website’s web.config file, set the following keys:
l

<add key=”ek_ecom_DefaultCurrencyId” value=”840” />
This key determines the base currency for your website. The default is 840 (the US
dollar). If needed, change to the Numeric ISO code for the default currency. See a
list of currencies and Numeric ISO codes on the Workarea > Settings >
Commerce > Configuration > Currencies screen. The ID is the Numeric ISO
code. See also: The default currency on page 1767.

l

<add key=”ek_MeasurementSystem” value=“English” />
For each item on your website, define a height, length, depth, and weight. If
English, the units are inches and pounds. If Metric, the units are centimeters and
kilograms. This information is used to calculate shipping costs. By default, this is
set to English. Change to Metric to use the Metric system. See also: Configuring
packages on page 1792.
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l

<add key=”ek_ecom_ComplianceMode” value=”false” />
Set this key to “true” when you want your site to be Security Compliant. This
means the Workarea will be encrypted in an SSL session, and logging is started.

Step 2. Select inventory system
Decide whether you want to use Ektron’s inventory system or an existing inventory
system. To use an existing system, add the custom provider between the web.config
file's <providers> tags and enter the name of your custom inventory provider. For
example:
<inventoryProvider defaultProvider=”MyCustomInventoryProvider”>
See also: Customizing the inventory provider on page 1909.

Step 3. Select a default payment gateway
1. Go to Settings > Commerce > Configuration > Payment Gateway.
2. Click a payment gateway’s name.
3. Click Edit.
4. Add your User ID, password and any needed custom values.
5. Click the Default check box to make that selection the default.
6. Click Save.
NOTE: If you decide to use PayPal instead of one of the default payment options,
see Using PayPal with Ektron eCommerce on page 1770.
If you are not using a gateway, create a custom payment provider and add it to the
web.config file’s EktronPaymentGateway element. Add the custom provider between
the EktronPaymentGateway’s <providers> tags. When added, the option should
appear in the Workarea’s Payment Gateway screen.
If you want to override the Workarea settings, change the default provider in the
web.config file from “Automatic” to the name of the desired payment gateway. For
example:
<EktronPaymentGateway defaultProvider=”AuthorizeNet”>
See also: Configuring payment options on page 1770.

Step 4. Set up a shipping provider
If you are not using the default flat rate shipping provider, open the shipment.config file
and set the default provider set in <shipmentProvider
defaultProvider=”FlatRateShipmentProvider”> to either “FedExShipmentProvider” or
“UPSShipmentProvider”. If you are using either of these shipping methods, complete
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the following information in the <providers> tags. This information is provided by
FedEx and UPS.
l

key=””

l

password=””

l

accountNumber=””

l

meterNumber=””

You can also add additional providers.
See also: Configuring eCommerce shipping screens on page 1790.

Step 5. Enable countries
Enabling a country where your website will sell its products:
l

makes it available for customers in a shipping and billing address

l

makes it available when you add a warehouse

l

automatically enables its corresponding tax table in the Country Tax Table section
of the Workarea

NOTE: The United States is enabled by default.
To enable a country:
1. Go to Settings > Commerce > Configuration > Countries.
2. Click a country’s name.
3. Click Edit.
4. Click the Enabled check box.
5. Click Save.
See also: Configuring countries on page 1763.

Step 6. Add and enable regions
Add and enable regions for each country your eCommerce site will service.
NOTE: All US states are enabled by default.
Regions can represent states, provinces, territories, and so on and further define areas
of a country. Adding and enabling a region:
l

makes it available for customers in a shipping and billing address

l

makes it available when you add a warehouse

l

automatically enables its corresponding tax table in the Regions Tax Table section
of the Workarea

To add and enable regions:
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PREREQUISITE

The region’s country is defined in the Countries screen.
1. Go to Settings > Commerce > Configuration > Regions.
2. Click New > Region.
3. Enter a name.
4. Click the Enabled check box.
5. In the Code box, enter an abbreviation for this region.
6. Select this region’s country from the pull down list.
7. Click Save.
See also: Configuring regions on page 1764.

Step 7. Enable currencies
If your website is selling products in another country and you want to display prices in
its currency, enable it in the Workarea:
NOTE: By default, U.S. dollar, Euro, and Australian dollar are enabled.
1. Go to Settings > Commerce > Configuration > Currencies.
2. Click a currency.
3. Click Enable.
4. Set the Exchange Rate. The default currency (set in the web.config file) is the
base reference currency when setting an exchange rate.
5. Click Save.
See also: Configuring countries on page 1763.

Step 8. Select credit cards
Decide which credit cards your eCommerce site will accept.
Credit cards are used during the checkout process, by the Checkout server control,
during the submit phase. During this phase, all enabled credit cards appear in a dropdown, which customers use to select their choice.
Add credit card types in the Workarea.
1. Go to Settings > Commerce > Configuration > Credit Card.
2. Choose New > Credit Card Type.
3. Enter the credit card’s name; for example, Visa.
4. Check the Accepted check box.
5. Add an image.
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6. Add a Regex Expression to validate the credit card number.
7. Click Save.
See also: Configuring credit card types on page 1788.

Step 9. Add or edit notification messages
Email notifications are sent to your customers after their order has been received,
canceled, shipped or completed. Ektron provides 4 predefined messages, 1 for each
event. For messages to be sent, content notifications must be enabled and the
customer must enter a valid email address.
1. Go to Settings > Commerce > Configuration > Messages.
2. Click the title of the message.
3. Click Edit.
4. Change the properties and fields as necessary.
5. Change the text as needed.
See also: Configuring countries on page 1763.

Step 10. Create tax classes (optional)
If you are collecting taxes for transactions on your eCommerce site, create a Tax Class
for each taxable category of products. For example, if your eCommerce site sells alcohol
and tobacco, set up a tax class for each type. Ektron provides 4 default tax classes:
l

Alcohol

l

Goods

l

Services

l

Tobacco

Tax classes are applied to Postal, Regional and Country Tax Tables. In those tables, you
define a separate rate for each Tax Class.
1. Go to Settings > Commerce > Tax > Tax Classes.
2. Choose New > Tax Class.
3. Enter a name; for example, Food.
4. Click Save .
See also: Cataloging entries that can be taxed on page 1801.

Step 11. Set tax rates
When your Tax Classes are set up, set a tax rate for each class in the Postal, Regional,
or Country Tax Tables.

1754

Ektron 9.40 SP1

Step 12. Select shipping methods

l

Postal Tax Tables. Use when there is a city or county tax. If there are postal,
regional and country taxes applied to a given area, roll them all into this table.

l

Regional Tax Tables. Use when there is a state, provincial or territorial tax. If
only regional and country taxes are applied to a given area, roll them into this
table.

l

Country Tax Tables. Use when there is country-wide tax. If only country level
taxes are applied to a given area, use this table.

Ektron checks these tables in the following order: Postal, Regional, then Country. When
it finds a tax, it stops. Therefore, if a postal zone has several taxes (for example, a local
tax and a regional tax), build the combined percentage into the postal code tax. So, if
New York City has a 4% tax, and New York state has a 3% tax, enter 7% into all Postal
Tax Tables within New York City.
While you need to create each Postal Tax Table, Regional and Country Tax Tables are
automatically generated when a country or region is added to Ektron. However, no tax
rates are defined in these tables.
To create a new Postal Tax Table:
1. Go to Settings > Commerce > Tax > Postal Tax Tables.
2. Choose New > Postal Code.
3. Enter a Postal Code.
4. Select the Country and Region.
5. Enter a tax rate for each Tax Class as needed.
6. Click Save.
To edit a Region’s or Country’s Tax Table:
1. Go to Settings > Commerce > Tax > Regional Tax Tables or Country Tax
Tables.
2. Click the Id or Code of the Region or Country.
3. Click Edit.
4. Change the information as needed.
5. Click Save.
See also: Applying local taxes on page 1802, Configuring regional tax tables on
page 1803, and Configuring country tax tables on page 1805.

Step 12. Select shipping methods
When you set up a shipping provider, define your customers' shipping options. For
example, if you use UPS, define whether to allow Next Day, 2nd Day, 3rd Day, Ground,
World Wide Standard, and so on. When enabled, a Shipping Method appears in the
Shipping Method phase of the Checkout server control.
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1. Go to Settings > Commerce > Shipping > Methods.
2. Choose New > Shipping Method.
3. Enter a Name. This name represents the option in the Shipping Method phase of
the checkout server control.
4. Click the Active check box to enable this method.
5. Click View Options.
6. From the Provider Service drop-down, select a shipping method.
7. Click Save.
8. Repeat these steps for all shipping methods.
See also: Configuring shipping methods on page 1793.

Step 13. Add a warehouse
Add a warehouse from which your products will be shipped. This does not have to be the
actual shipping address for the products. Ektron uses this information to determine the
“from” address when calculating shipping cost.
1. Go to Settings > Commerce > Shipping > Warehouses.
2. Choose New > Warehouse.
3. Complete the address information fields. Only countries and regions that have
been enabled for eCommerce appear in the drop-down lists.
4. Click the Default Warehouse check box if you want this to be the default
warehouse. Only the default warehouse is used in the checkout process.
5. Click Save.
See also: Using a warehouse on page 1790.

Step 14. Define package sizes
Define each package size your shipping department uses to ship your products.
Tangible products have size and weight dimensions. Ektron’s shipping calculator uses
this information to fit the order into the smallest-sized and fewest packages. It then
passes packaging information (number, sizes and weight) to the shipping provider,
which returns the order’s shipping costs.
1. Go to Settings > Commerce > Shipping > Packages.
2. Choose New > Package.
3. Enter a Name, Length, Height, Width and Maximum Weight a package can
handle.
4. Click Save.
5. Repeat these steps for all package sizes your company uses.
See also: Configuring packages on page 1792.
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Step 15. Create product type definitions
NOTE: The remaining steps in this example are based on selecting a Product for the
Product Type Class.
Product types are applied to catalog folders and let you control the way product
information is added to a catalog. This is similar to how Smart Form configurations,
once applied to content folders, affect the way Smart Forms are created. You can apply
multiple product types to a catalog.
1. Go to Settings > Commerce > Catalog > Product Types.
2. Choose New > Product Type.
3. Define the Product Type.
4. Click Save and move to the next step.
See also: Creating product types on page 1806.

Step 16. Create content page
After clicking Save from the previous step, a content editor appears and lets you enter
XML Smart Form information. A user completes this Smart Form when creating a
Catalog Entry (Product).
The information appears on a product’s details page on your website.
You might want to create these fields on your smart form.
l

Title

l

Description

l

Image

After you complete the Smart Form, click Save.
See also: Creating product types and catalogs on page 1806 and Working with Smart
Forms on page 888.

Step 17. Create a catalog
A catalog folder is an Ektron folder designed to hold eCommerce catalog entries
(products). This is similar to the way content folders hold HTML or Smart Form content.
By assigning a product type to the folder, you can control the way products are added
to the catalog.
1. Click the Content folder bar to display the list of content folders.
2. Choose New > Catalog.
3. Set the catalog’s Properties, Metadata, Web Alerts and Breadcrumb information.
(Similar to creating a Content Folder.)
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4. On the Product Types Tab, select a Product Type from the drop-down list.
5. Click Add.
6. Click Save.
See also: Creating a catalog folder on page 1819 and Assigning a catalog folder’s
product type on page 1820.

Step 18. Add catalog entries
Catalog Entries are products you offer on your eCommerce website. For example, a
catalog entry could be a CD, a subscription-based service, or a computer that a
customer can customize and the price adjusts accordingly.
1. Go to a catalog folder.
2. Click New and select a product type.
3. In the Title field, enter a name for the catalog entry.
4. Fill out the fields in the Smart Form as necessary.
5. Select the Summary tab and add a summary. (Optional)
6. Select the Properties tab and enter an SKU and the number of units that equal
one purchase.
7. Select a Tax Class.
8. If the product is a tangible product, click Expand next to Dimensions, click the
Tangible check box and enter the product’s physical dimensions. If you are using
Ektron as your inventory system, click Expand next to Inventory and enter the
information.
9. Select the Pricing tab and enter the product’s list and sales price. If you offer a
quantity discount, click Add Pricing Tier and add a quantity and a tier price. If
you enabled multiple currencies, select a currency from the drop-down and add
pricing information as needed.
10. Select the Attributes tab and fill out or change attributes as needed. (If you did
not define attributes in Step 15. Create product type definitions on the previous
page, the Attributes tab does not appear.)
11. Select the Media tab and click Add Images to associate images with the catalog
entry.
12. The Items tab is used to create a complex product. This lets you offer variants of a
product at different price points. For this example, we will skip this tab. See also:
Creating a complex product on page 1812.
13. Enter information as needed on these tabs: Metadata, taxonomy and Schedule.
14. Choose Action > Publish.
To add Cross Sell or Up Sell items associated with this catalog entry, click its Title and
then click View > Cross Sell or Up Sell. These items appear in the Recommendation
server control when it is associated with this catalog entry.
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See also: Creating a catalog entry on page 1821.

Step 19. Create a master page
Create a master page and add the following items to a header area or left side column.
l

CurrencySelect server control. lets customers select from available monetary
types. This control displays currencies that have been enabled in Step 7. Enable
currencies on page 1753. A My Cart link that leads to a template containing the
Cart server control. See also: Configuring currencies on page 1766.

l

My Account / Order History link. leads to a template containing the MyAccount
and OrderList server controls.

l

Product Search link. (Optional) adds a link that leads to a template containing a
ProductSearch server control.

l

Product Search server control. (Optional) lets the user search for a product
from anywhere on the site. Note: Adding this option is involves more than just
dragging and dropping a server control to the header or the left side column. It
includes advanced customizations and coding to pass a search term from one form
to another. See also: ProductSearch templated server controls

l

Login server control. (Optional) lets existing customers log in upon arrival at
your site. If you only want customers logging in through this control, set the
OnlyAllowMemberLogin property to True.

Step 20. Create a landing page
This template should be the first page a customer sees when arriving at your site. It
should have a mechanism that lets customers start shopping. Make sure this page has
one of the following:
l

ProductList server control. display products by taxonomy, Catalog or ID. See
also: Creating product types on page 1806.
l To display a single taxonomy, set the SourceType property to Taxonomy and
enter a single Taxonomy ID in the SourceId property.
l

To display multiple taxonomies, set the SourceType property to TaxonomyList
and enter a comma-separated list of Taxonomy IDs in the IdList property.

l

To display a single catalog, set the SourceType property to Catalog and enter
a single catalog ID in the SourceId property. If you want to display sub
catalogs for a given ID, set the Recursive property to True.

l

To display multiple catalogs, set the SourceType property to CatalogList and
enter a comma separated list of catalog IDs in the IdList property.

l

To display products by their ID, set the SourceType property to IdList and
enter a comma-separated list of product IDs in the IdList property.
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l

l

Set the TemplateProduct property to the template containing the Product
server control.

ProductSearch server control. lets customers search your website for products.
If this control is not on your landing page or part of your master page, you should
create a separate template containing this control.
l Set the CatalogId property to the ID of the catalog to search.
l

Set the TemplateCart property to the template containing the Cart server
control.

l

Set the TemplateProduct property to the template containing the Product
server control.
See also: ProductSearch templated server controls.

Step 21. Create a product page
This page allows a customer views a product’s details. It contains a Product server
control and optionally a Recommendation server control.
l

l

Product server control. displays a product’s details.
l Make sure the DynamicParameter property is set to the parameter name used
to pass product IDs to the QueryString.
l

If you want a default product to display when no ID is passed, set the
DefaultProductID property to the ID of a product.

l

Set the TemplateCart property to the template containing the Cart server
control.

Recommendation server control. displays Cross Sell and Up Sell opportunities
associated with a product. These are set in Workarea, under the View menu’s Cross
Sell and Up Sell selections for a catalog entry. See also: Recommendation server
control.
l Set the RecommendationType property to CrossSell or UpSell.
l

Make sure the DynamicProductParameter property is set to the parameter
name used to pass product IDs to the QueryString.

l

If you want a product’s default Cross Sell or Up Sell items to display when no
ID is passed, set the DefaultProductID property to the ID of a product.

l

Set the TemplateCart property to the template containing the Cart server
control.

l

Set the TemplateProduct property to the template containing the Product
server control.

Step 22. Create a product search page
This page lets customers search for products on your website.
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l

ProductSearch server control. lets customers search your website for products.
If this control is not on your landing page or part of your master page, you should
create a separate template containing this control.
l Set the CatalogId property to the ID of the catalog to search.
l

Set the TemplateCart property to the template containing the Cart server
control.

l

Set the TemplateProduct property to the template containing the Product
server control.
See also: ProductSearch templated server controls.

Step 23. Create a cart page
This template contains a Cart server control.
l

Cart server control. lets a customer work with products they have selected to
purchase. As a customer gos around your site selecting products to purchase, they
are added to a cart. See also: Cart server control.
l Set the TemplateCheckout property to the template containing the Checkout
server control.
l

Set the TemplateProduct property to the template containing the Product
server control.

l

Set the TemplateShopping property to the Landing page template or a
template containing a ProductList or ProductSearch server control.

l

If you are using coupons, make sure the EnableCoupons property is set to
True.

Step 24. Create a checkout page
l

l

Set the TemplateCart property to the template containing the Cart server
control.

l

Set the TemplateOrderHistory property to the template containing the
OrderList server control.

l

Set the TemplateShopping property to the landing page template or a
template containing a ProductList or ProductSearch server control.

l

If you are using SSL Encryption, set the IsSSLRequired property to True.

WARNING! Use SSL Encryption for this page, because credit card information is
entered into the Checkout server control.

Step 25. Create a My Account page
This template contains a MyAccount and an OrderList server control.
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l

MyAccount server control. Lets customers view billing, shipping and alternative
shipping information associated with their account.
l Set the DefaultCountryID property to the country you want to be the default
selection in the Billing and Shipping address sections.
l

l

OrderList server control. Lets customers view a list of their processed orders.
l Make sure the DynamicOrderParameter is set to the parameter name used to
pass order IDs to the QueryString.
l
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(Optional) Set the CustomPropertyID property to the ID or list of comma
separated IDs that represent custom properties associated with users. Custom
Properties are set up in Ektron’s Workarea > Settings > Configuration >
Custom Properties.

Make sure the DynamicProductParameter is set to the parameter name used
to pass product IDs to the QueryString.
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Configuring eCommerce
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
This section describes the configuration screens located in the Workarea at Settings
> Commerce > Configuration and Settings > Commerce > Tax.

Configuring countries
Use the Countries screen to modify existing country information or add new countries
to eCommerce.

How countries are used
l

to define country tax tables. For example, assume Canada has a national tax of
5% that applies to the sale of certain goods. National tax tables are defined in the
Country Tax Tables screen.

l

to determine shipping costs. In the checkout process, a purchaser selects a
shipping address, which includes country. So, be sure to enable countries from
which customers (site visitors) can enter orders. Countries are also part of the
location on the Warehouse screen. An order’s shipping cost is determined by the
distance between the warehouse and the destination.

Default countries
By default, Ektron provides information for countries on the ISO list of English country
names and code elements (ISO 3166-1-alpha-2 code).
The following is provided for each country.
l

name

l

numeric ISO code

l

long alphabetical ISO code

l

short alphabetical ISO code

The countries screen lets you enter new countries, and edit information for provided
countries.

Creating a country
PREREQUISITE
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The new country’s ISO codes.
To add a new country:
1. From the Workarea, choose Settings > Commerce > Configuration >
Countries.
2. Click New > Country.
3. Enter information in the following fields:
l Name. Enter the country’s name.
l

Numeric ISO. Enter the country’s ISO 3166-1 3-digit numeric ISO code. See
also: ISO 3166-1 numeric.

l

Enabled. Check this box if you want this country to be active. Only active
countries can be selected on the Edit Billing Information screen, which appears
during the Checkout procedure.

l

Long ISO. Enter the country’s ISO 3166-1 alpha-3, 3-letter country code. See
also: ISO 3166-1 alpha-3.

l

Short ISO. Enter the country’s ISO 3166-1 alpha-2, 2-letter country code.
See also: ISO 3166-1 alpha-2.

4. Click Save.

Editing a country
1. Go to Workarea > Settings > Commerce > Configuration > Countries.
2. Click the name of the country that you want to edit.
3. Click Edit.
4. Edit any of the fields, which are described in Creating a country on the previous
page.

Deleting a country
1. Go to Workarea > Settings > Commerce > Configuration > Countries.
2. Click the name of the country that you want to delete.
3. Click Delete (

).

4. Click OK. The country is deleted.

Configuring regions
The Regions screen lets you define geographic regions within countries that your
eCommerce site services. For example, in the United States of America, each state is a
region.
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Regions are used in the same way that countries are used. See also: How countries are
used on page 1763. By default, the Regions screen includes 50 United States of
America, the District of Columbia, and 9 Canadian Provinces.

Creating a region
PREREQUISITE

The region’s country is defined in the Countries screen
1. Go to Workarea > Settings > Commerce > Configuration > Regions.
2. Choose New > Region.
3. Use the following information to complete the screen.
l Name. Enter the region’s name.
l

Enabled. Check this box if you want this region to be active. Only active
regions can be selected on the Edit Billing Information screen, which appears
when customers enter billing information during the Checkout procedure.

l

Code. Enter an abbreviation for this region.

l

Country. Select this region’s country from the pull down list. If the country is
not there, exit this screen, and create the country using the Countries screen.

l

Add another region to this country?. This field saves the effort of
selecting a country when entering several regions for one country.
To add more regions for this country, check this box and press Save. When
you do, the screen refreshes, and the most recently selected country appears
as the default.

4. Click Save.

Editing a region
1. Go to Workarea > Settings > Commerce > Configuration > Regions.
2. Click the name of the region that you want to edit.
3. Click Edit.
4. Edit any of the fields, which are described in Creating a region above.

Deleting a region
1. Go to Workarea > Settings > Commerce > Configuration > Regions.
2. Click the name of the region that you want to delete.
3. Click Delete ( ).
4. Click OK.
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Configuring currencies
eCommerce supports all currencies. However, customers can choose only enabled
currencies. The Currency screen lets you enable and edit information for installed
currencies.

Installed currencies
By default, Ektron provides currencies on the ISO 4217 Current Currency & funds code
list.
The following information is provided for each installed currency.
l

name

l

enabled (yes or no)

l

numeric ISO code

l

alpha ISO code

l

exchange rate

Enabling currencies
When users are setting prices in the Workarea or site visitors are shopping, they can
only choose enabled currencies. When you install Ektron, the following currencies are
enabled.
l

U.S. dollar, the default currency. See also: The default currency on the facing
page.

l

Euro

l

Australian dollar

To see which currencies (other than the default) are enabled, click Action > Edit
Exchange Rates from the Currencies screen. Only non-default, enabled currencies
appear.
WARNING! The Euro and Australian dollar are shipped with a default exchange
rate. If you will support these currencies, you should update the rate to its current
value before going live. See also: Defining and updating exchange rates on
page 1768.
To enable any installed currency:
1. From the Workarea, choose Settings > Commerce> Configuration >
Currencies.
2. Click the currency you want to enable. (Use the Search box to quickly find a
currency.) The Edit Currency screen appears.
3. Check the Enabled check box.
4. Click Update.
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The default currency
The default currency is the reference currency when setting the exchange rate on the
Edit Currency screen. For example, if the default is US dollars, USD appears on the left
of the exchange rate equation.

The default currency is also the default value in the CurrencySelect server control, and
on the Pricing tab of the View/Edit Catalog Entry screen.

Viewing and changing the default currency
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When you install Ektron, the default currency is U.S. dollars, indicated by the Numeric
ISO code 840. At that time, you can change this by editing the value for the web.config
file’s ek_ecom_DefaultCurrencyId tag. You must enable the new default currency in
the Workarea before changing it in the web.config file.
WARNING! After your eCommerce feature goes live, do not change the ek_ecom_
DefaultCurrencyId value in web.config.
IMPORTANT: If you edit the siteroot/web.config file's ek_ecom_
DefaultCurrencyId property, you must begin a manual crawl. See also: Starting
crawls manually on page 395. You will only see the new default currency in search
results when that crawl is complete.

How currencies are used in the CurrencySelect server
control
If your developer places a CurrencySelect server control on a page, a site visitor can
use it to select any enabled currency.

Defining and updating exchange rates
The Edit Currency screen lets you define an exchange rate between the default and any
other currency. A good website for finding exchange rates is http://www.xe.com.
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The exchange rate can dynamically adjust prices when the rate changes. See also:
Alternate currency pricing on page 1828.
You can update the exchange rates using:
l

the Ektron API

l

the Edit Exchange Rates screen

The following Ektron API supports calling an exchange rate service to update rates
automatically: Ektron.Cms.Commerce.ExchangeRateApi. For more information, see
the Ektron API documentation (http://reference.ektron.com/developer/).
The Edit Exchange Rates screen lets you update the exchange rate for enabled
currencies:
1. In the Workarea, go to Settings > Commerce > Configuration > Currencies.
2. Choose Action > Edit Exchange Rates. The Edit Exchange Rates screen
appears, showing enabled currencies and their exchange rates.
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3. Update rates as needed.
4. Choose Action > Update.

Editing a currency
1. Go to the Workarea > Settings > Commerce > Configuration > Currencies.
2. Click the currency you want to edit.
3. You can only edit the Name, Enabled, and Exchange Rate fields. The Numeric
ISO Code and Alpha ISO Code are not editable and are determined by the currency
selected.
l Name. Enter the currency’s name.
l

Enabled. Check this box to enable this currency.

l

Exchange Rate. Enter the exchange rate between this currency and the
default one.

4. Click Update.

Deleting a currency
1. Go to the Workarea > Settings > Commerce > Configuration > Currencies.
2. Check the box next to the currency that you want to delete.
3. Choose Action > Delete Selected.
4. Click OK. The currency is deleted.

Configuring payment options
The Payment Options screen lets you determine which options are available for your
customers to pay for their purchases.
l

PayPal. The PayPal checkbox is not available for selection until you have set up a
PayPal account. See also: Using PayPal with Ektron eCommerce below

l

a payment gateway, such as AuthorizeNet. See also: Configuring payment
gateways on page 1777

Both options can be enabled, but only one gateway can be enabled at a time.
PayPal payments work like checks in that they need to be settled. After an order is
placed, the payment must be marked as “settled” for the workflow to proceed.

Using PayPal with Ektron eCommerce
Customers can use PayPal to pay for purchases from either of 2 points in the checkout
process
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l

the shopping cart screen

l

the payment screen

IMPORTANT: PayPal requires you to place the Pay with PayPal option on both
the shopping cart and payment screens.
If you access PayPal via the shopping cart screen, you follow these steps.

Here is the sequence illustrated above.
1. From the Cart screen, a site visitor clicks PayPal.
2. The site visitor logs into his or her PayPal account.
3. Account information populates the shipping and billing addresses.
4. The site visitor can change addresses if needed. If the PayPal account address is
used for the order, it is saved as part of the site visitor’s eCommerce account
information.
5. Shipping costs are added.
6. The order is confirmed.
7. Site visitor checks out via PayPal.
Alternatively, the site visitor can use the standard eCommerce checkout process, select
PayPal on the payment screen, and complete the order using the PayPal payment
screen. The following illustration shows the sequence.
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Enabling PayPal support
1. Create a sandbox account below. This step includes updating Ektron’s web.config
file.
2. Begin Using PayPal on page 1776
3. Enable PayPal in the Workarea on page 1777

Create a sandbox account
1. Sign on to PayPal Sandbox.
2. Sign up for an account.
3. You receive an email confirmation that directs you to another page.
4. Log in using the information you provided in Step 2.
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5. Under Test Accounts, click Create a preconfigured buyer or seller account.

6. Create a buyer account. You will use this to test the customer experience.
7. Change the password to one you can easily remember.

8. Click Home > Test Accounts > Create a preconfigured buyer or seller
account.
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9. Click Account Type Seller.

10. Create a seller account. You will use this to test the merchant experience.
11. Change the password to one you can easily remember.
12. In the upper left corner of the screen, click API Credentials.

13. Open your siteroot/web.config file.
14. Copy the following values from the API Credentials screen into the web.config’s
providers/paypal element. Save web.config.
l API Username > PayPalUser
l

API Password > PayPalPwd

l

Signature > PayPalSignature

The following illustration shows the PayPal API Username copied into the web.config
file’s PayPalUser property.
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Encrypting PayPal authentication values
Follow these steps to encrypt the following values in the web.config file’s
providers/paypal element.
l

PayPalUser

l

PayPalPwd

l

PayPalSignature

1. Open the siteroot/web.config file.
2. Set the AuthValuesEncrypted element to true.

3. Save and close web.config.
4. Open C:\Program Files(x86)\Ektron\CMS400vxx\Utilities.
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5. Run EncryptEmailPassword.exe. The Encrypt Utility dialog appears.

6. Enter the PayPal user name into the Text field.
7. Click Encrypt. The screen displays encrypted text in the Encrypted field.
8. Copy the encrypted text and paste it into the web.config file’s PayPalUser
element value.
9. Repeat Steps 6 through 8 for PayPalPwd and PayPalSignature.

Test the sandbox account
1. Sign into Workarea > eCommerce > Cart.
2. Click the PayPal button.
3. Enter the buyer account user name and password that you created in Create a
sandbox account on page 1772. You proceed to the Ektron Checkout screen.
After completing these steps, you have verified your PayPal buyer experience and are
ready to begin using PayPal.

Begin Using PayPal
1. Sign on to PayPal.
2. Create a new account.
3. Follow the instructions to obtain API credentials.
4. Copy the following values from the API Credentials screen into the web.config’s
providers/paypal element. Save web.config.
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l

API Username > PayPalUser

l

API Password > PayPalPwd

l

Signature > PayPalSignature

5. If you want to encrypt these values, see Encrypting PayPal authentication values
on page 1775.
6. Enable PayPal in the Workarea below.
7. If desired, customize the PayPal pageon your website.

Enable PayPal in the Workarea
1. From the Workarea, choose Settings > Commerce > Configuration >
Payment Options.
2. Click Action > Edit Payment options. The Edit Payment Options screen
appears.
3. Check PayPal.
4. Click Save.

Customizing the PayPal page
If you are using Ektron’s sample site and PayPal is enabled, the login screen contains an
Ektron logo for demonstration purposes.
You can replace the logo using the apiparamHDRIMG property of the <providers> add
name=”PayPal” element in the web.config file.

To change the logo, change the referenced image.
When setting values in the web.config’s providers/add name=” PayPal” element,
prefix any variable with apiparam. For example, to set the header background color,
enter apiparamHDRBACKCOLOR=”FFF666”.

Configuring payment gateways
A payment gateway provider is a pluggable component that is integrated into the
Ektron eCommerce module. A payment provider handles eCommerce customer
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payments by using third-party payment gateways. Ektron eCommerce module accepts
payments such as credit cards or checks. Then, it passes that information to a thirdparty service. The third-party service processes the payment and returns a transaction
ID that is stored with the customer's order.
Your company needs to set up an account with a third party payment service before
using the payment provider. Ektron provides 4 standard payment gateways:
authorize.net, Payflow, Sage Pay and PayFlowWebsite Payments Pro along with
manual. A manual gateway accepts credit cards. In this case, the merchant emails the
credit card information to the credit card company. You can customize these providers
or create your own using the extendable payment gateway Provider architecture. See
Customizing the Payment Gateway Provider on page 1894.
In addition, not all payment gateways support recurring payments. Recurring payments
let you create a payment that occurs at a given interval for a specified period of time.
For example, a payment for $9.99 is posted on the first of every month for the next 12
months. This is something to consider if your site relies on a subscription service.
Ektron lets you edit information on any provided gateway as well as create a new one.

Processing credit card transactions via a gateway
The following sequence explains typical processing of credit card transactions.
(source: www.authorize.net)
1. A customer purchases a product from your site and submits payment information.
2. Ektron passes the information to your payment gateway.
3. The payment gateway provider (PGP) receives secure transaction information and
passes it via secure connection to the Merchant Bank’s Processor.
4. The Merchant Bank’s Processor submits the transaction to the Credit Card
Interchange (a network of financial entities that manage credit card transactions).
5. The Credit Card Interchange sends the transaction to the customer’s Credit Card
Issuer.
6. The Credit Card Issuer approves or declines the transaction, based on the
customer’s available funds. It then passes the transaction results and, if approved,
the appropriate funds back through the Credit Card Interchange.
7. The Credit Card Interchange relays the transaction results to the Merchant Bank’s
Processor.
8. The Merchant Bank’s Processor relays the transaction results to PGP.
9. The PGP stores transaction results and sends them to the customer and/or the
merchant. This communication process averages 3 seconds or less.
10. The Credit Card Interchange passes the transaction’s funds from the Credit Card
Issuer to the merchant’s bank account.

Processing check transactions via a gateway
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The following sequence explains how a payment gateway processes checks. (source:
www.authorize.net)
1. Customer authorizes merchant to charge the customer's bank account for an
amount.
2. Order and payment information is securely transmitted via the Internet to the
payment gateway.
3. The transaction is accepted or rejected based on initial data validation and security
criteria defined by the payment gateway.
4. If accepted, the transaction is sent to the ACH Network for settlement.
5. The ACH Network uses the transaction’s bank account information to determine
the bank that holds the customer’s account (the RDFI).
6. The ACH Network instructs the RDFI to charge or refund the customer’s account.
7. The RDFI transfers funds from the customer’s account to the ACH Network. The
RDFI also notifies the ACH Network of any returns (if funds could not be collected
from the customer’s bank account) or charge backs (if a customer disputes a
purchase).
8. The ACH Network transfers funds for the transaction to the payment gateway’s
bank.
9. After a holding period, the payment gateway provider initiates a ACH transaction
that deposits the funds into the merchant’s bank account.

Establishing a relationship with a payment gateway provider
You need to set up an account with a third-party payment service before using a
payment provider. Each payment gateway provider accepts configuration parameters.
For example, Authorize.NET requires a username and password, while PayFlow requires
a Username, password, vendor, and partner.
In addition, some payment gateways do not support subscription payments. Consider
this if your site relies on subscriptions. See also: Creating a subscription on page 1814.

The default gateway
The eCommerce checkout uses the default gateway only. Additional gateways are
unused unless one is changed to the default.
You cannot delete the default gateway. If you want to delete it, you must first make
another gateway the default.
To change the default gateway:
1. Go to Settings > Commerce > Configuration > Payment Options.
2. Click the payment gateways tab. The currently-defined default has a check in
the Default column.
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3. Click the radio button next to the gateway you want to make the default.
4. Choose Action > Mark as Default.
5. Click OK.

Adding a payment gateway
NOTE: To create a new payment gateway provider, see Customizing the Payment
Gateway Provider on page 1894.
1. In Ektron, go to Settings > Commerce > Configuration > Payment Options.
2. Choose New > payment gateway.
3. Enter information or select options for the following fields:
l Name. Enter the name of the gateway.
l

Default. Check this box if this is the default gateway. If you do, and another
gateway is currently the default, it is replaced by this one.

l

User ID. Enter your User ID. This ID will identify your account with this
gateway provider.

l

Password. Enter the password for your account with this gateway provider.

l

Expand Custom Values. If this gateway provider needs additional fields of
information, enter those values into the Custom 1 and Custom 2 fields.

l

Credit Cards. Check if this payment gateway accepts credit cards.

l

Checks. Check if this payment gateway accepts checks.

The following sections explain how to set up standard Payment gateways.
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l

Setting up a PayFlow payment gateway on the facing page

l

Setting up a PayFlowWebsite Payments Pro payment gateway on the facing page

l

Setting up an Authorize.Net payment gateway on page 1782

l

Setting up a SagePay payment gateway on page 1783
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NOTE: When setting up a payment gateway, you are asked to enter authentication
codes, such as user name and password. To keep them safe, Ektron encrypts these
values when saving them to the database.

Setting up a PayFlow payment gateway
NOTE: See PayFlow's websitefor additional instructions on setting up the PayFlow
Gateway.
When setting up a PayFlow payment gateway:
1. Set up an account with PayFlow. To do this, go to Paypal: Payflow payment
gateway. During this process, you should obtain a Login ID and password.
2. Go to Settings > Commerce > Configuration > Payment Options.
3. Choose New > payment gateway.
4. Enter information or select options for the following fields:
l Name. Choose Payflow.
l

Default. Check this box to make PayFlow the default gateway.

l

User ID. Enter the user ID provided to you by the authorized PayPal Reseller
who registered you for the Payflow SDK. If you purchased your account
directly from PayPal, use PayPal.
Limitations: 64 alphanumeric, case-sensitive characters.

l

Password. Enter the password you defined while registering for account.
Limitations: 6- to-32 alphanumeric, case-sensitive characters

l

Expand Custom Values. Click this text to open the Custom 1 and Custom
2 fields.
o Custom 1. Enter the merchant login ID sent to you when you registered
the account.
Limitations: 64 alphanumeric, case-sensitive characters.
o

Custom 2. Enter the Partner ID sent to you by the authorized PayPal
Reseller who registered you for the Payflow SDK. If you purchased your
account directly from PayPal, use PayPal.
Limitations: 12 alphanumeric, case-sensitive characters.

l

Credit Cards. Check if this payment gateway accepts credit cards. You should
verify that this payment gateway supports credit card payments.

l

Checks. Check if you will accept checks with this payment gateway. You
should verify that this payment gateway supports check payments.

Setting up a PayFlowWebsite Payments Pro payment gateway
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The PayFlowWebsite Payments Pro payment gateway is used in the United Kingdom
and Australia.
1. Set up an account with PayFlowWebsite Payments Pro. To do this, go to Paypal:
Payflow payment gateway.
2. In the Workarea, go to Settings > Commerce > Configuration > Payment
Options.
3. Choose New > payment gateway.
4. Enter information or select options for the following fields:
l Name. Choose PayFlowWebsite Payments Pro.
l

Default. Check this box to make PayFlow the default gateway. See also: The
default gateway on page 1779

l

User ID. Enter the API username sent to you by the authorized PayPal
Reseller who registered you for the Payflow SDK. For example, sellUK_
1271963915_biz_api1.ektron.com. If you purchased your account directly
from PayPal, use PayPal.
Limitations: 64 alphanumeric, case-sensitive characters.

l

Password. Enter the API password you defined while registering for the
account.For example,1234567891.
Limitations: 6- to-32 alphanumeric, case-sensitive characters

l

Expand Custom Values. Click this text to open the Custom 1 and Custom
2 fields.
o Custom 1. Enter the API signature sent to you by the authorized PayPal
Reseller who registered you for the Payflow SDK. For example,
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
Limitations: 64 alphanumeric, case-sensitive characters.
o

l

Custom 2. Not used

Credit Cards. Check if this payment gateway accepts credit cards. You should
verify that this payment gateway supports credit card payments.

After defining the payment gateway, you typically want to test it. See Testing a
payment gateway on the facing page

Setting up an Authorize.Net payment gateway
1. Set up an account with Authorize.Net using AuthorizeNet. During this process, you
obtain an API login id and a transaction ID.
2. In the Workarea, go to Settings > Commerce > Configuration > Payment
Options.
3. Choose New > payment gateway.
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4. Enter information or select options for the following fields:
l Name. Choose Authorize.Net.
l

Default. Check this box to make Authorize.Net the default gateway.

l

User ID. Enter the API login id you obtained when setting up an Authorize.Net
account in Step 1.

l

Password. Enter the transaction ID you obtained when setting up an
Authorize.Net account in Step 1.

l

Custom 1 and Custom 2. Not used.

l

Credit Cards. Check if you will accept credit cards with this payment
gateway. You should verify that this payment gateway supports credit card
payments.

This gateway accepts only credit cards. No checks.
After defining the payment gateway, you typically want to test it. SeeTesting a
payment gateway below

Setting up a SagePay payment gateway
NOTE: SagePay does not support recurring billing nor check payments.
1. Set up an account with SagePay. To do this, go to Sage Pay. During this process,
you should obtain a Login ID and password.
2. Set up a SagePay simulator account using Sage Pay Account Registration.
3. From the Simulator Main Menu, click Account > Valid Currencies for this Account.
Enable currencies set up in your Workarea’s Currencies screen. See also:
Configuring currencies on page 1766
4. In Ektron, go to Settings > Commerce > Configuration > Payment Options.
5. Choose New > payment gateway.
6. Enter information or select options for the following fields:
l Name. Choose SagePay.
l

Default. Check this box to make SagePay the default gateway.

l

User ID. Enter the User ID you obtained in Step 1.

l

Password, Custom 1, Custom 2. Not used.

l

Credit Cards. Check if this payment gateway accepts credit cards. You should
verify that the gateway supports credit card payments.

l

Checks. Not available with SagePay.

After defining the payment gateway, you typically want to test it. SeeTesting a
payment gateway below and Testing SagePay payment gateway on the next page

Testing a payment gateway
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Typically, you test a default payment gateway before going live with it. eCommerce
provides a test mode for this purpose. While eCommerce is in test mode, customers
cannot purchase goods. So, disable test mode before going live with a new default
payment gateway.
To test a payment gateway, open the siteroot/web.config file and set
<ektronCommerce> ek_ecom_TestMode to true.
<ektronCommerce>
<add key="ek_ecom_ComplianceMode" value="false" />
<!-- This is used only when compliance mode is on, and cannot be less than 4. -->
<add key="ek_ecom_PasswordHistory" value="4" />
<add key="ek_ecom_OrderProcessingDisabled" value="false" />
<add key="ek_ecom_TestMode" value="true" />
....

When testing is done, change the value of ek_ecom_TestMode to false.

Testing SagePay payment gateway
Do not use the following cards with the SagePay test card number when testing the
SagePay payment gateway:
l

Japan Credit Bureau (JCB)

l

Mastercard

l

Visa Electron UK Debit

l

Visa Delta Debit

l

American Express

Because these cards do not have a cardholder field, the following error is displayed: The
CardHolder field should be between 1 and 50 characters long.
To test the SagePay payment gateway:
1. Follow instructions in Testing a payment gateway on the previous page.
2. Open your siteroot/web.config file.
3. Set <EktronPaymentGateway>/<providers> SagePay SimulatorMode to true.
<EktronPaymentGateway defaultProvider="Automatic">
<providers> . .
<add name="SagePay"
type="Ektron.Cms.Commerce.Providers.Payment.SagePayGateway"
SagePayVersion="2.23" SimulatorMode="true"
Description="Ektron CMS Order" />
</providers>
</EktronPaymentGateway>

4. When testing is complete, change the value of SimulatorMode to false.

Editing a payment gateway
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1. Go to Workarea > Settings > Commerce > Configuration > Payment
Options.
2. Click the payment gateway that you want to edit.
3. Click Edit.
4. Edit any of the fields, which are described in Adding a payment gateway on
page 1780.
5. Click Save.

Deleting a payment gateway
NOTE: You cannot delete the default gateway. If you want to delete it, you must
first make another gateway the default.
1. From Workarea, choose Settings > Commerce > Configuration > Payment
Options.
2. Click the payment gateway that you want to delete.
3. Click Delete (

).

4. Click OK.

Check support
Payment gateways generally offer 2 payment mechanisms: credit cards and checks.
You can enable or disable check support for a gateway via the Settings > Commerce
> Configuration > Payment options > Edit payment gateway screen.
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If checks are enabled for the default payment gateway, a site visitor can pay by Check
on the payment screen. If check support is not enabled, the Payment Method field
does not appear.

Check support integration documentation
Use the following resources to familiarize yourself with integrating checks into your
eCommerce site.
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l

Authorize.Net: eCheck.Net Operating Procedures and User Guide

l

PayFlow: Payflow Link User’s Guide; see the chapter “Integrating TeleCheck
Transactions.”
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Effect of check payment on order processing
The following describes a typical sequence of events when processing a check for
eCommerce payment.
However, Ektron is very flexible and does not enforce this sequence. For example, you
can enter a tracking number and mark an order shipped even though its payment has
not been captured yet.
1. eCommerce user accesses the View Payment screen’s Capture option, which
submits a payment request to the customer’s bank.

2. A few days later, the funds are transferred to the merchant’s account.
3. eCommerce user accesses the View Payment screen’s Mark as Settled option to
confirm the receipt of funds.
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4. If goods are tangible, eCommerce user ships the merchandise, using the View
Payment screen’s Enter Tracking Number option to insert the tracking number
and confirm the shipment.

5. If goods are not tangible, the workflow sends the customer an email with purchase
details, such as how to download it.

Configuring credit card types
Use this screen to enter types of credit cards that your eCommerce system may use. By
default, Ektron’s sample sites provide the following card types.
l

American Express

l

Diners Club (not accepted by default)

l

Discover

l

MasterCard

l

Visa

You can edit the information provided for these types or enter a new one.
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Where credit card types are used
During the checkout process (managed by the Checkout server control), the Payment
screen includes a drop-down list of enabled credit cards.

Creating a credit card type
To create a new credit card within Ektron:
1. From the Workarea, choose Settings > Commerce > Configuration > Card.
2. Choose New > Card Type to see the Add Card Type screen.
3. Enter the credit card's name in the Name field.
4. Enable the Accepted check box if site visitors can use this card to make purchases
on your website.
5. Add an image for the credit card. The image must reside on your computer.The
image does not appear on the standard checkout screen, but it is a field in the XML,
so you can enable it using XSLT.
a. Click Change. The Library Upload screen appears.
b. Click Add Library.
c. Click Browse and go to the folder that contains the image.
d. Choose the image file.
e. Enter a title in the Title field.
f. Click Add Library. The file name appears in the Image field with the image
directly below.
Ektron Reference

1789

Conducting eCommerce

6. Enter a Regex expression. See also: Using RegEx expressions for validation below.
7. Click Save.

Using RegEx expressions for validation
A RegEx expression is a simple way to validate a credit card account number. (See also:
http://regexlib.com/.) Validation occurs when a site visitor completes the Checkout
procedure’s Submit Order screen
RegEx prevents the submission of invalid account numbers to a payment gateway,
which may charge a fee for such failures.
Ektron provides a RegEx expression for the credit cards supplied with the medical
sample site. You can modify them as needed. If you enter a new credit card, you can
enter a RegEx expression for it.

Editing a credit card type
1. From the Workarea, choose Settings > Commerce > Configuration > Card.
2. Click the Credit Card Type that you want to edit.
3. Click Edit.
4. Edit any of the fields, which are described in Creating a credit card type on the
previous page.
5. Click Save.

Deleting a credit card type
1. From the Workarea, choose Settings > Commerce > Configuration > Card.
2. Click the Credit Card Type that you want to delete.
3. Click Delete (

).

4. Click OK. The Credit Card Type is deleted.

Configuring eCommerce shipping screens
The eCommerce shipping screens let you specify information about where catalog
entries are stocked, how they are packaged, and the available shipment methods.
This section contains the following topics.
l

Using a warehouse below

l

Configuring packages on page 1792

l

Configuring shipping methods on page 1793

Using a warehouse
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Use the Warehouses screen to enter information about warehouses that stock your
catalog entries. eCommerce uses this location as the “from” address when calculating
shipping costs.
Only the default warehouse is used by the checkout process. Additional warehouses are
unused until they are made the default. See also: Changing the default warehouse
below.
PREREQUISITE

Regions and Countries must be set up.

Creating a warehouse
1. Go to Settings > Commerce > Shipping > Warehouses.
2. Choose New > Warehouse.
3. Enter information or select options as follows:
l Name. Enter the warehouse’s name.
l

Street1, Street2. Enter the warehouse’s street address

l

City. Enter the warehouse’s city.

l

Postal Code. Enter the warehouse’s postal code.

l

Country. Select the warehouse’s country from the pull-down list.

l

State/Province. Select the warehouse’s state or province from the pull-down
list.

l

Default Warehouse. This check box indicates if this is the default
warehouse.

4. Click Save.

Changing the default warehouse
NOTE: You can also specify a warehouse as the default via the Edit Warehouse
screen’s Mark Default Warehouse toolbar button (

).

1. Go to Workarea > Settings > Commerce > Shipping > Warehouses.
2. Click the radio button next to the warehouse that you want to make the default.
3. Choose Action > Mark Default Warehouse. A confirmation dialog appears.
4. Click OK.

Editing a warehouse
1. Go to Workarea > Settings > Commerce > Shipping > Warehouses.
2. Click the warehouse that you want to edit.
3. Click Edit.
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4. Edit any of the fields as described in Creating a warehouse on the previous page.
5. Click Save.

Deleting a warehouse
You cannot delete the default warehouse. However, you can designate another
warehouse as the default, then delete the one that was the default.
1. Go to Workarea > Settings > Commerce > Shipping > Warehouse.
2. Click the warehouse that you want to delete.
3. Click Delete ( ).
4. Click OK. The warehouse is deleted.

Configuring packages
How packaging information is used
Each item in an order has size and weight dimensions. The shipping calculator uses
them to fit the order into the smallest-sized and fewest packages. It then passes
packaging information (number, sizes and weight) to the shipping provider, which
returns the order’s shipping costs. If a catalog entry’s dimensions exceed all box sizes,
eCommerce passes those dimensions to the shipping provider.
NOTE: Some shipping providers, FedEx and UPS for example, have size and weight
limits on packages. If the size or weight exceeds the limit, shipping rates may not be
returned when a site visitor is checking out. In this case, a site visitor cannot
continue the checkout process and an application error is logged in the Event Viewer.

Size and weight units of measure
By default, Ektron uses English units of measure (inches and pounds) for package size
and weight. At the beginning of your eCommerce implementation, you can change to
metric units of measure by updating the web.config file’s ek_measurementsystem tag
value to metric.
WARNING! After your eCommerce feature goes live, do not change the web.config
ek_measurementsystem value.

Creating a new package
1. Go to Settings > Commerce > Shipping > Packages.
2. Click New > Package.
3. Enter package information in the following fields:
l Name. Enter a text description of this package size.
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l

Length. Enter the package’s length in the units of measure that appear to the
right (inches or centimeters). See also: Size and weight units of measure on
the previous page.

l

Height. Enter the package’s height in the units of measure that appear to the
right (inches or centimeters).

l

Width. Enter the package’s width in the units of measure that appear to the
right (inches or centimeters).

l

Max Weight. Enter the package’s weight in the units of measure that appear
to the right (pounds or kilograms).

4. Click Save.

Editing a package
1. Go to Workarea > Settings > Commerce > Shipping > Packages.
2. Click the package that you want to edit.
3. Click Edit.
4. Edit any of the fields, which are described in Creating a new package on the
previous page.
5. Click Save.

Deleting a package
1. From the Workarea, choose Settings > Commerce > Shipping > Packages.
2. Click the package that you want to delete.
3. Click Delete ( ).
4. Click OK. The package is deleted.

Configuring shipping methods
Use the Shipping Methods to define choices your site visitors will have for delivering
their purchases.
PREREQUISITES
l

Default warehouse with an address

l

A default shipping provider is defined in the
siteroot\shipment.config file

Defining shipping providers
When you instEktron, several providers exist in the siteroot\shipment.config file:
l

FedExShipmentProvider

l

FlatRateShipmentProvider
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l

UPSShipmentProvider

However, the FedEx and UPS information is for testing purposes only. To use FedEx,
UPS, or another shipping provider, obtain the following information from them. (The
information can vary slightly for each provider.)
l

service URL

l

key

l

password

l

account number

l

meter number

l

transactionId

Then, enter that information into shipment.config, following the format of providers
already in the file.
The shipment.config file also contains name and type properties for each provider.
The specific text you insert is not important, but the name and type strings must match.
name="FedExShipmentProvider"
type="Ektron.Cms.Commerce.Shipment.Services.FedExShipmentProvider,
Ektron.Cms.Commerce"

To define a custom shipping provider, see Customizing the shipment provider on
page 1902.

Defining the default shipping provider
While you can define any number of shipping providers in the shipment.config file, only
one can be active. The active provider appears on the Settings > Commerce >
Shipping > Methods > New > Shipping Method screen when you click View
Options.
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Specify the default shipping provider via the defaultprovider property in
siteroot\shipment.config.
<?xml version="1.0" encoding="utf-8" ?>
<shipmentProvider defaultProvider="FedExShipmentProvider">
<providers>
<add name="FedExShipmentProvider" ...
</shipmentProvider>

Adding a shipping method
Use the Add Shipping Method screens to select shipping methods you will support.
When a site visitor submits an order, these shipping choices appear on the Shipping
screen.
1. Go to Workarea > Settings > Commerce > Shipping > Methods.
2. Choose New > Shipping Method. The Add Shipping Method screen appears.
3. Enter information or make selections in the following fields.
l Name. Enter the name of the shipping method. Site visitors select a shipping
method for their order using this name
l

Active. Check this box if you want site visitors to be able to select this
shipping method.

l

Provider Service. As explained in Defining the default shipping provider on
the previous page, a default shipping provider is defined in your site’s
shipment.config file. To view the methods offered by that provider, click View
Options. Then, select from the drop-down list that appears.

4. Click Save.
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Editing a shipping method
1. Go to Workarea > Settings > Commerce > Shipping > Methods.
2. Click the Shipping Method that you want to edit. The View Shipping Method screen
appears.
3. Click Edit (

).

4. Edit the fields described in Adding a shipping method on the previous page.

Deleting a shipping method
1. Go to Workarea > Settings > Commerce > Shipping > Methods.
2. Click the Shipping Method that you want to edit. The View Shipping Method screen
appears.
3. Click Delete ( ).

Changing the order of the shipping method
Each shipping method you define has an Order field. This determines the sequence in
which shipping methods appear on the Shipping Rates screen when a site visitor is
submitting an order.
The shipping method with 1 in the Order field appears at the top of the list.
By default, every shipping method’s order is set to 1. To set a sequence for shipping
methods, follow these steps
1. Go to Workarea > Settings > Commerce > Shipping > Methods.
2. Choose Action > Reorder Items.
3. Use the selection bar and arrows to arrange methods in the desired sequence.

4. Choose Action > Save.

Configuring eCommerce tax screens
eCommerce provides a set of tax screens in the Workarea that lets you:
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l

set up tax classes (for example, goods, services, tobacco)

l

define tax rates for these geographic entities (from most to least specific)
l postal code

l

l

region

l

country

apply tax classes
l for tax classes except shipping
l

applying shipping taxes

This section also contains the following topics.
l

Applying tax classes to catalog entries below

l

Calculating an order’s tax amount on the next page

l

Creating a new tax class on page 1802

l

Creating a new postal code tax table on page 1803

l

Configuring regional tax tables on page 1803

l

Configuring country tax tables on page 1805

Applying tax classes to catalog entries
You assign a tax class (except shipping) to a catalog entry via its Properties tab’s Tax
Class field (Content tab > select catalog entry > Action > Edit).
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Calculating an order’s tax amount
During checkout, Ektron tries to find a tax rate for each catalog entry’s Tax Class and
the shipping address’s geographic entity.
Ektron checks
the shipping
address for each
item's tax class

If it finds a tax rate for the geographic entity

If it does not
find a tax rate
for the
geographic
entity

It adds that amount and stops.
For example
1. Postal code
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l

an item costs $100.00

l

the postal code tax rate = 5%

l

a tax of $5.00 is applied

It checks the
shipping
address for a
regional tax
code.

Calculating an order’s tax amount

Ektron checks
the shipping
address for each
item's tax class

If it finds a tax rate for the geographic entity

If it does not
find a tax rate
for the
geographic
entity

It adds that amount and stops.
For example
2. Region

l

an item costs $100.00

l

the regional tax rate = 7%

l

a tax of $7.00 is applied

It checks the
shipping
address for a
country tax
code.

It adds that amount.
For example
3. Country

l

an item costs $100.00

l

the country tax rate = 10%

l

a tax of $10.00 is applied

No tax is
added to the
order.

If a postal zone has several taxes (for example, a local tax and a regional tax), build the
combined percentage into the postal code tax. So, assume New York City has a 4% tax,
and New York state has a 3% tax. Enter a combined total of 7% into postal zones within
New York City. See also: Cataloging entries that can be taxed on page 1801.
For example, the atrium chair is assigned to the Goods Tax Class. A person who lives in
New York state purchases the chair. Although no postal tax class is defined for the
shipping address, a regional tax of 8.5% is set up for New York state, and so is applied
to the order.
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Calculating an order’s shipping tax amount
The shipping tax is separate from the other taxes, and appears on a separate line of the
order.
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Enabling the shipping tax within Ektron

A shipping tax is applied to an order if
l

shipping tax is enabled in web.config
and

l

a tax rate is applied to one of the geographic regions in which the shipping address
falls.

Unlike the other tax classes, you do not apply shipping tax to catalog entries. Instead,
you apply them to geographic regions only. However, each tax class compares an
order's shipping address against regional tax tables to calculate the tax.

Enabling the shipping tax within Ektron
To enable the shipping tax, open your siteroot/web.config file and change the value
of the ek_ecom_ApplyTaxestoShipping element to True.

Enabling the shipping tax for a geographic region
You apply a shipping tax to every applicable geographic region. As explained in
Calculating an order’s tax amount on page 1798, the eCommerce module first looks for
a tax applied to the order's postal code. If one is found, that shipping tax is applied. If
none is found, eCommerce looks for a shipping tax applied to the order's region. If no
regional shipping tax is found, eCommerce looks for a shipping tax applied to the
order's country.

Applying a shipping tax to a geographic region
You apply a shipping tax rate to geographic regions as you do with the tax classes. See
also: Creating a new postal code tax table on page 1803, Configuring regional tax
tables on page 1803, Configuring country tax tables on page 1805

Cataloging entries that can be taxed
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Use the Tax Class screen to define classes of catalog entries that can be taxed. When
you install eCommerce, the following tax classes are installed.
l

alcohol

l

goods

l

service

l

tobacco

l

shipping

You can modify or delete all classes except shipping, which you can modify but not
delete. You also can add new classes.

Creating a new tax class
1. Go to Settings > Commerce > Tax > Classes.
2. Choose New > Tax Class.
3. Enter the name of the tax class.
4. Click Save.

Editing a tax class
1. Go to Settings > Commerce > Tax > Classes.
2. Click the Tax Class that you want to edit.
3. Click Edit.
4. Edit the name of the tax class.
5. Click Save.

Deleting a tax class
If a tax class has been assigned to a catalog entry that appears on any order, the Delete
button does not appear.
1. Go to Settings > Commerce > Tax > Classes.
2. Click the Tax Class that you want to delete.
3. Click Delete ( ).
4. Click OK. The Tax Class is deleted.

Applying local taxes
Use postal code tax tables to identify local areas (cities, counties, and so on) that apply
taxes to eCommerce catalog entries. The areas are identified by their postal code. For
example, London, England taxes alcohol delivered to addresses within it.
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You only need to create a postal tax table if the area that applies the tax is smaller than
a country’s geographical regions (states, provinces, and so on). If an entire region
applies a tax, use a regional tax table.

Creating a new postal code tax table
PREREQUISITE

The postal code’s country and region are defined in the Regions and
Countries screens
1. Go to Settings > Commerce > Tax > Postal Tax Tables.
2. Choose New > Postal Code.
3. Enter information into the following fields:
l Postal Code. Enter the postal code for which you want to enter a tax rate. If
this is for a US state, the code must consist of 5 or 9 digits.
l

Region. Enter the geographic region (for example, state or province) in which
the postal code resides.

l

Country. Enter the country in which the postal code resides.

4. Select the Tax Rates tab and specify values for the tax rates, for example, Alcohol,
Goods, Services, Shipping, Tobacco. For any tax class, enter a tax rate as a whole
number. For example, if the tax is 7%, enter 7.
5. Click Save.

Editing a postal code tax table
1. Go to Settings > Commerce > Tax > Postal Tax Tables.
2. Click the ID of the tax table that you want to edit.
3. Click Edit.
4. Edit the fields described in Creating a new postal code tax table above.
5. Click Save.

Deleting a postal code tax table
1. Go to Settings > Commerce > Tax > Postal Tax Tables.
2. Click the ID of the tax table that you want to delete.
3. Click Delete (

).

4. Click OK. The postal code tax table is deleted.

Configuring regional tax tables
Use regional tax tables to identify regions (states, provinces, and so on) that apply
taxes to eCommerce catalog entries. For example, within the United States of America,
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the state of New Jersey applies a 5% tax on goods purchased on the internet and
shipped to it.
You only need to define a regional tax table if the area that applies the tax is smaller
than a country. If an entire country applies a tax, use a country tax table.

Editing a regional tax table
A regional tax table is automatically created for every existing region. By default, tax
rates are zero (0). To change any tax rate:
1. Go to Settings > Commerce > Tax > Regional Tax Tables.
2. Click on the name of the region for which you want to set tax rates. The View
Region Tax Rate screen appears.

3. Click Click here to edit the tax rates.
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4. Click Edit.
5. Enter information into the following fields.
l Name. Select the region for which you want to enter a tax rate.
l

Enabled. Enable or disable the regional tax entry as required.

6. Select the Tax Rates tab and specify regional tax rates by class. For example,
Alcohol, Goods, Services, Tobacco, and Shipping. For any tax class, enter a tax
rate.
7. Click Save.

Deleting a regional tax table
1. Go to Settings> Commerce > Tax > Regional Tax Tables.
2. Click the ID of the tax table that you want to delete.
3. Click Delete ( ).
4. Click OK. The regional tax table is deleted.

Configuring country tax tables
Use country tax tables to identify nations that apply taxes to eCommerce catalog
entries. For example, Ethiopia applies a 5% tax on goods purchased on the internet and
shipped to it.

Editing a country tax table
A country tax table is automatically created for every existing country. By default, tax
rates are zero (0). To change any country tax rate:
1. Go to Workarea > Settings > Commerce > Tax > Country Tax Tables.
2. Select the country for which you want to edit a tax table. The View Country Tax
Rate screen appears.
3. Click Click here to edit the tax rates.
4. Click Edit.
5. Select the Tax Rates tab and edit the tax rates, for example, Alcohol, Goods,
Services, Tobacco, and Shipping. For any tax class, enter a tax rate.
6. Click Save.

Deleting a country tax table
1. Go to Workarea > Settings > Commerce> Tax > Country Tax Tables.
2. Click the ID of the tax table that you want to delete.
3. Click Delete (

).

4. Click OK. The country tax table is deleted.
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Creating product types and catalogs
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
After you configure the eCommerce site, build eCommerce products in the following
order:
1. Creating product types below
2. Creating a catalog folder on page 1819
3. Creating a catalog entry on page 1821

Creating product types
Create a separate product type definition for each category of catalog entries that you
sell. For example, you might have a product type for movies, another for books, a third
for electronics, and so on.
When thinking about creating new product types, the most significant differences are
the Class field and the content page, which defines the XML Smart Form for products
you will create for a Product Type.

Product classes
A catalog entry’s product class affects customers’ purchasing options.
l

Kit. Lets a customer (site visitor) select from any number of free-text options.
Options can increase or decrease the overall price. See also: Creating a kit on
page 1808.
Example: A computer whose price changes as a customer selects RAM, hard drive,
monitor, and so on.

l

Bundle. A catalog entry consisting of several other catalog entries bundled
together. Its pricing, shipping, images, and so on, are independent of the individual
items. See also: Creating a bundle on page 1811.
Example: A living room set: couch, end tables and lamps. Instead of buying each
item separately, the customer buys all for a “package” price.

l

Product. Simple or complex catalog entries. A complex product is a “wrapper” that
provides links to related simple products. Each simple product has its own SKU,
price, inventory data, and so on. See also: Creating a complex product on
page 1812.
Example: A movie in 3 formats and prices:
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l

l

VHS ($12.95)

l

DVD ($14.95)

l

Blu-ray ($17.95)

Subscription. A catalog entry which can provide access to designated site pages,
and may billed on a recurring basis. See also: Creating a subscription on
page 1814.
Example: website content that is only available to subscribed members

How product types affect the creation of catalog entries
Catalog folders generally contain the same kind of catalog entries, such as DVDs or
digital cameras. Some information applied to a catalog folder is inherited by all entries
in the folder.
After you create product types, apply appropriate types to existing catalog folders using
the Catalog Properties screen’s Product Types tab. Then, when creating a new catalog
entry, you first go to a catalog folder. Next, click New and choose a product type
assigned to the folder. See also: Assigning a catalog folder’s product type on page 1820
A product type determines the following aspects of the associated catalog entries:
l

Product class. Product classes on the previous page.

l

Attributes. Step 1: Defining properties, attributes, and media defaults below
Attributes define additional information about catalog entries based on this product
type. For example, if the Product Type is for movies, attributes might be Actors,
Running Time, Rating, Year Released, and so on. In another example, you want an
attribute that describes a chair’s dimensions. You create a text-based attribute for
the Product Type you will use to add chairs to a catalog. Then, whenever you add a
new chair to the catalog, you enter its dimensions into the Attributes tab’s
Dimensions field. By default, Attributes appear on the Product server control.

l

Media defaults (that is, size of thumbnail images added to a catalog entry). Step 1:
Defining properties, attributes, and media defaults below

l

Content page. Step 2: Creating the content page on page 1818

There are 2 steps to creating a product type.
l

Step 1: Defining properties, attributes, and media defaults below

l

Step 2: Creating the content page on page 1818

Step 1: Defining properties, attributes, and media
defaults
To create a product type:
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1. Go to Workarea > Settings > Commerce > Catalog > Product Types >
New > Product Type.
2. Click the Properties tab.
3. Enter a unique product type title in the Title field. The title identifies this entry on
the View Product Types screen. Also, when creating a new catalog entry, users
must pick a product type from the catalog’s New menu.
4. Enter a description for the product type in the Description field.
5. Select a product class from the Class drop-down menu. For information about how
class types affect how products are displayed, see Creating a kit below, Creating a
bundle on page 1811, Creating a complex product on page 1812, and Creating a
subscription on page 1814. In some cases, you will need to perform additional
steps on other screens.
6. Click the Attributes tab.
7. Click Add Attribute. The Add Attribute dialog box appears.
8. Enter an attribute name in the Name field, such as color.
9. Choose a data type from the Type drop-down menu.
l Text
l

Date

l

Number

l

Yes or No (boolean)

10. Click OK. When a customer views the chair’s product page, the customer sees the
attribute text below the thumbnails.
11. Click the Media Defaults tab.
12. Click Add thumbnail. The Add thumbnail dialog box appears.
13. Enter a name for the thumbnail in the Name field.
14. Specify the size if the thumbnail in pixels using the Width and Height fields.
15. Click OK.
16. Click Save. The XML Smart Form editor appears, as described in Step 2: Creating
the content page on page 1818.

Creating a kit
A kit is a type of catalog entry that allows a customer to select from free-text options,
which can affect the item’s price. The options can also be placed into logical groups.
For example, if a catalog entry is a laptop computer, one group may let you enter
options for RAM, another for operating system version, and a third could present hard
drive options.
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There is no limit to the number of groups you can add, nor the number of options in a
group. All groups and options are simple text, created on a kit’s Items tab as needed,
and can accommodate a price modifier. The following example shows how to set up
chair color combinations.

In this example, the options do not affect the price. Here is how the options appear on a
product page.
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Consider another example in which the price does change. In this case, use the Item
screen’s Price Modifier field to adjust price based on the chair frame. For example, if
the chair frame is teak, the sale price increases by $25.00.

Other chair materials might adjust the price.
l

Wrought Iron. $0.00

l

Aluminum. +$15.00

l

Steel. -$10.00

Note how the Price Modifier can either increase or decrease the sale price. Here are
these options on the product page.
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The chair’s base price is $79.99, and the teak frame increases it to $104.99.

Creating a bundle
A bundle consists of several simple products. You would use it to combine several
existing products into one “umbrella” catalog entry. That entry captures pricing, SKU
number, shipping, and inventory information for the bundle. The information for the
individual entries that make up the bundle are not affected when one is ordered.
As an example of a bundle using furniture, assume your eCommerce site sells a chair, a
table, and an ottoman separately. You also sell them together as a set.
Use a bundle to define the set, add pictures, pricing, and so on. On the bundle’s Items
tab, you select the individual catalog entries that make up the bundle.

Here is how this bundle looks on a product page.
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Creating a complex product
A Complex Product is similar to a bundle in that one catalog entry serves as an
“umbrella” for other entries. However, unlike a bundle, a customer must select one of
the catalog entries. So, the price is that of the selected entry, not the umbrella item.
The advantage of a Complex Product is its ability to consolidate several related items
under one title, yet lets customers choose the item they want. Because each item under
the umbrella is its own catalog entry, it is priced and tracked separately.
For example, a site sells movies in 3 formats: VHS, DVD, and Blu-ray. Each is priced
differently. To accommodate this, create catalog entries for the movie in each format,
assigning images, SKU number, pricing, dimensions, and so on. Then, create a Complex
Product, make its title the title of the movie, and use the Items tab to select the catalog
entries of the individual formats.
The Product List or Product Search control displays the Complex Product, which is the
movie title. When a customer selects that, the customer sees the product page, which
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lists the format and price of each assigned catalog entry. The customer can only choose
one.

Unlike the Kit or Bundle, a complex product does not have its own product class.
Instead, you create a catalog entry whose product class is Product, then assign other
catalog entries to it via the Items tab. As soon as you assign one catalog entry via the
Items tab, the original catalog entry is converted to a Complex Product.
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Note that the price of the “umbrella” product appears on the Product List and Product
Search server controls. This can be misleading, since the price of individual items within
the complex product can vary.
You cannot apply tier pricing to a complex product. See also: Tier pricing on page 1829

Creating a subscription
A subscription is a good or service which
l

can be billed on a one-time or a recurring basis

l

places users who purchase it into a designated membership group, letting you
grant them access to private content

Examples include
l

content only available to members who purchase a subscription

l

a gym membership

l

a book club, in which a customer makes the same payment and receives a different
book each month

l

anti-virus software that expires after 12 months

l

a 3-year maintenance contract on a digital television, payable yearly

If you use the recurring billing feature (a series of scheduled payments), the bill can be
generated for any number of months or years, but no other time increments. Each
payment must be the same for the subscription’s term. The term begins when a
customer submits the order.
Customers cannot apply a cart-level coupon to a subscription-based catalog entry. See
also: Creating a coupon on page 1841.

Creating a subscription-based catalog entry
Creating a subscription is the similar to creating a regular catalog entry:
1. Create a subscription-based Product Type. On the Product Type screen’s Class
drop-down, select Subscription.
2. Assign the Product Type to a catalog folder. See also: Creating a catalog folder on
page 1819.
3. In that folder, create a catalog entry for each subscription.
4. On the Pricing tab, enter the cost.
If using recurring billing, enter the term of the subscription. To learn about
Recurring Billing fields, see Entering recurring billing information on the facing
page.
If this product does not use recurring billing, click No at the Use Recurring
Billing drop-down. To learn about the Unit Pricing fields, see Entering a catalog
entry’s price information on page 1828.
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5. On the Items tab, assign membership and Ektron user groups. See also: Assigning
groups to a subscription-based catalog entry on the next page.
6. If a subscription provides access to Ektron content, use its folder Permissions
screen to grant permission to the membership and Ektron user groups you defined
in Step 5. See also: Subscriptions involving Ektron content on page 1817.
Subscription-based products do not support tier pricing. See also: Tier pricing on
page 1829.

Entering recurring billing information
IMPORTANT: Due to differences in the way payment gateways work, you should
test recurring payments with your gateway before processing live transactions.
The Pricing tab’s Recurring Billing area of a subscription-based catalog entry lets
you determine if a subscription is billed on a one-time or a recurring basis. If recurring,
it helps you define the terms.

To set up recurring billing:
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1. Select Yes from the Use Recurring Billing drop-down. The recurring billing term
begins when a customer submits an order, and is based on a number of months or
years.
2. Select a time interval from the Billing Cycle drop-down.
3. Enter a number of Billing Intervals for which a customer is charged. For
example, if a customer should be charged once a month for 12 months, complete
the screen as shown above. If a customer purchases the item on June 1, 2013, the
person's credit card will be billed on the first of each month from June 1, 2013 to
May 1, 2014.
As another example, if a customer should be charged once a year for 3 years, complete
the screen as shown.

If a customer purchases the item on June 1, 2013, the person's credit card will be
charged on the following dates.
l

June 1, 2013 (purchase date)

l

June 1, 2014

l

June 1, 2015

Assigning groups to a subscription-based catalog entry
You must assign a membership user group to a subscription-based catalog entry.
Optionally, you can assign an Ektron user group. You assign groups via the
subscription’s Items tab.
See also: Membership groups on page 1633
So, as part of setting up a subscription, you must either create new membership and
(possibly user) groups, or use existing groups.
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All users (identified by their email address) who purchase the product are automatically
added to one of the groups. Ektron checks a user’s email address to determine if the
user is an Ektron or a membership user.
l

Ektron users are added to the group defined in the CMS Author Group field

l

Non-Ektron users are added to the membership group defined at the Member
Group field

Subscriptions not involving Ektron content
If a subscription does not involve access to Ektron content, the membership group
provides a list of customers who purchased the subscription. You can use the list to
manage the accounts, notify them when the subscription is about to expire, and so on.

Subscriptions involving Ektron content
If a subscription involves access to Ektron content:
Create a folder and enable one or more subscription-based product types on its Product
Type screen.
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Place the subscription products in that folder. Customers shop for and purchase this
content on your website as they do all products, via eCommerce server controls.
Then, create a regular content folder in which to create the confidential content. Next,
use the content folder’s Permissions screen to grant the subscription user groups access
to that folder.

See also: Managing folder and content permissions on page 168 and Assigning
membership permissions on page 1634

Step 2: Creating the content page
After you complete and save the Add Product Type screen, a new screen lets you enter
XML Smart Form information. On this screen, you set up fields to collect information for
the content page of catalog entries based on this product type.
The content page appears on the Product server control, describing this catalog entry to
customers. The process of creating a product type content page is the same as creating
an XML Smart Form, described in Adding a Smart Form configuration on page 892.

Editing a product type
1. In the Workarea, go to Settings > Commerce > Catalog > Product Types.
2. Click the product type that you want to edit.
3. See Step 1: Defining properties, attributes, and media defaults on page 1807.
NOTE: You cannot edit a Product Type’s Class.

Viewing an attribute's published status
Each attribute has a publication status. To view attribute status, go to Settings >
Commerce > Catalog > Product Types, select a product type and click the
Attributes tab.
l
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l

Inactive. Attribute already assigned to one or more catalog entries, but can no
longer be assigned. To make an attribute inactive, click the corresponding Mark
for Delete (

).

l

Not Published. Attribute has been created but Product Type not saved yet

l

Active (marked for delete with strike through). Attribute will be deleted when
Product Type is saved.

You can delete an attribute only if it is not applied to a catalog entry. If you try to delete
an attribute applied to a catalog entry, it is marked “Inactive.” Inactive attributes can
no longer be assigned.

Deleting a product type
PREREQUISITE

The product type is not assigned to any catalog entries.
1. In the Workarea, go to Settings > Commerce > Catalog > Product Types.
2. Click a product type you want to delete.
3. Click Delete (

).

4. Click OK.
Although you cannot delete a product type that is being used, you can prevent users
from creating new catalog entries based on it. To do this, go to each applicable folder’s
Catalog Properties > Product Types screen and remove that product type.

Creating a catalog folder
PREREQUISITE

One or more product types.
A catalog folder is a special kind of Ektron folder designed to hold eCommerce entries.
Its unique icon (
) distinguishes it from other folder types. If you are familiar with
content folders, much of that information applies to catalog folders. See also: Setting
up your CMS folder structure on page 149
A Catalog folder's properties screen has several tabs/screens. The following screens are
the same as regular content folders.
l

Properties. See Setting folder properties on page 158

l

Taxonomy. See Organizing content with taxonomies on page 1357

l

Templates. See Working with templates on page 838

l

Flagging. See Defining flags for content on page 1717

l

Metadata. See Assigning metadata to a folder on page 832
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l

Breadcrumb. See Navigating a website with breadcrumbs on page 1431

l

Aliasing. See Creating user-friendly URLs with aliasing on page 1399

The unique screen is Product Types. See also: Assigning a catalog folder’s product
type below.
Like content folders, the following catalog folder information can be inherited from its
parent or uniquely set for each catalog. You can only make changes after creating the
catalog.
l

Permissions. See Managing folder and content permissions on page 168

l

Approvals. See Approving content for publication on page 749

l

Purge History. See Purging content history on page 167

l

Restore Web Alert Inheritance. See Assigning a Web Alert to a folder or
content on page 1496

Assigning a catalog folder’s product type
A catalog folder’s Product Types screen lets you identify product types upon which
catalog entries can be based. For example, you created a lawn mower Product Type,
and want only lawn mowers to be entered in a catalog folder. In this case, open a
catalog folder’s Product Types tab, break inheritance if necessary, and select Lawn
Mower as the catalog’s only product type.

Then, when an Ektron user creates an entry in this catalog, the user must use the Lawn
Mower product type.
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Deleting a catalog folder
PREREQUISITE

No catalog entries in the folder have been placed on an order
1. Go to the folder that you want to delete.
2. Choose Delete > This Catalog.
3. Click OK.

Searching a catalog folder
Searching a Catalog folder is the same as searching any other type of Workarea folder.
This procedure is described in Searching the Workarea on page 390.

Creating a catalog entry
PREREQUISITE

One or more catalog folders.
A Catalog entry is the eCommerce term that describes a product sold on your website.
It is similar to content in the rest of Ektron, so those concepts also apply to catalog
entries.
Catalog entries are built from Ektron XML Smart Forms, so use the same content and
folder structure as other Smart Forms. See also: Working with Smart Forms on
page 888
Catalog entries share the following features with regular content:
l

content status

l

workflow and permissions

l

metadata
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l

schedule

l

can be private

l

history and the ability to restore previous versions

l

search

l

taxonomies to categorize products

Catalog entries also have unique information:
l

Tax Class—Determines which taxes apply to item

l

Physical dimensions—Used to calculate shipping costs

l

Inventory tracking

l

Pricing—Can be fixed or variable for any currency
l tier pricing—Pricing adjusts when quantity reaches new plateau. For example,
1-9 items cost $500 each. But if 10 are sold, the price drops to $450 each.

l

Images (full sized and thumbnail) to display the product on your website

Because there is so much information to provide about managing catalog entries, this
section takes 2 approaches:
l

l

Creating a catalog entry on the previous page describes how to work with catalog
entries: create them, delete them, and so on.
o Creating/updating catalog Ee on the facing page
o

Deleting a catalog entry on the facing page

o

Recommending related products to a customer on page 1838

o

View and restore a previous version of a catalog entry—Go to catalog folder
> select catalog entry > View Menu > Content History option. See
also: Managing versions of content on page 701

o

Edit permissions for a catalog entry—To enable this, break permission
inheritance. Then, assign permissions to selected users. See also: Setting
permissions for content on page 173

o

Edit inherited workflow—First break permission inheritance, and assign
permission to users who need to be in the workflow. Then, update the catalog
entry’s workflow. See also: Approving content for publication on page 749

o

Make a catalog entry private, so that the website search does not find it—See
Making content private on page 695

o

Archive a catalog entry—See Setting archive options on page 700

o

Displaying catalog entries on your website on page 1837

The following topics describe all accessible options (tables, menus, and so on) from
the catalog entry screen
o Tabs on the catalog entry screen on page 1824
o

1822

Menu options on the catalog entry screen on page 1826

Ektron 9.40 SP1

Creating/updating catalog Ee

o

Folder view menu options on page 1835

o

Content view menu options on page 1835

Creating/updating catalog Ee
1. For information about the catalog entry screens, see Tabs on the catalog entry
screen on the next page) The required fields are:
l content Title
l

Properties tab > SKU Number

l

any fields on the content screen that your Ektron administrator has designated
as required

2. Check in or submit/publish the content.
After signing in to your website, you can also update a catalog entry’s information from
there using the context menu.

If a new catalog entry is similar to an existing one, you might find it quicker to copy the
existing entry then edit the fields that are different. Moving a catalog entry is the same
as moving content. See Moving or copying content on page 687

Deleting a catalog entry
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PREREQUISITES
l

Catalog entry is not on an order, or checked out.

l

You have delete permission for this catalog folder. See also: Managing
folder and content permissions on page 168

BEST PRACTICE
Avoid deleting catalog entries due to the affect on your website. For
example, if you delete an entry from your staging site, then run eSync, that
entry is removed from all active carts on your live site. Instead of deleting
entries, you should archive them using the Properties tab’s Archived
checkbox.
If you want to prevent customers from purchasing an item, but you cannot delete it
because it has been placed on existing orders, you have 2 options.
l

Uncheck its Buyable checkbox, located on the Properties screen. If you do, the
product still appears on your website, but the Add to Cart button does not appear
next to it.

l

archive it, using the Archived check box on the Properties screen (circled above).
In this case, the product does not appear on your website.

To delete a catalog entry:
1. Go to the catalog folder that contains the entry.
2. Click the entry.
3. Choose Action > Delete. A warning message appears.
4. Click OK. The catalog entry is deleted.

Tabs on the catalog entry screen
l

Content. The entry’s content page. See also: Entering a catalog entry’s content on
page 1826.

l

Summary. The content summary, by default the first 40 characters of the content
text. See also: Entering a catalog entry’s summary on page 1826.

l

Properties. eCommerce information about the catalog entry:
o SKU number
o

Number of Units

o

Tax Class

o

Archived

o

Buyable

o

Dimensions

o

Inventory
See also: Entering a catalog entry’s properties on page 1827
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l

Pricing. Lets you define list and sales price
l For each enabled currency, you can set a fixed price or have it float with
exchange rate
l

Allows tier pricing

l

For subscription products, you enter recurring billing interval and term
See also: Entering a catalog entry’s price information on page 1828

l

Attributes. Additional information to help describe a catalog entry. See also:
Entering a catalog entry’s attributes on page 1831

l

Media. Lets you add images that appear on several eCommerce server controls.
See also: Entering a catalog entry’s media on page 1832

l

Items. Catalog entries that you are adding to this “umbrella” item. See also:
l If you add catalog entries to a simple product, it becomes a complex product.
See also: Creating a complex product on page 1812
l

For bundles, add catalog entries that make up a bundle. Creating a bundle on
page 1811

l

For kits, enter groups and their options. See also: Creating a kit on page 1808.

l

For subscription products, define membership and Ektron user groups to
which users are assigned when they purchase the subscription. Creating a
subscription on page 1814

l

Metadata. Enter meta tags, title tags, and so on. Working with Metadata on
page 822 When viewing the metadata screen in view mode only, you see the
catalog entry’s Product Icon. The product icon is set on the Media tab. See also:
Using images in eCommerce on page 1747.

l

Alias. View and edit the catalog entry’s manual primary alias. View all automatic
aliases assigned to this catalog entry. This tab only appears if Aliasing is
enabled.See also: Creating user-friendly URLs with aliasing on page 1399

l

Schedule. Lets you control when a version of a catalog entry becomes visible on
the website. Similarly, you can remove a catalog entry on a predetermined date
and time. The Archive and remain on the site option is not available with
catalog entries. Scheduling content on page 698.

l

Comment. View comments on changes made when editing a catalog entry. To
view and edit catalog entry comments, open the editor and choose Change >
Comment. The comment also appears on the View Content and Content History
screens. Use it to help distinguish one version from another.

l

Tasks. View tasks assigned to this catalog entry. To add a task from the View
Entry screen, click Action > Add Task. See also: Assigning and managing tasks
on page 1449.

l

Category. Add a taxonomy category to the catalog entry. A list of available
taxonomies and whether one is required are defined on the Catalog properties
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screen. This tab only appears if at least one taxonomy is assigned to the catalog
folder. Organizing content with taxonomies on page 1357.

Menu options on the catalog entry screen
l

Action Menu
l Save. Saves the catalog entry without leaving the editor. It is a good idea to
save your work frequently.
l

Check in. Save and check-in the document. This action returns the changed
content to the database and exits the editor. It does not submit the content
into the workflow. Rather, it allows you and other users to continue changing
it.

l

Submit/Publish
l Submit the content into the workflow. This action also returns the new or
updated content to the database and exits the editor.
l

l

l

Publish the content to the website. Only the last approver in the
workflow sees this button. If no workflow is assigned to the content’s
folder, every authorized user sees this button. See also: Approving
content for publication on page 749 This action also returns the changed
content to the database and exits the editor.

Undo checkout. Exit screen and do not save changes made since you began
editing this catalog entry.

Change Menu
l Comment. Enter comments on changes made when editing a catalog entry.
The comment also appears on the View Content and Content History screens.
Use it to help distinguish one version from another.
l

Template. A folder’s default template is automatically applied to all content in
the folder. However, you can change a content item’s template to any of those
assigned to the folder.

Entering a catalog entry’s content
The Content tab displays the content page of this catalog entry’s product type.
Because the format is customized for your system, this documentation cannot explain
how to respond to the fields.
To learn about working with the editor, see Editing in Ektron on page 605.

Entering a catalog entry’s summary
Creating summary information for a catalog entry is done the same as with any other
type of content.
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Entering a catalog entry’s properties
The Properties screen collects eCommerce-specific information about your catalog
entries:
l

SKU. Enter a unique SKU code for this catalog entry. This is a required field that
does not accept a value of zero (0) or a space character.

l

Number of Units. If this item has a quantity other than one (1) for internal
record-keeping purposes only, enter that number.
For example, a 12 pack of soda. Set Quantity is 12 to represent the number of
units. But a customer still orders 1 of the item.
The quantity is not used when this item is ordered, nor does it affect inventory
levels. It is used for clerical purposes only.

l

Tax Class. Select the catalog entry’s Tax Class. See also: Configuring eCommerce
tax screens on page 1796.

l

Archived. Check this box if you want to archive this catalog entry. When archived,
customers can no longer see nor order it. Also, Ektron users cannot view an
archived catalog entry in its catalog folder via the View Folders screen. To view it,
open its catalog folder then select View > Archive.
To make the entry available again on your website, open its archive folder, edit the
entry by unchecking the Archived check box, and publish it.
A catalog entry can also be set to Archived status if it reaches its expiration date
and its Schedule tab > Action on End Date field is set to Archive and remove
from site (expire).

l

Buyable. To let customers add this catalog entry to a shopping cart, check this
box. Otherwise, uncheck it.
If a product is not buyable, it can still be seen by customers, but its product page
does not display an Add to Cart button.

l

Dimensions—Used to calculate packaging containers and shipping costs. See also:
Packages
o Tangible Item.
Check this box if the item is tangible, that is, it has dimensions, weight, and
will be shipped to a customer. Examples of non-tangible items are services,
warranties, and downloadable software. If a catalog entry is tangible, you
must enter its height, width, length, and weight.
o

Height. Enter the catalog entry’s height. The units of measure are specified in
the web.config file’s ek_measurementsystem property.

o

Width. Enter the catalog entry’s width.

o

Length. Enter the catalog entry’s length.

o

Weight. Enter the catalog entry’s weight.
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l

Inventory. eCommerce’s inventory system is a provider model, allowing you to
connect with third-party inventory systems.
o Disable Inventory. Check this box if you do not want to track inventory
activity for this catalog entry. As examples, it is a service contract or a
subscription to confidential content on your site.
o

In Stock. Enter the number of items on hand for this catalog entry. This
number is automatically adjusted when an order containing this entry is
submitted. For example, there are 100 items in stock. When an order for 10 is
submitted, the In Stock value changes to 90. If the amount placed on an
order exceeds the In Stock amount, the customer see this message “The item
... is not available for purchase. Please remove from cart before submitting
order.”

o

On Order. The number of items that have been ordered but not yet delivered
appears.

o

Reorder. Enter the In Stock quantity at which you need to reorder this item.
When the In Stock quantity reaches this level, an event is triggered which can
be used by an external inventory system to generate a new order.

Entering a catalog entry’s price information
Use the Pricing screen to enter price information for catalog entries.
l

Currency selector. Use this drop-down to select a currency for the prices. See
also: Alternate currency pricing below. Only enabled currencies appear. See also:
Enabling currencies on page 1766.

l

List Price. Enter the catalog entry’s list, or manufacturer’s suggested retail, price.
The list price appears on most eCommerce controls but is not used in any
calculations.

l

Our Sales Price. Enter the catalog entry’s sale price. This price is used to
calculate line item totals, coupon discounts, shipping costs, and so on. The sales
price appears on most eCommerce controls. .

l

Add Pricing Tier. See also: Tier pricing on the facing page.

l

Recurring Billing (appears only for subscription-based products). See also:
Creating a subscription on page 1814.

Alternate currency pricing
By default, the Pricing screen converts prices to every enabled currency using the
exchange rate. Customers who select a non-default currency see these prices. See
also: Defining and updating exchange rates on page 1768.
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The Float checkbox (checked by default) indicates that prices change as the exchange
rate changes.
If you do not want to float a catalog entry’s price, but instead fix it for a currency, select
the currency, uncheck Float, edit the price, and publish. From then on, if a customer
selects that currency and catalog entry, the price set on this screen is used. The
exchange rate is ignored.
For example, a television costs 700 Euros, regardless of its cost in US dollars or the
exchange rate. To incorporate this, do not check the Float checkbox.
When you first select EUR on the Pricing screen, the default currency’s prices are
converted using the exchange rate. For example, the television’s sale price is $1000 US
dollars, and today’s exchange rate is .7811. When you select Eur from the Pricing
screen’s currency selector, the television’s cost is set at 781.10 Euros. You change the
price to 700.00 Euros.
From that point on, the Euro price only changes if an authorized user accesses this
screen and changes it manually.

Tier pricing
eCommerce supports tier pricing, that is, a pricing schedule that adjusts according to
order quantity. Typically, the price is reduced as more items are ordered. For example,
if a visitor orders 1-5, items are $10.00 each; 6-10, $9.00 each; 11 or more, $8.50
each.
Tier pricing is not supported for subscription products, nor for complex products.
To set up tier pricing:
1. In the Workarea, open the catalog folder containing the entry to which you want to
apply tier pricing.
2. Edit the catalog entry.
3. Click the Pricing tab
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4. Click Add Pricing Tier. The Tier Pricing screen section appears.

5. In the left column, enter the quantity of items above which the tier price is used.
6. In the right column, enter the price to be used when an order quantity exceeds the
number in the left column.
7. Enter as many tiers as necessary.
NOTE: To remove a tier, check the box to its left, then click Remove Pricing Tier.

Tier pricing and non-default currencies: when floated
If a non-default currency is floated, then that currency’s pricing tiers mirror the default
currency’s pricing tier values. The amounts are adjusted by the exchange rate.
These values appear on pricing screen in view-only mode and cannot be changed.

If pricing tiers are set up for the default currency and the user unchecks the Float box,
the user is notified that the pricing tiers can now be edited. Next, Tier Pricing fields are
loaded with the existing values but the user can change values, remove existing tiers,
and add new ones.

Tier pricing and non-default currencies: when not floated
If a non-default currency is not floated, its pricing tiers are independent of the default
currency’s. That is, they do not exist initially regardless of whether they exist for the
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default currency. If the user clicks Add Pricing Tier, Tier Pricing fields appear and let
the user enter number of units and corresponding tier price per unit.
If pricing tiers are set up for a non-default currency and the user checks the Float box,
the pricing tiers are changed to mirror those of the default currency. If the default
currency has no pricing tiers, then that currency has none. You cannot independently
edit a non-default currency’s pricing tiers if Float is checked.

Entering a catalog entry’s attributes
Attributes are additional pieces of information that help describe a catalog entry.
Attribute fields, data types, and default values are created as part of a Product Type.
When you create a catalog entry, you base it on a product type. The product type’s
Attribute information is imported to the catalog entry. Like metadata that follows
Ektron content, if a catalog entry is moved to another folder, its attributes stay with it.
To illustrate the concept, the following attributes are applied to furniture in Ektron’s
sample site.

In the Workarea, you select a catalog entry then click the Attributes tab to enter or
modify attribute values. If no attributes are assigned to the product type on which a
catalog entry is based, you will not see an Attributes tab when working with that
catalog entry. You could change model year to 2009, or style to Woodland. You
cannot however change fields, field names, or data types.
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On your website, a catalog entry’s Attribute field names and values appear by default
on the Product server control.

Entering a catalog entry’s media
Use the Media tab to add product images that appear on the following server controls.
l

Product (the smallest thumbnail may appear)

l

Product List

l

Product Search

l

Recommendation

See also: Using images in eCommerce on page 1747.

Adding a new image
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1. Click the Media tab.
2. Click Add New Image. The add New Image dialog box appears.
3. Enter an image Title (required).
4. Enter the image’s Alt text (required).
5. Click Browse and go to the image you want to add.
6. Click Upload. The image is uploaded to the siteroot/uploadedimages folder and
you are returned to the Media tab. The uploaded image appears on the screen,
below any existing images.
7. Determine if you want the image’s smallest thumbnail to appear on the Product
server control by selecting Yes or No next to Gallery Display.
8. If you want to designate the image as the product icon, click Set as Product
Icon.
Image thumbnails and product icons are described in Using images in eCommerce on
page 1747.
When an image is uploaded to the Media tab, the original image and any thumbnails
associated with it are added to the Library. For example, if you add an image named
“TestImage” (actual file name: “case.jpg”) with a 150px and 50px thumbnails, you see
the following entries in your library (File Name - Path):
TestImage - /~siteroot~/uploadedImages/case.jpg
case[filename]150 - /~siteroot~/uploadedImages/case[filename]150.jpg
case[filename]50 - /~siteroot~/uploadedImages/case[filename]50.jpg
If you assign several images to an eCommerce catalog entry, and want to allow
searching for that catalog entry by image file name, the search only works with the first
image assigned to the catalog entry.

Editing an existing image
NOTE: You cannot change an existing image. If you need to do this, delete the
image you do not want, then add the correct one. You can only edit the Title and Alt
Text.
1. Click the Media tab.
2. Move the cursor to the field that you want to edit.
3. Click the pencil icon to the right of the field.>—Image—
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4. Update the text as needed.
5. Click OK (

).

Determining thumbnail size
When you create a catalog entry, you base it on a Product Type. The selected product
type’s Media Defaults information determines the sizes of thumbnails created for each
image assigned to the Media tab.

l

If the image is less than both thumbnail dimensions (height and width), it appears
full size.

l

If the image is greater than the thumbnail’s dimensions, the image is reduced
proportionately, scaling its dimensions to the thumbnail size.

The default image
If you do not assign an image to a catalog entry, but one is assigned to appear on a
server control, the following default image is used.

If you want to change the default image, edit the following file:
siteroot/WorkArea/images/application/Commerce/productImageBackground.gif

Entering a catalog entry’s items
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Use the Items tab to add additional information to the current entry. You can only
choose a catalog entry whose language matches the language of the original item. It is
used in these situations:
l

to select the catalog entries that make a product into a complex product.

l

to select the catalog entries that make up a bundle.

l

to select the groups and their options that make up kits.

l

to select a subscription-based catalog entry’s user groups. See also: Assigning
groups to a subscription-based catalog entry on page 1816.

Folder view menu options
New Menu
l

Catalog. Create a new catalog folder underneath the current one. See also:
Creating a catalog folder on page 1819.

l

product types assigned to folder. Create a new catalog entry based on one of
the displayed product types. Your product types may not match the following
product types. Product types are assigned to a catalog’s via the Product Types
screen. See also: Creating product types on page 1806.

View Menu
l

All types, Products, Kits, Bundles, Subscriptions. Lets you change the
display of catalog entries. You can see all entries in folder, or only those of a
selected product class.

l

Language. Limits display of catalog entries to one language. Also determines the
language of any new catalog entries you create in this folder.

l

Archive. Displays archived catalog entries.

l

Catalog Properties. Lets you view and edit catalog folder information.

Delete Menu
l

This Catalog. Lets you delete a catalog folder.

l

Entries. Lets you delete a catalog entry within a folder. You cannot delete a
catalog entry that has been placed on any order. The order’s status is irrelevant.

Action Menu
l

Move entry. Move catalog entry. You can only move catalog entries—you cannot
copy them. See also: Managing versions of content on page 701

l

Search. Search for a product. See also: Searching the Workarea on page 390

Content view menu options
Action Menu
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l

Edit. Edit the catalog entry.

l

Delete. Delete a catalog entry.

l

Link Search. Locates all content that includes a Quicklink to the displayed catalog
entry. This feature is useful before deleting a catalog entry, because it informs you
of every entry that will include a “dead” link if you delete that entry. You should
then edit those catalog entries and remove or change the obsolete Quicklinks.

l

Add Task. Assigning and managing tasks on page 1449

View Menu
l

Content History. Lists every version of the content available in Ektron. After
viewing the View Content History window, you can click any version to see its
detail. See also: Managing versions of content on page 701

l

View Approvals. Access the catalog folder’s workflow. See also: Approving
content for publication on page 749

l

View Permissions. Access the catalog folder’s permissions screen. See also:
Managing folder and content permissions on page 168

l

Cross Sell. Lets you assign cross sell items to this catalog entry. See also:
Recommending related products to a customer on page 1838

l

Up Sell. Lets you assign up sell items to this catalog entry. See also:
Recommending related products to a customer on page 1838

l

View Properties. Lets you:
l view the catalog entry’s product type
l

view the Flagging Definitions assigned to the catalog entry’s folder

l

view and edit the Content Searchable setting See also: Making content
searchable on page 371

Reports Menu
l

Content Statistics. User-ranking of content on page 1069

l

Analytics. Provides a visual display of order information for a selected catalog
entry. See also: eCommerce analytics on page 1875.

Editor view menu options
Action Menu
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l

Save. Save the content without leaving the editor. It is a good idea to save your
work frequently.

l

Check in. Save and check-in the document. This action returns the changed
content to the database and exits the editor. It does not submit the content into
the workflow. Rather, it allows you and other users to continue changing it.

l

Submit or Publish. Submit the content into the workflow. Publish the content to
the website. These actions also return the new or updated content to the database
and exits the editor. Only the last approver in the workflow sees this button. If no
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workflow is assigned to the content’s folder, every authorized user sees this
button. See also: Approving content for publication on page 749
l

Undo Checkout. Close the editor without saving changes.

Change Menu
l

Comment. Briefly describe the content, or comment on changes made when
editing content. The history comment appears on the View Content and Content
History screens.

l

Template. Lets you specify one or more templates for catalog entries in this
folder. These entries use the specified template when appearing on your website.
See also: Working with templates on page 838

Displaying catalog entries on your website
The eCommerce Module provides the following server controls for displaying catalog
entries on your website.
l

Product

l

ProductList

l

ProductSearch templated server controls
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Recommending related products to
a customer
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
Ektron eCommerce lets you recommend related products to a customer (site visitor)
based on products they are currently viewing.
Cross sell and upsell tactics are designed to increase the amount of cart sales. Use the
Recommendation server control to add cross sell and upsell offers.
Cross sell offers items related to a catalog entry. So, for example, if someone is
purchasing a digital camera, cross sell items might be a carrying bag, digital photo
printer, larger memory cards, additional warranty, and so on.
Up Sell refers to similar but more expensive items. So, for example, if someone is
viewing a 7 megapixel digital camera, upsell items might be a 10 megapixel camera, or
a digital SLR camera.

Displaying cross sell and upsell items on a website
Use the Recommendation server control to place cross sell or upsell items anywhere on
a Web page. A single control can only show either cross sell or upsell items.
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Assigning cross sell and upsell items to a catalog
entry
1. Open the catalog folder containing the catalog entry to which you want to assign
cross sell items.
2. Click that entry.
3. Click View > Cross Sell or Up Sell.

4. Click Add. A screen displays all catalog folders.

5. Open the folder that contains the cross sell or upsell catalog entry.
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6. Click that catalog entry.
7. Click OK.
8. Enter additional cross sell entries as needed.
9. Choose Action > Save.
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Using coupons
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
Most eCommerce sites periodically offer coupons to provide discounts to customers,
either to attract new business or reward loyalty. Ektron’s eCommerce feature lets you
generate coupons with the features such as:
l

percentage discounts—you can set a maximum coupon value regardless of the
amount calculated by percentage.

l

limit to catalog entries that you accept

l

limit to most or least expensive entry

l

limit to 1 use per customer

l

limit from being used with other coupons

l

limit to a date range when coupon is active

l

specify a maximum number of redemptions

l

specify a minimum order amount required to activate coupon

Creating a coupon
Create coupons in the Workarea by going to Settings > Commerce > Catalog >
Coupons. To make it easy to complete the information, the screens are arranged in
numbered steps. Subsequent screens are context-sensitive, so that you only see fields
that are a logical result of previous decisions.
The following list summarizes the information collected on each screen.
1. Type Screen
l whether discount is based on amount or percentage
l

code (unique identifier)

l

description

l

currency (for amount-based coupons only)

l

enabled or disabled

2. Discount Screen
l if amount, dollar amount
l

if percentage, percentage and maximum coupon value

3. Scope Screen
l applies to entire cart, accepted items only, most/least expensive item only
l

limit to one per customer
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l

allow combination with other coupons

l

apply to subscription-based products

l

apply amount-based coupons on a "per quantity" basis

l

limit maximum number of redemptions

l

require minimum cart value

l

start and end dates

4. Items Screen—if coupon is restricted to certain items, designate the items

Creating a coupon type

1. Select the type of coupon you are creating/editing using the Type radio buttons:
l Amount. discount is a dollar amount. If you select this type, choose a
currency at the Currency field. Then, enter the dollar amount on the
Discount screen.
l

Percentage. discount is a percentage. If you select this type, enter the
percentage on the Discount screen. That screen also lets you enter a
maximum amount.
Also, if the coupon type is percentage, the Currency field is disabled.
Percentage-based coupons are currency neutral.

2. Enter the coupon code in the Code field. The code cannot contain
l spaces
l
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l

single (‘) or double quotes (“)

l

ampersand (&)

l

slash (/) or back slash (\)

l

plus sign (+)

3. Click Validate Code. When you do, Ektron verifies that the code contains the
correct characters and is not already in use. Customers (site visitors) enter this
code to redeem the coupon on a page that hosts the Cart server control. The
following page gives suggestions about eCommerce coupons, including couponnaming strategies: ecommerce-guide
4. Enter a free text description of the coupon in the Description field. This helps
describe it on the initial Coupons screen in the Workarea.
5. Select the currency to which this coupon applies from the Currency drop-down
menu. If the coupon type is percentage, this field is disabled.See also: Configuring
currencies on page 1766.
IMPORTANT: The coupon is only valid if a customer selects this currency. So,
for example, if you create a coupon for a USD amount, and a customer selects
Euros when shopping on your site, the coupon is not accepted. To work around
this restriction, create a coupon for every applicable currency.
6. Set the status pf the coupon using the Status drop-down. Set to enabled to let
customers uses this coupon (providing all other conditions are met). Or, set to
disabled to keep the coupon in the eCommerce feature but prevent it from being
used.

Setting a discount
The discount screen displayed depends on the discount type selected in the first screen:
amount or percentage. If an amount discount was selected, enter the coupon’s
discount amount.

If the coupon amount exceeds the sum of all items to which it is applied, it is reduced to
the sum of the items. For example, a coupon amount is $10.00 and applies to the least
expensive item. If that item is $3.00, the amount changes to $3.00.
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If a percentage discount was selected:
1. Enter the percentage of the discount in the Percentage field.
2. Enter the maximum value of this coupon in the Maximum Amount field.
For example, if you set a discount of 10% and a Maximum Amount of $20.00, the
discount will never exceed $2.00 (that is, 10% of the Maximum Amount)
regardless of the amount of the goods ordered. Typically, you would include a
Maximum Amount in the email or announcement that describes the coupon.

Setting the coupon scope
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1. Select an Apply Coupon to setting:
l Entire cart. Coupon applies to all items in cart
l

All accepted items. Coupon applies all accepted items in cart.

l

Most expensive accepted item. Coupon applies to most expensive
accepted item in the cart.

l

Least expensive accepted item. Coupon applies to least expensive
accepted item in the cart.

IMPORTANT: If you select All accepted items, Most expensive accepted item,
or Least expensive accepted item, you must identify accepted items on the
Items tab. If you do not, the coupon is effectively inactive.
You cannot apply a cart-level coupon to a subscription product. However, you can
apply an item-level coupon to a subscription product. (An an item-level coupon is
one that applies to all accepted items, or the most or least expensive item.) See
also: Creating a subscription on page 1814.
2. Check the One per customer box if you want to limit each customer to one use of
the coupon. If you do and a customer completes an order with the coupon then
tries to use it a second time, the customer is notified that the coupon is not valid.
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3. Check the Can be combined with other coupons box if this coupon can be
combined with other coupons in the same order. If you do not check this box and a
customer tries to add this coupon to an order to which a coupon is already applied,
the customer is notified that the coupon is not valid.
4. Check the Apply to Subscriptions box if customers can use this coupon to
purchase subscriptions.
Customers can use only coupons with subscription items that have a sale price and
are set to recurring billing. See also: Creating a subscription on page 1814.
Customers can apply only an item-level coupon to a subscription product. (An an
item-level coupon is one that applies to all accepted items, or the most or least
expensive item.) See also: Select an Apply Coupon to setting:Entire cart. Coupon
applies to all items in cartAll accepted items. Coupon applies all accepted items in
cart. Most expensive accepted item. Coupon applies to most expensive accepted
item in the cart.Least expensive accepted item. Coupon applies to least expensive
accepted item in the cart.If you select All accepted items, Most expensive accepted
item, or Least expensive accepted item, you must identify accepted items on the
Items tab. If you do not, the coupon is effectively inactive.You cannot apply a cartlevel coupon to a subscription product. However, you can apply an item-level
coupon to a subscription product. (An an item-level coupon is one that applies to all
accepted items, or the most or least expensive item.) See also: Creating a
subscription on page 1813. on the previous page
5. Check the Apply to Quantities box if you want the coupon amount to discount
each accepted item in a cart. For example, if a coupon amount is $1.00, and a
customer purchases 5 of one item, the discount is $5.00.
If you do not check this box, the discount would be $1.00, regardless of the
quantity of an item purchased. This field is only available for an amount based
coupon.
6. If desired, enter a maximum number of times this coupon can be used in the
Maximum Redemptions field. It does not matter which customers use the
coupon. If you set a maximum, and the coupon is applied that number of times, the
next time someone tries to use the coupon, the customer is informed it is not valid.
7. If desired, enter the minimum order amount required to activate this coupon in the
Minimum Required Cart Value field. The order amount does not include tax or
shipping charges. For example, enter $50.00. If a shopping cart total is $40.00,
and a customer adds this coupon to an order, the customer is informed the coupon
is not valid.
8. Enter the date range within which this coupon is valid using the Start Date and
End Date selectors..
For example, you enter a Start Date of January 1, 2013 and an End Date of
December 31, 2013. If a customer inserts this coupon on February 9, 2014, the
customer is informed the coupon is not valid.
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Defining the coupon items
PREREQUISITE

The Coupon Scope screen’s Apply Coupon to field must be set to one of the
following:
l

All accepted Items

l

Most Expensive accepted Item

l

Least Expensive accepted Item

Use this screen to identify items to which this coupon applies. If Entire Shopping Cart
was selected, the following message appears: This coupon is accepted for all items.

IMPORTANT: Item-level coupon types apply only to items selected on this screen.
If a customer orders a catalog entry that’s not defined on this screen, an item-level
coupon does not apply to the item.
For example, you create a coupon worth 10% off any digital camera. The coupon is only
applicable if a digital camera is in the shopping cart. Typically, the email or
announcement that describes the coupon includes item restrictions. The discount is
applied to each accepted item in the cart. For example, a coupon provides a 10%
savings on items 1, 3, and 5 but not 2 and 4 because 2 and 4 are not on the accepted
items list.

Selecting a coupon’s accepted items
There are 3 ways to select items for the Include or Exclude list:
l

Individual items. Click Include Product and go through the Ektron folder
system to that content. You can only select items in a category folder (which are
blue to distinguish them from regular folders).
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l

All items in a catalog folder. Click Include Catalog and go through the Ektron
folder system to that folder. You can only select items in a category folder (which
are blue to distinguish them from regular folders).
NOTE: If you choose a parent catalog, its child catalogs are not selected. Only
products in the parent catalog are eligible for the coupon.
If you want to select a parent catalog and its child catalogs, first select the child
catalogs. Then, go to the parent catalog and select it.

l

All items in a taxonomy or category. Click Include Category and go through
the Ektron taxonomies to the desired taxonomy or category. All content applied to
the category will be eligible for the coupon.

Include vs. exclude
You can both include and exclude using any of the criteria listed above. If any product
appears on both lists, it is excluded from coupon eligibility.
So for example, one of your folders contains 500 digital cameras that your site offers.
You want the coupon to apply all but a few cameras.
On the Include tab, select the cameras folder. Then, use the Exclude tab to select the
few cameras to which the coupon does not apply. In this way, you can easily select the
majority of items but exclude a few.

Deleting a coupon
If a coupon is applied to an order, you cannot delete it but you can disable it.
To delete a coupon that is not applied to an order:
1. Go to Ektron Workarea > Settings > Commerce > Coupons.
2. Locate the coupon that you want to delete.
3. Click delete on the far right of the coupon information.
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4. A strikethrough line appears over all coupon text, and Restore ( ) replaces
Delete. If you change your mind and do not want to delete the coupon, click
Restore.
5. Click Save.
If the coupon cannot be deleted, it remains on the main Coupons screen and No
appears in the Enabled field. This coupon can no longer be used.

Disabling a coupon
When the coupon’s status is Disabled, customers can no longer apply it to an order.
Coupons can be disabled automatically (according to a schedule) or manually.

Using an expiration date to disable a coupon
When you create a coupon, a default end date is set for 10 years from the end of the
current year. At that time or at any time the coupon is active, you can change its end
date.
When the coupon’s end date is reached, its status changes to Disabled.

Manually disabling a coupon
1. Go to Ektron Workarea > Settings > Commerce > Coupons.
2. Locate and click on the coupon that you want to delete. The Coupon Propties
screen appears and the Type tab is selected.
3. Choose Disabled from the Status drop-down.
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Managing customer orders
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
The fulfillment aspect of eCommerce involves:
l

l

tracking submitted orders, including
o order status
o

charge capture

o

shipping

o

cumulative sales information on customers

customer information, such as
o orders submitted
o

addresses

o

current shopping carts

PREREQUISITES

To process orders, the Distributed Transaction Coordinator (DTC) Windows
service must be running. It is started by default when you install Ektron.

Order workflow
Ektron uses Microsoft’s Windows Workflow Foundation to create and implement order
process workflows to handle the ordering process. The workflow can be as simple or
complex as your business requires.
For example, you have a simple workflow that sends one email to the customer when
an order is received, and another to your shipping department. Or, you could have a
more complex workflow that:
l

sends an email to the customer when the order is received

l

checks to see whether the item is a tangible product or a virtual product. Then,
continues down the workflow path that’s appropriate for the item.

l

handles shipping notifications and updates the account throughout the shipping
process

l

handles the order if it is canceled

l

handles the order if it is determined to be fraudulent

l

marks the order as complete when activities are finished

For more information about workflows, see Customizing workflows on page 1877.
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Creating the order process
This section summarizes the shopper experience using Cart and Checkout for
information about the Cart and Checkout server controls used to implement the order
process.
1. As a shopper, you can add items (physical goods, subscriptions, or soft goods) to
your cart by clicking Add to Cart.

2. When you are ready to pay, click Checkout to begin the checkout process.
NOTE: Shoppers have the option of checking out using PayPal’s checkout
system. Order information is exported, and you can use your PayPal account to
fund the purchase. See also: Configuring payment options on page 1770.

3. When you return, you can log into your account and continue the checkout
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process. Your shipping and billing information appears.
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4. Click Create Profile and Checkout and complete the Billing Page.

5. Click Next Page to create an account. After confirming the information, you can
enter a different shipping address.
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6. When you click Next Page, you can select the delivery method. If the cart contains
a subscription or soft goods (such as downloadable software), this page is typically
bypassed.

7. On the Review Page, you can modify the order by clicking Edit your cart.
Otherwise, move forward to the Payment options page.
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8. Specify payment information and submit the order.

An order invoice page displays to confirm the order. If the order was for a subscription
or downloadable software, additional information appears.

Processing orders
Ektron Reference
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The orders screen provides information about all orders in your eCommerce system. To
access it, go to Workarea > Settings > Commerce > Fulfillment > Orders.

Initially, orders are sorted by submission date and time, with the most recent at the
top.

Selecting orders by criteria
You can select orders by any of the following criteria.
l

entry date range

l

customer

l

catalog entry

To use any filter, choose Reporting then the appropriate filter option:
l

Most Recent. This is the the default select and sort order: all orders with the most
recent on top.

l

By Date(s). If you choose to view orders By Date(s) and want to view orders for
today, enter tomorrow as the ending date.

l

By Customer

l

By Product

l

By ID

Order statuses
NOTE: The following table assumes you use the default workflow installed with
eCommerce. If you customize the workflow, the following table may be inaccurate.
See also: Customizing workflows on page 1877.
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Status

Description

How to Set

Received

Order has been submitted.

Customer submits order
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Status

Description

How to Set

Fraud

Your organization has
determined that the order is
fraudulent.

View Order Screen > Action
Menu > Mark as Fraud
View Order Screen > Action
Menu > Ship Order

Shipped

Order has been shipped. This
status can be the workflow’s
end point. You do not need to
use the Completed status.

Completed

All order activities are finalized.
No events can occur to a
Completed order.

View Order Screen > Action
Menu > Process Order

Cancelled

Order has been canceled.

View Order Screen > Action
Menu > Cancel Order

InProcess

Automatically assigned when
order is submitted.

Order placed but not yet
captured

or
View Order Screen > Action
Menu > Enter/Edit Tracking
Number > CheckMark as
Shipped checkbox and save

Viewing orders
To view the details of any order, click it. When you do, the View Order screen appears.
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If the Workflow tab does not display a flowchart, verify that the server’s Distributed
Transaction Coordinator (DTC) Windows service is running. It is started by default when
you install Ektron, but if it stops for some reason, the Workflow does not appear on this
screen.

Capturing orders
It is important to distinguish between authorization and capture in relation to orders:
l

Authorization occurs while a customer is using the Checkout server controls. It
submits a customer’s payment information to a payment gateway, bank, or PayPal,
and returns either an approval with an authorization number (transaction ID) or a
decline along with an explanation.

l

Capture is the process of submitting encrypted order information (including the
transaction ID) to a payment gateway account, bank, or PayPal. At this time, the
account is charged for the order amount.

Take into account the following:
l

In many states, you must ship an item before you can charge a customer’s credit
card for it.

l

Items that are not tangible are automatically captured if paid by PayPal or a credit
card.

After an order has been captured, you receive confirmation from the paying agency that
the money has been deposited to your account and is available. At this time, you use
the Mark as Settled option to inform the eCommerce feature that payment has been
received. This changes the order status to Complete. Confirmation occurs:
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l

PayPal or credit card—when the goods are shipped.

l

Check—When the check clears.

See also: Configuring payment options on page 1770.

Capturing an order
1. From the Workarea, choose Settings > Commerce > Fulfillment > Orders.
2. Click the order that you want to capture.
3. Click the Payment tab.
4. Click the payment to display. The View Payment screen appears, showing
information about the transaction captured when the customer (site visitor)
submitted payment information.
5. Choose Action > Capture. You are asked to confirm the action.
6. Click OK.

Canceling an order
Click Action > Cancel Order to stop all processing on the order. If you do, the order’s
status changes to Canceled.

Deleting an order
To delete any order, select it from the Orders screen then click Delete ( ).
After deleting an order, you cannot recover its information.

Entering a tracking number
When an order is shipped, the shipping provider typically provides a tracking number to
help locate the shipment within the delivery chain. Use the Enter Tracking Number
option to enter this part of the order information.
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After entering the tracking number, you can indicate whether the order has shipped.

Viewing the tracking number
You can display an order’s tracking number on the View Order screen by clicking the
Address tab and looking under the Shipping Address.

1860

Ektron 9.40 SP1

Marking the order as shipped

Marking the order as shipped
When you enter an order's tracking number, the screen lets you mark it as shipped. See
also: Entering a tracking number on page 1859.
If you did not mark the item as shipped at that time, a Ship Order option appears on
the Action menu. To denote that such an order has shipped:
NOTE: If that order has not yet been captured, it will be captured as part of the
shipping of the order.
1. From the Workarea, choose Settings > Commerce > Fulfillment > Orders.
2. Click the order that is being shipped.
3. Choose Action > Ship Order.

Marking the order as fraudulent
Use this option if your organization determines that the order is fraudulent. These
orders cannot be processed any further.

Entering order notes
After selecting an order, you are allowed to submit a note about it. You can use the note
to record information about the item, the buyer, shipping irregularities, and so on.
Only one note can be saved per order. If you edit and save a note, the previous note
text is permanently removed.

Sending eCommerce messages
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Ektron’s eCommerce feature provides a messaging feature that can notify a purchaser
or the Ektron administrator when the following events occur. Each message has a
unique type that corresponds to an event and, in one case, a recipient.
l

OrderReceived message type sends email to the purchaser when an order is
submitted.

l

OrderReceivedToAdmin message type sends a message to the Ektron
administrator when an order is submitted.

l

OrderCancelled message type sends email to the purchaser when am order is
cancelled.

l

OrderShipped message type sends email to the purchaser when an order is
shipped.

l

OrderComplete message type sends email to the purchaser when an order is
completed.

You can create any number of messages for each event, assigning one as the default.
Only the default message is sent when the corresponding event occurs. Here is a
sample message as set up within Ektron.
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Here is a portion of the same message as delivered to a recipient’s inbox.

How messages are created and generated
Ektron provides sample text for each type of message. To view and edit a message, go
to the Workarea > Settings > Commerce > Configuration > Messages.
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The Message Type determines the event that causes a message to be sent. For
example, the Orderreceived message is sent to a purchaser when the order is
submitted.
If content notification emails are being generated, the site visitor provided an email
address, and a message is defined for the event, emails are sent when eCommerce
events occur. No additional set up is required.
NOTE: eCommerce messages are distributed in the same way as content
notification emails. For information on setting this up, see Installing Ektron on
page 9.

Creating or editing an eCommerce message
1. From the Workarea, choose Settings > Commerce > Configuration >
Messages.
2. If a message of the type you want to create already exists, select it. Otherwise,
click Add Email Message.
3. Assign a Title, Subject (for the email subject line), Message Type, and message
text.
4. When the message is complete, click Save.

Message variables
An eCommerce message can include the following variables, which pull order
information into the message:
l

@CustomerFirstName@. Customer’s first name

l

@CustomerLastName@. Customer’s last name

l

@OrderCouponTotal@. The order’s coupon discounts

l

@OrderId@. The order’s ID number

l

@OrderItemQuantity@. The quantity of any item on the order

l

@OrderItemSalePrice@. The sale price of any item on the order

l

@OrderItemStart@ and @OrderItemEnd@. Use the start and end markers to
show information for ordered items.
The markers show no information by themselves. Instead, they repeat the
variables between them for every item on the order.So, for example, assume an
order has 10 items, and your message looks like this:
@OrderItemStart@
@OrderItemTitle@
@OrderItemQuantity@
@OrderItemSalePrice@
@OrderItemTotal@
@OrderItemEnd@
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The message prints the title, quantity, sale price, and total for each item on the
order.
l

@OrderItemTitle@. The title of any item on the order

l

@OrderItemTotal@. The total cost of one item. For example, if
orderItemSalePrice = $10 and orderItemQuantity = 2, orderItemTotal =
$20.

l

@OrderShippingTotal@. The order’s shipping cost

l

@OrderSubTotal@. The order’s subtotal, that is the amount of ordered items
prior to shipping costs, taxes, and coupon discounts

l

@OrderTaxTotal@. The order’s tax amount

l

@OrderTotal@. The order’s final cost (which includes taxes, shipping, and coupon
discounts)

l

@TrackingUrl@. The link to a Web page that tracks your package. It is usually a
combination of the shipper’s URL and the tracking number.

Setting up a recipient for the OrderReceivedToAdmin
message
The OrderReceivedToAdmin message type requires additional setup. Specifically, you
must update the following values in the web.config file.
l

adminEmail. email address of eCommerce administrator to receive order
confirmation message

l

ek_ecom_SendOrderReceivedEmailToAdmin. Set to true to enable this
functionality. Set to false to disable it.
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Viewing customer information
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
Customers create an account the first time they complete the checkout procedure. The
Customers screen provides information about all customers who order from your
website. The first screen presents the
l

customer ID number

l

user name

l

number of orders

l

amount of all orders

l

average order amount

You can click any customer’s ID number or name to see more details about the person's
order history. The View Customer screen provides information about the customer’s
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l

summary information (name, number of orders, total of all orders, average order
amount).

l

orders (see Processing orders on page 1855) .

l

addresses (you can edit any address or enter a new one) .

l

whenever a user creates a new order and enters a new or selects an existing
billing/shipping address, that becomes the new default.

l

shopping carts (see Creating the order process on page 1851).
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Generating eCommerce reports,
widgets, and logs
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
eCommerce provides several ways to measure and monitor your commerce activity:
l

View a set of standard reports by choosing Settings > Commerce > Reports.
These are also found in the Reports > Commerce section.

l

View a log of your eCommerce activity in Workarea > Settings >Commerce >
Audit.

l

View a visual display of order information for a selected catalog entry by viewing
the entry and choosing Reports > Analytics.

The eCommerce reports are also available as widgets for the Smart Desktop. See also
Managing content from the Smart Desktop on page 668.

Customer report
The Customer Report shows 5 customers ranked according to account date, total sales,
or orders.

The report contains the following fields:
l

Name. Customer first and last name

l

Orders. Total number of orders by this customer

l

Order Value. Total amount of sales to this customer

l

Date Created. The date this person first became a customer

To change the report type, follow these steps.
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1. Click Most Recent.
2. Select the type of report to view:
l Most Recent. the newest customers joining the site
l

Most Valuable. customers ranked by order value

l

Most Active. customers ranked by number of orders

Inventory report
The Inventory Report displays the following information for each catalog entry.
l

amount in stock

l

amount on order (number of items were been ordered but not delivered)

l

amount on reorder (quantity at which you need to reorder this item). When the In
Stock quantity reaches this level, an event is triggered which an external inventory
system can use to generate a new order.

l

inventory status of item (enabled or disabled)

The screen also lets you edit any amount and the inventory status. Any changes made
on the screen update the inventory fields on the catalog entry's Properties tab.
See also: Entering a catalog entry’s properties on page 1827

Sorting the inventory report
You can restrict the display to catalog entries in a selected Product Class. To do this,
click the Reporting button. For example, you can display complex products only.
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See also: Product classes on page 1806.

Editing inventory information
You can edit any catalog entry's inventory information. To do so, select it from the
Inventory Reports screen then click Edit.
NOTE: When editing the In Stock field, select a plus (+) or minus (-) sign from the
drop-down menu then enter the adjustment amount. The screen automatically
recalculates the in-stock amount for you.

Key performance indicators report
The Key Performance Indicators report compares sales and orders for 2 time periods.

To change the periods to compare:
1. In the Period column, click This Month.
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2. Click the first period for which you want to compare performance.
3. Repeat steps 1 and 2 for the second period with which you want to compare
performance.
4. Click Refresh (

).

Reconciliation reports
The Reconciliation report lists payments for a specific time period. Your accounting
department may used it reconcile bank statements with the order system.
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The report includes the following fields:
l

Date Captured. Date the payment was captured. See also: Capturing orders on
page 1858.

l

CardID. The last 4 digits of the credit or debit card used for payment.

l

Type. Type of payment used. See also: Configuring payment options on
page 1770.

l

TransactionId. The unique number returned from the Payment Provider for this
payment.

l

Amount. Total amount of the payment for this transaction.

l

Voided. Total amount voided in the transaction.

To run a report, follow these steps.
1. Click Calendar (

) next to Start Date to open the calendar.

2. Click a date to set the start date.
3. Click Calendar (

) next to End Date to open the calendar.

4. Click a date to set the end date.
5. Click Set New Dates to refresh the report.

Sales Trend report
The Sales Trend reports graphs the number of orders for the past 8 periods. You can
choose monthly or daily orders. The top of the graph display the total number of orders
and sales.
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To change the graph's duration, click a time period from the drop-down.

Top Products report
The Top Products reports shows the most popular products on your site.
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To create the report:
1. Click the link text next to the calendar icon.
2. Select the time period of sales from the drop-down.

3. To change the maximum number of products to show, click the value next to
Quantity, enter a value, and click Update.

eCommerce audit log
As an administrator, you should regularly review the eCommerce Audit Log. This is vital
to keeping your site secure and, if data is compromised, the log helps you determine
the source.
While it is important that Ektron captures this information, it is even more important
that you review, analyze and use it. For example, while reviewing the Audit Log, you
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might find that one eCommerce administrator has an unusually large number of login
failures. This could indicate that someone is trying to break into your system.
You can view a log of your eCommerce activity in the Workarea > Settings >
Commerce > Audit.
To enable eCommerce logging, open the website’s web.config file and change the
following key to True:
<addkey="ek_ecom_ComplianceMode" value="false"/>

When compliance mode is turned on, Ektron logs and displays the following events.
l

l

l

Actions affecting administrators (Administrator Group member, Commerce Admin
Role, Builtin Account).
o An administrator logs in or out
o

An administrator's login attempt fails

o

An administrator password is changed

Actions affecting an Ektron user’s rights to eCommerce.
o Adding a user to the Commerce Admin Role
o

Removing a user from the Commerce Admin Role

o

Adding a user to the Admin group

o

Removing a user from the Admin group

Actions affecting order information.
o Updates to an order's address
o

The transaction ID and response from the payment gateway

o

Any action conducted with the payment gateway. For example, when
capturing a previously authorized transaction.

o

Workflow activities. For example, sending an email.

o

Whenever the default gateway or payment options are changed in the
Workarea.

eCommerce analytics
The eCommerce Analytics screen provides a visual display of order information for a
selected catalog entry. Display a catalog entry and choose Reports > Analytics.
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l

Top left section graphs the quantity of this catalog entry ordered over the past 7
days

l

Top right charts the number of orders that used a coupon versus the number that
did not

l

Below that pie chart is another that shows the number of returning customers
versus the number of new ones

l

The lower part of the screen shows the following order information
l order number
l

date/time when order was entered

l

site from which order was entered

l

order status

l

customer information: new or returning, name, number of orders entered,
value of all orders entered, average order monetary value

l

order monetary value

l

if a coupon was used
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Customizing eCommerce
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
Ektron's eCommerce Module lets you set up an eCommerce website, which delivers a
full set of functionality for building an online marketplace.
As a developer, you can use Ektron’s standard functionality and out-of-the-box server
controls to quickly create an eCommerce website. See eCommerce Server Controls for
more information.
Ektron also lets you customize your website. For example, you can customize your
site’s order process workflow.

Customizing workflows
IMPORTANT: If you customize the workflow then upgrade to a new version of
Ektron, you need to point to the new references then compile the workflow.
Ektron uses Microsoft’s Windows Workflow Foundation to create and implement order
process workflows in Ektron. Within Ektron eCommerce functionality, you use a
workflow to handle the ordering process after your site has received an order. The
workflow can be as simple or complex as your business requires.
For example, you could have a simple workflow that sends an email to the customer
when their order is received, and sends another to the person shipping product for you.
Or, you could have a more complex workflow that:
l

sends an email to the customer when the order is received

l

checks to see whether the item is a tangible product or a virtual product. Then,
continues down the workflow path that’s appropriate for the item.

l

handles shipping notifications and updates the account throughout the shipping
process

l

handles the order if it is canceled

l

handles the order if it is determined to be fraudulent

l

marks the order as complete once all activities are finished

The following illustration shows Ektron’s default sample workflow.
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Windows Workflow Foundation (Released with Microsoft’s .NET 3.0) is a development
tool that lets you create activities-based workflow that can persist over a given length
of time or be paused and restarted depending on events. For more information on WF,
visit Windows Workflow Foundation.
Workflows are comprised of activities; each activity represents a portion of your
Business Process. When activities have finished within a workflow, it terminates. There
are 2 types of activities:
l
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Activities. executed inside the workflow once the activity is reached. For example,
an email might be sent to a customer once their order is received by using the
AdvancedEmailActivity placed after the OrderReceivedEventActivity. This email is
automatically sent with no human interaction needed, and the workflow would

Ektron 9.40 SP1

Customizing workflows

continue.
l

Event Activities. pauses the workflow until the event occurs. When the event
takes place, the associated activity is executed. Think of events as road blocks in
the workflow that are not opened unless a matching action happens. When the
event happens, the workflow follows the path associated with that event.
For example, an OrderFraudEventActivity in a workflow would keep the workflow
from going through the Fraud Event portion of the workflow unless the order is
marked as fraud.
l

AdvancedEmailActivity on page 1885. Send an email based on the order ID
and a specified message type.

l

BasicEmailActivity on page 1887. Send a generic email message when this
activity is reached in the workflow.

l

CaptureOrderActivity on page 1888. Customize the handling of an order when
it is captured.

l

CheckStockActivity on page 1889. Verify whether the item is an in-stock item
or not.

l

OrderCancelledEventActivity on page 1889. Customize the handling of an
order when it is canceled.

l

OrderCapturedEventActivity on page 1890. Customize the handling of an oder
when it is captured.

l

OrderFraudEventActivity on page 1891. Customize the handling of an order
when it’s marked as fraud.

l

OrderProcessedEventActivity on page 1891. Customize the handling of an
order when it’s being processed.

l

OrderReceivedEventActivity on page 1892. Customize the handling of an order
when it’s marked as received.

l

OrderShippedEventActivity on page 1892. Customize the handling of an order
when it’s marked as shipped.

l

OrderUpdatedEventActivity on page 1893. Customize the handling of an order
when it’s updated.

l

UpdateOrderActivity on page 1893. Update the order when this activity is
reached.

Ektron supports Sequential Workflows and State Machine Workflows. Sequential
Workflows are structured; a step-based process where one activity leads to the next.
State Machine Workflows typically move from one activity to another when their state
changes.
You can have multiple workflow projects associated with your eCommerce site and
change workflow projects at any time. However, only 1 workflow project can run at a
time. When an order process starts with a specified workflow, it continues through that
Workflow.
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Installing Ektron’s sample workflow template
PREREQUISITE

Ektron SDK is installed See also: Using Ektron’s Developer SDK.
Ektron provides a C# workflow template sample for a sequential workflow. You can
modify this sample or use it to create new workflows. It is based on the Ektron default
workflow.
To install Ektron’s sample workflow template, copy and paste the Ektron Ordering
Sequential Flow.zip file using the following From & To information.
From:
C:\Program Files(x86)\Ektron\CMS400SDK\Commerce\Workflow\Templates\VS2010

To:
C:\Documents and Settings\~user name~\My Documents\
Visual Studio 2010\Templates\ProjectTemplates\Visual C#\Workflow

NOTE: Make sure you replace ~user name~ in the path with the user name under
which Visual Studio project templates are saved.
Extract the .zip file in the To location. Then, you can work with a sample workflow. See
also: Working with the sample workflow below.

Working with the sample workflow
PREREQUISITE

You installed Ektron’s sample workflow template. See Installing Ektron’s
sample workflow template above.
1. Open Visual Studio.
2. Choose File > New > Project.
3. If you are using C#, expand the Visual C# project type. Otherwise, expand the
Visual Basic project type.
4. Click Workflow.
5. From the My Templates area, select Ektron Ordering Sequential Flow.
6. Select a new Name. If necessary, change the Location, Solution and Solution
Name.
7. Click OK.
8. If a prior version of the software developer's kit (SDK) is installed, the assemblies
in the sample may be older than those in your site. To avoid an issue:
a. From your project's bin folder, remove Ektron.Cms.Common.dll and
Ektron.Workflow.dll.
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b. Copy those files from the bin folder of your Ektron site to the bin folder of the
newly-created workflow project.
c. Re-establish the References to these dlls from the project's bin folder.
9. Open the Workflow.cs file in the Solution Explorer.

10. Make any necessary changes to the workflow.
11. Debug as needed.
12. Build the workflow. This creates a DLL of the workflow and places it in the project’s
bin/debug folder.
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13. Go to the DLL's folder. For example, C:\Documents and Settings\~user
name~\My Documents\Visual Studio
2010\Projects\MyWorkFlow\MyWorkFlow\bin\Debug.
14. Move or copy the new workflow DLL file to your website’s bin folder.

Adding workflow activities to your toolbox
1. Open or create a Workflow in Visual Studio. See Installing Ektron’s sample
workflow template on page 1880.
2. Display the Toolbox (View > Toolbox).
3. Right-click the mouse within the Toolbox and choose Add Tab.
4. Type Ektron Workflow Activities then press Enter.

5.
6. Click the Ektron Workflow Activities tab.
7. Right-click the mouse in the empty area and choose Choose Items. The Choose
Toolbox Items dialog appears.
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8. In Visual Studio 2010, select the .NET Framework Components tab.
9. Browse to webroot\siteroot\bin\Ektron.Workflow.dll file. This file provides
access to Ektron’s workflow activities.
NOTE: Alternatively, you could use the following location: C:\Program Files
(x86)\Ektron\CMS400vxx\bin. The file is identical in both places. Using the bin
folder in your site provides better speed. However, if you use the bin folder in
Program Files, you do not have to worry about deleting the .dll file if you change
or delete your site.
10. Click OK.
For easier viewing, right-click the workflow activities and select Sort Items
Alphabetically.
NOTE: Ektron’s workflow activities appear only when the workflow is opened in
design mode.

Removing workflow activities
1. Display the Visual Studio toolbox (View > Toolbox).
2. Right-click the mouse within the Toolbox.
3. Click Choose Items.
4. Click the Activities or .NET Framework Components tab.
5. Click Namespace or Assembly Name to sort Workflow Activities.
6. Uncheck all boxes that begin with Ektron.Workflow.Activities.
7. Click OK.
8. Right-click the Ektron Workflow Activities tab.
9. Click Delete Tab.

Updating workflow activities
To update workflow activities, remove the existing ones in Visual Studio, then add new
ones.
l

For information on removing workflow activities, see Removing workflow activities
above.

Inserting workflow activities using drag and drop
Because Visual Studio is a visual environment, lines that connect events and activities
change as you add or remove them. To add an activity to a workflow:
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1. Display the Visual Studio toolbox (View > Toolbox).
2. Click the Ektron Workflow Activities tab. Ektron’s Workflow Activities appear.

3. Drag an activity and drop it into the desired location in the Workflow.
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4. As desired, modify the activity’s properties using Visual Studio's Properties area.

AdvancedEmailActivity
Send an email notification, based on an order ID in Ektron, after an event takes place in
the workflow. For example, after an order is shipped, you might choose to send an
email that notifies customers when their orders are shipped. Or, you might send an
email to a customer when their order is received.
With this activity you can choose to send a predefined email message. These messages
are defined in the Workarea under Settings > Commerce > Configuration >
Messages. See also: Sending eCommerce messages on page 1861.
Two event handler properties in this activity let you add custom code to SendingEmail
and SentEmail events. The SendingEmail event fires immediately before the email is
sent. The SentEmail event fires immediately after the email sent.
Key properties of this activity are:
l

EmailArgs. Set this property to OrderId to associate the activity with orders in
Ektron.

l

MessageTypes. Set this property to the type of email message this activity sends.
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Associate email activity with orders in Ektron. You can either supply information such
as, To:, From:, Body:, and so on. or use information associated with the order. It also
lets you specify the type of message type that’s sent. (The BasicEmailActivity, on
the other hand, is a generic email activity where you specify To:, From:, Body:, and
other email information.)
Activities
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

Email Message
l

Bcc (String). A blind carbon copy of the email is sent to the address entered in this
property. If you select OrderId for the EmailArgs property, the Bcc property is
dynamically populated with the order’s information.

l

Body (String). Enter the main content of the email. If you select a parameter from
the MessageType property, the Body property uses the corresponding content for
that message type.

l

CC (String). A carbon copy of the email is sent to the email address entered in this
property. If you select OrderId for the EmailArgs property, the CC property is
dynamically populated with the order’s information.

l

From (String). The address from which the email is sent. If you select OrderId for
the EmailArgs property, the CC property is dynamically populated with the order’s
information.

l

HtmlBody (Boolean). Select whether to send the email in HTML or plain text. True
(default), use HTML; False, use plain text.

l

ReplyTo (String). Specify the address to which the recipient of the email replies.

l

Subject (String). Enter subject information for the email. If you select a parameter
from the MessageType property, the Subject property uses the subject
information for that message type.

l

To (String). The email is sent to the address in this property. If you select OrderId
for the EmailArgs property, the To property is dynamically populated with the
order’s email information.

Email Server
l

Port (Integer). Set this value to the port your system uses access to retrieve
email. In most cases, the port is set to 25. If that is not the case, see your System
Administrator. The default is 25. If blank, this property uses the ek_SMTPPort
value in the site’s web.config file.

l

SmtpHost (String). The address of the server hosting the email system. If blank,
this property uses the ek_SMTPServer in the site’s web.config file.

Handlers
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l

SendingEmail (String). Event handler to add custom code to the sending email
event. This event fires right before the email is sent.

l

SentEmail (String). Event handler to add custom code to the sent email event.
This event fires right after the email is sent.

Misc
l

EmailArgs. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

l

) and select OrderId from the list.

MessageType. Select the type of message that is sent for this activity. If you
select None, the message is sent with the text in the Body property.
o None (default). uses the text in the Body property.
o

OrderReceived. Sends the Order Received email defined in the Workarea >
Settings > eCommerce > Configuration > Messages screen when an
order is received.

o

OrderCancelled. Sends the Order Cancelled email defined in the Workarea
> Settings > eCommerce > Configuration > Messages screen when an
order is received.

o

OrderShipped. Sends the Order Confirmation email defined in the Workarea
> Settings > eCommerce > Configuration > Messages screen when an
order is received.

For information on defining the messages, see Sending eCommerce messages on
page 1861.

BasicEmailActivity
Send an email after an event takes place in the workflow. These emails are usually
generic and contain the same information for To:, From:, Subject, Body, and so on.
There are 2 event handler properties in this activity that let you add custom code to the
SendingEmail and SentEmail events. The SendingEmail event fires right before the
email is sent. The SentEmail event fires right after the email sent. For example, you
want to notify a supervisor when orders are received, but you don’t want the
notification to contain any order specific information.
Key properties of this activity are:
l

To. enter the address to receive the email.

l

From. enter the address from which the email is being sent.

l

Subject. enter a brief summary for the email.

l

Body. enter the main subject text of the email.

BasicEmailActivity sends a generic email. In the activity, you specify To:, From:, Body:,
and other email information. (The AdvancedEmailActivity, on the other hand, lets
you send an email associated with orders in Ektron.) You can either supply information
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such as, To:, From:, Body:, and so on, or use information associated with the order. It
also lets you specify the type of message type that’s sent.
Activities
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

Email Message
l

Bcc (String). A blind carbon copy of the email is sent to the address entered in this
property.

l

Body (String). Enter the main content of the email.

l

CC (String). A carbon copy of the email is sent to the email address entered in this
property.

l

From (String). The address from which the email is sent.

l

HtmlBody (Boolean). Select whether to send the email in HTML (True) or plain
text (False).

l

ReplyTo (String). Specify the address to which the recipient of the email replies.

l

Subject (String). Enter a brief summary for the email.

l

To (String). The email is sent to the address in this property.

Email Server
l

Port (Integer). Set this value to the port your system access to retrieve email. In
most cases, the port is set to 25. If that is not the case, see your System
Administrator. The default is 25. If blank, this property uses the ek_SMTPPort
value in the site’s web.config file.

l

SmtpHost (String). The address of the server hosting the email system. If blank,
this property uses the ek_SMTPServer in the site’s web.config file.

Handlers
l

SendingEmail (String). Event handler to add custom code to the sending email
event.

l

SentEmail (String). Event handler to add custom code to the sent email event.

CaptureOrderActivity
Initiate the capture of an order in Ektron. When the Workflow reaches this activity, the
process of submitting encrypted order information (including the transaction ID) to a
payment gateway account happens. At this time, the account is changed for the order
amount.
Use this activity when you want the capture to take place automatically in the
Workflow. This activity is the same as an Ektron user going to the Workarea and
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marking an order as Captured. For information on how a Capture works in the
Workarea, see Capturing orders on page 1858.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

Handlers
l

MethodInvoking. Select a method to call before the order is captured.

Misc
l

Select OrderId to dynamically associate this activity with orders in Ektron. Click
Browse (

) and select OrderId from the list.

CheckStockActivity
Verify the quantity of items ordered is available for shipping. When the workflow
reaches this activity, the quantity of each product in the order is checked. If the
required quantity exists for each item, the activity returns True. Otherwise, the activity
returns False.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

Handlers
l

MethodInvoking. Select a method to call before the stock level is checked.

Misc
l

orderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

l

) and select OrderId from the list.

ReturnValue (Boolean)
o True. the quantity of each product ordered is in stock.
o

False (default). there is not enough product in stock to fulfill the order.

OrderCancelledEventActivity
Block the workflow from going down a cancel path until the order actually has been
canceled.
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This activity does not cancel the order. It waits for a user, API code or
UpdateOrderActivity to mark the order canceled in Ektron before it continues down
the order cancel path. Think of it as gate that’s waiting for a certain event to happen
before it can continue. When the event happens, the path is opened in the workflow.
For information on how to cancel an order in the Workarea, see Canceling an order on
page 1859.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order is canceled.

Misc
l

Select OrderId to dynamically associate this activity with orders in Ektron. Click
Browse (

) and select OrderId from the list.

OrderCapturedEventActivity
Block the workflow from continuing down a path until the order actually has been
captured.
This activity does not capture the order. It waits for a user or API code to mark the
order as captured in Ektron before it continues down the path. Think of it as gate that’s
waiting for a certain event to happen before it can continue. When the event happens,
the path is opened in the workflow. For information on how an order is captured in the
Workarea, see Capturing orders on page 1858.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order has been captured.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (
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OrderFraudEventActivity
Block the workflow from going down a path that handles fraudulent orders until the
order actually has been marked as fraud.
This activity does not mark the order as fraudulent. It waits for a user, API code or the
UpdateOrderActivity to mark the order as fraud in Ektron before it continues down
the path. Think of it as gate that’s waiting for a certain event to happen before it can
continue. When the event happens, the path is opened in the workflow. For information
on how to mark an order as fraud in the Workarea, see Marking the order as fraudulent
on page 1861.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order has been marked as
fraud.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

) and select OrderId from the list.

OrderProcessedEventActivity
Block the workflow from going down an order process path until the order actually has
been processed. This is a generic event activity that lets you specify custom code to
somehow process the order.
This activity does not start the process. It waits for a user, API code or the
UpdateOrderActivity to kick off the Process Order action in Ektron before it continues
down the path. Think of it as gate that’s waiting for a certain event to happen before it
can continue. When the event happens, the path is opened in the workflow. For
information on how to cancel an order in the Workarea, see Canceling an order on
page 1859.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.
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l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order has been processed.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

) and select OrderId from the list.

OrderReceivedEventActivity
Usually the first item in an order workflow, this activity does not mark the order as
received, but instead waits for Ektron to register a new order. When the order is
received, this activity allows the workflow to start. Think of it as gate that’s waiting for a
certain event to happen before it can continue. When the event happens, the path is
opened in the workflow.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order has been received.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

) and select OrderId from the list.

OrderShippedEventActivity
Block the workflow from going down a shipped order path until the order actually has
been shipped.
This activity does not mark the order as shipped. It waits for a user, API code or
UpdateOrderActivity to mark the order as shipped in Ektron before it continues down
the path. Think of it as gate that’s waiting for a certain event to happen before it can
continue. When the event happens, the path is opened in the workflow. For information
on how to mark an order as shipped in the Workarea, see Marking the order as shipped
on page 1861.
Activity
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l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order is shipped.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

) and select OrderId. from the list.

OrderUpdatedEventActivity
Block the workflow from going down an updating order path until the order actually has
been updated.
This activity does not update the order as shipped. It waits for a user, API code or
UpdateOrderActivity to update an order inEktron before it continues down the path.
Think of it as gate that’s waiting for a certain event to happen before it can continue.
When the event happens, the path is opened in the workflow.
Activity
l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

l

Roles.

Handlers
l

Invoked (String). Specify code that executes when the order has been updated.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

) and select OrderId. from the list.

UpdateOrderActivity
Automate updating of an order’s status. This activity is the same as an Ektron user
going to the Workarea and performing any of the above actions on an order. For
information on how to manually complete these tasks in the Workarea, see Managing
customer orders on page 1850.
Activity
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l

Name (String). Enter a name for the Activity.

l

Description (String). Enter a description for the Activity.

l

Enabled (Boolean). True (default), enable the activity; False, disable.

Handlers
l

MethodInvoking. Select a method to call before the stock level is checked.

Misc
l

OrderId. Select OrderId to dynamically associate this activity with orders in
Ektron. Click Browse (

l

) and select OrderId. from the list.

orderStatus
o Received (default). marks an order as received
o

InProcess. marks the order as in process

o

Shipped. marks the order as shipped

o

Completed. marks the order as completed

o

Canceled. marks the order as canceled

o

OnHold. puts the order on hold

o

Fraud. marks the order as fraud

Customizing the Payment Gateway Provider
A Payment Gateway Provider is a pluggable component that is integrated into Ektron's
eCommerce module. A Payment provider handles eCommerce customer payments by
utilizing third party payment gateways. Ektron’s eCommerce module accepts payments
such as credit cards. Then, it passes that information to a third party service. The third
party service processes the payment, and returns a transaction ID that’s stored with
the customer's order.
NOTE: Your company needs to set up an account with a third party payment service
before utilizing the payment provider. This includes payment providers such as
Authorize.NET and PayFlow, which are included with Ektron’s eCommerce Module.
Ektron comes with several payment providers, including Authorize.NET and PayFlow.
You can customize these providers or create your own using the extendable Payment
Gateway Provider architecture.
Each type of payment gateway provider accepts configuration parameters. For
example, Authorize.NET requires a username and password while PayFlow requires a
username, password, vendor, and partner.
In addition, some payment gateways may support recurring payments, while others
may not. Recurring payments provide the ability to create a payment that recurs at a
given interval for a specified period of time. For example, you could create a payment
for $9.99 that occurs on the first of every month for the next 12 months. This is
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something to consider if your site relies on a subscription service. Contact your provider
to find out if they support recurring payments.
The following scenario shows the flow of payment information for a customer
purchasing a product from your site through you receiving the money in your account.
1. A customer purchases a product from your site and submits payment information.
2. Ektron passes the information to your payment gateway.
3. Your payment gateway provider passes the information to your bank’s processor.
4. The bank’s processor submits the information to a credit card interchange for
processing, clearing and settlement.
5. The interchange notifies the customer’s credit card company of the transactions
details.
6. The credit card company accepts or declines the transaction based on the
customers account information.
7. If the transaction is approved, the funds are transferred to the interchange.
8. The credit card interchange sends information about whether the transaction is
approved to your bank’s processor.
9. This information is passed to your payment gateway provider.
10. The provider notifies your site of the information. The results of the transaction are
displayed on the page the customer is viewing.
11. The credit card interchange sends funds to your merchant account.
This section explains how to extend Ektron’s Payment Gateway Provider Architecture to
build your own customized Payment Gateway Provider.
See also: Configuring payment options on page 1770.
The following figure shows the Object Model for Ektron’s Payment Gateway Provider.
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The PaymentGatewayProvider is the abstract base class you must extend to implement
your own payment gateway. Details and descriptions of the PaymentGatewayProvider
API can be found in the Ektron API Reference Manual’s Providers API >
PaymentGatewayProvider section.

Creating a Custom Payment Gateway Provider
In addition to the out-of-the-box payment gateways providers shipped with Ektron, you
can create your own custom payment providers that connect with any payment
gateway you choose. When you create a custom gateway provider, you need the
following basic code steps to complete. Additional code examples used by Ektron to
create the PayFlow and Authorize.NET providers are located in: C:\Program Files
(x86)\Ektron\CMS400SDK\Commerce\Providers\Commerce.Providers\PaymentGate
ways
The complete C# code sample used in this example is available at the end of this
section. See CustomGatewayProvider code example on page 1900.
1. Create a class library project in Visual Studio.
2. Add references to these DLLs:
l Ektron.Cms.Commerce
l

1896

Ektron.Cms.Common

Ektron 9.40 SP1

Creating a Custom Payment Gateway Provider

l

Ektron.Cms.ObjectFactory

l

Ektron.Cms.Instrumentation

l

System.Configuration

l

Add these using statements to the code-behind:
using
using
using
using
using
using

System;
System.Collection;
System.Collection.Specialized;
Ektron.Cms;
Ektron.Cms.Common;
Ektron.Cms.Commerce;

3. Change the namespace to:
namespace Ektron.Cms.Extensibility.Commerce.Samples

4. Rename your class and inherit:
public class CustomPaymentProvider:
Ektron.Cms.Commerce.PaymentGatewayProvider.PaymentGatewayProvider

5. Add the following constructor.
#region constructor, member variables
public CustomPaymentProvider() { }
#endregion

6. Add the methods required by the PaymentGatewayProvider base class. The
Initialize method reads configuration information, the others are related to the
payments and will be completed later in the example.
public override void
Initialize(string name,
System.Collections.Specialized.NameValueCollection config)
{ if (config == null)
{ throw new ArgumentNullException("config");
// Assign the provider a default name if it does not have one
if (String.IsNullOrEmpty(name)) name = "CustomPaymentProvider";
if (string.IsNullOrEmpty(config["description"]))
{ config.Remove("description");
config.Add("description", "CustomPaymentProvider");
}
// Call the base class's Initialize method
base.Initialize(name, config);
// Throw an exception if unrecognized attributes remain
if (config.Count > 0)
{ foreach (string key in config.AllKeys)
{ EkException.WriteToEventLog("Unrecognized Payment Gateway
Provider attribute: " + key,
System.Diagnostics.EventLogEntryType.Warning);
}
}
}
}
public override string Authorize()
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{
}
public override string AuthorizeAndCapture()
{
}
public override string CapturePreauthorization(string transactionId)
{
}
public override string VoidPreAuthorization(string transactionId)
{
}

7. Implement the Authorize method that you added in the previous step. This
method is called to authorize a given amount of money when an order is submitted.
public override string Authorize()
{ if (PaymentMethod.GetType() != typeof(CreditCardPayment))
throw new Ektron.Cms.Commerce.Exceptions
.AuthorizationException("Invalid Payment Type");
CreditCardPayment creditCard = (CreditCardPayment)this.PaymentMethod;
if (creditCard.ExpirationDate.IsExpired())
throw new Ektron.Cms.Commerce.Exceptions.Payment.CreditCard
.CardExpiredException("Card Is Expired");
IsSubmissionSuccess = true;
Authorization.AuthorizedOn = DateTime.Now;
Authorization.TransactionId = new Guid().ToString();
return Authorization.TransactionId;
}

In this example, the card number and card holder name are not checked. In a real
world scenario, there would be additional validation (for example, via checksum)
and the authorization may be obtained via Web services or HTTP post.
NOTE: If the authorization fails, you can choose to either throw an exception or
manually set the failure. For example:
SubmissionError = "Not enough Funds";IsSubmissionSuccess = false;
8. Implement the AuthorizeAndCapture, CapturePreauthorization and
VoidPreAuthorization methods you added earlier.
9. AuthorizeAndCapture requires that Authorization.CapturedOn be set, as the
capture occurs at the same time as the Authorization.
10. For CapturePreauthorization and VoidPreAuthorization, set the appropriate
dates for these actions, so they are recorded in the system properly.
public override string AuthorizeAndCapture()
{ IsSubmissionSuccess = true;
Authorization.AuthorizedOn = DateTime.Now;
Authorization.CapturedOn = DateTime.Now;
Authorization.TransactionId = new Guid().ToString();
return Authorization.TransactionId;
}
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public override string CapturePreauthorization(string transactionId)
{ IsSubmissionSuccess = true;
Authorization.CapturedOn = DateTime.Now;
return Authorization.TransactionId;
}
public override string VoidPreAuthorization(string transactionId)
{ IsSubmissionSuccess = true;
Authorization.VoidedOn = DateTime.Now;
return Authorization.TransactionId;
}

11. Save and build the project.
12. Copy your project’s DLL file to your Ektron website’s bin directory.
13. Register the provider in your site’s web.config file. The web.config file provides
the facility to manage payment gateway providers within Ektron.
14. To do this, locate the EktronPaymentGateway section and change the
defaultProvider parameter to the name of your custom provider. Note that
changing this from “Automatic” to the name of your provider overrides the settings
in Workarea > Settings > Commerce > Configuration > Payment
Gateways. Ektronnow will use the new provider.
15. If you start your search from the top of the file, it is the second instance.
<EktronPaymentGateway defaultProvider="CustomPaymentProvider">

16. Add your custom payment provider between the EktronPaymentGateway’s
<providers> tags. Note that the name defined here must match the
defaultProvider from the previous step.
<providers>
<add name="CustomPaymentProvider"
type="Ektron.Cms.Extensibility.Commerce.Samples.CustomPaymentProvider,
CustomPaymentProvider" />
</providers>

17. Save the web.config file.
18. Next, add the payment gateway to the Workarea.
a. Go to Workarea > Commerce > Configuration > Payment Options.
b. Select New > Payment Gateway.
c. In the Name drop-down, select customerPaymentProvider.
d. Check both Cards and Checks checkboxes.
e. Save these changes. Your custom payment provider is now the default
provider. Whenever a payment provider needs to be contacted, the
information routes through the new custom provider.

Displaying a custom provider an option in the Workarea
In the example above, you changed the web.config file’s EktronPaymentGateway
defaultProvider parameter to the name of your custom payment provider. This
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overrides the payment provider settings in the Workarea. To manage all payment
providers from the Workarea > Settings > Commerce > Configuration >
Payment Gateways screen:
1. In the web.config file, locate the EktronPaymentGateway section and make
sure the defaultProvider parameter is set to Automatic.
<EktronPaymentGateway defaultProvider="Automatic">

2. Save the web.config file.
3. Go to the Workarea > Settings > Commerce >Configuration > Payment
Gateways screen.
4. Choose New > Payment Gateway.
5. From the Name drop-down list, select the name of the your new custom gateway.
6. Check the Default box if you want this to be the default payment gateway. The
default payment gateway is the gateway all payment information is routed
through.
7. Enter the User ID for this payment gateway. This ID will identify your account with
this gateway provider.
8. Enter the password for your account with this gateway provider.
9. If this gateway provider expects additional parameters when contacting it, click the
Expand Custom Values link and enter those values into the Custom 1 and
Custom 2 fields.
10. Click Save. The custom gateway provider has been added and can now be
managed from the Workarea.

CustomGatewayProvider code example
WARNING! Copying, pasting, and using the following code without modification to
create a DLL will not result in a working custom payment provider. This code is
provided as an outline of what is needed to create an actual custom payment
provider.
using System;
using System.Collections;
using System.Collections.Specialized;
using System.Configuration.Provider;
using Ektron.Cms;
using Ektron.Cms.Common;
using Ektron.Cms.Commerce;
namespace Ektron.Cms.Extensibility.Commerce.Samples
{
public class CustomPaymentProvider :
Ektron.Cms.Commerce.PaymentGatewayProvider
{
public CustomPaymentProvider() { }
public override void Initialize(string name,
System.Collections.Specialized.NameValueCollection config)
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{
if (config == null throw new ArgumentNullException(;
// Assign the provider a default name if it does not have one
if (String.IsNullOrEmpty(name))
name = CustomPaymentProvider"
if string.IsNullOrEmpty(config(["description"]))
{
config.Remove("description");
config.Add("description", "CustomPaymentProvider";
}
// Call the base class's Initialize method
base.Initialize(name, config);
// Throw an exception if unrecognized
attributes remain
if (config.Count > 0)
{
foreach (string key in config.AllKeys)
{
EkException.WriteToEventLog("Unrecognized
Payment Gateway Provider attribute:
" + key,
System.Diagnostics.EventLogEntryType.Warning);
}
}
}
public override string Authorize()
{
if (PaymentMethod.GetType() != typeof(CreditCardPayment))
throw new Ektron.Cms.Commerce.Exceptions.
AuthorizationException("Invalid Payment Type");
CreditCardPayment creditCard = (CreditCardPayment)
this.PaymentMethod;
if (creditCard.ExpirationDate.IsExpired())
throw new Ektron.Cms.Commerce.Exceptions.Payment.CreditCard.
CardExpiredException( "Card Is Expired";
IsSubmissionSuccess = true;
Authorization.AuthorizedOn = DateTime.Now;
Authorization.TransactionId = new Guid().ToString();
return Authorization.TransactionId;
}
public override string AuthorizeAndCapture()
{
IsSubmissionSuccess = true;
Authorization.AuthorizedOn = DateTime.Now;
Authorization.CapturedOn = DateTime.Now;
Authorization.TransactionId = new Guid().ToString();
return Authorization.TransactionId;
}
public override
string CapturePreauthorization(string transactionId)
{
IsSubmissionSuccess = true;
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Authorization.CapturedOn = DateTime.Now;
return Authorization.TransactionId;
}
public override string VoidPreAuthorization(string transactionId)
{
IsSubmissionSuccess = true;
Authorization.VoidedOn = DateTime.Now;
return Authorization.TransactionId;
}
}
}

Customizing the shipment provider
A Shipment Provider is a pluggable component integrated into Ektron's eCommerce
module. The Shipping provider handles eCommerce real-time shipping rate retrieval by
utilizing third party shipping services such as FedEx or UPS, or you can create your own
fixed rate logic. Ektron's eCommerce shipping module calculates the package(s)
needed for an order and then passes the following information to the company
providing the shipping services via a Shipping Provider.
l

package information. For example, how many, height, width, depth and weight
of each package.

l

warehouse address. The address from which the items will be shipped. A
warehouse’s information can be set in the Workarea > Settings > Commerce >
Shipping > Warehouses screen.

l

destination address. The shipping address a customer entered when making the
purchase.

l

desired shipping options. For example, if you have Next Day, 2-Day Ground and
3-Day Ground as shipping options, you can pass the option chosen by the
customer.

Ektron comes with several shipping providers, including FedEx and UPS. You can
customize these providers or create your own using the extendable Shipping Provider
architecture.
Your company will need to set up or have an existing account with a third party shipping
service before utilizing the shipping provider. This includes shipping providers such as,
FedEx or UPS, which are included with Ektron's eCommerce Module.
Each type of shipping provider accepts configuration parameters. For example, FedEx
requires a username, password, account number, and meter number while UPS
requires a Username, password, and account number. These configuration parameters
along with the provider definitions are stored in the SiteRoot/shipment.config file.
The following example shows a provider definition for FedEx.
<add name="FedExShipmentProvider"
type="Ektron.Cms.Commerce.Providers.Shipment.FedExShipmentProvider,
Ektron.Cms.Commerce.Providers"
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serviceUrl="https://gatewaybeta.fedex.com/web-services"
key="" password=""
accountNumber=""
meterNumber=""
transactionId="Ektron FedEx v3"

The following steps show the flow of shipping calculations for a customer purchasing a
product from your site.
1. A customer adds 2 books to the cart and clicks checkout.
2. The shipping calculator looks for the smallest possible package that will fit the
items.
3. The shipping calculator calls the registered shipping provider for each package in
the order.
4. The shipping calculator combines all the rates received if more than one package is
being shipped and returns the shipping method rates to the checkout control.
5. The customer selects the desired shipping method and it is saved with the cart.
NOTE: Many Ektron settings affect your shipping calculations. A default warehouse
must be defined with a valid shipping address. Shipping methods you would like to
offer customers must be defined. For example, the FedEx provider supports over 10
possible shipping methods, but you may only be concerned with Priority, 2 Day, and
Ground. This must be defined in Ektron. You can also define the shipping packages
your business uses. The Shipping calculator will try and fit the order items into any
packages defined in Ektron. If no packages are defined, the item's dimensions are
passed to the provider instead.
The following figure shows the Object Model for Ektron’s Shipment Provider.

The ShipmentProvider is the abstract base class you must extend to implement your
own Shipping Provider. Details and descriptions of the ShipmentProvider API can be
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found in the Ektron API Reference Manual’s Providers API > Shipment > Provider
> ShipmentProvider.

Creating a custom shipment provider
In addition to the out-of-the-box shipment providers that come with Ektron, you can
create a custom provider that connects with any shipping company you choose. When
you create a custom shipping provider, you need the following basic code steps.
Additional code examples used by Ektron to create FedEx, Flat Rate and UPS shipment
providers are located in:
C:\Program Files(x86)\Ektron\CMS400SDK\Commerce\Providers\Commerce.Providers\Shipping

The complete C# code sample used in this example is available at the end of this
section. See CustomShipmentProvider code example on page 1907.
1. Create a class library project in Visual Studio.
2. Add references to these DLLs:
Ektron.Cms.Commerce
Ektron.Cms.Common
Ektron.Cms.ObjectFactory
Ektron.Cms.Instrumentation
Ektron.Cms.Contracts
System.Configuration

3. Add these using statements to the code-behind:
using System.Configuration.
using Ektron.Cms.Commerce.Shipment.Provider;
using Ektron.Cms.Commerce using Ektron.Cms.Instrumentation

4. Change the namespace to:
namespace Ektron.Cms.Extensibility.Commerce.Samples
{

5. Rename your class and inherit:
public class CustomShipmentProvider : ShipmentPovider
{

6. Add the following constructor private variables and properties. The items added to
the shippingOptionList are the shipping methods exposed as a service type in
the management screen inside the Workarea.
#region constructor, member variables
public CustomShipmentProvider()
{ IsTrackingSupported = false;
_shippingOptionList = new List<string>();
_shippingOptionList.Add("CustomOption_1");
_shippingOptionList.Add("CustomOption_2");
}
private List<string> _shippingOptionList;
#endregion
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7. Add the following methods required by the ShipmentProvider base class.
l Initialize. reads configuration information
l

GetServiceTypes. returns a List <string> of the shipping options available

l

GetTrackingUrl. exposes tracking support

l

GetRates. returns a list of shipping rates for the items being shipped. The
contents of this method will be added in the next step.

#region ShipmentProvider Implementation
public override void
Initialize(string name,
System.Collections.Specialized.NameValueCollection config)
{ if (config == null)
{ throw new ArgumentNullException("config");
// Assign the provider a default name if it does not have one
if (string.IsNullOrEmpty(name)) name = "CustomShipmentProvider";
if (string.IsNullOrEmpty(config["description"]))
{ config.Remove("description"); config.Add("description",
"CustomShipmentProvider Provider"); }
// Call the base class's Initialize method
base.Initialize(name, config);
// Throw an exception if unrecognized attributes remain
if (config.Count == 0) throw new
ProviderException("Shipment provider attribute missing.");
else {
//read all config attributes.
ServiceUrl = config["serviceUrl"];
Key = config["key"];
Password = config["password"];
AccountNumber = config["accountNumber"];
MeterNumber = config["meterNumber"];
TransactionId = config["transactionId"];
}
}
public override List<string> GetServiceTypes()
{ return _shippingOptionList;
}
public override string GetTrackingUrl(string trackingId)
{ return "";
}
public override List
<ShippingOptionData>GetRates(IEnumerable
<ShippingMethodData>
expectedOptions, AddressData origin, AddressData destination,
Weight weight, Dimensions dimensions)
{
}
#endregion

8. Implement the GetRates method. Add this code to public override for GetRates
which was added during the previous step. (This example uses flat rates for your
shipping methods. In a real world scenario, the shipping methods and their
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corresponding rates can be obtained via FedEx, UPS, a third party application or
Web services.) When complete, the code should look like this.
public override List <ShippingOptionData>
GetRates(IEnumerable<ShippingMethodData>
expectedOptions, AddressData origin, AddressData destination,
Weight weight, Dimensions dimensions)
{ List <ShippingOptionData> availableOptions =
new List <ShippingOptionData>();
try
{ foreach (ShippingMethodData expectedOption in expectedOptions)
{ Log.WriteInfo("Custom Shipping Provider.ExpectedOption:" +
expectedOption.Name);
switch (expectedOption.ProviderService.ToLower())
{ case "customoption_1": ShippingOptionData customOption1 =
new ShippingOptionData();
customOption1.Id = expectedOption.Id;
customOption1.Name = expectedOption.Name;
customOption1.ShippingFee = 25.00M;
customOption1.ProviderService = "CustomOption_1";
availableOptions.Add(customOption1);
break;
case "customoption_2":
ShippingOptionData customOption2 = new ShippingOptionData();
customOption2.Id = expectedOption.Id;
customOption2.Name = expectedOption.Name;
customOption2.ShippingFee = 50.00M;
customOption2.ProviderService = "CustomOption_2";
availableOptions.Add(customOption2);
break;
}
}
}
catch (Exception e)
{ Log.WriteError("Custom Shipping Provider: Error retrieving shipping
rates." + e.Message); throw;
}
return availableOptions;
}

9. You can use the GetRates method to restrict countries to which you ship. For
example, if you want to prevent shipping to all countries except Canada, add these
lines of code to the GetRates method.
if (destination.Country.Id != 124)
throw new Ektron.Cms.Commerce.Exceptions.Shipping.InvalidAddressException
("We ship only to Canada.");

10. Save and build the project.
11. Copy your project’s DLL file to your Ektron website’s bin directory.
12. Register the provider in your site’s shipment.config file. This file provides the
facility to manage shipping providers within Ektron. Locate the shipmentProvider
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section and change the defaultProvider parameter to the name of your custom
provider.
<shipmentProvider defaultProvider="CustomShipmentProvider">

13. Add your custom shipping provider between the shipmentProvider’s <providers>
tags. Note that the name defined here needs to match the name defined as the
defaultProvider in the previous step.
<providers>
<add name="CustomShipmentProvider"
type="Ektron.Cms.Extensibility.Commerce.Samples.CustomShipmentProvider,
CustomShipmentProvider" serviceUrl="" key="" password=""
accountNumber="" meterNumber=""
transactionId="CustomShipmentProvider based transaction" />
</providers>

14. Save the web.config file.
15. Your custom shipping provider is now the default provider. Whenever you need to
obtain shipping rate information, the information routes through the new custom
provider.
16. Add the shipping methods that are available for your provider in the Workarea >
Settings > Commerce -> Shipping > Methods screen.
a. Select New > Shipping Method.
b. Enter a name. This is what a customer sees during the checkout process. An
example is “Ground” or “Next Day”. For this example, use “Custom1”.
c. Check the Active checkbox.
d. Click View Options and select CustomOption_1 from the list.
e. Click Save).
f. Repeat this process for the CustomOption2 shipping method type.
The options are now available in the checkout process, and are shown on the shipping
method selection screen.

CustomShipmentProvider code example
WARNING! Copying, pasting, and using the following code without modification to
create a DLL does not result in a working “real time” shipping provider. This example
uses fixed rates and should be modified to meet your needs.
The following code example is used in Creating a custom shipment provider on
page 1904.
using System.Configuration.Provider;
using Ektron.Cms.Commerce.Shipment.Provider;
using Ektron.Cms.Commerce;
using Ektron.Cms.Instrumentation;
namespace Ektron.Cms.Extensibility.Commerce.Samples
{
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public class CustomShipmentProvider : ShipmentProvider
{
#region constructor, member variables
public CustomShipmentProvider()
{
IsTrackingSupported = false;
_shippingOptionList = new List<string>();
_shippingOptionList.Add("CustomOption_1");
_shippingOptionList.Add("CustomOption_2");
}
private List<string> _shippingOptionList;
#endregion
#region ShipmentProvider Implementation
public override void Initialize(string name,
System.Collections.Specialized.NameValueCollection config)
{
if (config == null)
throw new ArgumentNullException("config");
// Assign the provider a default name if it does not have one
if (string.IsNullOrEmpty(name))
name = "CustomShipmentProvider";
if (string.IsNullOrEmpty(config["description"]))
{
config.Remove("description");
config.Add("description", "CustomShipmentProvider Provider");
}
// Call the base class's Initialize method
base.Initialize(name, config);
// Throw an exception if unrecognized attributes remain
if (config.Count == 0)
throw new ProviderException("Shipment provider attribute missing.");
else
{
//read all config attributes.
ServiceUrl = config["serviceUrl"];
Key = config["key"];
Password = config["password"];
AccountNumber = config["accountNumber"];
MeterNumber = config["meterNumber"];
TransactionId = config["transactionId"];
}
}
public override List<string> GetServiceTypes()
{
return _shippingOptionList;
}
public override string GetTrackingUrl(string trackingId)
{
return "";
}
public override List<ShippingOptionData>
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GetRates(IEnumerable<ShippingMethodData>
expectedOptions, AddressData origin, AddressData destination,
Weight weight, Dimensions dimensions)
{
List<ShippingOptionData> availableOptions = new List<ShippingOptionData>();
try
{
foreach (ShippingMethodData expectedOption in expectedOptions)
{
Log.WriteInfo("Custom Shipping Provider.ExpectedOption:"
+ expectedOption.Name);
switch (expectedOption.ProviderService.ToLower())
{
case "customoption_1":
ShippingOptionData customOption1 = new ShippingOptionData();
customOption1.Id = expectedOption.Id;
customOption1.Name = expectedOption.Name;
customOption1.ShippingFee = 25.00M;
customOption1.ProviderService = "CustomOption_1";
availableOptions.Add(customOption1);
break;
case "customoption_2":
ShippingOptionData customOption2 = new ShippingOptionData();
customOption2.Id = expectedOption.Id;
customOption2.Name = expectedOption.Name;
customOption2.ShippingFee = 50.00M;
customOption2.ProviderService = "CustomOption_2";
availableOptions.Add(customOption2);
break;
}
}
}
catch (Exception e)
{
Log.WriteError("Custom Shipping Provider:
Error retrieving shipping rates." + e.Message);
throw;
}
return availableOptions;
}
#endregion
}
}

Customizing the inventory provider
An Inventory Provider is a pluggable component that’s integrated into Ektron's
eCommerce module. An Inventory Provider handles the retrieving and updating of
inventory information for products within Ektron. Out of the Box, Ektron comes with a
default Ektron Inventory Provider that tracks inventory within its database.
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If your business has an Accounting or Enterprise Resource Management solution that
manages inventory, you can create a custom Inventory Provider that retrieves and
updates inventory information directly from that system. Inventory data can be stored
in any number of locations, including databases, ERP or CRM systems, or even XML
files.
The following figure shows the Object Model for Ektron’s Inventory Provider.

The InventoryProvider is the abstract base class you must extend to implement your
own Inventory Provider. Details and descriptions of the InventoryProvider API can be
found in the Ektron API Reference Manual’s Providers API > Inventory > Provider
> InventoryProvider.

Creating a custom inventory provider
In addition to the out-of-the-box inventory provider that comes with Ektron, you can
create your own custom provider that connects with an existing inventory system.
When you create a custom inventory provider, you need the following basic code steps.
A code example for the inventory provider used by Ektron is located in:
C:\Program Files(x86)\Ektron\CMS400SDK\Commerce\Providers\Commerce.Providers\Inventory

The complete C# code sample used in this example is available at the end of this
section. See CustomInventoryProvider code example on page 1912.
1. Create a class library project in Visual Studio.
2. Add references to these DLLs:
l Ektron.Cms.Commerce

1910

l

Ektron.Cms.Common

l

Ektron.Cms.ObjectFactory

l

System.Configuration

Ektron 9.40 SP1

Creating a custom inventory provider

3. Add these using statements to the code-behind.
using
using
using
using
using

Ektron.Cms.Commerce.Inventory.Provider;
Ektron.Cms.Commerce.Data;
Ektron.Cms.Commerce; using Ektron.Cms.Common;
Ektron.Cms.Extensibility;
Ektron.Cms.Extensibility.Commerce;

4. Change the namespace to:
Ektron.Cms.Extensibility.Commerce.Samples {

5. Rename your class and inherit:
CustomInventoryProvider InventoryPovider

6. Add the following constructor, private variables and properties.
Public CustomInventoryProvider() { } private CmsInventory _inventory;
protected CmsInventory Inventory
{ get
{ if (_inventory == null)
{ _inventory = CmsInventory(RequestInformation);
} return_inventory;
}
}

7. Override the following methods. These methods area called when the inventory
system is queried.
l GetInventory. returns an InventoryData data class for a given product id.
l

SaveInventory. persists updates to the stock levels inside the inventory
system.
In this example, we trigger Ektron extensibility events, such as
OnBeforeInventorySave() and OnAfterInventorySave(). In a real world
scenario, your existing inventory system may have its own inventory events
that are used.

public override InventoryData GetInventory (long entryId)
{ return Inventory.GetInventory(entryId); }
public override void SaveInventory(InventoryData inventory)
{ OnBeforeInventorySave(inventory);
Inventory.SaveInventory(inventory);
OnAfterInventorySave(inventory);
if (inventory.UnitsInStock < inventory.ReorderLevel)
{ OnInventoryReorderLevelReached(inventory); }
}

8. Save and build the project.
9. Copy your project’s DLL file to your Ektron website’s bin directory.
10. Register the provider in your site’s web.config file. The web.config file provides
the facility to manage inventory providers within Ektron. Locate the
InventoryProvider section and change the defaultProvider parameter to the
name of your custom provider. If you start your search from the top of the file, it
will be the second instance.
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<inventoryProvider defaultProvider="CustomInventoryProvider">

11. Add your custom payment provider between the EktronPaymentGateway’s
<providers> tags. Note that the name defined here needs to match the name
defined as the defaultProvider in the previous step.
<providers>
<add name="CustomInventoryProvider"
type="Ektron.Cms.Extensibility.Commerce.Samples.CustomInventoryProvider,
CustomInventoryProvider"/>
</providers>

12. Save the web.config file.
Your custom inventory provider is now the default provider. Whenever the inventory is
queried, the call routes through the new custom provider.

CustomInventoryProvider code example
WARNING! Copying, pasting, and using the following code without modification to
create a DLL does not result in a working “real time” shipping provider. This example
uses fixed rates and should be modified to meet your needs.
The following code example is used in Creating a custom inventory provider on
page 1910.
using Ektron.Cms.Commerce.Inventory.Provider;
using Ektron.Cms.Commerce.Data;
using Ektron.Cms.Commerce;
using Ektron.Cms.Common;
using Ektron.Cms.Extensibility;
using Ektron.Cms.Extensibility.Commerce;
namespace Ektron.Cms.Extensibility.Commerce.Samples
{
public class CustomInventoryProvider : InventoryProvider
{
public CustomInventoryProvider() { }private CmsInventory _inventory;
protected CmsInventory Inventory
{
get
{
if (_inventory == null)
{
_inventory = new CmsInventory(RequestInformation);
}
return _inventory;
}
}
public override InventoryData GetInventory(long entryId)
{
return Inventory.GetInventory(entryId);
}
public override void SaveInventory(InventoryData inventory)
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{
OnBeforeInventorySave(inventory);
Inventory.SaveInventory(inventory);
OnAfterInventorySave(inventory);
if (inventory.UnitsInStock < inventory.ReorderLevel)
{
OnInventoryReorderLevelReached(inventory);
}
}
}
}

Customizing shipping calculations
The shipping system provides an easy and extensible way to override the shipping
calculations inside Ektron. This example sets up a custom shipping calculator to get
shipping rates with a different source location for a class of products. It has 2 major
parts.
l

Creating the calculator code below

l

Registering the event with the system on page 1917

Creating the calculator code
1. Create a class library project in Visual Studio named
Commerce.CustomShippingCalculator. You need to import the necessary Ektron
namespaces. To do this, add references to:
l Ektron.Cms.Api
l

Ektron.Cms.Commerce

l

Ektron.Cms.Common

l

Ektron.Cms.Instrumentation

l

Ektron.Cms.ObjectFactory

l

Microsoft.Practices.EnterpriseLibrary.Validation

l

System.Configuration

2. Add the following using statements.
using
using
using
using
using
using
using
using
using
using
using

System.Collections.Generic;
Microsoft.Practices.EnterpriseLibrary.Validation;
Ektron.Cms;
Ektron.Cms.Common;
Ektron.Cms.Commerce;
Ektron.Cms.Commerce.Shipment.Provider;
Ektron.Cms.Extensibility;
Ektron.Cms.Extensibility.Commerce;
Ektron.Cms.Instrumentation;
Ektron.Cms.Commerce.Exceptions;
Ektron.Cms.Commerce.Exceptions.Shipping;
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3. Change the namespace to Ektron.Cms.Extensibility.Commerce.Samples. Then,
rename your class to CustomShippingCalculator and inherit from the
ShippingCalculatorStrategy class.
namespace Ektron.Cms.Extensibility.Commerce.Samples
{ public class CustomShippingCalculator : ShippingCalculatorStrategy
{

4. Add a few helper variables, properties, and functions. The function
GetFlatPackageList "flattens" the items in the basket, returning 1 for each item
quantity. So, if we have 4 widgets, we'll have 4 packages, each with one widget.
5. The following logic fits the goods into packages, adding a function to get another
warehouse location. (It is hard-coded in this example.)
namespace Ektron.Cms.Extensibility.Commerce.Samples
{ public class CustomShippingCalculator : ShippingCalculatorStrategy
{ private EkRequestInformation _requestInfo;
private IShippingMethod _shippingService;
protected EkRequestInformation RequestInformation
{ get
{ if (_requestInfo == null)
{ _requestInfo =
ObjectFactory.GetRequestInfoProvider().GetRequestInformation();
}
return _requestInfo;
}
}
}
protected IShippingMethod ShippingService
{ get
{ if (_shippingService == null)
{ _shippingService = ObjectFactory.GetShippingMethod();
}
return _shippingService;
}
}
protected List<ShippingMethodData> GetActiveShippingMethodList()
{ Criteria<ShippingMethodProperty>
criteria = new Criteria<ShippingMethodProperty>
(ShippingMethodProperty.DisplayOrder,
EkEnumeration.OrderByDirection.Ascending);
criteria.AddFilter(ShippingMethodProperty.IsActive,
CriteriaFilterOperator.EqualTo, true);
return ShippingService.GetList(criteria);
}
protected List<ShippingPackageData>
GetFlatPackageList(List<AdjustedBasketItem> basketItems)
{ List<ShippingPackageData> flatList = new List<ShippingPackageData>();
foreach (AdjustedBasketItem item in basketItems)
{ if (item.IsTangible)
{ for (int x = 1; x <= item.Quantity; x++)
{ ShippingPackageData package =
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new ShippingPackageData(item.Dimensions, item.Weight);
package.Items.Add(item);
flatList.Add(package);
}
}
}
return flatList;
}
private AddressData GetWarehouseAddressData()
{ AddressData address = new AddressData();
address.Name = "Ektron";
address.AddressLine1 = "542 Amherst St.";
address.City = "Nashua";
address.Country = new CountryData();
address.Country.Id = 840;
// USA
address.Region = new RegionData();
address.Region.Id = 31;
// NH
address.PostalCode = "03063";
return address;
}
}

6. Override the OnBeforeCalculate method, which is called when shipping is
calculated for the basket.
public override void OnBeforeCalculate(BasketCalculatorData basketData,
ShippingMethodData shippingMethod, CancellableEventArgs eventArgs) { }

7. In this method, add code to ship items with a tax class id of 4 from another
warehouse, versus the default one specified (package.Items[0].TaxClassId ==
4 ).
public override void OnBeforeCalculate(BasketCalculatorData basketData,
ShippingMethodData shippingMethod, CancellableEventArgs eventArgs))
{ bool hasTangibles = basketData.Basket.HasTangibleItems;
List<ShippingMethodData>
availableShippingMethods = GetActiveShippingMethodList();
List<ShippingPackageData>
shippingPackages = GetOrderPackages(basketData.AdjustedItems);
//convert list of items into flat list - all 1 quantity.
List<ShippingPackageData>
shippingPackages = FlattenItemsIntoPackages(basketData.AdjustedItems);
if (shippingPackages.Count == 0)
{ Log.WriteInfo("No packages to calculate shipping for.");
return;
}
Dictionary<string, int> rateCount = new Dictionary<string, int>();
//Get Rate for each package
foreach (ShippingPackageData package in shippingPackages)
{ List<ShippingOptionData> shippingRateList;
Log.WriteVerbose(string.Format("Shipping package:
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{0} x {1} x {2} {3}, {4} {5}", package.Dimensions.Height,
package.Dimensions.Length, package.Dimensions.Width,
package.Dimensions.Units.ToString(), package.TotalItemWeight.Amount,
package.TotalItemWeight.Units.ToString()));
//Get rate for each available option and populate the
// BasketCalculatorData.ShippingRates list.
if (package.Items[0].TaxClassId == 4) shippingRateList =
ShipmentProviderManager.Provider.GetRates(availableShippingMethods,
GetWarehouseAddressData(), basketData.ShipTo, package.TotalItemWeight,
package.Dimensions);
else shippingRateList = ShipmentProviderManager.Provider.GetRates
(availableShippingMethods, basketData.ShipFrom, basketData.ShipTo,
package.TotalItemWeight, package.Dimensions);
if (shippingRateList.Count == 0)
{ EkException.ThrowException(new NoRatesAvailableException
("No shipping rates are available for the supplied item."));
}
//add rates to basket.ShippingRates
foreach (ShippingOptionData rate in shippingRateList)
{
//if there are multiple packages, we need to total up rates for each
//shipping method.
//NOTE: we can only return rates that are applicable to ALL packages.
//For example, package 1 has rates for ground, priority, freight
// package 2 has rates for ground, priority
//only return rates for ground and priority since freight will only be
//a partial quote.
//check if this shipping method has already been added.
ShippingOptionData existingMethodRate =
basketData.ShippingRates.Find(delegate(ShippingOptionData match)
{ return match.ProviderService == rate.ProviderService; });
if (existingMethodRate == null)
{ basketData.ShippingRates.Add(rate); }
else
{ existingMethodRate.ShippingFee += rate.ShippingFee; }
//need to keep count of how many times this shipping method rate is added
//to make sure we have a method rate for each package.
if(rateCount.ContainsKey(rate.ProviderService))
{ rateCount[rate.ProviderService]++; }
else
{ rateCount.Add(rate.ProviderService, 1); }
}
}
//default exchange rate
ExchangeRateData exchangeRate = new ExchangeRateData(0, 0, 1m, null);
if (basketData.ShippingRates.Count > 0
&& basketData.ShippingRates[0].CurrencyId
!= RequestInformation.CommerceSettings.CurrencyId)
{ IExchangeRate rateService = ObjectFactory.GetExchangeRate();
exchangeRate = rateService.GetCurrentExchangeRate();
if (exchangeRate == null)
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{ Log.WriteError(string.Format("No exchange rate found for
current currency {0}. Shipping rates could not be converted
to current currency.",
RequestInformation.CommerceSettings.CurrencyId));
EkException.ThrowException(new CmsException(string.Format
("No exchange rate found for current currency {0}. Shipping
rates could not be converted to current currency.",
RequestInformation.CommerceSettings.CurrencyId)));
}
}
//go through all shipping methods and remove any that do not have rates
//for packages.
for(int x = 0; x < basketData.ShippingRates.Count; x++)
{ bool removed = false;
if(rateCount[basketData.ShippingRates[x].ProviderService]
< shippingPackages.Count)
{ basketData.ShippingRates.RemoveAt(x); x--;
//need to decrement loop counter so we do not skip any as we loop through
removed = true;
}
if (!removed)
{ if (basketData.ShippingRates[x].CurrencyId
!= RequestInformation.CommerceSettings.CurrencyId)
{
//if shipping rate currency is not current currency, convert it
basketData.ShippingRates[x].ShippingFee
= exchangeRate.ConvertPrice(basketData.ShippingRates[x].ShippingFee);
}
//is this the selected shippingmethod for basket? If so, set shipping cost
//on basket
if (shippingMethod != null
&& shippingMethod.ProviderService
== basketData.ShippingRates[x].ProviderService)
{ basketData.TotalShippingCost
+= basketData.ShippingRates[x].ShippingFee;
}
}
}
if (basketData.ShippingRates.Count == 0 && hasTangibles)
{ basketData.ValidationResults.AddResult(new ValidationResult
("No shipping rates are available for the supplied item.", this,
"", "", null)); } eventArgs.IsCancelled = true;
}

8. When shipping is calculated for the basket, the above function runs first. Setting
the IsCancelled property to true on eventArgs instructs Ektron to stop further
execution of the shipping calculations. This, in effect, overrides the shipping
functionality.
9. Build the project, and copy the assembly into the Ektron site's bin directory.

Registering the event with the system
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After you create the event assembly and place it inside the bin directory, you need to
register the event. Use the objectfactory.config file to register custom events within
Ektron. To do that:
1. Open the siteroot/objectfactory.config file.
2. Find the objectStrategies section of the file.
3. Within that section, locate or add this key: name="ShippingCalculator".
4. Add a reference to the class created earlier in the <strategies> key.
<objectStrategies>
<add name=ShippingCalculator">
<strategies>
<add name="CustomShippingCalculator"
type="Ektron.Cms.Extensibility.Commerce.Samples.CustomShippingCalculator,
Commerce.CustomShippingCalculator"/>
</strategies>
</add>
</objectStrategies>
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GeoIP support lets you target your messaging to specific audiences based on current
geographical location. Ektron uses a site visitor’s IP address to detect the location. For
example, your website may have a special sale on snow blowers. That information is
relevant to people in northern climates but of no interest to those living in the tropics.
Or, a site visitor uses a cell phone to find the nearest store location, and the Ektron Map
server control displays a map of nearby stores based on the user's current latitude and
longitude.
Ektron maintains GeoIP information in a cookie only while a visitor uses the site. When
the visitor exits, Ektron deletes the cookie. Ektron obtains the following information
from the IP address of your site visitors. (The values are only examples.)
l

IP Address. 208.32.120.10

l

Country code and name. United States

l

Region. NH (New Hampshire)

l

US area code. 603

l

US metro code. 506

l

City. 506

l

US zip code. Nashua

l

Latitude and longitude. 42.7551/-71.4853

l

Organization. Sprint

l

Domain name. www.example.com

Ektron includes GeoLite data created by MaxMind. You can purchase more accurate
GeoIP databases from MaxMind.
Ektron retrieves the IP address information from a site visitor's IP address via 3
databases. The databases are installed to your site root's App_data folder and listed in
your site's web.config file.
NOTE: The tilde character (~) in the value element represents the site root folder.
l

<!-- GeoIP City Database -->
<add key="GeoIpCityDatabase" value="~/App_Data/GeoLiteCity.dat"/>
Returns the following information, based on IP address:

1920

o

Area code

o

City

o

US State

o

Country code and name

o

Latitude and Longitude

o

MetroCode
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o

PostalCode

Telephone area code
<!-- GeoIP Organization Database -->
o

l

<add key="GeoIpOrgDatabase" value="~/App_Data/GeoIPOrg.dat"/>
Returns the organization name, based on IP address.
l

<!-- GeoIP Domain Database -->
<add key="GeoIpDomainDatabase" value="~/App_Data/GeoIPDomain.dat"/>
Returns the domain name, based on IP address.

If you want to move the databases to another folder, you must update their
web.config value elements to the new location.
BEST PRACTICE
You should keep the GeoIP databases in the App_data folder, because this
folder prevents unauthorized copying of the database.

Using GeoIP information in the Targeted Content
widget
Among the Targeted Content widget's criteria is User Regional Info, which has 2
options: Country and US Regions.
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If you choose US Regions, you can select from states in the United States.
User Regional Info data uses GeoIP information. See also: Creating and using
widgets on page 1271

Using GeoIP information in the Map server control
You can center a map on a specific location by using the Map server control's latitude
and longitude properties. You also can use GeoIP information to obtain a user's
latitude and longitude, based on IP address. For example, if a site visitor searches for a
chain restaurant, the map can indicate restaurants near the user.
The following code shows how to set up the Map server control to populate latitude and
longitude with GeoIP information.
Sample .aspx page, showing the placement of the Map server control.
<cms:Map ID="uxMap" runat="server" />

Code-behind page in C#
Ektron.Cms.UserLocationData userLocationData =
Ektron.Cms.UserContext.GetCurrentUserLocationInfo();
if(userLocationData != null)
{
uxMap.Latitude = userLocationData.Latitude;
uxMap.Longitude = userLocationData.Longitude;
}

Accessing GeoIP information with the API
The following API code demonstrates the retrieval of a user's GeoIP information. Note
that Ektron.Cms.UserContext.GetCurrentUserLocationInfo() returns the
Ektron.Cms.UserLocationInfo() object, which provides access to all elements listed
in retrieving IP address informationexcept IP address.
To obtain the IP address, use Ektron.Cms.UserContext.IP.
Ektron.Cms.UserLocationData userLocationInfo =
Ektron.Cms.UserContext.GetCurrentUserLocationInfo();
//If GeoIpCity.dat/GeoIpLiteCity.dat file is present in webconfig
int AreaCode = userLocationInfo.AreaCode;
string City = userLocationInfo.City;
string CountryCode = userLocationInfo.CountryCode;
string CountryName = userLocationInfo.CountryName;
double Distance = userLocationInfo.Distance(userLocationInfo);
int DMACode = userLocationInfo.DMACode;
double Latitude = userLocationInfo.Latitude;
double Longitude = userLocationInfo.Longitude;
int MetroCode = userLocationInfo.MetroCode;
string PostalCode = userLocationInfo.PostalCode;

1922

Ektron 9.40 SP1

Accessing GeoIP information with the API

//
//
//
//

string Region = userLocationInfo.Region;
string RegionName = userLocationInfo.RegionName;
If GeoIpOrg.dat file and GeoIpCity.dat/GeoIpLiteCity.dat file
is provided in web config
string Organization = userLocationInfo.Organization;
If GeoIpDomain.dat and GeoIpCity.dat/GeoIpLiteCity.dat file
is provided in web config
string Domain = userLocationInfo.Domain;
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Ektron’s eSync keeps websites up-to-date efficiently. From single sites, global multisites, and server farms, eSync provides scalable, geo-synchronization capabilities that
let you easily update exactly what you want, when you want to update it.
Ektron’s eSync lets users update content anywhere safely by employing certificatebased authentication to secure your website, whether it is on a production server or a
development environment. Also, your updates can take place on the safe side of your
firewall before being moved to the live site. Within complex IT infrastructures, eSync
can synchronize content, assets, HTML pages and other website components, whether
they are managed by Ektron or not.
eSync efficiently makes updates and eliminates site downtime by moving only the
changes you want to move, from single pieces of content to entire sites. With its
intelligent synchronization technology, eSync securely moves selected content
bidirectionally: Web 2.0 sites have a wealth of user-generated content and membership
information which can be synchronized back to the development side of the firewall. To
track changes to Ektron data between syncs, eSync creates a c:\sync folder structure
that mirrors your site’s Windows folder structure. This structure is created on each
server when sync relationships are first established. No Ektron files reside in the \sync
folders. Instead, each folder has four .sync files that monitor changes to Ektron files in
the corresponding folder.
eSync manages content dependencies, that is references to other files such as images.
eSync automatically handles the synchronizing of dependencies, so you do not need to
worry about these extra files. Adjusting relationship settings on page 1992 explains
how to sync content dependencies.
You can synchronize at any time with single or multiple servers; strategic times that
assure optimal performance, while facilitating site updates; low-traffic times to
coordinate global multi-site setups. You also can schedule time-sensitive events.
If conflicting versions of content exist, eSync’s configurable conflict resolution engine
preserves your most recent content. The version that isn’t posted is saved in a history
log (along with other previous versions), letting you track changes or restore if
necessary.
If you have multiple development servers, eSync can create a copy of the live site to
work with. As your developers change the site, their updates can by synchronized to the
staging and production servers. eSync also can support advanced infrastructures,
including load balancing and failover server configurations.
Every server in a sync relationship is assigned a unique number. The originating server
is 1, the first server with which it establishes a relationship is 2, and so on. The server
number is stored in the c:\sync\serverinfoXX.xml file.
<SyncServerInfoList>
<SyncServerInfo IsSyncRunning="false" Migrated="false" MaxId="2" ServerNumber="1" ...

All Ektron data is assigned a unique ID number to distinguish it from similar objects.
Examples are content (see illustration), folders, menus, users, and so on.
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When you create a sync relationship, Ektron applies a new ID numbering range to each
server to ensure that, from then on, objects created on either server have a unique ID.
This prevents collisions when synchronizing between servers. For example, since
membership users created on a production server have a different ID number range
from those created on the staging server, eSync does not overwrite them.
To view a server’s ID number range, open its C:\sync\serverinfoXX.xml file, and
check the MaxId value as shown in the following example.
<SyncServerInfoList>
<SyncServerInfo IsSyncRunning="true" MaxId="3" ServerNumber="1"....

Multiply that number by 1 trillion to get the largest ID number which that server can
assign. For example, if MaxId = 3, ID numbers range from 2,000,000,000,001 to
3,000,000,000,000.

Setting up eSync
This section explains several scenarios for installing and setting up eSync.
l

Scenario 1: Synchronizing 2 sites on the same server on page 1933

l

Scenario 2: Synchronizing a local server with a remote server on page 1936

l

Scenario 3: Setting up a development > staging > production environment on
page 1947

PREREQUISITES FOR USING ESYNC

To use eSync, you must have the following:
l

Ektron software and files
o Ektron Version 8.5 or higher
IMPORTANT: The version of Ektron on every server in the sync
relationship must match. You can neither upgrade nor downgrade Ektron
using eSync.
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o

An Ektron base installation file (for example, cms400Base9x.exe). Use to
install a second site with which to sync your current site.

o

Ektron licenses that support Enterprise or Professional with eSync on every
server being synchronized.

o

Matching security certificates on every server being synchronized. See also:
Managing eSync security certificates on page 1979.
NOTE: If you upgrade, your initial sync must be to a min database.

l

Microsoft Software
o See Ektron System Requirements.
o

Microsoft Sync Framework 2.1
NOTE: It is not a problem if your templates were created using the 2.0
Framework.

o

l

User Permissions
o You are a member of the Ektron Administrators group or assigned the
Synchronization Admin role. See also: Defining roles on page 1581.
o

l

Database servers may use different SQL server versions. (For example, your
development server uses SQL 2008 Express, and your production server uses
SQL Server 2008 R2.)

The user performing the sync is assigned the following SQL database roles
o db_owner (needed for initial sync only; after that is complete, you may
remove this role)
o

db_datawriter

o

db_executor (created by Ektron installer when setting up database)

o

db_ddladmin

o

db_datareader

Server
o GMT time on each server’s clock must be within 5 minutes of each other.

Characteristics of eSync
You administer eSync through the Workarea > Settings > Configuration >
Synchronization > Profiles screen. The screen lets you establish a sync relationship
between 2 websites, then specify any number of sync profiles for each relationship.
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You can sync immediately by clicking Sync (

).

You create profiles to sync these kinds of data.
l

database objects (content, menus, users, and so on)

l

Workarea folder files

l

remaining site files

File types or individual files can be included or excluded from a sync profile.
Alternatively, you can sync content or folders. See also: Synchronizing content and
folders on page 1996.

Sync relationships
You can synchronize any server to or from any other server with one important
exception: you cannot initiate a sync from a server outside the firewall. You can only
initiate a sync from a server inside the firewall because an outside server does not know
the address of servers inside the firewall. However, your staging server can push to and
pull from a production server.
IMPORTANT: eSync transmissions use port 8732. This is not configurable.

Relationship 1: One staging server, one production server
The most basic eSync relationship involves a staging and a production server. Each
server has a database and one site.

eSync can automatically create a production server from your staging server. See also:
Initializing a new site on page 1933.
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For installation instructions for this relationship, see Scenario 2: Synchronizing a local
server with a remote server on page 1936.

Relationship 2: One development, one staging, one production
server
This relationship includes a development server. Developers can use it to create new
features and modify existing ones. When they are done, they can sync changes to the
staging server, where they can be verified before being moved to production.

For installation instructions for this relationship, see Scenario 3: Setting up a
development > staging > production environment on page 1947.

Relationship 2a: Multi-site staging and production servers
The following relationship illustrates synchronizing several sites on a staging server
with those sites on production.

Relationship 3: Several dev. servers, one staging, one
production server
As shown in the illustration, any number of development servers can sync to each other
and your staging and production servers.
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Relationship 4: One dev., one staging, one production site,
one production DB server
In this relationship, the production site has 2 servers: one for site files, and another for
the database.

To synchronize these servers, set up several eSync profiles. One syncs the database,
assets, and templates to the production database server. Another profile syncs the
staging server’s Workarea files with the production site server.
NOTE: When using separate site and database servers, assets are stored on the site
server.

Relationship 5: Relationship 4 plus pre-production server
This relationship adds a server between staging and production. The preproduction
server can be used for review and testing of changes before they are moved to
production.
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Relationship 6: Multi-site: each Site and DB on own production
server
In this relationship, each production server has its own database plus the site files. As
an alternative, you could have a separate server for each production database, with all
sites on one production server.
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NOTE: The above relationship also supports separate site and database servers.
To synchronize this type of relationship, set up several eSync profiles, one for each site.
l

3 database and template profiles

l

3 Workarea profiles

Initializing a new site
Typically, before you begin using eSync, one server hosts an Ektron website, and you
want to bring other servers into the relationship. After the servers are synchronized,
one is the staging server, the one on which content is created or updated, then
published. Another server, production, hosts your live website.
IMPORTANT: The names of the site and all folders must match on both servers.
This is because paths to images, XSLT files, and so on, refer to a site and its folders.
If the names do not match, the links break.
First, use eSync to initialize new servers from the existing one. Afterward, use eSync to
periodically sync updated content, folders, users, menus, and so on.

Scenario 1: Synchronizing 2 sites on the same server
It is unlikely that you will use this relationship in “real-life” situations, but it provides
the simplest way to begin testing and learning eSync.
IMPORTANT: Only use this scenario in a test environment. For a live environment,
use either Scenario 2: Synchronizing a local server with a remote server on
page 1936 or Scenario 3: Setting up a development > staging > production
environment on page 1947.
1. Log into your Ektron server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
2. Begin to install the first site. See also: Installing Ektron on page 9.
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3. During installation, when the following dialog appears, check eSync.
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4. Near the end of the installation, the following dialog appears.

a. At the Site Name drop-down, select the site you just installed.
b. Check the radio button next to Generate Certificates.
c. Click Generate.
5. Install a second site on the same server, again using the credentials of the service
account used by Ektron Windows Service 4.0 and your site's App Pool.
IMPORTANT: Install both sites to a physical folder relative to the root folder.
Do not install one site to a physical folder relative to the root folder and the
other site to a virtual directory.
6. Repeat Steps 2 and 3 above for the second site.
7. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The security configurator screen appears.
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8. In the Web Site Description drop-down, select the first site.
9. Click Apply Remote Server Certificates.
10. Click Browse next to that field.
11. Browse to C:\Program Files
(x86)\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityConfigurator.
12. Click Apply.
NOTE: Ektron Windows Services stop and restart at this point.
13. Repeat Step 7 through 11 for the second site.
Now that both sites’ security certificates are configured, continue from Part 3: Connect
local and remote servers on page 1941.

Scenario 2: Synchronizing a local server with a remote
server
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To sync a local to a remote server, install a minimal Ektron site to a new, remote server.
Next, use eSync to upload your Ektron site from the local to the remote server. After
the you complete the initial and template syncs explained in this chapter, the 2 sites are
mirror images of each other.
Follow these steps to configure 2 servers to sync with each other.
PREREQUISITE

See s for Using eSync on page 1927
Here’s a preview of the steps you will follow.
l

Part 1: Set up a Min site on the remote server below

l

Part 2: Generate and copy security certificates below

l

Part 3: Connect local and remote servers on page 1941

l

Part 4: Upload the local server’s database and resources to the remote server on
page 1942

l

Minimizing the time of the initial sync on page 1944

l

Part 5: Upload local server’s templates to remote server on page 1945

Part 1: Set up a Min site on the remote server
1. Upgrade the local server to the latest version of Ektron if necessary.
2. On the remote server, install a minimum Ektron site whose version matches the
local server by running the Ektron base installation file (CMS400Base9x.exe). For
more information, see System Requirements.
IMPORTANT: Install both sites to a physical folder relative to the root folder.
Do not install one site to a physical folder relative to the root folder and the
other site to a virtual directory.
3. If the local site is pre-compiled, you must also pre-compile the remote site.

Part 2: Generate and copy security certificates
Security certificates authorize file synchronization between servers. In this part, you
generate security certificates on the local server, then copy them to the remote.
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IMPORTANT: Near the end of the installation procedure, you are prompted to
generate security certificates. If you completed that screen, skip steps 2 through 6.

1. Sign on to the local server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
2. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
3. The following screen appears.

4. At the Web Site Description field, select the website on the local server.
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5. Click Generate.
6. Click Yes. The certificates are created on the local server.
NOTE: Ektron Windows Services stop and restart at this point.
7. Close the dialog.
8. Open 2 Windows Explorer windows side-by-side: one showing the local server’s file
system, and the other showing the remote server’s file system.
9. In the remote server window, create a folder underneath the root folder. Name the
folder local security certificate.
WARNING! Do not create the new folder under the Web root,
C:\inetpub\wwwroot.
10. In the local server window, open the following folder:
32-bit:
C:\ProgramFiles\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityCo
nfigurator
64-bit:
C:\ProgramFiles
(x86)\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityConfigurator
11. From that folder, copy these files.
l servername_SyncClient.pfx
l

servername_SyncClient.pvk

l

servername_SyncClient.cer

l

servername_SyncServer.pfx

l

servername_SyncServer.pvk

l

servername_SyncServer.cer

12. Paste the files into the remote folder you created in Step 8. Make sure there are no
other security files in the folder.
13. Close both windows you opened in Step 7.
NOTE: After copying security certificates to the remote folder, they need to be
registered and moved to the correct folders. The Security Configurator screen
does this.
14. Sign on to the remote server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
15. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
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16. The security configurator screen appears.

17. Click Apply Remote Server Certificates.
18. Click Browse next to that field.
19. Browse to the local security certificate folder where you pasted the security
certificates in Step 11.
20. Click Apply.
NOTE: Ektron Windows Services stop and restart at this point.
21. Click Yes to continue.
22. The security configurator copies the certificates you pasted in Step 11 to the
correct folder, and configures them for the remote server.
23. Click OK when you see All sites are now configured for eSync.
24. Next, generate security certificates on the remote server, then copy them to the
local.

1940

Ektron 9.40 SP1

Part 3: Connect local and remote servers

To accomplish this, repeat the steps in Part 2: Generate and copy security
certificates on page 1937, but this time, treat the remote server as the local server
and vice versa.

Part 3: Connect local and remote servers

WARNING! Back up your database before beginning this procedure.
1. On the local server, sign on to the Workarea > Settings > Configuration >
Synchronization > Profiles. The View All Synchronization Configurations screen
appears.

2. Click Create Synchronization Server Relationship. This screen appears.
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3. At the Remote Server field, enter the remote server name. The remote server
appears in the Choose Certificate field.
4. Click Connect. A screen shows the remote server's databases.

5. Click the database with which you want to sync then Next. A screen appears,
showing both servers.
6. Click Switch Synchronization Direction. The screen indicates that the database
will be uploaded from your local server to the remote server.
7. Click Create. This action connects the local and remote servers.

Part 4: Upload the local server’s database and resources to the
remote server
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NOTE: If your Ektron has a very large database or number of assets, and you want
to reduce the time required to complete the initial sync, see Minimizing the time of
the initial sync on the next page.
1. From the View All Synchronization Configurations screen, click Start Initial Sync
(

).

2. The initial sync uploads the local server’s database and resources to the remote
server. A screen tracks the progress.

3. When the sync is finished, Synchronization is Complete appears.
The initial sync creates a default database profile. You can reuse this profile to sync
database/resource files in the future.
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Minimizing the time of the initial sync
Use the following procedures if you have a large database or number of assets and want
to minimize the time to complete an initial sync. In both cases, you use a tool other
than eSync for the initial copy. From then on, use eSync to sync your servers.

Copying the initial database
To quickly copy a database between servers:
1. On your Ektron server, open the folder C:\Program Files
(x86)\Ektron\EktronWindowsService40.
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2. Open Ektron.ASM.Services40.exe.config.
3. Set the <add key="skipDataSyncChanges"> element to true.
4. Restart the Ektron Windows Service.
5. Back up the database of the local server.
6. Restore that backup to the remote server.
7. Run an initial sync.
8. Restart the Ektron Windows Service.
9. Update your license key.
For example, if the original database is backed up from staging and restored on
production, the license key in the database may be for the Staging.abc.com
domain. But, on the production server, you need a production domain key, such as
abc.com. See also: License keys on page 10.
10. Change the <add key="skipDataSyncChanges"> element to false.

Copying initial assets
Assets consist of files in these folders:
l

siteroot/assets

l

siteroot/privateassets

l

siteroot/uploadedfiles

l

siteroot/uploadedimages

l

C:/assetlibrary

If your Ektron has a large number of assets, you may want to reduce the initial sync
time. To copy asset files between servers quickly:
1. On your Ektron server, open C:\Program Files
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.Services40.exe.config.
2. Set the <add key="skipFileSyncChanges"> element to true.
3. Restart the Ektron Windows Service.
4. Using Windows Explorer, copy the folders listed above from the local to the
corresponding folders on the remote server.
5. Run an initial sync.
6. Change the <add key="skipFileSyncChanges"> element back to false.
7. Restart the Ektron Windows Service.

Part 5: Upload local server’s templates to remote server

Ektron Reference

1945

Synchronizing servers using eSync

1. From the View All Synchronization Configurations screen, click Add Sync Profile.
The Add Synchronization Profile screen appears.

2. At the Synchronization name field, give this profile a name, such as Local Remote Template Sync.
3. At the Items to Synchronize field, select Template.
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4. Check bin to include dlls and assembly changes.
5. For Synchronization Direction, choose Upload.
6. For Schedule, choose None.
7. Save the profile.
8. Click Sync (

) to the right of the template profile.

9. A screen tracks the sync’s progress. When it is complete, Synchronization is
Complete appears. You can use the template profile to sync templates in the
future.

Scenario 3: Setting up a development > staging >
production environment
Before

After
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In this scenario, Ektron initially resides on one server. Consider that your production
server and use it to initialize the staging and development servers.
NOTE: In this scenario, you cannot sync between the development and production
servers. The sync can only be run between Development and Staging or Staging and
Production.
Here’s a preview of the steps you will follow.
l

Part 1: Set up min site on the staging and development servers below

l

Part 2: Generate and copy security certificates below

l

Part 3: Connect staging and production servers on page 1956

l

Part 4: Download production server database to staging server on page 1958

l

Part 5: Download the production server’s templates to staging on page 1960

l

Part 6: Connect development and staging servers on page 1962

l

Part 7: Download staging server database to development server on page 1964

l

Part 8: Download staging server templates to development on page 1966

PREREQUISITE

See s for Using eSync on page 1927

Part 1: Set up min site on the staging and development servers
1. Upgrade your server to the current version of Ektron if necessary.
2. Install a minimum site on the staging and development servers by running the
Ektron base installation file (cms400Base9x.exe). See System Requirements.
IMPORTANT: Install both sites to a physical folder relative to the root folder.
Do not install one site to a physical folder relative to root and the other sites to
virtual directories.

Part 2: Generate and copy security certificates
Security certificates authorize synchronization between servers. In an eSync
relationship, every server needs a security certificate from every other server.
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To generate and copy these certificates:
l

2a. Generate certificates on production and copy to staging and development
below

l

2b. Generate certificates on staging and copy to development and production on
page 1951

l

2c. Generate certificates on development and copy to staging and production on
page 1954

2a. Generate certificates on production and copy to staging and
development
IMPORTANT: Near the end of the installation procedure, you are prompted to
generate security certificates. If you completed that screen, skip steps 2 through 4.
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1. Sign on to the production server using the credentials of the service account used
by Ektron Windows Service 4.0 and your site's App Pool.
2. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The following screen appears.

3. In the Web Site Description field, select the production server website.
4. Click Generate. The certificates are created on the production server.
5. Open 2 Windows Explorer windows: one showing the production server’s file
system, and the other showing the staging server’s file system.
6. In the staging server window, create a folder underneath the root folder. Name the
folder Prod security certificates.
WARNING! Do not create the new folder under the Web root,
C:\inetpub\wwwroot.
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7. In the production server window, open the following folder:
C:\ProgramFiles\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityCo
nfigurator.
8. From that folder, copy these files.
l servername_SyncClient.pfx
l

servername_SyncClient.pvk

l

servername_SyncClient.cer

l

servername_SyncServer.pfx

l

servername_SyncServer.pvk

l

servername_SyncServer.cer

9. Paste the files into the folder you created in Step 6. Make sure there are no other
security files in the folder.
10. Close both windows.
After copying security certificate files to the staging folder, they need to be
registered and moved to the correct folders. The Security Configurator screen does
this.
11. Sign on to the staging server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
12. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The security configurator screen appears.
13. Click Apply Remote Server Certificates.
14. Click the browse button next to that field.
15. Browse to the folder to which you pasted the security certificates in Step 9.
16. Click Apply. The security configurator copies the certificates you pasted in Step 9
to the correct folder, and configures them for the staging server.
17. Follow the same procedure to move production certificates to the development
server. To do this, begin at Step 6 and follow all steps. Wherever the instructions
mention a staging server, substitute the development server.

2b. Generate certificates on staging and copy to development and
production
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1. Sign on to the staging server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
IMPORTANT: Near the end of the installation procedure, you are prompted to
generate security certificates. If you completed that screen, skip steps 2
through 4.
2. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The following screen appears.
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3. At the Web Site Description field, select the staging server website.
4. Click Generate. The certificates are created on the staging server.
5. Open 2 Windows Explorer windows: one showing the staging server’s file system,
and the other showing the production server’s file system.
6. In the production server window, create a folder underneath the root folder. Name
it staging security certificates.
WARNING! Do not create the new folder under C:\inetpub\wwwroot.
7. In the staging server window, open the following folder:
C:\ProgramFiles\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityCo
nfigurator.
8. Copy these files.
l servername_SyncClient.pfx
l

servername_SyncClient.pvk

l

servername_SyncClient.cer

l

servername_SyncServer.pfx

l

servername_SyncServer.pvk

l

servername_SyncServer.cer
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9. Paste the files into the folder you created in Step 6. Make sure there are no other
security files in the folder.
10. Close both windows opened in Step 5.
NOTE: After copying the security certificate files to the production folder, they
need to be registered and moved to the correct folders. The Security
Configurator screen does this.
11. Sign on to the production server using the credentials of the service account used
by Ektron Windows Service 4.0 and your site's App Pool.
12. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The security configurator screen appears.
13. Click Apply Remote Server Certificates.
14. Click the browse button next to that field.
15. Browse to the folder to which you pasted the security certificates in Step 9.
16. Click Apply. The security configurator copies the certificates you pasted in Step 9
to the correct folder, and configures them for the production server.
17. Follow the same procedure to move staging certificates to the development server.
To do this, begin at Step 6 and follow all steps. Where the instructions mention a
production server, substitute the development server.

2c. Generate certificates on development and copy to staging and
production

1. Sign on to the development server using the credentials of the service account
used by Ektron Windows Service 4.0 and your site's App Pool.
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IMPORTANT: Near the end of the installation procedure, you are prompted to
generate security certificates. If you completed that screen, skip steps 2
through 4.
2. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
The following screen appears.

3. At the Web Site Description field, select the website on the development server.
4. Click Generate. The certificates are created on the development server.
5. Open 2 Windows Explorer windows: one showing the development server’s file
system, and the other showing the staging server’s file system.
6. In the staging server window, create a folder underneath the root folder. Name the
folder Dev security certificates.
WARNING! Do not create the new folder under C:\inetpub\wwwroot.
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7. In the development server window, open the following folder:
C:\ProgramFiles\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityCo
nfigurator.
8. Copy these files.
l servername_SyncClient.pfx
l

servername_SyncClient.pvk

l

servername_SyncClient.cer

l

servername_SyncServer.pfx

l

servername_SyncServer.pvk

l

servername_SyncServer.cer

9. Paste the files into the staging server folder you created in Step 6. Make sure there
are no other security files in the folder.
10. Close both windows you opened in Step 5.
11. After copying the security certificate files to the staging folder, they need to be
registered and moved to the correct folders. The Security Configurator screen does
this.
12. Sign on to the staging server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
13. Click the Windows Start button > All programs > Ektron > CMS400 v9x >
Utilities > Security Configurator. Right click and choose Run As
Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
14. Click Apply Remote Server Certificates.
15. Click the browse button next to that field.
16. Browse to the folder you created in Step 6.
17. Click Apply.
18. The security configurator copies the certificates you pasted in Step 9 to the correct
folder, and configures them for the staging server.
19. Follow the same procedure to move development certificates to the production
server. To do this, begin at Step 6 and follow all steps. Wherever the instructions
mention a staging server, substitute the production server.

Part 3: Connect staging and production servers
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WARNING! Back up your database before beginning this procedure!
1. On the staging server, sign on to Ektron.
2. In the Workarea, go to Settings > Configuration > Synchronization >
Profiles. The View All Synchronization Configurations screen appears.

3. Click Create Synchronization Server Relationship. That screen appears.

4. In the Remote Server field, enter the production server.
5. In the Choose Certificate field, the name of the production server appears.
6. Click Connect. This action connects the staging with the production server. A new
screen appears showing the production server's database.
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7. Click Next. A new screen appears, showing both servers.

8. Click Create. This action connects the staging and production servers.

Part 4: Download production server database to staging server
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Part 4: Download production server database to

NOTE: If your Ektron has a very large database or number of assets, and you want
to reduce the initial sync time, see Minimizing the time of the initial sync on
page 1944.
1. From the View All Synchronization Configurations screen, click Start Initial Sync
(

).

2. The initial sync downloads the production server’s database and resources to the
staging server. A screen tracks progress.

3. Synchronization is Complete appears.
The initial sync creates a default database profile. You can use the profile to run
database/resource syncs in the future.
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Part 5: Download the production server’s templates to staging
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Part 5: Download the production server’s

1. From the View All Synchronization Configurations screen, click Add Sync Profile.
The Add Synchronization Profile screen appears.
2. At the Synchronization name field, give this profile a name, such as Prod Staging Template Sync.
3. At the Items to Synchronize field, select Template.
4. Check bin to include dlls and assembly changes.
5. For Direction, choose Download.
6. For Schedule, choose None.
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7. Save the profile.
8. Click Sync (

) to the right of the profile. A screen tracks the sync’s progress.

9. When the sync is complete, Synchronization is Complete appears. You can
reuse the template sync profile in the future.

Part 6: Connect development and staging servers

1. Sign on to Ektron development server.
2. In the Workarea, go to Settings > Configuration > Synchronization >
Profiles. The View All Synchronization Configurations screen appears.
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3. Click Add (

). The Create Synchronization Server Configuration screen appears.

4. At the Remote Server field, enter the name of the staging server.
5. At the Choose Certificate field, the name of the staging server appears.
6. Click Connect. This action connects the development with the staging server.
After you connect to the staging server, a new screen appears showing its
database.
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7. Click Next. A new screen appears, showing both servers.

8. Click Create. This action connects the development and staging servers.

Part 7: Download staging server database to development
server

NOTE: If your Ektron has a very large database or number of assets, and you want
to reduce the initial sync time, see Minimizing the time of the initial sync on
page 1944.
1. From the View All Synchronization Configurations screen, click Start Initial Sync
(
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The initial sync downloads the staging server’s database and resources to the
development server. A screen tracks the sync’s progress.

2. When the sync is complete, Synchronization is Complete appears.
The initial sync also creates a default database profile. You can reuse this profile to
sync the database/resources between these 2 servers at any time in the future.
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Part 8: Download staging server templates to development
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Part 8: Download staging server templates to

1. From the View All Synchronization Configurations screen, click AddProfile. The
Add Synchronization Profile screen appears.
2. At the Name field, give this profile a name, such as Staging-Dev Template Sync.
3. At the Items to Synchronize field, select Template.
4. Check bin to include dlls and assembly changes.
5. For Direction, choose Download.
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6. For Schedule, choose None.

7. Save the profile.
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8. Click Sync (

) to the right of the profile. A screen tracks the sync’s progress.

9. When the sync is complete, Synchronization is Complete appears. You can
reuse the profile to sync templates in the future.

Setting up eSync profiles
To minimize data entry, eSync saves job specifications in a profile. After you enter
specifications once, select the profile to sync again using the same details. A profile
contains the following information:
l

source and destination databases

l

type of data being synchronized

l

files to include/exclude

l

direction

l

schedule

Use the Add/Edit Synchronization Profile screen to manage eSync profiles.
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While Setting up eSync on page 1927, you created a default database and a template
profile. This section explains how to modify those profiles and create new ones.
To sync a website, you need at least 2 profiles: one for the siteroot/Workarea folder,
and another for all other site files. To create a profile for

1970

l

your Workarea folder, check Items to Synchronize > Workarea

l

all other site files, check Items to Synchronize > Database/Resources,
Template, and bin
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The following list explains which files are synchronized by each grouping under Items
to Synchronize.
l

Database/Resources. Synchronizes database tables plus the following site root
folders. See also: Setting up a profile to Sync a database below.
o assets
o

PrivateAssets

o

uploadedimages

o

uploadedfiles

l

Workarea. Synchronizes files in the site’s Workarea folder. See also: Setting up a
profile to sync workarea files on page 1974.

l

Template. Synchronizes files in the site root folder. See also: Setting up a profile
to sync template and bin files on page 1975.
IMPORTANT: If you run a template sync and Bin is checked, and one server is
running is 32-bit mode while the other is running in 64-bit mode, users will not
be able to drag and drop DMS files on the staging server.
NOTE: If you perform an initial sync of a recently-installed min site with your
staging site, the min site’s templates could overwrite templates on your staging
site. This is because, when 2 templates have the same name, the most
recently-modified one overwrites the other.
To avoid this, rename the only template installed with the min site (login.aspx)
before performing the initial template sync. You should also rename login.aspx’s
supporting files, such as login.aspx.vb.

l

Bin. Synchronizes the siteroot/bin folder, including DLLs and assemblies.

The following file types are not synchronized by default.
l

.config files

l

.txt files

l

.sln files

You may add these file types to a Workarea or Template profile via the
Include/Exclude Files field.

Setting up a profile to Sync a database
PREREQUISITES
l

You created a Sync relationship and ran an initial sync. See also: Setting
up eSync on page 1927.

l

If your profile is based on an eSync package, it has been set up. See
also: Synchronizing servers using eSync on page 1925.

To set up a profile:
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1. Go to the Settings > Configuration > Synchronization > Profiles screen.

2. Click Add Sync Profile. The Add Synchronization Profile screen appears.
3. At the Name field, enter a name for this profile.
4. At the Profile Type field, choose Scope or Local Package.
l To define a Scope, continue through the steps.
l

To define a Local Package, see Synchronizing servers using eSync on
page 1925. After selecting the package, you still choose a Synchronization
Direction, Conflict Resolution Policy, and a Schedule.

5. At the Items to Synchronize field, select Database/Resources.
The following list describes the database scope filter checkboxes.
NOTE: The Include/ExcludeFiles field is available only for Workarea,
Template, or bin syncs.
Use these checkboxes to choose groups of database tables. You must choose one
scope if you check Database/Resources.
NOTE: Click any label under Database/Resources to see the list of database
tables synchronized by that scope.
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l

CMS Core. essential Ektron tables; includes Targeted Content rules

l

Workflow (eCommerce). eCommerce event history
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l

History. content history. Lets users on the destination server review content
changes (edited, published, and so on).

l

ASP.NET. Microsoft .NET ASP provider

l

Search. tables to support search functionality:
o Using synonym sets on page 374
o

Providing suggested results on page 376

o

Including external files in a search on page 385

l

Custom. Custom tables (if defined) See also: Synchronizing custom
SQL database tables on page 2001.

l

Notification. Notification activities See also: Sending notifications to a
community on page 1665.

l

User Generated Content. Content created by membership users and other
site visitors. For example:
o A membership user logs in and creates a new account
o

A site visitor rates content

o

Community members reply to forum questions and blog posts

o

A Community member creates a community folder

Whenever user-generated content is synchronized, the profile of the user who
created the content is also synchronized.
User-generated content is a subset of CMS Core, so you would not choose both
for the same sync. But you may select user-generated content with any other
scope.
When you set up a sync profile for user-generated content, you typically
choose Bidirectional as the direction. In this case, if a membership user
updates his or her profile on the production server, eSync copies the changes
to staging. On the other hand, if your administrator changes that information
on staging, the next eSync copies it from staging to production.
NOTE: Since notifications are part of the User Communities feature, they
are automatically checked if you check User Generated Content.
6. For the Include/Exclude files field, see Include/exclude files field on page 1975.
7. At the Synchronization Direction field, select the direction of the copy. Your
choices are:
l Bidirectional. Changed data on either server is updated on the other. See
also: Choosing a bidirectional sync on page 1977.
l

Upload. database is copied from the local server (the one to which you signed
on) to the remote server (specified at the Remote Site field above). Items on
the remote server are overwritten.

l

Download. database is copied from remote to local server. Items on the local
server are overwritten.
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8. At the Conflict Resolution Policy field, decide what to do if the same data
changed on both servers since the last sync. Your choices are:
l Version on Remote Site Wins
l

Version on Local Site Wins

Effect of Choosing Conflict Resolution Policy
To understand these choices, see table below.
Synchronization Direction
Bidirectional

Upload

Download

Version on
Remote Site
Wins

remote version
overwrites local
version

remote version is
retained; nothing is
copied

remote version
overwrites local
version

Version on
Local Site
Wins

local version
overwrites remote
version

local version
overwrites remote
version

local version is
retained; nothing is
copied

9. If desired, select a schedule on which sync runs automatically. The choices are
l None. Don’t set up a schedule. Sync as needed via the Sync Profile screen‘s
Sync Now button.
l

One Time. specify a start time and date. The profile runs once at that
date/time.

l

Hourly. specify a start minute. The profile runs every hour at this minute.

l

Daily. specify a start time. The profile runs every day at this time.

l

Weekly. specify a start time and weekday. The profile runs on this day every
week at this time.

l

Monthly. specify a start time and calendar day (numbers 1 through 31). After
the start date, the profile runs on this day every month at this time.
NOTE: If you enter a date greater than 28, the sync will not run in a month
that does not include that date. For example, if you enter 31, the sync will
not run in February, April, June, September, and November.

Setting up a profile to sync workarea files
Setting up a profile to sync Workarea files is the same as Setting up a profile to Sync a
database on page 1971 with the following exceptions:
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l

At the Items to Synchronize field, select Workarea.

l

You may use the Include/ExcludeFiles field to refine the files to be
synchronized. See also: Include/exclude files field below.

Include/exclude files field
Use the Include/Exclude Files field to include files not normally synchronized, or
exclude files or directories that are synchronized by default. This screen section is
active only if you choose a Template or Workarea sync and no
Database/Resources scopes.
NOTE: By default, eSync ignores .config and .txt files.
For example, .txt files are not normally synchronized, but you want to sync several of
them. In this case, check Include and enter *.txt into the Files field.
Examples of the Exclude Files option:
l

you do not want to sync Flash (.swf) files. If you check the Exclude button, and
enter .swf into the Files field, eSync ignores them.

l

you do not want to sync files in the widgets folder. If you check the Exclude
button, and enter widgets into the Directories field, eSync ignores them.

You can exclude file types and directories. eSync ignores files that satisfy either
criterion.

Files excluded from the Workarea sync
Workarea synchronizes all files in the site’s Workarea folder, except files in these
subfolders:
l

ewebeditpro

l

explorer

l

ewebdiff

l

foundation

l

resources

l

sync

Setting up a profile to sync template and bin files
Setting up a profile to sync Workarea files is the same as Setting up a profile to Sync a
database on page 1971 with the following exceptions:
l

At the Items to Synchronize field, under Files, select Templates and Bin.

l

You may use the Include/ExcludeFiles field to refine the list of files to be
synchronized.
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Regardless of how you complete the Include/ExcludeFiles field, the following siteroot
folders are not synchronized:
l

App_GlobalResources

l

App_WebReferences

l

Workarea

l

assetlibrary

l

assets, privateassets, uploadedfiles, uploadedimages (individual checkboxes under
Files)

l

latestchanges

Choosing files and file types via include/exclude files
Within a template/bin sync's folders, you can select individual files. For example, you
updated template files and related .css files on the staging server, and want to update
the production server without moving everything else.
After saving the profile, click Synchronize files ( ) from the View Profiles screen to
access the Sync Files screen. Here, you can select individual files. If you included files
types, only they are available for selection. If you excluded file types or directories,
they are unavailable.

IMPORTANT: If you select one or more files on the Sync Files screen, the profile
includes only those files. If you select no files, the profile includes all files indicated
by your responses to the Include/Exclude Files field.

Previewing a sync
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Before running a sync, you can view what will be synchronized by clicking Sync
Preview.

Ektron recommends this feature to help confirm that tables, assets, private assets,
uploaded files, uploaded images and assetlibrary files that you delete, add, or change
will be synchronized between servers as you expect. Also, you can predict how long a
sync will take, because the preview takes the same amount of time.
The Sync Preview produces Sync Log files. See also: Viewing eSync activity on
page 2009.
NOTE: You cannot preview a sync profile that includes only Workarea files.

Pausing the sync schedule
If a sync profile has a schedule, you can pause it by clicking the profile's pause/play
button.

While paused, the sync will not run. To resume the schedule, click the pause/play
button again.
For example, a sync is scheduled to run every hour @ :50: 1:50, 2:50, 3:50, and so on.
At 10:30 a.m., you pause the sync profile. So, at 10:50 a.m., the sync does not run. At
12:00 noon, you click the pause/play button again. The next sync starts at 12:50 p.m.

Choosing a bidirectional sync
Although most Ektron data is created and updated on the staging server, some data is
collected on the production server. This information can be viewed and edited on the
staging server. Here are some examples:
l

membership users

l

content ratings

l

forum and blog posts

l

community folders

When you set up a profile to sync this kind of data (maintained in the database), you
typically choose Bidirectional as the direction, and Notifications and User
Generated Content under Database/Resources. So, if a membership user updates
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his or her profile on the production server, eSync copies the changes to staging. On the
other hand, if your administrator changes that information on staging, the next eSync
copies it from staging to production.
If the same file on both servers was updated since the last sync, your conflict resolution
policy determines which data is saved.
NOTE: The first time you run a sync for templates or Workarea files, the sync is
bidirectional, regardless of the direction you specify on the Synchronization Direction
screen.
If you are using a bidirectional sync, and the same item changed on both servers since
the last sync, eSync must decide which version to keep, and which version to overwrite.
NOTE: If you use bidirectional sync and only one version was updated since the last
sync, the updated version overwrites the unchanged version.
Use the Synchronization Profile screen's Conflict Resolution Policy field to determine
which version ends up on both servers after synchronization. The choices are:
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l

Version on Remote Site Wins. the remote version overwrites the local

l

Version on Local Site Wins. the local version overwrites the remote
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Managing eSync security certificates
eSync uses security certificates to secure communication between servers. All servers
in an eSync relationship must have matching, encrypted security certificates to
establish an eSync relationship.
NOTE: If your relationship includes separate database servers, you do not need to
install security certificates on them. You only need to install certificates on servers
that host Ektron.
See also: Create eSync security certificates for a load-balanced cluster on page 2024.
Before you can establish an eSync relationship between servers, each server must have
its own (local) security certificates and certificates from every other server in the
relationship.

As another example, if an eSync relationship consists of 5 servers, each server requires
5 security certificates: one local and 4 remote.
Each server creates 2 certificates: a server and a client. Then, you copy the client
certificate to the other servers in the relationship. The local machine’s server certificate
must match a client certificate on the remote server, and vice versa.
You typically copy certificates only when establishing an eSync relationship between
servers. After that, any eSync activity triggers a background check, and you can only
proceed if certificates match.
Each certificate consists of these files.
l

Server certificate
o servername_SyncServer.pfx
o

servername_SyncServer.pvk
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o
l

servername_SyncServer.cer

Client certificate
o servername_SyncClient.pfx
o

servername_SyncClient.pvk

o

servername_SyncClient.cer

The security certificates can apply to one site or all sites on a server. You determine this
when installing them.

Viewing security certificates
Use Certificate Manager to view security certificates installed on your server. Check
marks indicate the certificates. You can also delete all certificates for a server.
NOTE: You can only remove certificates from remote servers. You cannot remove
them from the server to which you are logged in.
To view (and delete) certificates:
1. Click the Windows Start button > All programs > Ektron > CMS400vxx >
Utilities > Security Configurator > right click Run as Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
2. Click Manage Certs. Your server's security certificates appear.

3. To remove a remote server's certificates, select that row and click Remove.

Installing security certificates
PREREQUISITE
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Permission to copy and paste files between local and remote servers
To create and place eSync security certificates in the correct locations:
l

Step 1: Create security certificates on your local server below

l

Step 2: Create security certificates on the remote server on page 1983

l

Step 3: Copy local client certificate to remote server on page 1983

l

Step 4: Copy remote client certificate to local server on page 1985

l

Step 5: Test the security certificates on page 1986

Step 1: Create security certificates on your local server
1. Log on using the credentials of the service account used by Ektron Windows
Service 4.0 and your site's App Pool.
2. During the Ektron installation, you are asked if you want to install eSync security
certificates. The eSync checkbox (second from the top) is only accessible if your
license key contains an eSync modifier.

3. If you check eSync, near the end of installation, the following screen prompts you
to create the certificates.
NOTE: You can access this screen at any time screen by clicking the Windows
Start button > All programs > Ektron > CMS400 vxx > Utilities >
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Security Configurator > right click and choose Run as Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.

4. Use the following information to understand this screen.
l Generate Certificates. Use this screen area to create security certificates
that must be copied to a remote server with which you want to sync.
l

Site Name. If more than one site is installed on this server, use the pull-down
list to select the website for which you are installing security certificates. Or,
click All to apply certificates to all sites on the server.

l

Apply Remote Server Certificates. Use this screen area to apply security
certificates that were copied from a remote server to your local server. See
also: Step 3: Copy local client certificate to remote server on the facing page.

5. Click Generate.
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6. Local security certificates are created and configured.

NOTE: Only click Generate once. The status field at the bottom of the screen
updates as it progresses. If you click OK more than once, you delay the
certificates’ creation.

Step 2: Create security certificates on the remote server
1. Sign on to the remote server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
2. Generate security certificates for the remote server, following instructions in Step
1: Create security certificates on your local server on page 1981.

Step 3: Copy local client certificate to remote server

Ektron Reference

1983

Synchronizing servers using eSync

1. On the local server, open 2 Windows Explorer windows: one showing the local
server’s file system, and the other showing the remote server’s file system.
2. On the remote server window, create a folder underneath the root folder. The
folder name is not important.
IMPORTANT: Do not create the folder under the Web root folder, for example
C:\inetpub\wwwroot.
3. In the local server window, open the following folder:
C:\ProgramFiles\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityCo
nfigurator.
4. Copy the following files.
l servername_SyncClient.pfx
l

servername_SyncClient.pvk

l

servername_SyncClient.cer

l

servername_SyncServer.pfx

l

servername_SyncServer.pvk

l

servername_SyncServer.cer

NOTE: These files were created when you completed the eSync Security
Configurator Screen in Step 1.
5. Paste the files to the remote server folder that you created in Step 2. Make sure
there are no other security files in the folder.
After you copy the local server’s security certificates to the remote server, they
need to be registered and moved to the correct folders. The Security Configurator
screen does this.
6. Log into the remote server, using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
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7. Open the security configurator screen using this path: Windows Start button > All
programs > Ektron > CMS400 v9x > Utilities > Security Configurator >
right click and choose Run as Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
8. The security configurator screen appears.

9. Click Apply Remote Server Certificates (circled above).
10. Click the browse button next to that field.
11. Browse to the folder to which you pasted the security certificates in Step 5.
12. Click Apply.
13. The utility copies the security certificates you pasted in Step 5 to the correct folder,
and configures them for the remote server.

Step 4: Copy remote client certificate to local server
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1. Sign on to the remote server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
2. Follow the steps described in Step 3: Copy local client certificate to remote server
on page 1983, except substitute remote for local.

Step 5: Test the security certificates
1. From the local server, sign on to Ektron using the credentials of the service account
used by Ektron Windows Service 4.0 and your site's App Pool.
2. In the Workarea, go to Settings > Configuration > Synchronization >
Profiles.
3. Click Create Synchronization Server Configuration.
4. Enter the name of the Remote Server.
5. Select the security certificate you are testing.
6. Click Connect. If the next screen appears, the security certificates are working
properly.

Regenerating security certificates
Follow these steps to regenerate security certificates. You would do this if they stop
working, or you are concerned about a security breach.
1. Log into the Ektron server using the credentials of the service account used by
Ektron Windows Service 4.0 and your site's App Pool.
2. Access the eSync Security Configurator screen via Windows Start button > All
programs > Ektron > CMS400 v9x > Utilities > Security Configurator >
right click and choose Run as Administrator.
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If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
3. Use the Web Site Description field to select a site on your server, or choose All
sites.
4. Check the Discard Existing Keys box.

5. Click Generate. Security certificates are removed from your local server.
6. Reopen the Security Configurator screen.
7. Choose the correct website, verify the other settings, and click Generate. See
also: Step 1: Create security certificates on your local server on page 1981. This
action creates new security certificates on your server.
8. Copy the new certificates to all other servers in the eSync relationship. This is
explained in Step 3: Copy local client certificate to remote server on page 1983.

Troubleshooting security certificates
Could not connect error
When trying to connect to a remote server, after selecting a security certificate, you
may see the following message.
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To resolve the problem:
l

Check the Windows Event Viewer > EktronL2 log for the error. If the service is
hosted but already exists, stop then start the service (do not restart).

l

The certificates may be corrupted. To resolve this, see Regenerating security
certificates on page 1986.

No endpoint error
The following endpoint error indicates that

1988

l

the remote site may not be on the same Ektron version as the local site, or

l

the Ektron Windows Service is not started
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Specifying eSync settings
The eSync Settings screen lets you define many eSync settings.
Workarea > Configuration > Synchronization > Settings.
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l

Maximum configured memory for an eSync session (kb). Define a
maximum amount of memory that your server uses during a sync. The default is
32 MB. You can change it to any size up to the amount of RAM in your eSync server.

l

Remote SQL connection type. Data sync runs in one of 3 contexts: Direct,
Proxy, or Auto detect.
o Auto detect: Try to connect using TCP. If successful, the mode is switched to
direct. Otherwise, the mode is proxy. Auto detect is the default.

l

1990

o

Proxy: Use Windows Communication Foundation (WCF) service.

o

Direct: Direct SQL Connection (direct TCP connection used instead of WCF
connection)

Application transaction size. This value is typically the same as Maximum
configured memory for an eSync session. The commit occurs after the data
reaches this size.
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l

Encrypt scripts. If you check this box, all stored procedures and triggers are
encrypted.
The default value is false because Azure does not support encryption. You should
only check this box if you are using eSync in an on-premises environment.

l

Backup action, Backup location. Define when you want to run the backup (only
initially or each time) and the backup file location. See also: Backing up the
destination server during an eSync on page 1996.

l

Types of data (for which e-sync collisions will be resolved). Select data
types for which you want to resolve collisions. See also: Determining which
collisions are resolved on page 2015.

Running eSync
IMPORTANT: The names of the site and all folders must match on both servers.
This is because paths to images, xslt files, and so on, refer to a site and its folders. If
the servers’ site and folder names do not match, the links break.
NOTE: Syncs can be queued so they run 1 after the other. See also: Managing the
eSync queue on page 2008.

Optional steps before running a sync
You may want to adjust the web.config and db.config settings before running a Sync.
The following topics explain eSync features that you control via the .config files.
l

Synchronizing content and folders on page 1996

l

Using eSync with Web Alerts on page 2030

l

Using eSync with eCommerce on page 2030
IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive
support, but if you need to upgrade, contact your account manager for options.

l

Forcing the initial sync on page 1994

l

Replacing the file sync below

l

Adjusting relationship settings on the next page

Replacing the file sync
Some Ektron customers prefer a tool other than eSync to sync assets; for example
RoboCopy. To disable eSync's asset sync:
1. On your Ektron server, open C:\Program Files
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.Services40.exe.config.
2. Set the <add key="disableFileSyncProvider"> element to true.
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3. Save Ektron.ASM.Services40.exe.config.
4. Restart the Ektron Windows service.
From now on, eSync does not copy assets. Set up your replacement tool to do that.

Adjusting relationship settings
You can modify settings in the Ektron Windows service (EWS) config file
(C:\ProgramFiles
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.EktronServices40.exe.conf
ig) to accommodate your preferences. The settings are:
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l

DebugEnabled. By default, this is set to zero (0). If PDB files are present in the
EWS folder or it is a DEBUG build, this value is set to 1. Setting this value to 2
works as in version 8.5.

l

DependencyImageSyncExtensSprtForThumbnls. All valid image file
extensions. This list determines if a content item being synchronized is an image. If
true, a thumbnail is also synchronized. If this value is BLANK, no thumbnails are
synchronized while synchronizing dependent images (including the file sync retry
and content dependency sync).

l

DependencySyncRecursionDepth. The depth of recursion for the content
dependency sync. Zero (0) indicates that all dependencies are evaluated,
regardless of the number of recursions necessary. If you enter a number more than
zero, EWS only evaluates as far as the specified depth.

l

DownloadFileStreamsInParallel. If this is set to true on a server with more than
1 processor,, then it will download file streams from the remote server in parallel,
using as many threads as specified in MaxNumberOfParallelThreads. Ensure that
BOTH the local and remote server has enough resources to handle normal load if
the number of MaxNNumberOfParallelThreads processors run at 100% CPU.

l

EnableMetadataEvalInDependencySync. If set to True, metadata evaluation
occurs during the content dependency sync. If set to False, files specified in
metadata are not synchronized during a content sync. Default value is True.

l

EnableRecursiveDependencySync. If set to True, recursive dependency sync is
enabled for content sync. This means that if a content's metadata or HTML
references other content blocks, their dependencies are also evaluated and
synchronized. Default value is True. See also: Resource Selector on page 948,
Creating and deploying a related content definition on page 830.

l

EnableSiteFileHashIndexingAtStartup. If set to true AND if
UseFileHashForFolderSyncChangeDetection OR
UseFileHashForFilteredFolderSyncChangeDetection are also true, then the EWS will
start indexing all the files in the site which are synchronized using file sync, without
using high CPU. This process starts 5 minutes after the service starts.

l

FileSyncFailureMaxRetries. The maximum number of times the EWS tries to
sync a file that was not synchronized in the initial try. Default value is 5.
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l

FileSyncFailureSleepBetweenRetriesInSeconds. The time (in seconds) the
EWS "sleeps" before it attempts to retry a failed file sync. Default value is 5.

l

LoadFileStreamsInParallel. If this is set to true on a server with more than 4
processors, eSync loads file streams locally, in parallel, using as many threads as
specified in MaxNumberOfParallelThreads. Ensure that the server has enough
resources to handle a normal load if the number of MaxNumberOfParallelThreads>
processors run at 100% CPU.

l

MaxNumberOfParallelThreads. Specifies the maximum number of threads
created. You should increase this value if you have an adequate CPU resources to
significantly improve performance.

l

UploadFileStreamsInParallel. If this is set to true on a server with more than 1
processor, eSync uploads file streams to the remote server in parallel, using as
many threads as specified in MaxNumberOfParallelThreads. Ensure that both the
local and remote servers have enough resources to handle normal load if the
number of MaxNumberOfParallelThreads processors run at 100% CPU.

l

UseFileHashForFilteredFolderSyncChangeDetection. Similar to
UseFileHashForFolderSyncChangeDetection, but used for file syncs where folder
sync is filtered by file name.

l

UseFileHashForFolderSyncChangeDetection. Runs file sync in
CompareFileStreams mode as described here: FileSyncOptions Enumeration. This
is set to false by default because file hash mode can fail when the file is locked for
reads.

PREREQUISITES FOR RUNNING A SYNC
l

s for Using eSync on page 1927

l

You created an eSync relationship and profiles. See Setting up eSync on
page 1927.

l

You are not signed on to a production server that is outside the firewall.
You cannot sync from a production server outside the firewall to other
servers—you can only sync to this production server.

Beginning a sync
You can run eSync on a schedule, or on demand. To sync a profile immediately:
1. Go to the Settings > Configuration > Synchronization > Profiles screen.
2. If a profile is ready to sync, a sync button (

) appears in the right column.
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3. Click Sync (

).

NOTE: If another sync is running, and you have enabled the eSync Queue, this
sync is queued and will be synched after all other syncs in the queue are run.
See also: Managing the eSync queue on page 2008.
4. A screen monitors progress and indicates when the sync is complete.

NOTE: You can close the status window and reopen it at any time by clicking Sync (
). If you do, the sync’s current status appears.
IMPORTANT: If you performed a database sync and the site being synchronized
uses URL aliasing, you must go to its URL Aliasing Settings screen and click Refresh
(

) to update its aliasing information.

Forcing the initial sync
Use the Force Initial Sync button to reinitialize a server that was previously initialized.

Here is an example of when to use Force Initial Sync.
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1. You initialized a test server from your current Ektron server.
2. You experimented on the test server by adding content, deleting content, and so
on.
3. You no longer want the test server’s database. Instead, you want to reinitialize the
test server from your current Ektron server.
To accomplish step 3, use the Force Initial Sync button. The button only appears
when all of these conditions are present.
PREREQUISITE: FORCING INITIAL SYNC CONDITIONS

The Force Initial Sync feature requires these conditions.
l

The server’s web.config file’s ek_ForceReInit property is set to
true.

l

The site is not part of a multi-site relationship.

l

The server has only one sync server relationship.

l

The server is the destination (that is, on the download side) of the
sync server relationship.

The following image illustrates the last 2 conditions.

NOTE: The Force Initial Sync procedure ignores these checks that are normally
made prior to synchronization:
* the destination database is smaller than the source database
* the site was not previously staged
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Backing up the destination server during an eSync
You can create a backup of the destination server’s database. If you do and problems
occur during the sync, the database is restored to its pre-backup state. You can specify
the backup to occur on the initial sync only, or every time you sync.
NOTE: No backup is made when you sync a package, folder, content. See also:
Synchronizing content and folders below, Synchronizing servers using eSync on
page 1925.
To set up database backup:
1. Go to Workarea > Settings > Synchronization > Settings.
2. At the Backup action field, select an option.
l Before initial sync. Run backup before the initial sync only.
l

Before each sync. Run backup before each sync.

3. At the Backup location field, enter a local or network path to the folder to which
the backup file will be saved. The user account that runs the Ektron Windows
Service must have read and write permission to the folder.
4. Click Save.
The backup file format is [dbname][yyyy][mm][dd][hh][mm][ss][mmm].
[product].bak. For example: cms400min20120216075946765.esync.bak.

Synchronizing content and folders
This section explains how to sync content and folders using context menu options.
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Prerequisites for content/folder sync
See also: Prerequisites for Using eSync.
l

You are a member of the Administrators group or assigned the Synchronization
Admin Role.

l

Content/folder sync is enabled.
Set up content and folder sync
1. On the server on which content editors will sync content and folders, open the
site root/web.config file.
2. In the following area, set eSyncEnabled to true.
<eSyncSettings>
<!-- Set this key to true to enable content/folder sync if the eSync feature
is available -->
<add key="eSyncEnabled" value="false"/>
</eSyncSettings>

3. Save.
l

The server has a sync relationship and its initial sync has been run.

Rules governing folder and content sync
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Content sync
l

You can only sync content whose status is Approved.

l

If you try to sync content, and its folder was created or modified since the last full
sync, you are warned that you must sync the folder before synching the content.
o An example of folder modification is the assignment of a new metadata value.

l

If new tags or taxonomy categories were added to content since the last full sync,
you must run a folder sync before you can sync that content. You must also run a
full sync for all other sync profiles that use those tags or taxonomy categories. See
also: Tagging content, library items, users, and groups with keywords on
page 1723.

l

Forum posts are not synched.

l

When you sync a content item, all physical files (DMS assets and library files) in the
content’s folder are also synchronized.

Folder sync
l

blogs and forum posts are not synched.

Synchronizing a content item
Content sync copies selected content to another server. The sync also copies all entities
on which the content is dependent, such as
l

library resources within the content, such as images and quicklinks

l

content selector metadata, file selector metadata, image selector metadata See
also: Creating and deploying a related content definition on page 830.

l

aliases

NOTE: When you sync one content item, all physical files (DMS assets and library
files) in the content’s folder are also synchronized.
See also: Synchronizing content and folders on page 1996.
To sync a content item:
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1. In the Workarea, go to the content.
2. Click the arrow to its right to see its drop-down menu.

3. Click Synchronize.
NOTE: Alternatively, use the Synchronize button on the View Content screen.

4. All profiles whose direction is Upload or Bidirectional appear. Select the
appropriate one.
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5. Click Sync Now. The content is synchronized with the selected database.
NOTE: If another sync is running, and you have enabled the eSync Queue, this
sync is queued and will be synched after all other syncs in the queue are run.
See also: Managing the eSync queue on page 2008.

Synchronizing a folder
The folder sync updates folder properties and all content in the folder with the same
folder in another server. It does not affect content in folders underneath the selected
folder. See also: Synchronizing content and folders on page 1996.
To sync a folder:
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1. Go to the folder.
2. Choose Action > Synchronize Folder. A screen asks you to select a sync profile.

3. Click Start Sync. All content in the folder is synchronized with the selected
database.
NOTE: If another sync is running, and you have enabled the eSync Queue, this
sync is queued and will be synched after all other syncs in the queue are run.
See also: Managing the eSync queue on page 2008.

Synchronizing custom SQL database tables
You can use eSync to synchronize custom SQL database tables. To do this, you must
create the custom table on all servers. eSync does not create the tables, but will follow
rules for populating records in them.
IMPORTANT: Table names, which are case sensitive, must be identical on all
servers.

Adding an empty custom table to your database on the
source and destination servers
Run the following SQL Query on the database. The table must have a primary key and
cannot use identity columns.
Here is an example of a valid table.
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Create table foo3(Id int not null primary key clustered,
Id2 int not null, company nvarchar(50) null)

Here are examples of invalid tables, which incorrectly use identity columns.
create table foo1(Id int not null identity(1,1) primary key clustered,
company nvarchar(50) null)
create table foo2(Id int not null primary key clustered,
Id2 bigint not null identity(1,1),
company nvarchar(50) null

Adding a custom table to an eSync configuration
NOTE: The Manage Custom Table Configuration button (
database has custom tables.

) appears only if your

To add custom tables to an eSync Configuration, follow these steps on the source
server.
1. Go to Workarea > Settings > Configuration > Synchronization > Profiles.
2. Click Manage Custom Table Configuration (
Configurations screen appears.

). The Manage Custom Table

3. Click Edit Custom Table Configuration.
4. Click a custom table from the Available column to select it.
5. Click the right arrow button to move it to the Selected column.
6. Click Save Custom Table Configuration.
After you add a custom table, your eSync profile displays a new Database/Resource
scope, Custom Tables. Select it to sync custom tables.
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Synchronizing a package
You can group Ektron objects (content, folders, taxonomies, and so on) into a package,
which can be synchronized at any time without having to run a complete sync.
Advantages of a sync package include:
l

Quicker than a full sync

l

More granular control over which items are synchronized

l

Can sync individual items even if their dependencies were modified
NOTE: As described in Prerequisites for content/folder sync on page 1997, a
content and folder sync has restrictions and dependencies. A sync package, on
the other hand, includes modifications to parent objects. So, a package can
sync content and folders whether or not a parent folder’s properties were edited
recently.

l

Can sync various object types in a single action

For example, you are developing a new marketing campaign which consists of content
in 2 folders, all library files in those folders, and 2 menus. After assembling the items
into a sync package, you can sync it from development to production at any time
without affecting other site files.
For a video tutorial on eSync packages, see eSync Packages (Ektron 8.6.1).
A package may include these objects.
l

Folders

l

Content

l

Library images and files

l

Files within the site root folder and its children (for example, .css and .js files)

l

Taxonomies. Includes all assigned categories, content, users, and groups

l

Menus. Includes submenus along with content assigned to any menu in the "tree"

l

Collections. Includes all assigned content

l

Other package definitions—. Do not include objects in those packages

Package sync limitations
301 redirects are not synchronized automatically with a package.
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Creating a package
PREREQUISITES
l

You are a member of the Administrators group or assigned to the
Synchronization Admin role.

1. Workarea > Settings > Configuration > Synchronization > Packages.
2. Click Create Package.
3. Enter a unique Name and optional Description.
4. Click the tab of objects you want to add to the package.

5. Check items to include in the package.
Notes on the packages screen
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l

An item is added to the package as soon as you check it. There is no submit button.
Click Save Package to save all items in a package.

l

To view a package's contents at any time, click the Package Contents tab.

l

When you view a tab, items in the package are checked.

l

The Package Contents tab lists all objects in the package. Use the Show dropdown to display only objects of a selected type.
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l

o

Use Delete ( ) to remove items. You can also remove an item by clicking its
tab and unchecking it there.

o

If you choose a taxonomy, menu, or collection, only the top-level object
appears on the Package Contents tab. However, all child objects (taxonomy
categories, submenus, and so on) and all assigned content, users and groups
are synchronized with the package.

Content and Folders tab lets you select folders or content within them.
IMPORTANT: You cannot select eCommerce catalog folders.

o

Unlike content sync, content status does not affect your ability to sync it within
a package.
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o

If you select a folder, the package includes its content in all languages at the
time the package sync is run.
n If you view a folder, its content is checked and grayed out. This indicates
that the package includes the folder's content.

o

Folder selection is not recursive. So, you must select each child folder.

l

Library tab lets you select library images or files. Do not choose those inserted
into selected content, since they are automatically included.
o All folder attributes (described in Content and Folders, above) apply to
library folders.

l

File System tab lets you select files within the siteroot folder and its children.
o Exception. You cannot add these file types to a package: thumbs.db, .cer,
.pfx, .pvk, .refresh, .ekt, .config, .dll, .exe, .metadata, .sln, .svn, .tekt, ._svn,
.log, metaconfig.doc. They do not appear in the selection grid.

l

Taxonomy tab lets you select top-level taxonomies only. You cannot select
categories within them. By selecting a taxonomy, you also add the following to the
package
o all categories below it
o

all content, users and groups assigned to the taxonomy and its categories

As a taxonomy's content changes, the package automatically includes the current
files.
NOTE: By adding a taxonomy to a package, you automatically select all
language versions of that taxonomy.
l
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Menus tab lets you select top-level menus only. You cannot select submenus. By
selecting a top-level menu, you also add to the package
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o

all of its submenus

o

all items assigned to the menu and its submenus: content, library assets,
hyperlinks, and additional submenus

As a menu's content changes, the package automatically includes the current files.
Folders assigned to menus are not synchronized with them. See also: Assigning a
folder or template to a menu on page 1345.
NOTE: By adding a menu to a package, you automatically select all language
versions of that menu.
l

Collections tab lets you select any collection. By selecting a collection, you also
add to the package all content assigned to it. As a collection's content changes, the
package automatically includes the current files.

l

Local Packages tab lets you include other package definitions in the package.
This lets you re-use the packages on other servers in your eSync relationship.
Other package definitions do not include objects assigned to them (content,
folders, and so on).

l

Orphan Items tab lists records referenced in a package which, for some reason,
are not in the database.

Synchronizing a package
To sync a package, add it to a sync profile, then sync the profile.
IMPORTANT: The package sync requires but does not validate identical folder
structure on both servers. You must verify matching folder structures on both
servers before beginning a package sync.
PREREQUISITES
l

One or more eSync packages. See also: Creating a package on
page 2004.

l

You are a member of the Administrators group or assigned to the
Synchronization Admin role.

1. From the View All Synchronization Configurations screen, click Add Sync Profile.
The Add Synchronization Profile screen appears.
2. In the Profile Type field, check Local Package.
3. Use the Select Package drop-down to choose the package.
4. Complete the remaining fields, which are documented in Setting up a profile to
Sync a database on page 1971.
5. Click Save Synchronization Profile.
6. From the View All Synchronization Configurations screen, click the profile.
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7. Click Sync Now (

).

NOTE: If another sync is running, and you have enabled the eSync Queue, this
sync is queued and will be synched after all other syncs in the queue are run.
See also: Managing the eSync queue below.

Deleting a package
PREREQUISITE
l

You are a member of the Administrators group or assigned to the
Synchronization Admin role.

1. Workarea > Settings > Configuration > Synchronization> Packages.
2. Click Delete in the right column of the package that you want to delete.

Managing the eSync queue
The eSync queue holds profiles waiting to be synched. A profile is added to the queue in
FIFO order (first in—first out) if a sync process is running when you try to sync a profile.
To view the eSync queue, go to Workarea > Settings > Configuration
> Synchronization > Queue. The queue screen lets you
l

view profiles in the queue, in order

l

view each profile's state (in process or ready)

l

remove profiles from the queue
NOTE: You cannot remove a profile whose state is "in process."

l

move profiles up or down in the queue

You can only view the eSync queue for the site to which you are logged in.
If you enable queuing for several sites on the same server, the eSync queue consumes
a significant amount of server resources. So, you should carefully consider hardware
resources when using the eSync queue in a hosted environment.

Enabling the eSync queue
To enable the eSync queue, open the following 2 files and change value of
EnableSyncQueue to true.
l

siteroot\web.config

l

C:\Program Files (x86)\Ektron\EktronWindowsService40\
Ektron.ASM.EktronServices40.exe.config

eSync queue tasks
2008
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Within the eSync queue, you can remove a profile or move it up or down (unless its
state is "In Process"). If you want to sync a removed profile at a later time, return to the
View All Synchronization Configurations screen and click Sync (

) again.

Viewing eSync activity
eSync provides the following logs of sync activity.

Viewing synchronization configurations
The View All Synchronization Configurations screen lets you perform the following
eSync-related activities.

l

Work with eSync relationships
o Create a new one See also: Setting up eSync on page 1927.
o

Run the initial sync for one See also: Initializing a new site on page 1933.
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l

l

o

View information about

o

Delete

Work with eSync profiles See also: Setting up eSync profiles on page 1969.
o Create
o

View and edit

o

Sync a profile See also: Running eSync on page 1991.

o

Delete

Review Resolved Collisions

Viewing a profile’s most recent sync
To view a log of a profile’s most recent sync:
1. Go to Workarea > Settings > Configuration > Synchronization > View All
Synchronization Configurations screen.
2. Click Get Status (

) next to the profile.

This button also appears on the View Profile screen.

Get Status (

) appears only for previously-synchronized profiles.

The sync log appears upon completing a sync (see following image).
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Viewing a log of a sync server relationship’s most

Viewing a log of a sync server relationship’s most recent
sync
You can view a log of a Sync Server Relationship’s most recent sync by clicking Get
Status (
) in the header section of the screen.

Viewing a log of all syncs for a sync server relationship
The View All Synchronization Relationships screen provides a Synchronization Logs
button ( ) that displays a chronological log of all syncs on your server, with the most
recent at the top.
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Click the icon in the Status column to view any sync's details. If the column contains a
check mark, the sync was successful.
If the column contains a warning ( ), the sync failed for some items. If you click the
icon, a screen lists causes for the failure. Ektron support can use this log to troubleshoot
the problem.
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Reviewing collisions
To verify the accuracy of data being synchronized, eSync may check for and resolve
collisions between the following matching items.
l

user names

l

folder names

l

metadata definitions

l

messages

l

eCommerce products

l

URL aliases

l

tag entries

l

tag statistics

l

taxonomy counts

l

eCommerce price entries
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l

multi-site staging URLs

l

menus

For example, on the staging server, a user creates a folder under the root folder called
Marketing, and a user on the production server does the same.
NOTE: * Folders only match if they have the same name and folder path.
* Ektron and membership users are included.
A collision only occurs if both items were created since the last synchronization.
Although matching items have different ID numbers, their names are the same, so
users may be unable to distinguish them. To avoid confusion, eSync appends a number
to the more recently-created item. For example, the Marketing folder becomes
Marketing11329. This is an example of a resolved collision.
To track resolved collisions, the View All Synchronization Configurations screen has a
button ( ) that appears only after a collision is resolved. If the eSync direction is
download, the collision resolution information appears on the local server; if upload, it
appears on the remote server; if bi-directional, it appears on both servers.

When you click the button, you are prompted to review resolved collisions. If you click
Resolve, the following button appears on the toolbar.

Click that button to see the Review Synchronization Collisions screen, showing the
original and changed items.

Reviewing resolved collisions
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The Review Synchronization Collisions screen shows resolved collisions. Upon viewing
it, you should notify appropriate content authors, who may want rename the items.

After noting these changes, you can check the box in the left column, then click Mark
Reviewed to remove it.
The Users tab has an additional button, Mark Reviewed and Email. Use it to remove
the user from the screen and send an email to the user (using the address from the
Add/Edit User screen’s E-Mail Address field).
lbl sync collision email subject = Your username has been changed
lbl sync collision email body = For security purposes, your username has been
changed.
Your new username is {0}. You will need to use this new username the next time
you login. Thank you.

NOTE: You can change the email text in the resource file. To learn about editing it,
see Translating the Workarea on page 1548.

Determining which collisions are resolved
On the eSync Settings screen, use the Types of data field to identify items for which
you want to resolve collisions. Unchecked items are ignored.
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Ektron recommends disabling the Resolve Collisions during Synchronization
boxes for everyday use, because resources required to search for collisions may
negatively impact your website's performance. When activity that might cause
collisions occurs, you may temporarily enable checkboxes. Then, disable them again
once the activity is complete.

Using performance counters to monitor the Ektron
Windows Service
You can use the Windows Performance Counter to view the progress of a file sync
without affecting the EWS's performance. You can also use the Performance Counter to
debug and monitor the EWS.
You can set up the Performance Counter to write to a file, so that you may monitor its
activity over a few days or weeks.
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Performance counter notes

The Performance Counter helps you monitor a sync's progress, especially if it has been
running for a long time. If the counter's values stop changing, nothing is happening.
This information can help you determine that it is safe to stop the service.

Performance counter notes
l

Most counters increment over time—they do not rise and fall.

l

Restarting the service resets the counters.

Performance counter display options
l

Line
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l

Histogram

l

Report

These performance counters are available.
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NOTE: Definitions:
Initiating Server. The server from which file sync is initiated (via the website).
Peer Server. The other server(s) in a sync relationship.
Ektron Windows Service data
l

EWS Approximate Total Number of Threads Alive Currently. if eSync is
running, at least one thread is alive

l

EWS Approximate Total Number of Timers Alive Currently. increases as the
number of scheduled syncs increases

l

EWS Database Write Operations Total. increases when the EWS inserts/
updates or deletes rows in a site’s database.

l

EWS Database Read Operations Total. increases when the EWS reads rows
from a site’s database.

l

EWS Exceptions Total. if eSync or load balancing exceptions occur while the
service is running, they increment the performance counter and appear on the
graph. A continual increase indicates a problem.

eSync data
l

eSync. Total Number of Remote WCF Calls Made from Service. increases
when the EWS makes network calls to other EWS instances on the network.

File Sync data
l

File Sync. Applying Changes (Total) on Initiating and Peer Servers.
incremented when a file change is about to be attempted

l

File Sync. Changes Applied (Total) on Initiating and Peer Servers. counter
is incremented when a file change is applied

l

File Sync. Changes Detected (Total) on Initiating and Peer Servers.
counter is incremented when a change detection pass is completed

l

File Sync. Changes Skipped (Total) from Initiating and Peer Servers.
eSync was supposed to do something but the action was skipped. This may occur
if, for example, a file is locked.

l

File Sync. Completed Work on Initiating Server. amount of work completed
out of total work to be done

l

File Sync. Conflicts Detected (Total) from Initiating and Peer Servers.
indicates conflicts between servers in a sync relationship. This number always
increases, never decreases unless someone restarts the EWS.

l

File Sync. Copying File (Total) on Initiating and Peer Servers. incremented
periodically to show progress while a file is being copied

l

File Sync. Detecting Changes (Total) on Initiating and Peer Servers.
incremented for every directory , including the root directory, during a change
detection pass. This is incremented before change detection begins for that folder.
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l

File Sync. File Download Requests (Total) on Peer Server. total number of
download requests

l

File Sync. Files Skipped Change Detection (Total) from Initiating and
Peer Servers. eSync was supposed to do something but the action was skipped.
This may occur if, for example, a file is locked

l

File Sync. File Upload Calls (Total) from Initiating Server. indicates the
total number of upload calls from the initiating server to the remote EWS server

l

File Sync. File Upload Requests (Total) on Peer Server. total number of
upload requests received on the peer server

l

File Sync. File Upload Preview Calls (Total) from Initiating Server. total
number of upload preview calls made from the initiating server

l

File Sync. Temporary Files Deleted Total. total number of temporary files
deleted by EWS so far. This number should never be zero (0) on the destination
server while a sync is running.

l

File Sync. Total Work on Initiating Server. total work to be done by file sync

Setting up the performance counter display
To set up the display of the Ektron Windows Service performance counter:
1. Click the Windows Start button > Administrative Tools > Performance
Monitor.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
perfmon.msc. Right click and choose Run as Administrator.
2. Click Add (

).

3. In the upper left corner, click Ektron Windows Service - Performance
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Counter, then Add and OK.

Sync status email notification
Provides email notifications when the following important sync events occur.
l

A sync goes longer than a specified duration.

l

A sync fails.

l

A sync completes.

In the screen settings, you determine which events trigger an email notification.
To use this feature:
1. Go to Settings > Configuration > Synchronization > Settings page.
2. Set the values:

l

Sync(s) running longer than (minutes). Specify the number of minutes
before sending an email notification .
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l

FE Sync failure(s). Enable if you want an email notification to be sent if an
FE sync failure occurs.

l

All completed sync(s). Enable if you want an email notification to be sent
when a sync completes.

l

Recipient email addresses. Specify the email addresses of notification
recipients.
NOTE: Separate email addresses with a comma (,).

3. Open Ektron.ASM.EktronServices40.exe.config file.
4. Find following entry keys. Here, set the SMTP information for sending email.
<add
<add
<add
<add
<add
<add

key="CEIPSmtpServer" value="ektexch01" />
key="CEIPKey" value="" />
key="CEIPSmtpUserName" value="your-ID" />
key="CEIPSmtpPassword" value="************" />
key="CEIPSmtpEnableSSL" value="false" />
key="CEIPSmtpPortNo" value="25" />

Using eSync with other Ektron features
eSync in a load-balanced environment
Ektron supports a load-balanced environment, in which several servers share your
website’s processing load. See Balancing the load on your servers on page 99.
If your site uses load balancing, you can set up eSync so that, after one server in a load
balance cluster is synchronized, the other servers are automatically synchronized. Note
that if a separate database server is outside the load balance cluster, eSync only
synchronizes documents and files used by the search among the clustered servers. It
does not touch the database.
Beginning with Ektron version 8.5, the load-balance chain of servers is updated
automatically, and servers that are not available are removed. The following illustration
shows a typical load balanced cluster.
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IMPORTANT: In a load balanced environment, only update templates on the
staging server. Do not update them on the production server and assume they will
be synchronized with the staging server.
IMPORTANT: Assume your load balanced cluster consists of 2 staging servers (S1
and S2) and 2 production servers (P1 and P2).
If you add/modify/delete a file on S1, to get the file to S2, you must run either a
download sync on S2, or an upload sync on S1, or a bidirectional sync from either
server. If you run a download sync on S2, you also need to run an upload sync to
push the file to P2, which will then Load Balance with P1.
The best way to make sure that the added/modified/deleted file is changed on all
servers is to initiate the sync from the server on which the file was changed. In this
example, since you changed the file on S1, if you initiate a sync from S1, it will be
automatically updated on S2, P1, and P2.
PREREQUISITES
l

The connection string on all servers in the cluster matches

l

You must initiate eSync relationships and the sync from a staging server

l

If your staging servers are clustered, you must remove one from the
cluster before you can sync

Follow these steps to set up this capability.

Install a min site on every server in the cluster
1. Upgrade each server to the same version of Ektron. If Ektron is already installed on
one server, install a minimum site on the others. To do this, run the Ektron base
installation file (cms400Base9x.exe). See also: Installing the Ektron base on
page 13.
2. If the site with which you will sync is precompiled, precompile all min sites.
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Update Assetmanagement.config
1. Sign on to the first server in your load balanced cluster.
2. In the site root folder, open assetmanagement.config.
3. Change the value of LoadBalanced to 1 and save.
4. Do this on every server in the cluster.

Update the Ektron Windows Service config file
1. Sign on to the first server in your load balanced cluster.
2. Open C:\ProgramFiles
(x86)\Ektron\EktronWindowsService40\Ektron.ASM.EktronServices40.exe.
Config.
3. Change the value of LoadBalanced to 1.
4. Change the value of AssetsLoadBalanced to 1.
5. Change the value of LibraryLoadBalancedto 1.
6. Save the file.
7. Do this on every server in the cluster.
8. Stop and then Start the Ektron Windows Service on every server in the cluster.

Create eSync security certificates for a load-balanced cluster
You should be familiar with eSync security certificates before beginning this procedure.
See also: Managing eSync security certificates on page 1979.
Assume the load balance cluster has 3 servers: mach1, mach2, and mach3.

Part one: Generate security certificates
In this part, create the security certificates.
1. Sign on to mach1 using an account with administrative privileges and generate
security certificates. To do this, click the Windows Start button > All programs >
Ektron > CMS400 v9x > Utilities > Security Configurator > right click and
choose Run as Administrator.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
2. The security configurator screen appears. See Managing eSync security certificates
on page 1979. Select the Generate Certificates radio button. Click the Generate
button then click OK when the Ektron Windows Service’s warning dialog appears.
This action creates security certificates for your server and applies them to all the
sites on the server. Optionally, you can select a single site from the Web Site
Description drop-down to install certificates to a selected site.
3. Create a new folder (for example, mach1_certitificates) on the desktop.
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4. Open the following folder:
C:\ProgramFiles\Ektron\CMS400vxx\Utilities\SecurityConfig\SecurityCo
nfigurator.
5. Copy the following files from the SecurityConfigurator folder into the folder you
created in Step 3.
l mach1_SyncClient.pfx
l

mach1_SyncClient.pvk

l

mach1_SyncClient.cer

l

mach1_SyncServer.pfx

l

mach1_SyncServer.pvk

l

mach1_SyncServer.cer

6. Repeat steps 1 to 5 for every server in your load balance cluster.

Part Two: Apply security certificates
In this part, copy then apply the certificates to all other servers in the cluster.
1. Copy each server's certificates folder to the other servers in the cluster.
2. Run the Security Configurator (Start button > All programs > Ektron >
CMS400 v9x > Utilities > Security Configurator) and apply the certificates
from every other server in the cluster.
If you're using Windows 8 or 2012, press the Windows key ( )/Q then enter
Security Configurator. Right click and choose Run as Administrator.
For example, apply certificates from mach2 and mach3 on mach1; and apply
certificates from mach1 and mach3 on mach2.
To apply certificates, follow these steps.

Ektron Reference

2025

Synchronizing servers using eSync

a. Select the Apply Remote Server Certificates radio button.

b. Click the browse button next to that field.
c. Browse to the remote server’s certificates folder (which you copied in Step 1).
d. Click the Apply button. Then, click OK when the Ektron Windows Service
warning dialog appears.
e. Repeat the above steps for all remote server certificate folders.
f. Repeat steps on every server in the load balance cluster.

Set up and run eSync
Once load balanced servers are configured to sync assets, configure eSync as normal
between your staging server and one production server. When you sync with the
production sever, the Load Balance feature pushes those files to the other servers in the
LB configuration.

Using eSync in a multi-site environment
If you want to use eSync in a multi-site environment, you must do so before the initial
synchronization of a relationship. That is, you cannot set up a eSync relationship in a
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single-site environment and then later change to multi-site. You can set up a new
relationship at any time. See also: Supporting multi-site configurations on page 91.
Limitations on using eSync in a multi-site environment
l

In a multi-site environment, you cannot create a staging site from a production site
(as described in Initializing a new site on page 1933). You must first create all sites
on the staging server, then set up production sites with which they sync.

l

You should log into the main site then synchronizing it and all multi-sites from
there.

Setting up eSync in a multi-site environment
WARNING! Back up your database before beginning this procedure!
1. Set up all sites on the staging server, following the instructions in Supporting
multi-site configurations on page 91.
2. Install an Ektron min site on each production server that will host a site. To do this,
run the Ektron base installation file.
3. Install security certificates between the staging server and all production servers.
This procedure is described in Managing eSync security certificates on page 1979.
4. Sign on to the staging server.
5. In the Workarea, go to Settings > Configuration > Synchronization >
Profiles.
6. The View All Synchronization Configurations screen appears. Click Create
Synchronization Server Configuration. The screen appears.

NOTE: If you see the following error, The system cannot find the file
specified, you must set up security certificates. See also: Managing eSync
security certificates on page 1979.
7. Use the following information to complete the screen.
WARNING! The first time you sync an Ektron website, all of its data is
overwritten. Make sure that no important information resides on the production
server before beginning the first sync.
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8. Remote Server. Select a production server by choosing the path to the site’s
physical location on the remote server.
9. Choose Certificate. If you selected a single server above, its name appears here.
Proceed to the next step.
If you selected a domain or IP address above, click the drop-down arrow to view all
servers whose client security certificates reside on this server. Then, select the
server with which you want to set up an eSync relationship.
10. Click Connect. After you connect to the production server, all eligible databases on
it appear. The top one has a green check mark, indicating it is selected by default.

11. Click the database with which you want to sync. When you do, a green check mark
appears on it, and its background color changes.
12. Click Next.
13. A new screen appears, showing both servers and allowing you to change the
direction of the initial database copy. Make sure you are copying from staging to
production. Because the staging server is multi-site, the staging server area has a
Site Path pulldown field, which lets you select a site.
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14. When you are satisfied, click Create. This sets up the server relationship but does
not launch the initial sync.
15. The View All Synchronization Configurations screen appears with the new
relationship. If you are ready to overwrite the production database with the staging
one, click Start Initial Sync (

).

16. A screen monitors the sync’s progress.
17. The initial sync creates a default profile, which appears on the View All
Synchronization Configurations screen.
18. Set up and launch sync profiles to sync Workarea files and templates on the
staging server with those on the production server. (This is described in Setting up
eSync profiles on page 1969 and Running eSync on page 1991.) For
synchronization direction, choose Running eSync on page 1991.

Setting up staging multi-sites
By default, if you sign on to a staging server then insert library items (images,
quicklinks, and so on) into content, the path to those items includes the production
server. For example, your server setup includes 2 multi-sites: sales.ektron.com and
support.ektron.com.
NOTE: Multi-site names are defined in the site’s folder properties screen’s
Production Domain field, as described in Supporting multi-site configurations on
page 91.

Ektron Reference

2029

Synchronizing servers using eSync

So, library links in the sales.ektron.com site’s content look like this:
http://sales.ektron.com/template?id=id number. However, you may wish to
change library links so they refer to the staging server. This would help you verify that
the linked items exist on it.
To change library links to refer to your staging server:
1. Go to Settings > Configuration > Setup.
2. Click Edit.
3. Check the Staging Server checkbox.
4. Click Update.
5. Go to Content > the staging site folder.
6. Choose View > Properties.
7. Click Edit Properties.
8. Scroll down to the section labeled Multi-Site Domain Configuration:
9. In the Staging Domain field, enter the URL of your staging server.
10. Click Update.
From now on, when a user signs on to the staging server and works with library links,
the links include the staging server instead of the production server.

Using eSync with Web Alerts
The Web Alert feature enables Ektron to generate email for a list of registered users
whenever content is created or updated. See also: Sending Web Alert emails to
subscribers on page 1481.
In an eSync environment, you need to determine which servers send Web Alerts. For
example, Web Alerts should probably not be generated when content is published on a
staging server, but you would want them when content is published on a production
server.
To determine if a server generates Web alerts, use the following property of each
website’s web.config file.
<add key="ek_DisableWebAlerts" ..... />

Set the property’s value to true to suppress Web Alerts on a server.
Set the property’s value to false to generate Web Alerts to on a server.
Also, the server clock on the download side of the eSync relationship must be exactly
the same time as or slightly ahead of the clock on the sending server.

Using eSync with eCommerce
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IMPORTANT: Ektron has discontinued new development on its eCommerce
module. If you have a license to eCommerce, you will continue to receive support,
but if you need to upgrade, contact your account manager for options.
When using eSync with an eCommerce site, you need to prevent orders from being
processed on your staging server to prevent orders from being processed twice.
For example, a customer on your production site purchases a product. If the staging
server and production server are synchronized before the credit card is processed, it
might be charged twice: once from the production server and again from the staging
server.
To prevent orders from being processed on your staging server, edit your staging site’s
web.config file and set the following property to true:
<add key="ek_ecom_OrderProcessingDisabled" value="true" />

When the property is set to true, you cannot process or edit orders from the Workarea’s
View Order screen on the staging server. Also, if you try to create an order from the
staging server’s website, you receive the following message.
“We're sorry, an error occurred while processing your request. Please try again later...”
It is important to note that all other eSync functions still work properly. For example,
when you create catalog entries on a staging server and perform a sync, the entries are
moved to the production server. The ek_ecom_OrderProcessingDisabled key only
affects order processing.

Using eSync with notifications
When using eSync with notifications, new agents are not synchronized. This means that
you must manually add new agents to each server in your relationship.
When an agent exists on all servers in your relationship, eSync keeps them updated.
For example, assume a membership user logs into the production server and updates
the profile’s Activities tab by changing the activities a custom agent will perform.
eSync will sync those changes with the staging server.
See also: Adding a custom agent on page 1673; Sending notifications to a community
on page 1665.

Running Ektron 8.5 and Ektron 9.10 SP3 eSync
If you install an Ektron 9.10 SP3 site to a server that is also running an Ektron 8.5
version, the Ektron 9.10 SP3 Windows Service (EWS) replaces the 8.5 version. Also,
the dbSync.config file was removed for Ektron 9.10 SP3. To manage settings you
previously configured in dbsync.config file, run the following script.
IF(NOT EXISTS(SELECT NAME FROM SYS.OBJECTS WHERE (NAME='sync_settings') AND (type='u')))
begin
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create table [dbo].[sync_settings]
(
profile_id bigint not null,
memory_data_cache_size int not null default (32768),
remote_sql_connection tinyint not null default(2),
application_tran_size bigint not null default (0),
script_encryption bit not null default (0),
collision_action bigint not null default(0),
backup_action tinyint not null default(0),
backup_device nvarchar(max) null,
log_retain_count int not null default(50),
CONSTRAINT [PK_sync_settings] PRIMARY KEY CLUSTERED (profile_id)
)
end
go
if(not(exists(select 1 from sync_settings where profile_id=0)))
begin
insert into sync_settings(profile_id)values(0)
end
go

The following list describes some lines in the script.
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l

memory_data_cache_size int not null default (32768). Define a maximum
amount of memory that your server uses during a sync. The default is 32 MB. You
can change it to any size up to the amount of RAM in your eSync server.

l

remote_sql_connection tinyint not null default(2). 0-direct; 1-proxy; 2autodetect
o autodetect is generally the best solution

l

application_tran_size bigint not null default(0). if changes are
expected in multiple batches, set this value to memory_data_cache_size

l

collision_action bigint not null default(0). The value of the Resolved
Collisions during Synchronization field, which specifies types of data for which
collisions will be resolved. See also: Determining which collisions are resolved on
page 2015.
o 0=NONE
o

1=USER

o

2=FOLDERS

o

4=METADATA

o

8=EMAIL MESSAGE

o

16=URL ALIAS

o

32=TAG ENTRIES

o

64=STATISTICS ON TAG

o

128=TAG REGENERATION

o

256=TAXONOMY COUNTS
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o

512=PRICE ENTRIES

o

1024=MULTISITE STAGING URL

o

2048=MENU

l

backup_action tinyint not null default(0). 1-backup always; 2-backup
only before initial sync; determines when to back up destination database before a
sync

l

backup_device nvarchar(max) null—backup location

l

log_retain_count int not null default(50). set the number of logs
retained in the database.

Troubleshooting eSync
Problem: Sync not working with custom table
You created a custom table and try to sync it to the destination server, but eSync does
not synchronize the source and destination servers.
Solution: As stated in Synchronizing custom SQL database tables on page 2001, you
must create the custom table on all servers. eSync does not create the tables, but will
follow rules for populating records in them.
Problem: Synchronization has failed
There was no endpoint listening at
http://alphatest:8732/
Ektron.Sync.Communication/SyncCommunicationScheduleService.svc that could
accept the message. This is often caused by an incorrect address or SOAP action. See
InnerException, if present, for more details.
One server in the relationship cannot resolve the address of the other server. This may
be due to security restrictions or because the Ektron Windows Service (EWS) is off.
Solutions:
l

Modify the hostname of the other server so that it can be found.

l

Restart EWS

l

Reconfigure security

Problem: The identity check failed for the outgoing message. The expected identity is
xxx for the xxx target endpoint.
Local site cannot communicate with service.
Solution:
1. Load the security Configuration utility:
C:\Program Files
(x86)\Ektron\CMS400vxx\utilities\SecurityConfig\SecurityConfigurator
\securityconfigurator.exe.
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2. Select the website that is failing.
3. Click OK. This recopies client certificates to the site and updates web.config to use
them.
Problem: No viable CMS sites were found on the remote server specified. Please check
the remote server and try again.
No Ektron site exists on the remote server.
Possible Solution: Install an Ektron min site on the remote server.

Using eSync strategies
eSync Strategies are described in CMS Strategies. These strategies let you plug into the
EWS , so developers can implement functionality like sync notifications, data
modifications, and cache invalidation.

Design goals
The strategies' design goals explain the intent and functionality available through the
API.
l

The API is as similar as possible to the framework API.

l

Events are synchronous.

l

The API classes are decoupled from the internal implementation.

l

Events may be canceled.

l

Sample strategies are provided with the EWS.

l

Documentation is embedded within the code.

l

Strategies have minimal impact on eSync stability, scalability, and performance.

l

The data transform strategy, which has some performance penalty, is activated
only when it is implemented (to prevent undue performance impact).

l

You cannot break eSync by modifying parameters which do not make sense to be
modified via an API. Not all properties are writable.

l

Errors in the strategies do not crash the EWS.

l

The website progress always shows strategy execution details.

Limitations
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l

The API does not isolate events when multiple sites exist on the same server in a
co-located scenario.

l

Parameter changes cannot be propagated back to eSync from peer events.

l

Peer events are not available for load balancer strategies.

l

Whenever new strategies are registered, restart the EWS .
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l

Data transform strategy notes.
o Data transform strategy cannot modify deleted rows. See also:
ESyncDataTransformStrategy on page 2044.
o

Changes to detached or unchanged (DataRow state) rows do not propagate
back in the data transform strategy.

o

eSync parameter changes in the data transform strategy do not affect or
modify eSync.

o

Not all eSync parameters are available to the data transform strategy.

Tips for working with eSync strategies
l

Enable the sample strategy in the out-of-the-box ObjectFactory.config file
(C\Program Files
(x86)\Ektron\CMS400v
versionnumber
\Utilities\EWSUpdates\EktronWindowsService40\ObjectFactory.config).
After you do, each event is logged to the event viewer. Review the event viewer to
learn the order in which events fire.

l

eSync strategies run in the context of the EWS, as opposed to a site. So, by
default, strategies run for every eSync on a server, whether the sync is incoming or
outgoing. To restrict a strategy to certain syncs and sites, use validation. For an
example, see Notification strategy example on page 2038.

l

Tips for creating .dll files.
1. With the project open in Visual Studio:
a. Open Solution Explorer.
b. Right-click your project.
c. Choose Properties.
d. Set the Target Framework to .NET Framework 4.5.
IMPORTANT: The following .dlls require .NET 4.5.
2. Add references to Ektron Windows Services/Ektron.Cms.Contracts.dll
and Ektron.Cms.ObjectFactory.dll.
3. Add these namespaces:
using Ektron.Cms.Extensibility;
using Ektron.Cms.CoreService;

l

After you create .dll files, place them in the C\Program Files
(x86)\Ektron\CMS400v
releasenumber\Utilities\EWSUpdates\EktronWindowsService40 folder. Then,
when adding project references, reference .dlls in that folder, not .dlls in the site
folder.
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l

Stop the EWS before building the project. Otherwise, Ektron locks the .dll. So the
process is:
1. Stop EWS.
2. Build the project.
3. Move .dlls into the EWS folder.
4. Start EWS.
It may take 30-60 seconds to start the EWS with the new .dll. To know when EWS
has started, open the Event Viewer\Applications and Services Logs folder and
monitor the EktronL4 log. There are 2 messages:
o

Service initialized successfully. you've told EWS to start.

o

Service started successfully. only begin a new sync to test the latest build
after you see this message.

Events
The basic events are
l
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APIStrategy: ESyncNotificationStrategy See also:
ESyncNotificationStrategy on the facing page
o Local Database Sync Run Start. API Event Name:
OnAfterDatabaseSyncRunStartFromLocal
o

Local Database Sync Run Completed. API Event Name:
OnAfterDatabaseSyncRunCompleteFromLocal

o

Local Database Sync Run Error. API Event Name:
OnAfterDatabaseSyncRunErrorFromLocal

o

Local Folder Sync Run Start. API Event Name:
OnAfterFolderSyncRunStartFromLocal

o

Local Folder Sync Run Completed. API Event Name:
OnAfterFolderSyncRunCompleteFromLocal

o

Local Folder Sync Run Error. API Event Name:
OnAfterFolderSyncRunErrorFromLocal

o

Local Esync Run Start. API Event Name: OnAfterESyncRunStartFromLocal

o

Local Esync Run Completed. API Event Name:
OnAfterESyncRunCompleteFromLocal

o

Local Esync Run Error. API Event Name: OnAfterESyncRunErrorFromLocal

o

Peer Esync Run Start. API Event Name: OnAfterESyncRunStartFromPeer

o

Peer Esync Run Completed. API Event Name:
OnAfterESyncRunCompleteFromPeer

o

Peer Esync Run Error. API Event Name: OnAfterESyncRunErrorFromPeer

o

Peer Database Sync Run Start. API Event Name:
OnAfterDatabaseSyncRunStartFromPeer
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l

l

o

Peer Database Sync Run Completed. API Event Name:
OnAfterDatabaseSyncRunCompleteFromPeer

o

Peer Database Sync Run Error. API Event Name:
OnAfterDatabaseSyncRunErrorFromPeer

o

Peer Folder Sync Run Start. API Event Name:
OnAfterFolderSyncRunStartFromPeer

o

Peer Folder Sync Run Completed. API Event Name:
OnAfterFolderSyncRunCompleteFromPeer

o

Peer Folder Sync Run Error. API Event Name:
OnAfterFolderSyncRunErrorFromPeer

o

Local Database Sync Progress. API Event Name:
OnLocalDatabaseSyncProgress

o

Local File Sync Progress. API Event Name: OnLocalFileSyncProgress

o

Peer Database Sync Progress. API Event Name: OnPeerDatabaseSyncProgress

o

Peer File Sync Progress. API Event Name: OnPeerFileSyncProgress

APIStrategy: LoadBalancerStrategy See also:
LoadBalancerNotificationStrategy on page 2044
o Load Balance Run Start. OnAfterRunStart
o

Load Balance Run Completed. OnAfterRunComplete

o

Load Balance Run Error. OnAfterRunError

APIStrategy: ESyncDataTransformStrategy See also:
ESyncDataTransformStrategy on page 2044
o

Row synchronized during eSync. OnAfterDataRowSelected

ESyncNotificationStrategy
This is an abstract class, since it has no default functionality.
The eSync Notification strategy lets me detect events, such as when a database sync is
completed.
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There are two sets of methods: “FromLocal” and “FromPeer”.
l

FromLocal is called by the EWS, which manages eSync; it refers to the service on
the same server as the site from which the eSync call was made.

l

FromPeer methods are raised on the peer server, which may receive or send data.
These methods are called when EWS makes a WCF call to the peer EWS which, in
turn, raises this event. Note that, unless otherwise mentioned, the “FromPeer”
method is analogous to the “FromLocal” method raised on the peer server.

Notification strategy example
Comments on this sample notification strategy follow the example.
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Diagnostics;
using Ektron.Cms.Extensibility;
using Ektron.Cms.CoreService;
namespace ProcessTaxonomy
{
public class WriteToXml : ESyncNotificationStrategy
{
public override void OnAfterDatabaseSyncRunCompleteFromPeer(PeerServerDetails
peerDetails, SyncProfile syncProfileData)
{
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if (syncProfileData.RemoteSiteConfig.SitePath.ToLower().StartsWith
(@"c:\inetpub\syncreceiver") && (syncProfileData.SyncConfig.Direction ==
SyncDirection.Upload || syncProfileData.SyncConfig.Direction ==
SyncDirection.BiDirectional))
{
WriteTaxonomyToXml();
}
}
public void WriteTaxonomyToXml()
{
string path =
@"C:\inetpub\ConsoleApps\CreateTaxonomyXML\CreateTaxonomyXML\bin\Debug\CreateTaxonomyXM
L.exe";
Process proc = new Process();
proc.StartInfo = new ProcessStartInfo(path, "");
if (!IsProcessOpen("CreateTaxonomyXML"))
{
try
{
proc.Start();
EventLog.WriteEntry("CreateTaxonomyXml - Start",
proc.StartTime.ToString(), EventLogEntryType.Information);
proc.WaitForExit();
EventLog.WriteEntry("CreateTaxonomyXml - End", proc.ExitTime.ToString
(), EventLogEntryType.Information);
}
catch (Exception ex)
{
EventLog.WriteEntry("CreateTaxonomyXml - Error", ex.Message,
EventLogEntryType.Error);
}
}
else
{
EventLog.WriteEntry("CreateTaxonomyXml - Info", "Process already
running.", EventLogEntryType.Information);
}
}
public bool IsProcessOpen(string name)
{
try
{
var procs = Process.GetProcessesByName("CreateTaxonomyXML");
if (procs.Any())
return true;
}
catch (Exception ex)
{
EventLog.WriteEntry("CreateTaxonomyXml - Warning", "Error finding
process.", EventLogEntryType.Warning);
return false;
}

Ektron Reference

2039

Synchronizing servers using eSync

return false;
}
}
}

1. The following code overrides a method that is triggered after a database sync
completes. This example runs immediately upon completing the DB sync, even if
the sync has other tasks to complete, such as a file sync.
public override void
OnAfterDatabaseSyncRunCompleteFromPeer(PeerServerDetails
peerDetails, SyncProfile syncProfileData)

2. The following conditional validates that the sync runs only for the desired site and
direction. This example runs only if a certain site receives data, either through an
upload or bidirectional sync. The sitepath distinguishes this site from others on the
server. Alternatively, you can check for a DB name in the connection string, as
shown in the following example.
(syncProfileData.RemoteSiteConfig.SitePath.ToLower()
.StartsWith(@"c:\inetpub\syncreceiver")
&& (syncProfileData.SyncConfig.Direction
== SyncDirection.Upload
|| syncProfileData.SyncConfig.Direction
== SyncDirection.BiDirectional))
{
WriteTaxonomyToXml();
}

3. The following strategy executes a companion console application whenever a
database sync is completed. Here is the local path to the console application.
string path =
@"C:\inetpub\ConsoleApps\CreateTaxonomyXML\CreateTaxonomyXML\bin\Debug\CreateTaxono
myXML.exe";

4. The following standard .NET code executes a console application. Remember that
your EWS user (often Local System) must have execute permission for the
application.
proc = new Process();

5. Specify that you want to start the process at the following path. No arguments are
used.
proc.StartInfo = new ProcessStartInfo(path, "");

6. Check if the process is already running.
(!IsProcessOpen("CreateTaxonomyXML"))
{
try
{
proc.Start();

7. The following code gets the process name above. It must be run after the process
starts.
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EventLog.WriteEntry("Process Name", proc.ProcessName,
EventLogEntryType.Information);

NOTE: EventLog.WriteEntry methods write to the Event Viewer's Application
log, not the EWS log.
8. Log the process' start time.
EventLog.WriteEntry("CreateTaxonomyXml - Start",
proc.StartTime.ToString(),
EventLogEntryType.Information);

9. Wait for the process to end, to determine how long it takes to run the process.
proc.WaitForExit();

10. Log the process' end time.
EventLog.WriteEntry("CreateTaxonomyXml - End",
proc.ExitTime.ToString(),
EventLogEntryType.Information);

SyncProfile class
SyncProfile is the basic parameter class for eSync strategies. Its properties are neatly
categorized and have self-documenting names.

SyncSpecificDetails class
The SyncSpecificDetails class contains all sync details for a sync type (such as
template, folder, content, or package sync).
All properties of regular, profiled syncs are in the SyncProfile class. The
SyncSpecificDetails class is for extra properties that are only present in a specific
sync type.
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SyncProfile class
SyncProfile is the basic parameter class for eSync strategies. Its properties are neatly
categorized and have self-documenting names.
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SyncSpecificDetails class
The SyncSpecificDetails class contains all sync details for a sync type (such as
template, folder, content, or package sync).
All properties of regular, profiled syncs are in the SyncProfile class. The
SyncSpecificDetails class is for extra properties that are only present in a specific
sync type.
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ESyncDataTransformStrategy
This strategy lets you plug into database sync and modify columns within the records
being synchronized. Addition or deletion of records is not supported.

Only one method is called per record for each table that will be synchronized.

The SyncDataRowContext class provides context about the row being sent in the event.
The class is used in the sample strategy to make it easier to perform data row actions.

LoadBalancerNotificationStrategy
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This strategy provides a mechanism to get notified about local load balancer events. It
provides comprehensive information about them.
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Implementing strategies within the Ektron Windows
Service
The EWS includes a sample strategy that writes to the event log on the sending and
receiving servers.
Internal classes used by the EWS are not exposed via the API. All API classes are
present along with the rest of the CMS API classes in the Ektron.Cms.Contracts
assembly.
Internal EWS classes are, however, converted into API classes. By decoupling the API
from the EWS classes, the API cannot be changed inadvertently as Ektron changes the
EWS. The decoupling also ensures that the API is more developer-friendly, usable, and
self-documenting.
Strategies are raised only when they are configured to be raised in the
objectFactory.config file, within the EWS root folder. The following image files are
modified for strategy implementation.
l

app.config

l

ektron.cms.framework.unity.config

l

objectFactory.config

Define a strategy within the objectFactory.config file, as shown in the following image.

The ESyncStrategyLocalHandler class executes local strategies one by one, logging
any errors. The class also makes a WCF call to the remote EWS to execute strategy
there.
The peer server strategy contains a PeerServerDetails parameter that lets you
determine which server sent the request. On the remote server, the strategy execution
is straightforward, as shown in the following example.
The sample strategy shows records in the system event log, as shown in the following
example. These records clarify the order in which events fire on the local server.

The remote server shows peer events.
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Database events raised on the peer server also appear.

Progress events for database and file sync
Progress events provided for database and file sync let you track a sync operation's
progress. These events have both local and peer methods, because all types of Ektron
Sync have two sync orchestrators: one runs on the initiating server, and the other runs
on the peer server. Since progress is reported by both orchestrators, both are exposed
by the API.
The quality of information provided by the local/peer event is determined by the sync
direction and the initiating server. So, some properties may not be available in one
method or the other.

Load-balancer events
Load-Balancer events are exposed via a separate
LoadBalancerNotificationStrategy on page 2044, which provides information
through the API about what is being synchronized to which server. This strategy
provides extensive information about the load balancer, and is useful to end users.
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Chapter 38

Viewing network server
diagnostics
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Ektron's diagnostics utility provides the following comprehensive information about
your network's servers that are related to the website to which you are logged on. (An
Ektron network consists of your Ektron server, connected database servers, and other
servers with which your website has an eSyncor Load Balancerelationship.)
l

status of all services

l

version information for Windows, SQL, IIS, Visual Studio, and so on

l

event log

l

database connection status, test query, server, and so on

l

for each server: drive capacity and available space; available memory, and so on

l

eSync information, such as remote certificates for this server

NOTE: Most diagnostics fields are read-only but the utility lets you perform a few
actions.
The following video link provides additional information about the diagnostics utility:
The Making of Ektron eSync Diagnostics.
The following list shows how the diagnostic utility works:
1. The diagnostics utility uses Workarea Web services that is installed to the Ektron
server. This service runs independently of the Ektron Windows Service and your
Ektron website.
2. That Web service routes requests to the Ektron Diagnostics Service.
3. The Ektron Diagnostics Service collects diagnostic information from the database,
website files, and other locations like the event log. It also scans for other known
Web servers (eSync servers, load balance servers, and multi-site servers).
4. If any other servers are found, the Diagnostics Windows Service opens a
connection to the destination server's Diagnostics service. The Diagnostics Service
uses the same port as the Ektron Windows service.
5. The Ektron Diagnostics Service returns the collected data to the Silverlight viewer,
which dynamically builds the network that appears on the screen.

Installing the diagnostics utility
You should install the utility to every website and server in your Ektron network. This
includes Ektron Web servers, as well as servers used in Load Balance and eSync
configurations. You do not need to install the utility on client workstations.
You can install the diagnostics utility as a site option during the installation or upgrade
of Ektron (see Diagnostic Utility checkbox).
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If Diagnostic Utility was not checked during installation, you can install it by going to
Windows Start button > All Programs > Ektron > CMS400vxx > Utilities >
Ektron Diagnostic Utility.
The diagnostics utility installs the following files on each server.
l

web.config file additions

l

the Ektron Diagnostics Windows service

NOTE: If the diagnostics utility is not installed on a server, a node for that server
appears, but information about it is not available in the lower section of the screen,
and additional relationships are not visible.
For example, you have an eSync relationship between development and staging
servers, and between staging and production servers. If the diagnostics utility is
installed on the development server but not on staging, and you view the network
from the development Workarea, you see nodes for development and staging, but
not production. You can view details for development, but not staging.

Running the diagnostics utility
PREREQUISITES
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l

You are a member of the Ektron Administrator's group

l

The diagnostics utility was installed on every server with which your
website has an eSync or Load Balance relationship

l

The diagnostics utility requires Silverlight 4. If a client does not have it,
you are prompted to install it before you can view the screen.

To access the diagnostics utility, go to Workarea > Settings > Configuration >
Diagnostics. The Diagnostics screen consists Ektron network nodes connected by lines
that indicate relationships. Use the slider on the right side to adjust the zoom level.

You may drag the nodes around for easier viewing.

Connecting lines on the diagnostics screen
A connecting line's color indicates the type of relationship that exists between nodes.
l

Blue. eSync
The arrowhead direction indicates the direction of the profiles. For example:

l

o

no arrowheads. no profiles

o

2 arrowheads. one upload and one download profile exists between servers

Red. Database server
Appears even if the database resides on the same server with Ektron.
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l

Green. Load balance

l

Teal. Multi-site
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Network node icons
The following icons may appear in a network node.

l

Analysis. Reports server's installed memory, available memory, and available
disk space. Click the icon for more information. See also: Analyzing system
memory and disk space on the next page

l

Bandwidth test. Reports speed of server's connections. Click the icon for
more information. Testing bandwidth below

l

Refresh. For selected node, load or reload Viewing diagnostic details on
page 2055. Click the icon for more information.

l

Warning. When hovered over, displays a warning about the node. For
example, if your database resides on an Ektron server, you are advised to move
the database to its own server.

l

Web server. Hosts Ektron.

l

Database. Hosts MS SQL Server.

Testing bandwidth
You can run a bandwidth test between any 2 network nodes. The test checks the
speed of the selected server's connections. To accomplish this, the test sends a 32 MB
file in both directions then reports the transfer time.
Before
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After

As an example of when you would conduct a bandwidth test, assume it takes a long
time to sync a production server with a staging server. Use a bandwidth test to
diagnose the problem.

Analyzing system memory and disk space
The Analysis function reports a selected server's installed memory, available
memory, and available disk space.
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Each item is assigned a status of critical, warning, and OK. By default, the items are
sorted in that order. To change the sort order, click the Severity column header.

Viewing diagnostic details
The diagnostics utility screen has tabs in the lower section that provides many details
about your Ektron network.

Basic diagnostics
IMPORTANT: The Diagnostics screen runs as a Windows Service. So, that service
must have administrator access to perform the tests and retrieve the necessary
information.
The basic diagnostics screen has several subtabs:
l

Basic Connectivity. Displays server name, site URL, connection string, paths to
site, Workarea, assets, private assets, uploaded files and images, asset library
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l

Version. Installed version of Ektron, Windows service, IIS, Visual Studio

l

License. License key, status, expiration date, enabled features, maximum users

l

Settings. Active Directory, SMTP port, and DMS settings

l

Database. Connection status, Test query, SQL version, Database server,
Database name, Integrated Security (true/false).

l

Connections. Status of the following services:
o server controls Web service
o

content Web service

o

content service

o

indexing service

o

Windows services 2.0, 3.0, and 4.0
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l

Security. Information for the 10 default accounts installed with an Ektron sample
site.
o if user exists
o

if default password was changed

See also: Securing Ektron on page 57

l

Permissions. User permission settings for these DMS folders:
n asset library\servername\site name
n

\siteroot\assetmanagement\dmdata

n

\siteroot\assets

See also: Checking document management permissions on page 725

l

Events. The Windows Event Log
o each event includes: event, event type, time of occurrence, description,
source
o

l

sorted by log name

Authentication. Active Directory and LDAP settings
See also: Using Active Directory with Ektron on page 1589, Using LDAP with Ektron
on page 1616
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Server details
The Server Details tab provides information about the selected server.

The tab displays the following information.
l

Server index

l

Share index

l

Server time (UTC)

l

OS architecture (32 or 64 bit)

l

Number of Processors

l

CLR Version

l

OS version

l

Memory: total, available, current process usage

l

System storage: for each drive, the capacity and available space in megabytes

l

Site databases: name, Maximum size, location, size and type

l

Your website's asset server: callback URL, ID, date modified, and so on.

Sync certificates
Use this tab to view the site's encoded eSync certificate, copied from the web.config
file.
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Sync scope

The tab also displays all remote certificates for this server. Checks in the lower section
indicate the presence of certificate files on all servers. See also: Managing eSync
security certificates on page 1979.
NOTE: The tab does not indicate if the certificates on the servers in the sync
relationship match.

Sync scope
The Sync Scope tab retrieves details from the serverinfo.xml file. The tab also shows
information about saved eSync profiles. See also: Setting up eSync profiles on
page 1969.

Here is an example of what appears when you click View Child Profiles.
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The bottom section of the Sync Scope tab shows information for the eSync Logs. See
also: Viewing eSync activity on page 2009.

Site details
The Site Details tab shows Files over 100 MB in the site and the Knowledge and
Metadata Files Screen.
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l

Gray circle. No files to view

l

Green circle. You can view files under that server and its folders
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Files over 100 MB in the site
This tab highlights website files that exceed 100 MB. Files of this size may cause
problems when synchronizing or Load Balancing. This tab makes it easy to locate such
files.

Knowledge and Metadata Files screen
Use this section to view eSync Knowledge and Metadata files, which can be used to
troubleshoot problems with eSync relationships.

Service status
The Service Status tab provides information about EWS (Ektron Windows Service). It
also lets you stop and start the service. See also: Handling background processing
functions with the Ektron Windows Service on page 136

This screen tells you
l

how much memory the service is using

l

the user account under which it runs

l

its status

l

the name, address, and status of each internal Web service that EWS is running

Assets
The Assets tab display a recursive list of assets under each folder.
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Exporting diagnostic information
You can capture, save, and export diagnostic information for comparison with previous
and future versions, or send it to Ektron's Support staff for diagnosis.
To capture Diagnostics information, click Export Map.
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The exported file also includes a copy of configuration files and logs for servers in your
website's network. This information is packed into a .zip file for easy storage and
transfer. The .zip file contains the following information:
l

other zipped files, which contain the captured configuration and log files.

l

a NetworkMap.ekd file. You can load this file in the Diagnostic utility, in the
Silverlight viewer, or in a text editor, such as Notepad (the saved data is XML.)
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Viewing exported diagnostic information
PREREQUISITE

The location of the exported map file on your computer. The file's name is
DiagExportdate-time.zip.
1. Go to Workarea > Settings > Configuration > Diagnostics > Load Save.
2. Go to the saved DiagExportdate-time.zip file.
3. Click Open.
4. Click any node to view its information.
NOTE: You can also use the
C:\Program Files
(x86)Ektron\EktronDiagnosticsService\Tools\EktronDiagnosticsWPF.exe to
view a networkmap.ekd file.
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Chapter 39

Using the eWebEdit400
editor
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The eWebEdit400 editor is a Web content editor designed for dynamic websites that lets
you create and publish Web content. You can use the eWebEdit400 editor on Windows
and Macintosh operating systems.
Although you can still use the eWebEdit400 editor, it is not the default editor since
Ektron Version 8.7. For information about the default editor, see Editing in Ektron on
page 605.
To learn how to select an editor for users, or let them choose it themselves, see
Changing the default editor on page 637.
Working with tables in eWebEdit400 on page 2087 has more information about working
with tables in the eWebEdit400 editor.
eWebEdit400 Toolbar

When you cut, copy and paste from Microsoft Word, you can preserve the styles, class
attributes, and HTML tags by following these steps:
1. In the Workarea, choose Settings > Configuration >Setup. The Application
Setup screen appears.
2. Click Edit.
3. Click the Editor tab.
4. Check the boxes: Preserve MS-Word Styles and Preserve MS-Word Classes.

eWebEdit400 functions
l

2066

Select All (Ctrl/a). Select all content

l

Cut (Ctrl/x). Remove selected text and graphics. Place that data into
temporary memory, also known as the “clipboard.” (If you later cut or copy more
information onto the clipboard, the new information overwrites the original
information.)

l

Copy (Ctrl/c). Copy selected text and graphics into temporary memory.
Leave selected data where it is. (If you later cut or copy more information into
memory, the original information is lost.)

l

Paste (Ctrl/v). Insert the most recently cut or copied text and graphics at the
current cursor location.

l

Paste from Word, Cleaning Fonts & Styles. Designed for pasting Microsoft
Word content, this button strips fonts and classes. For example, if you use the
Paste button, Word content contains these tags.
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<p class="MsoNormal" style="MARGIN: 0in 0in 0pt">
<span style="BACKGROUND: lime; mso-highlight: lime">
<font size="3">
<font face="Times New Roman">

But if you paste that content using this button, only <p> tags are preserved.
l

Paste Plain Text. Paste the clipboard’s contents as plain text. That is, all
HTML tags (including images) are stripped out. This button is helpful when you
want to eliminate HTML formatting from the copied text.

l

Find and Replace. Launch the Search and Replace dialog box. The dialog
searches for (and lets you optionally replace) text that you specify. See Finding
and replacing text on page 2071.

l

l

l

l

Print (Ctrl/p). Print the editor content.
Undo (Ctrl/z). Reverse the most recent action, as if it never occurred. You can
undo as many actions as you wish.
Redo (Ctrl/y). Reverse the undo action.
Spell Check. Begin spell checker. See Checking spelling on page 2072.

l

Anchor Tag. Insert a bookmark anchor. See Using bookmarks on page 2072.

l

Add/edit Hyperlink. Change information about a hyperlink. Using hyperlinks
on page 2074.

l

l

l

Remove Hyperlink. Remove a hyperlink.
Library. Insert a library file. See Working with files in the library on page 733.
Add Wiki Link. Create a wiki link. See Using the wiki feature on page 2077.

l

Localize Section. Designate sections of content for certain languages only.
Creating one or more localized paragraphs on page 1534.

l

Translate. Translate content into another language. See Using machine
translation on page 1531.

l

l

l

l

l

Horizontal Line. Insert a horizontal line.
Insert Symbol. Insert symbols and special characters.
Validate. Check content for adherence to XHTML and accessibility standards.
Hide/Show Elements. Toggle to show/hide temporary markers in content.
Apply CSS Class. Display a list of style sheet classes. Users can
select from the list to apply a class to selected text. The list can change depending
on the selected text. Your Webmaster determines which styles are available.
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l

Paragraph Style. Display a list of paragraph styles. Users can
select from the list to apply a style to selected text. The list can change depending
on the selected text. Your Webmaster determines which styles are available.

l

Bold (Ctrl/b). Make selected text bold.

l

Italic (Ctrl/i). Make selected text italic.

l

l

Underscore (Ctrl/u). Make selected text underlined.
Strikethrough. Apply strikethrough to selected text. For example: Here is
some text

l

Superscript. Make selected text appear smaller and above text line.

l

Subscript. Make selected text appear smaller and below text line.

l

Relative Font Size. Change the relative font size. Your Webmaster
determines which relative font sizes are available.

l

Font Style. Change the font style. Your Webmaster determines
which fonts are available.
NOTE: If more than one font appears in a selection, the browser on the reader’s
PC tries to display text using the first font. If the browser cannot find that font, it
tries to use the second, and so on. Your system administrator can enable or
disable the font toolbar buttons (style, size, color, and background color).

l

Font Size. Change the font size in points. Your Webmaster determines
which font sizes in points are available.
Font Color. Change the font color.

l

Background Color. Change the background color of the selected content.

l

l

Number. Begin the line on which the cursor rests with a number. If the line
above this line is:
o not numbered, assign this line 1
o

numbered, assign a number one more than the line above

NOTE: The Number toolbar button applies a number to each paragraph. If you
want to switch to regular (that is, non-numbered) paragraphs, click the button a
second time
l

Bullet. Begin the line on which the cursor rests (or all selected lines) with a
bullet.
NOTE: The Bullet toolbar button applies a bullet to each paragraph. If you want
to switch to regular (that is, non-bulleted) paragraphs, click the button a second
time.
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l

Indent. Increase or decrease the current line’s distance from the left
margin.

l

Left, Center, and Right Justify. Align paragraph so that it
is arranged evenly on the...
o left side (uneven on the right)
o in

the center of each line
o evenly

o

on the right side (uneven on the left)

evenly on right and left side

Use the last button to remove justification.
l

Insert table. Insert a table. See: Working with tables in eWebEdit400 on
page 2087

l

Insert row above. Insert a new row above current one (that is, the one in
which the cursor currently resides).

l

Insert row below. Insert a new row below current one (that is, the one in
which the cursor currently resides).

l

Insert column left. Insert a new column to the left of the current one.

l

l

Insert column right. Insert a new column to the right of the current one.
Delete row. Delete current row.

l

Delete column. Delete current column.

l

Delete cell. Delete current cell.

l

Merge cells horizontally. Merge current cell with cell to its right.

l

Merge cells vertically. Merge current cell with cell below it.

l

Split cell. Divide a cell into two. After you split, each cell occupies one half the
size of the original cell.

l

Table properties. Adjust a table’s properties.

l

Cell properties. Adjust properties of current cell.

l

Show/hide border. Display/suppress internal table border.

Using temporary markers
Temporary markers let you insert your cursor in a place that is otherwise inaccessible.
For example, if 2 tables are adjacent to each other, you cannot insert text between
them without temporary markers. You can click on any marker and begin inserting new
content. When you save, temporary markers are removed.
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To toggle temporary markers on and off, click Hide/Show Elements (

).

NOTE: Your Ektron system administrator can use the siteroot/web.config file's
ek_ShowTemporaryMarkers element to enable (true) or disable (false) temporary
markers for all users.
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Finding and replacing text
To find (and optionally replace) text, click Find and Replace (
Replace dialog box appears.

). The Find and

In the Find field, type the text you want to find.
1. Click the Replace tab.
2. In the Replace With field, type the replacement text.
3. Set dialog box options.
l Selection only. operates on a selected portion of content.
l

Direction. Search from the current cursor location up (backwards) or down
(forwards).

l

Match case. The search must match the string exactly.

l

Match whole words only. Find only whole words. By default, the search
finds any occurrence of the text that you type into the Find field. For example,
if you enter the, the search finds the word the, as well as those letters
embedded in other words, such as others and theater.
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4. If you want to...
l replace all occurrences of the “find” text with the “replace” text, click Replace
All.
NOTE: You can undo replacements one at a time using the Undo button (
).
l

replace only the highlighted term with the “replace” text, click Replace.

l

find the next occurrence of the “find” text (and optionally replace it with the
“replace” text), click Find Next.

l

change the highlighted term using the editor, exit the Find and Replace dialog,
move to the term and edit as needed. To restart the search, press the Find
button ( ).

Continue to find and optionally replace or edit until you reach the end of the text.

Checking spelling
To begin spell checking, click the spell check button (
). eWebEdit400 puts a red line
under each word that’s not in the dictionary. Then, it stops at the first misspelled word
and displays your options for fixing the problem. Instead of stopping at every
misspelled word, you can place the cursor on any highlighted word. When you do, its
spelling options appear.

NOTE: The FireFox browser has its own spell check software. To eliminate confusion
between eWebEdit400’s and Firefox’s spell checker, you can disable Firefox’s by
choosing Tools > Options dialog > General Tab and unchecking the Check my
spelling as I type check box.
If you are done before fixing every misspelled word, click Finish spell checking from
the toolbar. Your changes are saved, and you return to edit mode. If you want to exit
the spell checker and ignore all changes you have made since beginning it, click Cancel
(circled above) at any time.

Using bookmarks

2072

Ektron 9.40 SP1

Using bookmarks

A bookmark lets you “jump” from any word or phrase to another place in the same
content block. On your Web page, text appears in a different color to indicate the
bookmark. Bookmarks are helpful if your page is long.
To create a bookmark, you must specify:
l

a source—the text a user clicks to move to the bookmark

l

a bookmark—the destination to which the cursor jumps when a user clicks the
source

For example, if your Web page contains minutes from several meetings, the top of the
page could list the meeting dates. You could then assign a hyperlink (source) to each
date and a bookmark to each set of minutes. The user sees that a date is in a different
color, so clicks it to “jump” (using the bookmark) to the correct minutes.
To create a bookmark:
1. Place the cursor where you want to create the bookmark..
2. Click Insert Bookmark (
Bookmark Tab selected.

). The Link Manager dialog appears with the

3. Enter a name for the bookmark and click OK. The editor screen redisplays. (The
bookmark does not appear on the page.)
4. Select the source text that will link to the bookmark that you created..
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5. Click Hyperlink Manager (
Hyperlink tab selected.

). The Hyperlink Manager dialog appears with the

6. Click the down arrow on the Existing Bookmark field and click the bookmark you
created.

7. Optionally set the Target Frame field on the Hyperlink Manager dialog to change
the window that displays the destination page.
l New Window. Appears in a new browser window, on top of the current
browser.
l

Same Window (default). Appears in the same position within the browser
window. The new window replaces the current one.

l

Parent Window. Appears if your page contains frames, in the frame that
contains the frame with the hyperlink.

l

Browser Window. Appears if your page contains frames, in the full display
area, replacing the frames.

8. Click OK.

Using hyperlinks
A hyperlink lets you “jump” from any word or phrase to another Web page. The page
can be within your network (that is, on an intranet) or anywhere on the internet.
To create a hyperlink, specify:
l

a source—the text a user clicks to move to the bookmark

l

a destination—the destination to which the cursor jumps when a user clicks the
source

NOTE: To create jumps within a content block, see Using bookmarks on page 2072.
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Creating a hyperlink
To create a hyperlink:
1. Select the source text. (You can also select an image as a hyperlink.)
2. Click Hyperlink Manager (

). The Link Manager dialog appears.

3. In the URL field, after http://, enter the address of the destination Web page. For
example, world.Optimizely.com/ektron/. If your Ektron library includes a
hyperlink that you want to apply, click the ellipsis button (
library and choose one.

) to browse the

4. Optionally set the Target Frame field to change the window in which the
destination text appears. If you leave the Target Frame field blank, the new
window replaces the current window.
5. Optionally enter "hover over" text in the Tooltip field.
6. If desired, use the Relationship field to set the link's rel attribute. See also:
HTML <a> rel Attribute. And use the Reverse Relationship field to set the link's
rev attribute. See also: HTML <link> rev Attribute
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7. The hyperlink's style is normally determined by the style sheet assigned to the
content’s page template. However, if you want to apply a special style sheet class
to this link, select it from the Style drop-down.
8. Click OK.

Creating an email hyperlink
An email link resembles a hyperlink. When a site visitor clicks the link, instead of
opening a Web page, the person's email application is launched. To create an email
hyperlink:
1. Select the source text. (You can also select an image as an email hyperlink.)
2. Click Hyperlink Manager ( ). The Link Manager dialog appears.
3. Click the E-mail tab. The selected text appears in the Link Text field.

4. In the Address field, enter the email address of the message recipient.
5. In the Subject field, enter default text for the email’s Subject line. The user
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sending the mail can edit it.
6. Click OK.

Editing a hyperlink
To change a hyperlink’s destination Web page or target frame:
1. Right click on hyperlinked text and choose Set Link Properties. The Link Manager
dialog appears.
2. Edit the fields as needed and click OK.

Removing a hyperlink
l

To remove a hyperlink from text, select the text and click Remove Link (

l

If you enter a URL or an email address into eWebEdit400, it automatically becomes
a hyperlink. To avoid this, select the text and click Remove Link (

).

).

Using the wiki feature
The Wiki feature lets registered site visitors (that is, membership users) and Ektron
users insert hyperlinks to other content. The hyperlinks can connect to existing content
or to content that doesn’t exist yet. This collaborative authoring style is used in wiki
sites such as Wikipedia, where any author can contribute new content and articles.
There are 2 ways to create a wiki link.
l

Surround text with double square brackets ([[ ]]). This is quick.

l

Use the wiki button ( ). This has the following advantages:
o Can link to existing content or create new content
o

Can choose new content’s folder
NOTE: Membership users cannot choose a folder. The new content is
created in the same folder as the content being edited.

o

Can change title of new content

o

Can select new window’s target frame

To create a wiki link using the wiki button, select the text to which you want to assign a
wiki hyperlink. It can be one or several words and click Add Wiki Link.
NOTE: The Wiki button only appears if you have permission to add content to the
folder that contains the current content.
The Add/Edit Wiki Link screen appears. It has 2 tabs.
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l

New Content tab. Create new content to which you will add information later. The
new content item will appear when a site visitor clicks the link text.
If you want to place the new content item in the folder that contains the text you
are editing, do nothing. To place new content in a different folder, click Change
and go to that folder. You can also edit the Title and the Target Frame.
NOTE: Membership users cannot assign a folder. New content is saved to the
folder that contains the source content.

l

Related Content tab. Link to existing content. If you click this tab, Ektron uses
the selected text to search your website. All content with that text then appears on
the screen. Each content item’s title appears followed by its summary. Click the
radio button next to the content you want to link to.

To indicate that a wiki has been applied to new content, the text color changes to blue
and bold, and small dots appear under the wiki text.
l

If you applied a link to related content, a regular hyperlink appears.

l

If you link to existing content, the link is the same as quicklink.

l

If you are creating new content, Ektron assigns a <span> tag to the selected text.
For example:
<Span class = "makelink">selected text here</span>

When the content is published, Ektron does the following:
l

Detects the <span class = "makelink"> tag.

l

Finds text surrounded by the <span> tag.

l

Creates a new content block in the selected folder.
o its name is typically the selected text. However, if the user used the wiki
button, the user can modify the new content block’s title on the Add/Edit Wiki
Link screen.
o

l
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its initial text is New Content: content for selected text. (Fill in the topic text as
you or other collaborators have time.)

Gets the quicklink for the newly-created content block.
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l

Opens the original content and replaces the <span> tag with the quicklink to newlycreated content.

Working with HTML
You do not need to know HTML to use eWebEdit400. However, if you know HTML, you
can view, insert or edit your Web page’s HTML code by clicking
at the bottom of the
editor. The HTML code appears.

To return to normal view, click

.

Working with images
PREREQUISITE

Before you can insert an image into eWebEdit400, the image must be either
uploaded to the Library or imported as an asset.
l

Moving or copying content on page 687 explains how to upload an
image to the Library.

l

Methods for importing assets on page 713 explains how to import an
asset.

Inserting an image into the editor
1. Place the cursor where you want the image to appear.
2. Click Library (

).

3. From the left panel's folder display, select the folder that contains the image you
want to insert. If you don’t know the image’s folder, use the search button ( ) to
find the image by title, description, or internal file name.
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4. Select Images from the content type drop-down.

NOTE: If you are inserting an asset, its content ID number (for example,
assets/1062.jpg) appears in the Insert Library Item screen.

5. Select an image to insert.
6. Click Insert (

). The image is inserted into the content.

Alternatively, you can insert a miniature version of the image, called a thumbnail,
by clicking the thumbnail button ( ). When the thumbnail appears on a Web
page, a site visitor can click it to view a full-sized image.
NOTE: You can change the thumbnail image by right clicking it, selecting Set
Image Properties and editing the Image Src field. If you do that, however,
and someone clicks it, the original full-sized image appears. If you want to
change both the thumbnail and the full-sized image, delete it then enter a new
thumbnail.
To delete an image, click it and click Cut (

).

Editing an image
To edit an image, right click it and choose Image Modification Tool.
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NOTE: The Image Modification Tool is not available in the default editor. To edit
image properties in the default editor, choose Review > Inspect Properties, then
click the image. The Inspector shows the properties you can edit.

l

. Save changes

l

. Exit without saving changes

l

l

l

l

. Crop image. Drag the box around the area you want to keep and click Done.
. Change image size. Specify the width and height. Check the box to keep the
aspect ratio.
. Rotate image
. Adjust brightness. Move slider to left to lighten image; to right to darken it.

Setting a border on an image
To add a border around a picture, enter the border’s thickness in pixels in the Border
Width field on the Image Properties dialog.
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1 pixel border

10 pixel border

If the picture is not a hyperlink, its border is black. If the picture is also a hyperlink, the
border is the same color as a hyperlink (for example, blue or purple if visited).

Aligning an image
To align an image , use the Image Alignment field on the Image Properties dialog.
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l

. The picture on the left margin, allowing subsequent text to wrap around it

l

. The picture on the right margin, allowing subsequent text to wrap around it
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l

. The top of the picture with the first line of text

image
l

. The vertical center of the picture with the first line of text

l

. The bottom of the picture with the first line of text

Adding space around an image
On the Image Properties dialog box, you can use the Spacing fields (Horizontal and
Vertical) to add space around the picture. You enter a number of pixels to determine
spacing value.

Ektron Reference

2083

Using the eWebEdit400 editor

NOTE: When you save an image, a version is placed in the siteroot/uploaded
images/CMS folder folder. The version is named filename.nextnumber.file
extension.
For example, if a library image is named ektronlogo.png, and someone inserts it into
content and saves it, a new version is created and named ektronlogo.1.png. If
someone later saves that image in another content block (or even another section of
the same content), that version is named ektronlogo.2.png. Also, whenever
someone edits and saves the image, a new version is created and assigned the next
highest number.
These edits have no effect on the original image stored in the library.

Editing image properties
After an image in inserted, you can adjust the image properties by right clicking on the
image and choosing Set Image Properties.
NOTE: To edit image properties in the default editor, choose Review > Inspect
Properties, then click the image. The Inspector shows the properties you can edit.
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l

Border Width. Set the width of the image’s border in pixels. See also: Setting a
border on an image on page 2081

l

Border Color. To set the color of the image’s border, click the X circled below.
When you do, a palette of colors appears. Click the border color from the palette.
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If a color has already been assigned, it appears next to this field label. To change it,
click down arrow next to the color to display the color palette.
l

Image Alt Text. The image’s title is used as the default alt text. Change if
desired.
The alt text appears in place of the image on the Web page if the image does not
display. Examples of when an image does not display include:
o

a speech browser (for example, a visually impaired person)

o

a text-only browser (for example, browsing from a mobile phone)

o

a graphical browser with images turned off

l

Image Alignment. The alignment of the image relative to adjacent text and
images. If you choose left or right alignment, the text wraps around the image. For
more information, see Aligning an image on page 2082

l

Image Src. The path to the image.
If you want to change the image, click the ellipsis (
From there, select a replacement image.

) button to open the library.

l

Horizontal Spacing, Vertical Spacing. The amount of horizontal and vertical
space around the picture. See also: Adding space around an image on page 2083

l

Width. The width of the picture in pixels. See also: Working with images on
page 2079
NOTE: The Width and Height settings determine the area on a Web page in
which the image appears. To display an image correctly, its height and width
settings should match its actual size (set using the resize button). See also:
Working with images on page 2079

l

Height. The height of the picture in pixels.

l

Constrain. The constrain feature lets you determine if an image’s height and width
can be adjusted independently. Typically, you want Constrain on, as shown.

In this state, if one dimension is adjusted, the other is automatically adjusted in
proportion to it. For example, if you change the height from 100 to 200, the width
is also doubled.
To turn Constrain off, click it. When you do, it looks like this.

When Constrain is off, the adjusted picture can be disproportionate.
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NOTE: If you substantially adjust a picture’s height and/or width, the picture
may be distorted when users view your Web page.

Deleting an image from an XML Smart Form and
eWebEdit400
If you want to remove an image from content created from an XML Smart Form and
eWebEdit400 is your editor, click image (
delete the image path.

), open the Image Properties dialog, and

NOTE: If you begin editing an image then click cancel ( ), and later try to edit that
image, you may see a small, red x instead of the image. (This problem only occurs if
your browser is Internet Explorer.) To remedy the problem, go to Tools > Internet
Options > Browsing History > Settings (or Temporary Files > Settings in
Internet Explorer 6). Set Check for newer versions of stored pages to Every
Visit.

Working with tables in eWebEdit400
You can do the following tasks with tables. For information about tables in the default
editor, see Working with tables on page 616.

Creating a table
Creating up to 6 rows by 6 columns
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1. Click Table (

). A table dialog box appears.

2. Drag the cursor over rows and column to indicate the size of the table.

3. Click the mouse.

4. Enter text and images in the table cells. You can also select the table and drag its
right border to the right and/or down to enlarge it for ease of use.
NOTE: You can create a table within a table by clicking Table ( ) inside a table
cell. To modify an inner table, click inside a cell and use right click menu options,
such as Set Table Properties.

Creating more than 6 rows by 6 columns:
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1. Click Table (

). A table dialog box appears.

2. Click Table Wizard. The Table Wizard dialog box appears.

3. To change the number of columns or rows, click the plus or minus signs (+ -) next
to Columns and Rows. The image adjusts to show the number of rows and
columns.
4. Press OK.
5. Enter text and images into the table cells.
NOTE: You can create a table within a table by clicking Table ( ) inside a table
cell. To modify an inner table, click inside a cell and use right click menu
options, such as Set Table Properties.

Deleting a table
1. Move the cursor over the table until the cursor becomes a 4-headed arrow (

).

2. Click the mouse button. The table becomes selected (small squares appear around
it).
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3. Press Delete.

Creating a section 508-compliant table
Narrative software uses the information from the Accessibility table fields (heading
rows, columns, caption alignment and summary) to produce a Tooltip message for each
table cell. Users with impaired vision can see those Tooltips as they hover over the cells.
To create a 508-compliant table:
1. Create a new table or edit an existing one.
2. Right click in the table and choose Set Table Properties. The Table Properties
dialog appears.
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3. Click the Accessibility tab.

l

Heading Rows. If you want your table to have a horizontal header, enter the
number of rows that it should occupy. The number cannot exceed five.
Beginning with the top, all cells in the specified number of rows are designated
as table headers.

l

Heading Columns. If you want your table to have a header, enter the
number of columns that it should occupy. The number cannot exceed 3.
Beginning with the left column, all cells in the specified number of columns are
designated as table headers.

l

Caption Alignment. To choose the caption’s alignment, click the down arrow
next to this field. Click the box that represents the alignment style you want.

l

Caption. Enter a table caption. The caption appears above the table. The
caption’s alignment is set in the Caption Alignment field.

l

Summary. Enter the table summary. Non-visual browsers use the summary
to explain the table’s contents. From HTML Techniques for Web Content
Accessibility Guidelines 1.0:
“A summary of the relationships among cells is especially important for tables
with nested headings, cells that span multiple columns or rows, or other
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relationships that may not be obvious from analyzing the structure of the table
but that may be apparent in a visual rendering of the table. A summary may
also describe how the table fits into the context of the current document. If no
caption is provided, it is even more critical to provide a summary.”
l

Associate Cells with Headers. Check this box if you want to associate the
table’s data cells with the appropriate headers. See also: H43: Using id and
headers attributes to associate data cells with header cells in data tables

4. Click on the Cell Properties tab to set the Abbreviation and Categories fields.

l
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information, see abbr attribute | abbr property
l

Categories. Sets or retrieves a comma-delimited list of conceptual categories
associated with that tag. Can be used to render non-visual media, such as
speech or Braille. For more information, see axis attribute | axis property

5. Click OK to make the table Section 508-compliant.

Formatting tables
Merging and splitting table cells
l

Merge cells in the table wizard.

l

Merge cells in a the editor by clicking in a cell, then right clicking and choosing
Merge Cells Horizontally (row span) or Merge Cells Vertically (column span).

l

Split a previously merged cell by clicking in a cell, then right clicking and choosing
Split Cell.

Inserting and deleting rows and columns
Ektron Reference
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1. Place the cursor in the cell from which you want to add or delete rows or columns.
2. Right click the mouse. A menu appears.

NOTE: These options are also on the toolbar.

Setting table borders
1. Right click in the table and choose Set Table Properties.
2. Click the Table Properties tab.
3. Use the icons within the Border area to indicate which border lines should appear.
Each icon has tooltip text that explains its function.
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NOTE: To view the selected borders on the dialog, a border color must be
assigned.

Setting the exterior border of a table
1. Right click in the table and choose Set Table Properties.
2. Click the Table Properties tab.
3. Enter a number of pixels in the Border field.

Setting the color of a table border
1. Right click the table and choose Set Table Properties.
2. Click the Table Properties tab.
3. Click the Border Colordrop-down. A color selection box appears.
4. Click a color to apply to the table’s border.

Deleting cells from a table
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To delete one or more cells, right click in the cell you want and choose Delete Cell.
Cells to the right of the deleted cell shift left to occupy the vacant space.
Before

After

Aligning the contents of a cell
1. Right click the cell you want and choose Set Cell Properties. The Cell Properties
dialog appears.
2. Click the down arrow to the right of Content Alignment. The alignment choices
appear.

3. Click your alignment choice.
4. Click Update.

Setting the word wrap feature
1. Right click in the cell you want and choose Set Cell Properties. The Cell
Properties dialog box appears.
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2. To turn off Word Wrap, click the No Wrapping checkbox.

3. Click Update.
Word Wrap causes text to move down to the next line when the width of the characters
on a line equals the column width. By default, all cells have the Word Wrap feature
turned on.
If Word Wrap is turned off, text stays on one line until you press Enter.

Ektron Reference

2097

Using the eWebEdit400 editor

Setting cell padding and spacing
1. Right click in the cell you want and choose Set Table Properties. The Table
Properties dialog appears.
2. Click the Table Properties tab.
3. In the Cell Padding and Cell Spacing fields, enter the number of pixels.

4. Click Update.

Setting the minimum height and width of a cell
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1. Right click on the cell you want and choose Set Cell Properties.
2. Click Cell Properties. The Cell Properties dialog appears.

3. Enter the cell width and height in the fields. You can enter the width in pixels or
percentage.
NOTE: When you set a cell width, there is no guarantee that the cell will occupy
that width when displayed in a browser. This is because the cell is part of a
column, and changes to other cells in the column can affect the cell whose width
you set. Setting cell width only guarantees that the cell will not be less than the
width you specify.
4. Click Update.

Setting a background color for a table or a cell
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1. Right click in a table cell and choose Set Table Properties.
2. Click the Table Properties tab (or the Cell Properties tab).
3. Click the Background drop-down list. A selection of colors appears.

4. Click a color for the table’s background. To choose no color, click the X color box.
NOTE: From the drop-down, you can add custom colors by selecting a color
patch or entering a color’s hex value. Follow these steps to get help on how to
use the color box. The custom colors box is only available with Internet
Explorer. If you are using Firefox or Google Chrome, you can enter a custom
color by its hexadecimal value.

Setting a background image for a table or a cell
1. Place the cursor within the table.
2. Right click the mouse.
3. Select Set Table Properties.
4. Click the Table Properties tab (or the Cell Properties tab).
5. In the Background Image field, click the ellipsis button (
From there, select an image for the table’s background.
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) to open the Library.

Setting a background color for a table row or

6. Click Update.

Setting a background color for a table row or column
1. Right click on a table cell and choose Set Table Properties.
2. Click the Cell Properties tab.
3. Within the Table Wizard dialog, hold down Ctrl while clicking all cells in the row. In
the following image, the second row from the top is selected (dark gray) and red is
chosen for the background color.
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4. Click a color for the table’s background.
5. Click OK.
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editor
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bubble text
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API
CreateContentQueryRequest Method
CreateQueryRequest Method
custom provider
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enabling
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referrers
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recurring
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multi-language
removing content
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permissions
viewing content
community groups
adding
calendars
creating personalization page
deleting
discussion boards
email address
members
accept/decline join request
add
delete
view
searching
tags
templates, assigning
using discussion boards
web calendars
community user
managing
community user profile
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comparing content
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published tab
staged tab
complex product
eCommerce
configuration
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configuration screen
search
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content
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advanced workflow
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basic workflow
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creating
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editing
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expired report
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view all pending reviews
view history of reviews for content
scheduling
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submitted, report
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summary
tags
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translating
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report
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coupons
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Solr search
starting manually
troubleshooting
understanding
CreateContentQueryRequest Method

702
783
822
687
1507
1059
1060
509
695, 697
167
1057
1057
1058
1059
1060
1062
705
1073
1069
1071
1073
1071
1070
698
371
698
1059
781
693
835
1061
698, 1530
705
390
679
1067
1309
1307
1308
1049
687
1214
1763
1805
1841
396
395
395
395
397
217
395
400
395
554

Ektron Reference

2113

Index

credit card types, eCommerce
cross sell items, eCommerce
CSS
applying a local version
applying a theme to a form
applying system-wide
CTA
add to blog post
CallToAction widget
creating
embed code
overview
placing on a page
culture, custom
currencies, eCommerce
default
custom permissions role
custom user properties
adding
changing order
deleting
editing
overview
with non-English languages
custom validation
data designer
HTML form
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D
dashboard
data designer
calculated field
checkbox field
choices field
creating custom list
conditional section
custom validation
group box field
relevance tab
image only field
plain text field
resource selector field
tabular data field
DateFacets widget
decline content publication
advanced workflow
default logo
changing
deleting
content
landing page
device detection
enabling for mobile devices
Diagnostics Utility
accessing
analysis screen
assets tab
bandwidth test
basic diagnostics screen
exporting
installing
prerequisites
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server details tab
service status tab
site details tab
sync certificates tab
sync scope tab
viewing exported information
did you mean feature
search
Digital Experience Hub (DxH)
DxHConnection admin role
DxHConnection user role
discussion boards
activity notifications
changing page size
community group
control panel
creating
deleting
editing
file types that may be uploaded
forums
creating
deleting
editing
locking
moderating from control panel
outputting as RSS
ranking users
in community groups
locking
maximum file upload size
overview
permissions
editing users and user groups
for membership users
granting to users and user groups
revoking for users and user groups
post reporting
setting up
posts
adding a reply
approving
attaching images and files
deleting from Web SIte
deleting from Workarea
editing
replacing words
replying to post from Web site
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restricting IP address
sort order
subject
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subscriptions
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reviewing
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approving
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deleting
editing title
locking
overview
sorting
Web site
adding video to a post
approving
deleting a topic
editing post from Web site
editing post from Workarea
suppressing user information
using on
distributing content
after first time
enabling
new
overview
overwrite existing document
prerequisites
procedures
document management feature
configuring
document types
file types
importing documents
introduction
permissions
troubleshooting
documentation
online
installing on local server
documents
importing into DMS
Droid
previewing content on
Dublin Core metadata
DXH
mapping form data
targeted content
DxHConnection
admin role
user role
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eCommerce
analytics
architecture
bundles
catalog entries
attributes
content
creating/updating
deleting
dimensions
inventory adjustments
pricing
items
entering
media
overview
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pricing
non-default currency
tier
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summary
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thumbnail size
thumbnails
catalog folders
assigning product type
deleting
overview
complex product
countries
country tax table
deleting
editing
overview
coupons
creating
eligible catalog entries
minimum order amount
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credit card types
creating
deleting
editing
introduction
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cross sell items
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default
enabled
installed
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overview
images
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customizing
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creating
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overview
variables
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order fulfillment
orders
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marking fraud
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introduction
payment gateway
creating
customizing
default
deleting
editing
introduction
postal tax table
creating
deleting
editing
product types
classes
deleting
editing
effect on catalog entries
overview
regional tax table
deleting
editing
overview
regions
reports
inventory
shipping calculations
customizing
shipping methods
adding
changing sequence
deleting
editing
shipping providers
customizing
default
defining
shipping workflow
site
design
setting up
templates, required
stock activity,customizing
subscription workflow
tax class
creating
deleting
editing
screens
taxes
how calculated
overview
shipping
upsell items
warehouse
creating
default, changing
deleting
editing
wireframe design
workflow
customizing
editing an author profile
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editor
customizing
cut, copy and paste
default, changing
editing source
images
deleting
editing
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inserting bookmarks
inserting bubble text
inserting links
inserting tables
inserting video
integrating into aspx page
introduction
mailto link
plug-ins
search and replace text
spell checking
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styles, applying
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table
caption
header
summary
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translating text
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validating content
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ek_LDAPMembershipUser
ek_LinkManagement
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ek_loginAttempts
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ek_MeasurementSystem
ek_MenuDisplayType
ek_PageSize
ek_QueueName
ek_RedirectFromLoginKeyName
ek_RedirectorInstalled
ek_RedirectorManualExt
ek_RedirectToLoginURL
ek_ServerURL
ek_ShowWorkareaRetErrorReferrer
ek_sitePath
ek_SMTPPass
ek_SMTPPort
ek_SMTPServer
ek_SMTPUser
ek_SSL_Port
ek_ToolBarFormatTag
ek_TreeModel
ek_UserMenuType
ek_UseSSL
ek_WorkareaLibSearchResultMode
ek_XliffVersion
Ektron CMS filehelper service
Ektron protocolhandler file helper service
Ektron query service
Ektron search server service
Ektron Windows service
email
address
community groups
disabling notification for a user
notification of content changes, configuring
to announce content changes, configuring
variables
email notification
embed code
CTA
YouTubeVideo
end date
content, setting
Episerver Find
API
overview
search Ektron assets
search Ektron content by taxonomy
search Ektron metadata
setting up
using with Ektron HTML content
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content
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prerequisites
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packages
authorization to use
pause schedule
performance counters
profile
setting up
queue
security certificates
installing
introduction
regenerating
replacing
testing
strategies
ESyncDataTransformStrategy
ESyncNotificationStrategy
events
implementing
LoadBalancerNotificationStrategy
troubleshooting
using with three-tier architecture
events
web calendar
adding
eWebEdit400
bookmarks
finding text
hyperlinks
editing
removing
images
inserting
replacing text
search
spelling
table
section 508
abbreviation
categories
table caption
table summary
temporary markers
text, searching
toolbar buttons
ExactTarget
expired content
report
extensions
eSync

2000
1994
1933
1925, 1927
2022
2009
1991
2026
2037
2003
2004, 2008
1977
2016
1969
2008
1980
1979
1986
1986
1986
2034
2044
2037
2036
2047
2044
2033
185

994
2072
2071
2074
2077
2077
2079
2071
2071
2072

2093
2093
2091
2091
2069
2071
2066
1130
1061
2034

F
Facebook
login

122
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Index

faceted search
fallback locale
FAST search
Microsoft
3-tier architecture
FAST Search
Microsoft
faceted search
making Title property sortable
overview
rank profiles
troubleshooting
Featured Items widget
file extensions
library folder property
file upload path
library folder property
files
copying to library
library
editing title
inserting into content
overwriting
viewing
filtered content search
Find
Episerver
overview
setting up
index
loading Ektron content
obtaining
flags
applied to content
deleting
edit details
finding
view details
definition
adding
assigning to folder
deleting
editing
overview
report
Flash widget
Flickr widget
folders
assigning metadata
assigning smart forms
assigning Web Alerts
basic workflow
assigning
editing
removing
viewing
community
content
applying
style sheet
deleting
managing
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487
1529

187

487
486
466
492
497
1311
737
737
740
743
743
745
742
662

195
195
198
195

1723
1723
1720
1722
1718
1719
1718
1718
1717
1067
1294, 1312
1313
832
903
1496
753
757
757
752
1639

160
166
149

Index

properties
toolbar
information available when viewing
move/copy
authorized users
folder types
introduction
private
traverse
fonts
adding
buttons, enabling
deleting
editing
managing
viewing
force check in
force content publication
advanced workflow
form data
mapping via DXH
form template
advanced
basic
creating from existing
creating new
editing
FormControl widget
forms
adding to content
HTML
assigning task
buttons, properties
chart types
creating content block
custom validation
field validation options
inserting fields
checkbox
text
reports, exporting
reports, viewing
viewing
viewing
forums
discussion boards
creating
deleting
editing
permissions
ranking users
searching
Foxit PDF filter
Front Page server extensions, removing
full screen, work page, customizing for user

158
159
151
164
165
162
696
170
676
131
677
677
676
676
156
785
1230
1205
1204
1219
1220
1218
1314
614, 747
843
886
864
879
846
859
857
848
854
886
881
865
747
1029
1026
1028
1027
1028
1030
363
342
727
1562

G
GA.js
GeoIP
information, accessing via API
support
using with Targeted Content Widget

1268
1175, 1922
1172, 1919
1173-1174, 1921-1922
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Index

geomapping
with mobile devices
GetReportNameList Method
Google
analytics
tracking persona management activity
map, inserting into editor
web analytics provider
OAuth2.0 protocol
Google Analytics
hidden fields
Google Gadget widget
google, using for SMTP server
group box field, data designer
groups
community

526
553

1152
626
559
567
1268
1219
1315
107
930
1651

H
header, table
Heading widget
Hello World widget
help
installing on local server
hidden fields
adding to a new form
history
content
HTML
saving Office document as
HTML forms
HTML5 validation
HubExchange (ExactTarget)
hyperlink, assigning target frame
hyperlinks
adding as menu option
definition
inserting
editor

619
1316
1317
35
1206
1225
702
723
843
633
1130
612-613
2074
1349
733
610

I
ical export of calendar events
iFrame
widget
IIS 7 certificate, setting up
image only field
data designer
image upload path
library folder property
images
adaptive, support
deleting
editing
editing within eWebEdit400
inserting
inserting into eWebEdit400 editor
login, changing
inbound connection
index, Find, obtaining
indexing (XML)
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997
1318
77
943
737
518
626
624
2080
622
2079
116
1227
195
905

Index

inheritance
breaking
restoring
integrated search
Search Server
inventory
provider
ecommerce
customizing
report
IP address
restricting for a forum
iPad
previewing content on
iPhone
previewing content on

170
171
385

1909
1869
1029
509
509

K
kits
eCommerce

1808

L
ladder system
ranking discussion forum members
landing page
cloning
creating
deleting
editing
content
PageBuilder template
hidden fields
manifest set up
overview
prefix
language awareness, URL aliasing
language export feature, see multi-language content
languages (multiple)
languages, support for multiple
LDAP authentication
Active Directory Setup screen
adding organizational unit
adding user information from LDAP server to CMS 400
deleting users
disabling
editing user information in CMS 400
enabling
library
accessing
asset, adding as menu item
copying files to
definition
files
deleting
editing
inserting into content
overwriting
viewing
folder properties

1030
1214
1203
1214
1208
1209
1209
1206
1215
1201
1218
1403
1533
1507
1269
1622
1619
1619
1622
1622
1621
1617
734
1349
740
733
747
743
743
745
742
736
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Index

forms
adding to content
viewing
items
actions that can be performed
quicklinks
adding to content
viewing
searching
license keys
modifying
link checker
link, assigning target frame
links
inserting
editor
List Summary widget
ListSummary
compared with collection and menu
Live Writer
load balancer
searach, Amazon cloud
load balancing
assets
introduction
keeping files in sync
library images and files
refreshing
search
status
LoadBalancerNotificationStrategy
locales
creating
custom culture
fallback
pseudolocalization strategy
localized section
creating
editing
overview
removing
lock
a user out
discussion boards
discussion forum
locked user account, unlocking
log out
user after 15 minutes of inactivity
login
author
Facebook
images, changing
locking out a user
preventing all users from
preventing CMS users from
procedure
restricting number of attempts
set up
LogLevel
logo
changing
logs
eSync
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614, 747
747
733
614, 747
747
738
129
689
612-613

610
1319
804
983
262
101
99
102
100
102
346
103
2044

1529
1529
1527
1534
1537
1534
1537
116
1017
1027
115
118
1240
122
116
116
116
116
114
115
1257
84
1267
2009

Index

M
machine translation
feature
strategy
mailto link, inserting
manifest
landing page set up
mapped network folder
removing
mark for translation status
marketing campaign
marketing optimization suite
marketing qualified lead
mashups
calendar, web
master layout
master zone
media settings
membership
module, accessing
user groups
users
activating
membership user groups
adding
adding users
deleting
deleting users
viewing users
membership users
deleting
permissions, assigning
unverified, confirmation message
unverified, viewing
menus
adding new
via content folder
via Menus module
appearance
to content contributor
to site visitor
assigning users permission to edit via the Roles screen
compared with collection and List Summary
definition
deleting
items
adding
content block as
external hyperlink as
library asset as
submenu
via content folder
rearranging
multi-language issues
template link field
URL link field
message board
comments, authorization to submit
comments, deleting
comments, replying

635
1526
612
1215
720
1539
1128
1123
1127
1007
1097
1097
85
1626
1633-1634
1503, 1630
1633
1634
1633
1634
1633
1628
1634
1504, 1630
1503, 1630

1340
1341
1340
1340
1583, 1585
804
1339
1345

1347
1349
1349
1350
1350
1352
1353
1343
1343, 1351
1645
1647
1647
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Index

moderating
users authorized
notification of postings
replies, authorization to submit
spam filtering
MessageBoard widget
messages
eCommerce
metadata
adding to content
applying to web calendar event
assigning to a folder
definitions
adding
converting style
Dublin Core
impact of folder inheritance
inheritance from parent folder
related content
creating and deploying definitions
requiring users to enter
search data
adding to content
searching for
MetaDataList widget
micromessaging bookmarklet
Microsoft FAST Search
faceted search
making Title property sortable
overview
rank profiles
troubleshooting
Microsoft Office documents
adding via Multiple DMS Documents option
checking out
compatability pack
deleting
importing
managing
replacing
saving
saving in html format
Microsoft Search Server
adding CMS site to server
configurations
installation
optimizing
register CMS site
Microsoft Search Server 2013
configurations
installation
mobile devices
configurations
adding
deleting
device-specific content
enabling device detection
geomapping
previewing content
templates
developing
templates, previewing content
mobile templates
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1644
1646
1649
1645
1649
1320
1861
834
997
832
823
831
836
834
834
830
833
832
372
1321
1728
487
486
466
492
497
715
721
721
722
712
720
721
722
723
346
325
325
341
337
405
405

512
518
511
507
526
509
507
509
506

Index

moderating message board
most popular widget
Most Popular widget
move content
MQL
multi-language content
creating new content
default language
determining available languages
disabling a language
enabling/disabling
language export
introduction
locales, creating
machine translation strategy
setting up Web site
spell checking
translating content
by machine
translation
files, importing
viewing site in another language
multi-language menus
multi-language support
multilingual settings
multimedia assets
Multiple DMS Documents option
multisite
MultivariateExperiment widget
MultivariateSection widget
MultivariateTarget widget

1644
543
1322
687
1127
1507
1521
1512
1510
1512
1510
1533
1524
1526
1509
1550
1530
1531
1537
1513
1353
1269
82
716
715
91
1323
1324
1324

N
new content
report
notification
advanced workflow
content changes, configuring
notifications
agents
delete
agents, custom
custom activity
default preferences
eSync
message board postings
messages
multi-site environment
overview
receiving
recipients
setting up
SMS,configuring
SSL
tokens
triggering

1059
768
105
1670
1671
1672-1673
1680
1675
1707
1649
1682
1704
1665
1679
1666
1669
1674
1707
1686
1666

O
OAuth2.0
authentication protocol

567
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Index

online help
installing on local server
organizational unit, LDAP, adding

35
1619

P
packages
eCommerce
eSync
authorization to use
synchronizing
PageBuilder
code samples
configuration file
dropzone user control
letting users add columns
letting users resize
set column width programmatically
editing a landing page template
master layout
asigning to pages folder
using to create new page
master zone
changing to layout zone
setting dropzone to
overview
page
create
place widgets
page,searching
three-tier architecture
wireframe
assign to folder
assigning custom taxonomy to
assigning default page to
password
enforcing change every 90 days
minimum, enforcing
prevent new one from matching previous
passwords
custom, strategy
setting for user
payment gateway
provider
ecommerce
customizing
performance counters
use with e Sync
permissions
assigning to community folders
assigning to content block
assigning to membership users
discussion boards
document management feature
inheritance
breaking
restoring
table
adding user or group
deleting user or group
editing user or group
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1792
2003
2004, 2008
2007
1115
1110
1114
1115
1113
1209
1097
1102
1102
1097
1103
1101
1075
1078, 1080
1082
363
184
1093
1105
1107
1106
118
119
119
119
1557, 1560
1770

1894
2016
1640
173
1634
1019
725
170
171
171
172
172

Index

persona management
activity
tracking via Google analytics
attributes
controlling
installing
overview
personas
creating
deleting
editing
server configuration
system requirements
personalization
introduction
personalization page
community group
plug-ins
editor
polls
creating
editing from Web site
replacing from Web site
post
blog
add comment
creating
from Workarea
editing
subscribe
preapproval groups
report
prefix for a landing page
preserve MS Word
classes
styles
pricing tier, eCommerce
private
assets
content
folders
messages
discussion boards
product types, eCommerce
profile
edit author
rank
overview
provider
search, changing
pseudolocalization strategy
purge history

1152
1139
1151
1144
1137
1139
1142
1142
1145
1146
1437
1446
637
868
872
872

1248
1243
1265
1245
1257
1064
1218
131
131
1829
697
695, 697
696
1054
1806
1243
492
299
1527
167

Q
QR Code widget
query service
Solr search
queue
eSync
quicklinks
adding to content
definition

1324
218
2008
614, 747
733
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Index

using for a collection
viewing

816
747

R
rank profiles
overview
ranking users
discussion boards
ranking users, for discussion boards
RecentPost widget
recurrence
web calendar events
referrers
business analytics reporting
refinements
Solr search
refresh reminder
report
regional tax table, eCommerce
regions, eCommerce
relevance tab
data designer group box field
remove a resource page
remove Ektron from server
replies
message board
authorization to submit
reports
approvals
bad links
checked in content
checked out content
content
overview
content flags
content pending start date
content to expire
expired content
new content
preapproval groups
refresh reminder
search phrase
site update activity
submitted content
request check in
resource selector field
data designer
overview
resources
new page
remove page
white papers
responsive design
ResponsiveImage widget
restoring content
roles
alias admin
alias author
analytics viewer
business rules screen
collection admin
collection approver
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492
1030
1030
1325
996
540
306
1060
1803
1764
936
1264
33

1645
1057
1064
1058
1059
1057
1067
1060
1061
1061
1059
1064
1060
1064
1062
1059
156
948
949
1259
1264
1252
1087
1327
705
1583
1583
1583
1583
1583
1584

Index

commerce admin
community admin
community group admin
community group create
custom permissions
defining
folder user admin screen
member admin
message board admin
metadata admin screen
multivariate tester
permission to delete content under advanced workflow
permission to work with collections
permission to work with menus
screens
search admin
smart forms admin
synchronization admin
synchronization user
synchronize widgets
task create screen
task delete screen
task redirect screen
taxonomy administrator
template configuration
translation state admin
user admin screen
XLIFF admin screen
RSS
discussion board forum output
RSS feed
RSS widget
rulesets

1584
1584
1584
1584
1587
1581
1582
1585
1585
1586
1586
1584
1583
1583, 1585
1582
1586
1586
1586
1586
1587
1586
1586
1586
1587
1587
1587
1586-1587
1587
1052
1257
1328
1473

S
Salesforce
connection
data mapping
targeting content
scheduling content
search
admin, role
advanced
Workarea
assets
autosuggest
adding term
removing term
troubleshooting
blogs
by content ID
configuration screen
logging in
registering site
content folder
crawls
monitoring
criteria for returned content
did you mean? feature
expired content
faceted

1134, 1229
1230
1170
698
1586
391
363
366
367
368
369
1251
393
336
340
390
401
361
371
361
487
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Index

files outside of Ektron
Search Server
filtered
forums
Foxit PDF filter
HTML forms
images
integrated
overview
Search Server
overview
language, effect of
library
library items
load balanced
metadata
multimedia
multiple terms, and/or relationship
overview
PageBuilder page
phrase report
private content
provider, changing
published tab
queries, how processed
query language
ranking results
results
did you mean?
display
postback message
rank
server
register CMS site
Smart Forms
Solr{see}Solr search
status screen
suggested results
synonym sets
tags
troubleshooting
unusual file extensions
using with three-tier architecture
Visio file
Web site
advanced
basic
Windows services used by
search load balancer
amazon cloud
search phrase
report
search screen
specifying
kind of content to search
word or phrase
Search Server 2013, Microsoft
configurations
installation
Search Server Express
setup
Search Server, Microsoft
configurations
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385
662
363
342
362
363
389
385
361
738
361
346
372
363
362
191
363
404
361
299
390
344
364
373
371
372
373
373
337
362
216
401
376
374
363
405
342
186
372
363
361
343
262
1064

392
393
405
405
317
325

Index

installation
optimizing
searchable content
field
searchable properties
adding to content
definitions
adding
security certificates, eSync
security group
amazon cloud
segments
Google analytics, viewing
shipping calculations
ecommerce
customizing
shipping provider
ecommerce
customizing
shipping tax
eCommerce
single signon
setup for IE7
site
statistics
site update activity
report
Sitecatalyst analytics
overview
reports
site content
site metrics
traffic sources
visitor profile
visitor retention
Smart Desktop
personalizing
set as start location for user
Smart Forms
adding
via data designer
via external XML file
conditional section
deleting
introduction
searching
XSLT
editing
smart forms admin role
SMTP
configuring
SMTP server configuration
SMTP server, google
social business software
social channels
sharing a blog
Solr search
admin service
API
asset transfer service
autocomplete
changing search provider to Solr
components

325
341
371
834
823
1979
240
584

1913

1902
1800
1607
1609
538
1062
594
599
600
599
601
602
602
668
1562

893
894
900
904
888
362
902
1586
105
81
107
1119
1248
216
218
310
218
308
299
217
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Index

crawl service
installing
on-premises server
on Amazon cloud
language support
monitoring
query service
refinements
registering site
on-premises server
registration information, edit
server
securing
site, unregister
Solr core diagram
stopwords list
troubleshooting
uninstall
using with three-tier architecture
sound for captcha
source content
editing
Spacer widget
spam filtering
message board
spell checking
foreign language
in eWebEdit400
set language
standard dictionaries
SSL support
SSL, configuring
SSL, setting up
start date
content
assigning
content block, setting
Static Content widget
stopwords list
Solr search
strategies
eSync
implementing
strategy
password
style sheets
applying to content folder
determining appearance of page on Web site
used in Ektron Workarea
styles
applying via editor
removing via editor
subfolders, adding
subject
discussion boards
submenus
adding as menu item
submitted content
report
subscriptions
blog
blog posts
CMS user sign-up
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217
225
240
305
300
218
306
238
297
224
296
219
305
311
298
186
1259
631-632
1329
1649
1550
2072
1550
1551
81
77
66

698
698
1330
305
2034
2047
119
160
160
667
608
609
157
1018
1350
1059
990, 1257
990, 1257
1505

Index

defining
user sign-up
suggested results
adding a link
creating
deleting
display, determining
editing a link
rearranging links
removing a link
summary
content
adding
summary, table
surveys
creating
synchronization admin role
synchronization user role
synchronize widgets role
synonym sets
creating
deleting
editing

1493
1502
376
383
380
385
382
384
384
384

693
617
868
1586
1586
1587
374
375
376
376

T
table
caption
header
permissions
adding user or group
deleting user or group
editing user or group
summary
tables
inserting
editor
tabular data field
data designer
tag
add to blog post
TagCloud widget
tags
community group
content
creating
default, creating
deleting
overview
searching
types
target frame, assigning to a link
targeted content widget
configuration
creating
deleting
editing
overview
referencing
creating conditions
customizing
multiple criteria

618
619
171
172
172
617

616
953
1247
1331
1656
835
1726
1725
1727
1723
363
1724
612-613
1155
1176
1177
1176
1175
1177
1158
1178
1167

Ektron Reference

2137

Index

TargetedContent widget
using with Salesforce
tasks
archiving
assigning
to content block
to HTML form
to user
comment
adding
definition
deleting
due date
editing
priority, assigning
purging
redirecting to another user
relationship to content blocks
start date
state, assigning
states
introduction
view
options by users
viewing
options
taxes
eCommerce, overview
taxonomy
adding a category
applying to web calendar event
assigning a folder
assigning items
changing order of categories
changing order of content
community groups
copy
creating
custom properties
deleting
editing
introduction
reordering
deleting
exporting
importing
move
multi-language support
overview
removing content from
removing folder from
using with social networking
using with web calendar
Taxonomy Summary widget
template
form
editing
template link
field on Add/Edit Menu screen
templates
adding new
assigning to content
community groups and members
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1332
1170
1459
1452, 1465
886
1451, 1465
1458
1450
1460
1453, 1466
1458
1452, 1465
1460
1451, 1465
1450
1452, 1466
1452, 1466
1456
1463
1462
1796
1378
996
1374
1363
1382
1383
1398
1379
1359
1393
1393
1389
1394
1379
1386
1386
1379
1396
1357
1380
1381
1398
1011
1333

1218
1343
839
842
1635

Index

declaring
deleting
mobile
overview
removing to folder
updating
using with editor
temporary markers
ewebedit400
Text Search widget
thank you page
custom
editing
PageBuilder template
three-tier architecture
aliasing
benefits
creating content
limitations
overview
setting up
using PageBuilder
using with eSync
using with Fast search
using with search
using with Solr serach
thumbnail, inserting
tier pricing
eCommerce
tokens
used in notifications
toolbar
toolbar buttons
editor
customizing
translating content
machine translation
translation
status, mark for
workarea
translation package
assigning content
assigning folders
creating
overview
traverse folders
trends widget
introduction
Trends widget

838
840
506
838
841
840
633
2069
1334
1212
1210
1209
184
177
183
177
175
179
184
185
187
186
186
624, 2080
1829
1686
1083
606
641
635
1539
1548
1545
1546
1545
1544
170
546
1335

U
uninstall Ektron
upsell items, eCommerce
URL aliasing
automatic
configuration
inactivating
delete
pattern
setting up
clear cache

33
1838
1416
1416
1421
1421
1416
1418
1410
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Index

community
troubleshooting
configuring
file extensions
enabling/disabling
filtering
introduction
language awareness
manual
activate/deactivate
add/edit
additional variables
enabling
introduction
query string parameters
remove
multi-language content
override template
permissions
redirect
RegEx
create/edit
restrictions
site
deleting
editing
introduction
three-tier architecture
types
URL link
field on Add/Edit Menu screen
user calendar
widget
widget, adding groups
user control file, widget, creating
user groups
creating
deleting
editing
removing user from
viewing
user profile
calendars
users
adding to permissions table
communities, managing
creating new
deleting
deleting from permissions table
editing
editing in permissions table
email, disabling notification
password, setting
profile
customizing work page width
set Smart Desktop as start location
removing from user group
unlocking locked account

1422
1401
1403
1411
1399
1403
1415
1411-1412
1415
1402
1411
1415
1416
1410
1403
1405
1427
1422
1422
1406
1427
1426
1425
184
1400
1343, 1351
1005
1006
1283
1567
1567
1567
1566
1566
999
171
1623
1556
1564
172
1559
172
1559, 1561
1557, 1560
1562
1562
1566
115

V
validation
editor
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633

Index

field
HTML forrms
variables, email
verification message for membership users
video
inserting
editor
view content difference
ViewAllMenus
Visio file
include in search results

857
109
1504, 1630

626
703
1339
372

W
warehouse, eCommerce
WCAG validation
Web Alerts
assigning to folders and content
Asynchronous Log File
email, setting up
overview
password reset for site visitors
setting up
asynchronous processor
message queue
subscriptions
CMS users
defining
multi-language
user sign-up
web analytics widget
web sites
supporting multiple
advantages
prerequisites
web traffic analytics
URL filtering
view from PageBuilder page
view from Workarea
viewing page level traffic
viewing site level traffic
web.config
active directory server configuration
appsettings
connection strings
ektronCommerce
images
mediasettings
menu settings
miscellaneous settings
multilingual settings
SMPT server configuration
SSL support
system.diagnostics
WebCalendar widget
Webtrends
white papers
widget
Activity Stream
Content Review
Flash
Flickr
FormControl

1790
633
1496
1063
1490
1481
1505, 1631
1483
1483
1505
1493
1495
1502
559

91
91
558
535
533
534
532
536
82
79
78
85
81
85
82
83, 86
82
81
81
84
1337
586
1252
1300
1309
1312
1313
1314
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Index

Google Gadget
Hello World
List Summary
MetaDataList
Most Popular
MultivariateExperiment
MultivariateSection
MultivariateTarget
QR Code
Recent Post
ResponsiveImage
RSS
Spacer
Static Content
TagCloud
Taxonomy Summary
Text Search
Trends
WebCalendar
widget TargetedContent
widgets
adding a field
adding to a wireframe template
adding to the PageBuilder Widgets pane
author facets
blogpostcalltoaction
blogsfeed
Brightcove video
CallToAction
collection
ContentBlock
contentlist
css files, working with
customizing
DateFacets
featured items
Flash
global properties, setting
heading
help,adding
iFrame
JavaScript, working with
local properties, setting
most popular
place on PageBuilder page.
removing
spaces
targeted content
trends
web analytics
web calendar
Windows
Live Writer
Windows services
Ektron
used by search
wireframe
PageBuilder
Word, Microsoft
classes, preserve
styles, preserve
Workarea
accessing
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1315
1317
1319
1321
1322
1323
1324
1324
1324
1325
1327
1328
1329
1330
1331
1333
1334
1335
1337
1332
1271
1291
1281
1281
1300
1302
1303
1296, 1304
1305
1306
1307
1308
1288
1287
1310
1311
1294
1289
1316
1293
1318
1288
1291
543
1082
1294
1442
1155
546
559
1004
983
136
343
1093
131
131
663
667

Index

advanced search
closing
translating
workflow
advanced
content
deleting
editing
managing
removing
submitting
custom
creating
removing
declining content publication
disabling
enabling
escalation
folder
editing
removing
forcing content publication
notification
overview
setting up for content
setting up for folder
standard
switching to basic
viewing
assigning users permission to delete content under advanced
basic
approval method
approval method, change
approval order
approvers, adding
approvers, removing
approving content
content, assigning
content, deleting
content, monitoring
declining content
examples
folder, assigning
folder, editing
folder, removing
overview
switching to advanced
concepts
folder
viewing
overview
setup
WSPath
WURFL

391
668
1548

786
787
783-784
779
781
765
788
803
786
768
768
766
774, 778
775
785
768
765
775
771
765
780
773, 778
1584
756
756
755
754
755
759
757
763
758
759
761
753
757
757
752
764
749
752
749
1265
84
528

X
XLIFF
creating file
XML indexing
search
setting up

1541
905
906
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Index

search criteria
types
user vs. developer
specifying elements to index
validation

908
908
909
907

Y
YouTubeVideo widget
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